SQL Server Login Dialog Box

Отзыв Вход в сервер SQL

Диалоговое окно «Вход в сервер SQL»

При попытке установить соединение OLE DB без указания данных, необходимых, чтобы драйвер связался с SQL Server, поставщик Microsoft® SQL Server™ OLE DB выводит диалоговое окно Вход в сервер SQL.

При первом отображении диалогового окна Вход в сервер SQL, оно содержит только следующие элементы.

Поле Сервер.

Флажок Использовать доверительное соединение.

Поле Пользователь.

Поле Пароль.

Кнопки OK, Отмена, Справка и Параметры.

При нажатии кнопки Параметры диалоговое окно раскрывается и отображает также группу Параметры:

Поле База данных

Поле Язык

Поле Приложение

Поле Рабочая станция

Поле Сервер

Имя сервера SQL Server в сети. Если имя сервера выбирается из списка, дальнейшая настройка не требуется. Если имя сервера набирается вручную, это должен быть расширенный вход в служебную программу настройки SQL-клиента или сетевое имя сервера, на котором работает SQL Server.

При использовании в качестве SQL-сервера то же самого компьютера в поле сервера можно ввести слово "(local)". Затем пользователь сможет подключиться к локальной копии SQL Server, даже при использовании несетевой версии SQL-сервера. Чтобы указать определенный экземпляр сервера SQL Server, имя сервера указывается в виде ServerName\InstanceName.

Дополнительные сведения об именах серверов для разных типов сетей содержатся в руководстве по установке SQL Server из электронной документации SQL Server Books Online.

Флажок Использовать доверительное соединение

Установленный флажок указывает на то, что поставщик SQL Server OLE DB запрашивает безопасное (или доверенное) подключение к серверу SQL Server, работающему в системе Microsoft Windows NT® или Microsoft Windows 2000. При выборе этого параметра SQL Server использует для подключения с помощью данного источника данных учетные сведения пользователя, а не режим проверки подлинности в текущем сеансе входа на сервер. Предоставленные имя и пароль игнорируются. Системный администратор SQL Server должен сопоставить ваше сетевое имя Microsoft Windows® с именем в SQL Server.

Когда флажок снят, SQL Server использует стандартную систему безопасности входа для установки подключений с помощью данного источника данных. Необходимо указывать пользователя и пароль для всех запросов подключений.

Поле Пользователь

Задает пользователя SQL Server, которого нужно использовать для подключения, если не установлен флажок Использовать доверительное соединение. Если флажок Использовать доверительное соединение установлен, поле Пользователь недоступно.

Поле Пароль

Задает пароль пользователя SQL Server для подключения, если не установлен флажок Использовать доверительное соединение. Если флажок Использовать доверительное соединение установлен, поле Пароль недоступно.

Поле База данных

Указывает используемую по умолчанию при этом подключении базу данных. Оно позволяет обойти используемую по умолчанию базу данных, указанную для входа на сервер. Если база данных не указана, подключение использует базу данных, указанную для входа на сервер.

Поле Язык

Указывает язык системных сообщений SQL Server. Язык должен быть установлен на SQL Server. Оно позволяет обойти используемый по умолчанию язык, указанный для входа на сервер. Если язык не указан, подключение использует язык, указанный для входа на сервер.

Поле Приложение

Дополнительно задает имя приложения, которое будет сохранено в столбце program_name в строке данного подключения в master.dbo.sysprocesses.

Поле Рабочая станция

Дополнительно задает идентификатор рабочей станции, который будет сохранено в столбце hostname в строке данного подключения в master.dbo.sysprocesses.

©Корпорация Майкрософт (Microsoft Corporation), 1988-2000. Все права защищены.


Microsoft SQL Server 2000 Copyright and Disclaimer

Отзыв Вход в сервер SQL

Microsoft SQL Server 2000: авторские права и отказ от обязательств

Данный документ, включая упоминаемые в нем примеры приложений, предоставлен исключительно для ознакомления, и корпорация Майкрософт не предоставляет на него никаких гарантий -- ни явных, ни подразумеваемых. В содержание настоящего документа, в том числе в примеры, URL-адреса и другие ссылки на веб-узлы в Интернете, могут быть внесены изменения без предварительного уведомления. Пользователь принимает на себя весь риск, связанный с использованием настоящего документа.

Главной целью примера является иллюстрация понятия или обоснованного применения определенной инструкции или предложения. Большинство примеров не включают весь исходный текст завершенного приложения, так как из него удалены обработчики проверки целостности данных или ошибок, чтобы заострить внимание на определенном понятии или инструкции. Техническая поддержка для примеров или исходных текстов не предоставляется.

Если не оговорено обратное, названия организаций и изделий, а также имена, даты и события, используемые в качестве примеров, являются вымышленными. Возможное сходство с реально существующими предприятиями, организациями, изделиями, лицами и событиями следует рассматривать как случайное. На пользователе лежит ответственность за соблюдение всех применимых в данном случае законов об авторском праве. В рамках, предусмотренных законами об авторских правах, никакая часть настоящего документа не может быть воспроизведена, сохранена или представлена в какой-либо системе хранения данных или передана в какой бы то ни было форме, какими бы то ни было средствами (электронными, механическими, фотокопировальными, записывающими или другими) и в каких бы то ни было целях без специального письменного разрешения корпорации Майкрософт.

Корпорация Майкрософт может являться правообладателем патентов и заявок, поданных на получение патента, товарных знаков и объектов авторского права, которые имеют отношение к содержанию данного документа. Предоставление вам данного документа не означает передачи какой-либо лицензии на использование данных патентов, товарных знаков и объектов авторского права, за исключением использования, явно оговоренного в лицензионном соглашении корпорации Майкрософт.

©Корпорация Майкрософт (Microsoft Corporation), 1996-2000. Все права защищены.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, Microsoft SQL Server, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Visual Studio, Win32, Windows 2000, Windows и Windows NT являются охраняемыми товарными знаками корпорации Майкрософт в США и других странах.

Названия прочих организаций и изделий являются товарными знаками их владельцев.

Версия: 8.00.000

©Корпорация Майкрософт (Microsoft Corporation), 1988-2000. Все права защищены.