Получение внешних данных с помощью Microsoft Query

Содержание раздела

Что такое Microsoft Query?

Настройка источников данных

Определение запросов

Работа с данными в Microsoft Excel

Что такое Microsoft Query?

Microsoft Query представляет собой программу для переноса данных из внешних источников в программы Microsoft Office, в частности Microsoft Excel. Извлечение данных из корпоративной базы данных и файлов с помощью Microsoft Query позволяет избежать их повторного ввода для анализа в Microsoft Excel. Кроме того, имеется возможность автоматического обновления отчетов и итоговых значений в Microsoft Excel при изменении данных в исходной базе данных.

Типы доступных баз данных. Допускается извлечение данных из нескольких типов баз данных, включая Microsoft Access, Microsoft SQL Server и службы Microsoft SQL Server OLAP. Кроме того, донные могут извлекаться из таблиц Excel и текстовых файлов. См. список типов доступных баз данных.

В Microsoft Excel также имеется возможность извлечения данные с веб-страниц, но для этого не требуется Microsoft Query. Сведения о получении данных с веб-страниц см. в справке Microsoft Excel.

Выбор данных из базы данных Извлечение данных из базы данных производится путем создания запроса, который является вопросом о данных, хранящихся во внешней базе данных. Например, если данные хранятся в базе данных Microsoft Access и требуется узнать объемы продаж указанного товара по области, можно извлечь только часть данных, выбрав данные по товару и области для анализа, опустив ненужные данные.

Пример выбора данных в Microsoft Query

С помощью Microsoft Query можно выбирать нужные столбцы данных и передавать в Microsoft Excel только эти данные.

Обновление листа за одну операцию После занесения внешних данных в книгу Microsoft Excel при каждом изменении базы данных можно обновить данные для обновления результатов анализа. Для этого не требуется повторное создание итоговых отчетов и диаграмм. Например, можно создать ежемесячный отчет о продажах и обновлять его каждый месяц при появлении новых данных.

Использование Microsoft Query для извлечения данных Перенос внешних данных в Microsoft Excel с помощью Microsoft Query состоит из трех шагов. Сначала настраивается источник данных для подключения к базе данных, затем с помощью мастера запросов выбираются необходимые данные, а затем данные передаются в Microsoft Excel, где они могут быть отформатированы, обобщены и включены в отчеты.

Возврат в начало

Настройка источников данных

Что такое источник данных? В источнике данных содержатся данные, позволяющие Microsoft Excel и Microsoft Query подключиться к внешней базе данных. При настройки источника данных в Microsoft Query ему назначается имя, а затем указывается имя и расположение базы данных или сервера, тип базы данных, идентификатор и пароль для входа. Данные также включают имя драйвера ODBC или драйвера источника данных. Эти драйверы позволяют подключиться к указанному типу базы данных. Для некоторых типов внешних баз данных (кубы OLAP) для извлечения данных необходимо только настроить источник данных.

Использование источников данных в Microsoft Query После настройки источника данных для конкретной базы данных он может использоваться для создания запроса на отбор или извлечение данных из базы данных (без ввода всех данных, необходимых для подключения). Microsoft Query подключается к базе данных с помощью источника данных и выводит доступные данные. После создания запроса и переноса данных в Microsoft Excel Microsoft Query извлекает данных и заносит в книгу Microsoft Excel данные по запросу и источнику данных повторного подключения к базе данных при обновлении.

Схема использования источников данных в Microsoft Query

Источник данных представляет собой средство, с помощью которого Microsoft Query и Microsoft Excel подключаются к конкретной базе данных и извлекают из нее данные.

Возврат в начало

Определение запросов

Использования мастера для создания большинства запросов Мастер создания запросов, входящий в Microsoft Query, предназначен для пользователей, не имеющих опыта создания запросов. Мастер позволяет легко выбрать и собрать вместе данные из различных таблиц и полей базы данных. После выбора данных также результаты запроса могут быт отфильтрованы и отсортированы с помощью этого мастера. Используйте мастер создания запросов для создания полного запроса или для выполнения запроса, который будет в дальнейшем изменен непосредственно в Microsoft Query.

Непосредственная работа в Microsoft Query с прочими типами запросов При наличии опыта создания запросов или при необходимости создания более сложных запросов можно работать непосредственно в Microsoft Query. Программа Microsoft Query может использоваться для просмотра и изменения запросов, которые были изначально созданы в мастере создания запросов, а также для создания новых запросов без использования мастера.

Непосредственно в Microsoft Query могут создаваться запросы, выполняющие следующие действия.

  • Выбор указанных данных из поля В больших базах данных иногда возникает необходимость выбрать из поля некоторые данные, пропустив ненужные. Например, если требуются данные по двум продуктам в поле, содержащем данные по многим продуктам, для выбора данных только для двух необходимых продуктов можно воспользоваться условием. Изучите использование условий.
  • Извлечение данных на основе условий отбора, изменяющихся при каждом выполнении запроса Если требуется создать один отчет Microsoft Excel или итоговые значения по нескольким областям одних внешних данных (например, отдельный отчет о продажах по каждой области), можно создать запрос с параметрами. При запуске запроса с параметрами на экран выводится приглашение на ввод данных, которые будут использоваться в качестве условий отбора записей. Например, запрос с параметрами, запрашивающий название региона, можно использовать повторно для создания отчетов о продажах в каждом конкретном регионе. См. сведения о запросах с параметрами.
  • Объединение данных различными способами Воспользуйтесь Microsoft Query для объединения или связывания данных из различных таблиц в базе данных. Например, две таблицы с данными о продажах продуктов и заказчиках можно объединить для отображения заказчиков, которые не производили закупки в последнее время. Изучите объединение таблиц.

Создание куба OLAP из данных запроса Электронная аналитическая обработка данных (On-Line Analytical Processing, OLAP) является способом организации данных для создания запросов и отчетов вместо обработки транзакций. В базе данных OLAP данные организованы иерархически и хранятся в кубах вместо таблиц.

Для создания куба OLAP из данных запроса может использоваться Microsoft Query, что позволит сэкономить время и усилия при создании отчетов Microsoft Excel на основании этих данных. Для создания куба OLAP запустите мастер создания кубов OLAP из мастера запросов или непосредственно из Microsoft Query. Данные можно вернуть в Excel в виде сводной таблицы. Изучите создание куба OLAP из запрашиваемых данных.

Дополнительные сведения

Использование мастера запросов и Microsoft Query

Возврат в начало

Работа с данными в Microsoft Excel

После создания запроса в мастере создания запросов или в Microsoft Query данные могут быть перенесены в таблицу Microsoft Excel. Данные становятся внешним диапазоном данных или сводной таблицы, которые могут быть использоваться для форматирования, анализа и обновления.

Форматирование и анализ данных В Microsoft Excel для представления и группирования данных могут использоваться такие средства, как мастер диаграмм или автоматические итоги. При обновлении внешних данных из исходной базы данных форматирование сохраняется. При добавлении столбцов формул к внешнему диапазону данных формулы автоматически могут быть скопированы в любую новую строку, добавляемую к диапазону при обновлении данных. Вместо имен полей могут использоваться пользовательские подписи столбцов и автоматически добавляться номера сток. Для получения сведений по поводу установки параметров форматирования внешнего диапазона данных обратитесь к справочной системе Microsoft Excel.

Повторное и совместное использование запросов Как в мастере запросов, так и в Microsoft Query допускается сохранение файла запроса.dqy, который может быть изменен и использован, в том числе и совместно. Файлы.dqy могут открываться непосредственно в Microsoft Excel, что позволяет другим пользователям создавать дополнительные диапазоны внешних данных из этого запроса.

Для совместного использования итогов или отчета Microsoft Excel, основанного на внешних данных, необходимо предоставить другим пользователям книгу Microsoft Excel, содержащую диапазон внешних данных, или создать шаблон отчета. Шаблон отчета позволяет сохранять итоги или отчет без сохранения внешних данных, что приводит к уменьшению размера файла. Внешние данные загружаются при открытии шаблона отчета. Для получения сведений о создании шаблонов отчета обратитесь к справочной системе Microsoft Excel.

Обновление внешних данных При обновлении внешних данных выполняется запрос для извлечения новых или измененных данных, удовлетворяющих условиям. Обновление запроса может производиться как в Microsoft Query, так и в Microsoft Excel. В Microsoft Excel имеется несколько режимов для обновления запросов, включая обновление данных при открытии книги и автоматическое обновление с определенными интервалами времени. Во время обновления данных можно продолжать работу в Microsoft Excel, а также проверить состояние обновления. Для получения сведений об обновлении внешних данных в Microsoft Excel обратитесь к справочной системе Microsoft Excel.

Возврат в начало


Получение справочных сведений о Microsoft Query

  • В меню Справка приложения Microsoft Query выберите пункт О программе.

    Отобразится диалоговое окно О программе, содержащее сведения о программе, в частности номер версии.


Комбинации клавиш в Microsoft Query

Предполагаемое действие:

Перемещение по областям Microsoft Query с использованием клавиатуры

Выделение данных и условий с использованием клавиатуры

Изменение данных и условий с использованием клавиатуры

Функциональные клавиши Microsoft Query

Используйте сочетание клавиш в мастере создания куба


Перемещение по областям Microsoft Query с использованием клавиатуры

Некоторые сведения в этом разделе могут быть неприменимы к отдельным языкам.

Перемещение в области таблиц

Клавиши | Действие
TAB | Перемещение между таблицами
ВВЕРХ или ВНИЗ | Перемещение к полю и выделение имен полей в таблице
SHIFT+ВВЕРХ или SHIFT+ВНИЗ | Выбор смежных полей в таблице или отмены выбора

Переходы между столбцами и строками в области данных и в области условий

Клавиши | Действие
F5, введите номер записи в поле Запись и нажмите клавишу ENTER | Переход к определенной записи (строке) в области данных
TAB, ВВОД или ВПРАВО (из выделенной ячейки) | Переход к следующему столбцу в области данных
SHIFT+TAB, SHIFT+ВВОД или ВЛЕВО (из выделенной ячейки) | Переход к предыдущему столбцу в текущей строке или к последнему полю предыдущей записи
END | Переход к последнему столбцу текущей строки
CTRL+END | Переход к последнему столбцу последней строки
HOME | Переход к первому столбцу текущей строки
CTRL+HOME | Переход к первому столбцу первой строки
ВНИЗ | Переход к текущему столбцу следующей строки
CTRL+ВНИЗ | Переход к текущему столбцу последней строки
ВВЕРХ | Переход к текущему столбцу предыдущей строки
CTRL+ВВЕРХ | Переход к текущему столбцу первой строки

Перемещение точки вставки в ячейке области данных или области условий

Клавиши | Действие
F2 | Отмена выделения и отображение точки вставки в выделенной ячейке
ВПРАВО | Перемещение на один знак вправо
CTRL+ВПРАВО | Перемещение на одно слово вправо
ВЛЕВО | Перемещение на один знак влево
CTRL+ВЛЕВО | Перемещение на одно слово влево
END | Перемещение к концу текущей строки в однострочных или многострочных значениях
CTRL+END | Перемещение к концу значения в многострочных значениях
HOME | Перемещение к началу текущей строки в однострочных или многострочных значениях
CTRL+HOME | Перемещение к началу значения в многострочных значениях

Переходы между экранами области данных или области условий

Клавиши | Действие
PAGE DOWN | Переход на один экран вниз
PAGE UP | Переход на один экран вверх
CTRL+PAGE DOWN | Переход на один экран вправо
CTRL+PAGE UP | Переход на один экран влево


Выделение данных и условий с использованием клавиатуры

Выделение значений в столбце

Клавиши | Действие
F2 | Выделение текущего значения или отмена выделения и отображение точки вставки
TAB, ENTER или СТРЕЛКА ВПРАВО (из выделенной ячейки) | Выделение значения в следующем столбце
SHIFT+HOME | Выделение значения от точки вставки до начала строки
SHIFT+END | Выделение значения от точки вставки до конца строки
SHIFT+СТРЕЛКА ВПРАВО | Расширение выделения или отмена выделения на один знак вправо
CTRL+SHIFT+СТРЕЛКА ВПРАВО | Расширение выделения или отмена выделения на одно слово вправо
SHIFT+СТРЕЛКА ВЛЕВО | Расширение выделения или отмена выделения на один знак влево
CTRL+SHIFT+СТРЕЛКА ВЛЕВО | Расширение выделения или отмена выделения на одно слово влево

Выделение строки

Клавиши | Действие
SHIFT+ПРОБЕЛ | Выделение текущей строки
СТРЕЛКА ВНИЗ | Выделение следующей строки, если выделена текущая строка
СТРЕЛКА ВВЕРХ | Выделение предыдущей строки, если выделена текущая строка
SHIFT+СТРЕЛКА ВНИЗ | Расширение выделения или отмена выделения на одну строку вниз
SHIFT+СТРЕЛКА ВВЕРХ | Расширение выделения или отмена выделения на одну строку вверх
SHIFT+PAGE DOWN | Расширение выделения на один экран вниз
SHIFT+PAGE UP | Расширение выделения на один экран вверх
CTRL+SHIFT+ПРОБЕЛ | Выделение всей таблицы результатов

Выделение столбца

Клавиши | Действие
CTRL+ПРОБЕЛ | Выделение текущего столбца
СТРЕЛКА ВПРАВО | Выделение столбца, расположенного справа от выделенного текущего столбца
СТРЕЛКА ВЛЕВО | Выделение столбца, расположенного слева от выделенного текущего столбца
SHIFT+СТРЕЛКА ВЛЕВО | Расширение или отмена выделения на один столбец влево
SHIFT+СТРЕЛКА ВПРАВО | Расширение или отмена выделения на один столбец вправо
CTRL+SHIFT+PAGE DOWN | Расширение выделения на один экран вправо
CTRL+SHIFT+PAGE UP | Расширение выделения на один экран влево


Изменение данных и условий с использованием клавиатуры

Копирование, вырезание, вставка или удаление

Клавиши | Действие
CTRL+C | Копирование текущего выделения в буфер обмена
CTRL+V | Вставка содержимого буфера обмена в место, определяемое точкой вставки
CTRL+X | Вырезание текущего выделения и копирование его в буфер обмена
BACKSPACE | Удаление текущего выделения или знака, расположенного слева от точки вставки
DEL | Удаление текущего выделения или знака, расположенного справа от точки вставки

Область ввода в области данных

Клавиши | Действие
SHIFT+F2 | Открытие диалогового окна Область ввода для удобства ввода значений в малые области ввода области данных


Функциональные клавиши Microsoft Query

Некоторые сведения в этом разделе могут быть неприменимы к отдельным языкам.

Клавиши | Действие
F1 | Вызов справочной системы
SHIFT+F1, после чего нажмите клавишу ENTER | Получение контекстной справки по выделенному элементу
F2 | Выделение или отмена выделения текущего значения
ALT+SHIFT+F2 или SHIFT+F12 | Сохранение запроса с помощью команды Сохранить
ALT+F2 или F12 | Сохранение запроса с помощью команды Сохранить как
SHIFT+F2 | Открытие диалогового окна Область ввода для удобства ввода значений в малые области ввода области данных
CTRL+F4 | Закрытие активного запроса
ALT+F4 | Выход из Microsoft Query
F5, введите номер записи в поле Запись и нажмите клавишу ENTER | Переход к определенной записи (строке) области данных
F6 | Переход к следующей области в окне запроса
SHIFT+F6 | Переход к предыдущей области в окне запроса
CTRL+F6 | Переход к следующему открытому окну запроса
CTRL+SHIFT+F6 | Переход к предыдущему открытому окну запроса
F9 | Выполнение открытого запроса


Использование сочетаний клавиш в мастере создания куба

На втором шаге мастера используются следующие клавиши.

Перемещение поля из списка «Исходные поля» в поле «Размерности»

  1. С помощью клавиши TAB перейдите в список Исходные поля.
  2. С помощью клавиш СТРЕЛКА ВВЕРХ и СТРЕЛКА ВНИЗ выделите поле, которое требуется переместить.
  3. С помощью клавиши TAB выделите кнопку > и нажмите клавишу ENTER.
  4. Для перемещения других полей повторите шаги с первого по третий.

Для перемещения поля внутри окна размерностей в нижний или верхних уровень.

  1. С помощью клавиши TAB перейдите в поле Размерности.
  2. С помощью клавиш СТРЕЛКА ВВЕРХ и СТРЕЛКА ВНИЗ выделите поле, которое требуется переместить.
  3. Нажмите клавиши CTRL+X.
  4. С помощью клавиш СТРЕЛКА ВВЕРХ и СТРЕЛКА ВНИЗ выберите место, куда требуется переместить поле.
  5. Нажмите клавиши CTRL+V.


Установка драйвера ODBC для доступа к внешнему источнику данных

Драйверы ODBC, поставляемые компанией Microsoft вместе с Microsoft Query, полностью установлены в момент установки Microsoft Query. См. список драйверов, поставляемых с Microsoft Query.

Если внешняя база данных, к которой требуется получить доступ, не поддерживается этими драйверами ODBC, необходимо приобрести и установить совместимые с Microsoft Office драйверы ODBC от сторонних поставщиков, например, от производителя соответствующей базы данных. За инструкциями по установке обращайтесь к поставщику базы данных.

Примечание. Базам данных OLAP не требуются драйверы ODBC. Драйверы и поддержка для доступа к базам данных, которые были созданы при помощи Microsoft SQL Server OLAP Services, уже установлены вместе с Microsoft Query. Для подключения к другим базам данных OLAP, требуется установить драйвер источника данных и клиентское программное обеспечение. См. раздел о сторонних поставщиках данных для куба.


Установка поставщиков данных для куба

Чтобы выполнить подключение к службам и базам данных OLAP через программные продукты сторонних разработчиков, необходимо установить программное обеспечение поставщика данных куба OLAP. Оно включает в себя дополнительные драйверы источников данных и клиентское программное обеспечение, позволяющее подключиться к серверной базе данных OLAP стороннего разработчика.

Для использования возможностей Microsoft Office по работе с данными OLAP поставщик данных для куба от стороннего разработчика должен быть совместим с Microsoft Office. Поставщик данных может как поддерживать, так и не поддерживать создание файлов автономного куба и работу с ними. Для проверки совместимости можно создать отчет сводной таблицы Microsoft Excel на основе базы данных OLAP стороннего разработчика. Если поставщик данных не поддерживает работу с файлами автономного куба, в меню Сводная таблица (панель инструментов Сводная таблица ) отчета сводной таблицы команда Настройка "клиент-сервер" будет недоступна.

Для получения дополнительных сведений по установке поставщиков данных для куба от сторонних поставщиков свяжитесь с системным администратором или производителем программного продукта. После того как поставщик данных будет установлен, можно настроить источники данных в Microsoft Query для доступа к базе данных поставщика.


Доступные базы данных

Драйверы Microsoft Office позволяют получать сведения из следующих источников данных:

  • Службы Microsoft SQL Server OLAP (поставщик данных OLAP)
  • Microsoft Access версии 2000 или более поздней
  • dBASE
  • Microsoft FoxPro
  • Microsoft Excel
  • Oracle
  • Paradox
  • SQL Server
  • Текстовые файлы баз данных

Примечание. Для получения сведений из других типов баз данных, не перечисленных здесь, включая другие типы баз данных OLAP, можно использовать драйверы ODBC или драйверы источников данных других производителей. Для получения сведений об установке драйверов ODBC или драйверов источников данных, не перечисленных в этом документе, обращайтесь к документации по соответствующей базе данных или к разработчику этой базы данных.


Указание внешнего источника данных

  1. Если диалоговое окно Выбор источника данных не открыто, нажмите кнопку Новый запрос Значок кнопки.
  2. Выполните одно из следующих действий.

    Чтобы указать источник данных для реляционной базы данных, базы данных текстового файла или таблицы Microsoft Excel, выберите вкладку Базы данных.

    Чтобы указать источник данных куба OLAP, выберите вкладку Кубы OLAP. Эта вкладка доступна только если Microsoft Query запущен из Microsoft Excel.

  3. Дважды щелкните Новый источник данных.
  4. На первом шаге введите имя источника данных.
  5. На втором шаге выберите драйвер, соответствующий типу базы данных, используемой в качестве источника.

    Если нужный тип отсутствует в списке, для источника данных может потребоваться установка драйвера ODBC или драйвера источника данных.

    Инструкции

  6. Выберите Связь и укажите сведения, необходимые для подключения к базе данных.

    Если была выбрана реляционная база данных, база данных текстовых файлов или таблица Microsoft Excel, предоставляемые данные зависят от выбранного типа базы данных. Возможно потребуется ввести идентификатор входа, пароль, версию используемой базы данных, ее расположение или другие сведения, зависящие от типа базы данных.

    Для такого источника данных, как службы Microsoft SQL Server OLAP следуйте инструкциям мастера соединения.

  7. После ввода необходимых сведений нажмите кнопку OK или Готово для возврата в диалоговое окно Создание нового источника данных.
  8. Если база данных содержит таблицы и необходимо автоматически отображать одну из них в мастере запросов, на шаге 4 щелкните список и выберите требуемую таблицу.
  9. Чтобы не вводить элемент и пароль для доступа к источнику данных, установите флажок Сохранить имя и пароль в определении источника данных. Если флажок недоступен, обратитесь к администратору базы.

    Когда эти шаги выполнены, имя источника данных появится в диалоговом окне Выбор источника данных.


Настройка источника данных, использующего драйвер Microsoft Access

  1. Если не открыто диалоговое окно Создание нового источника данных, выберите команду Создать запрос в меню Файл, а затем дважды щелкните значение Новый источник данных на вкладке Базы данных. Введите имя источника данных на первом шаге и выберите Драйвер Microsoft Access на втором.
  2. Затем нажмите кнопку Подключить.
  3. Нажмите кнопку Выбрать в группе База данных и найдите файлы в диалоговом окне Выбор базы данных.

    Если база данных должна открываться в Microsoft Query только для чтения, установите флажок Только чтение.

    Если при использовании этого источника данных соответствующая база данных была доступна только для Microsoft Query, установите флажок Монопольный доступ.

  4. Нажмите кнопку OK.

    Если требуется установка дополнительных параметров подключения к базе данных, нажмите кнопку Дополнительно. Узнайте у администратора базы данных, требуется ли изменение каких-либо из этих параметров. Чтобы получить сведения о дополнительных параметрах, нажмите кнопку Отмена, а затем — кнопку Справка в диалоговом окне Установка драйвера ODBC для Microsoft Access.

  5. Если Microsoft Query необходим доступ к системной базе данных, выберите вариант База данных в группе Системная база данных, а затем нажмите кнопку Системная база данных. В диалоговом окне Выбор системной базы данных найдите нужный файл базы данных и нажмите кнопку OK.
  6. Нажмите кнопку OK и введите имя и пароль для входа в группе Проверка подлинности. Если для получения доступа к базе данных имя для входа и пароль не используются, не заполняйте поля области Проверка подлинности.

Примечание. Для создания, восстановления и сжатия баз данных Microsoft Access может использоваться диалоговое окно Установка драйвера ODBC для Microsoft Access При отсутствии опыта работы с этими функциями их следует выполнять только в Microsoft Access. Для получения дополнительных сведений обратитесь к справочной системе Microsoft Access.


Настройка источника данных, использующего драйвер Microsoft dBASE или Microsoft FoxPro

Перед выполнением следующих шагов рекомендуется поместить все файлы баз данных, которые будут использоваться, в один каталог, чтобы мастер запросов мог найти все файлы и не было необходимости вводить полный путь при добавлении таблицы в запрос. При желании файлы баз данных можно поместить в один каталог, а индексные файлы в другой.

  1. Если не открыто диалоговое окно Создание нового источника данных, выберите команду Создать запрос в меню Файл, а затем дважды щелкните значение Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите Драйвер Microsoft dBase или Драйвер Microsoft Visual FoxPro.
  2. На шаге 3 нажмите кнопку Подключить.
  3. Выполните одно из следующих действий.

    Для драйвера Microsoft dBase выберите в списке Версия версию dBASE или FoxPro, которая использовалась при создании файла базы данных. Если файл базы данных находится не в текущей папке, снимите флажок Использовать текущий каталог и нажмите кнопку Выбор каталога для поиска папки. Если индексные файлы базы данных также находятся в другом каталоге, для поиска папки нажмите кнопку Выбор индексов.

    Для драйвера Microsoft Visual FoxPro выберите базу данных FoxPro в списке Тип базы данных, затем введите путь к базе данных в поле Путь.


Настройка источника данных, использующего драйвер Microsoft Excel

Драйвер ODBC для Microsoft Excel обеспечивает доступ только к данным из книг, которые находятся в одной папке. Перед выполнением следующих шагов скопируйте все книги, к которым будет осуществляться одновременный доступ, в одну папку и присвойте имя каждому диапазону листов, который должен восприниматься Microsoft Query как таблица.

Для каждой папки, к данным из которой будет осуществляться доступ, необходимо настроить отдельный источник данных.

Перед настройкой источника данных или выполнением запроса для получения доступа к данным в книге Microsoft Excel необходимо закрыть эту книгу в Microsoft Excel.

  1. Если не открыто диалоговое окно Создание нового источника данных, выберите команду Создать запрос в меню Файл, а затем дважды щелкните значение Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите Драйвер Microsoft Excel.
  2. На шаге 3 нажмите кнопку Подключить.
  3. В поле Версия выберите версию Microsoft Excel, которая использовалась для создания этой книги. Если книга была создана при помощи Microsoft Excel 97, 2000 или более поздней версии, выберите Microsoft Excel 97-2000. Если книга создана при помощи Microsoft Excel 95 (версии 7.0), выберите Microsoft Excel 5.0/7.0.
  4. Нажмите кнопку Выбор книги, а затем найдите файл книги.


Настройка источника данных, использующего драйвер Microsoft ODBC для Oracle

Драйвер Microsoft ODBC для Oracle позволяет подключаться к базам данных Oracle с поддержкой SQL*Net 2.3 (или более поздних версий). Дополнительные сведения об этой поддержке можно найти в документации по Oracle.

Для настройки источников данных, которые используют указанный драйвер, необходимо предварительно установить клиент Oracle и компоненты сетевого программного обеспечения версии 7.3 или более поздней. Эти компоненты можно получить у поставщика программных средств Oracle или в самой корпорации Oracle.

  1. Если не открыто диалоговое окно Создание нового источника данных, выберите команду Создать запрос в меню Файл, а затем дважды щелкните значение Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите Драйвер Microsoft ODBC для Oracle.
  2. На шаге 3 нажмите кнопку Подключить.
  3. В окне Базы данных нажмите кнопку Выбрать.
  4. В поле Имя пользователя введите идентификатор для входа в базу данных.
  5. Укажите имя сервера Oracle и другие дополнительные сведения, которые необходимы для подключения к этому серверу. За разъяснениями по этому вопросу можно обратиться к администратору баз данных Oracle. Чтобы получить дополнительные сведения о параметрах настройки, воспользуйтесь в диалоговом окне кнопкой Справка.
  6. Введите имя пользователя и пароль, а затем дважды нажмите кнопку OK.


Настройка источника данных, использующего драйвер Microsoft Paradox

Перед выполнением следующих шагов рекомендуется поместить все файлы баз данных, которые будут использоваться совместно, в одну папку, чтобы облегчить их поиск для Microsoft Query и не было необходимости вводить полное имя файла при добавлении таблицы в запрос.

  1. Если не открыто диалоговое окно Создание нового источника данных, выберите команду Создать запрос в меню Файл, а затем дважды щелкните значение Новый источник данных на вкладке Базы данных. Введите имя источника данных на первом шаге и выберите значение Драйвер для Microsoft Paradox на втором.
  2. На шаге 3 нажмите кнопку Подключить.
  3. В поле Версия выберите версию Microsoft Paradox, использовавшуюся для создания файлов базы данных.
  4. Если файлы базы данных находятся не в текущей папке, снимите флажок Использовать текущий каталог, а затем нажмите кнопку Выбор каталога для поиска файлов.
  5. Если для базы данных требуется установить дополнительные параметры, нажмите кнопку Параметры. Чтобы узнать, необходимо ли изменение этих параметров, обратитесь к администратору базы данных. Для получения дополнительных сведений о параметрах нажмите кнопку Справка в диалоговом окне Установка драйвера ODBC для Paradox.


Настройка источника данных, использующего драйвер Microsoft SQL Server

  1. Если не открыто диалоговое окно Создание нового источника данных, выберите команду Создать запрос в меню Файл, а затем дважды щелкните значение Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите значение SQL server.
  2. На шаге 3 нажмите кнопку Подключить.
  3. Введите имя SQL-сервера в сети в поле Сервер. Для получения дополнительных сведений о значениях, которые могут вводиться в поле Сервер, нажмите кнопку Справка.
  4. Нажмите кнопку Параметры и установите любые другие параметры, необходимые для базы данных. Чтобы получить сведения о том, следует ли изменять какие-либо из этих параметров, обратитесь к администратору базы данных. Для получения информации о значениях параметров нажмите кнопку Справка.
  5. Введите имя пользователя и пароль, а затем дважды нажмите кнопку OK.


Настройка источника данных, использующего драйвер служб Microsoft SQL Server OLAP

Этот драйвер может использоваться при настройке источников данных как для серверных баз данных, так и для файлов автономного куба (*.cub), созданных из баз данных служб Microsoft SQL Server OLAP с помощью мастера создания автономного куба в Microsoft Excel или из записей реляционной базы данных мастером куба OLAP в Microsoft Query. См. источники данных OLAP.

Примечание. В этом разделе описывается настройка источников данных, использующих в качестве поставщика данных OLAP первую версию служб Microsoft SQL Server OLAP (версия 7.0 MSMDCUBE.DLL). Чтобы настроить источники данных для последних версий данного поставщика, вместо Microsoft Query можно воспользоваться мастером подключения данных. Для получения дополнительных сведений об этих источниках данных см. справку конкретной версии служб Microsoft SQL Server OLAP.

  1. Если не открыто диалоговое окно Создание нового источника данных, выберите команду Создать запрос в меню Файл, дважды щелкните значение Новый источник данных на вкладке Кубы OLAP. Введите имя источника данных и выберите Поставщик Microsoft OLE DB для служб OLAP.

    Вкладка Кубы OLAP доступна, только если Microsoft Query запускается из Microsoft Excel.

  2. Нажмите кнопку Подключить на шаге 3 диалогового окна Создание нового источника данных.
  3. На шаге 1 в диалоговом окне Multi-Dimensional Connection (многомерное подключение) выполните одно из следующих действий.

    Чтобы подключиться к серверной базе данных, выберите вариант Analysis server (сервер анализа) и укажите имя сервера, соответствующее имя пользователя и пароль. Для получения дополнительных сведений по подключению к базе данных обратитесь к администратору сервера.

    Чтобы подключиться к автономному кубу, выберите вариант Cube file (файл куба) и задайте путь к файлу (.cub) в поле File (файл).

  4. Выполните одно из следующих действий.

    При подключении к автономному кубу нажмите кнопку Finish (готово).

    При подключении к серверной базе данных нажмите кнопку Next (далее), и выберите нужную базу данных. Нажмите кнопку Finish (готово). На четвертом шаге в диалоговом окне Создание нового источника данных укажите имя базы данных куба, которая будет использоваться в качестве источника.


Настройка источника данных, использующий драйвер Microsoft для текстовых файлов

Потребуется настроить отдельный источник данных для каждой папки, содержащей текстовые файлы, доступ к данным из которых необходим. Если необходимо использовать один источник данных для одновременного доступа к нескольким текстовым файлам, перед выполнением описанных ниже действий, скопируйте все файлы в одну папку.

  1. Если на экране не открыто диалоговое окно Создание нового источника данных, выберите команду Создать запрос в меню Файл, а затем дважды щелкните значение Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите Драйвер Microsoft для текстовых файлов.
  2. На шаге 3 нажмите кнопку Подключить.
  3. Если текстовые файлы находятся не в текущей папке, снимите флажок Использовать текущий каталог, а затем нажмите кнопку Выбор каталога для поиска папки.

Примечание. Может осуществляться доступ к данным из текстовых файлов нескольких форматов, включая столбцы, разделенные пробелами, запятыми или знаками табуляции. Для получения дополнительных сведений о форматах текстовых файлов, которые можно использовать, нажмите кнопку Справка в диалоговом окне Установка текстового драйвера ODBC.


О создании нового запроса

Запрос — это средство поиска записей в базе данных по определенным условиям. Запрос может быть создан мастером создания запроса или непосредственно в Microsoft Query. Способ создания запроса определяется требованиями к отбору данных в каждом конкретном случае.

Когда необходим мастер запросов. Используйте мастер запросов, если необходимо создать простой запрос. С помощью мастера запросов можно выбрать таблицы и поля, которые нужно включить в запрос. Внутреннее объединение создается автоматически, когда мастер распознает поле первичного ключа в одной таблице и поле с тем же именем в другой таблице.

При помощи мастера запросов также можно осуществлять сортировку таблицы результатов и простейший отбор данных. На завершающем шаге выполнения мастера можно передать данные в Microsoft Excel, продолжить работу с запросом в Microsoft Query, либо создать из данных куб OLAP. Выполнение готового запроса возможно как в Microsoft Excel, так и в Microsoft Query. Инструкции по использованию мастера создания запросов.

Создание запроса в Microsoft Query. В Microsoft Query создаются более сложные виды запросов. Этот способ позволяет наиболее полно использовать возможности создания запросов. Объем получаемых данных может быть уменьшен путем создания внутреннего объединения или внешнего объединения, а также за счет использования выражений и сложных условий. В состав выражений могут входить операторы, функции, имена полей и константы. Работа с условиями позволяет выполнять сложные виды отбора данных.

Таблица результатов может быть просмотрена в Microsoft Query. Если таблица результатов содержит все нужные данные, ее можно передать в Microsoft Excel. Также в Query можно создавать кубы OLAP. Созданный запрос можно выполнять в Microsoft Excel или в Microsoft Query. Инструкции по созданию запросов в Microsoft Query.

Запросы с параметрами. С помощью одного запроса с параметрами можно извлекать данные, которые отвечают нескольким различным условиям. Так, для получения всех сведений о продажах одного изделия в качестве условия может быть указано наименование этого изделия. Запросы с параметрами также удобны при извлечении части большой базы данных, если нехватка системных ресурсов не позволяет получить все содержащиеся в ней данные сразу.

Запросом с параметрами при запуске требует ввести условия выборки данных. Создать запрос с параметрами можно только в Microsoft Query, но не в мастере запросов. Условие служит для выборки данных из таблиц. Созданный запрос можно выполнить или в Excel, или в Query. Инструкции по созданию запроса с параметрами.


Создание запроса

Предполагаемое действие:

Создание запроса с использованием мастера запросов

Создание сложного запроса в Microsoft Query

Создание параметрического запроса

Не можете сделать выбор?


Создание запроса с параметрами

  1. Создайте запрос, который будет включать таблицы и поля нужных записей.

    Инструкции

  2. Убедитесь, что кнопка Автоматический режим Значок кнопки не нажата.
  3. Для отображения области условий убедитесь, что кнопка Отображение условий Значок кнопки нажата.
  4. Выберите ячейку в строке Условие и щелкните стрелку, чтобы выбрать из списка поле, которое следует использовать в качестве параметра запроса.
  5. Выделите первую ячейку в строке Значение. Введите [ (открывающая квадратная скобка) и текст, который Microsoft Query будет выводить при запуске запроса. Затем введите ] (закрывающая квадратная скобка). Например:

    Текст сообщения должен отличаться от имени поля, однако имя поля может входить в него.

    Для создания нескольких параметров запроса повторите пункты 4 и 5 для каждого параметра, который добавляется в следующий свободный столбец в области условий.

    Чтобы получить дополнительные сведения об условиях запросов, нажмите кнопку Значок кнопки .

  6. Нажмите клавишу ВВОД.
  7. Для выполнения запроса нажмите кнопку Выполнить запрос Значок кнопки.

Примечание. После извлечения необходимых данных таблица результатов может быть передана в Microsoft Excel. Чтобы получить более подробные сведения, нажмите кнопку Значок кнопки .


Открытие запроса

  1. Нажмите кнопку Открыть запрос Значок кнопки, выберите нужный файл запроса и нажмите кнопку Открыть.

    Файлы запросов имеют расширение «.dqy» или «.qry».

  2. При необходимости введите имя пользователя и пароль, а также другие данные, которые требуются для подключения к источнику данных.
  3. При необходимости введите значения параметров запроса и нажмите кнопку OK. Если нужные параметры неизвестны, обратитесь к автору запроса.

Примечание. Также можно открыть файл определения куба (.oqy), который был создан при помощи мастера создания куба OLAP. При открытии файла указанного типа автоматически запускается мастер, с помощью которого можно изменить определение куба. См. сведения о создании кубов при помощи мастера создания куба OLAP.


Сохранение запроса

Сохраняйте запрос, чтобы запомнить текущие параметры форматирования, а также для использования запроса в другое время или из другой книги. Для получения дополнительных сведений об открытии файлов запроса в Microsoft Excel обратитесь к справочной системе Microsoft Excel. Для передачи данных в Excel не требуется сохранение запроса.

  1. Нажмите кнопку Сохранить Значок кнопки.
  2. Введите имя в поле Имя файла.
  3. В диалоговом окне Сохранить как Microsoft Query автоматически выбирает тип Файлы запросов (*.dqy). Для использования запроса в более ранней версии Query, чем Microsoft Query 97, выберите тип Файлы запросов (*.qry).

    Параметрический запрос может быть сохранен только в формате *.dqy и не может быть использован в более ранней версии Query, чем Microsoft Query 97.

  4. Выберите папку, в которой будет сохранен запрос, из списка Папка.
  5. Нажмите кнопку Сохранить.

Примечания

  • При сохранении файла запроса Query не сохраняет текущую таблицу результатов, отображенную в области данных. Таблица результатов автоматически обновляется перед появлением диалогового окна Сохранение запроса, даже если кнопка Автоматический режим Значок кнопки не нажата.
  • Чтобы запретить выполнение запроса до его сохранения или возвращения данных в Excel, в меню Правка выберите Параметры и затем снимите флажок Проверять запросы перед сохранением или возвратом данных.
  • По умолчанию файлы запросов хранятся в папке профиля пользователя в Application Data\Microsoft\Queries. При сохранении запроса в стандартной папке имя файла запроса выводится на вкладке Запросы при открытии нового запроса в Microsoft Query или при выборе команды Выполнить сохраненный запрос (меню Данные, подменю Внешние данные) в Microsoft Excel.


Выполнение, просмотр и изменение команды, процедуры или инструкции SQL

Структурированный язык запросов (SQL) может использоваться при изменении инструкции SQL SELECT в запросе. Для получения дополнительных сведений по языку SQL обратитесь к документации базы данных.

  1. Создайте новый запрос. Не передавайте результаты в Microsoft Excel.

    Инструкции

  2. Нажмите кнопку Режим SQL Значок кнопки.

    В Microsoft Query будет выведено диалоговое окно Запрос SQL с соответствующей инструкцией SELECT языка SQL.

  3. Внесите необходимые изменения в инструкцию SQL и нажмите кнопку OK.

    Чтобы добавить строку в поле Инструкция SQL, нажмите клавишу ENTER.

Примечания

  • При изменении или замене инструкции SQL используется синтаксис, который использовался в Microsoft Query поддерживается источником данных. Microsoft Query интерпретирует используемый синтаксис и выводит на экран проект запроса и таблицу результатов.
  • Если Microsoft Query не может вывести проект запроса из-за синтаксической ошибки в какой-либо его части, таблица результатов все равно выводится. Однако допускается только изменение форматирования таблицы результатов, например шрифта экрана или ширины столбца. Изменение данных не допускается, а все изменения, вносимые в запрос, например добавление или удаление полей, должны производиться в диалоговом окне Запрос SQL.


Выполнение запроса автоматически или вручную

При каждом добавлении поля в область данных, а также при изменении или добавлении условий в области условий. Microsoft Query автоматически выполняет запрос и обновляет данные в таблице результатов. Если в запросе содержится большое число записей, может понадобиться отложить выполнение запроса до внесения всех изменений в запрос.

  • Для автоматического выполнения запроса при добавлении каждого нового условия или поля убедитесь, что кнопка Автоматический режим Значок кнопки нажата.
  • Чтобы отложить выполнение запроса до того, как будут добавлены все нужные поля и условия, убедитесь, что кнопка Автоматический режим Значок кнопки не нажата. Когда запрос будет готов, нажмите кнопку Выполнить запрос Значок кнопки.


Возврат таблицы результатов в Microsoft Excel

  1. Если не открыто диалоговое окно Передача внешних данных в Microsoft Excel, нажмите кнопку Вернуть данные Значок кнопки и при выводе сообщения введите необходимые для запроса параметры.
  2. Нажмите кнопку Свойства для установки параметров форматирования, используемых при передаче фрагмента внешних данных в Microsoft Excel. Для получения дополнительных сведений обратитесь к справочной системе Microsoft Excel.
  3. Чтобы поместить таблицу результатов на текущий лист, выберите параметр Существующий лист. Выберите ячейку листа, в которую будет помещен левый верхний элемент, из таблицы результатов и нажмите кнопку OK.

    Чтобы поместить таблицу результатов в новый лист, выберите параметр Новый лист, а затем нажмите кнопку OK. Microsoft Excel добавит новый лист к книге и автоматически поместит таблицу результатов в верхний левый угол нового листа.

    Для использования внешних данных в сводной таблице выберите Отчет сводной таблицы, а затем нажмите кнопку OK.

Примечания

  • Таблица результатов автоматически обновляется в Microsoft Query перед выводом диалогового окна Возврат данных в Microsoft Excel, даже если кнопка Автоматический режим Значок кнопки не нажата. Чтобы запретить выполнение запроса до возвращения данных в Microsoft Excel, в меню Microsoft Query Правка выберите команду Параметры, а затем снимите флажок Проверять запросы перед сохранением или возвратом данных.
  • Имеется возможность проверки состояния запроса, возврат данных которым выполняется слишком долго. В Microsoft Excel нажмите кнопку Состояние обновления значок кнопки на панели инструментов Внешние данные. Для отмены передачи данных нажмите Отменить обновление.


Выполнение инструкции или процедуры SQL

Для выполнения инструкции SQL SELECT необходимо иметь представление о языке SQL (структурированном языке запросов). Дополнительные сведения по этому языку можно найти в документации по базе данных.

  1. Выберите команду Выполнить запрос SQL в меню Файл.

    Для выполнения инструкции SQL в таблице из другого источника данных нажмите кнопку Источники данных, выберите нужный источник и нажмите кнопку OK. Можно указать новый источник данных.

    Инструкции

  2. Введите инструкцию SQL, которую нужно выполнить, в поле Инструкция SQL.

    Для выполнения существующей инструкции нажмите кнопку Открыть, выберите файл, содержащий процедуру на языке SQL, и нажмите кнопку Открыть.

    Для выполнения процедуры SQL, хранящейся во внешней базе данных, нажмите кнопку Процедуры, выберите нужную процедуру из списка Запрос, а затем нажмите кнопку Вставить, чтобы скопировать процедуру в поле Инструкция SQL.

  3. Нажмите кнопку Выполнить.

    Microsoft Query начнет выполнение инструкции SQL. Для отмены запроса, занимающего слишком много времени, нажмите клавишу ESC.

    Чтобы сохранить инструкцию SQL, нажмите кнопку Сохранить.

Примечания

  • При изменении или замене инструкции SQL используйте тот же синтаксис, что и Microsoft Query, или синтаксис, поддерживаемый источником данных. Microsoft Query интерпретирует используемый синтаксис и выводит на экран проект запроса и таблицу результатов.
  • Если Microsoft Query не может вывести проект запроса из-за синтаксической ошибки в какой-либо его части, то таблица результатов все равно выводится. Однако может быть изменено только форматирование таблицы результатов, например шрифт экрана или ширина столбца. Изменение данных невозможно, и все изменения, вносимые в запрос, например добавление или удаление полей, должны производиться в диалоговом окне SQL.
  • Если при выполнении запроса возвращается несколько таблиц результатов, в области данных Microsoft Query выводится только первая из них. Остальные таблицы результатов не отображаются.
  • Если запрос был успешно выполнен, но не вернул никакой таблицы результатов, Microsoft Query выводит сообщение об успешном выполнении запроса. Если при выполнении запроса были изменены строки в таблицах, в сообщении также указывается количество измененных строк.
  • Если при выполнении запроса произошла ошибка, Microsoft Query выводит соответствующее сообщение SQL об ошибке. Чтобы вывести диалоговое окно Выполнить запрос SQL и исправить инструкцию, нажмите кнопку OK.


О запросах OLAP

Средствами Microsoft Query можно создавать базы данных OLAP (On-Line Analytical Processing — электронная аналитическая обработка данных) и работать с записанными в них данными: настраивать источники баз данных, создавать кубы OLAP из реляционной базы данных и сохранять файлы определения куба OLAP. В этом разделе рассматривается подготовка данных OLAP с помощью Microsoft Query для последующего их использования в отчетах сводных таблиц и отчетах сводных диаграмм Microsoft Excel.

Данный раздел содержит сведения по следующим темам:

Что такое OLAP?

Подключение к базам данных OLAP

Создание куба OLAP из записей запроса

Сохранение файлов запроса OLAP

Что такое OLAP?

OLAP — способ организации больших коммерческих баз данных. Структура данных OLAP задается администратором базы данных таким образом, чтобы обеспечить наибольшую эффективность анализа и управления, а также свести к минимуму затраты труда и времени при подготовке отчетов.

Уровни детализации. Базы данных OLAP имеют многоуровневую структуру с таким подразделением на категории, которое ориентировано на выполнение задачи анализа данных. Например, база данных по международным продажам продукции компании может содержать отдельные поля, определяющие страну, область, город и место для каждой продажи. В базе данных OLAP эта географическая информация может быть организована по уровням:

Уровни в географическом аспекте

Уровни в географической размерности

Данная организация позволяет так же легко показывать итоги глобальных продаж, например продажи по стране или области, как и подробности для мест, где продажи чрезвычайно велики или малы. В отчете сводной таблицы или диаграммы можно вывести сводные данные на различных уровнях, а при просмотре уровней, содержащих более подробные данные, можно вывести только интересующие элементы.

Размерности и кубы. Размерность — таблица уровней, охватывающая одну сторону данных, как например, географические области. Аналогично, данные о дате продажи могут быть организованы по времени с уровнями год, квартал, месяц и день. Базы данных OLAP названы кубами, потому что они объединяют различные размерности, как например, время, географическое положение и продукты, с итоговыми данными, как например, продажи или инвентаризационные номера. Для каждого пересечения каждого уровня каждой размерности, как например суммарная продажа в течении дня, месяца, года для каждого места, области, страны для каждого продукта и группы продуктов, в базах данных OLAP вычисляются итоговые значения.

Возврат в начало

Подключение к базам данных OLAP

Поставщик данных для куба. Для подключения к базе данных OLAP требуется поставщик данных для куба, который поддерживает данный тип баз данных OLAP. Программное обеспечения поставщика данных для средств OLAP (Microsoft SQL Server OLAP Services) поставляется вместе с Microsoft Office. Для других продуктов, предоставляющих OLAP данные и услуги, требуется установить дополнительные драйверы и программное обеспечение клиента. Для получения дополнительных сведений об использовании поставщиков данных для куба от сторонних поставщиков свяжитесь с системным администратором или производителем продукта. См. сведения об установке поставщиков данных для куба.

Источники данных. Программное обеспечение клиента OLAP включает в себя драйвер источника данных для базы данных OLAP. Office содержит драйвер, именуемый Microsoft OLE DB Provider for OLAP Services, предназначенный для доступа к базам данных, созданных при помощи Microsoft SQL Server OLAP Services. При создании в Microsoft Query файлов кубов или файлов автономных кубов также создаются источники данных для доступа к этим кубам.

При запуске Microsoft Query для подключения к базе данных OLAP или файлу автономного куба настраивается новый источник данных, такой же как и для любого другого типа данных, исключая случай, когда для подключения к базе данных используется вкладка Кубы OLAP в диалоговом окне Выбор источника данных для указания имени источника данных и драйвера для поставщика данных для куба. Как настроить источник данных.

Возврат данных в Microsoft Excel. После настройки источника данных OLAP и его выбора для использования не создавайте запрос для выбора таблиц и полей, как это делается для других видов данных. Источник данных предоставляет доступ ко всем данным в кубе. Поля данных немедленно возвращаются в Microsoft Excel в качестве отчета сводной таблицы.

Возврат в начало

Создание куба OLAP из записей запроса

Используя Microsoft Query и клиентское программное обеспечение OLAP из Microsoft Office, можно создать из данных, запрошенных из реляционной базы данных, например Microsoft SQL Server, собственный куб OLAP или файл автономного куба. Создание куба повышает эффективность доступа к большим объемам реляционных данных и позволяет помочь организовать данные для их использования в отчетах. Для использования данного типа кубов нет необходимости в серверном OLAP-приложении.

Извлечение данных из куба. Для создания собственного куба настройте источник данных для реляционной базы данных, создайте запрос для извлечения данных и запустите мастер создания куба OLAP, который определит структуру куба для извлекаемых данных. При желании сохраните файл автономного куба.

Создание куба в памяти компьютера. При использовании мастера можно создать временный куб, который будет строиться в памяти каждый раз при открытии отчета, основанного на данном кубе. Для получения дополнительных указаний по созданию данного вида куба обратитесь к справочной системе мастера создания куба. Изучите работу мастера по созданию куба OLAP.

Создание автономного файла. Мастер создания кубов OLAP также позволяет создавать автономные файлы куба (.cub), которые могут быть сохранены на локальном или на сетевом диске. Сохранение на локальном диске позволяет продолжать работу с данными, даже когда машина отключена от сети или когда сервер недоступен. Сохранение на сетевом диске позволяет другим пользователям устанавливать источники данных для доступа к автономному кубу и основывать на нем отчеты. Изучите работу мастера по созданию файла автономного куба OLAP.

Возврат в начало

Сохранение файлов запроса OLAP

Источники данных OLAP. Если источник данных настраивается в диалоговом окне Выбор источника данных (вкладка Кубы OLAP), Microsoft Query сохраняет OQY-файл в папке профиля пользователя, которая находится в каталоге «Application Data\Microsoft\Queries». Этот файл может быть открыт непосредственно из приложения Microsoft Excel с целью подготовки отчета сводной таблицы. Содержащиеся в этом файле данные дополняют сведения об источнике, которые задаются при создании отчета сводной таблицы или сводной диаграммы в Microsoft Excel. Если OQY-файл подключен к базе данных сервера OLAP или к файлу автономного куба на сетевом диске, этот файл можно сделать доступным для других пользователей. Это избавит их от необходимости самостоятельной настройки источников данных при создании отчетов.

Кубы, созданные мастером создания кубов OLAP. После завершающего шага в мастере создания куба OLAP будет запрошено сохранение файла определения куба с расширением OQY. Этот файл содержит данные, которые необходимы Microsoft Excel или для создания куба в памяти, или для подключения к файлу автономного куба, если он был создан. Вместо того, чтобы возвращать записи запроса в Microsoft Excel, можно открыть этот файл в этом приложении для создания отчета сводной таблицы. Нет необходимости в настройке отдельного источника данных для куба OLAP, хотя можно настроить источник данных для файла автономного куба, если к нему требуется подключиться для создания отчетов.

Сохранение OQY-файла не равноценно сохранению копии запроса к записям реляционной базы данных, которые используются для создания куба OLAP. Если необходимо сохранить копию запроса, чтобы впоследствии добавить данные к кубу, следует сохранить запрос в DQY-файле (файл запроса к базе данных).

Возврат в начало


Создание куба OLAP на основе реляционных данных

В данном разделе описываются методы создания куба OLAP из запроса, который загружает данные из реляционной базы данных, например Microsoft Access или Microsoft SQL Server. Для использования или создания такого типа куба OLAP серверное приложение не требуется. Для понимания и использования этой возможности Microsoft Query необходимо ознакомиться с управлением баз данных и загрузкой данных для отчетов сводной таблицы или отчетов сводной диаграммы средствами Microsoft Query.

Этот раздел предоставляет сведения о следующем:

Что такое куб OLAP?

Создание запроса для данных

Создание куба OLAP

Обновление и изменение куба OLAP

Что такое куб OLAP?

Электронная аналитическая обработка данных (On-Line Analytical Processing — OLAP) — способ организации данных, ориентированный на анализ и управление данными, позволяющий ускорить процесс подготовки отчетов и сделать его менее трудоемким. При создании куба OLAP из запроса происходит преобразование линейной таблицы в структурную иерархию (куб); при этом обеспечивается требуемый уровень детализации в отчетах. Также заранее задаются итоговые значения для отчетов, что позволяет повысить скорость вычислений.

Создайте куб OLAP, когда необходимо обеспечить большой объем внешних данных для использования в отчетах Microsoft Excel, особенно если возврат записей для анализа в Microsoft Excel приводит к недостатку системных ресурсов. Поскольку куб позволяет загрузить в Microsoft Excel только те данные, которые необходимы для текущего вида отчета, для больших объемов данных создание и обновление отчета обычно происходит быстрее, чем при загрузки всей таблицы записей из базы данных.

Данные из куба OLAP могут быть возвращены в Microsoft Excel только в виде отчета сводной таблицы или сводной диаграммы, в отличие от записей реляционных баз данных в запросе, которые могут быть возвращены в Microsoft Excel также в виде диапазона внешних данных листа.

Возврат в начало

Создание запроса для данных

Для создания куба OLAP из записей реляционной базы данных необходимо настроить источник данных для реляционной базы данных и затем создать запрос для извлечения полей и записей, которые послужат данными для куба.

Выбор полей для запроса. Чтобы обеспечить наибольшую эффективность выполнения запроса, необходимо включить только те таблицы и поля, которые необходимы для куба в запросе. Однако убедитесь, что добавлены все необходимые поля. После создания куба невозможно добавить дополнительные поля в запрос и тем самым включить новые поля в куб. Для добавления новых полей в куб необходимо полностью заново создать куб.

Многократное добавление полей. Иногда необходимо использовать поле в кубе больше одного раза. Например, необходимо произвести две различные операции с полем «Продажи»: сложить суммы продаж и подсчитать количество продаж. Или необходимо включить две различные версии поля «Дата»: одно состоящее из кварталов и месяцев, второе — из кварталов и недель. Для того чтобы использовать поле больше одного раза в кубе, необходимо добавить поле в запрос по одному разу для каждого использования. Например, добавьте поле «Продажи» в запрос дважды, если предполагается суммировать и подсчитывать количество значений в этом поле.

Обратитесь к справочной системе мастера создания куба OLAP для получения точных указаний, когда необходимо включать поле в запрос больше одного раза. Если необходимо добавить поле в момент выполнения мастера, то отмените работу мастера, добавьте поле и запустите мастер заново.

Сохранение запроса. Если предполагается, что впоследствии куб будет заново создан с другими полями, убедитесь что запрос сохранен в файле базы данных запроса (расширение «.dqy»). Затем можно будет открыть DQY-файл, изменить запрос и создать новые кубы из измененного запроса.

Возврат в начало

Создание куба OLAP

Для создания куба необходимо запустить мастер создания куба OLAP. Обратитесь к справочной системе мастера создания куба OLAP для получения точных указаний по каждому шагу мастера.

Временные кубы и файлы автономного куба. Мастер позволяет создавать два типа кубов. Первый — определение куба, которое сохраняется в OQY-файле. При открытии отчета на основе данного типа OQY-файла происходит временное создание куба в памяти. Второй — отдельный файл автономного куба, который хранится на локальном или сетевом диске. Сохранение такого типа куба на локальном диске позволяет продолжать работу с данными, даже когда компьютер отключен от сети. Файл автономного куба может быть настроен как источник данных для отчетов.

Сохранение файла определения куба. Сохранялся или нет отдельный файл автономного куба, но мастер сохраняет файл определения куба (расширение «.oqy»). Этот файл содержит данные, необходимые Microsoft Query для загрузки куба, поэтому при его изменении и данные Microsoft Excel требуют или создания куба в памяти, или подключения к файлу автономного куба, если он был создан.

Создание файла определения куба для создания отчетов. Вместо того чтобы возвращать записи реляционной базы данных в Microsoft Excel, можно открыть OQY-файл в Microsoft Excel для создания сводной таблицы отчета, которая будет основываться на кубе OLAP. Затем можно сохранить сводную таблицу отчета в книге или создать сводную диаграмму отчета, которая будет основываться на сводной таблице отчета. Для получения дополнительных сведений об открытии OQY-файлов и создании отчетов обратитесь к справочной системе Microsoft Excel.

Возврат в начало

Обновление и изменение куба OLAP

Обновление куба OLAP. Для того чтобы обновить куб, необходимо открыть отчет, который основывается на этом кубе, в Microsoft Excel и обновить отчет. Если куб создан временно в памяти, то после этих действий новые или измененные данные из исходной базы данных будут перенесены в куб. Если куб представлен автономным файлом, то уже существующий файл будет заменен файлом с новыми данными. Для создания и обновления кубов необходим поставщик данных для куба, например службы Microsoft SQL Server OLAP с поддержкой описанных возможностей. Для получения дополнительных сведений о процедуре обновления отчета сводной таблицы (сводной диаграммы), основанного на кубе, обратитесь к справке Microsoft Excel.

Изменение куба OLAP. Для того чтобы изменить структуру данных или удалить ненужные в отчете поля, можно изменить куб, созданный мастером создания куба OLAP. Файл автономного куба может быть сохранен вместе с внесенными изменениями.

После создания куба OLAP добавление к нему других полей из исходной реляционной базы данных невозможно. Однако можно создать новый куб из того же DQY-файла базы данных запроса, так что будут использоваться различные поля из исходной базы данных.

Возврат в начало


Создание куба OLAP из реляционной базы данных

Данные из куба OLAP могут быть переданы обратно в Microsoft Excel только как отчет сводной таблицы, но не в виде диапазона внешних данных на листе.

  1. Создайте запрос для извлечения полей, необходимых для использования в кубе.

    Инструкции

  2. Запустите мастер создания куба OLAP одним из следующих способов:

    Если запрос был создан при помощи мастера, то в последнем шаге мастера нажмите кнопку Создание куба OLAP из данного запроса и затем нажмите кнопку Готово.

    Если запрос был создан в Microsoft Query, то в меню Файл нажмите кнопку Создать куб OLAP.

  3. Следуйте указаниям мастера создания куба. Обратитесь к справочной системе мастера создания куба OLAP для получения точных указаний по каждому шагу мастера.
  4. По завершении работы мастера будет выдан запрос на сохранение файла определения куба (.oqy). Введите имя файла и нажмите кнопку Сохранить.

Примечания

  • Если в мастере создания куба выбран файл автономного куба (.cub), после нажатия кнопки Сохранить этот файл будет записан на диск. При большом объеме данных сохранение файла может занять некоторое время. Пока создание CUB-файла не завершится, выполнение других действий в Microsoft Query невозможно.
  • На основе данных куба могут быть созданы дополнительные отчеты Microsoft Excel; в этом случае нет необходимости передавать данные запроса обратно в Microsoft Excel. Вместо этого откройте OQY-файл с помощью команды Открыть меню Файл.
  • Отчеты Microsoft Excel могут создаваться также на основе данных автономного куба. Для этого следует настроить источник данных для соответствующего файла, затем указать этот источник при запуске мастера сводных таблиц и диаграмм.
  • Если к кубу впоследствии будут добавляться поля, сохраните файл запроса к базе данных (.dqy), чтобы воспользоваться им при изменении куба.


Изменение содержания и установок куба OLAP

В уже существующем кубе OLAP допускается удаление полей и изменение их расположения, однако добавление новых полей невозможно. Если требуется добавить поля, создайте новый куб.

  1. Выберите Открыть в меню Файл Microsoft Query.
  2. Выберите Кубы OLAP в списке Тип файлов.
  3. Найдите и дважды щелкните файл определения куба (расширение «.oqy»), который требуется изменить.
  4. Следуя инструкциям мастера создания куба, измените требуемым образом его структуру и параметры. Более подробные сведения приведены в справочной системе мастера создания куба OLAP.
  5. После завершения работы мастера создания куба выдается запрос на сохранение OQY-файла. Чтобы заменить уже существующий файл, нажмите кнопку Сохранить. Для сохранения отдельного OQY-файла введите новое имя и нажмите кнопку Сохранить.

Примечания

  • Если в мастере создания куба указан файл автономного куба (.cub), то этот файл будет создан после нажатия кнопки Сохранить. Изменяемый CUB-файл должен быть создан заново. В зависимости от объема данных, сохранение файла может потребовать значительного времени. Пока создание CUB-файла не завершится, выполнение других задач в Microsoft Query невозможно.
  • Чтобы создать отчет Microsoft Excel на основе CUB-файла, откройте этот файл с помощью команды Открыть в меню Microsoft Excel Файл либо настройте источник данных для CUB-файла и укажите его при запуске мастера сводных таблиц и диаграмм.


Удаление файла автономного куба

При удалении файла автономного куба (.cub) он стирается с диска, освобождая место для других данных. Однако после этого изменение отчетов, которые были созданы на основе этого куба, будет невозможно. Также нельзя будет работать с источниками данных, в которых использовался удаленный файл.

  • В Microsoft Windows найдите и удалите этот CUB-файл.


Добавление таблицы в запрос

  1. Нажмите кнопку Добавить таблицу Значок кнопки.
  2. Выберите таблицу, которую требуется добавить.
  3. Нажмите кнопку Добавить.

Примечание. В запрос может быть добавлено любое число таблиц. Добавив нужные таблицы, нажмите кнопку Закрыть.


Удаление таблицы из запроса

  1. Выберите таблицу, которую нужно удалить.
  2. В меню Правка выберите команду Удалить.


Добавление или удаление поля

Поле — категория данных, например наимерование товара или сумма заказа из таблицы в базе данных. При добавлении или удаления поля запрос включает или исключает данные из этого поля. При этом база данных остается неизмененной.

Добавление поля. Чтобы добавить одно поле в таблицу результатов, дважды щелкните имя поля, которое нужно добавить, в области таблиц.

Пример одного поля, выбранного в области таблиц

Удаление поля. Чтобы удалить поле из таблицы результатов, щелкните заголовок столбца полей, которые нужно удалить, в области данных, а затем выберите команду Удалить столбец в меню Записи.

Советы

  • Для добавления за один раз нескольких полей из одной и той же таблицы выберите каждое поле, удерживая клавишу CTRL, и перетащите выбранные поля в область данных.
  • Чтобы добавить все поля из таблицы в результирующий набор, дважды щелкните * (звездочку) в верхней части таблицы (в области таблиц).

    Пример помеченных звездочкой (*) полей в области таблиц


Извлечение связанных записей из нескольких таблиц с объединениями

Данный раздел содержит сведения по следующим темам:

Объединение таблиц

Внутренние объединения

Внешние объединения

Самообъединения

Полные внешние объединения

Вычитательные объединения

Объединение таблиц

Базы данных содержат несколько таблиц со связанными данными. При добавлении двух (и более) таблиц к запросу, Microsoft Query автоматически создает «связь» между таблицами при обнаружении ключевого поля в одной таблице и поля с таким же именем в другой. Линии связи показывают схему данных в таблицах.

Линии связи между таблицами

Линии связи устанавливают связь между таблицей «Продукты» и таблицей «Подробности заказов», связывая поле «ИдентификационныйНомерПродукта» в каждой таблице. Таблицы «Подробности заказов» и «Продукты» также связаны полями «ИдентификационныйНомерЗаказа».

Для извлечения записей из нескольких таблиц существует два основных типа объединений. Внутреннее объединение извлекает только связанные записи из таблиц. Внешнее объединение извлекает все записи из одной таблицы и связанные записи из другой.

В дополнение к внутренним и внешним объединениям существует еще три других типа объединений: самообъединения, полное внешнее объединение и вычитательное объединение. Самообъединения возвращают таблицу результатов, которая объединяет данные содержащиеся в одной таблице. Полное внешнее объединение возвращает все записи из обоих таблиц, даже если записи не связаны. Вычитательное объединение возвращает только те записи из первой таблицы, которые не совпадают с записями из второй.

Возврат в начало

Внутренние объединения

Внутреннее объединение (тип объединения по умолчанию) извлекает только записи, которые имеют одинаковые значения в связанных полях. Microsoft Query объединяет совпадающие записи из каждой таблицы и показывает их в таблице результатов.

Пример внутреннего объединения

Дополнительные сведения

Объединение таблиц в запросе

Изменение типа объединения таблиц в запросе

Возврат в начало

Внешние объединения

Внешнее объединения извлекает все записи из одной таблицы и любые совпадающие записи из другой таблицы. Когда значения из двух таблиц одинаковы, Microsoft Query объединяет совпадающие записи и показывает их в таблице результатов как одну запись. Когда запись из таблицы, которая предоставила все свои записи, не совпадает с записью из другой таблицы, то эта запись тем не менее появится в таблице результатов. Однако, Query показывает пустые ячейки, где нет совпадающих записей, в другой таблице.

Пример внешнего объединения

Дополнительные сведения

Объединение таблиц в запросе

Изменение типа объединения таблиц в запросе

Возврат в начало

Самообъединения

Используйте самообъединения для объединения данных в одной таблице. Например, в таблице работников каждая запись включает идентификационный номер его руководителя, которому отчитывается работник. Записи о руководителях находятся в той же таблице работников, поэтому можно объединить таблицу с собой же, для возврата и имени, и идентификационного номера руководителя.

Объединяя таблицу с собой же, можно загрузить и идентификационный номер, и имя руководителя.

Дополнительные сведения

Загрузка нескольких полей при помощи самообъединений

Возврат в начало

Полные внешние объединения

Для объединения всех данных из двух таблиц необходимо создать запрос полного внешнего объединения. Данный тип запроса возвратит все данные из обеих таблиц, даже если данные не связаны.

Таблицы с похожими данными до проведения полного внешнего объединения

Например, можно воспользоваться полным внешним объединением двух таблиц («Заказчики» и «Заказы») для возврата всех ожидающих решения заказов (из таблицы «Заказы») и всех заказчиков (из таблицы «Заказчики») не сделавших заказ.

В таблице результатов отображены заказчики, не разместившие заказы

Два заказчика, имена которых указаны в таблице первыми, не разместили заказы.

Примечание. При создании полного внешнего объединения в Microsoft Query отображается только таблица результатов, а не таблицы используемые в запросе.

Дополнительные сведения

Объединение всех данных из двух таблиц

Возврат в начало

Вычитательные объединения

Вычитательное объединение может создаваться, если в двух таблицах содержатся схожие данные (например, в двух таблицах заказчиков), но в каждой из них есть некоторые сведения, отсутствующие в другой таблице. Вычитательное объединение возвращает только записи из первой таблицы, не совпадающие с записями из второй таблицы.

Таблицы с похожими данными до вычитательного объединения

Две таблицы с похожими данными о заказчиках

Пример вычитательного объединения

Дополнительные сведения

Извлечение отличающихся записей двух таблиц

Возврат в начало


Извлечение записей из нескольких таблиц

Если запрос содержит больше чем одну таблицу, то извлечение связанных записей из нескольких таблиц возможно при помощи объединений. Объединение — связь двух таблиц, где поля в одной таблице содержат такие же данные, что и в другой.

Предполагаемое действие:

Изучите извлечение записей при помощи внутренних и внешних объединений

Создание внутреннего объединения

Создание внешнего объединения

Создание самообъединения

Извлечение всех записей из двух таблиц

Извлечение только тех записей из двух таблиц, которые не являются общими


Объединение всех данных из двух таблиц

Для совмещения всех данных из двух таблиц, содержащих схожие, но не одинаковые данные, например из двух списков (таблиц) заказчиков, в которых содержатся разные сведения (поля) о каждом заказчике, можно создать запрос, включающий сведения обо всех заказчиках. При этом в каждом списке имеются заказчики, которых нет в другом списке. Такой запрос называется полным внешним объединением. Изучите полные внешние объединения.

  1. В Microsoft Query создайте запрос и добавьте в него обе таблицы.
  2. Создайте объединение совпадающих полей двух таблиц (например, полей кода заказчика) путем перетаскивания поля из первой таблицы во вторую.

    Выберите из обеих таблиц поле, содержащее данные во всех записях. Например, если в двух списках заказчиков содержатся совпадающие поля кода заказчика, создайте объединенное поле «Код заказчика».

  3. Дважды щелкните линию связи между двумя таблицами.
  4. В диалоговом окне Объединения выберите параметр 2, нажмите кнопку Добавить, после чего нажмите кнопку Закрыть.
  5. Добавьте нужные поля в запрос.
  6. В меню Вид выберите команду Запрос SQL.
  7. Выберите данные в поле Инструкция SQL, нажмите CTRL+C, чтобы скопировать их, а затем нажмите кнопку OK.
  8. Снова дважды щелкните линию связи.
  9. В диалоговом окне Объединения, выберите параметр 3, нажмите кнопку Добавить, а затем нажмите кнопку Закрыть.
  10. В меню Вид выберите команду Запрос SQL.
  11. Щелкните конец строки в поле Инструкция SQL, нажмите клавишу ENTER, введите заглавными буквами слово UNION и снова нажмите клавишу ENTER.
  12. Нажмите клавиши CTRL+V, чтобы вставить данные из буфера после слова UNION.
  13. Нажмите кнопку OK и после вывода сообщения о невозможности графического отображения запроса снова нажмите кнопку OK.


Извлечение отличающихся записей двух таблиц

При наличии двух таблиц, содержащих сходные данные, например двух списков (таблиц) заказчиков, в каждом из которых имеются сведения, отсутствующие в другом списке, можно создать запрос, возвращающий только те записииз первой таблицы, которые отсутствуют во второй. Такой запрос называется вычитательным объединением.

  1. В Microsoft Query создайте запрос и добавьте в него обе таблицы.
  2. Создайте объединение совпадающих полей двух таблиц (например, полей кода заказчика в двух списках) путем перетаскивания поля из первой таблицы во вторую.
  3. Дважды щелкните линию связи между двумя таблицами.
  4. В диалоговом окне Объединения выберите параметр 2, нажмите кнопку Добавить, после чего нажмите кнопку Закрыть.
  5. Добавьте объединенные поля в запрос.
  6. Добавьте отличное от объединенного поле из второй таблицы. Выберите поле, в котором содержатся данные для всех записей второй таблицы. Например, если были объединены поля кодов заказчиков из двух таблиц, можно добавить поле имени заказчика из второй таблицы.
  7. Выберите команду Условия в меню Вид.
  8. Из первого списка условий выберите поле, добавленное на шаге 6.
  9. В первом поле Значение введите Null.
  10. Для просмотра записей первой таблицы, которых нет во второй, нажмите кнопку Выполнить запрос Значок кнопки.
  11. Добавьте любые другие необходимые поля в запрос и передайте данные в Microsoft Excel.

Примечание. Для просмотра записей из второй таблицы, для которых нет совпадающих в первой, создайте второй запрос, выполнив те же шаги, но поменяв местами таблицы (сделайте вторую таблицу первой и наоборот).


Создание внешнего объединения

Внешние объединения отображают все записи из одной таблицы и любые связанные записи из другой.

  1. Создайте внутреннее объединение между таблицами. Инструкции по созданию внутреннего объединения.
  2. Дважды щелкните линию объединения таблиц.
  3. Выберите = (знак равно) в списке Оператор.
  4. Выполните одно из следующих действий.

    Для создания внешнего объединения, при котором используются все записи из таблицы слева, выберите параметр 2 из списка Объединение включает.

    Для создания внешнего объединения, в котором используются все записи из таблицы справа, выберите параметр 3 из списка Объединение включает.

Примечания

  • Извлечение всех записей из двух таблиц. Для объединения всех записей из двух таблицы, которые могут быть или не быть связанными, необходимо создать полное внешнее объединение.
  • Извлечение только тех записей из двух таблиц, которые не являются общими. Вместо извлечения связанных записей можно извлечь все записи из двух таблиц, которые не являются общими.


Создание внутреннего объединения

  • Перетащите поле из одной таблицы на совпадающее поле (поле такого же типа, содержащее те же данные) из списка полей другой таблицы.

Примечание. При внутреннем объединении Microsoft Query выбирает записи из обеих таблиц или запросов только тогда, когда значения в объединенных полях равны. Также можно создать внешнее объединение, которое выберет все записи из одной таблицы и любые связанные записи из другой.


Создание самообъединения

Используйте эту процедуру для объединения данных из двух копий одной таблицы — например, когда данные работника включают в себя идентификационный номер его руководителя и необходимо объединить идентификационный номер с именем руководителя. Тип запроса, создаваемый данной процедурой, называется самообъединением. См. сведения о самообъединениях.

  1. Создайте запрос в Microsoft Query и добавьте таблицу, для которой нужно создать самообъединение.
  2. Добавьте такую же таблицу к запросу еще раз.
  3. При сообщении, что таблица уже присутствует в запросе, нажмите кнопку OK.
  4. Если две таблицы будут объединены автоматически, то дважды щелкните линию связи, выберите Удалить, и затем нажмите кнопку Закрыть.
  5. Создайте внутреннее объединение между двумя таблицами. Например, если поле «Руководитель» использует для опознавания руководителей идентификационный номер работника, то можно объединить поле «Руководитель» из первой таблицы с полем «Идентификационный номер работника» из второй.
  6. Добавьте необходимые поля в запросе. Например, для того чтобы видеть имена руководителей каждого работника, можно добавить поля «Имя работника» и «Руководитель» из первой таблицы, а затем поле «Имя работника» из второй.


Операторы, используемые при объединении

При объединении могут использоваться следующие операторы.

Оператор | Описание
= (Равно) | Выбор записей, содержащих равные значения в объединенных полях.
<> (Не равно) | Выбор записей, содержащих разные значения в объединенных полях.
> (Больше) | Выбор записей из левой таблицы, содержащих в объединенных полях значения, превышающие значения записей из правой таблицы.
>= (Больше или равно) | Выбор записей из левой таблицы, содержащих в объединенных полях значения, превышающие значения записей из правой таблицы или равные им.
< (Меньше) | Выбор записей из левой таблицы, содержащих в объединенных полях меньшие значения, чем значения записей из правой таблицы.
<= (Больше или равно) | Выбор записей из левой таблицы, содержащих в объединенных полях меньшие значения, чем значения записей из правой таблицы или равные им.


Удаление объединения

Если запрос содержит внутреннее объединение или внешнее объединение, но не выбирает нужные записи, может понадобиться удаление объединения.

  1. Выберите линию объединения, которую требуется удалить из области таблиц.
  2. Нажмите клавишу DEL.

Примечания

  • Записи, включенные в таблицу результатов запроса, при удалении объединения будут изменены. В зависимости от типа удаляемого объединения, записи могут быть добавлены или удалены из таблицы результатов.
  • Удаление объединения из запроса влияет только на этот запрос. Например, если Microsoft Query автоматически создает внутреннее объединение двух таблиц в запросе и это объединение удаляется, то Microsoft Query снова автоматически создаст внутреннее объединение двух таблиц при использовании их в другом запросе.


Об использовании условий

Данный раздел содержит сведения по следующим темам:

Что такое условия

Выполнение одиночного условия

Выполнение нескольких условий

Поиск похожих записей

Выбор диапазона значений

Использование вычислений

Исключение определенных записей

Поиск незавершенных записей

Что такое условия

Условие — это параметры, указываемые для поиска определенных записей в базе данных или таблице. Использование условий позволяет ограничить записи (или строки), включаемые в таблицу результатов запроса. Например, условие ЦенаЗаШтуку > 30 отбирает записи со значением поля «ЦенаЗаШтуку» больше 30. Условия добавляются в область условий Microsoft Query, непосредственно в поле, либо с помощью команды Добавление условия меню Условия. Поля, используемые для указания условия, не должны включаться в таблицу результатов.

Поскольку запрос может содержать несколько таблиц с одинаковыми именами полей, убедитесь, что используются поля из нужной таблицы. Например, если необходимо найти всех поставщиков для определенной страны, выберите поле «Страна» из таблицы «Поставщики», а не из таблицы «Заказчики».

Дополнительные сведения

Задание условий для выбора записей

Возврат в начало

Выполнение одиночного условия

Можно найти все записи со значениями, которые выполняют одиночное условие — например, определенную страну или продукт. В следующем примере представлено условие, извлекающее все записи, которые содержат значение «Швеция» в поле «Страна».

Пример использования одиночного условия

Для указания одиночного условия выберите имя поля из списка Условие и затем введите значение для поиска в поле Значение.

Дополнительные сведения

Примеры выражений, использующих логические операторы

Возврат в начало

Выполнение нескольких условий

Выполнение условий в двух и более полях Можно найти все записи со значениями, выполняющими одно условие в одном поле и другое условие в другом поле. Например, найдем все записи о всех заказчиках, проживающих в России на территории Московской области. Для выбора этих записей введите две таблицы условий в области условий. Для указания нескольких условий, где все условия истинны, создайте условие «И».

Параметры, удовлетворяющие условию «И»

Для поиска записей, удовлетворяющих нескольким условиям, укажите поле поле параметра для каждого условия..

Выполнение нескольких условий в одном и том же поле Можно найти все записи со значениями, соответствующими нескольким условиям в одном и том же поле. Для примера найдем все записи о всех заказчиках проживающих не только в России, но и в Украине. Для выбора этих записей введите две таблицы условий в области условий. Для указания нескольких условий, где одно из условий истинно, создайте условие «ИЛИ». В условии «ИЛИ» только одно из двух (или более) условий должно быть истинным.

Параметры, удовлетворяющие условию «ИЛИ»

Вышеуказанному условию удовлетворяют все заказчики из России или Мексики.

Примечание. Оператор ИЛИ может также использоваться внутри значения условия. Например, вместо значения Мексика в поле ИЛИ можно ввести Россия ИЛИ Мексика в поле Значение.

Дополнительные сведения

Примеры выражений, использующих логические операторы

Возврат в начало

Поиск похожих записей

Можно найти записи, где значения в одном поле схожи, например номера телефонов с одинаковыми кодами страны или области. В качестве примера, найдем всех заказчиков, чьи телефонные номера начинаются с кода области (171) или кода страны (1) и (11).

Условие, использующее оператор «Похоже на»

Для использования оператора Похоже на введите слово Похоже на и затем в одинарных кавычках укажите значение, которое необходимо найти.

Примечание. Знак процента (%) из примера выше — это подстановочный знак, соответствующий любому количеству знаков. Для обозначения только одного знака используется знак подчеркивания (_). В зависимости от источника данных, используемые подстановочные знаки меняются. Для получения дополнительных сведений о подстановочный знаках, которые поддерживаются драйвером источника данных, обратитесь к документации по этому драйверу.

Дополнительные сведения

Примеры выражений, использующих прочие типы операторов

Возврат в начало

Выбор диапазона значений

Можно найти все записи попадающие в диапазон значений или дат. Для примера, извлеките все записи заказов, размещенных между 1 ноября 1998 года и 31 декабря 1998 года. Для указания нескольких условий, которые должны выполняться, создайте условие «И». Для определения диапазона значений укажите условие «И».

Пример диапазона с двумя условиями

Условие «И», использующее два вхождения одного поля в области условий.

Диапазон, содержащий оператор «И».

Условие «И», в котором нижняя и верхняя граница разделены оператором И.

Примечание. При вводе даты в области условий, дата в Microsoft Query преобразуется в распознаваемый формат. Например, при вводе условия >31.10.1998, оно будет преобразовано в Microsoft Query к виду >#31.10.98#.

Дополнительные сведения

Примеры выражений, использующих операторы сравнения

Возврат в начало

Использование вычислений

Для поиска записей, совпадающих с результатами вычислений, например всех записей, сумма заказа в которых превышает произведение значения поля цены на значение поля количества.

Пример использования вычисляемого условия

Для поиска записей, в которых сумма заказа превышает 500 рублей, создайте формулу вычисления суммы заказа, а затем укажите условие.

Дополнительные сведения

Примеры выражений, использующих арифметические операторы

Возврат в начало

Исключение определенных записей

Вместо поиска записей, совпадающих с указанным значением, можно найти записи, не совпадающие со значением. Например, можно воспользоваться оператором НЕ для поиска всех записей о поставщиках, не живущих в России.

Условие с оператором «НЕ»

Оператор НЕ используется для исключения записей.

Дополнительные сведения

Примеры выражений, использующих логические операторы

Возврат в начало

Поиск незавершенных записей

Можно найти записи, содержащие отсутствующие или незавершенные значения. Например, воспользуйтесь оператором Null для поиска всех записей сотрудников, в которых отсутствует значение имени инспектора.

Условие с оператором «Null»

Оператор Null используется для поиска записей с пустыми полями.

Дополнительные сведения

Примеры выражений, использующих прочие типы операторов

Возврат в начало


Ограничение числа обрабатываемых записей путем использования условий

С помощью условий можно выбирать определенные записи. Microsoft Query использует условия для выбора нужных записей и вывода их в таблицу результатов. Для ограничения выбора записей можно выбрать значение в таблице результатов, а затем найти другие записи, соответствующие этому значению. Можно также создать условие в области условий, а затем выбрать записи, выполняющие только это условие.

Предполагаемое действие:

Изучите использование условий

Выбор записей, соответствующих определенному значению

Задание условий для выбора записей

Примеры выражений, которые можно использовать в качестве условий


Задание условий для выбора записей

  1. Нажмите кнопку Отображение условий Значок кнопки.

    В окне Microsoft Query будет отображена область условий.

  2. В области условий щелкните первую ячейку в строке Условие, а затем выберите поле, к которому будет применено условие.

    Если в запросе присутствует несколько таблиц с одинаковыми названиями полей, убедитесь, что поле выбрано из нужной таблицы.

  3. Выберите ячейку, расположенную непосредственно под полем, выбранным в строке Условие, из строки Значение.
  4. Введите условия, которые будут использоваться Microsoft Query для отбора записей, и нажмите клавишу ENTER.

    Инструкции

  5. При необходимости добавьте имена полей, которые должны отображаться в таблице результатов.

    Инструкции

    Для отображения записей из разных таблиц необходимо добавить эти таблицы в область таблиц запроса. Для получения дополнительных сведений о добавлении таблиц нажмите кнопку Значок кнопки .

Примечания

  • Таблица результатов может быть ограничена путем добавления в область условий дополнительных условий. Например, можно найти все записи о поставщиках молочных продуктов из Норвегии или Италии. Для выбора этих записей введите два набора условий в области условий. Сначала выберите значение Страна из списка Условие и введите Норвегия ИЛИ Италия в поле Значение. Затем выберите значение Категория в следующем поле Условие и введите =Молочные продукты в соответствующем поле Значение.
  • Если используемое в качестве условия значение уже содержится в таблице результатов, его можно скопировать в область условий. Выберите нужное значение из таблицы результатов, выберите команду Копировать в меню Правка, щелкните ячейку, в которую нужно вставить значение, в строке Значение, а затем выберите команду Вставить в меню Правка.
  • Чтобы избежать длительной задержки при передаче данных из каждого поля, можно отложить извлечение данных до завершения добавления всех полей в таблицу результатов. Чтобы отложить передачу данных, убедитесь, что кнопка Автоматический режим Значок кнопки не нажата. Для выполнения запроса нажмите кнопку Выполнить запрос Значок кнопки.
  • Для отмены запроса, занимающего слишком много времени, нажмите клавишу ESC.


Выбор записей, соответствующих определенному значению

  1. Убедитесь, что кнопка Автоматический режим Значок кнопки нажата.
  2. Добавьте в область данных поле, для которого задаются условия.

    Инструкции

    Например, для выбора записей, значением поля "Страна" которых является "Франция", добавьте поле "Страна" в область данных.

  3. Выберите ячейку, содержащую сравниваемое с условием значение, в таблице результатов.
  4. Нажмите кнопку Условие по выделенному Значок кнопки.


Восстановление полной таблицы результатов путем удаления условий

Если запрос содержит много записей, то можно сэкономить время, отложив обновление таблицы результатов до полного удаления всех условий. Чтобы отложить обновление таблицы результатов, убедитесь, что кнопка Автоматический режим Значок кнопки не нажата.

  1. Щелкните заголовок столбца условий, которые требуется удалить, в области условий.
  2. Нажмите клавишу DEL.

    Повторите пункты 1 и 2 для каждого набора условий, который нужно удалить.

    Чтобы удалить все условия, выберите команду Удалить все условия в меню Условия.

Примечание. Если кнопка Автоматический режим не нажата, нажмите кнопку Выполнить запрос Значок кнопки,чтобы восстановить полную таблицу результатов.


О выражениях

Выражением называется конструкция, в которой используются операторы, функции, имена полей и константы.

Выражение может быть задано в качестве условия выбора записей. Для использования выражения в области условий выберите поля, содержащие значения, которые будут указаны в условиях, из списка Условие и введите нужные оператор и значение в поле Значение. При выборе поля в качестве условия убедитесь, что задано поле из нужной таблицы.

Выражения, использующие арифметические операторы. Для извлечения записей, основанных на результате вычислений, создайте выражение, использующие арифметические операторы для сложения, вычитания, умножения или деления. Примеры выражений, использующих арифметические операторы.

Выражения, использующие операторы сравнения. Операторы сравнения сравнивают одно значение с другим. Например, для того чтобы найти все заказы, где число проданных единиц больше 1000, введите >1000 как условие в поле «Количество». Примеры выражений, использующих операторы сравнения.

Выражения, использующие логические операторы. Логические операторы сравнения похожи на операторы сравнения. Например, для выбора всех записей о продавцах, живущих не во Франции, используется фраза НЕ Франция как условие для поля «Страна». Примеры выражений, использующих логические операторы.

Выражения, использующие прочие типы операторов. Для поиска значений, равных любому из нескольких значений, для определения содержания значения в определенном поле записи или для поиска записей с использованием подстановочного знака используются дополнительные операторы. Примеры выражений, использующих прочие типы операторов.


Примеры выражений

Выражением называется вычисление, в котором используются сочетания операторов, функций, имен полей и констант. Для выбора записей выражение используется в качестве условия. Для использования выражения в области условия выберите поле в списке Условие, содержащем значения для оценки, а затем введите оператор и значение в поле Значение.

Выберите пример

Выражения, использующие арифметические операторы

Выражения, использующие операторы сравнения

Выражения, использующие логические операторы

Выражения, использующие прочие типы операторов

Не можете сделать выбор?


Примеры выражений, использующих арифметические операторы

Арифметические операторы выполняют основные математические действия, например сложение, вычитание, умножение и деление и возвращают числовой результат. Арифметические операторы могут использоваться в выражениях в области условий или в вычисляемых полях.

Арифметический оператор | Значение | Пример | Синтаксис
+ (знак плюс) | Сложение | Общая задолженность заказчика | Стоимость_заказа+Фрахт
– (знак минус) | Вычитание | Полная стоимость заказа с учетом всех скидок | Стоимость_заказа-Скидка
* (звездочка) | Умножение | Стоимость заказа на отдельное изделие | Цена_изделия* Количество
/ (косая черта) | Деление | Цена единицы товара | Стоимость_заказа/ Количество


Примеры выражений, использующих операторы сравнения

Операторысравнения включаются в выражения, которые используются в качестве условий выбора записей для ограничения таблицы результатов.

Оператор сравнения | Значение | Пример | Выберите из списка условия | Введите в поле значения
= (знак равенства) | Равно | Поиск записей о покупателях из Германии | Страна | =Германия
<> (знак не равно) | Не равно | Поиск записей о поставщиках, живущих не в России | Страна | <>Россия
> (знак больше) | Больше | Поиск записей о заказах, размещенных после указанной даты | Дата_заказа | >6/30/2000
< (знак меньше) | Меньше | Поиск записей о заказах, размещенных до указанной даты | Дата_заказа | <6/30/2000
>= (знак больше или равно) | Больше или равно | Поиск записей о заказах, размещенных не раньше указанной даты | Дата_заказа | >=6/30/2000
<= (знак меньше или равно) | Меньше или равно | Поиск записей о заказах, размещенных не позже указанной даты | Дата_заказа | <=6/30/2000


Примеры выражений, использующих логические операторы

Логические операторы сравнения.

Логический оператор | Значение | Пример | Выберите в поле условия | Введите в поле значения
И | Оба значения в одном поле должны быть истинными в таблице результатов. | Поиск записей о заказах, размещенных в определенный промежуток времени | Дата_заказа | >05.06.2000 И <23.06.2000
ИЛИ | Оба условия должны быть истинными для записей в таблице результатов. | Поиск записей о поставщиках, живущих в одном из двух мест. | Страна | Россия ИЛИ Бразилия
НЕ | Это условие не должно быть истинным в таблице результатов. | Поиск записей о поставщиках, не живущих в указанной стране | Страна | НЕ Канада


Примеры выражений, использующих прочие типы операторов

В приведенной ниже таблице перечислены операторы, которые можно использовать для выбора диапазона значений, поиска значений, равных одному или нескольким из заданного набора, определения наличия некоторого значения в поле или для поиска записей с использованием подстановочных знаков.

Оператор | Значение | Пример | Выберите в поле условия | Введите в поле значения
"между" | Вывод значений, лежащих в заданном диапазоне | Поиск записей, в которых сумма заказа лежит в промежутке от 1000 до 3000 рублей. | Сумма_заказа | между 1000 и 3000
"содержится в" | Определяет, равно ли значение одному из значений из списка | Поиск записей о заказчиках из Пскова, Курска и Орла | Город | содержится в ('Псков', 'Курск', 'Орел')
Null | Проверяет отсутствие значения в указанном поле записи | Поиск записей сотрудников, не содержащих сведений об инспекторе | Руководитель | Null
не Null | Проверяет наличие значения в указанном поле записи | Поиск записей сотрудников, содержащих сведения об инспекторе | Руководитель | не Null
Похоже на | Сравнение значений при помощи оператора Похоже на и подстановочного знака "%" | Поиск записей сотрудников, фамилии которых начинаются на "См", например "Смехов" или "Смирнов" | Фамилии | содержит 'См%'


Создание вычисляемого поля

В специальном поле, которое называется вычисляемым полем, можно просматривать результаты заданных вычислений. При создании вычисляемого поля можно ввести выражение, состоящее из операторов, функций, имен полей и констант. Итоги могут быть рассчитаны с помощью встроенной функции.

Предполагаемое действие:

Создание вычисляемого поля с использованием выражения

Создание вычисляемого поля с использованием встроенных функций


Создание вычисляемого поля с использованием выражения

  1. Щелкните пустой заголовок столбца в области данных.
  2. Введите выражение для вычисления и нажмите клавишу ENTER. Выражение не должно начинаться со знака равенства (=).

    Например, если служащие получают комиссионные, равные 15-ти процентам от общего объема продаж, то можно подсчитать комиссионные, полученные каждым служащим, путем суммирования всех продаж, сделанных этим служащим, и умножения суммы на 0,15.

    Для просмотра примеров выражений, использующих арифметические операторы, нажмите кнопку Значок кнопки .


Создание вычисляемого поля с использованием функции

  1. Добавьте поле с суммируемыми значениями.

    Инструкции

  2. Щелкните суммируемое поле и нажмите кнопку Выбор групповой операции Значок кнопки.
  3. Нажимайте кнопку Выбор групповой операции до тех пор, пока Microsoft Query не выведет нужный тип суммы.

    При каждом нажатии кнопки Выбор групповой операции в Microsoft Query вычисляется и выводится сумма нового типа (используемая при этом функция отображается в заголовке столбца.) Для просмотра описаний функций, которые могут использоваться при создании сумм в вычисляемых полях, нажмите кнопку Значок кнопки .

  4. После выбора функции, создающей нужный тип суммы, нажмите кнопку Выполнить запрос Значок кнопки для вывода результатов в вычисляемом поле.

Примечания

  • Для удаления вычисления из поля нажимайте кнопку Выбор групповой операции до тех пор, пока в заголовке столбца не будет выведено исходное имя поля.
  • Если запрос содержит много записей, то можно сэкономить время путем задержки вывода результатов в вычисляемом поле до выбора нужной функции. Убедитесь, что кнопка Автоматический режим Значок кнопки не нажата.


Функции, которые можно использовать в вычисляемых полях

Функция возвращает значение, полученное в результате вычисления или другой операции. Например, функция СУММ возвращает сумму двух или более значений. Функции, поддерживаемые в Microsoft Query перечислены ниже. Доступные для источника данных функции зависят от драйвера ODBC. Для просмотра доступных для источника данных функций щелкните числовое поле и нажмите кнопку Выбор групповой операции Значок кнопки.

Для возврата этого значения | Использование
Среднее арифметическое набора значений полей | СРЗНАЧ
Общее число записей | СЧЁТ
Максимальное значение из набора | МАКС
Минимальное значение из набора | МИН
Сумма набора значений полей | СУММ


Изменение таблицы результатов

После вставки полей или изменения порядка их расположения, эти изменения сохраняются при работе в Microsoft Query и передаче таблицы результатов в Microsoft Excel.

Предполагаемое действие:

Изменение порядка расположения полей в таблице результатов

Вставка поля в таблицу результатов


Форматирование данных в Microsoft Query

Некоторые сведения в этом разделе могут быть неприменимы к отдельным языкам.

При сохранении запроса внесенные изменения сохраняются в Microsoft Query. Изменение форматирования в Microsoft Query не отражается на таблице результатов в Microsoft Excel. Однако изменения порядка полей запроса или таблицы результатов будут сохранены.

Предполагаемое действие:

Изменение заголовка столбца

Изменение ширины столбца или высоты строк

Изменение шрифта, стиля или размера текста в таблице результатов

Скрытие или отображение поля в таблице результатов

Изменение таблицы результатов


Переход к указанной записи таблицы результатов

  1. Выберите команду Перейти в меню Записи.
  2. Введите номер записи, к которой требуется перейти.


Сортировка записей в запросе

  1. Убедитесь, что кнопка Автоматический режим Значок кнопки нажата.
  2. В таблице результатов выберите поле для сортировки.
  3. Чтобы расположить записи в возрастающем порядке, выберите вариант Сортировка по возрастанию Значок кнопки.

    Чтобы расположить записи в убывающем порядке выберите вариант Сортировка по убыванию Значок кнопки.

Примечания

  • Чтобы выполнить сортировку нескольких столбцов одновременно, расположите их слева направо в области данных в том порядке, в котором они должны быть отсортированы. Нажав клавишу SHIFT, щелкните заголовки столбцов, которые требуется отсортировать, а затем выберите вариант Сортировка по возрастанию или Сортировка по убыванию.
  • Для возврата исходного порядка записей в меню Записи выберите команду Сортировка. Выберите из списка Сортировка в запросе поле, для которого требуется отменить сортировку, а затем нажмите кнопку Удалить.
  • Если расположение столбцов в таблице результатов после сортировки записей будет изменено, порядок сортировки не изменяется.


Просмотр разных полей в запросе

  1. Выберите команду Показать столбцы в меню Формат.
  2. Чтобы временно запретить отображение столбца в области данных, выберите соответствующий столбец и нажмите кнопку Скрыть.

    Чтобы вывести столбец, щелкните название столбца и нажмите кнопку Показать.

Примечание. При передаче таблицы результатов в Microsoft Excel передаются все поля, включая скрытые. Чтобы запретить передачу скрытых полей в Microsoft Excel, удалите эти поля из области данных перед возвратом таблицы результатов в Microsoft Excel.


Об изменении данных в базе данных, используемой для запроса

Изменение базы данных, из которой загружаются данные. В некоторых случаях можно использовать Microsoft Query для изменения или для удаления данных во внешней базе данных. При изменении результатов запроса Microsoft Query также изменяет данные в базовой таблице, которая используется для запроса.

Условия, при которых нельзя изменять базу данных. Нельзя изменять данные в базе данных, используемой для запроса, в следующих ситуациях:

  • Источник данных защищен от изменений или не допускает изменений.
  • Запрос содержит несколько таблиц.
  • Запрос содержит итоги или пользовательские выражения.
  • Изменяемое поле заблокировано, недоступно или находится в заблокированной записи.
  • Тип вводимых данных является запрещенным для базы данных. Значения, которые можно вводить в поле, зависят от того, в какую базу данных вносятся изменения.
  • Администратор базы данных запретил изменение содержимого базы данных.


Внесение изменений в содержимое базы данных, участвующей в запросе

Предполагаемое действие:

См. сведения о внесении изменений в содержимое базы данных, участвующей в запросе

Изменение содержимого базы данных, участвующей в запросе

Удаление содержимого базы данных, участвующей в запросе

Отмена изменений базы данных, участвующей в запросе


Использование динамического обмена данными (DDE) с Microsoft Query

Некоторые сведения в этом разделе могут быть неприменимы к отдельным языкам.

Microsoft Query поддерживает динамический обмен данными (DDE) между программами. DDE может использоваться в Visual Basic для приложений для связи и передачи данных между Microsoft Query и другой программой, например Microsoft Excel.

Инструкции по использованию DDE

Открытие канала DDE

Выполнение команд DDE

Команды DDE

Запрос состояния и других сведений

Доступ к данным

Выход из Microsoft Query с использованием DDE

Закрытие канала DDE

Использование Microsoft Query совместно с другими приложениями


Команды DDE

Для отображения справочных сведений выберите команду или запрос.

Activate

AddParameters

AllowEdit

BuildODBC

BuildSQL

Close

Command

EnableParameters

EnableTensor

Exit

Fetch and Fetch.Advise

Fetch.Unadvise

Logoff

Logon

LogonNow

ODBCLogon

Open

ParameterNames2

QueryNow

QueryType

SaveAs

SetParameterName

SetQueryName

SetQueryType

SetWindowState

UserControl

UserControl2

ViewPane


Разрешение вопросов при работе с Microsoft Query

Некоторые сведения в этом разделе могут быть неприменимы к отдельным языкам.

Создание и использование источников данных

Не удается создать новый источник данных.

Не удается найти или удалить источник данных.

Почему рядом с именем источника данных отображается звездочка ?

Используемый ранее драйвер ODBC не работает.

Создание запросов

Не удается найти нужную таблицу

Не удается создать требуемый тип объединения.

При объединении не возвращаются ожидаемые записи.

Не удается изменить типы параметров процедуры SQL в Microsoft Query.

Не удается изменить запрос.

Извлечение данных

Сообщение о неверном пути к базе данных.

Попытки подключения к базе данных часто оказываются безуспешными.

Невозможен доступ в Microsoft Query к данным списка Microsoft Excel.

Microsoft Query продолжает использовать ресурсы связи после завершения работы с базой данных.

Microsoft Query не возвращает все доступные записи.

Работа в Microsoft Query

Не удается продолжить работу с Microsoft Query

Изменения запроса не отображаются при его следующем выполнении.

Не удается вывести на печать таблицу результатов в Microsoft Query.

Не удается создать почтовые наклейки в Microsoft Query.

Не удается сохранить таблицу результатов в качестве таблицы базы данных.

Не удается добавить, скопировать или переместить запись в базе данных.


Разрешение вопросов с запросами и кубами OLAP

Итоговая функция, необходимая для данных куба, недоступна.

Поля со значениями даты или времени восстанавливаются некорректно.

При попытке сохранить файл автономного куба не хватает свободного места на диске.

Не удается добавить поля в куб OLAP.

Не удается изменить куб OLAP

Сообщение о потере данных во время изменения куба OLAP

Сообщение о невозможности открытия OQY-файла мастером создания куба OLAP.


Обработка дат 2000 года в Microsoft Query

Использование четырех цифр для записи года. Для обеспечения правильной выборки и интерпретации значений года убедитесь в том, что внешние базы данных, там где это возможно, хранят значение года в четырехзначном формате (2001 вместо 01).

Microsoft Query и Microsoft Excel интерпретируют двузначные года одинаково. И Microsoft Query, и Microsoft Excel интерпретируют год, состоящий из двух цифр, одинаково. Данные, которые содержат значения года в виде двух цифр, при просмотре в Microsoft Query и после их передачи в Microsoft Excel, значения будут одинаковыми в обеих программах.

Интерпретация двузначных значений года в Microsoft Query. Двузначные значения года, полученные Microsoft Query из внешних баз данных, интерпретируются следующим образом:

  • Значение года от 00 до 29. Двузначные значения года от 00 до 29 интерпретируются как годы с 2000 по 2029. Например, полученная из внешней базы данных дата 28/5/19 интерпретируется Microsoft Query как 28 мая 2019.
  • Значение года от 30 до 99. Двузначные значения года от 30 до 99 интерпретируются как годы с 1930 по 1999. Например, полученная из внешней базы данных дата 28/5/98 интерпретируется Microsoft Query как 28 мая 1998.

Возможность выбора способа интерпретации даты администратором. Правила интерпретации дат в Microsoft Office могут быть настроены системным администратором. Например, если в качестве наименьшего значения года, до которого даты рассматриваются как будущие, по умолчанию используется 29, администратор может выбрать другое число (оно должно состоять из двух цифр). Для того чтобы узнать, как настроена интерпретация, свяжитесь с системным администратором.


Невозможно выполнить запрос. Показать инструкцию SQL?

Microsoft Query не может выполнить инструкцию SQL, так как инструкция SQL ссылается на недоступный в настоящее время объект. Например, она может ссылаться на несуществующую таблицу. Для просмотра инструкции SQL и внесения необходимых изменений нажмите кнопку OK.


Таблица <имя> уже в запросе; добавить еще раз?

Попытка добавить в область таблиц уже присутствующую в ней таблицу.

  • Чтобы добавить таблицу для создания внутреннего объединения, нажмите кнопку OK.
  • Чтобы отменить добавление таблицы, нажмите кнопку Отмена.


Ошибка в формате данных; вставка невозможна

Microsoft Query не может вставить данные из буфера обмена из-за недостатка свободной памяти.

Попытайтесь закрыть другие приложения или другие окна в Microsoft Query. Если ошибка повторяется, перезапустите Microsoft Windows и повторите копирование и вставку.


Невозможно сохранить в файл, который уже открыт.

Файл, в который производится сохранение, открыт. Перед сохранением в файл закройте его.


Другое приложение занято.

Другая программа — участник сеанса динамического обмена данными (DDE) — занята и не может выполнить запрашиваемую операцию DDE. Подождите, пока программа не освободится.


Требуется BY после GROUP.

Инструкция SQL содержит выражение «GROUP» вместо «GROUP BY». Окончание «BY» неправильно введено или отсутствует.


Требуется BY после ORDER.

Инструкция SQL содержит выражение «ORDER» вместо «ORDER BY». Окончание «BY» неправильно введено или отсутствует.


Невозможно открытие буфера обмена

Буфер обмена не отвечает, так как он, возможно, используется другим приложением. Закройте это приложение и повторите операцию.


Невозможно открыть файл <имя>

Microsoft Query не может открыть или прочитать указанный файл, или файл не был сохранен. Возможно, произошел сбой диска или файл поврежден.


Невозможен запуск Microsoft Query. Повторите попытку

Произошла системная ошибка или недостаточно памяти для запуска Microsoft Query.

Повторно запустите Microsoft Query или закройте другие приложения. Если ошибка повторяется, перезапустите Microsoft Windows и повторите операцию.


Столбец <имя> не может использоваться с оператором <оператор>.

Источник данных не разрешает использование поля данного типа вместе с указанным оператором. Чтобы определить, какие операторы могут использоваться с полями этого типа данных, обратитесь к документации на источник данных.


Столбец <имя> не может быть использован в условии.

Для столбца (поля) этого типа данных не могут быть заданы условия.


Невозможен вывод справки из-за нехватки памяти, неправильной установки Microsoft Windows или Microsoft Query.

Чтобы освободить память, закройте окна или приложения. При необходимости выполните повторную установку Microsoft Windows или Microsoft Query.


Вставка невозможна

Буфер обмена не отвечает. Он может использоваться другой программой, данные из него могут иметь формат, несовместимый с Microsoft Query, или недостаточно памяти для вставки данных.

Попытайтесь закрыть другие приложения или другие окна в Microsoft Query. Если ошибка повторяется, перезапустите Microsoft Windows и повторите копирование и вставку.


Невозможно завершить работу Microsoft Query

Microsoft Query осуществляет динамический обмен данными (DDE) с другим приложением. Дождитесь завершения операции DDE, а затем завершите работу с Microsoft Query.


Невозможно показать условие.

Неправильно задано условие.


Невозможно добавить выражение <имя> в список сортировки.

Используемый источник данных не разрешает сортировку полей, содержащих результаты выражения.


Невозможно применение статистических функций к таблицам.

Вместо указания конкретного поля, для которого нужно выполнить групповые операции, в качестве параметра в поле Поле введена звездочка (*). Удалите знак (*) и введите имя поля.


Невозможно задать * в качестве поля. Для добавления всех полей перетащите * в бланк запроса.

В ячейке Поле области условий введена звездочка (*). Вместо этого при задании условий для всех полей запроса используйте один из следующих способов:

  • Перетащите знак (*) из таблицы в область условий.
  • Дважды щелкните звездочку в таблице.
  • Вручную добавьте каждое поле.


Функция <имя> не может использоваться в <имя столбца>.

Выбрана функция, которая не может быть использована для вычислений с полем этого типа данных. Например, невозможно вычислить среднее значение поля «Страна назначения», если оно содержит текст.


Формат буфера обмена не поддерживается

Формат данных из буфера обмена несовместим с Microsoft Query.


Некоторые запросы используют <имя соединения>, закрыть?

Удаляемый источник данных используется другими запросами.

  • Чтобы удалить источник данных и закрыть запросы, нажмите кнопку OK.
  • Чтобы оставить источник данных в списке, а запросы открытыми, нажмите кнопку Отмена.


Удалить следующее число записей: <число>?

Запрошено удаление указанного числа записей.

Примечание. Если число записей больше заданного, в Microsoft Query были найдены одинаковые по полям в области данных записи. Чтобы избежать повторения записей, перед удалением добавьте все поля в область данных.

  • Чтобы удалить записи, нажмите кнопку OK.
  • Для отмены удаления нажмите кнопку Отмена.


Найдено следующее число подходящих записей: <число>. Удалить?

Так как область данных не содержит поле, однозначно описывающее каждую запись, например «Номер заказчика» или «Номер заказа», в таблице результатов есть другие записи, совпадающие с той, которую нужно удалить. При удалении выбранной записи все совпадающие с ней записи будут удалены автоматически.

Чтобы различать записи перед изменением данных, убедитесь, что выбраны все поля таблицы или для нее создан уникальный индекс.


Будет обновлено записей: <число>

В области данных содержатся другие записи, совпадающие с измененной. Автоматически те же изменения будут внесены в совпадающие записи.

  • Чтобы избежать повторения записей в области данных, перед изменением данных добавьте в нее все поля.
  • Чтобы обновить записи, нажмите кнопку OK.
  • Для отмены обновления нажмите кнопку Отмена.


Невозможно создать файл.

Создание указанного файла запроса в Microsoft Query невозможно. Вероятно, произошел сбой диска или файл поврежден.


Таблица <имя> создана.

В Microsoft Query была создана таблица, указанная в описании источника данных.


Невозможно создать уникальный индекс. Создать индекс вручную?

Microsoft Query не может создать уникальный индекс для этой таблицы, несмотря на то, что таблица результатов, которую нужно сохранить как новую таблицу, получена из имеющей уникальный индекс таблицы.

  • Чтобы вывести диалоговое окно Создание индекса для создания уникального индекса таблицы, нажмите кнопку Да.
  • Чтобы отменить создание уникального индекса, нажмите кнопку Нет.


Указанная длина должна быть больше нуля.

Длина, заданная в поле Длина диалогового окна Просмотр определения таблицы, должна быть больше 0 (нуля).


Команда Activate (DDE)

Активизация указанного окна запроса. Эта команда используется для смены активного окна, когда открыто несколько окон. Она доступна только в системном канале.

Синтаксис

Activate(имя запроса )

имя запроса Имя активизируемого окна запроса.

Пример

В этом примере выполняется два запроса, которые создают два окна запроса. После выполнения второго запроса делается активным окно, созданное первым запросом.

DDEExecute chan, "[BuildSQL('Select * From Customers')]"
DDEExecute chan, "[QueryNow()]"
stQueryname1 = DDERequest(chan, "Query")
DDEExecute chan, "[BuildSQL('Select * From ORDERS')]"
DDEExecute chan, "[QueryNow()]"
stQueryName2 = DDERequest(chan, "Query")
DDEExecute chan, "[Activate('" & stQueryname1(1) & "')]"


Команда AddParameters (DDE)

Добавление параметров в активный запрос для использования в отчетах сводных таблиц.

Синтаксис

AddParameters(поле1, поле2, …)

поле1, поле2, … Имена столбцов таблицы, которые должны быть добавлены в качестве параметров к условиям. Имена новых параметров становятся именами полей. Если задаваемое имя не может быть использовано в активном запросе, возникает ошибка.

Заметки

AddParameters может использоваться даже в том случае, когда ввод параметров в Microsoft Query запрещен.

Измененная строка SQL может быть получена при запросе элемента ODBCSQLStatement.

Для восстановления параметров необходимо восстановление всей строки SQL.


Команда AllowEdit (DDE)

Определение возможности внесения изменений в окне запроса. Команда доступна как в системном канале, так и в канале запроса. Эквивалентна команде Разрешить изменение в меню Записи.

Синтаксис 1

AllowEdit(разрешитьправку, отменитьправку)

Синтаксис 2

Allow.Edit(разрешитьправку, отменитьправку)

Обе формы синтаксиса равноправны.

разрешитьправку Определение возможности внесения изменений в окне запроса. Аргумент может принимать значения True или False.

запретитьправку Отключение команды Разрешить изменение в меню Записи во время действия команды UserControl. Аргумент может принимать значения True или False.

Пример

В примере выполняется предварительно созданная инструкция SQL, после чего в Microsoft Query посылаются команды AllowEdit и UserControl. В результате этого пользователь имеет возможность просматривать, но не изменять данные в источнике данных (команда меню Разрешить изменение становится неактивной после выполнения команды UserControl).

DDEExecute chan,"[BuildSQL(""" & sql & """)]")
DDEExecute chan,"[QueryNow()]")
DDEExecute chan,"[AllowEdit(False, True)]")
DDEExecute chan,"[UserControl(""&Return Data"", 3, False)]")


Команда BuildODBC (DDE)

Пошаговое построение строки соединения произвольной длины.

Синтаксис

BuildODBC([стрсоедин])

стрсоедин Сегмент допустимой строки соединения. Если стрсоедин равен 0 (нулю) или опущен, строка соединения очищается.


Команда BuildSQL (DDE)

Пошаговое построение инструкции SQL для создания запроса в канале DDE. Команда доступна только в системном канале.

Синтаксис

BuildSQL[(SqlText)]

SqlText Допустимая инструкция SQL. Если аргумент SqlText не задан или равен нулю, инструкция SQL очищается.

Заметки

Команда BuildSQL удобна при создании длинных инструкций SQL. Например, если инструкция SQL настолько длинная, что не может быть отправлена в виде отдельного оператора, она может быть отправлена по частям.

После построения инструкция SQL может быть выполнена при помощи команды QueryNow.

Пример

В данном примере показывается использование элемента QueryDefinition, чтобы получить инструкцию SQL для запроса.

sql = DDERequest(chan,"QueryDefinition")

В этом примере команда BuildSQL используется для повторной отправки полученной строки SQL с дополнительным оператором WHERE.

DDEExecute chan, "[BuildSQL(""" & sql & """)]"
DDEExecute chan, "[BuildSQL("WHERE Freight > 10")]"
DDEExecute chan, "[QueryNow()]


Команда Close (DDE)

Закрытие текущего запроса. Команда доступна как в системном канале, так и в канале запроса.

Синтаксис

Close( )


Закрытие канала DDE

Для закрытия канала DDE используется метод DDETerminate. Этот метод принимает только один аргумент — номер закрываемого канала DDE. Все запросы, открытые на данном канале, при использовании DDETerminate автоматически закрываются и происходит отсоединение от всех источников данных.

При использовании неверного номера канала возвращается ошибка.


Команда Command (DDE)

Передача команды Open в Microsoft Query. Эта команда предназначена для использования в программах, для которых установлено ограничение длины строк, используемых с DDEExecute.

Данная команда доступна только в системном канале.

Синтаксис

Command(режим, выпстрока )

режим Определение способа получения команд Microsoft Query. Аргумент может принимать следующие значения.

Значение | Описание
1 | Инициализация буфера в Microsoft Query строкой выпстрока (с очисткой существующего буфера). Запрос при этом не выполняется.
2 | Добавление выпстрока в конец буфера.
3 | Добавление выпстрока в конец буфера и выполнение команд буфера. Поскольку после выполнения буфер команд очищается, повторное выполнение выпстрока невозможно.

выпстрока Фрагменты команды Open. Вся строка должна быть заключена в одинарные или двойные кавычки.

С использованием команды Command в Microsoft Query может быть отправлена только команда Open.

Заметки

Эта команда предусмотрена только для совместимости с Q+E. Для посылки длинных инструкций SQL рекомендуется по возможности использовать команду BuildSQL.


Команда EnableParameters (DDE)

Определение возможности задания пользователем параметров в области условий и окна SQL. По умолчанию параметры задаваться не могут. Задание параметров не может быть отменено после того, как оно было выполнено пользователем.

Синтаксис

EnableParameters(флаг)

флаг Определение возможности задания параметров пользователем. Если указано значение 0 (ноль), пользователь не может задавать параметры, а если 1 - может.


Команда EnableTensor (DDE)

Показывает какая из программ, в которую передаются данные, поддерживает источники данных OLAP. Данная команда доступна только в системном канале.

Синтаксис

EnableTensor(флаг)

флаг Если указано значение TRUE, то источник данных OLAP будет возвращен в программу-приемник. Если значение отсутствует или указано FALSE, то в программу-приемник будет возвращен источник данных, отличный от OLAP.


Выполнение команд DDE

При помощи DDEExecute команда может быть передана в Microsoft Query. Команды являются специфичными для Microsoft Query и могут не совпадать с командами меню Microsoft Query. Например, команды Открыть и Сохранить как выполняют те же функции, что и соответствующие команды меню Microsoft Query, но команды ODBCLogon и UserControl нет. Для получения списка доступных команд нажмите кнопку Значок кнопки .

Инструкция DDEExecute принимает два аргумента.

Аргумент | Описание
channel | Значение канала DDE, возвращаемое DDEInitiate.
команда | Команда, посланная Microsoft Query.

Чтобы пользователь мог создавать запросы в Microsoft Query, выполняется команда UserControl. В следующем примере показано присвоение команде My Exit Command функций команды Выход меню Файл Microsoft Windows.

DDEExecute Chan,"[UserControl('&My Exit Command',3,True)]"

Значение канала DDE ранее было присвоено переменной Chan, а командой, посылаемой Microsoft Query, является UserControl. Обратите внимание на то, что команда UserControl и ее аргументы заключены в двойные кавычки ( " " ) и квадратные скобки ( [ ] ).


Команда Exit (DDE)

Завершение Microsoft Query. Команда доступна только в системном канале.

Синтаксис

Exit(завершить)

завершить Завершение Microsoft Query при наличии открытых запросов на каналах, кроме канала, выполняющего команду Exit. Аргумент может принимать значения True или False.

Значение True используется для завершения Microsoft Query независимо от наличия открытых запросов. При пользовательском управлении Microsoft Query с использованием другого канала (в результате выполнения команды UserControl), данное значение параметра приводит к закрытию канала и передаче управления приложению, запустившему Microsoft Query под управлением пользователя.

Значение False используется для завершения Microsoft Query только при условии, что все открытые запросы были открыты на канале, выполняющем команду Exit.

Заметки

Эта команда DDE используется также для завершения Microsoft Query на Macintosh.


Выход из Microsoft Query с использованием DDE

Некоторые сведения в этом разделе могут быть неприменимы к отдельным языкам.

Для выхода из Microsoft Query приложение может использовать команду Exit вместо выполнения пользователем команды Выход в меню Файл.

Команда | Описание
Exit (Ложь) | Выход из Microsoft Query только при условии отсутствия открытых запросов на других каналах
Exit (Истина) | Выход из Microsoft Query независимо от наличия других открытых запросов


Команды Fetch и Fetch.Advise (DDE)

Команда Fetch извлекает данные из Microsoft Query и передает их непосредственно в приложение.

Команда Fetch.Advise выполняет автоматическое обновление в приложении при изменении значений в Microsoft Query, а не в момент отправки команды Fetch.Advise.

Команды доступны как в системном канале, так и в канале запроса.

Синтаксис 1

Fetch.Advise(имяприл, раздел, область, значения)

Синтаксис 2

Fetch(имяприл, раздел, область, значения)

имяприл Имя программы, в которую передаются данные. Для приложений Office аргументы имяприл могут принимать следующие значения:

Программа | Значение
Microsoft Access | MSAccess
Microsoft Excel | Excel
Microsoft Word | WinWord

раздел Имя таблицы, документа или элемента управления, которым передаются данные.

область Область в таблице, документе, элементе управления, которым передаются данные.

значения Значения, получаемые из Microsoft Query. (Допустимые значения для этого аргумента перечислены в приведенной ниже таблице.)

Примечание. Команда Fetch.Advise выполняет автоматическое обновление только данных запроса, а не элементы или ссылки стр#кол#.

Может принимать значения:

Значение | Описание
Request_item | Тип возвращаемых данных; например, QueryDefinition.
стр#кол# | Ссылка для нахождения указанных строк и столбцов, например, R3C5 в Microsoft Excel.
/Headers | Загрузка имен столбцов.
/Rownum | Номера строк.
Все | Загрузка всех записей.

Заметки

При использовании команды Fetch.Advise канал, созданный для возврата данных в приложение, не закрывается, пока не будет послана команда Fetch.Unadvise или Close.

Пример

В данном примере показано использование требуемых элементов NumRows и NumCols для получения количества строк и столбцов в запросе и передачи этих значений с заголовками столбцов в таблицу Microsoft Excel "Лист1."

rows=REQUEST(Chan,"NumRows")
cols=REQUEST(Chan,"NumCols")
DDEExecute chan, "[Fetch(""Excel"", ""Data.xls!Sheet1"", _
    ""R1C1:R"&rows&"C"&cols&""", ""All/Headers"")]"


Доступ к данным

В то время как DDERequest возвращает данные в программу, команды Fetch и Fetch.Advise заслуживают специального упоминания, так как они получают данные из Microsoft Query и передают их непосредственно в лист книги или документ. Fetch и Fetch.Advise используются в качестве аргументов DDEExecute.

Команда Fetch.Advise аналогична Fetch с тем исключением, что канал, созданный при первой передаче данных, не закрывается сразу. Microsoft Query продолжает пересылать любые изменения данных до тех пор, пока не закроется исходный канал DDE или Microsoft Query не получит команду Fetch.Unadvise.


Команда Fetch.Unadvise (DDE)

Отмена автоматического обновления, установленного командой Fetch.Advise и закрытие канала, открытого Microsoft Query для передачи данных приложению. Команда доступна как в системном канале, так и в канале запроса.

Примечание. Аргументы команды Fetch.Unadvise должны совпадать с аргументами, которые перед этим использовались командой Fetch.Advise.

Синтаксис

Fetch.Unadvise(имяприл, раздел, область, значения)

имяприл Имя программы, которой передаются данные. (См. команду Fetch.Advise).

раздел Имя таблицы, документа или элемента управления, которым передаются данные.

область Область в таблице, документе, элементе управления, которым передаются данные.

значения Значения, получаемые из Microsoft Query. (Таблица допустимых значений аргумента приводится в описании команды Fetch.Advise).


Несовместимая версия <имя файла>. Запуск Microsoft Query невозможен

Используется устаревшая версия файла «Ddeml.dll» или файл отсутствует. Попытайтесь переустановить Microsoft Query или Microsoft Windows.


Команда Logoff (DDE)

Отсоединение указанного источника данных. Команда доступна только в системном канале.

Синтаксис

Logoff(источник)

источник Имя источника данных, от которого требуется отсоединиться.


Команда Logon (DDE)

Отображение диалогового окна, позволяющего подсоединиться к источнику данных. Команда доступна только в системном канале.

Синтаксис

Logon(источник)

источник Имя источника данных, к которому необходимо подсоединиться.


Команда LogonNow (DDE)

Если для построения строки соединения использовалась команда BuildODBC, данная команда выполняет подсоединения, используя строку соединения из буфера. Если буфер не содержит строки соединения, возникает ошибка.

Синтаксис

LogonNow([диалог])

диалог Отображение диалогового окна при подсоединении. Аргумент может принимать следующие значения.

Значение | Описание
0 (ноль) | Окна диалога не отображаются. Если аргумент опущен, используется значение по умолчанию 0 (ноль).
1 | Отображаются диалоговые окна для получения от пользователя дополнительных сведений, не предусмотренных строкой соединения.
2 | Отображаются диалоговые окна со значениями из строки соединения, введенные, как значения по умолчанию.
3 | То же, что 1, но сведения, которые не являются обязательными для соединения с источником данных, отображаются затененными.


Команда ODBCLogon (DDE)

Подсоединение приложения к источнику данных. Можно указать, будут ли при подсоединении отображаться диалоговые окна. Команда доступна только в системном канале.

Синтаксис

ODBCLogon(стрсоедин, диалог)

стрсоедин Строка, содержащая данные (например, имя источника данных, идентификатор пользователя и пароль), необходимые драйверу для соединения с источником данных. Этот аргумент должен иметь формат, требуемый используемым драйвером. (Дополнительные сведения о строке соединения приводятся в документации по программе, которая является источником данных).

Примечание. В связи с тем, что в Microsoft Query поддерживаются файловые DSN (имена источников данных), элемент ConnectionString может использоваться для получения строки соединения без DSN для запроса, созданного из файлового DSN. Впоследствии эта строка соединения может быть использована для восстановления соединения с источником данных с любого компьютера.

диалог Отображение диалогового окна при подсоединении. Аргумент может принимать следующие значения.

Значение | Описание
0 (ноль) | Диалоговые окна не отображаются.
1 | Отображаются диалоговые окна для получения от пользователя дополнительных сведений, не предусмотренных строкой соединения.
2 | Отображаются диалоговые окна со значениями из строки соединения, введенные, как значения по умолчанию.
3 | То же, что 1, но сведения, которые не являются обязательными для соединения с источником данных, отображаются затененными.

Пример

В примере показано использование элемента ConnectionString для получения строки, необходимой для соединения с источником данных. Эта строка сохраняется после того, как пользователь подсоединился к источнику данных, после чего используется команда ODBCLogon для соединения с источником данных без ввода данных пользователем.

connstr = DDERequest(chan, "ConnectionString")
' intervening code
DDEExecute chan, "[ODBCLogon (connstr(1), 0)]"


Открытие канала DDE

Для открытия канала DDE используется метод DDEInitiate. Функция DDEInitiate принимает два аргумента: имя программы-источника и раздел сеанса DDE. Именем Microsoft Query является «MSQuery».

Разделы Microsoft Query могут быть следующими.

Раздел | Описание
query_window_name | Имя открытого окна запроса. Имя окна может быть указано только при условии, что загружено приложение Microsoft Query и окно открыто.
System | Общий раздел, позволяющий программе-приемнику установить связь с Microsoft Query, а не с окном запроса, файлом или инструкцией SQL SELECT.

При получении Microsoft Query запроса на открытие сеанса DDE по известному разделу возвращается ответ и открывается канал. Метод DDEInitiate возвращает номер канала DDE, который может быть присвоен переменной и использован для выполнения последующих операций на канале.

Для открытия нескольких окон на одном канале используйте раздел «System». При использовании раздела «System» для открытия канала DDE могут быть развернуты только окна, открытые на этом канале.


Команда Open (DDE)

Открывает и выполняет запрос, отображает данные в области данных. Команда доступна только в системном канале.

Синтаксис

Open(запрос)

запрос Имя файла Microsoft Query (для Microsoft Windows файл имеет расширение DQY) или Q+E (только для Microsoft Windows, файл имеет расширение QEF), который содержит запрос или SQL инструкцию SELECT.

Пример

В примере демонстрируется открытие запроса «Продажи».

DDEExecute chan, "[Open(""c:\msquery\sales.dqy"")]")

Такой же пример, но для Macintosh.

DDEExecute chan, "[Open(""drivename:msquery:sales"")]")

Для выполнения нового запроса это предложение использует инструкцию SQL SELECT

DDEExecute chan, "[Open(""SELECT * FROM pubs.dbo.titles"")]")


Запрос ParameterNames2 (DDE)

Возвращает сведения о параметрах запроса. Данный запрос доступен только в системном канале.

Синтаксис

ParameterNames2( )

Для каждого параметра ParameterNames2 возвращает имя, тип данных и максимально часто используемое значение. ParameterNames2 возвращает массив из трех столбцов по N строк в формате xlTable. Например как:

Столбец 1 | Столбец 2 | Столбец 3
Имя параметра | Тип данных колонки | Если возможно установить, то максимально часто используемое значение параметра, иначе пусто.

О формате xlTable можно узнать из справочной системы Visual Basic для Microsoft Excel.

Запрос к ParameterNames2 может быть произведен в любое время, даже если параметры для данного запроса отключены командой EnableParameters. Если у запроса отсутствуют параметры, то ParameterNames2 возвратит пустой массив.


Команда QueryNow (DDE)

Выполнение активного запроса в открытом канале DDE. При использовании команды BuildSQL для построения запроса эта команда выполняет предложение SQL в буфере и открывает окно запроса. Команда доступна как в системном канале, так и в канале запроса.

Синтаксис

QueryNow( )

Пример

Пример иллюстрирует сохранение инструкции SQL из запроса и отправку этой инструкции для повторного выполнения запроса.

sql = DDERequest(Chan, "QueryDefinition")
DDEExecute chan, "[BuildSQL(""" & sql & """)]"
DDEExecute chan, "[QueryNow()]"


Запрос QueryType (DDE)

Возвращает сведения об источнике данных для запроса. Данный запрос доступен только в системном канале.

Синтаксис

QueryType( )

Запрос QueryType возвращает массив из двух элементов в формате xlTable. Первый элемент содержит в себе тип запроса: ODBC или OLE/DB. Второй — тип команд допустимых источником данных: SQL, Cube или Cancel. Например как:

QueryType | CommandType | Описание
ODBC | SQL | Источник данных — SQL-совместимый ODBC.
OLEDB | Cube | Источник данных — куб OLAP. Имя куба содержится в инструкции SQL.
ODBC | Отмена | Запрос отменен и возвращен в программу-приемник.

О формате xlTable можно узнать из справочной системы Visual Basic для Microsoft Excel.

Используйте запрос QueryType только как первый запрос после завершения выполнения команды UserControl2.

Если QueryType показывает, что источник данных куб OLAP, то возможно использование запросов ODBCSQLStatement и ConnectionString для загрузки информации источника данных. Изучите использование DDE запросов.


Запрос состояния и других сведений

После открытия канала DDE в Microsoft Query можно вернуть таблицу результатов или другие данные при помощи DDERequest.

Метод DDERequest принимает два аргумента.

Аргумент | Описание
channel | Значение канала DDE, возвращаемое DDEInitiate.
request_item | Данные, которые нужно вернуть. Это может быть содержимое поля или группы полей в окне запроса, или другие данные, например число записей в окне запроса.

Запрашивать объекты можно как по каналу запросов, так и по системному каналу. По каналу запросов можно вернуть только сведения о запросе, например число строк (столбцов) или описание запроса. По системному каналу можно передать общие сведения о Microsoft Query, например текущие сеансы связи, имена разделов и состояния программ, а также данные, специфичные для активного запроса.

Запрашиваемые по каналу запросов или по системному каналу для текущего запроса объекты могут быть следующими.

Запрашиваемый объект | Возвращаемые данные
ColumnTitles | Массив заголовков столбцов. Заголовок столбца совпадает с именем поля, если он не был изменен пользователем в Microsoft Query.
ConnectionString | Массив сегментов строк связи (каждая длиной до 255 знаков), из которого получается строка связи с активным окном запроса. Если запрос был создан файловым источником данных (DSN), то возвращается строка связи без имени источника.
ConnectionString/n | Массив сегментов строк связи (каждая длиной до n знаков), из которого получается строка связи с активным окном запроса. Если запрос был создан файловым источником данных (DSN), то возвращается строка связи без имени источника.
DataSourceName | Имя источника данных (DSN), используемое активным запросом.
ErrorText | Текст сообщения об ошибке (если была), возникшей при выполнении последней инструкции SQL. Этот объект может запрашиваться несколько раз для получения сведений обо всех имевших место ошибках. После получения данных обо всех ошибках объект возвращает пустую строку. Если последняя инструкция SQL была выполнена успешно, то возвращается нулевая строка, даже если предыдущие инструкции не были выполнены успешно.
FieldDef | Массив значений, описывающих выражения и типы данных из столбцов (полей) в окне запроса. Каждая строка массива описывает поле в запросе. В массив в виде столбцов возвращаются следующие данные: имя поля, тип данных Q+E поля, ширина поля, точность значения поля и тип данных SQL.
GetUniqueItems | Массив элементов, уникальных для данного столбца результатов. Запрашиваемый объект должен быть порядковым номером столбца (начиная с нулевого), добавленным к строке «GetUniqueItems» (например, уникальные объекты из второго столбца возвращаются при помощи «GetUniqueItems1»). Объекты, не включенные в запрос, не могут быть запрошены. Этот объект возвращает то же значение, что и инструкция SELECT DISTINCT для запрашиваемого столбца при условии действия всех объединений и условий. Любые условия, использующие параметры, не учитываются.
NameSeparator | Одиночный знак, используемый в качестве разделителя имен ODBC.
NumCols | Число столбцов (полей) в запросе.
NumRows | Число строк (записей) в запросе.
ODBCSQLStatement | Массив сегментов SQL (каждый длиной до 255 знаков), из которого получается инструкция ODBC SQL для запроса. При помощи этой строки можно передавать инструкции ODBC SQL непосредственно для обработки ODBC, минуя Microsoft Query.
ODBCSQLStatement/n | Массив сегментов SQL (каждый длиной до n знаков), из которого получается инструкция ODBC SQL для запроса. Этот объект может использоваться для хранения инструкции ODBC SQL в нескольких сегментах меньшей длины.
ParameterNames | Массив параметров запроса. При отсутствии параметров возвращается пустой массив. Этот объект может быть запрошен в любое время, даже если у запроса нет параметров.
Query | Имя запроса.
QueryDefinition | Массив сегментов описаний запросов (каждый длиной до 255 знаков), из которого получается описание запроса (инструкция SQL), заданное Microsoft Query. Этот объект можно сохранить для последующих запросов.
QueryDefinition/n | Массив сегментов описаний запросов (каждый длиной до n знаков), из которого получается описание запроса (инструкция SQL).
Recest | Примерная оценка числа строк, которые можно получить одновременно.
TierType | Единичное число, указывающее тип источника данных: 1 указывает на файл, содержащий только одну таблицу; 2 указывает на файл базы данных, содержащий одну или несколько таблиц; 3 указывает на то, что данные недоступны для просмотра. Этот объект используется программой при открытии окна «Открытие документа» для просмотра содержимого диска.

При использовании перечисленных объектов на системном канале данные возвращаются для окна запроса, который последним использовался при выполнении операций DDE.

Для системного канала дополнительно можно запрашивать следующие объекты.

Запрашиваемый объект | Возвращаемые данные
Sources | Все связи с источниками данных (только DSN).
Logon | Все удаленные базы данных, с которыми можно установить соединение (элементы DSN из реестра).
Logoff | Все удаленные базы данных, с которыми установлена связь (только DSN).
Tables/source/user/database | Все таблицы для указанного соединения с источником, пользователя и базы данных. При этом имя источника должно являться допустимым именем DSN.
Users/source/database | Все пользователи для указанного соединения с источником и базы данных. При этом имя источника должно являться допустимым именем DSN.
Database/source | Все базы данных для указанного соединения с источником. При этом имя источника должно являться допустимым именем DSN.
Username/source/database | Имя пользователя для указанного соединения с источником и базы данных. При этом имя источника должно являться допустимым именем DSN.
Topics | Названия разделов, открытых на системном канале, включая раздел «System».
Status | Состояние программы («Готов» или «Занят»). «Готов» означает, что программа может участвовать в сеансе DDE с Microsoft Query. «Занят» означает, что Microsoft Query не может в данный момент открыть сеанс DDE.

В данном примере значение, возвращаемое объектом NumRows, вставляется в ячейку A10 Microsoft Excel.

ActiveWorksheet.Range("A10").Value = DDERequest(chan, "NumRows")


Команда SaveAs (DDE)

Сохранение конструкции нового или существующего запроса с другим именем. Действие аналогично выполнению команды Сохранить как в меню Файл. Команда доступна как в системном канале, так и в канале запроса.

Синтаксис 1

SaveAs(имязапроса )

Синтаксис 2

Save.As(имязапроса )

Обе формы синтаксиса равноправны.

имязапроса Новое имя запроса.


Команда SetParameterName (DDE)

Задание имени параметра, получаемого через передаваемую в Microsoft Query строку запроса. SetParameterName должна посылаться после команды BuildSQL.

Синтаксис

SetParameterName(индекс, имя)

индекс Индекс параметра.

имя Имя параметра.

Заметки

Если переданная командой BuildSQL инструкция SQL содержит параметры, однако команды SetParameterName не были получены, Query присваивает в форме «Parameter n» имена параметров по умолчанию, где n — приращение счетчика. Если переданное с помощью команды SetParameterName количество имен параметров не существенно, оставшиеся параметры имеют имя «Parameter n». Если отправлено слишком много имен параметров, лишние имена игнорируются.


Команда SetQueryName (DDE)

Задание имени активного запроса или создание запроса с этим именем при отсутствии активного запроса. Имя отображается в заголовке окна запроса.

Синтаксис

SetQueryName(имя)

имя Имя запроса.


Команда SetQueryType (DDE)

Некоторые сведения в этом разделе могут быть неприменимы к отдельным языкам.

Определяет действие, которое выполняется в Microsoft Query с запросами, построенными на источниках данных других типов. Данная команда доступна только в системном канале.

Синтаксис

SetQueryType(типзапроса, типкоманды)

Допустимым сочетанием параметров типзапроса и типкоманды является следующее:

Тип запроса | Тип команды | Описание
ODBC | SQL | Редактирование запроса в Microsoft Query. Если отсутствуют параметры, то присваиваются эти значения.
OLEDB | Cube | Запуск мастера создания куба OLAP для изменения определения куба.

При использовании SetQueryType(OLEDB, Cube) в Microsoft Query игнорируются все команды LogonNow, EnableParameters, SetQueryName и аргументы UserControl2, которые не являются допустимыми внутри контекста редактирования определения куба в мастере создания куба OLAP.


Команда SetWindowState (DDE)

Задание обычного, свернутого или развернутого вида активного окна при открытии. Команда доступна как в системном канале, так и в канале запроса.

Синтаксис

SetWindowState(состояние)

состояние Состояние активного окна. Аргумент может иметь следующие значения.

Значение | Описание
1 | Обычное
2 | Свернутое (только для Microsoft Windows)
3 | Развернутое


Команда UserControl2 (DDE)

Активизация Microsoft Query и обеспечение возможности создания, открытия или изменения запроса пользователем, как при выполнении Microsoft Query в качестве отдельного приложения.

Данная команда доступна только в системном канале.

Примечание. Отличие команды UserControl от UserControl2 состоит в том, что UserControl2 позволяет задавать команду, добавляемую в меню Файл, закрывающую все запросы Microsoft Query и возвращающую управление приложению, не передавая при этом данных.

Синтаксис

UserControl2(текствыход, текстзаверш, состприл, новыйзапрос)

текствыход Имя команды Выход, используемой для выхода из Microsoft Query после сеанса DDE. Если аргумент опущен, используется «Return».

текстзаверш Имя команды меню, используемой для завершения текущего сеанса. Команда добавляется в конец меню Файл в Microsoft Query. Если аргумент опущен, создание нового пункта меню не происходит.

состприл Состояние приложения. Может принимать следующие значения.

Значение | Описание
1 | Обычное
2 | Свернутое (только для Microsoft Windows)
3 | Развернутое

Если этот аргумент опущен, используется текущее состояние Microsoft Query.

новыйзапрос Определяет, отображается ли диалоговое окно Выбор источника данных при запуске Microsoft Query в диалоге DDE. Может принимать значения True и False.

Если новыйзапрос имеет значение True, отображается диалоговое окно Выбор источника данных, в котором следует выбрать источник данных. Если новыйзапрос имеет значение False (используется по умолчанию), то диалоговое окно не отображается и все открытые запросы в этом канале доступны.


Команда UserControl (DDE)

Активизация Microsoft Query и обеспечение возможности создания, открытия или изменения запроса пользователем, как при выполнении Microsoft Query в качестве отдельного приложения.

Данная команда доступна только в системном канале.

Синтаксис

UserControl(текствыход, состприл, новыйзапрос)

текствыход Имя команды Выход, используемой для выхода из Microsoft Query после сеанса DDE. Если аргумент опущен, используется «Return».

состприл Состояние приложения. Может принимать следующие значения.

Значение | Описание
1 | Обычное
2 | Свернутое (только для Microsoft Windows)
3 | Развернутое

Если этот аргумент опущен, используется текущее состояние Microsoft Query.

новыйзапрос Определяет, отображается ли диалоговое окно Выбор источника данных при запуске Microsoft Query в диалоге DDE. Может принимать значения True и False.

Если новыйзапрос имеет значение True, отображается диалоговое окно Выбор источника данных, в котором следует выбрать источник данных. Если новыйзапрос имеет значение False (используется по умолчанию), то диалоговое окно не отображается и все открытые запросы в этом канале доступны.

Заметки

Управление пользователя завершается при выборе команды Выход в меню Фа йл в Microsoft Query. После этого Microsoft Query возвращается в свое прежнее состояние и возвращает управление приложению.

Внимание! Нельзя допускать тайм-аут приложения, имеющего тайм-аут, до завершения управления пользователем.

При выполнении Microsoft Query под управлением пользователя все новые или существующие запросы открываются в одном канале DDE.

Пример

В примере показан запуск Microsoft Query как развернутого приложения и замена команды Выход в меню Файл в Microsoft Query командой Передать данные в Microsoft Excel. После этого отображается диалоговое окно Выбор источника данных.

DDEExecute chan, "[UserControl(""&Return To Excel"",3,True)]")


Использование DDE

Две программы могут обмениваться данными путем открытия сеанса DDE, открытого на канале DDE. Программа может создать несколько сеансов DDE с Microsoft Query, но каждый из них будет открыт на своем канале.

Приложение, открывающее сеанс, называется приемником, а отвечающее на запрос — источником. В сеансе DDE Microsoft Query всегда является источником. Это значит, что другие приложения всегда должны сами открывать сеанс DDE с Microsoft Query.

Примечание. Не все программы поддерживают DDE. Чтобы выяснить, поддерживает ли его данное приложение, обратитесь к документации на программу.

Каналы DDE

Существует два типа каналов DDE: системные каналы и каналы запросов.

Системный канал используется в сеансе DDE между программой-приемником и Microsoft Query для получения общих и связанных с запросами сведений. Помимо сведений о запросах системный канал дает возможность получения сведений о системе, например текущие сеансы связи, открытые запросы и состояние программы-приемника.

Канал запросов используется в сеансе DDE между программой-приемником и определенным запросом (например, «Запрос1») Microsoft Query. Перед использованием канала запросов окно запроса должно быть открыто при помощи системного канала.

Как работает DDE

Сеанс DDE можно сравнить с обычным разговором двух людей. Например, во время собеседования при приеме на работу работодатель может задать соискателю набор определенных вопросов. Работодатель (приемник) запрашивает сведения у соискателя (источника) и записывает их на листе бумаги (лист Excel или документ). Соискатель также может задавать вопросы работодателю и установить двустороннюю связь.

Аналогичным образом программы-участники сеанса DDE передают данные в двух направлениях. Например, чтобы использовать DDE для связи с Microsoft Query, процедура Visual Basic для приложений должна выполнить следующие шаги:

  1. Открыть канал при помощи метода DDEInitiate.
  2. При необходимости процедура может передать некоторые данные, например имена доступных источников данных или текущих сеансов связи, в Microsoft Query.
  3. Загрузить Microsoft Query. Этот шаг необходим для того, чтобы разрешить Microsoft Query выполнять команды. На этом этапе пользователь или процедура могут построить или изменить запрос. Процедура может передавать команды непосредственно Microsoft Query при помощи метода DDEExecute.
  4. После того, как пользователь или процедура завершат работу с Microsoft Query, управление возвращается в программу-приемник. Процедура может получить данные запроса и послать их обратно приемнику при помощи метода DDERequest, либо передать данные в Microsoft Query.
  5. Закрыть канал при помощи DDETerminate.

Для получения дополнительных сведений о конкретных методах DDE в Visual Basic для приложений обратитесь к справочной системе Visual Basic.


Использование Microsoft Query совместно с другими приложениями

Некоторые сведения в этом разделе могут быть неприменимы к отдельным языкам.

Как правило, приложения используют Microsoft Query для выполнения следующих задач:

  • Создание нового запроса.
  • Обновление существующих данных.
  • Изменение описания запроса или данных.

Microsoft Query как средство создания запросов к данным

При помощи DDE можно использовать Microsoft Query в качестве инструмента получения данных. После того, как макрос или программа откроют канал DDE, можно вызвать Microsoft Query. Затем можно указать, какая команда заменяет команду Выход в меню Фа йл Microsoft Windows, в каком состоянии (свернутом, развернутом или восстановленном) находится Microsoft Query и нужно ли выводить какие-либо диалоговые окна.

Затем можно создавать, открывать или изменять запрос, как если бы Microsoft Query была загружена как самостоятельное приложение. После построения запроса можно выполнить команду Выход или нажать кнопку Выход на панели инструментов.

После возвращения управления в программу-приемник (документ, таблицу или другой объект) данные могут быть запрошены у Microsoft Query. Например, можно запросить число строк или столбцов в запросе, строку SQL, описывающую запрос, строку связи с источником данных или имя источника данных. Данные могут быть возвращены в программу-приемник до закрытия канала DDE и завершения работы макроса или программы.

Обновление полученных данных

После выполнения запроса и возвращения таблицы результатов может понадобиться обновление данных, полученных из источника. При помощи DDE можно обновить данные без участия пользователя: программа может послать инструкцию SQL в Microsoft Query, которая затем будет выполнена и вернет таблицу результатов в программу-приемник.

Изменение описания запроса или данных

Другим примером использования Microsoft Query программой является изменение пользователем существующего описания запроса в Microsoft Query или изменение данных источника.

Программа начинает этот процесс с открытия канала DDE, соединения с источником данных и передачи строки SQL (сохраненной при предыдущем запросе) в Microsoft Query для создания нового запроса. После открытия программой нового запроса управление передается пользователю, который может изменить запрос или данные. После окончания работы пользователя в Microsoft Query данные возвращаются в программу, сохраняется новое описание запроса и происходит закрытие запроса.

Например, пользователь, работающий в Microsoft Word, может выполнить пользовательскую команду «Вывести графики продаж» для запуска соответствующего макроса. Этот макрос может вызвать Microsoft Query, построить запрос, а затем вернуть данные о продажах в документ Microsoft Word без оповещения пользователя.


Команда ViewPane (DDE)

Задание отображаемых областей окна запроса. Команда доступна как в системном канале, так и в канале запроса.

Синтаксис

ViewPane(область)

область Отображаемые области. Может принимать значения:

Значение | Описание
0 (ноль) | Только область данных
1 | Область данных и область таблиц
2 | Область данных и область условий
3 | Область данных, область таблиц и область условий


Типы данных Q+E

Значение | Тип
1 | SQL_CHAR
2 | SQL_BINARY, SQL_VARBINARY, SQL_LONGVARBINARY, SQL_LONGVARCHAR, SQL_VARCHAR
3 | SQL_NUMERIC, SQL_DECIMAL
4 | SQL_INTEGER, SQL_BIGINT
5 | SQL_BIT, SQL_TYNYINT, SQL_SMALLINT
6 | SQL_FLOAT
7 | SQL_REAL, SQL_DOUBLE
8 | SQL_TIME, SQL_DATE, SQL_TIMESTAMP


Типы данных SQL

Значение | Тип
0 | SQL_UNKNOWN_TYPE
1 | SQL_CHAR
2 | SQL_NUMERIC
3 | SQL_DECIMAL
4 | SQL_INTEGER
5 | SQL_SMALLINT
6 | SQL_FLOAT
7 | SQL_REAL
8 | SQL_DOUBLE
9 | SQL_DATETIME (только ODBC 3.0)
12 | SQL_VARCHAR


Таблица <имя> удалена.

Таблица и данные из нее были удалены Microsoft Query. Отмена удаления невозможна.


Удалить таблицу <имя>?

Запрошено удаление таблицы. При удалении таблицы все данные из нее будут удалены.

Внимание! Отмена удаления таблицы невозможна.

  • Чтобы удалить таблицу со всеми данными, нажмите кнопку Да.
  • Для отказа от удаления нажмите кнопку Нет.


Недопустимое состояние запроса. Операция сохранения прервана

Неправильный запрос запроса. Например, могли быть неверно заданы условия. Если команда Автоматический режим отключена, попытайтесь выполнить запрос путем выбора в меню Записи команды Выполнить запрос.


Для запуска Microsoft Query требуется разрешение экрана не менее 400 х 350 пикселов

Драйвер экрана не поддерживает разрешение, достаточное для запуска Microsoft Query. Замените драйвер при помощи программы установки Microsoft Windows. Перед заменой драйвера экрана может понадобиться установка нового видеоадаптера, поддерживающего более высокое разрешение.


Ошибка драйвера

Ошибка драйвера. Для получения дополнительных сведений обратитесь к документации на используемый драйвер.


Найдена повторяющаяся запись

Таблица результатов содержит одинаковые записи, так как в область данных не включено поле, единственным образом описывающее каждую запись, например «Номер заказчика» или «Номер заказа». Любые изменения в одной из одинаковых записей влияют на все такие записи.

Чтобы различать записи, перед началом изменения убедитесь, что все поля таблицы добавлены в область данных.


Невозможно редактировать вычисляемый столбец

Невозможно изменение столбца, для которого созданы групповые операции или в котором выводятся результаты пользовательских выражений.


Невозможно редактировать сгруппированный запрос

Невозможно изменение данных в запросе, который содержит групповые операции или в диалоговом окне Параметры запроса которого установлен флажок Группировать записи. Для изменения данных удалите групповые операции или снимите флажок Группировать записи.


Невозможно редактировать многотабличный запрос

Изменение данных в запросе, содержащем несколько таблиц, невозможно.

  • Для изменения данных таблицы добавьте только эту таблицу в запрос и выберите в меню Записи команду Разрешить правку.
  • Для изменения данных текущего запроса удалите из него все таблицы, кроме той, которую нужно изменить. Затем выберите меню Записи команду Разрешить правку.

Примечание. При удалении таблицы из запроса сама таблица не удаляется. Происходит только удаление таблицы и ее содержимого из текущего запроса.


Невозможно добавить источник данных

Microsoft Query не может добавить указанный источник данных из-за трудностей с подключением к источнику данных.


Неправильное выражение столбца: <выражение>

Выражение, указанное в операторе SELECT, неверно. Выражение должно иметь следующий формат:

SELECT employee.EMPLOY_ID, employee.HIRE_DATE
FROM C:\QT\employee employee


Требуется выражение после GROUP BY

Отсутствует выражение после оператора GROUP BY в инструкции SQL.


Требуется выражение после ORDER BY

Отсутствует выражение после оператора ORDER BY в инструкции SQL.


Невозможно открыть несколько копий файла

Файл запроса не может быть открыт дважды в одно и то же время.


Невозможно добавить таблицу <имя>

Не удается добавить указанную таблицу. Убедитесь, что:

  • Указанная таблица присутствует в базе данных.
  • Название таблицы указано правильно. Проверьте, не пропущены ли где-либо знаки ( _ ) или знаки препинания.
  • Указанная таблица содержит поля (столбцы).


Для создания самообъединения необходимо иметь две копии таблицы

Посредством задания одинаковых имен таблиц в полях Левая и Правая диалогового окна Объединения определено создание внутреннего объединения, но в области таблиц содержатся две разные таблицы.

  • Для создания внутреннего объединения необходимо поместить в область таблиц две копии одной таблицы.
  • Для объединения двух разных таблиц необходимо поместить одну из таблиц в левую часть объединения, а другую — в правую.


Длина <число> должна быть числом

В поле Длина введено не числовое значение. Исправьте значение на числовое.


Ошибка в имени <имя>

Имена таблицы и полей должны соответствовать стандартам имен, принятым для источника данных. Обратитесь к документации на источник данных.


Число знаков после десятичной запятой должно быть меньше или равно общей длине

Введенное в поле Число десятичных знаков значение превышает значение, заданное в поле Длина. Измените значение поля Число десятичных знаков на меньшее или равное значению поля Длина.


Максимальная длина типа <имя типа данных> — <число>

Введенное в поле Длина значение превышает максимальную допустимую для поля этого типа данных длину.


Обновление не выполнено

Microsoft Query не может обновить список таблиц в диалоговом окне Добавление таблиц, так как источник данных не отвечает. Убедитесь, что соединение с источником данных не прервано.


Невозможно удалить источник данных

Microsoft Query не может удалить указанный источник данных. Для удаления источника необходимо отсоединиться от него.


Общий сбой ODBC

Microsoft ODBC или источник данных вернули ошибку, подробные сведения о которой недоступны. Убедитесь, что база данных загружена и доступна, и повторите операцию.


Ошибка синтаксиса в предложении GROUP BY

Инструкция SQL содержит неверный оператор GROUP BY. Возможно, неверно введено или отсутствует зарезервированное слово, или неверно расставлены знаки препинания.


Ошибка синтаксиса в предложении HAVING

Инструкция SQL содержит неверный оператор HAVING. Возможно, неверно введено или отсутствует зарезервированное слово либо неверно расставлены знаки препинания.


Ошибка синтаксиса в операции JOIN

За оператором ON инструкции SQL следует недопустимое выражение. Выражение должно иметь следующий формат:

{oj C:\QT\orders orders LEFT OUTER JOIN C:\QT\orddtail orddtail ON orders.ORDER_ID = orddtail.ORDER_ID}


Ошибка синтаксиса в предложении ORDER BY

Инструкция SQL содержит неверный оператор ORDER BY. Возможно, неверно введено или отсутствует зарезервированное слово или неверно расставлены знаки препинания.


Сначала выберите источник данных

Попытка выполнить инструкцию SQL до указания источника данных. В диалоговом окне Выполнить запрос SQL нажмите кнопку Источники данных и выберите требуемый источник данных.


Требуется оператор join после <имя>

В выражении «LEFT OUTER JOIN» или «RIGHT OUTER JOIN» отсутствует оператор «=» между названиями двух таблиц. Внешние объединения должны использовать оператор «=».


Требуется LEFT или RIGHT после таблицы <имя>

В инструкции SQL содержится оператор OUTER JOIN без ключевых слов «LEFT» или «RIGHT». Оператор внешнего объединения в инструкции SQL должен иметь вид «LEFT OUTER JOIN» или «RIGHT OUTER JOIN».


Требуется выражение после HAVING

После оператора HAVING в инструкции SQL не указано условие поиска.


Требуется выражение после WHERE

После оператора WHERE в инструкции SQL не указано условие поиска.


Требуется имя таблицы после FROM

После оператора FROM в инструкции SQL не содержится названия таблицы.


Слишком длинный текст; вставка отменена

Вставляемый из буфера обмена текст слишком длинный, чтобы поместиться в выбранное поле области данных или области условий. Максимальное количество знаков, которое можно поместить в поле, зависит от длины поля, заданной при создании таблицы.


Ошибка ввода/вывода в процессе загрузки

Microsoft Query не может открыть или прочитать указанный файл. Возможно, произошел сбой диска или поврежден файл.


Невозможно прочитать этот файл

Microsoft Query не может прочитать указанный файл. Возможно, файл записан в формате, несовместимом с форматами Microsoft Query или Q+E, произошел сбой диска или файл поврежден.


Ошибка ввода/вывода в процессе сохранения

Microsoft Query не может сохранить запрос на диск. Возможно, произошел сбой диска.


Невозможно задать условие, пока не указано поле

Перед заданием условий для поля его необходимо добавить в область условий.


Драйвер поддерживает не все функции

Введенное выражение содержит функции, не поддерживаемые источником данных. Чтобы выяснить, какие функции поддерживает источник данных, обратитесь к документации на драйвер источника данных или свяжитесь с поставщиком драйвера.


Невозможно создать индекс

Источник данных таблицы не поддерживает индексы.


Индекс создан

Индекс для указанных полей таблицы успешно создан Microsoft Query.


Сеанс DDE закрыт или изменен

Другая программа без предупреждения закрыла сеанс динамического обмена данными (DDE), например с помощью инструкции DDETerminate или DDETerminateAll, или изменила его параметры.

Закройте текущий сеанс, а затем создайте новый сеанс обмена с этой программой.


Значение ширины должно быть от 1 до <число>

Задайте ширину столбца в указанном диапазоне или выберите параметр Стандартная ширина в диалоговом окне Ширина столбца.


Недопустимое имя файла

Имена файлов должны вводиться в соответствии со стандартами имен, принятыми для источника данных. Обратитесь к документации на источник данных.


Значение высоты должно быть от 1 до <число>

Задайте значение высоты строк, находящееся в указанном диапазоне, или выберите параметр Стандартная высота в диалоговом окне Высота строк.


В выражениях LEFT OUTER JOIN и RIGHT OUTER JOIN должен использоваться оператор «=»

В выражении «LEFT OUTER JOIN» или «RIGHT OUTER JOIN» отсутствует оператор «=» между названиями двух таблиц или указан другой оператор. Внешние объединения должны использовать оператор «=».


Столбцы <имя> и <имя>, по которым требуется создать объединение, имеют разный тип. Создать объединение?

Попытка объединения полей (столбцов) с разными типами данных. Например, объединение поля, содержащего даты, с полем, содержащим текст.

  • Для отмены объединения нажмите кнопку Отмена.
  • Для создания объединения нажмите кнопку OK.

Примечание. Такое объединение может не дать требуемых результатов. Убедитесь, что в таблице результатов Microsoft Query выводятся нужные данные.


Требуется JOIN после OUTER

Инструкция SQL содержит выражение «LEFT OUTER» или «RIGHT OUTER» вместо «LEFT OUTER JOIN» или «RIGHT OUTER JOIN». Слово «JOIN» неверно введено или отсутствует.


Транзакция DDE не выполнена. Убедитесь в правильности версии DDEML.DLL

Установка Microsoft Query выполнена не полностью или повреждена. Для исправления ошибки переустановите Microsoft Query и выберите режим восстановления.


Невозможно создать внешние объединения, если в запросе больше двух таблиц

При использовании внешнего объединения в области таблиц могут находиться только две таблицы. Удалите лишние таблицы из области таблиц и создайте внешнее объединение.


Очередь сообщений заполнена. Сообщение DDE потеряно

Microsoft Query не может выполнить все запрашиваемые операции динамического обмена данными (DDE).

Закройте некоторые сеансы DDE и попытайтесь повторить операцию.


Значение должно быть числовым

При задании числового параметра введено не числовое значение. Введите числовое значение.


Другое приложение не поддерживает используемый метод или операцию DDE

Другая программа не может выполнить требуемую операцию динамического обмена данными (DDE).

  • Программа не распознает переданные данные или команды. Чтобы определить, какие команды или данные принимает программа, обратитесь к документации на нее.
  • Программа не принимает параметр Объект на основании заданного раздела сеанса. Чтобы определить, какие объекты принимает программа, обратитесь к документации на нее.


Невозможно открыть канал DDE; Microsoft Query не находит указанное приложение или раздел

Microsoft Query не может найти указанное приложение или раздел для сеанса динамического обмена данными (DDE). Убедитесь, что другое приложение (приемник) загружено, раздел открыт и при определении сеанса DDE были правильно указаны имя приложения и раздел.


Невозможно сохранить столбец <имя> в этом источнике данных

Источник данных, в который записывается таблица результатов, не поддерживает тип данных какого-либо поля или не может преобразовать его в совместимый тип. Попытайтесь сохранить таблицу в другой источник данных, поддерживающий этот тип данных.


Недостаточно системных ресурсов для обновления изображения на экране

Недостаточно памяти для завершения операции Microsoft Query.

Попытайтесь закрыть другие приложения или другие окна в Microsoft Query. Если ошибка повторяется, перезапустите Microsoft Windows и повторите операцию.


Нет доступа к таблице <имя>

Указанная таблица не найдена, заблокирована другим пользователем или запросом или не содержит полей.


Не удается отобразить справку

Файл справки Microsoft Query отсутствует в текущей папке. Перенесите или скопируйте его в текущую папку.


Невозможно получить процедуры

Microsoft Query не может вывести список процедур из данного источника данных, так как источник не отвечает. Возможно, произошло отсоединение от источника данных.


Ни одна процедура не найдена

Источник данных не содержит процедур. Для создания процедур обратитесь к документации на источник данных.


Невозможно удалить, некоторые запросы используют этот источник

Удаляемый источник данных используется другими запросами. Необходимо сначала закрыть запросы, использующие этот источник данных.


Запись не существует

Запись с указанным номером не существует. Возможно, задан слишком большой или слишком маленький номер записи. Убедитесь, что в области данных присутствуют записи, и проверьте правильность ввода номера записи.


В таблице отсутствует уникальный индекс. Создать индекс вручную?

Таблица результатов, которую требуется сохранить как новую таблицу, получена из таблицы, для которой не существует уникального индекса.

  • Чтобы вывести диалоговое окно Создание индекса для создания уникального индекса таблицы, нажмите кнопку Да.
  • Чтобы отменить создание индекса, нажмите кнопку Нет.


Невозможно найти значения

Microsoft Query не может передать заданные в условиях значения. Возможной причиной может быть нехватка памяти или отсоединение от источника данных.

Если соединение с источником данных не прервано, попытайтесь закрыть другие приложения или другие окна Microsoft Query. Если ошибка повторяется, перезапустите Microsoft Windows.


Невозможно создать новое окно

Microsoft Query не может вывести указанный файл. Возможно, не хватает памяти.

Закройте другие активные приложения или окна Microsoft Query. При повторении ошибки перезапустите Microsoft Windows.


Отмена операции невозможна. Продолжать?

Для этой операции команда Отменить недоступна, так как операция слишком велика или недостаточно свободной памяти.

  • Чтобы продолжить выполнение операции без возможности отмены, нажмите кнопку OK.
  • Для отмены операции нажмите кнопку Отмена.


Требуется ON после оператора RIGHT JOIN для таблицы

Инструкция SQL содержит оператор LEFT OUTER JOIN или RIGHT OUTER JOIN и выражение для него, но отсутствует оператор ON со своим выражением. Слово «ON» введено неверно или отсутствует.


Запрос может содержать только одно внешнее объединение

В запросе может присутствовать только одно внешнее объединение.


Необходимо указать одно значение для оператора <оператор>

При создании условий с использованием этого оператора должно использоваться только одно значение. Microsoft Query выбирает только записи, содержащие указанное значение в поле, для которого задано в условие. Например, при выборе пункта «начинается с» из списка Оператор Microsoft Query производит поиск значений, начиная с указанного, в заданных условиями полях. Для таблицы результатов отбираются только эти записи.


Необходимо указать два значения для оператора <оператор>

При создании условий с помощью этого оператора необходимо использовать два значения. Например, при выборе «между» из списка Оператор, Microsoft Query производит поиск в значений, попадающих в указанный диапазон, в поле, для которого заданы условия. Для таблицы результатов отбираются только эти записи.


Невозможно открыть файл

Microsoft Query не может открыть указанный файл запроса. Возможно, произошел сбой диска или файл поврежден.


Не удается открыть файл

Microsoft Query не может открыть файл Microsoft Query, указанный в диалоговом окне Выполнить запрос SQL. Возможно, файл сохранен не в текстовом формате, произошел сбой диска или файл поврежден.


Требуется OUTER после LEFT/RIGHT

В инструкции SQL присутствует оператор внешнего объединения LEFT или RIGHT OUTER JOIN, в котором отсутствует ключевое слово «OUTER». Оператор внешнего объединения в инструкции SQL должен иметь вид «LEF OUTER JOIN» или «RIGHT OUTER JOIN».


Для внешнего объединения требуются только две таблицы. Удалить внешнее объединение для добавления таблицы?

В области таблиц уже имеются две таблицы, связанные внешним объединением. Для использования трех и более таблиц в области таблиц необходимо удалить внешнее объединение или заменить его внутренним.


Слишком большое число

Введите меньшее значение.


Слишком длинное выражение

Выражение слишком длинное для анализа в Microsoft Query. Попытайтесь сделать выражение короче или разбейте его на два выражения.


Нет доступа к <база данных>

Используемый источник данных разрешает выбор таблиц только из текущей базы данных (или из эквивалента базы данных).


Изменение заголовка столбца

  1. Дважды щелкните заголовок столбца поля, который нужно изменить.
  2. Введите заголовок в поле Заголовок столбца.


Изменение ширины столбца или высоты всех строк

Изменение ширины столбца. Чтобы изменить ширину столбца, поместите указатель мыши на правую границу заголовка столбца и установите нужную ширину.

Совет. Чтобы установить ширину столбца равной ширине максимального из значений, содержащихся в столбце, дважды щелкните правую границу заголовка столбца.

Изменение высоты строки. Чтобы изменить высоту всех строк, поместите указатель мыши на нижнюю границу любого заголовка строки и установите нужную высоту.

Примечание. Изменение высоты действует для всех строк в таблице результатов.


Изменение шрифта, стиля или размера текста в таблице результатов

  1. Выберите команду Шрифт в меню Формат.
  2. Внесите требуемые изменения.


Изменение типа объединения таблиц в запросе

  1. Дважды щелкните линию объединения таблиц.
  2. Выбрать оператор, который будет использоваться Microsoft Query при сравнении данных в объединенных полях, можно в списке Оператор. Для получения дополнительных сведений нажмите кнопку Значок кнопки .
  3. Для создания внешнего объединения, при котором используются все записи из таблицы слева, выберите параметр 2 из списка Объединение включает. Для создания внешнего объединения выберите оператор «=».

    Для создания внешнего объединения, в котором используются все записи из таблицы справа, выберите параметр 3 из списка Объединение включает.

    Для создания внутреннего объединения, в котором используются записи из обеих таблиц, выберите параметр 1 из списка Объединение включает.

  4. Нажмите кнопку Добавить.
  5. Нажмите кнопку Закрыть.

    Для получения дополнительных сведений о типах объединений и их влиянии на результаты запроса нажмите кнопку Значок кнопки .


Создание сложного запроса в Microsoft Query

  1. Нажмите кнопку Создать запрос Значок кнопки.
  2. Выберите базу данных, из которой требуется получить данные, на вкладке Базы данных или создайте новый источник данных.

    Инструкции

  3. Снимите флажок Использовать мастер запросов и нажмите кнопку OK.
  4. Добавьте нужные таблицы.

    Инструкции

  5. Внесите поля, которые требуется получить в таблице результатов.

    Инструкции

    Для включения в таблицу результатов определенных записей введите условия отбора записей.

    Инструкции

    Чтобы создать запрос с параметрами, при запуске которого требуется условие, укажите это параметр.

    Инструкции

    Для изменения таблицы результатов можно создать внутреннее объединение или внешнее объединение таблиц.

    Инструкции

Примечания

  • После извлечения необходимых данных таблица результатов может быть передана в Microsoft Excel. Чтобы получить более подробные сведения, нажмите кнопку Значок кнопки .
  • Для остановки выполнения запроса, занимающего слишком много времени, нажмите клавишу ESC.
  • Чтобы предотвратить выполнение запроса до окончания ввода всех полей в таблицу результатов, убедитесь, что кнопка Автоматический режим Значок кнопки не нажата. Для выполнения запроса нажмите кнопку Выполнить запрос Значок кнопки.
  • Чтобы запретить выполнение запроса до его сохранения или возвращения данных в Excel, в меню Правка выберите Параметры и затем снимите флажок Проверять запросы перед сохранением или возвратом данных.


Создание запроса с использованием мастера запросов

Некоторые сведения в этом разделе могут быть неприменимы к отдельным языкам.

  1. Нажмите кнопку Создать запрос Значок кнопки.
  2. Установите флажок Использовать мастер запросов.
  3. На вкладке Базы данных выберите базу данных, из которой будут импортированы данные.

    Чтобы настроить новый источник данных, дважды щелкните Новый источник данных, а затем укажите источник данных.

  4. Выполните указания мастера запросов.
  5. В диалоговом окне Мастер запросов — Готово выполните одну из следующих операций:

    Чтобы непосредственно передать данные в Microsoft Excel, выберите Вернуть данные в Microsoft Excel, затем Готово и укажите, куда нужно поместить эти данные.

    Для сохранения запроса в DQY-файле, который может быть открыт для редактирования в Microsoft Query или для запуска в Microsoft Excel, нажмите кнопку Сохранить запрос. Этот необязательный шаг рекомендуется выполнить, если в будущем из запроса будет создан куб OLAP.

    Для запуска мастера создания куба OLAP, который позволяет создать куб из данных запроса, нажмите кнопки Создание куба OLAP из данного запроса и Готово. После этого следуйте дальнейшим указаниям мастера. Этот режим рекомендован только для опытных пользователей. См. сведения о создании кубов OLAP.

    Для дальнейшего уточнения условий запроса выберите параметр Просмотр или изменение данных в Microsoft Query и нажмите кнопку Готово. Таблица результатов выводиться в области данных, где можно произвести изменения и затем позже вернуть ее в Microsoft Excel.

Совет. Чтобы прекратить выполнение запроса, занимающего слишком много времени, нажмите клавишу ESC.


Удаление содержимого базы данных, участвующей в запросе

Внимание! При удалении записи из базы данных она будет также полностью удалена из таблицы результатов.

  1. Убедитесь, что в меню Записи включена команда Разрешить правку.

    В некоторых случаях Microsoft Query запрещает изменение данных. Если команда Разрешить правку недоступна или Microsoft Query выводит сообщение при выборе команды Разрешить правку, то данные не могут быть изменены. Для получения дополнительных сведений нажмите кнопку Значок кнопки .

  2. Выберите удаляемую запись, щелкнув кнопку слева от записи.
  3. В меню Правка выберите команду Удалить.


Изменение содержимого базы данных, участвующей в запросе

  1. Убедитесь, что в меню Записи Microsoft Query включена команда Разрешить правку.

    В некоторых случаях Microsoft Query запрещает изменение данных. Если команда Разрешить правку недоступна, или Microsoft Query выводит сообщение при выборе команды Разрешить правку, то данные не могут быть изменены. Для получения дополнительных сведений нажмите кнопку Значок кнопки .

  2. Выберите поле, которое нужно изменить, в таблице результатов.
  3. Сделайте нужные изменения и нажмите клавишу ENTER.

Примечание. Если при изменении данных была сделана ошибка, то можно отменить последнее изменение, выбрав команду Вернуть в меню Правка. Отменять изменения нужно до перехода к другой записи или окну.


Вставка поля в таблицу результатов

  1. Щелкните заголовок столбца поля, расположенного справа от места вставки нового поля.
  2. Выберите команду Вставить в меню Записи.
  3. Выберите столбец, который нужно вставить, из списка Поле.

    При необходимости введите описательный заголовок в поле Заголовок столбца.

  4. Нажмите кнопку Вставить.

Примечание. Чтобы быстро вставить поле в таблицу результатов, можно перетащить его из области таблиц в таблицу результатов.


Изменение порядка расположения полей в таблице результатов

  1. Щелкните заголовок столбца поля, который нужно переместить.
  2. Поместите указатель мыши на заголовок столбца и перетащите столбец в нужное место.


Скрытие или отображение поля в таблице результатов

  1. Click the column heading of the field you want to hide.
  2. Выберите команду Скрыть столбцы в меню Формат.

Чтобы отобразить скрытый столбец, выберите команду Показать столбцы в меню Формат, выберите нужный столбец и нажмите кнопку Показать.


Отмена изменений базы данных, участвующей в запросе

  • Выберите команду Вернуть в меню Правка.

Примечание. Допускается отмена последнего изменения данных. Отмена изменений должна выполняться до перехода к другой записи или окну.


Выводится сообщение недопустимости пути к базе данных.

Проверьте подключение сетевого диска. Если база данных находится в общем сетевом каталоге, при настройке источника данных и указании файла базы данных адрес базы данных может быть автоматически записан в источнике данных с указанием подключенного сетевого диска, который использовался системой в тот момент. Например, если база данных называется Inventory.mdb, а диск G подключен к сетевому каталогу, в котором хранится эта база данных, в источнике данных адрес базы данных будет записан в виде «G:\public\Inventory.mdb». При попытке использовать этот источник данных или запустить запросы, созданные в этом источнике данных, драйвером ODBC будет выведено сообщение о том, что адрес указан неверно, если диск G не будет подключен к тому же общему сетевому каталогу.

Использование альтернативы подключению дисков Если для работы используются драйверы Microsoft Access или Microsoft Excel, эту проблему можно устранить, создав новый источник данных. При указании местоположения файла базы данных не следует выбирать подключенный сетевой диск. Вместо этого следует ввести адрес UNC общего сетевого каталога, а затем указать файл базы данных. Например, если файл базы данных хранится на сервере, который называется «Shared», следует ввести \\Shared\public, а затем выбрать файл «Inventory.mdb».

Подключите сетевой диск с назначением ему той же буквы перед использованием источника данных. При работе с другими драйверами ODBC перед использованием источника данных или выполнением запроса, созданного в этом источнике данных, убедитесь, что к общему сетевому каталогу, в котором находится база данных, подключен тот же диск, который использовался при создании источника данных.


Использовавшийся ранее драйвер ODBC не работает.

Необходимость использования в Microsoft Query другого драйвера может возникнуть в следующих ситуациях.

Убедитесь, что используется 32-разрядный драйвер ODBC Для Microsoft Query требуются 32-разрядные драйверы ODBC, такие как входящие в Microsoft Query версии 97 и более поздних. Например, если программа получения внешних данных, разработанная для Microsoft Excel с использованием Microsoft Visual Basic, используется пользователями Microsoft Excel версий 5.x, она может не работать с 16-разрядными драйверами ODBC в Microsoft Excel версии 5.x.

Убедитесь, что драйверы Microsoft имеют версию 3.0 или более позднюю При установке драйверов ODBC Microsoft, отличных от поставляемых с последними версиями Microsoft Excel или Microsoft Office, убедитесь, что устанавливаемые драйверы имеют версию 3.0 или более позднюю. Более ранние версии драйверов ODBC могут не работать с Microsoft Query версии 2000 или более поздней. Драйверы, поставляемые с Microsoft Excel 97 и Microsoft Office 97, имеют версию 3.0 и выше. При установке этих драйверов все драйверы более ранних версий замещаются автоматически.

Убедитесь, что используемые драйверы сторонних производителей имеют правильную версию Если для работы используется драйвер ODBC стороннего производителя, при обновлении или установке новой версии базы данных может потребоваться также установка нового драйвера ODBC для Microsoft Query. Чтобы выяснить, требуется ли установка нового драйвера, обратитесь к документации по базе данных.

Убедитесь, что источник данных настроен для драйвера с помощью Microsoft Query Microsoft Query не может использоваться для доступа к источникам данных, настроенным с помощью мастера подключения данных.


Поля со значениями даты или времени восстанавливаются некорректно.

Проверьте поля даты и времени в исходной базе данных Если не отображаются необходимые уровни в размерностях даты или времени куба OLAP, проверьте поля даты и времени в исходной реляционной базе данных, поставляющей записи для запроса. Дата или время в записях могут быть сохранены в виде текста, а не в форматах даты или времени, которые могут быть опознаны мастером создания куба OLAP. В этом случае необходимо обратиться к администратору реляционной базы данных для проверки и исправления формата даты и времени поля.

Проверьте верхний уровень размерности При добавлении полей даты и времени мастером создания куба OLAP в качестве нижних уровней существующей размерности дата не разбивается автоматически на уровни «год/квартал/месяц/неделя» и «час/минута/секунда». Это действие выполняется мастером только при добавлении поля даты или времени на верхний уровень новой размерности. Если поле даты или времени не является верхним уровнем, измените куб.


Изменения и форматирование запроса не отображаются при его следующем выполнении

В Microsoft Excel изменения форматирования в запросах не сохраняются При переносе данных в Microsoft Excel определение запроса сохраняется как часть листа, но автоматического сохранения отдельного файла запроса не происходит. При редактировании запроса в Microsoft Query для внешнего диапазона данных изменения форматирования или заголовков столбцов не сохраняются.

Изменения форматирования не сохраняются в файлах запросов.dqy При сохранении файла в формате.dqy изменения форматирования или заголовков столбцов не сохраняются.

Изменения форматирования сохраняются в файлах запросов.qry Для сохранения измененного форматирования в Microsoft Query выберите в меню Файл команду Сохранить как, а затем в списке Тип файла выберите значение Файлы запросов (*.qry). При повторном открытии файла запроса в Microsoft Query его форматирование будет отображено.


Сообщение о потере данных во время изменения куба OLAP

Включенное в куб поле более недоступно в исходной базе данных.

Проверьте изменения в исходной базе данных Если запрос, созданный после создания куба, был сохранен, можно открыть запрос базы данных; в противном случае допускается только создание нового запроса. Проверьте наличие в области данных запроса всех изначально включенных в него полей. Прокрутив список полей, можно посмотреть доступные поля в области таблицы.

Если открытие существующего запроса или создание нового невозможно, обратитесь к администратору базы данных для получения дополнительных сведений о способе ее изменения.

Создайте новый куб Если поля были удалены из базы данных, можно создать новый куб.


Не удается добавить поля в куб OLAP

После определения куба в мастере создания кубов OLAP не допускается вставка дополнительных полей из исходной реляционной базы данных. Для добавления новых полей необходимо изменить файл запроса к базе данных (.dqy) и создать заново куб.

Открытие или создание запроса Если созданный запрос к базе данных сохранен, можно открыть файл.dqy. Если запрос не сохранен, можно создать новый запрос.

Добавление полей к запросу Добавьте необходимые поля к запросу. Если в будущем может понадобиться куб с другими полями, сохраните копию запроса, чтобы не создавать заново запрос каждый раз.

Создание нового куба После создания запроса со всеми полями, необходимыми для куба, можно создать новый куб.


Итоговая функция, необходимая для данных куба, недоступна.

При использовании мастера для создания куба OLAP из записей в реляционной базе данных для вычислении значений полей данных доступны только такие итоговые функции, как «Сумма», «Число», «Минимум» и «Максимум».

Создайте отчет непосредственно из записей базы данных Если запрос может быть уточнен так, чтобы объем возвращаемых данных не превышал объем, который может быть обработан системой, и нет необходимости создавать куб OLAP для данных, попробуйте вместо создания куба вернуть записи запроса в Microsoft Excel.

При создании сводной таблицы или сводной диаграммы в Microsoft Excel на основе непосредственного запроса реляционной базы данных (без создания куба), будет доступно большее число функций суммирования: СУММ, СЧЁТ, СРЗНАЧ, МАКС, МИН, ПРОИЗВЕД, СТАНДОТКЛОН, СТАНДОТКЛОНПА, ДИСП и ДИСПР. Дополнительные сведения об итоговых функциях см. в справке Microsoft Excel.

Попробуйте настроить сервер OLAP для базы данных Службы Microsoft SQL Server OLAP, серверный программный продукт, выполняющий операции OLAP, позволяет задавать более широкий диапазон итоговых полей, чем клиентское программное обеспечение OLAP, входящее в пакет Microsoft Office.


При попытке сохранить файл автономного куба не хватает свободного места на диске

Реляционная база данных, для которых создается запрос, может быть очень большой. Если задано большое подмножество данных для автономного куба, возможна нехватка места на локальном жестком диске.

Освободите пространство на диске или найдите другой диск Удалите ненужные файлы с диска перед сохранением файла или попробуйте сохранить файл на сетевом диске.

Сократите объем данных, включаемых в автономный куб Рассмотрите пути уменьшения объема данных в файле, сохранив данные, необходимые для сводной таблицы и сводной диаграммы Microsoft Excel. Попробуйте выполнить следующие действия.

  • Включайте только самые необходимые поля На первом шаге мастера создания куба OLAP выберите только те поля данных, которые необходимы для отображения в отчете.
  • Включайте только те размерности, которые будут использоваться На втором шаге мастера создания куба OLAP добавьте только те поля, которые будут отображаться в отчете в качестве размерностей и уровней. Для получения инструкций по созданию размерностей обратитесь к справочной системе мастера создания куба OLAP.

Используйте временный куб вместо файла автономного куба Если все возможные данные исключены, а файл автономного куба не может быть сохранен, попробуйте выбрать первый режим (использование меньшего дискового пространства) на третьем шаге мастера создания куба OLAP. Этот режим перестраивает куб в памяти при открытии отчета, основанного на данном кубе, и извлекает только те данные, которые необходимы для отображения в отчете.


Не удается добавить, скопировать или переместить запись в базе данных

В Microsoft Query версии 2000 или более поздней имеется возможность изменения и удаления записей, уже присутствующих в базе данных, но изменение в Microsoft Query последовательности записей и их добавление в базы данных, доступ к которым осуществляется с помощью драйверов Microsoft Excel или драйверов текста.

Непосредственная работа в базе данных Если необходимо скопировать запись, откройте непосредственно базу данных и используйте имеющиеся в ней команды. Для получения дополнительных сведений и инструкций обратитесь к администратору базы данных.

Сортировка записей запроса в Microsoft Query Порядок расположения записей в таблице результатов может быть изменен с помощью команды Сортировка в меню Записи. Сортировка в Microsoft Query не влияет на исходную базу данных, а только на таблицу результатов. Для получения дополнительных сведений нажмите кнопку Значок кнопки .


Не удается создать требуемый тип объединения

Для внешнего объединения убедитесь, что запрос содержит не более двух таблиц Если запрос содержит более двух таблиц, внешнее объединение в запросе невозможно. Параметры 2 и 4 в диалоговом окне Объединения соответствуют внешним объединениям.

Запрос может содержать только одно внешнее объединение Число внутренних объединений не ограничено (параметр 1 в диалоговом окне Объединения), но в каждом запросе допускается только одно внешнее объединение. При наличии навыков программирования на языке SQL можно попытаться изменить инструкцию SQL в диалоговом окне Запрос SQL (меню Вид, команда Запрос SQL) для создания нескольких внешних объединений.

Сведения об объединениях Для получения дополнительных сведений о внешнем объединении записей нажмите кнопку Значок кнопки .


Не удается сохранить таблицу результатов в качестве таблицы базы данных

В Microsoft Query версии 2000 и более поздних не допускается сохранение таблицы результатов в качестве таблицы базы данных.

Импорт данных в базу данных из Microsoft Excel Если допускается импорт данных из Microsoft Excel в базу данных, можно перенести таблицу результатов в Microsoft Excel, а затем импортировать данные из Microsoft Excel в таблицу с помощью команд базы данных. Например, в Microsoft Access имеется мастер импорта таблиц, который может использоваться для создания таблиц из данных Microsoft Excel. Для получения дополнительных сведений обратитесь к документации или справочной системе базы данных.

Импорт текстовых файлов в базу данных Если допускается импорт текстовых файлов в базу данных, можно передать таблицу результатов в Microsoft Excel, сохранить ее как текстовый файл, а затем импортировать этот файл в таблицу с помощью команд базы данных. Для получения дополнительных сведений о преобразовании текстовых данных обратитесь к справочной системе Microsoft Excel.


Не удается найти или удалить источник данных.

Источники данных, созданные более ранними версиями Microsoft Query Источники данных, созданные при помощи более ранних версий Microsoft Query, чем Microsoft Query 97, помечены знаком звездочкой после имени источника данных. Все источники данных, включая созданные с помощью Microsoft Query версии 2000 или более поздних, хранятся в файлах с расширением.dsn. Для вывода списка источников данных, созданных более ранними версиями Microsoft Query, нажмите кнопку Параметры в диалоговом окне Выбор источника данных (меню Файл, команда Создать запрос), а затем установите флажок Источники из реестра в список доступных баз данных. Если источники данных хранятся в стандартной папке, можно выбрать их в диалоговом окне Выбор источника данных и нажать кнопку Удалить.

Расположение файлов источников данных Файлы источников данных из предыдущих версий Microsoft Query обычно хранятся в подпапке источников данных ODBC каталога «Common Files». Файлы источников данных для Microsoft Query версии 2000 и более поздних хранятся в папке профиля пользователя в каталоге «Application Data\Microsoft\Queries». Для просмотра папок, в которых хранятся файлы источников данных, нажмите кнопку Создать запрос Значок кнопки, откройте вкладку Базы данных и нажмите кнопку Параметры.

Поиск и удаление файлов источников данных Для поиска и удаления файлов источников данных можно выполнить следующие действия.

  • Воспользуйтесь панелью управления Windows Если все источники данных находятся в папке «Common Files\ODBC Datasources» или в папке профиля пользователя, дважды щелкните значок Источники данных ODBC (32) на панели управления, а в системах Microsoft Windows 2000 дважды щелкните значок Администрирование, а затем дважды щелкните значок Источники данных (ODBC). Откройте вкладку Файловый DSN и удалите ненужные файлы.dsn, нажав кнопку Удалить.
  • Найдите файлы.dsn Если файлы источников данных находятся в нескольких папках Microsoft Windows, найдите файлы с расширением.dsn с помощью команды Microsoft Windows Поиск, а затем удалите ненужные.


Не удается изменить запрос

Убедитесь, что изменение разрешено В меню Правка выберите команду Параметры и снимите флажок Запретить изменение результатов запроса.


Не удается найти нужную таблицу

Если список таблиц не содержит нужных таблиц, в зависимости от доступных для источника данных параметров, проверьте следующие свойства.

  • Проверьте владельца Таблицы могут принадлежать другому владельцу. В диалоговом окне Добавление таблиц выберите другого пользователя в поле Владелец. Перед использованием таблиц может потребоваться разрешение их владельца.
  • Проверьте типы отображаемых таблиц Нужные таблицы могут иметь тип, не выбранный для отображения. В диалоговом окне Добавление таблиц нажмите кнопку Параметры. Убедитесь, что в группе Показать выбраны все типы таблиц.
  • Обновите список таблиц Нужные таблицы могли быть добавлены в базу данных за время, прошедшее после подключения к ней Microsoft Query. Чтобы просмотреть список недавно добавленных таблиц, нажмите кнопку Параметры в диалоговом окне Добавление таблиц, а затем нажмите кнопку Обновить.


Не удается создать новый источник данных

Проверьте драйвер Прежде всего необходимо проверить, имеется ли для источника данных соответствующий драйвер ODBC или драйвер источника данных. Драйверы ODBC и источников данных обеспечивают гибкость Microsoft Query при подключении к новым базам данных, которые становятся доступными после установки новых драйверов. Однако следует убедиться, что для используемого типа базы данных установлен и настроен соответствующий драйвер.

Убедитесь, что драйвер работает с Microsoft Query В дополнение к драйверам, входящим в Microsoft Query, могут использоваться драйверы ODBC и источников данных сторонних производителей. Перед использованием такого драйвера желательно убедиться, что этот драйвер был протестирован производителем с данной версией Microsoft Query. Для некоторых баз данных лучше всего подходят драйверы, поставляемые вместе с программным обеспечением базы данных. Обратитесь к администратору базы данных для получения сведений о доступных драйверах, наиболее подходящих для работе с этой базой данных. Просмотрите список драйверов, входящих в Microsoft Query.

Проверьте адрес сервера и сведения для подключения Перед настройкой источника данных убедитесь, что известен адрес базы данных в сети, а также имеются необходимые разрешения на подключение к базе данных и вход в систему. Получите у администратора базы данных имя для входа, пароль и необходимые разрешения, а также убедитесь, что предоставленный доступ позволяет правильно осуществить подключение.

Убедитесь в правильности установки драйвера Для вывода списка доступных драйверов ODBC, нажмите кнопку Создать запрос Значок кнопки, дважды щелкните значение Новый источник данных на вкладке Базы данных или Кубы OLAP, введите имя на первом шаге в диалоговом окне Создание нового источника данных и выберите драйвер из списка на втором шаге. Если вкладка Кубы ОLAP недоступна, запустите Microsoft Query из Microsoft Excel, выбрав в меню Microsoft Excel Данные пункт Импорт внешних данных и команду Создать запрос. Дважды щелкните значение Новый источник данных на вкладке Кубы OLAP, а затем введите имя на первом шаге в диалоговом окне Создание нового источника данных и выберите драйвер из списка на втором шаге. Если нужный драйвер не отображается, убедитесь в правильности установки драйвера. См. способы установки драйверов.

Убедитесь, что указаны все сведения о конфигурации. После установки драйвера и его выбора на втором шаге в диалоговом окне Создание нового источника данных необходимо предоставить все необходимые сведения о конфигурации драйвера на третьем шаге. Для получения сведений о драйверах, разработанных корпорацией Майкрософт, нажмите кнопку Связь, а затем — кнопку Справка в диалоговом окне настройки драйвера. Для получения сведений о драйверах сторонних производителей обратитесь к справочной системе или документации по драйверу.

Если устанавливается источник данных с драйвером ODBC или драйвером источника данных, поставляемым корпорацией Майкрософт, для получения сведений о параметрах, которые необходимо установить на третьем шаге диалогового окна Создание нового источника данных, щелкните название драйвера.

Примечание. Доступ в Microsoft Query к источникам данных, созданным с помощью мастера подключения данных, невозможен.

Драйверы ODBC

Драйвер Microsoft Access

Драйвер Microsoft dBASE

Драйвер Microsoft Visual FoxPro

Драйвер Microsoft Excel

Драйвер Microsoft ODBC для Oracle

Драйвер Microsoft Paradox

Текстовый драйвер Microsoft

Драйвер Microsoft SQL Server

Драйвер источника данных

Драйвер служб Microsoft SQL Server OLAP


При объединении не возвращаются ожидаемые записи

В запросе по умолчанию используются внутренние объединения По умолчанию в Microsoft Query при объединении таблиц автоматически используется внутреннее объединение (вариант 1 в диалоговом окне Объединения). При внутреннем объединении двух таблиц записи из второй таблицы, не соответствующие записям из первой, не включаются в таблицу результатов.

Создайте внешнее объединение Для извлечения всех записей из обеих таблиц, если в одной из них содержатся записи, отсутствующие в другой, необходимо использовать внешнее объединение (варианты 2 и 3 в диалоговом окне Объединения). Для получения сведений об использовании внешних объединений записей нажмите кнопку Значок кнопки .

Проверьте множественные объединения одних таблиц Внешнее объединение двух таблиц иногда не возвращает записей из второй таблицы. Если добавить внутреннее объединение этих таблиц, Microsoft Query не загрузит записей из обеих таблиц. Чтобы отобразить записи, необходимо удалить одно из объединений.

Сведения об объединениях Для получения дополнительных сведений об объединениях нажмите кнопку Значок кнопки .


Microsoft Query не возвращает все доступные записи

Убедитесь в отсутствии ограничения на число возвращаемых записей Убедитесь, что ограничение на число возвращаемых записей не установлено. В меню Правка выберите команду Параметры и убедитесь, что флажок Максимальное число возвращаемых записей в группе Параметры не установлен.

Проверьте условия Убедитесь, что все заданные условия введены правильно для извлечения нужных данных. Для получения дополнительных сведений о задании условий нажмите кнопку Значок кнопки .

Проверьте объединения Убедитесь, что все созданные объединения дают нужные результаты. Для получения дополнительных сведений об объединениях нажмите кнопку Значок кнопки .


Попытки подключения к базе данных часто оказываются безуспешными.

Установите более долгое время для подключения По умолчанию Microsoft Query пытается подключиться к базе данных в течение интервала времени, определенного драйвером ODBC для источника данных. Если подключение к базе данных требует больше времени, можно установить более длинный интервал. Выберите в меню Microsoft Query Правка команду Параметры и убедитесь, что флажок Разрывать связь при отсутствии активности через, а затем задайте время в секундах, в течение которого должно производиться подключение.

Снимите ограничение на время подключения Чтобы отключить ограничение на период времени, в течение которого должно произойти подключение, снимите флажок Разрывать связь при отсутствии активности через. Если Microsoft Query не может подключиться к базе данных, то можно отменить подключение, нажав клавишу ESC.


Невозможен доступ в Microsoft Query к данным списка Microsoft Excel.

Закройте книгу Прежде чем пытаться получить доступ к данным, убедитесь, что книга не открыта в Microsoft Excel.

Проверьте лист На листе Microsoft Excel проверьте следующие параметры.

  • Проверьте формат списка Убедитесь, что список соответствует формату списка Microsoft Excel. Для получения дополнительных сведений о создании списка на листе книги обратитесь к справочной системе Microsoft Excel. Присвойте имена диапазонам, представленным в виде таблиц, а также убедитесь, что имена диапазонов не совпадают.
  • Присвойте имя списку Microsoft Query распознает как таблицы только именованные диапазоны. Чтобы присвоить имя списку, выделите весь список в Microsoft Excel и введите его имя в поле Имя на панели формул.
  • Доступ к списку не должен осуществляться как к системной таблице Не пытайтесь получить доступ к таблицам Microsoft Excel, установив параметр Системные таблицы в группе Показать диалогового окна Параметры таблицы. При использовании такого способа пустые ячейки листа могут быть восприняты Microsoft Query как данные, некоторые фактические данные могут не быть распознаны, а некоторые данные могут быть неправильно извлечены.
  • Форматируйте списки для объединения данных одинаково Используйте один и тот же формат для столбцов всех списков, которые нужно объединить. Например, если в каждом списке содержится столбец дат, форматируйте все эти столбцы одинаково. При использовании текстовых и числовых форматов внутри столбца драйвер для Microsoft Excel не сможет найти и объединить все данные.
  • Не используйте такие имена столбцов, как «Таблица» или «База данных» Microsoft Query использует некоторые подписи для служебных целей и не распознает их при использовании в данных.
  • Переместите все книги в одну папку Источник данных, определенный для драйвера Microsoft Excel, может одновременно обеспечить доступ только к книгам из одной папки. Если списки находятся в разных книгах, убедитесь, что книги находятся в папке, указанной при определении источника данных.
  • Переместите книги в папку, ожидаемую источником данных Перед загрузкой Microsoft Query скопируйте все необходимые книги в указанную в источнике данных папку. Microsoft Query не распознает автоматически новые книги, добавленные в папку при создании запроса. Для получения доступа к новым книгам нажмите кнопку Параметры в диалоговом окне Добавление таблиц, а затем нажмите кнопку Обновить.

Используйте Excel для объединения данных Microsoft Query может использоваться для объединения данных из двух и более списков Microsoft Excel. При работе с данными одного листа или использовании простых условий для выбора строк из одного листа удобнее использовать команды Microsoft Excel Автофильтр и Расширенный фильтр (меню Данные, подменю Фильтр). Для получения дополнительных сведений о командах Автофильтр и Расширенный фильтр обратитесь к справочной системе Microsoft Excel.


Не удается изменить типы параметров процедуры SQL в Microsoft Query

Чтобы создать параметры сохраняемой процедуры SQL и задать типы данных, выполните следующие действия.

  1. Выберите команду Выполнить запрос SQL в меню Файл.
  2. Создайте запрос с использованием фиксированных аргументов процедуры в поле Инструкция SQL, а затем нажмите кнопку Сохранить.
  3. В меню Вид выберите команду Запрос SQL.
  4. В поле Инструкция SQL замените каждый фиксированный аргумент вопросительным знаком (?).
  5. Нажмите кнопку OK, а затем выберите в меню Вид команду Параметры.
  6. Чтобы изменить тип данных параметра, выберите его и нажмите кнопку Изменить.


Не удается создать почтовые наклейки в Microsoft Query

Microsoft Query извлекает данные почтовых наклеек Microsoft Query является средством загрузки данных из базы данных, ив котором создание почтовых наклеек невозможно. Однако данные из Microsoft Query могут быть переданы в Microsoft Excel или Microsoft Word для создания почтовых наклеек.

Создайте почтовую наклейку в Microsoft Word Сначала передайте данные в Microsoft Excel, выбрав в меню Файл команду Вернуть данные в Microsoft Excel. После передачи таблицы результатов в Microsoft Excel эти данные могут быть использованы в качестве почтового списка в Microsoft Word. Для получения дополнительных сведений о почтовых наклейках обратитесь к справочной системе Microsoft Excel или Microsoft Word.


Не удается вывести на печать таблицу результатов в Microsoft Query

Возможность печати в Microsoft Query отсутствует Microsoft Query является средством извлечения данных из базы данных и не может использоваться для печати отчетов.

Напечатайте записи из Microsoft Excel Чтобы напечатать таблицу результатов, передайте ее в Microsoft Excel, выбрав в меню Файл команду Вернуть данные в Microsoft Excel. После передачи таблицы результатов в Microsoft Excel можно использовать все команды форматирования и печати Microsoft Excel. Для получения дополнительных сведений о печати в Microsoft Excel обратитесь к справочной системе Microsoft Excel.


Microsoft Query продолжает использовать ресурсы связи после завершения работы с базой данных

Каналы связи остаются открытыми на протяжении всего сеанса работы Microsoft Query По умолчанию, Microsoft Query открывает один канал связи с базой данных, который не закрывается до выхода из Microsoft Query, независимо от того, сколько окон запросов к базе данных открыто на протяжении этого времени. При создании запросов к нескольким базам данных во время работы с Microsoft Query открытые подключения загружают ресурсы и увеличивают время связи.

Закрывайте каналы связи при закрытии окон запросов Для сокращения времени связи Microsoft Query может закрыть подключение при отсутствии открытого окна запроса к базе данных. Чтобы канал связи был открыт только при наличии открытого окна запроса, выберите команду Параметры в меню Правка, а затем снимите флажок Поддерживать открытые каналы связи до закрытия MS Query.


Почему рядом с именем источника данных отображается звездочка?

Источник данных создан в более ранней версии Microsoft Query Формат источников данных Microsoft Query 97 и более поздних версий отличается от формата источников данных, созданных в более ранних версиях Microsoft Query. Источники данных и запросы, созданные в Microsoft версиях Query более ранних, чем Microsoft Query 97, могут выполняться в Microsoft Query 2000, однако совместный доступ нескольких пользователей к запросам, создаваемых с помощью этих источников данных, невозможен. В версиях Microsoft Query более ранних, чем Microsoft Query 97, сведения об источниках данных хранятся в качестве компонента операционной системы Microsoft Windows, и эти сведения доступны только на локальном компьютере.

Определите источники данных, не поддерживающие совместный доступ Чтобы использовать источники данных, созданные более ранними версиями Microsoft Query, нажмите кнопку Параметры в диалоговом окне Выбор источника данных (меню Файл, команда Создать запрос) и установите флажок Источники из реестра в список доступных баз данных. Все источники данных, созданные более ранними версиями Microsoft Query, чем Microsoft Query 97, в диалоговом окне Выбор источника данных будут помечены звездочкой.

Создайте источники данных для совместного использования Если требуется организовать совместный доступ к запросам или шаблонам отчетов, использующим данные из внешних баз данных, указанных в источниках данных, не поддерживающих совместный доступ, создайте новые источники данных для этих баз данных, и используйте их данных для создания запросов, файлов запросов и шаблонов отчетов.

Удалите старые источники данных См. сведения об удалении источников данных, не поддерживающих совместный доступ.


Не удается изменить куб OLAP

Убедитесь в доступности исходной базы данных Для изменения куба OLAP необходимо иметь доступ к исходной серверной базе данных, которая содержит данные куба. Проверьте расположение базы данных, чтобы убедиться, что она не переименована или перемещена. Убедитесь в доступности сервера и возможности подключения к нему.

Проверьте изменения исходной базы данных Таблицы в базе данных могут быть изменены или переименованы, поэтому исходные данные для куба перестали быть доступными. Проверьте наличие изменений в организации или структуре базы данных. Для этого можно открыть уже существующий запрос к базе данных или создать новый запрос. В меню Таблица нажмите кнопку Добавить таблицу, чтобы просмотреть доступные таблицы. Если открытие существующего запроса или создание нового невозможно, обратитесь к администратору базы данных для получения дополнительных сведений о ее изменении.


Сообщение о невозможности открытия OQY-файла мастером создания куба OLAP

Убедитесь, что файл исходно создан с помощью мастера Открытие и изменение файлов.oqy возможно, только если они созданы и сохранены с помощью мастера куба OLAP. Мастер не может использоваться для открытия или изменения других файлов.oqy, не содержащих описания куба, например подключенных к серверной базе данных OLAP или к файлу автономного куба.

Повторно создайте файл.oqy Если не удается открыть файл.oqy, был созданный мастером куба OLAP, возможно, этот файл поврежден. Попробуйте открыть резервную копию файла или повторно создайте куб, если резервная копия файла отсутствует.


Поскольку база данных доступна только для чтения, создание или удаление таблиц невозможно. Продолжить?

В базе данных, доступной только для чтения, возможен просмотр описания таблицы, но не создание новых или удаление существующих таблиц.


Нет доступа к записи: другой пользователь внес изменения или столбцов задано недостаточно.

Microsoft Query не может найти запись таблицы, совпадающую с удаленной или измененной в запросе записью. Запрос может содержать число столбцов, недостаточное для того, чтобы выделить запись, которую требуется обновить. С момента последнего запроса запись также могла быть изменена другим пользователем. Перед обновлением записи выполните одно из следующих действий:

  • Добавьте в запрос большее число столбцов или столбец, который единственным образом описывает запись.
  • Для получения последних данных из таблицы повторно выполните запрос, выбрав в меню Записи команду Выполнить запрос.


Существуют удаленные связи; закрыть?

С данными запроса установлена связь из других приложений, например Microsoft Excel или Microsoft Word.

  • Чтобы закрыть запрос и прервать связь, нажмите кнопку OK. После закрытия запроса связь не может быть восстановлена.
  • Чтобы оставить открытым запрос и не прерывать связь, нажмите кнопку Отмена.


Сохранить большое содержимое буфера обмена из <имя>?

В буфер обмена помещен большой объем данных.

  • Чтобы сохранить данные из буфера обмена и закрыть запрос или выйти из Microsoft Query, нажмите кнопку Да.
  • Чтобы удалить данные и закрыть запрос или выйти из Microsoft Query, нажмите кнопку Нет.
  • Чтобы продолжить работу в Microsoft Query с данными в буфере обмена, нажмите кнопку Отмена.


Не удается продолжить работу с Microsoft Query

Некоторые сведения в этом разделе могут быть неприменимы к отдельным языкам.

При отображении некоторых видов сообщений (помощником или без его помощи) продолжение работы с Microsoft Query может быть невозможно до тех пор, пока окно сообщения не будет закрыто. Это важные сообщения, для которых необходим ответ пользователя.

Выберите нужный вариант в окне сообщения. После закрытия окна сообщения можно продолжать работу в Microsoft Query. Если сообщение больше не отображается, а выводится раздел справки, щелкните любое место окна запроса, чтобы снова вывести сообщение.


Сохранить изменения в запросе <имя>?

С момента последнего сохранения в структуру или форматирование запроса были внесены изменения.

  • Чтобы сохранить изменения и закрыть запрос, нажмите кнопку Да.
  • Чтобы отменить изменения и закрыть запрос, нажмите кнопку Нет.
  • Чтобы оставить запрос открытым без сохранения изменений, нажмите кнопку Отмена.


Инструкция SQL выполнена. Обработано строк: <число>.

Указанная инструкция SQL выполнена Microsoft Query. При этом обработано указанное число строк (записей).


Выполнить запрос SQL не удалось.

Microsoft Query не может выполнить инструкцию SQL. Убедитесь, что инструкция введена корректно.


Таблица <имя> уже существует; заменить?

Таблица с указанным именем уже существует.

  • Чтобы заменить существующую таблицу новой, нажмите кнопку Да.
  • Для отмены нажмите кнопку Нет, а затем введите другое имя для новой таблицы.


Сохранить файл как <имя>.

Попытка сохранить таблицу результатов с неверно указанным или отсутствующим расширением.

  • Чтобы сохранить таблицу результатов в файле с верным расширением источника данных, нажмите кнопку OK.
  • Чтобы вернуться в Microsoft Query без сохранения таблицы результатов, нажмите кнопку Отмена.


Другое приложение закончило работу.

Другая программа-участник сеанса динамического обмена данными (DDE) неожиданно прервала работу. Перезапустите эту программу перед началом нового сеанса DDE.


Запрос SQL не может быть представлен графически. Продолжить?

Microsoft Query не может вывести область таблиц для этого запроса. Если запрос возвращает записи, изменение этих записей или структуры запроса в окне запроса невозможно. Однако, можно изменить структуру запроса, выбрав в меню Вид команду Запрос SQL и непосредственно изменив инструкции SQL.


Истек период ожидания отклика DDE.

Второй участник сеанса динамического обмена данными (DDE) не ответил на запрос в течение времени, определяемого параметром Время ожидания DDE.

  • Другая программа может ожидать ввода данных пользователем. Переключитесь в эту программу и закройте диалоговое окно или ответьте на сообщение, выданное другой программой.
  • Другая программа может быть слишком занята, чтобы ответить на сообщение DDE.

Примечание. Параметр Время ожидания DDE не может быть изменен.


Не требовалось <текст> после списка столбцов в инструкции GROUP BY.

Неверное выражение после списка столбцов в операторе GROUP BY.


Не требовалось <текст> после инструкции HAVING.

Неверное выражение после оператора HAVING в инструкции SQL.


Не требовалось <текст> после списка столбцов в инструкции ORDER BY.

Неверное выражение после оператора ORDER BY в инструкции SQL.


Не требовалось <текст> после списка в инструкции SELECT.

Неверное выражение после списка отбора оператора SELECT.


Не требовалось <текст> после оператора WHERE.

Неверное выражение после оператора WHERE в инструкции SQL.


Выделено слишком много значений.

Недостаточно памяти для хранения всех значений, заданных в условиях для этого поля. Введите меньшее число значений.


Неизвестная единица измерения

Microsoft Query не может распознать знаки, введенные при задании данного параметра. Введите число единиц измерения, не включая описатели типа, например «"» (двойная кавычка), «in» (дюймы), или «см» (сантиметры).


Обновление не выполнено. Продолжить изменение записи?

Microsoft Query не может обновить измененные данные, поскольку таблица или источник данных доступны только для чтения, таблица повреждена или для сохранения изменений недостаточно места на диске.


<Значение> - слишком много знаков после десятичного разделителя.

Количество десятичных позиций, расположенных справа от десятичной запятой превышает максимально допустимое значение для данного поля. Задайте число с меньшим количеством цифр после запятой.


<Значение> - не является логическим значением.

В поле, допускающем ввод только логических значений, введено значение другого типа. Например, в поле, допускающем только ввод значений «0» или «1», введена дата.


<Значение> - не является правильной датой.

В поле введено значение недопустимого типа. Например, введен текст в поле, допускающем только ввод дат.


<Значение> - не является правильным числом.

В поле введено значение недопустимого типа. Например, введен текст в числовом поле.


<Значение> превышает числовой диапазон столбца.

Значение превышает максимально допустимое для значений столбца (поля). Введите меньшее значение.


Существующая таблица не может быть изменена. Изменения могут быть использованы для создания новой таблицы.

Чтобы создать новую таблицу из существующей, необходимо изменить имя таблицы в диалоговом окне Просмотр определения таблицы. Новая таблица не будет содержать данных из существующей таблицы. Описания существующих таблиц не могут быть изменены в Microsoft Query.


Ошибочное расширение <расширение>.

Расширение файла таблицы базы данных задано неверно. Чтобы узнать правильное расширение файла, обратитесь к документации на источник данных.


Выражение слишком сложное.

Выражение слишком сложное для анализа. Попытайтесь упростить выражение.


Синтаксическая ошибка.

В выражении содержится синтаксическая ошибка. Например, не введен требуемый оператор, введен неверный знак или запятая, или введен текст, не заключенный в кавычки ( " или " ). Проверьте правильность задания выражения.


Синтаксическая ошибка в дате.

Выражение содержит неверное значение даты. Проверьте правильность задания выражения.


Недопустимое использование '.', '!' или '()'.

Выражение содержит неверные операторы «.» (точка), «!» (восклицательный знак) или скобки. Например, введен неверный идентификатор или скобка после константы «Null». Проверьте правильность задания выражения.


Синтаксическая ошибка в числе.

Выражение содержит неверное число. Проверьте правильность задания выражения.


Синтаксическая ошибка в строке.

Выражение содержит неверную строку. Например, могла быть превышена максимальная длина строки. Проверьте правильность задания выражения.


Оператор "Между" без "и".

При использовании оператора Между...и необходимо ввести зарезервированное слово и. Используйте следующий синтаксис:

выражение Между значение1 и значение2


Лишняя ')'.

Выражение содержит слишком много закрывающих скобок. Удалите все скобки, не имеющих соответствующих им открывающих скобок.


Не хватает памяти при вычислении.

Недостаточно памяти для выполнения расчетов.

Закройте окна в Microsoft Query или другие приложения. При повторном возникновении ошибки перезапустите Microsoft Windows и повторите вычисление.


Отсутствует ')', ']' или '|'.

В выражении не хватает закрывающей скобки, квадратной скобки или вертикальной черты. Проверьте правильность задания выражения.