Веб-таблица данных Access

Веб-таблица данных Access обеспечивает среду, аналогичную Excel, позволяющую просматривать и изменять данные. В ней содержимое списка или библиотеки документов отображается в формате строк и столбцов. Элементы и столбцы списка отображаются как строки и столбцы в веб-таблице данных Access. Можно добавлять и изменять строки и столбцы, применять фильтры и сортировку, отображать вычисляемые значения и итоги, а также выполнять другие действия.

На следующем рисунке показан список «Сотрудники» в веб-таблице данных Access.

Список сотрудников в представлении таблицы данных

Выноска 1 Строка соответствует элементу списка.

Выноска 2 Столбец соответствует полю списка.

Выноска 3 Стрелка раскрывающегося списка в заголовке столбца используется для фильтрации и сортировки данных.

Выноска 4 Строка итогов используется для отображения статистических значений для каждого столбца.

Просмотр списка в веб-таблице данных Access

В веб-таблице данных Access можно просмотреть большую часть типов списков. Это можно сделать двумя способами:

  • Список открывается в стандартном представлении, а затем происходит переключение в представление таблицы данных с помощью команды Изменить в таблице данных в меню Действие

    Примечание. Если стандартное представление не поддерживает изменение в представлении таблицы данных, команда Изменить в таблице данных будет недоступна в меню Действие. Например, в представлении проводника библиотеки документов редактирование в представлении таблицы данных не поддерживается.

  • Создание представления таблицы данных. Представление таблицы данных для списка можно сделать представлением по умолчанию.

Представление таблицы данных является независимым от всех других представлений списка. Если в стандартном представлении добавляется или удаляется столбец, эти изменения не влияют на представление таблицы данных.

Следующие типы списков не поддерживают представление таблицы данных:

  • доска обсуждений;
  • опрос;
  • галерея рисунков;
  • библиотека веб-шаблонов;
  • каталог веб-частей;
  • источники данных;
  • входящие.

Части списка в веб-таблице данных Access

Строки В веб-таблице данных Access содержится одна или несколько строк. В каждой строке сохраняется информация об одном элементе списка. Например, в строке списка «Сотрудники» сохраняются сведения о сотруднике.

Для добавления строки следует выполнить прокрутку до конца списка и ввести данные в строку со звездочкой (*). Допускается также изменение и удаление строк. Изменения отправляются на сервер после выхода из строки и заносятся в асинхронном режиме. Пользователь может изменять другие строки, а представление будет заносить изменения в фоновом режиме. Если изменения приводят к конфликту или ошибке, в представлении будет выводиться информация, необходимая для устранения конфликта или ошибки.

Можно изменить высоту строки, порядок сортировки по одному или нескольким столбцам, а также скрыть строки с помощью фильтров.

Столбцы. Представление содержит один или несколько столбцов. В каждом столбце сохраняется информация определенного типа о всех элементах списка. Например, в столбце «Имя» списка «Сотрудники» сохраняются имена сотрудников.

Добавить столбец в список можно в представлении таблицы данных и в стандартном представлении. Для столбца необходимо указать имя и определенный тип данных. Столбец можно пометить как обязательный и запретить пользователям пропускать столбец при вводе данных. Можно также задать дополнительные параметры столбца, такие как значение по умолчанию и максимальная ширина. Дополнительные сведения о добавлении столбцов в список см. в справке Службы Microsoft Windows SharePoint Services 3.0. Чтобы открыть справку Службы Windows SharePoint Services 3.0, нажмите кнопку Справка на панели инструментов страницы.

Допускается изменение существующих столбцов или удаление столбцов. Вид списка можно изменять, скрывая или отображая столбцы, изменяя их порядок, настраивая ширину и применяя фильтры или сортировку по столбцам. Можно также добавлять в список вычисляемые столбцы.

Меню «Действие» В меню Действие в верхней части представления отображаются команды для выполнения распространенных задач в представлении «Таблица данных», например, отображение области задач или добавление новой строки. В меню Действие отображаются различные команды для разных типов списков.

Строка состояния В строке состояния в нижней части представления отображаются полезные сведения, например:

  • сообщения об ошибках или предупреждения;
  • сведения, характерные для текущего выделения, например «Только для чтения»;
  • состояние связи с сервером.

Область задач. Область задач обеспечивает удобный доступ к определенным действиям, соответствующим текущему контексту, без выхода из представления таблицы данных.

На следующем рисунке показана область задач для простого списка:

Выноска 1 В верхней части области задач находится панель инструментов. На ней отображаются кнопки для часто выполняемых команд, таких как Вырезать, Копировать, Вставить, Сортировка и Справка.

Выноска 2 Щелчок в этой области приводит к отображению или скрытию области задач. Для изменения размеров области задач можно перетащить границу.

Выноска 3 Для прокрутки области по вертикали следует навести указатель на полосу прокрутки.

Выноска 4 Во внутренней части области задач отображаются различные команды.

Требования к программному обеспечению для работы с веб-таблицей данных Access

Для того чтобы просматривать список в веб-таблице данных Access, компьютер должен отвечать определенным требованиям к программному обеспечению.


Требования к программному обеспечению для работы веб-таблиц Access

Чтобы список можно было открыть в веб-таблице Access, должны выполняться следующие требования:

  • На компьютере должен быть установлен пакет Система Microsoft Office 2007 или более поздней версии.
  • На компьютере должен быть установлен компонент веб-таблиц Microsoft Office Access, включенный в Выпуск Office 2007.

    Примечание. Этот компонент устанавливается по умолчанию при установке Выпуск Office 2007.

  • Список следует открывать с помощью Microsoft Internet Explorer 5.01 с пакетом обновления SP2 или более поздней версии.
  • Параметры безопасности обозревателя должны разрешать использование элементов Microsoft ActiveX.
Если одно или более из приведенных выше требований не выполнено, выводится сообщение о том, что список будет отображаться в стандартном представлении. Перед тем, как список будет отображен таким образом, к стандартному представлению будут применены параметры, заданные для режима таблицы, такие как порядок столбцов, сортировка, фильтрация и параметры строки итогов. Однако такие параметры, как высота строк, ширина столбцов и скрытые столбцы, будут игнорированы.

Обратите внимание, что даже если выполнены не все перечисленные выше требования, в режиме таблицы можно вносить изменения. Изменения будут сохранены, а эффект от их применения можно будет увидеть, если воспользоваться компьютером, удовлетворяющим всем требованиям к программному обеспечению.


Отображение сведений о программе

В диалоговом окне О программе можно просмотреть версию компонента веб-доступа к таблицам данных Microsoft Office, установленного на компьютере, идентификатор продукта, системную информацию и других, связанных с этими данными, сведений.

  • Щелкните правой кнопкой мыши верхний левый угол списка и выберите пункт О программе.


Получение справки в веб-таблице Access

  • Чтобы получить справку о веб-таблице Access, щелкните правой кнопкой мыши ячейку в этом представлении и щелкните ссылку Справка.

    Важно. Разделы справки включают описание только тех функциональных возможностей, которые доступны в представлении таблицы данных. Чтобы получить общую справку о списках SharePoint, щелкните ссылку Справка на панели инструментов.

  • Чтобы получить справку о странице SharePoint, содержащей представление таблицы данных, щелкните ссылку Справка на панели инструментов в верхней части страницы.
  • Чтобы получить справку при отображении веб-части представления списка в представлении таблицы данных, щелкните ссылку Справка в меню веб-части. Разделы справки описывают страницы, свойства и соединения веб-частей.

Примечания

  • Некоторые диалоговые окна и текст строки состояния содержат ссылки на данные контекстной справки. Кроме того, можно щелкнуть ссылку Справка ( Значок справки) на панели инструментов в области задач.
  • Если работа ведется в режиме таблицы, при нажатии клавиши F1 выводится справка о режиме таблицы. В противном случае выведится справка по Internet Explorer.


Устранение неполадок веб-доступа к таблицам данных Access

Невозможно открыть список в веб-таблице данных Access, либо он открывается в стандартном представлении

Это могло произойти по одной из следующих причин.

  • Компьютер не удовлетворяет требованиям к программному обеспечению для отображения веб-таблицы данных Access.
  • Список или текущее представление (например, список коллекции рисунков или проводник библиотеки документов) не поддерживает режим таблицы, в меню Действия не отображается команда Изменить в таблице данных.
  • Ошибка при попытке получить сведения о структуре списка или описании представления. Попробуйте обновить представление.

Данные в представлении не отображаются или отображаются не полностью

Отсутствие данных в представлении может быть следствием занятости или недоступности сервера или по причине возникновения другой ошибки. Закройте список и повторите попытку позднее.

В представлении могут не отображаться некоторые строки или столбцы. Это происходит по одной или нескольким из следующих причин.

  • Применен фильтр либо он входит в описание представления.

    Чтобы проверить представление на существование в нем фильтров, убедитесь, что стрелка раскрывающегося меню в заголовке столбца отображается стандартным образом. Если к столбцу применен фильтр, стрелка отображается другим цветом. Разница в цвете может быть трудноразличима на некоторых мониторах.

    Чтобы проверить, указан ли фильтр в описании представления, щелкните поле Представление на панели инструментов, а затем выберите команду Изменить это представление. На странице Изменение представления проверьте раздел Фильтр .

  • Столбец скрыт, или он не включен в описание представления.

    Чтобы отобразить все скрытые столбцы, щелкните верхнюю левую ячейку в представлении правой кнопкой мыши и выберите команду Отобразить.

    Чтобы проверить, включен ли столбец в представление, щелкните поле Представление на панели инструментов, а затем выберите команду Изменить это представление. На странице Изменение представления загляните в раздел Столбцы. В случае если флажок Отобразить не установлен, установите его, чтобы включить столбец в представление.

  • Необходимо утверждение содержимого списка, либо в списке содержатся элементы, ожидающие утверждения, или те, которые были отклонены.

    Чтобы проверить состояние утверждения элементов, выберите «Мои отправленные данные» в раскрывающемся списке «Представление» и просмотрите содержание столбцов «Состояние утверждения» и «Заметки». Если какой-либо элемент был отклонен, отредактируйте его. После этого элемент будет помечен как ожидающий утверждения и будет заново отправлен на утверждение.

Получено сообщение «Список/Представление не существует.»

Не существует список или представление таблицы данных. Возможно, они были удалены другим пользователем. Проверьте, существует ли список или представление, а затем повторите попытку.

Получено сообщение «У вас нет разрешений.»

Это могло произойти по одной из следующих причин.

  • Отсутствуют разрешения на внесение изменений.
  • Запрещено добавление содержимого на узел.
  • Превышен объем дискового пространства для узла.
Чтобы избежать этих ошибок, свяжитесь с администратором системы.

Получено сообщение «Невозможно отобразить или вставить вложения.»

На сервере возникла ошибка. Попробуйте добавить или просмотреть вложение позже.

Получено сообщение «Не удалось обновить список.»

На сервере возникла ошибка, и представление невозможно обновить. Нажмите кнопку Да, чтобы повторить попытку. При повторном возникновении ошибки нажмите кнопку Нет и повторите попытку позже.

Получено сообщение «Обязательные поля отсутствуют в представлении.»

В представлении отсутствует один или более обязательных столбцов. Перед отправкой на сервер в строках обязательных столбцов должны присутствовать данные.

Если в представлении отсутствуют обязательные столбцы, невозможно выполнить следующие действия:

  • Добавить новые строки.
  • Изменить строку, если в обязательных столбцах находятся пустые значения.

    Примечание. В обязательном столбце не могут содержаться пустые значения. Однако если столбец не был помечен в качестве обязательного, а впоследствии для него был установлен запрет на наличие пустых значений, он может содержать пустые значения. Поэтому при изменении параметра столбца с Не обязательный на Обязательный отредактируйте список в представлении таблицы данных, чтобы убедиться, что каждая строка столбца не содержит пустое значение.

Чтобы избежать появления этого сообщения, добавьте в представление обязательные поля или свяжитесь с автором списка.

Представление или его часть доступны только для чтения

Это возможно по одной из нескольких причин. Для получения дополнительных сведений щелкните ссылку Только чтение в строке состояния.


Назначение представления Режим таблицы в качестве представления по умолчанию

При первом создании списка новое стандартное представление определяется для него по умолчанию. Список можно просмотреть, выбрав в таблице данных команду Действия и нажав кнопку Изменить в таблице данных. Однако если необходимо установить представление Режим таблицы представлением для списка по умолчанию, создайте сначала новое представление Режим таблицы для списка и затем назначьте его представлением по умолчанию.

Чтобы создать новое представление Режим таблицы для списка и назначить его представлением по умолчанию, выполните следующие действия.
  1. Выберите команду Настройка, а затем нажмите кнопку Создать представление.
  2. На странице Создать представление нажмите кнопку Режим таблицы.
  3. Введите название представления. Можно ввести название «таблица данных» в имя представления, что будет служить напоминанием, что это представление Режим таблицы.
  4. Установите флажок Сделать представлением по умолчанию.
  5. Нажмите кнопку ОК внизу страницы.
Чтобы назначить существующее представление Режим таблицы представлением по умолчанию, выполните следующие действия.
  1. В группе Настройка выберите значение Параметры списка.
  2. В нижней части страницы в группе Режимы выберите имя представления, которое будет представлением по умолчанию.
  3. На странице Изменение таблицы данных в разделе Имя установите флажок Сделать представлением по умолчанию.

    Примечание. Флажок не отображается, если это представление уже является представлением по умолчанию или личным представлением.


Отображение, скрытие и изменение размера области задач

  • Чтобы отобразить или скрыть область задач, нажмите кнопку Действия на панели инструментов, а затем выберите пункт Область задач.
  • Чтобы изменить размер области задач, поместите курсор на вертикальную полосу, служащую для отображения и скрытия области задач, которая находится в ее левой части, а затем, когда курсор примет вид курсора изменения размеров, перетащите его влево или вправо.


Сочетания клавиш

Чтобы ускорить доступ к часто используемым командам и операциям, можно пользоваться сочетаниями клавиш. Кроме того, их также можно применять для перемещения к различным частям представления без помощи мыши. Ниже представлены разделы, в которых указаны сочетания клавиш, доступные в веб-таблице данных Access.

Выбор компонентов представления

Выполнение команд

Изменение данных

Форматирование ячейки, поддерживающей форматированный HTML-текст

Сортировка и фильтрация данных

Выбор компонентов представления

Действие | Сочетание клавиш
Перемещение выделения слева направо, затем вниз; если выделено несколько ячеек — перемещение к следующей выделенной ячейке | TAB
Перемещение выделения сверху вниз, затем вправо; если выделено несколько ячеек — перемещение к следующей выделенной ячейке | ВВОД
Перемещение выделения справа налево; при достижении крайней левой ячейки будет выбрана последняя ячейка в предыдущей строке | SHIFT+TAB
Выбор ячейки над текущей ячейкой; при достижении самой верхней ячейки будет выбрана последняя ячейка предыдущего столбца | SHIFT+ВВОД
Циклический переход между списком, областью задач, строкой состояния и элементами управления в окне обозревателя | CTRL+TAB
Циклический переход между списком, областью задач, строкой состояния и элементами управления в окне обозревателя в обратном порядке | CTRL+SHIFT+TAB
Перемещение выделения в направлении, указанном стрелкой | Клавиши со стрелками
Уменьшение или увеличение области выделения в направлении, указанном стрелкой | SHIFT+клавиша со стрелкой
Перемещение выделения к последней ячейке в направлении, указанном стрелкой; если в указанном направлении присутствуют пустые ячейки — перемещение к последней ячейке, которая находится перед первой пустой ячейкой | CTRL+клавиша со стрелкой
Увеличение области выделения в сторону последней ячейки в направлении, указанном стрелкой; если в указанном направлении присутствуют пустые ячейки — увеличение области выделения в сторону последней ячейки, которая находится перед первой пустой ячейкой | CTRL+SHIFT+клавиша со стрелкой
Выбор первой ячейки в текущей строке | Home
Выбор первой ячейки в первой строке | CTRL+Home
Выбор последней ячейки в последней строке | CTRL+End
Увеличение области выделения до начала текущей строки | SHIFT+Home
Увеличение области выделения до конца текущей строки | SHIFT+End
Увеличение области выделения до начала списка | CTRL+SHIFT+Home
Увеличение области выделения до конца столбца | CTRL+SHIFT+End
Выделение всего столбца Удаление форматирования, если текст в ячейке выделен и столбец поддерживает форматирование HTML | CTRL+ПРОБЕЛ
Выделение всей строки | SHIFT+ПРОБЕЛ
Выделение всего списка | CTRL+A
Перемещение к следующей странице списка | PAGE DOWN
Отображение предыдущей страницы списка | PAGE UP
Увеличение выделения вниз на одну страницу | SHIFT+PAGE DOWN
Увеличение выделения вверх на одну страницу | SHIFT+PAGE UP
Перемещение к текущей ячейке | CTRL+BackSpace

К началу страницы

Выполнение команд

Действие | Сочетание клавиш
Отображение контекстного меню для текущего выделения | SHIFT+F10
Выполнение команды контекстного меню, содержащей букву с подчеркиванием | Буква с подчеркиванием в контекстном меню
Отмена изменений, внесенных в строку, если они не были подтверждены Закрытие контекстного меню (если оно отображено) без выполнения команды В режиме изменения: выход из режима и отмена изменений | ESC
Вызов справки представления таблицы данных, если это представление отображено и отключен режим изменения; в противном случае — вызов справки Internet Explorer | F1
Режим изменения | F2
Очистка текущей ячейки | Delete
Отображение области задач | F8
Скрытие области задач | SHIFT+F8
Копирование выделения в буфер обмена | CTRL+C
Вставка содержимого буфера обмена | CTRL+V
Перемещение выделения в буфер обмена | CTRL+X
Отображение диалогового окна Устранение конфликтов и ошибок | F7
Отображение меню присутствия, если ячейка содержит сведения о присутствии | ALT+SHIFT+F10
Закрытие окна обозревателя | ALT+F4

К началу страницы

Изменение данных

Действие | Сочетание клавиш
Отмена изменений, внесенных в текущую ячейку | CTRL+Z
Добавление неразрывного дефиса | CTRL+SHIFT+-
Отображение списка статистических функций, доступных в текущей ячейке в строке итогов; в столбцах с типом данных «Однострочный текст» — отображение списка значений, доступных в этом столбце | ALT+СТРЕЛКА ВНИЗ

К началу страницы

Форматирование ячейки, поддерживающей формат Rich Text (HTML)

Действие | Сочетание клавиш
Перемещение к списку «Шрифт» | CTRL+SHIFT+F
Перемещение к списку «Размер» | CTRL+SHIFT+P
Применение к выделению полужирного начертания | CTRL+B
Применение к выделению подчеркнутого начертания | CTRL+U
Применение к выделению курсивного начертания | CTRL+I
Выравнивание выделения по левому краю | CTRL+L
Выравнивание выделения по центру | CTRL+E
Выравнивание выделения по правому краю | CTRL+R
Добавление маркеров | CTRL+SHIFT+L
Увеличение отступа | CTRL+M
Уменьшение отступа | CTRL+SHIFT+M
Удаление форматирования HTML-текста в текущей ячейке | CTRL+ПРОБЕЛ

К началу страницы

Сортировка и фильтрация данных

Действие | Сочетание клавиш
Отображение раскрывающегося списка фильтров для выделенного столбца | ALT+SHIFT+СТРЕЛКА ВНИЗ
Закрытие раскрывающегося списка фильтров | ALT+SHIFT+СТРЕЛКА ВВЕРХ
Перемещение к предыдущему элементу раскрывающегося списка фильтров (если список открыт) | СТРЕЛКА ВВЕРХ
Перемещение к следующему элементу раскрывающегося списка фильтров (если список открыт) | СТРЕЛКА ВНИЗ
Перемещение к первому элементу раскрывающегося списка фильтров (если список открыт) | HOME
Перемещение к последнему элементу раскрывающегося списка фильтров (если список открыт) | END
Перемещение на одну страницу вверх или вниз в раскрывающемся списке (если список открыт) | Page Up, Page Down
Выполнение фильтрации по выбранному элементу раскрывающегося списка фильтров (если список открыт) | ВВОД

К началу страницы


Загрузка и обновление данных в веб-таблице Access

Изменение данных в веб-таблице осуществляется намного быстрее, чем в стандартном представлении.

В стандартном представлении за один раз изменяется один элемент. Следующий элемент не может быть изменен до тех пор, пока предыдущий элемент не отправлен на сервер и не сохранен.

В веб-таблице можно вносить изменения в строку, а затем переходить к следующей строке и начинать изменять ячейки в ней. Представление следит за отправкой изменений на сервер и возвращает сообщение о состоянии не прерывая работу.

Асинхронные обновления

При изменении или добавлении строки изменение посылается на сервер, строка помечается как ожидающая утверждения и в заголовке строки отображается значок ожидания утверждения ( Значок ожидания утверждения). При ожидании утверждения изменений в строке ее изменять нельзя, пока внесенные изменения не будут сохранены. Но в то время как последний набор изменений отправляется на сервер, можно продолжать изменение других строк.

Когда представление получает с сервера ответ, строка обновляется соответствующим образом. Если изменение привело к возникновению конфликта или ошибки, в заголовке строки отображается значок конфликта ( Значок конфликта) или ошибки ( Значок ошибки). Если изменение было сохранено успешно, значок ожидания утверждения удаляется, а строка становится доступной для изменения.

Изменения в описании, например изменение порядка столбцов или скрытие строки итогов, также посылаются на сервер асинхронно. Однако при ожидании утверждения изменений нельзя вносить структурные изменения или изменять вычисляемые столбцы. Перед тем, как вносить структурные изменения и изменять вычисляемые столбцы необходимо дождаться сохранения всех изменений и устранения результирующих конфликтов и ошибок.

При попытке обновления или перемещения из представления в процессе ожидания утверждения изменений потребуется дождаться сохранения всех изменений. Затем на основании ответа сервера можно устранить все конфликты и ошибки.

Асинхронная загрузка данных

При открытии в веб-таблице списка осуществляется загрузка первых 100 строк, а остальные строки загружаются асинхронно. В процессе загрузки данных с сервера в строке состояний отображается текст Загрузка данных. При попытке фильтрации или сортировки данных, чтобы посмотреть результат, потребуется дождаться завершения загрузки всех необходимых данных списка с сервера.

Если сервер занят, не найден или в случае возникновения другой ошибки, запрещающей загрузку необходимых строк, в представлении будет отображена ошибка.


Выбор ячейки, строки, столбца или списка

Выбор одной ячейки

  • Щелкните ячейку или воспользуйтесь клавишами со стрелками, чтобы перейти к нужной ячейке.

    Примечание. Если ячейка содержит гиперссылку, произойдет переход по соответствующему веб-адресу. Для выбора таких ячеек служат сочетания клавиш.

Выбор содержимого ячейки

  • Выберите ячейку, щелкните внутри нее, а затем выберите текст.

Выбор диапазона ячеек

  • Выберите первую ячейку диапазона, а затем, удеживая кнопку мыши, перетащите указатель до последней ячейки диапазона либо выберите первую ячейку и, удерживая клавишу SHIFT, щелкните последнюю ячейку.

Примечание. Для отображения последней ячейки используйте возможность прокрутки.

Выбор строки или столбца

  • Щелкните заголовок сроки или столбца.

Выбор нескольких строк или столбцов

  • Выберите заголовок первой стороки или столбца, а затем, удеживая кнопку мыши, перетащите указатель до последней строки или столбца либо выберите первую строку или столбец и, удерживая клавишу SHIFT, щелкните последнюю строку или столбец.


Добавление строки или столбца

Добавление строки

По умолчанию пустая строка, помеченная звездочкой (*), отображается на листе после последней строки. Эта строка служит для добавления на лист новых элементов.

  • Если пустая строка не видна, на панели инструментов нажмите кнопку Создать или щелкните стрелку вниз рядом с кнопкой Создать, а затем выберите Создать документ для перехода к пустой строке.

Примечание. Пустую строку нельзя вставить между двумя строками с данными и она не отображается в режиме чтения.

Добавление столбца

  1. Правой кнопкой мыши щелкните ячейку на листе.
  2. Выберите команду Добавить столбец.
  3. На странице Добавить столбец укажите параметры столбца и нажмите кнопку ОК.

    Новый столбец будет добавлен справа от существующих столбцов в таблице. Чтобы переместить столбец, перетащите его заголовок на новое место.


Добавление столбца выбора, одновременно допускающего несколько значений

Столбец выбора, одновременно допускающий несколько значений, используется для выбора более одного элемента из списка вариантов выбора одновременно. Например, в списке отслеживания задач можно связать несколько человек с каждой задачей. Варианты выбора вводятся при добавлении столбца к списку.

Добавление столбца выбора, одновременно допускающего несколько значений

  1. Щелкните правой кнопкой мыши заголовок столбца или любую ячейку в списке, а затем в контекстном меню выберите команду Добавить столбец.
  2. В группе Имя и тип введите имя столбца, а затем нажмите кнопку Выбор/Вариант.
  3. В группе Дополнительные параметры столбца введите варианты выбора, которые должны отобразиться в столбце, а затем нажмите кнопку Флажки (допускается выбор нескольких вариантов).
  4. Задайте остальные необходимые параметры, а затем нажмите кнопку ОК.

Для использования столбца выбора, одновременно допускающего несколько значений, во время просмотра таблицы щелкните стрелку раскрывающегося списка, а затем установите или снимите флажок рядом с каждым значением, которое требуется добавить или удалить из ячейки.

Изменение списка вариантов выбора в столбце выбора, одновременно допускающем несколько значений

Для добавления, изменения или удаления элементов из столбца выбора, одновременно допускающего несколько значений, выполните следующую процедуру.

  1. Щелкните правой кнопкой мыши любую ячейку в колонке, которую требуется изменить, а затем в контекстном меню выберите команду Изменить или удалить столбец.
  2. В группе Дополнительные параметры столбца измените список вариантов выбора.
  3. Задайте остальные необходимые параметры, а затем нажмите кнопку ОК.

Использование столбца выбора, одновременно допускающего несколько значений

Для использования столбца выбора, одновременно допускающего несколько значений, выполните следующую процедуру.

  1. Щелкните стрелку раскрывающегося списка в ячейке, которую требуется изменить.
  2. Установите или снимите флажок рядом с каждым элементом, который требуется добавить или удалить из ячейки.
  3. Нажмите кнопку ОК.

Заданные варианты выбора отображаются в ячейке, разделенные точками с запятой (;).


Добавление столбца подстановок, одновременно допускающего несколько значений

Столбец подстановок, одновременно допускающий несколько значений, используется для выбора более одного элемента из списка вариантов выбора одновременно. Например, в списке отслеживания задач можно связать несколько человек с каждой задачей. Значения столбца подстановок берутся из существующего столбца текущего или иного списка.

Добавление столбца подстановок, одновременно допускающего несколько значений

  1. Щелкните правой кнопкой мыши заголовок столбца или любую ячейку в списке, а затем в контекстном меню выберите команду Добавить столбец.
  2. В группе Имя и тип введите имя столбца, а затем нажмите кнопку Подстановка (данные, уже имеющиеся на этом узле).
  3. В группе Дополнительные параметры столбца в раскрывающемся списке Получить данные из: выберите список, содержащий значения, которые нужно отобразить в столбце подстановок.
  4. В раскрывающемся списке В этот столбец укажите столбец, который будет содержать выбранные значения.
  5. Выберите параметр Разрешить множественные значения.
  6. Задайте остальные необходимые параметры, а затем нажмите кнопку ОК.

Для использования столбца подстановок, одновременно допускающего несколько значений, во время просмотра таблицы щелкните стрелку раскрывающегося списка, а затем установите или снимите флажок рядом с каждым значением, которое требуется добавить или удалить из ячейки.

Изменение списка вариантов выбора в столбце подстановок, одновременно допускающем несколько значений

Вследствие того, что элементы столбца подстановок, одновременно допускающего несколько значений, берутся из другого столбца текущего или иного списка, необходимо изменить список, на котором основан столбец подстановки. Например, если столбец подстановок основан на столбце «Заголовок» списка «Задачи», для изменения значений в столбце подстановок необходимо изменить список «Задачи».

Использование столбца подстановок, одновременно допускающего несколько значений

Для использования столбца подстановок, одновременно допускающего несколько значений, выполните следующую процедуру:

  1. Щелкните стрелку раскрывающегося списка в ячейке, которую требуется изменить.
  2. Установите или снимите флажок рядом с каждым значением, которое требуется добавить или удалить из ячейки.
  3. Нажмите кнопку ОК.

Заданные варианты выбора отображаются в ячейке, разделенные точками с запятой (;).


Изменение ширины столбцов

  1. Щелкните правой кнопкой мыши заголовок столбца и выберите команду Ширина столбца.
  2. В диалоговом окне Ширина столбца введите число от 1 до 255.

Примечания

  • При задании в качестве ширины значения 0 столбец будет скрыт.
  • Правую границу заголовка столбца можно также перетаскивать до тех пор, пока не будет получена нужная ширина. Чтобы изменить размер столбца так, чтобы содержимое каждой ячейки умещалось в одной строке, поместите курсор над правой границей заголовка столбца. При появлении курсора изменения размера дважды щелкните линию границы.


Изменение высоты строки

  1. Щелкните правой кнопкой мыши заголовок строки и выберите команду Высота строки.
  2. В диалоговое окно Высота строки введите число между 1 и 409.

Примечания

  • Изменение высоты строки меняет высоты остальных строк списка.
  • При задании значения от 0 до 7,4 высота строки будет 7,5, что является минимальным значением. Можно также перетаскивать с помощью мыши верхнюю или нижнюю границу заголовка строки до тех пор, пока она не станет нужного размера. Для придания строке такого размера, при котором отображается все содержимое ячейки, переместите курсор к нижней границе заголовка столбца. При появлении курсора, позволяющего менять размер строки, дважды щелкните линию границы.


Удаление строки или столбца

Удаление строки

  1. Щелкните заголовок строки, которую требуется удалить.

    Примечание. Чтобы удалить несколько строк, щелкните заголовок первой строки, а затем перетащите указатель к последней строке. Можно также выбрать первую строку и, удерживая нажатой клавишу SHIFT, выбрать последнюю.

  2. Щелкните правой кнопкой мыши выделенные строки, а затем выберите команду Удалить строки.

Удаленные строки помещаются в корзину узла и при необходимости могут быть восстановлены в списке. Для получения дополнительных сведений о работе с корзиной откройте справку Службы Microsoft Windows SharePoint Services 3.0, нажав кнопку Справка на панели инструментов страницы.

Удаление столбца

  1. Щелкните правой кнопкой мыши заголовок столбца, который требуется удалить, и выберите команду Изменить или удалить столбец.
  2. На странице Изменение столбца нажмите кнопку Удалить.

Примечания

  • Удаленные столбцы не помещаются в корзину узла. Они удаляются безвозвратно.
  • За один раз можно удалить только один столбец. Если выбраны ячейки нескольких столбцов, то столбец, содержащий активную ячейку, будет считаться выбранным.
  • Нельзя удалить столбец, доступный только для чтения. Также нельзя удалять некоторые столбцы из некоторых типов списков, поскольку они необходимы для правильной работы эти списков.


Изменение параметров столбца

Можно изменять имя столбца, описание, тип данных или параметры, относящиеся к этому типу данных.

  1. Щелкните правой кнопкой мыши ячейку в столбце, параметры которого нужно изменить, а затем выберите команду Изменить или удалить столбец.
  2. На странице Изменение столбца внесите нужные изменения и нажмите кнопку OK.

Примечания

  • За один раз можно изменить только один столбец. Если выбраны ячейки нескольких столбцов, выбранным будет считаться столбец, содержащий активную ячейку.
  • Нельзя изменять столбец, доступный только для чтения.


Перемещение столбцов

Представление таблицы данных позволяет легко менять порядок столбцов.

  1. Для перемещения столбца установите указатель мыши на заголовке нужного столбца таким образом, чтобы появился указатель перемещения ( Указатель перемещения ).

    Для перемещения нескольких рядом стоящих столбцов щелкните заголовок первого столбца, а затем нажмите клавишу SHIFT и, удерживая ее нажатой, выберите последний столбец. Установите указатель мыши на одну из сторон прямоугольника, включающего в себя нужные столбцы таким образом, чтобы на экране появился указатель перемещения.

  2. Нажмите кнопку мыши и перетащите выделенные столбцы на новое место.

При перемещении столбца его описание автоматически обновляется.

Примечание. Строки перемещать нельзя. Можно изменить порядок строк путем сортировки.


Отображение и скрытие столбца

Отображение скрытого столбца

Если справа от заголовка столбца отображается толстая вертикальная линия, значит следующий за ним столбец скрыт.

  • Чтобы отобразить столбец, выделите столбцы с любой стороны от скрытого столбца, щелкните их правой кнопкой мыши и выберите команду Отобразить.
  • Чтобы отобразить все скрытые столбцы списка, щелкните левый верхний угол списка правой кнопкой мыши и выберите команду Отобразить.

Скрытие столбца

  • Чтобы скрыть столбец, щелкните его правой кнопкой мыши и выберите команду Скрыть.


Просмотр предыдущих записей в текстовых столбцах и столбцах типа «Многострочный текст»

Существует возможность настроить столбец Многострочный текст так, чтобы при редактировании данных в нем сохранялись первоначальные записи, а не измененные. Благодаря этому можно управлять ранее внесенными в столбец записями, а также знать, когда и кем были внесены изменения.

Создание нового столбца только для добавления записей

  1. Щелкните правой кнопкой мыши любую ячейку списка, а затем в контекстном меню выберите пункт Добавить столбец.
  2. Введите имя столбца в поле Имя столбца, а затем установите флажок Многострочный текст.
  3. В разделе Дополнительные настройки для пункта Внести изменения в существующий текст выберите значение Да.
  4. Внесите другие необходимые изменения, а затем нажмите кнопку ОК.

    Справа от существующих столбцов будет добавлен новый столбец. Чтобы переместить столбец, перетащите его заголовок в нужное место.

Превращение существующего столбца в столбец только для добавления записей

  1. Щелкните правой кнопкой заголовок столбца, который необходимо изменить, а затем в контекстном меню выберите команду Изменить или удалить столбец.
  2. Если тип данных столбца отличается от «Многостраничный текст», щелкните Многостраничный текст. Если этот параметр недоступен, тип данных столбца изменить невозможно. Необходимо создать новый столбец, используя процедуру, описанную в разделе Создание нового столбца только для добавления записей.
  3. В разделе Дополнительные настройки для пункта Внести изменения в существующий текст установите значение Да.
  4. Внесите все остальные необходимые изменения, а затем нажмите кнопку ОК.

Просмотр предыдущих записей в столбце только для добавления записей

В ячейке веб-таблицы данных Access выводится только последняя добавленная запись из столбца только для добавления записей. Чтобы просмотреть предыдущие записи, выполните следующие действия.

  1. Щелкните правой кнопкой мыши ячейку, в которой нужно просмотреть предыдущие записи, а затем в контекстном меню выберите пункт Просмотреть записи.

    Службы Microsoft Windows SharePoint Services 3.0 выведет на экран все данные об элементе, включая предыдущие записи в столбце только для добавления записей.


Типы данных

Сведения о типах данных см. в справке Службы Microsoft Windows SharePoint Services 3.0.

Для отображения справки Службы Windows SharePoint Services 3.0 нажмите кнопку Справка на панели инструментов страницы.


Задание значения по умолчанию для столбца

Значения по умолчанию можно задать для столбцов следующих типов данных: однострочный текст, число, денежный, дата и время, выбор, вычисляемый или да/нет. Заданное по умолчанию значение для столбца автоматически отображается в этом столбце для каждой новой строки. Это значение можно оставить или изменить.

  1. Щелкните правой кнопкой мыши столбец и выберите команду Изменить или удалить столбец.
  2. В группе значение по умолчанию выполните одно из следующих действий.
    • Текст. Если типом столбца является Однострочный текст, задайте строку в качестве значения по умолчанию.
    • Выбор. Если типом столбца является Выбор, задайте в качестве значения по умолчанию любой вариант из списка вариантов выбора.
    • Число. Если типом столбца является Число, задайте численное значение.
    • Валюта. Если типом столбца является Валюта, задайте нужную валюту.
    • Текущая дата. Если типом столбца является Дата и время, выберите этот параметр, чтобы значением по умолчанию была текущая дата.
    • Любая дата. Если типом столбца является Дата и время и нужно задать определенную дату, установите переключатель в последнюю позицию задайте дату в формате «ММ/ДД/ГГГГ» .
    • Да . Если типом столбца является Да/Нет(флажок), чтобы флажок в столбце по умолчанию был установлен, задайте в поле значение по умолчанию значение Да.
    • Вычисляемый. Если нужно использовать в качестве значения по умолчанию вычисляемое значение, введите формулу. Обратите внимание, что такая формула не может ссылаться на другие столбцы списка.


Устранение неполадок при работе с типами данных

Дополнительные сведения о проблемах, связанных с типами данных, см. в справке Службы Microsoft Windows SharePoint Services 3.0.

Чтобы открыть справку Службы Windows SharePoint Services 3.0, щелкните ссылку Справка на панели инструментов страницы.


Добавление, изменение и удаление содержимого ячеек

Внесение изменений в одну ячейку

Содержимое ячеек можно добавлять, изменять и удалять в режиме изменения.

  1. Выберите ячейку, которую нужно изменить.

    Примечание. Если ячейка содержит гиперссылку, произойдет переход по соответствующему веб-адресу.

  2. Снова щелкните ячейку, чтобы перейти в режим изменения и внесите нужные изменения.

    Примечание. Чтобы перейти в режим изменения, нажмите клавишу F2.

  3. По завершении нажмите клавишу TAB или ВВОД.

Примечание. Чтобы отменить последнее внесенное в ячейку изменение, нажмите на панели инструментов кнопку Отменить. Для выхода из режима изменения и удаления внесенных изменений нажмите клавишу ESC.

Редактирование большого количества ячеек

Большое количество ячеек, строк и столбцов можно редактировать следующими способами.

  • Путем копирования и вставки данных.
  • Путем перетаскивания маркера заполнения.


Изменение гиперссылки

Эта команда доступна, только если выбранная ячейка является гиперссылкой.

  1. Щелкните правой кнопкой мыши ячейку, содержащую гиперссылку, укажите на меню Гиперссылка, затем выберите строку Изменение гиперссылки.
  2. В диалоговом окне Изменение гиперссылки введите допустимый адрес URL в текстовое поле Веб-адрес. Допустимый адрес URL должен начинаться с протокола, например http:// или ftp://, и не должен содержать более 255 символов.
  3. Введите текст для отображения в текстовое поле Описание.


Ввод данных в ячейку путем их выбора из списка значений

Выбор значения из списка доступен для столбцов с типом данных «однострочный текст».

При вводе данных в ячейку над (или под) ней отображается раскрывающийся список со всеми значениями, когда-либо вводимыми в столбец, содержащий эту ячейку.

Например, если в строку 5 столбца «Состояние» ввести букву Б, в раскрывающемся списке отобразятся все значения, начинающиеся на эту букву, которые были введены в столбец «Состояние».

Чтобы просмотреть полный список значений для текущего столбца, щелкните правой кнопкой мыши пустую ячейку с этом столбце и выберите команду Выбрать из списка.


Получение уведомления об изменениях в содержимом списка

Показать Получение уведомления при изменении строки, документа или ячейки

  1. Щелкните правой кнопкой мыши заголовок строки или ячейку, при изменении которой будет выдаваться уведомление, а затем выберите команду Оповещать меня.
  2. На странице Создание оповещения задайте условия, при которых будет выдаваться оповещение.

Показать Получение уведомления при внесении любых изменений в список или библиотеку документов

  1. Щелкните правой кнопкой мыши левый верхний угол списка или библиотеки и выберите команду Оповещать меня.
  2. На странице Создание оповещения задайте условия, при которых будет выдаваться оповещение.


Отмена изменений

Изменения, которые еще не были сохранены в списке, можно отменить. В режиме редактирования можно отменить изменения, внесенные в текущую ячейку.

  • Нажмите кнопку Отменить на панели инструментов области задач или нажмите клавиши CRTL+Z.

Примечания

  • Если ячейки поддерживают форматирование HTML, каждая команда считается изменением.
  • Команда Отменить отличается от отмены в режиме изменения с помощью клавиши Esc.
  • Нельзя отменять изменения после их сохранения, а также после добавления или удаления вложения из записи.


Проверка данных

Справочную информацию о проверке данных можно получить в справке Службы Microsoft Windows SharePoint Services 3.0.

Чтобы открыть справку Службы Windows SharePoint Services 3.0, щелкните ссылку Справка на панели инструментов страницы.


Форматирование данных

Содержимое столбца можно форматировать, если он поддерживает многострочный текст и форматированный текст (RTF).

Чтобы разрешить поддержку форматированного текста в столбце, выполните следующие действия.

  1. Щелкните правой кнопкой мыши столбец, в котором хотите разрешить поддержку форматированного текста, а затем выберите команду Изменить или удалить столбец....
  2. В группе Имя и тип выберите пункт Несколько строк текста, если он еще не выбран.
  3. В группе Дополнительные параметры столбца выберите пункт Формат RTF (полужирный, курсив, выравнивание).
  4. Нажмите кнопку ОК.

После этого можно форматировать текст в одной или нескольких ячейках или только часть текста в ячейке следующим образом:

  1. Выберите ячейки или текст, который нужно форматировать.
  2. Если область задач не открыта, нажмите кнопку Действия, затем выберите пункт Область задач.
  3. Примените нужное форматирование. Если необходимо, можно изменить параметры шрифтов, цвет текста и фона, отступ и выравнивание, а также преобразовать текст в нумерованный или маркированный список.

Примечания

  • Форматирование текста можно убрать, выбрав текст и нажав клавиши CTRL+ПРОБЕЛ. Однако эта процедура не изменяет параметры выравнивания.
  • Нельзя применять форматирование к ячейкам, доступным только для чтения, а также к строке итогов.
  • Форматирование не применяется к скрытым в результате фильтрации строкам.


Включение или отключение обтекания текстом для столбца

Если обтекание текстом включено, в ячейке будет отображаться многострочный текст, если нет — текст отображается одной строкой. По умолчанию обтекание включено для всех столбцов.

Обтекание текстом применимо к следующим типам данных: Однострочный текст, Многострочный текст, Выбор, Пользователь или группа, Гиперссылка или рисунок и Вычисляемый.

  • Щелкните правой кнопкой мыши заголовок столбца, для которого нужно изменить этот параметр, и выберите команду Отключить перенос текста или Включить перенос текста.


Устранение ошибок форматирования данных

Кнопки форматирования не отображаются в области задач

Чтобы включить форматирование текста столбец должен поддерживать многострочный текст и текст в формате RTF.

Чтобы разрешить поддержку текста в формате RTF для столбца

  1. Щелкните правой кнопкой мыши столбец, для которого нужно включить поддержку текста в формате RTF и выберите команду Изменить или удалить столбец.
  2. В группе Имя и тип выберите Многострочный текст в случае, если этот параметр еще не выбран в качестве типа столбца.
  3. В группе Дополнительные параметры столбца выберите Форматированный текст (атрибуты: полужирный, курсив, выравнивание).
  4. Нажмите кнопку ОК.

После установления этих параметров можно отформатировать текст в одной или нескольких ячейках или только части текста в ячейке:

  1. Выберите ячейку или текст, которые следует отформатировать.
  2. Если область задач не открыта, нажмите кнопку Действия, а затем выберите Область задач.
  3. Примените требуемое форматирование. Можно изменить параметры шрифтов, цвет текста и фона, отступ и выравнивание, а также преобразовать текст в нумерованный или маркированный список.

Форматирование не применяется ко всем строкам столбца

Если выбрать весь столбец целиком и применить к нему форматирование, строка итогов и строки, скрытые из-за фильтрования, не будут отформатированы.

Утеряно форматирование для текста, вставленного в столбец типа «многострочный текст»

Форматирование исходного текста может быть не полностью распознано при включении в список. Убедитесь, что исходный текст не содержит форматирования, не поддерживаемого списком.

Чтобы узнать, какие форматы поддерживаются списком, выберите ячейку в столбце, поддерживающем RTF. В области задач под панелью инструментов отобразятся кнопки форматирования, соответствующие поддерживаемым форматам.

Получено сообщение о ячейке, превысившей максимальный размер

Форматированная ячейка содержит текст и информацию о форматировании. Если суммарный объем текста и информации о форматировании превышает максимальный размер ячейки, выводится сообщение. Уменьшите размер текста или количество примененных к нему элементов форматирования.


Фильтрация данных

Существует два способа фильтрации списков — при описании представления и при открытии списка в представлении Режим таблицы. При указании фильтра во время описания представления критерии фильтрации сохраняются как часть описания представления и применяются при каждом открытии списка в этом представлении. Вдобавок к сохраненным фильтрам к списку можно применить один или более фильтров в представлении Режим таблицы. Эти фильтры не сохраняются.

Например, представление «Руководители» для списка «Работники» создается путем выделения в списке с помощью фильтрации строк работников, имеющих значение «Да» в столбце «Руководитель». Этот список можно фильтровать еще раз, чтобы отображались только руководители со значением США в столбце «Страна» и значением Калифорния в столбце «Штат». На следующем рисунке показан список руководителей, работающих в Калифорнии.

представление «Руководители» для списка «Работники»

Обратите внимание на появление стрелки раскрывающегося списка в заголовках столбцов Область/Штат и Страна.

При переключении представлений или закрытии представления «Руководители» фильтры столбцов ««Страна» и «Штат» не сохраняются. При следующем открытии списка в представлении «Руководители» будут отображаться все руководители.

Столбцы типа «многострочный текст», «гиперссылка» или «рисунок» не поддерживают фильтрацию. Столбцы типа «вложение» можно фильтровать по значениям «Да» и «Нет». В столбцах типа «список значений» будут отображаться ячейки с выбранными значениями.


Применение фильтров

  1. В заголовке столбца щелкните стрелку раскрывающегося списка.

    Примечание. Если столбец не поддерживает применение фильтров, команды в списке будут недоступны.

  2. Выполните одно из следующих действий.
    • Выберите элемент, по которому нужно отфильтровать записи. Для нескольких столбцов будут выделены записи, содержащие этот элемент.
    • Выберите (Пустые), чтобы установить фильтр для записей, не имеющих значений.
    • Выберите (Непустые), чтобы установить фильтр для записей, имеющих значения.
    • Выберите Настраиваемый фильтр, чтобы определить условия отбора. В диалоговом окне Настраиваемый фильтр укажите операторы сравнения и нужные значения. Например, чтобы найти имена, начинающиеся с буквы «А» или «Б», выберите в верхнем левом списке пункт начинается с и введите A в правом верхнем поле. Затем выберите в среднем левом списке пункт начинается с и введите Б в среднем правом поле. Выберите верхний оператор Или, чтобы связать два условия и нажмите кнопку OK.

Примечание. В представлении можно также осуществлять сортировку и фильтрацию сразу нескольких столбцов.


Удаление фильтра и порядка сортировки

Чтобы посмотреть, отфильтрован ли столбец, щелкните стрелку раскрывающегося списка в заголовке столбца. Если фильтр отсутствует, в списке выбран параметр Отображать все.

Показать Удаление фильтра

  1. В заголовке столбца щелкните стрелку раскрывающегося списка.
  2. В списке выберите пункт Отображать все.

Показать Удаление всех фильтров порядков сортировки

  • На панели инструментов области задач нажмите кнопку Удалить фильтр.


Сортировка строк

Можно выполнять сортировку данных в представлении таблицы данных двумя способами: задавая представление и открывая список в преставлении таблицы данных. При задаче порядка сортировки при описания представления она сохраняется как часть описания и применяется при каждом открытии представления. Также можно выполнять сортировку данных после открытия представления. При этом порядок сортировки не сохраняется.

Сортировка столбца

  1. В заголовке столбца щелкните стрелку раскрывающегося списка.
  2. Выберите пункт По возрастанию или По убыванию.

Сортировка нескольких столбцов

В этом случае порядок сортировки определяет, как данные будут организованы в столбце. Например, при выполнения сортировки двух столбцов, определитесь, какой их будет внешним, а какой — внутренним. В диалоговом окне сначала задайте внешний столбец, а затем — внутренний. Например, для создания списка сотрудников каждого отдела, организованного в алфавитном порядке, сначала выполните сортировку для столбца «Отдел», а затем — для столбца «Сотрудники».

  1. Нажмите кнопку Сортировка на панели инструментов.
  2. В диалоговом окне Настраиваемая сортировка в списке под меню Сортировать по выберите внешний столбец для сортировки и щелкните По возрастанию или По убыванию.
  3. Повторите то же самое для еще двух столбцов, заканчивая внешним.
  4. Нажмите кнопку OK.

Примечания

  • Используя стрелку раскрывающегося списка в заголовках столбцов, можно также отсортировать несколько столбцов. Первый сортируемый столбец становится самым внутренним, а последний — самым внешним.
  • Можно применить один или несколько фильтров к отсортированному представлению.
  • Столбцы, содержащие многострочный текст, выбор из списка или подстановки с несколькими значениями, не поддерживают сортировку. Если столбец не поддерживает применение сортировки, команды в списке будут недоступны.
  • Порядок рядов после сортировки зависит от типов данных находящихся в столбцах.

    Порядок сортировки различных типов данных, используемый по умолчанию

    При применении сортировки по возрастанию представление таблицы данных использует следующий порядок. При применении сортировки по убыванию порядок обратный; исключением являются пустые ячейки, которые всегда располагаются последними.

    Тип данных | Порядок сортировки
    Числа | Сортируются в порядке от наименьшего отрицательного до наибольшего положительного числа.
    Буквы или цифры Сортируются справа налево, символ за символом. Например, если в ячейке содержится текст «A100,», она располагается после ячейки, содержащей только «A1», но перед «A11».

    Текст (в том числе и содержащий числа) сортируется в следующем порядке: 0 1 2 3 4 5 6 7 8 9 (пробел) ! " # $ % & ( ) * , . / : ; ? @ [ \ ] ^ _ ` { | } ~ + < = > буквы в алфавитном порядке

    Апостроф (') и дефис (-) игнорируются, но с одним исключением: если две текстовые строки различаются только присутствием дефиса в одной их них, строка с дефисом будет стоять на втором месте.
    Логические значения | No помещается перед Yes.
    Значения ошибок | Все значения ошибок считаются равноценными.


Устранение неполадок, связанных с сортировкой и фильтрацией

В представлении не отображается порядок сортировки или критерий фильтрации

Любая сортировка или фильтрация, примененная к списку после его открытия в режиме таблицы, не сохраняется. При закрытии представления или переключении на другое представление параметры такой фильтрации и сортировки теряются. Чтоб сохранить порядок сортировки или критерии фильтрации, задайте их в описании представления.

Недоступны команды сортировки и фильтрации

Соответствующие команды не отображаются при щелчке заголовка столбца, если столбец не поддерживает сортировку или фильтрацию.

В диалоговом окне Настраиваемый фильтр отсутствуют некоторые операторы

Список операторов, отображаемых в диалоговом окне Настраиваемый фильтр, зависит от типа данных выбранного столбца. Например, операторы Начинается с и Содержит не доступны для числовых столбцов.

Не отображается столбец, по которому нужно сортировать строки или фильтровать данные

Убедитесь, что этот столбец не является скрытым в режиме таблицы. Щелкните правой кнопкой мыши ячейку в верхнем левом углу списка и выберите команду Отобразить. Если команда Отобразить отключена, проверьте в описании представления, включен ли требуемый столбец в представление.

Порядок сортировки не соответствует параметрам компьютера

Это может быть связано с региональными настройками на сервере SharePoint. Дополнительные сведения см. в справке Службы Microsoft Windows SharePoint Services 3.0. Чтобы отобразить справку Службы Windows SharePoint Services 3.0, щелкните Справка на панели инструментов страницы.

Был применен фильтр или сортировка, но отображаемые представлением данные не соответствуют фильтру или порядку сортировки

При добавлении или редактировании данных после применения фильтра или сортировки не происходит автоматического обновления данных представления. Обновите представление или повторно примените фильтрацию или сортировку.


Перемещение, копирование и вставка содержимого ячеек

Часть списка можно скопировать или переместить в другое место в том же списке или в другой документ. При перемещении выделенного фрагмента этот фрагмент удаляется из списка и помещается в буфер обмена. При копировании фрагмента этот фрагмент остается в списке, а его копия помещается в буфер обмена. После вставки из буфера обмена фрагмент попадает в место назначения.

Перемещение и копирование частей списка

Вставка содержимого буфера обмена в список

Перемещение и копирование частей списка

Если выделенный диапазон содержит ячейки, которые нельзя оставить пустыми, или ячейки, доступные только для чтения, в операции перемещения будет отказано. Пустыми нельзя оставлять столбцы со следующими типами данных (поэтому их невозможно очистить в операции перемещения): «Флажок» и «Вычисляемый».

В следующей таблице описано содержимое буфера копирования после операции перемещения или копирования.

Перемещение или копирование | Содержимое буфера обмена
Данные либо одна или несколько ячеек (выделенный фрагмент не включает целые строки или столбцы) | Ячейки очищаются или копируются и их содержимое помещается в буфер обмена.
Одна или несколько строк | Выделенные ячейки удаляются или копируются и их содержимое помещается в буфер обмена.
Столбец (может только копироваться, перемещение невозможно) | Выделенный фрагмент помещается в буфер обмена.
Строка итогов | После перемещения выражение для ячеек в строке итогов отсутствует. Операция копирования на строку итогов не влияет. Статистические значения помещаются в буфер обмена.
Ячейка флажка | Не очищается при операции перемещения. В буфер обмена помещается значение Yes или No.
Вычисляемый столбец | Не очищается при операции перемещения. Рассчитанные значения помещаются в буфер обмена.

Вставка содержимого буфера обмена в список

При вставке содержимого из буфера обмена новые строки, при необходимости, добавляются в нижнюю часть представления таблицы данных. Если представление не содержит нужные столбцы, операция не выполняется. Кроме того, отказ при операции вставки имеет место в следующих ситуациях:

  • некоторые или все конечные ячейки доступны только для чтения;
  • вставка содержимого в выделенные ячейки приведет к нарушению условий на значение;
  • попытка вставить данные, не соответствующие типам данных конечных ячеек;
  • попытка вставить данные в вычисляемый столбец.

При попытке вставить данные одного типа в столбец другого типа в списке выполняется попытка преобразовать исходные данные соответственно типу конечного столбца. Например, если исходными являются числовые данные, а конечные ячейки поддерживают текстовые, то исходные данные будут преобразованы в текст и вставлены в конечные ячейки. Если исходные данные невозможно преобразовать к типу, соответствующему конечным ячейкам, операция вставки не выполняется.

В следующей таблице описаны результаты различных операций вставки.

Содержимое буфера обмена | Назначение операции вставки | Результат операции
Одна ячейка | Диапазон ячеек | Содержимое копируется в каждую ячейку выделенного диапазона.
Диапазон ячеек | Одна ячейка | Конечный диапазон расширяется, чтобы вместить все содержимое буфера обмена; выделенная ячейка становится верхней левой ячейкой конечного диапазона.
Одна или несколько строк или столбцов | Первая ячейка строки или столбца | Конечный диапазон расширяется, чтобы вместить все содержимое буфера обмена; выделенная ячейка становится верхней левой ячейкой конечного диапазона.
Одна или несколько строк | Ячейка, отличная от первой ячейки строки | Операция вставки не выполняется.
Один или несколько столбцов | Ячейка, отличная от первой ячейки столбца | Операция вставки успешно выполняется за исключением случай, когда конечный диапазон распространяется за пределы последней строки представления, а представление содержит обязательные столбцы. Поскольку обязательные столбцы в новых строках будут пустыми, новые строки не добавляются и выводится сообщение о том, что некоторые строки пропущены.
Диапазон ячеек | Диапазон ячеек | Если размеры диапазонов совпадают, операция вставки выполняется, в противном случае имеет место отказ.
Ячейки в строке итогов | Строка итогов | Выражение из исходных ячеек помещается в конечные ячейки.
Ячейки в строке итогов | Любое место, отличное от строки итогов | В конечные ячейки помещаются статистические значения.


Автоматическое заполнение ячеек данными

Диапазон ячеек можно заполнить определенным значением, диапазоном значений или линейно возрастающими значениями.

Копирование содержимого ячейки в другие ячейки столбца

Копирование диапазона значений в другие ячейки столбца

Линейно возрастающие значения для диапазона ячеек столбца

Копирование содержимого ячейки в другие ячейки столбца

Например, в столбце «Год» требуется скопировать значение 1980 из строки 1 в строки 2, 3, 4 и 5.

  1. Выделите ячейку, содержимое которой нужно скопировать.
  2. Наведите указатель мыши на перемещаемый маркер заполнения в правом нижнем углу ячейки.

    Указатель мыши на перемещаемом маркере заполнения

  3. Когда появится курсор перемещения (+), перетаскивайте его до тех пор, пока не будут включены все нужные ячейки. Перетаскивать можно выше и ниже выделенной ячейки.

    Нужные ячейки, выбранные с помощью маркера заполнения

  4. Отпустите кнопку мыши, и содержание первой ячейки скопируется в нужные ячейки.

    Нужные ячейки, заполненные данными из исходной ячейки

Копирование диапазона значений в другие ячейки столбца

Например, требуется заполнить ячейки столбца «Квартал» значениями 1, 2, 3, 4, 1, 2, 3, 4 и т. д.

  1. Введите в первой строке значение 1, во второй — 2, в третьей — 3 и в четвертой — 4.
  2. Выделите все четыре ячейки.
  3. Наведите указатель мыши на перемещаемый маркер заполнения в правом нижнем углу выделения.
  4. Когда появится курсор перемещения (+), нажмите клавишу CTRL и, удерживая ее перетаскивайте, курсор до тех пор, пока не будут включены все нужные ячейки. Перетаскивать можно выше и ниже выделенных ячеек.

Линейно возрастающие значения для диапазона ячеек столбца

Определенные текстовые или числовые столбцы можно заполнять последовательностями линейно возрастающих значений, увеличивающихся начиная с исходной ячейки или с нескольких исходных ячеек. Типы столбцов, для которых эта операция не поддерживается, перечислены ниже в примечаниях.

Например, требуется заполнить ячейки столбца «Год» значениями 1910, 1920, 1930 и т. д.

  1. Введите в первой строке значение 1910, а во второй — 1920.
  2. Выделите ячейку «Год» первой и второй строк.
  3. Наведите указатель мыши на перемещаемый маркер заполнения в правом нижнем углу выделения.
  4. Когда появится курсор перемещения (+), перетаскивайте его до тех пор, пока не будут включены все нужные ячейки. Перетаскивать можно выше и ниже выделенной ячейки.

Примечание. Если исходные ряды содержат единственное значение, для создания рядов удерживайте клавишу CTRL при перетаскивании маркера заполнения.

Примеры линейно возрастающих значений

В следующей таблице перечислено несколько рядов, созданных при помощи перетаскивании маркера заполнения.

Исходные значения | Результирующие ряды
1, 2, 3 | 4, 5, 6...
Пн | Вт, Ср, Чт...
Понедельник | Вторник, Среда, Четверг...
Янв | Фев, Мар, Апр...
Янв, Апр | Июл, Окт, Янв...
1/1/2005 | 1/2/2005, 1/3/2005...
1/15/2005, 3/15/2005 | 5/15/2005, 7/15/2005...
1999, 2000 | 2001, 2002, 2003...
Кв-л3 | Кв-л4, Кв-л1, Кв-л2...
Кв3 | Кв4, Кв1, Кв....
Текст1, ТекстA | Текст, Текста, Текст, Текста
1-й период | 2-й период, 3-й период...
Продукт 1 | Продукт 2, Продукт 3...

Примечания

  • За одну операцию автоматически можно заполнить несколько столбцов. Выделенные ячейки каждого столбца будут использоваться для заполнения нужных ячеек.
  • Столбцы следующих типов данных не поддерживают заполнение линейно возрастающими значениями:
    • Многострочный текст
    • Выбор
    • Поиск
    • Да/Нет(флажок)
    • Пользователь или группа
    • Гиперссылка или рисунок
    • Вычисляемый
  • При попытке заполнить ячейки, доступные только для чтения, или при попытке ввода неправильного значения операция заполнения для данной ячейки будет отменена.


Устранение неполадок при автоматическом заполнении ячеек данными

Получено сообщение «Ячейки доступны только для чтения».

При перетаскивании маркера заполнения выделены ячейки, доступные только для чтения.

Получено сообщение «Строки пропущены, поскольку новые строки содержали недопустимые значения в обязательных полях.»

При перетаскивании маркера заполнения выделены строки, не содержащие значений, в одном или нескольких столбцах, помеченных как обязательные.

Получено сообщение «Эту операцию нельзя выполнять над вычисляемыми столбцами.»

Нельзя заполнять вычисляемый столбец с помощью перетаскивания на него маркера заполнения. Значения в вычисляемом столбце являются результатом применения формулы. Чтобы просмотреть или изменить формулу, дважды щелкните ячейку в столбце.

Получено сообщение «Попытка заполнения ячеек или строк недопустимыми значениями.»

Попытка заполнения ячеек значениями, не отвечающими правилам проверки на значение в ячейке или строке.

Получено сообщение «Некоторые данные были усечены.»

Попытка заполнения ячеек значениями, размер которых превышает максимальную разрешенную длину.


Устранение неполадок при перемещении, копировании и вставки содержимого ячеек

Невозможно вставить данные в столбец, или появляется сообщение «N ячеек не может быть вставлено».

Выполните одно из следующих действий:

  • Убедитесь, что столбец не является вычисляемым.
  • Убедитесь, что тип вставляемых данных совпадает с типом конечных ячеек.
  • Убедитесь, что правила проверки на значения, установленные для ячейки или строки, не нарушаются при вставке.

Появляется сообщение «Некоторые данные были усечены».

Совершена попытка вставить больше символов, чем разрешено, в одну или несколько конечных ячеек. Например, при попытке вставить строку длинною более, чем в 255 символов, в однострочную ячейку лишние символы усекаются.

Появляется сообщение «Эти ячейки обязательны и не могут быть очищены».

Совершена попытка переместить ячейки в обязательный столбец. Обязательные столбцы не могут быть пустыми; вместо перемещения данные скопируйте их в конечные столбцы и удалите ненужные строки.

Появляется сообщение «Ячейки/строки доступны только для чтения»

Совершена попытка переместить данные из ячеек, доступных только для чтения, или вставить данные в такого типа ячейки. Нельзя менять содержимое ячеек и строк, доступных только для чтения.

Появляется сообщение «Вставка не удалась, т.к. вставляемая область не помещается в список».

Это могло произойти по следующим причинам:

  • Совершена попытка вставить строки в ячейку, не являющуюся первой в строке.
  • Совершена попытка вставить диапазон ячеек, но в таблице недостаточно строк и столбцов, расположенных справа и снизу от конечной ячейки.

Появляется сообщение «Вставка не удалась, т.к. вставляемая и конечная области не совпадают по размерам».

Совершена попытка вставить диапазон ячеек в конечный диапазон, но эти диапазоны не совпадают по величине. Убедитесь, что в конечном диапазоне выбрано столько же строк и столбцов, что и во вставляемом.

Появляется сообщение «Строки были пропущены».

Это могло произойти по следующим причинам:

  • Совершена попытка вставить ячейки в ячейку, которая не является первой в столбце.
  • Совершена попытка вставить данные в строку, помеченную звездочкой (*), но нельзя добавить данные в обязательные столбцы.

Любая операция, при которой добавляются новые строки, но обязательные столбцы остаются пустыми, будет неудачной. Вставка возможна лишь для существующих строк, остальные пропускаются.


Текущее состояние (сведения о присутствии)

Когда список или библиотека документов открыты в представлении таблицы данных, возможен просмотр текущего состояния пользователей, чьи имена перечислены в определенных столбцах. Существует возможность узнать, интерактивен ли пользователь, занят или разговаривает по телефону. Основываясь на этой информации, можно начать дискуссию, послать почтовое сообщение, запланировать собрание.

Для просмотра информации о присутствии необходимо войти в программу Windows Messenger. Подобным образом информация о других пользователях доступна, только если они пользуются Windows Messenger и их электронные адреса есть на веб-узле. В противном случае их статус будет отображен как автономный.

На следующем рисунке показан список «Моя библиотека» в представлении таблицы данных.

Библиотека документов в представлении таблицы данных

В одном столбце этого списка отображена текущая информация о присутствии. Обратите внимание на значок «Присутствие» ( Значок «Присутствие» ) слева от имени в столбце Кем изменен. Любой столбец, для которого установлен тип данных Подстановка и который получает информацию из списка Сведения о пользователе, может отображать информацию о присутствии. Список Сведения о пользователе содержит информацию о пользователях узла SharePoint, например выводимое имя и электронный адрес. В зависимости от типа списка один или несколько столбцов получают данные из списка Сведения о пользователе по умолчанию. К тому же можно самостоятельно добавить столбцы с типом «Подстановка» для отображения информации о присутствии.

При открытии представления на экране появляются ряды значков, соответствующих пользователям, занятым и интерактивным, и всплывающая подсказка, отображающая состояние пользователей. Если значок не появляется, значит, пользователь не активен или не пользуется программой Windows Messenger. Значок неактивного пользователя будет отображен при задержке курсора мыши на соответствующем элементе. Заметьте, что в режиме редактирования информация о присутствии отображаться не будет. Для получения сведений о значках и их описаниях см. справку Windows Messenger.

Щелкнув значок «Присутствие», можно открыть список с представленными действиями, которые следует предпринять для работы с данным пользователем; можно, например, послать почтовое сообщение или начать дискуссию. Содержание списка действий зависит от состояния пользователя.

Нельзя выполнить сортировку или отбор в списке, использующем информацию о присутствии. Можно отключить отображение информации о присутствии для столбца, который получает информацию из списка Сведения о пользователе. Системный администратор может отключить возможность получения информации о присутствии для всего узла.


Просмотр сведений о присутствии

  1. Убедитесь, что в представлении есть хотя бы один столбец, содержащий сведения о присутствии. Если столбец поддерживает отображение сведений о присутствии, в его заголовке (перед именем) отображается значок присутствия ( Значок присутствия ).
  2. Выйдите из режима изменения, нажав клавишу ESC.
  3. Для отображения значка присутствия задержите указатель мыши над строкой в столбце.
  4. Щелкните стрелку раскрывающегося списка, чтобы открыть список действий для совместной работы с пользователями.

Показать Добавление столбца со сведениями о присутствии

  1. Щелкните правой кнопкой мыши существующий столбец и выберите Добавить столбец.
  2. Укажите имя столбца и выберите Пользователь или группа в качестве типа данных для хранения в столбце.
  3. Убедитесь, что в раскрывающемся списке Показать поле выбрано Имя (со сведениями о присутствии), и нажмите кнопку ОК.


Отправка изменений данных диспетчеру списка для утверждения

Данные, добавленные или измененные в списке, требующем утверждения содержимого, останутся недоступными для остальных до их утверждения пользователем с правом на управление списками.

Примечание. Изменениям, вносимым в список пользователем с правом на управление списками, автоматически присваивается значение Утверждено.

Дополнительные сведения о работе со списками, требующими утверждения содержимого, см. в справке к приложению Службы Microsoft Windows SharePoint Services 3.0. Чтобы открыть справку к приложению Службы Windows SharePoint Services 3.0, щелкните ссылку Справка на панели инструментов страницы.

Чтобы отправить внесенные изменения на утверждение, не обладая правами на управление списками, выполните следующие действия.

  1. Откройте список в представлении «Мои отправленные данные».

    В этом представлении отображаются все элементы, добавленные в список, в том числе отклоненные элементы. В данном представлении вдобавок к столбцам списка отображаются также столбцы Состояние утверждения и Примечание. Однако столбцы Состояние утверждения, Примечание, Изменен и Кем изменен доступны только для чтения.

  2. Если список отображается в стандартном представлении, нажмите кнопку Изменить в таблице данных, чтобы переключиться на представление таблицы данных.
  3. Добавление или редактирование строки.

    При добавлении или редактировании строки в ее столбец Состояние утверждения автоматически заносится значение Ожидание утверждения. Это относится и к строкам, для которых ранее было установлено состояние Утверждено. Каждая редактируемая строка рассматривается как новая строка и нуждается в отправке на утверждение.


Утверждение или отклонение ожидающих утверждения элементов

Пользователи с правом «Управление списками» для списка, параметры настройки которого требуют запрашивать утверждения содержимого, могут просматривать данные, ранее внесенные в список другими пользователями перед тем, как эти данные будут отображаться для всех. Просмотренные данные можно утвердить или отклонить. Для пользователей узла будут отображаться только утвержденные данные.

Дополнительные сведения о требующих утверждения списках см. в справке Службы Microsoft Windows SharePoint Services 3.0. Для отображения справки Службы Windows SharePoint Services 3.0 нажмите кнопку Справка на панели инструментов страницы.

  1. Для просмотра данных, введенных другими пользователями, откройте список в представлении «Утвердить или отклонить элементы». В данном представлении кроме столбцов списка отображаются столбцы Состояние утверждения и Заметки.
  2. Если список отображается в стандартном представлении, нажмите кнопку Изменить в таблице данных для переключения на представление таблицы данных. В этом представлении можно быстро отредактировать столбцы Состояние утверждения и Заметки.
  3. Примените фильтр к представлению, чтобы отображались только ожидающие подтверждения элементы. Щелкните стрелку раскрывающегося списка в заголовке столбца Состояние утверждения и выберите пункт На рассмотрении.
  4. Чтобы утвердить или отклонить строку, просмотрите данные в строке и задайте в столбце Состояние утверждения значение Утверждена или Отклонена. Введите комментарии в столбец Заметки.

    Чтобы обновить соседние строки с использованием общего состояния подтверждения или комментариев, введите нужные значения в первую строку и перетащите маркер заполнения, чтобы включить нужные строки. Можно также копировать и вставлять значения в столбцы.

Примечание. Для утвержденного или отклоненного элемента можно восстановить состояние ожидания утверждения.


Работа с библиотеками документов

В представлении таблицы данных обеспечивается один и тот же уровень поддержки для библиотек документов и списков. Библиотеку документов можно открыть в представлении таблицы данных, чтобы просмотреть ее содержимое, добавить или удалить папки и документы, а также изменить документы и их свойства.

Если библиотека документов создана впервые, она имеет два представления: «Все документы» и представление проводника. Для редактирования библиотеки документов в представлении таблицы данных нажмите кнопку Действия и выберите пункт Изменить в таблице данных. Следующий рисунок показывает библиотеку документов в представлении таблицы данных.

Библиотека документов в представлении таблицы данных.

Каждая строка представления содержит сведения о документе или папке. В качестве параметра папки в представлении задано значение Отображать элементы папок, так что документы, расположенные в папке Отчеты прошлого года, отображаются только при выборе имени папки.

С библиотекой документов в представлении таблицы данных можно работать двумя способами.

  • В представлении «Все документы» или в любом другом стандартном представлении нажмите кнопку Действия и выберите пункт Изменить в таблице данных.
  • Создание одного или более представлений таблицы данных для библиотеки.
    1. Щелкните раскрывающийся список Представление, затем выберите пункт Создать представление.
    2. Нажмите кнопку Режим таблицы.
    3. Введите имя представления в поле Имя представления. Можно добавить слова «Таблица данных» к имени представления; таким образом позже можно увидеть, какое это представление.
    4. Установите любые другие параметры для представления, затем нажмите ОК.
    5. Новое представление будет доступно в раскрывающемся списке Представление.

Если в качестве параметра папки представления задано значение Отображать элементы папок, то при открытии библиотеки будут отображаться только документы и папки верхнего уровня. Если в качестве параметра задано значение Отображать элементы папок, то все документы, включая расположенные внутри папок, при открытии библиотеки будут отображаться в виде строк.

Для изменения параметра папки.

  1. Щелкните список Представление, а затем выберите пункт Изменить это представление.
  2. Прокрутите вниз и нажмите кнопку Папки, чтобы раскрыть раздел.
  3. В списке Папки или без структуры выберите нужный параметр.

Управление документами и папками в представлении таблицы данных
  • Добавить и отправить документы в библиотеку можно тем же способом, что и в представлении «Все документы» или в любом другом стандартном представлении.
  • Если в качестве параметра папки представления задано значение Отображать элементы папок, можно добавлять новые папки, а также перемещаться в другие папки библиотеки.
  • Документ можно открыть, изменить, извлечь и вернуть.
  • Можно удалить папки и документы. При удалении папки ее содержимое, включая вложенные папки, также удаляется из библиотеки.
  • Имеется возможность добавить столбцы или удалить и изменить добавленный столбец. Можно также вводить и изменять данные, хранящиеся в столбцах строк, содержащих документы. Строки, соответствующие папкам, изменять нельзя. Столбцы «Тип» и «Автор изменений/Кем изменено» доступны только для чтения. Их нельзя изменять или удалять, а также нельзя вводить и изменять их содержимое.
  • Можно отобразить и скрыть строку итогов.
  • Библиотеку можно фильтровать и сортировать на основе различных столбцов, включая столбец «Тип».
  • Для библиотеки документов не отображается строка, помеченная звездочкой (*).
  • Значение столбца «Тип» нельзя ввести ни с помощью перетаскивания маркера заполнения, ни с помощью выбора значения из раскрывающегося списка ячейки.


Добавление, просмотр и удаление документов, вложенных в строку

Можно вложить один или более документов в строки определенных типов списков.

  1. Откройте список в представлении таблицы данных или переключитесь на представление таблицы данных, для этого нажмите кнопку Действия и выберите пункт Изменить в таблице данных.
  2. Щелкните правой кнопкой мыши столбец «Вложения», выберите строку Изменить вложение.

    Примечание. Нельзя добавлять вложение к строке, которая не была сохранена.

  3. В диалоговом окне Вложения в элемент списка нажмите кнопку Добавить. Выберите файл или файлы, которые необходимо вложить в строку, и нажмите кнопку Открыть.

    Для просмотра вложения до его добавления дважды щелкните его в диалоговом окне Вложения в элемент списка.

    Для удаления вложения выделите его и нажмите кнопку Удалить.

  4. Если все необходимые вложения находятся в диалоговом окне Вложения в элемент списка, нажмите кнопку ОК для добавления их в строку. В столбце Вложения будет отображен значок «скрепка», показывающая, что строка содержит один или несколько вложенных файлов.


Извлечение и возврат документа

Возврат извлеченного, но не открытого документа

  1. Щелкните правой кнопкой мыши заголовок строки или ячейку, соответствующую документу, который необходимо вернуть, выделите пункт Документ, затем выберите команду Вернуть документ.
  2. На странице Возврат выберите один из следующих переключателей: «Вернуть документ», «Вернуть изменения, внесенные в документ, но оставить документ извлеченным» или «Отменить изменения и извлечение».
  3. Введите заметки по внесенным изменениям и нажмите кнопку OK.

Извлечение документа

  • Щелкните правой кнопкой мыши заголовок строки или ячейку, соответствующую документу, который необходимо извлечь, выделите пункт Документ, затем выберите команду Извлечь документ.

Примечание. Нельзя извлекать документ, извлеченный другим пользователем.


Удаление папки или документа

При удалении папки удаляется все ее содержимое, включая вложенные папки.

  • Щелкните правой кнопкой мыши заголовок строки или ячейку строки, соответствующую папке или документу, который необходимо удалить, затем выберите строку Удалить папку или Удалить документ.

Примечание. За один раз можно удалить только одну папку.


Редактирование документа

Редактировать можно только документы, созданные в приложениях Microsoft Office, таких как Microsoft Office Excel 2007 или Microsoft Office Word 2007.

  • Щелкните правой кнопкой мыши заголовок строки или ячейку, соответствующую документу, который необходимо изменить, установите указатель мыши на строку Документ, затем выберите Правка документа.

    Если для параметра Требовать извлечение библиотеки документов установлено значение Да, приложение Службы Microsoft Windows SharePoint Services 3.0 уведомит, что пользователь собирается извлечь и редактировать документ. Для продолжения нажмите кнопку ОК.

Документ будет открыт при помощи соответствующего приложения Office. Изменив документ, его можно сохранить в исходной библиотеке или другом месте.

Примечание. Нельзя редактировать документ, извлеченный другим пользователем. Нельзя также изменять ячейки, соответствующие документу, пока он не возвращен.


Установка разрешений на уровне элементов

Ограничить доступ пользователей на просмотр и изменения в списке можно с помощью установки разрешений на уровне элементов. Например, можно установить разрешения для списка, позволяющие пользователям просматривать только собственные элементы, или установить разрешения, позволяющие пользователям просматривать все элементы, а изменять только собственные. При создании нового списка разрешения настраиваются так, что пользователи могут просматривать и изменять все элементы, независимо от того, кто их создал.

Ограничение на чтение элементов других пользователей

Установите ограничения на чтение, используя следующую процедуру.

  1. На панели инструментов нажмите кнопку Настройка, а затем щелкните Параметры списка.
  2. На странице Настроить список нажмите кнопку Дополнительные параметры.
  3. На странице Дополнительные параметры списка в группе Разрешения на уровне элементов выберите один из параметров списка Доступ на чтение:
    • Выберите переключатель все элементы для просмотра всех элементов списка всеми пользователями.
    • Выберите переключатель только свои собственные для просмотра пользователями только собственноручно созданных элементов.
  4. Нажмите кнопку «ОК».

Ограничение на изменение элементов

Установите ограничения на изменение, используя следующую процедуру:

  1. На панели инструментов нажмите кнопку Настройка, а затем щелкните Параметры списка.
  2. На странице Настроить список нажмите кнопку Дополнительные параметры.
  3. На странице Дополнительные параметры списка в группе Разрешения на уровне элементов выберите один из параметров списка Доступ на изменение:
    • Выберите переключатель все элементы для просмотра всех элементов списка всеми пользователями.
    • Выберите переключатель только свои собственные для просмотра пользователями только собственноручно созданных элементов.
    • Выберите переключатель Нет доступа для запрещения изменения всех элементов всеми пользователями.
  4. Нажмите кнопку «ОК».


Как сделать документ доступным для обсуждения

  • Щелкните правой кнопкой мыши заголовок строки или любую ячейку, соответствующую документу, который необходимо сделать доступным для обсуждений, затем выберите строку Обсудить.

Документ будет открыт с помощью Internet Explorer. Окно обозревателя отобразит панель инструментов Обсуждения.


Открытие папки или документа

  • Чтобы перейти в папку или открыть документ, щелкните значок в столбце Тип для папки или файла.

    Если документ был создан в Microsoft Office, он откроется в соответствующем приложении. Другие документы открываются в Internet Explorer.


Отслеживание и просмотр сведений о версиях элементов списка

Можно сохранять сведения об изменениях, вносимых в отдельные элементы списка. Затем можно просматривать, какие изменения сделаны для каждого элемента, а также кто и когда вносил эти изменения.

Активация отслеживания версий элементов списка

  1. На панели инструментов щелкните значок Настройки, а затем выберите пункт Настройки листа.
  2. В разделе Общие настройки выберите пункт Настройки версий.
  3. В разделе История версий элемента выберите вариант Да, чтобы при каждом изменении элемента создавалась новая версия.
  4. Для ограничения количества сохраняемых версий установите флажок Сохранять следующее число версий и введите максимальное число сохраняемых версий.
  5. Нажмите кнопку ОК.

Просмотр версий элемента списка

  1. Щелкните правой кнопкой мыши заголовок столбца или любую ячейку строки, в которой находится нужный элемент списка.
  2. В контекстном меню выберите команду Элемент, а затем щелкните пункт Версии.

    На экран будут выведены сведения о версиях элемента списка.


Просмотр версий документа

Если в библиотеке документов сохранены версии документов (если установлен соответствующий параметр), можно просматривать сведения о каждой версии документа.

  • Щелкните правой кнопкой мыши заголовок строки или ячейку, соответствующую документу, версию которого требуется просмотреть, выделите пункт Документ, а затем выберите команду Версии документа.

Чтобы изменить параметр версии документа в библиотеке документов

  1. Щелкните Параметры, затем выберите команду Параметры библиотеки документов.
  2. В группе Общие параметры выберите Параметры управления версиями.
  3. В группе Журнал версий документа выберите требуемую схему управления версиями и нажмите кнопку ОК.


Устранение конфликтов при изменениях

Конфликт возникает, когда два пользователя одновременно вносят изменения в одну и ту же часть данных или структуры списка. Первый пользователь, отправивший изменения, сможет успешно занести их, тогда как второй пользователь получит уведомление о конфликте.

Например, пользователь А заменяет в третьей строке столбца «Город» значение «Москва» на «Тула», а в это время вы заменяете значение ячейки «Москва» на «Ростов». Изменения, внесенные пользователем А, отправляются на сервер первыми, а за ними поступают ваши изменения. Сервер информирует вас о конфликте и позволяет вам устранить его.

Примечание. Конфликт возникает даже в случае, когда пользователи изменяют разные ячейки в одной строке.

На следующем рисунке показан список со значком Конфликт в заголовке третьей строки.

Строка с конфликтом

До устранения конфликта внести любые изменения в строку невозможно.

Если щелкнуть значок «Конфликт», открывается диалоговое окно Устранение конфликтов.

Примечание. При попытке удалить строку, обновленную другим пользователем, конфликт возникает, но значок конфликта не отображается, поскольку строка уже обновлена. В этом случае для открытия диалогового окна Устранение конфликтов следует щелкнуть ссылку Устранить в строке состояния.

Диалоговое окно «Устранение конфликтов»

В таблице сведений отображаются все столбцы текущего представления. В изменяемой строке отображаются внесенные вами изменения, а также изменения, внесенные другим пользователем. Измененные столбцы выделяются. Следует отметить, что невозможно изменить значения, отображаемые в таблице сведений. Сверху в диалоговом окне можно видеть имя пользователя, который внес изменения, а также дату и время изменений.

Когда два или несколько пользователей вносят ряд изменений, возможно возникновение нескольких конфликтов. Новый конфликт может возникнуть при попытке устранить существующий конфликт. Если имеется несколько конфликтов, диалоговое окно Устранение конфликтов позволяет просмотреть подробные сведения о каждом конфликте с помощью расположенных сверху кнопок Назад и Далее. Конфликты сортируются по номерам строк. Другими словами, конфликт в третьей строке отображается перед конфликтом в четвертой строке. При прокрутке конфликтов затрагиваемые строки получают фокус в таблице. Можно также просмотреть сведения о конкретном конфликте, щелкнув значок «Конфликт» в соответствующей строке. В диалоговом окне будет автоматически выполнена прокрутка к выбранному конфликту, после чего можно просматривать другие конфликты с помощью кнопок Назад и Далее.

Примечание. Если в дополнение к конфликтам в представлении возникли ошибки, в диалоговом окне Устранение конфликтов выводятся сведения об ошибках и предлагаются возможности их устранения.

На основании данных в таблице сведений можно либо отбросить внесенные вами изменения, либо повторить попытку внести эти изменения. Если изменения вносятся в разные столбцы строки, то повторение попытки приведет к объединению внесенных вами изменений с изменениями, внесенными пользователем А. Если изменения вносятся в один и тот же столбец, то ваши изменения будут записаны поверх изменений, внесенных пользователем А. Если имеется несколько конфликтов, то можно выполнить отдельные действия по устранению каждого конфликта или выполнить одно действие для всех конфликтов. Чтобы игнорировать или попытаться повторить все ваши изменения, щелкните ссылку Отменить все мои изменения или Повторить все мои изменения.

Можно закрыть это диалоговое окно без выполнения действий, но в этом случае до устранения конфликтов невозможно будет покинуть или обновить список, а также внести изменения в вычисляемый столбец.

Показать Особые ситуации в диалоговом окне Устранение конфликтов

Ниже перечислены особые случаи, когда информация в диалоговом окне Устранение конфликтов может отображаться по-другому.
  • Вы обновляете строку, которая была удалена другим пользователем. В этом случае в диалоговом окне не отображается имя пользователя и дата и время изменения. В таблице сведений в строке, соответствующей другому пользователю, отображается Удаленная строка. Единственной доступной для вас возможностью является отказ от изменений. Повторить попытку внесения изменений невозможно.
  • Пользователь А обновляет столбец, который не включен в текущее представление. В этом случае в таблицу сведений не будет включен столбец, измененный пользователем А. Повторение попытки своих изменений не приведет к переписыванию изменений, внесенных пользователем А в столбцы, не включенные в представление.
  • Пользователь А изменяет столбец, а затем еще раз изменяет его так, что ячейка получает исходное значение. В этом случае в диалоговом окне будет отображено лишь последнее изменение.
  • Если текущий фильтр задает скрытие строки с конфликтом, то диалоговое окно временно снимает фильтр для отображения строки в таблице. После закрытия диалогового окна фильтр снова применяется автоматически.
  • Если пользователь А добавляет или удаляет вложение с помощью обозревателя, а вы обновляете строку, вы получите сообщение о конфликте. Однако в диалоговом окне столбец в строке Изменения другого пользователя будет выделен только в случае, когда пользователь добавляет первое вложение или удаляет последнее вложение. В столбце в таблице сведений будет отображаться Да, когда имеется одно или несколько вложений, и Нет при отсутствии вложений.
  • Если затронутая ячейка содержит гиперссылку, то в таблице сведений будет отображаться ее URL-адрес, если выводимое имя недоступно. Для рисунка в таблице будет отображаться путь. Если изменяемый столбец содержит текст в формате RTF, то в таблице сведений отображается текст без форматирования. Однако столбец будет выделен при изменении форматирования.
Устранение конфликтов структуры

Возникновение конфликта структуры возможно, когда два или несколько пользователей изменяют разные части списка. Конфликт структуры возникает в случаях, когда устранить противоречия невозможно. Например, пользователь А удаляет столбец, а пользователь Б пытается его изменить; или пользователь А изменяет тип данных столбца, а пользователь Б вводит данные, несовместимые с новым типом данных. В таких ситуациях пользователю Б выводится приглашение обновить список. При обновлении списка будет получена последняя версия списка, но обновления, внесенные пользователем Б, будут отброшены.

Устранение конфликта может привести к новому конфликту или ошибке

Устранение конфликта может привести к возникновению одного или нескольких новых конфликтов или ошибок. Например, пользователь В может внести приводящие к конфликтам изменения, пока вы устраняете конфликты, возникшие после действий пользователя А. Если попытка повторно применить изменения приводит к новому конфликту, он будет добавлен в список существующих конфликтов, а диалоговое окно будет обновлено.


Устранение ошибок

При работе в представлении таблицы данных можно столкнуться с одной или несколькими ошибками. Некоторые из них можно устранить с помощью простого повторения действия или обновления представления. Для устранения других могут потребоваться некоторые усилия. В зависимости от ошибки в представлении отображается достоверная информация для устранения этой ошибки.

Возникновение ошибок
Ошибки возникают в следующих случаях.
  • Открытие представления таблицы данных. Например, могут быть не загружены или не отображены данные.
  • Просмотр или изменение данных в представлении. Например, если сервер не найден, сохранение изменений в данных может не выполниться.
  • Просмотр и изменение структуры списка. Например, удаление столбца может привести к ошибке, связанной с отсутствием разрешений.
  • Просмотр и изменение описания. Например, переупорядочение столбцов может не выполниться в результате превышения времени ожидания сервера.

Типы ошибок
Существует два типа ошибок — ошибки, которые можно устранить с помощью повторного применения изменений, и ошибки, которые можно устранить с помощью отмены изменений.

Ошибки, устраняемые при повторном применении изменений.

  • Нет ответа от сервера. Это может произойти при превышении времени ожидания.
  • Сервер занят или не найден.
  • Ответ сервера нечеткий.
  • Любая другая неожиданная ошибка.

Ошибки, устраняемые при отмене изменений.

  • Для внесения изменений нет необходимых разрешений.
  • Запрещено добавление содержимого на узел.
  • Превышен объем дискового пространства для узла.
Чтобы избежать этих ошибок, свяжитесь с администратором системы.

Устранение ошибок
При возникновении ошибки в соответствующей строке представления, а также в строке состояний отображается значок ошибки ( Значок ошибки). В строке состояний также отображается текст Устранить ошибки. При наличии конфликтов и ошибок отображается текст Устранить конфликты и ошибки данных.

На следующем рисунке показано диалоговое окно Устранение ошибок.

Диалоговое окно «Устранение ошибок»

В таблице сведений отображаются все столбцы текущего представления. В изменяемой строке отображаются внесенные изменения. Значения в таблице сведений изменять нельзя. В верхней части диалогового окна отображается описание ошибки.

При наличии нескольких ошибок сведения о каждой ошибке можно просмотреть с помощью кнопок Назад и Далее в верхней правой части диалогового окна.

На основании информации об ошибке в таблице сведений можно либо отменить внесенные изменения, либо повторить попытку внести эти изменения. При наличии нескольких ошибок можно либо выполнить действия для каждой из них в отдельности, либо выполнить одно действие для всех ошибок сразу. Чтобы пропустить или повторить все ошибки, нажмите кнопку Отменить все мои изменения или Повторить все мои изменения.

Любое действие по устранению ошибки может привести к возникновению новой ошибки. В этом случае диалоговое окно будет обновлено и в нем появятся сведения о новой ошибке.

Можно закрыть это диалоговое окно без выполнения действий, но в этом случае до устранения ошибок невозможно будет покинуть или обновить список, а также внести изменения в вычисляемый столбец.


Устранение ошибок и проблем с конфликтующими изменениями

  1. Щелкните значок Устранить в строке состояния, чтобы отобразить диалоговое окно Устранение конфликтов и ошибок.

  2. Выполните одно из следующих действий.

    • Чтобы разрешить текущий конфликт или ошибку путем игнорирования внесенных в строку изменений, нажмите кнопку Отменить мои изменения. Изменения будут утеряны.
    • Чтобы устранить все конфликты с отложенными изменениями и все ошибки путем игнорирования всех изменений, внесенных в список, нажмите кнопку Отменить все мои изменения.
    • Чтобы разрешить текущий конфликт или ошибку путем повторного применения изменений, нажмите кнопку Повторить мои изменения. В случае возникновения конфликта, когда вы и другой пользователь изменили один и тот-же столбец, повторное применение ваших изменений приведет к замене изменений другого пользователя на ваши. Если редактировалось несколько столбцов, ваши изменения будут слиты с изменениями другого пользователя.
    • Чтобы устранить все конфликты с отложенными изменениями и ошибки путем повторного применения ваших изменений, нажмите кнопку Повторить все мои изменения.
    • Чтобы просмотреть подробные сведения о следующем конфликте или ошибке, нажмите кнопку Далее в верхнем правом углу диалогового окна.
    • Чтобы просмотреть подробные сведения о предыдущем конфликте или ошибке, нажмите кнопку Назад в верхнем правом углу диалогового окна.
    • Чтобы устранить конфликты и ошибки позднее, нажмите кнопку Закрыть в строке заголовка диалогового окна.

Примечания

  • В таблице сведений отображаются все столбцы текущего представления. Если некоторые столбцы не видны, воспользуйтесь горизонтальной полосой прокрутки или перетащите правый край диалогового окна, чтобы увеличить ширину таблицы сведений.

    Чтобы увеличить содержимое столбца, щелкните столбец в таблице сведений. Ваши изменения и изменения другого пользователя будут отображены в диалоговом окне Сведения о поле. Это диалоговое окно также полезно для просмотра изменений RTF.

  • В таблице сведений для строки, уделенной вами или другим пользователем, вместо содержимого строки отображается сообщение Удаленная строка. Если строка была удалена другим пользователем, то имя этого пользователя и время удаления не отображаются в диалоговом окне. Повторить попытку внесения изменений в такую строку невозможно.


Возникновение конфликтов

Конфликт возникает, когда два пользователя одновременно вносят изменения в одну и ту же часть данных или структуры списка. Пользователь, первым отправивший изменения, сможет успешно внести их, тогда как другой пользователь получит уведомление о конфликте.

Типы изменений, которые можно внести в список

Ситуации, приводящие к конфликту

Ситуации, не приводящие к конфликту

Ситуации, приводящие к конфликту структуры

Ситуации, не приводящие к появлению сообщения об ошибке или конфликту

Типы изменений, которые можно внести в список

В список можно внести изменения трех типов. В следующей таблице перечиен каждый из них и приведены примеры.

Тип изменений | Примеры
Изменение данных в списке | Добавление, изменение и удаление строки Вставка содержимого буфера обмена Добавление данных в ячейки путем перетаскивания маркера заполнения Добавление и удаление вложений Форматирование содержимого одной или нескольких ячеек
Изменение структуры списка | Добавление и удаление столбца Изменение параметров столбца Внесение изменений в вычисляемый столбец Изменение параметров списка
Изменение описания представления | Применение фильтра или порядка сортировки Изменение ширины столбцов или высоты строк Изменение порядка столбцов Отображение и скрытие строки итогов.

К началу страницы

Ситуации, приводящие к конфликту

В следующей таблице перечислены ситуации, в которых возникает конфликт.

Пользователь А | Пользователь Б
Удаляет строку | Обновляет ту же строку
Обновляет строку | Обновляет или удаляет ту же строку Примечание. Если пользователь А обновляет строку или документ в библиотеке документов, а пользователь Б удаляет ту же строку или документ, конфликт не возникает.
Добавляет или удаляет вложение с помощью обозревателя | Обновляет или удаляет ту же строку
Удаляет документ | Обновляет ту же строку
Изменяет, переименовывает или сохраняет документ | Обновляет ту же строку
Обновляет строку без изменения документа | Обновляет ту же строку
Изменяет форматирование RTF | Обновляет или удаляет ту же строку

Если пользователь А открывает документ в библиотеке документов, а пользователь Б редактирует документ или изменяет его параметры, то пользователь Б получает сообщение о блокировке документа.

К началу страницы

Ситуации, не приводящие к конфликту

В следующей таблице перечислены ситуации, в которых конфликт не возникает.

Пользователь А | Пользователь Б | Пример
Изменяет данные | Изменяет описание представления | Пользователь А добавляет строку, а пользователь Б применяет порядок сортировки представления
Изменяет структуру | Изменяет описание представления | Пользователь А добавляет столбец, а пользователь Б применяет порядок сортировки представления
Изменяет описание представления | Изменяет данные | Пользователь А применяет порядок сортировки представления, а пользователь Б добавляет строку
Изменяет описание представления | Изменяет структуру | Пользователь А применяет порядок сортировки представления, а пользователь Б добавляет столбец
Изменяет описание представления | Изменяет описание представления | Пользователь А применяет порядок сортировки представления, а вслед за ним пользователь Б применяет другой порядок сортировки Примечание. Поскольку сохраняется последнее изменение, изменения, внесенные пользователем Б, переопределяют изменения, внесенные пользователем А

Примечание. Если пользователи А и Б открывают документ в библиотеке документов только для чтения, а затем решают изменить и сохранить документ, заменяя существующую версию, то последние изменения записываются поверх изменений, внесенных предыдущим пользователем.

К началу страницы

Ситуации, приводящие к конфликту структуры

В следующей таблице перечислены ситуации, в которых выводится сообщение об ошибке. Пользователю Б выводится приглашение обновить список и внесенные им изменения будут отброшены.

Пользователь А | Пользователь Б
Удаляет столбец | Обновляет данные в том же столбце
Изменяет тип данных столбца | Добавляет или обновляет данные с несогласующимся типом
Добавляет, переименовывает или удаляет столбец, изменяет тип данных в столбце или другие свойства | Изменяет вычисляемый столбец
Переименовывает список, изменяет его описание или параметры безопасности, упорядочивает столбцы, включает и отключает запрет вложений или добавляет список на панель быстрого запуска. | Изменяет вычисляемый столбец
Изменяет вычисляемый столбец | Добавляет, переименовывает или удаляет столбец, изменяет тип данных в столбце или другие свойства Примечание. Пользователь Б должен находиться на странице Добавить столбец или Изменение столбца до того, как пользователь A начнет вносить изменения в вычисляемый столбец.
Изменяет вычисляемый столбец | Переименовывает список, изменяет его описание или параметры безопасности, упорядочивает столбцы, включает и отключает запрет вложений или добавляет список на панель быстрого запуска. Примечание. Пользователь Б должен находиться на странице Параметры списка до того, как пользователь А начнет вносить изменения в вычисляемый столбец.

К началу страницы

Ситуации, не приводящие к появлению сообщения об ошибке или конфликту

В следующей таблице перечислены ситуации, в которых не возникает ошибка или конфликт.

Пользователь А | Пользователь Б
Удаляет столбец | Удаляет тот же столбец
Удаляет вложение | Удаляет то же вложение
Удаляет документ | Удаляет тот же документ или строку
Удаляет строку | Удаляет ту же строку

К началу страницы


Экспорт представления таблицы данных

Представление таблицы данных можно экспортировать в приложения Microsoft Office Access 2007 или Microsoft Office Excel 2007. В приложении Office Access 2007 можно экспортировать представление в таблицу в новой или существующей базе данных. Представление можно экспортировать в статическую или связанную с самим представлением таблицу Access. В приложении Office Excel 2007 можно к представлению таблицы данных создать запрос в существующем листе, в новом листе или в новой книге. Изменения, сделанные в представлении таблицы данных будут отражаться в листе Excel. Но изменения в листе Excel не отражаются в представлении таблицы данных.

Экспорт в приложение Access

При экспорте из Службы Microsoft Windows SharePoint Services 3.0 в прилоожение Access в нем создается статическая таблица с данными из представления таблицы данных. Все последующие изменения, вносимые в представление таблицы данных, не будут отображены в статической таблице Access, а изменения в таблице не будут синхронизированы с представлением таблицы данных.

Отслеживание списка в приложении Access

В приложении Access при выборе в области задач пункта Отслеживать этот список в Access создается таблица, которая динамически связывается с таблицей данных SharePoint. Изменения данных в представлении таблицы автоматически отражаются в таблице Access. Аналогично, изменения данных в таблице Access автоматически отражаются в представлении таблицы данных.

Примечание. В некоторых типах списков существуют столбцы, которые можно менять в представлении таблицы данных Службы Windows SharePoint Services 3.0, но которые доступны только для чтения в связанных таблицах Access.

Запрос к списку в приложении Excel

При запросе к представлению таблицы данных из приложения Excel создается запрос в Excel, получающий данные из представления таблицы данных. Изменения данных в представлении таблицы данных отражаются в листе Excel, но изменения в листе Excel не отражаются в представлении таблицы данных.


Запрос к списку из приложения Excel

  1. На панели инструментов представления таблицы данных нажмите кнопку Действия, а затем выберите пункт Область задач для отображения области задач представления таблицы данных.
  2. Выберите пункт Запрос к списку из приложения Excel.

Служба Windows SharePoint Services экспортирует представление таблицы данных в Microsoft Excel в виде файла веб-запроса. Если приложение Excel уже запущено, предлагается выбрать способ отображения данных и вариант их добавления: в существующий лист, новый лист или новую книгу. В противном случае выполняется заупск Excel и с добавлением данных в новую книгу. Затем импортированные данные отображаются на листе в виде списка, после чего устанавливается связь между этим листом и представлением таблицы данных.

Обновление листа в соответствии с изменениями, внесенными в представление таблицы данных

После внесения изменений в данные в представлении таблицы данных можно обновить лист Excel с помощью средства обновления внешних данных в Excel. Дополнительные сведения см. в справке Excel.


Экспорт контактной информации и сведений о событиях

Экспорт контактной информации

В стандартном представлении и в представлении таблицы данных списка контактов можно экспортировать в приложение Microsoft Office Outlook 2007 весь список контактов или отдельный контакт из списка.

Экспорт списка контактов

  1. В стандартном представлении или в представлении таблицы данных списка контактов нажмите кнопку Действия, а затем выберите пункт Подключиться к Outlook.
  2. В ответ на приглашение приложения Office Outlook 2007 подтвердить подключение списка контактов к приложению Outlook нажмите кнопку Да.

После экспорта списка контактов в Outlook ссылка настраивается таким образом, что при внесении изменений в список контактов Windows SharePoint Services эти изменения также вносятся в список контактов Outlook. Изменения отображаются после перезагрузки списка контактов в Outlook.

Экспорт отдельного контакта

  1. Выполните одно из следующих действий.
    • В стандартном представлении щелкните стрелку раскрывающегося списка в ячейке «Фамилия» для того контакта, который нужно экспортировать, а затем выберите команду Экспорт контакта.
    • В представлении таблицы данных щелкните правой кнопкой мыши контакт, который нужно экспортировать, а затем выберите команду Экспорт контакта.
  2. В ответ на приглашение подтвердить загрузку файла виртуальной визитной карточки (файл с расширением VCF) нажмите кнопку Открыть.

При этом контакт будет экспортирован в список контактов Контакты Outlook, используемый по умолчанию. Затем можно принять решение, сохранять контакт в списке Контакты или в другом списке контактов.

Экспорт сведений о событиях

В стандартном представлении и в представлении таблицы данных списка событий можно экспортировать в Microsoft Outlook весь список событий либо отдельное событие.Чтобы увидеть календарь как список событий, в раскрывающемся списке Вид выберите значение Все события.

Экспорт списка событий

  1. В стандартном представлении или в представлении таблицы данных списка событий нажмите кнопку Действия, а затем выберите команду Подключиться к Outlook.
  2. В ответ на приглашение подтвердить подключение календаря в службе Windows SharePoint Services к приложению Outlook нажмите кнопку Да.

После экспорта списка событий в Outlook для списка событий создается календарь в Outlook. Ссылка настраивается таким образом, что при внесении изменений в список событий в службе Windows SharePoint Services эти изменения также вносятся в календарь Outlook. Изменения отображаются после перезагрузки календаря в Outlook.

Экспорт отдельного события

  1. Выполните одно из следующих действий.
    • В представлении таблицы данных щелкните правой кнопкой мыши в любом месте строки события, которое требуется экспортировать, и выберите команду Экспорт события.
    • В стандартном представлении щелкните событие, которое требуется экспортировать, а затем нажмите кнопку Экспорт события.
  2. В ответ на приглашение подтвердить загрузку файла календаря Интернета (файл с расширением ICS) нажмите кнопку Открыть.

При этом событие будет экспортировано в календарь Календарь Outlook, используемый по умолчанию. Затем можно принять решение, сохранить событие в календаре Календарь или в другом календаре.


Экспорт или связывание представления таблицы данных с программой Access

Экспорт представления таблицы данных в приложение Access
  1. На панели инструментов представления таблицы данных нажмите кнопку Действия, а затем выберите пункт Область задач для отображения области задач представления таблицы данных.
  2. Выберите команду Экспорт в Access.
  3. Выберите экспорт представления таблицы данных в существующую или новую базу данных и нажмите кнопку ОК.

Microsoft Access предлагает задать расположение базы данных и открывает таблицу, содержащую экспортированные данные.

Отслеживание списка в приложении Access

Отслеживать представление таблицы данных в приложении Access можно путем создания связанной таблицы в Access, связанной с представлением таблицы данных.

  1. Если область задач еще не отображена, на панели инструментов представления таблицы данных нажмите кнопку Действия, а затем выберите пункт Область задач.
  2. Выберите команду Отслеживать этот список в Access.
  3. Выберите, экспортировать таблицу данных в существующую или новую базу данных, а затем нажмите кнопку ОК.

Access предлагает задать расположение базы данных и создает связанную таблицу, связанную с представлением таблицы данных.

Обновление представления таблицы данных в соответствии с изменениями в связанной таблице После обновления связанной таблицы нажмите кнопку Действия на панели инструментов представления таблицы данных и выберите команду Обновить данные

Обновление связанной таблицы в соответствии с изменениями в представлении таблицы данных После изменения данных в представлении таблицы данных можно увидеть изменения в связанной таблице, воспользовавшись командой «Обновить» приложения Access или закрыв и вновь открыв связанную таблицу.


Создание отчета приложения Access

Для создания отчета Microsoft Access в представлении таблицы данных необходимо создать связанную таблицу, содержащую необходимые данные, а затем составить отчет, основанный на этих данных.

  1. На панели инструментов представления таблицы данных нажмите кнопку Действия и выберите пункт Область задач для отображения области задач представления таблицы данных.
  2. Нажмите кнопку Отчет в Access.
  3. Выберите, будет ли таблица экспортироваться в существующую или новую базу данных, и нажмите кнопку ОК.

Access предлагает задать расположение базы данных и создает связанную таблицу с данными Службы Microsoft Windows SharePoint Services 3.0. Затем создается простой отчет, отображающий поля и записи исходной таблицы. Для получения дополнительных сведений об отчетах Access выполните поиск по словам «создать отчет» в справке Access.


Создание диаграммы Microsoft Excel

При создании диаграммы Microsoft Office Excel 2007 на основе представления таблицы данных необходимо связать эту таблицу с Office Excel 2007, а затем построить диаграмму на основе полученных данных.

  1. На панели инструментов режима таблицы данных нажмите кнопку Действия, а затем выберите пункт Область задач для отображения области задач представления таблицы данных.
  2. Выберите пункт Диаграмма в Excel.

Windows SharePoint Services экспортирует таблицу данных в Excel в виде файла веб-запроса.

Если приложение Microsoft Excel открыто, файл веб-запроса можно импортировать в существующий лист, новый лист или новую книгу. В противном случае Microsoft Excel открывает и импортирует таблицу данных в новую книгу. Полученные данные отображаются в виде списка на листе Excel, который связывается с представлением таблицы данных; затем предлагается построить диаграмму, используя мастер диаграмм. Дополнительные сведения о диаграммах см. в разделе справки Microsoft Excel «Диаграммы».


Создание сводной таблицы Microsoft Excel

При создании сводной таблицы Microsoft Office Excel 2007 на основе представления таблицы данных необходимо связать эту таблицу с Office Excel 2007, а затем создать сводную таблицу на основе полученных данных.

  1. На панели инструментов представления таблицы данных нажмите кнопку Действия и выберите пункт Область задач для отображения области задач представления таблицы данных.
  2. Нажмите кнопку Создать отчет сводной таблицы Excel.

Службы Службы Microsoft Windows SharePoint Services 3.0 экспортируют таблицу данных в Excel в виде файл веб-запроса.

Если приложение Microsoft Excel открыто, файл веб-запроса можно импортировать в существующий лист, новый лист или новую книгу. В противном случае таблица данных будет по умолчанию импортирована в новую книгу Microsoft Excel. Полученные данные отображаются в виде списка на листе Excel, который связывается с представлением таблицы данных. Затем отображается список полей сводной таблицы, панель инструментов сводной таблицы и выводится предложение о создании сводной таблицы. Дополнительные сведения о сводной таблице Microsoft Excel см. в разделе справки Microsoft Excel «Отчеты сводных таблиц».


Печать представления таблицы данных в приложении Excel

При печати таблицы данных в Microsoft Office Excel 2007 службы Windows SharePoint Services сначала создают заспрос списка в Office Excel 2007, а затем печатают экспортированные данные.

  1. На панели инструментов представления таблицы данных нажмите кнопку Действия, а затем выберите пункт Область задач для отображения области задач для представления таблицы данных.
  2. Нажмите кнопку Печать в Excel.

Windows SharePoint Services экспортирует представление таблицы данных в Excel как файл веб-запроса.

Если приложение Excel запущено, пользователю можно выбрать импорт данных из файла веб-запроса в существующий лист, новый лист или новую книгу. В противном случае, Excel создает новую книгу и импортирует в нее таблицу данных. Затем импортированные данные отображаются в виде списка Excel на листе, а лист связывается с представлением таблицы данных.


Операторы вычисления

Операторы задают тип вычисления, которое нужно выполнить над элементами формулы. Списки поддерживают три различных типа операторов вычисления: арифметические, сравнения и текстовые.

Типы операторов

Порядок выполнения операций в формуле Microsoft Excel

Типы операторов

Арифметические операторы Следующие арифметические операторы используются для выполнения обычных математических операций, таких как сложение, вычитание или умножение, объединения чисел и получения числовых результатов.

Арифметический оператор | Значение (пример)
+ (знак «плюс») | Сложение (3+3)
- (знак «минус») | Вычитание (3–1) Отрицание (–1)
* (звездочка) | Умножение (3*3)
/ (косая черта) | Деление (3/3)
% (знак процента) | Процент (20%)
^ (крышка) | Возведение в степень (3^2)

Операторы сравнения. С помощью следующих операторов можно сравнить два значения. Результатом сравнения является логическое значение Yes или No.

Оператор сравнения | Значение (пример)
= (знак равенства) | Равно (A=B)
> (знак «больше») | Больше (A>B)
< (знак «меньше») | Меньше (A<B)
>= (знак «больше или равно») | Больше или равно (A>=B)
<= (знак «меньше или равно») | Меньше или равно (A<=B)
<> (знак «не равно») | Не равно (A<>B)

Оператор связывания текста. Амперсанд (&) служит для связи нескольких текстовых строк в единый фрагмент текста.

Текстовый оператор | Значение (пример)
& (амперсанд) | Связывает два значения для получения одного слитного текстового значения («Северный»&«ветер»)

К началу страницы

Порядок выполнения операций формулы в списке

Значения формул вычисляются в определенном порядке. Формула списка должна начинаться со знака равенства (=), за которым следуют вычисляемые элементы (операнды), разделенные операторами вычисления. Формулы в списках вычисляются слева направо в соответствии с определенным порядком для каждого оператора в формуле.

Приоритет операторов

При сочетании в одной формуле нескольких операторов операции в списке выполняются в порядке, приведенном в следующей таблице. Если в формуле содержатся операторы с одинаковым приоритетом, например оператор умножения и деления, операторы вычисляются слева направо.

Оператор | Описание
– | Отрицание (например, –1)
% | Процент
^ | Возведение в степень
* и / | Умножение и деление
+ и – | Сложение и вычитание
& | Связь двух строк текста (связывание)
= < > <= >= <> | Сравнение

Использование скобок

Чтобы изменить порядок вычисления, необходимо заключить в скобки ту часть формулы, которая должна вычисляться первой. Например, результатом вычисления следующей формулы будет значение 11, так как умножение в списке вычисляется перед сложением. В формуле число 2 умножается на 3 и к результату прибавляется 5.

=5+2*3

Если использовать скобки, то сначала будут сложены 5 и 2, а затем полученное значение умножается на 3. В результате будет получено значение 21.

=(5+2)*3

В следующем примере благодаря скобкам вокруг первой части формулы сначала вычисляется сумма [Цена]+25, а затем результат делится на сумму значений столбцов EC1 и EC2.

=([Цена]+25)/СУММ([EC1]+[EC2])

К началу страницы


Ссылки на столбцы в формулах

Ссылка на столбец задает ячейку в текущей строке листа и указывает на расположение значений или данных, которые нужно использовать в формуле. Например, ссылка [Цена] указывает на значения ячейки столбца «Цена» текущей строки. Если ячейка на пересечении текущей строки и столбца «Цена » содержит значение 100, формула вида «=[Цена]*3» вернет значение 300.

Ссылки позволяют использовать данные из разных столбцов списка в одной или нескольких формулах. В формулах можно использовать ссылки на столбцы следующих типов данных: однострочный текст, число, денежный, дата и время, выбор, да/нет, вычисляемый.

Чтобы сослаться на столбец в формуле, нужно использовать имя столбца. Если имя содержит пробелы или специальные знаки, нужно заключить имя в квадратные скобки ([ ]). Регистр знаков в ссылках не учитывается. Например, на столбец «Цена товара» можно ссылаться в формуле как на [Цена Товара] или [цена товара].

Примечание. Нельзя ссылаться на значение в строке, отличной от текущей. Нельзя также включать ссылки на столбцы в формулы, заданные как значения столбца по умолчанию.


Константы в формулах

Константа — это значение, не являющееся результатом вычисления. Например, дата 10/9/2008, число 210 или текст «ежеквартальная прибыль». Существуют следующие типы констант.

  • String (Пример: =[Last Name] = "Иванов")

    Строковые константы заключаются в двойные кавычки и могут содержать до 225 знаков.

  • Number (Пример: =[Cost] >= 29.99.)

    Числовые константы могут содержать десятичные знаки, а также быть положительными или отрицательными.

  • Date (Пример: =[Date] <> 7/7/2002)

    Эти константы не требуют символов-разделителей.

  • Boolean (Пример: =IF([Cost]>[Revenue], "Loss", "No Loss")

    Yes и No также являются константами типа Boolean. Их можно использовать в условных выражениях. В приведенном примере значение Cost больше значения Revenue, поэтому функция IF возвращает Yes, а результатом является строка «Loss». Если значение Cost равно значению Revenue, функция возвращает No, а результатом является строка «No Loss».


Отображение итогов и вычисляемых значений

В списке в режиме веб-таблицы Access можно выполнять различные виды вычислений, отображать статистические значения (например, сумму или среднее) для столбцов, добавлять вычисляемые столбцы, которые содержат формулы для вычисления значений каждой строки, а также использовать формулы для задания значения по умолчанию для столбца.

На следующем рисунке показан список «Сотрудники — Платежная ведомость» в режиме веб-таблицы Access. В списке отражены статистические значения в строке итогов в нижней части списка и вычисляемый столбец «Платеж».

Таблица с вычислениями и итогами

В строке итогов отображается число строк столбца «Сотрудник» и сумма значений столбца «Платеж», вычисляемых по формуле, которая отображается на всплывающей подсказке для каждой строки.

Отображение статистических значений

Отображение вычисляемых данных в столбце

Использование формулы для вычисления значений по умолчанию

Отображение статистических значений

Строку итогов можно отобразить или скрыть, нажав кнопку Действия и затем выбрав Итоги. При первом нажатии кнопки Итоги в строке итогов отображаются суммарные значения для каждого числового столбца в списке. Если таких столбцов нет, отображается число элементов последнего столбца списка. Данные в строке итогов изменять нельзя.

Если строка итогов отображается, то можно показать или скрыть статистические значения для заданного столбца, а также изменить статистическую функцию, используемую в столбце, выбрав другую в раскрывающемся списке строки итогов. При наведении указателя мыши на статистическое значение, указывающее на используемую в колонке статистическую функцию, появится соответствующая всплывающая подсказка.

Нельзя применять фильтр к списку статистических значений. Однако если список содержит фильтр, статистические значения будут вычисляться на основе элементов, отображаемых в результате применения этого фильтра. Кроме того, данные в строке итогов не участвуют в сортировке.

В следующей таблице приведены статистические функции, доступные в списке, а также типы данных, поддерживаемые каждой из этих функций.

Функция | Описание | Поддерживаемые типы данных
Среднее | Возвращает среднее для значений столбца, участвующего в вычислении | Number, Currency, DateTime
Число | Суммирует число значений. Для столбцов с типами Boolean, Attachment и DocIcon в вычислении участвуют значения Yes | Number, Currency, DateTime, Boolean, Attachment, DocIcon, ShortText, MultiLineText, SingleChoice, MultiChoice, Lookup, Hyperlink
Максимум | Возвращает наибольшее значение в столбце, участвующем в вычислении | Number, Currency, DateTime
Минимум | Возвращает наименьшее значение в столбце, участвующем в вычислении | Number, Currency, DateTime
Сумма | Вычисляет сумму значений в столбце | Number, Currency
Стандартное отклонение | Возвращает стандартное отклонение по выборке (из значений), полагая, что выборкой является часть генеральной совокупности | Number, Currency
Дисперсия | Возвращает дисперсию по выборке (из значений), полагая, что выборкой является часть генеральной совокупности | Number, Currency

Кроме этих функций, в списке строки итогов есть вариант Нет. Выберите Нет, чтобы отключить отображение итогов для данного столбца.

Данные в вычисляемом столбце можно сгруппировать. При этом количество доступных функций зависит от типа данных, возвращаемых при вычислении.

К началу страницы

Отображение вычисляемых данных в столбце

Чтобы вычислить значения с помощью формулы, следует добавить вычисляемый столбец в список. В формулу входят значения, содержащиеся в различных столбцах, но в одной строке. При этом в формуле нельзя ссылаться на какую-либо другую ячейку или набор ячеек.

Результаты вычислений сохраняются в столбце, однако их нельзя изменять. При изменении значения, на которое ссылается формула, итоговое значение будет пересчитано в вычисляемом столбце.

Если поместить указатель мыши на вычисляемое значение, появится всплывающая подсказка, отображающая формулу, по которой производится вычисление. Формулу можно изменить в соответствующей ячейке в режиме изменения. После этого в столбце будут отображены новые значения в соответствии с введенной формулой.

В вычисляемом столбце можно проводить сортировку, а также применять фильтр.

К началу страницы

Использование формулы для вычисления значений по умолчанию

Если в список добавляется столбец с типом Однострочный текст, Выбор, Число, Денежный или Дата и время, то вместо константы в качестве значения по умолчанию можно задать формулу. При добавлении новой строки формула вычисляется, а результат отображается в столбце как значение по умолчанию.

Если в качестве значения по умолчанию задается формула, в ней допустимо использование любых доступных функций, однако при этом она не может ссылаться на другие столбцы, поскольку вычисляется до того, как в эти столбцы введены данные.

К началу страницы


Формулы

Формулы выполняют вычисления со значениями в списке. Формула начинается со знака равенства (=). Например, в следующей формуле число 2 умножается на 3 и результат складывается с числом 5.

=5+2*3

Формулы можно использовать в вычисляемом столбце, а также для вычисления значений по умолчанию для столбца.

Формула может также содержать функции, ссылки на столбец, операторы и константы.

Части формулы
= ПИ()*[Result]^2

Функции. Функция ПИ() возвращает значение числа pi: 3,142...

Ссылки (имена столбцов). [Результат] показывает значение текущей строки в столбце «Результат».

Константы. Числа или текстовые значения, вводимые в формулу. Например, число 2.

Операторы. Оператор «^» (крышка) возводит число в степень, а оператор «*» (звездочка) перемножает.

Примеры

В формуле может использоваться один или несколько элементов, упомянутых выше. Ниже приведено несколько примеров формул (в порядке сложности).

  • Простые формулы (например, =128+345)

    Следующие формулы содержат константы и операторы.

    Пример | Описание
    =128+345 | Сложение чисел 128 и 345.
    =5^2 | Возведение числа 5 в квадрат.
  • Формулы, содержащие ссылки на столбцы (например, =[Доход] – [Цена])

    С помощью следующих формул осуществляется ссылка на другие столбцы списка.

    Пример | Описание
    =[Доход] | Использует значение столбца «Доход».
    =[Доход]*10/100 | 10% от значения столбца «Доход».
    =[Доход] > [Цена] | Возвращает Да, если значение столбца «Доход» больше, чем значение столбца «Цена».
  • Формулы, вызывающие функции (например, =«AVG»(1, 2, 3, 4, 5)»)

    Следующие формулы вызывают встроенные функции.

    Пример | Описание
    =МАКС(Q1; Q2; Q3; Q4) | Возвращает наибольшее значение в наборе значений.
    =ЕСЛИ(Цена>Доход; "Плохо"; "Хорошо") | Возвращает Плохо, если цена больше дохода. В противном случае возвращает Хорошо.
    =ДЕНЬ("15-Апр-2008") | Возвращает день в дате. Данная формула возвращает число 15.
  • Формулы с вложенными функциями (например, =СУММ(ОКРУГЛ([Цена];2);[Прибыль])

    В следующих формулах в качестве аргументов выступают одна или несколько функций.

    Пример Описание
    =СУММ(ЕСЛИ(A>B; A-B; 10); C) Функция ЕСЛИ возвращает разницу между значениями в столбцах A и B или число 10.

    Функция СУММ складывает значение, возвращаемое функцией ЕСЛИ, и значение столбца C.

    =ГРАДУСЫ(ПИ()) Функция ПИ возвращает число 3,14159265358979.

    Функция ГРАДУСЫ преобразует в градусы значение в радианах. Данная формула возвращает значение 180.
    =ЕЧИСЛО(НАЙТИ("БД"; Столбец1)) Функция НАЙТИ осуществляет поиск строки «БД» в столбце 1 и возвращает начальную позицию строки. Если строка не найдена, функция возвращает значение ошибки.

    Функция ЕЧИСЛО возвращает Да, если результатом вычисления функции НАЙТИ является числовое значение. В противном случае возвращается значение Нет.


Изменение формулы

  1. Выберите мышью любую ячейку в вычисляемом столбце.
  2. Повторно щелкните ячейку, чтобы отобразить текущую формулу.
  3. Измените формулу и нажмите клавишу ВВОД.

    Примечание. После того, как в вычисляемый столбец введен знак равенства (=), можно вставлять в формулу ссылки на столбцы путем выбора ячеек текущей строки. Однако, если столбец ячейки принадлежит к типу данных, не поддерживающему вычисления, если ячейка принадлежит другой строке, а также при попытке выбрать несколько ячеек вставки ссылки в формулу не произойдет.

  4. Нажмите кнопку Продолжить для подтверждения изменений.
  5. При наличии конфликтов,ошибок или отложенных изменений в списке будет предложено отклонить или применить изменения. Изменение формулы приводит к изменению структуры списка, поэтому новая формула вычисляется только после применения или отклонения всех изменений и устранения всех конфликтов и ошибок списка.

    Нажмите кнопку ОК, чтобы применить изменения и устранить конфликты и ошибки.

  6. Отложенные изменения будут отправлены из списка на сервер. При наличии конфликтов и ошибок будет отображено диалоговое окно Устранение конфликтов и ошибок. Примите или отклоните изменения.


Примеры обычных формул

Примечание. Следующие примеры можно использовать в вычисляемых столбцах. Примеры, не содержащие ссылок на столбец, можно использовать для указания в столбце значения по умолчанию.

Условные формулы

Показать Проверка условия, когда число больше или меньше другого числа

Для этой задачи используется функция ЕСЛИ.

Столбец1 | Столбец2 | Формула | Описание
15000 | 9000 | =Столбец1>Столбец2 | Столбец1 больше Столбец2? (0)
15000 | 9000 | =ЕСЛИ(Столбец1<=Столбец2; "Да"; "Нет") | Столбец1 меньше или равняется Столбец2? (Нет)

Показать Возвращение логического значения после сравнения содержимого столбцов

Для того чтобы результат был логическим значением (0 или 1), используют функции И, ИЛИ или НЕ.
Столбец1 | Столбец2 | Столбец3 | Формула | Описание
15 | 9 | 8 | =И(Столбец1>Столбец2; Столбец1<Столбец3) | 15 больше 9 и меньше 8? (Нет)
15 | 9 | 8 | =ИЛИ(Столбец1>Столбец2; Столбец1<Столбец3) | 15 больше 9 или меньше 8? (Да)
15 | 9 | 8 | =НЕ(Столбец1+Столбец2=24) | 15 плюс 9 не равно 24? (Нет)

Для того чтобы результат определялся другим вычислением или был значением, отличным «Да» или «Нет», используют функции ЕСЛИ, И и ИЛИ.

Столбец1 | Столбец2 | Столбец3 | Формула | Описание
15 | 9 | 8 | =ЕСЛИ(Столбец1=15; "Да"; "Нет") | Если Столбец1 равняется 15, возвращается «Да». (Да)
15 | 9 | 8 | =ЕСЛИ(И(Столбец1>Столбец2; Столбец1<Столбец3); "Да"; "Нет") | Если 15 больше 9 и меньше 8, возвращается «Да». (Нет)
15 | 9 | 8 | =ЕСЛИ(ИЛИ(Столбец1>Столбец2; Столбец1<Столбец3); "Да"; "Нет") | Если 15 больше 9 или меньше 8, возвращается «Да». (Да)

Показать Отображение нулей в виде пустых значений или дефисов

Для этой задачи используется функция ЕСЛИ.
Столбец1 | Столбец2 | Формула | Описание
10 | 10 | =Столбец1-Столбец2 | Второе число вычитается из первого (0)
10 | 10 | =ЕСЛИ(Столбец1-Столбец2;"";Столбец1-Столбец2) | Когда значение равняется нулю, возвращается пустое значение (пустой столбец)
15 | 9 | =ЕСЛИ(Столбец1-Столбец2;"-";Столбец1-Столбец2) | Когда значение равняется нулю, возвращается дефис (-)

Формулы для значений даты и времени

Показать Сложение дат

Чтобы прибавить к дате определенное число дней, используется оператор сложения (+). Отметим, что при операциях с датами для вычисляемого столбца следует выбрать тип данных Дата и время.
Столбец1 | Столбец2 | Формула | Описание
9.06.2007 | 3 | =Столбец1+Столбец2 | Прибавляет 3 дня к 09.06.2007 (12.06.2007)
10.12.2008 | 54 | =Столбец1+Столбец2 | Прибавляет 54 дня к 10.12.2008 (02.02.2009)

Чтобы прибавить к дате определенное число месяцев, используются функции ДАТА, ГОД, МЕСЯЦ и ДЕНЬ.

Столбец1 | Столбец2 | Формула | Описание
09.06.2007 | 3 | =ДАТА(ГОД(Столбец1);МЕСЯЦ(Столбец1)+Столбец2;ДЕНЬ(Столбец1)) | Прибавляет 3 месяца к 09.06.2007 (09.09.2007)
10.12.2008 | 25 | =ДАТА(Год(Столбец1);МЕСЯЦ(Столбец1)+Столбец2;ДЕНЬ(Столбец1)) | Прибавляет 25 месяцев к 10.12.2008 (10.01.2011)

Чтобы прибавить к дате определенное число лет, используются функции ДАТА, ГОД, МЕСЯЦ и ДЕНЬ.

Столбец1 | Столбец2 | Формула | Описание
09.06.2007 | 3 | =ДАТА(ГОД(Столбец1)+Столбец2;МЕСЯЦ(Столбец1);ДЕНЬ(Столбец1)) | Прибавляет 3 года к 09.06.2007 (09.06.2010)
10.12.2008 | 25 | =ДАТА(ГОД(Столбец1)+Столбец2;МЕСЯЦ(Столбец1);ДЕНЬ(Столбец1)) | Прибавляет 25 лет к 10.12.2008 (10.12.2033)

Чтобы прибавить к дате определенную комбинацию дней, месяцев и лет лет, используются функции ДАТА, ГОД, МЕСЯЦ и ДЕНЬ.

Столбец1 | Формула | Описание
09.06.2007 | =ДАТА(ГОД(Столбец1)+3;МЕСЯЦ(Столбец1)+1;ДЕНЬ(Столбец1)+5) | Прибавляет 3 года, 1 месяц и 5 дней к 09.06.2007 (14.07.2010)
10.12.2008 | =ДАТА(ГОД(Столбец1)+1;МЕСЯЦ(Столбец1)+7;ДЕНЬ(Столбец1)+5) | Прибавляет 1 год, 7 месяцев и 5 дней к 09.06.2007 (14.01.2009)

Показать Расчет разности двух дат

Для этой задачи используется функция РАЗНДАТ.
Столбец1 | Столбец2 | Формула | Описание
01-Янв-1995 | 01-Июн-1995 | =РАЗНДАТ(Столбец1; Столбец2;"д") | Возвращает число дней между двумя датами (1626)
01-Янв-1995 | 01-Июн-1995 | =РАЗНДАТ(Столбец1; Столбец2;"гм") | Возвращает число месяцев между датами, игнорируя часть года (5)
01-Янв-1995 | 01-Июн-1995 | =РАЗНДАТ(Столбец1; Столбец2;"гд") | Возвращает число дней между датами, игнорируя часть года (165)

Показать Расчет разности двух значений времени

Для представления результата в стандартном формате времени (часы:минуты:секунды), используется оператор вычитания (-) и функция ТЕКСТ.

Для применения этого способа значение часов не должно превышать 24, а значения минут и секунд не должны превышать 60.

Столбец1 | Столбец2 | Формула | Описание
06/09/2007 10:35 AM | 06/09/2007 3:30 PM | =ТЕКСТ(Столбец2-Столбец1;"ч") | Количество часов между двумя значениями времени (4)
06/09/2007 10:35 AM | 06/09/2007 3:30 PM | =ТЕКСТ(Столбец2-Столбец1;"ч:мм") | Количество часов и минут между двумя значениями времени (4:55)
06/09/2007 10:35 AM | 06/09/2007 3:30 PM | =ТЕКСТ(Столбец2-Столбец1;"ч:мм:сс") | Количество часов, минут и секунд между двумя значениями времени (04:55:00)

Для представления результата с помощью одной единицы изменения времени используется функция ЦЕЛОЕ или функции ЧАС, МИНУТЫ и СЕКУНДЫ.

Столбец1 | Столбец2 | Формула | Описание
06/09/2007 10:35 AM | 06/10/2007 3:30 PM | =ЦЕЛОЕ((Столбец2-Столбец1)*24) | Количество часов между двумя значениями времени (28)
06/09/2007 10:35 AM | 06/10/2007 3:30 PM | =ЦЕЛОЕ((Столбец2-Столбец1)*1440) | Количество минут между двумя значениями времени (1735)
06/09/2007 10:35 AM | 06/10/2007 3:30 PM | =ЦЕЛОЕ((Столбец2-Столбец1)*86400) | Количество секунд между двумя значениями времени (104100)
06/09/2007 10:35 AM | 06/10/2007 3:30 PM | =ЧАС(Столбец2-Столбец1) | Количество часов между двумя значениями времени, когда разница не превышает 24. (4)
06/09/2007 10:35 AM | 06/10/2007 3:30 PM | =МИНУТЫ(Столбец2-Столбец1) | Количество минут между двумя значениями времени, когда разница не превышает 60. (55)
06/09/2007 10:35 AM | 06/10/2007 3:30 PM | =СЕКУНДЫ(Столбец2-Столбец1) | Количество секунд между двумя значениями времени, когда разница не превышает 60 (0).

Показать Преобразование значений времени

Для преобразования значения часов из стандартного формата времени в десятичное число, используется функция ЦЕЛОЕ.
Столбец1 | Формула | Описание
10:35 AM | =(Столбец1-ЦЕЛОЕ(Столбец1))*24 | Количество часов после полудня (10.583333)
12:15 PM | =(Столбец1-ЦЕЛОЕ(Столбец1))*24 | Количество часов после полудня (12.25)

Для преобразования значения часов из десятичного числа в стандартный формат (часы:минуты:секунды), используется оператор деления и функция ТЕКСТ.

Столбец1 | Формула | Описание
10:5833 | =ТЕКСТ(Столбец1/24; "ч:мм") | Количество часов после полудня (10:35)
12:25 | =ТЕКСТ(Столбец1/24; "ч:мм") | Количество часов после полудня (12:15)

Показать Вставка юлианских дат

Слова «юлианская дата» иногда используются для ссылки на формат дат, представляющий комбинацию текущего года и числа дней с начала года. Например, 1 января 2007 г. представляется как 2007001, а 31 декабря 2007 г. представляется как 2007356.

Юлианские даты, часто используемые в астрономии, представляют последовательную систему датировки, начинающуюся с 1 января 4713 г. до н. э.

Примечание. Этот формат не базируется на юлианском календаре.

Для преобразования даты в юлианскую даты используются функции ТЕКСТ и ДАТАЗНАЧ.

Столбец1 | Формула | Описание
23.06.2007 | =ТЕКСТ(Столбец1;"гг")&ТЕКСТ((Столбец1-ДАТАЗНАЧ("1/1/"& ТЕКСТ(Столбец1;"гг"))+1);"000") | Дата в юлианском формате с двухзначным значением года (07174)
23.06.2007 | =ТЕКСТ(Столбец1;"гггг")&ТЕКСТ((Столбец1-ДАТАЗНАЧ("1/1/"&ТЕКСТ(Столбец1;"гг"))+1);"000") | Дата в юлианском формате с четырехзначным значением года (2007174)

Для преобразования даты к юлианскому астрономическому формату используется константа 2415018,50.

Эта формула работает только для дат после 01.03.1901 и только при использовании системы дат 1900.

Столбец1 | Формула | Описание
23.06.2007 | =Столбец1+2415018,50 | Дата в юлианском формате, используемом в астрономии (2454274,50)

Показать Отображение дат как дней недели

Для преобразование дат в текстовое значение дня недели используются функции ТЕКСТ и ДЕНЬНЕД.
Столбец1 | Формула | Описание
19-Фев-2007 | =ТЕКСТ(ДЕНЬНЕД(Столбец1); "дддд") | Для даты рассчитывается день недели и возвращается полное название дня (понедельник)
01-Янв-2008 | =ТЕКСТ(ДЕНЬНЕД(Столбец1): "ддд") | Для даты рассчитывается день недели и возвращается краткое название дня (понедельник)

Математические формулы

Показать Сложение чисел

Для сложения чисел из двух или нескольких столбцов в строке используется оператор сложения или функция СУММ.

Столбец1 | Столбец2 | Столбец3 | Формула | Описание
6 | 5 | 4 | =Столбец1+Столбец2+Столбец3 | Сумма значений из трех первых столбцов (15)
6 | 5 | 4 | =СУММ(Столбец1;Столбец2;Столбец3) | Сумма значений из трех первых столбцов (15)
6 | 5 | 4 | =СУММ(ЕСЛИ(Столбец1>Столбец2; Столбец1-Столбец2; 10); Столбец3) | Если Столбец1 больше Столбец2, суммирует разность и Столбец3. В противном случае суммирует 10 и Столбец3. (5)

Показать Вычитание чисел

Для этой задачи используется оператор вычитания (-).
Столбец1 | Столбец2 | Столбец3 | Формула | Описание
15000 | 9000 | -8000 | =Столбец1-Столбец2 | Вычитание 9000 из 15000 (6000)
15000 | 9000 | -8000 | =СУММ(Столбец1; Столбец2; Столбец3) | Сумма значений из трех первых столбцов, включая отрицательные значения (16000)

Показать Расчет относительно разности двух чисел

Используются операторы вычитания (-) и деления (/) с функцией ABS.
Столбец1 | Столбец2 | Формула | Описание
2342 | 2500 | =(Столбец2-Столбец1)/ABS(Столбец1) | Относительное изменение (6,75% или 0,06746)

Показать Умножение чисел

Для этой задачи используется оператор умножения (*) или функция ПРОИЗВЕД.
Столбец1 | Столбец2 | Формула | Описание
5 | 2 | =Столбец1*Столбец2 | Произведение чисел из двух первых столбцов (10)
5 | 2 | =ПРОИЗВЕД(Столбец1; Столбец2) | Произведение чисел из двух первых столбцов (10)
5 | 2 | =ПРОИЗВЕД(Столбец1;Столбец2;2) | Произведение чисел из двух первых столбцов и числа 2 (20)

Показать Деление чисел

Для этой задачи используется оператор деления (/).

Столбец1 | Столбец2 | Формула | Описание
15000 | 12 | =Столбец1/Столбец2 | Деление 15000 на 12 (1250)
15000 | 12 | =(Столбец1+10000)/Столбец2 | Сумма 15000 и 9000 делится на 12 (2000)

Показать Расчет среднеарифметического значения для нескольких чисел

Среднеарифметическое значение также называют просто средним. Для расчета среднего значения чисел из двух или нескольких столбцов в строке используется функция СРЗНАЧ.

Столбец1 | Столбец2 | Столбец3 | Формула | Описание
6 | 5 | 4 | =СРЗНАЧ(Столбец1;Столбец2;Столбец3) | Среднее значение чисел из трех первых столбцов (5)
6 | 5 | 4 | =СРЗНАЧ(ЕСЛИ(Столбец1>Столбец2; Столбец1-Столбец2; 10); Столбец3) | Если Столбец1 больше Столбец2, рассчитывается среднее для разности и Столбец3. В противном случае рассчитывается среднее для 10 и Столбец3. (2,5)

Показать Расчет медианы чисел

Медиана (срединное значение) представляет значение в центре упорядоченного диапазона чисел. Для расчета срединного значения группы чисел используется функция МЕДИАНА.
A | B | C | D | E | F | Формула | Описание
10 | 7 | 9 | 27 | 0 | 4 | =МЕДИАНА(A; B; C; D; E; F) | Медиана чисел из шести первых столбцов (8)

Показать Расчет минимального и максимального значения в диапазоне

Для расчета минимального или максимального значения чисел из двух или нескольких столбцов в строке используются функции МИН или МАКС.
Столбец1 | Столбец2 | Столбец3 | Формула | Описание
10 | 7 | 9 | =МИН(Столбец1; Столбец2; Столбец3) | Наименьшее число (7)
10 | 7 | 9 | =МАКС(Столбец1; Столбец2; Столбец3) | Наибольшее число (10)

Показать Подсчет количества значений

Для подсчета количества значений используется функция СЧЁТ.
Столбец1 | Столбец2 | Столбец3 | Формула | Описание
Яблоко |  | 12.12.2007 | =СЧЁТ(Столбец1; Столбец2; Столбец3) | Подсчет количества столбцов, содержащих числовые значения, включая значения даты и времени. Исключаются текстовые и пустые значения. (1)
$12 | #ДЕЛ/0! | 1.01 | =СЧЁТ(Столбец1; Столбец2; Столбец3) | Подсчет количества столбцов, содержащих числовые значения; исключаются ошибки и логические значения.

Показать Увеличение или уменьшение числа на определенный процент

Для этой задачи используется оператор процента (%).
Столбец1 | Столбец2 | Формула | Описание
23 | 3% | =Столбец1*(1+5%) | Увеличение значения Столбец1 на 5% (24,15)
23 | 3% | =Столбец1*(1+Столбец2) | Увеличение значения Столбец1 на процентное значение Столбец2: 3% (23,69)
23 | 3% | =Столбец1*(1-Столбец2) | Уменьшение значения Столбец1 на процентное значение Столбец2: 3% (22,31)

Показать Возведение числа в степень

Для этой задачи используется оператор возведения в степень (^) или функция СТЕПЕНЬ.
Столбец1 | Столбец2 | Формула | Описание
5 | 2 | =Столбец1^Столбец2 | Рассчитывается значение 5 в квадрате (25)
5 | 3 | =СТЕПЕНЬ(Столбец1; Столбец2) | Рассчитывается значение 5 в кубе (125)

Показать Округление числа

Для округления чисел сверху используются функции ОКРУГЛВВЕРХ, НЕЧЁТ и ЧЁТН.

Столбец1 | Формула | Описание
20.3 | =ОКРУГЛВВЕРХ(Столбец1;0) | Округление числа 20,3 вверх до ближайшего целого значения (21)
-5,9 | =ОКРУГЛВВЕРХ(Столбец1;0) | Округление числа -5,9 вверх (-6)
12,5493 | =ОКРУГЛВВЕРХ(Столбец1;2) | Округление 12,5493 вверх до ближайших сотых долей, т. е. двух десятичных разрядов (12,55)
20,3 | =ЧЁТН(Столбец1) | Округление числа 20,3 вверх до ближайшего четного значения (22)
20,3 | =НЕЧЁТ(Столбец1) | Округление числа 20,3 вверх до ближайшего нечетного значения (21)

Для округления чисел снизу используются функция ОКРУГЛВНИЗ.

Столбец1 | Формула | Описание
20,3 | =ОКРУГЛВНИЗ(Столбец1;0) | Округление числа 20,3 вниз до ближайшего целого значения (20)
-5.9 | =ОКРУГЛВНИЗ(Столбец1;0) | Округление числа -5,9 вниз (-5)
12,5493 | =ОКРУГЛВНИЗ(Столбец1;2) | Округление 12,5493 вниз до ближайших сотых долей, т. е. двух десятичных разрядов (12,54)

Для округления числа до ближайшего целого числа или дроби используется функция ОКРУГЛ.

Столбец1 | Формула | Описание
20.3 | =ОКРУГЛ(Столбец1;0) | Округляет число 20,3 вниз, поскольку дробная часть меньше 0,5 (20)
5,9 | =ОКРУГЛ(Столбец1;0) | Округляет число 5,9 вверх, поскольку дробная часть больше 0,5 (6)
-5,9 | =ОКРУГЛ(Столбец1;0) | Округляет число -5,9 вниз, поскольку дробная часть меньше -0,5 (-6)
1,25 | =ОКРУГЛ(Столбец1; 1) | Округляет число до ближайших десятых (один десятичный разряд). Если дробная часть больше или равняется 0,05, число округляется вверх (результат: 1,3)
30,452 | =ОКРУГЛ(Столбец1; 2) | Округляет число до ближайших сотых (два десятичных разряда). Так как округляемая дробная часть 0,002 меньше 0,005, число округляется вниз (результат: 30,45)

Для округления числа до трех значащих цифр выше 0 используются функции ОКРУГЛ, ОКРУГЛВВЕРХ, ОКРУГЛВНИЗ, ЦЕЛОЕ и ДЛСТР.

Столбец1 | Формула | Описание
5492820 | =ОКРУГЛ(Столбец1;3-ДЛСТР(ЦЕЛОЕ(Столбец1))) | Округление числа до трех значащих цифр (5490000)
22230 | =ОКРУГЛВНИЗ(Столбец1;3-ДЛСТР(ЦЕЛОЕ(Столбец1))) | Округление числа вниз до трех значащих цифр (22200)
5492820 | =ОКРУГЛВВЕРХ(Столбец1; 5-ДЛСТР(ЦЕЛОЕ(Столбец1))) | Округление числа вверх до трех значащих цифр (5492900)

Текстовые формулы

Показать Изменение регистра знаков

Для этой задачи используются функции ПРОПИСН, СТРОЧН или ПРОПНАЧ.
Столбец1 | Формула | Описание
иван Петров | =ПРОПИСН(Столбец1) | Переводит буквы в прописные (ИВАН ПЕТРОВ)
иван Петров | =СТРОЧН(Столбец1) | Переводит буквы в строчные (иван петров)
иван Петров | =ПРОПНАЧ(Столбец1) | Переводит первые буквы слов в прописные (Иван Петров)

Показать Объединение имени и фамилии

Для этой задачи используется оператор конкатенации (&) или функция СЦЕПИТЬ.
Столбец1 | Столбец2 | Формула | Описание
Ольга | Белова | =Столбец1&Столбец2 | Слияние двух строк (ОльгаБелова)
Ольга | Белова | =Столбец1&" "&Столбец2 | Объединение двух строк, разделенных пробелом (Ольга Белова)
Ольга | Белова | =Столбец2&", "&Столбец1 | Объединение двух строк, разделенных запятой и пробелом (Белова, Ольга )
Ольга | Белова | =СЦЕПИТЬ(Столбец2; ","; Столбец1) | Объединение двух строк, разделенных запятой (Белова,Ольга )

Показать Объединение текста и чисел из разных столбцов

Для этой задачи используется оператор конкатенации (&) и функции СЦЕПИТЬ и ТЕКСТ.
Столбец1 | Столбец2 | Формула | Описание
Сидоров | 28 | =Столбец1&" продал "&Столбец2&" единиц." | Из содержимого составляется фраза (Сидоров продал 28 единиц)
Петров | 40% | =Столбец1&" продал "&ТЕКСТ(Столбец2;"0%")&" от общего число товаров." | Из содержимого составляется фраза (Петров продал 40% от общего число товаров.) Примечание. Функция ТЕКСТ добавляет отформатированное значение Столбец2 вместо базового значения, равного 0,4.
Сидоров | 28 | =СЦЕПИТЬ(Столбец1;" продал ";Столбец2;" единиц.") | Из содержимого составляется фраза (Сидоров продал 28 единиц)

Показать Объединение текста с датой или временем

Для этой задачи используется функция ТЕКСТ и оператор конкатенации (&).
Столбец1 | Столбец2 | Формула | Описание
Дата оплаты | 5.06.2007 | ="Выставлен: "&ТЕКСТ(Столбец2; "д-ммм-гггг") | Объединение текста с датой (Выставлен: 5-Июн-2007)
Дата оплаты | 5.06.2007 | =Столбец1&" "&ТЕКСТ(Столбец2; "ммм-дд-ггг") | Объединение текста и даты из разных столбцов (Дата оплаты Июн-05-2007)

Показать Сравнение содержимого столбцов

Для сравнения столбца с другим столбцом или списком значений используются функции СОВПАД и ИЛИ.
Столбец1 | Столбец2 | Формула | Описание
BD122 | BD123 | =СОВПАД(Столбец1;Столбец2) | Сравнение содержимого двух столбцов (Нет)
BD122 | BD123 | =СОВПАД(Столбец1; "BD122") | Сравнение содержимого Столбец1 и строки "BD122" (Да)
BD122 | BD123 | =ИЛИ(СОВПАД("BD121"; Столбец1; Столбец2) | Сравнение строки "BD121" с содержимым первых двух столбцов (Нет)

Показать Проверка совпадения значения или части значения столбца с определенным текстом

Чтобы проверить, совпадает ли значение или часть значения столбца, с определенным текстом, используются функции ЕСЛИ, НАЙТИ, ПОИСК и ЕЧИСЛО.

Столбец1 | Формула | Описание
Белова | =ЕСЛИ(Столбец1="Белова"; "Да"; "Нет") | Проверка, содержит ли Столбец1 строку "Белова" (Да)
Белова | =ЕСЛИ(ЕЧИСЛО(НАЙТИ("в";Столбец1)); "Да"; "Нет") | Проверка, содержит ли Столбец1 букву "в" (Да)
BD123 | =ЕЧИСЛО(НАЙТИ("BD";Столбец1)) | Проверка, содержит ли Столбец1 буквы "BD" (Да)

Показать Подсчет непустых столбцов

Для этой задачи используется функция СЧЁТЗ.
Столбец1 | Столбец2 | Столбец3 | Формула | Описание
Продажи | 19 |  | =СЧЁТЗ(Столбец1; Столбец2) | Подсчет количества непустых столбцов (2)
Продажи | 19 |  | =СЧЁТЗ(Столбец1; Столбец2; Столбец3) | Подсчет количества непустых столбцов (2)

Показать Удаление символов из текста

Для этой задачи используются функции ДЛСТР, ЛЕВСИМВ и ПРАВСИМВ.
Столбец1 | Формула | Описание
Витамин A | =ЛЕВСИМВ(Столбец1;ДЛСТР(Столбец1)-2) | Возвращаются 7 знаков (9-2), начиная слева (Витамин)
Витамин B1 | =ПРАВСИМВ(Столбец1; ДЛСТР(Столбец1)-8) | Возвращаются 2 знака (10-8), начиная справа (B1)

Показать Удаление пробелов из начала и конца значения столбца

Для этой задачи используется функция СЖПРОБЕЛЫ.
Столбец1 | Формула | Описание
Привет всем! | =СЖПРОБЕЛЫ(Столбец1) | Удаление пробелов из начала и конца значения (Привет всем!)

Показать Повторение символа в столбце

Для этой задачи используется функция ПОВТОР.
Формула | Описание
=ПОВТОР(".";3) | Точка повторяется 3 раза (...)
=ПОВТОР("-";10) | Дефис повторяется 10 раз (----------)

Другие формулы

Показать Скрытие значений ошибок в столбцах

Функцию ЕОШИБКА используют, чтобы вывести вместо значения ошибки другой текст, например, дефис, "#Н/Д" или "НД".
Столбец1 | Столбец2 | Формула | Описание
10 | 0 | =Столбец1/Столбец2 | Возвращается ошибка (#ДЕЛ/0)
10 | 0 | =ЕСЛИ(ЕОШИБКА(Столбец1/Столбец2);"НД";Столбец1/Столбец2) | При ошибке возвращается "НД"
10 | 0 | =ЕСЛИ(ЕОШИБКА(Столбец1/Столбец2);"-";Столбец1/Столбец2) | При ошибке возвращается дефис


Отображение и скрытие статистических значений

  • Чтобы отобразить или скрыть статистические значения для всех столбцов списка, нажмите на панели инструментов списка кнопку Итоги.

    Если строка «Всего» была скрыта, она появится в нижней части списка. В ней отображается суммарное значение для каждого числового столбца или же число непустых строк в последнем столбце списка, если в списке нет числовых столбцов. Если строка итогов отображается, то после нажатия кнопки Итоги она скроется.

  • Чтобы отобразить или скрыть статистические значения для одного и более столбцов, выполните следующие действия.
    1. Выберите столбец в строке итогов.
    2. В списке статистических функций выберите Нет, чтобы скрыть суммарное значение. Чтобы отобразить суммарное значение, выберите функцию, отличающуюся от Нет.


Устранение неполадок, связанных с итогами и вычисляемыми значениями

Получено сообщение, в котором говорится, что результаты расчета по формуле будут отправлены на сервер

Получена синтаксическая ошибка

В ячейке вместо результата отображается формула

При изменении вычисляемого столбца получено сообщение об изменениях, ожидающих утверждения

Получена ошибка времени ожидания или непредвиденная ошибка

Получена ошибка, показывающая, что изменена структура списка

Получено сообщение об отсутствии разрешения на изменение вычисляемого столбца списка

Невозможно изменить формулу, так как для одного или нескольких столбцов требуется присвоить значения

Получена ошибка о том, что одна или несколько ссылок на столбцы не разрешены

Получена ошибка о том, что столбец не существует

При изменении вычисляемого столбца невозможно выделить нужный столбец

В ячейках вычисляемого столбца отображается #ИМЯ?

В ячейках вычисляемого столбца отображается #ЦИКЛ!

В ячейках вычисляемого столбца отображается #ЗНАЧ!

В ячейках вычисляемого столбца отображается #ЧИСЛО!

В ячейках вычисляемого столбца отображается #ДЕЛ/0!

В ячейках вычисляемого столбца отображается #ПУСТО!

В ячейках вычисляемого столбца отображается #Н/Д

Получено сообщение, в котором говорится, что результаты расчета по формуле будут отправлены на сервер

После изменения формулы в списке выполняется попытка отправить новые результаты на сервер. Выполните одно из следующих действий:

  • Нажмите кнопку Продолжить, чтобы завершить изменение. Если существуют изменения, ожидающие утверждения, конфликты или ошибки, потребуется выполнить соответствующие действия.
  • Нажмите кнопку Отмена, чтобы вернуться в ячейку, содержащую формулу.

К началу страницы

Получена синтаксическая ошибка

Это могло произойти по одной или нескольким следующим причинам.

  • В формуле использовано разное количество открывающихся и закрывающихся скобок. Убедитесь в том, что каждой открывающейся скобке соответствует закрывающаяся.
  • Формула содержит специальный знак, отличный от знака равенства (=) и операторов вычислений.
  • Формула вызывает одну или несколько функций, но для этих функций указано неверное число аргументов.
  • В формуле используется функция, не поддерживаемая списком. В частности, списки не поддерживают функции СЛЧИС и ТДАТА. Функции СЕГОДНЯ и МЯ нельзя использовать в вычисляемых столбцах, однако их можно использовать для задания значения по умолчанию для столбца.

К началу страницы

В ячейке вместо результата отображается формула

Убедитесь в том, что ячейка, содержащая формулу, является частью вычисляемого столбца. При вводе формулы в столбец, отличный от вычисляемого, например столбец, имеющий тип Однострочный текст, список будет рассматривать формулу как текстовую строку и отображать ее как есть.

К началу страницы

При изменении вычисляемого столбца получено сообщение об изменениях, ожидающих утверждения

Любые изменения вычисляемого столбца приводят к изменению структуры списка. Вносить в список структурные изменения можно только при отсутствии изменений, ожидающих утверждения, конфликтов и ошибок. Если это требование не выполняется, пользователю будет предложено дождаться отправки изменений на сервер или устранить все ошибки и конфликты перед тем, как будет можно добавить или изменить столбец.

К началу страницы

Получена ошибка времени ожидания или непредвиденная ошибка

Обновите список и повторите изменения, внесенные в вычисляемый столбец.

К началу страницы

Получена ошибка, показывающая, что изменена структура списка

Изменение вычисляемого столбца приводит к изменению структуры списка. Если в списке обнаружен конфликт между внесенным изменением и структурным изменением, внесенным другим пользователем, будет предложено обновить список. При обновлении списка обновляется представление, но отменяются изменения, внесенные в вычисляемый столбец. Попробуйте повторить изменения.

К началу страницы

Получено сообщение об отсутствии разрешения на изменение вычисляемого столбца списка

Изменение вычисляемого столбца приводит к изменению структуры списка. Без разрешений на внесение изменений в структуру списка невозможно изменять вычисляемые столбцы.

К началу страницы

Невозможно изменить формулу, так как для одного или нескольких столбцов требуется присвоить значения

Список должен сохранить все изменения перед изменением формулы. Строка не может быть сохранена, если один из ее столбцов является обязательным, но не заполнен. Введите значения во все обязательные столбцы, а затем попробуйте изменить формулу.

К началу страницы

Получена ошибка о том, что одна или несколько ссылок на столбцы не разрешены

Формула включает ссылку на столбец, тип данных которого не поддерживает вычисления. Удалите ссылки на неподдерживаемые столбцы.

К началу страницы

Получена ошибка о том, что столбец не существует

В качестве операнда указана строка, а список не может найти столбец с именем, соответствующим строке. Выполните одно или несколько следующих действий:

  • Убедитесь, что столбцы, на которые указывает ссылка в формуле, существуют.
  • Убедитесь в том, что имена столбцов заключены в квадратные скобки ([]), если они содержат пробелы или специальные знаки.
  • Проверьте в ссылках на столбцы орфографию.

К началу страницы

При изменении вычисляемого столбца невозможно выделить нужный столбец

После того как в вычисляемый столбец введен знак равенства (=), можно вставлять в формулу ссылки на столбцы путем выбора ячеек текущей строки. Однако если столбец ячейки принадлежит к типу данных, не поддерживающему вычисления, если ячейка принадлежит другой строке, а также при попытке выбрать более одной ячейки вставки ссылки в формулу не произойдет.

К началу страницы

В ячейках вычисляемого столбца отображается #ИМЯ?

Столбец, на который осуществляется ссылка в формуле, больше не существует. Необходимо либо добавить столбец в список, либо удалить ссылку.

К началу страницы

В ячейках вычисляемого столбца отображается #ЦИКЛ!

Ошибка вызвана одной или несколькими циклическими ссылками. Циклическая ссылка возникает в следующих случаях.

  • Формула в столбце содержит ссылку на себя. Например, формула для вычисления значений столбца «Налогооблагаемый доход» ссылается на столбец «Налогооблагаемый доход».
  • Два или несколько столбцов ссылаются друг на друга. Например, в столбце Выч1 используется формула =[Выч2]+2, а в столбце Выч2 используется формула =[Выч1]-1.
Чтобы удалить циклическую ссылку, выполните одно или несколько следующих действий:
  • Убедитесь, что формула не ссылается на столбец, содержащий формулу.
  • Если формула ссылается на столбец, убедитесь в том, что формула в этом столбце не ссылается на первый столбец.
  • Проверьте в ссылках на столбцы орфографию.

К началу страницы

В ячейках вычисляемого столбца отображается #ЗНАЧ!

Данная ошибка может возникнуть в одном из двух случаев.

  • В формуле используется неверный тип операнда.
  • Для функции, используемой в формуле, указан неверный тип аргумента.
Проверьте тип данных операндов и аргументов.

К началу страницы

В ячейках вычисляемого столбца отображается #ЧИСЛО!

Данная ошибка возникает, когда формула содержит недопустимое числовое значение, например:

  • значение, возвращаемое формулой, слишком большое для представления в списке;
  • формула обнаружила дату ранее 1/1/1900;
  • в функции предполагается числовой аргумент, а вместо него указан нечисловой. Для функции, используемой в формуле, указан неверный тип аргумента.

К началу страницы

В ячейках вычисляемого столбца отображается #ДЕЛ/0!

Данная ошибка возникает при делении числа на ноль (0), например:

  • явное указание деления на ноль (0), например =133/0;
  • в формуле содержатся ссылки на столбцы, и во время вычисления значения в столбцах, на которые осуществляется ссылка, приводят к делению на ноль (0). Например, столбцы [Счет1] и [Счет2] имеют в нескольких строках одинаковые значения, и выполнение формулы =[Кол]/[Счет1]-[Счет2] приведет к возникновению ошибки для этих строк.

К началу страницы

В ячейках вычисляемого столбца отображается #ПУСТО!

Данная ошибка возникает, когда аргумент или операнд, указанный в формуле, имеет пустое значение. Если один элемент в формуле имеет пустое значение, результатом всей формулы будет пустое значение. Чтобы избежать этой ошибки, убедитесь, что пустые значения заменены на ноль (0). Можно также изменить параметр столбцов, на которые осуществляется ссылка, на значение Обязательный для того, чтобы все строки имели непустое значение.

К началу страницы

В ячейках вычисляемого столбца отображается #Н/Д

Данная ошибка возникает, когда в функции пропущено значение. Убедитесь в том, что для функции указаны все обязательные аргументы.

К началу страницы


Функции

Функции — это встроенные формулы, выполняющие вычисления в определенном порядке, используя специальные значения (аргументы). Функции можно использовать для выполнения простых и сложных вычислений. Например, функция ОКРУГЛ округляет число в столбце «Цена».

=ОКРУГЛ(Цена; 2)

Ниже приведены основные положения, которые необходимо учитывать при использовании функций:

  • Структура Структура функции начинается со знака равенства (=), за которым следует имя функции, открывающаяся скобка, аргументы функции, разделенные точкой с запятой, и закрывающаяся скобка.
  • Имя функции Имя функции, поддерживаемое списками. Каждая функция принимает заданное число аргументов, обрабатывает их и возвращает значение.
  • Аргументы Аргументами могут являться числа, текст, логические значения (Истина или Ложь) или ссылки на столбцы. Аргумент должен иметь допустимое значение. В качестве аргументов могут также выступать константы, формулы или другие функции.
  • Подсказка аргументов. Подсказка с синтаксисом и аргументами появляется при вводе функции. Например, подсказка появится, если ввести =ОКРУГЛ(. Подсказки появляются только для встроенных функций.

Примечание. Списки не поддерживают функции СЛЧИС и ТДАТА. Функции СЕГОДНЯ и Я не поддерживаются в вычисляемых столбцах, но поддерживаются в параметре значений по умолчанию для столбца.

Вложенные функции

В некоторых случаях может потребоваться использовать функцию в качестве аргумента другой функции. Например, в следующей формуле используется вложенная функция СРЗНАЧ и результат сравнивается с суммой значений двух столбцов.

=СРЗНАЧ([Цена1]; СУММ([Цена2]+[Скидка]))

Допустимые возвращаемые значения При использовании функции в качестве аргумента возвращаемый тип значения должен совпадать с типом этого аргумента. Например, если аргумент использует значения Да или Нет, вложенная функция должна возвращать Да или Нет. В противном случае в списке отражается значение ошибки #ЗНАЧ!.

Ограничения на количество уровней вложенности Формула может содержать до восьми уровней вложенных функций. Если функция Б используется в функции А в качестве аргумента, то она является функцией второго уровня. Например, функция СУММ является функцией второго уровня, так как она выступает в качестве аргумента для функции СРЗНАЧ. Функция, вложенная в функцию СУММ, является функцией третьего уровня и т. д.


Добавление или редактирование вычисляемого столбца

В список можно добавить столбец, вычисляющий значения каждой своей строки на основе значений в этой строке из других столбцов.

Добавление вычисляемого столбца

  1. Щелкните правой кнопкой мыши заголовок столбца и выберите команду Добавить столбец.
  2. На странице Добавление столбца задайте имя столбца.
  3. Установите переключатель в положение Вычисляемый, чтобы задать тип данных для столбца.
  4. Введите новую формулу в текстовое поле Формула. Чтобы включить в формулу ссылку на столбец, выберите нужный столбец в списке Добавить столбец и щелкните ссылку Добавить в формулу.
  5. Задайте формат значения, возвращаемого формулой, и другие параметры.

Изменение вычисляемого столбца

  1. Щелкните правой кнопкой мыши заголовок столбца и выберите команду Изменить или удалить столбец.
  2. Измените формулу в текстовом поле Формула. Чтобы включить в формулу ссылку на столбец, выберите нужный столбец в списке Добавить столбец и щелкните ссылку Добавить в формулу.
  3. Задайте формат значения, возвращаемого формулой, и другие параметры.

Примечания

  • Добавление или изменение столбца приводит к изменению структуры списка. Вносить в список структурные изменения можно только при отсутствии отложенных изменений, конфликтов и ошибок. Если это требование не выполняется, пользователю будет предложено дождаться отправки изменений на сервер или разрешить проблемы и конфликты, перед тем как будет возможно добавлять или изменять столбец.
  • Тип данных существующего столбца нельзя изменить на Вычисляемый. Чтобы использовать формулу в не вычисляемом столбце, удалите этот столбец и добавьте в список вычисляемый столбец.


Изменение типа итогового значения столбца

  1. Выберите в строку итогов в столбце, для которого нужно изменить тип итогового значения.
  2. Щелкните стрелку раскрывающегося списка и выберите нужную функцию.

Примечание. Чтобы отключить представление итогов для этого столбца, выберите вариант Нет.


ДАТА

Возвращает целое число, представляющее определенную дату.

Синтаксис

ДАТА(год;месяц;день)

Год — аргумент, который может иметь от одной до четырех цифр..

  • Если значение аргумента «год» находится в диапазоне от 4 до 1899 (включительно), Excel прибавляет это значение к числу 1900 для вычисления года. Например, DATE(108,1,2) возвращает 2 января 2008 (1900+108) года.

  • Если значение аргумента «год» находится в диапазоне от 1900 до 9999 (включительно), это значение используется как год. Например, DATE(2008,1,2) возвращает 2 января 2000 года.

Месяц — число, представляющее месяц года. Если значение аргумента больше 12, введенное число месяцев отсчитывается от первого месяца указанного года. Например, DATE(2008,14,2) возвращает число, соответствующее 2 февраля 2009 года.

День — число, представляющее день месяца. Если значение аргумента больше числа дней в указанном месяце, введенное число дней отсчитывается от первого дня месяца. Например, DATE(2008,1,35) возвращает число, соответствующее 4 февраля 2008 года.

Примечания

  • Даты сохраняются последовательно, поэтому их можно использовать в вычислениях. По умолчанию 31-му декабря 1899 года присваивается номер 1, а 1-му января 2008 года присваивается номер 39448, поскольку с 1-го января 1900 до этого дня пройдет 39448 дней.
  • Функция ДАТА полезна в тех формулах, где год, месяц и день представлены формулами, а не константами.

Пример

Год | Месяц | День | Формула | Описание (Результат)
2008 | 1 | 1 | =ДАТА([Год];[Месяц];[День]) | Порядковый номер даты (1/1/2008 или 39448)


РАЗНДАТ

Вычисление количества дней, месяцев или лет между двумя датами. Эта функция предназначена для совместимости с Lotus 1-2-3.

Синтаксис

РАЗНДАТ(нач_дата;кон_дата;единицы)

Нач_дата — начальная дата измеряемого периода. Даты могут быть заданы в виде текстовой строки в кавычках (например, "2001/1/30"), в виде серийных номеров (например, 36921, этот номер обозначает 30 января 2001года, если не используется система дат 1900) или в виде результатов работы других формул или функций (например, ДАТАЗНАЧ("2001/1/30")).

Кон_дата — конечная дата периода.

Единицы — тип возвращаемых данных.

Единицы | Возвращаемые данные
"Y" | Количество полных лет в периоде.
"M" | Количество полных месяцев в периоде.
"D" | Количество дней в периоде.
"MD" | Разница между днями конца (кон_дата) и начала (нач_дата) периода. Заданные в этих датах значения месяцев и годов игнорируются.
"YM" | Разница между месяцами конца (кон_дата) и начала (нач_дата) периода. Заданные в этих датах значения дней и годов игнорируются.
"YD" | Разница между днями конца (кон_дата) и начала (нач_дата) периода. Заданные в этих датах значения годов игнорируются.

Примечания

  • Даты сохраняются последовательно, поэтому их можно использовать в вычислениях. По умолчанию 31-му декабря 1899 года присваивается номер 1, а 1-му января 2008 года присваивается номер 39448, поскольку с 1-го января 1900 до этого дня пройдет 39448 дней.
  • Функция РАЗНДАТ полезна в функциях, в которых нужно рассчитывать возраст.

Пример

Нач_дата | Кон_дата | Формула | Описание (Результат)
1/1/2001 | 1/1/2003 | РАЗНДАТ(Нач_дата;Кон_дата,"Y") | Период содержит два полных года (2)
6/1/2001 | 8/15/2002 | РАЗНДАТ(Нач_дата;Кон_дата,"D") | Между 1 июня 2001 г. и 15 августа 2002 г. 440 дней (440)
6/1/2001 | 8/15/2002 | РАЗНДАТ(Нач_дата;Кон_дата,"YD") | Между 1 июня и 15 августа одного года 75 дней (75)
6/1/2001 | 8/15/2002 | РАЗНДАТ(Нач_дата;Кон_дата,"MD") | Разница между 1-ым и 15-ым числом, без рассмотрения месяце в годов в параметрах нач_дата и кон_дата (14)


ДАТАЗНАЧ

Возвращает дату_в_числовом_формате, если дата представлена как текст. Функция ДАТАЗНАЧ используется для преобразования даты, представленной в виде текста, в дату в числовом формате.

Синтаксис

ДАТАЗНАЧ(дата_как_текст)

Дата_как_текст представляет собой текст, отображающий дату в формате даты. Например, дата представлена в виде текстовых строк в кавычках: «1/30/2008» или «30-янв-2008».

Если в параметре дата_как_текст опущен год, функция ДАТАЗНАЧ использует текущее значение года встроенных часов сервера. Сведения о времени в параметре дата_как_текст игнорируются.

Примечания

  • Даты хранятся как последовательность дат_в_числовом_формате, поэтому их можно использовать в вычислениях. По умолчанию 31-му декабря 1899 года присваивается номер 1, а 1-му января 2008 года присваивается номер 39448, поскольку с 1-го января 1900 до этого дня пройдет 39448 дней.
  • Большинство функций самостоятельно преобразует значения дат в даты_в_числовом_формате .

Пример

Формула | Описание (Результат)
=ДАТАЗНАЧ(«8/22/2008») | Дата_в_числовом_формате: 39682
=ДАТАЗНАЧ(«22-авг-2008») | Дата_в_числовом_формате: 39682
=ДАТАЗНАЧ(«2008/02/23») | Дата_в_числовом_формате: 39501
=ДАТАЗНАЧ(«5-июль») | Дата_в_числовом_формате (на встроенных часах компьютера установлен 2000 год): 36712


ДЕНЬ

Возвращает дату, представленную в дате_в_числовом_формате. Дата представляет собой целое число от 1 до 31.

Синтаксис

ДЕНЬ(дата_в числовом_формате)

Дата_в_числовом_формате представляет собой требуемую дату.

Примечания

  • Даты хранятся как последовательность дат_в_числовом_формате, поэтому они могут быть использованы в вычислениях. По умолчанию 31-му декабря 1899 года присваивается серийный номер 1, а 1-му января 2008 года присваивается серийный номер 39448, потому что с 1-го января 1900 до этого дня пройдет 39.448 дней.
  • Значения, возвращаемые функциями ГОД, МЕСЯЦ и ДЕНЬ, считаются по григорианскому календарю вне зависимости от формата отображения встроенных значений данных. Например, если встроенные данные отображаются в формате Хиджра, возвращаемые данные функций ГОД, МЕСЯЦ и ДЕНЬ будут представлять собой значения, связанные с эквивалентной григорианской датой.

Пример

Формула | Описание (Результат)
=ДЕНЬ(«15-апреля-2008») | Дата (15)


ДНЕЙ360

Возвращает количество дней между двумя датами на основе 360-дневного года (двенадцать 30-дневных месяцев). Эта функция используется для расчета платежей, если бухгалтерия основана на двенадцати 30-дневных месяцах.

Синтаксис

ДНЕЙ360(нач_дата;кон_дата;метод)

Нач_дата и кон_дата — две даты, количество дней между которыми необходимо вычислить. Если нач_дата соответствует дате более поздней, чем кон_дата, функция возвращает отрицательное значение.

Метод — это логическое значение, которое определяет, какой метод, европейский или американский, должен использоваться при вычислениях.

Метод | Определение
ЛОЖЬ или опущено | Американский метод (NASD). Если начальная дата является 31-м числом месяца, то она полагается равной 30-ому числу того же месяца. Если конечная дата является 31-м числом месяца и начальная дата меньше, чем 30-ое число, то конечная дата полагается равной 1-ому числу следующего месяца, в противном случае конечная дата полагается равной 30-ому числу того же месяца.
ИСТИНА | Европейский метод. Начальная и конечная даты, которые приходятся на 31-ое число месяца, полагаются равными 30-ому числу того же месяца.

Примечания

Даты сохраняются последовательно, поэтому их можно использовать в вычислениях. По умолчанию 31-му декабря 1899 года присваивается номер 1, а 1-му января 2008 года присваивается номер 39448, поскольку с 1-го января 1900 до этого дня пройдет 39448 дней.

Пример

Столбец1 | Столбец2 | Формула | Описание (Результат)
1/30/2008 | 2/1/2008 | =ДНЕЙ360([Столбец1];[Столбец2]) | Количество дней между приведенными датами, вычисленное на основе 360-дневного года (1)


Функция ЧАС

Возвращает час, соответствующий заданному времени в числовом формате. Час определяется как целое в интервале от 0 до 23.

Синтаксис

ЧАС(время_в_числовом_формате)

Время_в_числовом_формате — значение времени, из которого нужно выделить часы. Время может быть задано в виде текстовой строки в кавычках (например, "18:45"), десятичным числом (например, 0,78125 — соответствует 18:45) или результатом других формул или функций (например, ВРЕМЯЗНАЧ("18:45")).

Примечания

Время представляет собой дробную часть значения даты и задается десятичным числом (например, 12:00 представляется как 0,5).

Пример

Формула | Описание (Результат)
=ЧАС("3:30:30") | Час от времени (3)
=ЧАС("15:30:30") | Час от времени (15)
=ЧАС("15:30:00") | Час от времени (15)


МИНУТЫ

Возвращает секунды, соответствующие заданному времени в числовом формате. Это значение представляет собой целое число в пределах от 0 до 59.

Синтаксис

МИНУТЫ(время_в_числовом_формате)

Время_в_числовом_формате представляет собой требуемое значение времени. Время может вводиться как текстовые строки в кавычках (например, «18:45»), в виде десятичных дробей (например, 0.78125, что равнозначно 18:45) или как результат других формул или функций (например, ВРЕМЗНАЧ(«18:45»)).

Примечания

Значение времени является частью даты и представляется в виде десятичной дроби (например, 12:00 равнозначно 0.5, т.к. является половиной суток).

Пример

Формула | Описание (Результат)
=МИНУТЫ(«16:48:00») | 48 минут


МЕСЯЦ

Возвращает значение месяца, отраженное в дате_в_числовом_формате. Это значение дается как целое число в пределах от 1 (Январь) до 12 (Декабрь).

Синтаксис

МЕСЯЦ(дата_в _числовом_формате)

Дата_в_числовом_формате представляет собой требуемую дату.

Примечания

Даты сохраняются последовательно, поэтому их можно использовать в вычислениях. По умолчанию 31-му декабря 1899 года присваивается номер 1, а 1-му января 2008 года присваивается номер 39448, поскольку с 1-го января 1900 до этого дня пройдет 39448 дней.

Значения, возвращаемые функциями ГОД, МЕСЯЦ и ДЕНЬ, считаются по григорианскому календарю вне зависимости от формата отображения встроенных значений данных. Например, если встроенные данные отображаются в формате Хиджра, возвращаемые данные функций ГОД, МЕСЯЦ и ДЕНЬ будут представлять собой значения, связанные с эквивалентной григорианской датой.

Пример

Формула | Описание (Результат)
=МЕСЯЦ(«15-апрель-2008») | Значение месяца 4


СЕКУНДЫ

Возвращает секунды, соответствующие заданному времени в числовом формате. Это значение представляет собой целое число в пределах от 0 (нуля) до 59.

Синтаксис

СЕКУНДЫ(время_в_числовом_формате)

Время_в_числовом_формате — значение времени, из которого нужно выделить часы. Время может быть задано в виде текстовой строки в кавычках (например, "18:45"), десятичным числом (например, 0,78125 соответствует 18:45) или результатом других формул или функций (например, ВРЕМЯЗНАЧ("18:45")).

Примечания

Время представляет собой дробную часть значения даты и задается десятичной дробью (например, 12:00 представляется как 0,5, т.к. является половиной суток).

Пример

Формула | Описание
=СЕКУНДЫ("4:48:18") | 18 секунд
=СЕКУНДЫ("4:48") | 0 секунд


Функция ВРЕМЯ

Возвращает время в числовом формате для заданного времени. Время в числовом формате, возвращаемое функцией ВРЕМЯ — это десятичная дробь в интервале от 0 до 0,99999999, представляющая время от 0:00:00 (12:00:00 ночи) до 23:59:59 (11:59:59 вечера).

Синтаксис

ВРЕМЯ(часы;минуты;секунды)

Часы — число от 0 (ноль) до 32767, отражающее час. Величина, большая чем 23, будет поделена на 24, и остаток от деления будет отражать значение часа. Например, ВРЕМЯ(27;0;0) = ВРЕМЯ(3;0;0) = ,125 или 3:00.

Минуты — число от 0 (ноль) до 32767, отражающее минуты. Величина, большая чем 59, будет преобразована в часы и минуты. Например, ВРЕМЯ(0;750;0) = ВРЕМЯ(12;30;0) = ,520833 или 12:30.

Секунды — число от 0 до 32767, отражающее секунды. Величина, большая чем 59, будет преобразована в часы, минуты и секунды. Например, ВРЕМЯ(0;0;2000) = ВРЕМЯ(0;33;22) = ,023148 или 12:33:20.

Примечания

Время представляет собой дробную часть значения даты и задается десятичным числом (например, 12:00 представляется как 0,5).

Пример

Часы | Минуты | Секунды | Формула | Описание (Результат)
12 | 0 | 0 | =ВРЕМЯ([Часы];[Минуты];[Секунды]) | Десятичное представление времени (0,5)
16 | 48 | 10 | =ВРЕМЯ([Часы];[Минуты];[Секунды]) | Десятичное представление времени (0,700115741)


Функция ВРЕМЗНАЧ

Возвращает время в числовом формате для времени, заданного текстовой строкой. Время в числовом формате — это десятичная дробь в интервале от 0 до 0,99999999, представляющая время от 0:00:00 (12:00:00 ночи) до 23:59:59 (11:59:59 вечера).

Синтаксис

ВРЕМЗНАЧ(время_как_текст)

Время_как_текст — текстовая строка, задающая время в любом из форматов времени; например, текстовые строки "18:45" и "18:45:00" в кавычках представляют время.

Примечания

  • Сведения о дате в поле время_как_текст игнорируются.

Пример

Формула | Описание (Результат)
=ВРЕМЗНАЧ("2:24") | Десятичная часть дня для заданного времени (0,1)
=ВРЕМЗНАЧ("22-Августа-2008 6:35") | Десятичная часть дня для заданного времени (0,274305556)


Функция СЕГОДНЯ

Возвращает текущую дату в числовом формате. Числовой формат даты — это код дата-время, используемый в вычислениях с датами и периодами времени.

Примечание. Функцию СЕГОДНЯ можно использовать только как значение по умолчанию; неприменима в вычисляемом столбце.

Синтаксис

СЕГОДНЯ( )

Примечания

Даты хранятся как последовательность дат в числовом формате, поэтому они могут быть использованы в вычислениях. По умолчанию 31-му декабря 1899 года присваивается номер 1, а 1-му января 2008 года присваивается номер 39448, потому что с 1-го января 1900 до этого дня пройдет 39 448 дней.


Функция ДЕНЬНЕД

Возвращает день недели, соответствующий аргументу дата_в_числовом_формате. По умолчанию день недели определяется как целое в интервале от 1 (воскресенье) до 7 (суббота).

Синтаксис

ДЕНЬНЕД(дата_в_числовом_формате;тип)

Дата_в_числовом_формате — число, соответствующее дате, день недели которой необходимо найти.

Тип — число, определяющее тип возвращаемого значения.

Тип | Возвращаемое число
1 или опущен | От 1 (воскресенье) до 7 (суббота)
2 | От 1 (понедельник) до 7 (воскресенье)
3 | От 0 (понедельник) до 6 (воскресенье)

Примечания

Даты сохраняются последовательно, поэтому их можно использовать в вычислениях. По умолчанию 31-му декабря 1899 года присваивается номер 1, а 1-му января 2008 года присваивается номер 39448, поскольку с 1-го января 1900 до этого дня пройдет 39448 дней.

Пример

Формула | Описание (Результат)
=ДЕНЬНЕД("2/14/2008") | День недели с числами от 1 (воскресенье) до 7 (суббота) (5)
=ДЕНЬНЕД("2/14/2008";2) | День недели с числами от 1 (понедельник) до 7 (воскресенье) (4)
=ДЕНЬНЕД("2/14/2008";3) | День недели с числами от 0 (понедельник) до 6 (воскресенье) (3)

Примечание. 2/14/2008 — вторник.


Функция ГОД

Возвращает год, соответствующий дате.

Синтаксис

ГОД(дата_в_числовом_формате)

Дата_в_числовом_формате — дата, год которой необходимо найти.

Примечания

Даты хранятся как последовательность дат в числовом формате, поэтому они могут быть использованы в вычислениях. По умолчанию 31-му декабря 1899 года присваивается номер 1, а 1-му января 2008 года присваивается номер 39448, потому что с 1-го января 1900 до этого дня пройдет 39 448 дней.

Значения, возвращаемые функциями ГОД, МЕСЯЦ и ДЕНЬ, считаются по григорианскому календарю вне зависимости от формата отображения введенного значения даты. Например, если введенная дата данные отображаются в формате Хиджра, возвращаемые функциями ГОД, МЕСЯЦ и ДЕНЬ значения будут представлять собой значения, связанные с эквивалентной датой по григорианскому календарю.

Пример

Формула | Описание (Результат)
=ГОД("7/5/2008") | Год, соответствующий первой дате (2008)
=ГОД("7/5/10") | Год, соответствующий второй дате (2010)


ДДОБ

Возвращает значение амортизации актива за заданный период, используя метод двойного процента со снижающегося остатка или иной явно указанный метод.

Синтаксис

ДДОБ(нач_стоимость;остаточная_стоимость;время_эксплуатации;период;коэффициент)

Стоимость — это затраты на приобретение актива.

Остаточная_стоимость — это остаточная стоимость актива в конце периода амортизации.

Время_эксплуатации — это количество периодов, за которые собственность амортизируется (иногда называется периодом амортизации).

Период — это период, для которого требуется вычислить амортизацию. Период должен быть измерен в тех же единицах, что и время_эксплуатации.

Коэффициент — процентная ставка снижающегося остатка. Если коэффициент опущен, то он полагается равным 2 (метод удвоенного процента со снижающегося остатка).

Все пять аргументов должны быть положительными числами.

Примечания

  • Метод двойного процента со снижающегося остатка вычисляет амортизацию, используя увеличенный коэффициент. Амортизация максимальна в первый период, в последующие периоды уменьшается. Функция ДДОБ использует следующую формулу для вычисления амортизации за период:

    ((нач_стоимость - остаточная_стоимость) - суммарная амортизация за предшествующие периоды) * (коэффициент/время_эксплуатации)

  • Если нужно использовать другой метод вычисления амортизации, измените значение аргумента «коэффициент».

Пример

Нач_стоимость | Остаточная_стоимость | Время_эксплуатации | Формула | Описание (Результат)
2400 | 300 | 10 | =ДДОБ([Нач_стоимость];[Остаточная_стоимость];[Время_эксплуатации]*365;1) | Амортизация за первый день. Автоматически предполагается, что коэффициент равен 2 (1,32)
2400 | 300 | 10 | =ДДОБ([Нач_стоимость];[Остаточная_стоимость];[Время_эксплуатации]*12;1;2) | Амортизация за первый месяц (40,00)
2400 | 300 | 10 | =ДДОБ([Нач_стоимость];[Остаточная_стоимость];[Время_эксплуатации];0;1) | Амортизация за первый год (480,00)
2400 | 300 | 10 | =ДДОБ([Нач_стоимость];[Остаточная_стоимость];[Время_эксплуатации];2;1,5) | Амортизация за второй год с использованием коэффициента 1,5 вместо метода удвоенного процента со снижающегося остатка (306,00)
2400 | 300 | 10 | =ДДОБ([Нач_стоимость];[Остаточная_стоимость];[Время_эксплуатации];10) | Амортизация за десятый год. Коэффициент автоматически предполагается равным 2 (22,12)

Примечание. Результаты округляются до двух знаков после запятой.


БС

Возвращает будущую стоимость инвестиции на основе периодических постоянных (равных по величине сумм) платежей и постоянной процентной ставки.

Синтаксис

БС(ставка;кол_пер;плт;пс;тип)

Для получения более подробной информации об аргументах функции БС и более подробной информации о других функциях выплат по аннуитету см. справку по функции ПС.

Ставка — процентная ставка за период.

Кол_пер — общее число периодов выплат годовой ренты.

Плт — это выплата, производимая в каждый период; это значение не может меняться в течение всего периода выплат. Обычно плт состоит из основного платежа и платежа по процентам, но не включает других налогов и сборов. Если аргумент опущен, должно быть указано значение аргумента «пс».

Пс — это приведенная к текущему моменту стоимость или общая сумма, которая на текущий момент равноценна ряду будущих платежей. Если аргумент «пс» опущен, то он полагается равным 0. В этом случае должно быть указано значение аргумента плт.

Тип — число 0 или 1, обозначающее, когда должна производиться выплата. Если аргумент «тип» опущен, то он полагается равным 0.

Тип | Когда нужно выплатить
0 | В конце периода
1 | В начале периода

Примечания
  • Убедитесь, что вы последовательны в выборе единиц измерения для задания аргументов «ставка» и «кол_пер». Если вы делаете ежемесячные выплаты по четырехгодичному займу из расчета 12 процентов годовых, то используйте 12%/12 для задания аргумента «ставка» и 4*12 для задания аргумента «кол_пер». Если вы делаете ежегодные платежи по тому же займу, то используйте 12% для задания аргумента «ставка» и 4 для задания аргумента «кол_пер».
  • Все аргументы, означающие деньги, которые платятся (например, депозитные вклады), представляются отрицательными числами; деньги, которые получены (например, дивиденды), представляются положительными числами.

Пример 1

Ставка | Кол_пер | Плт | ПС | Тип | Формула | Описание (Результат)
6% | 10 | -200 | -500 | 1 | =БС([Ставка]/12;[Кол_пер];[Плт]; [ПС]; [Тип]) | Будущая стоимость вклада с указанными характеристиками (2581,40)

Примечание. Годовая процентная ставка делится на 12, т. к. начисление сложных процентов производится ежемесячно.

Пример 2

Ставка | Кол_пер | Плт | Формула | Описание (Результат)
12% | 12 | -1000 | =БС([Ставка]/12, [Кол_пер], [Плт]) | Будущая стоимость вклада с указанными характеристиками (12682,50)

Примечание. Годовая процентная ставка делится на 12, т. к. начисление сложных процентов производится ежемесячно.


ПРПЛТ

Возвращает сумму платежей процентов по инвестиции за данный период на основе постоянства сумм периодических платежей и постоянства процентной ставки. Для получения более полного описания смысла аргументов функции ПРПЛТ и более подробной информации о функциях, связанных с ежегодными выплатами, см. справку по функции «ПС»

Синтаксис

ПРПЛТ(ставка;период;кол_пер;pv;бс;тип)

Ставка — процентная ставка за период.

Период — это период, для которого требуется найти платежи по процентам; должен находиться в интервале от 1 до «кол_пер».

Кол_пер — общее число периодов выплат годовой ренты.

Пс — текущая стоимость или общая сумма всех будущих платежей с настоящего момента.

Бс — будущая стоимость или баланс наличности, который нужно достичь после последней выплаты. Если аргумент бс опущен, то предполагается, что он равен 0 (например, бс для займа равно 0).

Тип — число 0 или 1, обозначающее, когда должна производиться выплата. Если аргумент «тип» опущен, то он полагается равным 0.

Тип | Когда нужно выплатить
0 | В конце периода
1 | В начале периода

Примечания
  • Убедитесь, что вы последовательны в выборе единиц измерения для задания аргументов «ставка» и «кол_пер». Если вы делаете ежемесячные выплаты по четырехгодичному займу из расчета 12 процентов годовых, то используйте 12%/12 для задания аргумента «ставка» и 4*12 для задания аргумента «кол_пер». Если вы делаете ежегодные платежи по тому же займу, то используйте 12% для задания аргумента «ставка» и 4 для задания аргумента «кол_пер».
  • Все аргументы, означающие деньги, которые платятся (например, депозитные вклады), представляются отрицательными числами; деньги, которые получены (например, дивиденды), представляются положительными числами.

Пример

Ставка | Период | Кол_пер | ПС | Формула | Описание (Результат)
10% | 1 | 3 | 8000 | =ПРПЛТ([Ставка]/12; [Период]*3; [Кол_пер]; [ПС]) | Выплаты по процентам за первый месяц на приведенных условиях (-22,41)
10% | 1 | 3 | 8000 | =ПРПЛТ([Ставка]; 3; [Кол_пер]; [ПС]) | Выплаты по процентам за последний год на приведенных условиях (начисления процентов производятся ежегодно) (-292,45)

Примечание. Чтобы получить месячную процентную ставку, надо годовую ставку разделить на 12. Чтобы узнать количество выплат, надо количество лет кредита умножить на 12.


ПРОЦПЛАТ

Вычисление выплаты за указанный период инвестиции.

Синтаксис

ПРОЦПЛАТ(ставка;период;кол_пер;пс)

Ставка — процентная ставка для инвестиции.

Период — период, для которого требуется найти прибыль; должен находиться в интервале от 1 до кол_пер.

Кол_пер — общее число периодов выплат для данной инвестиции.

Пс — стоимость инвестиции на текущий момент. Для займа пс — это сумма займа..

Примечания

  • Убедитесь, что вы последовательны в выборе единиц измерения для задания аргументов «ставка» и «кол_пер». Если вы делаете ежемесячные выплаты по четырехгодичному займу из расчета 12 процентов годовых, то используйте 12%/12 для задания аргумента «ставка» и 4*12 для задания аргумента «кол_пер». Если вы делаете ежегодные платежи по тому же займу, то используйте 12% для задания аргумента «ставка» и 4 для задания аргумента «кол_пер».
  • Все аргументы, означающие деньги, которые вы платите (например депозитные вклады), представляются отрицательными числами; деньги, которые вы получаете (например дивиденды), представляются положительными числами.
  • Подробнее о финансовых функциях см. в справке по функции «ПС».

Пример

Ставка | Период | Кол_пер | ПС | Формула | Описание (Результат)
10% | 1 | 3 | 8000000 | =ПРОЦПЛАТ([Ставка]/12;[Период];[Кол_пер]*12;[ПС]) | Сумма первого из ежемесячных платежей за кредит на приведенных условиях (-64814,8)
10% | 1 | 3 | 8000000 | =ПРОЦПЛАТ(([Ставка],1,[Кол_пер],[ПС]) | Сумма процентов, выплаченных в первом году за кредит на приведенных выше условиях (-533333)

Примечание. Чтобы получить месячную процентную ставку, надо годовую ставку разделить на 12. Чтобы узнать количество выплат, надо количество лет кредита умножить на 12.


Функция КПЕР

Возвращает общее количество периодов выплаты для данного вклада на основе периодических и постоянных выплат, а также постоянной процентной ставки.

Синтаксис

КПЕР(ставка; платеж; пс; бс; тип)

Более полное описание аргументов функции КПЕР и дополнительные сведения о функциях платежей по ссуде см. в разделе «Функция ПС»

Ставка — процентная ставка за период.

Платеж — выплата, производимая в каждый период; это значение не может меняться в течении всего периода выплат. Обычно плата состоит из основного платежа и платежа по процентам, но не включает других налогов и сборов.

Пс — текущая стоимость или общая сумма всех будущих платежей с настоящего момента.

Бс — будущая стоимость или баланс наличности, который нужно достичь после последней выплаты. Если аргумент бс опущен, то предполагается, что он равен 0 (например, бс для займа равно 0).

Тип — число 0 или 1, обозначающее, когда должна производиться выплата.

Тип | Когда нужно выплатить
0 или опущен | В конце периода
1 | В начале периода

Пример
Ставка | Платеж | ПС | БС | Тип | Формула | Описание (Результат)
12% | -100 | -1000 | 10000 | 1 | =КПЕР([Ставка]/12; [Платеж]; [ПС]; [БС]; 1) | Период выплат при заданных аргументах (60)
12% | -100 | -1000 | 10000 | 1 | =КПЕР([Ставка]/12; [Платеж]; [ПС]; [БС]) | Период выплат при заданных аргументах, за исключением выплат в начале периода (60)
12% | -100 | -1000 | 10000 | 1 | =КПЕР([Ставка]/12; [Платеж]; [ПС]) | Период выплат при заданных аргументах, за исключением будущей стоимости 0 (-9,578)


Функция ЧПС

Вычисляет чистую приведенную стоимость инвестиции, используя скидки, серии будущих выплат (отрицательные значения) и доходы (положительные значения).

Синтаксис

ЧПС(ставка;значение1;значение2; ...)

Ставка — это учетная ставка за один период.

Значение1, значение2, ... — это от 1 до 29 аргументов, представляющих расходы и доходы.

  • Значение1, значение2, ... должны быть равномерно распределены во времени, выплаты должны осуществляться в конце каждого периода.
  • ЧПС использует порядок аргументов значение1, значение2, ... для определения порядка поступления денежных средств. Убедитесь в том, что платежи и поступления введены в правильном порядке.
  • Аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел, учитываются; аргументы, которые являются значениями ошибки или текстами, которые не могут быть преобразованы в числа, игнорируются.

Примечания

  • Инвестиция, значение которой вычисляет функция ЧПС, начинается за один период до даты денежного взноса значение1 и заканчивается с последним денежным взносом в списке. Вычисления функции ЧПС базируются на будущих денежных взносах. Если первый денежный взнос приходится на начало первого периода, то первое значение следует добавить к результату функции ЧПС, но не включать в список аргументов. Дополнительные сведения см. в примерах ниже.
  • Если n - это количество денежных взносов в списке значений, то формула для функции ЧПС имеет следующий вид.

  • Функция ЧПС аналогична функции ПС (текущее значение). Основное различие между этими функциями заключается в том, что ПС допускает, чтобы денежные взносы происходили либо в конце, либо в начале периода. В отличие от денежных взносов переменной величины в функции ЧПС денежные взносы в функции ПС должны быть постоянны в течении всего периода инвестиции. Дополнительные сведения о функциях, связанных с ежегодными выплатами, и финансовых функциях см. в разделе «Функция ПС».
  • ЧПС также связана с функцией ВСД (внутренняя ставка дохода). ВСД — это ставка, для которой ЧПС равняется нулю: ЧПС(ВСД(...); ...) = 0.

Пример 1

В следующем примере.

  • Ставка — это годовая учетная ставка.
  • Значение1 — это начальная стоимость инвестиции через год.
  • Значение2 — это прибыль после первого года.
  • Значение3 — это прибыль после второго года.
  • Значение4 — это прибыль после третьего года.
Ставка | Значение1 | Значение2 | Значение3 | Значение4 | Формула | Описание (Результат)
10% | -10000 | 3000 | 4200 | 6800 | =ЧПС([Ставка]; [Значение1]; [Значение2]; [Значение3]; [Значение4]) | Чистая приведенная стоимость инвестиции (1 188,44)

В предыдущем примере начальная стоимость 10 000 руб. была включена как одно из значений, поскольку выплата производилась в конце первого периода.

Пример 2

В следующем примере.

  • Ставка — это годовая учетная ставка. Она может показывать уровень инфляции или процентную ставку параллельной инвестиции.
  • Значение1 — это начальная стоимость инвестиции через год.
  • Значение2 — это прибыль после первого года.
  • Значение3 — это прибыль после второго года.
  • Значение4 — это прибыль после третьего года.
  • Значение5 — это прибыль после четвертого года.
  • Значение6 — это прибыль после пятого года.
Ставка | Значение1 | Значение2 | Значение3 | Значение4 | Значение5 | Значение6 | Формула | Описание (Результат)
8% | 40000 | 8000 | 9200 | 10000 | 12000 | 14500 | =ЧПС(Ставка; [Значение2]; [Значение3]; [Значение4]; [Значение5]; [Значение6])+[Значение1] | Чистая приведенная стоимость инвестиции (1 922,06)
8% | 40000 | 8000 | 9200 | 10000 | 12000 | 14500 | =ЧПС(Ставка; [Значение2]; [Значение3]; [Значение4]; [Значение5]; [Значение6]; -9000)+[Значение1] | Чистая приведенная стоимость инвестиции с учетом убытка на шестом году 9000 (-3 749,47)

В предыдущем примере начальная стоимость 40 000 руб. не включалась в список значений, поскольку выплата пришлась на начало периода.


ПЛТ

Возвращает сумму периодического платежа для аннуитета на основе постоянства сумм платежей и постоянства процентной ставки.

Синтаксис

ПЛТ(ставка;кол_пер;пс;бс;тип)

Более подробное описание аргументов функции ПЛТ см. в описании функции ПС.

Ставка — процентная ставка для ссуды.

Кол_пер — общее число выплат для данной ссуды.

Пс — приведенная к текущему моменту стоимость, или общая сумма, которая на текущий момент равноценна ряду будущих платежей, называемая также основной суммой.

Бс — будущая стоимость или баланс наличности, который нужно достичь после последней выплаты. Если аргумент бс опущен, то предполагается, что он равен 0, т.е. что кредит полностью возвращен.

Тип — число 0 или 1, обозначающее, когда должна производиться выплата.

Тип | Когда нужно выплатить
0 или опущен | В конце периода
1 | В начале периода

Примечания
  • Выплаты, возвращаемые функцией ПЛТ, включают основные платежи и платежи по процентам, но не включают налогов, резервных платежей или комиссий, иногда связываемых со ссудой.
  • Убедитесь, что вы последовательны в выборе единиц измерения для задания аргументов «ставка» и «кол_пер». Если вы делаете ежемесячные выплаты по четырехгодичному займу из расчета 12 процентов годовых, то используйте 12%/12 для задания аргумента «ставка» и 4*12 для задания аргумента «кол_пер». Если вы делаете ежегодные платежи по тому же займу, то используйте 12 процентов для задания аргумента «ставка» и 4 для задания аргумента «кол_пер».

Показать Совет

Для нахождения общей суммы, выплачиваемой на протяжении интервала выплат, умножьте возвращаемое функцией ПЛТ значение на кол_пер.

Пример 1

В следующем примере:

  • Ставка— это годовая процентная ставка
  • Кол_пер— это количество месяцев платежей
  • ПС— это сумма кредита
Ставка | Кол_пер | ПС | Формула | Описание (Результат)
8% | 10 | 10000 | =ПЛТ([Ставка]/12; [Кол_пер]; [ПС]) | Месячная сумма платежа по указанной ссуде (-1037,03)
8% | 10 | 10000 | =ПЛТ([Ставка]/12; [Кол_пер]; [ПС]; 0; 1) | Месячная сумма платежа по указанной ссуде, исключая платежи, производимые в начале периода (-1030,16)

Пример 2

Функцию ПЛТ можно использовать для расчета платежей по аннуитетам (не только в случае ссуд).

В следующем примере:

  • Ставка— это годовая процентная ставка.
  • Кол_пер— это предполагаемое число лет хранения сбережений.
  • ПС— это требуемое количество сбережений через 18 лет.
Ставка | Кол_пер | ПС | Формула | Описание (Результат)
6% | 18 | 50000 | =ПЛТ([Ставка]/12; [Кол_пер]*12; 0; [ПС]) | Необходимая сумма месячного платежа для получения 50 000 в конце восемнадцатитилетнего периода (-129,08)

Примечание. Чтобы получить месячную процентную ставку, надо годовую ставку разделить на 12. Чтобы узнать количество выплат, надо количество лет кредита умножить на 12.


ОСПЛТ

Возвращает сумму основного платежа по инвестиции за данный период на основе постоянства сумм периодических платежей и постоянства процентной ставки.

Синтаксис

ОСПЛТ(ставка,период,кпер,пс,бс,тип)

Полное описание аргументов функции ОСПЛТ см. ПС.

Ставка — процентная ставка за период.

Период задает период от 1 до кпер.

Кпер — общее число периодов выплат годовой ренты.

Пс — приведенная к текущему моменту стоимость или общая сумма, которая на текущий момент равноценна ряду будущих платежей.

Бс — будущая стоимость или баланс наличности, который нужно достичь после последней выплаты. Если аргумент бс опущен, то предполагается, что он равен 0, т.е. что кредит полностью возвращен.

Тип — это число 0 или 1, обозначающее, когда должна производиться выплата.

Тип | Когда нужно выплатить
0 или опущен | В конце периода
1 | В начале периода

Примечания

Убедитесь, что для аргументов ставка и кпер используются согласованные единицы измерения. Если производятся ежемесячные платежи по четырехгодичному займу из расчета 12% годовых, то ставка должна быть 12%/12 , а кпер должно быть 4*12. Если производятся ежегодные платежи по тому же займу, то ставка должна быть 12%, а кпер должно быть 4.

Пример 1

Ставка | Кпер | ПС | Формула | Описание (Результат)
10% | 2 | 2000 | =ОСПЛТ([Ставка]/12, 1, [Кпер]*12, [ПС]) | Основной платеж на первый месяц займа равен -75.62

Примечание. Для получения месячной ставки разделите процентную ставку на 12. Для получения количества платежей умножьте на 12 число лет, в течение которых производятся выплаты.

Пример 2

Ставка | Период | ПС | Формула | Описание (Результат)
8% | 10 | 200,000 | =ОСПЛТ([Ставка], [Период], 10, [ПС]) | Основной платеж последнего года займа при заданных аргументах равен -27,598.05


Функция ПС

Возвращает текущую стоимость инвестиции. Текущая стоимость — это общая сумма, которую составят будущие платежи. Например, когда деньги берутся взаймы, заимствованная сумма и есть текущая стоимость для заимодавца.

Синтаксис

ПС(ставка;кпер;пс;бс;тип)

Ставка — процентная ставка за период. Например, если получена ссуда под автомобиль под 10 процентов годовых и делаются ежемесячные выплаты, то процентная ставка за месяц составит 10%/12 или 0,83%. В качестве значения аргумента ставка нужно ввести в формулу 10%/12 или 0,83% или 0,0083.

Кпер — общее число периодов выплат годовой ренты. Например, если получена ссуда на 4 года под автомобиль и делаются ежемесячные платежи, то ссуда имеет 4*12 (или 48) периодов. В качестве значения аргумента кпер в формулу нужно ввести число 48.

Пс — это выплата, производимая в каждый период и не меняющаяся за все время выплаты ренты. Обычно выплаты включают основные платежи и платежи по процентам, но не включают других сборов или налогов. Например, ежемесячная выплата по четырехгодичному займу в 10 000 руб. под 12 процентов годовых составит 263,33 руб. В качестве значения аргумента пс нужно ввести в формулу число -263,33.

Бс — будущая стоимость или баланс наличности, который нужно достичь после последней выплаты. Если аргумент опущен, он полагается равным 0 (например, будущая стоимость займа равна 0). Например, если предполагается накопить 50 000 руб. для оплаты специального проекта в течение 18 лет, то 50 000 руб. это и есть будущая стоимость. Можно сделать предположение о сохранении заданной процентной ставки и определить, сколько нужно откладывать каждый месяц. Если аргумент бс опущен, необходимо использовать аргумент плт.

Тип — это число 0 или 1, обозначающее, когда должна производиться выплата.

Тип | Когда нужно выплатить
0 или опущен | В конце периода.
1 | В начале периода.

Примечания
  • Убедитесь, что для аргументов ставка и кпер используются согласованные единицы измерения. Если производятся ежемесячные платежи по четырехгодичному займу из расчета 12% годовых, то ставка должна быть 12%/12 , а кпер должно быть 4*12. Если производятся ежегодные платежи по тому же займу, то ставка должна быть 12%, а кпер должно быть 4.
  • Следующие функции применяются при ежегодных выплатах:
    • БС
    • ОСПЛТ
    • ПЛТ
    • ПРПЛТ
    • ПС
    • СТАВКА
    Ежегодные выплаты — это последовательность постоянных денежных платежей, производимых в непрерывный период. Например, заем под автомобиль или заклад являются ежегодными выплатами. Дополнительные сведения см. в описании каждой функции, связанной с ежегодными выплатами.
  • В функциях, связанных с ежегодными выплатами, выплачиваемые деньги, такие как депозит на накопление, представляются отрицательным числом; полученные деньги, такие как чеки на дивиденды, представляются положительным числом. Например, депозит в банк на сумму 1 000 руб. представляется аргументом -1 000 для вкладчика и аргументом 1 000 для банка.
  • Каждый финансовый аргумент выражается через другие. Если ставка не равна 0, то:

    Если ставка равна 0, то:

    (плт *кпер) + пс + бс = 0.

Пример

В следующем примере.

  • Плт — это деньги, выплачиваемые по страховке в конце каждого месяца.
  • Ставка — это процентная ставка, полученная с выплаты денег.
  • Кпер — это количество лет, в течении которых будут выплачиваться деньги.
Плт | Ставка | Кпер | Формула | Описание (Результат)
500 | 8% | 20 | =ПС([Ставка]/12; 12*[Кпер]; [Плт]; ; 0) | Текущая стоимость годовой ренты с указанными аргументами (-59 777,15)

Результат получается отрицательный, поскольку он представляет деньги, которые необходимо выплатить. Настоящий объем вклада (59 777,15 руб.) меньше, чем запрашиваемая цена (60 000 руб.). Следовательно, можно сделать вывод, что это не самый лучший способ инвестирования денег.

Примечание. Чтобы получить месячную процентную ставку, надо годовую ставку разделить на 12. Чтобы узнать количество выплат, надо количество лет кредита умножить на 12.


СТАВКА

Возвращает процентную ставку по аннуитету за один период. СТАВКА вычисляется путем итерации и может давать нулевое значение или несколько значений. Если последовательные результаты функции СТАВКА не сходятся с точностью 0,0000001 после 20-ти итераций, то СТАВКА возвращает сообщение об ошибке #ЧИСЛО!.

Синтаксис

СТАВКА(кол_пер;плт;пс;бс;тип;прогноз)

Полное описание смысла аргументов кол_пер, плт, пс, бс и тип см. в справке по функции ПС.

Кол_пер — общее число периодов выплат годовой ренты.

Плт — это выплата, производимая в каждый период; это значение не может меняться в течение всего периода выплат. Обычно плт состоит из основного платежа и платежа по процентам, но не включает других налогов и сборов. Если аргумент опущен, должно быть указано значение аргумента «бс».

Пс — приведенная к текущему моменту стоимость или общая сумма, которая на текущий момент равноценна ряду будущих платежей.

Бс — будущая стоимость или баланс наличности, который нужно достичь после последней выплаты. Если аргумент бс опущен, то предполагается, что он равен 0 (например, бс для займа равно 0).

Тип — число 0 или 1, обозначающее, когда должна производиться выплата.

Тип | Когда нужно выплатить
0 или опущен | В конце периода
1 | В начале периода

Прогноз — предполагаемая величина ставки.

  • Если прогноз опущен, то он полагается равным 10 процентам.
  • Если СТАВКА не сходится, попробуйте подставить различные значения для прогноза. СТАВКА обычно сходится, если величина прогноза находится между числами 0 и 1.

Примечания

Убедитесь, что вы последовательны в выборе единиц измерения для задания аргументов прогноз и кол_пер. Если делаются ежемесячные выплаты по четырехгодичному займу под 12 процентов годовых, используйте 12%/12 для задания аргумента прогноз и 4*12 для задания аргумента кол_пер. Если делаются ежегодные платежи по тому же займу, то используйте 12% для задания аргумента прогноз и 4 для задания аргумента кол_пер.

Пример

Кол_пер | Плт | ПС | Формула | Описание (Результат)
4 | -200 | 8000 | =СТАВКА([Кол_пер]*12, [Плт], [ПС]) | Месячная процентная ставка по займу с заданными параметрами (1%)
4 | -200 | 8000 | =СТАВКА([Кол_пер]*12, [Плт], [ПС])*12 | Годовая процентная ставка по займу с заданными параметрами (0,09241767 или 9,24%)

Примечание. Количество лет кредита умножено на 12, чтобы получить число месяцев.


АПЛ

Возвращает равномерное начисление износа актива за период времени.

Синтаксис

АПЛ(нач_стоимость,ост_стоимость,время_эксплуатации)

Нач_стоимость — начальная стоимость актива.

Ост_стоимость — остаточная стоимость актива в конце периода амортизации.

Время_эксплуатации — число периодов амортизации актива (иногда называется временем полезной службы актива).

Пример

Нач_стоимость | Ост_стоимость | Время_эксплуатации | Формула | Описание (Результат)
30,000 | 7,500 | 10 | =АПЛ([Нач_стоимость], [Остаточная_стоимость], [Время_эксплуатации]) | Ежегодная налоговая скидка на амортизацию: 2,250


Функция АСЧ

Возвращает величину амортизации актива за данный период, рассчитанную методом суммы годовых чисел.

Синтаксис

АСЧ(нач_стоимость;ост_стоимость;время_эксплуатации;период)

Нач_стоимость — начальная стоимость актива.

Ост_стоимость — остаточная стоимость актива в конце периода амортизации.

Время_эксплуатации — число периодов амортизации актива (иногда называется временем полезной службы актива).

Период — период; должен указываться в тех же единицах, что и время_эксплуатации.

Примечания

  • АСЧ вычисляется следующим образом:

Пример

Нач_стоимость | Ост_стоимость | Время_эксплуатации | Формула | Описание (Результат)
30000 | 7500 | 10 | =АСЧ([Нач_стоимость];[Ост_стоимость];[Время_эксплуатации];1) | Годовая амортизация за первый год (4 090,91)
30000 | 7500 | 10 | =АСЧ([Нач_стоимость];[Ост_стоимость];[Время_эксплуатации];10) | Годовая амортизация за десятый год (409,09)


Функции проверки типа

В данном разделе описываются восемь функций, предназначенных для проверки типа значения или ссылки.

Каждая функция проверяет тип значения и в зависимости от результата возвращает значение ИСТИНА или ЛОЖЬ. Например, функция ЕПУСТО возвращает логическое значение ИСТИНА, если значение является ссылкой на пустую ячейку. В противном случае возвращается значение ЛОЖЬ.

Синтаксис

ЕПУСТО(значение)
ЕОШ(значение)
ЕОШИБКА(значение)
ЕЛОГИЧ(значение)
ЕНД(значение)
ЕНЕТЕКСТ(значение)
ЕЧИСЛО(значение)
ЕТЕКСТ(значение)

Значение — это значение, которое нужно проверить. В качестве него можно использовать пустое значение, значение ошибки, логическое выражение, текст, число или ссылку.

Функция | Возвращает значение ИСТИНА, если
ЕЛОГИЧ | Значение ссылается на любое логическое значение.
ЕНД | Значение ссылается на значение ошибки #Н/Д (значение недоступно).
ЕНЕТЕКСТ | Значение ссылается на любой элемент, который не является текстом. (Функция возвращает ИСТИНА, если значение ссылается на пустую ячейку.)
ЕОШ | Значение ссылается на любое значение ошибки, кроме #Н/Д.
ЕОШИБКА | Значение ссылается на любое значение ошибки (#Н/Д, #ЗНАЧ!, #ССЫЛ!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО!).
ЕПУСТО | Значение ссылается на пустую ячейку.
ЕТЕКСТ | Значение ссылается на текст.
ЕЧИСЛО | Значение ссылается на число.

Примечания
  • Аргумент этих функций не преобразуется. Для большинства других функций, например, если в качестве аргумента требуется число, то текстовое значение "19" преобразуется в число 19. Однако в формуле ЕЧИСЛО("19") "19" не преобразуется из текста в число и функция ЕЧИСЛО возвращает значение ЛОЖЬ.
  • Эти функции полезны в формулах для проверки результатов вычислений. Комбинируя эти функции с функцией ЕСЛИ, можно локализовать ошибки в формулах (см. следующие примеры).

Пример 1

Формула | Описание (Результат)
=ЕЛОГИЧ(ИСТИНА) | Проверяет, является ли значение ИСТИНА логическим (ИСТИНА)
=ЕЛОГИЧ("ИСТИНА") | Проверяет, является ли значение "ИСТИНА" логическим (ЛОЖЬ)
=ЕЧИСЛО(4) | Проверяет, является ли 4 числом (ИСТИНА)

Пример 2

Столбец1 | Формула | Описание (Результат)
Золото | =ЕПУСТО([Столбец1]) | Проверяет, является ли значение в столбце Столбец1 пустым (ЛОЖЬ)
#ССЫЛ! | =ЕОШИБКА([Столбец1]) | Проверяет, является ли значение в столбце Столбец1 ошибкой (ИСТИНА)
#ССЫЛ! | =ЕНД([Столбец1]) | Проверяет, является ли значение в столбце Столбец1 ошибкой #Н/Д (ЛОЖЬ)
#Н/Д | =ЕНД([Столбец1]) | Проверяет, является ли значение в столбце Столбец1 ошибкой #Н/Д (ИСТИНА)
#Н/Д | =ЕОШ([Столбец1]) | Проверяет, является ли значение в столбце Столбец1 ошибкой (ЛОЖЬ)
330,92 | =ЕЧИСЛО([Столбец1]) | Проверяет, является ли значение в столбце Столбец1 числом (ИСТИНА)
Регион1 | =ЕТЕКСТ([Столбец1]) | Проверяет, является ли значение в столбце Столбец1 текстом (ИСТИНА)


Я

Возвращает текущее имя пользователя.

Синтаксис

Я

Примечания

  • Эта функция может использоваться только со значениями по умолчанию; ее нельзя использовать в вычисляемых столбцах.


И

Возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА; возвращает значение ЛОЖЬ, если хоть один из аргументов имеет значение ЛОЖЬ.

Синтаксис

И(логическое_значение1;логическое_значение2;...)

логическое_значение1; логическое_значение2; ... — это от 1 до 30 условий, принимающих значения ИСТИНА или ЛОЖЬ.

Примечания

  • Аргументы должны либо вычисляться и выдавать значения ИСТИНА или ЛОЖЬ, либо ссылаться на столбец, содержащий логические значения.
  • Если аргумент-ссылка содержит текст, функция «И» возвращает сообщение об ошибке «#ЗНАЧ!», если аргумент-ссылка пуста, функция возвращает значение ЛОЖЬ.
  • Если аргументы не содержат логических значений, функция «И» возвращает сообщение об ошибке «#ЗНАЧ!».

Пример 1

Формула | Описание (Результат)
=И(ИСТИНА; ИСТИНА) | Все аргументы имеют значение ИСТИНА (ИСТИНА)
=И(ИСТИНА; ЛОЖЬ) | Один аргумент имеет значение ЛОЖЬ (ЛОЖЬ)
=И(2+2=4; 2+3=5) | Результатом вычисления всех аргументов является значение ИСТИНА (ИСТИНА)

Пример 2

Столбец1 | Столбец2 | Формула | Описание (Результат)
50 | 104 | =И(1<[Столбец1]; [Столбец1]<100) | Число 50 лежит между 1 и 100 (ИСТИНА)
50 | 104 | =ЕСЛИ(И(1<[Столбец2]; [Столбец2]<100); [Столбец2]; "Значение лежит вне интервала.") | Отображается значение из второго столбца, если оно лежит в интервале от 1 до 100. В противном случае выводится сообщение (Значение лежит вне интервала.)
50 | 104 | =ЕСЛИ(И(1<[Столбец1]; [Столбец1]<100); [Столбец1]; "Значение лежит вне интервала.") | Отображается значение из первого столбца, если оно лежит в интервале от 1 до 100. В противном случае выводится сообщение (50)


ВЫБОР

Использует номер_индекса, чтобы выбрать и вернуть значение из списка аргументов-значений. Функция ВЫБОР используется, чтобы выбрать одно значение из списка, в котором может быть до 29 значений. Например, если значения от значение1 до значение7 — это дни недели, то функция ВЫБОР возвращает один из дней при использовании числа от 1 до 7 в качестве аргумента номер_индекса.

Синтаксис

ВЫБОР(номер_индекса;значение1;значение2;...)

Номер_индекса — это номер выбираемого аргумента-значения. Номер_индекса должен быть числом от 1 до 29, формулой или ссылкой на ячейку, содержащую число в диапазоне от 1 до 29.

  • Если номер_индекса равен 1, то функция ВЫБОР возвращает значение1; если он равен 2, то функция ВЫБОР возвращает значение2 и так далее.

  • Если номер_индекса меньше 1 или больше, чем номер последнего значения в списке, то функция ВЫБОР возвращает значение ошибки #ЗНАЧ!.

  • Если номер_индекса является дробным, то он усекается до меньшего целого.

Значение1; значение2; ... — это от 1 до 29 аргументов-значений, из которых ВЫБОР, используя номер_индекса, выбирает значение или выполняемое действие. Аргументы могут быть числами, ссылками на ячейки, именами, формулами, функциями или текстами.

Примечания

Пример 1

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Формула | Описание (Результат)
Первый | Второй | Третий | Законченный | =ВЫБОР(2;[Столбец1];[Столбец2];[Столбец3];[Столбец4]) | Значение из второго аргумента (Второй)
Гвозди | Винты | Гайки | Болты | =ВЫБОР(4;[Столбец1];[Столбец2];[Столбец3];[Столбец4]) | Значение из четвертого аргумента (Болты)

Пример 2

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Формула | Описание (Результат)
23 | 45 | 12 | 10 | =СУММ([Столбец1]; ВЫБОР(2;[Столбец2];[Столбец3]; [Столбец4])) | Сумма значения первого аргумента (Столбец1) и результата функции ВЫБОР (35)


ЛОЖЬ

Возвращает логическое значение ЛОЖЬ.

Синтаксис

ЛОЖЬ( )

Примечания

При введении слова ЛОЖЬ непосредственно в формулу оно рассматривается как логическое значение ЛОЖЬ.


Функция ЕСЛИ

Возвращает одно значение, если заданное условие при вычислении дает значение ИСТИНА, и другое значение, если ЛОЖЬ..

Функция ЕСЛИ используется при проверке условий для значений и формул.

Синтаксис

ЕСЛИ(лог_выражение;значение_если_истина;значение_если_ложь)

Лог_выражение — это это любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. Например, [Квартал1]=100 — это логическое выражение. Если значение строки в столбце [Квартал1] равно 100, то выражение принимает значение ИСТИНА. В противном случае — ЛОЖЬ. Этот аргумент может быть использован в любом операторе сравнения.

Значение_если_истина — это значение, которое возвращается, если лог_выражение равно ИСТИНА. Например, если этот аргумент — строка «В пределах бюджета» и лог_выражение равно ИСТИНА, тогда функция ЕСЛИ отобразит текст «В пределах бюджета». Если лог_выражение равно ИСТИНА, а значение_если_истина пусто, то возвращается значение 0. Чтобы отобразить слово ИСТИНА, необходимо использовать логическое значение ИСТИНА для этого аргумента. Значение_если_истина может быть формулой.

Значение_если_ложь — это значение, которое возвращается, если лог_выражение равно ЛОЖЬ. Например, если этот аргумент — строка «Превышение бюджета» и лог_выражение равно ЛОЖЬ, то функция ЕСЛИ отобразит текст «Превышение бюджета». Если лог_выражение равно ЛОЖЬ, а значение_если_ложь опущено (то есть после значение_если_истина нет точки с запятой), то возвращается логическое значение ЛОЖЬ. Если лог_выражение равно ЛОЖЬ, а значение_если_ложь пусто (то есть после значение_если_истина стоит точка с запятой с последующей закрывающей скобкой), то возвращается значение 0. Значение_если_ложь может быть формулой.

Примечания

  • Для конструирования более сложных проверок в качестве значений аргументов значение_если_истина и значение_если_ложь могут быть вложены друг в друга до семи функций ЕСЛИ. См. последний из приведенных ниже примеров.
  • Когда значения аргументов значение_если_истина и значение_если_ложь вычислены, функция ЕСЛИ возвращает полученное значение.
  • Если любой из аргументов функции ЕСЛИ является массивом, все элементы массива вычисляются при выполнении функции ЕСЛИ.

Пример 1

Столбец1 | Столбец2 | Столбец3 | Расходы | Формула | Описание (Результат)
 |  |  | 50 | =ЕСЛИ([Расходы]<=100;"В пределах бюджета";"Превышение бюджета") | Если число меньше или равно 100, то отображается «В пределах бюджета», в противном случае — «Превышение бюджета» (В пределах бюджета)
23 | 45 | 89 | 50 | =ЕСЛИ([Расходы]=100;СУММ([Столбец1];[Столбец2];[Столбец3]);"") | Если число равно 100, то добавляется три значения, в противном случае возвращается пустая строка ()

Пример 2

Фактические расходы | Прогнозированные расходы | Формула | Описание (Результат)
1500 | 900 | =ЕСЛИ([Фактические расходы]>[Прогнозированные расходы];"Превышение бюджета";"OK") | Проверяет, соответствует ли первая строка превышению бюджета (Превышение бюджета)
500 | 900 | =ЕСЛИ([Фактические расходы]>[Прогнозированные расходы];"Превышение бюджета";"OK") | Проверяет, соответствует ли вторая строка превышению бюджета (ОК)

Пример 3

Оценка | Формула | Описание (Результат)
45 | =ЕСЛИ([Оценка]>89;"A";ЕСЛИ([Оценка]>79;"B";ЕСЛИ([Оценка]>69;"C";ЕСЛИ([Оценка]>59;"D";"F")))) | Назначает буквенную категорию первой оценке (F)
90 | =ЕСЛИ([Оценка]>89;"A";ЕСЛИ([Оценка]>79;"B";ЕСЛИ([Оценка]>69;"C";ЕСЛИ([Оценка]>59;"D";"F")))) | Назначает буквенную категорию второй оценке (A)
78 | =ЕСЛИ([Оценка]>89;"A";ЕСЛИ([Оценка]>79;"B";ЕСЛИ([Оценка]>69;"C";ЕСЛИ([Оценка]>59;"D";"F")))) | Назначает буквенную категорию третьей оценке (C)

В предыдущем примере вторая инструкция ЕСЛИ является в то же время аргументом значение_если_ложь для первой инструкции ЕСЛИ. Аналогично, третья инструкция ЕСЛИ является аргументом значение_если_ложь для второй инструкции ЕСЛИ. Например, если первое лог_выражение ([Оценка]>89) имеет значение ИСТИНА, то возвращается значение "A". Если первое лог_выражение имеет значение ЛОЖЬ, то вычисляется вторая инструкция ЕСЛИ и так далее.

Буквенные категории назначаются числам следующим образом (предполагается использование только целых чисел).

Если «Оценка» | Возвращается значение
Больше 89 | A
От 80 до 89 | B
От 70 до 79 | C
От 60 до 69 | D
Меньше 60 | F


НЕ

Меняет на противоположное значение аргумента. Функция НЕ используется, когда требуется убедиться, что данное значение не равно другому значению.

Синтаксис

НЕ(логическое_условие)

Логическое_условие представляет собой значение или выражение, вычисленное как ИСТИНА или ЛОЖЬ.

Примечания

Если логический аргумент ЛОЖЬ, НЕ возвращает значение ИСТИНА, и наоборот.

Пример

Формула | Описание (Результат)
=НЕ(ЛОЖЬ) | ЛОЖЬ обратно ИСТИНА
=НЕ(1+1=2) | Меняет значение ИСТИНА на обратное ЛОЖЬ


ИЛИ

Возвращает значение ИСТИНА, если логическое значение любого из аргументов ИСТИНА; возвращает значение ЛОЖЬ, если логические значения всех аргументов ЛОЖЬ.

Синтаксис

ИЛИ(логическое_условие1,логическое_условие2,...)

Логическое_условие1, логическое условие2, ... представляют собой от 1 до 30 условий, истинность которых необходимо проверить.

Примечания

  • Аргументы должны либо вычисляться и давать значения ИСТИНА или ЛОЖЬ, либо быть массивами или ссылаться на столбец, содержащий логические значения.
  • Если аргумент, содержащий ссылку на столбец, имеет текст или пуст, эти значения игнорируются.
  • Если заданная ячейка не содержит логических значений, функция ИЛИ возвращает значение ошибки #ЗНАЧ!.

Пример

Формула | Описание (Результат)
=ИЛИ(ИСТИНА) | Значение аргумента ИСТИНА (ИСТИНА)
=ИЛИ(1+1=1,2+2=5) | Все аргументы дают значение ЛОЖЬ (ЛОЖЬ)
=ИЛИ(ИСТИНА,ЛОЖЬ,ИСТИНА) | По крайней мере один аргумент имеет значение ИСТИНА (ИСТИНА)


Функция ИСТИНА

Возвращает логическое значение ИСТИНА.

Синтаксис

ИСТИНА( )

Примечания

Можно непосредственно ввести значение ИСТИНА в ячейки и формулы без использования этой функции. Функция ИСТИНА предназначена для обеспечения совместимости с другими приложениями.


ABS

Возвращает абсолютное значение числа (число без знака).

Синтаксис

ABS(число)

Число — это вещественное число, абсолютное значение которого необходимо узнать.

Пример

Столбец 1 | Формула | Описание (Результат)
-4 | =ABS([Col1]) | Абсолютное значение -4 равно 4


ACOS

Возвращает арккосинус, или обратный косинус, числа. Арккосинус является углом, для которого данное число является косинусом. Угол дается в радианах от 0 (нуля) до pi.

Синтаксис

ACOS(число)

Число является косинусом требуемого угла и лежит в пределах от -1 до 1.

Примечания

Если необходимо перевести результат из радиан в градусы, умножьте его на 180/Pi или используйте функцию ГРАДУСЫ.

Пример

Формула | Описание (Результат)
=ACOS(-0,5) | Арккосинус -0,5 равен 2*Pi/3 радиан (2,094395)
=ACOS(-0,5)*180/Pi | Арккосинус -0,5 равен 120 градусов
=ГРАДУСЫ(ACOS(-0,5)) | Арккосинус -0,5 равен 120 градусов


ACOSH

Возвращает обратный гиперболический косинус числа. Число должно быть больше или равно 1. Обратный гиперболический косинус является значением, гиперболический косинус которого есть число, таким образом, ACOSH(COSH(число)) равняется числу.

Синтаксис

ACOSH(число)

Число всегда вещественно и больше или равняется 1.

Пример

Формула | Описание (Результат)
=ACOSH(1) | Обратный гиперболический косинус 1 равен 0
=ACOSH(10) | Обратный гиперболический косинус 10 равен 2,993223


ASIN

Возвращает арксинус, или обратный синус, числа. Арксинус является углом, синус которого есть число. Угол дается радианах в пределах от -Рi/2 до Рi/2.

Синтаксис

ASIN(число)

Число есть синус требуемого угла, его значение лежит в пределах от -1 до 1.

Примечания

Для выражения арксинуса в градусах умножьте результат на 180/pi или используйте функцию ГРАДУСЫ.

Формула | Описание (Результат)
=ASIN(-0.5) | Арксинус -0,5 равен -Рi/6 (-0,5236) радиан
=ASIN(-0,5)*180/Pi | Арксинус -0,5 равен -30 градусов
=ГРАДУСЫ(ASIN(-0,5)) | Арксинус -0,.5 равен -30 градусов


ASINH

Возвращает обратный гиперболический синус числа. Обратный гиперболический синус представляет собой значение, гиперболическим синусом которого является число, таким образом, ASINH(SINH(число)) равняется числу.

Синтаксис

ASINH(число)

Число представляет собой любое вещественное число.

Пример

Формула | Описание (Результат)
=ASINH(-2.5) | Обратный гиперболический синус -2,5 равен -1,4723
=ASINH(10) | Обратный гиперболический синус 10 равен 2,998223


ATAN

Возвращает арктангенс, или обратный тангенс, числа. Арктангенс является углом, тангенс которого есть число. Угол дается в радианах в пределах от -Рi/2 до Рi/2.

Синтаксис

ATAN (число)

Число представляет собой тангенс требуемого угла.

Примечания

Для выражения арктангенса в градусах умножьте результат на 180/pi или используйте функцию ГРАДУСЫ.

Пример

Формула | Описание (Результат)
=ATAN(1) | Арктангенс 1 равен Рi/4 (0,785398) радиан
=ATAN(1)*180/Pi | Арктангенс 1 равен 45 градусов
=ГРАДУСЫ(ATAN(1)) | Арктангенс 1 равен 45 градусов


Функция ATAN2

Возвращает арктангенс для заданных координат x и y. Арктангенс — это угол между направлением оси x и прямой, соединяющей точки с координатами (0; 0) и (x_num; y_num). Угол задается в радианах и принимает значения от -pi до pi, исключая -pi.

Синтаксис

ATAN2(x_num;y_num)

X_num — координата точки по оси х.

Y_num — координата точки по оси у.

Примечания

  • Если результат функции положительный, угол отсчитывается против часовой стрелки относительно оси x; отрицательный — по часовой стрелке.
  • Выражение ATAN2(a;b) равно выражению ATAN(b/a), если аргумент а не равен 0 в функции ATAN2.
  • Если x_num и y_num равны 0, ATAN2 возвращает значение ошибки #ДЕЛ/0!.
  • Для выражения угла в градусах умножьте результат на 180/ПИ( ) или воспользуйтесь функцией ГРАДУСЫ.

Пример

Формула | Описание (Результат)
=ATAN2(1; 1) | Арктангенс точки с координатами (1;1) в радианах, pi/4 (0,785398)
=ATAN2(-1; -1) | Арктангенс точки с координатами (-1;-1) в радианах, -3*pi/4 (-2,35619)
=ATAN2(-1; -1)*180/PI() | Арктангенс точки с координатами (1;1) в градусах (-135)
=ГРАДУСЫ(ATAN2(-1; -1)) | Арктангенс точки с координатами (1;1) в градусах (-135)


ATANH

Возвращает обратный гиперболический тангенс числа. Число должно лежать в пределах от -1 до 1 (исключая значения -1 и 1). Обратный гиперболический тангенс представляет собой значение, гиперболический тангенс которого есть число; ATANH(TANH(число)) равно числу.

Синтаксис

ATANH(число)

Число представляет собой вещественное число, находящееся в пределах от 1 до -1.

Пример

Формула | Описание (Результат)
=ATANH(0,76159416) | Обратный гиперболический тангенс 0,76159416 примерно равен 1
=ATANH(-0,1) | Обратный гиперболический тангенс -0,1 равен -0,10034


Функция ОКРВВЕРХ

Округляет до ближайшего большего по модулю значения, кратного указанному значению. Например, если нужно избежать рублей в своих ценах и товар стоит 442 рубля, воспользуйтесь формулой =ОКРВВЕРХ(442;10), чтобы округлить цену с точностью до 10 рублей.

Синтаксис

ОКРВВЕРХ(число;точность)

Число — округляемое числовое значение.

Точность — кратное, до которого нужно округлить.

Примечания

  • Если аргумент не является числом, ОКРВВЕРХ возвращает значение ошибки #ЗНАЧ!.
  • Независимо от знака числа, округление производится с избытком. Если число уже кратно точности, то никакого округления не производится. .
  • Если число и точность имеют различные знаки, ОКРВВЕРХ возвращает значение ошибки #ЧИСЛО!.

Пример

Формула | Описание (Результат)
=ОКРВВЕРХ(2,5; 1) | Округляет 2,5 до ближайшего числа, кратного 1 (3)
=ОКРВВЕРХ(-2,5; -2) | Округляет -2,5 до ближайшего большего по модулю числа, кратного -2 (-4)
=ОКРВВЕРХ(-2,5; 2) | Возвращает ошибку, поскольку числа -2,5 и 2 имеют разные знаки (#ЧИСЛО!)
=ОКРВВЕРХ(1,5; 0.1) | Округляет 1,5 до ближайшего числа, кратного 0,1 (1,5)
=ОКРВВЕРХ(0,234; 0.01) | Округляет 0,234 до ближайшего числа, кратного 0,01 (0,24)


COS

Возвращает косинус заданного угла.

Синтаксис

COS(число)

Число представляет собой угол в радианах, косинус которого необходимо узнать.

Примечания

Если значение угла дано в градусах, умножьте его на Pi/180 или используйте функцию РАДИАНЫ для преобразования градусов в радианы.

Пример

Формула | Описание (Результат)
=COS(1.047) | Косинус 1.047 радиан равен 0.500171
=COS(60*PI/180) | Косинус 60 градусов равен 0.5
=COS(РАДИАНЫ(60)) | Косинус 60 градусов равен 0.5


COSH

Возвращает гиперболический косинус числа.

Синтаксис

COSH(число)

Число представляет собой вещественное число, гиперболический косинус которого требуется узнать.

Примечания

Формула гиперболического косинуса:

Пример

Формула | Описание (Результат)
=COSH(4) | Гиперболический косинус 4 равен 27.30823
=COSH(EXP(1)) | Гиперболический косинус основания натурального логарифма равен (7.610125)


ГРАДУСЫ

Переводит радианы в градусы.

Синтаксис

ГРАДУСЫ(угол)

Угол представляет собой величину, которую необходимо перевести.

Пример

Формула | Описание (Результат)
=ГРАДУСЫ(PI()) | Угловая мера pi радиан есть 180 градусов


Функция ЧЁТН

Возвращает число, округленное до ближайшего четного целого. Эту функцию можно использовать при обработке объектов, которые поступают парами. Например, упаковочный ящик позволяет упаковывать по два объекта в ряд. Ящик будет заполнен, если количество объектов, округленное до ближайшего четного числа, равняется вместимости ящика.

Синтаксис

ЧЁТН(число)

Число — округляемое числовое значение.

Примечания

  • Если аргумент число числом не является, ЧЁТН возвращает значение ошибки #ЗНАЧ!.
  • Независимо от знака числа округление производится с избытком. Если число уже является четным целым, то никакого округления не производится.

Пример

Формула | Описание (Результат)
=ЧЁТН(1,5) | Округляет 1,5 до ближайшего четного целого (2)
=ЧЁТН(3) | Округляет 3 до ближайшего четного целого (4)
=ЧЁТН(2) | Округляет 2 до ближайшего четного целого (2)
=ЧЁТН(-1) | Округляет -1 до ближайшего четного целого (-2)


EXP

Возвращает число е, возведенное в степень данного числа. Константа е равна 2.71828182845904, она является основанием натурального логарифма.

Синтаксис

EXP(число)

Число представляет собой показатель степени, в которую возводится основание e.

Примечания

  • Для возведения других чисел в степень используйте оператор ^.
  • Функция EXP обратна функции LN (натуральный логарифм числа).

Пример

Формула | Описание (Результат)
=EXP(1) | Примерное значение числа e равно 2.718282
=EXP(2) | Основание натурального логарифма e, возведенное в степень 2, равно 7.389056


ФАКТР

Возвращает факториал числа. Факториал числа равен 1*2*3*...* число.

Синтаксис

ФАКТР(число)

Число является неотрицательным числом, факториал которого требуется вычислить. Если число не целое, но округляется.

Пример

Формула | Описание (Результат)
=ФАКТР(5) | Факториал 5, или 1*2*3*4*5, равен 120
=ФАКТР(1.9) | Факториал целой части числа 1.9 равен 1
=ФАКТР(0) | Факториал 0 равен 1
=ФАКТР(-1) | Отрицательное число вызывает значение ошибки #ЧИСЛО!
=ФАКТР(1) | Факториал 1 равен 1


Функция ОКРВНИЗ

Округляет число до ближайшего меньшего по модулю целого.

Синтаксис

ОКРВНИЗ(число;точность)

Число — округляемое числовое значение.

Точность — кратное, до которого требуется округлить.

Примечания

  • Если аргумент не является числом, ОКРВНИЗ возвращает значение ошибки #ЗНАЧ!.
  • Если число и точность имеют различные знаки, ОКРВНИЗ возвращает значение ошибки #ЧИСЛО!.
  • Независимо от знака числа, округление всегда производится с недостатком. Если число уже кратно точности, то никакого округления не производится.

Пример

Формула | Описание (Результат)
=ОКРВНИЗ(2,5; 1) | Округляет 2,5 до меньшего по модулю числа, кратного 1 (2)
=ОКРВНИЗ(-2,5; -2) | Округляет -2,5 до меньшего по модулю числа, кратного -2 (-2)
=ОКРВНИЗ(-2,5; 2) | Возвращает ошибку, поскольку числа -2,5 и 2 имеют разные знаки (#ЧИСЛО!)
=ОКРВНИЗ(1,5; 0,1) | Округляет 1,5 в меньшую сторону до ближайшего числа, кратного 0,1 (1,5)
=ОКРВНИЗ(0,234; 0,01) | Округляет 0,234 в меньшую сторону до ближайшего числа, кратного 0,01 (0,23)


ЦЕЛОЕ

Округляет число до ближайшего меньшего целого.

Синтаксис

ЦЕЛОЕ(число)

Число является вещественным числом, которое требуется округлить.

Пример 1

Формула | Описание (Результат)
=ЦЕЛОЕ(8.9) | Округляет 8.9 до 8
=ЦЕЛОЕ(-8.9) | Округляет -8.9 до -9

Пример 2

Столбец1 | Формула | Описание (Результат)
19.5 | =[Столбец1]-ЦЕЛОЕ([Столбец1]) | Возвращает десятичную часть положительного вещественного числа в Столбце1 (значение 0.5)


LN

Возвращает натуральный логарифм числа. Основанием натурального логарифма является константа e (2.71828182845904).

Синтаксис

LN(число)

Число представляет собой положительное число, натуральный логарифм которого требуется вычислить.

Примечания

Функция LN является обратной функции EXP.

Пример

Формула | Описание (Результат)
=LN(86) | Натуральный логарифм 86 равен 4.454347
=LN(2.7182818) | Натуральный логарифм значения константы e равен 1
=LN(EXP(3)) | Натуральный логарифм e в степени 3 равен 3


LOG

Возвращает логарифм числа по заданному основанию.

Синтаксис

LOG(число, основание)

Число представляет собой положительное число, логарифм которого требуется вычислить.

Основание представляет собой основание логарифма. Если основание не задано, оно считается равным 10.

Пример

Формула | Описание (Результат)
=LOG(10) | Логарифм 10 равен 1
=LOG(8, 2) | Логарифм 8 по основанию 2 равен 3
=LOG(86, 2.7182818) | Логарифм 86 по основанию e равен 4.454347


LOG10

Возвращает десятичный логарифм числа.

Синтаксис

LOG10(число)

Число представляет собой положительное число, десятичный логарифм которого требуется вычислить.

Пример

Формула | Описание (Результат)
=LOG10(86) | Десятичный логарифм 86 равен 1.934498451
=LOG10(10) | Десятичный логарифм 10 равен 1
=LOG10(1E5) | Десятичный логарифм 1Е5 равен 5
=LOG10(10^5) | Десятичный логарифм 10^5 равен 5


ОСТАТ

Возвращает остаток деления. Результат имеет тот же знак, что и делитель.

Синтаксис

ОСТАТ(число,делитель)

Число представляет собой делимое, от которого требуется найти остаток.

Делитель представляет собой число, на которое делится делимое.

Примечания

  • Если делитель равен 0, функция ОСТАТ возвращает значение ошибки #Деление/0!.

  • Функция ОСТАТ может быть выражена через функцию ЦЕЛОЕ:

    MOD(n, d) = n - d*INT(n/d)

Пример

Формула | Описание (Результат)
=ОСТАТ(3, 2) | Остаток деления 3/2 равен 1
=ОСТАТ(-3, 2) | Остаток деления -3/2 равен 1. Знак остатка такой же, как и делителя.
=ОСТАТ(3, -2) | Остаток деления 3/-2 равен -1. Знак остатка тот же, что и делителя.
=ОСТАТ(-3, -2) | Остаток деления -3/-2 равен -1. Знак остатка тот же, что и делителя.


НЕЧЕТ

Возвращает число, округленное до ближайшего нечетного целого.

Синтаксис

НЕЧЕТ(число)

Число представляет собой значение, которое нужно округлить.

Примечания

  • Если значение не является числом, функция НЕЧЕТ возвращает значение ошибки #ЗНАЧ!.
  • Независимо от знака числа округление производится с избытком. Если число уже является четным целым, то никакого округления не производится.

Пример

Формула | Описание (Результат)
=НЕЧЕТ(1.5) | Округляет число 1.5 до ближайшего нечетного 3
=НЕЧЕТ(3) | Округляет число 3 до ближайшего нечетного 3
=НЕЧЕТ(2) | Округляет число 2 до ближайшего нечетного 3
=НЕЧЕТ(-1) | Округляет число -1 до ближайшего нечетного -1
=НЕЧЕТ(-2) | Округляет число -2 до ближайшего нечетного -3


ПИ

Возвращает число 3.14159265358979, математическую постоянную pi, с точностью до 15 знаков.

Синтаксис

ПИ( )

Пример

Формула | Описание (Результат)
=ПИ() | Pi равно 3.14159265358979
=ПИ()/2 | Pi/2 равно 1.570796327
=ПИ()*(3^2) | Область круга радиуса 28.27433388


СТЕПЕНЬ

Возвращает результат возведения числа в степень.

Синтаксис

СТЕПЕНЬ(число,степень)

Число представляет собой основание. Может быть только вещественным числом.

Степень представляет собой показатель степени, в которую возводится число.

Примечания

Оператор «^» может использоваться вместо функции СТЕПЕНЬ для обозначения степени, в которую оно возводится, например, 5^2.

Пример

Формула | Описание (Результат)
=СТЕПЕНЬ(5,2) | 5 в квадрате равно 25
=СТЕПЕНЬ(98.6,3.2) | 98.6 в степени 3.2 равно 2401077
=СТЕПЕНЬ(4,5/4) | 4 в степени 5/4 равно 5.656854


ПРОИЗВЕД

Перемножает все аргументы и возвращает произведение.

Синтаксис

ПРОИЗВЕД(число1,число2,...)

Число1, число2, ... является набором 1 — 30 чисел, произведение которых требуется вычислить.

Примечания

  • Считаются все аргументы, являющиеся числами, логическими значениями или текстовыми представлениями чисел; аргументы, представляющие собой значения ошибок или текст вызывают ошибки.
  • Если аргумент является ссылкой на столбец, считаются только числа. Пустые аргументы, логические значения, текст и значения ошибок игнорируются.

Пример

Столбец1 | Столбец2 | Столбец3 | Формула | Описание (Результат)
5 | 15 | 30 | =ПРОИЗВЕД([Столбец1], [Столбец2], [Столбец3]) | Результат умножения чисел: 2250
5 | 15 | 30 | =ПРОИЗВЕД([Столбец1], [Столбец2], [Столбец3],2) | Результат умножения чисел и числа 2: 4500


РАДИАНЫ

Преобразует градусы в радианы.

Синтаксис

РАДИАНЫ(угол)

Угол представляет собой угол в градусах, которых нужно преобразовать.

Пример

Формула | Описание (Результат)
=РАДИАНЫ(270) | 270 градусов равно 4.712389 или 3?/2 радиан


Функция РИМСКОЕ

Преобразует арабские числа в римские, в текстовом формате.

Синтаксис

РИМСКОЕ(число;форма)

Число — число в арабской записи, которое требуется преобразовать.

Форма — число, указывающее желаемый тип числа в римской записи. Форма записи римских чисел варьируется от классической до упрощенной и становится все более наглядной с увеличением значения аргумента форма. См. ниже пример для ROMAN(499,0).

Форма | Тип
0 или опущен | Классический.
1 | Более наглядный. См. пример ниже.
2 | Более наглядный. См. пример ниже.
3 | Более наглядный. См. пример ниже.
4 | Упрощенный.
ИСТИНА | Классический.
ЛОЖЬ | Упрощенный.

Примечания

  • Если число отрицательно, возвращается значение ошибки #ЗНАЧ!.
  • Если число больше 3999, возвращается значение ошибки #ЗНАЧ!.

Пример

Формула | Описание (Результат)
=РИМСКОЕ(499;0) | Классический римский стиль для числа 499 (CDXCIX)
=РИМСКОЕ(499;1) | Более наглядное представление числа 499 (LDVLIV)
=РИМСКОЕ(499;2) | Более наглядное представление числа 499 (XDIX)
=РИМСКОЕ(499;3) | Более наглядное представление числа 499 (VDIV)
=РИМСКОЕ(499;4) | Более наглядное представление числа 499 (ID)
=РИМСКОЕ(2013;0) | Классический римский стиль для числа 2013 (MMXIII)


Функция ОКРУГЛ

Некоторые сведения в этом разделе могут быть неприменимы к отдельным языкам.

Округляет число до указанного количества десятичных разрядов.

Синтаксис

ОКРУГЛ(число;число_разрядов)

Число — округляемое число.

Число_разрядов — количество десятичных разрядов, до которого нужно округлить число.

Примечания

  • Если число_разрядов больше 0, то число округляется до указанного количества десятичных разрядов справа от десятичной запятой.
  • Если число_разрядов равно 0, то число округляется до ближайшего целого.
  • Если число_разрядов меньше 0, то число округляется слева от десятичной запятой.

Пример

Формула | Описание (Результат)
=ОКРУГЛ(2,15; 1) | Округляет 2,15 до одного десятичного разряда (2,2)
=ОКРУГЛ(2,149; 1) | Округляет 2,149 до одного десятичного разряда (2,1)
=ОКРУГЛ(-1,475; 2) | Округляет -1,475 до двух десятичных разрядов (-1,48)
=ОКРУГЛ(21,5; -1) | Округляет 21,5 до одного десятичного разряда слева от десятичной запятой (20)


Функция ОКРУГЛВНИЗ

Округляет число до ближайшего меньшего по модулю целого.

Синтаксис

ОКРУГЛВНИЗ(число;число_разрядов)

Число — любое вещественное число, которое нужно округлить в меньшую сторону.

Число_разрядов — количество десятичных разрядов, до которого нужно округлить число.

Примечания

  • Функция ОКРУГЛВНИЗ подобна функции ОКРУГЛ, за тем исключением, что число всегда округляется в меньшую сторону.
  • Если количество_цифр больше 0 (нуля), то число округляется в меньшую сторону до заданного количество десятичных разрядов после запятой.
  • Если число_разрядов равно 0, то число округляется в меньшую сторону до ближайшего целого.
  • Если количество_цифр меньше 0, то число округляется в меньшую сторону до заданного количеств десятичных разрядов слева от запятой.

Пример

Формула | Описание (Результат)
=ОКРУГЛВНИЗ(3,2; 0) | Округляет 3,2 в меньшую сторону до целого (3)
=ОКРУГЛВНИЗ(76,9;0) | Округляет 76,9 в меньшую сторону до целого (76)
=ОКРУГЛВНИЗ(3,14159; 3) | Округляет 3,14159 в меньшую сторону до трех десятичных разрядов (3,141)
=ОКРУГЛВНИЗ(-3,14159; 1) | Округляет -3,14159 в меньшую сторону до одного десятичного разряда (-3,1)
=ОКРУГЛВНИЗ(31415,92654; -2) | Округляет 31415,92654 в меньшую сторону до двух десятичных разрядов слева от десятичной запятой (31400)


Функция ОКРУГЛВВЕРХ

Округляет число по модулю до ближайшего большего по модулю целого.

Синтаксис

ОКРУГЛВВЕРХ(число;число_разрядов)

Число — любое вещественное число, которое нужно округлить в большую сторону.

Число_разрядов — количество десятичных разрядов, до которого нужно округлить число.

Примечания

  • Функция ОКРУГЛВВЕРХ подобна функции ОКРУГЛ, за тем исключением, что число всегда округляется в большую сторону.

  • Если число_разрядов больше 0, то число округляется в большую сторону до указанного количества десятичных разрядов справа от десятичной запятой.

  • Если число_разрядов равно 0, то число округляется в большую сторону до ближайшего целого.

  • Если число_разрядов меньше 0, то число округляется в большую сторону слева от десятичной запятой.

Пример

Формула | Описание (Результат)
=ОКРУГЛВВЕРХ(3,2;0) | Округляет 3,2 в большую сторону до целого (4)
=ОКРУГЛВВЕРХ(76,9;0) | Округляет 76,9 в большую сторону до целого (77)
=ОКРУГЛВВЕРХ(3,14159;0,3) | Округляет 3,14159 в большую сторону до трех десятичных разрядов (3,142)
=ОКРУГЛВВЕРХ(-3,14159;0,1) | Округляет -3,14159 в большую сторону до одного десятичного разряда (-3,2)
=ОКРУГЛВВЕРХ(31415,92654;-2) | Округляет 31415,92654 в большую сторону до двух десятичных разрядов слева от десятичной запятой (31500)


ЗНАК

Определяет знак числа. Возвращает 1, если число положительное, ноль (0), если число равно 0, и -1, если задано отрицательное число.

Синтаксис

ЗНАК(число)

Число представляет собой любое вещественное число

Пример

Формула | Описание (Результат)
=ЗНАК(10) | Знак положительного числа: 1
=ЗНАК(4-4) | Знак нуля: 0
=ЗНАК(-0.00001) | Знак отрицательного числа: -1


SIN

Возвращает синус заданного угла.

Синтаксис

SIN(число)

Число представляет собой угол в радианах, для которого вычисляется синус.

Примечания

Если аргумент дан в градусах, умножьте его на PI/180 или воспользуйтесь функцией РАДИАНЫ для преобразования градусов в радианы.

Пример

Формула | Описание (Результат)
=SIN(PI) | Синус числа pi примерно равен 0
=SIN(PI/2) | Синус pi/2 радиан равен 1
=SIN(30*PI/180) | Синус 30 градусов равен 0.5
=SIN(РАДИАНЫ(30)) | Синус 30 градусов равен 0.5


Функция SINH

Возвращает гиперболический синус числа.

Синтаксис

SINH (число)

Число — любое вещественное число.

Примечания

Формула для гиперболического синуса числа:

Пример 1

Формула | Описание (Результат)
=SINH(1) | Гиперболический синус числа 1 (1,175201194)
=SINH(-1) | Гиперболический синус числа -1 (-1,175201194)

Пример 2

Гиперболический синус можно использовать для аппроксимации интегрального распределения вероятности. Предположим, что значение времени лабораторных измерений меняется в интервале от 0 до 10 секунд. Эмпирический анализ собранных экспериментальных данных показывает, что вероятность получения результата x, не превосходящего t секунд, аппроксимируется следующим уравнением:

P(x<t) = 2,868 * SINH(0,0342 * t), где 0<t<10

Для вычисления вероятности получения результата, меньшего чем 1,03 сек., вместо t следует подставить 1,03.

Формула | Описание (Результат)
=2,868*SINH(0,0342*1,03) | Вероятность получения результата, меньшего чем 1,03 сек.(0,101049063)

Получение такого результата будет ожидаться в 101 случае из каждых 1000 проделанных экспериментов.


КОРЕНЬ

Возвращает положительное значение квадратного корня.

Синтаксис

КОРЕНЬ(число)

Число представляет собой число, квадратный корень которого необходимо найти.

Примечания

Если число отрицательное, функция SQRT возвращает значение ошибки #ЧИСЛО!.

Пример

Формула | Описание (Результат)
=КОРЕНЬ(16) | Квадратный корень числа 16 равен 4
=КОРЕНЬ(-16) | Т.к. число отрицательное, возвращается значение ошибки #ЧИСЛО!
=КОРЕНЬ(ABS(-16)) | Квадратный корень абсолютной величины числа равен 4


Функция СУММ

Суммирует числа в указанных аргументах.

Синтаксис

СУММ(число1;число2; ...)

Число1, число2, ... — от 1 до 30 аргументов, для которых требуется определить итог или сумму.

Примечания

  • Учитываются числа, логические значения и текстовые представления чисел, которые непосредственно введены в список аргументов. См. ниже первый и второй примеры.
  • Аргументы, которые являются значениями ошибки или текстом, не преобразуемым в числа, вызывают ошибки.

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Формула | Описание (Результат)
-5 | 15 | 30 |  | ИСТИНА | =СУММ(3; 2) | Складывает 3 и 2 (5)
-5 | 15 | 30 |  | ИСТИНА | =СУММ("5"; 15; ИСТИНА) | Складывает 5, 15 и 1; в числа преобразуются текстовые значения, а логическое значение ИСТИНА представляется как 1 (21)
-5 | 15 | 30 |  | ИСТИНА | =СУММ([Столбец1];[Столбец2];[Столбец3]) | Суммирует первые три числа в столбцах (40)
-5 | 15 | 30 |  | ИСТИНА | =СУММ([Столбец1];[Столбец2];[Столбец3];15) | Суммирует первые три числа в столбцах и число 15 (55)
-5 | 15 | 30 |  | ИСТИНА | =СУММ([Столбец4]; [Столбец5];2) | Суммирует значения в двух последних столбцах и число 2 (2)


Функция СУММКВ

Возвращает сумму квадратов аргументов.

Синтаксис

СУММКВ(число1;число2; ...)

Число1, число2, ... — от 1 до 30 аргументов, квадраты которых суммируются.

Пример

Формула | Описание (Результат)
=СУММКВ(3; 4) | Сумма квадратов чисел 3 и 4 (25)


Функция TAN

Возвращает тангенс заданного угла.

Синтаксис

TAN(число)

Число — угол в радианах, для которого определяется тангенс.

Примечания

Если аргумент задан в градусах, умножьте его на ПИ()/180 или воспользуйтесь функцией РАДИАНЫ для преобразования градусов в радианы.

Пример

Формула | Описание (Результат)
=TAN(0,785) | Тангенс 0,785 радиан (0,99920)
=TAN(45*ПИ()/180) | Тангенс 45 градусов (1)
=TAN(РАДИАНЫ(45)) | Тангенс 45 градусов (1)


Функция TANH

Возвращает гиперболический тангенс числа.

Синтаксис

TANH(число)

Число — любое вещественное число.

Примечания

Формула гиперболического тангенса имеет следующий вид:

Пример

Формула | Описание (Результат)
=TANH(-2) | Гиперболический тангенс числа -2 (-0,96403)
=TANH(0) | Гиперболический тангенс числа 0 (0)
=TANH(0,5) | Гиперболический тангенс числа 0,5 (0,462117)


Функция ОТБР

Усекает число до целого, отбрасывая его дробную часть.

Синтаксис

ОТБР(число;число_разрядов)

Число — усекаемое число.

Число_разрядов — число, определяющее точность усечения. Значение по умолчанию аргумента число_разрядов - 0 (ноль).

Примечания

Функции ОТБР и ЦЕЛОЕ возвращают целые части числа, однако ОТБР отбрасывает дробную часть числа, а ЦЕЛОЕ округляет число в меньшую сторону до ближайшего целого с учетом значения дробной части. Эти функции различаются только при использовании отрицательных чисел: TRUNC(-4.3) возвращает -4, а INT(-4.3) возвращает -5, поскольку -5 является ближайшим снизу числом.

Пример

Формула | Описание (Результат)
=ОТБР(8,9) | Целая часть от числа 8,9 (8)
=ОТБР(-8,9) | Целая часть от числа -8,9 (-8)
=ОТБР(ПИ()) | Целая часть от числа pi (3)


СРОТКЛ

Возвращает среднее значение абсолютных отклонений элементов от среднего значения. Функция СРОТКЛ позволяет оценить разброс элементов набора данных.

Синтаксис

СРОТКЛ(число1;число2; ...)

Набор число1, число2, ... включает в себя от 1 до 30 аргументов, для которых требуется вычислить среднее значение абсолютного отклонения.

Примечания

  • Аргумент должен представлять собой число или ссылку на столбец, содержащий набор чисел.
  • Если столбец, на который делается ссылка в аргументе, содержит текст, логические значения или пуст, эти значения игнорируются или возвращается значение ошибки #ЗНАЧ!; при этом, однако, значение становится равным нулю.
  • Уравнение среднего отклонения следующее:

Фунукция СРОТКЛ зависит от единиц измерения вводимых данных.

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Столбец6 | Столбец7 | Формула | Описание (Результат)
4 | 5 | 6 | 7 | 5 | 4 | 3 | =СРОТКЛ([Столбец1];[Столбец2];[Столбец3];[Столбец4];[Столбец5];[Столбец6];[Столбец7]) | Среднее значение абсолютного отклонения чисел от среднего равно 1.020408


СРЗНАЧ

Возвращает среднее значение (среднее арифметическое) аргументов.

Синтаксис

СРЗНАЧ(число1;число2; ...)

Набор число1, число2, ... включает в себя от 1 до 30 аргументов, для которых требуется вычислить среднее значение.

Примечания

  • Аргумент должен представлять собой число или ссылку на объект, содержащий набор чисел.
  • Если в качестве аргумента используется ссылка на массив или столбец, содержащий текст, логические значения или пустой, эти значения игнорируются или возвращается значение ошибки #ЗНАЧ!; при этом, однако, значение становится равным нулю.

Пример

№1 | №2 | №3 | №4 | №5 | Формула | Описание (Результат)
10 | 7 | 9 | 27 | 2 | =СРЗНАЧ([Столбец1]; [Столбец2]; [Столбец3]; [Столбец4]; [Столбец5]) | Среднее значение чисел, содержащихся в столбцах, равно 11
10 | 7 | 9 | 27 | 2 | =AVERAGE([Столбец1], [Столбец2], [Столбец3], [Столбец4], [Столбец5], 5) | Среднее значение чисел, содержащихся в столбцах, и числа 5 равно 10


Функция СРЗНАЧА

Вычисляет среднее арифметическое значений из списка аргументов. В отличие от функции СРЗНАЧА, в качестве аргументов могут выступать текстовые и логические значения (например, ИСТИНА и ЛОЖЬ).

Синтаксис

СРЗНАЧА(значение1;значение2; ...)

Значение1, значение2, ... — от 1 до 30 аргументов, для которых нужно вычислить среднее арифметическое.

Примечания

  • Аргументы, содержащие текст либо являющиеся пустым текстом (""), выражаются как 0 (ноль). Если выражение не должно содержать текстовых значений, воспользуйтесь функцией СРЗНАЧА.
  • Аргументы, содержащие значение ИСТИНА, выражаются как 1; ЛОЖЬ — как 0 (ноль).

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Столбец6 | Формула | Описание (Результат)
10 | 7 | 9 | 2 | 0 |  | =СРЗНАЧА([Столбец1]; [Столбец2]; [Столбец3]; [Столбец4]; [Столбец5]) | Среднее арифметическое чисел (5,6)
10 | 10 | 9 | 2 | 1 |  | =СРЗНАЧА([Столбец1]; [Столбец2]; [Столбец3]; [Столбец4]; [Столбец6]) | Среднее арифметическое чисел, пустой аргумент (7,75)


Функция БЕТАРАСП

Возвращает функцию интегрального бета-распределения вероятности. Эта функция обычно используется для изучения вариации в процентах какой-либо величины, например доли дня, которую люди проводят у телевизора.

Синтаксис

БЕТАРАСП(x;альфа;бета;A;B)

X — значение между A и B, для которого вычисляется функция.

Альфа — параметр распределения.

Бета — параметр распределения.

A — нижняя граница интервала, к которому принадлежит x. Необязательное значение.

B — верхняя граница интервала, к которому принадлежит x. Необязательное значение.

Примечания

  • Если любой из аргументов не является числом, БЕТАРАСП возвращает значение ошибки #ЗНАЧ!.
  • Если альфа ? 0 или бета ? 0, БЕТАРАСП возвращает значение ошибки #ЧИСЛО!.
  • Если x < A, x > B или A = B, БЕТАРАСП возвращает значение ошибки #ЧИСЛО!.
  • Если A и B будут опущены, БЕТАРАСП возвращает стандартное интегральное бета-распределение (A = 0 и B = 1).

Пример

X | Альфа | Бета | A | B | Формула | Описание (Результат)
2 | 8 | 10 | 1 | 3 | =БЕТАРАСП([X];[Альфа];[Бета];[A];[B]) | Интегральная функция плотности бета-вероятности для заданных параметров (0,685470581)


Функция БЕТАОБР

Возвращает обратную функцию к интегрального функции бета-распределения вероятности. Если вероятность = БЕТАРАСП(x;...), то БЕТАОБР(вероятность;...) = x. Интегральное бета-распределение можно использовать при планировании проекта для прогнозирования времени его завершения на основе ожидаемого времени и возможных изменений в течение работы.

Синтаксис

БЕТАОБР(вероятность;альфа;бета;A;B)

Вероятность — вероятность, связанная с бета-распределением.

Альфа — параметр распределения.

Бета — параметр распределения.

A — нижняя граница интервала, к которому принадлежит x. Необязательное значение.

B верхняя граница интервала, к которому принадлежит x. Необязательное значение.

Примечания

  • Если любой из аргументов не является числом, БЕТАОБР возвращает значение ошибки #ЗНАЧ!.
  • Если альфа ? 0 или бета ? 0, БЕТАОБР возвращает значение ошибки #ЧИСЛО!.
  • Если вероятность ? 0 или вероятность > 1, БЕТАОБР возвращает значение ошибка #ЧИСЛО!.
  • Если A и B будут опущены, БЕТАОБР возвращает обычное интегральное бета-распределение (A = 0 и B = 1).

БЕТАОБР использует метод итераций для вычисления значения. Если задано значение вероятности, то функция БЕТАОБР производит итерации, пока не получит результат с точностью ±3x10-7. Если БЕТАОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

Вероятность | Альфа | Бета | A | B | Формула | Описание (Результат)
0,685470581 | 8 | 10 | 1 | 3 | =БЕТАОБР([Вероятность];[Альфа];[Бета];[A];[B]) | Обратная функция к интегральной функции плотности бета-вероятности для заданных параметров (2)


БИНОМРАСП

Возвращает отдельное значение биномиального распределения. Функция БИНОМРАСП используется в задачах с фиксированным числом тестов или испытаний, когда результатом любого испытания может быть только успех или неудача, испытания независимы, и вероятность успеха постоянна на протяжении всего эксперимента. Например, БИНОМРАСП может вычислить вероятность того, что двое из трех следующих новорожденных будут мальчиками.

Синтаксис

БИНОМРАСП(число_успехов;число_испытаний;вероятность_успеха;интегральная)

Число_успехов — количество успешных испытаний.

Число_испытаний — число независимых испытаний.

Вероятность_успеха — вероятность успеха каждого испытания.

Интегральная — логическое значение, определяющее форму функции. Если аргумент «интегральная» имеет значение ИСТИНА, то функция БИНОМРАСП возвращает интегральную функцию распределения, то есть вероятность того, что число успешных испытаний не менее значения аргумента число_успехов; если этот аргумент имеет значение ЛОЖЬ, то возвращается функция распределения, то есть вероятность того, что число успешных испытаний в точности равно значению аргумента число_успехов.

Примечания

  • Число_успехов и число_испытаний усекаются до целых.
  • Если число_успехов, число_испытаний или вероятность_успеха не является числом, то функция БИНОМРАСП возвращает значение ошибки #ЗНАЧ!.
  • Если число_успехов < 0 или число_успехов > число_испытаний, то функция БИНОМРАСП возвращает значение ошибки #ЧИСЛО!.
  • Если вероятность_успеха < 0 или вероятность_успеха > 1, БИНОМРАСП возвращает значение ошибки #ЧИСЛО!.
  • Биномиальная функция распределения имеет следующий вид:

    где:

    — ЧИСЛКОМБ(n;x).

    Примечание. Функция ЧИСЛКОМБ используется в этом примере, чтобы проиллюстрировать математическую формулу, используемую в функции БИНОМРАСП. Эту функцию нельзя использовать в списке.

    Интегральное биномиальное распределение имеет следующий вид:

Пример

число_успехов | число_испытаний | вероятность_успеха | Формула | Описание (Результат)
6 | 10 | 0,5 | =БИНОМРАСП([число_успехов];[число_испытаний];[вероятность_успеха];ЛОЖЬ) | Вероятность того, что успешными будет ровно 6 испытаний из 10 (0,205078)


Функция ХИ2РАСП

Возвращает одностороннюю вероятность распределения хи-квадрат. Распределение ?2 связано с критерием ?2. Критерий ?2 используется для сравнения предполагаемых и наблюдаемых значений. Например, в генетическом эксперименте выдвигается гипотеза, что следующее поколение растений будет обладать определенной окраской. Сравнивая наблюдаемые результаты с предполагаемыми, можно определить, была ли исходная гипотеза обоснованной.

Синтаксис

ХИ2РАСП(x;степени_свободы)

X — значение, для которого строится распределение.

Степени_свободы — число степеней свободы.

Примечания

  • Если аргумент не является числом, ХИ2РАСП возвращает значение ошибки #ЗНАЧ!.
  • Если x < 0, CHIDIST возвращает значение ошибки #ЧИСЛО!.
  • Если степени_свободы не является целым числом, берется его целая часть.
  • Если степени_свободы < 1 или степени_свободы ? 10^10, ХИ2РАСП возвращает значение ошибки #ЧИСЛО!.
  • ХИ2РАСП вычисляется как ХИ2РАСП = P(X>x), где X — произвольная переменная хи-квадрат.

Пример

X | Степени свободы | Формула | Описание (Результат)
18,307 | 10 | =ХИ2РАСП([X];[Степени свободы]) | Односторонняя вероятность распределения хи-квадрат для заданных аргументов (0,050001)


Функция ХИ2ОБР

Возвращает обратную величину к величине односторонней вероятности распределения хи-квадрат. Если вероятность = ХИ2РАСП(x;...), то ХИ2ОБР(вероятность;...) = x. Эта функция может использоваться для сравнения наблюдаемых и ожидаемых величин, чтобы проверить правильность исходной гипотезы.

Синтаксис

ХИ2ОБР(вероятность;степени_свободы)

Вероятность — вероятность, связанная распределением хи-квадрат.

Степени_свободы — число степеней свободы.

Примечания

  • Если аргумент не является числом, ХИ2ОБР возвращает значение ошибки #ЗНАЧ!.
  • Если вероятность < 0 или вероятность > 1, ХИ2ОБР возвращает значение ошибки #ЧИСЛО!.
  • Если степени_свободы не является целым числом, берется его целая часть.
  • Если степени_свободы < 1 или степени_свободы ? 10^10, ХИ2ОБР возвращает значение ошибки #ЧИСЛО!.

ХИ2ОБР использует метод итераций для вычисления значения. Если задано значение вероятности, то функция ХИ2ОБР производит итерации, пока не получит результат с точностью ± 3x10^-7. Если ХИ2ОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

Вероятность | Степени свободы | Формула | Описание (Результат)
0,05 | 10 | =ХИ2ОБР([Вероятность];[Степени свободы]) | Обратная величина к величине односторонней вероятности распределения хи-квадрат (18,30703)


ДОВЕРИТ

Возвращает доверительный интервал для среднего генеральной совокупности с нормальным распределением. Доверительный интервал — это интервал с обеих сторон от среднего выборки. Например, если вы заказали товар по почте, то вы можете определить с определенным уровнем достоверности самую раннюю и самую позднюю даты прибытия товара.

Синтаксис

ДОВЕРИТ(альфа;станд_откл;размер)

Альфа — это уровень значимости, используемый для вычисления уровня надежности. Уровень надежности равняется 100*(1 - альфа) процентам, или, другими словами, значение альфа, равное 0,05, означает 95-процентный уровень надежности.

Станд_откл — это стандартное отклонение генеральной совокупности для интервала данных, которое предполагается известным.

Размер — размер выборки.

Примечания

  • Если какой-либо из аргументов не является числом, то функция ДОВЕРИТ возвращает значение ошибки #ЗНАЧ!.
  • Если альфа ? 0 или альфа ? 1, то функция ДОВЕРИТ возвращает значение ошибки #ЧИСЛО!.
  • Если станд_откл ? 0, то функция ДОВЕРИТ возвращает значение ошибки #ЧИСЛО!.
  • Если размер не является целым числом, то он усекается.
  • Если размер < 1, то функция ДОВЕРИТ возвращает значение ошибки #ЧИСЛО!.
  • Если предположить, что альфа равняется 0,05, то нужно определить ту часть стандартной нормальной кривой, которая равняется (1 - альфа), или 95 процентам. Это значение равно ± 1,96. Доверительный интервал, следовательно, определяется следующим образом:

Пример

Предположим, что в нашем примере с 50 пассажирами, пользующимися сезонными билетами, средняя продолжительность поездки на работу составляет 30 минут со стандартным отклонением для генеральной совокупности равным 2,5. В таком случае, мы можем быть на 95 процентов уверены в том, что среднее для генеральной совокупности находится в интервале:

Альфа | Стандартное отклонение | Размер | Формула | Описание (Результат)
0,05 | 0,5 | 50 | =ДОВЕРИТ([Альфа];[Стандартное отклонение];[Размер]) | Доверительный интервал для математического ожидания генеральной совокупности. Другими словами, доверительный интервал средней продолжительности поездки на работу для генеральной совокупности составляет 30 ± 0,692951 минут или от 29,3 до 30,7 минут. (0,692951)


Функция СЧЁТ

Вычисляет число аргументов, содержащих числа.

Синтаксис

СЧЁТ(значение1;значение2; ...)

Значение1, значение2, ... — от 1 до 30 аргументов, которые могут содержать или ссылаться на данные различных типов, но в подсчете участвуют только числа.

Примечания

  • В подсчете участвуют аргументы, являющиеся числами, датами или числами, записанными в виде текста; игнорируются значения ошибок и текст, который невозможно перевести в числа.
  • Для подсчета логических значений, элементов текста или значений ошибок служит функция СЧЁТЗ.

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Столбец6 | Столбец7 | Формула | Описание (Результат)
Сбыт | 12/8/2008 |  | 19 | 22,24 | ИСТИНА | #ДЕЛ/0! | =СЧЁТ([Столбец1];[Столбец2];[Столбец3];[Столбец4];[Столбец5];[Столбец6];[Столбец7]) | Вычисляет число аргументов списка, содержащих числа (3)
 |  |  | 19 | 22,24 | ИСТИНА | #ДЕЛ/0! | =СЧЁТ([Столбец4];[Столбец5];[Столбец6];[Столбец7]) | Вычисляет число аргументов в последних 4 строках списка, содержащих числа (2)
Сбыт | 2/8/2008 |  | 19 | 22,24 | ИСТИНА | #ДЕЛ/0! | =СЧЁТ([Столбец1];[Столбец2];[Столбец3];[Столбец4];[Столбец5];[Столбец6];[Столбец7];2) | Вычисляет число аргументов списка, содержащих числа, а также значение 2 (2)


СЧЕТЗ

Считает число аргументов, не являющихся пустыми.

Синтаксис

СЧЕТЗ(значение1,значение2, ...)

Значение1, значение2, ... представляет собой набор, содержащий от 1 до 30 аргументов, состоящий из значений, которые необходимо сосчитать. В этом случае значением является любой тип информации, включая отсутствие текста (""), но не пустые аргументы. Если необходимо сосчитать логические значения, элементы текста, значения ошибок, используется функция COUNT.

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Столбец6 | Столбец7 | Формула | Описание (Результат)
Сбыт | 12/8/2008 |  | 19 | 22.24 | ИСТИНА | #ДЕЛ/0! | =СЧЕТЗ([Столбец1],[Столбец2],[Столбец3],[Столбец4],[Столбец5],[Столбец6],[Столбец7]) | Число аргументов в списке, не являющихся пустыми, равно 6
Сбыт | 12/8/2008 |  | 19 | 22.24 | ИСТИНА | #ДЕЛ/0! | =СЧЁТЗ([Столбец4];[Столбец5];[Столбец6];[Столбец7]) | Считает число аргументов, не являющихся пустыми, в последних4 строках списка, и оно равно 4
Сбыт | 12/8/2008 |  | 19 | 22.24 | ИСТИНА | #ДЕЛ/0! | =СЧЁТЗ([Столбец1];[Столбец2];[Столбец3];[Столбец4];[Столбец5];[Столбец6];[Столбец7];2) | Считает число аргументов, не являющихся пустыми, в списке и числе 2; оно равно 7
Сбыт | 12/8/2008 |  | 19 | 22.24 | ИСТИНА | #ДЕЛ/0! | =СЧЕТЗ([Столбец1],[Столбец2],[Столбец3],[Столбец4],[Столбец5],[Столбец6],[Столбец7], «Два») | Считает число аргументов, не являющихся пустыми, в списке и значении «Два»; оно равно 7


Функция КРИТБИНОМ

Возвращает наименьшее значение, для которого интегральное биномиальное распределение больше или равно заданному критерию. Эта функция используется в приложениях, связанных с контролем качества. Например, функция КРИТБИНОМ используется для определения наибольшего допустимого числа дефектных изделий, которые можно удалять со сборочной линии без отбраковки всей партии.

Синтаксис

КРИТБИНОМ(число_испытаний;вероятность_успеха;альфа)

Число_испытаний — число испытаний Бернулли.

Вероятность_успеха — вероятность успеха при каждом испытании.

Альфа — значение критерия.

Примечания

  • Если любой из аргументов не является числом, КРИТБИНОМ возвращает значение ошибки #ЗНАЧ!.
  • Если число_испытаний не является целым числом, берется его целая часть.
  • Если число_испытаний < 0, функция КРИТБИНОМ возвращает значение ошибки #ЧИСЛО!.
  • Если вероятность_успеха < 0 или вероятность_успеха > 1, КРИТБИНОМ возвращает значение ошибки #ЧИСЛО!.
  • Если альфа < 0 или альфа > 1, КРИТБИНОМ возвращает значение ошибки #ЧИСЛО!.

Пример

Число испытаний | Вероятность успеха | Альфа | Формула | Описание (Результат)
6 | 0,5 | 0,75 | =КРИТБИНОМ([Число испытаний];[Вероятность успеха];[Альфа]) | Наименьшее значение, для которого биномиальная функция распределения больше или равна заданному значению (4)


КВАДРОТКЛ

Возвращает сумму квадратов отклонений элементов данных от выборочного среднего.

Синтаксис

КВАДРОТКЛ(число1,число2, ...)

Набор число1, число2, ... включает в себя от 1 до 30 аргументов, для которых требуется вычислить сумму квадратов отклонений.

Примечания

  • Аргумент должен представлять собой число или ссылку на столбец, содержащий набор чисел.
  • Если аргумент содержит текст, логические значения, или пуст, эти значения игнорируются; нулевое значение учитывается.
  • Уравнение суммы квадратов отклонений:

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Столбец6 | Столбец7 | Формула | Описание (Результат)
4 | 5 | 8 | 7 | 11 | 4 | 3 | =КВАДРОТКЛ([Столбец1],[Столбец2],[Столбец3],[Столбец4],[Столбец5],[Столбец6],[Столбец7]) | Сумма квадратов отклонений от выборочного среднего равна 48


Функция ЭКСПРАСП

Возвращает экспоненциальное распределение. Функция ЭКСПРАСП используется для моделирования временных задержек между событиями, например, сколько времени займет денежный перевод в автоматизированном банке. Например, можно использовать функцию ЭКСПРАСП, чтобы определить вероятность того, что этот процесс займет не более 1 минуты.

Синтаксис

ЭКСПРАСП(x;лямбда;интегральная)

X — аргумент функции.

Лямбда — значение параметра.

Интегральная — логическое значение, определяющее возвращаемую функцию: интегральную функцию распределения, если ИСТИНА; функцию плотности распределения вероятности, если ЛОЖЬ.

Примечания

  • Если х или лямбда не являются числами, ЭКСПРАСП возвращает значение ошибки #ЗНАЧ!.
  • Если х < 0, функция ЭКСПРАСП возвращает значение ошибки #ЧИСЛО!.
  • Если x ? 0, функция ЭКСПРАСП возвращает значение ошибки #ЧИСЛО!.
  • Уравнение функции плотности распределения вероятности имеет следующий вид:

  • Уравнение интегральной функции распределения имеет следующий вид:

Пример 1

Формула | Описание (Результат)
=ЭКСПРАСП(0,2;10;ЛОЖЬ) | Экспоненциальная функция распределения вероятности (1,353353)

Пример 2

X | Лямбда | Формула | Описание (Результат)
0,2 | 10 | =ЭКСПРАСП([X];[Лямбда];ИСТИНА) | Интегральная экспоненциальная функция распределения (0,864665)


Функция FРАСП

Возвращает F-распределение вероятности. Эту функцию можно использовать для определения степени отклонения для двух наборов данных. Например, можно сравнить тестовые задания мальчика и девочки, поступающих в среднюю школу, и найти отличия среди них.

Синтаксис

FРАСП(x;степени_свободы1;степени_свободы2)

X — значение, для которого вычисляется функция.

Степени_свободы1 — числитель степеней свободы.

Степени_свободы2 — знаменатель степеней свободы.

Примечания

  • Если любой из аргументов не является числом, FРАСП возвращает значение ошибки #ЗНАЧ!.
  • Если x < 0, FРАСП возвращает значение ошибки #ЧИСЛО!.
  • Если степени_свободы1 и степени_свободы2 не являются целыми числами, берется целая часть числа.
  • Если степени_свободы1 < 1 или степени_свободы1 ? 10^10, FDIST возвращает значение ошибки #ЧИСЛО!.
  • Если степени_свободы2 < 1 или степени_свободы2 ? 10^10, FDIST возвращает значение ошибки #ЧИСЛО!.
  • FРАСП вычисляется как FРАСП=P( F<x ), где F — это произвольная переменная F-распределения.

Пример

X | Степень1 | Степень2 | Формула | Описание (Результат)
15,20675 | 6 | 4 | =FРАСП([X];[Степень1];[Степень2]) | F-распределение вероятности для заданных аргументов (0,01)


FРАСПОБР

Возвращает обратное значение для F-распределения вероятностей (F-распределения Фишера). Если p = FРАСП(x;...), то FРАСПОБР(p;...) = x.

F-распределение может быть использовано в F-тесте, который сравнивает степени разброса двух множеств данных. Например, можно проанализировать распределение доходов США и Канады, чтобы определить, имеют ли две страны подобные степени плотности.

Синтаксис

FРАСПОБ(вероятность;степени_свободы1;степени_свободы2)

Вероятность — это вероятность, связанная с F-распределением.

Степени_свободы1 — числитель степеней свободы.

Степени_свободы2 — знаменатель степеней свободы.

Примечания

  • Если какой-либо из аргументов не является числом, то функция FРАСПОБР возвращает значение ошибки #ЗНАЧ!..
  • Если вероятность < 0 или вероятность > 1, FРАСПОБР возвращает значение ошибки #ЧИСЛО!.
  • Если степени_свободы1 и степени_свободы2 не являются целыми числами, берется целая часть числа.
  • Если степени_свободы1 < 1 или степени_свободы1 ? 10^10, FРАСПОБР возвращает значение ошибки #ЧИСЛО!.
  • Если степени_свободы2 < 1 или степени_свободы2 ? 10^10, FРАСПОБР возвращает значение ошибки #ЧИСЛО!.

FРАСПОБР можно использовать, чтобы определить критические значения F-распределения. Например, результаты дисперсионного анализа обычно включают данные для F-статистики, F-вероятности и F-критическое значение с уровнем значимости 0,05. Чтобы определить критическое значение F, нужно использовать уровень значимости s как аргумент вероятность для FРАСПОБР.

FРАСПОБР использует метод итераций для вычисления значения. Если задано значение вероятности, то функция FРАСПОБР производит итерации, пока не получит результат с точностью ± 3x10^-7. Если FРАСПОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

Вероятность | Степень1 | Степень2 | Формула | Описание (Результат)
0,01 | 6 | 4 | =FРАСПОБ(Вероятность];[Степень1];[Степень2]) | Обратное значение для F-распределения вероятностей для приведенных данных (15,20675)


ФИШЕР

Применяет преобразование Фишера к переменной x. При преобразовании получается функция, которая в большей степени относительно нормально распределена, чем несиметрична. Эта функция используется для проверки коэффициента корреляции.

Синтаксис

ФИШЕР(x)

X представляет собой численное значение, которое нужно преобразовать.

Примечания

  • Если переменная x несимметрична, функция ФИШЕР возвращает значение ошибки #ЗНАЧ!.
  • Если x ? -1 или x ? 1, функция ФИШЕР возвращает значение ошибки #ЧИСЛО!.

  • Уравнение преобразования Фишера:

Пример

Формула | Описание (Результат)
=ФИШЕР(0.75) | Преобразование Фишера, примененное к числу 0.75, дает значение 0.972955


ФИШЕРОБР

Применяет обратное преобразование Фишера. Эта функция применяется при анализе корреляции между рядами и массивами данных. Если y = ФИШЕР(x), тогда ФИШЕРОБР(y) = x.

Синтаксис

ФИШЕРОБР(y)

Y представляет собой значение, к которому требуется применить обратное преобразование.

Примечания

  • Если y несимметричен, функция ФИШЕРОБР возвращает значение ошибки #ЗНАЧ!.

  • Уравнение обратного преобразования Фишера:

Пример

Формула | Описание (Результат)
=ФИШЕРОБР(0.972955) | Применение обратного преобразования Фишера к числу 0.972955 дает значение 0.75


Функция ГАММАРАСП

Возвращает гамма-распределение. Эта функция служит для анализа несимметричного распределения переменных, а гамма-распределение используется при анализе систем массового обслуживания.

Синтаксис

ГАММАРАСП(x;альфа;бета;интегральная)

X — значение, для которого строится распределение.

Альфа — параметр распределения.

Бета — параметр распределения. Если бета = 1, ГАММАРАСП возвращает стандартное гамма-распределение.

Интегральная — логическое значение, определяющее возвращаемую функцию: интегральную функцию распределения, если ИСТИНА; весовую функцию распределения, если ЛОЖЬ.

Примечания

  • Если альфа или бета не являются числами, ГАММАРАСП возвращает значение ошибки #ЗНАЧ!.
  • Если х < 0, функция ГАММАРАСП возвращает значение ошибки #ЧИСЛО!.
  • Если альфа ? 0 или бета ? 0, ГАММАРАСП возвращает значение ошибки #ЧИСЛО!.
  • Уравнение гамма-распределения имеет следующий вид:

    Стандартное гамма-распределение:

  • При альфа = 1, ГАММАРАСП возвращает экспоненциальное распределение:

  • При альфа = n/2, бета = 2 и интегральная = ИСТИНА для любого целого положительного n, ГАММАРАСП возвращает (1 - ХИ2РАСП(x)) с n степенями свободы.
  • Если альфа целое положительное, то ГАММАРАСП также называется распределением Эрланга.

Пример

X | Альфа | Бета | Формула | Описание (Результат)
10 | 9 | 2 | =ГАММАРАСП([X];[Альфа];[Бета];ЛОЖЬ) | Гамма-распределение вероятности для заданных аргументов (0,032639)
10 | 9 | 2 | =ГАММАРАСП([X];[Альфа];[Бета];ИСТИНА) | Интегральное гамма-распределение для заданных аргументов (0,068094)


Функция ГАММАОБР

Возвращает обратное гамма-распределение. Если p = ГАММАРАСП(x,...), то ГАММАОБР(p,...) = x.

Эта функция может быть использована при анализе несимметричного распределения переменных.

Синтаксис

ГАММАОБР(вероятность;альфа;бета)

Вероятность — вероятность, связанная с гамма-распределением.

Альфа — параметр распределения.

Бета — параметр распределения. Если бета = 1, ГАММАОБР возвращает стандартное гамма-распределение.

Примечания

  • Если любой из аргументов не является числом, ГАММАОБР возвращает значение ошибки #ЗНАЧ!.
  • Если вероятность < 0 или вероятность > 1, ГАММАОБР возвращает значение ошибки #ЧИСЛО!.
  • Если альфа ? 0 или бета ? 0, ГАММАОБР возвращает значение ошибки #ЧИСЛО!.

ГАММАОБР использует метод итераций для вычисления функции. Если задано значение вероятности, то функция ГАММАОБР производит итерации, пока не получит результат с точностью ±3x10^-7. Если ГАММАОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

Вероятность | Альфа | Бета | Формула | Описание (Результат)
0,068094 | 9 | 2 | =ГАММАОБР([Вероятность];[Альфа];[Бета]) | Обратное гамма-распределение для заданных аргументов (10)


ГАММАНЛОГ

Возвращает натуральный логарифм гамма-функции ?(x).

Синтаксис

ГАММАНЛОГ(x)

X представляет собой значение, для которого требуется вычислить функцию ГАММАНЛОГ.

Примечания

  • Если переменная x несимметрична, функция ГАММАНЛОГ возвращает значение ошибки #ЗНАЧ!.
  • Если x ? 0, функция ГАММАНЛОГ возвращает значение ошибки #ЧИСЛО!.
  • Число е, возведенное в степень ГАММАНЛОГ(i), где i является целым числом, возвращает один и тот же результат (i - 1)!.
  • Функция ГАММАНЛОГ считается следующим образом:

    где:

Пример

Формула | Описание (Результат)
=ГАММАНЛОГ(4) | Натуральный логарифм гамма-функции числа 4 равен 1.791759


СРГЕОМ

Возвращает среднее геометрическое положительных данных. Например, функция GEOMEAN может использоваться для вычисления среднего темпа роста при данной процентной ставке.

Синтаксис

СРГЕОМ(число1,число2, ...)

Набор число1, число2, ... включает в себя от 1 до 30 аргументов, для которых требуется вычислить среднее.

Примечания

  • Аргумент должен представлять собой число или ссылку на столбец, содержащий набор чисел.
  • Если столбец содержит текст, логические значения, или пуст, эти значения игнорируются; при этом, однако, значение принимается равным нулю.
  • Если какой-либо элемент данных ? 0, функция СРГЕОМ возвращает значение ошибки #ЧИСЛО!.
  • Уравнение для вычисления среднего геометрического:

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Столбец6 | Столбец7 | Формула | Описание (Результат)
4 | 5 | 8 | 7 | 11 | 4 | 3 | =СРГЕОМ([Столбец1];[Столбец2];[Столбец3];[Столбец4];[Столбец5];[Столбец6];[Столбец7]) | Геометрическое среднее приведенных данных равно 5.476987


СРГАРМ

Возвращает среднее гармоническое набора данных. Среднее гармоническое представляет собой обратную величину арифметического среднего обратных дробей.

Синтаксис

СРГАРМ(число1,число2, ...)

Набор число1, число2, ... включает в себя от 1 до 30 аргументов, для которых требуется вычислить среднее.

Примечания

  • Аргумент должен представлять собой число или ссылку на столбец, содержащий набор чисел.
  • Если аргумент-ссылка содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; аргументы, содержащие нулевые значения, учитываются.
  • Если какой-либо элемент данных ? 0, функция СРГАРМ возвращает значение ошибки #ЧИСЛО!.
  • Среднее гармоническое всегда меньше среднего геометрического, а оно, в свою очередь, меньше среднего геометрического.
  • Уравнение среднего гармонического:

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Столбец6 | Столбец7 | Формула | Описание (Результат)
4 | 5 | 8 | 7 | 11 | 4 | 3 | =СРГАРМ([Столбец1];[Столбец2];[Столбец3];[Столбец4];[Столбец5];[Столбец6];[Столбец7]) | Среднее гармоническое данных (5,476987)


ГИПЕРГЕОМЕТ

Возвращает гипергеометрическое распределение. ГИПЕРГЕОМЕТ возвращает вероятность заданного количества успехов в выборке, если заданы размер выборки, количество успехов в генеральной совокупности и размер генеральной совокупности. Функция ГИПЕРГЕОМЕТ используется для задач с конечной генеральной совокупностью, где каждое наблюдение — это успех или неудача, а каждое подмножество заданного размера выбирается с равной вероятностью.

Синтаксис

ГИПЕРГЕОМЕТ(число_успехов_в_выборке;размер_выборки;число_успехов_в_совокупности;размер_совокупности)

Число_успехов_в_выборке — это количество успешных испытаний в выборке.

Размер_выборки — это размер выборки.

Число_успехов_в_совокупности — это количество успешных испытаний в генеральной совокупности.

Размер_совокупности — это размер генеральной совокупности.

Примечания

  • Все аргументы усекаются до целых.
  • Если любой из аргументов не является числом, ГИПЕРГЕОМЕТ возвращает значение ошибки #ЗНАЧ!.
  • Если число_успехов_в_выборке < 0 или число_успехов_в_выборке больше, чем меньшее из чисел размер_выборки и число_успехов_в_совокупности, то функция ГИПЕРГЕОМЕТ возвращает значение ошибки #ЧИСЛО!.
  • Если число_успехов_в_выборке меньше, чем большее из чисел 0 и (размер_выборки - размер_совокупности + число_успехов_в_совокупности), то функция ГИПЕРГЕОМЕТ возвращает значение ошибки #ЧИСЛО!.
  • Если размер_выборки < 0 или размер_выборки > размер_совокупности, то функция ГИПЕРГЕОМЕТ возвращает значение ошибки #ЧИСЛО!.
  • Если число_успехов_в_совокупности < 0 или число_успехов_в_совокупности > размер_совокупности, то функция ГИПЕРГЕОМЕТ возвращает значение ошибки #ЧИСЛО!.
  • Если размер_совокупности < 0, то функция ГИПЕРГЕОМЕТ возвращает значение ошибки #ЧИСЛО!.
  • Уравнение для гипергеометрического распределения имеет следующий вид:

    где:

    x = число_успехов_в_выборке

    n = размер_выборки

    M = число_успехов_в_совокупности

    N = размер_совокупности

    ГИПЕРГЕОМЕТ используется для выборок без повторений из конечной генеральной совокупности.

Пример

В коробке 20 конфет. Восемь из них с карамелью, а остальные 12 с орешками. Если некто выбирает 4 конфеты наугад, то следующая функция вернет вероятность того, что в точности одна конфета окажется с карамелью.

Число_успехов_в_выборке | Размер_выборки | Число_успехов_в_совокупности | Размер_совокупности | Формула | Описание (Результат)
1 | 4 | 8 | 20 | =ГИПЕРГЕОМЕТ([Число_успехов_в_выборке];[Размер_выборки];[Число_успехов_в_совокупности];[Размер_совокупности]) | Гипергеометрическое распределение для приведенной выборки и совокупности (0,363261)


ЭКСЦЕСС

Возвращает эксцесс набора данных. Эксцесс характеризует относительную островершинность или пологость распределения в сравнении с нормальным распределением. Положительный эксцесс указывает на относительно отсровершинное распределение. Отрицательный эксцесс указывает на относительно пологое распределение.

Синтаксис

ЭКСЦЕСС(число1,число2, ...)

Набор число1, число2, ... включает в себя от 1 до 30 аргументов, для которых требуется вычислить эксцесс.

Примечания

  • Аргумент должен представлять собой число или ссылку на столбец, содержащий набор чисел.
  • Если столбец содержит текст, логические значения, или пуст, эти значения игнорируются; при этом, однако, значение принимается равным нулю.
  • Если задано менее, чем четыре элемента данных, или стандартное отклонение равно нулю, функция ЭКСЦЕСС возвращает значение ошибки #ДЕЛ/0!.
  • Эксцесс определен как:

    где:

    s является стандартным отклонением.

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Столбец6 | Столбец7 | Столбец8 | Столбец9 | Столбец10 | Формула | Описание (Результат)
3 | 4 | 5 | 2 | 3 | 4 | 5 | 6 | 4 | 7 | =ЭКСЦЕСС([Столбец1], [Столбец2], [Столбец3], [Столбец4], [Столбец5], [Столбец6],[Столбец7],[Столбец8],[Столбец9],[Столбец10]) | Эксцесс набора данных равен -0.1518


Функция ЛОГНОРМОБР

Возвращает обратную функцию логарифмического нормального распределения x, где ln(x) имеет нормальное распределение с параметрами среднее и стандартное_отклонение. Если p = ЛОГНОРМРАСП(x;...), то ЛОГНОРМОБР(p;...) = x.

Логарифмическое нормальное распределение используется для анализа логарифмически преобразованных данных.

Синтаксис

ЛОГНОРМОБР(вероятность;среднее;стандартное_отклонение)

Вероятность — вероятность, связанная с логарифмическим распределением.

Среднее — среднее ln(x).

Стандартное_отклонение — стандартное отклонение ln(x).

Примечания

  • Если любой из аргументов не является числом, ЛОГНОРМОБР возвращает значение ошибки #ЗНАЧ!.
  • Если вероятность < 0 или вероятность > 1, ЛОГНОРМОБР возвращает значение ошибки #ЧИСЛО!.
  • Если стандартное_отклонение < 0, функция ЛОГНОРМОБР возвращает значение ошибки #ЧИСЛО!.

  • Обратная функция логарифмического нормального распределения имеет следующий вид:

Пример

Вероятность | Среднее | Стандартное отклонение | Формула | Описание (Результат)
0,039084 | 3,5 | 1,2 | =ЛОГНОРМОБР([Вероятность];[Среднее];[Стандартное отклонение]) | Обратная функция логарифмического нормального распределения для заданных параметров (4,000028)


ЛОГНОРМРАСП

Возвращает кумулятивное нормальное распределение логарифма переменной x, где ln(x) нормально распределен параметрами среднего и стандартного отклонения. Эта функция используется для анализа логарифмическим преобразованных данных.

Синтаксис

ЛОГНОРМРАСП(x,среднее,стандартное_отклонение)

X представляет собой значение, при котором вычисляется функция.

Среднее представляет собой среднее значение ln(x).

Стандартное_отклонение представляет собой стандартное отклонение ln(x).

Примечания

  • Если аргумент не является числом, функция ЛОГНОРМРАСП возвращает значение ошибки #ЗНАЧ!.
  • Если переменная x ? 0 или стандартное отклонение ? 0, функция ЛОГНОРМРАСП возвращает значение ошибки #ЧИСЛО!.
  • Уравнение кумулятивного нормального распределения:

Пример

X | Среднее | Стандартное отклонение | Формула | Описание (Результат)
4 | 3.5 | 1.2 | =ЛОГНОРМРАСП([X],[Среднее],[Стандартное отклонение]) | Кумулятивное нормальное распределение при значении переменной 4 и при заданных аргументах равно 0.039084


МАКС

Возвращает наибольшее из набора значений.

Синтаксис

МАКС(число1,число2, ...)

Набор число1, число2, ... включает в себя от 1 до 30 значений, из которых требуется выбрать наибольшее.

Примечания

  • Можно задавать аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел. Аргументы, являющиеся значениями ошибок или текстом, не могут быть переведены и вызывают ошибку.
  • Если нельзя игнорировать логические значения и текст, используется функция МАКСА.
  • Если в аргументе не содержится чисел, функция МАКС возвращает значение 0 (ноль).

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Формула | Описание (Результат)
10 | 7 | 9 | 27 | 2 | =МАКС([Столбец1]; [Столбец2]; [Столбец3]; [Столбец4]; [Столбец5]) | Наибольшее число (27)
10 | 7 | 9 | 27 | 2 | =МАКС([Столбец1];[Столбец2];[Столбец3];[Столбец4];[Столбец5];30) | Наибольшее из чисел в столбцах и числа 30 (30)


Функция МАКСА

Возвращает наибольшее значение в списке аргументов. Наряду с числовыми значениями выполняется также сравнение текстовых и логических значений (ИСТИНА и ЛОЖЬ).

Функция МАКСА родственна функции МИНА. Дополнительные сведения см. в примерах к функции МИНА.

Синтаксис

МАКСА(значение1;значение2; ...)

Значение1, значение2, ... — от 1 до 30 значений, среди которых ищется наибольшее.

Примечания

  • Можно задавать аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел. Аргументы, которые являются значениями ошибки, приводят к ошибке. Если логические значения и тексты не должны включаться в вычисление, следует пользоваться функцией МАКС.
  • Аргументы, содержащие значение ИСТИНА, выражаются как 1; текст или ЛОЖЬ — как 0 (ноль).
  • Если аргументы не содержат значений, то функция МАКСА возвращает 0 (ноль).

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Формула | Описание (Результат)
0 | 0,2 | 0,5 | 0,4 | ИСТИНА | =МАКСА([Столбец1];[Столбец2];[Столбец3];[Столбец4];[Столбец5]) | Наибольшее из значений. ИСТИНА выражается как 1 (1)


Функция МЕДИАНА

Возвращает медиану заданных чисел. Медиана — это число, которое является серединой множества чисел, то есть половина чисел имеют значения большие, чем медиана, а половина чисел имеют значения меньшие, чем медиана.

Синтаксис

МЕДИАНА(число1;число2; ...)

Число1, число2, ... — от 1 до 30 чисел, для которых определяется медиана.

Примечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.
  • Если аргумент-ссылка содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; аргументы, содержащие нулевые значения, учитываются.

  • Если в множестве четное количеств чисел, то функция МЕДИАНА вычисляет среднее двух чисел, находящихся в середине множества. См. второй из следующих примеров.

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Столбец6 | Формула | Описание (Результат)
1 | 2 | 3 | 4 | 5 | 6 | =МЕДИАНА([Столбец1]; [Столбец2]; [Столбец3]; [Столбец4]; [Столбец5]) | Медиана первых пяти чисел списка (3)
1 | 2 | 3 | 4 | 5 | 6 | =МЕДИАНА([Столбец1];[Столбец2];[Столбец3];[Столбец4];[Столбец5];[Столбец6]) | Медиана всех чисел или среднее значение чисел 3 и 4 (3.5)


МИН

Возвращает наименьшее из набора значений..

Синтаксис

МИН(число1,число2, ...)

Набор число1, число2, ... включает в себя от 1 до 30 значений, из которых требуется выбрать наименьшее.

Примечания

  • Можно задавать аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел. Аргументы, являющиеся значениями ошибок или текстом, не могут быть переведены и вызывают ошибку.
  • Если в аргументе стоит ссылка на столбец, в ней могут использоваться только числа. Для избежания этого используйте функцию МИНА.
  • Если в аргументе не содержится чисел, функция МИН возвращает значение 0.

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Формула | Описание (Результат)
10 | 7 | 9 | 27 | 2 | =МИН([Столбец1]; [Столбец2]; [Столбец3]; [Столбец4]; [Столбец5]) | Наименьшее значение чисел (2)
10 | 7 | 9 | 27 | 2 | =МИН([Столбец1];[Столбец2];[Столбец3];[Столбец4];[Столбец5];0) | Наименьшее значение чисел в столбцах и числа 0 (0)


МИНА

Возвращает наименьшее значение в списке аргументов. Наряду с числовыми значениями выполняется также сравнение текстовых и логических значений (ИСТИНА и ЛОЖЬ).

Синтаксис

МИНА(значение1,значение2,...)

Набор число1, число2, ... включает в себя от 1 до 30 значений, из которых требуется выбрать наименьшее.

Примечания

  • Можно задавать аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел. Аргументы, которые являются значениями ошибки, приводят к ошибке. Если логические значения и тексты не должны включаться в вычисление, следует пользоваться функцией МИН.
  • Аргументы, содержащие значение ИСТИНА, выражаются как 1; текст или ЛОЖЬ — как 0 (ноль).
  • Если в аргументе не содержится чисел, функция МИНА возвращает значение 0.

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Формула | Описание (Результат)
ЛОЖЬ | 0.2 | 0.5 | 0.4 | 0.8 | =МИНА([Столбец1]; [Столбец2]; [Столбец3]; [Столбец4]; [Столбец5]) | Наименьшее из значений. ИСТИНА приравнивается к 0 (0)


Функция РЕЖИМ

Возвращает наиболее часто встречающееся или повторяющееся значение в массиве или интервале данных. Также как и функция МЕДИАНА, функция РЕЖИМ является мерой взаимно расположения значений.

Синтаксис

РЕЖИМ(число1;число2; ...)

Число1, число2, ... — от 1 до 30 аргументов, для которых вычисляется мода.

Примечания

  • Аргументы должны быть числами или ссылками на столбцы, которые содержат числа.
  • Если аргумент-ссылка содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; аргументы, содержащие нулевые значения, учитываются.
  • Если множество данных не содержит одинаковых данных, то функция РЕЖИМ возвращает значение ошибки #Н/Д.

В наборе значений мода — это наиболее часто встречающееся значение; медиана — это значение в середине массива; среднее - это среднее арифметическое значение. Ни одно из этих чисел не характеризует в полной мере то, в какой степени центрированы данные. Пусть данные сгруппированы в трех областях, одна половина данных близка к некоторому малому значению, а другая половина данных близка к двум другим большим значениям. Обе функции СРЗНАЧ и МЕДИАНА могут вернуть значение из относительно пустой середины, а функция РЕЖИМ скорее всего вернет доминирующее малое значение.

Пример

Столбец1 | Столбец2 | Столбец3 | Столбец4 | Столбец5 | Столбец6 | Формула | Описание (Результат)
5,6 | 4 | 4 | 3 | 2 | 4 | =РЕЖИМ([Столбец1];[Столбец2];[Столбец3];[Столбец4];[Столбец5];[Столбец6]) | Мода или чаще всего встречающееся число (4)


ОТРБИНОМРАСП

Возвращает отрицательное биномиальное распределение. ОТРБИНОМРАСП возвращает вероятность того, что случится число_неудач неудачных испытаний, прежде чем будет достигнуто число_успехов успешных испытаний, при том условии, что вероятность успешного испытания постоянна и равна значению аргумента вероятность_успеха. Эта функция подобна биномиальному распределению, за тем исключением, что количество успехов фиксированное, а количество испытаний — переменное. Как и в случае биномиального распределения, испытания считаются независимыми.

Например, вам нужно найти 10 человек с блестящими способностями, и вы знаете, что вероятность того, что кандидат обладает такими способностями, равна 0,3. Тогда функция ОТРБИНОМРАСП вычислит вероятность того, что придется провести собеседования с определенным количеством неподходящих кандидатов, прежде чем будут найдены все 10 подходящих кандидатов.

Синтаксис

ОТРБИНОМРАСП(число_неудач;число_успехов;вероятность_успеха)

Число_неудач — это число неудач.

Число_успехов — пороговое значение числа успешных испытаний.

Вероятность_успеха — вероятность успеха каждого испытания.

Примечания

  • Число_неудач и число_успехов должно быть >= 0.
  • Число_неудач и число_успехов усекаются до целых.
  • Если какой-либо из аргументов не является числом, то функция ОТРБИНОМРАСП возвращает значение ошибки #ЗНАЧ!.
  • Если вероятность_успеха < 0 или вероятность > 1, то функция ОТРБИНОМРАСП возвращает значение ошибки #ЧИСЛО!.
  • Уравнение для отрицательного биномиального распределения имеет следующий вид:

    где:

    x — это число_неудач, r — это число_успехов, а p — это вероятность_успеха.

Пример

Число_неудач | Число_успехов | Вероятность успеха | Формула | Описание (Результат)
10 | 5 | 0.25 | =ОТРБИНОМРАСП([Число_неудач]; [Число_успехов]; [Вероятность успеха]) | Отрицательное биномиальное распределение для приведенных данных (0,055049)


Функция НОРМРАСП

Возвращает нормальную функцию распределения для указанного среднего и стандартного отклонения. Эта функция широкий используется в статистике, включая проверку гипотез.

Синтаксис

НОРМРАСП(x;среднее;стандартное_отклонение;интегральная)

X — значение, для которого строится распределение.

Среднее — среднее арифметическое распределения.

Стандартное_отклонение — стандартное отклонение распределения.

Интегральная — логическое значение, определяющее возвращаемую функцию: интегральную функцию распределения, если ИСТИНА; весовую функцию распределения, если ЛОЖЬ.

Примечания

  • Если среднее или стандартное_отклонение не являются числами, НОРМРАСП возвращает значение ошибки #ЗНАЧ!.
  • Если x ? 0, функция НОРМРАСП возвращает значение ошибки #ЧИСЛО!.
  • Если среднее = 0, стандартное_отклонение = 1, а интегральная = ИСТИНА, функция НОРМРАСП возвращает стандартное нормальное распределение, то есть НОРМСТРАСП.
  • Уравнение для плотности нормального распределения имеет следующий вид (интегральная = ЛОЖЬ):

  • Если интегральная = ИСТИНА, результатом является интеграл от минус бесконечности до x от заданного выражения.

Пример

X | Среднее | Стандартное отклонение | Формула | Описание (Результат)
42 | 40 | 1,5 | =НОРМРАСП([X];[Среднее];[Стандартное отклонение];ИСТИНА) | Интегральная функция распределения для заданных параметров (0,908789)
42 | 40 | 1,5 | =НОРМРАСП([X];[Среднее];[Стандартное отклонение];ЛОЖЬ) | Весовая функция распределения для заданных аргументов (0,10934005)


Функция НОРМОБР

Возвращает обратное нормальное распределение для указанного среднего и стандартного отклонения.

Синтаксис

НОРМОБР(вероятность;среднее;стандартное_отклонение)

Вероятность — вероятность, соответствующая нормальному распределению.

Среднее — среднее арифметическое распределения.

Стандартное_отклонение — стандартное отклонение распределения.

Примечания

  • Если любой из аргументов не является числом, НОРМОБР возвращает значение ошибки #ЗНАЧ!.
  • Если вероятность < 0 или вероятность > 1, НОРМОБР возвращает значение ошибки #ЧИСЛО!.
  • Если x ? 0, функция НОРМОБР возвращает значение ошибки #ЧИСЛО!.

  • НОРМОБР использует стандартное нормальное распределение, если среднее = 0 и стандартное_отклонение = 1 (см. НОРМСТОБР).

НОРМОБР использует метод итераций для вычисления значения. Если задано значение вероятности, то функция НОРМОБР производит итерации, пока не получит результат с точностью ± 3x10^-7. Если НОРМОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

Вероятность | Среднее | Стандартное отклонение | Формула | Описание (Результат)
0,908789 | 40 | 1,5 | =НОРМОБР([Вероятность];[Среднее];[Стандартное отклонение]) | Обратное нормальное распределения для заданных параметров (42)


НОРМСТРАСП

Возвращает функцию стандартного нормального интегрального распределения. Среднее распределения равняется нулю, а стандартное отклонение равно единице. Эта функция используется вместо таблицы для стандартной нормальной кривой. .

Синтаксис

НОРМСТРАСП(z)

Z представляет собой значение, для которого необходимо найти распределение.

Примечания

  • Если значение z несимметрично, функция НОРМСТРАСП возвращает значение ошибки #ЗНАЧ!.
  • Функция стандартной нормальной плотности:

Пример

Формула | Описание (Результат)
=НОРМСТРАСП(1.333333) | Функция стандартного нормального интегрального распределения для значения 1.333333 дает результат 0.908789


НОРМСТОБР

Возвращает обратное стандартное нормальное интегральное распределение. Его среднее равняется нулю, а стандартное отклонение равно единице.

Синтаксис

НОРМСТОБР(вероятность)

Вероятность представляет собой вероятность, соответствующую нормальному распределению.

Примечания

  • Если вероятность несимметрична, функция НОРМСТОБР возвращает значение ошибки #ЗНАЧ!.
  • Если вероятность < 0 или вероятность > 1, то функция НОРМСТОБР возвращает значение ошибки #ЧИСЛО!.

Функция НОРМСТОБР использует при вычислении итерационный метод. При заданном значении вероятности функция НОРМСТОБР производит итерацию, пока не будет достигнута точность ± 3x10^-7. Если функция НОРМСТОБР не сходится после 100 итераций, она возвращает значение ошибки #Н/Д.

Пример

Формула | Описание (Результат)
=НОРМСТОБР(0.908789) | Обратное стандартное нормальное интегральное распределение при вероятности 0.908789 равно 1.3333


Функция ПУАССОН

Возвращает распределение Пуассона. Обычно распределения Пуассона применяется для предсказания количества событий, происходящих за определенное время, например количество машин, появляющихся на площади за 1 минуту.

Синтаксис

ПУАССОН(x;среднее;интегральная)

X — количество событий.

Среднее — ожидаемое численное значение.

Интегральная — логическое значение, определяющее форму возвращаемого распределения вероятностей. Если аргумент интегральная имеет значение ИСТИНА, то функция ПУАССОН возвращает интегральное распределение Пуассона, то есть вероятность того, что число случайных событий будет лежать в пределах от 0 до x включительно; если этот аргумент имеет значение ЛОЖЬ, то возвращается функция плотности распределения Пуассона, то есть вероятность того, что событий будет в точности x.

Примечания

  • Если х не является целым числом, берется его целая часть.
  • Если х или среднее не являются числами, ПУАССОН возвращает значение ошибки #ЗНАЧ!.
  • Если x ? 0, функция ПУАССОН возвращает значение ошибки #ЧИСЛО!.
  • Если среднее ? 0, функция ПУАССОН возвращает значение ошибки #ЧИСЛО!.
  • Функция ПУАССОН вычисляется следующим образом.

    Если интегральная = ЛОЖЬ:

    Если интегральная = ИСТИНА:

Пример

X | Среднее | Формула | Описание (Результат)
2 | 5 | =ПУАССОН([X];[Среднее];ИСТИНА) | Интегральное распределение Пуассона с заданными аргументами (0,124652)
2 | 5 | =ПУАССОН([X];[Среднее];ЛОЖЬ) | Функция плотности распределения Пуассона с заданными аргументами (0,084224)


Функция СКОС

Возвращает асимметрию распределения. Асимметрия характеризует степень несимметричности распределения относительно его среднего. Положительная асимметрия указывает на отклонение распределения в сторону положительных значений. Отрицательная асимметрия указывает на отклонение распределения в сторону отрицательных значений.

Синтаксис

СКОС(число1;число2; ...)

Число1, число2... — от 1 до 30 аргументов, для которых вычисляется асимметричность.

Примечания

  • Аргумент должен представлять собой число или ссылку на столбец, содержащий набор чисел.
  • Если аргумент-ссылка содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; аргументы, содержащие нулевые значения, учитываются.
  • Если имеется менее трех точек данных, или стандартное отклонение равно нулю, то функция СКОС возвращает значение ошибки #ДЕЛ/0!.
  • Уравнение для асимметрии определяется следующим образом:

Пример

Д1 | Д2 | Д3 | Д4 | Д5 | Д6 | Д7 | Д8 | Д9 | Д10 | Формула | Описание (Результат)
3 | 4 | 5 | 2 | 3 | 4 | 5 | 6 | 4 | 7 | =СКОС([Д1]; [Д2]; [Д3]; [Д4]; [Д5]; [Д6]; [Д7]; [Д8]; [Д9]; [Д10]) | Асимметрия распределение для набора данных (0,359543)


НОРМАЛИЗАЦИЯ

Возвращает нормировочное значение из распределения, характеризующегося средним и стандартным_отклонением.

Синтаксис

НОРМАЛИЗАЦИЯ(x,среднее,стандартное_отклонение)

X представляет собой значение, для которого делается нормировка.

Среднее есть среднее арифметическое распределения.

Стандартное_отклонение является стандартным отклонением распределения.

Примечания

  • Если стандартное_отклонение ? 0, функция НОРМАЛИЗАЦИЯ возвращает значение ошибки #ЧИСЛО!.
  • Уравнение нормировочного значения:

Пример

X | Среднее | Стандартное отклонение | Формула | Описание (Результат)
42 | 40 | 1.5 | =НОРМАЛИЗАЦИЯ([X],[Среднее],[Стандартное отклонение]) | Нормировочное значение числа 42 при заданных аргументах равно 1.333333


Функция СТАНДОТКЛОН

Оценивает стандартное отклонение по выборке. Стандартное отклонение — это мера того, насколько широко разбросаны значения относительно их среднего.

Синтаксис

СТАНДОТКЛОН(число1;число2; ...)

Число1, число2,... — от 1 до 30 числовых аргументов, соответствующих выборке из генеральной совокупности.

Примечания

  • Логические значения (ИСТИНА и ЛОЖЬ), а также текст игнорируются. Чтобы избежать этого, воспользуйтесь функцией СТАНДОТКЛОНА.
  • СТАНДОТКЛОН предполагает, что аргументы являются только выборкой из генеральной совокупности. Если данные представляют всю генеральную совокупность, то стандартное отклонение следует вычислять с помощью функции СТАНДОТКЛОНП.
  • Стандартное отклонение вычисляется с использованием «несмещенного» или «n-1» метода.
  • СТАНДОТКЛОН использует следующую формулу:

Пример

Предположим, что из инструментов, отштампованных одной и той же машиной, выбраны наугад 10 штук и испытаны на излом.

С1 | С2 | С3 | С4 | С5 | С6 | С7 | С8 | С9 | С10 | Формула | Описание (Результат)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =СТАНДОТКЛОН([С1]; [С2]; [С3]; [С4]; [С5]; [С6]; [С7]; [С8]; [С9]; [С10]) | Стандартное отклонение сопротивления на излом (27,46391572)


Функция СТАНДОТКЛОНА

Оценивает стандартное отклонение по выборке. Стандартное отклонение - это мера того, насколько широко разбросаны точки данных относительно их среднего. В расчет также включаются текстовые и логические значения (ИСТИНА и ЛОЖЬ).

Синтаксис

СТАНДОТКЛОНА(значение1;значение2; ...)

Значение1, значение2, ... — от 1 до 30 значений, соответствующих выборке из генеральной совокупности.

Примечания

  • СТАНДОТКЛОНА предполагает, что аргументы являются только выборкой из генеральной совокупности. Если данные представляют всю генеральную совокупность, то стандартное отклонение следует вычислять с помощью функции СТАНДОТКЛОНПА.
  • Аргументы, содержащие значение ИСТИНА, выражаются как 1; текст или ЛОЖЬ — как 0 (ноль). Если текст и логические значения должны игнорироваться, воспользуйтесь функцией рабочего листа СТАНДОТКЛОН.
  • Стандартное отклонение вычисляется с использованием «несмещенного» или «n-1» метода.
  • СТАНДОТКЛОНА использует следующую формулу:

Пример

Предположим, что из инструментов, отштампованных одной и той же машиной, выбраны наугад 10 штук и испытаны на излом.

С1 | С2 | С3 | С4 | С5 | С6 | С7 | С8 | С9 | С10 | Формула | Описание (Результат)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =СТАНДОТКЛОНА([С1]; [С2]; [С3]; [С4]; [С5]; [С6]; [С7]; [С8]; [С9]; [С10]) | Стандартное отклонение сопротивления на излом для всех инструментов (27,46391572)


Функция СТАНДОТКЛОНП

Вычисляет стандартное отклонение по генеральной совокупности. Стандартное отклонение — это мера того, насколько широко разбросаны значения относительно их среднего.

Синтаксис

СТАНДОТКЛОНП(число1;число2; ...)

Число1, число2,... — от 1 до 30 числовых аргументов, соответствующих генеральной совокупности.

Примечания

  • Логические значения (ИСТИНА и ЛОЖЬ), а также текст игнорируются. Чтобы избежать этого, воспользуйтесь функцией рабочего листа СТАНДОТКЛОНА.
  • СТАНДОТКЛОНП предполагает, что аргументы образуют всю генеральную совокупность. Если данные являются только выборкой из генеральной совокупности, то стандартное отклонение следует вычислять с использованием функции СТАНДОТКЛОН.
  • Для больших выборок СТАНДОТКЛОН и СТАНДОТКЛОНП возвращают примерно равные значения.
  • Стандартное отклонение вычисляется с использованием «смещенного» или «n» метода.
  • СТАНДОТКЛОНП использует следующую формулу:

Пример

С1 | С2 | С3 | С4 | С5 | С6 | С7 | С8 | С9 | С10 | Формула | Описание (Результат)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =СТАНДОТКЛОНП([С1]; [С2]; [С3]; [С4]; [С5]; [С6]; [С7]; [С8]; [С9]; [С10]) | Стандартное отклонение сопротивления на излом для 10 инструментов (26,05455814)


Функция СТАНДОТКЛОНПА

Вычисляет стандартное отклонение по генеральной совокупности, заданной аргументами, которые могут включать текст и логические значения. Стандартное отклонение — это мера того, насколько широко разбросаны значение относительно их среднего.

Синтаксис

СТАНДОТКЛОНПА(значение1;значение2; ...)

Значение1, значение2, ... — от 1 до 30 значений, соответствующих генеральной совокупности.

Примечания

  • СТАНДОТКЛОНПА предполагает, что аргументы образуют всю генеральную совокупность. Если данные являются только выборкой из генеральной совокупности, то стандартное отклонение следует вычислять с использованием функции СТАНДОТКЛОНА.
  • Аргументы, содержащие значение ИСТИНА, выражаются как 1; текст или ЛОЖЬ — как 0 (ноль). Если текст и логические значения должны игнорироваться, воспользуйтесь функцией рабочего листа СТАНДОТКЛОНП.
  • Для больших выборок СТАНДОТКЛОНА и СТАНДОТКЛОНПА возвращают примерно равные значения.
  • Стандартное отклонение вычисляется с использованием «смещенного» или «n» метода.
  • СТАНДОТКЛОНПА использует следующую формулу:

Пример

С1 | С2 | С3 | С4 | С5 | С6 | С7 | С8 | С9 | С10 | Формула | Описание (Результат)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =СТАНДОТКЛОНПА([С1]; [С2]; [С3]; [С4]; [С5]; [С6]; [С7]; [С8]; [С9]; [С10]) | Стандартное отклонение сопротивления на излом для 10 инструментов (26,05455814)


СТЬЮДРАСП

Возвращает процентные точки (вероятность) для t-распределения Стьюдента, где численное значение (x) — это вычисленное значение , для которого должны быть вычислены вероятности. T-распределение используется для проверки гипотез при малом объеме выборки. Данную функцию можно использовать вместо таблицы критических значений t-распределения.

Синтаксис

СТЬЮДРАСП(x;степени_свободы;хвосты)

X — численное значение, для которого требуется вычислить распределение.

Степени_свободы — целое, указывающее число степеней свободы.

Хвосты — число возвращаемых хвостов распределения. Если хвосты = 1, то функция СТЬЮДРАСП возвращает одностороннее распределение. Если хвосты = 2, то функция СТЬЮДРАСП возвращает двухстороннее распределение.

Примечания

  • Если какой-либо из аргументов не является числом, то функция СТЬЮДРАСП возвращает значение ошибки #ЗНАЧ!.
  • Если степени_свободы < 1, то функция СТЬЮДРАСП возвращает значение ошибки #ЧИСЛО!.
  • Аргументы степени_свободы и хвосты усекаются до целых.
  • Если хвосты — любое значение, отличное от 1 и 2, то функция СТЬЮДРАСП возвращает значение ошибки #ЧИСЛО!.
  • СТЬЮДРАСП вычисляется следующим образом: СТЬЮДРАСП=p( x<abs(X)), где X — это случайная величина, соответствующая t-распределению.

Пример

X | Степени_свободы | Формула | Описание (Результат)
1,96 | 60 | =СТЬЮДРАСП([X];[Степени_свободы];2) | Двухстороннее распределение (0,054644927, или 5,46 процента)
1,96 | 60 | =СТЬЮДРАСП([X];[Степени_свободы];1) | Одностороннее распределение (0,027322463, или 2,73 процента)


СТЬЮДРАСПОБР

Возвращает t-значение распределения Стьюдента как функцию вероятности и числа степеней свободы.

Синтаксис

СТЬЮДРАСПОБР(вероятность;степени_свободы)

Вероятность — вероятность, соответствующая двустороннему распределению Стьюдента.

Степени_свободы — число степеней свободы, характеризующее распределение.

Примечания

  • Если любой из аргументов не является числом, то функция СТЬЮДРАСПОБР возвращает значение ошибки #ЗНАЧ!.
  • Если вероятность < 0 или вероятность > 1, то функция СТЬЮДРАСПОБР возвращает значение ошибки #ЧИСЛО!.
  • Если степени_свободы не является целым числом, берется его целая часть.
  • Если степени_свободы < 1, то функция СТЬЮДРАСПОБР возвращает значение ошибки #ЧИСЛО!.
  • СТЬЮДРАСПОБР вычисляется следующим образом: СТЬЮДРАСПОБР=p(t<X ), где X — это случайная величина, соответствующая t-распределению.
  • Одностороннее t-значение может быть получено при замене аргумента вероятность на 2*вероятность. Для вероятности 0,05 и числа степеней свободы равного 10 двухстороннее значение вычисляется СТЬЮДРАСПОБР(0,05;10) и равно 2,28139. Одностороннее значение для той же вероятности и числа степеней свободы может быть вычислено формулой СТЬЮДРАСПОБР(2*0,05;10) и равняется 1,812462.

    Примечание. В некоторых таблицах вероятность описана как (1-p).

СТЬЮДРАСПОБР использует метод итераций для вычисления функции. Если задано значение вероятности, то функция НОРМСТОБР производит итерации, пока не получит результат с точностью ± 3x10^-7. Если СТЬЮДРАСПОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

Вероятность | Степени_свободы | Формула | Описание (Результат)
0,054645 | 60 | =СТЬЮДРАСПОБР([Вероятность];[Степени_свободы]) | t-значение распределения Стьюдента на приведенных условиях (1,959997462)


Функция ДИСП

Оценивает дисперсию по выборке.

Синтаксис

ДИСП(число1,число2, ...)

Число1, число2,... — от 1 до 30 числовых аргументов, соответствующих выборке из генеральной совокупности.

Примечания

  • ДИСП предполагает, что аргументы являются только выборкой из генеральной совокупности. Если данные представляют всю генеральную совокупность, дисперсия вычисляется с помощью функции ДИСПР.
  • Логические значения (ИСТИНА и ЛОЖЬ), а также текст игнорируются. Чтобы избежать этого, воспользуйтесь функцией ДИСПА.
  • ДИСП использует следующую формулу:

Пример

Предположим, что из инструментов, отштампованных одной и той же машиной, выбраны наугад 10 штук и испытаны на излом.

С1 | С2 | С3 | С4 | С5 | С6 | С7 | С8 | С9 | С10 | Формула | Описание (Результат)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =ДИСП([С1]; [С2]; [С3]; [С4]; [С5]; [С6]; [С7]; [С8]; [С9]; [С10]) | Дисперсия сопротивления на излом для инструментов (754,26666667)


Функция ДИСПА

Оценивает дисперсию по выборке. Помимо численных значений учитываются также текстовые и логические значения (ИСТИНА и ЛОЖЬ).

Синтаксис

ДИСПА(значение1;значение2; ...)

Значение1, значение2, ... — от 1 до 30 числовых аргументов, соответствующих выборке из генеральной совокупности.

Примечания

  • ДИСПА предполагает, что аргументы являются только выборкой из генеральной совокупности. Если данные представляют всю генеральную совокупность, дисперсия вычисляется с помощью функции ДИСПРА.
  • Аргументы, содержащие значение ИСТИНА, выражаются как 1; текст или ЛОЖЬ — как 0 (ноль). Если текст и логические значения должны игнорироваться, воспользуйтесь функцией ДИСПА.
  • ДИСПА использует следующую формулу:

Пример

Предположим, что из инструментов, отштампованных одной и той же машиной, выбраны наугад 10 штук и испытаны на излом.

С1 | С2 | С3 | С4 | С5 | С6 | С7 | С8 | С9 | С10 | Формула | Описание (Результат)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =ДИСПА([С1]; [С2]; [С3]; [С4]; [С5]; [С6]; [С7]; [С8]; [С9]; [С10]) | Оценивает дисперсию сопротивления на излом (754,2666667)


Функция ДИСПР

Вычисляет дисперсию для генеральной совокупности.

Синтаксис

ДИСПР(число1,число2, ...)

Число1, число2,... — от 1 до 30 числовых аргументов, соответствующих генеральной совокупности.

  • Логические значения (ИСТИНА и ЛОЖЬ), а также текст игнорируются. Чтобы избежать этого, воспользуйтесь функцией ДИСПРА.

Примечания

  • ДИСПР предполагает, что аргументы образуют всю генеральную совокупность. Если данные являются только выборкой из генеральной совокупности, то димперсию следует вычислять с использованием функции ДИСП.
  • Уравнение для ДИСПР имеет следующий вид:

Пример

Предположим, что из 10 инструментов, отштампованных одной и той же машиной, выбраны все и испытаны на излом.

С1 | С2 | С3 | С4 | С5 | С6 | С7 | С8 | С9 | С10 | Формула | Описание (Результат)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =ДИСПР([С1]; [С2]; [С3]; [С4]; [С5]; [С6]; [С7]; [С8]; [С9]; [С10]) | Дисперсия сопротивления на излом для всех инструментов в предположении, что произведено только 10 инструментов (678,84)


Функция ДИСПРА

Вычисляет дисперсию для генеральной совокупности. Помимо численных значений, учитываются также текстовые и логические значения (ИСТИНА и ЛОЖЬ).

Синтаксис

ДИСПРА(значение1,значение2, ...)

Значение1, значение2, ... — от 1 до 30 числовых аргументов, соответствующих генеральной совокупности.

Примечания

  • ДИСПРА предполагает, что аргументы образуют всю генеральную совокупность. Если данные являются только выборкой из генеральной совокупности, то дисперсию следует вычислять с использованием функции ДИСПА.
  • Аргументы, содержащие значение ИСТИНА, выражаются как 1; текст или ЛОЖЬ — как 0 (ноль). Если текст и логические значения должны игнорироваться, воспользуйтесь функцией ДИСПР.
  • Уравнение для ДИСПРА имеет следующий вид:

Пример

Предположим, что из 10 инструментов, отштампованных одной и той же машиной, выбраны все и испытаны на излом.

С1 | С2 | С3 | С4 | С5 | С6 | С7 | С8 | С9 | С10 | Формула | Описание (Результат)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =ДИСПРА([С1]; [С2]; [С3]; [С4]; [С5]; [С6]; [С7]; [С8]; [С9]; [С10]) | Дисперсия сопротивления на излом для всех инструментов в предположении, что произведено только 10 инструментов (678,84)


Функция ВЕЙБУЛЛ

Возвращает распределение Вейбулла. Это распределение используется при анализе надежности, например для вычисления среднего времени наработки на отказ какого-либо устройства.

Синтаксис

ВЕЙБУЛЛ(x;альфа;бета;интегральная)

X — значение, для которого вычисляется функция.

Альфа — параметр распределения.

Бета — параметр распределения.

Интегральная — определяет форму функции.

Примечания

  • Если альфа или бета не являются числами, ВЕЙБУЛЛ возвращает значение ошибки #ЗНАЧ!.
  • Если х < 0, функция ВЕЙБУЛЛ возвращает значение ошибки #ЧИСЛО!.
  • Если альфа ? 0 или бета ? 0, ВЕЙБУЛЛ возвращает значение ошибки #ЧИСЛО!.
  • Уравнение для интегральной функции распределения Вейбулла имеет следующий вид:

  • Уравнение для функции плотности распределения Вейбулла имеет следующий вид:

  • При альфа = 1, ВЕЙБУЛЛ возвращает экспоненциальное распределение:

Пример

X | Альфа | Бета | Формула | Описание (Результат)
105 | 20 | 100 | =ВЕЙБУЛЛ([X];[Альфа];[Бета];ИСТИНА) | Интегральная функция распределения Вейбулла для заданных аргументов (0,929581)
105 | 20 | 100 | =ВЕЙБУЛЛ([X];[Альфа];[Бета];ЛОЖЬ) | Функция плотности распределения Вейбулла для заданных аргументов (0,035589)


ASC

Для языков DBCS меняет полноширинные (двухбайтовые) символы на полуширинные (однобайтовые).

Синтаксис

ASC(текст)

Текст представляет собой ссылку на текст или столбец с текстом, который необходимо изменить. Если в тексте нет полноширинных букв, он не меняется.

Пример

=ASC("EXCEL") equals "EXCEL"

=ASC(" Excel Excel Excel Excel ") equals " Excel Excel Excel Excel "


СИМВОЛ

Возвращает символ числа. Функция СИМВОЛ используется для перевода чисел, содержащихся в кодовой странице, взятой из файла или другого компьютера, в символы.

Синтаксис

СИМВОЛ(число)

Число должно находиться в пределах от 1 до 255, задавая требуемый символ. Символ берется из набора символов, используемых данным компьютером.

Пример

Формула | Описание (Результат)
=СИМВОЛ(65) | Отображает 65 символ набора (A)
=СИМВОЛ(33) | Отображает 33 символ набора (!)


ПЕЧСИМВ

Удаляет из текста все непечатаемые символы. Функция ПЕЧСИМВ используется для обработки текстов, созданных в других приложениях, не печатаемых данной операционной системой. Например, можно использовать функцию ПЕЧСИМВ для удаления компьютерных кодов нижнего уровня, которые обычно находятся в начале и конце файлов, содержащих данные, и не могут быть напечатаны.

Синтаксис

ПЕЧСИМВ(текст)

Текст представляет собой любую информацию, из которой нужно удалить непечатаемые символы.

Пример

Столбец1 | Формула | Описание (Результат)
=СИМВОЛ(7)&"текст"&СИМВОЛ(7) | =ПЕЧСИМВ([Столбец1]) | Удаляет непечатаемый символ СИМВОЛ(7) из строки (текста).


КОД

Возвращает численный код первого символа текстовой строки. Этот код соответствует символу, используемому данным компьютером.

Синтаксис

КОД(текст)

Текстом является любой текст, для которого требуется узнать код первого символа текстовой строки.

Пример

Формула | Описание (Результат)
=КОД("A") | Отображает численный код символа A (65)
=КОД("!") | Отображает численный код символа ! (33)


СЦЕПИТЬ

Объединяет несколько тестовых строк в одну.

Синтаксис

СЦЕПИТЬ (текст1,текст2,...)

Текст1, текст2, ... является набором, содержащим от 1 до 30 текстовых элементов, которые требуется объединить в единый тестовый элемент. Текстовыми элементами могут быть текстовые строки, числа, ссылки на столбцы.

Примечания

Оператор "&" может использоваться вместо функции СЦЕПИТЬ для объединения текстовых элементов.

Пример

Столбец1 | Столбец2 | Столбец3 | Формула | Описание
brook trout | species | 32 | =СЦЕПИТЬ("Stream population for ",[Столбец1]," ",[Столбец2]," is ",[Столбец3],"/mile") | Связанное предложение: Stream population for brook trout species is 32/mile


РУБЛЬ

Преобразует число в текст, используя денежный формат с округлением до заданного числа десятичных знаков. Используется следующий формат: # ##0,00 р.;- # ##0,00 р.

Синтаксис

РУБЛЬ(число;число_знаков)

Число — либо число, либо ссылка на ячейку, содержащую число, либо формула, вычисление которой дает число.

Число_знаков — число цифр справа от десятичной запятой. Если число_знаков отрицательно, то число округляется слева от десятичной запятой. Если число_знаков опущено, то для определения числа знаков после запятой будет использован параметр языка системы.

Примечания

В функции РУБЛЬ используются заданный на компьютере параметр валюты. Чтобы всегда использовалась валюта США, используйте функцию ДОЛЛСША.

Пример

Столбец1 | Формула | Описание (Результат)
1234,567 | =РУБЛЬ([Столбец1]; 2) | Отображает первое число в денежном формате, 2 цифры справа от десятичной запятой (1234,57 р.)
1234,567 | =РУБЛЬ([Столбец1]; -2) | Отображает первое число в денежном формате, 2 цифры слева от десятичной запятой (1200 р.)
-1234,567 | =РУБЛЬ([Столбец1]; -2) | Отображает второе число в денежном формате, 2 цифры слева от десятичной запятой ((1200 р.))
-0,123 | =РУБЛЬ([Столбец1]; 4) | Отображает третье число в денежном формате, 4 цифры справа от десятичной запятой((0,1230 р.))
99,888 | =РУБЛЬ([Столбец1]) | Отображает четвертое число в денежном формате, 2 цифры слева от десятичной запятой (99,89 р.)


СОВПАД

Сравнивает две текстовые строки и возвращает значение ИСТИНА, если они одинаковы, и ЛОЖЬ, если нет. Функция СОВПАД учитывает регистр. Используйте функцию СОВПАД для проверки текста, вводимого в документ.

Синтаксис

СОВПАД(текст1,текст2)

Текст1 является первой текстовой строкой.

Текст2 является второй текстовой строкой.

Пример

Столбец1 | Столбец2 | Формула | Описание (Результат)
слово | слово | =СОВПАД([Столбец1],[Столбец2]) | Проверяет, одинаковы ли строки, и возвращает значение ИСТИНА
Слово | слово | =СОВПАД([Столбец1],[Столбец2] | Проверяет, одинаковы ли строки, и возвращает значение ЛОЖЬ
сл ово | слово | =СОВПАД([Столбец1],[Столбец2]) | Проверяет, одинаковы ли строки, и возвращает значение ЛОЖЬ


Функция НАЙТИ

Функция НАЙТИ находит вхождение одной текстовой строки (искомый_текст) в другую текстовую строку (просматриваемый_текст) и возвращает номер начальной позиции искомого текста относительно первого знака просматриваемого текста. Для поиска вхождений одной текстовой строки в другую можно также использовать функцию ПОИСК, но в отличии от функции ПОИСК, функция НАЙТИ учитывает регистр и не допускает подстановочных знаков.

Синтаксис

НАЙТИ(искомый_текст;просматриваемый_текст;нач_позиция)

Искомый_текст — это искомый текст.

Просматриваемый_текст — это текст, в котором нужно найти искомый текст.

Нач_позиция — это знак, с которого нужно начать поиск. Первый знак в тексте просматриваемый_текст имеет номер 1. Если номер опущен, он полагается равным 1.

Показать Совет

Аргумент нач_позиция можно использовать, чтобы пропустить нужное количество знаков. Например, задана текстовая строка «МДС0093.МесячныеПродажи». Чтобы найти номер первого вхождения «М» в описательную часть текстовой строки, задайте значение аргумента нач_позиция равным 8, так что в той части текста, которая является серийным номером, поиск производиться не будет. Функция НАЙТИ начинает со знака 8, находит искомый_текст в следующем знаке и возвращает число 9. Функция НАЙТИ всегда возвращает номер знака, считая от левого края текста просматриваемый_текст, а не от значения аргумента нач_позиция.

Примечания

  • Если в качестве аргумента искомый_текст задана пустая строка (""), функция НАЙТИ выводит значение, равное первому знаку в строке поиска (знак с номером, соответствующим аргументу нач_позиция или 1).
  • Искомый_текст не может содержать подстановочные знаки.
  • Если искомый_текст отсутствует в тексте просматриваемый_текст, функция НАЙТИ возвращает значение ошибки #ЗНАЧ!.
  • Если нач_позиция не больше нуля, функция НАЙТИ возвращает значение ошибки #ЗНАЧ!.
  • Если нач_позиция больше, чем длина аргумента просматриваемый_текст, то возвращается значение ошибки #ЗНАЧ!..

Пример 1

Формула | Описание (Результат)
=НАЙТИ("Е";"Евгений Ерофеев") | Позиция первого знака «Е» в строке (1)
=НАЙТИ("е";"Евгений Ерофеев") | Позиция первого знака «е» в строке (4)
=НАЙТИ("Е";"Евгений Ерофеев";3) | Позиция первого знака «Е» в строке, начиная с третьего знака (9)

Пример 2

Столбец1 | Формула | Описание (Результат)
Керамический изолятор №124-ТД45-87 | =ПСТР([Столбец1];1;НАЙТИ("№";[Столбец1];1)-1) | Выделяет текст от позиции 1 до позиции «№» в строке (Керамический изолятор)
Медная пружина №12-671-6772 | =ПСТР([Столбец1];1;НАЙТИ("№";[Столбец1];1)-1) | Выделяет текст от позиции 1 до позиции «№» в строке (Медная пружина)
Переменный резистор №116010 | =ПСТР([Столбец1];1;НАЙТИ("№";[Столбец1];1)-1) | Выделяет текст от позиции 1 до позиции «№» в строке (Переменный резистор)


Функция ФИКСИРОВАННЫЙ

Округляет число до заданного количества десятичных цифр, форматирует число в десятичном формате с использованием запятых и точек и возвращает результат в виде текста.

Синтаксис

ФИКСИРОВАННЫЙ(число;число_знаков;без_разделителей)

Число — число, которое требуется округлить и преобразовать в текст.

Число_знаков — число знаков справа от десятичного разделителя.

Без_разделителей — логическое значение; если ИСТИНА, то функция ФИКСИРОВАННЫЙ не включает запятые в возвращаемый текст.

Примечания

  • Если число_знаков < 0, число слева от десятичного разделителя округляется.
  • Если число_знаков опущено, то для определения числа знаков после запятой будет использован параметр языка системы.
  • Если без_разделителей имеет значение ЛОЖЬ или опущено, возвращаемый текст обычно содержит запятые.

Пример

Формула | Описание (Результат)
=ФИКСИРОВАННЫЙ(1234,567; 1) | Первое число округляется до первого знака справа от десятичного разделителя (1;234,6)
=ФИКСИРОВАННЫЙ(1234,567; -1) | Первое число округляется до первого знака слева от десятичного разделителя (1;230)
=ФИКСИРОВАННЫЙ(-1234,567; -1; ИСТИНА) | Второе число округляется до первого знака слева от десятичного разделителя, запятая убирается (-1230)
=ФИКСИРОВАННЫЙ(44,332) | Третье число округляется до второго знака слева от десятичного разделителя (44,33)


ЛЕВСИМВ

Функция ЛЕВСИМВ возвращает первый символ или несколько первых символов текстовой строки, в зависимости от заданного числа символов.

Синтаксис

ЛЕВСИМВ(текст, число_знаков)

Текст представляет собой текстовую строку, содержащую символы, которые требуется извлечь.

Число_знаков задает количество символов, которые извлечет функция ЛЕВСИМВ.

  • Число_знаков должно быть больше или равно нулю.

  • Если число_знаков превышает длину текста, функция ЛЕВСИМВ возвращает весь текст.

  • Если число_знаков опускается, оно считается равным 1.

Пример

Столбец1 | Формула | Описание (Результат)
Sale Price | =ЛЕВСИМВ([Столбец1],4) | Первые четыре символа строки: Sale
Sweden | =ЛЕВСИМВ([Столбец1]) | Первый символ строки: S


ДЛСТР

Функция ДЛСТР возвращает число символов в текстовой строке.

Синтаксис

ДЛСТР(текст)

Текст представляет собой текст, длину которого нужно узнать. Пробелы считаются символами.

Пример

Столбец1 | Формула | Описание (Результат)
Phoenix, AZ | =ДЛСТР([Столбец1]) | В строке 11 символов
 | =ДЛСТР([Столбец1]) | Длина строки равняется 0
A One | =ДЛСТР([Столбец1]) | Длина строки, включающей в себя 5 пробелов, равна 8


СТРОЧН

Преобразует все прописные буквы в текстовой строке в строчные.

Синтаксис

СТРОЧН(текст)

Текст представляет собой текст, который необходимо записать строчными буквами. СТРОЧН не меняет небуквенные символы строки.

Пример

Столбец1 | Формула | Описание (Результат)
E. E. Cummings | =СТРОЧН([Столбец1]) | Строка записана строчными буквами: e. e. cummings
Apt. 2B | =СТРОЧН([Столбец1]) | Строка записана строчными буквами: apt. 2b


ПСТР

ПСТР возвращает указанное число знаков из текстовой строки, начиная с указанной позиции.

Синтаксис

ПСТР(текст;начальная_позиция;количество_знаков)

Текст представляет собой текстовую строку, содержащую символы, которые требуется извлечь.

Начальная_позиция — позиция первого знака, извлекаемого из текста. Первый знак в тексте имеет начальную позицию 1 и так далее.

Число_знаков указывает, сколько знаков требуется вернуть.

Примечания

  • Если начальная_позиция больше, чем длина текста, то функция ПСТР возвращает строку "" (пустую строку).
  • Если начальная_позиция меньше, чем длина текста, но начальная_позиция плюс количество_знаков превышают длину текста, то функция ПСТР возвращает знаки вплоть до конца текста.
  • Если начальная_позиция меньше 1, то функция ПСТР возвращает значение ошибки #ЗНАЧ!.

  • Если количество_знаков отрицательно, то функция ПСТР возвращает значение ошибки #ЗНАЧ!.

Пример

Формула | Описание (Результат)
=ПСТР("Поток жидкости";1;5) | Шесть знаков из приведенной строки, начиная с первого (Поток)
=ПСТР("Поток жидкости";7;20) | Двадцать знаков из приведенной строки, начиная с седьмого (жидкости)
=ПСТР("Поток жидкости";20;5) | Т. к. начальная позиция больше, чем длина строки, возвращается пустая строка ()


ПРОПНАЧ

Делает строчной первую букву текстовой строки и все буквы, следующие за небуквенными символами. Все остальные буквы преобразуются в строчные.

Синтаксис

ПРОПНАЧ(текст)

Текст представляет собой текст, взятый в кавычки, формулу, возвращающую текст, или ссылку на столбец, который требуется преобразовать.

Пример

Формула | Описание (Результат)
=ПРОПНАЧ("this is a TITLE") | Преобразование строки (This Is A Title)
=ПРОПНАЧ("2-cent's worth") | Преобразование строки (2-Cent'S Worth)
=ПРОПНАЧ("76BudGet") | Преобразование строки (76Budget)


ЗАМЕНИТЬ

Функция ЗАМЕНИТЬ заменяет символы текстовой строки, количество которых задано другой текстовой строкой.

Синтаксис

ЗАМЕНИТЬ(старый_текст,нач_поз,число_знаков,новый_текст)

Старый_текст представляет собой текст, в котором требуется заменить несколько символов.

Нач_поз является расположением символа, который требуется заменить новым_текстом, в старом_тексте.

Число_знаков есть число символов в старом_тексте, которые требуется заменить новым_текстом.

Новый_текст представляет собой текст, который заменит символы в старом_тексте.

Пример

Формула | Описание (Результат)
=ЗАМЕНИТЬ("abcdefghijk",6,5,"*") | Заменяет пять символов, начиная с шестого: abcde*k
=ЗАМЕНИТЬ("2009",3,2,"10") | Заменяет последние два знака цифры 2009 на 10: 2010
=ЗАМЕНИТЬ("123456",1,3,"@") | Заменяет первые три символа на @: @456


ПОВТОР

Повторяет текст заданное количество раз. Используйте функцию ПОВТОР для добавления в текстовую строку нескольких копий текста.

Синтаксис

ПОВТОР(текст,число_раз)

Текст представляет собой часть текста, которую нужно повторить.

Число_раз представляет собой положительное число, задающее число повторений.

Примечания

  • Если число_раз равно 0 (нулю), функция ПОВТОР возвращает значение «» (отсутствие текста).

  • Если число_раз задано не целым, оно округляется.

  • Функция ПОВТОР не может применяться более чем к 2000 символам, иначе функция возвращает значение ошибки #ЗНАЧ!.

Пример

Формула | Описание (Результат)
=ПОВТОР("*-", 3) | Отображает строку 3 раза: *-*-*-
=ПОВТОР("-",10) | Отображает штрих 10 раз: ----------


ПРАВСИМВ

Функция ПРАВСИМВ возвращает заданное количество последних символов строки.

Синтаксис

ПРАВСИМВ(текст,число_знаков)

Текст представляет собой текстовую строку, содержащую символы, которые необходимо изъять.

Число_знаков задает количество символов, которые требуется вернуть.

Примечания

  • Число_знаков должно быть больше или равно нулю.
  • Если число_знаков превышает длину текста, функция ПРАВСИМВ возвращает весь текст.
  • Если число_символов опущено, оно считается равным 1.

Пример

Формула | Описание (Результат)
=ПРАВСИМВ("Sale Price",5) | Последние 5 символов строки: Price
=ПРАВСИМВ("Stock Number") | Последний символ строки: r


ПОИСК

Возвращает позицию первого вхождения знака или текстовой строки при поиске слева направо, начиная с нач_позиция. Функция ПОИСК используется для поиска вхождения знака или строки текста в другую строку текста, с тем чтобы применить функции ПСТР или ЗАМЕНИТЬ для изменения текста.

Синтаксис

ПОИСК(искомый_текст;просматриваемый_текст;нач_позиция)

Искомый_текст — это искомый текст. В аргументе искомый_текст можно использовать подстановочные знаки вопросительный знак (?) и звездочка (*). Вопросительный знак соответствует любому знаку; звездочка соответствует любой последовательности знаков. Если нужно найти вопросительный знак или звездочку, то следует поставить перед ними знак тильда (~).

Текст_для_поиска — текст, в котором нужно найти искомый_текст.

Начальная_позиция — номер знака в тексте текст_для_поиска, с которого следует начать поиск.

Показать Совет

Аргумент нач_позиция можно использовать, чтобы пропустить нужное количество знаков. Пусть задана текстовая строка «МДС0093.МесячныеПродажи». Чтобы найти первое вхождение «М» в описательную часть текстовой строки, укажите, что нач_позиция равна 8, так что в той части текста, которая является серийным номером, поиск производиться не будет. Функция ПОИСК начинает с знака 8, находит искомый_текст в следующем знаке и возвращает число 9. Функция ПОИСК всегда возвращает номер знака, считая от левого края текста, а не от значения аргумента нач_позиция. .

Примечания

  • ПОИСК не различает регистры при поиске текста.
  • ПОИСК аналогична функции НАЙТИ, за исключением того, что НАЙТИ работает с учетом регистра.
  • Если искомый_текст не найден, то возвращается значение ошибки #ЗНАЧ!.
  • Если аргумент нач_позиция опущен, то он полагается равным 1.
  • Если аргумент нач_позиция не больше 0 или больше, чем длина аргумента текст_для_поиска, то возвращается значение ошибки #ЗНАЧ!.

Пример

Столбец1 | Столбец2 | Столбец3 | Формула | Описание (Результат)
Утверждения | Поле дохода | доход | =ПОИСК("е";[Столбец1];6) | Позиция первого знака «е» в строке «Утверждения», начиная с шестого знака (8)
Утверждения | Поле дохода | доход | =ПОИСК([Столбец2];[Столбец3]) | Позиция слова «доход» в строке «Поле дохода» (6)
Утверждения | Поле дохода | поле | =ЗАМЕНИТЬ([Столбец3];ПОИСК([СТОЛБЕЦ3];[СТОЛБЕЦ2]);1;"Сумма") | Слово «Поле» заменяется на слово «Сумма» (Сумма дохода)


Функция T

Возвращает текст, на который ссылается значение.

Синтаксис

T(значение)

Значение — значение, которое нужно проверить.

Примечания

  • Если значение является текстом или ссылается на него, функция T возвращает значение. Если значение не ссылается на текст, T возвращает пустой текст ("").

  • Нет необходимости использовать функцию T в формуле, поскольку обычно значения преобразуются автоматически при необходимости.

Пример

Формула | Описание (Результат)
=T("Ливень") | Значение является текстом — функция возвращает текст (Ливень)
=T(19) | Значение является числом — функция возвращает пустой текст ()
=T(ИСТИНА) | Значение является логическим значением — функция возвращает пустой текст ()


Функция ТЕКСТ

Преобразует значение в текст в заданном числовом формате.

Синтаксис

ТЕКСТ(значение;формат)

Значение — числовое значение либо формула, вычисление которой дает числовое значение, либо ссылка на ячейку, содержащую числовое значение.

Формат — числовой формат в текстовой форме.

Примечания

  • Функция ТЕКСТ преобразует значение в форматированный текст, и результат больше не участвует в вычислениях в качестве числа.

Пример

Продавец | Продажи | Формула | Описание (Результат)
Иванов | 2800 | =[Продавец]&" продал товара на "&ТЕКСТ([Продажи], "0,00;(0,00 р.)")&"" | Из содержимого формулы составляется фраза (Иванов продал товара на 2 800,00 р.)
Петров | 0,4 | =[Продавец]&" продол "&ТЕКСТ([Продажи],"0,00%")&" от общего числа товаров." | Из содержимого формулы составляется фраза (Петров продал 40,00% от общего число товаров.)


Функция СЖПРОБЕЛЫ

Удаляет из текста все пробелы, за исключением одиночных пробелов между словами. Функция СЖПРОБЕЛЫ служит для обработки текстов, полученных из других прикладных программ, поскольку эти тексты могут содержать избыточные пробелы.

Синтаксис

СЖПРОБЕЛЫ(текст)

Текст — текст, из которого удаляются пробелы.

Пример

Формула | Описание (Результат)
=СЖПРОБЕЛЫ(" Выплаты за первый квартал ") | Удаляет пробелы в начале и в конце текста в формуле (Выплаты за первый квартал)


Функция ПРОПИСН

Делает все буквы в тексте прописными.

Синтаксис

ПРОПИСН(текст)

Текст — текст, преобразуемый в верхний регистр. Текст может быть ссылкой на столбец или текстовой строкой.

Пример

Формула | Описание (Результат)
=ПРОПИСН("итог") | Верхний регистр строки (ИТОГ)
=ПРОПИСН("Выход") | Верхний регистр строки (ВЫХОД)


Функция ДОЛЛСША

Преобразует число в текст, используя денежный формат с округлением до указанного количества десятичных знаков. Используется следующий формат: $#,##0,00_);($#,##0,00)

Синтаксис

ДОЛЛСША(число;число_знаков)

Число — число либо ссылка на столбец, содержащий число, либо формула, вычисление которой дает число.

Число_знаков — число цифр справа от десятичной запятой. Если число_знаков отрицательно, то число округляется слева от десятичной запятой. Если число_знаков опущено, то для определения числа знаков после запятой будет использован параметр языка системы.

Примечания

Функция ДОЛЛСША всегда отображает валюту США. Если необходимо использовать параметр валюты, заданный на компьютере, воспользуйтесь функцией РУБЛЬ.

Пример

Столбец1 | Формула | Описание (Результат)
1234,567 | =ДОЛЛСША([Столбец1]; 2) | Отображает первое число в денежном формате, 2 цифры справа от десятичной запятой ($1200)
1234,567 | =ДОЛЛСША([Столбец1]; -2) | Отображает первое число в денежном формате, 2 цифры слева от десятичной запятой ($1200)
-1234,567 | =ДОЛЛСША([Столбец1]; -2) | Отображает второе число в денежном формате, 2 цифры слева от десятичной запятой (($1200))
-0,123 | =ДОЛЛСША([Столбец1]; 4) | Отображает третье число в денежном формате, 4 цифры справа от десятичной запятой(($0,1230))
99,888 | =ДОЛЛСША([Столбец1]) | Отображает четвертое число в денежном формате, 2 цифры слева от десятичной запятой ($99,89)


Функция ЗНАЧЕН

Преобразует строку текста, представляющую собой число, в число.

Синтаксис

ЗНАЧЕН(текст)

Текст — текст в кавычках или ссылка на столбец, содержащий текст, который нужно преобразовать.

Примечания

  • Текст может быть в любом формате: константа, дата или время. Если текст не удовлетворяет ни одному из этих форматов, то функция ЗНАЧЕН возвращает значение ошибки #ЗНАЧ!.

Пример

Формула | Описание (Результат)
=ЗНАЧЕН("1000 р.") | Числовой эквивалент строки (1000)
=ЗНАЧЕН("16:48:00")-ЗНАЧЕН("12:00:00") | Время в числовом формате, эквивалентное 4 часам, 48 минутам, т. е. результату действия «16:48:00-12:00:00» (0,2 или 4:48)


Повышение производительности веб-таблицы данных Access

Производительность представления таблицы данных зависит от многих факторов, таких как размер списка, производительность и конфигурация сервера, сетевые условия. Данный раздел содержит несколько советов по повышению производительности представления.

Выполнение следующих процедур занимает некоторое время, поэтому их количество следует минимизировать.

  • Обновление представления, содержащего большой объем данных.
  • Перемещение или копирование больших наборов данных.
  • Заполнение большого количества ячеек путем перетаскивания маркера заполнения.
  • Изменение формулы в вычисляемом столбце.
  • Вложение больших документов.
  • Экспорт из программы Microsoft Office Excel и связь с ней.
  • Устранение большого количества ошибок.

Для повышения производительности представления выполните следующие действия.

  • Удалите из представления лишние столбцы. На странице Изменение представления таблицы данных снимите флажок Отобразить для столбцов, которые отображать не требуется. Столбцы, помеченные как Обязательный удалять не следует. Если представление не будет содержать все обязательные столбцы, добавить данные будет невозможно.
  • Примените один или более фильтров, чтобы удалить ненужные строки. Например, можно добавить в описание представления «Руководители» фильтр, скрывающий всех работников, не являющихся руководителями.

    Вдобавок к сохраняемым фильтрам можно применять фильтры во время сеанса, чтобы еще больше уменьшить объем данных в представлении. Например, при работе с данными по руководителям из Вашингтона рекомендуется скрыть строки руководителей из других штатов.

  • Можно повысить производительность путем настройки сервера SharePoint. Дополнительные сведения по повышению производительности сервера см. в справке к приложению Службы Microsoft Windows SharePoint Services 3.0. Для отображения справки к приложению Службы Windows SharePoint Services 3.0 щелкните ссылку Справка на панели инструментов окна приложения.


Сообщение: «Структура списка изменена»

Если в список вносятся изменения одновременно двумя пользователями и один из них отправил измененные данные на сервер, данные будут обновлены, а второй пользователь получит сообщение об изменении структуры списка.

В следующей таблице представлены случаи, в которых будет выдаваться такое сообщение.

Пользователь А | Пользователь Б
Удаляет столбец | Обновляет данные в том же столбце
Изменяет тип данных столбца | Добавляет или удаляет данные с несогласованными типами
Добавляет, переименовывает или удаляет столбец, изменяет тип данных в столбце или другие свойства | Изменяет вычисляемый столбец
Переименовывает список, изменяет его описание или параметры безопасности, упорядочивает столбцы, включает и отключает запрет вложений или добавляет список на панель быстрого запуска | Изменяет вычисляемый столбец
Изменяет вычисляемый столбец | Добавляет, переименовывает или удаляет столбец, изменяет тип данных в столбце или другие свойства Примечание. К моменту, когда Пользователь A начнет вносить изменения в вычисляемый столбец, Пользователь Б должен находиться на странице Добавление столбца или Изменение столбца.
Изменяет вычисляемый столбец | Переименовывает список, изменяет его описание или параметры безопасности, упорядочивает столбцы, включает и отключает запрет вложений или добавляет список на панель быстрого запуска Примечание. К моменту, когда Пользователь A начнет вносить изменения в вычисляемый столбец, Пользователь Б должен находиться на странице Параметры списка.

Конфликт, возникающий в результате изменения структуры списка, можно разрешить, обновив список. При этом внесенные изменения будут удалены, и список обновиться в соответствии с его последней версией. После обновления внесите изменения повторно.


Сообщение: «Приостановка отправки изменений»

Сообщение вызвано попыткой приостановить отправку изменений на сервер перед тем, как обновить список, перейти в другую область или внести изменения в вычисляемый столбец. Выполните одно из следующих действий.

  • Нажмите кнопку Да, чтобы остановить отправку изменений на сервер. При этом все несохраненные на сервере данные будут утеряны. Кроме того, могут возникнуть ошибки и конфликты, связанные с данными, уже отправленными на сервер.
  • Нажмите кнопку Нет, чтобы продолжить отправку изменений. Это позволит избежать конфликтов и ошибок и повторно отправить изменения на сервер.


Сообщение: «Отправка изменений, ожидающих утверждения»

Перед тем как обновить содержимое списка, внести изменения в вычисляемый столбец или выйти из представления этого списка, будет произведена попытка отправки измененных данных на сервер. Выполните одно из следующих действий.

  • Подождите, пока данные будут отправлены на сервер. Это позволит избежать конфликтов и ошибок, а также заново переслать изменения на сервер при необходимости.
  • Удалите изменения, нажав кнопку Отмена. При нажатии кнопки Отмена будет выдано сообщение о подтверждении приостановки отправки данных на сервер. Если нажать кнопку Да, несохраненные данные будут утеряны. Кроме того, могут возникнуть ошибки и конфликты, связанные с данными, уже отправленными на сервер.


Сообщение: «Отправка или обновление списка изменений, ожидающих утверждения»

Выполняется попытка обновления, выхода из списка или внесения изменений в вычисляемый столбец. Некоторые изменения, внесенные в список, не были отправлены на сервер.

Выполните одно из следующих действий.

  • Нажмите кнопку Да, чтобы дождаться отправки изменений на сервер. Если при отправке возникли конфликты или ошибки, необходимо устранить их и повторить отправку изменений.
  • Нажмите кнопку Нет, чтобы продолжить выполнение последнего действия. При этом все или часть изменений, не отправленных на сервер, будет утеряна. Кроме того, нельзя устранить ошибки и конфликты, связанные с изменениями, уже отправленными на сервер.


Сообщение в строке состояния: «Изменения, ожидающие утверждения»

Для продолжения редактирования содержимого списка не нужно ждать, пока предыдущие изменения будут отправлены на сервер. Отправка измененных данных происходит автоматически в процессе редактирования списка. Если изменения вносятся одновременно в несколько ячеек, например заполнение строк в столбце путем перетаскивания маркера заполнения, процесс отправки данных на сервер может занять несколько секунд. В этом случае в строке состояния появляется ссылка Изменения, ожидающие утверждения.

Появление ссылки не означает, что нужно отложить добавление или изменение данных до тех пор, пока предыдущие изменения не будут отправлены на сервер. Однако при попытке изменить формулу в вычисляемом столбце, а также обновить или закрыть представление будет выдано сообщение, рекомендующее подождать, пока измененные данные не будут отправлены.


Сообщение в строке состояний: «Только чтение» или «Это представление доступно только для чтения»

Выделенная ячейка, столбец, строка или все представление доступны только для чтения. Такие ячейки, столбцы или строки изменять нельзя. Если все представление доступно только для чтения, части этого представления также нельзя изменять.

Только для чтения могут быть доступны части представления или все представление. Ниже перечислены возможные причины такого ограничения доступа.

  • Определенные столбцы, такие как Кем создано и Изменено, всегда доступны только для чтения. Значения этих столбцов вводятся автоматически.
  • Внесенные в выбранную строку или столбец изменения были отправлены на сервер. Строку или столбец можно будет редактировать после сохранения изменений, если не возникнет ошибок или конфликтов.
  • В выбранной строке или столбце присутствует неустраненный конфликт. Перед изменением строки или столбца следует устранить конфликты и ошибки.
  • Настройки списка требуют утверждения содержимого, и список отображается в представлении «Все элементы».
  • Столбцы Состояние утверждения и Заметки в представлении «Мои отправленные данные» для списка, требующего утверждения содержимого, доступны только на чтение. Для редактирования этих столбцов нужно обладать правами на управление списками.
  • Вложения в список, требующий утверждения содержимого, доступны только на чтение. Вложения нельзя просматривать или редактировать ни в одном представлении.
  • Документ из текущей строки был извлечен пользователем. Столбцы этой строки нельзя редактировать, пока пользователь не вернет документ.
  • У вас отсутствуют разрешения на редактирование строки или столбца. За дополнительными сведениями обратитесь к создателю списка.


Сообщение в строке состояния: «Получение данных»

Список получает данные пакетами по 100 строк в каждом. Производится загрузка очередного пакета. Если сервер занят, процесс может занять некоторое время.

Если при загрузке данных возникнет ошибка, будет выдано сообщение. Закройте список и повторите попытку.


Многоязыковая поддержка

Подробности многоязыковой поддержки списков описаны в справке к приложению Службы Microsoft Windows SharePoint Services 3.0.

Чтобы открыть справку к приложению Службы Windows SharePoint Services 3.0, щелкните ссылку Справка на панели инструментов страницы.


Повторное преобразование строки символов

Примечание. Данная команда доступна, только если операционная система настроена и поддерживает редактор способов ввода для японского и китайского (традиционное и упрощенное письмо), или через меню «Языковые настройки Microsoft Office».

Можно вновь преобразовать строку символов, которая была введена и преобразована ранее.

  1. Установите курсор рядом с символами, которые требуется повторно преобразовать.
  2. Щелкните правой кнопкой мыши ячейку, затем в контекстном меню выберите пункт Повторить преобразование.
  3. Выберите нужный символ, затем дважды нажмите клавишу ВВОД.