 Punto Switcher 4.1

Программа Punto Switcher предназначена для автоматического переключения раскладки клавиатуры. Иногда вы забываете переключить раскладку с русской на английскую и получаете, например, «Цштвщцы» вместо «Windows» и, наоборот, не переключив раскладку клавиатуры с английского на русский, вы получаете «Hjccbz» вместо «Россия». Теперь о переключателе клавиатуры можно просто забыть, переключение будет производиться автоматически.

Punto Switcher делает много других полезных вещей, о которых вы узнаете после ознакомления со справкой.

ООО «ЯНДЕКС» 2008–2015


 Быстрый старт

Punto Switcher переключает раскладку (язык) автоматически! Просто набирайте текст, программа сама определит, когда происходит набор на русском, а когда на английском языке. Переключение может происходить сразу после набора нескольких букв, в некоторых случаях программа ожидает окончания набора слова и только после этого производит переключение. Вот несколько правил для быстрого начала работы с программой:

  • Отмена и обратная конвертация — если программа произвела нежелательную конвертацию слова, просто нажмите клавишу Break (эта клавиша используется программой по умолчанию, она обычно располагается справа — в верхнем ряду клавиатуры) или клавишу, которую вы можете назначить самостоятельно. Также при помощи Break можно в любой момент произвести конвертацию последнего набранного слова в другую раскладку.
  • Автопереключение — позволяет отключить автоматическое переключение раскладки, при этом остальные функции программы будут действовать. Цвет фона индикатора сменится на серый. Также вы можете использовать горячие клавиши.
  • Пользовательские правила переключения. Программа работает, используя принцип невозможности сочетаний некоторых букв для русского и английского языков. В русском языке, например, слово не может начинаться с буквы «Ь». Punto Switcher следит за тем, какие буквы на клавиатуре набираются и, если программа видит недопустимое сочетание, происходит переключение раскладки. Мы использовали словарь из нескольких миллионов слов для того, чтобы определить такие невозможные сочетания для русского и английского языков. Если же вдруг произойдет переключение там, где оно не требуется (или наоборот), вы можете добавить исключение в словарь Punto Switcher (подробнее см. Правила переключения).
  • Переключение в полях ввода паролей. Punto Switcher не переключает раскладку в стандартных системных окнах ввода паролей. Однако, в Internet Explorer и некоторых других программах, где используются нестандартные окна ввода паролей, раскладка может переключаться. В этом случае вы можете в конце ввода пароля нажать на любую курсорную клавишу, то переключения не произойдёт. Это же правило можно использовать не только с паролями, а везде, где переключение не нужно.


 Что нового в версии 4.1

  • Полная поддержка Windows 10.

  • Усовершенствованная обработка опечаток, когда случайно нажаты близко соседствующие клавиши.

  • Исправлены проблемы с зависанием в программе Microsoft Outlook.

  • Решены трудности с переключением в ручном режиме в программах 1С.

  • Стабилизирована работа в чатах Skype.


 Команды меню

По нажатию правой кнопки мыши на значок программы:

  • Настройки — вызов окна с настройками Punto Switcher.
  • Автопереключение — временная отмена/разрешение автоматического переключения раскладки, при этом остальные функции программы продолжают работать.
  • Звуковые эффекты — включение или выключение всех звуков. Необходимы при запуске игр, записи звука на компьютер и т.д.
  • Буфер обмена — работа с буфером обмена:

    Изменить раскладку — перевод буфера обмена из символов латиницы в кириллицу и наоборот;
    Транслитерировать     — представление кириллического текста буфера обмена символами латиницы;
    Проверить орфографию     — проверка орфографии буфера обмена средствами MS Word. Исправленный текст помещается в буфер обмена;
    Посмотреть историю — просмотр истории буфера обмена.

  • Дополнительно — открывает пункты меню:

    Вести дневник     — активизация дневника Punto Switcher;
    Открыть дневник     — вызов программы просмотра дневника;
    Список автозамены     — вызов списка используемых пользователем автозамен;
    Отправить выделенный текст в Twitter — посылка выделенного текста в Twitter.
    Системные свойства — вызов языковой панели Windows.
    Преобразование числа в текст — замена цифровой формы числа на словесную.
  • Найти — открывает пункты меню поиска:

    В Яндексе     — поиск в Яндексе выделенного на экране текста;
    Определение в Яндекс.Словарях — поиск выделенного на экране текста в Яндекс.Словарях;
    Перевод в Яндекс.Словарях — перевод слова или выражения с иностранного языка на русский язык или наоборот в Яндекс.Словарях;
    Адрес в Яндекс.Картах — поиск географического названия в Яндекс.Картах;
    Товар в Яндекс.Маркете — поиск товара в Яндекс.Маркете;
    Новость в Яндекс.Новостях — поиск новостей в Яндекс.Новостях;
    Изображение в Яндекс.Картинках — поиск изображений и фотографий в Яндекс.Картинках;
    В русской Википедии — поиск определения выделенного на экране слова в русской Википедии;
    В английской Википедии     — поиск определения выделенного на экране слова в английской Википедии.
  • О Punto Switcher — вывод информации о версии и годе выпуска программы, ссылка “Обратная связь” для отправки письма разработчикам.
  • Справка — отображение данной справки.
  • Выйти — полное завершение работы программы и всех её функций.

По нажатию левой кнопки мыши на значок программы:

  • Список автозамены (отключаемый) — вставка любого слова из автозамены в позицию курсора.
  • Список языков — переключение языка в текущей программе.
  • Выключить/включить — выключить/включить автоматическое переключение раскладки.


 Список автозамены

Список автозамены позволяет быстро заполнять формы в браузере, таблицы Excel и другие документы с наличием часто повторяющихся фрагментов текста.

Введите нужные фрагменты текста в список автозамены и вызовите его. Для этого вам нужно самостоятельно назначить комбинацию клавиш. Поместите курсор в то место, куда вы хотите вставить текст, и щелкните по нужному пункту списка.

Опция «Прозрачный список» позволяет самостоятельно устанавливать прозрачность окна.


 Замена стандартного переключателя

Punto Switcher выводит на панель задач индикатор раскладки клавиатуры. Это полнофункциональный индикатор, по виду аналогичный стандартному. Вы можете убрать из системного лотка стандартный индикатор, воспользовавшись панелью управления.

Индикатор имеет серый фон, когда Punto Switcher выключен. Красный цвет индикатора сигнализирует о возможной опечатке. Возможны небольшие отличия от показаний стандартного индикатора при щелчках в области системного лотка (System Tray), однако, это вызвано не ошибками в Punto Switcher, а особенностями реализации стандартного переключателя раскладки.

Punto Switcher может показывать плавающий индикатор, который можно поместить в любое место экрана. Плавающий индикатор может быть закреплен на экране. Для этого щелкните по нему правой кнопкой мыши и выберите «Закрепить индикатор».


 Конвертация выделенного текста

Чтобы конвертировать текст, выделенный на экране, нажмите:

  • Shift + Break (Break или назначенную вами комбинацию клавиш) — выполнится перевод выделенного текста в другую раскладку (Русский <-> Английский);
  • Alt + Break (или назначенную вами комбинацию) — выполнится принудительная инверсия регистра символов выделенного фрагмента («пРИВЕТ» <-> «Привет»);
  • Alt + Scroll Lock — выполнится транслитерация выделенного текста («Привет» <-> «Privet»).
  • Вы также можете заменять на текст числа и денежные суммы, написанные цифрами (247-23 преобразуется в "Двести сорок семь рублей 23 копейки", 458 в "Четыреста пятьдесят восемь"). Для этого назначьте собственное сочетание клавиш.

См. также Горячие клавиши.


 Полезные советы

 | Совет
1. | Чтобы эффективно использовать Punto Switcher, настройте и используйте горячие клавиши.
2. | Самый быстрый способ исправления или конвертации уже набранного фрагмента текста — выделить его с помощью стрелок, удерживая Ctrl и Shift, а затем нажать горячие клавиши.
3. | Добавьте в автозамену слова, которые вы часто пишете — электронные адреса, адреса сайтов, подписи, названия фирм и т.д. После этого вы можете либо использовать сокращённые варианты этих слов, либо по горячей клавише выводить меню, в котором они будут содержаться, и вставлять длинные фразы одним щелчком мыши.
4. | Вы можете убрать стандартный индикатор языка, щёлкнув по нему правой кнопкой мыши, выбрав «Свойства» и сняв флажок «Отображать индикатор языка на панели задач». Punto Switcher способен полностью заменить его.
5. | Переключение раскладки по одной клавише очень удобно, например, по «правому Ctrl». Включить такую возможность можно на вкладке Общие.
6. | Вы можете убрать индикатор Punto Switcher с панели задач, освободив место, или установить плавающий индикатор.
7. | Если вы стремитесь сократить расход памяти и ускорить срабатывание программы, можете отключить звуки.
8. | Чтобы настроить правила транслитерации Punto Switcher для себя, отредактируйте текстовые файлы: translit-en.dat и translit-ru.dat, которые находятся в папке Data.
9. | При навигации по справке выделяйте пункты курсорными клавишами и нажимайте Enter для их отображения.
10. | Если озвучивание клавиш мешает вам в некоторых программах, вы можете временно выключить все звуки.
11. | Для поиска определения или перевода слова, вы можете самостоятельно назначить горячие клавиши. По умолчанию горячая клавиша Windows+S позволяет осуществлять поиск в Яндексе любого выделенного на экране текста.


 Возможные проблемы и их решение

 | Проблема | Причина | Решение
1. | Punto Switcher блокирует некоторые клавиши на клавиатуре. | При настройке клавиатурных сокращений эти клавиши или их комбинации были заданы без служебных клавиш «Ctrl», «Alt», «Shift» или «Windows». | Настройте горячие клавиши.
2. | Windows 8 и 10. Punto Switcher не работает в программе, запущенной с правами администратора. | В системе Windows 8 и 10 программы, запущенные без прав администратора, могут неполноценно работать с программами, запущенными с правами администратора. По умолчанию Punto Switcher запускается без прав администратора. | Пожалуйста, запускайте Punto Switcher, включив опцию (меню «Настройки» -> «Общие») «Запускать с правами администратора».
3. | Конвертация выделенного текста не работает в некоторых программах. | Программы не поддерживают копирование в буфер обмена по Ctrl+C и вставку по Ctrl+V. | Если возможно, настройте программу, которую вы используете, для работы с данными комбинациями клавиш.
4. | Переключение раскладки происходит не всегда или не исправляется первая буква. | Конфликт при работе с другими программами, может возникать из-за несовпадения алгоритмов при работе с клавиатурой. | В случае конфликта с другими программами напишите разработчикам этих программ и разработчикам Punto Switcher. Обновите программу с официального сайта.
5. | Программа некорректно работает в некоторых приложениях. | Изначально Punto Switcher не был ориентирован на работу в консольных приложениях, возможны проблемы при работе в Windows 2012. Замечены проблемы при работе с некоторыми версиями программ: IntelliJ IDEA, PhpStorm, Synergy, QIP, Miranda, AutoCad. | Мы постоянно работаем над решением старых и новых проблем. Проблемы, порождаемые программами, к разработке которых мы не имеем прямого отношения, требуют некоторого времени.
6. | Punto Switcher часто исправляет сокращения, которые вы используете. | Отсутствие этих сокращений в словаре. | Попробуйте занести их в словарь (меню «Настройки» -> «Правила переключения») и послать разработчикам. Зайдите на сайт и скачайте последнюю версию Punto Switcher. Также можно включить опцию «Исправлять аббревиатуры».
7. | Другая проблема. |  | Напишите в клуб Punto Switcher Punto Switcher.


 Проверка обновления

Мы понимаем, что нет предела совершенству, и надеемся постоянно улучшать правила и саму программу. Для этого мы предусмотрели возможность обновления Punto Switcher.

Для проверки наличия новой версии программы мы настоятельно рекомендуем использовать опцию Проверка обновления. После установки программы эта опция включена по умолчанию.


 Настройки

Чтобы открыть диалог «Настройки», щелкните по индикатору правой кнопкой мыши и выберите пункт меню «Настройки». В левой половине окна находится дерево, при выборе ветвей которого отображаются различные вкладки диалога. Параметры по умолчанию оптимальны для большинства пользователей, однако, вы можете настроить Punto Switcher под свои потребности. Мы постарались сделать процесс настройки максимально простым.


 Настройки — Общие

Вкладка Основные:

 Запускаться при старте — если флажок установлен, то программа будет запускаться вместе с Windows.

Автопереключение — когда эта опция включена, программа производит автоматическое переключение раскладки клавиатуры.

Запускать с правами Администратора — эта опция позволяет запускать Punto Switcher так, чтобы он работал в программах запущенных с правами Администратора.

Проверять обновления — при включении, программа периодически, проверяет наличие обновления и, если оно найдено, предлагает загрузить новую версию.

Показывать плавающий индикатор — при выборе этой опции индикатор текущей раскладки можно будет перемещать мышкой по экрану. Установите его в удобное положение, и при следующем запуске программы он будет находиться там же. Чтобы не дублировать индикаторы, выводимые Punto Switcher, вы можете отключить опцию — Показывать значок в системном лотке. Плавающий индикатор может быть закреплен на экране, для этого щелкните по нему правой кнопкой мыши и выберите «Закрепить индикатор».

Скрывать плавающий индикатор после смены раскладки — при установленном флажке плавающий индикатор будет виден в течение двух секунд после смены раскладки. Эта опция поможет вам освободить дополнительное экранное пространство.

Изменять цвет значка при опечатках — при включении данной опции Punto Switcher будет окрашивать свой значок в ярко-красный цвет и производить звук, когда, по его мнению, произошла опечатка (не работает при замене языкового индикатора флагами стран). Это не замена проверки орфографии, и будет обнаружена далеко не каждая опечатка, но если Punto Switcher всё же её обнаружил, то она с большой вероятностью имеет место.

Сделать значок в виде флагов стран — после выбора этой функции в системном лотке в качестве индикатора клавиатурной раскладки будут использоваться флаги соответствующих стран.

Всегда показывать флаги в полную яркость — если выбран показ индикатора раскладки в виде флагов, флаги будут отображаться в полную яркость даже тогда, когда автопереключение отключено.

Отключать горячие клавиши при отключении автопереключения — если вам мешает то, что горячие клавиши срабатывают, когда выключена автокоррекция языка (например, в играх), включите эту опцию. Punto Switcher будет «отключаться» полностью.

Показывать полезные советы — при включении данной опции через минуту после запуска Punto Switcher будет показана всплывающая подсказка с полезным советом.

Вкладка Дополнительные:

Исправлять аббревиатуры — эта опция может пригодиться, если вы часто вводите слова-аббревиатуры или сокращения, и Punto Switcher напрасно переключает раскладку. Альтернативный путь — указать эти слова как исключения или послать их разработчикам (возможно, они добавят их в словарь следующих версий программы).

Исправлять две заглавные буквы в начале слова — при наборе такого слова, в том числе и в другой раскладке, оно будет автоматически исправлено. Особые случаи, такие как СПб, исправляться не будут.

Исправлять случайное нажатие Caps Lock — если включен Caps Lock и набрано слово со строчной первой буквой и прописными остальными, оно будет автоматически исправлено.

Отключить кнопку Caps Lock — если пользователь не использует Caps Lock, возможность отключения этой клавиши.

Использовать Scroll Lock как Caps Lock — если вы выберете переключение раскладки по Caps Lock, то Scroll Lock сможет заменить её.

Исправлять раскладку при работе с меню, содержащим горячие клавиши — при нажатии клавиши Alt, если в окне есть стандартное меню, будет проанализирован язык символов меню, и на основании анализа будет включена соответствующая раскладка. Опция полезна для ускорения доступа к меню по горячим клавишам. Если в программе разработчики использовали нестандартное меню, опция работать не будет.

Показывать окно с результатами конвертации буфера — при установленном флажке результат конвертирования буфера обмена будет показываться в отдельном всплывающем окне.

Следить за буфером обмена — при включении опции Punto Switcher запоминает 30 последних текстов буфера обмена. Позже они могут быть выбраны из меню и вставлены в приложение. Назначьте горячую клавишу для показа меню истории буфера обмена.

Сохранять историю буфера обмена после перезагрузки Windows — при включении этой опции Punto Switcher запоминает содержимое буфера обмена, которое сохраняется даже после перезагрузки Windows.

Показывать всплывающие подсказки — включает вывод всплывающих подсказок при автозамене и коррекции случайного нажатия Caps Lock или коррекции двух первых прописных букв.

Запятая по двойному нажатию клавиши Пробел — выбор этой функции позволяет использовать двойное нажатие клавиши Пробел, для постановки запятой. Это сделано для удобства набора, так как запятая в русской раскладке ставится с использованием клавиши Shift.

Переключение раскладки:

Переключение раскладки. Переключать по... — раскладка клавиатуры будет переключаться при нажатии на клавиши, которые можно выбрать из списка. Поддерживаются обе Ctrl и обе Shift, а также Caps Lock, Alt и Space. Раскладку переключает лишь короткое нажатие, вы можете удерживать клавишу, чтобы избежать переключения (исключение — Caps Lock).

Только русский/английский — при использовании нескольких раскладок, основными из которых являются русская и английская, вы можете сделать так, чтобы по выбранной клавише происходило переключение только между этими двумя раскладками, а, к примеру, по Ctrl + Shift выполнялся перебор всех раскладок.

Единая раскладка — для всех приложений в системе раскладка клавиатуры будет одинаковой, такой, какой вы её последний раз выбрали при помощи Punto Switcher. Опция работает лишь при переключении раскладки по одной клавише. При активизации приложения Punto Switcher включит требуемую раскладку за вас.

Дополнительно переключать по... — включение режима «Левый Shift — русская, правый Shift — английская раскладка» и т.п. Другие раскладки в текущей версии не поддерживаются.


 Настройки — Горячие клавиши

Все горячие клавиши являются полностью настраиваемыми, вы можете задать любую клавишу в комбинации с Shift, Ctrl, Alt или Windows. Отключить любую комбинацию можно, удалив содержимое поля ввода комбинации.

  • Отменить конвертацию раскладки — отмена выполненной конвертации текста. По умолчанию для этого используется клавиша Break, если вам удобнее использовать другую клавишу, назначьте её самостоятельно.
  • Сменить раскладку выделенного текста — перевод раскладки выделенного на экране текста из символов английского языка в русские и наоборот. По умолчанию используется комбинация клавиш Shift+Break.
  • Сменить регистр выделенного текста — перевод выделенного на экране текста из символов верхнего регистра в нижний и наоборот. По умолчанию используется комбинация клавиш Alt+Break.
  • Транслитерировать выделенный текст — перевод кириллических символов, выделенных на экране, в латиницу по правилам, хранящимся в файле translit.dat. Вы можете редактировать его при необходимости изменения правил транслитерации. По умолчанию используется комбинация клавиш Alt+Scroll Lock.
  • Преобразовать число в текст — замена выделенного числа или денежной суммы, написанных цифрами, на число или сумму прописью. Функция пригодится тем, кто работает с платёжными документами. Позволяет заменить, например, 247-23 на "Двести сорок семь рублей 23 копейки" или 457 — на "Четыреста пятьдесят семь", не вписывая текст вручную. Назначьте для этой функции собственную комбинацию клавиш.
  • Включить / выключить автопереключение раскладки — эта комбинация эквивалентна команде «Включить / выключить» в меню.
  • Включить / выключить звуковые эффекты — иногда включенное озвучивание клавиш может мешать вам, к примеру, в играх. Нажатие выбранных сочетаний клавиш временно выключит все звуки. Повторное нажатие клавиш включит звуки.
  • Вставка текста без форматирования — возможность произвести вставку копируемого текста, очищенного от форматирования. По умолчанию используется комбинация клавиш Ctrl+Win+V.
  • Открыть настройки Punto Switcher — быстрый доступ к окну настроек программы.
  • Открыть настройки автозамены — вызов окна для работы с автозаменами. Использование автозамен позволяет сэкономить значительное время при выполнении рутинных функций.
  • Показать / скрыть список автозамены — аналог команды Список быстрой вставки в главном меню.
  • Показать меню вставки автозамены — вывод меню, содержащего полные фразы, введённые вами в диалоге Автозамена. Выберите нужную фразу, и она вставится в текст.
  • Добавить выделенный текст в автозамену — запись выделенного текста или фразы в Автозамену. Опция полезна для тех, кто активно использует автозамену.
  • Показать историю буфера обмена — вывод меню, каждая строка которого соответствует тексту буфера обмена, который запомнил Punto Switcher. Запоминается 15 последних текстов. Выберите строку для вставки ее в приложение.
  • Сменить раскладку буфера обмена — перевод буфера обмена из символов английского языка в русские и наоборот.
  • Транслитерировать текст в буфере обмена — перевод содержимого буфера обмена в латиницу или наоборот.
  • Показать дневник — вызов программы просмотра дневника.
  • Записать текст из буфера обмена в Дневник — запись в Дневник содержимого буфера обмена.
  • Записать выделенный текст в дневник — запись в Дневник выделенного текста. Опция полезна для сохранения текстовой информации в одном месте. Сохранение текста в дневник сопровождается кратковременным изменением цвета индикатора на зеленый (не поддерживается в случае использования значков в виде флагов).
  • Свернуть активное окно — возможность назначить клавишу для сворачивания активного окна.
  • Развернуть / восстановить активное окно — возможность назначить клавишу для разворачивания и восстановления активного окна.
  • Найти в Яндексе — поиск выделенного на экране текста в Яндексе. Вы можете самостоятельно назначить для этого комбинацию клавиш. В случае если на экране нет выделенного текста, то по нажатию назначенной пользователем горячей клавиши будет вызвано окно для поиска. Результаты поиска будут показаны в новом окне вашего дефолтного браузера.
  • Найти определение в Яндекс.Словарях — поиск выделенного на экране текста в Яндекс.Словарях.
  • Найти перевод в Яндекс.Словарях — перевод выделенного на экране слова или словосочетания в Яндекс.Словарях.
  • Найти адрес в Яндекс.Картах — поиск выделенного на экране адреса или географического названия в Яндекс.Картах.
  • Найти товар в Яндекс.Маркете — поиск выделенного слова в товарах на Яндекс.Маркете.
  • Найти новость в Яндекс.Новостях — поиск выделенного на экране слова в Яндекс.Новостях.
  • Найти изображение в Яндекс.Картинках — поиск выделенного на экране слова в изображениях на Яндекс.Картинках.
  • Найти в русской Википедии — поиск выделенного на экране слова или термина в русской Википедии.
  • Найти в английской Википедии — поиск выделенного на экране слова или термина в английской Википедии.
  • Отправить выделенный текст в Twitter — посылка выделенного на экране текста в Twitter.


 Настройки - Правила переключения

Правила переключения необходимы для нормальной работы программы. Именно на правилах невозможности тех или иных сочетаний букв для русского и английского языков программа совершает переключение раскладки. Пользователю предоставляется возможность самостоятельно создавать правила переключения, а также вносить исключения в существующие правила. Внимание. Правило вводимое пользователем становится главным, только в случае если оно не вступает в конфликт с базовыми правилами Punto Switcher. Если вы столкнулись с такой ситуацией, пожалуйста, пришлите нам несрабатывающее правило support@punto.yandex.ru — и мы внесем его в исключения.

  • Добавить — вызывает окно для создания правил переключения или добавления исключений. В нём можно указать, на каких словах нужно переключать раскладку, а на каких не нужно.
  • Предлагать добавить правило после нескольких отмен подряд — если выбрана эта опция, то после заданного пользователем числа отмен автопереключения, ему будет предложено внести это сочетание или слово в пользовательский словарь.

Введите слово, которое вызвало проблемы, и укажите необходимые значения. Будьте внимательны, желательно выделить из слова характерную часть без окончания, суффикса и т.д. и добавить именно это сочетание. Подумайте, может ли это сочетание быть в начале слова, в произвольном месте. Лучшее решение — послать слово, вызвавшее проблему, разработчикам, чтобы оно было добавлено в словарь следующих версий программы.

  • Содержать данное сочетание букв — позволяет установить переключение в случаях, когда сочетание букв содержится в любом месте данного слова.
  • Начинаться с данных букв — позволяет установить переключение только в случаях, когда комбинация букв располагается в начале слова.
  • Совпадать с данным сочетанием — позволяет установить переключение исключительно в случаях, когда комбинация букв точно совпадает с указанным сочетанием.
  • Учитывать регистр — при создании такого правила будут строго учитываться прописные и строчные буквы.

Пункт Действие:

  • Переводить слово в другую раскладку — если набираемое слово несет в себе сочетание букв, требующих переключения раскладки, то включите эту опцию, если же это сочетание допустимо, то выключите её.
  • Не переводить слово в другую раскладку — если набираемое слово несет в себе допустимое сочетание букв, не требующих переключения раскладки, то включите эту опцию.
  • Отправить разработчикам — при установленном флажке при нажатии на кнопку "Добавить" запустится почтовая программа. Вам останется только вставить текст письма из буфера обмена и отправить письмо разработчикам.


 Настройки — Программы-исключения

В список программ-исключений можно поместить программы, в которых вы всё время отключаете Punto Switcher. Когда одна из таких программ станет активной, Punto Switcher отключится автоматически. Вы можете задавать программы по файлу приложения, заголовку окна или по папке с программами — для этого выберите соответствующую вкладку.

На вкладке «По файлу приложения» при нажатии кнопки «Добавить» появляется всплывающее меню. Кнопка «Обзор» позволяет выбрать нужную программу в стандартном диалоге. Пункт «Запущенные приложения» содержит список текущих процессов, что удобно при добавлении уже запущенной программы.

На вкладке «По заголовку окна» при нажатии на кнопку «Добавить» появляется новый пункт в списке заголовков окон. Введите требуемый заголовок окна или его часть, и, когда окно с таким заголовком станет активным, Punto Switcher выключится автоматически. Регистр символов в заголовке окна учитывается.

На вкладке «По папке с программами» при нажатии на кнопку «Добавить» появляется стандартный диалог, позволяющий выбрать нужную папку. После этого автопереключение Punto Switcher перестанет работать в программах, находящихся в выбранной пользователем папке.

Кнопка «Изменить» позволяет отредактировать выделенный пункт списка.

Кнопка «Удалить» позволяет удалить программу из списка программ-исключений для Punto Switcher.


 Настройки — Устранение проблем

Если вы занимаетесь активным редактированием текстов, Punto Switcher иногда может переключать раскладку при исправлении окончаний. В этом случае мы советуем установить флажки в строках с клавишами, использование которых во время редактирования будет отключать переключение раскладки. Если непосредственно перед вводом слова были нажаты эти клавиши, Punto Switcher не будет переключать раскладку. Однако, возможно снижение общего показателя качества автоматического переключения. Выберите то, что вам удобнее.

  • Учитывать ввод только в русской и английской раскладках — если вы используете какие-либо раскладки клавиатуры помимо «Русский» и «Английский, США», то при наборе слов на других языках Punto Switcher может некстати переключать раскладку. Выбор этой опции заставляет Punto Switcher отслеживать ввод только на двух основных для него языках.
  • Автопереключение только между русской и английской раскладкой — если кроме раскладок «Русский» и «Английский, США», вы используете какие-либо иные раскладки, то при наборе слов на русском или английском языках может происходить неправильное переключение. Выбор этой опции позволяет Punto Switcher переключаться только между двумя основными для него языками.
  • Не переключать раскладку по клавишам «Tab» и «Enter» — включите эту опцию, если у вас Punto Switcher вызывает двойное нажатие Enter или есть проблемы с функцией «Автотекст» в WinWord.
  • Не взаимодействовать с программами-исключениями — включите эту опцию, если вы замечаете, что выключенный Punto Switcher сильно нагружает процессор, например, в играх с интенсивным использованием клавиатуры. Учтите, что горячие клавиши конвертации текста в этом случае работать не будут.
  • Хранить данные пользователя в папке Punto Switcher — если вы хотите хранить свои персональные данные: дневник, исключения, автозамены в папке программы, включите эту функцию. Изменения вступят в силу после перезагрузки.


 Настройки — Автозамена

Здесь вы можете задать сокращения, которые Punto Switcher будет «разворачивать» за вас. К примеру, «СНП» можно будет автоматически преобразовывать в «С наилучшими пожеланиями». При наборе сокращённого слова рядом появится подсказка, показывающая полную фразу (ее появление можно отключить). Слова могут разворачиваться по нажатию Enter, Tab или пробел.

Флажок «Заменять при наборе в другой раскладке» активизирует автозамену, даже если вы набираете сокращение на другом языке.

Флажок «Показывать список в меню Punto Switcher на панели задач» позволяет показать список полных фраз по щелчку левой кнопки мыши на значке программы. При этом вы можете вставить длинную фразу в текст одним щелчком мыши. Для этого также можно воспользоваться горячей клавишей.

Флажок «Запоминать позицию курсора», в окне "Новое правило автозамены", даёт возможность указать, где будет находиться курсор после автозамены.


 Настройки — Звуки

Вы можете озвучить каждое из событий Punto Switcher. Поддерживается как воспроизведение WAV-файлов через звуковую карту, так и воспроизведение звуков разной частоты через встроенный динамик.

  • Нажатие клавиш (русский, английский) — часто при использовании ноутбука можно заметить, что клавиши не производят привычного клика, как это бывает на больших клавиатурах. Если эта опция включена, вы услышите негромкий клик при каждом нажатии на клавишу. Можно назначить различные звуки для русской и английской раскладок, можно задать и один звук, выбрав один и тот же файл.
  • Автопереключение раскладки — при установленном флажке, когда вы печатаете, не глядя на экран, и происходит автоматическое переключение раскладки, вы слышите сигнал переключения.
  • Опечатка — при включении данной опции Punto Switcher будет издавать звуковой сигнал тогда, когда, по его мнению, произошла опечатка. Это не замена проверке орфографии, и звуковой сигнал будет издаваться не при каждой опечатке, но если вы всё же его услышали, то опечатка наверняка имеет место.
  • Переключение на русский — звуковой сигнал при ручной активизации русской раскладки.
  • Переключение на английский — звуковой сигнал при ручной активизации английской раскладки.
  • Отмена автопереключения — звуковой сигнал при нажатии Break или другой, назначенной пользователем, клавиши.
  • Конвертация выделенного текста — звуковой сигнал при конвертировании выделенного текста.
  • Конвертирование буфера обмена, исправление двух прописных букв, исправление случайного нажатия Caps Lock и др. — звуковой сигнал при данных операциях.
  • Исправление двух прописных букв в начале слова — звуковой сигнал сообщает о произведенном исправлении.
  • Исправление случайного нажатия Caps Lock — звуковой сигнал в момент исправления случайного нажатия клавиши Caps.
  • Инверсия регистра выделенного текста — звуковой сигнал производится в момент изменения регистра.
  • Автозамена — в момент вставки текста по Автозамене программа воспроизводит заданный пользователем звук.
  • Транслитерация выделенного текста — звуковой сигнал во время транслитерации.
  • Нажатие Backspace — звуковой сигнал в момент удаления текста клавишей backspace.
  • Доступна Автозамена — когда на определенную комбинацию букв имеется автозамена, программа будет производить звук.

Punto Switcher поставляется с небольшим набором звуков. При желании вы можете поэкспериментировать со стандартными звуками, поставляемыми с Windows.

Ждем от наших креативных пользователей новых звуковых схем!


 Настройки — Дневник

Пользователю предоставляется возможность самостоятельно настроить работу дневника по некоторым важным параметрам.

  • Вести дневник — опция включает запись набираемых на клавиатуре текстов в дневник Punto Switcher (аналогична одноименной опции в меню значка программы «Дополнительно» —> «Вести дневник»).
  • Установить пароль — пользователь может установить пароль для ограничения доступа к дневнику. После установления пароля, дневник шифруется и открыть его можно только с помощью пароля. Длина пароля ограничена 32 символами. Пожалуйста, не теряйте пароль, мы не сможем его восстановить! Вы можете включить автосохранение в Дневнике содержимого буфера обмена, включив опцию — Автоматически сохранять содержимое буфера обмена.
  • Не сохранять записи короче ... слов — возможность фильтрации содержимого дневника. Как правило, одиночные слова и короткие фразы не содержат осмысленной информации. Если запись в дневнике (записью считаются слова, набранные без переключения в другое окно) содержит меньшее количество слов, чем указано в настройках, она не будет внесена в дневник. По умолчанию в дневник не вносятся одиночные слова (менее двух). Это предотвращает запись паролей в дневник.
  • Удалять записи старше ... дней — пользователь может установить срок хранения записей, после которого всё записанное в дневник будет удаляться автоматически. Это сделано в целях безопасности и сохранения приватности данных пользователя.
  • Вести дневник в программах-исключениях — ведение Дневника в тех программах, которые заданы в списке исключений.
  • Открыть дневник — эта опция вызывает программу просмотра.
  • Очистить дневник — удаление всех записей из дневника. Если дневник запаролен, то программа потребует введения пароля.


 Дневник Punto Switcher

В Punto Switcher встроена возможность ведения дневника, который сохраняет информацию, набираемую на клавиатуре. Дневник создан с целью помочь вам в организации, хранении и упорядочивании личной информации.


 Назначение дневника

Дневник Punto Switcher разработан с целью помочь вам сохранить и упорядочить текстовую информацию, которую вы ежедневно набираете на клавиатуре и не сохраняете. Это может быть полезно для цитирования в будущем: забытого разговора, переписки в форумах и чатах, восстановления текста после сбоя компьютера или необратимого изменения документа и т.д.

Предоставляются следующие возможности:

  • Запись в дневник информации, набираемой на клавиатуре;
  • Запись выделенного текста в дневник нажатием горячих клавиш;
  • Выборочный просмотр и поиск информации за любой период;
  • Удаление записей.

Дневник может быть отключен по желанию пользователя. Пользователь сам выбирает, с какого количества слов дневник будет запоминать текст и вносить его в Дневник. Если вы не хотите, чтобы набираемые вами пароли попали в дневник, не меняйте параметры дневника, устанавливаемые по умолчанию. В этом случае в дневнике не сохраняются одиночные слова, а сохраняется только связанный текст.


 Работа с дневником

При включении дневника Punto Switcher отслеживает ввод текста с клавиатуры и записывает его. Каждая запись включает имя приложения, в котором был набран текст, и дату набора. Заголовок окна и другие данные не включаются в дневник для обеспечения приватности.

Для включения дневника установите флажок «Вести дневник» в меню или одноименный флажок на вкладке «Дневник» в «Настройках».

Опция «Не сохранять записи короче ... слов» предназначена для фильтрации содержимого дневника. Как правило, одиночные слова и короткие фразы не содержат осмысленной информации, а часто являются паролями. Если запись дневника (слова, набранные без переключения в другое окно) содержит меньшее количество слов, чем указано в настройках, она не будет внесена в дневник. По умолчанию в дневник не вносятся одиночные слова (менее двух).

Опция «Удалять записи старше ... дней» предназначена для установления срока хранения записей, после которого всё записанное в дневник будет удаляться автоматически. Это сделано в целях безопасности и сохранения приватности данных пользователя.

Кнопка «Открыть дневник» вызывает программу просмотра.

Программа просмотра позволяет перемещаться по дневнику по датам. Выделив диапазон дат, вы можете просмотреть все записи за этот период и произвести поиск слова в указанном диапазоне дат.

Назначение кнопок программы просмотра:

  • «Сохранить как» — сохранение текущей информации, показанной в окне просмотра, в файл формата RTF.
  • «Копировать» — копирование текста, выделенного на экране.
  • «Удалить» — удаление из дневника информации, которая в данный момент показана в окне просмотра.
  • «Найти» — вызов стандартного окна поиска текста в текущем документе.
  • «Выбрать период» — вызов диалога для установления диапазона дат для просмотра или удаления записей.
  • «Календарь» — вызов календаря для поиска нужного дня, месяца и года.
  • «Кнопки перемещения по дневнику» — последовательное листание дней и просмотр записей дневника.
  • «Справка» — вызов справки по работе с дневником.

Для сохранения в Дневнике любого текста из сети интернет или из документов вы можете назначить горячую клавишу Записать выделенный текст в дневник.


 Техническая поддержка

Если во время работы программы Punto Switcher возникают проблемы, пожалуйста, ознакомьтесь сначала с данной справкой. Кроме того, на странице «Вопросы и ответы» вы сможете найти ответы на наиболее часто задаваемые вопросы.

У программы есть официальный клуб, где вы можете непосредственно пообщаться с другими пользователями и разработчиками Punto Switcher.
Для устранения проблемы нам может понадобиться следующая информация:

  • Номер версии Punto Switcher (узнать её можно кликнув правой кнопкой по значку Punto -> О Punto Switcher).
  • Описание проблемы
  • Текст сообщения об ошибке, появляющийся на экране
  • Тип компьютера и процессора
  • Версия Windows
  • Снимок экрана с сообщением об ошибке (желательно)

Совершенствование программы Punto Switcher базируется исключительно на обратной связи с пользователями, мы ждём ваших отзывов, советов и пожеланий.

ООО «ЯНДЕКС» 2008–2015