Консоль ММС (Microsoft Management Console)

Консоль MMC (Microsoft Management Console)

Консоль MMC (Microsoft Management Console) группирует средства администрирования, которые используются для администрирования компьютеров, служб, других системных компонентов и сетей.

  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Сведения общего характера см. в разделе Основные понятия.
  • Сведения о специальных возможностях см. в разделе Специальные возможности MMC.
  • Инструкции по устранению неполадок см. в разделе Устранение неполадок MMC.


Инструкции

  • Открытие MMC и сохраненных файлов консолей
  • Создание файла консоли MMC
  • Изменение сохраненного файла консоли MMC
  • Работа с MMC и сохраненными файлам консолей
  • Настройка политики для MMC и оснасток


Открытие MMC и сохраненных файлов консолей

  • Открытие консоли MMC
  • Открытие сохраненной консоли MMC для локального компьютера
  • Открытие сохраненной консоли MMC для удаленного компьютера
  • Создание ярлыка на рабочем столе для открытия MMC


Открытие консоли MMC

Чтобы открыть консоль MMC

  • Выполните одно из следующих действий.
    • Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc и нажмите кнопку OK.
    • В командной строке введите mmc и нажмите клавишу ENTER.

Полный синтаксис командной строки для MMC приводится ниже:

mmc путь\имя_файла.msc [/a] [/64] [/32]

путь\имя_файла.msc

Запускает MMC с открытием сохраненной консоли. Необходимо указать полный путь и имя файла для сохраненной консоли. Если файл консоли не указан, MMC открывает новую консоль.

Для создания командных строк и ярлыков, которые не зависят от явного расположения файлов консоли, можно использовать переменные среды. Например, если путь к файлу консоли включает системную папку (например, mmc c:\winnt\system32\console_name.msc), то для указания пути можно использовать переменную %systemroot%: (mmc %systemroot%\system32\console_name.msc). Это полезно при делегировании заданий пользователям, работающим на разных компьютерах.

/a

Открывает сохраненную консоль в авторском режиме. Используется для внесения изменений в сохраненные консоли. Когда консоли открываются с этим параметром, они открываются в авторском режиме, независимо от режима, используемого по умолчанию. При этом установки режима по умолчанию для файлов не меняются; при пропуске этого параметра MMC открывает файлы консолей в соответствии с их режимами по умолчанию.

/64

Открывает 64-разрядную версию MMC (MMC64). Этот параметр следует использовать только при выполнении 64-разрядной операционной системы Microsoft. Дополнительные сведения см. в разделе Выполнение 32- и 64-разрядных оснасток в Win64.

/32

Открывает 32-разрядную версию MMC (MMC32). При выполнении 64-разрядной операционной системы Microsoft можно выполнять 32-разрядные оснастки, открыв MMC с этим параметром командной строки. Дополнительные сведения см. в разделе Выполнение 32- и 64-разрядных оснасток в Win64.

Примечания

  • После открытия MMC или файла консоли любая существующая консоль открывается с помощью команды Открыть из меню Консоль.
  • С помощью командной строки можно создавать ярлыки для запуска MMC и работы с сохраненными консолями. Команда для командной строки работает в окне команды Выполнить из меню Пуск, в любом окне командной строки, в ярлыках, в пакетных файлах и программах, вызывающих такие команды.
  • По умолчанию оснастки — 32-разрядные.

См. также


Открытие сохраненной консоли MMC для локального компьютера

Чтобы открыть сохраненную консоль MMC для локального компьютера

  1. При использовании операционной системы Windows XP Professional или Windows XP Home Edition для получения инструкций щелкните ссылку здесь.
  • Нажмите кнопку Пуск.
  • Выберите в меню команду Панель управления.
  • Щелкните значок Администрирование.
  • Затем щелкните значок службы компонентов.

Примечания

  • Другие способы открытия консолей.
    • Файлы консолей могут быть также открыты с помощью команды Запуск от имени. Используя эту команду, можно на компьютере войти в систему с правами пользователя, выполняющего повседневные задачи, но открывать файлы консолей с правами администратора для выполнения административных задач. Чтобы использовать эту команду, введите runas в командной строке или щелкните правой кнопкой мыши файл .msc и выберите Запуск от имени из контекстного меню.
    • Откройте папку, в которой размещена консоль, и дважды щелкните консоль.
    • Инструкции для Windows 2000 см. по ссылке здесь.
  • Нажмите кнопку Пуск.
  • Выберите в меню команду Настройка.
  • Выберите в меню команду Панель управления.
  • Щелкните значок Администрирование.
  • Затем щелкните значок службы компонентов.
  • Файлы консолей по умолчанию недоступны в папке «Администрирование» в меню Программы. Однако, если создана специальная консоль и сохранена в папке «Администрирование» для пользователя (размещается по адресу системный_диск\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), в меню Программы для данного пользователя появляется эта папка.

См. также


Открытие сохраненной консоли MMC для удаленного компьютера

Чтобы открыть сохраненную консоль MMC для удаленного компьютера

  1. При использовании операционной системы Windows XP Professional или Windows XP Home Edition для получения инструкций щелкните ссылку здесь.
  • Нажмите кнопку Пуск.
  • Выберите в меню команду Панель управления.
  • Щелкните значок Администрирование.
  • Затем щелкните значок службы компонентов.

Примечания

  • Другие способы открытия консолей.
    • Файлы консолей могут быть также открыты с помощью команды Запуск от имени. Используя эту команду, можно на компьютере войти в систему с правами пользователя, выполняющего повседневные задачи, но открывать файлы консолей с правами администратора для выполнения административных задач. Чтобы использовать эту команду, введите runas в командной строке или щелкните правой кнопкой мыши файл .msc и выберите Запуск от имени из контекстного меню.
    • Откройте папку, в которой размещена консоль, и дважды щелкните файл консоли.
    • Инструкции для Windows 2000 см. по ссылке здесь.
    • Нажмите кнопку Пуск.
    • Выберите в меню команду Настройка.
    • Выберите в меню команду Панель управления.
    • Щелкните значок Администрирование.
    • Затем щелкните значок службы компонентов.
  • Файлы консолей по умолчанию недоступны в папке «Администрирование» в меню Программы. Однако, если создана специальная консоль и сохранена в папке «Администрирование» для пользователя (размещается по адресу системный_диск\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), в меню Программы для данного пользователя появляется эта папка.

См. также


Создание ярлыка на рабочем столе для открытия MMC

Чтобы создать ярлык на рабочем столе для открытия MMC

  1. Щелкните правой кнопкой мыши рабочий стол, выберите пункт Создать, а затем Ярлык.
  2. Следуйте указаниям на экране. На рабочем столе появится ярлык.

Примечание

  • Ярлык, созданный на рабочем столе, может быть перетащен в другие папки, например папку с файлами .msc или папку для меню Пуск.
  • Ярлык для MMC в папках может быть создан с помощью проводника Windows. Чтобы сделать это, щелкните папку, в которую будет добавлен ярлык, в меню Файл выберите команды Создать, затем Ярлык и следуйте указаниям на экране.

См. также


Параметры командной строки ММС

Открытие консоли MMC Используя параметры командной строки ММС можно открыть конкретную консоль ММС, открыть ММС в авторском режиме и определить, какая версия ММС открыта 32-разрядная или 64-разрядная.

Синтаксис

mmc путь\имя_файла.msc [/a] [/64] [/32]

Параметры

путь\имя_файла.msc
Запускает MMC с открытием сохраненной консоли. Необходимо указать полный путь и имя файла для сохраненной консоли. Если файл консоли не указан, MMC открывает новую консоль.
/a
Открывает сохраненную консоль в авторском режиме. Используется для внесения изменений в сохраненные консоли.
/64
Открывает 64-разрядную версию MMC (MMC64). Этот параметр следует использовать только при выполнении 64-разрядной операционной системы Microsoft.
/32
Открывает 32-разрядную версию MMC (MMC32). При выполнении 64-разрядной операционной системы Microsoft можно выполнять 32-разрядные оснастки, открыв MMC с этим параметром командной строки.
/?
Отображение справки в командной строке.

Заметки

  • Использование параметра командной строки путь\имя_файла.msc

    Для создания командных строк и ярлыков, которые не зависят от явного расположения файлов консоли, можно использовать переменные среды. Например, если путь к файлу консоли включает системную папку (например, mmc c:\winnt\system32\console_name.msc), то для указания пути можно использовать переменную %systemroot%: (mmc %systemroot%\system32\console_name.msc). Это полезно при делегировании заданий пользователям, работающим на разных компьютерах.

  • Использование параметра командной строки /a

    Когда консоли открываются с этим параметром, они открываются в авторском режиме, независимо от режима, используемого по умолчанию. При этом установки режима по умолчанию для файлов не меняются; при пропуске этого параметра MMC открывает файлы консолей в соответствии с их режимами по умолчанию.

  • После открытия MMC или файла консоли любая существующая консоль открывается с помощью команды Открыть из меню Консоль.
  • С помощью командной строки можно создавать ярлыки для запуска MMC и работы с сохраненными консолями. Команда для командной строки работает в окне команды Выполнить из меню кнопки Пуск, в любом окне командной строки, в ярлыках, в пакетных файлах и программах, вызывающих такие команды.

Условные обозначения форматирования

Формат | Описание
Курсив | Сведения вводимые пользователем
Полужирный шрифт | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурных скобках ({}), варианты, разделенные вертикальной линией (|) Пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы

См. также


Использование старых и новых версий консолей ММС.

Чтобы использовать файлы, созданные ранними версиями ММС, с помощью ММС 2.0

  • ММС 2.0 читает консоли, созданные ранними версиями ММС.
  • Существуют следующие методы сохранения файлов, созданных ранними версиями ММС.
    • При работе с файлом, созданным ранней верией ММС, в авторском режиме ММС 2.0, он сохраняется только в ММС 2.0.
    • С файлом консоли ММС 1.2 можно работать в любых пользовательских режимах в ММС 2.0.
    • В таких режимах ММС 2.0 сохраняет изменения консоли ранней версии в новом формате в католог профилей пользователя. В файле сохраняются все изменения, определенные пользователем, включая изменение размера файла. Кроме того, исходная консоль не изменяется в первоначальном формате. ММС 2.0 открывает этот файл консоли с изменениями настройки. При копировании консоли на другой компьютер или удалении параметров настройки с помощью команды Консоль/Параметры изменения, внесенные пользователем, не сохраняются.

См. также


Создание файла консоли MMC

  • Добавление элемента на новую консоль MMC для локального компьютера
  • Добавление элемента на новую консоль MMC для удаленного компьютера
  • Добавление опубликованной оснастки на новую консоль MMC
  • Добавление расширения оснастки на консоль MMC
  • Добавление опубликованного расширения оснастки на консоль MMC
  • Создание вида панели задач в сохраненной консоли MMC
  • Создание задач для вида панели задач в сохраненной консоли MMC
  • Изменение вида панели задач в сохраненной консоли MMC
  • Изменение задач в виде панели задач в сохраненной консоли MMC
  • Добавление элемента в список «Избранное» на консоли MMC
  • Упорядочение списка «Избранное» на консоли MMC
  • Установка программы, управляемой оснасткой консоли MMC
  • Установка параметров консоли MMC
  • Сохранение файла консоли MMC


Добавление элемента на новую консоль MMC для локального компьютера

Чтобы добавить элемент на новую консоль MMC для локального компьютера

  1. Откройте консоль MMC.
  2. В меню Консоль выберите команду Добавить или удалить оснастку и нажмите кнопку Добавить.
  3. Под заголовком Оснастка двойным щелчком выберите добавляемый элемент, затем, если будет выведена подсказка, выполните одно из следующих действий.
    • Установите переключатель в положение локальным компьютером (тем, на котором она выполняется) и нажмите кнопку Готово.
    • Если появится окно мастера, следуйте указаниям на экране.
  4. Чтобы добавить на консоль еще один элемент, повторите шаг 3.

Примечания

  • Чтобы открыть консоль управления, нажмите кнопку Пуск, выберите команду Выполнить и введите mmc затем нажмите кнопку OK.
  • Если на консоль добавлена оснастка, но впоследствии оснастка оказалась поврежденной, попытайтесь добавить на консоль другой экземпляр той же оснастки, настройте его соответствующим образом и удалите первый экземпляр оснастки.
  • Если консоль сохранена в папке «Администрирование» для пользователя (размещается в системный_диск\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), она доступна для этого пользователя в папке «Администрирование» в меню Программы.
  • Имеется доступ только к оснасткам в Active Directory.
  • Если оснастка отсутствует в списке, сначала необходимо установить программу, устройство или службу, администрируемые оснасткой. Оснастки, которые не установлены локально,но доступны из службы катологов Active Directory, доступны из диалогового окна Добавить или удалить оснастку, только если используемый компьютер работает под управлением следующих систем. (см. здесь)
    • Windows 98 с установщиком Windows Installer.

      • –или–

    • Windows NT 4.0 с установщиком Windows Installer.

      • –или–

    • Windows Millennium Edition.

      • –и–

    • Входит в домен Windows.
    • Дополнительные сведения см. в справке.
  • Чтобы добавить подчиненный элемент для элемента, не являющегося корнем консоли, щелкните соответствующий элемент в списке Оснастки, прежде чем на шаге 2 нажать кнопку Добавить.

См. также


Добавление элемента на новую консоль MMC для удаленного компьютера

Чтобы добавить элемент на новую консоль MMC для удаленного компьютера

  1. Откройте консоль MMC.
  2. В меню Консоль выберите команду Добавить или удалить оснастку и нажмите кнопку Добавить.
  3. В списке Оснастка двойным щелчком выберите добавляемый элемент, затем выполните следующие действия.
    • Установите переключатель другим компьютером, введите имя компьютера, который будет управляться данным элементом, и нажмите кнопку Готово.
    • Если появится окно мастера, следуйте указаниям на экране.
  4. Чтобы добавить на консоль еще один элемент, повторите шаг 3.

Примечания

  • Чтобы открыть консоль управления, нажмите кнопку Пуск, выберите команду Выполнить и введите mmc затем нажмите кнопку OK.
  • Если диалоговое окно или мастер не появились на шаге 3, данный элемент можно использовать только для администрирования локального компьютера.
  • Если на консоль добавлена оснастка, но впоследствии оснастка оказалась поврежденной, попытайтесь добавить на консоль другой экземпляр той же оснастки, настройте его соответствующим образом и удалите первый экземпляр оснастки.
  • Если оснастка отсутствует в списке, сначала необходимо установить программу, устройство или службу, администрируемые оснасткой. Оснастки, которые не установлены локально, доступны из диалогового окна Добавить или удалить оснастку, если используемый компьютер находится под управлением только следующих операционных систем( см.здесь).
    • Windows 98 с установщиком Windows Installer.

      • –или–

    • Windows NT 4.0 с установщиком Windows Installer.

      • –или–

    • Windows Millennium Edition.

      • –и–

    • Входит в домен Windows.
    • Дополнительные сведения см. в справке.
  • Если консоль сохранена в папке «Администрирование» для пользователя (размещается в системный_диск\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), она доступна для этого пользователя в папке «Администрирование» в меню Программы.
  • Чтобы добавить подчиненный элемент для элемента, не являющегося корнем консоли, щелкните соответствующий элемент в списке Оснастки, прежде чем на шаге 2 нажать кнопку Добавить.

См. также


Добавление опубликованной оснастки на новую консоль MMC

Чтобы добавить опубликованную оснастку на новую консоль MMC

  1. Откройте консоль MMC.
  2. В меню Консоль выберите команду Добавить или удалить оснастку и нажмите кнопку Добавить.
  3. Выберите опубликованную оснастку, которую нужно добавить, и нажмите кнопку Добавить.
  4. Если появится окно мастера установщика Windows Installer, следуйте инструкциям на экране, затем выполните одно из перечисленных ниже действий.
    • Установите переключатель в положение локальным компьютером (тем, на котором она выполняется) и нажмите кнопку Готово.
    • Если появится окно мастера для оснастки, следуйте указаниям на экране.
  5. Чтобы добавить на консоль еще один элемент, повторите шаг 3.

Примечания

  • Чтобы открыть консоль управления, нажмите кнопку Пуск, выберите команду Выполнить и введите mmc затем нажмите кнопку OK.
  • Для оснасток, доступных в службе каталога Active Directory, в столбце Поставщик выводится Не установлено.
  • Доступ к расширениям оснастки, опубликованной в Active Directory, возможен только при выполнении следующих условий на используемом компьютере.( см. здесь)
    • Выполняется Windows 98 с установщиком Windows Installer.

      • –или–

    • Выполняется Windows NT 4.0 с установщиком Windows Installer.

      • –или–

    • Работает под управлением Windows Millennium Edition.

      • –и–

    • Входит в домен Windows.
    • Дополнительные сведения о публикации приложений и Windows Installer см. в справке.
  • Если консоль сохранена в папке «Администрирование» для пользователя (размещается по адресу: системный_диск\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), она доступна для этого пользователя в папке «Администрирование» в меню Программы.
  • Чтобы добавить подчиненный элемент для элемента, не являющегося корнем консоли, щелкните соответствующий элемент в списке Оснастки, прежде чем на шаге 2 нажать кнопку Добавить.
  • Дополнительные сведения об установщике Windows Installer см. на веб-узле MSDN Online Downloads (http://www.microsoft.com/)

См. также


Добавление расширения оснастки на консоль MMC

Чтобы добавить расширение оснастки на консоль MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск на панели задач, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку OK.
  2. В меню Консоль выберите команду Добавить или удалить оснастку, и затем щелкните элемент, который требуется расширить.
  3. На вкладке Расширения под заголовком Доступные расширения установите флажок рядом с добавляемым расширением, затем нажмите кнопку OK.

Примечания

  • Чтобы добавить все доступные для данного элемента расширения, на вкладке Расширения установите флажок Добавить все расширения. Если требуется добавить только определенные расширения, снимите этот флажок.
  • Данную процедуру можно использовать для удаления расширений с консоли, снимая установленные ранее флажки для расширений.

См. также


Добавление опубликованного расширения оснастки на консоль MMC

Чтобы добавить опубликованное расширение оснастки на консоль MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск на панели задач, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку OK.
  2. В меню Консоль выберите команду Добавить или удалить оснастку.
  3. На вкладке Расширения в списке Оснастки, которые могут быть расширены щелкните оснастку, которая будет расширена.
  4. В списке Доступные расширения установите флажок рядом с опубликованным расширением, которое нужно добавить, и нажмите кнопку Загрузка.
  5. Если будут вызваны один или несколько мастеров, следуйте инструкциям на экране и нажмите кнопку OK.

Важно!

  • Если на вкладке Расширения установлен флажок Добавить все расширения, на консоль добавляются только расширения оснасток, установленные и зарегистрированные локально. Чтобы расширения оснасток стали доступными на консоли, они должны быть загружены из службы каталога. Таким образом, чтобы добавить к заданному элементу все опубликованные расширения, не устанавливайте флажок Добавить все расширения, а установите флажки рядом с каждым опубликованным расширением.

Примечания

  • Для расширений оснасток, доступных в службе каталога Active Directory, за именами оснасток следует фраза (Не установлено).
  • Доступ к расширениям оснастки, опубликованной в Active Directory, возможен только при выполнении следующих условий на используемом компьютере.( см. здесь)
  • Выполняется Windows 98 с установщиком Windows Installer.

    • –или–

  • Выполняется Windows NT 4.0 с установщиком Windows Installer.

    • –или–

  • Работает под управлением Windows Millennium Edition.

    • –и–

  • Входит в домен Windows.
  • Дополнительные сведения о публикации приложений и Windows Installer см. в справке.

См. также


Создание вида панели задач в сохраненной консоли MMC

Чтобы создать вид панели задач в сохраненной консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск на панели задач, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку OK.
  2. В дереве консоли щелкните значок оснастки.
  3. В меню Действие выберите команду Новый вид панели задач.
  4. Следуйте инструкциям мастера создания вида панели задач.
  5. Если сразу после создания вида панели задач необходимо создать задачи, установите флажок Запустить мастер создания новой задачи на последнем экране мастера.

Примечание

  • Вид панели задач также может быть создан в новой консоли, но сначала необходимо добавить оснастку.

См. также


Создание задач для вида панели задач в сохраненной консоли MMC

Чтобы создать задачи для вида панели задач в сохраненной консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc путь\имя_файла.msc/a и нажмите кнопку OK.
  2. В дереве консоли щелкните элемент, связанный с видом панели задач, затем в меню Действие выберите команду Новый вид панели задач.
  3. На вкладке Задачи нажмите кнопку Создать.
  4. Следуйте инструкциям мастера создания задачи.

Примечания

  • Если создается новый вид панели задач и необходимо добавить задачу, установив флажок Запустить мастер создания новой задачи на последнем экране мастера создания вида панели задач, можно запустить мастера создания новой задачи.
  • Если выбран пункт Задача, выполняемая элементом дерева и на странице команд контекстного меню мастера создания новой задачи в списке Источник команд не удается просмотреть все элементы дерева консоли, необходимо раскрыть дерево консоли вручную перед запуском мастера создания новой задачи.

См. также


Изменение вида панели задач в сохраненной консоли MMC

Чтобы изменить вид панели задач в сохраненной консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку OK.
  2. В дереве консоли щелкните элемент, связанный с видом панели задач. В меню Действие выберите команду Новый вид панели задач.
  3. На вкладке Общие выполните следующие действия.
    • Чтобы изменить имя вида панели задач, в поле Имя введите новое имя. Имя появляется в левом верхнем углу вида панели задач и на вкладке в нижней части вида панели задач.
    • Чтобы изменить описание вида панели задач, в поле Описание введите новое описание. Описание появляется под именем в левом верхнем углу вида панели задач.
    • Чтобы изменить формат списка или настроить вид панели задач на хранение только задач, установите переключатель Стиль для области сведений в положение, соответствующее новому формату списка, или в положение Без списка.
    • Чтобы удалить вкладку Стандарные из вида панели задач, снимите флажок Скрыть стандартную вкладку.
    • Чтобы настроить описания задач, установите переключатель Стиль для описания задачи в положение Текст или Подсказка. Текстовые описания отображаются справа от задачи. Описания подсказки «всплывают» при указании на задачу мышью.
    • Чтобы изменить размер списка, в поле Размер списка выберите новое значение ширины (вертикальный список) или высоты (горизонтальный список).
  4. Нажмите кнопку Параметры и выполните одно из следующих действий.
    • Чтобы применить вид панели задач только к выбранному в настоящий момент элементу дерева консоли, установите переключатель в положение к выбранному элементу дерева.
    • Чтобы применить вид панели задач ко всем элементам в дереве консоли, имеющим тот же тип, что и выбранный в настоящее время элемент дерева консоли, установите переключатель в положение ко всем элементам, имеющим тип выбранного элемента.

      Примечание

      • Если выбрана эта возможность и данный вид панели задач должен появляться по умолчанию вместо вкладки Стандартные, установите флажок Изменить вид по умолчанию для этих элементов дерева на данной панели задач.

См. также


Изменение задач в виде панели задач в сохраненной консоли MMC

Чтобы изменить задачи в виде панели задач в сохраненной консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск на панели задач, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку OK.
  2. В дереве консоли щелкните элемент, связанный с видом панели задач, затем в меню Действие выберите команду Новый вид панели задач.
  3. На вкладке Задачи в группе Отображать эти задачи щелкните задачу и выполните указанные ниже действия.
    • Чтобы переместить выбранную задачу вверх в списке отображения вида панели задач, нажмите кнопку Вверх.
    • Чтобы переместить выбранную задачу вниз в списке отображения вида панели задач, нажмите кнопку Вниз.
    • Чтобы удалить выбранную задачу из списка отображения вида панели задач, нажмите кнопку Удалить.
    • Нажмите кнопку Изменить и выполните одно из следующих действий.
      • Чтобы изменить имя задачи, на вкладке Общие в поле Имя задачи введите новое имя. Имя появляется под задачей.
      • Чтобы изменить описание задачи, на вкладке Общие в поле Описание введите новое описание. В зависимости от настроек вида панели задач, описание появляется справа от задачи или всплывает при указании задачи мышью.
      • Чтобы изменить значок для задачи, на вкладке Значок задачи щелкните новый значок и нажмите кнопку OK.

См. также


Добавление элемента в список «Избранное» на консоли MMC

Чтобы добавить элемент в список «Избранное» на консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc путь\имя_файла.msc/a и нажмите кнопку OK.
  2. В дереве консоли щелкните элемент, который нужно добавить в список «Избранное».
  3. В области сведений выберите вкладку Обычные или вкладку вида панели задач, которую нужно добавить.
  4. Выберите в меню Избранное команду Добавить в избранное.
  5. В поле Создать в выполните одно из описанных ниже действий.
    • Чтобы добавить элемент к существующей папке, щелкните требуемую папку и нажмите кнопку OK.
    • Чтобы добавить элемент к новой папке, щелкните папку, которая будет выступать в качестве родительской для создаваемой папки, и нажмите кнопку Создать папку. В поле Имя папки введите имя, нажмите кнопку OK и снова нажмите кнопку OK.

Примечание

  • Вкладка Стандартные и вкладки для видов панели задач доступны в области сведений, если для элемента, указанного в дереве консоли, настроен вид панели задач. В противном случае в области сведений вкладки не видны.

См. также


Упорядочение списка «Избранное» на консоли MMC

Чтобы упорядочить список «Избранное» на консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc путь\имя_файла.msc/a и нажмите кнопку OK.
  2. В меню Избранное выберите команду Упорядочить избранное и выполните следующие действия.
    • Чтобы добавить папку, нажмите кнопку Создать папку, введите имя в поле Имя папки и нажмите кнопку OK.
    • Чтобы переместить элемент в папку, щелкните элемент, расположенный ниже папки «Избранное», нажмите кнопку Переместить в папку, щелкните папку, в которой элемент будет размещен, и нажмите кнопку OK.
    • Чтобы изменить имя элемента, щелкните элемент, расположенный ниже папки «Избранное», нажмите кнопку Переименовать, введите новое имя и нажмите клавишу ENTER.
    • Чтобы удалить элемент, щелкните элемент, расположенный ниже папки «Избранное», и нажмите кнопку Удалить.

См. также


Установка программы, управляемой оснасткой консоли MMC

Чтобы установить программу, управляемую оснасткой консоли MMC

  1. При использовании операционной системы Windows XP Professional или Windows XP Home Edition для получения инструкций щелкните ссылку здесь.
    • Нажмите кнопку Пуск.
    • Выберите в меню команду Панель управления.
    • Дважды щелкните значок Установка и удаление программ.
    • Следуйте указаниям на экране.
  2. Инструкции для Windows 2000 см. по ссылке здесь.
    • Нажмите кнопку Пуск.
      • ,
    • Выберите в меню команду Настройка.
    • Выберите в меню команду Панель управления.
    • Дважды щелкните значок Установка и удаление программ.
    • Следуйте инструкциям, выводимым на экран.


Установка параметров консоли MMC

Чтобы установить параметры консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск на панели задач, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку OK.
  2. В меню Консоль выберите команду Параметры.
  3. Что изменить заголовок консоли, введите новый заголок в поле.
  4. Чтобы изменить значок для консоли, нажмите кнопку Сменить значок. В поле Имя файла введите путь к файлу, содержащему значки. В поле Текущий значок выберите значок и нажмите кнопку OK.
  5. Чтобы изменить режим использования консоли по умолчанию, из списка Режим консоли выберите режим, в котором будет открываться консоль.
  6. Если по умолчанию консоль используется в одном из пользовательских режимов, выполните указанные ниже действия.
    • Чтобы запретить пользователям изменение консоли, установите флажок Не сохранять изменения для этой консоли.
    • Чтобы сделать диалоговое окно Настройка вида доступным для пользователей, установите флажок Позволить пользователю настраивать вид консоли.

Примечания

  • Если изменен заголовок консоли, в поле заголовка не будет отображаться путь к элементу, выбранному в дереве консоли. Однако, если заголовок не изменен или удален, пути отображаются.
  • Значки, которые могут быть использованы для специальных консолей, находятся во многих файлах. Например, значки можно найти в файле Shell32.dll, который находится в папке системный_корневой_каталог\System32.
  • Чтобы отменить получение сообщения Сохранить настройку консоли в имя_консоли?, которое появляется при каждом закрытии консоли, открытой в авторском режиме, установите в качестве режима использования консоли по умолчанию один из пользовательских режимов и снимите флажок Не сохранять изменения для этой консоли. В этом случае любые изменения в консоли будут сохраняться по умолчанию.

См. также


Сохранение файла консоли MMC

Чтобы сохранить файл консоли MMC

  • В консоли MMC, открытой в авторском режиме, из меню Консоль выберите команду Сохранить.

Примечания

  • Чтобы открыть сохраненную консоль в авторском режиме, правой кнопкой мыши щелкните файл с расширенитем .msc и выберите из меню «Автор» или нажмите кнопку Пуск, затем выберите команду Выполнить и введите mmc путь\имя_файла.msc /a.
  • Если консоль открыта не в авторском режиме, команда Сохранить в меню Консоль не доступна. В этом случае возможность сохранения определяется тем, был ли установлен флажок Не сохранять изменения для этой консоли (доступен по команде Параметры в меню Консоль) при настройке консоли. Если этот флажок не был установлен, изменения сохраняются автоматически при закрытии MMC. Если флажок был установлен, при закрытии MMC изменения теряются.
  • Если консоль сохранена в папке «Администрирование» для пользователя (размещается по адресу: системный_диск\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), она доступна для этого пользователя в папке «Администрирование» в меню Программы.

См. также


Изменение сохраненного файла консоли MMC

  • Переименование элемента дерева консоли MMC
  • Удаление оснастки или другого элемента с консоли MMC
  • Создание нового окна консоли из консоли MMC
  • Создание нового окна консоли из части дерева консоли MMC


Переименование элемента дерева консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск на панели задач, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку OK.
  2. В дереве консоли выберите элемент, который требуется переименовать.
  3. В меню Действие выберите команду Переименовать и введите новое имя.

Примечание

  • Не все элементы дерева консоли могут быть переименованы. Если команда Переименовать отсутствует в меню Действие, то переименование элемента не допускается.

См. также


Удаление оснастки или другого элемента с консоли MMC

Чтобы удалить оснастку или другой элемент с консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск на панели задач, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку OK.
  2. В меню Консоль выберите команду Добавить или удалить оснастку.
  3. На вкладке Изолированная оснастка выберите элемент, который требуется удалить, и нажмите кнопку Удалить.

См. также


Создание нового окна консоли из консоли MMC

Чтобы создать новое окно консоли из консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск на панели задач, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку OK.
  2. В меню Окно выберите команду Новое.

Примечание

  • Новое окно консоли имеет в качестве своего корня корень сохраненной консоли.

См. также


Создание нового окна консоли из части дерева консоли MMC

Чтобы создать новое окно консоли из части дерева консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск на панели задач, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку OK.
  2. В дереве консоли щелкните элемент, который будет корнем новой консоли.
  3. В меню Действие выберите команду Новое окно отсюда..

См. также


Работа с MMC и сохраненными файлами консолей

Работа с MMC и сохраненными файлам консолей

  • Скрытие и отображение компонентов сохраненной консоли MMC
  • Скрытие и отображение меню и панелей инструментов для оснастки
  • Изменение порядка столбцов в консоли MMC
  • Скрытие и отображение столбцов в консоли MMC
  • Фильтрация строк в консоли MMC
  • Экспорт столбцов консоли MMC в текстовый файл
  • Просмотр связанной оснастки и элемента для страницы свойств


Просмотр расширений

Чтобы просмотреть расширения оснасток

  • Нажмите кнопку Пуск, выберите команду Дополнительные программы или Все программы, далее выберите команду Администрирование и щелкните имя файла консоли.
  • В диалоговом окне Добавить изолированную оснастку в списке Оснастки выберите необходимую оснастку.
  • Откройте вкладку Расширения.
  • В поле Доступные расширения отображаются расширения для оснастки.
  • Расширения других оснасток отображаются при выборе в элементов в списке Оснастки, которые могут быть расширены.

Примечание

  • Команда меню Добавить или удалить оснастку видна только при работе в авторском режиме.
  • Оснастки, добавленные пользователем, по умолчанию сохраняются в папке «Administrative Tools» (%системный_диск%/Documents and Settings/%UserName%/Start/Programs/Administrative Tools). Они могут быть сохранены в месте, указанном пользователем.
  • Для открытий файла консоли в авторском режиме, правой кнопкой мыши щелкните имя файла и в контекстном меню выберите команду Автор.
  • В открытой консоли ММС выберите меню Консоль. В раскрывающемся меню выберите команду Добавить или удалить оснастку.
  • Команда меню Добавить или удалить оснастку недоступна в других режимах пользователя.

См. также


Использование вкладки очистки диска

Чтобы использовать вкладку очистки диска

  1. Откройте консоль MMC.
  2. В строке меню откройте меню Консоль.
  3. Выберите команду Параметры. Откроется диалоговое окно Параметры с двумя вкладками.
  4. Щелкните вкладку Очистка диска.
  5. Для удаления файлов консолей нажмите кнопку Удалить файлы.
  6. Закройте диалоговое окно. нажав кнопку ОК.
  7. Для отмены удаления файлов, нажмите кнопку Отмена в нижней части окна.

Примечания

  • Чтобы открыть консоль управления, нажмите кнопку Пуск, выберите команду Выполнить и введите mmc, затем нажмите кнопку OK.
  • В тексте на вкладке Очистка диска сообщается, что изменения вида файла консоли сохранены в профиле пользователя. На вкладке Очистка диска также указан объем дискового пространства, отведенного под изменения консолей.


Скрытие и отображение компонентов сохраненной консоли MMC

Чтобы скрыть или отобразить компоненты сохраненной консоли MMC

  1. Откройте сохраненную консоль.
    • Чтобы открыть сохраненную консоль в авторском режиме, щелкните правой кнопкой файл .msc и выберите команду Автор.
    • Нажмите кнопку Пуск, выберите команду Выполнить и введите mmc путь\имя_файла.msc /a.
  2. В меню Вид выберите команду Настроить.
  3. В группе MMC выполните следующие действия.
    • Чтобы отобразить или скрыть дерево консоли, установите или снимите флажок Дерево консоли.
    • Чтобы отобразить или скрыть меню Действие и Вид, установите или снимите флажок Стандартные меню (Действие и Вид).
    • Чтобы отобразить или скрыть панель инструментов консоли, установите или снимите флажок Панель инструментов Стандартная.
    • Чтобы отобразить или скрыть строку состояния в нижней части окна консоли, установите или снимите флажок Строка состояния.
    • Чтобы отобразить или скрыть область описания, расположенную вдоль верхней стороны области сведений, установите или снимите флажок Область описания.
    • Чтобы отобразить или скрыть вкладки в нижней части области сведений, установите или снимите флажок Вкладки панели задач.

Важно!

  • Если флажок Стандартные меню (Действие и Вид) снят, а диалоговое окно Настройка вида закрыто, доступ к командам меню Действие и Вид, включая команду Настроить, отсутствует. В этом случае, чтобы получить доступ к диалоговому окну Настройка вида, щелкните системное меню (значок в левом верхнем углу консоли) и выберите команду Настроить вид.

Примечания

  • Установив или сняв соответствующие флажки, просмотрите консоль и проверьте, что были сделаны именно ожидаемые изменения.
  • Если снять флажок Дерево консоли, меню Избранное(если есть) будет отображено в меню.
  • Отобразить и скрыть вкладки в нижней части области сведений можно из существующего вида панели задач. Выберите команду Действие из меню, затем команду Новый вид панели задач и установите или снимите флажок Скрыть стандартную вкладку, потом нажмите кнопку OK.

См. также


Скрытие и отображение меню и панелей инструментов для оснастки

Чтобы скрыть или отобразить меню и панели инструментов для оснастки

  1. Откройте сохраненную консоль.

    Примечание

      Чтобы открыть сохраненную консоль в авторском режиме, щелкните правой кнопкой файл .msc и выберите команду Автор.
      Нажмите кнопку Пуск, выберите команду Выполнить и введите mmc путь\имя_файла.msc /a.
      Нажмите кнопку OK.

  2. В меню Вид выберите команду Настроить.
  3. В группе Оснастка выполните одно или несколько следующих действий.
    • Чтобы отобразить или скрыть специальные меню для оснастки, установите или снимите флажок Меню.
    • Чтобы отобразить или скрыть специальные панели инструментов для оснастки, установите или снимите флажок Панели инструментов.

Примечание

  • Когда устанавливается или снимаются флажки Меню и Панели инструментов, меню и панели инструментов отображаются или скрываются для всех оснасток консоли, не только для текущей оснастки. Если переключение флажков не изменяет вид консоли, текущая оснастка не имеет специальных меню или панелей инструментов.

См. также


Изменение порядка столбцов в консоли MMC

Чтобы изменить порядок столбцов в консоли MMC

  1. В открытой консоли MMC щелкните элемент в дереве консоли, который выводит столбцы в области сведений.
  2. В меню Вид выберите команду Добавить или удалить столбцы.
  3. В диалоговом окне Добавление или удаление столбцов в списке Отображаемые столбцы щелкните имя столбца и нажмите кнопку Вверх или Вниз для изменения расположения столбца.

Примечания

  • Изменить порядок столбцов в области сведений можно с помощью мыши, перетаскивая заголовок столбца вправо или влево от первоначального положения. Во время перетаскивания столбца маркер между заголовками показывает новое положение столбца.
  • Размер столбцов может быть изменен перетаскиванием границы заголовка столбца.
  • Эта возможность доступна не для всех элементов. Если в меню Вид команда Добавить или удалить столбцы отсутствует, эта возможность не может быть использована для выбранного элемента.

См. также


Скрытие и отображение столбцов в консоли MMC

Чтобы скрыть или отобразить столбцы в консоли MMC

  1. В открытой консоли MMC щелкните элемент в дереве консоли, который выводит столбцы в области сведений.
  2. В меню Вид выберите команду Добавить или удалить столбцы.
  3. Выполните следующие действия в диалоговом окне Добавить или удалить столбцы.
    • Чтобы скрыть столбец, в списке Отображаемые столбцы выберите скрываемый столбец и нажмите кнопку Удалить.
    • Чтобы отобразить столбец, в списке Скрытые столбцы выберите отображаемый столбец и нажмите кнопку Добавить.

Примечания

  • Некоторые столбцы невозможно скрыть в области сведений.
  • Эта возможность доступна не для всех элементов. Если в меню Вид команда Выбрать столбцы отсутствует, эта возможность не может быть использована для выбранного элемента.

См. также


Фильтрация строк в консоли MMC

Чтобы отфильтровать строки в консоли MMC

  1. В открытой консоли MMC щелкните элемент в дереве консоли, который выводит столбцы в области сведений.
  2. В меню Вид выберите команду Фильтр.
  3. При необходимости измените параметры на вкладке Фильтр диалогового окна Свойства приложения.

    4. Результаты фильтрации отображаются в области сведений под заголовками столбцов.

Примечание

  • Эта возможность доступна не для всех элементов. Если в меню Вид команда Фильтр отсутствует, эта возможность не может быть использована для выбранного элемента.

См. также


Экспорт столбцов консоли MMC в текстовый файл

Чтобы экспортировать столбцы консоли MMC в текстовый файл

  1. В открытой консоли MMC щелкните элемент в дереве консоли, который выводит столбцы в области сведений.

    2. Примечания

    • Чтобы экспортировать только определенные столбы в области сведений, выберите их.
    • Если необходимо экспортировать все содержимое области сведений, пропустите этот шаг.
  2. Выберите в меню Действие команду Экспортировать список.
  3. В диалоговом окне Сохранить как введите требуемые сведения.
    • В поле со списком Папка выберите расположение сохраняемого файла.
    • В поле Имя файла введите имя файла.
    • В поле со списком Тип файла выберите формат файла.
    • Чтобы экспортировать только определенные строки, установите флажок Сохранить только выбранные строки.
  4. Нажмите кнопку Сохранить.

Примечания

  • Некоторые оснастки не предоставляют возможность выбора нескольких строк в области сведений. Для этих оснасток можно экспортировать только все строки в области сведений, а не выбранные строки.
  • Файлы формата Unicode не доступны в поле со списком Тип файла в операционных системах, более ранних чем Windows NT 4.0.

См. также


Просмотр связанной оснастки и элемента для страницы свойств

Чтобы просмотреть связанную оснастку и элемент для страницы свойств

  1. В дереве консоли или области сведений открытой консоли MMC щелкните правой кнопкой мыши элемент, для которого необходимо просмотреть свойства и выберите из контекстного меню команду Свойства.
  2. Выполните следующие действия в диалоговом окне свойств.
    • Чтобы определить, какая оснастка предоставляет конкретную страницу свойств в диалоговом окне, укажите мышью подпись вкладки, удерживая нажатой клавишу CTRL.
    • Чтобы определить расположение в дереве консоли элемента, связанного с диалоговым окном свойств, укажите мышью заголовок диалогового окна свойств, удерживая нажатой клавишу CTRL.


Настройка политики для MMC и оснасток

  • Ограничение доступа к MMC в авторском режиме
  • Ограничение доступа к MMC в авторском режиме для домена
  • Ограничение доступа списком разрешенных оснасток
  • Ограничение доступа для домена списком разрешенных оснасток
  • Ограничение и разрешение доступа к оснастке
  • Ограничение и разрешение доступа к оснастке для домена


Ограничение доступа к MMC в авторском режиме

Чтобы ограничить доступ к MMC в авторском режиме

  1. Откройте консоль MMC.
  2. В меню Консоль выберите команду Добавить или удалить оснастку и нажмите кнопку Добавить.
  3. В поле Оснастка, выберите Групповая политика, затем нажмите кнопку Добавить.
  4. В диалоговом окне Выбор объекта групповой политики выполните одно их следующих действий.
    • Чтобы изменить локальный объект групповой политики, выберите Локальный компьютер.
    • Чтобы изменить другой объект групповой политики, нажмите кнопку Обзор.
  5. Нажмите кнопку Готово, кнопку Закрыть, а затем — кнопку OK.

    Оснастка «Групповая политика» откроет выбранный объект групповой политики.

  6. В дереве консоли щелкните компонент Консоль управления Microsoft.

    Где?

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Компоненты Windows
    • Консоль управления Microsoft
  7. В области сведений дважды щелкните Запретить пользователям использовать авторский режим.
  8. На вкладке Политика выполните одно из следующих действий.
    • Чтобы разрешить пользователю использовать авторский режим в MMC, установите переключатель в положение Не задана или Отключена.
    • Чтобы запретить пользователю использовать авторский режим в MMC, установите переключатель в положение Включена.

Примечания

  • Чтобы открыть консоль управления, нажмите кнопку Пуск, выберите команду Выполнить и введите mmc затем нажмите кнопку OK.
  • Если включен режим Запретить пользователям использовать авторский режим, при попытке доступа к консоли появится сообщение об ошибке, указывающее на закрытый доступ к консоли в авторском режиме. Пользователи с администраторскими правами могут восстановить доступ к файлам в авторском режиме с помощью команды Пуск/Выполнить/gpedit.msc, которая откроет консоль групповой политики для политики локального компьютера. Затем, щелкните Конфигурация пользователя/Административные шаблоны/Компоненты Windows/Консоль управления Microsoft. В области сведений дважды щелкните Запретить пользователям использовать авторский режим. Установите переключатель Не задана или Отключена вместо Включена.
  • Эта возможность доступна только в сети с настроенной групповой политикой, системный администратор должет запустить оснастку «Групповая политика» Не доступна в системе Windows XP Home Edition.
  • Чтобы получить дополнительные сведения, выберите вкладку Объяснение диалогового окна Запретить пользователям использовать авторский режим или см. справку.

См. также


Ограничение доступа к MMC в авторском режиме для домена

Чтобы ограничить доступ к MMC в авторском режиме для домена

  1. Откройте оснастку Пользователи и компьютеры Active Directory.
  2. В дереве консоли щелкните правой кнопкой подразделение, для которого нужно настроить политику, и выберите команду Свойства.
  3. На вкладке Групповая политика нажмите кнопку Изменить.

    Появится консоль «Групповая политика».

  4. В дереве консоли щелкните компонент Консоль управления Microsoft.

    Где?

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Компоненты Windows
    • Консоль управления Microsoft
  5. В области сведений дважды щелкните Запретить пользователям использовать авторский режим.
  6. На вкладке Политика выполните одно из следующих действий.
    • Чтобы разрешить пользователю использовать авторский режим в MMC, установите переключатель в положение Не задана или Отключена.
    • Чтобы запретить пользователю использовать авторский режим в MMC, установите переключатель в положение Включена.

Примечания

  • Чтобы открыть окно «Пользователи и компьютеры Active Directory», нажмите кнопку Пуск и выберите команды Программы, Администрирование и Пользователи и компьютеры Active Directory.
  • Это верно в сети с настроенной групповой политикой. Чтобы использовать компьютер, являющийся контроллером домена, для настройки групповой политики для домена, надо быть администратором домена или иметь эквивалентные права.
  • Чтобы получить дополнительные сведения, выберите вкладку Объяснение диалогового окна Запретить пользователям использовать авторский режим или см. справку.

См. также


Ограничение доступа списком разрешенных оснасток

Чтобы ограничить доступ списком разрешенных оснасток

  1. Откройте консоль MMC.
  2. В меню Консоль выберите команду Добавить или удалить оснастку и нажмите кнопку Добавить.
  3. В поле Оснастка, выберите Групповая политика, затем нажмите кнопку Добавить.
  4. В диалоговом окне Выбор объекта групповой политики выполните одно их следующих действий.
    • Чтобы изменить локальный объект групповой политики, выберите Локальный компьютер.
    • Чтобы изменить другой объект групповой политики, нажмите кнопку Обзор.
  5. Нажмите кнопку Готово, кнопку Закрыть, а затем — кнопку OK.

    Оснастка «Групповая политика» откроет выбранный объект групповой политики.

  6. В дереве консоли щелкните компонент Консоль управления Microsoft.

    Где?

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Компоненты Windows
    • Консоль управления Microsoft
  7. В области сведений дважды щелкните Ограничить использование оснасток списком явно разрешенных оснасток.
  8. На вкладке Политика выполните одно из следующих действий.
    • Чтобы разрешить пользователю доступ к оснасткам, которые явно не запрещены, установите переключатель в положение Не задана или Отключена.
    • Чтобы запретить пользователю доступ к любой оснастке, которая явно не разрешена, установите переключатель в положение Включена.

Примечания

  • Чтобы открыть консоль управления ММС, нажмите кнопку Пуск, выберите команду Выполнить и введите mmc, затем нажмите кнопку OK.
  • Эта возможность не доступна в системе Windows XP Home Edition.
  • Эта возможность доступна только в сети с настроенной групповой политикой, системный администратор должет запустить оснастку «Групповая политика»
  • Если разрешена данная политика, только разрешенные оснастки появляются в списке доступных оснасток в диалоговом окне Добавить изолированную оснастку в MMC.
  • Чтобы получить дополнительные сведения, выберите вкладку Объяснение диалогового окна Свойства: Ограничить использование оснасток списком явно разрешенных оснасток или см. справку.

См. также


Ограничение доступа для домена списком разрешенных оснасток

Чтобы ограничить доступ для домена списком разрешенных оснасток

  1. Откройте оснастку Пользователи и компьютеры Active Directory.
  2. В дереве консоли щелкните правой кнопкой подразделение, для которого нужно настроить политику, и выберите команду Свойства.
  3. На вкладке Групповая политика нажмите кнопку Изменить.

    Появится консоль «Групповая политика».

  4. В дереве консоли щелкните компонент Консоль управления Microsoft.

    Где?

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Компоненты Windows
    • Консоль управления Microsoft
  5. В области сведений дважды щелкните Ограничить использование оснасток списком явно разрешенных оснасток.
  6. На вкладке Политика выполните одно из следующих действий.
    • Чтобы разрешить пользователю доступ к оснасткам, которые явно не запрещены, установите переключатель в положение Не задана или Отключена.
    • Чтобы запретить пользователю доступ к любой оснастке, которая явно не разрешена, установите переключатель в положение Включена.

Примечания

  • Чтобы открыть окно «Пользователи и компьютеры Active Directory», нажмите кнопку Пуск и выберите команды Программы, Администрирование и Пользователи и компьютеры Active Directory.
  • Это верно в сети с настроенной групповой политикой. Чтобы использовать компьютер, являющийся контроллером домена, для настройки групповой политики для домена, надо быть администратором домена или иметь эквивалентные права.
  • Если разрешена данная политика, только разрешенные оснастки появляются в списке доступных оснасток в диалоговом окне Добавить изолированную оснастку в MMC.
  • Чтобы получить дополнительные сведения, выберите вкладку Объяснение диалогового окна Свойства: Ограничить использование оснасток списком явно разрешенных оснасток или см. справку.

См. также


Ограничение и разрешение доступа к оснастке

Чтобы ограничить или разрешить доступ к оснастке

  1. Откройте консоль MMC.
  2. В меню Консоль выберите команду Добавить или удалить оснастку и нажмите кнопку Добавить.
  3. В поле Оснастка, выберите Групповая политика, затем нажмите кнопку Добавить.
  4. В диалоговом окне Выбор объекта групповой политики выполните одно их следующих действий.
    • Чтобы изменить локальный объект групповой политики, выберите Локальный компьютер.
    • Чтобы изменить другой объект групповой политики, нажмите кнопку Обзор.
  5. Нажмите кнопку Готово, кнопку Закрыть, а затем — кнопку OK.

    Оснастка «Групповая политика» откроет выбранный объект групповой политики.

  6. В дереве консоли щелкните Запрещенные или разрешенные оснастки.

    Где?

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Консоль управления Microsoft
    • Запрещенные или разрешенные оснастки
  7. В области сведений дважды щелкните оснастку, которую необходимо разрешить или запретить, и выполните одно из следующих действий.
    • Чтобы разрешить пользователю доступ к этой оснастке, если это не запрещено политикой Ограничить использование оснасток списком явно разрешенных оснасток, установите переключатель в положение Не задана.
    • Чтобы разрешить пользователям доступ к оснастке, установите переключатель в положение Включена.
    • Чтобы запретить пользователям доступ к оснастке, установите переключатель в положение Отключена.

Примечания

  • Чтобы открыть консоль управления ММС, нажмите кнопку Пуск, выберите команду Выполнить и введите mmc затем нажмите кнопку OK.
  • Эта возможность доступна только в сети с настроенной групповой политикой, системный администратор должет запустить оснастку «Групповая политика»
  • Чтобы получить дополнительные сведения, выберите вкладку Объяснение диалогового окна Свойства: оснастка или см. справку по Windows 2000.

См. также


Ограничение и разрешение доступа к оснастке для домена

Чтобы ограничить или разрешить доступ к оснастке для домена

  1. Откройте оснастку Пользователи и компьютеры Active Directory.
  2. В дереве консоли щелкните правой кнопкой подразделение, для которого нужно настроить политику, и выберите команду Свойства.
  3. На вкладке Групповая политика нажмите кнопку Изменить.

    Появится консоль «Групповая политика».

  4. В дереве консоли щелкните Запрещенные или разрешенные оснастки.

    Где?

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Компоненты Windows
    • Консоль управления Microsoft
    • Запрещенные или разрешенные оснастки
  5. В области сведений дважды щелкните оснастку, которую необходимо разрешить или запретить, и выполните одно из следующих действий.
    • Чтобы разрешить пользователю доступ к этой оснастке, если это не запрещено политикой Ограничить использование оснасток списком явно разрешенных оснасток, установите переключатель в положение Не задана.
    • Чтобы разрешить пользователям доступ к оснастке, установите переключатель в положение Включена.
    • Чтобы запретить пользователям доступ к оснастке, установите переключатель в положение Отключена.

Примечания

  • Чтобы открыть окно «Пользователи и компьютеры Active Directory», нажмите кнопку Пуск и выберите команды Программы, Администрирование и Пользователи и компьютеры Active Directory.
  • Active Directory не доступна в системе Windows XP Professional или Windows XP Home Edition.
  • Это верно в сети с настроенной групповой политикой. Чтобы использовать компьютер, являющийся контроллером домена, для настройки групповой политики для домена, надо быть администратором домена или иметь эквивалентные права.
  • Когда запрещается или явно разрешается доступ к оснастке, она добавляется в список запрещенных или разрешенных оснасток. Список запретов имеет приоритет перед списком разрешений, поэтому доступ к оснастке, присутствующей в обоих списках, запрещен.
  • Чтобы получить дополнительные сведения, выберите вкладку Объяснение диалогового окна Свойства: оснастка или см. справку.

См. также


Основные понятия

В этом разделе рассмотрены следующие темы.

  • Общие сведения о ММС
  • Общее представление о MMC
  • Использование MMC
  • Ресурсы


Общие сведения о консоли ММС

Общие сведения о консоли MMC

Консоль управления Microsoft Management Console (MMC) — средство для создания, сохранения и открытия средств администрирования (называемых консолями MMC), которые управляют оборудованием, программными и сетевыми компонентами операционной системы Windows. ММС запускается на различных операционных системах Windows 9x и Windows NT.

MMC не выполняет административные функции, но на ней размещаются инструменты, выполняющие эти функции. Основной тип инструментов, которые можно добавить на консоль называется оснасткой. Другими добавляемыми элементами являются элементы управления ActiveX, ссылки на веб-страницы, папки, виды панели задач и задачи.

Есть два основных способа использования консоли ММС: в пользовательском режиме, работая с существующими консолями ММС, можно администрировать систему, или в авторском режиме создавать новые консоли или изменять существующие. Дополнительные сведения об отличиях между режимами пользователя и автора см. в разделе Режимы доступа консоли.


Общее представление о MMC

В этом разделе рассмотрены следующие темы.

  • Консоли MMC
  • Групповая политика и MMC
  • Консоль MMC в авторском режиме


Консоли MMC

Новая консоль MMC представляет окно, разделенное на две области. В левой области отображается дерево консоли. Дерево консоли показывает элементы, доступные в консоли. Правая область является областью сведений. Область сведений содержит описания элементов и выполняемых ими функций. Содержание области сведений соответствует выбранному элементу в дереве консоли. Область сведений может отображать различные типы сведений, включая веб-страницы, графики, диаграммы, таблицы и столбцы.

Каждая консоль имеет свои собственные меню и панель инструментов, отделенные от таких же элементов главного окна MMC, что удобно для выполнения заданий пользователя. Дополнительные сведения о главном окне MMC см. в разделе Окно MMC.

Используемая операционная система может уже иметь заранее настроенные и сохраненные файлы консоли, доступные в меню Программы или в папке «Администрирование» на панели управления.

Консоли, созданные с помощью более старых версий ММС ( версии 1.1 и 1.2), просматриваются консолью управления ММС версии 2.0. Тем не менее, чтобы сохранить или изменить эти консоли, требуется преобразовать их в консоли ММС версии 2.0. Дополнительные сведения см. в разделе Использование старых и новых версий консолей ММС.


Групповая политика и MMC

Только администраторы могут использовать групповую политику для разрешения и ограничения доступа к определенным оснасткам или ограничения возможности пользователя или группы использовать авторский режим в MMC. Это верно в сети с настроенной групповой политикой.

Чтобы настроить политику для пользователей определенного компьютера, необходимо быть администратором компьютера или иметь эквивалентные права. Чтобы настроить политику для подразделения в домене, необходимо быть администратором домена или иметь эквивалентные права. Эта версия MMC не может быть использована для создания политик компьютера, можно создавать только политики пользователей.

Дополнительные сведения о групповой политике содержатся в справке.

Для получения дополнительных сведений о применении групповой политики к MMC см. Настройка групповой политики в MMC.


Консоль MMC в авторском режиме

MMC в авторском режиме позволяет создавать новые и изменять существующие консоли. Для создания административного средства на консоль добавляются оснастки и другие элементы. Имеется возможность создания дополнительных окон консоли, которые обеспечивают отображение различных элементов, образующих консоль. Также имеется возможность создания видов панели задач, которые содержат ярлыки ссылок для выполнения команд меню из разных мест и инструментов на панели, а также для запуска функций, вызываемых из командной строки. После сохранения консоли ее можно разослать пользователям.

В этом разделе рассмотрены следующие темы.

  • Окно MMC
  • Оснастки
  • Виды панели задач и задачи
  • Дерево и корень консоли
  • Список «Избранное»
  • Режимы доступа консоли

Кроме того, руководство по созданию и настройке консолей см. на веб-узле корпорации Майкрософт (http://www.microsoft.com/)


Окно MMC

Компоненты консоли MMC содержатся в окне MMC. Это окно имеет несколько меню и панель инструментов с командами открытия, создания и сохранения консолей MMC. Меню и панель инструментов окна MMC называются панелью главного меню и главной панелью инструментов соответственно. Кроме того, имеется строка состояния в нижней части окна и область описания вдоль верхней части области сведений. Чтобы увидеть окно MMC, откройте консоль MMC.

При открытии новой консоли MMC в рабочей области окна MMC появляется окно консоли. В окне консоли можно собрать и настроить новую консоль, а затем работать со средствами новой консоли. После того как элементы добавлены на консоль, панель главного меню, главная панель инструментов, область описания и строка состояния могут быть скрыты от пользователя для предотвращения внесения им нежелательных изменений консоли. Дополнительные сведения см. в разделах Скрытие и отображение компонентов сохраненной консоли MMC и Скрытие и отображение меню и панелей инструментов для оснастки.


Оснастки

Оснастка — это основной компонент консоли MMC. Оснастки всегда содержатся в консоли; они не могут выполняться отдельно.

При установке компоненты, с которой связана оснастка, оснастка доступна любому пользователю, создающему на компьютере консоль (если не имеется ограничений политики пользователя). Сведения о политике пользователя см. в разделе Групповая политика и MMC.

Изолированные оснастки и расширения

В консоли ММС существует два вида оснасток: изолированные оснастки и расширения. Изолированная оснастка, обычно называемая просто оснасткой, может быть добавлена к дереву консоли без предварительного добавления других элементов. Оснастка расширения, обычно называемая расширением, всегда добавляется к другой изолированной оснастке или расширению, уже имеющимся в дереве консоли. Если для оснастки разрешены расширения, они работают с объектами, управляемыми оснасткой, например с компьютером, принтером, модемом или другим устройством.

Когда оснастка или расширение добавляются на консоль, они могут появиться в виде нового элемента в дереве консоли или добавлять новые пункты контекстного меню, дополнительные панели инструментов, дополнительные страницы свойств или мастера к оснастке, уже установленной на консоли.

Добавление оснасток на консоль

На консоль может быть добавлена как одиночная оснастка, так и несколько оснасток и другие элементы. Кроме того, вы можете добавить на одну консоль несколько экземпляров одной и той же оснастки для администрирования различных компьютеров или для восстановления поврежденной консоли. Всякий раз, когда новый экземпляр оснастки добавляется на консоль, любые переменные для оснастки установлены в значения по умолчанию, пока оснастка на будет настроена. Например, если определенная оснастка настроена для управления удаленным компьютером и добавляется второй экземпляр оснастки, этот второй экземпляр автоматически не будет настроен на управление удаленным компьютером.

Обычно имеется возможность добавлять только оснастки, установленные на компьютере, который используется для создания консоли. Однако, если компьютер является частью домена, консоль MMC может быть использована для загрузки оснасток, которые не установлены локально, но доступны в службе каталога Active Directory. Дополнительные сведения о добавлении опубликованных оснасток и расширений на консоль см. в разделе Создание консолей. Дополнительные сведения о распространении программного обеспечения с помощью Active Directory см. в справке.


Виды панели задач и задачи

Виды панели задач представляют собой страницы, на которые могут быть добавлены представления области сведений консоли, а также ярлыки функций внутри и вне данной консоли. Эти ярлыки можно использовать для выполнения задач, например запуска мастера, открытия страницы свойств, выполнения команд меню, запуска командных строк или открытия веб-страниц. Вид панели задач может быть настроен таким образом, чтобы он содержал все задачи, которые могут понадобиться данному пользователю. Кроме того, на консоли можно создать несколько видов панели задач, поэтому имеется возможность группировать задачи по функциям и пользователям.

Виды панели задач могут упростить выполнение работы новичкам. Например, можно добавить все подходящие задачи на вид панели задач и затем скрыть дерево панели, так что пользователь может начать использовать средство еще до того, как будет изучено расположение отдельных элементов в дереве консоли и операционной системе.

Виды панели задач позволяют упростить сложные задачи. Например, если пользователь часто выполняет задачу, требующую несколько оснасток и другие программы, задачи могут быть представлены в одном месте, в котором открываются или запускаются необходимые диалоговые окна, страницы свойств, командные строки и сценарии.

Дополнительные сведения о создании видов панели задач и задач см. в разделе Создание консолей.


Дерево и корень консоли

Дерево консоли — это иерархическая структура в левой области консоли MMC. Дерево консоли показывает элементы, доступные в консоли. Эти элементы могут включать папки, оснастки, элементы управления, веб-страницы и другие средства.

Чтобы увидеть дерево новой консоли, откройте консоль MMC.

В новой консоли единственным элементом дерева консоли является папка, помеченная как «Корень консоли». Административные функции консоли могут быть созданы добавлением на консоль новых элементов. Рекомендации по добавлению элементов к консоли см. в разделе Создание консолей.

Если не нужно привязывать окно консоли к корню консоли, окно консоли может быть привязано к любому элементу в дереве консоли. В этом случае элементы дерева консоли выше корня скрываются и окно фокусируется на новом корневом элементе и любых средствах администрирования в подчиненной области (ниже по дереву).

Рекомендации по изменению корня консоли см. в разделе Создание нового окна консоли из части дерева консоли MMC.

Контейнеры в дереве консоли

Контейнером называется любой элемент дерева консоли, к которому добавлены элементы. Щелкнув знак плюс плюс, можно развернуть контейнер и отобразить его содержимое; знак минус минус сворачивает контейнер. Чаще всего контейнер — это просто папка папка, используемая для объединения элементов дерева консоли. Однако с помощью MMC можно добавлять средства к элементам, отличным от папок, и тогда эти элементы тоже становятся контейнерами.

Корень консоли является контейнером; его единственное назначение — содержать дерево консоли. Верхний элемент оснастки обычно является папкой или другим контейнером.

Отображаемый элемент представляет собой другой тип элемента, содержащего другие элементы. Щелчок по отображаемому элементу открывает в окне сведений список, текст или рисунок, а не дополнительные элементы. Веб-страницы являются отображаемыми элементами, так как для них требуется программа обозревателя, которая открывается только в области сведений. Не следует добавлять элементы к отображаемым элементам, так как пользователь может скрыть дерево консоли, не ожидая, что в отображаемом элементе содержатся другие элементы. Вместо этого, лучше создать для набора отображаемых элементов папку, добавив ее к дереву консоли. Это позволит пользователю выбирать из всех элементов такой папки при скрытом дереве консоли.

Инструкции по скрытию дерева консоли см. в разделе Скрытие и отображение компонентов сохраненной консоли MMC.

Лист — это единственный тип элемента, который не может содержать других элементов. Щелкнув лист, можно отобразить в панели сведений список элементов. Обычно это элементы, которые по отдельности включены в дерево консоли. Однако, если число таких элементов велико (сотни и тысячи), в оснастке желательно применять лист, а не контейнер.

Добавление новой возможности к консоли

Возможно ни одна из оснасток, предлагаемых командой Добавить или удалить оснастку, не соответствует требованиям. Можно попробовать возможные решения, перечисленные ниже.

  • Поищите требуемую оснастку или расширение на веб-страницах среди оснасток, поставляемых Microsoft или другими разработчиками.
  • Создайте собственное расширение для дополнения существующей оснастки или создайте новую изолированную оснастку.

Дополнительные сведения об этих возможностях см. в разделе Ресурсы.


Список «Избранное»

Список «Избранное» находится в меню Избранное. Список «Избранное» может быть использован для создания ярлыков элементов дерева консоли. Для удобства использования предоставлена возможность добавлять ярлыки для часто используемых инструментов или инструментов, расположенных в дереве консоли несколькими уровнями ниже. Новичкам список «Избранное» облегчает выполнение задач. Например, можно создать консоль с ярлыками в списке «Избранное» только для тех элементов в дереве консоли, которые нужны данному пользователю для выполнения своей работы. Для упрощения представления данных можно скрыть дерево консоли.

Список «Избранное» может быть использован для организации видов панели задач. Например, сложная консоль имеет несколько видов панели задач, которые распределяются между несколькими элементами в дереве консоли. Добавление этих видов панели задач к списку «Избранное» позволит пользователям обращаться к ним из одного места.

Дополнительные сведения см. в разделе Создание консолей.


Режимы доступа консоли

Создавая специальную консоль, можно присвоить ей один из двух основных режимов доступа: авторский режим или пользовательский режим. В свою очередь, существуют три уровня режима пользователя, так что всего имеется четыре варианта предустановленного режима доступа для консоли:

  • авторский режим;
  • режим пользователя - полный доступ;
  • режим пользователя - ограниченный доступ, многооконный;
  • режим пользователя - ограниченный доступ, однооконный.

Эти параметры могут быть настроены в диалоговом окне Параметры в консоли MMC. Сведения об открытии этого диалогового окна см. в разделе Установка параметров консоли MMC.

Назначение консоли авторского режима предоставляет полный доступ ко всем возможностям MMC, включая добавление и удаление оснасток, создание новых окон и видов панели задач, добавление элементов в список «Избранное» и просмотр любых частей дерева консоли. При выборе одного из режимов пользователя исключаются авторские возможности, которые пользователь не может использовать. Например, если для консоли установлен параметр пользовательский режим - полный доступ, предоставляются все команды управления окном и полный доступ к дереву консоли, но пользователю запрещено добавление и удаление оснасток и изменение свойств консоли.

Изменения, внесенные в консоль в авторском и пользовательском режимах, сохраняются по разному. Если работа ведется в авторском режиме, при закрытии консоли будет выведено предложение сохранить изменения. Однако при работе в пользовательском режиме и снятом флажке Не сохранять изменения для этой консоли (доступном по команде Параметры в меню Консоль) изменения будут сохранены автоматически, когда консоль закрывается.

Если выполнено одно из следующих условий, предустановленный режим консоли игнорируется и консоль открывается в авторском режиме.

  • MMC уже открыта при открытии консоли.
  • Консоль открыта с помощью команды контекстного меню Автор.
  • Консоль открыта в командной строке с параметром /a.

Подробнее о режимах консоли и синтаксисе командной строки см. в разделе Открытие консоли MMC.

Авторский режим не требуется пользователям, так как им не нужно создавать или изменять консоли MMC. Системный администратор может настроить профили пользователей так, чтобы запретить им переход в авторский режим как через параметр /a, так и через контекстное меню. Кроме того, администратор может использовать настройки групповой политики для запрещения пользователям открытия MMC и сохраненных консолей в авторском режиме. Дополнительные сведения см. в разделе Групповая политика и MMC.


Использование MMC

В этом разделе рассмотрены следующие темы.

  • Использование консолей MMC
  • Настройка групповой политики в MMC
  • Использование справочной системы консоли MMC
  • Разработка консолей MMC
  • Выполнение 32- и 64-разрядных оснасток в Win64


Использование консолей MMC

В процессе работы может понадобиться использовать сохраненные консоли MMC, являющиеся только частью операционной системы или приложения, и никогда не нужно будет создавать консоли для своих нужд. Такие заранее настроенные консоли обычно доступны в папке «Администрирование» на панели управления или в меню Пуск. Если специальная консоль сохранена в папке «Администрирование» для пользователя (размещается по адресу \\системный_диск\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), она доступна в папке «Администрирование» в меню Программы.

Возможно, что любая из заранее настроенных консолей, являющихся частью операционной системы, может быть отрыта в любом из трех пользовательских режимов. По умолчанию используется режим Режим пользователя - ограниченный доступ, однооконный. Дополнительные сведения настройках режима консоли по умолчанию см. в разделе Режимы доступа консоли.

Настройка вида MMC и сохраненных консолей

Чтобы скрыть и отобразить элементы консоли, можно использовать диалоговое окно Настройка вида, открываемое командой Настроить в меню Вид. Одним из элементов, которые могут быть скрыты, является само меню Вид. Если это было сделано, но необходимо перенастроить вид, диалоговое окно Настройка вида может быть открыто командой Настроить вид в системном меню. Дополнительные сведения см. в разделах Скрытие и отображение компонентов сохраненной консоли MMC и Скрытие и отображение меню и панелей инструментов для оснастки.

Работа со столбцами в сохраненных консолях

В сохраненных консолях, которые выводят столбцы в области сведений, может быть настроен внешний вид столбцов и строк. Например, можно изменить порядок столбцов или скрыть некоторые из них. Также, щелкнув заголовок столбца, можно выстроить строки в алфавитном или хронологическом порядке. Кроме того, в некоторых оснастках столбцы могут отфильтрованы в соответствии с дополнительными атрибутами. Если эта возможность разрешена, под заголовком столбца появляется ряд полей с раскрывающимися списками, содержащих параметры фильтрации. Дополнительные сведения о настройке столбцов см. в разделах Изменение порядка столбцов в консоли MMC, Скрытие и отображение столбцов в консоли MMC и Фильтрация строк в консоли MMC.

Содержимое столбцов может быть экспортировано в текстовый файл. Дополнительные сведения см. в разделе Экспорт столбцов консоли MMC в текстовый файл.

Если столбцы настроены в консоли, настройки автоматически сохраняются из сеанса в сеанс.

Использование страниц свойств в сохраненных консолях

Многие из работ с консолью выполняются на страницах свойств. Фактически, определенные оснастки или расширения доступны на консоли только через страницу свойств. Чтобы определить, какая оснастка предоставляет определенную страницу свойств, удерживайте нажатой клавишу CTRL, указывая мышью подпись вкладки на странице свойств. Если, нажав клавишу CTRL, указать мышью заголовок диалогового окна свойств, можно определить путь в дереве консоли к элементу, связанному со страницей свойств. Дополнительные сведения см. в разделе Просмотр связанной оснастки и элемента для страницы свойств.

Диалоговые окна свойств консолей часто бывают скрыты за файлами консолей и других средств. Если не удается найти страницу свойств, с которой производилась работа, просто откройте снова диалоговое окно или сверните другие программы на экране.

Использование консолей ранних версий ММС

Консоли, созданные с помощью более старых версий ММС ( версии 1.1 и 1.2), просматриваются ММС версии 2.0. Тем не менее, чтобы сохранить или изменить эти консоли, требуется преобразовать их в консоли ММС версии 2.0. Дополнительные сведения см. в разделе Использование старых и новых версий консолей ММС.


Настройка групповой политики в MMC

Эта возможность доступна только в сети с настроенной групповой политикой, системный администратор должет запустить оснастку «Групповая политика». Дополнительные сведения содержатся в разделе Групповая политика.

Политика Команда Результат
Установлен параметр Запретить пользователям использовать авторский режим. Открытие MMC или консоли в авторском режиме.
  • Введите mmc в командную строку.
  • Введите mmc путь\имя_файла.msc /a в командную строку.
  • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
  • Откройте файл консоли, настроенный на открытие в авторском режиме.
 Появится сообщение об ошибке отказа в доступе к файлу консоли в авторском режиме.

Пользователи с правами администратора могут открыть доступ на использование авторского режима. Ограничение доступа к MMC в авторском режиме.
Параметр Запретить пользователям использовать авторский режим отключен или не настроен. Открытие MMC или консоли в авторском режиме.
  • Введите mmc в командную строку.
    • .
  • Введите mmc путь\имя_файла.msc /a в командную строку.
    • .
  • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор
    • .
  • Откройте файл консоли, настроенный на открытие в авторском режиме
    • .
 Использование авторского режима не ограничивается.
Включен параметр Ограничить использование оснасток списком явно разрешенных оснасток. Открытие консоли, содержащей оснастку, не включенную в список разрешенных, или оснастку, расширенную оснасткой, не включенной в список разрешенных.
  • Введите mmc путь\имя_файла.msc в командную строку
    • .
  • Дважды щелкните файл .msc
    • .
  • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Открыть
    • .
 Появляется сообщение об ошибке.

Примечание

  • Если разрешена данная политика, только явно разрешенные оснастки появляются в вписке доступных оснасток в диалоговом окне Добавить изолированную оснастку в MMC — остальные оснастки запрещены.
Параметр Ограничить использование оснасток списком явно разрешенных оснасток отключен или на настроен. Открытие консоли, содержащей оснастку, не включенную в список разрешенных, или оснастку, расширенную оснасткой, не включенной в список разрешенных.
  • Введите mmc путь\имя_файла.msc в командную строку
    • .
  • Дважды щелкните файл .msc
    • .
  • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Открыть
    • .
 Использование консоли, содержащей оснастку не ограничено.
Явное разрешение оснастки. Открытие консоли, содержащей указанную оснастку или оснастку, расширенную указанной оснасткой.
  • Введите mmc путь\имя_файла.msc в командную строку
    • .
  • Дважды щелкните файл .msc
    • .
  • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Открыть
    • .
 Использование консоли, содержащей оснастку не ограничено.
Явное ограничение использования оснастки. Открытие файла консоли, содержащей указанную оснастку или оснастку, расширенную указанной запрещенной оснасткой.
  • Введите mmc путь\имя_файла.msc в командную строку
    • .
  • Дважды щелкните файл .msc
    • .
  • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Открыть
    • .
 Появляется сообщение об ошибке.
Политика разрешения или ограничения использования оснастки не настроена. Открытие файла консоли, содержащей указанную оснастку или оснастку, расширенную указанной оснасткой.
  • Введите mmc путь\имя_файла.msc в командную строку
    • .
  • Дважды щелкните файл .msc
    • .
  • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Открыть
    • .
 Использование консоли не ограничено, если пользователь, группа или подразделение не ограничены списком явно разрешенных оснасток.


Использование справочной системы консоли MMC

Вызвать справку позволяют: меню Справка главной панели инструментов, кнопка кнопка справки панели инструментов окна консоли, системное меню окна MMC или окна консоли, щелчок правой кнопкой мыши на дереве консоли или в области сведений и клавиша F1.

Справка для MMC отображает объединенное оглавление, включающее общую справку для MMC и специальную справку для каждой оснастки, добавленной к консоли. Справка оснастки обеспечивается только существующими файлами справки, разработанными для оснасток их авторами. При разработке консоли может потребоваться снабдить ее дополнительной документацией по выполняемым действиям, либо добавить сведения, предназначенные специально для пользователей сети.


Разработка консолей MMC

В этом разделе рассмотрены следующие темы.

  • Создание консолей
  • Сохранение консолей
  • Использование настраиваемых консолей

Дополнительные сведения о режиме автора см. в разделе Консоль MMC в авторском режиме.


Создание консолей

Прежде чем создавать новую консоль, необходимо определить действия, для которых предназначена новая консоль, список администрируемых компонентов, список оснасток и других элементов, которые потребуются для выполнения заданий. Следует также рассмотреть необходимость создания видов панели задач и задач. После принятия этих решений можно открыть новую консоль и начать добавлять элементы к дереву консоли. Руководство по созданию и настройке консолей см. на веб-узле корпорации Майкрософт (http://www.microsoft.com/)

Чтобы создать или изменить консоль, откройте консоль в авторском режиме (используйте параметр командной строки /a). Чтобы просмотреть полный синтаксис командной строки, см. раздел Открытие консоли MMC.

Добавление элементов к дереву консоли

Имеется возможность оказать помощь пользователям в поиске требуемых им компонентов консоли. Для этого расположите элементы иерархически или по группам в дереве консоли. Для добавления элементов к дереву консоли используется команда Добавить или удалить оснастку из меню Консоль главной панели инструментов MMC.

Список Оснастки в диалоговом окне Добавить/удалить оснастку определяет элемент дерева консоли, к которому выполняется добавление элементов. По умолчанию это Корень консоли. Можно щелкнуть и найти любой элемент дерева в поле Оснастки.

Диалоговое окно Добавить изолированную оснастку выводит список доступных оснасток. Для компьютеров, которые являются членами домена, этот список включает остановленные локально оснастки и оснастки, опубликованные в службе каталога Active Directory. Для оснасток, доступных в Active Directory, в столбце Поставщик появляется значение Не установлено.

Если данная оснастка уже установлена и требуется подключить одно из ее расширений, можно использовать вкладку Расширения в диалоговом окне Добавить/удалить оснастку. На этой вкладке можно выбрать любой элемент дерева консоли, позволяющий расширения, и просмотреть список расширений, которые могут быть включены или отключены. После подключения расширение автоматически размещается в дереве консоли под оснасткой, к которой оно относится. Если дерево консоли содержит больше одного экземпляра оснастки, к которой подключено расширение, все остальные экземпляры автоматически получают это расширение.

Подключив расширение, можно заметить, что оно появилось в списке Оснастки, которые могут быть расширены вместе с изолированными оснастками. Это означает, что расширение также имеет расширения, которые, в свою очередь, могут быть подключены.

Администратор может опубликовать в Active Directory и изолированные оснастки, и расширения. Расширения оснасток, доступные пользователю в Active Directory, появляются в списке доступных расширений, как и любые установленные локально расширения, но за ними следует фраза (не установлено). Чтобы расширения оснасток стали доступными на консоли, они должны быть загружены из службы каталога. Таким образом, для загрузки всех расширений указанного элемента не устанавливайте флажок Добавить все расширения на вкладке Расширения диалогового окна Добавить/удалить оснастку. Вместо этого, снимите этот флажок и установите флажки возле каждого из загружаемых расширений.

На консоль может быть добавлено несколько экземпляров одной оснастки, чтобы управлять несколькими удаленными компьютерами с одной консоли или чтобы восстановить поврежденную консоль. Пример последней ситуации: было обнаружено, что средство управления ведет себя не так, как ожидается. Это может быть связано с тем, что настройки устарели или превышен интервал ожидания вследствие удаления ресурсов. Чтобы восстановить консоль, попытайтесь добавить на консоль новый экземпляр оснастки, настройте его и затем удалите старый экземпляр оснастки с консоли.

Сведения о добавлении элементов в дерево консоли см. в разделах Добавление элемента на новую консоль MMC для локального компьютера, Добавление элемента на новую консоль MMC для удаленного компьютера, Добавление опубликованной оснастки на новую консоль MMC, Добавление расширения оснастки на консоль MMC и Добавление опубликованного расширения оснастки на консоль MMC.

Добавление видов панели задач и задач

Перед добавлением видов панели задач и задач на консоль определите число требуемых видов панели задач. Если требуется несколько видов панели задач, также необходимо определить разделение задач по этим видам. Кроме того, следует принять решение относительно типа используемой панели задач. Панель задач может отображать список и задачи или только задачи.

Чтобы создать вид панели задач для консоли, консоль должна содержать по крайней мере одну оснастку. Для настройки заголовков и списков, появляющихся в виде панели задач, и для определения одного или нескольких элементов в дереве консоли, с которыми связывается панель задач, может быть использован мастер создания вида панели задач.

После завершения работы мастера создания вида панели задач для добавления задач к виду панели задач можно использовать мастера создания задачи. Задачи могут включать команды меню для элементов консоли и команды, запускаемые из командной строки. Могут быть созданы команды, действующие как часть дерева консоли или области сведений или открывающие другой компонент на компьютере. Однако, если задача создана из команды меню для элемента в дереве консоли, а элемент удален, задача отключается.

Сведения о создании и изменении видов панели задач и задач см. в разделах Создание вида панели задач в сохраненной консоли MMC, Создание задач для вида панели задач в сохраненной консоли MMC, Изменение вида панели задач в сохраненной консоли MMC и Изменение задач в виде панели задач в сохраненной консоли MMC.

Просмотр дерева консоли в окне консоли

Если дерево консоли видно, оно появляется в левой области окна консоли. Дерево консоли может быть скрыто. Сведения о скрытии дерева консоли см. в разделе Скрытие и отображение компонентов сохраненной консоли MMC.

Содержание, отображаемое в окне консоли, определяется тем, какой элемент дерева консоли является корневым для окна консоли. Начальное окно новой консоли находится в папке «Корень консоли», как и новые окна создаваемые командой Новое из меню Окно главной панели инструментов.

Закройте окно консоли, чтобы скрыть корень консоли или все дерево консоли. Затем можно настроить консоль так, чтобы скрытые части дерева остались невидимыми для пользователей. Тем не менее при сохранении консоли запоминается полное дерево консоли.

Создание окон консоли для элементов дерева консоли

Хотя можно применить MMC для создания консолей, удовлетворяющих все потребности администрирования в группе, можно также разрабатывать и простые консоли для менее опытных пользователей. Например, добавив элементы к дереву консоли, можно открыть дополнительные окна для любых элементов дерева консоли. Этот метод позволяет создать окна для отдельных административных компонентов дерева консоли. Затем можно закрыть окна, которые пользователю видеть не требуется.

Закрытие окна не удаляет никаких элементов из дерева консоли; при закрытии окна удаляется только отображение его элементов. Все дерево консоли сохраняется вместе с консолью и всегда можно увидеть корень консоли.

Сведения об изменении корня консоли см. в разделе Создание нового окна консоли из части дерева консоли MMC.

Сведения о просмотре скрытого корня консоли см. в разделе Создание нового окна консоли из консоли MMC.

Добавление элементов в список «Избранное»

Список «Избранное» может быть использован для создания ярлыков элементов дерева консоли и видов панели задач. Эти значки затем доступны в меню Избранное.

Дополнительные сведения о создании списка «Избранное» см. в разделе Добавление элемента в список «Избранное» на консоли MMC и Упорядочение списка «Избранное» на консоли MMC.

Настройка параметров консоли

Для выбора значка, изменения названия и установки режима консоли по умолчанию можно использовать диалоговое окно Параметры, доступное через меню Консоль.

Значки находятся в нескольких источниках, включая файл Shell32.dll, находящийся в папке системный_корневой_каталог\system32.

При изменении названия консоли помните, что по умолчанию при выборе элементов в дереве консоли заголовок выводит путь к выбранному элементу. Но если название консоли изменено, путь в заголовке выводиться не будет. Однако при удалении названия восстанавливается настройка по умолчанию.

При рассмотрении вопроса о режиме консоли, используемом по умолчанию, помните, что при использовании одного из пользовательских режимов консоль может быть открыта в любой момент с помощью команд Автор или Запуск от имени — для большинства задач управления не потребуется использовать авторский режим.

Дополнительные сведения о параметрах консоли см. в разделах Установка параметров консоли MMC и Режимы доступа консоли.


Сохранение консолей

При сохранении консоли MMC в файл записываются: список загруженных оснасток консоли, размещение и содержимое окон консоли в главном окне MMC, режим по умолчанию, а также сведения о разрешениях. Все настройки инструментов и элементов управления сохраняются в консоли и восстанавливаются при открытии файла консоли. Можно открывать консоль на разных компьютерах или даже в разных сетях, восстанавливая при этом настройки всех инструментальных средств.

Файлы консоли имеют расширение .msc (management saved console). Используемая операционная система может уже иметь заранее настроенные и сохраненные файлы консоли, доступные в папке «Администрирование» на панели управления. Если создаются файлы консоли и сохраняются в папке «Администрирование» для пользователя (размещается по адресу: системный_диск\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), они доступны в папке «Администрирование» в меню Программы только для пользователя — файлы консоли недоступны для других пользователей компьютера. Сохраненную консоль можно записать на дискету, переслать по электронной почте или по локальной сети.

При работе с консолью в авторском режиме имеется возможность сохранения изменений в консоли с помощью команды Сохранить в меню Консоль. При работе с консолью в одном из пользовательских режимов возможность сохранения изменений в консоли определяется флажком Не сохранять изменения для этой консоли (доступен по команде Параметры в меню Консоль), устанавливаемым при настройке консоли. Если этот флажок не был установлен, изменения сохраняются автоматически при закрытии MMC. Если флажок был установлен, при закрытии MMC изменения теряются. Дополнительные сведения о сохранении консолей см. в разделе Сохранение файла консоли MMC. Дополнительные сведения режимах консоли см. в разделе Режимы доступа консоли.


Использование настраиваемых консолей

После того как консоль MMC создана и сохранена, она может быть использована на локальном компьютере, отправлена другим пользователям по электронной почте, передана по сети или Интернету или скопирована на гибкий диск для установки на других компьютерах. Кроме того, MMC и служба каталога Active Directory могут быть использованы для опубликования консолей или назначения их пользователям. Дополнительные сведения о распространении программного обеспечения с помощью Active Directory см. в справке.

Требования к использованию консоли

Использование консоли требует, чтобы имелся доступ к службам и средствам администрирования, добавленным на консоль, как к установленным на локальном компьютере, так и к доступным по сети. Необходимо также иметь административные разрешения для всех компонентов системы, администрируемых данной консолью.

Открытие сохраненной консоли

Если консоль сохранена в папке «Администрирование» для пользователя (размещается по адресу системный_диск\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), она доступна в папке «Администрирование» в меню Программы.

Если путь и имя файла консоли известны, консоль можно открыть как любой другой документ.

  • Двойным щелчком файла .msc.
  • Щелчком файла .msc правой кнопкой мыши и последующим выбором команды Открыть из контекстного меню.
  • Из командной строки.

Кроме того, на компьютерах под управлениемWindows XP Professional или Windows 2000 можно войти в систему с правами пользователя и выполнять обычные задачи, но использование команды Запуск от имени для открытия консоли и выполнения административных задач требует прав администратора. Чтобы использовать эту команду, введите runas в командной строке или щелкните правой кнопкой мыши файл .msc и выберите Запуск от имени из контекстного меню.

Дополнительные сведения об открытии консолей см. в разделах Открытие сохраненной консоли MMC для локального компьютера, Открытие сохраненной консоли MMC для удаленного компьютера и Открытие консоли MMC.


Администрирование консолей ММС

В этом разделе рассмотрены следующие темы.

  • Управление консолями ММС из командной строки


Управление консолями ММС из командной строки

С помощью командной строки возможно ограниченное использование консоли ММС. В принципе, ММС работает с графическим интерфейсом пользователя, поэтому режим графического интерфейса предпочтителен для использования. Параметры командной строки позволяют открыть консоль ММС, конкретные консоли, открыть консоли ММС в авторском режиме и определить, какая версия ММС открыта: 32-разрядная или 64-разрядная. Для получения подробных сведений см.Параметры командной строки ММС.


Ресурсы

Дополнительные сведения о MMC можно найти в следующих источниках.

  • На веб-узле центра технической поддержки корпорации Майкрософт, который находится по адресу: веб-узел корпорации Майкрософт (http://www.microsoft.com/), содержатся основные сведения о поддержке и статьи, написанные сотрудниками службы технической поддержки корпорации Майкрософт.
  • Руководство по созданию и настройке консолей ММС см. на веб-узле Windows по адресу веб-узел корпорации Майкрософт (http://www.microsoft.com/)


Специальные возможности MMC

В дополнение к продуктам и службам, поддерживающим специальные возможности в Microsoft Windows, консоль MMC обеспечивает комбинации клавиш для выбора команд и перемещения в окнах консоли и между ними.

  • Перемещения в MMC
  • Быстрые клавиши для главного окна MMC
  • Быстрые клавиши для окна консоли MMC

Оснастки и другие элементы, добавленные на консоль MMC, могут сами предоставлять специальные возможности. Дополнительные сведения см. в справке или другой документации по элементам консоли.


Перемещения в MMC

Развертывание и свертывание ветвей консоли MMC осуществляются с помощью значков плюс Плюс и минус Минус или одинарным и двойным щелчком кнопки мыши. Следующая таблица включает быстрые клавиши для перемещений как внутри окон, так и между окнами консоли.

Нажатие клавиш | Результат
TAB или F6 | Перемещает между областями активного окна консоли.
SHIFT+TAB или SHIFT+F6 | Перемещает между областями активного окна консоли в обратном направлении.
CTRL+TAB или CTRL+F6 | Перемещает вперед между окнами консоли.
CTRL+SHIFT+TAB или CTRL+SHIFT+F6 | Перемещает назад между окнами консоли.
ПЛЮС (+) на цифровой клавиатуре | Развертывает выбранный элемент.
МИНУС (-) на цифровой клавиатуре | Свертывает выбранный элемент.
Звездочка (*) на цифровой клавиатуре | Развертывает все дерево консоли под корневым элементом в окне консоли.
СТРЕЛКА ВВЕРХ | Перемещает выделение на один элемент вверх.
СТРЕЛКА ВНИЗ | Перемещает выделение на один элемент вниз.
PAGE UP | Перемещает выделение на самый верхний видимый элемент области.
PAGE DOWN | Перемещает выделение на самый нижний видимый элемент области.
HOME | Выбирает первый элемент области.
END | Выбирает последний элемент области.
СТРЕЛКА ВПРАВО | Развертывает выбранный элемент. Если выбранный элемент не содержит скрытых элементов, действует как стрелка вниз.
СТРЕЛКА ВЛЕВО | Свертывает выбранный элемент. Если выбранный элемент не содержит скрытых элементов, действует как стрелка вверх.
ALT+СТРЕЛКА ВПРАВО | Перемещает выделение на следующий элемент. Выполняет те же функции, что и стрелка «Вперед» на панели инструментов.
ALT+СТРЕЛКА ВЛЕВО | Перемещает выделение на предыдущий элемент. Выполняет те же функции, что и стрелка «Назад» на панели инструментов.

Следующая таблица включает список действий мыши для перемещения по дереву консоли.

Действия с мышью | Результат
Нажатие левой кнопки мыши | Выбирает элемент.
Двойной щелчок | Отображает либо скрывает элементы, скрытые внутри выбранного элемента. Отображает свойства либо открывает элемент.
Нажатие правой кнопки мыши | Отображает контекстное меню Действие для выбранного элемента.

Примечание

  • Если кнопки мыши ведут себя не так, как описано, то, вероятно, они переключены. Используемый компьютер, возможно, настроен так, что по умолчанию правой и левой кнопкам мыши приписаны обратные действия.


Быстрые клавиши для главного окна MMC

Следующая таблица включает быстрые клавиши, действительные для всей консоли или для главного окна консоли.

Команда | Результат
CTRL+O | Открывает сохраненную консоль.
CTRL+N | Открывает новую консоль.
CTRL+S | Сохраняет открытую консоль.
CTRL+M | Добавляет или удаляет элемент консоли.
CTRL+W | Открывает новое окно.
F5 | Обновляет содержимое всех окон консоли.
ALT + ПРОБЕЛ | Отображает системное меню MMC.
ALT+F4 | Закрывает консоль.
ALT+A | Открытие меню Действие.
ALT+V | Открытие меню Вид.
ALT+В | Открытие меню Консоль.
ALT+М | Открытие меню Избранное.

Примечание

  • Сочетание клавиш CTRL+W доступно для консолей, открытых в авторском режиме или пользовательском режиме с полным доступом. Другие сочетания с клавишей CTRL доступны только для консолей, открытых в авторском режиме.


Быстрые клавиши для окна консоли MMC

Следующая таблица включает быстрые клавиши для команд меню, работающих либо с активным окном консоли, либо с содержимым окна.

Команда | Результат
CTRL+P | Печатает текущую страницу или активную область.
ALT+МИНУС | Отображает системное меню активного окна консоли.
SHIFT+F10 | Отображает контекстное меню Действие для выбранного элемента.
F1 | Открывает раздел справки (если он есть) для выбранного элемента.
F5 | Обновляет содержимое всех окон консоли.
CTRL+F10 | Развертывает активное окно консоли.
CTRL+F5 | Восстанавливает активное окно консоли.
ALT+ENTER | Отображает диалоговое окно свойств выбранного элемента, если оно существует.
F2 | Переименовывает выбранный элемент.
CTRL+F4 | Закрывает активное окно консоли. Если консоль имеет единственное окно, то закрывается и консоль.


Устранение неполадок

Установите вид неполадки.

Не удается найти справку по оснастке.

Причина. Вызвать справку позволяют: меню Справка главной панели инструментов, значок кнопка справки на панели инструментов окна консоли, системное меню окна MMC или окна консоли, щелчок правой кнопкой мыши на дереве консоли или в области сведений и клавиша F1. Однако, если после добавления оснастки на консоль не удается стандартными способами обнаружить справочные сведения для добавленного объекта, то, возможно, оснастка не содержала файла справки для включения в справочную систему консоли. Оснастка может использовать другие способы предоставления справочных сведений.

Решение. Откройте в авторском режиме консоль, содержащую оснастку, щелкните в дереве консоли элемент, справку для которого нужно получить, и щелкните меню Справка. Над командой Вызов справки в меню Справка может появиться отдельная команда для справки по оснастке. Если отдельная команда не появилась, поищите в содержимом панелей инструментов и в области сведений кнопку справки или дополнительный Кнопка справки значок. Если отсутствуют дополнительная команда, кнопка и значок, то справка для оснастки недоступна через MMC.

Оснастка отсутствует в списке диалогового окна Добавить изолированную оснастку.

Причина. Соответствующая служба или программное обеспечение не установлены на компьютере.

Решение. Необходимо установить компонент, чтобы увидеть его оснастку.

См. также Установка программы, управляемой оснасткой консоли MMC.

Причина. Если используется компьютер под управлением Windows 2000 или Windows XP Professional, администратор мог установить политику, запрещающую доступ пользователя к оснастке.

Решение. Обратитесь к системному администратору.

См. также Настройка групповой политики в MMC.

При использовании консоли возникла одна или несколько следующих неисправностей: поведение консоли отличается от ожидаемого, превышен интервал ожидания консоли или выведены сообщения об ошибках, не появлявшиеся ранее.

Причина. Консоль повреждена или конфигурация консоли устарела из-за изменений в сети.

Решение. Определите оснастку, вызывающую проблему, и обратитесь к сведениям по устранению неполадок в документации по этой оснастке для нахождения способа восстановления или перенастройки оснастки. Чтобы выявить оснастку, вызывающую неполадки, щелкните правой кнопкой мыши элемент в дереве консоли или в области сведений и выберите из контекстного меню команду Свойства. Удерживая нажатой клавишу CTRL, укажите подписи вкладок диалогового окна.

Если не удается непосредственно восстановить или перенастроить консоль, попробуйте добавить на консоль другой экземпляр используемой оснастки, настройте ее и затем удалите старую версию оснастки.

См. также Добавление элемента на новую консоль MMC для локального компьютера, Добавление элемента на новую консоль MMC для удаленного компьютера, Оснастки и Просмотр связанной оснастки и элемента для страницы свойств.


Запрошенное средство недоступно.

Для доступа к этому средству попробуйте выполнить следующие действия.

Настройте компьютер

Чтобы получить доступ к определенным административным средствам, выполните следующие действия.

  • Компьютер под управлением Windows 2000 или Windows XP Professional должен быть настроен как контроллер домена.
  • На компьютере-клиенте с системой Windows 2000 Server или Professional (including Windows XP Professional), который был добавлен в домен, установите пакет средств администрирования Windows.
  • На компьютере-сервере с системой Windows 2000 Server или Windows XP Professional, который был добавлен в домен, установите пакет средств администрирования Windows.

Дополнительные сведения о настройке контроллера домена и установке пакета средств администрирования см. в справке.

Установите необходимое оборудование.

Некоторые программы устанавливаются автоматически при установке оборудования, для работы с которым они предназначены. Например, при установке устройства работы с факсами Windows установит компонент «Факс». Чтобы установить новое оборудование, нажмите кнопку Пуск на панели задач, выберите команды Настройка и Панель управления и дважды щелкните значок Установка оборудования (Windows XP Professional и Windows 2000).

Установите данное средство.

Средство может быть не установлено на компьютере по следующим причинам.

  • Средство является необязательным компонентом. Чтобы установить дополнительный компонент, нажмите кнопку Пуск, выберите команды Настройка и Панель управления и дважды щелкните значок Установка и удаление программ.
  • Если компьютер работает в сети, системный администратор мог удалить эту программу или установить политику, не позволяющую запускать ее.
  • На компьютере установлены средства администрирования; и это средство является одним из дополнительных компонентов, которые еще не были установлены.

Необходим доступ к оснастке Active Directory.

Для доступа к службам терминалов на компьютере под управлением операционной системы Windows 2000 Server, в которой имеется эта оснастка, можно использовать средство Windows XP «Дистанционное управление рабочим столом». Для получения дополнительных сведений об использовании средства «Дистанционное управление рабочим столом» и служб терминалов Windows 2000 см.

  • Чтобы создать новое подключение
  • Документация Microsoft Windows 2000 Server (http://www.microsoft.com/)

Обратитесь к системному администратору.

Если компьютер работает в сети, системный администратор мог удалить это средство.


Выполнение 32- и 64-разрядных оснасток в Win64

64-разрядные операционные системы корпорации Майкрософт могут выполнять и 32-разрядные консоли ММС (ММС32), и 64-рязрядные (ММС64). Консоль ММС64 не может выполнять 32-разрядные оснастки, а ММС32 — 64-разрядые. В данном разделе даются инструкции по управлению и определению, какая версия ММС выполняется на 64-разрядной операционной системе корпорации Майкрософт.

Консоль ММС запускается с помощью параметров командной строки, например имени файла консоли. Также ММС64 распознает следующие параметры командной строки.

  • /32
  • /64

Если в командной строке определены оба приведенных параметра, выполняется крайний правый параметр.

Выбор варианта запуска, если указан параметр /32 или /64

Если консоль ММС64 запускается без параметров командной строки или с параметром /64, то она выполняется как приложение ММС64. Если консоль ММС64 запускается с параметром командной строки /32, открывается консоль ММС32 с теми же параметрами, что в исходной ММС64 (за исключением параметра командной строки /32),а ММС64 завершает работу.

Выбор варианта запуска, если указан файл консоли

Если командная строка консоли ММС64 не содержит параметра /32 или /64, но в ней указано имя файла консоли, ММС64 проверяет файл перед определением, какую версию ММС выбрать для выполнения. ММС64 использует следующий алгоритм.

  1. Если все оснастки из файла консоли доступны в 64-разрядном режиме, консоль ММС64 является рабочей версией (дальнейшие шаги алгоритма не выполняются). Оснастка считается доступной в 64-разрядном режиме, если она указана в реестре как раздел HKEY_CLASSES_ROOT\CLSID\код_класса_оснастки\InprocServer32, где код_класса_оснастки — зарегистрированный код класса CLSID оснастки.
  2. Если же не все из оснасток, находящихся в файле консоли, доступны в 64-разрядном режиме, а в 32-разрядном доступны все, запускается версия ММС32. ММС32 выполняется с помощью указанного в командной строке файла консоли, а ММС64 приостанавливает работу (дальнейшие шаги алгоритма не выполняются). Оснастка считается доступной в 32-разрядном режиме, если она указана в реестре как раздел HKEY_CLASSES_ROOT\Wow6432Node\CLSID\код_класса_оснастки\InprocServer32, где код_класса_оснастки — зарегистрированный код CLSID для этой оснастки.
  3. Если количество недоступных 64-разрядных оснасток является подмножеством недоступных 32-разрядных оснасток, рабочей версией остается консоль ММС64 ( дальнейшие шаги алгоритма не выполняются).
  4. Если количество недоступных 32-разрядных оснасток является подмножеством недоступных 64-разрядных оснасток, консоль ММС64 запускает ММС32 и прекращает работу (дальнейший шаг алгоритма не выполняется).
  5. Если же ни один из предыдущих шагов не подходит, пользователю предоставляется право с помощью интерфейса пользователя определить версию консоли ММС для запуска ( пользователь может также отменить версию).

В любом случае при неудачном запуске ММС32, продолжает работать консоль ММС64. После успешного запуска консоли ММС32 консолью ММС64, работа последней завершается. При возникноверии ошибки после успешного запуска консоли ММС32, консоль ММС64 не будет уведомлена, т.к. она закрыта.


Настройка столбцов в сохраненных консолях MMC

В сохраненных консолях MMC, которые выводят столбцы в области сведений, может быть настроен внешний вид столбцов и строк. Например, можно изменить порядок столбцов или скрыть некоторые из них. Также, щелкнув заголовок столбца, можно выстроить строки в алфавитном или хронологическом порядке. Кроме того, в некоторых оснастках столбцы могут отфильтрованы в соответствии с дополнительными атрибутами. Если эта возможность разрешена, под заголовком столбца появляется ряд полей с раскрывающимися списками, содержащих параметры фильтрации. Дополнительные сведения о настройке столбцов см. в разделах Изменение порядка столбцов в консоли MMC, Скрытие и отображение столбцов в консоли MMC и Фильтрация строк в консоли MMC.

Содержимое столбцов может быть экспортировано в текстовый файл. Дополнительные сведения см. в разделе Экспорт столбцов консоли MMC в текстовый файл.

Если столбцы настроены в консоли, настройки автоматически сохраняются из сеанса в сеанс.


Работа с файлами консоли управления MMC

Консоль управления Microsoft Management Console (MMC) группирует средства, включая оснастки, которые применяются для администрирования как локальных, так и удаленных компьютеров. Система Windows может уже включать служебные программы, сохраненные как файлы консоли (с расширением .msc). Эти программы доступны в папке «Администрирование» на панели управления и в меню Программы. Кроме того, можно создавать специализированные средства администрирования и рассылать их пользователям. В Windows XP Professional и Windows 2000 Server средства можно сохранить так, что они будут доступны в папке «Администрирование» в меню Программы.

  • Администрирование локальных компьютеров

    • Чтобы добавить элемент на новую консоль MMC для локального компьютера

    1. Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc и нажмите кнопку OK.
    2. В меню Консоль выберите команду Добавить или удалить оснастку и нажмите кнопку Добавить.
    3. В списке Оснастка двойным щелчком выберите добавляемый элемент, затем выполните одно из следующих действий.
      • Установите переключатель в положение локальным компьютером (тем, на котором она выполняется) и нажмите кнопку Готово.
      • Если появится окно мастера, следуйте указаниям на экране.
    4. Чтобы добавить на консоль еще один элемент, повторите шаг 3.

    Примечания

    • Если консоль сохранена в папке «Администрирование» для пользователя (размещается по адресу системный_диск\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), она доступна для этого пользователя в папке «Администрирование» в меню Программы.
    • Если оснастка не появилась в списке, необходимо предварительно установить программу, устройство или службу, администрируемые этим объектом.
    • Чтобы добавить подчиненный элемент для элемента, не являющегося корнем консоли, щелкните соответствующий элемент в списке Оснастки, прежде чем на шаге 2 нажать кнопку Добавить.

    Чтобы открыть сохраненную консоль MMC для локального компьютера

    • Выполните одно из следующих действий.
      • Нажмите кнопку Пуск, выберите команды Настройка и Панель управления, дважды щелкните значок Администрирование, а затем дважды щелкните консоль.
      • Нажмите кнопку Пуск и выберите команды Программы, Администрирование и щелкните консоль.
      • Щелкните консоль в меню Программы.
      • Откройте папку, в которой размещена консоль, и дважды щелкните консоль.
  • Администрирование удаленных компьютеров

    • Чтобы добавить элемент на новую консоль MMC для удаленного компьютера

    1. Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc и нажмите кнопку OK.
    2. В меню Консоль выберите команду Добавить или удалить оснастку и нажмите кнопку Добавить.
    3. В списке Оснастка двойным щелчком выберите добавляемый элемент, затем выполните следующие действия.
      • Установите переключатель другим компьютером, введите имя компьютера, который будет управляться оснасткой, и нажмите кнопку Готово.
      • Если появится окно мастера, следуйте указаниям на экране.
    4. Чтобы добавить на консоль еще один элемент, повторите шаг 3.

    Примечания

    • Если оснастка не появилась в списке, необходимо предварительно установить программу, устройство или службу, администрируемые оснасткой на удаленном компьютере.
    • Если диалоговое окно или мастер не появились на шаге 3, данную оснастку можно использовать только для администрирования локального компьютера.
    • Если консоль сохранена в папке «Администрирование» для пользователя (размещается по адресу: системный_диск\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), она доступна для этого пользователя в папке «Администрирование» в меню Программы.
    • Чтобы добавить подчиненный элемент для элемента, не являющегося корнем консоли, щелкните соответствующий элемент в списке Оснастки, прежде чем на шаге 2 нажать кнопку Добавить.

    Чтобы открыть сохраненную консоль MMC для удаленного компьютера

    • Выполните одно из следующих действий.
      • Нажмите кнопку Пуск и выберите команды Программы, Администрирование и щелкните консоль.
      • Откройте папку, в которой размещена консоль, и дважды щелкните соответствующую консоль.
  • Общие процедуры

    • Чтобы открыть консоль MMC

    • Введите в командную строку команду:

      • mmc

    Чтобы установить программу, управляемую оснасткой консоли MMC

    1. Нажмите кнопку Пуск, выберите команды Настройка и Панель управления, а затем дважды щелкните значок Установка и удаление программ.
    2. Следуйте указаниям на экране.


Дополнительная справка в Интернете

Если на возникшие технические вопросы по операционной системе Windows не удается найти ответы ни в ее справке, ни в другой документации, обратитесь к изготовителю компьютеров, предоставившему данное программное обеспечение.

Служба поддержки Майкрософт Самую свежую техническую информацию по продуктам корпорации Майкрософт можно получить в интерактивной службе поддержки на веб-узле Майкрософт (http://www.microsoft.com/).


Интерактивная поддержка

Интерактивная поддержка и информация
Интерактивная поддержка
и информация
  • Домашняя страница Windows (http://www.microsoft.com/windows)
  • Рекомендации и практические советы пo Windows (http://www.microsoft.com/windows)
  • Загрузка обновлений, новых возможностей и драйверов с веб-узла Windows Update (http://windowsupdate.microsoft.com)
  • Поиск совместимого с Windows программного обеспечения (http://www.microsoft.com/windows)
  • Поиск совместимого с Windows оборудования (http://www.microsoft.com/windows)
  • Сведения о пакете Windows Resource Kit (http://windows.microsoft.com/windows2000/reskit)
  • Сведения о ресурсах специальных возможностей (http://www.microsoft.com/enable)