Attrib

Изменение атрибутов отдельного файла или папки. Эта команда позволяет устанавливать и удалять атрибуты, назначенные файлам и папкам, такие как «Только чтение», «Сжатый», «Системный» и «Скрытый».

Команда attrib с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда attrib с другими параметрами доступна из командной строки.

attrib [+r|-r] [+s|-s] [+h|-h] [+c|-c] [[диск:][путь] имя_файла]

Параметры

+r

Установка атрибута «Только чтение».

-r

Удаление атрибута «Только чтение».

+s

Установка атрибута «Системный».

-s

Удаление атрибута «Системный».

+h

Установка атрибута «Скрытый».

-h

Удаление атрибута «Скрытый».

+c

Установка атрибута «Сжатый».

-c

Удаление атрибута «Сжатый».

[[диск:]путь] имя_файла]

Задание размещения и имени файла или папки, атрибуты которых следует изменить. Одновременно могут быть изменены атрибуты только одного файла или одной папки.

Примечание

  • Одной командой могут быть изменены сразу несколько атрибутов одного файла или одной папки.

См. также


Batch

Выполнение команд, указанных в текстовом файле. Команда batch доступна только при использовании консоли восстановления, которую можно запустить с установочного компакт-диска.

batch входной_файл [выходной_файл]

Параметры

входной_файл

Текстовый файл, содержащий список команд, которые должны быть выполнены. Входной_файл может состоять из имени диска с двоеточием, имени каталога, имени файла или их комбинации.

выходной_файл

Если этот параметр задан, он указывает файл, в котором сохраняются выходные данные команд. Если файл не задан, информация выводится на экран.

Пример

В следующем примере исполняется пакетный файл C:\Jobs\Find.txt, а выходные данные выводятся в файл C:\Jobs\Results.txt.

batch c:\jobs\find.txt c:\jobs\results.txt

Примечание

  • Пакетный файл не может содержать вложенную команду batch.


Bootcfg

Команда bootcfg предназначена для настройки и восстановления конфигурации загрузки (на большинстве компьютеров она хранится в файле boot.ini).

Команда bootcfg с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда bootcfg с другими параметрами доступна из командной строки.

Использование

bootcfg /default

Загрузочная запись, используемая по умолчанию.

bootcfg /add

Добавление установленной копии Windows в список для загрузки.

bootcfg /rebuild

Просмотр всех установленных копий Windows с возможностью выбора копий, добавляемых в список.

Примечание

  • Перед использованием команды bootcfg /rebuild следует создать резервную копию файла boot.ini с помощью команды bootcfg /copy.

bootcfg /scan

Поиск установленных копий Windows на всех дисках и отображение результатов.

Примечание

  • Результаты поиска сохраняются в течение одного сеанса. Если в течение этого сеанса конфигурация дисков изменилась, для получения обновленных результатов сканирования необходимо перезагрузить компьютер и повторить сканирование.

bootcfg /list

Вывод списка записей, имеющихся в загрузочном списке.

bootcfg /disableredirect

Отключение перенаправления в загрузчике.

bootcfg /redirect [скорость_порта] | [useBiosSettings]

Включение перенаправления загрузчика с заданной конфигурацией.

Пример

bootcfg /redirect com1 115200

bootcfg /redirect useBiosSettings


Chdir (Cd)

Вывод имени текущего каталога или переход в другую папку.

Команды chdir и cd с перечисленными ниже параметрами доступны только при использовании консоли восстановления. Команда chdir с другими параметрами доступна из командной строки.

chdir [диск:][путь] [..]

-или-

cd [диск:][путь] [..]

Параметры

отсутствуют

При вызове команды chdir без параметров будет выведено имя текущего диска и папки. При вызове только с именем диска (например cd C:) команда chdir выводит текущую папку на указанном диске.

[диск:][путь]

Задание имени диска (если он отличается от текущего) и папки, куда требуется перейти.

[..]

Задание перехода в родительскую папку. Пробел между chdir и двумя точками обязателен.

Примечания

  • При вызове команды сhdir пробелы рассматриваются как разделители. Имя папки, содержащее пробелы, следует заключать в кавычки. Например:

    cd "driver cache"

  • Команда Chdir работает только в системных папках имеющейся установленной версии Windows, папках съемных носителей, в корневой папке любого раздела жесткого диска и локальных папках-источниках для установки.


Chkdsk

Создание и отображение отчета о состоянии диска. Команда chkdsk также составляет список ошибок на диске и исправляет их.

Команда chkdsk с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда chkdsk с другими параметрами доступна из командной строки.

chkdsk [диск:] [/p] [/r]

Параметры

отсутствуют

Команда chkdsk без параметров выводит информацию о состоянии текущего диска.

диск:

Диск, который следует проверить с помощью команды chkdsk.

/p

Выполнение углубленной проверки, даже если диск не отмечен для проверки посредством chkdsk. Использование данного параметра не приводит к изменению диска.

/r

Поиск поврежденных секторов и восстановление той части данных, которая еще может быть прочитана. Действие этого параметра включает в себя действие параметра /p.

Примечание

  • Для выполнения команды chkdsk необходим файл Autochk.exe. Если данный файл отсутствует в папке запуска (по умолчанию \%systemroot%\Winnt\System32), будет произведена попытка поиска данного файла на установочном компакт-диске Windows. Если на компьютере установлено несколько операционных систем, команду необходимо вводить с диска, содержащего Windows.


Cls

Очистка экрана.

На очищенном экране отображаются только командная строка и курсор.

cls

Параметры

отсутствуют


Copy

Копирование одного файла в другую папку. Команда copy с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда copy с другими параметрами доступна из командной строки.

copy исходный_файл [конечный_файл]

Параметры

исходный_файл

Размещение и имя файла, который подлежит восстановлению. Параметр исходный_файл может состоять из имени диска с двоеточием, имени папки, имени файла или их комбинации.

конечный_файл

Размещение и имя файла или набора файлов, куда следует скопировать данные. Параметр конечный_файл может состоять из имени диска с двоеточием, имени папки, имени файла или их комбинации.

Примечания

  • В качестве размещения исходных файлов могут задаваться съемные носители, любые папки в системных папках текущей установленной копии Windows, корневые папки любых дисков, локальные источники установки или папка Cmdcons.
  • В качестве размещения конечных файлов может указываться то же размещение, что и для исходных файлов, кроме случая съемных носителей. Если назначение не указано, по умолчанию используется текущая папка.
  • Сжатый файл, копируемый с исходного диска Windows, распаковывается.
  • Команда Copy не поддерживает подстановочные символы.


Delete (Del)

Удаление одного файла. Команды delete и del с перечисленными ниже параметрами доступны только при использовании консоли восстановления. Команды delete и del с другими параметрами доступны из командной строки.

delete [диск:][путь] имя_файла

-или-

del [диск:][путь] имя_файла

Параметры

[диск:][путь] имя_файла

Имя и размещение удаляемого файла.

Примечание

  • Команда delete может быть выполнена только в системных папках текущей установленной копии Windows, папках съемных носителей, в корневой папке любого раздела жесткого диска и локальных источниках установки.


Dir

Вывод списка файлов и подпапок в папке. Команда dir с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда dir с другими параметрами доступна из командной строки.

dir [диск:][путь][имя_файла]

Параметры

[диск:][путь]

Задание диска и папки, содержимое которой будет отображено.

[имя_файла]

Задание файла или группы файлов, сведения о которых будут выведены. Может быть задано несколько файлов. Имена файлов могут быть разделены пробелами, запятыми или точками с запятой. Для вывода группы файлов в параметре имя_файла допускается применение подстановочных символов (? и *).

Команда dir также позволяет вывести метку тома и серийный номер диска, общее число перечисленных в списке файлов, их общий размер и размер свободного места на диске (в байтах). Команда dir выводит для каждого файла в подпапке расширение имени файла, размер файла в байтах, дату и время последнего изменения файла и указанные атрибуты файла (если атрибут доступен).

Сокращение | Атрибут
d | Папка
h | Скрытый файл
s | Системный файл
e | Зашифрованный файл
r | Только чтение
a | Файл, готовый к архивированию
c | Сжатый файл
p | Точка повторной обработки

Примечание

  • Команда dir может выполняться только в системных папках текущей установленной копии Windows, папках съемных носителей, в корневой папке любого раздела жесткого диска и локальных папках источников установки.


Disable

Отключение службы или драйвера устройства операционной системы Windows XP, Windows 2000 или Windows NT 4.0. Команда disable доступна только при использовании консоли восстановления.

disable {[имя_службы] | [имя_драйвера_устройства]}

Параметры

имя_службы

Имя системной службы, которую следует отключить.

имя_драйвера_устройства

Имя драйвера устройства, который следует отключить.

Пример

В следующем примере отключается служба Eventlog.

disable eventlog

Примечания

  • Команда disable устанавливает для указанной службы или указанного драйвера тип запуска SERVICE_DISABLED.
  • При использовании команды disable для отключения системной службы или драйвера устройства на экране будет отображено имя предыдущего типа запуска данной службы или драйвера. Данное имя следует запомнить или записать на случай необходимости восстановления предыдущего значения типа запуска при помощи команды enable.
  • Существуют пять типов запуска: первые три, SERVICE_AUTO_START, SERVICE_DISABLED и SERVICE_DEMAND_START, соответствуют стандартным типам запуска — автоматическому запуску, отключению службы или драйвера и запуску вручную; данные типы запуска обычно настраиваются в окне «Службы» средства «Управление компьютером»; остальные два типа, SERVICE_BOOT_START и SERVICE_SYSTEM_START, обычно используются для задания способа загрузки драйвера устройства, например, при запуске компьютера или при запуске Windows.


Diskpart

Создание и удаление разделов на жестком диске. Команда diskpart доступна только при использовании консоли восстановления.

diskpart [/add | /delete] [имя_устройства | имя_диска | имя_раздела] [размер]

Параметры

отсутствуют

Команда diskpart без параметров задает запуск версии средства diskpart с текстовым интерфейсом.

/add

Создание нового раздела

/delete

Удаление существующего раздела.

имя_устройства

Устройство, на котором необходимо создать или удалить раздел. Для получения имени устройства можно воспользоваться командой map. Имя устройства может выглядеть следующим образом.

\Device\HardDisk0

имя_диска

Буквенное обозначение раздела, который следует удалить. Используется только с параметром /delete. Имя диска может выглядеть следующим образом.

D:

имя_раздела

Имя раздела, который следует удалить. Может использоваться вместо параметра имя_диска. Используется только с параметром /delete. Имя раздела может выглядеть следующим образом.

\Device\HardDisk0\Partition1

размер

Размер, в мегабайтах (Мбайт), раздела, который требуется создать. Используется только с параметром /add.

Примеры

В следующих примерах раздел удаляется.

diskpart /delete \Device\HardDisk0\Partition3

diskpart /delete F:

В следующем примере на жестком диске создается раздел размером в 20 Мбайт.

diskpart /add \Device\HardDisk0 20


Enable

Включение службы или драйвера устройства операционной системы Windows XP, Windows 2000 или Windows NT 4.0. Команда enable доступна только при использовании консоли восстановления.

enable {имя_службы | имя_драйвера_устройства} [тип_запуска]

Параметры

имя_службы

Имя системной службы, которую требуется включить.

имя_драйвера_устройства

Имя драйвера устройства, который следует включить.

тип_запуска

Тип запуска, который требуется назначить данной службе или драйверу устройства. Существуют следующие типы запуска.

  • SERVICE_BOOT_START
  • SERVICE_SYSTEM_START
  • SERVICE_AUTO_START
  • SERVICE_DEMAND_START

Пример

В следующем примере службе Eventlog назначается автоматический тип запуска (SERVICE_AUTO_START).

enable eventlog service_auto_start

Примечания

  • Если тип запуска не указан, результатом выполнения команды enable будет отображение текущего типа запуска службы или драйвера устройства, указанного в качестве значения параметра имя_службы.
  • При изменении типа запуска командой enable на экране будет отображено имя предыдущего типа запуска. Данное имя следует запомнить или записать на случай необходимости восстановления предыдущего значения типа запуска.


Exit

Закрытие консоли восстановления и перезапуск компьютера. Команда exit доступна только при использовании консоли восстановления.

exit

Параметры

отсутствуют


Expand

Извлечение файла из сжатого файла. Данная команда может использоваться для извлечения файла драйвера из CAB-файла или сжатого файла.

Команда expand с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда expand с другими параметрами доступна из командной строки.

expand источник [/F:имя_файла}] [назначение] [/d] [/y]

Параметры

источник

Файл, который требуется развернуть. Данный параметр следует использовать, если исходный файл содержит в себе только один файл. Параметр источник может состоять из имени диска с двоеточием, имени папки, имени файла или их комбинации. Использование подстановочных символов не допускается.

/f:имя_файла

Если в источнике содержится более одного файла, данный параметр задает имя файла, который требуется развернуть. Для указания извлекаемых файлов могут использоваться подстановочные символы.

назначение

Папка или имя извлеченного файла.

/d

Перечисление файлов, содержащихся в CAB-файле, без их разворачивания или излечения.

/y

Подавление запроса о перезаписи файла при разворачивании или извлечении.

Примеры

В следующем примере файл Msgame.sys извлекается из CAB-файла Drivers с установочного компакт-диска и копируется в каталог C:\Windows\System\Drivers.

expand d:\i386\driver.cab /f:msgame.sys c:\Windows\system\drivers

В следующем примере разворачивается сжатый файл Access.cp_.

expand d:\i386\acces.cp_ c:\Windows\system32\access.cpl

В следующем примере выводится список всех файлов в CAB-файле Drivers с установочного компакт-диска.

expand /d d:\i386\driver.cab

Важно!

  • CAB-файл Drivers, который содержит большую часть драйверов, входящих в комплект Windows, включает в себя тысячи файлов. Разворачивание всех файлов из данного CAB-файла на жесткий диск потребует значительного времени и большого объема дискового пространства. Рекомендуется извлекать из данного CAB-файла только необходимые файлы.

Примечания

  • Если назначение не указано, файл копируется по умолчанию в текущую папку.
  • В качестве назначения не может быть задан съемный носитель, такой как гибкий диск или компакт-диск.


Fixboot

Запись в системный раздел нового загрузочного сектора. Команда fixboot доступна только при использовании консоли восстановления.

fixboot [диск]

Параметры

диск

Диск, на который требуется записать загрузочный сектор. По умолчанию используется системный раздел, с которого была осуществлена загрузка системы. Имя диска может выглядеть следующим образом.

D:

Пример

В следующем примере новый загрузочный сектор будет записан в системный раздел диска D.

fixboot d:

Примечание

  • При вводе команды fixboot без параметров новый загрузочный сектор записывается в системный раздел, с которого была осуществлена загрузка системы.


Fixmbr

Восстановление основной загрузочной записи загрузочного диска. Команда fixmbr доступна только при использовании консоли восстановления.

fixmbr [имя_устройства]

Параметры

имя_устройства

Устройство (диск), на которое требуется записать новую основную загрузочную запись. Для получения имени устройства можно воспользоваться командой map. Имя устройства может выглядеть следующим образом.

\Device\HardDisk0

Пример

В следующем примере новая основная загрузочная запись записывается на указанное выше устройство.

fixmbr \Device\HardDisk0

Примечания

  • Если параметр имя_устройства не указан, новая основная загрузочная запись будет записана на устройство загрузки, которое является диском, с которого была загружена основная система.
  • Если обнаружена неправильная или нестандартная подпись таблицы разделов, выводится запрос подтверждения продолжения работы. Если доступ к дискам осуществляется без сбоев, на подтверждение следует ответить отрицательно. Запись новой основной загрузочной записи на системный раздел может привести к повреждению таблиц разделов, в результате чего разделы могут стать недоступными.


Format

Форматирование указанного диска для заданной файловой системы. Команда format с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда format с другими параметрами доступна из командной строки.

format [диск:] [/q] [/fs:файловая_система]

Параметры

диск:

Диск, который требуется отформатировать. Из консоли восстановления не могут форматироваться гибкие диски

/q

Быстрое форматирование диска. Диск не сканируется на предмет поврежденных областей; использование данного параметра допускается только для дисков, которые уже форматировались.

/fs:файловая_система

Тип файловой системы, которая будет создана на диске: FAT, FAT32 или NTFS. Если файловая система не указана, будет использоваться формат текущей файловой системы.


Help

Вывод справки о командах консоли восстановления.

help [имя_команды]

Параметры

Отсутствуют

Перечень команд, доступных из консоли восстановления.

имя_команды

Вывод сведений о команде, включая допустимые параметры.

Примечание

  • Существует два способа получения интерактивной справки о команде. Можно указать имя интересующей команды после команды help или ввести имя команды с ключом /? в командной строке. Например, оба следующих варианта выведут информацию о команде extract.

    help extract
    extract /?


Listsvc

Вывод списка служб и драйверов, установленных на данном компьютере. Команда listsvc доступна только при использовании консоли восстановления.

listsvc

Параметры

отсутствуют


Logon

Вход в установленную копию операционной системы Windows. Команда logon доступна только при использовании консоли восстановления.

logon

Параметры

Отсутствуют

Примечания

  • Команда logon выводит список всех обнаруженных установленных копий Windows и запрашивает пароль локального администратора той системы, в которую требуется войти.
  • После трех неудачных попыток входа работа консоли восстановления завершается и компьютер перезагружается.


Map

Отображение соответствий буквенных обозначений дисков и имен физических устройств. Данные сведения могут потребоваться при использовании команд fixboot и fixmbr. Команда map доступна только при использовании консоли восстановления.

Map [arc]

Параметры

arc

Отображение имен устройств, выводимых командой map, в формате Advanced RISC Computing (ARC) вместо обычных имен устройств. Имя устройства в формате ARC может выглядеть следующим образом.

multi(0)disk(0)rdisk(0)partition(1)

Аналогичное обычное имя устройства выглядит так.

\Device\HardDisk0\Partition1

Пример

В следующем примере задается отображение соответствий имен физических устройств и имен устройств в формате ARC.

map arc

Примечания

  • Без указания параметра arc команда map отображает имена устройств.
  • Команда map также отображает тип файловой системы и размер каждого диска в мегабайтах (Мбайт).


Mkdir (Md)

Создание папки или подпапки. Команда mkdir с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда mkdir с другими параметрами доступна из командной строки.

mkdir [диск:]путь

-или-

md [диск:]путь

Параметры

диск:

Диск, на котором будет создана новая папка.

путь

Имя и размещение новой папки. Использование подстановочных символов (* и ?) не допускается.

Примечание

  • Mkdir работает только в системных папках текущей установленной копии Windows, папках съемных носителей, в корневой папке любого раздела жесткого диска и локальных источниках установки.


More

Вывод содержимого текстового файла на экран. Команды more и type применяются для просмотра текстового файла без внесения в него изменений. Команда more с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда more с другими параметрами доступна из командной строки.

more [диск:][путь] имя_файла

-или-

type [диск:][путь] имя_файла

Параметры

[диск:][путь] имя_файла

Размещение и имя файла, который требуется просмотреть.

Если в файловой системе NTFS имя файла содержит пробелы, его необходимо заключать в кавычки (").


Delete (Del)

Рисунок Microsoft Windows

Net use

Подключение сетевого ресурса к букве диска. Команда net use с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда net use с другими параметрами доступна из командной строки.

Синтаксис

net use [\\имя_компьютера\имя_ресурса [/user:[имя_домена\]имя_пользователя] пароль] | [буква_диска:] [/d]

Параметры

\\имя_компьютера\имя_ресурса

Имя сервера и общего ресурса. Если параметр имя_компьютера содержит пробелы, все имя компьютера от двойной обратной черты (\\) до конца должно быть заключено в прямые кавычки ("). Имя компьютера может иметь длину от 1 до 15 знаков.

/user:

Задание имени пользователя для подключения к общему ресурсу.

имя_домена

Имя домена для проверки учетных данных пользователя.

имя_пользователя

Имя пользователя для подключения.

пароль

Пароль, необходимый для подключения к общему ресурсу. Если пароль не указан, будет выведено приглашение для его ввода. При вводе с клавиатуры символы пароля не отображаются на экране.

/d

Указывает, что данное подключение должно быть прервано.


Rename (Ren)

Изменение имени отдельного файла. Команда rename с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда rename с другими параметрами доступна из командной строки.

rename [диск:][путь] имя_файла1 имя_файла2

-или-

ren [диск:][путь] имя_файла1 имя_файла2

Параметры

[диск:][путь] имя_файла1

Имя и размещение файла, который требуется переименовать. Использование подстановочных символов не допускается.

имя_файла2

Новое имя файла. При переименовании не могут быть заданы новый диск или каталог.


Rmdir (Rd)

Удаление папки. Команда rmdir с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда rmdir с другими параметрами доступна из командной строки.

rmdir [диск:]путь

-или-

rd [диск:]путь

Параметры

[диск:]путь

Диск и местоположение удаляемой папки. Использование подстановочных символов не допускается.

Примечания

  • Для успешного выполнения команды папка должна быть пуста.
  • Команда rmdir работает только в системных папках текущей установленной копии Windows, папках съемных носителей, в корневой папке любого раздела жесткого диска и локальных источниках установки.


Set

Отображение и установка переменных среды консоли восстановления. Команда set является дополнительной командой, которая должна использоваться с шаблонами безопасности.

Команда set с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда set с другими параметрами доступна из командной строки.

set [переменная=[строка]]

Параметры

переменная

Имя переменной, значение которой требуется задать или изменить.

В консоли восстановления поддерживаются следующие переменные среды.

Переменная | Описание
AllowWildCards | Включение поддержки подстановочных символов для некоторых команд (таких как команда del).
AllowAllPaths | Возможность доступа ко всем файлам и папкам в системе.
AllowRemovableMedia | Возможность копирования файлов на съемные носители, такие как гибкий диск.
NoCopyPrompt | Отключение отображения подтверждения при перезаписи существующего файла.

строка

Строковое значение для указанной переменной.

Примеры

В следующем примере включается возможность использования подстановочных символов в некоторых командах консоли восстановления.

set allowwildcards=true

В следующем примере отключается подтверждение при перезаписи файлов.

set nocopyprompt=true

Примечания

  • Вызванная без параметров, команда set выводит список установленных переменных среды и их значений.
  • По умолчанию команда set отключена. Для включения команды set используйте шаблоны безопасности. Атрибут Включение команды Set для консоли восстановления находится в дереве консоли в разделе Политика "Локальный компьютер"/Конфигурация компьютера/Конфигурация Windows/Параметры безопасности/Локальные политики/Параметры безопасности.
  • По умолчанию все переменные среды имеют значение «FALSE».


Systemroot

Выбор в качестве текущей папки системного корневого каталога установленной копии Windows, в которую вошел пользователь. Команда systemroot доступна только при использовании консоли восстановления.

systemroot

Параметры

Отсутствуют


Type

Вывод содержимого текстового файла на экран. Команды type и more применяются для просмотра текстового файла без внесения в него изменений. Команда type с перечисленными ниже параметрами доступна только при использовании консоли восстановления. Команда type с другими параметрами доступна из командной строки.

type [диск:][путь] имя_файла

-или-

more [диск:][путь] имя_файла

Параметры

[диск:][путь] имя_файла

Размещение и имя файла, который требуется просмотреть.

Если в файловой системе NTFS имя файла содержит пробелы, необходимо заключить его в кавычки.


Команды консоли восстановления

На консоли восстановления можно использовать следующие команды.

  • Attrib

    • Смена атрибутов файла или папки.

  • Batch

    • Выполнение команд, указанных в текстовом файле.

  • Bootcfg

    • Настройка и восстановление файла параметров загрузки (boot.ini).

  • ChDir (Cd)

    • Вывод имени текущей папки или переход в другую папку.

  • Chkdsk

    • Проверка диска и вывод отчета о его состоянии.

  • Cls

    • Очистка экрана.

  • Copy

    • Копирование одного файла в другую папку.

  • Delete (Del)

    • Удаление одного или нескольких файлов.

  • Dir

    • Вывод списка файлов и подпапок в папке.

  • Disable

    • Отключение системной службы или драйвера устройства.

  • Diskpart

    • Управление разделами на жестких дисках.

  • Enable

    • Запуск или включение системной службы или драйвера устройства.

  • Exit

    • Выход из консоли восстановления и перезапуск компьютера.

  • Expand

    • Извлечение файла из сжатого файла.

  • Fixboot

    • Запись в указанный раздел нового загрузочного сектора раздела.

  • Fixmbr

    • Восстановление основной загрузочной записи указанного диска.

  • Format

    • Форматирование диска.

  • Help

    • Отображение списка команд консоли восстановления.

  • Listsvc

    • Вывод списка служб и драйверов, установленных на данном компьютере.

  • Logon

    • Вход в установленную копию операционной системы Windows.

  • Map

    • Отображение списка сопоставления букв дисков.

  • Mkdir (Md)

    • Создание каталога.

  • More

    • Отображение текстового файла.

  • Net Use

    • Подключение сетевого ресурса к букве диска.

  • Rename (Ren)

    • Переименование одного файла.

  • Rmdir (Rd)

    • Удаление папки.

  • Set

    • Отображение и установка переменных среды.

  • Systemroot

    • Выбор в качестве текущей папки системного корневого каталога системы, в которую вошел пользователь.

  • Type

    • Отображение текстового файла.


Консоль восстановления: обзор

Если безопасный режим и другие особые варианты загрузки не помогают устранить неполадку, можно попробовать воспользоваться консолью восстановления. Данный способ рекомендуется только для опытных пользователей, которые могут воспользоваться основными командами для определения драйверов и файлов, вызвавших неполадку. Кроме того, консоль восстановления могут использовать только члены группы администраторы.

С консоли восстановления можно запускать и останавливать службы, форматировать диски, считывать и записывать данные на локальный диск (включая диски, использующие файловую систему NTFS), а также выполнять многие другие задачи администрирования. Консоль восстановления обычно используется, когда требуется восстановить систему, копируя файлы с гибкого диска или компакт-диска на локальный жесткий диск, или если требуется изменить параметры службы, мешающей правильной загрузке компьютера.

Консоль восстановления можно запустить двумя способами.

  • Если запустить компьютер не удается, консоль восстановления может быть запущена с установочного компакт-диска.
  • Консоль восстановления также можно установить на локальном компьютере, чтобы она была доступной, если не удается перезапустить Windows. Тогда консоль восстановления можно будет выбрать в качестве одного из вариантов загрузки в меню доступных операционных систем.

После запуска консоли восстановления нужно будет выбрать установленную операционную систему (если на компьютере установлены две или несколько систем) и войти в систему, используя пароль администратора.

С помощью основных команд, предоставляемых консолью, можно совершать простые действия, такие как смена текущей папки или ее просмотр, а также более сложные, например восстановление загрузочного сектора. Для получения справки по командам консоли восстановления введите help в командной строке консоли.

Для получения сведений о запуске и использовании консоли восстановления щелкните ссылку «См. также».

Чтобы получить справку по доступным командам консоли восстановления, введите команду help.


Удаление консоли восстановления

Рисунок Microsoft Windows

Чтобы удалить консоль восстановления

  1. Откройте папку Мой компьютер.
  2. Дважды щелкните жесткий диск, на котором установлена консоль восстановления.
  3. В меню Сервис выберите команду Свойства папки.
  4. Перейдите на вкладку Вид.
  5. Выберите вариант Показывать скрытые файлы и папки, снимите флажок Скрывать защищенные системные файлы и нажмите кнопку ОК.
  6. Удалите из корневой папки каталог \Cmdcons.
  7. Удалите из корневой папки файл Cmldr.
  8. Щелкните правой кнопкой мыши файл Boot.ini в корневой папке и выберите команду Свойства.
  9. Снимите флажок Только чтение и нажмите кнопку OK.
  10. Откройте файл Boot.ini в программе «Блокнот» и удалите запись, соответствующую консоли восстановления. Она будет похожа на следующую.

    C:\cmdcons\bootsect.dat="Microsoft Windows Recovery Console" /cmdcons

  11. Сохраните этот файл и закройте его.

Предупреждение

  • Неправильное изменение файла Boot.ini может привести к невозможности загрузки компьютера. Будьте внимательны, чтобы удалить только запись, соответствующую консоли восстановления.

Примечания

  • XOX
  • После выполнения этой процедуры рекомендуется снова установить атрибут файла Boot.ini «Только чтение». Также можно снова скрыть все системные файлы.


Установка консоли восстановления в виде варианта загрузки

Рисунок Microsoft Windows

Чтобы установить консоль восстановления в виде варианта загрузки

  1. Во время работы Windows вставьте установочный компакт-диск в дисковод для компакт-дисков.
  2. Нажмите кнопку Пуск и выберите команду Выполнить.
  3. Введите следующую строку (D: — буква дисковода для компакт-дисков).

    D:\i386\winnt32.exe /cmdcons

  4. Следуйте указаниям на экране.

Примечания

  • Чтобы запустить консоль восстановления, необходимо перезагрузить компьютер и выбрать в списке доступных операционных систем консоль восстановления.
  • Для выполнения этой процедуры необходимо войти в систему с учетной записью «Администратор» или члена группы «Администраторы». Если компьютер подключен к сети, параметры сетевой политики могут запретить выполнение данной процедуры.
  • Для вывода списка команд, доступных на консоли восстановления, введите в командной строке команду help.
  • Если компьютер не загружается, запустите консоль восстановления с установочного компакт-диска. Для получения сведений о запуске консоли восстановления при невозможности загрузки компьютера щелкните ссылку «См. также».


Запуск компьютера и использование консоли восстановления

Рисунок Microsoft Windows

Чтобы запустить компьютер и приступить к использованию консоли восстановления

С установочного компакт-диска

  1. Вставьте установочный компакт-диск в дисковод для компакт-дисков и перезагрузите компьютер. При необходимости выберите вариант загрузки с компакт-диска.
  2. В начале текстового этапа установки следуйте указаниям программы установки; нажмите клавишу R для восстановления системы.
  3. При наличии двух или нескольких установленных систем выберите систему, доступ к которой необходимо получить из консоли восстановления.
  4. По запросу введите пароль администратора.
  5. В командной строке введите команды консоли восстановления. Для вывода на экран списка команд введите help или введите help имя_команды для получения справки по определенной команде.
  6. Для завершения работы консоли восстановления и перезагрузки компьютера введите exit.

Если консоль восстановления уже установлена

  1. В ходе загрузки выберите в меню режимов загрузки вариант Консоль восстановления.
  2. При наличии двух или нескольких установленных систем выберите систему, доступ к которой необходимо получить из консоли восстановления.
  3. По запросу введите пароль администратора.
  4. В командной строке введите команды консоли восстановления. Для вывода на экран списка команд введите help или введите help имя_команды для получения справки по определенной команде.
  5. Для завершения работы консоли восстановления и перезагрузки компьютера введите exit.

Важно!

  • Поскольку консоль восстановления является мощным средством, ее рекомендуется использовать только опытным пользователям или администраторам.