Общие сведения о калькуляторе

Данная программа предназначена для выполнения тех же действий, что и обычный калькулятор. Она выполняет основные арифметические действия, такие, как сложение и вычитание, а также функции инженерного калькулятора, например нахождение логарифмов и факториалов.

См. также


Выполнение простых вычислений

Рисунок Microsoft Windows

Чтобы выполнить простое вычисление

  1. Введите первое число.
  2. Нажмите кнопку + (сложение), - (вычитание), * (умножение) или / (деление).
  3. Введите следующее число.
  4. Введите остальные операторы и числа.
  5. Нажмите кнопку =.

Примечание

  • Чтобы получить возможность ввода цифр и операторов с цифровой клавиатуры, нажмите клавишу NUM LOCK.


Выполнение инженерных расчетов

Чтобы выполнить инженерный расчет

  1. В меню Вид выберите команду Инженерный.
  2. Выберите систему счисления.
  3. Выберите требуемую разрядность результата и приступайте к расчету.

Примечания

  • Для чисел в шестнадцатеричной, восьмеричной и двоичной системах счисления доступны четыре варианта отображения: 8 байтов (64 бита), 4 байта (32 бита), 2 байта (16 битов) и 1 байт (8 битов). Для чисел в десятичной системе счисления доступны три варианта отображения: в градусах, радианах и градах.
  • Чтобы получить возможность ввода цифр и операторов с цифровой клавиатуры, нажмите клавишу NUM LOCK.


Выполнение статистических расчетов

Чтобы выполнить статистический расчет

  1. В меню Вид выберите команду Инженерный.
  2. Введите первое число и нажмите кнопку Sta, чтобы открыть окно Статистика.
  3. Нажмите кнопку RET, чтобы вернуться в окно калькулятора, а затем нажмите кнопку Dat, чтобы сохранить это значение.
  4. Введите остальные числа, нажимая кнопку Dat после ввода каждого из них.
  5. Нажмите кнопку Ave, Sum или s.

Примечания

  • Чтобы получить возможность ввода цифр и операторов с цифровой клавиатуры, нажмите клавишу NUM LOCK.
  • Кнопка Ave вычисляет среднее значение для чисел, сохраненных в окне Статистика, кнопка Sum — сумму этих чисел, а кнопка s — несмещенное стандартное отклонение.
  • После того как все данные введены, их список можно просмотреть, нажав кнопку Sta.
  • В нижней части окна Статистика показано количество сохраненных значений. Можно удалить любое значение из списка, нажав кнопку CD, или удалить все значения, нажав кнопку CAD. Нажав кнопку LOAD, можно сменить число, отображаемое на калькуляторе, числом, выбранным в окне Статистика.


Преобразование чисел при переключении режимов

Чтобы преобразовать число при переключении режимов

  1. Нажмите кнопку MS, чтобы занести число в память.
  2. В меню Вид выберите нужный режим.
  3. Нажмите кнопку MR, чтобы вызвать число из памяти.

Примечания

  • При переключении между обычным и инженерным режимом экран калькулятора очищается. Выполнение перечисленных выше шагов позволяет переводить числа из одного режима в другой.
  • Числа в шестнадцатеричном, восьмеричном и двоичном форматах при переходе от инженерного к обычному режиму преобразуются в десятичный формат.


Выполнение операций с памятью

Чтобы выполнить операцию с памятью

  • Чтобы занести отображаемое число в память, нажмите кнопку MS.
  • Чтобы вызвать число из памяти, нажмите кнопку MR.
  • Чтобы очистить память, нажмите кнопку MC.
  • Чтобы сложить отображаемое число с числом, хранящимся в памяти, нажмите кнопку M+. Чтобы вызвать результат, нажмите кнопку MR.

Примечание

  • После сохранения числа над кнопками памяти на панели калькулятора появится индикатор M. Каждое новое число, занесенное в память, заменяет предыдущее.


Разделение групп разрядов

Чтобы разделить группы разрядов

  • В меню Вид выберите команду Количество цифр в группе.

Примечания

  • Этот режим позволяет сгруппировать цифры больших чисел для удобства просмотра.
  • Для разделения групп разрядов десятичных и шестнадцатеричных чисел в калькуляторе используются пробелы.


Преобразование значения из одной системы счисления в другую

Чтобы преобразовать число в другую систему счисления

  1. В меню Вид выберите команду Инженерный.
  2. Введите число для преобразования.
  3. Выберите систему счисления, в которую его требуется преобразовать.
  4. Выберите необходимую разрядность результата.

Примечания

  • При преобразовании нецелого десятичного числа в другую систему счисления его дробная часть отбрасывается.
  • Шестнадцатеричные, восьмеричные и двоичные числа, преобразованные в десятичные, отображаются как целые.


Клавиши, эквивалентные кнопкам калькулятора

Ниже в алфавитном порядке перечислены кнопки калькулятора и эквивалентные им сочетания клавиш. Чтобы напечатать этот список, выберите в меню Параметры команду Печать. Чтобы определить эквивалентное сочетание клавиш для любой кнопки калькулятора, щелкните эту кнопку правой кнопкой мыши и выберите команду Что это такое.

Кнопка | Клавиша | Кнопка | Клавиша
% | % | Hyp | h
( | ( | Int | ;
) | ) | Inv | i
* | * | ln | n
+ | + | log | l
+/- | F9 | Lsh | <
- | - | M+ | CTRL+P
. | . или , | MC | CTRL+L
/ | / | Mod | %
0-9 | 0-9 | MR | CTRL+R
1/x | r | MS | CTRL+M
= | ENTER | n! | !
A-F | A-F | Not | ~
And | & | Oct | F7
Ave | CTRL+A | Or | | (верт. черта)
Backspace | BACKSPACE | pi | p
Bin | F8 | 8 байт | F12
1 байт | F4 | Радианы | F3
C | ESC | s | CTRL+D
CE | DEL | sin | s
cos | o | sqrt | @
Dat | INS | Sta | CTRL+S
Dec | F6 | Sum | CTRL+T
Градусы | F2 | tg | t
dms | m | 2 байта | F3
4 байта | F2 | Xor | ^
Exp | x | x^2 | @
F-E | v | x^3 | #
Грады | F4 | x^y | y
Hex | F5


Последовательности клавиш для вызова функций

Приведенные ниже последовательности нажатий клавиш воспринимаются как функции при вводе данных в калькулятор. Например, откройте блокнот и введите следующий текст:

123 :m

Скопируйте в блокноте 123 :m и вставьте в калькуляторе. Число 123 будет отображено и записано в память калькулятора.

:c | Очистка памяти.
:e | Включение режима ввода десятичных чисел в экспоненциальной нотации.
:m | Занесение отображаемого числа в память.
:p | Прибавление отображаемого числа к числу, хранящемуся в памяти.
:q | Очистка калькулятора для новых вычислений.
:r | Отображение числа, хранящегося в памяти.
\ | Эквивалентно кнопке Dat. Перед использованием этой клавиши необходимо нажать кнопку Sta.

Примечание

  • XOX


Средства повышения точности

Средства повышения точности обеспечивают точность всех операций по крайней мере до 32 разрядов. Кроме того, для обеспечения точности рациональные числа сохраняются в калькуляторе как дроби. Например, 1/3 сохраняется именно как 1/3, а не как 0,333. Однако ошибки могут накапливаться при последовательных операциях с иррациональными числами. Например, калькулятор обрезает число pi на 32 разрядах, поэтому последовательные операции с pi будут приводить к понижению точности по мере увеличения числа операций.


Выполнение расчетов с большими числами

Если результат расчета в шестнадцатеричной, двоичной или восьмеричной системе счисления превышает разрядность результата, будут отображены лишь младшие разряды. Таким образом имитируется выполнение вычислений на компьютере.

В шестнадцатеричной системе счисления восьмибайтовые результаты могут содержать до шестнадцати знаков, четырехбайтовые - до восьми знаков, двухбайтовые - до четырех знаков, а однобайтовые - до двух знаков.

Например, при отображении двухбайтовых значений в шестнадцатеричной системе счисления наибольший возможный результат — FFFF (равный 65535 в десятичной системе счисления). Если удвоить это значение (FFFFx2), результатом будет 1FFFE. Хотя результат содержит пять знаков, в калькуляторе будут отображены лишь четыре младших знака: FFFE.