Диспетчер устройств

Диспетчер устройств используют для обновления драйверов (или программного обеспечения) оборудования, изменения настроек оборудования, а также для устранения неполадок.

  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Сведения общего характера см. в разделе Основные понятия.


Инструкции

  • Просмотр сведений об устройстве
  • Настройка свойств и параметров устройства
  • Удаление и переустановка устройств
  • Обновление и просмотр драйверов устройств


Просмотр сведений об устройстве

  • Просмотр устройств и параметров ресурсов
  • Просмотр состояния устройства
  • Просмотр распределения питания для концентраторов USB
  • Просмотр распределений пропускной способности контроллера узла USB
  • Печать сведений о конкретном устройстве


Просмотр устройств и параметров ресурсов

Рисунок Microsoft Windows

Чтобы просмотреть устройства и параметры ресурсов

  1. Запустите диспетчер устройств.
  2. В меню Вид выберите одну из команд, перечисленных ниже.
    Параметр | Описание
    Устройства по типу | Отображение устройств по их типу, например монитор или мышь. Имя подключения отображается под типом. Это режим просмотра устанавливается по умолчанию.
    Устройства по подключению | Отображение устройств по способу подключения к компьютеру. Каждое устройство отображается под тем основным устройством компьютера, к которому оно подключено. Например, при наличии контроллера SCSI все подключенные к нему устройства войдут в семейство этого контроллера.
    Ресурсы по типу | Отображение состояния всех распределенных ресурсов по типу устройства, использующего эти ресурсы. Это могут быть каналы прямого доступа к памяти (DMA), порты ввода-вывода, запросы на прерывание (IRQ) и адреса памяти.
    Ресурсы по подключению | Отображение состояния всех распределенных ресурсов по типу подключения. Это могут быть: каналы DMA, порты ввода-вывода и адреса памяти.

Примечания

  • XOX
  • Чтобы отображать скрытые ресурсы, в меню Вид выберите команду Показать скрытые устройства. Если установлен флажок Показать скрытые устройства, скрытые устройства отображаются. Если требуется снять данный флажок, щелкните его. Скрытые устройства включают и устройства, не поддерживающие технологию Plug and Play (т. е. устройства с более ранними драйверами устройств Windows).

См. также


Просмотр состояния устройства

Чтобы просмотреть состояние устройства

  1. Запустите диспетчер устройств.
  2. Дважды щелкните тип устройства, который требуется просмотреть.
  3. Щелкните правой кнопкой мыши необходимое устройство и выберите в контекстном меню команду Свойства.
  4. На вкладке Общие в группе Состояние устройства отображается состояние устройства.

Примечания

  • XOX
  • Если в устройстве имеются неполадки, тип неполадок также отображается. Кроме этого, иногда отображается код, номер неполадки и предлагаемое решение. При обращении в службу поддержки этот номер может помочь определить и выявить неполадку.
  • Для получения сведений по устранению неполадок оборудования нажмите кнопку Диагностика, чтобы запустить мастер устранения неполадок.


Просмотр распределения питания для концентраторов USB

Чтобы просмотреть распределение питания для концентраторов USB

  1. Запустите диспетчер устройств.
  2. Дважды щелкните узел Контроллеры универсальной последовательной шины USB
  3. Щелкните правой кнопкой запись Корневой концентратор для USB и выберите команду Свойства.
  4. На вкладке Питание просмотрите электропитание, требуемое для каждого устройства, в списке Подключенные устройства.

Примечания

  • XOX
  • Концентраторы устройств для универсальной последовательной шины USB имеют свое питание или получают его от шины. Концентратор со своим питанием (т. е. концентратор, подключенный к электрической розетке) обеспечивает максимальное электропитания для устройства. Концентратор с питанием от шины (т. е. подключенный к другому порту USB) обеспечивает минимум электропитания. Устройства, для которых необходимо большое количество электроэнергии, например камеры, должны подключаться к концентраторам, имеющим свое питание.
  • Проверка распределения питания для концентратора USB позволяет определить ситуации, когда слишком много устройств используют один концентратор.
  • Узел Контроллеры универсальной последовательной шины USB отображается только для компьютеров, имеющих порт USB.
  • Вкладка Питание отображается только для концентраторов USB.


Просмотр распределений пропускной способности контроллера узла USB

Чтобы просмотреть распределения пропускной способности контроллера узла USB

  1. Запустите диспетчер устройств.
  2. Дважды щелкните узел Контроллеры универсальной последовательной шины USB
  3. Щелкните правой кнопкой запись Универсальный хост-контроллер USB и выберите команду Свойства.
  4. На вкладке Дополнительно просмотрите пропускную способность, использующуюся каждым устройством, в списке Устройства, расходующие пропускную способность.

Примечания

  • XOX
  • Имеется возможность просмотра пропускной способности для контроллера универсальной последовательной шины USB. Некоторые устройства USB (например, модемы) могут не отобразиться, т. к. они считаются внешними устройствами и не сообщают операционной системе требований к пропускной способности.
  • Каждый USB контроллер имеет фиксированную пропускную способность, которой должны пользоваться все подключенные к нему устройства. Если есть опасения, что контроллеру USB не хватает пропускной способности, в этом можно убедиться, просмотрев пропускную способность, используемую в настоящее время каждым устройством.
  • Узел Контроллеры универсальной последовательной шины USB отображается только для компьютеров, имеющих порт USB.


Печать сведений о конкретном устройстве

Чтобы напечатать сведения о конкретном устройстве

  1. Запустите диспетчер устройств.
  2. Дважды щелкните тип устройства, сведения о котором требуется распечатать, и выберите конкретное устройство.
  3. Выберите в меню Действие команду Печать.
  4. В диалоговом окне Печать в группе Тип отчета выберите параметр О выбранном классе или устройстве.

    Также имеется возможность печатать другие отчеты из этого диалогового окна. В следующей таблице описаны типы отчетов, которые можно печатать.

    5. Параметр | Описание
Сведения о системе | Печать списка устройств, установленных на локальный или на удаленный компьютер. В сводке указаны номер версии продукта, тип шины, владелец и сведения о ресурсе, например об использовании запросов на прерывание (IRQ) или портов ввода/вывода.
О выбранном классе / устройстве | Печать отчета о выбранном устройстве или типе устройств. В отчет включается название устройства, расположение его драйвера, сведения о версии и изготовителе, ресурсах, распределенных для данного устройства, например портах ввода/вывода и адресах памяти.
О системе и всех устройствах | Печать отчета о каждом устройстве или типе устройств, установленных на компьютер, а также сводки о системе. Если на компьютер установлено большое число устройств, этот документ может получиться длинным.

Примечания

  • XOX
  • Файл с расширением .prn можно напечатать, установив флажок Печать в файл.
  • Параметр О выбранном классе или устройстве устанавливается по умолчанию типом печатаемого отчета.


Настройка свойств и параметров устройства

  • Включение устройства
  • Отключение устройства
  • Изменение параметров ресурсов для устройства
  • Изменение параметров сетевого адаптера
  • Изменение параметров порта
  • Изменение параметров мыши PS/2
  • Изменение параметров контроллера IDE
  • Изменение региональных настроек дисководов DVD
  • Изменение параметров адаптера ISDN
  • Изменение параметров управления электропитанием устройства
  • Включение и отключение цифровых компакт-дисков
  • Настройка устройств мультимедиа
  • Переход от однопроцессорной системы к многопроцессорной


Включение устройства

Чтобы включить устройство

  1. Запустите диспетчер устройств.
  2. Дважды щелкните тип устройства, который требуется включить.
  3. Щелкните правой кнопкой мыши необходимое устройство и выберите в контекстном меню команду Задействовать.

Примечания

  • XOX
  • XOX
  • Команда Задействовать присутствует, только если устройство отключено.
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Отключение устройства

Чтобы отключить устройство

  1. Запустите диспетчер устройств.
  2. Дважды щелкните тип устройства, который требуется отключить.
  3. Щелкните правой кнопкой мыши необходимое устройство и выберите в контекстном меню команду Отключить.

Внимание!

  • Если было отключено устройство, которое требуется для запуска системы, например дисковод для гибких дисков или DVD и компакт-дисковод, эти устройства не будут работать, а система может не запуститься.

Примечания

  • XOX
  • XOX
  • При отключении устройства оно остается физически подключенным к компьютеру. При включении устройства драйверы снова становятся доступными. Отключение устройств полезно при наличии на компьютере нескольких конфигураций оборудования или если компьютер является переносным и подключается к стыковочному узлу.
  • После отключения устройства и перезагрузки компьютера (если это было необходимо) ресурсы, использовавшиеся с этим устройством освобождаются и могут быть распределены для использования с другими устройствами.
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».
  • Некоторые устройства невозможно отключить.


Изменение параметров ресурсов устройства

Чтобы изменить параметры ресурсов устройства

  1. Запустите диспетчер устройств.
  2. Дважды щелкните тип устройства, который требуется изменить.
  3. Дважды щелкните конкретное устройство, которое требуется изменить. Если устройство имеет параметры ресурсов, которые возможно изменить, в диалоговом окне появится вкладка Ресурсы.
  4. Щелкните вкладку Ресурсы и снимите флажок Автоматическая настройка. Этот флажок может быть недоступен для устройства, не поддерживающего технологию Plug and Play.
  5. В поле со списком Конфигурация выберите конфигурацию оборудования, которую нужно изменить.
  6. В диалоговом окне Перечень ресурсов в группе Тип ресурса выберите тип ресурса, который требуется изменить: прямой доступ к памяти (DMA), запрос на прерывание (IRQ), порт ввода-вывода или адрес памяти.
  7. Нажмите кнопку Изменить и введите новое значение типа ресурсов.
  8. Повторите данную процедуру необходимое число раз.

Внимание!

  • Неправильное изменение настроек ресурсов может привести к отключению устройств или послужить причиной неправильной работы компьютера. Параметры ресурсов должны изменяться только пользователями, обладающими глубокими знаниями компьютерного оборудования и настройки конфигураций.

Внимание!

  • Необходимо убедиться, что новые применяемые значения не конфликтуют с параметрами других устройств. Конфликты устройств при их обнаружении перечислены в группе Список конфликтующих устройств.
  • Флажок Автоматическая настройка недоступен для устройств, для которых отсутствуют настройки других параметров, и устройств, управляемых ресурсами Plug and Play, чьи параметры не должны изменяться пользователем.

Примечания

  • XOX
  • XOX
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».
  • Обычно нет необходимости изменять параметры ресурсов, потому что они автоматически выделяются системой при установке оборудования.


Изменение параметров сетевого адаптера

Чтобы изменить параметры сетевого адаптера

  1. Запустите диспетчер устройств.
  2. Дважды щелкните узел Сетевые платы.
  3. Щелкните правой кнопкой мыши сетевой адаптер, параметры которого нужно изменить, и выберите команду Свойства.
  4. На вкладке Дополнительно сделайте нужные изменения.

Примечания

  • XOX
  • XOX
  • Параметры сетевого адаптера зависят от самого адаптера. Обратитесь к инструкциям производителя, чтобы определить параметры, которые нужно изменить.
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Изменение параметров порта

Чтобы изменить параметры порта

  1. Запустите диспетчер устройств.
  2. Дважды щелкните узел Порты COM и LPT.
  3. Щелкните правой кнопкой мыши порт, параметры которого нужно изменить, и выберите команду Свойства.
  4. На вкладке Параметры порта сделайте нужные изменения.

Примечания

  • XOX
  • XOX
  • Для большинства устройств, использующих порты, скорость порта устанавливается автоматически. Значения скорости порта, используемые по умолчанию, указываются в компоненте Параметры телефона и модема на Панели управления.
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Изменение параметров мыши PS/2

Чтобы изменить параметры мыши PS/2

  1. Запустите диспетчер устройств.
  2. Дважды щелкните узел Мыши и иные указывающие устройства.
  3. Правой кнопкой мыши щелкните запись PS/2-совместимая мышь и выберите команду Свойства.
  4. На вкладке Дополнительные параметры сделайте нужные изменения.

Примечания

  • XOX
  • XOX
  • Некоторые параметры мыши PS/2 зависят от самого устройства. Обратитесь к инструкциям производителя, чтобы определить параметры, которые можно изменять.
  • Для получения дополнительных сведений об изменении других параметров мыши щелкните ссылку «См. также».
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Изменение параметров контроллера IDE

Чтобы изменить параметры контроллера IDE

  1. Запустите диспетчер устройств.
  2. Дважды щелкните узел Контроллеры IDE ATA/ATAPI, щелкните правой кнопкой мыши устройство IDE, дополнительные параметры которого нужно изменить, и выберите команду Свойства.
  3. Внесите необходимые изменения на вкладке Дополнительные параметры и нажмите кнопку OK.

Примечания

  • XOX
  • XOX
  • Вкладка Дополнительные параметры отображается не для всех контроллеров IDE.
  • Некоторые параметры контроллеров IDE зависят от самого устройства. Обратитесь к инструкциям производителя, чтобы определить параметры, которые можно изменять.
  • Значение параметра в поле Тип устройства изменить нельзя, если устройство или канал IDE уже были определены системой. Таким образом предотвращается выбор значения Отсутствует, отключающего устройство IDE. Для получения сведений об отключении данного устройства щелкните ссылку «См. также».
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Изменение региональных настроек дисководов DVD

Чтобы изменить региональные параметры дисководов DVD

  1. Запустите диспетчер устройств.
  2. Дважды щелкните узел DVD и компакт-дисководы щелкните правой кнопкой мыши дисковод DVD, дополнительные параметры которого нужно изменить, и выберите команду Свойства.

  3. На вкладке Регион для DVD сделайте нужные изменения.

    Многие программные декодеры требуют для работы средство прямого доступа к памяти (DMA), поэтому необходимо проверить параметры контролеров интегрированного интерфейса накопителей (IDE) ATA/ATAP. В группе Режим передачи должен быть установлен флажок DMA, если доступно. Если возможно, необходимо проверить этот параметр для вторичного канала IDE.

Примечания

  • XOX
  • XOX
  • Вкладка Регион для DVD доступна не для всех дисководов DVD.
  • Чтобы настроить дисковод DVD-дисков для воспроизведения дисков из других зон, выберите географическую область в списке. В большинстве случаев выбирается область своего местонахождения. Обычно не возникает необходимости изменять этот параметр еще раз.
  • Число изменений зоны ограничено. Если счетчик Осталось изменений имеет значение 1, при выборе новой зоны отображается предупреждение, что после внесенных изменений проигрывать DVD-диски можно будет только из данной зоны. Следует иметь в виду, что некоторые аппаратные и программные DVD-декодеры не поддерживают изменение зоны.
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Изменение параметров адаптера ISDN

Чтобы изменить параметры адаптера ISDN

  1. Запустите диспетчер устройств.
  2. Дважды щелкните узел Сетевые платы, щелкните правой кнопкой плату адаптера ISDN, параметры которого требуется изменить, а затем выберите команду Свойства.
  3. На вкладке ISDN в поле со списком Выберите тип коммутатора или протокол D-канала выберите тип коммутатора или протокол D-канала, а затем нажмите кнопку Настроить.
  4. Внесите требуемые изменения.

Примечания

  • XOX
  • XOX
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».
  • Сведения, необходимые для настройки параметров адаптера ISDN, должны быть предоставлены телефонной компанией или изготовителем оборудования.


Изменение параметров управления электропитанием устройства

Чтобы изменить параметры управления электропитанием устройства

  1. Запустите диспетчер устройств.
  2. Дважды щелкните тип устройства, параметры управления электропитанием которого нужно изменить.
  3. Щелкните правой кнопкой мыши необходимое устройство и выберите в контекстном меню команду Свойства.
  4. На вкладке Управление электропитанием сделайте необходимые изменения.

Примечания

  • XOX
  • XOX
  • Имеется возможность использовать параметры управления электропитанием, чтобы указать, что система должна выходить из состояния с низким потреблением энергии для обработки события. Например, входящий звонок на модем будет оповещать операционную систему о необходимости обработки этого вызова, даже если она находится в спящем режиме. Также можно указать, должна ли операционная система отключать устройство, если оно не занято, например, обрабатыванием вызова.
  • Вкладка Управление электропитанием отображается в свойствах только тех драйверов устройств, которые поддерживают стандарты управления электропитанием, например — в свойствах сетевых адаптеров.
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Включение и отключение цифровых компакт-дисков

Чтобы включить или отключить цифровой компакт-диск

  1. Запустите диспетчер устройств.
  2. Дважды щелкните узел DVD и компакт-дисководы, щелкните правой кнопкой мыши компакт-дисковод и выберите команду Свойства.
  3. На вкладке Свойства установите или снимите флажок Использовать цифровое воспроизведение.

    Этот флажок разрешает цифровое воспроизведение звука компакт-дисководами и отправку данных либо на звуковую плату, либо на динамики USB. Динамики USB позволяют прослушивать компакт-диски.

Примечания

  • XOX
  • XOX
  • Может потребоваться перезагрузка компьютера после изменения этого параметра.
  • Включение этой возможности позволяет повысить качество звука, поскольку Windows читает напрямую с компакт-диска, минуя цифро-аналоговые преобразователи компакт-дисковода. Прямой доступ к компакт-диску улучшает качество звука, т. к. позволяет устранить внешние электромагнитные помехи, пройти через защиту кабеля, соединяющего компакт-дисковод со звуковой платой.
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также»


Настройка устройств мультимедиа

Чтобы настроить устройства мультимедиа

  1. Запустите диспетчер устройств.
  2. Дважды щелкните узел Звуковые, видео и игровые устройства.
  3. Щелкните правой кнопкой устройство, которое требуется настроить, и выберите команду Свойства.
  4. На вкладке Свойства найдите нужное устройство и дважды его щелкните.
  5. Сделайте требуемые изменения в настойке устройства.

Примечания

  • XOX
  • XOX
  • Кнопка Свойства доступна, только если на компьютере установлены более ранние драйверы. Если эта кнопка недоступна, настройте устройство на вкладке Ресурсы.
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Переход от однопроцессорной системы к многопроцессорной

Чтобы перейти от однопроцессорной системы к многопроцессорной

  1. Запустите диспетчер устройств.
  2. Дважды щелкните узел Компьютер.
  3. Щелкните правой кнопкой мыши модель компьютера и выберите команду Свойства.
  4. На вкладке Драйвер нажмите кнопку Обновить. При нажатии этой кнопки запускается мастер обновления оборудования.
  5. Выберите параметр Установка из указанного места и нажмите кнопку Yesлее.
  6. На странице Задайте параметры поиска и установки выберите параметр Не выполнять поиск. Я сам выберу нужный драйвер и нажмите кнопку Yesлее.
  7. На странице Выбор драйвера устройства выберите из списка Модели подходящий тип компьютера.
  8. Нажмите кнопку Yesлее, нажмите кнопку Yesлее еще раз, а затем нажмите кнопку Готово.

Примечания

  • XOX
  • XOX


Удаление и переустановка устройств

  • Удаление устройства
  • Переустановка устройств Plug and Play
  • Переустановка устройств, не являющихся самонастраиваемыми
  • Возврат к предыдущей версии драйвера
  • Отсоединение переносного компьютера от стыковочного узла
  • Отключение или извлечение устройств


Удаление устройства

Чтобы удалить устройство

  1. Запустите диспетчер устройств.
  2. Дважды щелкните тип устройства, который требуется удалить.
  3. Щелкните правой кнопкой мыши конкретное устройство, которое следует удалить, и выберите команду Удалить.
  4. В диалоговом окне Подтверждение удаления устройства нажмите кнопку OK.
  5. После завершения процесса удаления выключите компьютер и извлеките устройство из компьютера.

Примечания

  • XOX
  • Обычно диспетчер устройств не используется для удаления устройств, поддерживающих технологию Plug and Play. Устройство Plug and Play можно просто отключить от компьютера. Может потребоваться перезагрузка компьютера. Для получения дополнительных сведений обращайтесь к инструкциям производителя устройства.
  • После удаления устройства его драйверы устройств не удаляются с жесткого диска.
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas.


Переустановка устройств Plug and Play

Чтобы переустановить устройство Plug and Play

  1. Запустите диспетчер устройств.
  2. Дважды щелкните тип устройства, который требуется переустановить.
  3. Щелкните правой кнопкой мыши необходимое устройство и выберите в контекстном меню команду Удалить.
  4. В диалоговом окне Подтверждение удаления устройства нажмите кнопку OK.
  5. Чтобы переустановить это устройство, выберите в меню Действие команду Обновить конфигурацию оборудования.
  6. Следуйте указаниям на экране.

Примечания

  • XOX
  • XOX
  • Устройство Plug and Play нужно переустанавливать только в случае его отказа или неправильной работы. Прежде чем переустанавливать устройство, попробуйте перезагрузить компьютер и проверить работу устройства еще раз. Если устройство не начало функционировать, попробуйте его переустановить.
  • Обычно устройство Plug and Play не нужно переустанавливать или удалять. Такие устройства можно просто извлечь из компьютера. Чтобы правильно извлечь устройство, следуйте инструкциям производителя по его установке и удалению.
  • При использовании команды Обновить конфигурацию оборудования устройство Plug and Play не будет переустановлено, если устройство и его драйвер определяется системой. Устройства Plug and Play нужно удалять перед обновлением конфигурации.
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Переустановка устройств не Plug and Play

Чтобы установить устройство, не поддерживающее технологию Plug and Play

  1. Чтобы установить новое оборудование, нажмите кнопку Пуск, выберите команды Настройка, а затем Панель управления и дважды щелкните значок Установка оборудования, чтобы запустить мастер установки оборудования.
  2. Следуйте инструкциям мастера.

Примечания

  • XOX
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Возврат к предыдущей версии драйвера

Чтобы осуществить возврат к предыдущей версии драйвера

  1. Запустите диспетчер устройств.
  2. Щелкните правой кнопкой мыши устройство, для которого требуется установить предыдущую версию драйвера, и выберите команду Свойства.
  3. Щелкните вкладку Драйверы.
  4. Нажмите кнопку Откатить.

Примечания

  • XOX
  • XOX
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Отсоединение переносного компьютера от стыковочного узла

Чтобы отсоединить переносной компьютер от стыковочного узла

  1. Нажмите кнопку Пуск и выберите команду Извлечь компьютер. Будет выведено сообщение о том, что теперь отсоединение компьютера безопасно.
  2. Отсоедините компьютер или, если стыковочный узел снабжен электромотором, переносной компьютер будет отсоединен автоматически.

Внимание!

  • Извлечение переносного компьютера без использования команды Извлечь компьютер не поддерживается и может привести к потери данных и даже к повреждению оборудования. Чтобы избежать этого, используйте команду Извлечь компьютер для отсоединения компьютера или выключите систему и отсоедините компьютер, пока система отключена. Отсоединение переносного компьютера, находящегося в ждущем или спящем режиме также не поддерживается и тоже скорее всего приведет к потере данных и нестабильной работе системы.

Примечания

  • Команда Извлечь компьютер появляется в меню Пуск только в случае, если компьютер поддерживает интерфейс ACPI. Если команда Извлечь компьютер не появляется в меню Пуск, это значит, что компьютер не поддерживает ACPI, отсоединение или отсутствуют требуемые привилегии безопасности для отсоединения переносного компьютера. Для получения привилегий обратитесь к администратору.
  • Стыковочные узлы некоторых компьютеров имеют кнопку извлечения. Для отсоединения переносного компьютера достаточно нажать эту кнопку. Для получения дополнительных сведений обращайтесь к инструкциям производителя.
  • Для работы с сетевыми файлами и папками убедитесь, что элемент на отсоединенном переносном компьютере доступен. Для дополнительных сведений об использовании папок в автономном режиме см. раздел Общие сведения об автономных папках в ссылке «См. также».
  • Для оптимального быстродействия персонального компьютера измените схему управления питанием с помощью компонента Электропитание на Панели управления.
  • Программы, находящиеся в сети, будут недоступны для переносного компьютера после его отсоединения.


Отключение или извлечение устройств

Чтобы отключить или извлечь устройство

  1. В области уведомлений рядом с панелью дважды щелкните значок Безопасное извлечение. Приложение безопасного извлечения отображает список устройств Plug and Play, в настоящее время подключенных к системе, поддерживающих режим безопасного извлечения.

    Если значок Безопасное извлечение не виден, устройство не поддерживает безопасное извлечение, и невозможно отключить его или извлечь, используя приложение безопасного извлечения.

  2. В поле Безопасное извлечение устройства выберите из списка устройство, которое требуется отключить или извлечь, и нажмите кнопку Остановить. Таким образом система получает сообщение, что будет производиться отключение или извлечение устройства.

  3. В диалоговом окне Остановка устройства нажмите кнопку OK.

    Появляется уведомление о том, что теперь безопасно отключить или извлечь устройство.

Внимание!

  • Отключение или извлечение устройства, которое поддерживает режим безопасного извлечения, без использования приложения безопасного извлечения для предупреждения системы может вызвать потерю данных или нестабильную работу системы. Например, если устройство отключено во время передачи данных, эти данные будут, скорее всего, потеряны. При использовании безопасного извлечения система получает предупреждение до того, как устройство отключено или извлечено, таким образом предотвращается возможная потеря данных.

Примечание

  • Для съемных запоминающих устройств, которые можно безопасно извлекать во время работы системы, по умолчанию кэширование операций записи запрещено. Это требуется для того, чтобы устройства могли быть удалены без потери данных. Однако, когда кэширование операций записи запрещено, в системе скорее всего появятся неполадки, так что следует отменить запрет на кэширование операций записи сразу после извлечения устройства.


Обновление и просмотр драйверов устройств

  • Обновление или смена драйвера устройства
  • Просмотр сведений о драйвере устройства
  • Запуск и остановка драйверов устройств, не поддерживающих технологию Plug and Play


Обновление или смена драйвера устройства

Чтобы обновить или сменить драйвер устройства

  1. Запустите диспетчер устройств.
  2. Дважды щелкните тип устройства, который требуется обновить или изменить.
  3. Правой кнопкой мыши щелкните конкретный драйвер устройства, который требуется обновить или сменить, а затем выберите команду Обновить драйвер, чтобы открыть мастер обновления оборудования. Следуйте инструкциям мастера.

Примечания

  • XOX
  • XOX
  • Необходимо иметь следующие разрешения и привилегии, чтобы установить драйвер. Такие разрешения имеют администраторы.
    • Привилегия загрузки/выгрузки драйвера.
    • Разрешения, необходимые для копирования файлов в каталог system32\drivers.
    • Разрешения, необходимые для записи параметров в реестр.

    Вход в систему с такими привилегиями делает систему безопасности компьютера уязвимой. Для получения дополнительных сведений о нежелательности использования привилегий администратора без необходимости щелкните ссылку «См. также».

  • При обновлении драйвера или при установки нового оборудования Windows Update запускается автоматически. Это позволяет производить поиск драйвера для загрузки и установки. Компьютер должен иметь доступ к Интернету для запуска Windows Update. Для получения дополнительных сведений о Windows Update щелкните ссылку «См. также».
  • Для пользователей, не являющихся администраторами или членами группы «Администраторы», имеется возможность выполнять некоторые действия администратора с помощью команды runas. Для получения дополнительных сведений об использовании команды runas щелкните ссылку «См. также».


Просмотр сведений о драйвере устройства

Чтобы просмотреть сведения о драйвере устройства

  1. Запустите диспетчер устройств.
  2. Дважды щелкните тип устройства, который требуется просмотреть.
  3. Щелкните правой кнопкой мыши необходимое устройство и выберите в контекстном меню команду Свойства.
  4. На вкладке Драйвер нажмите кнопку Сведения.

Примечания

  • XOX
  • Чтобы просмотреть сведения о драйверах скрытых устройств, в меню Вид выберите команду Показать скрытые устройства. Дважды щелкните узел Драйверы устройств не Plug and Play и выполните шаги 3 и 4. Для просмотра скрытых устройств нужно быть администратором или иметь разрешения администратора.
  • Эти сведения могут быть полезны при определении версии файла драйвера устройства.
  • Значок появляется радом с драйвером устройства, содержащим цифровую подпись. Для дополнительных сведений о цифровых подписях драйверов см. раздел Подписывание драйверов для Windows в ссылке «См. также».


Запуск и остановка драйверов устройств, не поддерживающих технологию Plug and Play

Запуск и остановка драйверов устройств, не поддерживающих технологию Plug and Play

  1. Запустите диспетчер устройств.
  2. В меню Вид выберите команду Показать скрытые устройства.
  3. Дважды щелкните узел Драйверы устройств не Plug and Play, щелкните правой кнопкой мыши драйвер и выберите команду Свойства.
  4. На вкладке Драйвер нажмите кнопку Запустить или Остановить, чтобы запустить или остановить протокол драйвера, а затем нажмите кнопку OK.

Внимание!

  • Неправильное изменение типа запуска загрузочных или системных устройств может привести к нестабильной работе системы или к невозможности дальнейших загрузок или вызвать прекращение работы устройства. Перед изменением этого параметра следует очень внимательно прочитать инструкцию.
  • Следует соблюдать осторожность при запуске или остановке несистемных устройств. Неправильный запуск или остановка такого устройства может вызвать полное прекращение работы устройства.

Примечания

  • XOX
  • XOX
  • Если кнопка Запустить недоступна, значит драйвер уже загружен.
  • В поле Тип запуска по умолчанию устанавливается тип запуска, необходимый для первой загрузки драйвера. Можно изменить установки по умолчанию, используя следующую таблицу. Следует соблюдать осторожность при изменении типа запуска. Перед внесением изменений следует очень внимательно прочитать инструкцию.
    • Тип | Описание
Авто | Запускается каждый раз при загрузке системы после запуска загрузочных и системных устройств. Этот параметр следует устанавливать для устройств, не являющихся необходимыми для базовой функциональности системы.
Загрузка | Запускается каждый раз при загрузке системы перед запуском всех других устройств. Этот параметр следует устанавливать для устройств, необходимых для базовой функциональности системы.
Запрос | Запускается при определении устройства или после конкретного события. Этот параметр следует устанавливать для устройств, не являющихся необходимыми для базовой функциональности системы или необходимых для определения устройств.
Система | Запускается каждый раз при загрузке системы после запуска загрузочных устройств. Этот параметр следует устанавливать для устройств, необходимых для базовой функциональности системы.


Основные понятия

В этом разделе представлены следующие основные сведения.

  • Общие сведения о диспетчере устройств
  • Настройка устройств
  • Удаление устройств
  • Общие сведения о профилях оборудования


Общие сведения о диспетчере устройств

В окне диспетчера устройств представлено графическое отображение оборудования, установленного на компьютер. Диспетчер устройств используют для обновления драйверов (или программного обеспечения) оборудования, изменения настройки оборудования, а также для устранения неполадок.

Внимание!

  • Неправильное изменения конфигурации оборудования может повредить систему. Перед внесением изменений в конфигурацию оборудования следует прочитать соответствующие инструкции.

Диспетчер устройств позволяет:

  • определять правильность работы оборудования компьютера;
  • изменять параметры конфигурации оборудования;
  • определять драйверы устройств, загружаемые для каждого устройства, и получать сведения о каждом драйвере;
  • изменять дополнительные параметры и свойства устройств;
  • устанавливать обновленные драйверы устройств;
  • отключать, включать и удалять устройства;
  • осуществлять возврат к предыдущей версии драйвера;
  • распечатывать список устройств, установленных на компьютер.

Обычно диспетчер устройств используется для проверки состояния оборудования и обновления драйверов устройств на компьютере. Возможности диагностики диспетчера устройств также могут использоваться опытными пользователями, обладающими глубокими знаниями о компьютерном оборудовании, для разрешения конфликтов устройств и изменения параметров ресурсов.

Внимание!

  • Неправильное изменение настроек ресурсов может привести к отключению устройств или послужить причиной неправильной работы компьютера. Параметры ресурсов должны изменяться только пользователями, обладающими глубокими знаниями компьютерного оборудования и его настройки.

Обычно для изменения параметров ресурса не нужно использовать диспетчер устройств, поскольку ресурсы распределяются автоматически операционной системой в процессе настройки оборудования.

Для управления драйверами устройств необходимы разрешения и привилегии, перечисленные ниже. Такие разрешения имеют администраторы.

  • Привилегия загрузки/выгрузки драйвера.
  • Разрешения, необходимые для копирования файлов в каталог system32\drivers.
  • Разрешения, необходимые для записи параметров в реестр.
Вход в систему с такими привилегиями делает систему безопасности компьютера уязвимой. Дополнительные сведения о нежелательности использования привилегий администратора без необходимости см. в разделе Почему не следует работать на компьютере с учетной записью администратора.

Управлять устройствами с помощью диспетчера устройств можно только на локальном компьютере. Для удаленного компьютера диспетчер устройств будет работать только в режиме чтения.


Удаление устройств

Обычно для удаления устройства Plug and Play достаточно его отключить или удалить из конфигурации. Для удаления некоторых устройств необходимо сначала выключить компьютер. Чтобы выполнить правильно последовательность действий по удалению устройства, обратитесь к инструкциям производителя по установке и удалению устройства.

Удаление устройств, не являющихся устройствами Plug and Play, обычно состоит из двух шагов.

  • Отмена установки устройства с помощью диспетчера устройств.
  • Удаление устройства из конфигурации компьютера.

Диспетчер устройств используется для уведомления системы о том, что требуется удалить устройство не Plug and Play. После уведомления системы об удалении устройства необходимо физически отключить или удалить его из компьютера. Например, если устройство подключено к порту вне компьютера, необходимо выключить компьютер, отключить устройство от порта, а затем отсоединить шнур питания от устройства.

Чтобы не отменять установку устройства, которое может быть подключено заново (например модем), устройство Plug and Play можно отключить. При отключении устройства, физически оно остается подключенным к компьютеру, но Windows обновляет системный реестр таким образом, что драйверы отключенного устройства не загружаются при запуске компьютера. При включении устройства драйверы снова становятся доступными. Отключение устройств полезно при наличии на компьютере нескольких конфигураций оборудования или если компьютер является переносным и подключается к стыковочному узлу.

Инструкции по удалению, переустановке и восстановлению устройств см. в разделе Удаление и переустановка устройств.

Сведения общего характера по аппаратному обеспечению и инструкции по установке устройств см. в разделах Общие сведения об оборудовании и Общие сведения об установке устройств.