Общие сведения об аварийном восстановлении системы

Наборы аварийного восстановления системы следует создавать регулярно в рамках общего плана восстановления системы в случае сбоя. Аварийное восстановление системы должно быть последним средством, используемым только после исчерпания других возможностей, таких как загрузка в безопасном режиме или загрузка последней удачной конфигурации. Дополнительные сведения о возможностях восстановления см. в разделе Общие сведения о восстановлении.

Система аварийного восстановления состоит из двух частей: архивации и восстановления. Архивация выполняется с помощью мастера аварийного восстановления системы, доступного из программы архивации. Этот мастер архивирует состояние системы, системные службы и все диски, связанные с компонентами операционной системы. Кроме того, он создает файл, содержащий сведения об архивации, конфигурациях дисков (включая базовый и динамический тома) и инструкции по выполнению восстановления.

Доступ к восстановлению выполняется нажатием клавиши F2 в ответ на соответствующее приглашение на текстовом этапе процесса установки. Средство аварийного восстановления системы считывает конфигурации дисков из созданного ей файла и восстанавливает все подписи дисков, тома и разделы по крайней мере на дисках, необходимых для загрузки компьютера. (Выполняется попытка восстановления конфигураций всех дисков, но при некоторых обстоятельствах это может оказаться невозможным.) Затем средство аварийного восстановления системы выполняет простую установку Windows и автоматически запускает процесс восстановления с использованием архива, созданного мастером аварийного восстановления системы.


Загрузка компьютера в безопасном режиме

Рисунок Microsoft Windows

Чтобы загрузить компьютер в безопасном режиме

  1. Перед продолжением данные инструкции следует вывести на печать. Они будут недоступны после выключения компьютера на шаге 2.
  2. XOX
  3. В диалоговом окне «Завершение работы Windows» выберите действие Перезагрузка и нажмите кнопку OK.
  4. При появлении сообщения Выберите операционную систему для запуска нажмите клавишу F8.
  5. При помощи клавиш со стрелками выберите подходящий безопасный режим и нажмите клавишу ENTER.
  6. При наличии на компьютере двух или нескольких операционных систем, выберите нужную с помощью клавиш со стрелками, а затем нажмите клавишу ENTER.

Примечания

  • При загрузке в безопасном режиме доступны только основные файлы и драйверы (драйверы мыши, монитора, клавиатуры, дисков, базового видеоадаптера; стандартные системные службы; сетевые подключения отсутствуют). Можно выбрать Безопасный режим с загрузкой сетевых драйверов, в котором загружаются все вышеперечисленные драйверы и файлы, а также основные сетевые службы и драйверы, или Безопасный режим с поддержкой командной строки, который идентичен обычному безопасному режиму, но вместо графического интерфейса пользователя запускается командная строка. Также можно выбрать вариант Загрузка последней удачной конфигурации, при котором компьютер загружается с использованием данных реестра, сохраненных при последнем завершении работы компьютера.
  • Безопасный режим помогает определить причину неполадок. Если при загрузке в безопасном режиме неполадки не возникают, можно удалить настройки по умолчанию и минимальный набор драйверов устройств как возможные причины возникновения этих неполадок. Если причиной возникающих неполадок является добавление нового устройства или смена драйвера, безопасный режим можно использовать для удаления этого устройства или отмены изменений.
  • В некоторых ситуациях, например при повреждении системных файлов Windows, необходимых для загрузки системы, безопасный режим помочь не может. В этом случае может помочь консоль восстановления.
  • Для использования клавиш со стрелками на цифровой клавиатуре режим NUM LOCK должен быть отключен.

См. также


Загрузка компьютера с использованием последней удачной конфигурации

Рисунок Microsoft Windows

Чтобы загрузить компьютер с использованием последней удачной конфигурации

  1. Прежде чем продолжить, выведите данные инструкции на печать. Они не будут доступны после выключения компьютера в ходе выполнения действий пункта 2.
  2. XOX
  3. В диалоговом окне «Завершение работы Windows» выберите действие Перезагрузка и нажмите кнопку OK.
  4. При появлении сообщения Выберите операционную систему для запуска нажмите клавишу F8.
  5. С помощью стрелок выберите Загрузка последней удачной конфигурации, а затем нажмите клавишу ENTER.
  6. При наличии на компьютере двух или нескольких операционных систем, выберите нужную с помощью клавиш со стрелками, а затем нажмите клавишу ENTER.

Примечания

  • Выбор варианта Загрузка последней удачной конфигурации позволяет восстановить реестр в случае неполадок, вызванных, например, добавлением нового драйвера, неправильно работающего с имеющимся оборудованием. Данный вариант не устраняет неполадки, вызванные повреждением или отсутствием драйверов или файлов.
  • При выборе варианта Загрузка последней удачной конфигурации восстанавливаются только данные в разделе реестра HKLM\System\CurrentControlSet. Любые изменения в других разделах реестра сохраняются.
  • Для использования клавиш со стрелками на цифровой клавиатуре режим NUM LOCK должен быть отключен.

См. также


Загрузка компьютера в режиме командной строки

Рисунок Microsoft Windows

Чтобы загрузить компьютер в режиме командной строки

  1. Прежде чем продолжить, выведите данные инструкции на печать. После выключения компьютера на шаге 2 они будут недоступны.
  2. XOX
  3. В диалоговом окне «Завершение работы Windows» выберите действие Перезагрузка и нажмите кнопку OK.
  4. При появлении сообщения Выберите операционную систему для запуска нажмите клавишу F8.
  5. При помощи клавиш со стрелками выберите Безопасный режим с поддержкой командной строки и нажмите клавишу ENTER.
  6. При наличии на компьютере двух или нескольких операционных систем, выберите нужную с помощью клавиш со стрелками, а затем нажмите клавишу ENTER.

Примечания

  • Для использования клавиш со стрелками на цифровой клавиатуре режим NUM LOCK должен быть отключен.

См. также


Варианты загрузки

Если компьютер не загружается в обычном режиме, попробуйте загрузить его в безопасном режиме. В безопасном режиме Windows использует настройки по умолчанию (монитор VGA, поддержка сети отсутствует, драйвер мыши Microsoft и минимальный набор драйверов устройств, необходимых для запуска Windows).

Если компьютер не загружается после установки нового программного обеспечения, попробуйте запустить его в безопасном режиме с минимальным набором служб и изменить настройки компьютера или удалить новое программное обеспечение, которое, возможно, и является причиной сбоя. При необходимости переустановите операционную систему или пакет обновления.

Если при загрузке в безопасном режиме неполадки не возникают, можно удалить настройки по умолчанию и минимальный набор драйверов устройств как возможные причины этих неполадок.

Доступны следующие варианты загрузки.

Безопасный режим

Загрузка с использованием только основных файлов и драйверов (драйвер мыши, кроме драйвера мыши для последовательного порта; монитор; клавиатура; диски; видеоадаптер; стандартные системные службы; отсутствие сетевых подключений). Если загрузить компьютер в безопасном режиме не удается, для восстановления системы может потребоваться использование консоли восстановления.

Дополнительные сведения см. в разделе Загрузка компьютера в безопасном режиме.

Безопасный режим с загрузкой сетевых драйверов

Загрузка с использованием только основных файлов и драйверов, а также сетевых подключений.

Безопасный режим с поддержкой командной строки

Загрузка с использованием только основных файлов и драйверов. После входа в систему вместо графического интерфейса Windows выводится командная строка.

Дополнительные сведения см. в разделе Загрузка компьютера в режиме командной строки.

Включить протоколирование загрузки

При загрузке система записывает в файл перечень всех драйверов и служб, которые были загружены (или не загружены). Этот файл называется ntbtlog.txt и хранится в каталоге %windir%. При загрузке компьютера в безопасном режиме, в безопасном режиме с загрузкой сетевых драйверов и в безопасном режиме с поддержкой командной строки в журнал загрузки добавляется список всех загружаемых драйверов и служб. Журнал загрузки полезен для определения точной причины неполадок при загрузке системы.

Включить режим VGA

Загрузка с использованием основного драйвера VGA. Этот режим полезен, если причиной неправильной загрузки Windows является новый драйвер для видеоадаптера. Основной драйвер видеоадаптера всегда используется при загрузке в безопасном режиме («Безопасный режим», «Безопасный режим с загрузкой сетевых драйверов» или «Безопасный режим с поддержкой командной строки»).

Загрузка последней удачной конфигурации

Загрузка с использованием данных реестра и драйверов, сохраненных Windows при последнем завершении работы. Все изменения, сделанные со времени последней успешной загрузки, будут утеряны. Данный вариант следует использовать только в случае неправильной конфигурации. Он не устраняет неполадки, вызванные повреждением или отсутствием драйверов или файлов.

Дополнительные сведения см. в разделе Загрузка компьютера с использованием последней удачной конфигурации.

Восстановление службы каталогов

Этот вариант предназначен для серверных операционных систем и используется только для восстановления каталога SYSVOL и службы каталогов Active Directory на контроллере домена.

Режим отладки

Загрузка с отправкой данных об отладке на другой компьютер через прямое кабельное подключение.

Если для установки Windows используется или использовалась служба удаленной установки, могут быть доступны дополнительные варианты, связанные с восстановлением системы при помощи служб удаленного доступа.


Общие сведения о восстановлении

В Windows XP включено несколько средств, обеспечивающих правильность установки и работы компьютера, приложений и устройств. Эти средства помогают пользователям устранять неполадки, возникающие в результате добавления, удаления или замены файлов, необходимых для работы операционной системы, приложений и устройств. Большинство этих средств доступно во всех трех версиях Windows XP: Windows XP Home Edition, Windows XP Professional и Windows XP 64-Bit Edition.

Выбор средства или средств восстановления зависит от типа возникшей неполадки или сбоя. Следующий список помогает выбрать средства для устранения конкретных неполадок.

Личные файлы данных отсутствуют или повреждены, либо требуется вернуться к предыдущей версии файла.

Если копия нужного файла данных была сохранена в другом расположении, файл можно скопировать обратно на жесткий диск. Резервную копию можно создать в любое время, скопировав файл в другую папку на используемом компьютере, на внешний носитель (такой как съемный диск) или на другой компьютер.

Программа архивации
Использование: при необходимости восстановления версии файла данных, сохраненной с помощью программы архивации.
Выполняемые действия: восстановление файлов из архивов.
Доступность: во всех версиях Windows XP. По умолчанию данное средство в Windows XP Home Edition не устанавливается. Однако его можно установить с компакт-диска Windows XP Home Edition.
Дополнительные сведения см. в разделе Архивация файлов и папок.

После обновления драйвера вход в систему возможен, но система нестабильна.

Откат драйверов устройств
Использование: когда требуется только отменить обновление драйвера устройства (кроме драйвера принтера). Необходимо войти в систему в качестве администратора.
Выполняемые действия: повторная установка драйвера, использовавшегося ранее, и восстановление всех параметров драйвера, измененных при добавлении нового драйвера. Другие файлы или параметры не затрагиваются. Откат драйверов принтера невозможен.
Доступность: Windows XP Home Edition и Windows XP Professional.
Дополнительные сведения см. в разделе Возврат к предыдущей версии драйвера.
Восстановление системы
Использование: в случаях, когда после обновления драйвера устройства не удается восстановить стабильность системы с помощью средства отката драйверов. Для использования данного средства необходимо войти в систему в качестве администратора.
Выполняемые действия: восстановление параметров системы и приложений, действовавших на указанный момент времени. Отмена изменений ключевых файлов приложений, драйверов и операционной системы, сделанных с указанного момента времени. Файлы данных не затрагиваются.
Доступность: Windows XP Home Edition и Windows XP Professional.
Дополнительные сведения см. в разделе Общие сведения о восстановлении системы.

После установки нового устройства система работает нестабильно.

Отключение устройства
Использование: при подозрении о том, что причиной неполадки является одно или несколько устройств. Необходимо войти в систему в качестве администратора.
Выполняемые действия: отключение устройства и его драйверов.
Доступность: Windows XP Home Edition и Windows XP Professional.
Дополнительные сведения см. в разделе Отключение устройства.
Восстановление системы
Использование: если при подозрении о том, что причиной неполадки является одно или несколько устройств, отключение или удаление устройства не привело к устранению неполадки. Необходимо войти в систему в качестве администратора.
Выполняемые действия: восстановление параметров системы и приложений, действовавших на указанный момент времени. Восстановление ключевых файлов приложений, драйверов и операционной системы, измененных с указанного момента времени. Файлы данных не затрагиваются.
Доступность: Windows XP Home Edition и Windows XP Professional.
Дополнительные сведения см. в разделе Общие сведения о восстановлении системы.

Изменение параметров системы или приложения привело к ухудшению работы компьютера, а способ восстановления предыдущих параметров неизвестен.

Откат драйверов устройств
Использование: когда требуется только отменить обновление драйвера устройства (кроме драйвера принтера). Необходимо войти в систему в качестве администратора.
Выполняемые действия: повторная установка использовавшегося ранее драйвера устройства и восстановление всех параметров драйвера, измененных при добавлении нового драйвера. Другие файлы или параметры не затрагиваются. Откат драйверов принтера невозможен.
Доступность: Windows XP Home Edition и Windows XP Professional.
Дополнительные сведения см. в разделе Возврат к предыдущей версии драйвера.
Восстановление системы
Использование: при подозрении о внесении любого из следующих изменений:
  • изменение параметров системы или приложения, в том числе с помощью диалоговых окон свойств или системного реестра;
  • установка, обновление или удаление приложений;
  • добавление или удаление файлов, кроме файлов данных.
При подозрении о том, что причиной неполадки является установка приложения, сначала попробуйте удалить это приложение. Если это не устранит неполадку, воспользуйтесь средством восстановления системы. Для использования средства восстановления системы необходимо войти в систему в качестве администратора.
Выполняемые действия: восстановление параметров системы и приложений, действовавших на указанный момент времени. Восстановление ключевых файлов приложений, драйверов и операционной системы, измененных с указанного момента времени. Файлы данных не затрагиваются.
Доступность: Windows XP Home Edition и Windows XP Professional.
Дополнительные сведения см. в разделе Общие сведения о восстановлении системы.

После установки приложения система работает нестабильно или приложение работает неправильно.

В некоторых случаях система предлагает восстановить или переустановить приложение из сетевого ресурса или с исходного установочного носителя (например, с компакт-диска). В этих случаях следуйте инструкциям на экране по восстановлению программы. При выводе такого предложения для восстановления программы можно воспользоваться одним из следующих средств.

Установка и удаление программ
Использование: при подозрении о том, что причиной неполадки является одна или несколько программ.
Выполняемые действия: удаление указанных программ.
Доступность: во всех версиях Windows XP.
Дополнительные сведения см. в разделе Установка и удаление программ: обзор.
Восстановление системы
Использование: когда устранить неполадку с помощью средства «Установка и удаление программ» не удается. Необходимо войти в систему в качестве администратора.
Выполняемые действия: восстановление всех параметров системы и приложений, действовавших на указанный момент времени. Восстановление ключевых файлов приложений, драйверов и операционной системы, измененных с указанного момента времени. В результате отменяются все изменения, внесенные в систему данной программой. Файлы данных не затрагиваются.
Доступность: Windows XP Home Edition и Windows XP Professional.
Дополнительные сведения см. в разделе Общие сведения о восстановлении системы.

Операционная система не загружается (экран входа в систему не выводится)

Загрузка последней удачной конфигурации
Использование: при подозрении о том, что причиной сбоя является изменение, внесенное в систему перед перезагрузкой.
Выполняемые действия: восстановление параметров реестра и драйверов, действовавших при последней успешной загрузке компьютера.
Доступность: Windows XP Home Edition и Windows XP Professional.
Дополнительные сведения см. в разделе Загрузка компьютера с использованием последней удачной конфигурации.
Загрузка в безопасном режиме и восстановление системы
Использование: если после загрузки с использованием последней удачной конфигурации система по-прежнему не работает.
Выполняемые действия: загрузка с использованием только основных файлов и драйверов (драйвер мыши, кроме драйвера мыши для последовательного порта; монитор; клавиатура; диски; видеоадаптер; стандартные системные службы; отсутствие сетевых подключений). Если удалось загрузить систему в безопасном режиме, воспользуйтесь средством восстановления системы для восстановления всех параметров системы и приложений, действовавших на тот момент времени, когда система работала оптимально.
Доступность: Windows XP Home Edition и Windows XP Professional.
Дополнительные сведения см. в разделах Общие сведения о восстановлении системы и Загрузка компьютера в безопасном режиме.
Консоль восстановления
Использование: в случае сбоя загрузки с использованием последней удачной конфигурации и загрузки в безопасном режиме. Данный способ рекомендуется только для опытных пользователей, которые могут воспользоваться основными командами для определения драйверов и файлов, вызвавших неполадку. Для использования консоли восстановления перезагрузите компьютер, вставив в устройство чтения компакт-дисков установочный компакт-диск операционной системы. При появлении соответствующего приглашения на текстовом этапе процесса установки нажмите клавишу R для запуска консоли восстановления.
Выполняемые действия: с помощью консоли восстановления можно выполнять доступ к дискам компьютера. После этого можно вносить любые из следующих изменений для обеспечения возможности загрузки компьютера:
  • включать и отключать драйверы устройств или службы;
  • копировать файлы с установочного компакт-диска операционной системы или других съемных носителей (например, можно скопировать необходимый файл, который был удален);
  • создать новый загрузочный сектор и новую основную загрузочную запись (MBR). Это может потребоваться при сбое загрузки с существующего загрузочного сектора.
Доступность: во всех версиях Windows XP.
Дополнительные сведения см. в разделе Консоль восстановления: обзор.
Аварийное восстановление системы
Использование: в случае неудачи всех попыток восстановления или после замены поврежденного системного жесткого диска. Предварительно необходимо создать набор аварийного восстановления системы с помощью программы архивации.
Выполняемые действия: восстановление всех подписей дисков, томов и разделов на дисках, необходимых для загрузки компьютера. Затем система аварийного восстановления системы выполняет простую установку Windows и автоматически запускает процесс восстановления с использованием архива, созданного мастером аварийного восстановления системы.
Доступность: Windows XP Professional. В Windows XP Home Edition средство аварийного восстановления системы недоступно.
Дополнительные сведения см. в разделе Общие сведения об аварийном восстановлении системы.
Установочный компакт-диск Windows
Использование: При отсутствии архива для использования средством аварийного восстановления системы, если не удалось загрузить компьютер в безопасном режиме, с использованием последней удачной конфигурации или консоли восстановления.
Выполняемые действия: переустановка операционной системы. После этого необходимо переустановить приложения и восстановить файлы данных из архива.
Доступность: во всех версиях Windows XP.