Управление дисками

Оснастка «Управление дисками» в операционной системе XOX предназначена для таких задач, как создание и форматирование разделов и томов и назначение букв дисков. На компьютерах под управлением XOX и Windows 2000 Server оснастка «Управление дисками» может также использоваться для выполнения сложных задач, например для создания и восстановления отказоустойчивых томов.

  • Перед началом процесса добавления диска на компьютер ознакомьтесь с разделом Контрольный список для добавления нового диска.
  • Советы по использованию оснастки «Управление дисками» см. в разделе Советы и рекомендации.
  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Сведения общего характера собраны в разделе Основные понятия.
  • Инструкции по устранению неполадок см. в разделе Устранение неполадок.


Контрольный список для добавления нового диска

Действие | Ссылка
Ознакомьтесь с основными понятиями. | Общие сведения об управлении дисками Советы и рекомендации
Убедитесь, что входите в группу «Администраторы». | Сведения об учетных записях пользователей
Добавьте новый диск. | Управление новыми дисками
Создайте разделы или тома. | Типы разделов и запоминающих устройств Чтобы создать раздел или логический диск
Отформатируйте тома на диске. | Файловые системы операционной системы Windows Чтобы отформатировать базовый том Чтобы отформатировать динамический том


Новые способы выполнения некоторых задач

В следующей таблице перечислены общие задачи администрирования дисков и томов. Пользовательский интерфейс XOX для выполнения этих задач отличается от того, который применяется в Windows NT 4.0.

Примечание

  • XOX
Действие | Средства в операционной системе Windows NT 4.0 | Средства в операционной системе XOX
Форматирование тома | Команда Администратор дисков в меню «Администрирование». | Оснастка Управление компьютером (локальным). Для получения дополнительных сведений см. раздел Чтобы отформатировать динамический том.
Добавление нового диска | Команда Администратор дисков в меню «Администрирование». | Оснастка Управление компьютером (локальным). Для получения дополнительных сведений см. раздел Чтобы управлять новыми дисками.
Создание зеркального набора | Команда Администратор дисков в меню «Администрирование». | Оснастка Управление компьютером (локальным). Для получения дополнительных сведений см. раздел Чтобы создать зеркальный том.
Создание чередующегося набора с четностью | Команда Администратор дисков в меню «Администрирование». | Оснастка Управление компьютером (локальным). Для получения дополнительных сведений см. раздел Создание тома RAID-5.


Советы и рекомендации

  • Архивируйте данные
    При удалении или создании новых разделов или томов все существующие данные будут утеряны. До начала создания или удаления томов или разделов убедитесь, что все данные были архивированы. Поскольку данные, содержащиеся на дисках серверов, могут подвергнуться значительным изменениям, перед изменением разделов рекомендуется создать резервную копию для всего диска, даже если вы не планируете изменение одного или нескольких разделов.
  • Форматируйте тома в файловой системе NTFS
    Многие дополнительные возможности, такие как разрешения для файлов и папок, шифрование, поддержка больших томов и обработка разреженных файлов, доступные в Windows 2000 и XOX, требуют этого формата файлов.
  • Используйте динамические диски
    Некоторые задачи оснастки «Управление дисками» можно выполнить только с динамическими дисками, например возможность создания отказоустойчивых дисков. Использование динамических дисков позволяет создавать и удалять динамические тома следующих типов: простые, составные, чередующиеся, зеркальные и RAID-5. Динамические диски не содержат разделов или логических дисков, и прямой доступ к ним невозможно получить с компьютеров, на которых установлена операционная система MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT или XOX. Таким образом, эти операционные системы не могут быть запущены на динамических дисках. Однако общие папки на динамических дисках могут быть доступны по сети с компьютеров, на которых установлены эти операционные системы.


Инструкции

  • Настройка окна «Управление дисками»
  • Управление дисками
  • Управление динамическими томами
  • Управление базовыми томами


Управление окном «Управление дисками»

Рисунок Microsoft Windows

Настройка окна «Управление дисками»

  • Отображение дисков в виде списка или в графическом представлении
  • Изменение цветов и узоров томов и разделов дисков
  • Изменение размера отображения диска
  • Изменение отображения разделов
  • Обновление имени диска, файловой системы и сведений о томах


Отображение дисков и томов в виде списка или в графическом представлении

Чтобы отобразить диски и тома в виде списка или в графическом представлении

  1. XOX
  2. В меню Вид выполните одно из следующих действий.
    • Чтобы задать способ отображения в верхней области, выберите с помощью указателя мыши команду Верх и щелкните Список дисков, Список томов или Графическое представление.
    • Чтобы задать способ отображения в нижней области, выберите с помощью указателя мыши команду Низ и щелкните Список дисков, Список томов, Графическое представление или Скрыть.

Примечания

  • XOX
  • XOX
  • XOX
  • Чтобы увеличить или уменьшить размер каждой области, перетащите разделительную линию между ними.
  • Чтобы скрыть или отобразить дерево консоли, на стандартной панели инструментов нажмите кнопку Скрытие/отображение дерева консоли.
  • При выборе тома в списке томов раздел диска, который содержит этот том, будет выделен в графическом отображении дисков.

См. также


Изменение цветов и фоновых рисунков томов и разделов дисков

Чтобы изменить цвета и фоновые рисунки томов и разделов дисков

  1. XOX
  2. В меню Вид выберите команду Параметры.
  3. На вкладке Оформление в списке Область диска выберите изменяемый элемент.
  4. В поле со списком Цвет выберите новый цвет, а в поле со списком Узор — новый узор.

Примечания

  • XOX
  • XOX
  • XOX

См. также


Изменение размера отображения диска

Чтобы изменить размер отображения диска

  1. XOX
  2. В меню Вид выберите команду Параметры.
  3. На вкладке Масштаб в группе Изображать диски выберите параметр отображения дисков компьютера.

Примечания

  • XOX
  • XOX
  • XOX

См. также


Изменение отображения разделов

Чтобы изменить отображение разделов

  1. XOX
  2. В меню Вид выберите команду Параметры.
  3. На вкладке Масштаб в группе Изображать области диска выберите параметр отображения разделов дисков компьютера.

Примечания

  • XOX
  • XOX
  • XOX

См. также


Обновление имени диска, файловой системы и сведений о томах

Обновление имени диска, файловой системы и сведений о томе

  1. XOX
  2. XOX
  3. В меню Действие выберите команду Обновить.

Примечания

  • XOX
  • XOX
  • При выборе команды Обновить производится обновление имени диска, файловой системы, сведений о томах и съемных носителях, а также проверяется читаемость томов, которые было невозможно прочитать. Однако проверка оборудования не производится. Чтобы обновить сведения об оборудовании, выберите команду Повторить сканирование дисков.

См. также


Управление дисками

  • Инициализация нового диска
  • Обнаружение новых дисков
  • Перемещение дисков на другой компьютер
  • Просмотр свойств диска
  • Обновление сведений о дисках
  • Реактивизация отсутствующего или неподключенного динамического диска
  • Преобразование базового диска в динамический
  • Преобразование динамического диска обратно в базовый
  • Преобразование диска с основной загрузочной записью в диск с таблицей разделов GUID
  • Преобразование диска с таблицей разделов GUID в диск с основной загрузочной записью
  • Управление дисками на удаленном компьютере
  • Удаление отсутствующего динамического диска


Инициализация нового диска

Чтобы инициализировать новый диск

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши диск, который следует инициализировать, и выберите команду Инициализировать диск.
  4. В диалоговом окне Инициализация дисков выберите диск(и) для инициализации.

    5. При работе в 64-разрядном XOX 64-Bit Edition имеется возможность выбора стиля разделов с основной загрузочной записью или с таблицей разделов с кодами GUID.

    Диск инициализируется как базовый диск.

Примечания

  • XOX
  • XOX
  • Новые диски отображаются с состоянием Не проинициализирован. Использовать диск можно только после его инициализации. Если запустить консоль «Управление дисками» после добавления дисков, открывается мастер инициализации дисков, помогающий выполнить инициализацию.

См. также


Обнаружение новых дисков

Чтобы обнаружить новые диски

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. В меню Действие выберите команду Обновить конфигурацию оборудования.
  4. XOX
  5. В меню Действие выберите команду Повторить сканирование дисков.

Примечания

  • XOX
  • XOX
  • Если консоль «Управление дисками» не обнаруживает новый диск после выбора команды Повторить сканирование дисков, может потребоваться перезагрузка компьютера. Новые диски отображаются с состоянием Не проинициализирован. Использовать диск можно только после его инициализации. Для получения инструкций по инициализации диска щелкните ссылку См. также. Если запустить консоль «Управление дисками» после добавления дисков, открывается мастер инициализации дисков, помогающий выполнить инициализацию.
  • Новые диски могут быть преобразованы в динамические.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    rescan

Значение | Описание
rescan | Находит новые диски, которые были добавлены на компьютер

Примечания

  • XOX
  • XOX
  • Поиск изменений в оборудовании компьютера выполняется с помощью программы «Диспетчер устройств». Команда rescan программы DiskPart используется, когда конфигурация была изменена, но изменения не отображаются в консоли «Управление дисками». Для получения дополнительных сведений о программе «Диспетчер устройств» щелкните ссылку См. также.
  • При повторном сканировании дисков программой DiskPart проверяются изменения конфигурации на всех присоединенных дисках. Кроме того, обновляются сведения о съемных носителях, дисководах компакт-дисков, базовых томах, файловых системах и именах дисков.
  • Повторное сканирование дисков может занять несколько минут, в зависимости от числа установленных устройств.
  • Для получения дополнительных сведений о программе DiskPart щелкните ссылку См. также.

См. также


Перемещение дисков на другой компьютер

Чтобы переместить диски на другой компьютер

С помощью интерфейса Windows

  1. Перед попыткой перемещения дисков с одного компьютера на другой напечатайте или перепишите эти инструкции.
  2. В оснастке «Управление дисками» убедитесь, что тома на диске имеют состояние Исправен. Если состояние тома отличается от Исправен, перед перемещением дисков поврежденные тома необходимо восстановить. Для получения дополнительных сведений о восстановлении дисков щелкните ссылку См. также.

    3. Инструкции

    1. XOX
    2. XOX

      3. Состояние тома отображается в режимах Список томов и Графическое представление.

      • В режиме Список томов состояние тома отображается в столбце Состояние.
      • В режиме Графическое представление состояние тома отображается под размером диска и информацией о файловой системе.
  3. Удалите диски, которые требуется переместить, с помощью диспетчера устройств.

    4. Инструкции

    1. XOX
    2. XOX
    3. В списке устройств дважды щелкните значок Дисковые устройства.
    4. Щелкните правой кнопкой диски, которые следует удалить, и выберите команду Удалить.
    5. В диалоговом окне Подтверждение удаления устройства нажмите кнопку OK.
  4. Для базовых дисков пропустите шаг 5. Для удаления динамических дисков, которые требуется переместить, используется оснастка «Управление дисками».

    5. Инструкции

    1. XOX
    2. XOX
    3. Щелкните правой кнопкой мыши диск, который требуется переместить, и выберите команду Изъять диск.
    4. Если диски являются внешними, отключите их от компьютера. Если диски являются внутренним, выключите компьютер и физически извлеките диски.
  5. Если диски являются внешними, подсоедините их к компьютеру. Если диски являются внутренними, убедитесь, что компьютер выключен, и физически установите диски в этот компьютер.
  6. Запустите компьютер, содержащий перемещенные диски.
  7. Следуйте инструкциям в диалоговом окне Найдено новое оборудование.

    8. Если диалоговое окно Найдено новое оборудование не открывается, воспользуйтесь мастером установки оборудования. XOX

  8. Для обнаружения новых дисков используйте оснастку «Управление дисками».

    9. Инструкции

    1. XOX
    2. XOX
    3. В меню Действие выберите команду Повторить сканирование дисков.

      4. Если диски являются динамическими, оснастка «Управление дисками» отображает диалоговое окно Импорт чужих дисков. Щелкните правой кнопкой мыши любой диск с меткой Чужой, выберите команду Импорт чужих дисков и следуйте инструкциям, появляющимся на экране.

Примечания

  • XOX
  • XOX
  • После перемещения на другой компьютер именем базового диска становится первая доступная буква диска на этом компьютере. Динамические диски сохраняют букву, которая была им сопоставлена на предыдущем компьютере. Если на компьютере, на который перемещаются диски, эта буква диска уже используется, диску сопоставляется следующая доступная буква.
  • После перемещения динамического диска из другого компьютера все существующие на нем тома можно просматривать и использовать.
  • При перемещении составных, чередующихся, зеркальных томов и томов RAID-5 рекомендуется перемещать вместе все диски, содержащие том. В противном случае тома на дисках невозможно будет подключить и они будут доступны только для удаления.
  • Не перемещайте тома, расположенные на нескольких дисках, с компьютеров под управлением Windows NT 4.0 на компьютеры под управлением XOX. Операционная система XOX не поддерживает зеркальные наборы, чередующиеся наборы, чередующиеся наборы с четностью и наборы томов. Перед перемещением дисков в этом случае следует создать резервные копии томов и удалить сами тома, а затем создать новые динамические тома в XOX и восстановить данные.
  • При удалении или импорте дисков на компьютер необходимо каждый раз в меню Действие выбирать команду Повторить сканирование дисков, чтобы проверить правильность данных на диске.
  • Чтобы переместить несколько дисков с разных компьютеров на другой компьютер, необходимо их установить, открыть консоль «Управление дисками», щелкнуть правой кнопкой мыши любой из новых дисков и выбрать команду Импорт чужих дисков. При импорте нескольких дисков с разных компьютеров всегда импортируйте сразу все диски с одного компьютера. Например, если диски импортируются с двух компьютеров, то сначала импортируйте диски с первого компьютера, а затем со второго.
  • Консоль «Управление дисками» отображает состояние томов на дисках до импорта. Внимательно просмотрите эти сведения. При наличии ошибок отображаются сведения о том, что произойдет с каждым томом на этих дисках после импорта. Для получения дополнительных сведений щелкните ссылку См. также.
  • Диски с таблицей разделов с кодами GUID можно перемещать только на другие компьютеры с процессорами Itanium, работающие под управлением XOX 64-Bit Edition. На компьютерах с процессором x86 в консоли «Управление дисками» диски GPT отображаются с одним разделом, занимающим весь диск, однако доступ к данным на таких дисках невозможен.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите

    rescan

  4. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, который требуется импортировать.

  5. В командной строке DISKPART введите:

    select disk n

  6. В командной строке DISKPART введите:

    import

Значение | Описание
rescan | Находит новые диски, которые были добавлены на компьютер
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
select disk n | Выбирает указанный диск (n — номер диска) и переводит на него фокус
import | Импортирует группу внешних дисков в группу дисков локального компьютера. Команда import импортирует каждый диск, находящийся в одной группе с диском, имеющим фокус

Примечания

  • XOX
  • XOX
  • Не перемещайте тома, расположенные на нескольких дисках, с компьютеров под управлением Windows NT 4.0 на компьютеры под управлением XOX. Операционная система XOX не поддерживает зеркальные наборы, чередующиеся наборы, чередующиеся наборы с четностью и наборы томов. Перед перемещением дисков в этом случае следует создать резервные копии томов и удалить сами тома, а затем создать новые динамические тома в XOX и восстановить данные.
  • После перемещения динамического диска из другого компьютера все существующие на нем тома можно просматривать и использовать.
  • Диски с таблицей разделов с кодами GUID можно перемещать только на другие компьютеры с процессорами Itanium, работающие под управлением XOX 64-Bit Edition. На компьютерах с процессором x86 в консоли «Управление дисками» диски GPT отображаются с одним разделом, занимающим весь диск, однако доступ к данным на таких дисках невозможен.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Просмотр свойств диска

Чтобы просмотреть свойства диска

  1. XOX
  2. В графическом представлении или в представлении списка дисков щелкните правой кнопкой диск и выберите команду Свойства.

Примечание

  • XOX
  • XOX
  • XOX
  • В диалоговом окне Свойства отображаются сведения о физических дисках и о содержащихся в них томах. При необходимости просмотреть свойства одного из томов, представленных в списке, щелкните этот том правой кнопкой мыши и выберите команду Свойства.


Обновление сведений о дисках

Чтобы обновить сведения о дисках

  1. XOX
  2. В меню Действие выберите команду Повторить сканирование дисков.

Примечания

  • XOX
  • XOX
  • XOX
  • Команду Повторить сканирование дисков используют, когда конфигурация была изменена, но изменения не отображаются в окне «Управление дисками».
  • При повторном сканировании на всех подсоединенных дисках проверяются изменения конфигурации. Кроме того, обновляются сведения о съемных носителях, дисководах компакт-дисков, базовых томах, файловых системах и именах дисков.
  • Повторное сканирование дисков может занять несколько минут, в зависимости от числа установленных устройств.

См. также


Реактивизация отсутствующего или неподключенного динамического диска

Чтобы реактивизировать отсутствующий или неподключенный динамический диск

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши диск с меткой Отсутствует или Не подключен и выберите команду Реактивизировать диск.

    После реактивизации диск должен иметь метку Подключен.

Примечания

  • XOX
  • XOX
  • Динамический диск может иметь метку Отсутствует, если он поврежден, отсоединен или от него отключено питание.
  • Динамический диск может иметь метку Не подключен, если он поврежден или периодически бывает недоступен. Метка Не подключен может также быть назначена динамическому диску в случае сбоя импорта чужого динамического диска. На диске с меткой Не подключен появляется значок ошибки. Состояние Отсутствует или Не подключен отображается только для динамических дисков.
  • Реактивизировать можно только динамические диски.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, который требуется реактивизировать.

  4. В командной строке DISKPART введите:

    select disk n

  5. В командной строке DISKPART введите:

    online

Значение | Описание
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
select disk n | Устанавливает фокус на диск с номером n
online | Подключает отключенный диск или том, на который установлен фокус

Примечания

  • XOX
  • XOX
  • Динамический диск может иметь метку Отсутствует, если он поврежден, отсоединен или от него отключено питание.
  • Динамический диск может иметь метку Не подключен, если он поврежден или периодически бывает недоступен. Метка Не подключен может также быть назначена динамическому диску в случае сбоя импорта чужого динамического диска. На диске с меткой Не подключен появляется значок ошибки. Состояние Не подключен отображается только для динамических дисков.
  • Реактивизировать можно только динамические диски.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Преобразование базового диска в динамический

Чтобы преобразовать базовый диск в динамический

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши базовый диск, который требуется преобразовать, выберите команду Преобразовать в динамический диск и следуйте инструкциям на экране.

    4. Если данная команда не отображается, возможно вместо диска выбран том, диск уже может быть преобразован в динамический или компьютер является переносным. (XOX) Помимо этого, можно преобразовать диски кластера, подключенные к общей шине SCSI или Fibre Channel, в динамические диски. Службой кластеров поддерживаются только базовые диски.

Примечания

  • XOX
  • XOX
  • Для получения дополнительных сведений о преобразовании базовых дисков в динамические щелкните ссылку См. также.
  • После преобразования базового диска в динамический динамические тома не могут быть обратно преобразованы в разделы. Вместо этого необходимо удалить все динамические тома на диске и выполнить команду Преобразовать в базовый диск. Если требуется сохранить данные на диске, создайте их резервную копию или переместите на другой том. Для получения дополнительных сведений о команде Преобразовать в базовый диск щелкните ссылку См. также.
  • Перед преобразованием дисков закройте все программы, выполняемые на этих дисках.
  • Чтобы успешно выполнить преобразование, каждый диск с основной загрузочной записью, подлежащий преобразованию, должен содержать не менее 1 Мбайт незанятого места для размещения базы данных динамического диска. В Windows 2000 и XOX это пространство автоматически резервирует при создании разделов или томов на диске, но на дисках с разделами или томах, созданных в других операционных системах, этого места может не быть. (Это пространство может существовать, даже если оно не отображается в окне «Управление дисками».)
  • После преобразования динамический диск не будет содержать базовых томов (основных разделов или логических дисков), и не сможет быть доступен в операционных системах MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT и XOX. Получить доступ к динамическим дискам можно только в Windows 2000 и XOX.
  • При преобразовании базового диска в динамический все существующие разделы базового диска или логические диски преобразуются в простые тома динамического диска.
  • Не следует преобразовывать диски, содержащие несколько установок Windows 2000 или XOX, в динамические диски. При преобразовании диска в динамический записи всех разделов этого диска удаляются, за исключением записей загрузочных и системных томов установленной операционной системы. При преобразовании диска в динамический не проверяются другие установки Windows и удаляются записи разделов всех других загрузочных томов на диске. Помимо этого, записи реестра, относящихся к тому второй установки устаревают, и эту операционную систему уже невозможно запустить.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, который требуется преобразовать в динамический.

  4. В командной строке DISKPART введите:

    select disk n

  5. В командной строке DISKPART введите:

    convert dynamic

Значение | Описание
list disk | Выводит список дисков и сведения о них, такие как размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов GUID (GPT). Диск, помеченный звездочкой (*), имеет фокус.
select disk | Выбирает указанный диск, где n представляет номер диска, и переводит на него фокус.
convert dynamic | Преобразование базового диска в динамический.

Примечания

  • XOX
  • XOX
  • Для получения дополнительных сведений о преобразовании базовых дисков в динамические щелкните ссылку См. также.
  • После преобразования базового диска в динамический динамические тома не могут быть обратно преобразованы в разделы. Вместо этого необходимо удалить все динамические тома на диске и выполнить команду DiskPart convert basic. Если требуется сохранить данные на диске, создайте их резервную копию или переместите на другой том. Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.
  • Перед преобразованием дисков закройте все программы, выполняемые на этих дисках.
  • Чтобы успешно выполнить преобразование, каждый диск с основной загрузочной записью, подлежащий преобразованию, должен содержать не менее 1 Мбайт незанятого места для размещения базы данных динамического диска. В Windows 2000 и XOX это пространство автоматически резервируется при создании разделов или томов на диске, но на дисках с разделами или томах, созданных в других операционных системах, этого места может не быть. (Это пространство может существовать, даже если оно не отображается в окне «Управление дисками».)
  • После преобразования динамический диск не будет содержать разделов или логических дисков и не сможет быть доступен в операционных системах MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT и XOX. Получить доступ к динамическим дискам можно только в Windows 2000 и XOX.
  • При преобразовании базового диска в динамический все существующие разделы базового диска или логические диски преобразуются в простые тома динамического диска.
  • Не следует преобразовывать диски, содержащие несколько установок Windows 2000 или XOX, в динамические диски. При преобразовании диска в динамический записи всех разделов этого диска удаляются, за исключением записей загрузочных и системных томов установленной операционной системы. При преобразовании диска в динамический не проверяются другие установки Windows и удаляются записи разделов всех других загрузочных томов на диске. Помимо этого, записи реестра, относящихся к тому второй установки устаревают, и эту операционную систему уже невозможно запустить.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Преобразование динамического диска обратно в базовый

Чтобы преобразовать динамический диск обратно в базовый

С помощью интерфейса Windows

  1. Создайте резервные копии всех томов на диске, который требуется преобразовать из динамического в базовый, или переместите их.

    2. Для получения дополнительных сведений о резервном копировании томов щелкните ссылку См. также.

  2. XOX
  3. XOX
  4. Щелкните правой кнопкой мыши динамический диск, который требуется преобразовать в базовый, и выберите команду Удалить том для каждого тома на диске.
  5. После удаления всех томов на диске щелкните его правой кнопкой мыши и выберите команду Преобразовать в базовый диск.

Примечания

  • XOX
  • XOX
  • Диск может быть преобразован в базовый, только если он пуст. Если требуется сохранить данные на диске, перед преобразованием диска в базовый создайте их резервную копию или переместите их на другой том.
  • После преобразования динамического диска обратно в базовый на нем можно создавать только разделы и логические диски.

С помощью командной строки

  1. Создайте резервные копии всех томов на диске, который требуется преобразовать из динамического в базовый, или переместите их.

    2. Для получения дополнительных сведений о резервном копировании томов щелкните ссылку См. также.

  2. Откройте окно Командная строка.
  3. Введите:

    diskpart

  4. В командной строке DISKPART введите:

    list volume

    Запишите номера томов, которые требуется удалить.

  5. В командной строке DISKPART введите:

    select volume=n

  6. В командной строке DISKPART введите:

    delete volume

  7. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, который требуется преобразовать в базовый.

  8. В командной строке DISKPART введите:

    select disk n

  9. В командной строке DISKPART введите:

    convert basic

Значение | Описание
list volume | Отображает список базовых и динамических томов на всех дисках
select volume | Выбирает указанный том (n — номер тома) и переводит на него фокус. Если том не указан, команда select отображает текущий том, имеющий фокус. Том можно указать по номеру, букве диска или пути к точке подключения. На базовом диске при выборе тома фокус переводится на соответствующий раздел
delete volume | Удаляет выделенный том. Нельзя удалить системный том, загрузочный том, а также любой другой том, содержащий активный файл подкачки или аварийную копию памяти (дамп памяти)
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
select disk | Выбирает указанный диск (n — номер диска) и переводит на него фокус
convert basic | Преобразует пустой динамический диск в базовый

Примечания

  • XOX
  • XOX
  • Диск может быть преобразован в базовый, только если он пуст. Если требуется сохранить данные на диске, перед преобразованием диска в базовый создайте их резервную копию или переместите их на другой том.
  • После преобразования динамического диска обратно в базовый на нем можно создавать только разделы и логические диски.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Преобразование диска с основной загрузочной записью в диск с таблицей разделов с кодами GUID

Чтобы преобразовать диск с основной загрузочной записью в диск с таблицей разделов с кодами GUID (только в 64-разрядной системе)

С помощью интерфейса Windows

  1. Создайте резервные копии всех томов на диске с основной загрузочной записью (MBR-диск), который требуется преобразовать в диск с таблицей разделов с кодами GUID (GPT-диск), или переместите их. Если диск уже пуст, перейдите к шагу 2.

    2. Для получения дополнительных сведений о резервном копировании томов щелкните ссылку См. также.

  2. XOX
  3. XOX
  4. Если диск пуст, перейдите к шагу 5. В противном случае щелкните правой кнопкой мыши каждый том на диске и выберите команду Удалить том.
  5. Щелкните правой кнопкой мыши диск с основной загрузочной записью, который требуется преобразовать, и выберите команду Преобразовать в GPT-диск.

Примечания

  • XOX
  • XOX
  • На компьютерах с процессором Itanium MBR-диск может быть преобразован в GPT-диск, если он пуст.
  • Стиль разделов GPT не может использоваться на съемных носителях, съемных дисках с интерфейсом USB или IEEE 1394 (называемом также FireWire) и на дисках кластера, подключенных к общей шине SCSI или Fibre Channel, используемой службой кластеров.
  • На компьютерах с процессорами x86 поддерживаются только MBR-диски. На компьютерах с процессорами Itanium поддерживаются как MBR-, так и GPT-диски.

С помощью командной строки

  1. Создайте резервные копии всех томов на диске с основной загрузочной записью (MBR-диск), который требуется преобразовать в диск с таблицей разделов с кодами GUID (GPT-диск), или переместите их. Если диск уже пуст, перейдите к шагу 2.

    2. Для получения дополнительных сведений о резервном копировании томов щелкните ссылку См. также.

  2. Откройте окно Командная строка.
  3. Введите:

    diskpart

    4. Если диск уже пуст, перейдите к шагу 7.

  4. В командной строке DISKPART введите:

    list volume

    Запишите номер тома, который следует удалить.

  5. В командной строке DISKPART введите:

    select volume n

  6. В командной строке DISKPART введите:

    delete volume

  7. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, который требуется преобразовать в диск с таблицей разделов с кодами GUID.

  8. В командной строке DISKPART введите:

    select disk n

  9. В командной строке DISKPART введите:

    convert gpt

Внимание!

  • Диск может быть преобразован в GPT-диск, только если он пуст. Перед преобразованием диска создайте архивную копию данных, а затем удалите все разделы и тома.
Значение | Описание
list volume | Отображает список базовых и динамических томов на всех дисках
select volume | Выбирает указанный том (n — номер тома) и переводит на него фокус. Если том не указан, команда select отображает текущий том, имеющий фокус. Том можно указать по номеру, букве диска или пути к точке подключения. На базовом диске при выборе тома фокус переводится на соответствующий раздел
delete volume | Удаляет выделенный том. Нельзя удалить системный том, загрузочный том, а также любой другой том, содержащий активный файл подкачки или аварийную копию памяти (дамп памяти)
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
select disk n | Выбирает указанный диск (n — номер диска) и переводит на него фокус
convert gpt | На компьютерах с процессором Itanium преобразует пустой базовый диск со стилем разделов основная загрузочная запись в базовый диск со стилем таблица разделов с кодами GUID

Примечания

  • XOX
  • XOX
  • На компьютерах с процессором Itanium MBR-диск может быть преобразован в GPT-диск, если он пуст.
  • Стиль разделов GPT не может использоваться на съемных носителях, съемных дисках с интерфейсом USB или IEEE 1394 (называемом также FireWire) и на дисках кластера, подключенных к общей шине SCSI или Fibre Channel, используемой службой кластеров.
  • На компьютерах с процессорами x86 поддерживаются только MBR-диски. На компьютерах с процессорами Itanium поддерживаются как MBR-, так и GPT-диски.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Преобразование диска с таблицей разделов с кодами GUID в диск с основной загрузочной записью

Чтобы преобразовать диск с таблицей разделов с кодами GUID в диск с основной загрузочной записью (только в 64-разрядной системе)

С помощью интерфейса Windows

  1. Создайте резервные копии всех томов на диске с таблицей разделов с кодами GUID (GPT-диск), который требуется преобразовать в диск с основной загрузочной записью (MBR-диск), или переместите их. Если диск уже пуст, перейдите к шагу 2.

    2. Для получения дополнительных сведений о резервном копировании томов щелкните ссылку См. также.

  2. XOX
  3. XOX
  4. Если диск пуст, перейдите к шагу 5. В противном случае щелкните правой кнопкой мыши каждый том на диске и выберите команду Удалить том.
  5. Щелкните правой кнопкой мыши GPT-диск, который требуется преобразовать в MBR-диск, и выберите команду Преобразовать в MBR-диск.

Примечания

  • XOX
  • XOX
  • На компьютерах с процессором Itanium GPT-диск может быть преобразован в MBR-диск, только если он пуст.
  • На компьютерах с процессорами x86 поддерживаются только MBR-диски. На компьютерах с процессорами Itanium поддерживаются как MBR-, так и GPT-диски.

С помощью командной строки

  1. Создайте резервные копии всех томов на диске с таблицей разделов с кодами GUID (GPT-диск), который требуется преобразовать в диск с основной загрузочной записью (MBR-диск), или переместите их. Если диск уже пуст, перейдите к шагу 2.

    2. Для получения дополнительных сведений о резервном копировании томов щелкните ссылку См. также.

  2. Откройте окно Командная строка.
  3. Введите:

    diskpart

    4. Если диск уже пуст, перейдите к шагу 7.

  4. В командной строке DISKPART введите:

    list volume

    Запишите номер тома, который следует удалить.

  5. В командной строке DISKPART введите:

    select volume n

  6. В командной строке DISKPART введите:

    delete volume

  7. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, который требуется преобразовать в MBR-диск.

  8. В командной строке DISKPART введите:

    select disk n

  9. В командной строке DISKPART введите:

    convert mbr

Внимание!

  • Диск может быть преобразован в MBR-диск, только если он пуст. Перед преобразованием диска создайте резервную копию данных, а затем удалите все разделы и тома.
Значение | Описание
list volume | Отображает список базовых и динамических томов на всех дисках
select volume | Выбирает указанный том (n — номер тома) и переводит на него фокус. Если том не указан, команда select отображает текущий том, имеющий фокус. Том можно указать по номеру, букве диска или пути к точке подключения. На базовом диске при выборе тома фокус переводится на соответствующий раздел
delete volume | Удаляет выделенный том. Нельзя удалить системный том, загрузочный том, а также любой другой том, содержащий активный файл подкачки или аварийную копию памяти (дамп памяти)
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
select disk | Выбирает указанный диск (n — номер диска) и переводит на него фокус
convert mbr | На компьютерах с процессором Itanium преобразует пустой базовый диск со стилем разделов таблица разделов с кодами GUID в базовый диск со стилем разделов основная загрузочная запись

Примечания

  • XOX
  • XOX
  • На компьютерах с процессором Itanium GPT-диск может быть преобразован в MBR-диск, только если он пуст.
  • На компьютерах с процессорами x86 поддерживаются только MBR-диски. На компьютерах с процессорами Itanium поддерживаются как MBR-, так и GPT-диски.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Управление дисками на удаленном компьютере

Чтобы приступить к управлению дисками на удаленном компьютере

  1. XOX
  2. В дереве консоли щелкните правой кнопкой мыши компонент Управление компьютером (локальным) и выберите команду Подключиться к другому компьютеру.
  3. В поле другим компьютером введите имя компьютера, которым требуется управлять удаленно.

Примечания

  • XOX
  • Зеркальные тома, тома RAID-5 и диски с таблицей разделов с кодами GUID доступны не во всех версиях Windows. Типы томов и дисков, которые могут быть созданы, зависят от того, под управлением какой версии Windows работает удаленный (а не локальный) компьютер. Например, локальный компьютер под управлением XOX можно использовать для создания зеркальных томов и томов RAID-5 на удаленном компьютере, работающем под управлением Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server.
  • Компьютер-клиент и компьютер-сервер должны находиться в одном домене или в доверенном домене.
  • Пользователь компьютера-клиента должен быть членом группы «Администраторы» удаленного компьютера.
  • Компьютер с операционной системой XOX можно использовать для управления дисками на удаленном компьютере с операционной системой Windows 2000, и наоборот.
  • Компьютер с процессором x86 можно использовать для управления компьютером с процессором Itanium и наоборот.
  • Если компьютер с операционной системой XOX используется для управления удаленным компьютером с операционной системой Windows 2000, некоторые сведения на страницах свойств съемных дисков IEEE 1394 и USB не отображаются.
  • Если компьютер с операционной системой Windows 2000 используется для управления удаленным компьютером с процессором Itanium и операционной системой XOX 64-Bit Edition, управление дисками с таблицей разделов с кодами GUID и динамическими дисками на удаленном компьютере возможно только тогда, когда ни один из дисков в группе не является GPT-диском.

См. также


Удаление отсутствующего динамического диска

Чтобы изъять отсутствующий динамический диск

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши динамический диск с меткой Отсутствует и выберите команду Удалить том, чтобы удалить все тома на диске с состоянием Отсутствует.
  4. Щелкните правой кнопкой мыши динамический диск с меткой Отсутствует и выберите команду Изъять диск.

Примечания

  • XOX
  • XOX
  • Динамический диск может иметь метку Отсутствует, если он поврежден, отсоединен или от него отключено питание.
  • Если на компьютере имеется несколько динамических дисков, перед изъятием диска с состоянием Отсутствует необходимо удалить на нем все тома. В противном случае остальные динамические диски с состоянием Подключен сохраняют сведения о диске с состоянием Отсутствует и его томах в базе данных динамических дисков, в результате чего этот диск и его тома продолжают отображаться в оснастке «Управление дисками».

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, который требуется удалить из списка дисков.

  4. В командной строке DISKPART введите:

    select disk n

  5. В командной строке DISKPART введите:

    delete disk

Значение | Описание
list disk | Выводит список дисков и сведения о них, такие как размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
select disk n | Выбирает указанный диск (n — номер диска) и переводит на него фокус
delete disk | Удаляет отсутствующий динамический диск из списка дисков

Примечания

  • XOX
  • XOX
  • Динамический диск может иметь метку Отсутствует, если он поврежден, отсоединен или от него отключено питание.
  • Если на компьютере имеется несколько динамических дисков, перед изъятием диска с состоянием Отсутствует необходимо удалить на нем все тома. В противном случае остальные динамические диски с состоянием Подключен сохраняют сведения о диске с состоянием Отсутствует и его томах в базе данных динамических дисков, в результате чего этот диск и его тома продолжают отображаться в оснастке «Управление дисками».

См. также


Управление базовыми томами

  • Просмотр свойств тома
  • Назначение, смена и удаление буквы диска
  • Создание подключенного диска
  • Выбор активного раздела
  • Форматирование базового тома
  • Создание раздела или логического диска
  • Удаление раздела или логического диска
  • Расширение базового тома


Просмотр свойств базового тома

Чтобы просмотреть свойства базового тома

  1. XOX
  2. В оснастке Управление дисками щелкните правой кнопкой мыши раздел, логический диск или любой базовый том и выберите команду Свойства.

Примечания

  • XOX
  • XOX
  • XOX

См. также


Назначение, смена и удаление буквы диска

Чтобы назначить, сменить или удалить букву диска

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши раздел, логический диск или том и выберите команду Изменить букву диска или путь к диску.
  4. Выполните одно из следующих действий.
    • Чтобы назначить букву диска, нажмите кнопку Добавить, выберите нужную букву и нажмите кнопку ОК.
    • Чтобы сменить букву диска, выберите ее, нажмите кнопку Изменить, выберите нужную букву и нажмите кнопку ОК.
    • Чтобы удалить букву диска, выберите диск и нажмите кнопку Удалить.

Внимание!

  • При назначении буквы диску необходимо быть осторожным, поскольку многие программы MS-DOS и Windows ссылаются на буквы дисков. Например, переменная среды path отображает имена дисков при связывании с именами программ.

Примечания

  • XOX
  • XOX
  • На компьютере можно использовать до 26 букв дисков. Буквы «A» и «B» зарезервированы для дисководов гибких дисков, но можно назначать эти буквы съемным дискам, если компьютер не имеет соответствующего дисковода гибких дисков. Жесткие диски компьютера получают буквы от «C» до «Z», тогда как сопоставленным сетевым дискам буквы назначаются в обратном порядке (от «Z» до «B»).
  • Не допускается изменение буквы диска системного и загрузочного томов.
  • При выборе имени тома, дисковода компакт-дисков или другого съемного носителя может появиться сообщение об ошибке, например если устройство используется какой-либо программой системы. В этом случае закройте программу, осуществляющую доступ к тому или диску, и выберите команду Изменить букву диска или путь к диску еще раз.
  • Windows 2000 и XOX позволяют жестко присваивать буквы дисков томам, разделам и устройствам чтения компакт-дисков. Это означает, что имя диска постоянно связано с определенным разделом, томом или дисководом компакт-дисков. При добавлении нового жесткого диска в компьютер существующие имена дисков не будут изменены.
  • Кроме того, локальный диск можно подключить к пустой папке на томе NTFS с помощью пути к диску вместо буквы диска. Для получения дополнительных сведений щелкните ссылку См. также.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list volume

    Запишите номер простого тома, для которого выполняется назначение, смена или удаление буквы диска.

  4. В командной строке DISKPART введите:

    select volume n

    Выбор тома n, для которого выполняется назначение, смена или удаление буквы диска.

  5. В командной строке DISKPART введите одну из следующих команд:
    • assign letter=L

      • L — буква диска, которую требуется назначить или сменить.

    • remove letter=L

      • L — буква диска, которую требуется удалить.

Значение | Описание
list volume | Отображает список базовых и динамических томов на всех дисках
select volume | Выбирает указанный том (n — номер тома) и переводит на него фокус. Если том не указан, команда select отображает текущий том, имеющий фокус. Том можно указать по номеру, букве диска или пути к точке подключения. На базовом диске при выборе тома фокус переводится на соответствующий раздел
assign letter=L | Назначает букву диска L тому, имеющему фокус. Если буква диска не указана, используется следующая доступная буква. Если буква диска уже используется, возникает ошибка
remove letter=L | Удаляет букву диска L с тома, имеющего фокус. Если буква диска или точка подключения не указана, команда DiskPart удаляет первую обнаруженную букву диска или точку подключения. Команду remove можно использовать для смены буквы диска, связанной со съемным диском. Не допускается удаление буквы диска для системного и загрузочного томов, а также для тома, содержащего файл подкачки. Удаление букв диска разделов, созданных ИВТ, любых GPT-разделов с нераспознанной таблицей GUID, а также особых, не содержащих данных GPT-разделов, например системных разделов EFI, также не допускается

Примечания

  • XOX
  • XOX
  • На компьютере можно использовать до 26 букв дисков. Буквы «A» и «B» зарезервированы для дисководов гибких дисков, но можно назначать эти буквы съемным дискам, если компьютер не имеет соответствующего дисковода гибких дисков. Жесткие диски компьютера получают буквы от «C» до «Z», тогда как сопоставленным сетевым дискам буквы назначаются в обратном порядке (от «Z» до «B»).
  • Не допускается изменение буквы диска системного и загрузочного томов.
  • При выборе имени тома, дисковода компакт-дисков или другого съемного носителя может появиться сообщение об ошибке, например, если устройство используется какой-либо программой системы. В этом случае закройте программу, осуществляющую доступ к тому или диску, и выберите команду Изменить букву диска или путь к диску еще раз.
  • Windows 2000 и XOX позволяют жестко присваивать буквы дисков томам, разделам и устройствам чтения компакт-дисков. Это означает, что имя диска постоянно связано с определенным разделом, томом или дисководом компакт-дисков. При добавлении нового жесткого диска в компьютер существующие имена дисков не будут изменены.
  • Кроме того, локальный диск можно подключить к пустой папке на томе NTFS с помощью пути к диску вместо буквы диска. Для получения дополнительных сведений щелкните ссылку См. также.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Создание подключенного диска

Чтобы создать подключенный диск

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши раздел или том, который требуется подключить, и выберите команду Изменить букву диска или пути к диску.
  4. Выполните одно из следующих действий.
    • Чтобы подключить том, нажмите кнопку Добавить. Выберите параметр Подключить как указанную ниже NTFS-папку, введите путь к пустой папке в томе NTFS или нажмите кнопку Обзор для поиска папки.
    • Для отключения тома нажмите кнопку Удалить.

Примечания

  • XOX
  • XOX
  • При подключении локального диска к пустой папке на томе NTFS консоль «Управление дисками» назначает путь к диску вместо его имени. Пути к дискам доступны только для пустых папок в базовых или динамических томах NTFS.
  • При администрировании локального или удаленного компьютера можно просматривать папки NTFS на этом компьютере.
  • При использовании кластеров серверов необходимо проверять уникальность создаваемых подключенных дисков, чтобы они не конфликтовали с существующими локальными дисками на любых узлах в кластере.
  • При использовании кластеров серверов не создавайте подключенные диски между дисками в устройстве хранилища кластера (дисками кластера) и локальными дисками.
  • При использовании кластеров серверов не создавайте подключенные диски из дисков кластера, содержащих ресурс кворума (диск кворума). Однако можно создать подключенный диск с диска кластера на диск кворума.
  • При использовании кластеров серверов подключенные диски с одного диска кластера на другой должны находиться в одной группе ресурсов кластера и зависеть от корневого диска.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Из диска или папки NTFS, которые требуется подключить к другому месту, введите:

    diskpart.

  3. В командной строке DISKPART введите:

    list volume

    Запишите номер простого тома, который следует подключить к другому месту.

  4. В командной строке DISKPART введите:

    select volume n

    Выбор простого тома n, который следует подключить к другому месту.

  5. В командной строке DISKPART введите:

    6. assign [mount=путь]

Значение | Описание
list volume | Отображает список базовых и динамических томов на всех дисках
select volume | Выбирает указанный том (n — номер тома) и переводит на него фокус. Если том не указан, команда select отображает текущий том, имеющий фокус. Том можно указать по номеру, букве диска или пути к точке подключения. На базовом диске при выборе тома фокус переводится на соответствующий раздел
assign | Назначает букву диска или точку подключения тому, имеющему фокус. Если буква диска или точка подключения не указана, используется следующая доступная буква. Если буква диска или точка подключения уже используется, возникает ошибка. С помощью команды assign можно изменить букву съемного диска. Нельзя назначать буквы дисков системным томам, загрузочным томам или томам, содержащим файл подкачки. Кроме того, буква диска не может быть назначена разделу ИВТ или разделу GPT, отличному от раздела MSDATA
mount=путь | Указывает существующую пустую папку NTFS, в которой будет находиться подключенный диск

Примечания

  • XOX
  • XOX
  • Пути к дискам доступны только для пустых папок в базовых или динамических томах NTFS.
  • Для изменения пути к диску удалите его, а затем задайте путь для нового местоположения диска. Изменить путь к диску напрямую нельзя.
  • При использовании кластеров серверов необходимо проверять уникальность создаваемых подключенных дисков, чтобы они не конфликтовали с существующими локальными дисками на любых узлах в кластере.
  • При использовании кластеров серверов не создавайте подключенные диски между дисками в устройстве хранилища кластера (дисками кластера) и локальными дисками.
  • При использовании кластеров серверов не создавайте подключенные диски из дисков кластера, содержащих ресурс кворума (диск кворума). Однако можно создать подключенный диск с диска кластера на диск кворума.
  • При использовании кластеров серверов подключенные диски с одного диска кластера на другой должны находиться в одной группе ресурсов кластера и зависеть от корневого диска.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.
  • Создать подключенный диск можно также с помощью команды mountvol. Для получения дополнительных сведений о команде mountvol щелкните ссылку См. также.

См. также


Выбор активного раздела

Чтобы выбрать активный раздел

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой основной раздел, который требуется сделать активным, и выберите команду Сделать раздел активным.

Примечания

  • XOX
  • XOX
  • В режиме списка и в графическом представлении системные, активные и загрузочные разделы отмечены как Система, Активен и Загрузка соответственно.
  • Логические диски не могут быть помечены как активные.
  • Сделать раздел активным можно только на диске с с основной загрузочной записью (MBR).
  • Компьютер может иметь на диске только один активный раздел.
  • Изменение или удаление активного раздела может привести к тому, что компьютер не будет запускаться.
  • Обычно разделы, содержащие системные и загрузочные файлы, называются системными и загрузочными соответственно.
  • Системный раздел должен быть основным разделом, сделанным активным для загрузки, и должен находиться на диске, доступном для компьютера при запуске системы. В каждый отдельный момент активным может быть только один системный раздел на диске. Можно иметь несколько базовых дисков с одним активным разделом на каждом. Однако компьютер будет загружаться только с одного указанного диска. Если необходимо использовать другую операционную систему, то перед перезагрузкой ее системный раздел нужно сделать активным.
  • Системный раздел не может быть частью чередующегося тома, составного тома или тома RAID-5.
  • Существующие динамические тома не могут быть помечены как активные. Однако базовый диск, содержащий активный раздел, может быть преобразован в динамический диск. После преобразования диска раздел становится простым активным томом. Если активный раздел не является текущим системным или загрузочным разделом, он становится простым томом и его запись в таблице разделов пропадает, поэтому он больше не может быть активным.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list partition

    Запишите номер раздела, который следует сделать активным.

  4. В командной строке DISKPART введите:

    select partition n

    Выбор раздела n, который следует сделать активным.

  5. В командной строке DISKPART введите:

    active

Внимание!

  • DiskPart проверяет только факт присутствия в разделе файлов загрузки операционной системы. DiskPart не проверяет содержимое раздела. Если по ошибке раздел, помеченный как «active», не содержит файлов загрузки операционной системы, компьютер запускаться не будет.
Значение | Описание
list partition | Отображает разделы, перечисленные в таблице разделов текущего диска
select partition | Выбирает указанный раздел и передает ему фокус. Если раздел не указан, команда select отображает текущий раздел, имеющий фокус
active | Помечает раздел на базовом диске, имеющий фокус, как активный. Эта информация указывает базовой системе ввода-вывода (BIOS) или расширенному интерфейсу микропрограмм, что раздел или том является действующим системным разделом или системным томом. В качестве активных могут быть помечены только разделы

Примечания

  • XOX
  • XOX
  • Логические диски не могут быть помечены как активные.
  • Сделать раздел активным можно только на диске с с основной загрузочной записью (MBR).
  • Компьютер может иметь на диске только один активный раздел.
  • Изменение или удаление активного раздела может привести к тому, что компьютер не будет запускаться.
  • Обычно разделы, содержащие системные и загрузочные файлы, называются системными и загрузочными соответственно.
  • Системный раздел должен быть основным разделом, сделанным активным для загрузки, и должен находиться на диске, доступном для компьютера при запуске системы. В каждый отдельный момент активным может быть только один системный раздел. Можно иметь несколько базовых дисков с одним активным разделом на каждом. Однако компьютер будет загружаться только с одного указанного диска. Если необходимо использовать другую операционную систему, то перед перезагрузкой ее системный раздел нужно сделать активным.
  • Системный раздел не может быть частью чередующегося тома, составного тома или тома RAID-5.
  • Существующие динамические тома не могут быть помечены как активные. Однако базовый диск, содержащий активный раздел, может быть преобразован в динамический диск. После преобразования диска раздел становится простым активным томом. Если активный раздел не является текущим системным или загрузочным разделом, он становится простым томом и его запись в таблице разделов пропадает, поэтому он больше не может быть активным.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Форматирование базового тома

Чтобы отформатировать базовый том

  1. XOX
  2. Щелкните правой кнопкой мыши раздел, логический диск или базовый том, который требуется форматировать (или переформатировать), и выберите команду Форматировать.
  3. Выберите соответствующие параметры и нажмите кнопку OK.

Примечания

  • XOX
  • XOX
  • XOX
  • Не допускается форматирование системного и загрузочного разделов.
  • Сжатие поддерживается только томами NTFS.
  • Быстрое форматирование удаляет с диска все файлы без проверки поверхности. Используйте этот параметр, если диск ранее уже был отформатирован и имеется уверенность, что он не испорчен.

См. также


Создание раздела или логического диска

Чтобы создать раздел или логический диск

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши невыделенную область на базовом диске и выберите команду Создать раздел или щелкните правой кнопкой свободное пространство в дополнительном разделе, а затем выберите команду Создать логический диск.
  4. В мастере создания раздела нажмите кнопку Далее, выберите Основной раздел, Дополнительный раздел или Логический диск и следуйте инструкциям на экране.

Примечания

  • XOX
  • XOX
  • Основные и дополнительные разделы и логические диски могут быть созданы только на базовых дисках. На компьютерах, работающих под управлением операционных систем MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT 4.0 и XOX вместо динамических томов следует создавать базовые тома.
  • На дисках с основной загрузочной записью можно создать до четырех основных разделов (или до трех основных и один дополнительный).
  • На дисках с таблицей разделов с кодами GUID возможно создание до 128 основных разделов.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, на котором следует создать основной или дополнительный раздел.

  4. В командной строке DISKPART введите:

    select disk n

    Выбор диска n, на котором следует создать основной или дополнительный раздел.

  5. В командной строке DISKPART введите одну из следующих команд:

    create partition primary [size=n] [offset=n] [ID=byte | GUID] [noerr]

    или

    create partition extended [size=n] [offset=n] [noerr]

    или

    create partition logical [size=n] [offset=n] [noerr]

Значение | Описание
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
select disk | Выбирает указанный диск (n — номер диска) и переводит на него фокус
create partition primary | Создает основной раздел на текущем базовом диске. После создания раздела фокус автоматически переносится на него. Раздел не получает букву диска автоматически; ее необходимо назначить с помощью команды assign
create partition extended | Создает дополнительный раздел на текущем диске. После создания раздела фокус автоматически переносится на этот раздел. На диске можно создать только один дополнительный раздел. Команда не выполняется при попытке создать дополнительный раздел в другом дополнительном разделе. Дополнительный раздел следует создавать до создания логических дисков
create partition logical | Создает логический диск в дополнительном разделе. После создания раздела фокус автоматически переносится на новый логический диск
size=n | Размер раздела в мегабайтах (Мбайт). Если размер не указан, раздел будет продолжен до тех пор, пока в текущей области не останется незанятого места. Размер определяется цилиндрами и округляется до ближайшей границы цилиндра. Например, если задать размер 500 Мбайт, то размер раздела будет округлен до 504 Мбайт
offset=n | Смещение в байтах для начала нового раздела. Если смещение не указано, начало раздела совпадет с началом свободного места на диске. Для дисков с основной загрузочной записью (MBR) смещение определяется размерами цилиндров и округляется до ближайшей границы цилиндра. Например, если указано смещение 27 Мбайт, а размер цилиндра 8 Мбайт, то смещение округляется до границы 24 Мбайт
ID=byte | GUID

Этот параметр предназначен только для использования ИВТ.

Внимание!

  • Создание разделов с этим параметром может привести к сбоям в работе компьютера или к невозможности его загрузки. Использовать параметр ID=byte | GUID при создании GPT-дисков рекомендуется только ИВТ и специалистам в области информационных технологий, имеющим опыт работы с GPT-дисками. Используйте команду create partition efi для создания системных разделов EFI, команду create partition msr для создания разделов MSR и команду create partition primary (без параметра ID=byte | GUID) для создания основных разделов на GPT-дисках.

Для MBR-дисков можно задавать байт типа раздела. Если байт типа раздела на MBR-диске не задан, команда create partition primary создает раздел с типом 0x6. Любой байт типа раздела может быть задан с помощью параметра ID=byte | GUID. Команда DiskPart не выполняет проверку допустимости байта типа раздела, а также какие-либо другие проверки параметра ID.

Для GPT-дисков можно задать тип GUID создаваемого раздела.

  • Системный раздел EFI: c12a7328-f81f-11d2-ba4b-00a0c93ec93b
  • Раздел MSR: e3c9e316-0b5c-4db8-817d-f92df00215ae
  • Раздел MSDATA: ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
  • Раздел метаданных диспетчера локальных дисков на динамическом диске: 5808c8aa-7e8f-42e0-85d2-e1e90434cfb3
  • Раздел данных диспетчера локальных дисков на динамическом диске: af9b60a0-1431-4f62-bc68-3311714a69ad

Если тип GUID разделов не задан, команда create partition primary создает раздел MSDATA. Любой тип раздела можно задать с помощью параметра ID=byte | GUID. Команда DiskPart не выполняет проверку допустимости GUID раздела, а также какие-либо другие проверки параметра ID
noerr | Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки

Примечания

  • XOX
  • XOX
  • Основные и дополнительные разделы и логические диски могут быть созданы только на базовых дисках. На компьютерах, работающих под управлением операционных систем MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT 4.0 и XOX вместо динамических томов следует создавать базовые тома.
  • На дисках с основной загрузочной записью можно создавать до четырех основных разделов (или до трех основных и один дополнительный).
  • На дисках с таблицей разделов с кодами GUID возможно создание до 128 основных разделов.
  • Команда DiskPart не позволяет создавать разделы на съемных носителях.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Удаление раздела или логического диска

Чтобы удалить раздел или логический диск

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши раздел, логический диск или том, которой требуется удалить, и выберите команду Удалить раздел.

Внимание!

  • После удаления раздела все данные на удаленном разделе или логическом диске будут потеряны.
  • Удаленные разделы и логические диски не могут быть восстановлены.

Примечания

  • XOX
  • XOX
  • Нельзя удалить системный том, загрузочный том, а также любой другой том, содержащий активный файл подкачки или аварийную копию памяти (дамп памяти).
  • Дополнительный раздел можно удалить лишь в том случае, если он пуст.

    Перед удалением дополнительного раздела необходимо удалить все логические диски на дополнительном разделе.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, на котором требуется удалить раздел.

  4. В командной строке DISKPART введите:

    select disk n

    Выбор диска n, на котором требуется удалить раздел.

  5. В командной строке DISKPART введите:

    list partition

    Запишите номер раздела, который требуется удалить.

  6. В командной строке DISKPART введите:

    select partition n

    Выбор раздела n, который нужно удалить.

  7. В командной строке DISKPART введите:

    delete partition

Внимание!

  • Удаление раздела на динамическом диске может привести к удалению всех динамических томов на этом диске, в результате чего диск будет преобразован в базовый. Для удаления динамического тома используйте команду delete volume.

Внимание!

  • После удаления раздела все данные на удаленном разделе или логическом диске будут потеряны.
  • Удаленные разделы и логические диски не могут быть восстановлены.
Значение | Описание
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
select disk | Выбирает указанный диск (n — номер диска) и переводит на него фокус
list partition | Отображает разделы, перечисленные в таблице разделов текущего диска
select partition n | Выбирает указанный раздел и передает ему фокус. Если раздел не указан, команда select отображает текущий раздел, имеющий фокус
delete partition | На базовом диске удаляет раздел, имеющий фокус. Нельзя удалить системный раздел, загрузочный раздел, а также любой другой раздел, содержащий активный файл подкачки или аварийную копию памяти (дамп памяти)

Примечания

  • XOX
  • XOX
  • Нельзя удалить системный том, загрузочный том, а также любой другой том, содержащий активный файл подкачки или аварийную копию памяти (дамп памяти).
  • Дополнительный раздел можно удалить лишь в том случае, если он пуст.

    Перед удалением дополнительного раздела необходимо удалить все логические диски на дополнительном разделе.

  • Команда DiskPart не позволяет удалять разделы на съемных носителях.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Расширение базового тома

Чтобы расширить базовый том

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list volume

    Запишите номер базового тома, который следует расширить.

  4. В командной строке DISKPART введите:

    select volume n

    Выбор базового тома n, который требуется расширить на смежную пустую область на том же диске.

  5. В командной строке DISKPART введите:

    extend [size=n]

    Расширение выбранного тома на размер size=n Мбайт.

Значение | Описание
list volume | Отображает список базовых и динамических томов на всех дисках
select volume | Выбирает указанный том (n — номер тома) и переводит на него фокус. Если том не указан, команда select отображает текущий том, имеющий фокус. Том можно указать по номеру, букве диска или пути к точке подключения. На базовом диске при выборе тома фокус переводится на соответствующий раздел
extend | Расширяет том, имеющий фокус, на примыкающее к нему незанятое место. Для базовых томов оно должно находиться на том же диске и следовать за разделом, имеющим фокус (иметь более высокий сектор смещения). Простой или составной динамический том можно расширить на пустое пространство на любом динамическом диске. С помощью этой команды существующий том может быть расширен на новое, только что созданное место. Если раздел был ранее отформатирован в файловой системе NTFS, файловая система автоматически расширяется на увеличенный раздел. Данные при этом не теряются. Если раздел был ранее отформатирован в любой файловой системе, отличной от NTFS, имеет место отказ команды без изменения раздела. Невозможно расширить текущий системный или загрузочный раздел
size=n | Объем в мегабайтах (Мбайт), добавляемый к текущему разделу. Если размер не указан, диск расширяется на все примыкающее к нему незанятое место

Примечания

  • XOX
  • XOX
  • Расширить можно только том, отформатированный в файловой системе NTFS.
  • Базовый том можно расширить только в пределах одного диска.
  • Расширение базового тома возможно лишь в том случае, когда за ним непосредственно следует незанятое место.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Управление динамическими томами

  • Просмотр свойств тома
  • Назначение, смена и удаление буквы диска
  • Создание подключенного диска
  • Форматирование динамического тома
  • Удаление динамического тома
  • Управление простыми томами
  • Управление составными томами
  • Создание чередующегося тома
  • Управление зеркальными томами
  • Управление томами RAID-5
  • Реактивизация динамического тома


Форматирование динамического тома

Чтобы отформатировать динамический том

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши том, который требуется отформатировать (или переформатировать), и выберите команду Форматировать.
  4. Выберите соответствующие параметры и нажмите кнопку OK.

Примечания

  • XOX
  • XOX
  • Не допускается форматирование системного и загрузочного томов.
  • Сжатие файлов поддерживается только на томах NTFS с размером кластера 4 Кбайт и меньше.
  • Если установлен флажок Быстрое форматирование, файлы удаляются с диска, но поиск поврежденных секторов на диске не выполняется. Используйте этот параметр, если диск ранее уже был отформатирован и имеется уверенность, что он не поврежден.
  • В оснастке «Управление дисками» для динамических томов доступна только файловая система NTFS. Однако с помощью команды format можно форматировать динамические тома для файловых систем FAT и FAT32.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    format том [/fs:файловая_система] [/v:метка] [/q] [/a:размер] [/c]

Значение | Описание
том | Задает точку подключения, имя тома или диска, который необходимо отформатировать. Если никакие из следующих параметров командной строки не заданы, команда format будет использовать тип тома для определения параметров форматирования диска по умолчанию
/fs:файловая_система | Тип файловой системы, которая будет создана на диске: FAT, FAT32 или NTFS. Гибкие диски могут использовать только файловую систему FAT
/v:метка | Задает метку тома. Если параметр командной строки /v пропущен или метка не задана, команда format выведет запрос для ввода метки тома после завершения форматирования. Чтобы отключить вывод запроса для ввода метки, введите параметр со следующим синтаксисом: /v:. Если с помощью команды format форматируется несколько дисков, всем дискам будет присвоена одна метка тома
/q | Выполняет быстрое форматирование. Удаляет таблицу файлов и корневой каталог ранее отформатированного тома без поиска поврежденных секторов. Параметр командной строки /q следует использовать только для форматирования дисков, которые находятся в хорошем состоянии
/a:размер Задает размер кластера (также называется размером блоков выделения) для томов FAT, FAT32 и NTFS. Используйте одно из следующих значений параметра размер. Если параметр размер не задан, он будет определен исходя из размера диска.
512 | Создает кластеры размером 512 байтов.
1024 | Создает кластеры размером 1024 байта.
2048 | Создает кластеры размером 2048 байтов.
4096 | Создает кластеры размером 4096 байтов.
8192 | Создает кластеры размером 8192 байтов.
16K | Создает кластеры размером 16 Кбайт.
32K | Создает кластеры размером 32 Кбайт.
64K | Создает кластеры размером 64 Кбайт
/c | Только для NTFS. Файлы, создаваемые на новом диске, будут по умолчанию сжиматься

Примечания

  • XOX
  • XOX
  • Не допускается форматирование системного и загрузочного томов.
  • Быстрое форматирование удаляет с диска все файлы без поиска поврежденных секторов. Используйте этот параметр, если диск ранее уже был отформатирован и имеется уверенность, что он не поврежде
  • Сжатие файлов поддерживается только на томах NTFS с размером кластера 4 Кбайт и меньше.
  • В операционных системах Windows NT 4.0, Windows 2000 и XOX размер кластера на томах FAT16 размером от 2 Гбайт до 4 Гбайт составляет 64 Кбайт, что может вызвать несовместимость с некоторыми приложениями. Например, программы установки могут неправильно определять размер свободного места на томах с размером кластера 64 Кбайт и в результате не выполняться из-за недостатка места. В связи с этим на томах, размер которых превышает 2 Гбайт, необходимо использовать файловую систему FAT32 или NTFS. Перед форматированием тома с размером кластера 64 Кбайт для файловой системы FAT16 команда format выводит предупреждение и запрос на подтверждение.
  • Для получения дополнительных сведений о команде format щелкните ссылку См. также.

См. также


Удаление динамического тома

Чтобы удалить динамический том

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши динамический том, который требуется удалить, и выберите команду Удалить том.

Внимание!

  • Будьте внимательны при удалении тома. При удалении простого, составного, чередующегося, зеркального тома или тома RAID-5 удаляются все данные на томе, а также сам том.
  • Удаленные тома не могут быть восстановлены.

Примечания

  • XOX
  • XOX
  • Нельзя удалить системный том, загрузочный том, а также любой другой том, содержащий активный файл подкачки или аварийную копию памяти (дамп памяти).
  • Динамические простые, составные, чередующиеся и зеркальные тома, а также тома RAID-5 недоступны в операционной системе XOX. Динамические зеркальные тома и тома RAID-5 недоступны в операционных системах XOX и XOX 64-Bit Edition.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list volume

    Запишите номер динамического тома, который требуется удалить.

  4. В командной строке DISKPART введите:

    select volume n

    Выбор динамического тома n, подлежащего удалению.

  5. В командной строке DISKPART введите:

    delete volume

    Удаление выделенного динамического тома.

Внимание!

  • Будьте внимательны при удалении тома. При удалении простого, составного, чередующегося, зеркального тома или тома RAID-5 удаляются все данные на томе, а также сам том.
  • Удаленные тома не могут быть восстановлены.
Значение | Описание
list volume | Отображает список базовых и динамических томов на всех дисках
select volume | Выбирает указанный том (n — номер тома) и переводит на него фокус. Если том не указан, команда select отображает текущий том, имеющий фокус. Том можно указать по номеру, букве диска или пути к точке подключения. На базовом диске при выборе тома фокус переводится на соответствующий раздел
delete volume | Удаляет выделенный том. Нельзя удалить системный том, загрузочный том, а также любой другой том, содержащий активный файл подкачки или аварийную копию памяти (дамп памяти)

Примечания

  • XOX
  • XOX
  • Нельзя удалить системный том, загрузочный том, а также любой другой том, содержащий активный файл подкачки или аварийную копию памяти (дамп памяти).
  • Динамические простые, составные, чередующиеся и зеркальные тома, а также тома RAID-5 недоступны в операционной системе XOX. Динамические зеркальные тома и тома RAID-5 недоступны в операционных системах XOX и XOX 64-Bit Edition.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Реактивизация динамического тома

Чтобы реактивизировать динамический том

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши динамический том с состоянием Неисправен и выберите команду Реактивизировать том.

    4. В результате должно быть восстановлено состояние Исправен.

Примечание

  • XOX
  • XOX

См. также


Управление простыми томами

  • Создание простого тома
  • Расширение простого или составного тома


Создание простого тома

Чтобы создать простой том

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши незанятое место динамического диска, где требуется создать простой том, и выберите команду Создать том.
  4. В мастере создания тома нажмите кнопку Далее, установите переключатель Простой том и следуйте инструкциям на экране.

Примечания

  • XOX
  • XOX
  • Новые простые тома можно создавать только на динамических дисках.
  • Том может быть расширен, только если на нем нет файловой системы или он отформатирован с помощью файловой системы NTFS. Тома, отформатированные с помощью FAT или FAT32, не могут быть расширены.
  • Не допускается расширение системного и загрузочного томов.
  • Простые и составные тома, не являющиеся системными или загрузочными, могут быть расширены при наличии доступного места на диске. Можно расширить простые и составные тома, созданные как динамические или базовые и затем преобразованные в динамические в операционной системе XOX.
  • Расширение чередующихся томов, зеркальных томов и томов RAID-5 невозможно.
  • После обновления Windows 2000 на XOX невозможно расширение простого или составного тома, созданного как базовый и преобразованного в динамический в Windows 2000.
  • Допускается расширение простого тома на дополнительные диски для создания составного тома. Составные тома не могут быть зеркально отображены или включены в чередующийся том.
  • Если был расширен составной том, нельзя удалить любую его часть, не удаляя всего тома.
  • Простые тома не являются отказоустойчивыми.
  • Доступ к простым томам возможен только с помощью Windows 2000 и XOX. Следует создавать базовые тома на базовых дисках, если на компьютере установлена операционная система MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT 4.0 или XOX, поскольку динамические тома недоступны из этих операционных систем.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, на котором требуется создать простой том.

  4. В командной строке DISKPART введите:

    create volume simple [size=n] [disk=n]

Значение | Описание
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
create volume simple | Создает простой том. После создания тома фокус автоматически переносится на этот том
size=n | Размер раздела в мегабайтах (Мбайт). Если размер не задан, новый том занимает все свободное место на диске
disk=n | Динамический диск, на котором создается том. Если диск не задан, используется текущий диск

Примечания

  • XOX
  • XOX
  • Новые простые тома можно создавать только на динамических дисках.
  • Том может быть расширен, только если на нем нет файловой системы или он отформатирован с помощью файловой системы NTFS. Тома, отформатированные с помощью FAT или FAT32, не могут быть расширены.
  • Не допускается расширение системного и загрузочного томов.
  • Простые и составные тома, не являющиеся системными или загрузочными, могут быть расширены при наличии доступного места на диске. Можно расширить простые и составные тома, созданные как динамические или базовые и затем преобразованные в динамические в операционной системе XOX или XOX.
  • Расширение чередующихся томов, зеркальных томов и томов RAID-5 невозможно.
  • После обновления Windows 2000 на XOX или XOX невозможно расширение простого или составного тома, созданного как базовый и преобразованного в динамический в Windows 2000.
  • Допускается расширение простого тома на дополнительные диски для создания составного тома. Составные тома не могут быть зеркально отображены или включены в чередующийся том.
  • Если был расширен составной том, нельзя удалить любую его часть, не удаляя всего тома.
  • Простые тома не являются отказоустойчивыми.
  • Доступ к простым томам возможен только с помощью Windows 2000 и XOX. Следует создавать базовые тома на базовых дисках, если на компьютере установлена операционная система MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT 4.0 или XOX, поскольку динамические тома недоступны из этих операционных систем.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Расширение простого или составного тома

Чтобы расширить простой или составной том

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши простой или составной том, который требуется расширить, выберите команду Расширить том и следуйте появляющимся на экране инструкциям.

Примечания

  • XOX
  • XOX
  • Том можно расширить, только если на нем нет файловой системы или он отформатирован с помощью файловой системы NTFS. Тома, отформатированные с помощью FAT или FAT32, не могут быть расширены.
  • Не допускается расширение системного и загрузочного томов.
  • Простые и составные тома, не являющиеся системными или загрузочными, могут быть расширены при наличии доступного места на диске. Это относится также к простым и составным томам, созданным как динамические или базовые и затем преобразованным в динамические в операционной системе XOX.
  • Невозможно расширение чередующихся томов, зеркальных томов и томов RAID-5.
  • После обновления Windows 2000 на XOX невозможно расширение простого или составного тома, созданного как базовый и преобразованного в динамический в Windows 2000.
  • Допускается расширение простого тома на дополнительные диски для создания составного тома. Составные тома не могут быть зеркально отображены или включены в чередующийся том.
  • Если был расширен составной том, нельзя удалить любую его часть, не удаляя всего тома.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list volume

    Запишите номер простого тома, который требуется расширить на другой диск.

  4. В командной строке DISKPART введите:

    select volume n

    Выбор простого тома n, который требуется расширить на другой диск.

  5. В командной строке DISKPART введите:

    extend [size=n] [disk=n]

    Расширение выбранного тома на диск n и задание размера расширения, равного n мегабайт (Мбайт).

Значение | Описание
list volume | Отображает список базовых и динамических томов на всех дисках
select volume | Выбирает указанный том (n — номер тома) и переводит на него фокус. Если том не указан, команда select отображает текущий том, имеющий фокус. Том можно указать по номеру, букве диска или пути к точке подключения. На базовом диске при выборе тома фокус переводится на соответствующий раздел
extend | Расширяет том, имеющий фокус, на примыкающее к нему незанятое место. Для базовых томов оно должно находиться на том же диске и следовать за разделом, имеющим фокус (иметь более высокий сектор смещения). Простой или составной динамический том может быть расширен на пустое пространство на любом динамическом диске. С помощью этой команды существующий том можно расширить на новое, только что созданное место. Если раздел был ранее отформатирован в файловой системе NTFS, файловая система автоматически расширяется на увеличенный раздел. Данные при этом не теряются. Если раздел был ранее отформатирован в любой файловой системе, отличной от NTFS, имеет место отказ команды без изменения раздела. Невозможно расширить текущий системный или загрузочный раздел
disk=n | Динамический диск, на который расширяется том. На этом диске выделяется объем, равный значению size=n. Если диск не указан, том расширяется на текущий диск
size=n | Объем в мегабайтах (Мбайт), добавляемый к текущему разделу. Если размер не указан, диск расширяется на все примыкающее к нему незанятое место

Примечания

  • XOX
  • XOX
  • Том можно расширить, только если на нем нет файловой системы или он отформатирован с помощью файловой системы NTFS. Тома, отформатированные с помощью FAT или FAT32, не могут быть расширены.
  • Не допускается расширение системного и загрузочного томов.
  • Простые и составные тома, не являющиеся системными или загрузочными, могут быть расширены при наличии доступного места на диске. Это относится также к простым и составным тома, созданным как динамические или базовые и затем преобразованным в динамические в операционной системе XOX.
  • Невозможно расширение чередующихся томов, зеркальных томов и томов RAID-5.
  • После обновления Windows 2000 на XOX невозможно расширение простого или составного тома, созданного как базовый и преобразованного в динамический в Windows 2000.
  • Допускается расширение простого тома на дополнительные диски для создания составного тома. Составные тома не могут быть зеркально отображены или включены в чередующийся том.
  • Если был расширен составной том, нельзя удалить любую его часть, не удаляя всего тома.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Управление составными томами

  • Создание составного тома
  • Расширение простого или составного тома


Создание составного тома

Чтобы создать составной том

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши незанятое место динамического диска, где требуется создать составной том, а затем выберите команду Создать том.
  4. В мастере создания тома нажмите кнопку Далее, установите переключатель Составной том и следуйте инструкциям на экране.

Примечания

  • XOX
  • XOX
  • Новые составные тома можно создавать только на динамических дисках.
  • Для создания составного тома необходимы как минимум два динамических диска.
  • Составной том может быть расширен максимум на 32 динамических диска.
  • Составные тома не могут быть зеркально отображены или включены в чередующийся том.
  • Составные тома не являются отказоустойчивыми.

См. также


Создание чередующегося тома

Создание чередующегося тома

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши незанятое место динамического диска, где требуется создать чередующийся том, а затем выберите команду Создать том.
  4. В мастере создания тома нажмите кнопку Далее, установите переключатель Чередующийся и следуйте инструкциям на экране.

Примечания

  • XOX
  • XOX
  • Для создания чередующегося тома необходимо как минимум два динамических диска. Чередующийся том может быть создан максимум на 32 динамических дисках.
  • Чередующиеся тома не являются отказоустойчивыми и не могут быть зеркально отображены или расширены.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, на котором требуется создать чередующийся том.

  4. В командной строке DISKPART введите:

    create volume stripe [size=n] [disk=n[,[n,…]]

Значение | Описание
list disk | Выводит список дисков и сведения о них, такие как размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов GUID (GPT). Диск, помеченный звездочкой (*), имеет фокус.
create volume stripe | Создает чередующийся том на указанных дисках. После создания тома фокус автоматически переносится на этот том.
size=n | Объем в мегабайтах (Мбайт), который том будет занимать на каждом диске. Если размер не задан, новый том занимает все свободное место на самом маленьком диске и равный объем на каждом последующем диске.
disk=n | Динамические диски, на которых создается том. Объем, равный значению size=n, выделяется на каждом диске.

Примечания

  • XOX
  • XOX
  • Для создания чередующегося тома необходимо как минимум два динамических диска. Чередующийся том может быть создан максимум на 32 динамических дисках.
  • Чередующиеся тома не являются отказоустойчивыми и не могут быть зеркально отображены или расширены.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Управление зеркальными томами

  • Создание зеркального тома
  • Добавление зеркала существующего простого тома
  • Разделение зеркального тома на два тома
  • Удаление зеркала из зеркального тома
  • Подключение диска и восстановление зеркального тома
  • Реактивизация зеркального тома
  • Замена вышедшего из строя зеркала новым зеркалом


Создание зеркального тома

Чтобы создать зеркальный том

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши незанятое место динамического диска, где требуется создать зеркальный том, а затем выберите команду Создать том.
  4. В мастере создания тома нажмите кнопку Далее, установите переключатель Зеркальный том и следуйте инструкциям, появляющимся на экране.

Примечания

  • XOX
  • XOX
  • Создание зеркальных томов возможно только на компьютерах, работающих под управлением Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server.
  • Для создания зеркального тома необходимы два динамических диска.
  • Может быть отражен существующий простой том.
  • Зеркальные тома отказоустойчивы и используют архитектуру RAID-1, которая обеспечивает избыточную отказоустойчивость путем создания двух идентичных копий тома.
  • Зеркальные тома не могут расширены или включены в чередующийся том.
  • Обеим копиям (зеркалам) зеркального тома сопоставлена одна буква диска.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list disk

    Запишите номера динамических дисков, которые будут составлять зеркальный том.

  4. В командной строке DISKPART введите:

    select disk n

    Если диск пуст, перейдите к шагу 5, чтобы создать на этом диске простой том. В противном случае переходите к шагу 6.

  5. В командной строке DISKPART введите:

    create volume simple [size=n] [disk=n]

  6. В командной строке DISKPART введите:

    add disk n

Значение | Описание
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
select disk | Выбирает указанный диск (n — номер диска) и переводит на него фокус
create volume simple | Создает простой том. После создания тома фокус автоматически переносится на этот том
size=n | Размер раздела в мегабайтах (Мбайт). Если размер не задан, новый том занимает все свободное место на диске
disk=n | Динамический диск, на котором создается том. Если диск не задан, используется текущий диск
add disk=n | Отражает простой том с фокусом на указанный диск (n — номер диска). Необходимо, чтобы размер незанятого места на этом диске был не меньше размера простого тома, который требуется отразить

Примечания

  • XOX
  • XOX
  • Создание зеркальных томов возможно только на компьютерах, работающих под управлением Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server.
  • Для создания зеркального тома необходимы как минимум два динамических диска.
  • Зеркальные тома отказоустойчивы и используют архитектуру RAID-1, которая обеспечивает избыточную отказоустойчивость путем создания двух идентичных копий тома.
  • Зеркальные тома не могут быть расширены или включены в чередующийся том.
  • Обеим копиям (зеркалам) зеркального тома сопоставлена одна буква диска.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Добавление зеркала существующего простого тома

Чтобы добавить зеркало существующего простого тома

С помощью интерфейса Windows

Создание зеркальных томов возможно только на компьютерах, работающих под управлением Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server.

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши простой том, зеркало которого требуется создать, выберите команду Добавить зеркало и следуйте появляющимся на экране инструкциям.

Примечания

  • XOX
  • XOX
  • Для любого существующего простого тома можно создать зеркало на другом динамическом диске, на котором достаточно незанятого места. Если динамический диск с достаточным объемом свободного места отсутствует, команда меню Добавить зеркало недоступна. (Чтобы определить, достаточно ли места на диске, щелкните диск правой кнопкой мыши, выберите команду Свойства и проверьте значение в поле Свободно. Оно может быть несколько меньше значения, отображаемого в режиме списка и в графическом представлении.)
  • Зеркальные тома отказоустойчивы и используют архитектуру RAID-1, которая обеспечивает избыточную отказоустойчивость путем создания двух идентичных копий тома.
  • Расширить простой том после создания зеркала нельзя.
  • Обеим копиям (зеркалам) зеркального тома сопоставляется одна буква диска.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list volume

    Запишите номер простого тома, который требуется отразить на другой диск.

  4. В командной строке DISKPART введите:

    select volume n

    Выбор простого тома n, который требуется отразить на другой диск.

  5. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, на который требуется отразить том.

  6. В командной строке DISKPART введите:

    add disk n

Значение | Описание
list volume | Отображает список базовых и динамических томов на всех дисках
select volume | Выбирает указанный том (n — номер тома), и переводит на него фокус. Если том не указан, команда select отображает текущий том, имеющий фокус. Том можно указать по номеру, букве диска или пути к точке подключения. На базовом диске при выборе тома фокус переводится на соответствующий раздел
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
add disk n | Отражение простого тома с фокусом на указанный диск. Необходимо, чтобы размер незанятого места на указанном диске был не меньше размера простого тома, который требуется отразить

Примечания

  • XOX
  • XOX
  • Создание зеркальных томов возможно только на компьютерах, работающих под управлением Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server.
  • Зеркальные тома отказоустойчивы и используют архитектуру RAID-1, которая обеспечивает избыточную отказоустойчивость путем создания двух идентичных копий тома.
  • Расширить простой том после создания зеркала нельзя.
  • Обеим копиям (зеркалам) зеркального тома сопоставляется одна буква диска.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Разделение зеркального тома на два тома

Чтобы разделить зеркальный том на два тома

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши одну из копий тома в зеркальном томе и выберите команду Разделить зеркальный том.

Примечания

  • XOX
  • XOX
  • При разделении зеркального тома две копии тома, составлявшие зеркальный том, становятся двумя независимыми простыми томами. Эти тома уже не будут отказоустойчивыми. Буква диска или точка подключения копии тома, которая была выбрана при разделении зеркального тома, сохраняется, а второму тому операционная система XOX назначает следующую доступную букву диска.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list disk

    Запишите номера дисков зеркального тома, который требуется разбить на два отдельных тома.

  4. В командной строке DISKPART введите:

    list volume

    Запишите номер зеркального тома.

  5. В командной строке DISKPART введите:

    select volume n

    Выбор зеркального тома, который требуется разбить на два отдельных тома.

  6. В командной строке DISKPART введите:

    break disk n

Значение | Описание
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
list volume | Отображает список базовых и динамических томов на всех дисках
select volume | Выбирает указанный том (n — номер тома) и переводит на него фокус. Если том не указан, команда select отображает текущий том, имеющий фокус. Том можно указать по номеру, букве диска или пути к точке подключения. На базовом диске при выборе тома фокус переводится на соответствующий раздел
break disk n | Применяется только к динамическим дискам. Разбивает зеркальный том на два простых тома. Эти тома уже не будут отказоустойчивыми. Фокус устанавливается на диск с номером n, что позволяет назначить ему букву диска. Если указанный диск является системным или загрузочным томом, эта команда не может быть выполнена. Для другого диска сохраняются буква диска и все точки подключения, принадлежавшие зеркальному тому

Примечания

  • XOX
  • XOX
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Удаление зеркала из зеркального тома

Чтобы удалить зеркало из зеркального тома

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши зеркало, которое требуется удалить, выберите команду Удалить зеркало и следуйте инструкциям, появляющимся на экране.

Внимание!

  • После удаления зеркала из зеркального тома его место освобождается, а оставшееся зеркало становится простым томом, который уже не является отказоустойчивым. Все данные зеркала удаляются вместе с ним.

Примечания

  • XOX
  • XOX

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list disk

    Запишите номер диска, содержащего зеркальный том, который требуется разбить на два отдельных тома.

  4. В командной строке DISKPART введите:

    break disk n [nokeep]

Значение | Описание
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
break disk n | Применяется только к динамическим дискам. Разбивает зеркальный том на два простых тома. Эти тома уже не будут отказоустойчивыми. Фокус устанавливается на диск с номером n, что позволяет назначить ему букву диска. Если указанный диск является системным или загрузочным томом, эта команда не может быть выполнена. Для другого диска сохраняются буква диска и все точки подключения, принадлежавшие зеркальному тому. Если задан параметр nokeep, указанный диск с номером n удаляется и преобразуется в свободное место, а другая половина зеркала сохраняется как простой том. Фокуса не получает ни один из томов
nokeep | Задает сохранение только одного из отраженных томов. Второй простой том удаляется и преобразуется в свободное место. Фокуса не получает ни один из томов

Внимание!

  • После удаления зеркала из зеркального тома его место освобождается, а оставшееся зеркало становится простым томом, который уже не является отказоустойчивым. Все данные зеркала удаляются вместе с ним.

Примечания

  • XOX
  • XOX
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Подключение диска и восстановление зеркального тома

Чтобы подключить диск и восстановить зеркальный том

Диск, содержащий фрагмент зеркального тома, был отключен. Попытайтесь заново подключить его и реактивизировать диск.

  1. Убедитесь, что физический диск включен, подключен к сети и подсоединен к компьютеру. При необходимости включите или заново подсоедините физический диск.
  2. XOX
  3. XOX
  4. Щелкните отсутствующий или неподключенный диск правой кнопкой мыши и выберите команду Реактивизировать диск.

    5. Если диску, содержащему часть зеркального тома, не возвращается состояние Исправен, см. раздел Замена вышедшего из строя зеркала новым на другом диске.

Примечания

  • XOX
  • XOX

См. также


Реактивизация зеркального тома

Чтобы реактивизировать зеркальный том

Если ошибки ввода-вывода случайны, можно попытаться реактивизировать диск.

  1. XOX
  2. XOX
  3. Щелкните частично неисправный диск правой кнопкой мыши и выберите команду Реактивизировать диск.

    4. Состояние зеркального тома должно измениться на Регенерация, а потом — на Исправен.

    Если диску, содержащему часть зеркального тома, не возвращается состояние Исправен, см. раздел Замена вышедшего из строя зеркала новым на другом диске.

Примечания

  • XOX
  • XOX

См. также


Замена вышедшего из строя зеркала новым на другом диске

Чтобы заменить вышедшее из строя зеркало новым на другом диске

Если диск, содержащий часть зеркального тома, отсутствует и тому не возвращается состояние Исправен, вышедшее из строя зеркало необходимо заменить новым на другом диске.

  1. XOX
  2. XOX
  3. Щелкните зеркало на диске с состоянием Отсутствует или Не подключен правой кнопкой мыши и выберите команду Удалить зеркало. Следуйте указаниям на экране.
  4. Щелкните правой кнопкой мыши том, для которого требуется создать новое зеркало, и выберите команду Добавить зеркало. Следуйте указаниям на экране.

Внимание!

  • Перед установкой нового диска необходимо разбить зеркальный том и просмотреть системный журнал на предмет записей о сбоях контроллера диска. Если вышедшее из строя зеркало подключено к неисправному контроллеру, установка нового диска на этот контроллер не устранит неполадку. Если требуется открыть окно «Просмотр событий» для просмотра системного журнала, щелкните ссылку См. также.

Примечания

  • XOX
  • XOX
  • Чтобы заменить зеркало в зеркальном томе, необходим динамический диск, размер незанятого места на котором не меньше размера восстанавливаемой области. Если диск с достаточным объемом свободного места отсутствует, команда Добавить зеркало недоступна. (Чтобы определить, достаточно ли места на диске, щелкните диск правой кнопкой мыши, выберите команду Свойства и проверьте значение в поле Свободно. Оно может быть несколько меньше значения, отображаемого в режиме списка и в графическом представлении.)
  • При замене одного из дисков в зеркальном системном томе необходимо использовать диск, идентичный заменяемому. В противном случае, если диски имеют разную геометрию или разные смещения для системных томов, могут возникнуть неполадки при загрузке. Для проверки конфигурации запускайте Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server с каждого тома, чтобы убедиться, что операционная система XOX действительно может быть запущена в случае сбоя одного из дисков.

См. также


Управление томами RAID-5

  • Создание тома RAID-5
  • Подключение диска и восстановление тома RAID-5
  • Замена раздела диска в томе RAID-5
  • Реактивизация диска RAID-5


Создание тома RAID-5

Создание тома RAID-5

С помощью интерфейса Windows

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши незанятое место динамического диска, где требуется создать том RAID-5, а затем выберите команду Создать том.
  4. В мастере создания тома нажмите кнопку Далее, установите переключатель Том RAID-5 и следуйте инструкциям, появляющимся на экране.

Примечания

  • XOX
  • XOX
  • Создание томов RAID-5 возможно только на компьютерах, работающих под управлением Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server.
  • Для создания тома RAID-5 необходимы как минимум три динамических диска.
  • Отказоустойчивость, обеспечиваемая томами RAID-5, требует включения в том только одного дополнительного диска. Это означает, что том RAID-5, созданный из трех дисков емкостью по 10 Гбайт каждый, будет иметь размер 20 Гбайт. Оставшиеся 10 Гбайт используются для четности
    • .
  • Тома RAID-5 не могут быть расширены или зеркально отображены.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    diskpart

  3. В командной строке DISKPART введите:

    list disk

    Запишите номера дисков, на которых требуется создать том RAID-5.

  4. В командной строке DISKPART введите:

    create volume raid [size=n] disk=n,n,n

    Создание на выбранных дисках тома RAID-5 с размером n Мбайт.

Значение | Описание
list disk | Выводит список дисков и сведения о них: размер, свободный объем, является ли диск базовым диском, а также использует ли диск стиль раздела основная загрузочная запись (MBR) или таблица разделов с кодами GUID. Диск, помеченный звездочкой (*), имеет фокус
create volume raid | Создает том RAID-5 на указанных динамических дисках. После создания тома фокус автоматически переносится на этот том
size=n | Объем в мегабайтах (Мбайт), который том будет занимать на каждом диске. Если размер не указан, создается том RAID-5 максимального возможного размера. Размер тома RAID-5 определяется диском с наименьшим объемом непрерывного свободного места. Такой же объем выделяется на каждом диске. Фактический объем доступного дискового пространства на томе RAID-5 меньше суммы всего занятого дискового пространства, поскольку некоторая его часть требуется для четности
disk=n | Динамические диски, на которых создается том. Объем, равный значению size=n, выделяется на каждом диске

Примечания

  • XOX
  • XOX
  • Создание томов RAID-5 возможно только на компьютерах, работающих под управлением Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server.
  • Для создания тома RAID-5 необходимы как минимум три динамических диска.
  • Отказоустойчивость, обеспечиваемая томами RAID-5, требует включения в том только одного дополнительного диска. Это означает, что том RAID-5, созданный из трех дисков емкостью по 10 Гбайт каждый, будет иметь размер 20 Гбайт. Оставшиеся 10 Гбайт используются для четности
    • .
  • Тома RAID-5 не могут быть расширены или зеркально отображены.
  • Для получения дополнительных сведений о команде DiskPart щелкните ссылку См. также.

См. также


Подключение диска и восстановление тома RAID-5

Чтобы подключить диск и восстановить том RAID-5

Диск, содержащий фрагмент тома RAID-5, был отключен. Попытайтесь заново подключить его и реактивизировать диск.

  1. Убедитесь, что физический диск включен, подключен к сети и подсоединен к компьютеру. При необходимости включите или заново подсоедините физический диск.
  2. XOX
  3. XOX
  4. Щелкните отсутствующий или неподключенный диск правой кнопкой мыши и выберите команду Реактивизировать диск.

    5. Если диску, содержащему часть тома RAID-5, не возвращается состояние Исправен, см. раздел Замена раздела диска в томе RAID-5.

Внимание!

  • Просмотрите системный журнал на предмет записей о сбоях контроллера диска. Если вышедший из строя диск подключен к неисправному контроллеру, установка нового диска на этот контроллер не устранит неполадку. Если требуется открыть окно «Просмотр событий» для просмотра системного журнала, щелкните ссылку См. также.

Примечания

  • XOX
  • XOX

См. также


Замена раздела диска в томе RAID-5

Чтобы заменить область диска в томе RAID-5

Если диск, содержащий часть тома RAID-5, не может быть реактивизирован и тому не возвращается состояние Исправен, неисправный раздел диска в томе RAID-5 следует заменить.

  1. XOX
  2. XOX
  3. Щелкните правой кнопкой мыши часть тома RAID-5 на неисправном диске, выберите команду Восстановить том и следуйте инструкциям на экране.

Примечания

  • XOX
  • XOX
  • Чтобы заменить раздел диска в томе RAID-5, необходим динамический диск, размер незанятого места на котором не меньше размера восстанавливаемого раздела. Если диск с достаточным объемом свободного пространства отсутствует, команда Восстановить том недоступна. (Чтобы определить, достаточно ли места на диске, щелкните диск правой кнопкой мыши, выберите команду Свойства и проверьте значение в поле Свободно. Оно может быть несколько меньше значения, отображаемого в режиме списка и в графическом представлении.)
  • При серьезном сбое компонента тома RAID-5 (как, например, потеря питания или сбой всего жесткого диска) операционная система XOX может восстановить данные с остальных компонентов этого тома RAID-5.
  • Если повреждение RAID-5 произошло из-за сбоя питания или неполадок кабеля на отдельном устройстве, то данные отказавшего компонента тома RAID-5 восстановятся при возвращении к работе жесткого диска.
  • Состояние тома RAID-5 не будет иметь значение Исправен в окне «Управление дисками», пока данные не будут восстановлены полностью.
  • Том RAID-5 с состоянием Исправен не может быть восстановлен.


Реактивизация диска RAID-5

Чтобы реактивизировать диск RAID-5

Если ошибки ввода-вывода случайны, можно попытаться реактивизировать диск.

  1. XOX
  2. XOX
  3. Щелкните частично неисправный диск правой кнопкой мыши и выберите команду Реактивизировать диск.

    4. Состояние тома RAID-5 должно измениться на Регенерация, а потом — на Исправен.

    Если диску, содержащему часть тома RAID-5, не возвращается состояние Исправен, см. раздел Замена раздела диска в томе RAID-5.

Примечания

  • XOX
  • XOX

См. также


Основные понятия

В этом разделе собраны общие сведения управлении дисками.

  • Общие сведения об управлении дисками
  • Общее представление об управлении дисками
  • Использование оснастки «Управление дисками»
  • Ресурсы


Управление дисками: обзор

Общие сведения об оснастке «Управление дисками»

Оснастка «Управление дисками» — это служебная программа усправления жесткими дисками и содержащимися на них томами или разделами. С помощью этой программы можно инициализировать новые диски, создавать тома, форматировать тома для использования файловых систем FAT, FAT32 или NTFS, а также создавать отказоустойчивые дисковые системы. Оснастка «Управление дисками» позволяет выполнять задачи по работе с дисками без перезагрузки компьютера и прерывания сеансов пользователей; большинство изменений вступает в силу незамедлительно.

Оснастка «Управление дисками», заменившая служебную программу «Администратор дисков», которая использовалась в Windows NT 4.0, предлагает следующие возможности.

  • Упрощенные задачи и интуитивный интерфейс пользователя. Оснастка «Управление дисками» является простой в использовании. Контекстные меню, открывающиеся щелчком правой кнопки мыши, отображают задачи, которые можно выполнить над выбранным объектом. Мастера помогают поэтапно выполнять задачи по созданию разделов или томов, а также выполнять инициализацию или преобразование дисков.
  • Хранение базовых и динамических дисков. Базовые диски содержат базовые тома, такие, как основные разделы, дополнительные разделы и логические диски. Базовые диски используются на переносных компьютерах или в ситуациях, когда требуется установить несколько операционных систем на разных разделах одного диска.

    Динамические диски содержат динамические тома, с помощью которых доступны некоторые возможности, недоступные при работе с базовыми дисками, такие, как создание отказоустойчивых томов. Можно расширять динамические тома или создавать зеркальные динамические тома, а также добавлять новые динамические диски без перезагрузки компьютера.

  • Управление локальными и удаленными дисками. При помощи оснастки «Управление дисками» можно управлять удаленными компьютерами, на которых запущена операционная система Windows 2000 или XOX, на которых вы являетесь участником группы «Администраторы».
  • Подключенные диски. Программу «Управление дисками» можно использовать для подключения или присоединения локального диска к любой пустой папке локального тома NTFS. Подключенные диски облегчают доступ к данным и обеспечивают гибкое управление запоминающими устройствами в зависимости от состояния рабочей среды и загруженности системы. Ограничение числа дисков двадцатью шестью из-за количества букв латинского алфавита не распространяется на подключенные диски. Таким образом, подключенные диски можно использовать, если на компьютере необходимо иметь более 26 дисков.
  • Служба диспетчера логических дисков Служба диспетчера логических дисков использует группы дисков для управления информацией о текущем состоянии дисков на компьютере.
  • Поддержка MBR-дисков и GPT-дисков. Оснасткой «Управление дисками» поддерживаются диски с основной загрузочной записью на компьютерах с процессором типа x86 и MBR-диски и диски с таблицах разделов GUID (GPT) — на компьютерах с процессором Itanium.
  • Управление дисками с командной строки. Программа DiskPart, позволяющая выполнять задачи работы с дисками с командной строки, является альтернативой использованию оснастки «Управление дисками». С помощью DiskPart можно создавать сценарии для автоматизации ряда задач, таких, как создание томов или преобразование дисков в динамические.


Общее представление об управлении дисками

В этом разделе собраны сведения по следующим вопросам.

  • Окно управления дисками
  • Типы разделов и запоминающих устройств
  • Файловые системы операционной системы Windows
  • Базовые диски и тома
  • Динамические диски и тома
  • Удаленное управление


Окно управления дисками

В окне управления дисками отображаются диски и тома в графическом представлении и в виде списка. Пользователь имеет возможность настроить представление, изменяя тип сведений, отображающихся в верхней и нижней области окна, а также выбирая цвета и узоры, используемые для отображения томов и разделов дисков. Чтобы изменить вид объектов в окне управления дисками, откройте меню Вид и выберите необходимые параметры.


Типы разделов и запоминающих устройств

В Windows 2000 и XOX используются два типа запоминающих устройств: базовый диск и динамический диск.

Базовые диски

Базовый диск — это физический диск, содержащий основные разделы, дополнительные разделы или логические диски. С базовыми дисками можно выполнять следующие операции:

  • создавать и удалять основные и дополнительные разделы;
  • создавать и удалять логические диски в пределах дополнительного раздела;
  • форматировать раздел и пометить его в качестве активного;
  • проверять свойства диска, такие, как емкость, доступное свободное место и текущее состояние;
  • просматривать свойства тома и раздела, такие, как размер, назначенную букву диска, метку, тип и файловую систему;
  • задавать буквы для томов или разделов диска, для оптических запоминающих устройств (например, для дисковода для компакт-дисков) и для съемных дисков;
  • открывать общий доступ к диску и устанавливать параметры безопасности для томов и разделов, отформатированных с помощью NTFS;
  • преобразовывать базовые диски в динамические.

Дополнительные сведения о преобразовании базового диска в динамический см. в разделе Преобразование базового диска в динамический.

Дополнительные сведения о базовых дисках и томах см. в разделе Базовые диски и тома.

Динамические диски

Динамические диски предоставляют возможности, недоступные для базовых дисков, такие, как возможность создания томов, расположенных на нескольких дисках (составных и чередующихся), и отказоустойчивых томов (зеркальных и RAID-5). Все тома на динамических дисках называются динамическими томами. С динамическими дисками можно выполнять следующие операции:

  • создавать или удалять простые, составные, чередующиеся, зеркальные и RAID-5 тома;
  • расширять простые или составные тома;
  • удалять зеркало из зеркального тома или разделить том на два тома;
  • восстанавливать зеркальные тома или тома RAID-5;
  • реактивизировать отсутствующий или неподключенный диск;
  • проверять свойства диска, такие, как емкость, доступное свободное место и текущее состояние;
  • просматривать свойства тома и раздела, такие, как размер, назначенную букву диска, метку, тип и файловую систему;
  • задавать буквы для томов или разделов диска, для оптических запоминающих устройств (например, для дисковода для компакт-дисков) и для съемных дисков;
  • открывать общий доступ к диску и устанавливать параметры безопасности для томов и разделов, отформатированных с помощью NTFS;
  • преобразовывать базовые диски в динамические.

Дополнительные сведения о динамических дисках и томах см. в разделе Динамические диски и тома.

Типы разделов

Тип разделов представляет собой способ, используемый в XOX для упорядочения разделов на диске. На компьютерах с процессорами x86 используется тип разделов основная загрузочная запись (MBR). Основная загрузочная запись содержит таблицу разделов, в которой указано расположение разделов на диске. Поскольку основная загрузочная запись является единственным типом разделов, доступных на компьютерах с процессором x86, этот тип не нужно выбирать (он используется автоматически).

На компьютерах с процессором Itanium, на которых установлена операционная система XOX 64-Bit Edition, используется новый тип разделов таблица разделов GUID (GPT). Существует несколько отличий между типами разделов MBR и GPT, однако большинство задач, связанных с дисками, выполняется одинаково. Работа с базовыми и динамическими дисками выполняется одинаково в Windows 2000, и эти запоминающие устройства доступны на дисках вне зависимости от типа разделов. Дополнительные сведения о GPT-дисках см. в разделе Таблица разделов GUID (GPT).

На компьютерах, на которых установлена операционная система XOX 64-Bit Edition необходим GPT-диск, содержащий системный раздел EFI (Extensible Firmware Interface), а также файлы, необходимые для запуска компьютера. Можно также установить MBR-диски на компьютер с процессором Itanium, однако запустить систему с такого диска не удастся. Дополнительные сведения о системных разделах EFI (Extensible Firmware Interface) и о расширенном интерфейсе микропрограмм (EFI) см. в разделе Расширенный интерфейс микропрограмм (EFI).

Чтобы легче отличать диски, использующие типы разделов MBR и GPT, в оснастке «Управление дисками» диски, использующие основную загрузочная запись, помечаются как MBR-диски, а диски, использующие таблицу разделов GUID, помечаются как GPT-диски.

В представленной далее таблице содержаться сведения о типах разделов и запоминающих устройств в Windows 2000 и XOX.

Операционная система | Типы запоминающих устройств |  |  | Типы разделов
 | Базовые тома | Динамические простые, составные и чередующиеся тома | Динамические зеркальные тома и тома RAID-5 | MBR-диски | GPT-диски
XOX | X |  |  | X |
XOX | X | X |  | X |
Windows 2000 Server | X | X | X | X |
Windows 2000 Advanced Server | X | X | X | X |
Windows 2000 Datacenter Server | X | X | X | X |
XOX 64-Bit Edition | X | X |  | X | X


Файловые системы операционной системы Windows

Перед форматированием тома или раздела следует выбрать файловую систему, в которой он будет форматироваться. Windows 2000 и XOX поддерживают файловые системы NTFS, FAT и FAT32. Для Windows 2000 и XOX рекомендуется использовать файловую систему NTFS, поскольку она поддерживает некоторые возможности, отсутствующие в других файловых системах, такие как разрешения для файлов и папок, шифрование, поддержка больших томов и обработка разреженных файлов. Том или раздел необходимо форматировать под файловую систему FAT, если планируется получать доступ к данным тома или раздела из другой операционной системы, включая MS-DOS, Windows 95, Windows 98, Windows Millennium Edition и Windows NT 4.0.

Если необходимо наличие всех преимуществ, предоставляемых файловой системой NTFS, и предполагается работать с операционной системой Windows 2000 и XOX, то все тома и разделы можно отформатировать под файловую систему NTFS.

Следующие средства доступны только в NTFS.

  • Сжатие
  • Дисковые квоты
  • Шифрование
  • Точки подключения
  • Внешнее хранилище

Помимо этого, на всех динамических дисках и в таблицах разделов GUID (GPT) файловая система NTFS является обязательной.

Дополнительные сведения об установке нескольких операционных систем на том см. в разделе Установка нескольких операционных систем на компьютер.


Базовые диски и тома

Базовый диск — это физический диск, содержащий основные разделы, дополнительные разделы или логические диски. На базовом диске можно создать до четырех основных разделов или до трех основных и один дополнительный с неограниченным количеством логических дисков. Разделы и логические диски на базовых дисках называют базовыми томами.

Базовые тома включают разделы и логические диски в дополнительных разделах на базовом диске. Они могут создаваться только на базовых дисках.

Число разделов, которые могут быть созданы на базовом диске, зависит от стиля разделов диска.

  • На дисках с основной загрузочной записью допускается создание до четырех основных разделов или трех основных и одного дополнительного раздела. В дополнительном разделе можно создать неограниченное число логических дисков.
  • На дисках с таблицей разделов с кодами GUID допускается создание до 128 основных разделов. Поскольку на дисках, использующих таблицу разделов с кодами GUID, число основных разделов не ограничено четырьмя, допускается создание расширенных разделов и логических дисков.

Объем существующих основных разделов и логических дисков можно расширить за счет примыкающего к ним невыделенного свободного места на том же диске. Это возможно только в случае, если том отформатирован в файловой системе NTFS. Логический диск расширяется за счет смежной с ним свободной области в том же дополнительном разделе, в котором он содержится. Если для расширения логического диска недостаточно свободного места, доступного в дополнительном разделе, последний увеличится так, чтобы логический диск уместился на нем при условии, что к дополнительному разделу примыкает непрерывная невыделенная область. Инструкции по расширению базового тома см. в разделе Расширение базового тома.

На компьютерах, работающих под управлением операционной системы MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT 4.0 или XOX, имеющей конфигурацию двойной загрузки с XOX всегда используйте основные тома, а не динамические. В этих операционных системах доступ к данным в динамических томах не поддерживается.

В операционных системах Windows 2000 и XOX не поддерживаются основные тома на нескольких дисках, созданные с помощью Windows NT 4.0 или более ранней версии: наборы томов, зеркальные наборы, чередующиеся наборы, чередующиеся наборы с четностью. Перед установкой XOX или перемещением дисков на компьютер под управлением этой операционной системы необходимо создать резервные копии основных томов на нескольких дисках и затем удалить эти тома. В Windows 2000 можно восстановить эти данные на основном диске, преобразовать основной диск в динамический, а затем создать новые составные, чередующиеся, зеркальные тома или тома RAID-5 с помощью динамического хранилища.

Сведения об использовании основных томов на нескольких дисках Windows NT 4.0 см. в разделе Использование хранилищ на нескольких дисках Windows NT 4.0.

Дополнительные сведения о динамических томах см. в разделе Динамические диски и тома.


Динамические диски и тома

Динамические диски предоставляют возможности, недоступные для базовых дисков, например возможность создания томов, расположенных на нескольких дисках (составных и чередующихся), и отказоустойчивых томов (зеркальных и RAID-5). Все тома на динамических дисках называются динамическими томами.

Существует пять типов динамических томов: простые, составные, чередующиеся, зеркальные и RAID-5. Зеркальные тома и тома RAID-5 являются отказоустойчивыми и доступны только на компьютерах под управлением операционных систем Windows 2000 Server, Windows 2000 Advanced Server, Windows 2000 Datacenter Server и XOX. Однако компьютер под управлением XOX можно использовать для создания зеркальных томов и томов RAID-5 в этих операционных системах.

Независимо от используемого динамическим диском стиля разделов (основная загрузочная запись или таблица с GUID разделов) допускается создание до 2000 динамических томов в каждой группе дисков, однако не рекомендуется создавать на одном диске более 32 динамических томов.

Сведения об управлении динамическими томами см. в разделе Управление динамическими томами.

Ограничения для динамических дисков и динамических томов

При работе с динамическими томами действуют следующие ограничения.

  • При установке XOX. Если динамический том создается на незанятом месте динамического диска, на этот том невозможно будет установить XOX. Однако том можно расширить (если это простой или составной том). Ограничения при установке появляются потому, что при установке XOX распознаются только динамические тома, записи которых имеются в таблице разделов.
  • На переносных компьютерах. XOX Если при работе с переносным компьютером щелкнуть правой кнопкой мыши диск в списке или в графическом представлении окна управления дисками, возможность преобразования диска в динамический будет отсутствовать.
  • На компьютерах с двумя операционными системами. Доступ к динамическим томам и содержащимся на них данных, а также создание таких дисков невозможны на компьютерах под управлением MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT 4.0 или XOX, имеющих конфигурацию двойной загрузки с XOX или XOX. Чтобы обеспечить доступ к этим данным с компьютеров под управлением перечисленных операционных систем, данные следует хранить на базовых томах. Сведения о базовых томах см. в разделе Базовые диски и тома.
  • При расширении тома. Базовый том, преобразованный в динамический, может иметь или не иметь запись в таблице разделов в зависимости от того, был ли этот том системным или загрузочным разделом. Если преобразованный том был системным или загрузочным разделом, его запись сохраняется в таблице разделов. На этот том можно установить операционную систему XOX, но его нельзя расширить. Если преобразованный том не был системным или загрузочным разделом, его записи нет в таблице разделов. На этот том нельзя установить операционную систему XOX, но его можно расширить.

    В Windows 2000 тома, преобразованные из разделов, имеют запись в таблице разделов. В XOX записей томов, преобразованных из разделов, в таблице разделов нет, если только эти разделы не были системными или загрузочными. Чтобы определить в оснастке «Управление дисками», существует ли запись тома в таблице разделов, щелкните этот том правой кнопкой мыши. Если команда Расширить том недоступна, значит, запись этого тома имеется в таблице разделов.

    Операционная система XOX может быть установлена только на простых и зеркальных динамических томах, причем эти тома должны иметь записи в таблице разделов, то есть должны быть системными или загрузочными.


Удаленное управление

Для управления дисками, подключенными к удаленному компьютеру, необходимо быть членом группы «Администраторы» на локальном и удаленном компьютере. Кроме того, учетная запись пользователя и оба компьютера должны находиться в одном домене или в доверенном домене.

Зеркальные тома, тома RAID-5 и диски с таблицей разделов GUID недоступны во всех версиях Windows 2000. Типы томов и дисков, которые могут быть созданы, зависят от того, под управлением какой версии Windows 2000 работает удаленный компьютер (а не локальный). Например, локальный компьютер под управлением XOX можно использовать для создания зеркальных томов и томов RAID-5 на удаленном компьютере, работающем под управлением Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server.

Дополнительные сведения об управлении дисковой системой на другом компьютере см. в разделе Чтобы управлять дисками на удаленном компьютере.


Использование оснастки «Управление дисками»

В этом разделе собраны сведения по следующим вопросам.

  • Добавление диска
  • Работа с подключенными дисками NTFS
  • Поддержка съемных носителей
  • Просмотр состояния диска или тома
  • Описание состояний диска
  • Описание состояний тома
  • Использование базовых дисков
  • Использование динамических дисков


Добавление диска

При подключении нового диска к компьютеру необходимо его инициализировать до создания томов или разделов. Основное хранилище используют, если требуется создать на диске разделы и логические диски или использовать диск с другими операционными системами. Впоследствии можно преобразовать базовое хранилище в динамическое хранилище, если необходимо создать составной, чередующийся, зеркальный том или том RAID-5. Динамическое хранилище использует динамические диски, доступ к которым невозможен на компьютерах под управлением MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT 4.0 или XOX, имеющих конфигурацию двойной загрузки с XOX или XOX.

Установка инициализированного диска рассматривается в разделе Управление новыми дисками.

Изменение типа хранилища, для которого инициализирован диск, описано в разделах Чтобы преобразовать базовый диск в динамический и Чтобы преобразовать динамический диск обратно в базовый.


Работа с подключенными дисками NTFS

С помощью программы управления дисками можно подключить локальный диск к пустой папке на локальном томе NTFS. Допускается форматирование подключенного диска с помощью любой файловой системы, поддерживаемой XOX.

При подключении локального диска к пустой папке на томе NTFS консоль управления дисками назначает путь к диску вместо имени диска. Ограничение числа дисков двадцатью шестью из-за количества букв латинского алфавита не распространяется на подключенные диски. Таким образом, если на компьютере необходимо иметь больше 26 дисков, можно использовать подключенные диски. В Windows пути дисков сохраняют связь с диском, поэтому можно добавлять или изменять конфигурации запоминающих устройств без сбоев путей дисков.

Например, если имеется дисковод компакт-дисков с именем D и том NTFS с именем C, можно присоединить компакт-дисковод к пустой папке с путем C:\CD-ROM. После этого дисковод компакт-дисков будет доступен с помощью пути C:\CD-ROM. При желании имя диска D можно удалить и в дальнейшем использовать для работы с дисководом путь к подключенному диску.

Подключенные диски облегчают доступ к данным и обеспечивают гибкое управление запоминающими устройствами в зависимости от состояния рабочей среды и загруженности системы. Можно, например, выполнить следующие действия.

  • Создать папку C:\Users на подключенном диске с дисковыми квотами NTFS, чтобы отслеживать или ограничивать использование диска, но не диска C.
  • Подключить диск к папке C:\Temp, чтобы предоставить больше места на диске для временных файлов.
  • При нехватке места на диске C переместить папку My Documents на диск большего размера и присоединить ее как C:\My Documents.

При использовании подключенных дисков NTFS с кластерами серверов всегда следуйте приведенным ниже инструкциям.

  • Необходимо проверять уникальность создаваемых подключенных дисков, чтобы они не конфликтовали с существующими локальными дисками на любых узлах в кластере.
  • Не создавайте подключенные диски между дисками в устройстве хранилища кластера (дисками кластера) и локальными дисками.
  • Не создавайте подключенные диски из дисков кластера, содержащих ресурс кворума (диск кворума). Однако можно создать подключенный диск с диска кластера на диск кворума.
  • Подключенные диски с одного диска кластера на другой должны находиться в одной группе ресурсов кластера и зависеть от корневого диска.


Поддержка съемных носителей

В режиме Графическое представление съемные носители имеют метку Съемное устройство.

В большинстве случаев съемные носители, такие как съемные диски и оптические диски (например DVD-ОЗУ), уже имеют основной раздел, размер которого совпадает с размером носителя. Если на съемном носителе нет основного раздела, можно его создать. Однако невозможно сделать этот раздел активным или удалить его. Создание дополнительных разделов, логических дисков и динамических томов на съемных носителях не допускается.

Помимо этого, на компьютерах с процессором Itanium невозможно использовать тип разделов таблица разделов GUID (GPT) на съемных носителях.

Инструкции по отображению дисков и томов в режиме Графическое представление см. в разделе Чтобы отобразить диски и тома в виде списка или в графическом представлении.


Просмотр состояния диска или тома

При отказе диска или тома важно восстановить их как можно быстрее, чтобы избежать потери данных. На следующем рисунке показаны столбцы состояния дисков и томов в окне «Управление дисками».

Рисунок, показывающий состояние дисков и томов

В столбце Состояние в списке отображается состояние диска или тома. В графическом представлении каждого диска или тома тоже отображается его состояние. Для получения сведений о типах состояния томов см. раздел Описание состояний тома. Для получения сведений о типах состояния дисков см. раздел Описание состояний диска. Если состояние томов отлично от Исправен, а для дисков — от Подключен, см. раздел Устранение неполадок.


Описание состояний диска

Одно из состояний, описанных ниже, всегда отображается в графическом представлении диска и в столбце Состояние диска в списке.

Компакт-диск

Состояние Компакт-диск возникает, когда звуковой компакт-диск находится в дисководе компакт-дисков или дисководе DVD.

Инородный

Состояние Инородный возникает при перемещении динамического диска на локальный компьютер с компьютера, на котором установлена Windows 2000 или XOX. Состояние «Инородный» может также возникать на компьютерах, выполняющих XOX и имеющих конфигурацию двойной загрузки с другой операционной системой, которая использует динамические диски (такой как Windows 2000 Professional). Динамические диски не поддерживаются в XOX или на переносных компьютерах. На диске с состоянием Инородный отображается значок предупреждения.

Чтобы получить доступ к данным на диске, необходимо добавить его в конфигурацию компьютера. Чтобы добавить диск в конфигурацию системы компьютера, импортируйте чужой диск, щелкнув правой кнопкой мыши диск и выбрав команду Импорт чужих дисков. Все тома, существующие на чужом диске, станут видимы и доступны после его импорта. Инструкции по перемещению и импорту дисков см. в разделе Чтобы переместить диск на другой компьютер.

В XOX доступ к данным на диске получить нельзя, но можно преобразовать этот диск в базовый диск, чтобы использовать его. Преобразование динамического диска в базовый диск приведет к уничтожению всех данных на диске.

Внимание!

  • Преобразование динамического диска в базовый диск следует выполнять только в том случае, когда данные на этом диске больше не нужны.
  • Чтобы преобразовать диск в пустой базовый диск, см. раздел Чтобы преобразовать динамический диск обратно в базовый.

В некоторых случаях для диска, который был подключен к системе, может отображаться состояние Инородный. Данные конфигурации динамических дисков хранятся на всех динамических дисках, поэтому сведения о дисках, принадлежащих системе, теряются при сбое всех динамических дисков.

Инструкции по исправлению дисков, имеющих состояние Инородный, см. в разделе Устранение неполадок.

Инициализация

Состояние Инициализация является временным и возникает при преобразовании базового диска в динамический диск. После завершения инициализации состояние диска меняется на Исправен.

Отсутствует

Состояние Отсутствует возникает, если динамический диск поврежден, отсоединен или от него отключено питание. Состояние Отсутствует отображается не в столбце состояний, а в качестве имени диска. После подсоединения отсутствующего диска или после подключения питания откройте оснастку «Управление дисками», щелкните правой кнопкой мыши отсутствующий диск и выберите команду Реактивизировать диск.

Инструкции по исправлению дисков, имеющих состояние Отсутствует, см. в разделе Устранение неполадок.

Нет носителя

Состояние Нет носителя возникает, когда дисковод компакт-дисков, дисков DVD или съемных дисков является пустым. Если вставить соответствующий носитель в дисковод, состояние меняется на Подключен или Компакт-диск. Состояние Нет носителя отображается только для дисководов компакт-дисков, DVD и съемных дисков.

Не проинициализирован

Состояние Не проинициализирован возникает, когда диск не содержит действительной подписи. После установки нового диска операционная система XOX должна создать основную загрузочную запись (MBR) или таблицу разделов GUID (GPT), прежде чем станет возможным создание разделов на этом диске. При первом запуске консоли «Управление компьютером» после установки нового диска открывается окно мастера со списком новых дисков, обнаруженных XOX. Если отменить выполнение мастера до записи подписи диска, диск будет иметь состояние Не проинициализирован до тех пор, пока пользователь не щелкнет его правой кнопкой и выберет команду Инициализировать диск. На короткое время будет отображаться состояние Инициализация, а затем диск получит состояние Исправен.

Инструкции по исправлению дисков, имеющих состояние Не проинициализирован, см. в разделе Устранение неполадок.

Подключен

Состояние Подключен возникает, когда базовый или динамический диск подключен и не вызывает известных проблем. Это нормальное состояние диска. Не требуется никаких действий пользователя.

Работает (ошибки)

Состояние Работает (ошибки) возникает при обнаружении ошибки ввода/вывода в разделе динамического диска. Значок предупреждения отображается на динамическом диске с ошибками.

Если ошибки ввода/вывода являются временными, следует реактивизировать диск. После этого диску возвращается состояние Подключен.

Инструкции по исправлению дисков, имеющих состояние Работает (ошибки), см. в разделе Устранение неполадок.

Не подключен

Состояние Не подключен возникает, когда динамический диск является недоступным. Динамический диск может быть поврежден или периодически недоступен. Значок ошибки появляется на отключенном динамическом диске диске.

Если состояние диска Не подключен и имя диска изменяется на Отсутствует, это значит, что диск был только что доступен для системы, но в данный момент не может быть найден и определен. Отсутствующий диск может быть поврежден, выключен или отсоединен.

Чтобы подключить отключенный или отсутствующий диск

Устраните все неполадки диска, контроллера или подключения и убедитесь, что физический диск включен, подключен к сети и подсоединен к компьютеру. В окне оснастки «Управление дисками» щелкните правой кнопкой мыши диск и выберите команду Реактивизировать диск, чтобы подключить диск заново.

Если состояние диска остается Не подключен, имя диска Отсутствует и ошибка диска не может быть устранена, можно изъять диск из системы с помощью команды Изъять диск. Однако, прежде чем диск можно будет изъять, необходимо удалить все тома (или зеркала) на диске. Зеркальные тома можно сохранить на диске, удалив зеркало вместо всего тома. Удаление тома приведет к потере всех находящихся на нем данных, поэтому изымать его следует только в случае абсолютной уверенности в том, что диск поврежден без возможности восстановления и не пригоден для дальнейшего использования.

Чтобы подключить отключенный диск, все еще имеющий имя (не отсутствующий)

В окне оснастки «Управление дисками» щелкните правой кнопкой мыши диск и выберите команду Реактивизировать диск, чтобы подключить диск заново. Если состояние диска продолжает оставаться Не подключен, проверьте кабели и контроллер диска, а также убедитесь в исправности физического диска. Устраните неисправности и попробуйте снова реактивизировать диск. Если реактивизация прошла успешно, состояние всех томов диска должно автоматически вернуться к значению Исправен.

Инструкции по исправлению дисков, имеющих состояние Не подключен, см. в разделе Устранение неполадок.

Не читается

Состояние Не читается возникает, когда базовый или динамический диск является недоступным. Диск может быть поврежден, возможны сбои оборудования или ошибки ввода/вывода. Может быть повреждена копия базы данных конфигурации дисков системы. На диске с состоянием Не читается отображается значок ошибки.

Состояние Не читается может отображаться для дисков, когда набирается рабочая скорость вращения или во время повторного сканирования всех дисков системы программой управления дисками. В некоторых случаях невозможность прочитать диск означает, что он неисправен и не может быть восстановлен. Состояние Не читается для динамических дисков обычно является следствием повреждения или ошибок ввода/вывода скорее части диска, чем сбоя целиком всего диска. Можно повторить сканирование диска (в меню Действие выберите команду Повторить сканирование дисков) или перезагрузить компьютер, чтобы посмотреть, изменится состояние диска или нет.

Инструкции по исправлению дисков, имеющих состояние Не читается, см. в разделе Устранение неполадок.


Описание состояний тома

В консоли управления дисками одно из состояний тома, описанных ниже, всегда отображается в графическом представлении тома и в столбце Состояние тома в списке.

Отказ

Состояние Неисправен возникает, когда не удается запустить автоматически базовый или динамический том, поврежден диск или повреждена файловая система. Это состояние также возникает после импорта тома с состоянием Неполные данные. Значок ошибки появляется на отказавшем томе. Если диск или файловую систему восстановить невозможно, состояние Неисправен указывает на потерю данных.

Если том является базовым, убедитесь, что физический диск включен, подключен к сети и подсоединен к компьютеру. Другие действия пользователя с базовыми томами невозможны.

Если том является динамическим, убедитесь, что динамические диски подключены. Если диски не подключены, следует их реактивизировать. Если диск успешно реактивизирован, том автоматически перезапускается и возвращается в состояние Исправен. Для получение сведений о подключении диска см. раздел Чтобы реактивизировать отсутствующий или неподключенный диск.

Если динамический диск возвращается в состояние Подключен, а том не возвращен в состояние Исправен, его можно реактивизировать вручную. Инструкции по реактивизации тома см. в разделе Чтобы реактивизировать динамический том.

Зеркальные тома и тома RAID-5 с устаревшими данными не будут автоматически реактивизированы после подключения базового диска. Если диски, содержащие текущие данные, отключены, эти диски должны быть подключены первыми, чтобы данные были синхронизированы. В противном случае следует реактивизировать том RAID-5 вручную, а затем запустить Chkdsk.exe.

Инструкции по реактивизации тома см. в разделе Чтобы реактивизировать динамический том. Чтобы запустить Chkdsk.exe, нажмите кнопку Пуск, выберите команду Выполнить, введите chkdsk и нажмите кнопку OK.

Инструкции по исправлению томов, имеющих состояние Неисправен, см. в разделе Устранение неполадок.

Отказавшая избыточность

Состояние Отказавшая избыточность возникает, когда данные зеркального тома или тома RAID-5 уже не являющимся отказоустойчивым, поскольку один из базовых дисков не подключен. Значок предупреждения отображается на томе с отказавшей избыточностью.

Для томов с состоянием Отказавшая избыточность обычно в скобках отображаются дополнительные сведения о состоянии. Каждый раз отображаются только одни дополнительные сведения. Дополнительные сведения отображаются в порядке перечисления в следующей таблице. Например, если имеется только один том, который одновременно является загрузочным, системным, активным, содержит файл подкачки и аварийный дамп памяти, его состояние отображается как Отказавшая избыточность (Система). Однако при возникновении ошибки в зеркальном томе или томе RAID-5 приоритетными являются дополнительные сведения (Под угрозой).

Отказавшая избыточность (дополнительные сведения) | Описание
Система | Указывает, что том является системным томом.
Загрузка | Указывает, что том является загрузочным томом.
Файл подкачки | Указывает, что том содержит файл подкачки. Дополнительные сведения о файле подкачки см. в разделе Общие сведения о свойствах системы.
Аварийная копия памяти | Указывает, что том содержит аварийную копию памяти, которую также называют дампом памяти. В аварийную копию памяти записывается память компьютера при аварийной остановке XOX. Дополнительные сведения о различных типах аварийных копий памяти см. в разделе Указание действий при неожиданной остановке системы.
Под угрозой | Указывает, что данные на зеркальном томе или томе RAID-5 уже не являются отказоустойчивыми, поскольку произошел сбой одного диска и обнаружены ошибки ввода/вывода на оставшемся динамическом диска. При обнаружении ошибки ввода/вывода в любой части диска, значок предупреждения отображается на всех томах на диске. Состояние Исправен (под угрозой) отображается для динамических томов, не являющихся отказоустойчивыми. Когда состояние тома — Отказавшая избыточность (под угрозой), состояние базового диска обычно — Работает (ошибки). Необходимо заново активизировать диск, чтобы вернуть его к состоянию Подключен, после чего том должен вернуться к состоянию Отказавшая избыточность.

Допускается доступ к тому с помощью оставшихся подключенных дисков, но при сбое другого диска, содержащего данный том, том и всего его данные будут утеряны. Чтобы избежать потери данных, следует попытаться восстановить том как можно быстрее.

  • Если базовый диск не подключен, реактивизируйте диск, щелкнув правой кнопкой мыши диск и выбрав команду Реактивизировать диск. Если реактивизация прошла успешно, том автоматически восстанавливается и ему возвращается состояние Исправен. Зеркальный том восстанавливается путем ресинхронизации данных в зеркалах. Том RAID-5 восстанавливается с помощью регенерации четности и данных.
  • Если диск возвращается в состояние Подключен, а том в состояние Исправен не возвращается, его можно реактивизировать вручную, щелкнув правой кнопкой мыши том и выбрав команду Реактивизировать том.
  • Если диск не возвращается в состояние Подключен, а том — в состояние Исправен, возможно диск неисправен. Зеркало или раздел диска RAID-5 с ошибкой необходимо заменить. Чтобы заменить зеркало зеркального тома с ошибкой, щелкнув правой кнопкой мыши вышедшее из строя зеркало и выберите команду Удалить зеркало, затем щелкните правое кнопкой мыши диск и выберите команду Добавить зеркало, чтобы создать новое зеркало на другом диске. Замените неисправный раздел диска в RAID-5 томе, щелкнув правой кнопкой мыши том RAID-5 и выбрав команду Восстановить том.

Инструкции по исправлению зеркал или томов RAID-5, имеющих состояние Отказавшая избыточность, см. в разделе Устранение неполадок.

Форматирование

Состояние Форматирование является временным состоянием, которое возникает, когда том форматируется под файловую систему. Во время форматирования отображается отформатированный объем в процентах. После завершения форматирования состояние тома изменяется на Исправен.

Исправен

Состояние Исправен является нормальным состоянием базовых и динамических томов, когда том доступен и ошибок не обнаружено. Не требуется никаких действий пользователя.

Для томов с состоянием Исправен обычно в скобках отображается дополнительная информация о состоянии. Каждый раз отображаются только одни дополнительные сведения. Дополнительные сведения отображаются в порядке перечисления в следующей таблице. Например, если имеется только один том, который одновременно является загрузочным, системным, активным, содержит файл подкачки и аварийный дамп памяти, его состояние отображается как Исправен (Система). Однако при возникновении ошибки в динамическом томе приоритетной является дополнительная информация (Под угрозой).

Исправен (дополнительные сведения) | Описание
Система | Указывает, что том является системным томом.
Загрузка | Указывает, что том является загрузочным томом.
Файл подкачки | Указывает, что том содержит файл подкачки. Дополнительные сведения о файле подкачки см. в разделе Общие сведения о свойствах системы.
Активен | Указывает, что том является активным томом на базовом диске. Дополнительные сведения об активных томах см. в разделе Выбор активного раздела.
Аварийная копия памяти | Указывает, что том содержит аварийную копию памяти, которую также называют дампом памяти. В аварийную копию памяти записывается память компьютера при аварийной остановке Windows XP или XOX. Дополнительные сведения о различных типах аварийных копий памяти см. в разделе Указание действий при неожиданной остановке системы.
Раздел спящего режима | Указывает, что раздел является разделом спящего режима, размеченным изготовителем вычислительной техники (OEM). Такие разделы на некоторых переносных компьютерах предназначены для сохранения текущего состояния системы во время спящего режима. Дополнительные сведения о спящем режиме см. в разделе Управление питанием переносного компьютера.
Раздел, защищенный GPT | Указывает на компьютерах x86, что том является диском с таблицей с GUID разделов (GPT). Раздел, защищенный GPT, содержит защитную основную загрузочную запись (MBR), не позволяющую утилитам работы с дисками на компьютере x86 случайно уничтожить разделы GPT.
Шифрованный (EFI) системный раздел | Указывает, что том является системным разделом EFI (Extensible Firmware Interface) на диске GPT.
Конфигурация EISA | Указывает, что том является разделом изготовителя вычислительной техники (OEM).
Неизвестный раздел Указывает, что раздел не распознается.

Разделы на дисках с основной загрузочной записью (MBR) или таблицей GUID разделов (GPT), имеющие состояние Исправен (Неизвестный раздел), могут быть нераспознаваемыми разделами изготовителя вычислительной техники или разделами операционной системы, отличной от XOX. Невозможно выполнять форматирование, назначать буквы диска или определять точки подключения для разделов с состоянием Исправен (Неизвестный раздел). Однако пользователь может удалить такие разделы с помощью консоли «Управление дисками» или команды DiskPart. Инструкции по удалению разделов см. в разделе Удаление раздела или логического диска.
Под угрозой Указывает, что динамический том в настоящее время доступен, но обнаружены ошибки ввода/вывода на содержащем его динамическом диске. При обнаружении ошибки ввода/вывода в любой части диска, все тома диска будут иметь состояние Исправен (под угрозой). На томе появится значок предупреждения.

Когда том имеет состояние Исправен (Под угрозой), диск, на котором находится том, обычно имеет состояние Подключен (Ошибки). Необходимо заново активизировать диск, содержащий том, чтобы вернуть его к состоянию Подключен, после чего том должен вернуться к состоянию Исправен. Если сохраняется состояние Исправен (Под угрозой), то диск, вероятно, начинает отказывать. Создайте архивную копию данных и немедленно замените диск.

Инструкции по исправлению томов, имеющих состояние Исправен (Под угрозой), см. в разделе Устранение неполадок.

Регенерация

Состояние регенерация возникает при добавлении зеркала, импорте зеркального тома, реактивизации отсутствующего тома, а также если данные и четность регенерируются для тома RAID-5. Не требуется никаких действий пользователя. После завершения восстановления тому RAID-5 возвращается состояние Исправен. В процессе восстановления данных и четности доступ к тому RAID-5 разрешен.

Ресинхронизация

Состояние Ресинхронизация возникает при создании зеркала или перезагрузке компьютера с зеркальным томом или томом или при ресинхронизации зеркальных томов, чтобы оба зеркала содержали идентичные данные. Не требуется никаких действий пользователя. После завершения ресинхронизации зеркальному тому возвращается состояние Исправен. Ресинхронизация может занять некоторое время, в зависимости от размера зеркального тома. Хотя в процессе ресинхронизации зеркальный том доступен, не следует вносить изменения в конфигурацию (например разделять зеркальный набор) в процессе ресинхронизации.

Для томов с состоянием Ресинхронизация обычно в скобках отображается дополнительная информация о состоянии. В представленной далее таблице содержаться возможные дополнительные сведения, отображающиеся для томов со статусом Ресинхронизация.

Ресинхронизация (дополнительные сведения) | Описание
Система | Указывает, что том является системным томом.
Загрузка | Указывает, что том является загрузочным томом.
Файл подкачки | Указывает, что том содержит файл подкачки. Дополнительные сведения о файле подкачки см. в разделе Общие сведения о свойствах системы.
Аварийная копия памяти | Указывает, что том содержит аварийную копию памяти, которую также называют дампом памяти. В аварийную копию памяти записывается память компьютера при аварийной остановке XOX. Дополнительные сведения о различных типах аварийных копий памяти см. в разделе Указание действий при неожиданной остановке системы.

Нет данных

Состояние Нет данных обычно возникает, когда поврежден загрузочный сектор тома (обычно из-за вируса) и невозможно получить доступ к данным тома. Состояние Нет данных возникает также, когда установлен новый диск, но не выполнялся мастер создания подписи диска.

Инструкции по исправлению томов, имеющих состояние Нет данных, см. в разделе Устранение неполадок.

При импорте дисков для всех томов на этих дисках отображается состояние ОК в диалоговом окне Тома добавляемых дисков, если они не содержат ошибок. При импорте зеркальных томов или томов RAID-5 могут возникать следующие состояния: Неполные данные, Нет избыточности данных или Устаревшие данные.

Неполные данные

Состояние Неполные данные отображается в диалоговом окне Тома добавляемых дисков и возникает, если данные занимают несколько дисков, но не все диски были перемещены. Данные этого тома будут уничтожены, если оставшиеся диски, содержащие данный том, не будут перемещены, а затем одновременно импортированы. Отсутствующие диски не могут быть импортированы позже для восстановления данных.

Инструкции по исправлению томов, имеющих состояние Неполные данные, см. в разделе Устранение неполадок.

Нет избыточности данных

Состояние Нет избыточности данных отображается в диалоговом окне Тома добавляемых дисков при импорте всех дисков, кроме одного, в зеркальном томе или томе RAID-5. В оснастке «Управление дисками» импортированная часть зеркального диска обладает состоянием Отказавшая избыточность, пока диск, содержащий половину зеркала, которая не была импортирована, имеет состояние Отсутствует. Тома RAID-5 получают состояние Отказавшая избыточность.

Чтобы избежать состояния Нет избыточности данных, подключите одновременно к компьютеру все диски, относящиеся к зеркальному тому или тому RAID-5, а затем импортируйте все диски вместе. Для зеркальных томов позже можно импортировать диски с состоянием Отсутствует для восстановления избыточности.

Инструкции по исправлению томов, имеющих состояние Нет избыточности данных, см. в разделе Устранение неполадок.

Устаревшие данные

Состояние Устаревшие данные отображается в диалоговом окне Тома добавляемых дисков и возникает, когда для зеркального тома или тома RAID-5 указаны устаревшие сведения о зеркале или четности или возникают ошибки ввода/вывода.

Инструкции по исправлению зеркал или томов RAID-5, имеющих состояние Устаревшие данные, см. в разделе Устранение неполадок.


Использование базовых дисков

В этом разделе собраны сведения по следующим вопросам.

  • Работа с разделами
  • Преобразование базового диска в динамический
  • Использование хранилищ на нескольких дисках Windows NT 4.0


Работа с разделами

Разделы на базовом диске используются так же, как и при работе с Windows, но изменения диска вступают в силу немедленно, без перезагрузки компьютера.

На физическом диске может быть создано до четырех основных разделов (или до трех, если имеется дополнительный раздел диска). Свободное пространство дополнительного раздела может использоваться для создания неограниченного числа логических дисков. Его нельзя использовать для создания наборов томов или других отказоустойчивых томов.

Для получения сведений о добавлении нового раздела или логического диска см. раздел Создание раздела или логического диска. Изменения, внесенные с помощью оснастки «Управление дисками», вступают в действие немедленно. За исключением тех из них, которые затрагивают существующие файлы на диске, система применяет изменения без подтверждения со стороны пользователя.

Для получения сведений о следующих процедурах см. раздел Управление базовыми томами.

  • Форматирование базового тома
  • Назначение, смена и удаление буквы диска
  • Выбор активного раздела
  • Удаление раздела или логического диска


Преобразование базового диска в динамический

В XOX при использовании управления установкой и управления дисками можно быть уверенным, что диски, инициализированные XOX, могут быть преобразованы в динамические диски. Динамические диски предоставляют возможности, недоступные при использовании базовых дисков, такие как создание томов на нескольких дисках, чередующиеся, зеркальные тома и тома RAID-5. Перед преобразованием дисков закройте все программы, выполняемые на этих дисках.

После преобразования базового диска в динамический все существующие разделы базового диска преобразуются в простые (динамические) тома. Динамические тома невозможно преобразовать обратно в разделы.

Прямой доступ к динамическим дискам невозможен в MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT или XOX, таким образом, невозможно запускать эти операционные системы на динамических дисках. Однако общие папки на динамических дисках могут быть доступны по сети с компьютеров, на которых установлены эти операционные системы.

Доступ к динамическим дискам также ограничен типом разделов, используемым на динамическом диске.

  • Доступ к динамическим MBR-дискам может осуществляться только с компьютеров с процессором x86, на которых запущена операционная система Windows 2000 или XOX, или с компьютеров с процессором Itanium, на которых запущена операционная система XOX 64-bit Edition.
  • Доступ к GPT-дискам с таблицей разделов GUID может осуществляться только с компьютеров с процессором Itanium, на которых запущена операционная система XOX 64-Bit Edition.

Чтобы успешно преобразовать базовый диск в динамический, необходимо придерживаться следующих правил.

  • Диск с основной загрузочной записью (MBR) должны содержать по крайней мере 1 мегабайт (Мбайт) свободного места в конце диска для размещения базы данных динамического диска. Средствами «Управление дисками» и «Установка» это пространство автоматически резервируется при создании разделов или логических дисков на диске, но на дисках с разделами или томах, созданных в других операционных системах, этого места может не быть. Для GPT-дисков с таблицей разделов GUID не требуется 1 мегабайт (Мбайт) свободного места в конце диска. Вместо этого оснасткой «Управление дисками» для создания отдельного раздела для базы данных динамического диска используется свободное место раздела MSR.
  • GPT-диски с таблицей разделов GUID должны содержать непрерывные, распознанные разделы с данными с файловой системой XOX. Если нераспознанный раздел (например созданный другой операционной системой или служебной программой, использующей тип разделов GUID, не поддерживаемый XOX 64-Bit Edition) находится между двумя распознанными разделами, GPT-диск преобразовать в динамический диск не удастся.
  • Диск не должен быть съемным носителем. Устройства съемных носителей не могут быть преобразованы в динамические тома. Эти устройства могут содержать только основные разделы.
  • Диски не должны быть на переносном компьютере. XOX и XOX не поддерживают динамические диски на переносных компьютерах.
  • Размер сектора должен составлять 512 байт. В противном случае не удастся преобразовать базовый диск в динамический. Для определения размера сектора диска можно использовать команду chkdsk.

Другие вопросы по преобразованию

При преобразовании базового диска в динамический возможны следующие последствия.

  • Переустановка XOX. Можно выполнить новую установку XOX на динамическом томе, только если том был преобразован из базового тома и запись тома сохранилась в таблице разделов. Простые тома, преобразованные из базовых дисков в XOX, не имеют записи в таблице разделов, если только эти тома не были системными или загрузочными до преобразования. Эти сведения необходимы для новой установки операционной системы XOX на динамических томах.
  • Загрузочные и системные разделы. Базовый диск, содержащий системные или активные разделы, может быть обновлен до динамического. После завершения преобразования диска разделы становятся простыми системными и загрузочными томами (после перезагрузки компьютера). Существующие динамические тома не могут быть помечены как активные. Базовый диск, содержащий загрузочный раздел (операционную систему XOX), может быть преобразовать в динамический. После завершения преобразования диска загрузочный раздел становится простым загрузочным томом (после перезагрузки компьютера).
  • Сбои преобразования. Для успешного завершения преобразования загрузочного диска или тома (раздела), используемого на преобразуемом диске, необходимо перезапустить компьютер. При условиях, описанных ниже, после перезагрузки компьютера возможен сбой преобразования.
    • Все существующие динамические диски отсоединены во время перезапуска компьютера.
    • Преобразуемый диск или набор дисков заменен во время перезапуска компьютера. (Управление дисками определяет замену диска и возможен сбой преобразования.)
    • Изменено расположение преобразуемого диска.
    • В процессе преобразования произошли ошибки ввода/вывода.
  • Зеркальное отображение загрузочных и системных томов. После завершения преобразования в динамический том диска, содержащего загрузочные и системные разделы, допускается зеркальное отображение загрузочных и системных томов на другой динамический диск. Затем, при повреждении дисков, содержащих загрузочные и системные тома, имеется возможность запуска компьютера с дисков, содержащих зеркальные отображения этих томов.
  • Выполнение преобразования. Системные и загрузочные разделы преобразуются в динамические тома после перезагрузки компьютера. Все другие разделы и базовые тома преобразуются немедленно. Однако если преобразуемый раздел или базовый том на диске в настоящее время используется, то будет произведено принудительное отключение, означающее, что любые программы, использующие данный том, будут автоматически отключены. Если том не может быть автоматически отключен (например из-за активного файла подкачки), то преобразование диска не будет завершено до перезагрузки компьютера.
  • Другие операционные системы. При преобразовании диска с разделом, содержащим операционную систему, отличную от Windows 2000 или XOX, запустить компьютер из данной операционной системы после преобразования будет невозможно.
  • Обратное преобразование в базовые диски. После преобразования базового диска в динамический динамические тома не могут быть обратно преобразованы в разделы. Вместо этого необходимо удалить все динамические тома на диске и выполнить команду Преобразовать в базовый диск.

Для получения сведений о процедуре преобразования базовых дисков в динамические см. раздел Чтобы обновить базовый диск до динамического.


Использование хранилищ на нескольких дисках Windows NT 4.0

Windows 2000 и XOX не поддерживают зеркальные наборы, чередующиеся наборы, чередующиеся наборы с четностью и наборы томов, созданные в Windows NT 4.0. Необходимо создать резервные копии этих томов на нескольких дисках и затем удалить эти тома или преобразовать их в динамические диски до установки XOX. Если резервные копии этих томов не были созданы перед обновлением до XOX, доступ к этим томам можно получить при помощи служебной программы ftonline. Служебная программа ftonline может быть установлена как компонент средств поддержки, расположенных в папке \support\tools на компакт-диске Windows XP.

В XOX можно использовать динамические диски для создания аналогичных типов хранилищ на нескольких дисках, расположенных на базовых дисках в Windows NT 4.0.

Тип хранилища Windows NT 4.0 | Тип хранилища XOX
зеркальный набор | зеркальный том
чередующийся набор | чередующийся том
чередующийся набор с четностью | том RAID-5
набор томов | составной том

Зеркальные тома и тома RAID-5 недоступны в XOX и XOX и не могут быть расширены.


Использование динамических дисков

  • Использование простых томов
  • Использование составных томов
  • Использование чередующихся томов
  • Использование зеркальных томов
  • Использование томов RAID-5


Использование простых томов

Простой том — это часть физического диска, которая ведет себя как независимое устройство. Простые тома являются динамическими хранилищами, которые эквивалентны основным разделам в операционной системе Windows NT 4.0 и более ранних версиях. При наличии только одного динамического диска они являются единственным типом тома, который можно создать.

Создание и расширение простых томов

Новые простые тома могут создаваться только на динамических дисках. Простые тома не могут содержать разделы или логические диски, а доступ к ним невозможно получить в операционных системах MS-DOS или Windows, отличных от Windows 2000 или XOX. Следует создавать разделы вместо динамических томов, если на компьютере также установлена операционная система Windows NT 4.0 или более ранней версии, Windows 95, Windows 98, Windows Millennium Edition или MS-DOS.

Можно увеличить размер существующего простого тома, расширив том в невыделенную область на том же или на другом диске. Для расширения простого тома необходимо, чтобы этот том был неотформатирован или отформатирован при помощи версии NTFS, используемой Windows 2000 или XOX. В XOX простые тома могут быть расширены, если они не являются системными разделами, загрузочными разделами или простыми томами, которые раньше были разделами на базовых дисках, преобразованных в динамические с помощью Windows 2000. При расширении простого тома на том же диске том остается простым томом, и можно создать его зеркальную копию.

Простой том также можно расширить на величину разделов других динамических дисков этого компьютера. При расширении простого тома на один или несколько других дисков он становится составным томом. После расширения составного тома нельзя удалить его часть, не удалив весь том. Составные тома не могут быть зеркально отображены или включены в чередующийся том.

Для получения сведений о процедуре создания и расширения простых томов см. раздел Управление простыми томами.

Назначение буквы диска

Операционная система Windows позволяет создать более 26 томов, однако не дает возможности назначить имена более чем 26 томам одновременно. Буквы «A» и «B» зарезервированы для дисководов гибких дисков, но можно назначать эти буквы съемным дискам, если компьютер не имеет соответствующего дисковода гибких дисков. Жесткие диски компьютера получают буквы от «C» до «Z», тогда как сопоставленным сетевым дискам буквы назначаются в обратном порядке (от «Z» до «B»).

Операционная система Windows использует механизм статического назначения имен. Это означает, каждое имя всегда обозначает один и тот же жесткий диск и том. Добавление в систему нового жесткого диска никак не влияет на статически присвоенные имена существующих дисков.

Назначение дискам имен требует особой осторожности, поскольку многие программы как для MS-DOS, так и для Windows часто ссылаются на конкретные имена дисков. В переменной среды path имена дисков присутствуют в явном виде.

Тома, буквы которых имеют порядковый номер больше 26, могут быть доступны только с использованием точек подключения тома, как описано в разделе Работа с присоединенными дисками NTFS.

Форматирование и создание меток томов

До начала использования созданных томов для хранения файлов и каталогов необходимо отформатировать каждый том в необходимую файловую систему. В это же время целесообразно присвоить разделам поясняющие их назначение метки.

Если том отформатирован в файловую систему NTFS, то можно включить сжатие данных. Если у тома нет ни назначенной буквы, ни точки подключения, то до начала его форматирования необходимо назначить ему букву или указать точку подключения.

Чтобы отформатировать том, см. раздел Чтобы отформатировать динамический том.

Удаление томов

Прежде чем удалить тома, следует убедиться, что все нужные данные сохранены на другом носителе и проверены. В XOX невозможно удалить системный том или загрузочный том.


Использование составных томов

Составные тома — это объединение незанятого места нескольких дисков в один логический том, что позволяет эффективно использовать все свободное место и все буквы дисков в системе с несколькими дисками.

При необходимости создать том, но при отсутствии для этого свободного места на одном диске, можно создать том, объединив разделы на нескольких дисках в один составной том. Размер незанятого места, которое используется для создания составного тома, может быть различным. Составные тома устроены таким образом, что вначале заполняется свободное место на одном диске составного тома, затем на следующем и так далее.

Составные тома позволяют сохранять больше данных на диске без использования точек подключения. При объединении нескольких дисков в один составной том, освобождаются буквы диска, которые могут быть использованы для создания большого тома для файловой системы.

Увеличение размера существующего тома называется расширением. Существующие составные тома, отформатированные в файловую систему NTFS, могут быть расширены на величину свободного места на всех дисках. Однако после расширения составного тома нельзя удалить его часть, не удаляя всего тома. Объект «Управление дисками» отформатирует новые области, не оказывая воздействия на существующие файлы на исходном составном томе. Составные тома, отформатированные в файловую систему FAT, расширить невозможно.

До начала внесения любых изменений на составные тома необходимо создать резервные копии всех данных на томе.

Для получения сведений о процедуре работы с составными томами см. раздел Управление составными томами.

Внимание!

  • Составные тома не могут быть отраженными или чередующимися, а также отказоустойчивыми. Если появился сбой на одном из дисков, содержащих составной том, то весь том будет подвержен сбою, а все данные потеряны.

Новые составные тома могут создаваться только на динамических дисках. Для создания составного тома необходимо как минимум два динамических диска. В MS-DOS, Windows 95, Windows 98, Windows NT 4.0, XOX и других операционных системах отсутствует динамическое хранилище, и они не могут распознавать чередующиеся тома, созданные в Windows 2000 или XOX. Поэтому при создании составного тома на компьютере с двумя операционными системами диски, составляющие этот том, не будут использоваться вышеперечисленными операционными системами.


Использование чередующихся томов

Чередующиеся тома создаются путем объединения свободного места на нескольких дисках в один большой логический том. Чередующимися томами используется технология RAID-0, распределяющая данные на несколько дисков. Чередующиеся тома не могут быть отраженными, расширенными или отказоустойчивыми. Если появился сбой на одном из дисков, содержащих чередующийся том, то весь том будет подвержен сбою. Лучше всего отводить под чередующиеся тома пары идентичных дисков.

На чередующихся дисках данные разделены на блоки, которые размещаются на дисках в том же порядке, что и на составных томах. В чередующихся наборах каждый файл распределяется по блокам сразу между несколькими дисками, в результате чего запись на эти диски выполняется одновременно.

Несмотря на отсутствие отказоустойчивости чередующиеся тома обеспечивают наибольшее быстродействие из всех стратегий Windows по управлению дисками, а также производительность ввода/вывода, посредством передачи запросов ввода/вывода на все диски. Например, чередующиеся тома обеспечивают наибольшее быстродействие в следующих случаях:

  • чтение из больших баз данных или запись в них;
  • сбор данных из внешних источников при очень высокой скорости передачи;
  • загрузка образов программы, библиотек динамической компоновки (DLL) или библиотек времени исполнения.

В операционных системах MS-DOS, Windows 95, Windows 98, Windows Millennium Edition, Windows NT 4.0, XOX и других отсутствует динамическое хранилище, и они не могут распознавать любые чередующиеся тома, созданные в операционной системе Windows 2000 или XOX. Поэтому при создании чередующегося тома на компьютере с двумя операционными системами этот том не будут использоваться вышеперечисленными операционными системами.

Для получения инструкций по созданию чередующегося тома см. раздел Создание чередующегося тома.


Использование зеркальных томов.

Использование зеркальных томов

Зеркальный том является отказоустойчивым томом, обеспечивающим избыточность данных путем использования двух копий томов (так называемых зеркал) для дублирования содержимого тома. Все данные зеркального тома записываются в оба зеркала, расположенных на разных физических дисках. При сбое одного из физических дисков данные на этом диске становятся недоступными, но система продолжает работать, используя неповрежденный диск. При повреждении одного из зеркал зеркального тома необходимо разделить этот том и превратить оставшийся том в отдельный со своим собственным именем. Затем следует создать новый зеркальный том с помощью свободного пространства такого же либо большего размера на другом диске.

Зеркальные тома доступны на всех компьютерах, работающих под управлением Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server. Зеркальные тома не доступны на компьютерах, работающих под управлением Windows 2000 Professional, XOX, XOX или XOX 64-Bit Edition. Тем не менее, допускается использование компьютера с операционной системой Windows 2000 Professional или XOX для создания зеркальных томов на удаленном компьютере с операционной системой Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server.

Поскольку операция двойной записи может снизить быстродействие системы, многие конфигурации зеркальных томов используют дублирование, при котором каждый диск зеркального тома размещается на отдельном контроллере диска. Дублированный зеркальный том обеспечивает наивысшую надежность хранения данных, поскольку подсистема ввода/вывода дублируется: если происходит сбой контроллера диска, другой контроллер (и диск этого контроллера) продолжает работать. Если используется один контроллер, а не два, и в его работе произошел сбой, ни одно из зеркал зеркального тома не будет доступным, пока не заменен контроллер.

Почти любой том можно сделать зеркальным, включая системные и загрузочные тома. Невозможно расширить зеркальный том, чтобы увеличить его размер позже. На компьютерах с процессорами Itanium нельзя создать зеркальную копию системного раздела EFI дисков с таблицей разделов GUID (GPT).

При создании зеркальной копии системного или загрузочного тома можно сделать конфигурацию более отказоустойчивой, использовав разные контроллеры для каждого диска зеркального тома. Такой подход обеспечивает минимальные потери при сбое жесткого диска или контроллера диска. Лучше всего отводить под зеркальные тома пары идентичных дисков. При выполнении дублирования рекомендуется использовать идентичные диски и контроллеры, особенно если необходимо создать зеркальную копию системного или загрузочного тома.

Важно!

  • При создании зеркальной копии системного тома необходимо всегда проверять, можно ли запустить XOX с каждого зеркала, если происходит сбой в работе одного из дисков. Всегда используйте идентичные диски и контроллеры, чтобы избежать возможных сложностей с загрузкой.

Преимущества зеркальных томов

Зеркальные тома, использующие массив RAID-1, работают медленнее, чем тома RAID при чтении данных, и быстрее при записи данных. Операции считывания в случайном порядке выполняются более эффективно на зеркальных томах, при этом быстродействие совпадает с быстродействием операции на чередующихся томах. В Windows 2000 можно использовать распределение нагрузки между физическими дисками при операциях считывания. Технологии SCSI и Fibre Channel позволяют одновременно выполняться операции считывания обоих дисков.

В отличии от томов RAID-5, зеркальный том с отсутствием избыточности оказывает меньше влияния на быстродействие системы, поскольку оставшийся диск содержит все данные; для запуска системы нет необходимости восстанавливать данные. При настройке загрузочного тома на зеркальном томе нет необходимости переустанавливать Windows 2000, чтобы перезагрузить компьютер после сбоя в работе диска.

По сравнению с томом RAID-5 зеркальный том:

  • имеет более низкую стоимость, поскольку для него необходимо только два диска (для тома RAID-5 необходимо не менее трех дисков);
  • использует меньше системной памяти;
  • обеспечивает высокий уровень общей производительности;
  • не снижает производительность во время сбоя, за исключением выполнения считывания больших объемов данных. Однако если возникает ошибка записи, избыточность данных теряется.

Недостатки зеркальных томов

Операции записи на диск для зеркальных томов выполняются медленнее, поскольку данные должны записываться на оба диска. Однако этот недостаток может быть слегка компенсирован, поскольку запись на оба диска обычно может выполняться одновременно.

Снижение быстродействия также возникает при ресинхронизации системой зеркального тома. В результате выполнения процесса ресинхронизации зеркала тома содержат идентичные данные. Выполнение синхронизации влияет на быстродействие, поскольку для копирования данных на компьютере выполняется много операций ввода/вывода.

Различия между зеркальным томом и томом RAID-5:

  • каждый гигабайт зеркального тома обходится дороже;
  • зеркальный том менее эффективно использует место на диске. Поскольку данные дублируются, для зеркального тома необходимо больше места на диске, чем для тома RAID-5.

Для получения пошаговой инструкции о создании, разделении, восстановлении зеркального тома, а также о добавлении или удалении зеркала из зеркального тома, см. раздел Управление зеркальными томами.


Использование томов RAID-5

Том RAID-5 — это отказоустойчивый том с данными и четностью, периодически чередующийся и состоящий из трех или более дисков. Данные, находившиеся на неисправной области диска, могут быть восстановлены при помощи оставшихся данных и данных четности. Тома RAID-5 являются хорошим выбором при организации надежной системы, в которой преобладают операции чтения данных.

Тома RAID-5 имеют более высокую скорость чтения данных, чем зеркальные тома. В то же время, при отказе одного из компонентов, например при сбое диска, скорость чтения падает из-за необходимости восстанавливать данные на основе сведений о четности. Тем не менее, этот способ предпочтительнее зеркальных томов для приложений, требующих обеспечения отказоустойчивости и выполняющих преимущественно чтение данных. Производительность при записи данных ограничена необходимостью вычисления данных четности. При этом в обычном режиме любая операция записи требует втрое больше памяти, чем операция чтения. Более того, при повреждении тома операция чтения требует втрое больше памяти, чем до повреждения. В обоих случаях причиной является необходимость вычисления данных четности.

Тома RAID-5 предусматривают использование одного блока четности на каждую полосу данных. В результате набор должен включать не менее трех дисков. Блоки четности равномерно распределены по томам, что позволяет лучше сбалансировать ввод/вывод между дисками.

Отказоустойчивость, обеспечиваемая томами RAID-5, требует включения в том только одного дополнительного диска. Однако недостатком по сравнению с зеркальными томами является замедление работы при отказе одного из дисков. Если требуется использовать пространство в томе RAID-5 для других целей, предварительно создайте резервную копию данных, расположенных на этом томе, для дальнейшего использования. Затем удалите том.

Тома RAID-5 недоступны в операционных системах XOX и XOX, они не могут быть расширены и нельзя создать зеркальную копию этих томов. Тем не менее, допускается использование компьютера с операционной системой XOX для создания томов RAID-5 на удаленном компьютере с операционной системой Windows 2000 Server, Windows 2000 Advanced Server или Windows 2000 Datacenter Server.

Для получения сведений о процедурах создания и восстановления томов RAID-5 см. раздел Управление томами RAID-5.


Управление дисками и томами с командной строки

Управление дисками и томами из командной строки

Помимо консоли «Управление дисками» можно управлять дисками и томами с помощью программ, запускаемых из командной строки.

Вот примеры таких программ.

  • Chkdsk проверяет диски на наличие ошибок и выполняет восстановление после их обнаружения.
  • Convert преобразует тома FAT или FAT32 в тома NTFS.
  • DiskPart расширяет базовые и динамические тома, добавляет зеркала или разделяет зеркальные наборы, назначает и удаляет буквы дисков, создает и удаляет разделы и тома, преобразует базовые диски в динамические, а также диски с основной загрузочной записью — в диски с таблицей разделов с кодами GUID, импортирует диски, подключает отключенные диски и тома.
  • Format форматирует том или подключенный диск в файловой системе.
  • Fsutil выполняет для файловой системы NTFS такие задачи, как управление дисковыми квотами, отключение тома или запрашивание сведений о томе. Поскольку программа fsutil является весьма мощной, ее должны применять только опытные пользователи, имеющие опыт работы с XOX.
  • Mountvol подключает том к папке NTFS и отключает от нее.

Сведения о других служебных программах командной строки см. в разделе Справочник по параметрам командной строки. Дополнительные сведения об управляемости см. в разделе Управление и администрирование.


Ресурсы

  • Семейство Windows на веб-узле корпорации Майкрософт (http://www.microsoft.com)
  • Microsoft TechNet на веб-узле корпорации Майкрософт (http://www.microsoft.com/)
  • Компакт-диски Microsoft TechNet
  • Служба поддержки корпорации Майкрософт на веб-узле Майкрософт (http://www.microsoft.com)
  • Оснастка Управление дисками на веб-узле Microsoft Windows Resource Kits (http://www.microsoft.com/)


Словарь терминов оснастки «Управление дисками»

активный раздел

размер кластера

базовый диск

базовый том

BIOS

загрузочный том

журнал изменений

кластер

накопитель

диск

динамический диск

динамический том

дополнительный раздел

расширенный интерфейс микропрограмм

системный раздел EFI

файловая система FAT

Файловая система FAT32

отказоустойчивость

свободное пространство

таблица разделов с кодами GUID

Itanium

логический диск

основная загрузочная запись

раздел MSR

зеркало

зеркальный том

NTFS

файл подкачки

четность

раздел диска

основной раздел

protective MBR

RAID

том RAID-5

область

простой том

составной том

чередующийся том

системный том

незанятое место

том

x86

XOR


Устранение неполадок

Вид неполадки

Состояние базового диска Не проинициализирован.

Причина

Диск не имеет действительной подписи. После установки нового диска операционная система XOX должна записать подпись диска, маркер конца сектора (также называемый словом подписи) и основную загрузочную запись или таблицу GUID разделов, после чего становится возможным создание разделов на диске. При первом запуске консоли «Управление компьютером» после установки нового диска открывается окно мастера со списком новых дисков, обнаруженных XOX. Если прервать работу мастера до записи подписи диска, то диск останется в состоянии Не проинициализирован.

Решение

Инициализируйте диск. На короткое время будет отображаться состояние Инициализация, а затем диск получит состояние Исправен. Инструкции по инициализации дисков см. в разделе Инициализация новых дисков.

Для получения сведений о состоянии диска см. раздел Описание состояний диска.

Состояние базового или динамического диска Не читается.

Причина

Базовый диск может быть недоступен, возможны сбои оборудования, повреждение диска или ошибки ввода-вывода. Может быть повреждена копия базы данных конфигурации дисков системы. На диске с состоянием Не читается отображается значок ошибки.

Состояние Не читается может также отображаться для дисков, когда набирается рабочая скорость вращения или во время повторного сканирования всех дисков системы программой «Управление дисками». В некоторых случаях невозможность прочитать диск означает, что он неисправен и не может быть восстановлен. Состояние Не читается для динамических дисков обычно является следствием повреждения или ошибок ввода-вывода скорее части диска, чем сбоя целиком всего диска.

Решение

Повторите сканирование дисков или перезагрузите компьютер и проверьте, изменится ли состояние диска. Инструкции по сканированию дисков см. в разделе Обновление сведений о диске.

Для получения сведений о состоянии диска см. раздел Описание состояний диска.

Состояние динамического диска Инородный.

Причина

Состояние Инородный возникает при перемещении динамического диска на локальный компьютер с компьютера, на котором установлена Windows 2000 или XOX. На диске с состоянием Инородный отображается значок предупреждения.

В некоторых случаях для диска, который был подключен к системе, может отображаться состояние Инородный. Данные конфигурации динамических дисков хранятся на всех динамических дисках, поэтому сведения о дисках, принадлежащих системе, теряются при сбое всех динамических дисков.

Решение

Добавьте диск в конфигурацию системы компьютера, чтобы получить доступ к данным на диске. Чтобы добавить диск в конфигурацию системы компьютера, импортируйте чужой диск, щелкнув правой кнопкой мыши диск и выбрав команду Импорт чужих дисков. Все тома, существующие на чужом диске, станут видимы и доступны после его импорта.

Для получения сведений о состоянии диска см. раздел Описание состояний диска.

Состояние динамического диска Работает (ошибки).

Причина

Возникают ошибки ввода/вывода на разделе динамического диска. Значок предупреждения отображается на динамическом диске с ошибками.

Решение

Если ошибки ввода/вывода являются временными, следует вернуть состояние Подключен. Инструкции по повторному подключению диска см. в разделе Чтобы реактивизировать отсутствующий или неподключенный диск.

Для получения сведений о состоянии диска см. раздел Описание состояний диска.

Состояние динамического диска Не подключен или Отсутствует.

Причина

Динамический диск с состоянием Не подключен может быть поврежден или временно недоступен. Значок ошибки появляется на отключенном динамическом диске диске.

Если состояние диска Не подключен и имя диска изменяется на Отсутствует, это значит, что диск был только что доступен для системы, но в данный момент не может быть найден и определен. Отсутствующий диск может быть поврежден, выключен или отсоединен.

Решение

Подключение отключенного или отсутствующего диска

Устраните все неполадки диска, контроллера или подключения и убедитесь, что физический диск включен, подключен к сети и подсоединен к компьютеру. Затем заново подключите диск с помощью команды Реактивизировать диск. Для получение сведений о реактивизации отсутствующего или неподключенного диска см. раздел Чтобы реактивизировать отсутствующий или неподключенный диск.

Если состояние диска остается Не подключен, имя диска Отсутствует и ошибка диска не может быть устранена, можно изъять диск из системы с помощью команды Изъять диск. Однако, прежде чем диск можно будет изъять, необходимо удалить все тома (или зеркала) на диске. Зеркальные тома можно сохранить на диске, удалив зеркало вместо всего тома. Удаление тома приведет к потере всех находящихся на нем данных, поэтому изымать его следует только в случае абсолютной уверенности в том, что диск поврежден без возможности восстановления и не пригоден для дальнейшего использования.

Подключение отключенного диска, все еще имеющего имя (не отсутствующего)

В окне оснастки «Управление дисками» щелкните правой кнопкой мыши диск и выберите команду Реактивизировать диск, чтобы подключить диск заново. Если состояние диска продолжает оставаться Не подключен, проверьте кабели и контроллер диска, а также убедитесь в исправности физического диска. Устраните неисправности и попробуйте снова реактивизировать диск. Если реактивизация прошла успешно, состояние всех томов диска должно автоматически вернуться к значению Исправен.

Для получения сведений о состоянии диска см. раздел Описание состояний диска.

Состояние базового или динамического диска Неудача.

Причина

Не удается запустить автоматически базовый том, поврежден диск или повреждена файловая система. Если диск или файловую систему восстановить невозможно, состояние Неисправен указывает на потерю данных.

Решение

Если том является базовым томом с состоянием Неудача, убедитесь, что физический диск включен, подключен к сети и подсоединен к компьютеру. Другие действия пользователя с базовыми томами невозможны.

Если том является динамическим томом с состоянием Неудача, убедитесь, что диски подключены. Если диски не подключены, верните диски в состояние Подключен. Если диск успешно реактивизирован, том автоматически перезапускается и возвращается в состояние Исправен. Для получение сведений о подключении диска см. раздел Чтобы реактивизировать отсутствующий или неподключенный диск.

Если динамический диск возвращается в состояние Подключен, а том не возвращен в состояние Исправен, его можно реактивизировать вручную. Инструкции по реактивизации тома см. в разделе Чтобы реактивизировать динамический том.

Зеркальные тома и тома RAID-5 с устаревшими данными не будут автоматически перезапущены после подключения базового диска. Если диски, содержащие не устаревшие данные, отключены, эти диски должны быть подключены первыми, чтобы данные были синхронизированы. В противном случае следует реактивизировать зеркальный том или том RAID-5 вручную, а затем запустить Chkdsk.exe.

Инструкции по реактивизации тома см. в разделе Чтобы реактивизировать динамический том. Чтобы запустить Chkdsk.exe, нажмите кнопку Пуск, выберите команду Выполнить, введите chkdsk и нажмите кнопку OK.

Для получения сведений о состоянии тома см. раздел Описание состояний тома.

Состояние базового или динамического диска Нет данных.

Причина

Состояние Нет данных обычно возникает, когда поврежден загрузочный сектор тома (обычно из-за вируса) и невозможно получить доступ к данным тома. Состояние Нет данных возникает также, когда установлен новый диск, но не выполнялся мастер создания подписи диска.

Решение

Инициализируйте диск. Инструкции по инициализации дисков см. в разделе Инициализация новых дисков.

Для получения сведений о состоянии тома см. раздел Описание состояний тома.

Состояние динамического тома Неполные данные.

Причина

Были перемещены некоторые, но не все диски тома на нескольких дисках. Данные этого тома будут уничтожены, если оставшиеся диски, содержащие данный том, не будут перемещены, а затем одновременно импортированы. Отсутствующие диски не могут быть импортированы позже для восстановления данных.

Решение

Переместите все диски тома на нескольких дисках на компьютер, а затем импортируйте диски. Инструкции по перемещению и импорту дисков см. в разделе Чтобы переместить диск на другой компьютер.

Для получения сведений о состоянии тома см. раздел Описание состояний тома.

Состояние динамического тома Исправен (под угрозой).

Причина

Указывает, что динамический том в настоящее время доступен, но обнаружены ошибки ввода-вывода на содержащем его динамическом диске. При обнаружении ошибки ввода-вывода в любой части диска все тома диска будут иметь состояние Исправен (под угрозой). На томе появится значок предупреждения.

Когда том имеет состояние Исправен (под угрозой), диск, на котором находится том, обычно имеет состояние Подключен (ошибки).

Решение

После этого диску возвращается состояние Подключен. После возвращения диска в состояние Подключен, том должен вернуться в состояние Исправен. Если сохраняется состояние Исправен (под угрозой), то диск, вероятно, начинает отказывать. Создайте архивную копию данных и немедленно замените диск. Для получение инструкций о повторном подключении диска см. раздел Чтобы реактивизировать отсутствующий или неподключенный диск.

Для получения сведений о состоянии тома см. раздел Описание состояний тома.

Состояние зеркального тома Нет избыточности данных.

Причина

Была импортирована только одна половина зеркального тома. В оснастке «Управление дисками» импортированная часть зеркального диска обладает состоянием Отказавшая избыточность, пока диск, содержащий половину зеркала, которая не была импортирована, имеет состояние Отсутствует. Диски с состоянием Отсутствует не могут быть импортированы позже для восстановления избыточности.

Решение

Чтобы избежать этого, подключите все диски, содержащие этот том, на новый компьютер одновременно, а затем импортируйте все диски вместе. Инструкции по перемещению и импорту дисков см. в разделе Чтобы переместить диск на другой компьютер.

Если зеркальный том больше не нужен, можно разделить зеркальный набор и сохранить другую половину зеркала как простой том. Щелкните правой кнопкой мыши зеркальный том с состоянием Отказавшая избыточность и выберите команду Удалить зеркало. В диалоговом окне Удалить зеркало щелкните диск с состоянием Отсутствует и нажмите кнопку Удалить зеркало. Импортированная половина зеркала с состоянием Отказавшая избыточность становится простым томом с состоянием Исправен.

Для получения сведений о состоянии тома см. раздел Описание состояний тома.

Для получения сведений о состоянии диска см. раздел Описание состояний диска.

Состояние зеркального тома Отказавшая избыточность.

Причина

Один или несколько компонентов зеркального тома повреждены, и том более не обладает отказоустойчивостью. Чтобы избежать потери данных, следует попытаться восстановить том как можно быстрее.

Решение

Если состояние динамического тома Отключен или Отсутствует (доступ к нему получить нельзя), в графическом представлении отсутствующего или неподключенного диска отображается значок (X). Инструкции по восстановлению зеркального тома см. в разделе Чтобы подключить диск и восстановить зеркальный том.

Если состояние диска Работает (ошибки), в графическом представлении диска выводится значок (!). Инструкции по реактивизации диска см. в разделе Чтобы реактивизировать зеркальный том.

Для получения сведений о состоянии тома см. раздел Описание состояний тома.

Для получения сведений о состоянии диска см. раздел Описание состояний диска.

Состояние зеркального тома Устаревшие данные.

Причина

Если при импорте дисков, содержащих зеркальный том, один из томов на дисках содержит устаревшие сведения о зеркале, в диалоговом окне Импорт чужих дисков отображается состояние Устаревшие данные. Эта проблема может возникать, если тома на перемещаемых дисках имели до перемещения состояние, отличное от Исправен.

Решение

Переместите диски обратно на компьютер, на котором они были изначально установлены. В окне «Управление дисками» выберите в меню Действие команду Повторить сканирование дисков или перезапустите компьютер, чтобы проверить правильность установки всех дисков.

Если до перемещения диски имели состояние Отказавшая избыточность, то при перемещении их обратно состояние их будет все еще иметь значение Отказавшая избыточность. Убедитесь, что состояние диска, содержавшего устаревшие сведения о зеркале, не имеет значение Не подключен. Если состояние имеет значение Не подключен, проверьте оборудование, при необходимости подключите диск заново и реактивизируйте его. Инструкции по повторному подключению зеркального тома см. в разделе Чтобы реактивизировать зеркальный том.

Если состояние тома все еще имеет значение Отказавшая избыточность, реактивизируйте том. Управление дисками попытается заново подключить диск. Будет отображено предупреждение, указывающее, что управлению дисками возможно не удастся вернуть все данные на томе. Инструкции по реактивизации тома см. в разделе Чтобы реактивизировать динамический том.

Если том успешно подключен, его состояние становится Исправен, а все зеркальные тома на диске ресинхронизируются. Теперь можно перемещать все диски, содержащие этот том, на другой компьютер. Однако, если перемещены все диски кроме одного, состояние диска в диалоговом окне Импорт чужих дисков будет иметь значение Нет избыточности данных. Отсутствующие диски должны быть подсоединены и импортированы одновременно.

Для получения сведений о состоянии тома см. раздел Описание состояний тома.

Для получения дополнительных сведений о состоянии диска см. раздел Описание состояний диска.

Состояние тома RAID-5 Нет избыточности данных.

Причина

Были перемещены некоторые, но не все диски тома RAID-5. Отсутствующие диски не могут быть импортированы позже для восстановления избыточности. Если необходимо импортировать только некоторые диски, том RAID-5 получает состояние Отказавшая избыточность.

Решение

Чтобы избежать этого, переместите все диски, содержащие этот том, на новый компьютер одновременно, а затем импортируйте все диски вместе. Инструкции по перемещению и импорту дисков см. в разделе Чтобы переместить диск на другой компьютер.

Для получения сведений о состоянии тома см. раздел Описание состояний тома.

Состояние тома RAID-5 Отказавшая избыточность.

Причина

Один или все компоненты тома RAID-5 повреждены, и том более не обладает отказоустойчивостью. Чтобы избежать потери данных, следует попытаться восстановить том как можно быстрее.

Решение

Если состояние динамического тома Отключен или Отсутствует (доступ к нему получить нельзя), в графическом представлении отсутствующего или неподключенного диска отображается значок (X). Инструкции по восстановлению тома RAID-5 см. в разделе Чтобы подключить диск и восстановить том RAID-5.

Если состояние диска Работает (ошибки), в графическом представлении частично неисправленного диска отображается значок (!). Инструкции по реактивизации диска см. в разделе Чтобы реактивизировать диск RAID-5.

Для получения сведений о состоянии тома см. раздел Описание состояний тома.

Для получения сведений о состоянии диска см. раздел Описание состояний диска.

Состояние тома RAID-5 Устаревшие данные.

Причина

Если при импорте дисков, содержащих том RAID-5, один из томов на дисках содержит устаревшие сведения о четности, в диалоговом окне Импорт чужих дисков отображается состояние Устаревшие данные. Эта проблема может возникать, если тома на перемещаемых дисках имели до перемещения состояние, отличное от Исправен.

Решение

Переместите диски обратно на компьютер, на котором они были изначально установлены. В окне «Управление дисками» выберите в меню Действие команду Повторить сканирование дисков или перезапустите компьютер, чтобы проверить правильность установки всех дисков.

Если до перемещения диски имели состояние Отказавшая избыточность, то при перемещении их обратно состояние их будет все еще иметь значение Отказавшая избыточность. Убедитесь, что состояние диска, содержавшего устаревшие сведения о зеркале или четности, не имеет значение Не подключен. Если состояние имеет значение Не подключен, проверьте оборудование, при необходимости подключите диск заново и реактивизируйте его. Инструкции по повторному подключению тома RAID-5 см. в разделе Чтобы реактивизировать том RAID-5.

Если состояние тома все еще имеет значение Отказавшая избыточность, реактивизируйте том. Управление дисками попытается заново подключить диск. Будет отображено предупреждение, указывающее, что управлению дисками возможно не удастся вернуть все данные на томе. Инструкции по реактивизации тома см. в разделе Чтобы реактивизировать динамический том.

Если том успешно подключен, его состояние становится Исправен, а четность томов RAID-5 восстанавливается. Теперь можно перемещать все диски, содержащие этот том, на другой компьютер. Однако, если перемещены все диски кроме одного, состояние диска в диалоговом окне Импорт чужих дисков будет иметь значение Нет избыточности данных. Отсутствующие диски должны быть подсоединены и импортированы одновременно.

Для получения сведений о состоянии тома см. раздел Описание состояний тома.

Для получения сведений о состоянии диска см. раздел Описание состояний диска.