Программа «Дефрагментация диска»

«Дефрагментация диска» — это системная служебная программа, выполняющая анализ локальных томов с последующим поиском и объединением фрагментированных файлов и папок. Дефрагментацию дисков также можно запустить из командной строки с помощью команды defrag.

  • Перед выполнением дефрагментации файлов или папок ознакомьтесь с разделом Контрольный список для дефрагментации томов.
  • Советы по использованию программы «Дефрагментация диска» см. в разделе Советы и рекомендации.
  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Общие фундаментальные сведения собраны в разделе Основные понятия.
  • Инструкции по устранению неполадок содержатся в разделе Устранение неполадок.


Контрольный список: дефрагментация томов

Действие | Ссылка
Просмотрите обзор. | Дефрагментация диска: обзор
Просмотрите советы и рекомендации. | Советы и рекомендации
Убедитесь, что входите в группу Администраторы. | Сведения об учетных записях пользователей
Проанализируйте том. | Анализ тома
Дефрагментируйте том. | Дефрагментация тома
Просмотрите отчет. | Поля результатов и отчеты об анализе и дефрагментации с


Советы и рекомендации

  • Анализ перед дефрагментацией
    Проанализируйте тома перед их дефрагментацией. После проведения анализа отображается диалоговое окно с сообщением о проценте фрагментированных файлов и папок в томе и рекомендацией к действию. Анализ рекомендуется проводить регулярно, а дефрагментацию только после соответствующей рекомендации программы дефрагментации диска. Анализ томов рекомендуется выполнять не реже одного раза в неделю. Если потребность в дефрагментации возникает редко, интервал выполнения анализа томов можно увеличить до одного месяца.
  • Анализ после добавления большого числа файлов
    После добавления большого количества файлов или папок тома могут стать сильно фрагментированными, поэтому в таких случаях рекомендуется их проанализировать. Тома на занятых файловых серверах должны дефрагментироваться чаще, чем на рабочих станциях пользователей.
  • Убедитесь, что на диске не менее 15% свободного пространства
    Для полной и правильной дефрагментации с помощью программы «Дефрагментация диска» том должен иметь не менее 15% свободного пространства. Программа «Дефрагментация диска» использует этот объем как область для сортировки фрагментов файлов. Если объем составляет менее 15% свободного пространства, то программа «Дефрагментация диска» выполнит только частичную дефрагментацию. Чтобы освободить дополнительное место на диске, удалите ненужные файлы или переместите их на другой диск.
  • Дефрагментация во время неактивного использования
    Дефрагментируйте тома файлового сервера тогда, когда они используются не очень активно, чтобы процесс дефрагментации не повлиял на производительность сервера. Время, необходимое для дефрагментации тома, зависит от нескольких факторов, в том числе от его размера, общего числа файлов, числа фрагментированных файлов и доступных системных ресурсов.
  • Дефрагментация после установки программного обеспечения или установки Windows
    Дефрагментируйте тома после установки программного обеспечения или после выполнения обновления или чистой установки Windows. После установки программного обеспечения тома часто фрагментируются, поэтому выполнение программы дефрагментации диска помогает обеспечить наивысшую производительность файловой системы.


Инструкции

  • Анализ тома
  • Дефрагментация тома


Analyze a volume

Рисунок Microsoft Windows

Чтобы проанализировать том

Использование интерфейса Windows

  1. Откройте программу Дефрагментация диска.
  2. Выберите том, который требуется проверить на наличие фрагментированных файлов и папок, и нажмите кнопку Анализ.

    3. По завершении анализа тома программа дефрагментации диска выводит результаты анализа. Также выводится диалоговое окно с сообщением о том, нуждается ли данный том в дефрагментации.

  3. Нажмите кнопку Вывести отчет, чтобы просмотреть отчет об анализе, содержащий более подробные сведения о томе и список наиболее фрагментированных файлов.

Примечания

  • XOX
  • XOX

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите defrag том [/a] [/v]
    3. Аргумент | Описание
том | Буква диска или точка подключения тома, который требуется проанализировать.
/a | Анализ тома и вывод краткого отчета об анализе.
/v | Вывод полного отчета об анализе.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис команды, введите defrag /?
  • В ходе анализа и дефрагментации тома в программе defrag отображается мигающий курсор. По завершении анализа и дефрагментации тома программа defrag выводит отчет об анализе, отчет о дефрагментации или оба этих отчета, после чего окно командной строки закрывается.
  • По умолчанию программа defrag выводит сводку обоих отчетов (об анализе и о дефрагментации), если не был введен параметр /a или /v.
  • Чтобы экспортировать отчеты в текстовый файл, введите параметр >имя_файла.txt, где имя_файла.txt — имя файла, задаваемое пользователем. Например:

    • defrag том /v >имя_файла.txt

  • Ввод команды defrag и запуск программы «Дефрагментация диска» являются взаимно исключающими действиями. Если программа «Дефрагментация диска» используется для дефрагментации тома, а пользователь запускает команду defrag из командной строки, то команда defrag не выполняется. И наоборот, если команда defrag выполняется из командной строки, а пользователь открывает программу «Дефрагментация диска», то параметры дефрагментации в окне этой команды являются недоступными.

См. также


Дефрагментация тома

Рисунок Microsoft Windows

Чтобы дефрагментировать том

Использование интерфейса Windows

  1. Откройте программу Дефрагментация диска.
  2. Выберите том, который требуется дефрагментировать, и нажмите кнопку OK.

    3. По завершении дефрагментации результаты будут отображены графически в соответствующем поле.

  3. Нажмите кнопку Вывести отчет, чтобы просмотреть отчет о дефрагментации, содержащий подробные сведения о дефрагментированном томе.

Примечания

  • XOX
  • XOX
  • Перед дефрагментацией томов необходимо их проанализировать. Это позволит определить, стоит ли тратить время на дефрагментацию томов.
  • Для полной и правильной дефрагментации с помощью программы «Дефрагментация диска» том должен иметь не менее 15% свободного пространства. Программа «Дефрагментация диска» использует этот объем как область для сортировки фрагментов файлов. Если объем составляет менее 15% свободного пространства, то программа «Дефрагментация диска» выполнит только частичную дефрагментацию. Чтобы освободить дополнительное место на диске, удалите ненужные файлы или переместите их на другой диск.
  • Тома, которые, возможно, повреждены, помечаются файловой системой как «грязные»; дефрагментация таких томов невозможна. Чтобы дефрагментировать грязный том, для него необходимо выполнить команду chkdsk. Определить, является ли том грязным, можно с помощью команды fsutil dirty query. Для получения дополнительных сведений о командах chkdsk и fsutil dirty щелкните ссылку «См. также».
  • Время, необходимое для дефрагментации тома, зависит от нескольких факторов, в том числе от его размера, числа и размера файлов в томе, процента его фрагментации и доступных ресурсов системы.
  • Допускается дефрагментация томов только локальной файловой системы и выполнение только одного экземпляра программы дефрагментации диска одновременно.
  • Чтобы прервать или приостановить дефрагментацию тома, нажмите кнопку Остановка или Пауза соответственно.
  • При запуске программы «Дефрагментация диска» во время выполнения архивации дефрагментация будет прервана.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите defrag том [/v]
    3. Аргумент | Описание
том | Буква диска или точка подключения тома, который требуется дефрагментировать.
/v | Отображение полных отчетов об анализе и дефрагментации.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис команды, введите defrag /?
  • Для полной и правильной дефрагментации с помощью команды defrag том должен иметь не менее 15% свободного пространства. Defrag использует этот объем как область для сортировки фрагментов файлов. Если объем составляет менее 15% свободного пространства, то команда defrag выполнит только частичную дефрагментацию. Чтобы освободить дополнительное место на диске, удалите ненужные файлы или переместите их на другой диск.
  • Тома, которые, возможно, повреждены, помечаются файловой системой как «грязные»; дефрагментация таких томов невозможна. Чтобы дефрагментировать грязный том, для него необходимо выполнить команду chkdsk. Определить, является ли том грязным, можно с помощью команды fsutil dirty query. Для получения дополнительных сведений о командах chkdsk и fsutil dirty щелкните ссылку «См. также».
  • В ходе анализа и дефрагментации тома в программе defrag отображается мигающий курсор. По завершении анализа и дефрагментации тома программа defrag выводит отчет об анализе, отчет о дефрагментации или оба этих отчета, после чего окно командной строки закрывается.
  • По умолчанию программа defrag выводит сводку обоих отчетов (об анализе и о дефрагментации), если не был введен параметр /a или /v.
  • Чтобы экспортировать отчеты в текстовый файл, введите параметр >имя_файла.txt, где имя_файла.txt — имя файла, задаваемое пользователем. Например:

    • defrag том /v >имя_файла.txt

  • Чтобы прервать процесс дефрагментации, нажмите клавиши CTRL+C в окне командной строки.
  • Ввод команды defrag и запуск программы «Дефрагментация диска» являются взаимно исключающими действиями. Если программа «Дефрагментация диска» используется для дефрагментации тома, а пользователь запускает команду defrag из командной строки, то команда defrag не выполняется. И наоборот, если команда defrag выполняется из командной строки, а пользователь открывает программу «Дефрагментация диска», то параметры дефрагментации в окне этой команды являются недоступными.

См. также


Основные понятия

В этом разделе

  • Дефрагментация диска: обзор
  • Программа дефрагментации дисков
  • Использование программы дефрагментации дисков
  • Ресурсы


Общие сведения о программе «Дефрагментация диска»

Программа «Дефрагментация диска» анализирует локальные тома и объединяет фрагментированные файлы и папки таким образом, чтобы каждый файл или папка тома занимали единое непрерывное пространство. В результате чтение и запись файлов и папок выполняется эффективнее. Объединяя отдельные части файлов и папок, программа дефрагментации также объединяет в единое целое свободное место на томе, что делает менее вероятной фрагментацию новых файлов. Процесс объединения фрагментированных файлов и папок называется дефрагментацией.

Время, необходимое для дефрагментации тома, зависит от нескольких факторов, в том числе от его размера, числа и размера файлов, степени фрагментации и доступных системных ресурсов. Перед выполнением дефрагментации можно найти все фрагментированные файлы и папки, проанализировав том. Затем можно оценить степень фрагментации тома и принять решение о целесообразности его дефрагментации. Пошаговые инструкции по анализу и дефрагментации тома см. в разделах Анализ тома и Дефрагментация тома.

Программа дефрагментации дисков позволяет обрабатывать тома, отформатированные в файловых системах FAT, FAT32 и NTFS.


Программа дефрагментации дисков

В этом разделе

  • Почему фрагментируются тома
  • Почему файлы не перемещаются в некоторые области томов с файловой системой NTFS
  • Поля результатов и отчеты об анализе и дефрагментации


Почему фрагментируются тома

Тома становятся фрагментированными при создании и удалении файлов и папок, установке новых программ или загрузке файлов из Интернета. Компьютеры обычно сохраняют файлы на первом непрерывном участке свободного пространства, достаточном для размещения файла. Если найти участок для размещения всего файла не удается, компьютер сохраняет часть файла на самом большом участке доступного пространства, после чего сохраняет остальные данные на следующем доступном участке свободного пространства и т. д.

Когда большая часть тома задействована для хранения файлов и папок, большинство файлов сохраняется частями на разных участках тома. Остающееся после удаления файлов и папок свободное место заполняется в произвольном порядке при сохранении новых файлов и папок.

Чем сильнее фрагментирован диск, тем медленнее осуществляется ввод и вывод файлов.


Почему файлы не перемещаются в некоторые области томов с файловой системой NTFS

На томах, форматированных в системе NTFS, часть свободного пространства на разделе диска зарезервирована Windows для основной таблицы файлов. В основной таблице файлов Windows хранит все сведения, необходимые для получения файлов с данного тома.

Программа дефрагментации диска не может перемещать файлы в зону основной таблицы файлов, поскольку эта область зарезервирована Windows. Тем не менее, когда другое дисковое пространство недоступно, Windows позволяет сохранять другие файлы в области, зарезервированной под основную таблицу файлов.


Поля результатов и отчеты об анализе и дефрагментации

После анализа или дефрагментации тома результаты можно просмотреть в графическом представлении с цветовой кодировкой в так называемых полях результатов анализа и дефрагментации. Для просмотра более подробных результатов можно также воспользоваться отчетом об анализе или дефрагментации.

Поля результатов анализа и дефрагментации

Каждая линия в полях результатов анализа и дефрагментации представляет собой десятки или даже сотни кластеров, в зависимости от размера тома и кластера. Поля результатов анализа и дефрагментации недостаточно велики, чтобы отображать цветную вертикальную линию для каждого кластера диска в составе тома. Поскольку в одной группе кластеров могут находиться и фрагментированные файлы, и нефрагментированные файлы, и неперемещаемые файлы (файлы, текущее положение которых на диске не может быть изменено), и свободное пространство, цвет каждой вертикальной линии определяется следующими правилами.

Цвет | Описание
Красный | Большинство кластеров являются частью фрагментированного файла.
Синий | Большинство кластеров в группе содержат только свободное пространство и нефрагментированные файлы.
Зеленый | Большинство кластеров являются частью неперемещаемого файла.
Белый | Большинство кластеров представляют свободное пространство.

В полях результатов анализа и дефрагментации отображается приблизительное представление фрагментации тома. Эти поля содержат меньше подробностей, чем отчеты. При сравнении результатов можно заметить расхождения. Для получения точных числовых значений используйте отчеты об анализе и дефрагментации.

Отчеты об анализе и дефрагментации

Отчеты об анализе и дефрагментации можно просмотреть после выполнения анализа или дефрагментации тома. Отчеты содержат подробные сведения о томе, проверенном на наличие фрагментированных файлов и папок, включая: размер тома и свободного пространства, число фрагментированных файлов и папок, а также среднее число фрагментов в файле.

Инструкции по выполнению анализа тома и просмотру отчета см. в разделе Анализ тома. Инструкции по выполнению дефрагментации тома и просмотру отчета см. в разделе Дефрагментация тома.

Отчет об анализе

Отчет об анализе можно просмотреть или вывести на печать только после выполнения анализа тома. В диалоговом окне Отчет об анализе выводятся подробные сведения о томе, который был проверен на наличие фрагментированных файлов и папок, включая пути и имена наиболее фрагментированных файлов, число фрагментов в этих файлов, размер тома, процент свободного пространства, а также среднее число фрагментов в одном файле. Если среди таких файлов имеются часто используемые, их влияние на производительность системы может быть более существенным, чем это указано параметром В среднем фрагментов на файл.

Среднее число фрагментов в файле характеризует степень фрагментации файлов в томе. Возможные средние величины и их значение показаны в следующей таблице.

В среднем фрагментов на файл | Описание
1,00 | Большинство или все файлы являются не фрагментированными.
1,10 | Около десяти процентов разбиты на два фрагмента или более.
1,20 | Около двадцати процентов разбиты на два фрагмента или более.
1,30 | Около тридцати процентов разбиты на два фрагмента или более.
2,00 | Большая часть или все файлы разбиты на два фрагмента или более.

Отчет о дефрагментации

Отчет о дефрагментации можно просмотреть или вывести на печать только после выполнения дефрагментации тома. В диалоговом окне Отчет о дефрагментации отображаются подробные сведения о дефрагментированном томе. Во второй половине отчета о дефрагментации перечислены все файлы, которые были дефрагментированы.

Если том отформатирован для файловой системы NTFS, то при наличии файлов, открытых с возможностью записи, в отчете о дефрагментации могут быть перечислены мелкие файлы (например, размером в 1 Кбайт) с большим числом фрагментов. Дело в том, что при открытии файла с возможностью записи NTFS выполняет попытку выделить дополнительное пространство с целью предотвращения фрагментации файла по мере его увеличения. Поскольку программа дефрагментации дисков не позволяет перемещать и объединять это лишнее пространство, пока файл открыт, в отчете это пространство указывается как дополнительные фрагменты.


Использование программы дефрагментации дисков

В этом разделе

  • Окно программы дефрагментации диска
  • Дефрагментация дисков из командной строки


Окно программы дефрагментации диска

Окно программы дефрагментации диска состоит из двух главных областей. В верхней части отображается список томов данного локального компьютера. В нижней части отображается графическое представление степени фрагментации тома. Для отображения состояния тома используются различные цвета:

  • красным отображаются фрагментированные файлы;
  • синим отображаются непрерывные (нефрагментированные) файлы;
  • белым отображается свободное пространство тома;
  • зеленым отображаются неперемещаемые файлы, которые не могут быть перемещены программой дефрагментации диска.

    • На томах FAT и FAT32 зеленым обычно отображаются файлы подкачки. Однако на томах, отформатированных для использования файловой системы NTFS, зеленым также может отображаться пространство, используемое под журнал изменений NTFS и файл журнала NTFS.

Программа дефрагментации диска не выполняет попытку объединения всего свободного пространства тома. Хотя свободное пространство, фрагментированное на сотни частей, и снижает быстродействие системы, свободное пространство, разделенное на несколько частей, такого влияния не оказывает. Объединение всего свободного пространства в единое целое слабо влияет на быстродействие.

Поля результатов анализа и дефрагментации позволяют оценить улучшения в структуре тома после его дефрагментации. Дополнительные сведения см. в разделе Поля результатов и отчеты об анализе и дефрагментации.

Пошаговые инструкции по анализу и дефрагментации тома см. в разделах Анализ тома и Дефрагментация тома.


Дефрагментация дисков из командной строки

Помимо использования программы «Дефрагментация диска» для анализа и дефрагментации дисков можно использовать defrag.

Дополнительные сведения о других служебных программах командной строки см. в разделе Справочник по параметрам командной строки. Дополнительные сведения об управляемости см. в разделе Управление и администрирование.


Ресурсы

  • Программа дефрагментации дисков была разработана Executive Software International при участии корпорации Майкрософт. Дополнительные сведения см. на странице Executive Software веб-узла корпорации Майкрософт (http://www.microsoft.com)
  • Домашняя страница Microsoft Windows на веб-узле корпорации Майкрософт (http://www.microsoft.com/)
  • Microsoft TechNet на веб-узле корпорации Майкрософт (http://www.microsoft.com/)
  • Компакт-диски Microsoft TechNet
  • Служба поддержки корпорации Майкрософт на веб-узле корпорации Майкрософт (http://www.microsoft.com)


Устранение неполадок

Вид неполадки

Компьютер работает медленно или открытие программ на жестком диске стало выполняться медленно.

Причина. Тома на жестком диске могли стать сильно фрагментированными (возможно, из-за того, что недавно было создано много файлов или папок или установлено новое программное обеспечение).

Решение. Проанализируйте тома на жестком диске и, при необходимости, выполните их дефрагментацию. Дополнительные сведения см. в разделе Советы и рекомендации.

Сведения, выводимые на экран, не соответствуют отчету.

Причина. В полях результатов анализа и дефрагментации отображается общее представление фрагментации тома. Эти поля содержат меньше подробностей, чем отчеты об анализе и дефрагментации, поэтому при сравнении результатов можно заметить расхождения. Для получения точных числовых значений всегда используйте отчеты.

Решение. Поля результатов анализа и дефрагментации предназначены только для создания общего представления о фрагментации тома. Отчеты об анализе и дефрагментации содержат точные числовые значения. Дополнительные сведения см. в разделе Поля результатов и отчеты об анализе и дефрагментации.

Некоторые неперемещаемые файлы расположены на томах, отличных от системного и загрузочного.

Причина. Файлы подкачки отображаются в программе дефрагментации дисков как неперемещаемые. На томах NTFS журнал изменений NTFS также отображается как неперемещаемый файл.

Решение. Это не является ошибкой, поскольку файлы подкачки нельзя перемещать и, следовательно, дефрагментировать. Дополнительные сведения см. в разделе Почему файлы не перемещаются в некоторые области томов с файловой системой NTFS.

Отчет о дефрагментации на томе NTFS показывает мелкие файлы с большим числом фрагментов.

Причина. При открытии файла для записи NTFS выполняет попытку заранее выделить дополнительное пространство с целью предотвращения фрагментации по мере увеличения файла. При дефрагментации тома программа дефрагментации дисков не позволяет перемещать и объединять это лишнее пространство, пока файл открыт. Это лишнее пространство в отчете отображается как дополнительные фрагменты.

Решение. Закройте файл, чтобы освободить дополнительные фрагменты и уменьшить размер файла. Значение На диске (щелкните файл правой кнопкой и выберите команду Свойства) показывает размер файла в закрытом состоянии.