Общие сведения о программе «Доктор Ватсон»

Программа «Доктор Ватсон» для Windows представляет собой отладчик программных ошибок.

Сведения, обнаруживаемые и записываемые программой «Доктор Ватсон», используются группами технической поддержки при диагностике программных ошибок на компьютерах, работающих под управлением Windows. Текстовый файл журнала (Drwtsn32.log) создается при обнаружении ошибки и может быть передан сотрудникам групп технической поддержки любым доступным способом. Кроме того, имеется возможность создания двоичного файла аварийной копии памяти, который может быть загружен программистом в отладчик.

При возникновении программных ошибок программа «Доктор Ватсон» запускается автоматически. Чтобы запустить программу «Доктор Ватсон» вручную, нажмите кнопку Пуск, выберите команду Выполнить, а затем введите drwtsn32. Чтобы запустить программу «Доктор Ватсон» из командной строки, перейдите в корневой каталог и введите drwtsn32.

См. также


Настройка программы «Доктор Ватсон»

Программа «Доктор Ватсон» (Drwtsn32.exe) устанавливается в системную папку при установке Windows. Параметры, используемые по умолчанию, задаются при первом запуске программы «Доктор Ватсон», который выполняется при возникновении программной ошибки или по команде пользователя.

При возникновении программной ошибки в Windows система выполняет поиск обработчика программных ошибок. Он обрабатывает ошибки по мере их возникновения во время выполнения программы. Если найти обработчик не удается, система проверяет, чтобы приложение не находилось в режиме отладки, после чего рассматривает ошибку как не подлежащую обработке. Далее система ищет отладчик программных ошибок в системном реестре и обрабатывает такие ошибки.

Система выполняет в разделе реестра HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug поиск параметров с именами Debugger и Auto. Значение параметра Debugger задает команду для отладчика, который будет использован для анализа ошибок программы. Если значение для параметра Debugger найдено, система проверяет, имеет ли параметр Auto значение 0 или 1.

  • Если параметр Auto имеет нулевое значение, система создает окно сообщения об ошибке программы. Если значение параметра Debugger задает команду для допустимого отладчика, окно сообщения будет содержать две кнопки: OK и Отмена. Кнопка OK завершает выполнение программы. Кнопка Отмена запускает указанный отладчик. Если параметр Debugger имеет пустое значение, окно сообщения будет содержать только кнопку OK, а отладчик запускаться не будет.
  • Если параметр Auto имеет значение 1, а значение параметра Debugger задает команду для допустимого отладчика, система автоматически запускает отладчик, не создавая окно сообщения.

При установке Windows на компьютер параметр Auto по умолчанию получает значение 1, а в параметре Debugger задается команда запуска программы «Доктор Ватсон». Это означает, что при возникновении программных ошибок программа «Доктор Ватсон» для Windows автоматически выполняет диагностику ошибок и записывает соответствующие сведения в журнал.

Если в качестве отладчика по умолчанию используется другая программа и вместо нее требуется использовать «Доктор Ватсон», перейдите в режим командной строки и введите drwtsn32 -i. Параметр -i вызывает внесение необходимых изменений в системный реестр.

Программа «Доктор Ватсон» может предоставить более точные сведения для отладки, если установлены соответствующие символы и задан путь поиска символов. Чтобы сделать это, необходимо сначала скопировать символы с компакт-диска Windows в новую папку на компьютере. Затем необходимо создать новую переменную среды. Перейдите в системный корневой каталог и создайте новую папку с именем Symbols. Затем перейдите на компакт-диске в папку \\Support\Debug\i386 и скопируйте содержащиеся в ней символы в папку Symbols, созданную на компьютере. После копирования символов создайте новую переменную среды. При создании новой переменной среды следует ввести _NT_SYMBOL_PATH в качестве ее имени и %systemroot%\Symbol в качестве значения. Существует возможность установки различных символов в различные папки, разделенные точкой с запятой, с указанием на каждую из этих папок при помощи одной и той же переменной среды. Обязательно включите переменные для добавленных пакетов обновления. Например: _NT_SYMBOL_PATH=%systemroot%\symbol;%systemroot%\hotfixes;%systemroot%\symbolsNt4Sp3.

XOX

См. также


Работа с программой «Доктор Ватсон»

Для изменения параметров программы «Доктор Ватсон» используется диалоговое окно Доктор Ватсон для Windows. Указанные в этом окне данные сохраняются в системном реестре в разделе \\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson.

Для получения сведений об элементах данного диалогового окна щелкните ссылку с названием нужного элемента.

  • Поле «Файл журнала»
  • Поле «Аварийная копия памяти»
  • Поле «Файл .wav»
  • Поле «Число инструкций»
  • Поле «Число сохраняемых ошибок»
  • Флажок «Сохранение копии таблицы символов»
  • Флажок «Сохранение копий контекстов для всех потоков»
  • Флажок «Добавление в существующий файл журнала»
  • Флажок «Визуальное оповещение»
  • Флажок «Звуковое оповещение»
  • Флажок «Создание файла аварийной копии памяти»
  • Кнопка «Показать»
  • Кнопка «Очистить»
  • Список «Ошибки приложения»

См. также


Использование файла журнала программы «Доктор Ватсон»

При возникновении программной ошибки программа «Доктор Ватсон» создает файл журнала (Drwtsn32.log). Этот файл всегда начинается со строки

Исключение в приложении:

Следующая часть файла журнала содержит сведения об ошибке. Приведенный номер исключения соответствует ошибке, генерируемой системой.

Ошибка исключения в приложении

Следующая часть файла журнала содержит системные сведения о пользователе и компьютере, на котором возникла ошибка программы.

Сведения о системе

Следующая часть файла журнала содержит список задач, которые выполнялись в системе во время возникновения ошибки программы.

Следующая часть файла журнала содержит список модулей, загружаемых программой.

Следующая часть файла журнала содержит копию памяти для контекста, соответствующего указанному идентификатору потока. Копия контекста состоит из копии регистров, результатов дизассемблирования кода вокруг текущего программного счетчика, трассировки стека и копии необработанного стека. Эта часть копии памяти содержит идентификатор потока.

Копия памяти для потока 0xbf

Следующая часть копии памяти содержит копию регистров.

Сведения о регистрах

Следующая часть копии памяти содержит результаты дизассемблирования кода.

Сведения о дизассемблировании кода

Следующая часть копии памяти содержит сведения обратной трассировки стека.

Обратная трассировка стека

Заключительная часть копии памяти содержит копию необработанного стека.

Копия необработанного стека

Часть файла журнала, следующая за копией контекста, содержит таблицу символов.

См. также