Средство диагностики DirectX

Документация средства диагностики Microsoft DirectX содержит следующие разделы.

  • Общие сведения о средстве диагностики DirectX
  • Выявление проблем с помощью средства диагностики DirectX
  • Тестирование компонентов DirectX
  • Переопределение характеристик по умолчанию
  • Сохранение информации
  • Проверка цифровых подписей WHQL


Общие сведения о средстве диагностики DirectX

Средство диагностики Microsoft DirectX отображает сведения о компонентах и драйверах интерфейса программирования приложений (API) Microsoft DirectX в данной системе. Оно позволяет проверить работу звуковой и графической систем, а также поставщиков службы DirectPlay. С его помощью можно также отключить некоторые средства аппаратного ускорения.

Кроме того, средство диагностики позволяет собрать сведения, необходимые при обращении в службу технической поддержки по телефону. Эти сведения можно вставить в сообщение электронной почты.

Сведения отображаются на нескольких страницах. Для перемещения со страницы на страницу воспользуйтесь любым из следующих способов:

  • щелкните нужную вкладку;
  • нажмите кнопку Следующая страница;
  • нажмите клавишу СТРЕЛКА ВЛЕВО или СТРЕЛКА ВПРАВО, когда фокус находится на вкладке.

На некоторых страницах окна средства диагностики, например Файлы DirectX, Музыка и Ввод, данные отображаются в табличном виде. Для упрощения поиска нужных сведений в этих таблицах предусмотрена возможность сортировки данных.

Чтобы выполнить сортировку данных в таблице

  1. Определите, в каком столбце находятся сведения, по которым требуется выполнить сортировку таблицы.
  2. Нажмите кнопку заголовка в верхней части столбца.

    В зависимости от содержимого столбца таблица будет упорядочена по алфавиту или по порядку числовых значений. Для упорядочения данных в обратном порядке (например, для сортировки от Я до А вместо сортировки от А до Я), нажмите кнопку заголовка еще раз.

* Примечания

  • Некоторые сведения, например объем памяти на видеоплате, могут быть приблизительными.
  • Для получения дополнительных сведений о сохранении данных, полученных с помощью средства диагностики, щелкните ссылку См. также.

См. также

Тестирование компонентов DirectX

Сохранение информации


Выявление проблем с помощью средства диагностики DirectX

Если при использовании приложений Microsoft DirectX возникают неполадки, средство диагностики DirectX поможет обнаружить их источник. Ниже перечислены некоторые диагностические сведения, на которые следует обратить внимание.

  • Неправильные версии компонентов DirectX. В разделе Примечания страницы Файлы DirectX просмотрите предупреждения о бета-версиях и отладочных файлах. Бета-версии — это ранние пробные версии, которые не должны устанавливаться вместе с коммерческими приложениями. Отладочные версии, используемые на этапе разработки программ, не должны устанавливаться вместе с готовым продуктом. Отладочные версии компонентов могут значительно замедлить работу программ по сравнению с коммерческими версиями.
  • Отсутствие аппаратного ускорения. Некоторые программы выполняются очень медленно или вообще не выполняются, если отсутствует аппаратное ускорение Microsoft DirectDraw или Direct3D. На странице Дисплей проверьте в группе Возможности DirectX, имеется ли метка «Недоступно» для ускорения DirectDraw, Direct3D или текстуры AGP. При наличии такой метки рассмотрите возможность обновления оборудования. Если продукт используется в одной из систем семейства Windows Server 2003, может потребоваться включение ускорения графики. Для этого щелкните значок Экран на панели управления и на вкладке Параметры нажмите кнопку Дополнительно. Выберите вкладку Диагностика и установите ползунок Аппаратное ускорение в положение Полное.
  • Устройство не подключено. Если джойстик или другое устройство ввода не отвечает, возможно, оно было неверно установлено. Проверьте, что устройство представлено на странице Ввод средства диагностики DirectX. В противном случае добавьте устройство с помощью панели управления.
  • Неподписанные драйверы. Неподписанные драйверы не проверены корпорацией Майкрософт на полную совместимость с последней версией DirectX. Рекомендуется использовать драйверы, имеющие цифровую подпись Microsoft Windows Hardware Quality Labs (WHQL).

* Примечание

  • При использовании служб терминалов для работы на удаленном компьютере, поддерживающем аппаратное ускорение, средство диагностики DirectX может отметить наличие поддержки для аппаратного ускорения. Однако службы терминалов не могут использовать аппаратное ускорение, так что поддержка в этом случае недоступна.

См. также

Сохранение информации

Проверка цифровых подписей WHQL


Тестирование компонентов DirectX

Компоненты Microsoft DirectDraw и Direct3D можно тестировать на любом мониторе, подключенном к компьютеру. Кроме того, компонент DirectSound можно тестировать на любом устройстве вывода звука, а компонент DirectMusic — на любом музыкальном порте.

Чтобы проверить компонент DirectX

  1. Нажмите кнопку Проверка на соответствующей странице.
  2. Прочтите сообщения, если они последуют.
  3. Просмотрите или прослушайте тесты.
  4. Каждый тест должен выполняться до тех пор, пока на экране не появится вопрос, был ли данный тест успешным. Если пользователь отвечает Нет, другие тесты не выполняются.

При проверке DirectMusic выполняется единый тест. Нажмите кнопку ОК после ответов на вопросы о качестве воспроизведения звука.

Функциональность Microsoft DirectPlay можно проверить для всех доступных поставщиков.

Чтобы проверить DirectPlay

  1. На странице Сеть нажмите кнопку Проверить DirectPlay.
  2. В диалоговом окне Проверка DirectPlay введите имя пользователя и выберите поставщика.
  3. Выберите параметр Создать новый сеанс и нажмите кнопку ОК.
  4. Если выбрано подключение через модем, нажмите кнопку Ответить в диалоговом окне Подключение через модем, чтобы перевести модем в режим автоответа.

После этого запустите средство диагностики Microsoft DirectX на другом компьютере, способном установить выбранное подключение с первым компьютером.

  1. Нажмите кнопку Проверка DirectPlay.
  2. Введите другое имя пользователя.
  3. Выберите того же самого поставщика.
  4. Нажмите кнопку Подсоединиться к существующему сеансу, а затем — кнопку ОК.

    Для некоторых типов подключений может потребоваться ввод дополнительных сведений, таких как телефонный номер. Для подключения TCP/IP через локальную сеть поле можно оставить пустым.

  5. На втором компьютере в диалоговом окне Список сеансов выберите имя сеанса, созданного на первом компьютере.
  6. После этого на обоих компьютерах должно быть открыто диалоговое окно разговора. Введите сообщение в поле ввода на одном компьютере и нажмите кнопку Отправить. Введенное сообщение должно появиться в области прокрутки диалогового окна разговора на обоих компьютерах.


Переопределение характеристик по умолчанию

На странице Звук можно изменить уровень аппаратного ускорения, перетащив соответствующий ползунок. Для изменения уровня аппаратного ускорения нужно обладать правами системного администратора. Выбранный уровень будет применяться даже после закрытия окна средства диагностики Microsoft DirectX.

Можно отключить аппаратное ускорение для Microsoft DirectDraw или Direct3D, если оно доступно. Для этого откройте страницу Дисплей для каждого дисплея и нажмите кнопку Отключить. Отключенное аппаратное ускорение остается отключенным и недоступным для любых приложений даже после завершения работы средства диагностики DirectX. Чтобы снова включить аппаратное ускорение, нажмите кнопку Включить на странице Дисплей для соответствующего устройства.

* Примечание

  • Отключение ускорения DirectDraw приводит к отключению ускорения для Direct3D.

Пользователь имеет также возможность переопределить частоту обновления монитора, установленную полноэкранными приложениями DirectDraw. Это следует делать только в том случае, если у некоторых приложений возникают неполадки с выводом на экран и есть причины подозревать, что приложение устанавливает недопустимую частоту обновления.

Чтобы переопределить частоту обновления

  1. На странице Если ничего не помогло нажмите кнопку Частота.
  2. В диалоговом окне Частота обновления экрана выберите параметр Другое значение и введите частоту обновления, допустимую для используемого монитора.
  3. Нажмите кнопку ОК.

Чтобы отменить переопределение частоты обновления и позволить приложениям DirectDraw задавать собственную частоту обновления

  1. На странице Если ничего не помогло нажмите кнопку Частота.
  2. В диалоговом окне Частота обновления экрана выберите параметр По умолчанию.


Сохранение сведений

Чтобы сохранить сведения

  1. Для сохранение сведений, собранных с помощью средства диагностики Microsoft DirectX, нажмите кнопку Сохранить все сведения.
  2. Данные со всех страниц будут сохранены в файле, имя и положение которого указываются пользователем. Для сохранения в файле формата XML в списке Тип файла выберите тип Файл XML (*.xml).

* Примечание

  • Кроме того, сохранить сведения можно с помощью командной строки:

    dxdiag [/x выходной_файл] [/t выходной_файл]

    В этой команде параметр /x задает запись данных в файл XML, параметр /t задает запись в текстовый файл, а значение выходной_файл указывает имя и положение этого файла.


Проверка цифровых подписей WHQL

Если при проверке окажется, что драйверы имеют цифровую подпись WHQL (Microsoft Windows Hardware Quality Labs), средство диагностики DirectX может попытаться установить соединение через Интернет для загрузки новых сертификатов WHQL. При этом никакие данные с вашего компьютера не извлекаются. При первом запуске средства диагностики пользователю предлагается разрешить или запретить подключение к Интернету. Этот вопрос будет задан только один раз. Чтобы изменить ранее выбранный режим проверки, перейдите на страницу Система и установите или снимите флажок Проверять цифровые подписи WHQL.

То же самое можно сделать с помощью командной строки:

dxdiag [/whql:on] [/whql:off]

В этой команде параметр /whql:on разрешает проверку цифровых подписей WHQL средством диагностики DirectX, а параметр /whql:off запрещает такую проверку.