Общие сведения о редакторе личных символов

С помощью редактора личных символов (PCE) можно создать до 6 400 уникальных символов (например, специальные буквы и эмблемы) для использования в имеющейся библиотеке шрифтов. PCE содержит основные инструменты для создания и изменения символов, а также дополнительные возможности.

Откройте редактор личных символов.

Примечания

  • XOX
  • Личные символы можно связать со всеми шрифтами в библиотеке шрифтов (чтобы они отображались любым выбранным шрифтом) либо только с указанными шрифтами (чтобы они отображались лишь определенным шрифтом).
  • В диалоговом окне Выбор кода можно просмотреть весь набор личных символов. В этом окне отображаются миниатюрные изображения всех личных символов и соответствующие им шестнадцатеричные значения.
  • Если требуется создать личный символ на основе существующего, следует либо скопировать существующий символ в область «Редактирование» и изменить его нужным образом, либо отобразить в окне «Образец» рядом с областью «Редактирование» и использовать в качестве визуального образца. В качестве основы может служить любой символ из любого установленного шрифта.
  • По умолчанию символы, создаваемые в PCE, относятся к набору символов Юникод. Если в системе установлен один из азиатских языков ввода (китайский, японский или корейский), в PCE будут доступны также наборы символов Windows.

См. также


Создание личных символов с использованием средств рисования

Для рисования и изменения личного символа в области Редактирование можно использовать следующие инструменты и возможности.

Действие | Выполните следующее действие
Рисование символа | В меню Инструменты укажите на команду Элемент и выберите инструмент рисования либо нажмите соответствующую кнопку на панели инструментов. Рисование осуществляется перетаскиванием указателя мыши в области Редактирование.
Выделение всего изображения или его части | Выберите в меню Инструменты команду Элемент, а затем — Выделение прямоугольника или Выделение произвольной формы, либо нажмите соответствующую кнопку на панели инструментов. Выделение всего изображения или его части осуществляется перетаскиванием указателя мыши в области Редактирование.
Перемещение выделенного фрагмента | Щелкните выделенный фрагмент и перетащите его в новое место.
Изменение размеров выделенного фрагмента | Щелкните сторону или угол выделенного фрагмента и перетащите границу.
Отражение и поворот изображения или выделенного фрагмента | В меню Инструменты выберите команду Отразить/повернуть. Выберите направление, в котором требуется отразить или повернуть изображение или его фрагмент, и нажмите кнопку ОК.
Изменение выделенного фрагмента | В меню Правка выберите команду Вырезать, Копировать, Вставить или Удалить.
Отмена действия | Выберите в меню Правка команду Отменить.
Копирование символа в область Редактирование. | В меню Правка выберите команду Копировать символ. Выберите символ, который требуется скопировать, и нажмите кнопку ОК.
Отображение существующего символа в окне Образец рядом с областью Редактирование в качестве визуального образца. | В меню Окно выберите команду Образец. В диалоговом окне Образец выберите нужный символ и нажмите кнопку ОК.
Копирование символа или его части из окна Образец в область Редактирование | В меню Окно выберите команду Образец. В диалоговом окне Образец выберите нужный символ и нажмите кнопку ОК. В области Редактирование с помощью перетаскивания выделите для копирования все изображение символа или его часть. В меню Правка выберите команду Копировать. Щелкните заголовок области редактирования, а затем выберите в меню Правка команду Вставить. Перетащите вставленный элемент в нужное место и отпустите его, щелкнув в любом месте области редактирования.
Скрытие и отображение сетки | В меню Вид выберите команду Сетка.
Отображение структуры изображения для просмотра символа как установленного шрифта | В меню Вид выберите команду Показать структуру.


Использование панели инструментов для создания личных символов

Панель инструментов, расположенная у левого края окна Редактор личных символов, содержит различные инструменты для создания и изменения личных символов.

Действие | Инструмент
Рисование тонкой произвольной линии | Карандаш
Рисование толстой произвольной линии | Кисть
Рисование прямой линии | Прямая линия
Рисование незаполненного прямоугольника | Прямоугольник
Рисование заполненного прямоугольника | Заполненный прямоугольник
Рисование незаполненного эллипса | Эллипс
Рисование заполненного эллипса | Заполненный эллипс
Выделение прямоугольного фрагмента для изменения | Выделение прямоугольника
Выделение фрагмента произвольной формы для изменения | Выделение произвольной формы
Стирание частей изображения | Резинка

Примечания

  • Чтобы скрыть или показать панель инструментов, выберите в меню Вид команду Панель инструментов. Установленный флажок означает, что панель инструментов отображается.
  • Чтобы выбрать инструмент, когда панель инструментов скрыта, выберите в меню Инструменты команду Элемент, а затем щелкните название нужного инструмента.


Сохранение личного символа

Рисунок Microsoft Windows

Чтобы сохранить личный символ

  • Чтобы сохранить личный символ под шестнадцатеричным кодом, показанным на панели описания, выберите в меню Правка команду Сохранить символ.
  • Чтобы сохранить личный символ под другим шестнадцатеричным кодом, выберите в меню Правка команду Сохранить символ как.


Смена шрифта, с которым связан личный символ

Чтобы сменить шрифт, с которым связан личный символ

  1. Запустите редактор личных символов (если это еще не сделано) и нажмите кнопку Отмена, чтобы закрыть диалоговое окно Выбор кода.
  2. В меню Файл выберите команду Связи шрифтов.
  3. Выполните одно из следующих действий:
    • чтобы связать личный символ со всеми шрифтами, установленными на компьютере, выберите вариант Установить связь со всеми шрифтами и нажмите кнопку OK;
    • чтобы связать личный символ с определенным шрифтом из числа установленных на данном компьютере, выберите вариант Установить связь с выбранными шрифтами, выберите нужный шрифт, нажмите кнопку Сохранить как, введите имя файла шрифта личных символов и нажмите кнопку Сохранить. Нажмите кнопку OK.

Примечание

  • XOX


Удаление личного символа

Чтобы удалить личный символ

  1. Запустите редактор личных символов, если он еще не запущен. Будет автоматически открыто диалоговое окно Выбор кода. Если редактор личных символов уже запущен, для открытия диалогового окна Выбор кода выберите в меню Правка команду Выбрать код.
  2. Нажмите кнопку, соответствующую символу, который требуется удалить, и нажмите кнопку ОК.
  3. В меню Инструменты выберите команду Элемент, а затем — Выделение прямоугольника.
  4. В области Редактирование перетащите указатель мыши, чтобы нарисовать прямоугольник вокруг символа.
  5. В меню Правка выберите команду Удалить.
  6. В меню Правка выберите команду Сохранить символ.

Примечание

  • XOX


Просмотр сведений на панели описания

Панель описания расположена под меню в окне редактора личных символов. На панели описания отображаются следующие сведения.

Набор символов. Текущий набор символов, которому соответствует личный символ. Чаще всего используется набор символов Юникод. Однако если в системе установлен один из азиатских языков ввода (китайский, японский или корейский), будут доступны также наборы символов Windows.

Код. Шестнадцатеричный код, назначенный личному символу.

Шрифт. Имя связанного шрифта или указание на связь со всеми шрифтами. Показывает, будет ли отображаться данный личный символ только в указанном шрифте или во всех шрифтах.

Файл. Имя файла для данного личного символа. Если личный символ связан со всеми шрифтами, установленными в системе, по умолчанию используется имя файла Eudc.tte. Если данный символ связан лишь с определенным шрифтом, имя файла задается пользователем.

Примечание

  • Чтобы скрыть или показать панель описания, выберите в меню Вид команду Панель описания. Установленный флажок означает, что панель описания отображается.


Отображение области редактирования

Чтобы отобразить область редактирования

  1. Запустите редактор личных символов (если он еще не запущен). Будет автоматически открыто диалоговое окно Выбор кода. Если редактор личных символов уже запущен, для открытия диалогового окна Выбор кода выберите в меню Правка команду Выбрать код.
  2. В диалоговом окне Выбор кода выберите поле символа, который требуется создать или изменить, и нажмите кнопку ОК. Чтобы создать новый символ, выберите пустое поле.

Примечание

  • XOX


Просмотр набора личных символов

Чтобы просмотреть набор личных символов

  • Запустите редактор личных символов (если он еще не запущен). Будет автоматически открыто диалоговое окно Выбор кода. Если редактор личных символов уже запущен, для открытия диалогового окна Выбор кода выберите в меню Правка команду Выбрать код.

Примечание

  • XOX


Последовательный просмотр личных символов

Чтобы последовательно просмотреть личные символы

  1. Запустите редактор личных символов (если это еще не сделано) и закройте диалоговое окно Выбор кода, нажав кнопку Отмена.
  2. Просмотрите символы с помощью следующих двух команд:
    • чтобы просмотреть набор личных символов в порядке их отображения в окне Выбор кода, выберите в меню Вид команду Следующий код;
    • чтобы просмотреть набор личных символов в порядке, обратном порядку их отображения в окне Выбор кода, выберите в меню Вид команду Предыдущий код.

Примечания

  • XOX
  • Отображаются только личные символы, связанные со шрифтом, название которого показано на панели описания.


Использование личных символов в программах типа «Блокнот»

Чтобы использовать личные символы в программах типа «Блокнот»

  1. Откройте таблицу символов.
  2. В списке Шрифт выберите шрифт, с которым связаны нужные личные символы.

    В скобках после имени шрифта должно быть написано личные символы. Например, если личные символы связаны со шрифтом Times New Roman, выберите пункт Times New Roman (личные символы). Если личные символы связаны со всеми шрифтами, выберите пункт Все шрифты (личные символы).

  3. Выберите нужный личный символ, нажмите кнопку Выбрать, а затем — кнопку Копировать.
  4. Откройте программу, в которой требуется использовать личный символ. Для примера можно открыть программу Блокнот.
  5. Выберите в меню Формат программы «Блокнот» команду Шрифт, а затем — шрифт, с которым связан нужный личный символ.

    6. Этот шрифт должен совпадать со шрифтом, выбранным в шаге 2.

  6. В меню Правка программы «Блокнот» выберите команду Вставить.

    7. В документ программы «Блокнот» будет вставлен выбранный личный символ.

Примечание

  • XOX