Дата компиляции

 Дата компиляции 01.09.2001


Интерфейс EFI

Расширяемый интерфейс микропрограмм (Extensible Firmware Interface, EFI) — новый тип интерфейса между микропрограммым обеспечением, оборудованием и операционной системой компьютера. Он используется на компьютерах с процессором Intel Itanium для загрузки и запуска Windows XP 64-Bit Edition. EFI выполняет на компьютерах с процессором Itanium те же функции, что и базовая система ввода-вывода на компьютерах с процессорами x86, обладая при этом следующими дополнительными возможностями:

  • единообразный способ запуска любой совместимой операционной системы;
  • легкое добавление драйверов EFI для новых загрузочных устройств без необходимости обновления микропрограммного (записанного в ПЗУ) обеспечения компьютера.

Благодаря EFI, компьютер с процессором Itanium может иметь жесткие диски с форматом разделовGPT (GUID partition table — таблица разделов с кодами GUID) и MBR (master boot record — основная загрузочная запись). Однако для загрузки и запуска Windows XP 64-Bit Edition при помощи EFI, эта операционная система должна размещаться на GPT-диске. В смешанной среде, включающей GPT- и MBR-диски, последние используются исключительно для хранения данных.

Любой компьютер с процессором Itanium должен иметь по крайней мере один GPT-диск с системным разделом EFI. Подобно системному тому компьютера с процессором x86, системный раздел EFI содержит загрузчик ОС, драйверы и другие файлы, необходимые для запуска Windows XP 64-Bit Edition. В компьютере с единственным GPT-диском системный раздел EFI является первым разделом на диске.

Системный раздел EFI форматируется для FAT и содержит в корневом каталоге каталог EFI. Windows XP 64-Bit Edition создает подкаталог \Microsoft\Winnt50. Кроме того, в разделе могут присутствовать другие подкаталоги, создаваемые поставщиками операционных систем, ИВТ, поставщиками BIOS и прочими поставщиками. Подкаталог \Msutil содержит программы, используемые микропрограммами EFI и операционной системой. Такие программы и содержимое системного раздела EFI доступны с помощью диспетчера загрузки EFI. Содержимое подкаталога \Microsoft\Winnt50 доступно только для уполномоченных сотрудников служб технической поддержки.

Дополнительные сведения о GPT см. в разделе Таблица GPT. Дополнительные сведения об EFI см. в документации изготовителя, входящей в комплект поставки вашего компьютера, или на веб-узле Intel.

XOX


Таблица GPT

В компьютерах с процессором Intel Itanium для организации взаимодействия микропрограммного (записанного в ПЗУ) обеспечения, оборудования и ОС вместо системы BIOS используется интерфейс EFI (Extensible Firmware Interface — расширяемый интерфейс микропрограмм). EFI включает новый формат разбиения диска на разделы — GPT (GUID partition table — таблица разделов с кодами GUID).

По сравнению с форматом MBR (master boot record — основная загрузочная запись), позволяющим создавать тома размером до 2 терабайт и до 4 основных разделов на диске (либо 3 основных раздела и один дополнительный с неограниченным числом логических дисков), GPT поддерживает тома размером до 18 эксабайт и до 128 разделов на диске. В отличие от дисков с MBR, метаданные платформы находятся в разделах, а не в неразмеченных или скрытых секторах. Кроме того, диски с GPT имеют резервные основную и архивную таблицы разделов, повышающие сохранность данных структуры разделов.

В оснастке «Управление дисками» диски с таблицей разделов с кодами GUID называются GPT-дисками, а диски с основной загрузочной записью — MBR-дисками. На GPT-дисках можно выполнять такие же задачи, как и на MBR-дисках, с учетом перечисленных далее исключений.

  • GPT-диски поддерживаются только Windows XP 64-Bit Edition. Нельзя переместить GPT-диск на компьютер, работающий под управлением 32-разрядной версии Windows XP. В оснастке «Управление дисками» на компьютере с 32-разрядной версией Windows XP GPT-диск отображается как базовый MBR-диск с одним разделом, занимающим весь диск, однако данные на таком диске остаются недоступными.
  • Загрузчик операционной системы и загрузочный раздел должны находиться на GPT-диске. Остальные диски в системе могут быть либо MBR-дисками, либо GPT-дисками.
  • В единую группу динамического диска могут входить как MBR-диски, так и GPT-диски. Кроме того, можно сочетать базовые GPT-диски и MBR-диски при условии, что они не входят в группы дисков.
  • Преобразование из MBR-диска в GPT-диск (и наоборот) возможно только для пустого диска.
  • Таблица GPT не может использоваться на съемных носителях, съемных дисках с интерфейсом USB или IEEE 1394 (также называется FireWire) и на дисках кластера, подключенных к общей шине SCSI или Fibre Channel, используемой службой кластеров.

Разделы на базовых GPT-дисках создаются с помощью микропрограммы diskpart.efi, программы командной строки diskpart.exe или оснастки «Управление дисками» в Windows XP 64-Bit Edition.

При реализации плана аварийного восстановления системы для воссоздания GPT-диска см. документацию изготовителя, входящую в комплект поставки вашего компьютера.

Дополнительные сведения о программе DiskPart.exe см. в разделе DiskPart. Дополнительные сведения об оснастке «Управление дисками» см. в разделе Управление дисками. Дополнительные сведения о микропрограмме diskpart.efi см. на веб-узле Intel.

Дополнительные сведения об управлении GPT- и MBR-дисками см. в разделе Интерфейс EFI.

XOX