HyperTerminal

Программа HyperTerminal служит для подключения к другим компьютерам, узлам Telnet, электронным доскам объявлений (BBS), интерактивным службам или ведомому компьютеру с помощью модема или нуль-модемного кабеля.

  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Сведения общего характера находятся в разделе Основные понятия.
  • Инструкции по устранению неполадок содержатся в разделе Устранение неполадок.


Инструкции

  • Создание подключения
  • Изменение параметров повторного набора
  • Изменение параметров порта модема
  • Изменение параметров подключения
  • Вызов удаленного компьютера с помощью сохраненного подключения
  • Отправка файла на удаленный компьютер
  • Ожидание или прекращение ожидания вызова с помощью программы HyperTerminal
  • Получение файла с удаленного компьютера
  • Проверка модема в программе HyperTerminal
  • Сохранение поступающих данных в текстовом файле
  • Изменение размера буфера
  • Изменение числа строк и столбцов
  • Прекращение использования программы HyperTerminal в качестве клиента telnet


Создание подключения

Рисунок Microsoft Windows

Чтобы создать новое подключение

С помощью интерфейса Windows

  1. Запустите программу HyperTerminal.
  2. В меню Файл выберите команду Новое подключение.
  3. В поле Название введите описательное название подключения.
  4. В поле Значок выберите подходящий значок и нажмите кнопку ОК.
  5. В диалоговом окне Подключение выберите порт или модем в раскрывающемся списке Подключаться через.
  6. Введите сведения для набора телефонного номера при подключении с помощью модема или адрес узла и номер порта при подключении по протоколу TCP/IP (Winsock), а затем нажмите кнопку OK.
  7. Если для вызова используется модем и требуется изменить параметры набора номера, нажмите кнопку Параметры, внесите нужные изменения и нажмите кнопку ОК.
  8. Если используется модем, для выполнения вызова нажмите кнопку Набрать номер.

Примечания

  • XOX

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Перейдите на том, на котором установлена операционная система, и введите: cd Program Files\Windows NT, а затем нажмите клавишу ENTER.
  3. Введите

    hypertrm.exe/t <адрес telnet>[:<порт>]

Значение | Описание
адрес telnet | Адрес подключения, которое требуется создать
порт | Номер порта (по умолчанию 23), который требуется использовать для подключения

Примечания

  • XOX

См. также


Изменение параметров повторного набора

Чтобы изменить параметры повторного набора номера

  1. Запустите программу HyperTerminal.
  2. В меню Файл выберите команду Свойства, а затем откройте вкладку Подключение.
  3. Установите или снимите флажок Перезвонить, если занято в зависимости от того, что требуется сделать.

Примечания

  • XOX


Изменение параметров порта модема

Чтобы изменить параметры порта модема

  1. Запустите программу HyperTerminal.
  2. Выберите в меню Файл команду Свойства.
  3. На вкладке Подключение нажмите кнопку Настроить.
  4. Измените параметры на вкладках Общие и Дополнительные параметры связи. Нажмите кнопку OK. Затем еще раз нажмите кнопку OK.

Примечания

  • XOX
  • Данная процедура применяется только к подключениям с использованием модема или последовательного (COM) порта.
  • Описанные выше действия изменяют параметры порта только для выбранного соединения.
  • Обычно при установке модема все его параметры определяются правильно и их не следует изменять. Тем не менее, для некоторых подключений требуется изменение параметров порта. Например, для подключения к какому-либо серверу может потребоваться отключить сжатие данных или снизить скорость передачи данных через порт. Для получения справки по какому-либо элементу диалогового окна Предпочтения подключения щелкните этот элемент правой кнопкой мыши и выберите команду Что это такое?

См. также


Изменение параметров подключения

Чтобы изменить параметры подключения

  1. Запустите программу HyperTerminal.
  2. Выберите в меню Файл команду Свойства.
  3. Просмотрите и измените нужным образом параметры на вкладках Подключение и Параметры.

Примечания

  • XOX

См. также


Вызов удаленного компьютера с помощью сохраненного подключения

Чтобы вызвать удаленный компьютер с помощью сохраненного подключения

  1. Запустите программу HyperTerminal.
  2. В меню Файл выберите команду Открыть.
  3. В поле Имя файла введите или выберите имя сохраненного сеанса.
  4. Нажмите кнопку Открыть, а затем — кнопку Набрать номер.

Примечание

  • XOX
  • Файлы сеансов сохраняются с расширением HT. По умолчанию подключения сохраняются в папке «Documents and Settings\user name\Start Menu\Programs\Accessories\Communications\HyperTerminal».

См. также


Отправка файла на удаленный компьютер

Чтобы отправить файл на удаленный компьютер

  1. Запустите программу HyperTerminal.
  2. В меню Передача выберите команду Отправить файл или Отправить текстовый файл, в зависимости от типа файла, который требуется отправить.
  3. В поле Имя файла введите путь к файлу и его имя.
  4. В списке Протокол выберите протокол, по которому требуется отправить файл.
  5. Нажмите кнопку Отправить.

Примечания

  • XOX
  • Перед выполнением этой процедуры необходимо иметь подключенный сеанс HyperTerminal.
  • В большинстве случаев требуется подготовить программное обеспечение удаленного компьютера для правильного приема файлов. Для получения дополнительных сведений обратитесь к администратору удаленного компьютера.

См. также


Ожидание или прекращение ожидания вызова с помощью программы HyperTerminal

Чтобы дождаться вызова или прекратить ожидание вызова с помощью программы HyperTerminal

  1. Запустите программу HyperTerminal.
  2. В меню вызов выберите команду Ждать звонка или Отменить ожидание, в зависимости от того, что требуется сделать.

Примечания

  • XOX
  • По умолчанию в программе HyperTerminal не принимаются входящие вызовы, поэтому при необходимости требуется включать этот режим вручную.
  • При отключении вызова необходимо всегда следовать данной процедуре для включения ожидания следующего вызова.

См. также


Получение файла с удаленного компьютера

Чтобы принять файл с удаленного компьютера

  1. Отправьте файл на свой компьютер с помощью программного обеспечения для модема удаленного компьютера.
  2. Запустите программу HyperTerminal.
  3. В меню Передача выберите команду Принять файл.
  4. В поле Поместить принятый файл в каталог введите путь к папке, в которой требуется сохранить загруженный файл.
  5. В списке Протокол приема выберите протокол, по которому удаленный компьютер передает файл, а затем нажмите кнопку Принять.

Примечания

  • XOX
  • Перед выполнением этой процедуры необходимо иметь подключенный сеанс HyperTerminal.
  • Если удаленный компьютер использует для передачи данных протокол Zmodem, данную процедуру выполнять не требуется, поскольку файлы по протоколу Zmodem программа HyperTerminal принимает автоматически.

См. также


Проверка модема с помощью программы HyperTerminal

Чтобы проверить модем с помощью программы HyperTerminal

  1. Запустите программу HyperTerminal.
  2. Выберите в меню Файл команду Свойства.
  3. На вкладке Подключение выберите в поле Подключаться через модем, который требуется проверить, и нажмите кнопку OK.
  4. В меню Файл выберите команду Новое подключение.
  5. В диалоговом окне Описание подключения нажмите кнопку Отмена.
  6. В окне программы HyperTerminal введите ate1 и нажмите клавишу ENTER.

    Если модем работает правильно, в окне появится ответ OK или 0.

    Если после выполнения проверки модема в окне программы HyperTerminal не появится ответа OK или 0, значит, модем работает неправильно. Воспользуйтесь средством устранения неполадок модема либо обратитесь за помощью к изготовителю модема.

Примечания

  • XOX
  • В зависимости от настроек компьютера введенные символы ate1 могут не отображаться.

См. также


Сохранение поступающих данных в текстовом файле

Чтобы сохранять поступающие данные в текстовом файле

  1. Запустите программу HyperTerminal.
  2. В меню Передача выберите команду Запись протокола в файл или, для отправки текстового файла непосредственно на принтер, команду Направить протокол на принтер.
  3. В поле Файл введите описательное имя файла протокола и нажмите кнопку Начало.

Примечания

  • XOX
  • При сохранении поступающих данных в текстовом файле или отправке этих данных на принтер программа HyperTerminal записывает все данные, передаваемые в ходе сеанса подключения. Отбор данных в программе HyperTerminal невозможен.

См. также


Изменение размера буфера

Чтобы изменить размер буфера

  1. Запустите программу HyperTerminal.
  2. В меню Файл выберите команду Свойства и откройте вкладку Параметры.
  3. В поле Размер буфера (строк) введите число строк текста, которые требуется сохранять помимо отображаемых на экране, и нажмите кнопку OK.

Примечания

  • XOX
  • Максимальный размер буфера составляет 500 строк.

См. также


Изменение числа строк и столбцов

Чтобы изменить число строк и столбцов

  1. Запустите программу HyperTerminal.
  2. Выберите в меню Файл команду Свойства.
  3. Откройте вкладку Параметры. В раскрывающемся списке Эмуляция терминала выберите VT100 или VT100J.
  4. Нажмите кнопку Настройка и измените параметры нужным образом. Нажмите кнопку OK. Затем еще раз нажмите кнопку OK.

Примечания

  • XOX
  • Данная процедура действует только при эмуляции терминала VT100 или VT100J.

См. также


Прекращение использования программы HyperTerminal в качестве клиента telnet

Чтобы прекратить использование программы HyperTerminal в качестве клиента telnet

  1. Откройте папку Мой компьютер.
  2. В меню Сервис выберите команду Свойства папки.
  3. На вкладке Типы файлов прокрутите список зарегистрированных типов файлов до значения URL: Протокол Telnet.
  4. Выделите строку URL: Протокол Telnet и нажмите кнопку Дополнительно.
  5. В поле Действия выделите open и нажмите кнопку Изменить.
  6. Удалите содержимое поля Приложение, исполняющее действие и введите:

    rundll32.exe url.dll,TelnetProtocolHandler %l

  7. Закройте диалоговые окна, нажимая кнопку OK для сохранения указанных параметров.

Примечание

  • XOX


Основные понятия

Данный раздела содержит сведения общего характера о программе HyperTerminal.

  • Общие сведения о программе HyperTerminal
  • Общее представление о программе HyperTerminal


Общие сведения о программе HyperTerminal

Программа HyperTerminal служит для подключения к другим компьютерам, узлам Telnet, электронным доскам объявлений (BBS), интерактивным службам или ведомому компьютеру с помощью модема, нуль-модемного кабеля или подключения Ethernet.

Доступ к BBS с помощью программы HyperTerminal становится менее популярным с распространением Интернета, но данная программа остается удобным средством для настройки и проверки используемого модема или для проверки состояния подключения к другим узлам. Дополнительные сведения см. в разделе Создание подключения.

Программа HyperTerminal записывает сообщения, передаваемые компьютером или службой с другой стороны подключения в обоих направлениях. Таким образом, она может быть удобным средством устранения неполадок при настройке и использовании модема. Чтобы убедиться в правильном подключении модема или просмотреть его параметры, отправьте команду в окне программы и проверьте результат. Программа HyperTerminal также обладает возможностью обратной прокрутки, позволяющей просматривать текст, прокрученный за пределы экрана.

С помощью программы HyperTerminal можно передавать большие файлы с компьютера на переносной компьютер через последовательный порт, вместо того чтобы настраивать переносной компьютер для подключения к сети. Дополнительные сведения см. в разделе Отправка файла на удаленный компьютер.

Программу HyperTerminal можно использовать для отладки исходного текста программ с удаленного терминала. Кроме того, программу HyperTerminal можно использовать для связи с устаревшими компьютерами с текстовым интерфейсом.

Программа HyperTerminal разработана как простой в использовании инструмент и не призвана заменить другие полнофункциональные средства. С помощью программы HyperTerminal можно выполнять описанные выше задачи, но не следует использовать ее для более сложных коммуникаций. Дополнительные сведения о функциях, поддерживаемых и не поддерживаемых программой HyperTerminal, можно найти в ответах на часто задаваемые вопросы на веб-узле Hilgraeve

XOX


Общее представление о программе HyperTerminal

В этом разделе

  • Общее представление о подключениях программы HyperTerminal
  • Общее представление о передаче файлов в программе HyperTerminal


Общее представление о подключениях программы HyperTerminal

Программа HyperTerminal допускает создание и сохранение нескольких подключений. Каждое подключение должно иметь уникальную конфигурацию, включая телефонный номер и параметры порта, такие как скорость передачи данных и проверка четности.

Как часть конфигурации подключения программа HyperTerminal также позволяет эмулировать различные типы терминалов, например терминалы TTY.

Текущее подключение, открытое в программе HyperTerminal, отображается в строке заголовка окна программы HyperTerminal.

В течение каждого сеанса программы HyperTerminal можно использовать только одно подключение. Однако можно запустить несколько сеансов программы HyperTerminal, открыв в каждом из них новое подключение (при условии, что каждое подключение использует отдельный порт). Сведения о настройке нового подключения см. в разделе Создание подключения.

При первом запуске программы HyperTerminal выводится приглашение использовать программу HyperTerminal в качестве клиента telnet по умолчанию. Также предоставляется возможность отключить повторный вывод диалогового окна приглашения. Если после отключения повторного вывода этого приглашения требуется изменить режим использования программы HyperTerminal в качестве клиента telnet по умолчанию, см. раздел Устранение неполадок.

Программа HyperTerminal не может автоматически предоставлять имя и пароль пользователя при установке подключения.


Общее представление о передаче файлов в программе HyperTerminal

С помощью программы HyperTerminal можно обмениваться текстом и файлами данных с удаленным компьютером. Состояние текущего процесса передачи отображается в окне программы HyperTerminal. Сведения о состоянии передаваемого файла также можно записать и отправить непосредственно на принтер. Дополнительные сведения см. в разделе Сохранение сеанса HyperTerminal в текстовом файле.

Сведения об отправке файла см. в разделе Отправка файла на удаленный компьютер. Сведения о получении файла см. в разделе Получение файла с удаленного компьютера.

Изменить размеры окна программы HyperTerminal для увеличения или уменьшения объема отображаемых сведений невозможно.


Устранение неполадок

Вид неполадки

Требуется использовать программу HyperTerminal в качестве клиента telnet по умолчанию, но соответствующее приглашение при запуске программы HyperTerminal не выводится

Причина. При первом выводе приглашения использовать программу HyperTerminal в качестве клиента telnet по умолчанию была нажата кнопка Нет и установлен флажок Больше не задавать этот вопрос

Решение. Откройте редактор реестра. В редакторе реестра перейдите в следующий раздел и измените его значение на 1:

HKEY_LOCAL_USER\Software\Microsoft\HyperTerminal\Telnet Check.

При следующем запуске программы HyperTerminal после изменения данного значения будет выведено диалоговое окно с приглашением использовать программу HyperTerminal в качестве клиента telnet по умолчанию.

Примечания

  • XOX

Внимание!

  • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных. Если после внесения изменений возникли неполадки, при запуске системы выберите вариант Загрузка последней удачной конфигурации.

При развертывании окна программы HyperTerminal на весь экран размер окна терминала не изменяется

Причина. Размер экрана терминала в программе HyperTerminal определяется используемым размером шрифта. Независимо от выбранного шрифта в окне отображается 24 строки по 80 (или 132) символа.

Решение. В меню Вид программы HyperTerminal выберите команду Шрифт. Если требуется увеличить окно терминала, выберите больший размер шрифта. Если требуется уменьшить окно терминала, выберите меньший размер шрифта.

Вводимые сведения не отображаются в окне терминала программы HyperTerminal

Причина. В окне терминала отображаются сведения с удаленного компьютера, а не сведения, вводимые на локальном компьютере. Для просмотра вводимых сведений следует настроить удаленный компьютер для обратной передачи вводимых сведений. Кроме того, при отображении вводимых сведений в окне терминала вводимые сведения могут отображаться с задержкой.

Решение. Убедитесь, что подключение к удаленному компьютеру установлено правильно и удаленный компьютер настроен для обратной передачи вводимых сведений.

Символы ANSI не отображаются должным образом

Причина. Используется шрифт, отличный от шрифта Terminal.

Решение. В меню Вид программы HyperTerminal выберите команду Шрифт. Выберите шрифт Terminal и нажмите кнопку OK.

Программа HyperTerminal не повторяет набор номера, когда линия занята

Причина. Возможно, флажок Перезвонить, если занято не установлен.

Решение. В меню Файл программы HyperTerminal выберите команду Свойства. Откройте вкладку Подключение и убедитесь, что флажок Перезвонить, если занято установлен.

После подключения к удаленному компьютеру в окне терминала отображаются бессмысленные данные

Причина. Неправильно выбрана эмуляция терминала.

Решение. В меню Файл программы HyperTerminal выберите команду Свойства. Откройте вкладку Параметры. В раскрывающемся списке Эмуляция терминала выберите тип терминала удаленного компьютера. Если тип терминала удаленного компьютера отсутствует в данном списке, значит он не поддерживается программой HyperTerminal.

Не удается удалить символы из окна терминала

Причина. Управление символами, отображаемыми в окне терминала, осуществляет удаленный компьютер, с которым установлено соединение. Удаленный компьютер ожидает наличия курсора в определенных позициях на экране, исходя из того, что данные уже отправлены на экран. При локальном изменении экрана пользователь мог выполнить действия, не предусмотренные или не управляемые удаленным компьютером, тем самым нарушив взаимодействие с ним. В результате удаление символов с экрана с помощью программы HyperTerminal стало невозможным.

Решение. Отсутствует.

Не удается вставить данные в окно терминала с помощью сочетания клавиш CTRL+V

Причина. Если в свойствах подключения выбран параметр клавиши терминала, по нажатию клавиш CTRL+V отправляется управляющая последовательность эмулятора терминала. Многие узлы используют сочетание клавиш CTRL+V для навигации в системе.

Решение. Выберите вариант клавиши Windows и сочетание клавиш CTRL+V будет работать правильно. Для этого выберите в меню Файл программы HyperTerminal команду Свойства. Откройте вкладку Параметры и установите первый переключатель в положение клавиши Windows.

Важно!

  • При использовании параметра клавиши Windows все нажатия функциональных клавиш, клавиш со стрелками и управляющих клавиш будут обрабатываться локально. Рекомендуется использовать параметр клавиши терминала и выполнять вставку данных с помощью команд меню.

Дополнительные сведения об устранении неполадок и другие сведения можно найти в ответах на часто задаваемые вопросы на веб-узле Hilgraeve

XOX