Дата компиляции

 Дата компиляции 01.09.2001


Ввод символов, отсутствующих на клавиатуре

Рисунок Microsoft Windows

Чтобы ввести символ, отсутствующий на клавиатуре

  1. Нажмите клавишу ALT и, удерживая ее нажатой, наберите на цифровой клавиатуре десятичный код нужного символа.
  2. После завершения ввода, отпустите клавишу ALT.

    3. Windows создаст указанный символ.

Примечания

  • Если первая цифра ввода 0, значение будет распознано как кодовая точка, или значение символа текущего языка ввода. Например, если языком ввода является Английский (США) (кодовая страница 1252: Латинская Windows-1), после ввода 0163 на цифровой клавиатуре при нажатой клавише ALT будет отображен знак фунта — £ (U+00A3). Если языком ввода является Русский (кодовая страница 1251: Windows Windows), после нажатия того же сочетания клавиш на экране отобразится заглавная буква Ј (U+0408).
  • Если первой вводится цифра от 1до 9, значение будет распознано как кодовая точка кодовой страницы OEM системы. Результаты будут различаться в зависимости от языка системы, указанного в компоненте панели управления «Язык и региональные стандарты». Например, если языком ввода является Английский (США), кодовая страница 437 (MS-DOS Латинская США), после ввода 163 на цифровой клавиатуре при нажатой клавише ALT будет отображена строчная буква U с знаком «акут» — ú (U+00FA). Если языком системы является Греческий (кодовая страница OEM 737 MS-DOS Греческий), после нажатия того же сочетания клавиш на экране отобразится строчная греческая буква «мю» (U+03BC).

См. также


Создание документа с использованием нескольких языков

Чтобы создать документ с использованием нескольких языков

  1. Создайте или откройте документ
  2. В области уведомлений щелкните индикатор языка, а затем выберите нужный язык.
  3. Создайте документ.
  4. Для смены языков щелкните индикатор языка в области уведомлений и выберите другой язык из списка.

Примечание

  • Если индикатор языка отсутствует в области уведомлений, нажмите кнопку Пуск, выберите команду Панель управления, а затем дважды щелкните значок Язык и региональные стандарты. На вкладке Языки установите флажок Отображать индикатор на панели задач.

См. также


Вставка управляющего символа Юникода

Чтобы вставить управляющий символ Юникода

  1. В поле щелкните правой кнопкой в том месте текста, в которое предполагается вставить управляющий символ Юникода, а затем выберите команду Вставить управляющий символ Юникода.
  2. Выберите управляющий символ, который требуется вставить.

Примечания

  • Управляющие символы Юникода представляют собой теги, облегчающие выбор направления письма и расположения текста для таких языков как иврит или арабский.
  • Если на компьютере установлено несколько языков, управляющие символы Юникода можно вставлять щелчком правой кнопки мыши на любом элементе управления редактированием в Windows, таком как поле, или при использовании программы «Блокнот».

См. также


Общие сведения о языке и региональных стандартах

С помощью компонента панели управления «Язык и региональные стандарты» можно устанавливать на компьютер несколько языков, например иврит, арабский, японский, корейский и западноевропейские языки (французский, испанский, немецкий и многие другие). Для создания документа можно выбрать любой язык. После того как Windows делает доступным набор символов для выбранного языка, можно приступить к созданию документа.

Для создания документов на других языках можно использовать и программу «Блокнот», и WordPad, но текстовые процессоры предоставляют другие полезные средства для облегчения процесса создания документов на разных языках, такие как проверка орфографии.

При отправке документа на разных языках другому пользователю получатель сможет прочесть или изменить файл только в том случае, если на его компьютере установлены все необходимые языки.

См. также


Установка порядка чтения справа налево

Чтобы установить порядок чтения справа налево

  • В поле щелкните правой кнопкой на месте, с которого предполагается начать чтение справа налево, а затем выберите команду Порядок чтения: справа налево
    • .

Примечания

  • Кроме изменения порядка чтения при этом также производится выравнивание текста по правой части экрана для языков, использующих порядок чтения справа налево, например арабский и иврит.
  • Если на компьютере установлено несколько языков, можно установить порядок чтения справа налево щелчком правой кнопки мыши на любом элементе управления редактированием в Windows, таком как поле, или при использовании программы «Блокнот».

См. также


Отображение управляющих символов Юникода

Чтобы отобразить управляющие символы Юникода

  • Щелкните правой кнопкой мыши в любом месте поля и выберите команду Показать управляющие символы Юникода.
    • .

Примечания

  • Управляющие символы Юникода являются тегами, облегчающими выбор направления письма и расположения текста для таких языков, как иврит и арабский.
  • Если на компьютере установлено несколько языков, управляющие символы Юникода могут отобразить щелчком правой кнопки мыши на любом элементе управления редактированием в Windows, таком как поле, или при использовании программы «Блокнот».

См. также


Управляющие символы Юникода

Управляющие символы Юникода являются тегами, облегчающими выбор направления письма и расположения текста для таких языков, как иврит и арабский. Эти языки устанавливаются в компоненте панели управления «Язык и региональные стандарты».

Эти описания соответствуют стандартам организации Unicode Consortium. См. материалы: The Unicode Standard, Version 2.0. Reading, Massachusetts: Addison-Wesley Developers Press, February 1997.

Отметить слева направо (LRM)

Действует аналогично символам чтения слева направо, но не отображается. Другого семантического воздействия LRM не оказывает

Отметить справа налево (RLM)

Действует аналогично символам чтения справа налево, но не отображается. Другого семантического воздействия RLM не оказывает.

Элемент языка HTML «Zero width joiner» (ZWJ)

Предотвращает объединение последовательных символов при выводе.

Элемент языка HTML «Zero width non-joiner» (ZWNJ)

Вставляет знак, предотвращающий объединение двух символов, как при письме, во время формирования текста.

Начать вставку слева направо (LRE)

Показывает, что часть текста вставлена слева направо. Например, английская цитата в арабском предложении может быть помечена как текст, вставленный слева направо. (LRE влияет на порядок слов, а не на порядок символов.)

Начать вставку справа налево (RLE)

Показывает, что часть текста вставлена справа налево. Например, фраза на иврите в английской цитате может быть помечена как текст, вставленный справа налево. (RLE влияет на порядок слов, а не на порядок символов.)

Начать отмену слева направо (LRO)

Отменяет двунаправленные типы символов. Это бывает необходимо в некоторых случаях, например для номеров компонентов. LRO жестко фиксирует направление письма слева направо для всех символов

Начать отмену справа налево (RLO)

Отменяет двунаправленные типы символов. Это бывает необходимо в некоторых случаях, например для номеров компонентов. RLO жестко фиксирует направление письма слева направо для всех символов.

Направленное форматирование (PDF)

Отменяет последствия применения последнего кода (вставки или отмены) и возвращает двунаправленный режим в состояние, предшествующее применению последнего управляющего символа LRE, RLE, RLO или LRO.

Замена национального написания цифр (NADS)

Отображает символы с U+0030 по U+0039 (цифры ASCII) при помощи национального написания цифр. Национальное написание цифр определяется текущим языком пользователя.

Обычное (европейское) написание цифр (NODS)

Отображает символы с U+0030 по U+0039 (цифры ASCII) при помощи обычного написания цифр. Обычным считается западное написание цифр.

Разрешить симметричную подкачку (ASS)

Указывает, нужно ли интерпретировать термин "Левый" или "Правый" в парных именах символов (например, для круглых скобок) как открывающий или закрывающий, соответственно. (По умолчанию разрешено)

Запретить симметричную подкачку (ISS)

Выключает симметричную подкачку таких символов, как круглые скобки. После этого правый и левый будет означать только написание символа, в противоположность значению открывающего и закрывающего символа при включенной симметричной подкачке.

Разрешить написание арабских символов (AAFS)

Управляет поведением написания символов, совместимых с арабскими. В процессе представления некоторые символы могут быть соединены, как при письме. Коды выбора написания показывают, разрешен или запрещен процесс определения написания символа (выбора образа символа), используемый для эффективного представления. (По умолчанию запрещено)

Запретить написание арабских символов (IAFS)

Запрещает процесс определения написания символа на основе их расположения.

Разделитель записей (RS)

Начинает новую строку после каждого разделителя строк.

Разделитель сегментов (US)

Начинает новый абзац после каждого разделителя абзацев.

См. также