Сбои и неполадки в службе SMTP (Microsoft)

Служба SMTP (Microsoft)

Для передачи и доставки сообщений служба SMTP использует стандартный для Интернета протокол SMTP (Simple Mail Transfer Protocol), описанный в документах RFC 821 и RFC 822. Служба включает также расширение основного набора функций протокола. Предусмотрены возможности для управления маршрутизацией и доставкой сообщений, обеспечивающие безопасность данных.

  • Справку по определенным задачам см. в разделе Инструкции.
  • Общие сведения см. в разделе Основные понятия.
  • Сведения о наблюдении за производительностью служб см. в разделе Сопровождение.
  • Инструкции по разрешению проблем см. в разделе Устранение неполадок.

    • © Корпорация Майкрософт (Microsoft Corp.), 2001. Все права защищены.


Инструкции

В этом разделе перечислены инструкции по настройке и работе со службой SMTP (Microsoft).
  • Использование консоли MMC
  • Запуск консоли MMC
  • Запуск, остановка или приостановка виртуального SMTP-сервера
  • Запуск, остановка или приостановка службы SMTP (Microsoft)
  • Настройка идентификации виртуального SMTP-сервера
  • Настройка типа запуска по умолчанию
  • Создание дополнительных виртуальных SMTP-серверов
  • Настройка подключения
  • Активизация ведения журнала протокола
  • Настройка виртуального сервера для кластеризации
  • Настройка параметров безопасности
  • Управление сообщениями
  • Доставка сообщений
  • Создание или удаление домена
  • Настройка локальных доменов
  • Настройка удаленных доменов


Средства администрирования

Использование консоли MMC

Консоль MMC является средством администрирования службы SMTP. С ее помощью можно выполнять любые задачи администрирования в локальной сети (ЛВС).

На компьютере, где работает служба SMTP, это средство администрирования устанавливается по умолчанию.

Для администрирования службы SMTP с удаленного компьютера при помощи консоли MMC на компьютере, где работает служба SMTP, должна быть установлена система Windows 2000, а на удаленном компьютере - средства администрирования Windows 2000 (пункт «Администрирование» в меню кнопки «Пуск»).

Примечание. Операторы службы SMTP должны иметь соответствующие права доступа. См. также Настройка параметров безопасности.


Запуск консоли MMC

Управлять службой SMTP можно с помощью консоли MMC, установленной на том же компьютере, где работает эта служба.

Примечание. С помощью консоли MMC можно также управлять виртуальным SMTP-сервером с удаленного компьютера, находящегося в одной локальной сети с компьютером, на котором работает служба SMTP. При этом удаленный компьютер должен работать под управлением системы Windows 2000, и на нем должны быть установлены средства администрирования Windows 2000.

Запуск консоли MMC на компьютере с работающей службой SMTP

  1. В меню Пуск выберите команду Настройка, затем выберите Панель управления.
  2. Дважды щелкните пункт Администрирование, затем дважды щелкните пункт Управление компьютером.
  3. В дереве консоли разверните узел Службы и приложения, затем разверните узел Информационные службы Интернета.
  4. Разверните узел службы SMTP (Microsoft).

Примечание. После установки этой службы виртуальному серверу по умолчанию присваивается имя «Виртуальный SMTP-сервер по умолчанию».

Просмотр или изменение свойств виртуального SMTP-сервера

  1. Выделите виртуальный SMTP-сервер, свойства которого нужно изменить.
  2. В меню Действие выберите Свойства.
  3. Перейдите на вкладку с теми параметрами, которые требуется просмотреть или изменить.
  4. Измените требуемые параметры. (См. также раздел Вкладки).


Запуск, остановка или приостановка виртуального SMTP-сервера

Виртуальный SMTP-сервер по умолчанию запускается во время установки службы SMTP (Microsoft). Его можно приостановить, остановить или перезапустить с помощью консоли MMC.

Примечание. Можно также запустить, остановить или приостановить всю службу SMTP. Однако, если создано более одного виртуального сервера, остановка службы скажется на всех виртуальных SMTP-серверах, работающих на данном компьютере. При остановленной службе SMTP нельзя пользоваться консолью управления для администрирования виртуальных SMTP-серверов.

Остановить и запустить службу SMTP можно вручную. Однако останавливать, приостанавливать или перезапускать работающую службу нужно аккуратно, чтобы минимизировать воздействие на пользователей.

Далее описано, как запустить, остановить и приостановить службу SMTP с помощью консоли управления.

  • Запуск виртуального SMTP-сервера
  • Остановка виртуального SMTP-сервера
  • Приостановка виртуального SMTP-сервера


Запуск виртуального SMTP-сервера

Если тип запуска по умолчанию виртуального SMTP-сервера устанавлен Вручную, следует воспользоваться консолью MMC.

  1. Чтобы найти виртуальный SMTP-сервер, разверните структуру компонентов консоли MMC.
  2. Выделите виртуальный SMTP-сервер.
  3. Выберите в меню Действия команду Пуск.


Приостановка виртуального SMTP-сервера

Приостановка виртуального SMTP-сервера применяется для изменения его настройки и сопровождения. Приостановка запрещает подключения новых клиентов, но не останавливает работу виртуального сервера с подключившимися ранее клиентами и не отменяет доставку очередных сообщений.

  1. Чтобы найти виртуальный SMTP-сервер, разверните структуру компонентов консоли MMC.
  2. Выделите виртуальный SMTP-сервер.
  3. В меню Действие выберите команду Пауза.


Остановка виртуального SMTP-сервера

Остановка виртуального SMTP-сервера используется для изменения его настройки и сопровождения.

  1. Чтобы найти виртуальный SMTP-сервер, разверните структуру компонентов консоли MMC.
  2. Выделите виртуальный SMTP-сервер.
  3. В меню Действие выберите команду Остановить.


Запуск, остановка и приостановка службы SMTP (Microsoft)

Служба SMTP является служебной программой сервера Microsoft Windows 2000 Server и запускается после его установки. Несмотря на то, что на компьютере только одна служба SMTP, можно создать несколько виртуальных SMTP-серверов. Можно запустить, остановить или приостановить любой виртуальный сервер вне зависимости от другого, если запущена служба SMTP (Microsoft).

Если заведено несколько виртуальных SMTP-серверов, то важно помнить, что остановка или приостановка всей службы SMTP повлияет на все виртуальные серверы. Когда служба остановлена, нельзя использовать консоль MMC для администрирования виртуальных SMTP-серверов.

Примечание. Единственное исключение состоит в том, что можно запустить виртуальный сервер при остановленной службе SMTP. При запуске виртуального SMTP-сервера перезапустится вся служба SMTP. Это в свою очередь запустит все остальные виртуальные серверы, которые работали в момент остановки службы SMTP.

После запуска служба SMTP принимает новые подключения клиентов. При остановке службы SMTP она перестает принимать новые подключения. При приостановке службы SMTP каждый работающий виртуальный SMTP-сервер приостанавливает принятие новых подключений, но продолжает обслуживать существующие.

Запуск, остановка или приостановка службы SMTP с помощью средств администрирования

  1. В меню Пуск выберите Программы, далее Администрирование и Службы компонентов.
  2. В структуре компонентов консоли MMC выделите компонент Службы (локальные).
  3. В области подробностей щелкните правой кнопкой Служба SMTP (Microsoft), а затем выберите команду Пуск, Остановить или Пауза.
Примечание. При перезапуске службы SMTP все виртуальные серверы, работавшие в момент остановки, автоматически перезапустятся. Если какой-либо виртуальный SMTP-сервер был остановлен до остановки службы, он так и останется остановленным, даже после того, как будет перезапущена служба SMTP.


Настройка идентификации виртуального SMTP-сервера

Для идентификации виртуального SMTP-сервера используется отображаемое имя и комбинация IP-адрес/порт TCP. Во время установки виртуальному SMTP-серверу приписывается по умолчанию имя, отображаемое на консоли MMC. Это имя - «Виртуальный SMTP-сервер по умолчанию» - можно сохранить или изменить. Порядок изменения имени виртуального сервера приведен ниже. Кроме того, можно выбрать для виртуального SMTP-сервера IP-адрес.

Порядок настройки идентификации виртуального SMTP-сервера

  1. В окне консоли MMC выделите виртуальный SMTP-сервер. Перейдите в меню Действия, затем выберите команду Переименовать.
  2. Чтобы изменить принятое по умолчанию имя виртуального сервера, введите его новое имя.

    Примечание. Не используйте в имени виртуального SMTP-сервера символы национальных алфавитов.

  3. Выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  4. В раскрывающемся списке IP-адрес выберите IP-адрес для виртуального сервера. Виртуальный SMTP-сервер может обслуживать запросы на подключение по всем настроенным на данном компьютере IP-адресам. Чтобы определить TCP-порт для каждого IP-адреса виртуального сервера, выберите команду Дополнительная настройка. Рекомендуется использовать порт 25, который является стандартным TCP-портом для SMTP-сервера. Порт 25 может использоваться несколькими виртуальными серверами, если они имеют различные IP-адреса.
Примечание. Для изменения настройки виртуального SMTP-сервера можно использовать команду Пауза. Эта команда запрещает подключения новых клиентов, но не останавливает работу службы SMTP с подключившимися ранее клиентами и не отменяет доставку очередных сообщений.


Настройка типа запуска по умолчанию

Для настройки типа запуска службы SMTP (Microsoft) по умолчанию можно использовать средства администрирования.

  1. В меню Пуск выберите Программы, далее Администрирование и Службы компонентов.
  2. В структуре компонентов консоли MMC выделите компонент Службы (локальные).
  3. В области подробностей щелкните правой кнопкой Служба SMTP (Microsoft), а затем в контекстном меню выберите Свойства.
  4. На вкладке Общие в поле Тип запуска выберите Авто, Вручную или Отключено.


Создание дополнительных виртуальных SMTP-серверов

В большинстве случаев достаточно использовать только один виртуальный SMTP-сервер. Однако, если в связке нескольких доменов требуется задать по умолчанию хотя бы два домена, можно создать несколько виртуальных SMTP-серверов, которые будут рассматриваться пользователем как отдельные серверы с уникальными комбинациями IP-адрес/TCP-порт.

При создании виртуального SMTP-сервера указывается путь к основному каталогу. Этот каталог должен находиться на жестком диске компьютера, на котором запущена служба SMTP (Microsoft).

Порядок создания нового виртуального SMTP-сервера с помощью консоли MMC
  1. Если в новом виртуальном SMTP-сервере нужно задать новый IP-адрес, выберите команду Настройка в меню Пуск, затем выберите команду Сеть и удаленный доступ к сети. См. раздел «Сеть и удаленный доступ к сети» в справке по Windows 2000.
  2. После задания IP-адреса выделите существующий виртуальный SMTP-сервер на консоли MMC. Затем в меню Действие укажите Создать, а затем выберите Виртуальный сервер.
  3. Далее следуйте инструкциям мастера создания виртуального SMTP-сервера. Убедитесь, что выбранная комбинация IP-адрес/TCP-порт не используется другим виртуальным SMTP-сервером. Рекомендуемый мастером порт 25 является стандартным TCP-портом для SMTP-серверов. Несколько виртуальных серверов могут использовать один и тот же TCP-порт, если они имеют различные IP-адреса.
  4. Принятые по умолчанию параметры запуска службы SMTP устанавливаются автоматически, поэтому новый виртуальный SMTP-сервер запускается сам. Если этого не произойдет, значит выбранная комбинация IP-адрес/TCP-порт уже используется на другом сервере.
  5. Настройте новый виртуальный SMTP-сервер.


Настройка подключения

Подключение инициируется при отправке сообщения на удаленный сервер и при получении сообщения с удаленного сервера.

Настройка входящих подключений

Примечание. Назначение порта TCP, используемого службой SMTP (Microsoft) для получения входящих сообщений, происходит при настройке идентификации виртуального сервера SMTP.

Настройка входящих подключений

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Общие установите флажок Ограничить число подключений (по умолчанию - без ограничений) и настройте следующие параметры.

    Параметр | Описание
    Ограничить число подключений | Если этот флажок установлен, действует ограничение на число одновременных подключений для доставки входящих сообщений. Минимальное число подключений равно 1. Когда этот флажок не установлен, число подключений не ограничено.
    Время ожидания (минуты) | Здесь указывается допустимое время существования неактивного подключения. По умолчанию установлено 10 минут.

Настройка исходящих подключений

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доставка нажмите кнопку Исходящие подключения. Откроется диалоговое окно Исходящие подключения.
  3. В группе Исходящие подключения установите флажок (по умолчанию число подключений не ограничено) и настройте следующие параметры.

    Параметр | Описание
    Ограничить число подключений Когда установлен этот флажок, задается общее число одновременных исходящих подключений ко всем удаленным доменам. По умолчанию установлено 1 000 подключений. Минимальное значение равно 1.

    Данный параметр может быть изменен с целью увеличения производительности системы в сочетании с ограничением числа сообщений за сеанс, которое устанавливается на вкладке Сообщения.
    Время ожидания (минуты) | Здесь указывается допустимое время существования неактивного подключения. По умолчанию установлено 10 минут.
    Ограничить число подключений с одного домена | Установка этого флажка ограничивает число подключений к одному удаленному домену. По умолчанию установлено 100 подключений. Это число должно быть не больше значения параметра Ограничить число подключений.
    Порт TCP | Назначает порт TCP, используемый для передачи исходящих сообщений. По умолчанию используется порт 25. Параметры порта исходящих сообщений могут быть теми же, что и параметры порта входящих сообщений, но могут и различаться.

Обзор процессов, задействованных при отправлении почты, см. в разделе Основные понятия.


Активизация ведения журнала протокола

В журналах регистрируются команды, получаемые виртуальным SMTP-сервером по сети от SMTP-клиентов Формат записи данных в журнал, используемый службой SMTP (Microsoft), можно выбрать.

При настройке файла журнала помните, что форматы журналов и имена файлов по умолчанию являются теми же самыми, что используются другими информационными службами Интернета (IIS). Если выбраны имена по умолчанию, то все операции для всех служб регистрируются в одном и том же файле. Если нужно вести записи раздельно, то можно назначить отдельный файл для каждой службы. Если выбирается файл с расположением, отличным от расположения по умолчанию, убедитесь, что он хранится на локальном диске, а не в сети. Кроме того, поскольку журналы используются совместно с IIS, то некоторые из имен не являются специфичными для протокола SMTP.

Подробные сведения о журналах операций и их форматах содержатся в разделе Ведение журналов операций по обработке сообщений.

Активизация ведения журнала, использующего текстовый формат ASCII

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Общие установите флажок Вести журнал.
  3. В списке Формат журнала выберите необходимый формат журнала.
  4. Нажмите кнопку Свойства, а затем на вкладке Общие свойства укажите размер и расположение файла журнала.
  5. Если был выбран расширенный формат файла журнала W3C, перейдите на вкладку Расширенные свойства и выберите элементы, которые нужно отслеживать.

Активизация ведения журнала с использованием формата ODBC

  1. Установите ODBC-совместимую базу данных.
  2. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  3. На вкладке Общие установите флажок Вести журнал.
  4. В списке Формат журнала выберите Ведение журнала ODBC.
  5. Нажмите кнопку Свойства, а затем укажите размер и расположение журнала.


Настройка виртуального сервера для кластеризации

Компонент кластеризации Windows – поставляется с сервером Windows 2000 Advanced Server. Подробнее об установке компонента кластеризации Windows см. в документации по системе Windows 2000.

Серверный кластер – это группа независимых систем компьютера, называемых узлами и работающих вместе как единая система, обеспечивающая доступность клиентам приложений и ресурсов. Серверные кластеры обеспечивают высокий уровень доступа. Высокий уровень доступа кластера SMTP-серверов означает, что если откажет один виртуальный сервер, то его задания распределятся по оставшимся виртуальным серверам кластера, поэтому работа почтовой службы не будет прервана. Кроме того, кластеры серверов полезны при нехватке серверных ресурсов, когда при выключении одного виртуального сервера тут же подключается другой и принимает задание на себя.

Узел в кластеризации – это система, в которой установлены и работают сервер Windows 2000 Advanced Server и служба кластеризации. Рекомендуется создавать новые виртуальные серверы, а не перенастраивать виртуальный SMTP-сервер по умолчанию.

Более подробно о кластеризации Windows и кластерах серверов можно узнать в документации по серверу Windows 2000 Advanced Server. Эта документация содержит подробное описание установки и администрирования серверных кластеров.

Настройка виртуального SMTP-сервера для кластеризации

  1. Если необходимо, измените тип запуска по умолчанию службы SMTP (Microsoft) на режим Вручную.
  2. Перед тем, как создать новый виртуальный сервер, откройте консоль MMC, щелкните правой кнопкой виртуальный SMTP-сервер по умолчанию, затем выберите команду Свойства.
  3. На вкладке Общие нажмите кнопку Дополнительно.
  4. В группе IP-адрес дважды щелкните элемент (все неназначенные).
  5. В диалоговом окне Идентификация измените номер порта TCP с 25 на другой. Будет работать любой неназначенный порт. Важно изменить номер порта, чтобы избежать конфликта с новым виртуальным сервером SMTP, создаваемым для кластеризации. Введите новый номер порта (убедитесь, что он уникален) и нажмите кнопку OK.
  6. Создайте новый виртуальный SMTP-сервер. Созданный сервер нужно запустить вручную. Убедитесь, что новый виртуальный сервер использует порт TCP по умолчанию, 25-й.

    Внимание

    На экране Выберите основной каталог и домен по умолчанию мастера создания виртуального SMTP-сервера не забудьте ввести пути к общим ресурсам, используемым при кластеризации. Не вводите пути к локальным дискам.

  7. Для синхронизации всех данных IIS на узле с другими узлами серверного кластера запустите команду синхронизации IIS. В командной строке перейдите в узле в каталог \WINNT\System32\Inetsrv и введите iissync имя сервера, где имя сервера - это другой узел в серверном кластере. Более подробные сведения о команде синхронизации IIS содержатся в документации по IIS.
  8. После синхронизации узлов кластера может потребоваться проверка номеров портов TCP для созданного виртуального SMTP-сервера и виртуального сервера по умолчанию. При просмотре данного локального узла из других узлов кластера убедитесь, что параметры порта TCP идентичны с теми, что были установлены в данном локальном узле. Во всех узлах виртуальный SMTP-сервер по умолчанию не должен указывать на порт по умолчанию (25), а новому виртуальному SMTP-серверу должен быть назначен порт 25. Чтобы кластеризация работала, параметры должны быть идентичны для каждого узла.
  9. Запустите администратор кластера. Следуйте указаниям мастера и присвойте тип ресурса новому виртуальному серверу SMTP.

    Примечание. Выберите новый виртуальный SMTP-сервер в раскрывающемся списке диалогового окна Parameters, а не виртуальный SMTP-сервер по умолчанию. Более подробные сведения об администраторе кластера можно найти в документации по серверу Windows 2000 Advanced Server.


Настройка параметров безопасности

В этом разделе описываются параметры безопасности виртуального SMTP-сервера.

  • О параметрах безопасности
  • Формирование списка операторов
  • Требование проверки подлинности для входящих подключений
  • Настройка проверки подлинности для исходящих сообщений
  • Требование TLS-шифрования
  • Настройка ограничения доступа к серверу по IP-адресу
  • Отмена ограничений ретрансляции через виртуальный сервер


О параметрах безопасности

Уровень безопасности виртуального SMTP-сервера можно выбирать с помощью двух вкладок безопасности. Параметры этих вкладок применяются ко всем доменам виртуального сервера.

Вкладка | Настройка
Безопасность | Здесь назначаются пользователи, имеющие права оператора запускать службу SMTP (Microsoft). Операторы имеют право настраивать виртуальный SMTP-сервер.
Доступ | Содержит параметры требования проверки подлинности и использования TLS-шифрования для всех входящих подключений. Здесь можно также предоставить или запретить доступ к определенным компьютерам или сетям.


Формирование списка операторов

Можно назначать, каким пользователям предоставляются права операторов виртуального SMTP-сервера. После установки пользователей сервера Windows 2000 Server эти права можно предоставить посредством выбора пользователей в списке. Права могут быть аннулированы с помощью удаления учетных записей пользователей из списка операторов виртуального сервера.

Включение в список операторов

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Безопасность нажмите кнопку Добавить. Откроется диалоговое окно Выбор: Пользователи или Группы.
  3. Выделите учетную запись пользователя сервера Windows 2000 Server, нажмите кнопку Добавить, затем нажмите кнопку OK. Выбранный пользователь будет занесен в Список операторов.

Удаление из списка операторов

Можно отменить права оператора для пользователей сервера Windows 2000 Server, включенных в Список операторов.

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Безопасность выделите оператора, которого нужно удалить.
  3. Нажмите кнопку Удалить.


Требование проверки подлинности для входящих подключений

Существует три способа проверки подлинности. Можно выбрать один, два или все три способа. По умолчанию установлены все три способа.

Вариант проверки подлинности | Описание
Анонимный доступ | Имя пользователя или пароль не требуются. Этот режим отменяет проверку подлинности для виртуального SMTP-сервера.
Обычная проверка подлинности | Имя пользователя и пароль отправляются открытым текстом. Укажите домен Windows, добавленный к имени пользователя для проверки подлинности.
Пакет безопасности Windows | Проверка подлинности по имени пользователя Windows и его паролю.

Отмена проверки подлинности для входящих сообщений

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доступ в группе Управление доступом нажмите кнопку Проверка подлинности. Откроется диалоговое окно Проверка подлинности.
  3. Установите флажок Анонимный доступ, затем снимите оставшиеся флажки других способов проверки подлинности.

Настройка проверки подлинности для входящих сообщений с использованием незашифрованного текста

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доступ в группе Управление доступом нажмите кнопку Проверка подлинности. Откроется диалоговое окно Проверка подлинности.
  3. Выберите способ Обычная проверка подлинности.
  4. В поле Домен по умолчанию введите имя домена Windows. Этот домен по умолчанию отличен от домена по умолчанию виртуального SMTP-сервера.

Использование пакета безопасности Windows для проверки подлинности входящих сообщений

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доступ в группе Управление доступом нажмите кнопку Проверка подлинности. Откроется диалоговое окно Проверка подлинности.
  3. Выберите Пакет безопасности Windows.


Настройка проверки подлинности для исходящих сообщений

Виртуальный SMTP-сервер можно настроить так, чтобы он предоставлял серверу-получателю сведения, необходимые для проверки подлинности. Есть три режима проверки подлинности: анонимный, основной (открытый текст) и пакет безопасности Windows. Анонимный режим не требует проверки подлинности. В режиме открытого текста имя пользователя и пароль сервера, к которому подключаются, передаются открытым текстом. Пакет безопасности Windows требует имя пользователя и пароль системы Windows.

Устанавливаемый здесь параметр может быть переопределен для определенного удаленного домена. При этом проверку подлинности будет проходить большинство передач, за исключением передач с отдельных адресов. В следующей таблице описаны различные примеры настройки.

Примечание. О шифровании исходящих сообщений см. Требование TLS-шифрования.

Передача SMTP | Вариант проверки подлинности
Обычно сообщения отправляются по нескольким адресам. | Отмените проверку подлинности для виртуального SMTP-сервера. Если попытка доставить почту не удалась вследствие проверки подлинности, добавьте адрес удаленного домена. Затем включите проверку подлинности для данного домена в том же режиме, который требует сервер.
Сообщения обычно отправляются на один адрес, требующий проведения проверки подлинности. | Определите требуемый для подключения уровень проверки подлинности. Затем включите тот же уровень проверки подлинности для виртуального SMTP-сервера. Если затем нужно будет отправить почту по другим адресам, установите удаленные домены и установите для них иные способы проверки подлинности. Если используется этот вариант, то, скорее всего, используемое имя идентифицирует компьютер как направляющий узел.

Отключение проверки подлинности для исходящих сообщений

  1. На вкладке Доставка нажмите кнопку Безопасность подключений. Откроется диалоговое окно Безопасность исходящих подключений.
  2. Установите переключатель Анонимный доступ.
  3. Очистите все остальные параметры.

Настройка обычной проверки подлинности для исходящих сообщений

  1. На вкладке Доставка нажмите кнопку Безопасность подключений. Откроется диалоговое окно Безопасность исходящих подключений.
  2. Установите переключатель Обычная проверка подлинности.
  3. В полях Имя пользователя и Пароль введите имя пользователя и пароль, предоставляющие доступ к компьютеру, к которому необходимо подключиться.

Настройка проверки подлинности с помощью пакета безопасности Windows для исходящих сообщений

  1. На вкладке Доставка нажмите кнопку Безопасность подключений. Откроется диалоговое окно Безопасность исходящих подключений.
  2. Установите переключатель Пакет безопасности Windows.
  3. В полях Учетная запись и Пароль введите имя учетной записи Windows и пароль, обеспечивающие доступ к компьютеру, к которому производится подключение.


Требование TLS-шифрования

Можно потребовать, чтобы при подключении к виртуальному SMTP-серверу по умолчанию все клиенты использовали TLS-шифрование, то есть общий протокол безопасности, подобный протоколу SSL. Этот режим увеличивает безопасность подключения, но не используется для проверки подлинности.

Чтобы использовать TLS-шифрование для виртуального сервера, нужно создать пары ключей и настроить сертификаты ключей. Тогда клиенты смогут использовать TLS-шифрование сеансов со службой SMTP (Microsoft) и таким образом отправлять всю почту. Служба SMTP может также использовать TLS-шифрование в сеансах с удаленными серверами.

Создание и управление сертификатами ключей

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. Чтобы установить сертификаты ключей и управлять установленными сертификатами для виртуального SMTP-сервера, на вкладке Доступ в группе Безопасные подключения нажмите кнопку Сертификат.

Пары криптографических ключей состоят из определенного числа битов (разрядов), определяющего уровень безопасности ключа. Повысить уровень безопасности можно, увеличив уровень шифрования с 40-разрядного (по умолчанию) до 128-разрядного. Чем больше число разрядов, тем сложнее расшифровать сообщение. Пользователи, намеревающиеся обезопасить доступ, должны использовать тот же самый уровень шифрования, который установлен вами, иначе сообщения будут возвращены с отчетом о невозможности доставки (ОНД)..

Настройка для сервера уровня TLS-шифрования

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доступ в группе Управление доступом нажмите кнопку Проверка подлинности. Откроется диалоговое окно Проверка подлинности.
  3. Выберите способ Обычная проверка подлинности.
  4. Установите флажок Требуется TLS-шифрование.

Примечание. Доступны два дополнительных режима использования TLS. Чтобы использовать TLS для исходящих подключений, нажмите кнопку Безопасность подключений на вкладке Доставка, а затем установите флажок TLS-шифрование. Кроме того, если сервер, к которому вы обычно подключаетесь, требует использования TLS-шифрования для всех входящих подключений, то можно создать удаленный домен и установить флажок TLS-шифрование.


Настройка ограничения доступа к серверу по IP-адресу

Можно разрешить или запретить для определенных IP-адресов доступ к виртуальному SMTP-серверу. По умолчанию виртуальный SMTP-сервер доступен со всех IP-адресов. Ограничения можно установить, указав отдельный IP-адрес или группу адресов с помощью маски подсети, либо имя домена сервера Windows 2000 Server.

Настройка ограничения доступа по IP-адресам

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доступ в группе Управление подключением нажмите кнопку Подключение. Откроется диалоговое окно Подключение.
  3. Вберите вариант Только указанные в списке или вариант Все, кроме указанных в списке.
  4. Чтобы добавить компьютер в список компьютеров, нажмите кнопку Добавить. Откроется диалоговое окно Компьютер.
  5. Чтобы удалить компьютер из списка компьютеров, выделите этот компьютер и нажмите кнопку Удалить.


Настройка ограничений ретрансляции через виртуальный сервер

По умолчанию служба SMTP (Microsoft) запрещает компьютерам ретрансляцию нежелательной почты через виртуальный сервер. Чтобы разрешить компьютеру ретрансляцию через виртуальный SMTP-сервер, нажмите кнопку Ретрансляция на вкладке Доступ. По умолчанию ретрансляция запрещена всем компьютерам за исключением тех, которые успешно прошли проверку подлинности с параметрами, назначенными в диалоговом окне Проверка подлинности (открывается кнопкой Проверка подлинности на вкладке Доступ).

Можно также разрешить ретрансляцию сообщений на определенный удаленный домен, подробности см. в разделе Настройка удаленных доменов. Параметры домена имеют приоритет над параметрами виртуального SMTP-сервера.

Примечание. Если настраиваемый виртуальный сервер находится и Интернете, не следует разрешать ретрансляцию во избежание ретрансляции нежелательной почты.

Отмена ограничений ретрансляции через виртуальный сервер

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доступ в группе Ограничения ретрансляции нажмите кнопку Ретрансляция. Откроется диалоговое окно Ограничения ретрансляции.
  3. Выберите либо вариант Только указанные в списке, либо Все, кроме указанных в списке.
  4. Нажатием кнопки Добавить откройте диалоговое окно Компьютер, затем добавьте исключения к варианту глобального доступа, выбранному на шаге 3.

В диалоговом окне Ограничения ретрансляции можно указать следующие параметры.

Параметр | Описание
Только указанные в списке | Ретранслировать сообщения через виртуальный SMTP-сервер могут только те компьютеры, которые указаны в списке.
Все, кроме указанных в списке | Через виртуальный SMTP-сервер могут ретранслировать почту все компьютеры, кроме указанных в списке. Этот режим установлен по умолчанию, как и режим Разрешить ретрансляцию любому не указанному в списке компьютеру, но только после проверки подлинности.
Кнопки «Добавить» и «Удалить» | Служат для добавления и удаления записей в списке компьютеров, которым предоставлен или запрещен доступ для ретрансляции.
Разрешить ретрансляцию любому не указанному в списке компьютеру, но только после проверки подлинности | Разрешает ретрансляцию через виртуальный SMTP-сервер компьютерам, удовлетворяющим требованиям проверки подлинности, которые указываются в диалоговом окне Проверка подлинности. Этот режим установлен по умолчанию.


Управление почтой

В этом разделе описывается, как установить ограничения подключений для увеличения производительности, как установить ограничения для размера сообщения, для числа получателей и что делать с недоставленной почтой.

  • Настройка ограничения числа сообщений за сеанс
  • Настройка ограничений на размер сообщения
  • Настройка ограничений на количество получателей
  • Хранение ОНД


Настройка ограничения числа сообщений за сеанс

С помощью этого параметра можно ограничить количество сообщений, отправляемых при одном подключении. Он также является способом увеличения производительности системы, поскольку позволяет использовать несколько подключений для доставки почты на удаленный домен. При достижении ограничения автоматически открывается новое соединение, и передача продолжается до тех пор, пока вся почта не будет доставлена.

Например, если вы обычно отправляете большое число сообщений на определенный удаленный домен, то следует настроить параметр Ограничение числа сообщений на один сеанс на относительно малую величину, например, 20. В результате при отправке 100 сообщений служба SMTP (Microsoft) откроет новое подключение, как только первые 20 будут отправлены, еще одно подключение, как только будут отправлены вторые 20 сообщений и так далее. В этом случае должно быть пять одновременных подключений для доставки стоящих в очереди сообщений одному получателю. Доставка почты должна производиться быстрее, поскольку одновременно доставляются несколько сообщений, а не один длинный поток при одном подключении.

Чтобы определить величину ограничения, просмотрите счетчик производительности Отправка сообщений (сообщения/с) для объекта SMTP-сервер в окне системного монитора. Значение параметра Ограничение числа сообщений на один сеанс должно быть меньше, чем показание счетчика производительности. Если счетчик показывает 30, а максимальное число сообщений установлено на 50, то никаких одновременных подключений не будет, поскольку сервер не сможет обрабатывать более 30 сообщений в секунду. Такая установка параметров не является ошибкой, но сообщения будут отправляться длинным потоком за одно подключение. Этот параметр имеет отношение только к исходящим сообщениям. Его можно использовать для увеличения скорости передачи исходящих данных, но он не влияет на скорость обработки входящих сообщений.

Ограничение числа сообщений, отправляемых за одно подключение

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Сообщения установите флажок Ограничение числа сообщений на один сеанс, затем введите в поле нужное значение. По умолчанию установлено значение 20. Максимально допустимое значение равно 2 000 000 000.


Настройка ограничений на размер сообщений

Есть два параметра ограничения размера сообщения. Первый, Ограничение на размер сообщения, есть предпочтительное ограничение размера сообщения для виртуального сервера. Этот параметр служба SMTP (Microsoft) будет предлагать в качестве максимального размера сообщения, который сможет принять виртуальный SMTP-сервер. Если почтовый клиент отправит сообщение, превосходящее данное ограничение, то это будет ошибкой. Если удаленный сервер поддерживает EHLO, то он определит предлагаемое ограничение на размер сообщения при подключении к виртуальному SMTP-серверу и не станет пытаться доставить сообщение, превосходящее это ограничение. Вместо этого удаленный сервер пошлет отправителю чрезмерно большого сообщения ОНД. Если команда EHLO не поддерживается удаленным сервером, будет выполнена попытка отправить превышающее ограничение сообщение. После ее неудачного завершения, отправителю будет выдан такой же отчет о невозможности доставки сообщения.

Ограничение на размер сеанса - это максимальное количество данных, передаваемых за все подключение. Это сумма всех сообщений, отправленных за время подключения (суммируется только размер тела сообщения).

Установка ограничения на размер сообщений

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Сообщения установите флажок Ограничение на размер сообщения (КБ) и введите величину (в килобайтах) максимального размера сообщения. По умолчанию установлено значение 2048 КБ. Минимальное значение 1 КБ.
  3. На вкладке Сообщения установите флажок Ограничение на размер сеанса (КБ) введите величину максимального суммарного размера (в килобайтах) всех сообщений в данном подключении. Это число должно всегда быть больше, чем максимальный размер сообщения, и поэтому должно вводится аккуратно, поскольку иначе агент передачи сообщений (MTA) будет, повторять попытки отправить сообщение. По умолчанию установлено значение 10240 КБ. Эта величина должна быть не меньше, чем введенная для поля Ограничение на размер сообщения (КБ).


Настройка ограничения на количество получателей

Можно задать максимальное количество получателей для одного сообщения за одно подключение. По умолчанию это 100, максимальное количество, указанное в RFC 821. Многие клиентские программы, получив сообщение об ошибке, связанной с превышением максимального количества получателей, возвращают сообщения с отчетом о невозможности доставки (ОНД). Однако служба SMTP (Microsoft) не будет возвращать эти сообщения. Она немедленно откроет новое подключение и отправит данные для оставшихся получателей. Например, если ограничение установлено на 100, а получено сообщение на 105 получателей, то первые 100 будут доставлены в одно подключение. Затем установится новое подключение и будут обработаны оставшиеся получатели.

Настройка ограничения числа получателей

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Сообщения в поле Ограничение числа получателей одного сообщения введите максимальное число получателей. Чтобы отменить это ограничение, снимите флажок.


Хранение ОНД

Если сообщение невозможно доставить, служба SMTP (Microsoft) возвращает его отправителю вместе с отчетом о невозможности доставки (ОНД). Можно также назначить отправление копии ОНД куда-либо еще. Если сообщение с ОНД не может быть доставлено отправителю, то копия этого сообщения помещается в каталог ошибочной почты.

Все сообщения с ОНД проходят через тот же самый процесс доставки, что и обычная почта, включая попытки повторной отправки. Если исчерпаны все попытки отправить ОНД отправителю, то его копия помещается в каталог ошибочной почты. Сообщения, помещенные в каталог ошибочной почты, уже не могут быть доставлены или возвращены.

Настройка места хранения ОНД

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Сообщения в поле Копии отчетов о невозможности доставки отправлять по адресу введите адрес почтового ящика, где следует хранить копии ОНД. Это может быть любой действительный SMTP почтовый адрес. Заполнение этого поля необязательно. Чтобы отменить эту проверку, снимите флажок.
  3. В поле Каталог ошибочной почты введите каталог, где следует хранить сообщения, которые невозможно доставить. По умолчанию этот каталог расположен в root:\Inetpub\Mailroot\Badmail. Чтобы выбрать другую папку, нажмите кнопку Обзор. Можно назначить любой каталог, если только он расположен на том же компьютере, что и служба SMTP.


Доставка сообщений

После того как подключение установлено и от принимающего сервера получено уведомление о готовности приема данных можно начинать передачу доставляемых сообщений. В этом разделе описаны параметры, определяющие ход доставки сообщений, в том числе параметры маршрутизации и число повторных попыток доставки.

  • Параметры доставки сообщений
  • Настройка числа повторных попыток и интервалов повторения
  • Настройка числа пересылок
  • Настройка имени подменяющего домена
  • Настройка полного доменного имени
  • Настройка направляющего узла
  • Разрешение обратного поиска в DNS


О параметрах доставки сообщений

Для установки параметров доставки и маршрутизации сообщений используется вкладка Доставка. Параметры делятся на три категории, указанные ниже.

Параметры маршрутизации

  • Направляющий узел: назначает сервер, через который следует направлять все исходящие сообщения.
  • Счетчик пересылок сообщения: определяет максимальное число серверов, через которые сообщение может пройти, прежде чем будет установлена невозможность его доставки.
  • Полное доменное имя (FQDN): уточняет адрес, который следует использовать в MX-записях.

Параметры передачи

  • Число повторных попыток и интервал повторения: определяют, сколько раз и с какими интервалами следует повторно посылать сообщение, прежде чем будет установлена невозможность его доставки.
  • Доставка также возможна с помощью каталога отбора, позволяющего передавать сообщения, созданные в текстовом формате.

Параметры обеспечения безопасности

  • Безопасность подключений: позволяет использовать проверку подлинности и TLS-шифрование для исходящих сообщений.
  • Обратный поиск в DNS: проверяет, действительно ли сообщение исходит от компьютера и домена, указанных в поле From (От).
  • Имя подменяющего домена: заменяет любое имя локального домена, используемое в строках протокола Mail From (Отправитель), на имя другого домена. Это имя будет внесено в исходящие сообщения.


Настройка числа повторных попыток и интервалов повторения

Если не удалось доставить сообщение с первой попытки, то служба SMTP (Microsoft) отправит его снова через указанное время из каталога очереди. Интервалы между попытками доставки можно установить. Можно также назначить число попыток повторной доставки. После того, как этот предел будет достигнут, сообщение вернется отправителю вместе с ОНД, а копии сообщения и ОНД будут направлены в указанное место. ОНД помещается в каталог очереди и проходит через тот же процесс доставки, что и обычная почта. Если будет исчерпан предел попыток доставки ОНД, он вместе с исходным сообщением будет отправлен в каталог ошибочной почты.

Установка числа повторных попыток и интервалов повторения

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. Перейдите на вкладку Доставка.
  3. В поле Пауза до 1-й попытки (мин) введите время ожидания попытки доставки до отправки первого уведомления. По умолчанию установлено 15 минут.
  4. В поле Пауза до 2-й попытки (мин) введите время ожидания попытки доставки до отправки второго уведомления. По умолчанию это 30 минут после первой паузы.
  5. В поле Пауза до 3-й попытки (мин) введите время ожидания попытки доставки до отправки третьего уведомления. По умолчанию это 60 минут после второй паузы.
  6. В поле Дальнейшие паузы (мин) введите время ожидания для остальных попыток до отправки соответствующих уведомлений. По умолчанию установлено 240 минут.

Уведомления о задержке

Чтобы разрешить сетевые задержки, можно установить время задержки до отправки уведомлений о доставке. Минимальное значение равно 1 минуте, по умолчанию – 12 часов, максимальное время – 9999 дней. Чтобы указать минуты, часы или дни, воспользуйтесь расположенным рядом раскрывающимся списком.

Срок хранения

Введите значение времени хранения неотправленных сообщений после окончания всех отведенных на уведомления и повторные попытки доставки сроков. Минимальный срок равен 1 минуте, по умолчанию – 2 дня, максимальный срок – 9999 дней. Чтобы указать минуты, часы или дни, воспользуйтесь расположенным рядом раскрывающимся списком.


Настройка числа пересылок

В процессе доставки, сообщение может маршрутизироваться через множество серверов прежде чем достигнет конечного пункта назначения. Можно указать через какое количество серверов разрешено пройти этому сообщению. Этот параметр называется числом пересылок.

После того, как установлено число пересылок, SMTP-сервер считает пересылки по строкам Received (Получено) в заголовке сообщения. Если число строк Received в заголовке превышает установленный предел пересылок, сообщение будет возвращено отправителю вместе с отчетом о невозможности доставки (ОНД).

Настройка числа пересылок сообщений

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доставка нажмите кнопку Дополнительно. Откроется диалоговое окно Дополнительная настройка доставки.
  3. В поле Максимальное число пересылок введите величину предельного числа пересылок сообщения между серверами отправителя и получателя. По умолчанию установлено значение 15.


Настройка имени подменяющего домена

Имя подменяющего домена заменяет любое имя локального домена, используемое в любой строке заголовка Mail From. Замена происходит только при первой пересылке.

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доставка нажмите кнопку Дополнительно. Откроется диалоговое окно Дополнительная настройка доставки.
  3. В поле Имя подменяющего домена введите имя домена, которое следует употреблять в заголовках сообщений вместо фактического имени локального домена.

    Примечание. Все ответы на такие сообщения будут проходить через тот виртуальный SMTP-сервер, который использует домен, определяемый этим именем.


Настройка полного доменного имени

Необходимо обеспечить определение имени домена электронной почты посредством доменной системы имен (DNS). Существует два типа записей DNS для определения имени домена электронной почты. В большинстве случаев запись типа mail exchanger (MX-запись) служит для связи домена электронной почты с полным доменным именем (FQDN) одного или нескольких виртуальных SMTP-серверов, обслуживающих этот домен. Каждый SMTP-сервер, указанный в MX-записи, должен иметь запись типа address (A-запись). A-запись отображает данное полное доменное имя в его IP-адрес.

Для домена электронной почты можно определить только A-запись. В этом случае А-запись отображает домен в IP-адрес или адреса виртуальных SMTP-серверов, обслуживающих домен. Тем не менее, рекомендуется добавление MX-записи к А-записи, поскольку MX-запись позволяет администратору SMTP указывать упорядоченный список серверов, используемых клиентами для отправки почты в данный домен. Служба SMTP (Microsoft) всегда сначала проверяет MX-запись и только в случае неудачи обращается к A-записи, так что установка MX-записей может увеличить быстродействие. В некоторых случаях A-записи используются для иных целей, например, для протокола HTTP, тогда как MX-записи используются обычно для протокола SMTP. MX-запись позволяет одному серверу оперировать с http://microsoft.com (клиенты HTTP используют A-запись), а другому серверу оперировать с someone@microsoft.com (клиенты SMTP используют MX-запись).

В настройках службы SMTP существует два способа задания полного доменного имени (FQDN). Можно использовать имя, указанное на вкладке Сетевая идентификация в разделе «Система» панели управления, или указать уникальное полное доменное имя для настраиваемого виртуального SMTP-сервера.

При загрузке имя, указанное на вкладке Сетевая идентификация, автоматически используется в качестве полного имени домена. Если это имя изменить (вручную или посредством присоединения к домену Windows 2000), то после перезагрузки компьютера будет автоматически использоваться новое полное имя домена. Для обновления полного доменного имени для виртуального сервера никаких действий не требуется.

Чтобы отменить автоматическое использование имен компьютера и домена на вкладке Сетевая идентификация, измените полное доменное имя в диалоговом окне Дополнительная настройка доставки, вызываемом через вкладку Доставка. Служба SMTP сможет использовать назначенное имя вместо указанного на вкладке Сетевая идентификация.

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доставка нажмите кнопку Дополнительно. Откроется диалоговое окно Дополнительная настройка доставки.
  3. В поле Полное доменное имя введите полное доменное имя.


Настройка направляющего узла

Можно выполнять маршрутизацию всех исходящих сообщений для удаленного домена через направляющий сервер, вместо того, чтобы отправлять их напрямую в этот домен. Это позволяет направлять почту по более прямому и менее дорогому маршруту. Работа направляющего узла похожа на работу маршрутного домена для связи с удаленными доменами. Отличие состоит в том, что после назначения направляющего узла вся исходящая почта направляется на этот сервер. Для маршрутного домена, на указанный сервер посылаются только сообщения для удаленных доменов.

Если задается направляющий узел, для удаленного домена можно также назначить другой маршрут. Параметры, установленные для маршрутного домена имеют приоритет над параметрами направляющего узла.

Примечание. Задать направляющий узел можно полным доменным именем (FQDN) или IP-адресом (но если IP-адрес изменится, то его придется изменять для всех виртуальных серверов). При использовании IP-адреса заключайте его в квадратные скобки [ ], это увеличит быстродействие. Служба SMTP (Microsoft) сначала проверяет имя сервера, а затем IP-адрес. Скобки идентифицируют значение как IP-адрес, поэтому поиск в DNS не производится.

Настройка направляющего узла

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доставка нажмите кнопку Дополнительно. Откроется диалоговое окно Дополнительная настройка доставки.
  3. В поле Направляющий узел введите имя сервера направляющего узла. Можно ввести текстовую строку имени или IP-адрес.
  4. Если нужно, чтобы служба SMTP попыталась доставить сообщение на удаленный домен напрямую до отправки его на направляющий узел, установите флажок Попытаться отправить без использования направляющего узла. По умолчанию задан режим пересылки всех сообщений для удаленных доменов на направляющий узел без попыток прямой доставки.


Разрешение обратного поиска в DNS

При разрешении обратного поиска, служба SMTP (Microsoft) будет пытаться проверять, совпадает ли IP-адрес клиента с узлом/доменом, указанным клиентом в команде EHLO/HELO. Если обратный поиск в DNS завершается успешно, заголовок RECEIVED останется без изменений. Если проверяемые данные не подтвердились, в заголовке RECEIVED данного сообщения, после IP-адреса появляется отметка \ldblquote unverified\rdblquote .

Примечание. Так как при данном режиме работы проверяются адреса всех входящих сообщений, то это может снизить производительность службы SMTP. Чтобы отменить эту проверку, снимите флажок.

Разрешение обратного поиска в DNS

  1. В окне консоли MMC выделите виртуальный SMTP-сервер, затем в меню Действие выберите команду Свойства.
  2. На вкладке Доставка нажмите кнопку Дополнительно. Откроется диалоговое окно Дополнительная настройка доставки.
  3. Установите флажок Выполнять для входящих сообщений обратный поиск в DNS.


Создание и удаление домена

Домены службы SMTP (Microsoft) отличаются от доменов DNS и доменов серверов Windows 2000 Server. Домены службы SMTP используются для организации сообщений с целью их доставки.

В этом разделе содержатся общие сведения о доменах и основных процедурах.

  • О доменах
  • Создание домена
  • Удаление домена

Дополнительные сведения

  • О локальных доменах см. раздел Настройка локальных доменов
  • Об удаленных доменах см. раздел Настройка удаленных доменов


О доменах

Виртуальный SMTP-сервер имеет по крайней мере один домен – это локальный домен по умолчанию. Можно добавить еще несколько доменов и настроить их как локальные или удаленные. Можно удалить любой домен, кроме домена по умолчанию.

Локальные домены

Локальный домен – это домен DNS, обслуживаемый локальным SMTP-сервером. Любое сообщение с именем локального домена, приходящее на SMTP-сервер, должно быть либо доставлено локально в каталог сбора, либо возвращено отправителю с отчетом о невозможности доставки (ОНД). Локальные домены иногда называют служебными доменами или поддерживаемыми доменами. Адреса электронной почты с именами локальных доменов часто называют локальными адресами.

Если домен является локальным, то его можно определить либо как домен «по умолчанию», либо как «псевдоним». Домен по умолчанию всегда один. Он используется как штемпель в заголовках сообщений, не содержащих конкретизации домена. Домен-псевдоним – это псевдоним домена по умолчанию. При добавлении домена и назначении его новым доменом по умолчанию, старый домен по умолчанию становится доменом-псевдонимом.

Удаленные домены

Домены, расположенные вне локальной сети, называются удаленными или нелокальными доменами, и на адрес электронной почты удаленных доменов ссылаются как на удаленные адреса. Служба SMTP (Microsoft) проводит поиск адресов удаленных доменов в DNS.

Если нужно установить специфические требования по доставке для определенного удаленного домена, то можно добавить удаленный домен и настроить его соответствующим образом. Например, можно добавить удаленный домен и потребовать, чтобы служба SMTP всегда использовала TLS-шифрование при подключении к этому домену. Можно изменить маршрутизацию так, чтобы сообщения, посылаемые на один удаленный домен, проходили через другой удаленный домен. Чтобы настроить домены, воспользуйтесь диалоговым окном свойств доменов.


Создание домена

В службе SMTP (Microsoft) можно создавать два типа доменов: псевдонимы и удаленные. Домены-псевдонимы позволяют создавать вторичные домены, указывающие на домен по умолчанию и используют его параметры, в том числе и каталог сбора. В любом сообщении, отправленном в домен-псевдоним, будет указано имя домена по умолчанию.

Удаленные домены могут быть установлены для доменов, куда обычно отправляется почта. Для каждого удаленного домена можно установить предопределенный маршрут или потребовать использовать TLS-шифрование при всех сеансах с этим доменом. В имени домена можно также использовать знак подстановки, так что все домены, включенные в создаваемый, будут использовать те же параметры. Используйте звездочку (*) в качестве первого символа, а за ней точку (.). Например, звездочку в качестве символа подстановки можно использовать в следующем формате:

*.microsoft.com

Создание домена-псевдонима с помощью консоли MMC

  1. Чтобы найти виртуальный SMTP-сервер, разверните структуру компонентов консоли MMC.
  2. Выделите Домены.
  3. В меню Действие укажите Создать, а затем выберите Домен.
  4. Настроить локальный домен-псевдоним поможет мастер создания домена.

Создание удаленного домена с помощью консоли MMC

  1. В окне консоли MMC разверните узел виртуального SMTP-сервера
  2. Выделите Домены.
  3. В меню Действие укажите Создать, а затем выберите Домен.
  4. Настроить удаленный домен поможет мастер создания домена.
  5. Чтобы назначить домен маршрутизации, установите проверку подлинности исходящих сообщений или использование TLS-шифрования, выделите домен в области подробностей, в меню Действие выберите Свойства, а затем укажите параметры.


Удаление домена

Добавленные домены можно удалять.Нельзя удалить домен по умолчанию, пока не добавлен домен-псевдоним, который затем будет сделан доменом по умолчанию.

Удаление домена

  1. На консоли управления MMC разверните узел виртуального SMTP-сервера.
  2. Разверните Домены.
  3. В области подробностей выделите домен, который необходимо удалить.
  4. Выберите в меню Действие команду Удалить.


Настройка локальных доменов

В этом разделе описывается, как установить параметры для существующих локальных доменов.

  • Назначение домена по умолчанию
  • Настройка домена-псевдонима
  • Назначение каталога сбора


Назначение домена по умолчанию

Домен по умолчанию используется для указания его в сообщениях из адресов, не имеющих домена. Простейший виртуальный SMTP-сервер может иметь только один домен по умолчанию, который не может быть удален.

Для присвоения имени домену по умолчанию используется имя, указанное на вкладке DNS страницы свойств протокола TCP/IP в разделе сетевых настроек панели управления. Это имя домена используется и для всех других служб. Тем не менее, можно указать отдельный домен, используемый в качестве домена по умолчанию только службой SMTP (Microsoft).

При запуске имя, указанное на вкладке DNS страницы свойств протокола TCP/IP в разделе сетевых настроек панели управления, автоматически используется в качестве имени домена по умолчанию. Если имя на вкладке DNS изменить, то новое имя автоматически будет использоваться как имя домена по умолчанию при следующем запуске службы. Чтобы обновить домен по умолчанию для службы SMTP, ничего делать не надо.

Чтобы избежать автоматического использования сетевого имени домена по умолчанию, укажите домен по умолчанию на вкладке Общие. Служба SMTP будет использовать назначенное имя вместо сетевого.

Переименование домена по умолчанию

  1. Разверните виртуальный SMTP-сервер, затем щелкните Домены.
  2. В области подробностей щелкните правой кнопкой мыши домен по умолчанию, а затем выберите команду Переименовать.
  3. Введите новое имя для домена по умолчанию.


Настройка домена-псевдонима

Домен-псевдоним устанавливается с теми же параметрами, что и домен по умолчанию. Сообщения, получаемые службой SMTP (Microsoft) для домена-псевдонима, помещаются в каталог сбора, определенный для домена по умолчанию.

Настройка домена-псевдонима

  1. Разверните виртуальный SMTP-сервер и правой кнопкой щелкните Домены.
  2. Выберите команду Создать, затем выберите Домен. Будет запущен Мастер создания домена.
  3. В окне мастера создания домена выберите Локальный, а затем Далее.
  4. Введите имя для домена-псевдонима, затем нажмите кнопку Готово.


Назначение каталога сбора

Для домена по умолчанию необходимо определить каталог, в который будет собираться вся входящая почта. Служба SMTP (Microsoft) помещает сообщения для доменов-псевдонимов в каталог сбора, используемый для домена по умолчанию. В качестве каталога сбора можно указать любой каталог, если он находится на том же компьютере, что и служба SMTP, и не указан уже как каталог отбора. По умолчанию назначается подкаталог каталога Mailroot.

Назначение каталога сбора

  1. В области подробностей щелкните правой кнопкой мыши домен по умолчанию, а затем выберите команду Свойства.
  2. В поле Каталог сбора введите каталог, который будет использоваться как каталог сбора всех входящих сообщений. По умолчанию его расположение: root:\Inetpub\Mailroot\Drop. Или нажмите кнопку Обзор и выберите каталог. Убедитесь, что выбранный каталог сбора не является каталогом отбора.


Настройка удаленных доменов

Можно задать уникальные требования по доставке для определенного удаленного домена, добавив домен и выполнив для него соответствующую настройку. Например, можно установить предопределенную маршрутизацию, установить проверку подлинности, потребовать использования TLS-шифрования при всех подключениях к удаленному домену. Если удаленный домен специально не настроен, то служба SMTP (Microsoft) не будет производить для него этих операций. В то же время, будет выполняться обычный поиск в DNS. В данном разделе содержатся следующие статьи.

  • Настройка маршрутного домена
  • Включение TLS-шифрования для удаленного домена
  • Настройка проверки подлинности для удаленного домена
  • Настройка команды ATRN для удаленного домена


Настройка маршрутного домена

Можно указать путь доставки, более быстрый и менее дорогой, чем прямая связь. Введите имя сервера или его IP-адрес, через который следует направлять почту для данного удаленного домена. Если вводится IP-адрес, заключите его в квадратные скобки ([ ]), это увеличит быстродействие. Эта настройка имеет больший приоритет, чем настройка направляющего узла на вкладке Доставка.

Назначение маршрутного домена

  1. Щелкните виртуальный SMTP-сервер правой кнопкой мыши, укажите команду Создать, а затем выберите Домен.
  2. С помощью мастера создания домена создайте удаленный домен. В области подробностей щелкните правой кнопкой мыши новый удаленный домен, а затем выберите команду Свойства.
  3. На вкладке Общие в группе Маршрутный домен установите флажок Пересылать всю почту на направляющий узел, а затем введите имя или IP-адрес сервера, через который следует направлять сообщения на этот удаленный домен.

    Примечание. Задать направляющий узел можно полным доменным именем или IP-адресом (но если IP-адрес изменится, то его придется изменять для всех виртуальных серверов). При использовании IP-адреса заключайте его в квадратные скобки [ ], это увеличит быстродействие. Служба SMTP (Microsoft) сначала проверяет имя сервера, а затем IP-адрес. Скобки идентифицируют значение как IP-адрес, поэтому поиск в DNS не производится.


Включение TLS-шифрования для удаленного домена

Если решено не использовать TLS-шифрование для виртуального SMTP-сервера, но для данного удаленного домена установлен флажок TLS-шифрование, то служба SMTP будет использовать шифрование при подключении к этому домену. Настройка доменов всегда имеет приоритет перед настройкой виртуальных серверов.

Включение TLS-шифрования для удаленного домена

  1. Разверните виртуальный SMTP-сервер, затем щелкните Домены.
  2. В области подробностей выделите удаленный домен, который необходимо изменить. В меню Действие выберите Свойства.
  3. На вкладке Общие нажмите кнопку Безопасность подключений. Откроется диалоговое окно Безопасность исходящих подключений.
  4. Установите переключатель Пакет безопасности Windows.
  5. Введите имя пользователя Windows и пароль.
  6. Нажмите кнопку OK.
  7. Установите флажок TLS-шифрование, затем нажмите кнопку ОК.
Примечание. Если удаленный домен не поддерживает TLS-шифрование, то все сообщения будут возвращаться с ОНД.


Настройка проверки подлинности для удаленного домена

Виртуальный SMTP-сервер можно настроить на предъявление учетных сведений, требуемых удаленным доменом для проверки подлинности. Есть два режима проверки подлинности: основной (открытым текстом) и пакет безопасности Windows. В основном режиме имя пользователя и пароль для сервера, к которому подключаются, передаются открытым текстом. Режим пакета безопасности Windows требует имя пользователя и пароль Windows. Проверку подлинности можно отменить, это установлено по умолчанию.

Режим проверки подлинности для удаленного домена имеет приоритет над режимом проверки подлинности для виртуального SMTP-сервера, заданного на вкладке Доступ. В следующей таблице описаны различные примеры настройки.

Передачи виртуального SMTP-сервера | Вариант проверки подлинности
Обычно сообщения отправляются по нескольким адресам. | Отмените проверку подлинности для виртуального SMTP-сервера. Если попытка доставить почту не удалась вследствие проверки подлинности, добавьте адрес удаленного домена. Затем включите проверку подлинности для данного домена в том же режиме, который требует сервер.
Сообщения обычно отправляются на один адрес, требующий проведения проверки подлинности. | Определите требуемый для подключения уровень проверки подлинности. Затем включите тот же уровень проверки подлинности для виртуального SMTP-сервера. Если затем нужно будет отправить почту по другим адресам, установите удаленные домены и установите для них иные способы проверки подлинности. Если используется этот вариант, то, скорее всего, используемое имя идентифицирует компьютер как направляющий узел.

Отключение проверки подлинности для исходящих сообщений

  1. Разверните виртуальный SMTP-сервер, затем щелкните Домены.
  2. В области подробностей выделите удаленный домен, который необходимо изменить. В меню Действие выберите Свойства.
  3. На вкладке Общие нажмите кнопку Безопасность подключений. Откроется диалоговое окно Безопасность исходящих подключений.
  4. Установите переключатель Анонимный доступ, затем нажмите кнопку OK.

Настройка обычной проверки подлинности для исходящих сообщений

  1. Разверните виртуальный SMTP-сервер, затем щелкните Домены.
  2. В области подробностей выделите удаленный домен, который необходимо изменить. В меню Действие выберите Свойства.
  3. На вкладке Общие нажмите кнопку Безопасность подключений. Откроется диалоговое окно Безопасность исходящих подключений.
  4. Установите переключатель Обычная проверка подлинности.
  5. Введите имя пользователя и пароль для компьютера, к которому подключаетесь.
  6. Нажмите кнопку OK.

Настройка проверки подлинности для исходящих сообщений с помощью пакета безопасности Windows

  1. Разверните виртуальный SMTP-сервер, затем щелкните Домены.
  2. В области подробностей выделите удаленный домен, который необходимо изменить. В меню Действие выберите Свойства.
  3. На вкладке Общие нажмите кнопку Безопасность подключений. Откроется диалоговое окно Безопасность исходящих подключений.
  4. Выберите Пакет безопасности Windows.
  5. Введите имя пользователя Windows и пароль.
  6. Нажмите кнопку OK.


Настройка поддержки команды ATRN для удаленного домена

Служба SMTP (Microsoft) сохраняет почту для клиентов, которые могут периодически подключаться для ее выгрузки. В таком случае, клиент посылает на сервер команду ATRN. Удаленная служба SMTP при этом начинает отправку почты на домен, выдавший команду ATRN. Можно создать удаленный домен для адреса, который периодически выполняет обзор сообщений и включает ATRN для домена.

Настройка поддержки команды ATRN для удаленного домена

  1. Разверните виртуальный SMTP-сервер, затем щелкните Домены.
  2. В области подробностей выделите удаленный домен, который необходимо изменить. В меню Действие выберите Свойства.
  3. Перейдите на вкладку Дополнительно и установите флажок Помещать сообщения в очередь на удаленную доставку.
  4. Используя кнопки Добавить и Удалить, определите пользователей Windows 2000, которым разрешено использовать в этом домене команду ATRN.


Настройка подключений к LDAP-серверу

Протокол LDAP (Протокол облегченного доступа к каталогам) используется для доступа к данным в каталогах LDAP-сервера. Получив соответствующие права доступа, можно просматривать, считывать и проводить поиск данных в каталогах LDAP-сервера.

С помощью вкладки Маршрутизация LDAP можно настроить службу SMTP, чтобы она запрашивала LDAP-сервер о списках отправителей и получателей. Например, можно использовать службу Active Directory Windows 2000 в качестве LDAP-сервера, а с помощью пользователей и компьютеров, определенных в службе Active Directory, можно создать список групповой рассылки с автоматическим развертыванием на виртуальном SMTP-сервере.

В данном разделе указаны способы настройки службы SMTP в качестве LDAP-клиента, предоставляющего пользователю доступ к данным в каталогах LDAP-сервера. Раздел содержит следующие статьи.

  • Предварительные этапы настройки подключений к LDAP-серверу
  • Выбор типа схемы
  • Задание уровня проверки подлинности
  • Настройка маршрутизации LDAP


Предварительные этапы настройки подключений к LDAP-серверу

Некоторые установочные параметры на вкладке Маршрутизация LDAP влияют друг на друга, поэтому рекомендуется перед настройкой протокола LDAP проводить ее предварительное планирование.

  1. Определите тип схемы, который будет использоваться.
  2. Задайте уровень проверки подлинности, необходимый для установления связи с каталогом LDAP. Если LDAP-сервер, с которым поддерживается связь, не требует проверки подлинности, учетные данные можно не использовать.
  3. Определите, нужно ли задавать контекст именования. Он может быть необходим, если учетная запись пользователя находится в подконтейнере каталога LDAP. Это позволит ускорить поиск в LDAP-каталоге, а в некоторых случаях, когда внутри LDAP-сервера существует несколько сходных имен, указывать отличительное имя просто необходимо.


Выбор типа схемы

Следующие типы схем можно выбрать из раскрывающегося списка Тип схемы на вкладке Маршрутизация LDAP.

Тип схемы | Описание
Служба Active Directory | При этом типе схемы служба Active Directory Windows 2000 используется в качестве LDAP-сервера. Для управления почтовыми ящиками используются объекты \ldblquote Пользователи\rdblquote и \ldblquote Компьютеры\rdblquote службы Active Directory.
Каталог Membership сервера Microsoft Site Server | Выбирается, когда для управления почтовыми ящиками используется служба LDAP, установленная как часть Microsoft Commercial Internet System 2.0 Mail.
Служба Exchange LDAP | Выбирается, когда для управления почтовыми ящиками используются сервер Microsoft Site Server 3.0 или более новые версии LDAP-сервера.


Задание уровня проверки подлинности

Тип привязки определяет уровень проверки подлинности подключений. Имеются четыре типа привязки. Выбор одного из параметров автоматически влияет на остальные.

Тип привязки | Описание
Анонимный | Проверка подлинности не требуется. Выбирается, когда сервер не требует учетной записи и пароля.
Обычный текст | Разрешается передача учетных данных в текстовом формате. Если выбран этот параметр, необходимо задать учетные данные.
Windows SSPI | Чтобы установить наиболее строгий способ доступа, клиент и сервер договариваются друг с другом, определяя доступный для обоих уровень проверки подлинности. Если выбран этот параметр, необходимо задать учетные данные.
Учетные записи службы | Используется учетная запись пользователя, под управлением которого работает служба SMTP (Microsoft). Управление учетными записями осуществляется с помощью компонента Службы компонентов средства Администрирование.


Настройка маршрутизации LDAP

  1. Для заданного виртуального SMTP-сервера выберите команду Свойства в окне консоли MMC.
  2. Перейдите на вкладку Маршрутизация LDAP.
  3. Установите флажок Маршрутизация LDAP.
  4. Задайте параметры, описание которых приведено в следующей таблице.
Параметр | Описание
Имя LDAP-сервера | Введите имя компьютера, работающего с каталогом LDAP. Если применяется тип схемы для службы Exchange LDAP, заполнение этого поля не требуется, поскольку служба сама автоматически найдет и начнет использовать ближайший сервер.
Тип схемы | Выберите тип схемы.
Тип привязки | Выберите уровень проверки подлинности для привязки к LDAP-серверу. Обычный текст передает пароли открытым текстом. Чтобы установить наиболее строгий способ проверки подлинности из доступных для виртуального SMTP-сервера, выберите Windows SSPI. По умолчанию принят тип привязки к LDAP-серверу Анонимный, не использующий проверку подлинности. Учетная запись службы применяется, когда пользователь с помощью учетных данных пытается связаться с LDAP-сервером.
Домен | Введите имя домена для учетной записи, которую требуется использовать для привязки к LDAP-каталогу. Этот параметр применяется, если для типа привязки выбрано значение Обычный текст или Windows SSPI.
Имя пользователя | Введите отличительное имя (DN) для учетной записи, которую требуется использовать для привязки к LDAP-каталогу. Например, cn=user1,ou=users,o=company. Этот параметр применяется, если для типа привязки выбрано значение Обычный текст или Windows SSPI.
Пароль | Введите пароль, используемый для подключения к службе каталогов. Этот параметр применяется, если для типа привязки выбрано значение Обычный текст или Windows SSPI.
База | Этот параметр определяет отличительное имя контейнера в той службе каталогов, к которой выполняется доступ. С его помощью можно указать, в каком месте LDAP-каталога служба SMTP (Microsoft) должна начинать поиск. Поиск начинается с доступного контейнера и, в случае необходимости, продолжается по подконтейнерам.


Основные понятия

Доставка почты является обычным свойством узлов Интернета. Почтовые сообщения в Интернете чаще всего передаются по протоколу SMTP (Simple Mail Transfer Protocol). Почтовые сообщения в Интернете чаще всего передаются по протоколу SMTP (Simple Mail Transfer Protocol). Для настройки компьютера на доставку почты по локальной сети или через Интернет можно использовать службу SMTP (Microsoft).

Служба SMTP поддерживает основные функции доставки сообщений SMTP. Она также позволяет выбрать настройку, удовлетворяющую специфическим требованиям доставки и безопасности почты.

В этом разделе содержатся общие сведения о службе SMTP.

  • Обзор службы SMTP (Microsoft)
  • Основные возможности
  • Компоненты
  • Обзор процессов


Обзор службы SMTP (Microsoft)

Этот раздел содержит общие сведения о настройке службы SMTP. Далее описано следующее.

  • Вкладки
  • Увеличение производительности системы


Вкладки

Для настройки службы SMTP (Microsoft) используется шесть вкладок. Их описание приведено в следующей таблице.

Вкладка | Описание
Общие | Содержит параметры, определяющие то, как сервер подключается к другим серверам для передачи и доставки почты. Вкладка может быть использована для включения журнала.
Доступ | Содержит настройки проверки подлинности и использования TLS-шифрования (разновидность SSL-шифрования) для всех протоколов и всех входящих подключений. Можно также предоставить или запретить как общий доступ, так и ретрансляцию к определенным компьютерам или сетям.
Сообщения | Настраивается ограничение сообщений и определяется, как поступать с сообщениями, которые невозможно доставить.
Доставка | Содержит параметры, определяющие, как сервер доставляет почту, включая количество отправок за сеанс, маршрут и повторную отправку почты.
Маршрутизация LDAP | Содержит параметры для протокола LDAP, позволяющего обращаться к каталогам, совместимым со структурой каталогов X.500.
Безопасность | Здесь назначаются пользователи, имеющие права настраивать службу SMTP.

Доступ ко вкладкам свойств SMTP-сервера обеспечивается через консоль MMC

  1. Выберите требуемый виртуальный SMTP-сервер.
  2. В меню Действие выберите Свойства.
  3. Перейдите на вкладку, с которой хотите работать.


Увеличение поизводительности системы

Изменение некоторых параметров настройки влияет на производительность системы. Сведения о том, как повысить быстродействие и оптимизировать доставку сообщений, содержатся в следующих разделах справки.

  • Настройка ограничения числа сообщений за сеанс
  • Настройка направляющего узла
  • Разрешение обратного поиска в DNS


Основные возможности

Служба SMTP (Microsoft) обеспечивает следующие возможности.

Поддержка стандартного протокола Интернета

Служба SMTP обеспечивает полную поддержку протокола SMTP и совместима с почтовыми клиентами SMTP.

Масштабируемость

Настройки нескольких доменов для одного сервера позволяют поддерживать сотни клиентских подключений к одному серверу.

Удобства администрирования и интеграция с Microsoft Windows 2000 Server

Для администрирования службы SMTP используется консоль MMC. Это средство входит в состав Информационных служб Интернета (IIS). Для сбора статистики, отслеживания сообщений и операций, оценки сценариев использования администраторы могут задействовать другие возможности администрирования сервера Windows 2000 Server, в том числе протокол SNMP, журналы событий, журналы операций.

Дополнительные средства безопасности

Для шифрования данных служба SMTP использует TLS-шифрование.

Управление получением почты

На своем домене по умолчанию служба SMTP помещает все входящие сообщения в каталог сбора. Это позволяет использовать службу SMTP в качестве получателя почты для других приложений.

Помимо подключения к порту TCP, для отправки почты приложения могут использовать каталог отбора. Служба SMTP доставляет сообщение после того, как оно скопировано в каталог отбора в виде текстового файла.


Компоненты

В этом разделе описываются компоненты службы SMTP (Microsoft), что они делают и как взаимодействуют. Раздел включает в себя следующие подразделы.

  • Настройка компонентов и консоли MMC
  • Связи между компонентами
  • Корневой почтовый каталог и каталоги по умолчанию


Настройка компонентов и консоли MMC

Все установленные на компьютере компоненты информационных служб Интернета (IIS) отображаются на консоли MMC. В структуре компонентов консоли служба SMTP (Microsoft) представлена узлом. При выделении узла, на панели подробностей отображаются более полные сведения о нем. В следующей таблице приведено описание узлов компьютера и службы SMTP.

Узел | Значок | Описание
Компьютер | Компьютер | Это главный компонент администрирования информационных служб Интернета. Здесь отображаются данные о каждой службе IIS, включая ее текущее состояние, IP-адрес и порт.
Виртуальный SMTP-сервер по умолчанию | Узел SMTP | Это основной компонент администрирования службы SMTP. Здесь предоставляется доступ к основным вкладкам свойств. Чтобы отобразить список доменов и текущих сеансов, дважды щелкните узел.
Домены | Домены | Это организационные компоненты службы SMTP. В этом узле предоставляется доступ к диалоговому окну Свойства домена, где можно создавать и настраивать домены, и отображаются данные обо всех установленных для узла доменах.
Текущие сеансы | Текущие сеансы | Здесь можно получить сведения о состоянии использования службы SMTP. Предоставляется доступ к списку пользователей, расположению источников и времени подключения для каждого сеанса.


Связи между компонентами

В окне консоли MMC видно, что виртуальный SMTP-сервер связан с работой службы SMTP (Microsoft) и других информационных служб Интернета (IIS). В виртуальный сервер включен домен по умолчанию, используемый для "штампования" сообщений с адресов, не имеющих домена. Домен по умолчанию нельзя удалить. Однако можно создать домен-псевдоним. Все домены-псевдонимы используют для "штампования" сообщений домен по умолчанию.

Более подробные сведения о доменах см. в разделе О доменах.


Корневой почтовый каталог и каталоги по умолчанию

Программа установки создает в корневом почтовом каталоге пять подкаталогов по умолчанию, чтобы служба SMTP (Microsoft) могла обрабатывать почту. Четыре из этих подкаталогов описаны в следующей таблице. Каталог «SortTemp», также создаваемый при установке, содержит временные файлы. Расположение корневого почтового каталога по умолчанию: root:\Inetpub\Mailroot, однако, во время установки можно назначить другое расположение. Подкаталоги корневого почтового каталога и их содержимое описаны в следующей таблице.

Папка | Описание
Badmail (каталог ошибочной почты) | Хранит недоставленные сообщения, которые невозможно вернуть отправителю.
Drop (каталог сбора) | Получает все входящие сообщения для всех ведомых компьютером доменов. Любой каталог может быть назначен каталогом сбора, кроме уже назначенного каталогом отбора.
Pickup (каталог отбора) | Обрабатывает исходящие сообщения, созданные и скопированные в этот каталог как текстовые файлы. Служба SMTP начинает доставку сообщения в формате, определенном документом RFC 822, как только оно скопировано в каталог отбора.
Queue (каталог очереди) | Хранит сообщения, ожидающие доставки. Если сообщение не может быть отправлено по причине занятости или повреждения подключения, то оно хранится в очереди и отправляется через заданные интервалы до успешного выполнения доставки.


Обзор процессов

Для передачи и доставки сообщений служба SMTP использует протокол SMTP (Simple Mail Transfer Protocol), описанный в документах RFC 821 и RFC 822. Почта передается между удаленными почтовыми серверами и каталогом сбора, назначенным для домена по умолчанию. Структура службы SMTP обеспечивает быстрое подключение и обработку максимального количества сообщений в секунду.

В этом разделе описывается процесс передачи и доставки сообщения с помощью службы SMTP. Далее описано следующее.

  • Обработка сообщений
  • Доставка локальных сообщений
  • Доставка удаленных сообщений


Обработка сообщений

После того, как сообщение скопировано в каталог отбора или поступило через назначенный порт TCP (по умолчанию принят порт 25), оно помещается в каталог очереди Queue. Если получатели находятся в пределах локальной сети, то сообщение доставляется. В противном случае сообщение обрабатывается для удаленной доставки. Схема обработки показана на следующем рисунке.

Схема обработки локальных и удаленных сообщений


Доставка локальных сообщений

Если сообщение предназначено локальному получателю, то оно перемещается из каталога очереди в каталог сбора, назначенный для домена по умолчанию. С помещением сообщения в каталог сбора цикл доставки службы SMTP (Microsoft) завершается. Каталог сбора может быть назначен в диалоговом окне Домен по умолчанию. Схема обработки показана на следующем рисунке.

Схема обработки сообщений по протоколу SMTP


Доставка удаленных сообщений

В следующей таблице описываются процессы, используемые службой SMTP (Microsoft) для доставки удаленных сообщений. Также указаны вкладки, используемые для настройки параметров.

Процесс | Описание
Сортировка почты и постановка ее в очередь для доставки | Сообщения остаются в каталоге очереди. Получатели для каждого сообщения отсортированы по доменам, так что служба SMTP может отправлять их группами. Это позволяет службе SMTP оптимизировать подключения, доставляя несколько сообщений в один сеанс.
Определение готовности принимающего сервера к получению почты. | Служба SMTP пытается связаться с почтовым сервером получателя. Если сервер не готов, то сообщение остается в очереди, а попытки связи возобновляются с назначенным интервалом вплоть до максимального количества попыток. Эти интервалы - параметры повторения - устанавливаются на вкладке Доставка.
Отправка сообщения. После того, как получатели проверены, сообщение отправляется. Доставка службой SMTP завершается получением подтверждения о передаче с сервера получателя. Ниже описаны параметры доставки.

Если для удаленной доставки включено TLS-шифрование, то служба SMTP шифрует все исходящие сообщения. Эту функцию можно включить или выключить для определенных удаленных доменов. TLS-шифрование может быть установлено в диалоговом окне Безопасность подключений после нажатия кнопки Безопасность подключений на вкладке Доставка.

Все сообщения для удаленных доменов могут быть отправлены на направляющий узел, который затем отправит сообщения получателям. Направляющий узел может быть назначен в диалоговом окне Дополнительная настройка доставки, которое вызывается нажатием кнопки Дополнительно на вкладке Доставка.

Подробнее об использовании вкладок для настройки службы SMTP см. раздел Обзор службы SMTP (Microsoft).


Сопровождение

В данном разделе описаны способы настройки службы SMTP и наблюдения за ее работой, которые позволяют анализировать настройку сервера и обеспечить эффективную обработку почты. Также приведены инструкции по остановке и приостановке службы SMTP для проведения наладочных работ. Раздел содержит следующие статьи.

  • Обзор средств наблюдения
  • Ведение журналов системных процессов
  • Наблюдение за производительностью и настройкой службы SMTP
  • Ведение журналов операций по обработке сообщений


Обзор средств наблюдения

Ниже перечислены средства отслеживания событий и производительности, которые применяются для устранения неисправностей и диагностики происшедших в системе изменений.

Журнал событий сервера Windows 2000 Server

Данное средство позволяет следить за работой службы SMTP при помощи информационных и предупреждающих записей, а также записей об ошибках, требующих внимания администратора. Имеются три вида журнала событий: системный журнал, журналы безопасности и приложений.

Запись событий начинается автоматически, независимо от того, запущен или нет сервер Windows 2000 Server. Для каждого типа журналов можно определить максимальные размеры, сроки хранения записанных данных, а также задать либо автоматический режим замены имеющихся записей при заполнении журнала, либо ручную очистку журнала.

Системный монитор

Это средство измеряет производительность службы SMTP. Системный монитор позволяет вести журнал статистики фактической нагрузки для любых компонентов системы. Это дает возможность проанализировать собранные данные и определить, необходимо ли изменение настроек для обеспечения эффективной обработки сообщений. Для сбора данных следует включить наблюдение и указать объект наблюдения.

Журнал

В журнал записываются операции по обработке отдельных сообщений, переданных по протоколу SMTP. Необходимо сначала разрешить ведение журнала, а затем определить частоту и формат записей.


Ведение журналов системных процессов

На сервере Windows 2000 Server имеется два журнала событий: журнал безопасности и системный журнал. Служба SMTP заносит в каждый журнал информационные и предупреждающие записи, а также записи об ошибках.

Эти журналы следует внимательно просматривать и периодически архивировать, чтобы избежать их переполнения. Для предупреждения потери данных необходимо время от времени проводить очистку журналов, тогда служба SMTP будет записывать новые события на свободное место, а не поверх старых.


Наблюдение за производительностью и настройкой службы SMTP

Данный раздел описывает, как с помощью системного монитора следить за производительностью и другими параметрами системы. В нем содержатся следующие статьи.

  • Обзор возможностей системного монитора
  • Наблюдение за производительностью
  • Наблюдение за загруженностью системы


Обзор возможностей системного монитора

После настройки системы, за ее работой можно наблюдать с помощью программы, называемой системным монитором. Системный монитор позволяет регистрировать статистику текущей нагрузки для любых объектов системы. Последующий анализ полученных сведений позволяет определить, как необходимо изменить настройку системы, чтобы обеспечить эффективную передачу сообщений.

Процесс регистрации событий можно настроить на различные виды данных. После определения объектов системы, за которыми нужно вести наблюдение, производится установка счетчиков, регистрирующих работу этих объектов. Для повышения качества наблюдения и реакции администратора на происходящие события можно настроить системный монитор таким образом, чтобы он подавал сигнал в случаях, когда показания счетчиков выходят за допустимые пределы. Собранные системным монитором данные можно экспортировать в электронные таблицы и базы данных для дальнейшего анализа.

Средства наблюдения позволяют:

  • наблюдать за работой одного или нескольких компьютеров одновременно;
  • наблюдать за производительностью в режиме реального времени в окне диаграмм, либо заносить данные в журналы для дальнейшей обработки.

Более подробные сведения об использовании системного монитора см. в справке и документации по серверу Windows 2000 Server.


Наблюдение за производительностью

Можно наблюдать за обработкой сообщений и подключениями для SMTP-сервера. Некоторые измеряемые величины приведены в следующей таблице.

Счетчик | Показание нормы | Описание
Длина локальной очереди | 0 | Количество сообщений в локальной очереди. Если показания счетчика >0, значит сервер получает больше сообщений, чем может обработать. При постоянном росте числа сообщений в очереди необходимо установить причину задержки их обработки.
Длина удаленной очереди | 0 | Количество сообщений в удаленной очереди. Если показания счетчика >0, значит сервер получает больше сообщений, чем может обработать. При стабильном росте количества сообщений в очереди необходимо установить причину задержки.
Текущее количество входящих подключений | >0 | Количество входящих подключений на данный момент. Показание счетчика «0» для продолжительного периода времени может указывать на неполадки в сети.


Наблюдение за загруженностью системы

Анализ фактического использования доступных ресурсов позволяет предвидеть возможный их дефицит. Наблюдение за загруженностью службы SMTP предполагает сравнение физических ресурсов службы с загруженностью службы SMTP. Если физический ресурс службы используется на все 100 процентов, то она полностью загружена. Такая служба выполняет запросы с задержкой.

Примечание. Чтобы проверить реальную загруженность сервера, запустите программу diskperf. Введите на сервере команду diskperf -y и перезапустите компьютер.

В следующей таблице приведены объекты, загруженность которых необходимо постоянно контролировать.

Объект | Счетчик | Показание нормы | Описание
Логический диск | % Время работы диска | <70% | Процент затраченного времени, приходящийся на выбранный диск, когда он занят обслуживанием запросов на чтение или запись. Если этот процент постоянно превышает 70%, то следует подумать о создании дополнительного SMTP-сервера.
Сбои и неполадки в системе | % Полное время работы процессоров | <70% | Средний процент затраченного времени, приходящийся на все процессоры системы. В системе с несколькими постоянно работающими процессорами этот процент равен 100%. Если процессоры загружены на 50%, то он равен 50%. Если одна четвертая часть процессоров загружена на 100%, а остальные находятся в состоянии бездействия, то он составляет 25%. Фактически этот процент является долей совокупного времени, затраченного процессорами на обработку потоков команд. Процессор, выполняющий непродуктивные циклы во время холостого потока команд, не может обрабатывать другие потоки.
Память | Доступные байты | >10% общей памяти | Параметр мгновенного подсчета памяти. Показывает размер текущей виртуальной памяти в списках обнуленной, свободной и резервной памяти. Память, заполненная нулями, называется обнуленной. Память, удаленная из рабочего процесса, но остающаяся доступной, называется резервной. Эти виды памяти всегда готовы для использования.


Ведение журналов операций по обработке сообщений

В данном разделе описано, как использовать журналы операций для наблюдения за передачей сообщений. В нем содержатся следующие статьи.

  • Обзор журналов
  • Форматы журналов
  • Сравнение форматов журналов
  • Планирование журналов протокола
  • Ведение журнала протокола


Обзор журналов

Обзор журналов протокола

В журналах протокола регистрируются команды, получаемые виртуальным SMTP-сервером от клиентов SMTP.

Для отслеживания команд используются четыре формата. В каждом из них одни и те же данные хранятся по-разному. Форматы различаются между собой степенью детализации, способом отображения и областью аналитического применения. При выборе формата следует определить объекты слежения, способы просмотра данных и методы отслеживания операций по обработке сообщений из других служб Internet Information Services (IIS) . См. также Планирование.

По умолчанию принимается расширенный формат файла журнала World Wide Web Consortium (W3C), но его можно заменить на другой. В трех из четырех форматов запись операций по обработке сообщений производится в текстовый файл. Можно задать период ведения записей и максимальные размеры файла. Когда размер файла достигнет максимально допустимой величины, будет создан новый файл. Чтобы избежать переполнения диска во время записи в файл журнала текущих операций, старые файлы следует копировать в архив и затем удалять. Имеется также формат, позволяющий собирать данные в базе данных, совместимой с драйвером ODBC.

Примечание. Данные форматы журналов и имена принятых по умолчанию файлов также используются в других службах Internet Information Services (IIS). Перед выбором формата службы SMTP следует определить объекты слежения для всех служб, количество используемых файлов и способ задания размера файлов. См. также Планирование.


Форматы журналов

Для журналов операций предусмотрено четыре формата. Различия и особенности форматов, а также примеры журналов можно найти в следующих разделах.

  • Сравнение форматов журналов
  • Формат файла журнала Microsoft IIS
  • Общий формат файла журнала NCSA
  • Расширенный формат файла журнала W3C
  • Ведение журнала базы данных, совместимой с драйвером ODBC


Сравнение форматов журнала

Следующие примеры показывают, как данные операций по обработке сообщений записываются и отображаются в каждом из четырех форматов. Журнальные записи передач сообщений по протоколу SMTP обычно содержат несколько частей. Для каждого формата показана только одна запись, чтобы иметь возможность сравнить различия форматов.

Например, пользователь Mariab, зарегистрированный на сервере Nwtraders.com, отправляет сообщение коллеге 18 августа 1997г. примерно в 13:17.

Формат файла журнала Microsoft IIS

10.456.789.1, Nwtraders.com, 8/18/97, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 90, 42, 0, 250, 0, MAIL FROM, -, FROM:<mariab@Nwtraders.com>,

Общий формат файла журнала NCSA

10.456.789.1 - Nwtraders.com [18/Aug/1997:13:17:37 - 0800] "MAIL FROM -? FROM: mariab HTTP/1.0 250 0

Расширенный формат файла журнала W3C

Следующие примеры включают только настройки по умолчанию. При необходимости их можно изменить.

13:17:37 10.456.789.1 MAIL FROM - 250

Ведение журнала в базе данных, совместимой с драйвером ODBC

В базе данных имеются следующие записи.

  • IP-адрес клиента
  • Имя домена клиента
  • Дата и время соединения
  • Служба IIS
  • Имя сервера
  • IP-адрес сервера
  • Время обработки в миллисекундах
  • Количество байт, полученных сервером
  • Количество байт, посланных сервером
  • Код ответа протокола SMTP
  • Код ошибки или состояния Win32
  • Команда протокола SMTP
  • Получатель
  • Параметры


Формат файла журнала Microsoft IIS

  • В этом формате данные записываются в текстовый файл в ASCII-кодах с разделением запятой.
  • Данные фиксированы; параметры журнала не могут быть изменены.
  • За одну передачу записывается несколько записей.

Чтобы увидеть полный список, щелкните какую-либо ссылку.

10.123.12.3,   Nwtraders.com,  8/18/97,  13:17:37,  SMTPSVC1, MAIL01,  10.200.200.1,  90, 42,  0,  250,  0,  MAIL FROM,  -,FROM:<someone@Nwtraders.com>,
10.123.12.3, Nwtraders.com, 8/18/97, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 0, 32, 0, 250, 0, RCPT TO, -, TO:<someone@microsoft.com>,
10.123.12.3, Nwtraders.com, 8/18/97, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 270, 480, 101, 250, 0, DATA, -, 0019E3517201287MAIL01,
10.123.12.3, Nwtraders.com, 8/18/97, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 81, 4, 52, 0, 541, QUIT, -, MAIL01,


Записи файла журнала Microsoft IIS

10.123.12.3, Nwtraders.com, 8/18/97, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 90, 42, 0, 250, 0, MAIL FROM, -, FROM:<someone@Nwtraders.com>,

Поле | Пример
IP-адрес клиента | 10.123.12.3
Имя домена клиента | Nwtraders.com
Дата соединения | 8/18/97
Время соединения | 13:17:37
Код узла и службы IIS | SMTPSVC1
Имя сервера | MAIL01
IP-адрес сервера | 10.200.200.1
Время обработки в миллисекундах | 90
Количество полученных байт | 42
Количество посланных байт | 0
Код ответа протокола SMTP | 250
Код ошибки или состояния Win32 | 0
Команда протокола SMTP | MAIL FROM
Дополнительное поле | -
Переменное поле, зависит от команды протокола | FROM:<someone@Nwtraders.com>


Расширенный формат файла журнала W3C

  • Этот формат используется службой SMTP, а также другими службами Internet Information Services (IIS) по умолчанию.
  • Данные переменны. Можно выбрать объект слежения.
  • Этот формат подходит для журнала ограниченного размера.
  • Сведения записываются в текстовый файл в ASCII кодах.
  • Этот формат содержит параметры поля, которые относятся только к службам Web и FTP.
  • Для одной передачи используется несколько записей.

Чтобы увидеть полный список, щелкните какую-либо ссылку.

1997-08-18  13:17:37  10.321.255.1  Nwtraders.com  MAIL01,   10.200.200.1  MAIL FROM  -  -  250  -  357  0  90  -  -  -  -
1997-08-18 13:17:37 10.255.255.1 Nwtraders.com SMTPSVC1 MAIL01 10.200.200.1 RCPT TO - +TO:+<someone@microsoft.com> 250 0 0 33 0 - - -
1997-08-18 13:17:37 10.255.255.1 Nwtraders.com SMTPSVC1 MAIL01 10.200.200.1 DATA - 001b60731171d87 250 0 101 1209 250 0 - - -
1997-08-18 13:17:37 10.255.255.1 Nwtraders.com SMTPSVC1 MAIL01 19.200.200.1 QUIT - Nwtraders.com 0 3215 52 4 291 0 - - -


Записи расширенного формата файла журнала WC3

Данные записи являются журнальными записями службы SMTP. Они несколько отличаются от аналогичных записей для служб Web и FTP. Пустые поля для текстовых значений, которые не применяются в службе SMTP, представляются в файле журнала дефисом (-) или нулем (0), а пустые поля для числовых значений - только нулем (0). В следующей таблице поля, выделенные полужирным шрифтом, относятся к записям файла журнала.

Поле | Поле журнала | Описание
Дата | Дата | Дата подключения
Время | Время | Время подключения
IP-адрес клиента | c-ip | IP-адрес клиента, доступного серверу
Имя домена клиента | cs-username | Доступный серверу клиент
Имя службы | s-sitename | Служба Internet Information Services (IIS)
Имя сервера | s-computername | Сервер, на котором создаются записи журнала
IP-адрес сервера | s-ip | IP-адрес сервера, на котором создаются записи журнала
Метод | cs-method | Посланная клиентом команда протокола SMTP
Ресурс URI | cs-uri-stem | Неприменим к службе SMTP
Запрос URI | cs-uri-query | Изменяется в службе SMTP; зависит от команды протокола SMTP
Состояние протокола HTTP | sc-status | Код ответа протокола SMTP
Состояние Win32 | sc-win32-status | Код ошибки или состояния сервера Windows 2000 Server; «0» обозначает отсутствие ошибки
Количество посланных байт | sc-bytes | Количество байт, посланных сервером
Количество полученных байт | cs-bytes | Количество байт, полученных сервером
Затраченное время | time-taken | Время, затраченное на операцию, в миллисекундах
Порт сервера | s-port | Неприменим к службе SMTP
Агент обработки | cs(User-Agent) | Неприменим к службе SMTP
Cookie | cs(Cookie) | Неприменим к службе SMTP
Источник ссылки | cs(Referrer) | Неприменим к службе SMTP


Общий формат файла журнала NCSA

  • Данные записываются в текстовый файл в ASCII кодах. В качестве формата используется формат Национального центра по применению суперкомпьютеров (NCSA).
  • Данные фиксированы; параметры журнала не могут быть изменены.
  • За одну передачу записывается несколько записей.

Чтобы увидеть весь список, щелкните какую-либо ссылку.

10.321.255.1 -  Nwtraders.com  [18/Aug/1997:13:17:37 - 0800] "MAIL FROM -? FROM: someone HTTP/1.0"  250 0
10.321.255.1 - Nwtraders.com[18/Aug/1997:13:17:37 - 0800] "RCPT TO -? TO: someone@microsoft.com HTTP/1.0" 250 0
10.321.255.1 - Nwtraders.com[18/Aug/1997:13:17:37 - 0800] "DATA -?000B72730441764MAIL01 HTTP/1.0" 250 97
10.321.255.1 - Nwtraders.com[18/Aug/1997:13:17:37 - 0800] "QUIT -?someone HTTP/1.0" 0 0


Записи журнала в общем формате NCSA

10.321.255.1 - Nwtraders.com [18/Aug/1997:13:17:37 - 0800] "MAIL FROM -? FROM: someone HTTP/1.0" 250 0

Поле | Пример
IP-адрес клиента | 10.321.255.1
Имя домена клиента | Nwtraders.com
Дата и время соединения | [18/Aug/1997:13:17:37 - 0800]
Команда протокола SMTP и связанные с ней сведения | "MAIL FROM -? FROM: someone HTTP/1.0"
Код ответа протокола SMTP | 250
Количество посланных байт | 0


Ведение журнала в базе данных, совместимой с драйвером ODBC

  • Перед использованием этого формата следует установить базу данных, совместимую с драйвером ODBC.
  • Сведения записываются в базу данных.
  • За одну передачу записывается несколько записей.

В следующей таблице приведены описания полей и типов данных файла журнала операций в формате базы данных, совместимой с драйвером ODBC.

Имя поля | Тип данных | Описание
ClientHost (Узел клиента) | Текстовый(255) | IP-адрес клиента
Пользователь | Текстовый(255) | Имя домена клиента
LogTime (Время операции) | Дата/время | Дата и время соединения
Service (Служба) | Текстовый(255) | Службы Internet Information Services (IIS)
Machine (Компьютер) | Текстовый(255) | Имя компьютера
ServerIP (IP-адрес сервера) | Текстовый(50) | IP-адрес сервера
ProcessingTime (Время обработки) | Целое | Время обработки в миллисекундах
BytesRecvd (Получено байт) | Целое | Количество байт, полученных сервером
BytesSent (Кол. отправленных байт) | Целое | Количество байт, посланных сервером
ServiceStatus (Состояние службы) | Целое | Код ответа протокола SMTP
Win32Status (Состояние Win32) | Целое | Код ошибки или состояния сервера Windows 2000 Server («0» обозначает отсутствие ошибки)
Operation (Операция) | Текстовый(255) | Команда протокола SMTP
Target (Получатель) | Текстовый(255) | Получатель
Параметры | Текстовый(255) |


Планирование журналов протокола

В данном разделе описываются способы планирования журналов протокола для службы SMTP и других служб Internet Information Services (IIS).

Использование настроек по умолчанию

Если использовать принятые по умолчанию настройки для всех служб IIS, то для каждой службы будет ежедневно создаваться журнал операций, однако форматы этих журналов будут разными. 1 Расширенный формат файла журнала W3C принимается по умолчанию службами Web и FTP. Записи операций, проходящих по этим службам, объединяются в отдельном файле с помощью параметров, принятых по умолчанию только для этого формата. Служба SMTP использует по умолчанию формат файла журнала Microsoft IIS. Записи операций этой службы также заносятся в отдельный файл.

Определение нужного формата

В разных службах IIS приняты по умолчанию разные форматы. Если требуется объединить записи всех служб в одном файле, нужно задать один и тот же формат для всех служб. При выборе формата следует определить, каким образом будут анализироваться и просматриваться данные. Один из четырех форматов осуществляет запись в базу данных, совместимую с драйвером ODBC, а три остальных - в текстовые файлы в ASCII-кодах либо с разделительной запятой, либо с разделительным пробелом.

Настройка файла журнала

При настройке файла журнала операций следует установить содержимое трех позиций.

Позиция | Описание
Частота записей | Определяется период регистрации файлов, которая может происходить ежедневно, еженедельно или ежемесячно.
Содержимое файла журнала | Определяется, какие данные будут содержаться в файле. Если для всех служб IIS заданы по умолчанию одни и те же имена файлов и один и тот же формат, записи операций по обработке сообщений могут быть объединены в один файл журнала. Чтобы создать отдельный файл для службы SMTP, когда для всех служб используется одинаковый формат, следует задать отдельный файл для журнала операций.
Размер файла журнала | Определяется размер файла журнала, который может быть неограниченным или определенным.


Ведение журнала протокола

Вкладка Общие предназначена для выбора формата журнала операций и его ведения. При настройке файла журнала помните, что форматы журналов и имена файлов по умолчанию являются теми же самыми, что используются другими информационными службами Интернета (IIS). Для ведения отдельных записей по каждой службе следует задать отдельные файлы. Если нужно вести записи раздельно, то можно назначить отдельный файл для каждой службы.

Если файл сохранен не в том месте, которое принято по умолчанию, следует убедиться, что он находится на локальном диске, а не в сети.

Активизация ведения журнала с использованием текстового формата ASCII

  1. На странице Общие установите флажок Вести журнал.
  2. В раскрывающемся списке Формат журнала выберите формат файла журнала операций.
  3. Нажмите кнопку Свойства, задайте местоположение и ограничение на размер файла журнала.
  4. Если выбран расширенный формат файла журнала W3C, перейдите на вкладку Расширенные свойства и выберите элементы, которые нужно отслеживать.

Активизация ведения журнала с использованием формата ODBC

  1. Создайте базу данных, совместимую с драйвером ODBC.
  2. На странице Общие установите флажок Вести журнал.
  3. В раскрывающемся списке Формат журнала выберите пункт Ведение журнала ODBC.
  4. Нажмите кнопку Свойства, задайте местоположение и ограничение на размер файла журнала.


Создание базы данных, совместимой с драйвером ODBC

  1. С помощью программы базы данных, такой как Microsoft Access или Microsoft SQL Server, создайте базу данных, совместимую с драйвером ODBC.
  2. В базе данных создайте таблицу с полями, список которых приведен ниже.

    Имя поля | Тип данных
    ClientHost (Узел клиента) | Текстовый(255)
    Пользователь | Текстовый(255)
    LogTime (Время операции) | Дата/время
    Service (Служба) | Текстовый(255)
    Machine (Компьютер) | Текстовый(255)
    ServerIP (IP-адрес сервера) | Текстовый(50)
    ProcessingTime (Время обработки) | Целое
    BytesRecvd (Получено байт) | Целое
    BytesSent (Кол. отправленных байт) | Целое
    ServiceStatus (Состояние службы) | Целое
    Win32Status (Состояние Win32) | Целое
    Operation (Операция) | Текстовый(255)
    Target (Получатель) | Текстовый(255)
    Параметры | Текстовый(255)


Предупреждение и устранение неполадок

Данный раздел содержит сведения по общим оперативным вопросам. В следующих статьях можно найти руководства по устранению возникающих неполадок.

  • Общие замечания по предупреждению и устранению неполадок
  • Сбои и неполадки при доставке сообщений
  • Сбои и неполадки в системе
  • Сбои и неполадки в службе SMTP


Общие замечания по предупреждению и устранению неполадок

Для предупреждения неполадок можно контролировать процесс передачи сообщений и изменять настройки системы. Для устранения неполадок существует несколько способов.

Регулярная диагностика

Настройка системы на регулярную диагностику процесса передачи сообщений и загруженности системы позволяет предупреждать появление неисправностей.

Настройка почтового ящика на получение отчетов ОНД и недоставленной почты

Служба SMTP не предусматривает создание почтовых ящиков. Чтобы получать копии отчетов о невозможности доставки (ОНД) и недоставленной почте, следует выбрать имя существующего почтового ящика на другом сервере и указать путь к нему. Например, можно создать почтовый ящик на сервере клиента, задать ему имя «Администратор почтового сервера и периодически просматривать отчеты ОНД и недоставленные сообщения, предупреждая тем самым возникновение проблем, связанных с передачей сообщений. Недоставленные сообщения имеют расширение bad.

Использование счетчиков производительности для определения загруженности сервера и причин перегрузок

Системный монитор представляет собой эффективное средство наблюдения за потоками данных. Регулярная проверка счетчиков позволяет проводить своевременную настройку параметров системы и не допускать критических ситуаций. Можно следить за такими параметрами, как количество сообщений в очереди, число подключений, среднее число повторов и получателей, количество посланных байт. Системный монитор является средством администрирования сервера Windows 2000 Server. При постоянном превышении значения одного из параметров обязательна проверка и настройка параметров системы.

Об использовании системного монитора см. также раздел Наблюдение за производительностью и настройкой службы SMTP.

Определение причины

При обнаружении неполадок следует установить причины их возникновения. Для анализа критической ситуации предусмотрены следующие операции.

Просмотр событий в окне просмотра событий

В трех журналах событий - в системном, безопасности и приложений - ведется запись событий службы SMTP и других компьютерных процессов. Необходимо внимательно просмотреть содержимое этих журналов, чтобы установить причину возникшей неполадки.

Просмотр rtr-файлов в каталоге очереди для выяснения причины недоставки сообщений

Доставка сообщений может оказаться невозможной из-за отключения удаленного сервера, переполнения очереди или по другим причинам. В этом случае следует открыть файлы с расширением rtr в каталоге очереди и определить причину невозможности доставки сообщений при первой попытке отправки и причину образования очереди.


Доставка

Недостаток свободного места на диске или неправильно заданный путь чаще всего становятся причиной неполадок при доставке сообщений. Данный раздел содержит следующие статьи.

  • Сбои при доставке сообщений в каталог сбора
  • Сбои при доставке сообщений в удаленный домен
  • Удаленные сообщения не проходят через направляющий узел
  • Имя подменяющего домена задано, но заголовок «From» не изменился


Сбои при доставке сообщений в каталог сбора

Ситуация | Каталог или диск переполнены.
Решение | Очистите каталог сбора и по возможности освободите дополнительное место на диске.

Ситуация | Для каталога указан недопустимый путь.
Решение | Проверьте путь к каталогу сбора в диалоговом окне Свойства домена по умолчанию. Этот каталог должен быть расположен на локальном диске.


Сбои при доставке сообщений в удаленный домен

Ситуация | Неверно указан путь маршрутного домена, который выдает ошибку "Узел недостижим".
Решение | Проверьте путь, заданный в диалоговом окне Свойства удаленного домена.
Ситуация | Сервер-получатель отключен; сообщение не доставлено по неизвестной причине.
Решение | Для выяснения причины проверьте rtr-файлы формата в каталоге Queue. Проверьте счетчики повторов с помощью системного монитора. Проверьте сервер-получатель.

Ситуация | Неверно указано имя или адрес.
Решение | Проверьте имя и путь.

Ситуация | Для подключения требуется TLS-шифрование (Transport Layer Security). Возможно, используется недопустимый сертификат ключа или неподходящий уровень шифрования.
Решение | Возможно, использование TLS-шифрования было задано в диалоговом окне Свойства удаленного домена. Проверьте уровень TLS-шифрования, заданный в диалоговом окне Безопасность. Убедитесь в том, что этот уровень поддерживается принимающим сервером. Используйте Диспетчер ключей для установки пар ключей.


Удаленные сообщения не проходят через направляющий узел

Ситуация | Маршрутный домен предназначен для удаленного домена и игнорирует настройку направляющего узла.
Решение | Измените настройку маршрутного домена. Маршрутный домен не может одновременно быть доменом, принятым по умолчанию, а также выступать под альтернативным именем.

Ситуация | Домен, принятый по умолчанию, или домен-псевдоним задан как направляющий узел. Нельзя использовать локальный домен вместо направляющего узла.
Решение | Измените настройку направляющего узла в диалоговом окне Дополнительная настройка доставки, нажав кнопку Дополнительно на вкладке Доставка.


Имя подменяющего домена задано, но заголовок «From» не изменился.

Ситуация | В заголовке «From» нет имени подменяющего домена.
Решение | Заголовок «From» изменяется только для первой пересылки.


Сбои и неполадки в системе

Неисправленные ошибки доставки могут привести к сбоям в системе. В данном разделе имеется одна статья.

  • Ошибка "Недостаточно памяти"


Ошибка "Недостаточно памяти"

Ситуация Невозможно отправить полученные сообщения для дальней доставки, что стало причиной образования очереди. Каждое полученное сообщение ассоциировано с соответствующим объектом в памяти. Когда сообщения сохраняются в каталоге сбора, они автоматически удаляются из памяти. Если сообщения не могут быть доставлены, и в памяти находится более 100 тысяч объектов (значение по умолчанию), то генерируется системная ошибка "Недостаточно памяти".
Решение Проверьте перечисленные ниже счетчики производительности.

Длина локальной очереди

Длина удаленной очереди

Длина очереди локальных повторов

Длина очереди удаленных повторов

Если первые два счетчика имеют значение "0", значит сообщения были доставлены сразу по их получении. Если счетчики показывают больше нуля, значит произошла задержка.

Если счетчики очередей повторов показывают высокие значения, значит сообщения не были доставлены. Чтобы выяснить причину сбоя, следует открыть rtr-файлы.

Например, при выключенном удаленном сервере показания счетчика длины очереди удаленных повторов будут иметь высокое значение, а в rtr-файлах каталога очереди появятся сообщения об ошибке "Узел не найден."


Сбои и неполадки в службе SMTP (Microsoft)

Данный раздел описывает ошибки и неполадки, обычно возникающие при работе службы SMTP, и содержит следующие статьи.

  • При запуске службы SMTP не запускается виртуальный SMTP-сервер
  • Оснастка SMTP не отображается в консоли MMC
  • Каталог очереди содержит файлы с расширением bad
  • Клиент не может установить соединения


При запуске службы SMTP не запускается виртуальный SMTP-сервер

Ситуация | С помощью консоли MMC был отключен узел и остановлена служба SMTP, после чего служба SMTP была запущена из командной строки.
Решение | Используя консоль MMC, перезапустите виртуальный SMTP-сервер.


Оснастка SMTP не отображается на консоли MMC

Ситуация | Консоль MMC была открыта из командной строки.
Решение | Добавьте оснастку SMTP вручную.


Каталог очереди содержит файлы с расширением .bad

Ситуация | Каталог ошибочной почты переполнен, и файлы с расширением bad остаются в каталоге очереди.
Решение | Удалите сообщения из каталога ошибочной почты.


Клиент не может установить соединения

Ситуация | Клиенту запрещен доступ.
Решение | Проверьте права доступа для компьютера клиента на вкладке Безопасность.


Добавление оснастки SMTP вручную

  1. Выберите в меню Консоль команду Добавить/Удалить оснастку.
  2. В поле Оснастки: выберите пункт Информационные службы Интернета.
  3. Нажмите кнопку Добавить.
  4. Выберите в списке пункт Информационные службы Интернета (IIS).
  5. Перейдите на вкладку Расширения.
  6. Выберите Протокол SMTP.


Перезапуск виртуального SMTP-сервера с помощью консоли MMC

  1. Выберите требуемый виртуальный SMTP-сервер.
  2. В меню Действие выберите команду Запуск.


Уведомление об авторском праве

Документация корпорации Майкрософт

В содержание данного документа, включая адреса URL и другие ссылки на веб-узлы, могут быть внесены изменения без предварительного уведомления. Названия организаций, имена и даты, используемые в качестве примеров, являются вымышленными, если не оговорено обратное. Пользователь несет ответственность за соблюдение всех применимых в данном случае законов об авторском праве. Никакая часть настоящего руководства ни в каких целях не может быть воспроизведена или передана в какой бы то ни было форме и какими бы то ни было средствами, будь то электронные или механические, включая фотокопирование и запись на магнитный носитель, если на то нет письменного разрешения корпорации Майкрософт (Microsoft Corp).

Корпорация Microsoft может являться правообладателем патентов и заявок, поданных на получение патента, товарных знаков и объектов авторского права, которые имеют отношение к содержанию данного документа. Предоставление вам данного документа не означает передачи какой-либо лицензии на использование данных патентов, товарных знаков, и объектов авторского права, за исключением того использования, которое явно оговорено в лицензионном соглашении корпорации Майкрософт.

© Корпорация Майкрософт (Microsoft Corp.), 2001. Все права защищены.

Microsoft, Active Directory, MS-DOS, Win32, Windows и Windows NT являются охраняемыми товарными знаками корпорации Microsoft в США и других странах.

Названия других продуктов или предприятий, указанные здесь, могут быть товарными знаками соответствующих владельцев.


Создание базы данных, совместимой с драйвером ODBC

Настройка ODBC-совместимой базы данных

  1. С помощью программы базы данных, например, Microsoft Access или Microsoft SQL Server, создайте базу данных, совместимую с драйвером ODBC.
  2. В базе данных создайте таблицу с полями, список которых приведен ниже.

    Имя поля | Тип данных
    ClientHost (Узел клиента) | Текстовый(255)
    Пользователь | Текстовый(255)
    LogTime (Время операции) | Дата/время
    Service (Служба) | Текстовый(255)
    Machine (Компьютер) | Текстовый(255)
    ServerIP (IP-адрес сервера) | Текстовый(50)
    ProcessingTime (Время обработки) | Целое
    BytesRecvd (Получено байт) | Целое
    BytesSent (Кол. отправленных байт) | Целое
    ServiceStatus (Состояние службы) | Целое
    Win32Status (Состояние Win32) | Целое
    Operation (Операция) | Текстовый(255)
    Target (Получатель) | Текстовый(255)
    Параметры | Текстовый(255)