Наблюдение за производительностью

Компоненты «Системный монитор» и «Оповещения и журналы производительности» консоли управления предоставляют подробные сведения об использовании ресурсов операционной системы.

  • Прежде чем начать наблюдение, ознакомьтесь с разделом Контрольный список для наблюдения за производительностью.
  • Описания средств, изменившихся в Windows XP, см. в разделе Новые способы выполнения типичных задач.
  • Советы по наблюдению за производительностью содержатся в разделе Советы и рекомендации.
  • Справочные сведения по конкретным задачам см. в разделе Инструкции.
  • Сведения общего характера см. в разделе Основные понятия.
  • Рекомендации по устранению возможных неисправностей см. в разделе Устранение неполадок.


Контрольный список для наблюдения за производительностью

Действие | Справочные сведения
Ознакомьтесь с основными понятиями наблюдения за производительностью. | Введение в наблюдение за производительностью; Советы и рекомендации
Убедитесь в наличии разрешений, необходимых для наблюдения за определенным компьютером. | Настройка конфигурации подсистемы наблюдения
Настройте конфигурацию подсистемы наблюдения. | Настройка конфигурации подсистемы наблюдения
По результатам наблюдения определите средний уровень производительности. | Анализ данных о производительности
Изучите изменения в данных о производительности и настройте необходимым образом компоненты. | Повышение производительности системы
Создайте архив данных о производительности, чтобы использовать их позже для анализа тенденций. | Выявление тенденций и планирование наращивания ресурсов


Новые способы выполнения типичных задач

В следующей таблице содержится список типичных задач для компонентов «Системный монитор» и «Оповещения и журналы производительности» консоли «Производительность» (Perfmon.msc). В ней также указано, с помощью каких средств эти задачи где можно выполнить в Windows XP и Windows 2000. Для пользователей предыдущей версии системного монитора (Perfmon.exe) в таблице указаны средства Windows NT 4.0. Многие кнопки панели инструментов не изменились и могут использоваться вместо приведенных последовательностей действий.

Задача | Средство Windows NT 4.0 | Средство Windows 2000 или Windows XP
Создание диаграммы, на основе данных о производительности. | Системный монитор в меню Администрирование. | Компонент Системный монитор консоли «Производительность», открываемой из окна «Администрирование».
Создание отчета. | Системный монитор в меню Администрирование. | Компонент «Системный монитор» консоли «Производительность», открываемой из окна «Администрирование».
Создание журнала. | Системный монитор в меню Администрирование. | Компонент «Оповещения и журналы производительности» консоли «Производительность» или компонент «Служебные программы» оснастки «Управление компьютером», открываемой из окна «Администрирование».
Просмотр данных журнала. | Системный монитор в меню Администрирование. | Компонент «Системный монитор» консоли «Производительность», открываемой из окна «Администрирование».
Создание оповещения. | Системный монитор в меню Администрирование. | Компонент «Оповещения и журналы производительности» консоли «Производительность» или компонент «Служебные программы» оснастки «Управление компьютером», открываемой из окна «Администрирование».
Создание рабочего пространства с несколькими представлениями. | Системный монитор в меню Администрирование. | Консоль управления MMC, меню Файл, команда Добавить/удалить оснастку.

Системный монитор для Windows NT 4.0 см. на веб-узле Microsoft Windows Resource Kits (http://www.microsoft.com/).

Системный монитор Windows XP позволяет открывать файлы параметров, созданные в системном мониторе для Windows NT 4.0.


Советы и рекомендации

  • Настройка конфигурации подсистемы наблюдения

    Настройте компонент «Оповещения и журналы производительности» на регистрацию данных рекомендуемых счетчиков через равные интервалы времени (например, каждые 10 или 15 минут). Не удаляйте журналы продолжительное время, храните данные в базе данных и запрашивайте их для составления отчетов и проведения анализа в целях оценки общей производительности, анализа тенденций и планирования ресурсов.

    Для достижения наилучших результатов перед запуском на наблюдаемом компьютере системного монитора или компонента «Оповещения и журналы производительности»:

    • остановите программы-заставки;
    • отключите ненужные или не относящиеся к наблюдению службы;
    • увеличьте размер файла подкачки так, чтобы он полтора раза превышал объем физической памяти компьютера;
    • в редакторе реестра просмотрите записи в следующих подразделах реестра и убедитесь, что они имеют ненулевые значения:
      • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SessionManager\Memory Management
      • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

      Внимание!

      • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных.

      Для повышения производительности можно изменить некоторые из этих значений. Сведения об изменении значений реестра см. в разделе Общие сведения о редакторе реестра.

    • Если необходмый сервер не работает или не отвечает, запустите системный монитор с другого компьютера.
  • Снижение нагрузки, создаваемой подсистемой наблюдения

    Как правило, средства наблюдения за производительностью рассчитаны на минимальную дополнительную нагрузку системы. Однако при выполнении каждого из следующих условий нагрузка может увеличиваться:

    • системный монитор запущен в режиме диаграммы;
    • в режиме отчета выбран вариант, не используемый по умолчанию (текущее значение);
    • выборка данных происходит с большой частотой (с интервалом менее 3 секунд);
    • выбрано множество различных объектов и счетчиков.

    Кроме того, на работу средств наблюдения за производительность также влияют размер файла и дисковое пространство, занимаемое файлами журнала. Чтобы уменьшить размер файла и занимаемое дисковое пространство, увеличьте интервал обновления. Кроме того, журнал не должен размещаться диске, за которым ведется наблюдение. При частом обращении к файлу журнала также возрастает количество дисковых операций ввода-вывода.

    Если излишняя нагрузка нежелательна, запускайте только службу «Оповещения и журналы производительности», и не системный монитор в режиме диаграммы.

    Во время удаленного ведения журнала при частом обновлении производительность может уменьшаться из-за повышения нагрузки сети. В этом случае рекомендуется вести журнал на удаленном компьютере, а потом загружать его файлы для анализа, например, раз в день.

  • Анализ результатов наблюдения за производительностью и определение ее среднего уровня

    Просмотрите данные журнала в виде диаграммы в системном мониторе или экспортируйте их для печати. Сравните значения с пороговыми значениями счетчиков, приведенными в разделе Анализ данных о производительности, чтобы убедиться в том, что показатели использования ресурсов и других операций лежат в пределах допустимых значений. Определите средний уровень производительности, соответствующий обычной рабочей нагрузке.

  • Задание оповещений

    Настройте оповещения, задав пороговые значения счетчиков, исходя из полученной оценки среднего уровня производительности.

  • Настройка с целью повышения производительности

    Измените настройку системы и рабочую нагрузку для повышения производительности и повторите наблюдение, чтобы посмотреть на результаты внесенных изменений.

    Инструкции по изменению конфигурации и выполнению других задач повышения производительности содержатся в разделе Повышение производительности системы.
  • Планирование

    Наблюдайте за изменением производительности для планирования ресурсов и наращивайте их по мере необходимости. Храните данные журнала в базе данных и отмечайте изменения потребности в ресурсах. Выявив изменения в потоке операций или спросе на ресурсы, можно определить, какие дополнительные ресурсы требуются.


Инструкции

  • Работа со счетчиками
  • Работа в разных режимах наблюдения
  • Работа с данными
  • Работа с параметрами
  • Создание и настройка журналов счетчиков
  • Создание и настройка журналов трассировки
  • Создание и настройка оповещений
  • Работа с журналами и оповещениями


Работа со счетчиками

  • Добавление счетчиков
  • Удаление счетчиков
  • Просмотр описаний счетчиков


Добавление счетчиков в системном мониторе

Рисунок Microsoft Windows

Чтобы добавить счетчики в системном мониторе

  1. Откройте оснастку Производительность.
  2. Щелкните правой кнопкой мыши область сведений системного монитора и выберите команду Добавить счетчики.

    Или, нажмите кнопку Добавить на панели инструментов.

  3. Для наблюдения за любым компьютером, на котором работает консоль наблюдения, выберите вариант Использовать локальные счетчики.

    Или, для наблюдения за счетчиками какого-либо компьютера независимо от того, где запущена консоль наблюдения, выберите вариант Выбрать счетчики с компьютера и укажите имя компьютера (по умолчанию задано имя локального компьютера).

  4. В списке Объекты выберите объект для наблюдения. По умолчанию выбран объект «Процессор».
  5. Для наблюдения за всеми счетчиками установите режим Все счетчики.

    Или, для наблюдения только за отдельными счетчиками установите режим Выбрать счетчики из списка, а затем выберите требуемые счетчики. По умолчанию выбран счетчик «% загруженности процессора».

  6. Для наблюдения за всеми экземплярами выбранных счетчиков установите режим Все вхождения.

    Или, для наблюдения только за отдельными экземплярами установите режим Выбрать вхождения из списка, а затем выберите требуемые экземпляры. По умолчанию выбран элемент «_Total».

  7. Нажмите кнопку Добавить.

Примечания

  • XOX
  • По умолчанию в системном мониторе отображаются три счетчика: Память\Обмен страниц в сек, Физический диск(_Total)\Средняя длина очереди диска и Процессор(_Total)\% загруженности процессора.
  • Если выбран объект на удаленном компьютере, можно заметить небольшую задержку, так как происходит обновление списка объектов, присутствующих на удаленном компьютере.
  • При создании консоли наблюдения для экспорта убедитесь, что выбран вариант Использовать локальные счетчики. В противном случае системный монитор будет получать данные с компьютера, имя которого задано в поле, независимо от того, где установлен файл консоли.
  • Для получения описания счетчика выделите его в окне Добавить счетчики и нажмите кнопку Объяснение.
  • Для отображения суммы значений всех экземпляров определенного счетчика выберите элемент _Total.
  • Пока не включен режим получения данных из журнала, в списке можно выделять только активные экземпляры.
  • По умолчанию счетчики обозначаются и названием, и номером экземпляра. Чтобы отключить эту функцию, щелкните правой кнопкой мыши область сведений, выберите команду Свойства, откройте вкладку Общие и снимите флажок Допускать дублирование счетчиков.
  • Объекты некоторых типов могут иметь несколько экземпляров. Например, в многопроцессорных системах существует несколько экземпляров объекта «Процессор». Объект «Физический диск» будет иметь две копии в системе с двумя жесткими дисками. Некоторые объекты, такие как «Память» и «Сервер», существуют только в одном экземпляре. Для сбора статистики по нескольким экземплярам объекта могут быть заданы несколько счетчиков, а во многих случаях для всех экземпляров можно задать общий счетчик.
  • Если выбраны номера двух экземпляров одного счетчика, например при наблюдении за несколькими потоками одного процесса, имейте в виду, что номер, назначенный экземпляру, может меняться со временем при запуске и остановке экземпляра счетчика (в данном примере — потока). Нельзя рассчитывать на то, что потоку на протяжении всего времени наблюдения за процессом будет соответствовать один номер.
  • По умолчанию к именам процессов и потоков добавляется суффикс #n (где n — целое число). Чтобы вместо числа добавлять код процесса, создайте в реестре параметр типа DWORD с именем ProcessNameFormat в разделе HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PerfProc\Performance и задайте для него значение 2. Аналогично, для добавления кода потока создайте в реестре параметр типа DWORD с именем ThreadNameFormat в разделе HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PerfProc\Performance и задайте для него значение 2. Для отключения любого из этих параметров и возвращения к настройке по умолчанию задайте для соответствующего параметра значение 1.
  • На вкладке Данные диалогового окна Свойства: Системный монитор можно изменить используемые по умолчанию параметры отображения счетчиков, такие как цвет, тип и ширина линии, а также масштаб отображения. Чтобы открыть вкладку Данные, щелкните правой кнопкой мыши область сведений и выберите команду Свойства.
См. также


Удаление счетчиков системного монитора

Рисунок Microsoft Windows

Чтобы удалить счетчики системного монитора

  1. Откройте оснастку Производительность.
  2. В области сведений системного монитора выделите название счетчика в области условных обозначений.
  3. Нажмите клавишу DELETE.

Примечания

  • XOX
  • Счетчики также можно удалять с помощью кнопки Удалить на вкладке Данные диалогового окна Свойства: Системный монитор.
  • Чтобы удалить все счетчики, нажмите на панели инструментов кнопку Новый набор счетчиков.
  • Чтобы удалить из окна все отображаемые данные, нажмите кнопку Очистить экран. (Эта кнопка доступна только при работе с текущими данными, а не с данными из журнала).

См. также


Просмотр описаний счетчиков

Рисунок Microsoft Windows

Чтобы просмотреть описание счетчика

  1. Откройте оснастку Производительность.
  2. Щелкните правой кнопкой мыши область сведений системного монитора и выберите команду Добавить счетчики.
  3. В списке Объект выберите объект.
  4. В списке Выбрать счетчики из списка выделите необходимый счетчик.
  5. Нажмите кнопку Объяснение.

Примечания

  • XOX
  • При работе с системным монитором можно сопоставить линию графика со счетчиком, поставляющим исходные данные. Для этого в области условных обозначений дважды щелкните счетчик или выделите счетчик, а затем нажмите кнопку Выделить на панели инструментов. Если линии на диаграмме расположены слишком близко, попробуйте найти точку, где они расходятся. В противном случае возможна ошибка при определении значения интересующего счетчика.

  • Дополнительные сведения о счетчиках производительности см. в справочном файле Windows Performance Counter Reference (Counters.chm) на компакт-диске Microsoft Windows Resource Kits (http://www.microsoft.com/).


Работа в разных режимах наблюдения

  • Работа с данными журнала
  • Смена счетчиков и изменение их свойств
  • Изменение параметров выборки данных
  • Наблюдение за другим компьютером
  • Выделение данных счетчика
  • Выход из режима отображения графика
  • Добавление заголовка, сетки и других атрибутов
  • Смена цветов фона, диаграммы и текста, а также изменение свойств шрифта


Использование данных журнала

Рисунок Microsoft Windows

Чтобы использовать данные журнала

  1. Откройте оснастку Производительность.
  2. Щелкните правой кнопкой мыши область сведений системного монитора и выберите команду Свойства.
  3. Откройте вкладку Источник.
  4. Установите переключатель Источник данных в положение Файлы журнала, а затем добавьте один или несколько файлов, которые следует использовать в качестве источника данных.

    Чтобы добавить файл в список, нажмите кнопку Добавить для открытия диалогового окна Выбор файла журнала. Дважды щелкните имя необходимого файла.

    Или, чтобы удалить файл из списка, нажмите кнопку Удалить.

  5. Нажмите кнопку Диапазон времени. Чтобы задать отображаемый диапазон времени для файлов журналов, перетащите прямоугольник или ползунки его границ для выбора требуемого начального и конечного времени.
  6. На вкладке Данные нажмите кнопку Добавить, чтобы открыть диалоговое окно Добавить счетчики. Будут показаны счетчики, выбранные в ходе настройки журнала. Все или некоторых из них можно добавить на диаграмму.

Примечания

  • XOX
  • Если не требуется особое наблюдение за событиями запуска, следует исключить интервал появления таких событий из наблюдаемого диапазона времени, поскольку они изменяют общую картину результатов.
  • При просмотре данных журнала кнопка Очистить экран на панели инструментов недоступна.
  • Данные журнала счетчиков также можно просмотреть, открыв в Microsoft Excel файлы, сохраненные в текстовом формате с разделителями-запятыми или разделителями-знаками табуляции.
  • Чтобы просмотреть данные из базы данных SQL, откройте вкладку Источник. Далее, установите переключатель Источник данных в положение База данных, а затем введите имя источника в поле DSN системы и выберите набор журналов в списке Набор журналов. Для доступа к базе данных SQL должно быть заранее определено имя системы DSN (System DSN, System Database Source Name), а пользователь должен иметь право записи в эту базу данных. Набор журналов, определяемый DSN, должен быть уже создан в базе данных.
  • В списке Выбрать счетчики из списка можно выделить несколько счетчиков (в том числе и несмежные). Чтобы выделить несколько счетчиков, нажмите клавиши SHIFT+ СТРЕЛКА ВНИЗ. Чтобы выделить несмежные счетчики, щелкайте элементы списка Выбрать счетчики из списка, удерживая нажатой клавишу CTRL.

См. также


Смена счетчиков и изменение их свойств

Рисунок Microsoft Windows

Чтобы сменить счетчики и изменить их свойства

  1. Откройте оснастку Производительность.
  2. Щелкните правой кнопкой мыши область сведений системного монитора и выберите команду Свойства.
  3. На вкладке Данные установите требуемые параметры.
    • Добавить. Открытие диалогового окна Добавить счетчики для выбора дополнительных счетчиков.
    • Удалить. Удаление счетчика, выделенного в списке счетчиков.
    • Цвет. Цвет выбранного счетчика.
    • Масштаб. Масштаб отображения выбранного счетчика в режиме графика или гистограммы. Значения счетчика могут масштабироваться экспоненциально от 0,0000001 до 1000000,0. Изменение масштаба позволит сделать диаграмму более наглядной. При этом оно не влияет на статистические данные, отображаемые в строке значений.
    • Ширина. Ширина линии выбранного счетчика. Следует иметь в виду, что изменение ширины влияет набор доступных типов линии.
    • Стиль. Тип линии выбранного счетчика. Смена типа возможна, если для линии выбрана ширина, назначенная для использования по умолчанию.

Примечания

  • XOX
  • По умолчанию системный монитор отображает данные счетчиков «Обмен страниц в сек», «Средняя длина очереди диска» и «% загруженности процессора» для локального компьютера.

См. также


Изменение параметров выборки данных

Рисунок Microsoft Windows

Чтобы изменить параметры выборки данных

  1. Откройте оснастку Производительность.
  2. Щелкните правой кнопкой мыши область сведений системного монитора и выберите команду Свойства.
  3. На вкладке Общие установите требуемые параметры выборки данных.
    • Для автоматической выборки данных через определенные промежутки времени установите флажок Снимать показания каждые и введите в поле сек значение интервала (в секундах). По умолчанию этот интервал равен 1 сек.
    • Для выборки данных вручную снимите флажок Снимать показания каждые. Для выборки данных вручную также служит кнопка панели инструментов Не изменять отображение.

      Снятие показаний счетчиков в режиме выборки данных вручную выполняется кнопкой Обновить данные.

Примечания

  • XOX
  • Чтобы удалить из окна все отображаемые данные, нажмите на панели инструментов кнопку Очистить экран. (Эта кнопка доступна только при работе с текущими данными, а не с данными из журнала).

См. также


Наблюдение за другим компьютером

Рисунок Microsoft Windows

Чтобы провести наблюдение за другим компьютером

  1. Откройте оснастку Производительность.
  2. Щелкните правой кнопкой мыши область сведений системного монитора и выберите команду Добавить счетчики.
  3. Установите режим Выбрать счетчики с компьютера и введите имя наблюдаемого компьютера в формате UNC (Uniform Naming Convention — единая система именования), например \\MyLogServer.

    Данные счетчиков будут получаться с указанного компьютера независимо от того, где запущен системный монитор.

  4. В списке Объект выберите объект для наблюдения.
  5. В списке Выбрать счетчики из списка выделите один или несколько счетчиков и выберите вариант Все счетчики, чтобы задействовать все счетчики данного объекта.
  6. Для использования всех экземпляров счетчиков, доступных в системном мониторе, выберите вариант Все вхождения.

    Или, для наблюдения только за отдельными экземплярами установите режим Выбрать вхождения из списка, а затем выберите необходимые экземпляры.

Примечания

  • XOX
  • Если у пользователя недостаточно прав для наблюдения за компьютером, будет выдано сообщение об ошибке; при этом области условных обозначений диаграммы счетчик останется, но данные отображаться не будут.
  • Если выбран объект удаленного компьютера, можно заметить небольшую задержку, поскольку происходит обновление списка объектов, присутствующих на этом компьютере.
  • Если необходимый счетчик отсутствует, возможно, служба или средство, предоставляющие соответствующий объект, не установлены или не включены на данном компьютере. В этом случае для получения необходимых данных следует установить или включить службу или средство.


Выделение данных счетчика

Рисунок Microsoft Windows

Чтобы выделить данные счетчика

  1. Откройте оснастку Производительность.
  2. В области условных обозначений выберите счетчик, данные которого требуется выделить.
  3. Нажмите кнопку Выделить или клавиши CTRL+H.

    Цветная линия выбранного счетчика будет заменена толстой линией. Для белого и светлого фона (определяемого свойством BackColor) эта линия черная, для остальных цветов фона она белая.

Примечания

  • XOX
  • При работе с элементом «Системный монитор» в Microsoft Word имейте в виду, что по умолчанию сочетание клавиш CTRL+H уже используется в Microsoft Word и может конфликтовать с сочетанием клавиш, принятым для выделения в системном мониторе. При использовании в Microsoft Word элемента «Системный монитор» (файл Sysmon.ocx, папка системный_корневой_каталог\System32) для поддержки функции выделения может потребоваться изменение существующей настройки.


Выход из режима отображения графика

Рисунок Microsoft Windows

Чтобы выйти из режима отображения графика

  1. Откройте оснастку Производительность.
  2. На панели инструментов нажмите кнопку Просмотр гистограммы, чтобы перейти в режим отображения гистограммы, или кнопку Просмотр отчета, чтобы перейти в режим отображения отчета.

Примечания

  • XOX
  • Способ отображения также можно задать, изменив значение параметра Вид на вкладке Общие диалогового окна Свойства: Системный монитор.
  • В отчете системного монитора данные и путь счетчика отображаются не так, как на диаграмме. В режиме отчета сведения отображаются в столбцах, где названия счетчиков и данные сгруппированы по связанным с ними объектам производительности.

    Данные из строки значений диаграммы в отчет не включаются. Используя вкладку Общие диалогового окна Свойства: Системный монитор, можно выбрать одно значение, отображаемое в отчете: последнее (используется по умолчанию), текущее, среднее, минимальное или максимальное. По умолчанию для отчетов по текущей активности используется текущее значение, а для данных из журнала — среднее.

  • Если в режиме просмотра отчета выбрано среднее, минимальное или максимальное значение, отображаемые данные пересчитываются после очередной выборки. Это приводит к дополнительной нагрузке на систему.
  • В режиме гистограммы линии графика заменяются столбцами. Остальные элементы отображаются так же, как и в режиме графика.
  • Если установлен соответствующий флажок, панель инструментов отображается во всех режимах.
  • По умолчанию числовые значения выводятся без разделителей групп разрядов. Чтобы включить отображение разделителей групп разрядов, с помощью редактора реестра создайте параметр типа DWORD с именем DisplayThousandsSeparator в подразделе HKEY_CURRENT_USER\Software\Microsoft\SystemMonitor и задайте для него значение 1.
  • По умолчанию если диапазон данных достаточно велик для интервала выборки, в режиме отображения графика системного монитора используются минимальные и максимальные значения. Чтобы включить отображение средних значений, с помощью редактора реестра создайте параметр типа DWORD с именем DisplaySingleLogSampleValue в подразделе HKEY_CURRENT_USER\Software\Microsoft\SystemMonitor и задайте для него значение 1.

См. также


Добавление заголовка, сетки и других атрибутов

Рисунок Microsoft Windows

Чтобы добавить заголовок, сетку и другие атрибуты

  1. Откройте оснастку Производительность.
  2. Щелкните правой кнопкой мыши область сведений системного монитора и выберите команду Свойства.
  3. На вкладке График установите требуемые параметры диаграммы.

Примечания

  • XOX
  • По умолчанию для минимального и максимального значений шкалы установлены 0 и 100 соответственно.
  • Чтобы сменить цвет сетки, воспользуйтесь вкладкой Оформление.
  • Чтобы добавить или удалить область условных обозначений, строку значений или панель инструментов, воспользуйтесь вкладкой Общие.
  • Чтобы изменить тип и вид рамки, воспользуйтесь вкладкой Общие.

См. также


Смена цветов фона, диаграммы и текста, а также изменение свойств шрифта

Рисунок Microsoft Windows

Чтобы сменить цвет фона, диаграммы, текста или другого элемента, а также изменить свойства шрифта

  1. Откройте оснастку Производительность.
  2. Щелкните правой кнопкой мыши область сведений системного монитора и выберите команду Свойства.
  3. Откройте вкладку Оформление.
  4. В списке Цвет выберите элемент, цвет которого необходимо изменить. Чтобы изменить цвет выбранного элемента, нажмите кнопку Изменить.

    Или, чтобы изменить шрифт текста и чисел, присутствующих на диаграмме, в группе Шрифт нажмите кнопку Изменить. В окне Шрифт установите необходимые параметры: Шрифт, Начертание, Размер и Набор символов.

  5. В списке Цвет доступны следующие элементы:
    • Фоновый рисунок. Цвет фона области окна, в которой отображается диаграмма.
    • Фон элемента управления. Цвет фона, окружающего область окна, в которой отображается диаграмма.
    • Текст. Цвет текста.
    • Сетка. Цвет вертикальных и горизонтальных линий сетки.
    • Панель времени. Цвет линии времени.

Примечание

  • XOX

См. также


Работа с данными

  • Копирование данных между экземплярами системного монитора
  • Печать данных о производительности
  • Сохранение данных диаграммы в виде страницы HTML
  • Сохранение данных в файл журнала
  • Вставка элемента «Системный монитор» в документ Microsoft Word
  • Сбор данных о производительности с помощью WMI


Копирование данных счетчика между экземплярами системного монитора

Рисунок Microsoft Windows

Чтобы скопировать данные счетчика между экземплярами системного монитора

  1. Откройте оснастку Производительность.
  2. В области сведений системного монитора нажмите на панели инструментов кнопку Копировать свойства.

    Все текущие свойства будут скопированы в буфер обмена Windows в формате HTML.

  3. Откройте другой экземпляр системного монитора и нажмите кнопку Вставить список счетчиков, чтобы загрузить настройку счетчиков из буфера обмена в текущее окно.

Примечание

  • XOX


Печать данных о производительности

Рисунок Microsoft Windows

Чтобы напечатать данные о производительности

  1. Откройте оснастку Производительность.
  2. Нажмите клавиши ALT+PRINT SCREEN, чтобы скопировать содержимое текущего окна.
  3. Нажмите кнопку Пуск, выделите пункт Программы, затем выделите пункт Стандартные и выберите команду Paint.
  4. В меню Правка выберите команду Вставить.

    При появлении сообщения с запросом Фрагмент, находящийся в буфере, превосходит рисунок по размерам. Увеличить рисунок?, нажмите кнопку Да.

  5. В меню Файл выберите команду Печать.

Примечания

  • XOX
  • Данные о производительности также можно печатать следующими способами:
    • добавьте элемент «Системный монитор» в приложение Microsoft Office, такое как Microsoft Word или Microsoft Excel, и напечатайте данные из этого приложения;
    • сохраните данные о производительности как файл HTML и напечатайте его из обозревателя Internet Explorer или другой программы;
    • импортируйте файл журнала в текстовом формате с разделителями-запятыми (.csv) или разделителями-знаками табуляции (.tsv) в электронную таблицу Microsoft Excel и напечатайте его из этой программы.

См. также


Сохранение данных диаграммы в виде страницы HTML

Рисунок Microsoft Windows

Чтобы сохранить данные диаграммы в виде страницы HTML

  1. Откройте оснастку Производительность.
  2. Добавьте в диаграмму счетчики.
  3. Щелкните правой кнопкой мыши диаграмму и выберите команду Сохранить как.
  4. В диалоговом окне Сохранить как выберите путь и введите имя сохраняемого файла HTML.

Примечание

  • XOX
  • Параметры счетчиков, сохраненные в виде страницы HTML, можно задействовать, перетащив файл HTML из проводника Windows на диаграмму системного монитора. При открытии файла HTML в обозревателе будет выведена статическая диаграмма системного монитора с данными, соответствующими времени сохранения файла HTML.
  • Кроме того, данные счетчиков, сохраненные в буфере обмена Windows, можно импортировать в системный монитор, а все свойства — экспортировать из системного монитора в буфер обмена Windows. Кнопка Копировать свойства на панели инструментов служит для передачи в буфер обмена Windows свойств счетчиков, отображаемых в системном мониторе. Кнопка Вставить список счетчиков на панели инструментов служит для передачи свойств из буфера обмена в текущее окно.
  • Данные отчета можно также сохранить в виде текстового файла с разделителями-знаками табуляции для использования в Microsoft Excel. Для этого в режиме отображения отчета нажмите правую кнопку мыши, а затем выберите команду Сохранить как. В диалоговом окне Сохранить как введите имя файла отчета и выберите .tsv в качестве формата файла. Нажмите кнопку Сохранить.

См. также


Вставка элемента «Системный монитор» в документ Microsoft Word

Рисунок Microsoft Windows

Чтобы вставить элемент «Системный монитор» в документ Microsoft Word

  1. Откройте документ Word и установите курсор там, где требуется вставить элемент.
  2. В меню Вид выделите пункт Панели инструментов, а затем выберите команду Элементы управления.
  3. Нажмите кнопку Другие элементы и выберите элемент System Monitor Control.

Примечания

  • Элемент управления системного монитора размещается в указанном месте документа. По умолчанию элемент находится в режиме конструктора. Это означает, что с ним можно работать в редакторе Visual Basic. При этом элемент принимает внешние свойства приложения. То есть значения свойств BackColor, ForeColor и Font элемента определяются документом Word. Чтобы изменить эти параметры или добавить счетчики, нажмите кнопку Выход из режима конструктора.
  • После добавления счетчиков и настройки графика можно напечатать данные о производительности или сохранить документ, используя соответствующие команды Word.
  • Эти инструкции применимы к Microsoft Word 97 и более поздним версиям.

См. также


Сохранение данных в файл журнала

Рисунок Microsoft Windows

Чтобы сохранить данные в файл журнала

  1. Откройте оснастку Производительность.
  2. Выберите файл журнала в качестве источника отображаемых данных.
  3. Щелкните правой кнопкой мыши область сведений системного монитора и выберите команду Сохранить данные как.
  4. Введите имя сохраняемого файла журнала и выберите формат.
  5. Введите коэффициент выборки (значение n) для сохраняемого файла журнала в поле Сократить журнал: сохранять только одну запись из n оригинальных.

    По умолчанию n равно 1; это означает, что сохраненный файл журнала и исходный файл содержат одинаковый набор данных.

  6. Нажмите кнопку Сохранить.

Примечания

  • XOX
  • Эта возможность предусмотрена только для файлов журналов (не для данных, собираемых в реальном масштабе времени).

  • Для получения дополнительных сведений по просмотру данных журналов щелкните ссылку «См. также».

См. также


Сбор данных о производительности с помощью WMI

Рисунок Microsoft Windows

Чтобы собрать данные о производительности с помощью WMI

  • В командной строке введите:

    mmc.exe путь\perfmon.msc /sysmon_wmi

    где путь — полный путь сохраненного файла консоли, например:
    %systemroot%\system32

Примечания

  • XOX
  • Эта процедура позволяет получать данные о производительности посредством инструментария управления Windows (Windows Management Instrumentation, WMI), а не реестра.
  • Кроме того, эту процедуру можно выполнить, введя в командной строке:

    perfmon.exe /wmi

См. также


Работа с параметрами

  • Сохранение настройки консоли наблюдения
  • Сохранение параметров журнала или оповещения как страницы HTML
  • Создание пользовательской консоли
  • Использование файлов параметров системного монитора для Windows NT 4.0


Сохранение консоли наблюдения

Рисунок Microsoft Windows

Чтобы сохранить консоль наблюдения

  1. Откройте оснастку Производительность.
  2. С помощью системного монитора или средства в разделе «Оповещения и журналы производительности» задайте требуемые параметры.
  3. В меню Файл выберите команду Сохранить как и введите имя консоли. Обычно этот файл сохраняется в папке System32 корневого системного каталога.
  4. Нажмите кнопку Сохранить.

Примечание

  • XOX

См. также


Сохранение параметров журнала или оповещения в виде страницы HTML

Рисунок Microsoft Windows

Чтобы сохранить параметры журнала или оповещения в виде страницы HTML

  1. Откройте оснастку Производительность.
  2. Создайте журнал или оповещение.
  3. В области сведений щелкните правой кнопкой мыши название журнала или оповещения и выберите команду Сохранить параметры как. По умолчанию параметры сохраняются в личной папке пользователя, которая обычно называется «Мои документы».

Примечание

  • XOX

См. также


Создание пользовательской консоли наблюдения

Рисунок Microsoft Windows

Чтобы создать пользовательскую консоль наблюдения

  1. Откройте консоль управления MMC.
  2. В меню Консоль выберите команду Добавить или удалить оснастку.
  3. На вкладке Изолированная оснастка нажмите кнопку Добавить.
  4. В списке оснасток выберите оснастку Элемент ActiveX и нажмите кнопку Добавить.
  5. В окне Вставка элемента управления ActiveX нажмите кнопку Далее.

    Следующее окно будет открыто после небольшой задержки.

  6. В поле со списком Категория элемента выберите пункт Все категории.
  7. В списке Тип элемента выберите пункт Элемент управления системного монитора.
  8. Нажмите кнопку Далее.

    Этот элемент предоставляет функциональные возможности системного монитора.

  9. В поле Выберите имя элемента ActiveX введите название для элемента и нажмите кнопку Готово.

Примечание

  • Чтобы открыть консоль управления MMC, нажмите кнопку Пуск, выберите команду Выполнить и введите mmc.
  • Пользовательская консоль может быть удобна, если требуется совместить в одной консоли системный монитор и окно просмотра событий или другое средство.


Использование файлов параметров системного монитора Windows NT 4.0

Рисунок Microsoft Windows

Чтобы воспользоваться файлами параметров системного монитора Windows NT 4.0

  • В командной строке введите:

    perfmon.exe имя_файла

    где имя_файла является именем файла параметров.

Примечания

  • В результате выполнения этой процедуры будет открыта консоль «Производительность» Windows XP с параметрами системного монитора Windows NT 4.0.
  • Эта процедура применима к файлам параметров системного монитора Windows NT 4.0 следующих типов: диаграмма (.pmc), отчет (.pmr), оповещение (.pma) и журнал (.pml). Файлы рабочего пространства (.pmw), которые были созданы в системном мониторе Windows NT 4.0, не полностью совместимы с системным монитором Windows XP. Только одно из представлений, ранее сохраненных в файле рабочего пространства, будет доступно в системном мониторе.
  • Для отображения файла параметров Windows NT 4.0 в системном мониторе этот файл временно преобразуется в формат системного монитора, но после запуска консоли преобразованная версия удаляется. Если файл параметров требуется сохранить для дальнейшего использования в системном мониторе, введите следующую команду:

    perfmon.exe /HTMLFILE:преобразованный_файл файл_параметров

    где преобразованный_файл — имя, с которым должен быть сохранен преобразованный файл, а файл_параметров — имя исходного файла параметров Windows NT 4.0.

См. также


Создание и настройка журналов счетчиков

  • Создание журнала счетчиков
  • Добавление объектов в журнал
  • Добавление счетчиков в журнал
  • Просмотр описаний объектов и счетчиков
  • Задание параметров файла журнала


Создание журнала счетчиков

Рисунок Microsoft Windows

Чтобы создать журнал счетчиков

Использование интерфейса Windows

  1. Откройте оснастку Производительность.
  2. Дважды щелкните значок Оповещения и журналы производительности, а затем дважды щелкните значок Журналы счетчиков.

    3. В области сведений будут показаны все имеющиеся записи журналов. Зеленый значок показывает, что журнал запущен, а красный значок — что журнал остановлен.

  3. Щелкните правой кнопкой мыши пустое место в области сведений и выберите команду Новые параметры журнала.
  4. В поле Имя введите имя журнала и нажмите кнопку ОК.
  5. На вкладке Общие нажмите кнопку Добавить объекты и выберите необходимые объекты; или, нажмите кнопку Добавить счетчики и выберите отдельные счетчики, показания которых следует заносить в журнал.
  6. Чтобы изменить файл и расписание, используемые по умолчанию, задайте необходимые параметры на вкладках Файлы журнала и Расписание.

Примечания

  • XOX
  • Можно также воспользоваться полем От имени и кнопкой Задать пароль для указания учетной записи для журналов производительности и службы оповещений. Эти средства доступны на вкладке Общие.
  • Чтобы сохранить настройку счетчиков для журнала счетчиков, журнала трассировки или записи оповещения, в области сведений щелкните этот элемент правой кнопкой мыши и выберите команду Сохранить параметры как. Далее задайте файл .htm, в котором следует сохранить параметры. Чтобы использовать сохраненные сведения в новом журнале или оповещении, щелкните правой кнопкой мыши область сведений и выберите команду Новые параметры журнала из или Новые параметры оповещений из. Это наиболее простой способ получения новых параметров из настройки записи журнала или оповещения.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    logman create counter имя_выборки –c {путь [путь...]} | {–cf имя_файла}

Значение | Описание
create counter имя_выборки | Создание запроса имя_выборки на выборку данных счетчиков.
–c {путь [путь...]} | –cf {имя_файла} | Путь журнала для счетчика производительности (путь) или путь и имя файла журнала, в котором содержится список этих счетчиков (–cf имя_файла). Чтобы задать несколько путей счетчиков, используйте пробел для разделения командной строки или параметр -cf, чтобы ввести список путей счетчиков из входного файла (по одному в строке). Для каждого пути объекта используется следующий формат: [\\компьютер]\объект[экземпляр]\счетчик, где компьютер (необязательный параметр) — имя или IP-адрес удаленного компьютера. Если имя компьютера не указано, по умолчанию будет использоваться локальный компьютер; объект — объект счетчика производительности (процесс или память); экземпляр (если указан) — объект производительности (процесс); счетчик — счетчик производительности для объекта (процессорное время).
Например, чтобы создать запрос perf_log на выборку данных счетчика «% загруженности процессора», введите:

logman create counter perf_log –c "\Процессор(_Total)\% загруженности процессора"

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    logman /?

См. также


Добавление объектов в журнал

Рисунок Microsoft Windows

Чтобы добавить объекты в журнал

Использование интерфейса Windows

  1. Откройте оснастку Производительность.
  2. Дважды щелкните элемент Оповещения и журналы производительности и выберите раздел Журналы счетчиков или Оповещения.
  3. В области сведений дважды щелкните запись журнала или оповещения, которую требуется изменить.
  4. На вкладке Общие нажмите кнопку Добавить объекты. Для каждого объекта, который требуется добавить в журнал или оповещение, выполните следующие действия.
    • Для записи данных объектов компьютера, на котором запущена служба «Оповещения и журналы производительности», выберите вариант Использовать локальные объекты счетчиков.

      Или, для записи данных объектов какого-либо компьютера, независимо от того, где запущена эта служба, выберите вариант Выбрать объекты счетчиков с компьютера и укажите имя наблюдаемого компьютера в формате UNC (Uniform Naming Convention — единая система именования), например \\MyLogServer.

    • В списке Объекты выберите объект для наблюдения.
    • Нажмите кнопку Добавить.

Примечания

  • XOX
  • При создании консоли наблюдения для экспорта убедитесь, что выбран вариант Использовать локальные объекты счетчиков. В противном случае журналы счетчиков будут получать данные с компьютера, имя которого задано в поле, независимо от того, где установлен файл консоли.
  • Для получения описания объекта выделите его в списке Объекты и нажмите кнопку Объяснение.
  • При выборе имени удаленного компьютера (вариант Выбрать объекты счетчиков с компьютера) в соответствующем списке отображаются только имя локального компьютера и имена тех компьютеров, которые были введены в ходе текущего сеанса наблюдения. Имена компьютеров, введенные в предыдущих сеансах, не отображаются в списке.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    logman update имя_выборки –c {путь [путь...]} | {–cf имя_файла}

Значение | Описание
update имя_выборки | Обновление выборки с именем имя_выборки. После изменения параметров выборку данных счетчика необходимо перезапустить.
–c {путь [путь...]} | –cf {имя_файла} | Путь журнала для объекта производительности (путь) или путь и имя файла журнала, в котором содержится список этих объектов (–cf имя_файла). Чтобы задать несколько путей объектов, используйте пробел для разделения командной строки или параметр -cf, чтобы ввести список путей объектов из входного файла (по одному в строке). Для каждого пути объекта используется следующий формат: [\\компьютер]\объект[*]\*, где компьютер (необязательный параметр) — имя или IP-адрес удаленного компьютера. Если имя компьютера не указано, по умолчанию будет использоваться локальный компьютер; объект — объект счетчика производительности (процесс или память).
Например, чтобы добавить все объект «Физический диск» в выборку perf_log на компьютере \\COMP1, введите:

logman update perf_log –c "\\COMP1\Физический диск(*)\*"

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    logman /?

См. также


Добавление счетчиков в журнал

Рисунок Microsoft Windows

Чтобы добавить счетчики в журнал

Использование интерфейса Windows

  1. Откройте оснастку Производительность.
  2. Дважды щелкните элемент Оповещения и журналы производительности и выделите раздел Журналы счетчиков.
  3. В области сведений дважды щелкните журнал, который требуется изменить.
  4. На вкладке Общие нажмите кнопку Добавить счетчики. Для каждого счетчика или группы счетчиков, которые требуется добавить в журнал, выполните следующие действия.
    • Для записи данных счетчиков компьютера, на котором запущена служба «Оповещения и журналы производительности», выберите вариант Использовать локальные счетчики.

      Или, для записи данных счетчиков какого-либо компьютера, независимо от того, где запущена эта служба, выберите вариант Выбрать счетчики с компьютера и укажите имя наблюдаемого компьютера в формате UNC (Uniform Naming Convention — единая система именования), например \\MyLogServer.

    • В списке Объект выберите объект для наблюдения.
    • В списке Выбрать счетчики из списка выберите один или несколько счетчиков для наблюдения.
    • Для наблюдения за всеми экземплярами выбранных счетчиков выберите вариант Все вхождения. (Двоичные журналы могут включать экземпляры, которые недоступны при запуске журнала, но становятся доступны позже).

      Или, для наблюдения за определенными экземплярами выбранных счетчиков, выберите вариант Выбрать вхождения из списка и выделите один или несколько экземпляров для наблюдения.

    • Нажмите кнопку Добавить.

Примечания

  • XOX
  • При создании консоли наблюдения для экспорта убедитесь, что выбран вариант Использовать локальные счетчики. В противном случае журналы счетчиков будут получать данные с компьютера, имя которого задано в поле, независимо от того, где установлен файл консоли.
  • Для получения описания счетчика выделите его в списке Выбрать счетчики из списка и нажмите кнопку Объяснение.
  • Объекты некоторых типов могут иметь несколько экземпляров. Например, в многопроцессорных системах существует несколько экземпляров объекта «Процессор». Объект «Физический диск» будет иметь два экземпляра в системе с двумя жесткими дисками. Некоторые объекты, такие как «Память» и «Сервер», существуют только в одном экземпляре. Для сбора статистики по нескольким экземплярам объекта могут быть заданы несколько счетчиков, а во многих случаях для всех экземпляров можно задать общий счетчик. По умолчанию счетчики обозначаются и названием, и номером экземпляра. Чтобы отключить эту функцию, щелкните правой кнопкой мыши диаграмму системного монитора, выберите команду Свойства и снимите флажок Допускать дублирование счетчиков.
  • При выборе имени удаленного компьютера (вариант Выбрать счетчики с компьютера) в соответствующем списке отображаются только имя локального компьютера и имена тех компьютеров, которые были введены в ходе текущего сеанса наблюдения. Имена компьютеров, введенные в предыдущих сеансах, не отображаются в списке.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    logman update имя_выборки –c {путь [путь...]} | {–cf имя_файла}

Значение | Описание
update имя_выборки | Обновление выборки с именем имя_выборки. После изменения параметров выборку данных счетчика необходимо перезапустить.
–c {путь [путь...]} |
–cf {имя_файла} 		Путь журнала для счетчика производительности (путь) или путь и имя файла журнала, в котором содержится список этих счетчиков (–cf имя_файла). Чтобы задать несколько путей счетчиков, используйте пробел для разделения командной строки или параметр -cf, чтобы ввести список путей счетчиков из входного файла (по одному в строке). Для каждого пути объекта используется следующий формат: [\\компьютер]\объект[экземпляр]\счетчик, где

компьютер (необязательный параметр) — имя или IP-адрес удаленного компьютера. Если имя компьютера не указано, по умолчанию будет использоваться локальный компьютер;

объект — объект счетчика производительности (процесс или память);

экземпляр (если указан) — объект производительности (процесс);

счетчик — счетчик производительности для объекта (процессорное время).

Примечание

  • В пути счетчика в качестве знака подстановки можно использовать звездочку (*). Например, чтобы указать все экземпляры счетчика «% загруженности процессора», введите:
    "\Процессор(*)\% загруженности процессора"
Например, чтобы добавить все экземпляры счетчика «% времени прерываний» в выборку perf_log на компьютере \\COMP1, введите:

logman update perf_log –c "\\COMP1\Процессор(*)\% времени прерываний"

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    logman /?

См. также


Просмотр описаний объектов и счетчиков

Рисунок Microsoft Windows

Чтобы просмотреть описание объекта или счетчика

  1. Откройте оснастку Производительность.
  2. Дважды щелкните значок Оповещения и журналы производительности, а затем щелкните значок Журналы счетчиков.
  3. В области сведений дважды щелкните журнал счетчиков.
  4. Нажмите кнопку Добавить объекты или кнопку Добавить счетчики, чтобы открыть одноименное диалоговое окно.
  5. В диалоговом окне Добавить объекты в списке Объекты выделите объект и нажмите кнопку Объяснение.
  6. В диалоговом окне Добавить счетчики в списке Объект выберите объект, в списке Выбрать счетчики из списка выделите счетчик и нажмите кнопку Объяснение.

Примечание

  • XOX
  • Кнопка Объяснение открывает всплывающее окно с описанием выбранного объекта или счетчика. Дополнительные сведения о счетчиках, включая описание процедур вычисления значений счетчиков и инструкции по использованию счетчиков для диагностики неполадок, связаных с производительностью системы, см. в справочном файле «Windows Performance Counter Help Reference» (Counters.chm) на компакт-диске Microsoft Windows Resource Kit.

См. также


Задание параметров файла журнала

Рисунок Microsoft Windows

Чтобы задать параметры файла журнала

Использование интерфейса Windows

  1. Откройте оснастку Производительность.
  2. Дважды щелкните значок Оповещения и журналы производительности.
  3. Чтобы задать свойства файла журнала счетчиков, дважды щелкните значок Журналы счетчиков.

    Или, чтобы задать свойства файла журнала трассировки, дважды щелкните значок Журналы трассировки.

  4. В области сведений дважды щелкните запись журнала.
  5. На вкладке Файлы журнала установите следующие параметры:
    • Тип журнала. Выберите в этом списке необходимый формат для файла журнала, установите параметры, а затем нажмите кнопку Настроить.
      Формат файла журнала | Описание | Применение
      Текстовый файл (разделитель — запятая) | Файл журнала с разделителями-запятыми и расширением .csv. Этот формат используется, например, для экспорта данных из журнала в электронные таблицы. | Журналы счетчиков
      Текстовый файл (разделитель — табуляция) | Файл журнала с разделителями-знаками табуляции и расширением .tsv. Этот формат используется, например, для экспорта данных из журнала в электронные таблицы. | Журналы счетчиков
      Двоичный файл | Последовательный двоичный файл журнала с расширением .blg. Этот формат используется, если требуется обеспечить запись данных экземпляров, время от времени активизирующихся после запуска журнала. Файлы журналов в формате, отличном от двоичного, не могут применяться для записи данных непостоянных экземпляров. | Журналы счетчиков
      Двоичный циклический файл | Циклический двоичный файл журнала с расширением .blg. Этот формат используется для последовательной записи данных в один файл журнала с заменой предыдущих записей новыми данными, после того как будет достигнут максимальный размер журнала. | Журналы счетчиков
      Файл циклической трассировки | Файл журнала циклической трассировки с расширением .etl. Этот формат используется для последовательной записи данных в один файл журнала с заменой предыдущих записей новыми данными, после того как будет достигнут максимальный размер журнала. | Журналы трассировки
      Файл последовательной трассировки | Файл журнала последовательной трассировки с расширением .etl. Собирает данные, пока не будет достигнут заданный пользователем размер, после чего текущий файл закрывается и создается новый. | Журналы трассировки
      База данных SQL | В этом режиме задаются существующая база данных SQL и набор журналов в этой базе данных, в который будут записываться и извлекаться данные о производительности. Используйте этот формат для сбора и анализа данных о производительности в масштабе предприятия (не в масштабе отдельного сервера). | Журналы счетчиков
    • Имена файлов оканчиваются на. Установите этот флажок и выберите из списка требуемый суффикс. Флажок Имена файлов оканчиваются на позволяет выбрать файл журнала с постоянным именем или группу автоматически создаваемых файлов с похожими именами.
    • Нумерация начинается с. Задайте число для автоматической нумерации файлов, если в поле Имена файлов оканчиваются на выбран вариант nnnnnn.
    • Комментарий. Если требуется, введите комментарий или описание файла журнала.
    • Настроить. Задайте необходимые параметры в зависимости от выбранного типа файлов журналов.
      Параметр | Описание | Применение
      Размещение | Введите имя папки, в которой должен быть создан файл журнала, или нажмите кнопку Обзор, чтобы найти ее. | Настройка файлов журнала
      Файл | Введите базовое имя для файла журнала. Поле Файл при необходимости можно использовать в сочетании с полем Имена файлов оканчиваются на. | Настройка файлов журнала
      Имя репозитория | Выберите в списке DSN системы (Data Source Name — имя источника данных), а затем введите имя набора журналов в поле Набор журналов. Этот набор будет храниться в базе данных DSN системы. | Настройка журналов SQL
  6. Размер файла журнала. На основе следующих вариантов решите, требуется ограничить размер файла журнала или нет.
  7. Или, Размер набора журналов. На основе следующих вариантов решите, требуется ограничить размер файла журнала или нет.
    • Максимально возможный. Если выбран этот вариант, данные последовательно заносятся в файл журнала, пока не будет достигнут предел, определяемый дисковой квотой или операционной системой. (Для журналов SQL данные заносятся в базу данных до тех пор, пока она не достигнет размера, определяемого заданным числом записей.)
    • Не более. Максимально допустимый размер файла журнала. Для журналов трассировки и счетчиков максимальный размер задается в мегабайтах. Для журналов SQL максимальный размер задается в записях.

Примечания

  • XOX
  • Если свободное место на диске меньше указанного минимума, появится сообщение об ошибке. Если выбран вариант создания максимально возможного файла журнала, проверьте наличие достаточного места на диске и во всех действующих дисковых квотах. Если при ведении журнала закончится свободное место на диске, возникнет ошибка. Параметр Размер файла журнала связан с параметром Когда файл журнала заполнен на вкладке Расписание.
  • Если указан максимальный размер файла журнала или набора журналов, параметр Когда файл журнала заполнен соответствует этому размеру.
  • Поле Файл может обозначать группу файлов журналов с одинаковыми параметрами.
  • Суффикс Имена файлов оканчиваются на может быть последовательностью цифр или строкой, обозначающей дату и время запуска журнала. Например, можно ввести в поле Файл значение «Ежедневный», тогда службой «Оповещения и журналы производительности» к каждому имени будет добавлена дата, и в результате получится группа файлов: «Ежедневный_19990715», «Ежедневный_19990716» и т. п. для каждого дня ведения журнала.
  • Комментарий и имя файла отображаются в области сведений окна консоли «Оповещения и журналы производительности».
  • Последовательные файлы журналов счетчиков и трассировки могут превышать максимальный размер, заданный пользователем. Это может происходить по разным причинам в зависимости от выбранного типа журнала. Для журналов счетчиков служба откладывает проверку размера файла журнала до тех пор пока не была получена последняя выборка данных, в то время как в этом состоянии размер файла уже мог превысить указанный предел. Для журналов трассировки служба записывает в журнал дополнительные буферы в момент остановки, что может обусловить незначительное превышение заданного предела.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите подходящую команду (см. ниже).
Действие | Команда
Определение формата файла журнала | logman update имя_выборки -f {bin | bincirc | csv | tsv | SQL}
Задание суффикса файла. | logman update имя_выборки –v {nnnnn | ммддччмм}
Задания начального номера для автомаческой нумерации. | logman update имя_выборки –v nnnnn
Задание местоположения файла журнала. | logman update имя_выборки –o путь
Задание местоположения базы данных SQL и набора журналов для записи выходных данных. | logman update имя_выборки –o DSN!журнал_счетчиков
Значение | Описание
update имя_выборки | Обновление выборки с именем имя_выборки. После изменения параметров выборку данных счетчика необходимо перезапустить.
-f bin | bincirc | csv | tsv | SQL Формат файла, используемый для сбора данных счетчиков производительности и данных трассировки. Для журнала может быть выбран один из следующих форматов: двоичный (bin), циклический двоичный (circbin), текст с разделителями-запятыми (csv) и текст с разделителями-знаками табуляции (tsv), а также формат базы данных SQL.

Примечание

  • При работе с базой данных SQL необходимо: использовать параметр -o совместно с аргументом DNS!журнал_счетчиков; системное имя источника данных (DSN) должно быть известно заранее; пользователь должен иметь разрешения на запись в эту базу данных. Набор журналов журнал_счетчиков создается в базе данных и определяется DSN.
Если формат файла не указан, по умолчанию используется двоичный.
–v nnnnn | ммддччмм | Добавление данных контроля версий в конец выходного файла и пути. Используйте для контроля версий числовой формат nnnnn или формат даты ммддччмм, включающий месяц, день, час (в 24-часовой нотации) и минуты.
–o путь | Путь файла, в котором записываются данные счетчиков производительности или данные трассировки. По умолчанию в качестве имени файла журнала используется имя выборки с расширением .blg для счетчиков производительности или .etl для данных трассировки.
–o DSN!журнал_счетчиков | Задание местоположения базы данных SQL и набора журналов.
Например, чтобы задать запись выборки данных счетчиков perf_log в набор журналов daily_log базы данных perfdb, введите:

logman update perf_log –f sql –o perfdb!daily_log

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    logman /?

См. также


Создание и настройка журналов трассировки

  • Создание журнала трассировки
  • Определение поставщиков и событий журнала трассировки
  • Определение буферов журналов трассировки


Создание журнала трассировки

Рисунок Microsoft Windows

Чтобы создать журнал трассировки

Использование интерфейса Windows

  1. Откройте оснастку Производительность.
  2. Дважды щелкните значок Оповещения и журналы производительности, а затем выделите элемент Журналы трассировки.

    В области сведений будут показаны все имеющиеся записи журналов. Зеленый значок показывает, что журналы запущены, а красный значок — что журналы остановлены.

  3. Щелкните правой кнопкой мыши пустое место в области сведений и выберите команду Новые параметры журнала.
  4. В поле Имя введите имя создаваемого журнала трассировки и нажмите кнопку ОК.

    По умолчанию файл журнала создается в папке PerfLogs корневого каталога, а к его имени добавляется число (номер в последовательности журналов) и расширение .etl. На вкладках Файлы журналов и Дополнительно измените или определите дополнительные параметры, если требуется. На вкладке Общие определите поставщиков и события для занесения в журнал. На вкладке Расписание укажите интервал времени для ведения журнала.

Примечания

  • XOX
  • Можно также воспользоваться полем От имени и кнопкой Задать пароль для указания учетной записи для журналов производительности и службы оповещений. Эти средства доступны на вкладке Общие.
  • Чтобы сохранить параметры файла журнала, щелкните правой кнопкой мыши этот файл в области сведений и выберите команду Сохранить параметры как. Далее задайте файл .htm, в котором следует сохранить параметры. Чтобы использовать сохраненные сведения в новом журнале, щелкните правой кнопкой мыши область сведений и выберите команду Новые параметры журнала из.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Чтобы создать журнал трассировки, введите:

    Logman create trace имя_выборки

Значение | Описание
create trace | Создание запроса на выборку данных журнала трассировки
имя_выборки | Имя запроса на выборку данных

Например, чтобы создать журнал трассировки perf_log, введите:

logman create trace perf_log

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    logman /?

См. также


Определение поставщиков и событий журнала трассировки

Рисунок Microsoft Windows

Чтобы определить поставщиков и события журнала трассировки

Использование интерфейса Windows

  1. Откройте оснастку Производительность.
  2. Дважды щелкните значок Оповещения и журналы производительности, а затем щелкните значок Журналы трассировки.
  3. В области сведений дважды щелкните запись журнала.
  4. Для получения списка установленных поставщиков и их состояний (доступны или нет) нажмите кнопку Состояние поставщиков.

    По умолчанию выбран вариант Несистемные поставщики, чтобы свести к минимуму дополнительную нагрузку, обусловленную трассировкой.

  5. В режиме События, протоколируемые системным поставщиком для наблюдения за процессами, потоками и другими объектами будет использоваться поставщик данных трассировки ядра Windows. Чтобы задать события для протоколирования, установите соответствующие флажки.
  6. В режиме Несистемные поставщики можно выбрать необходимых поставщиков данных, например, если имеются поставщики собственной разработки. Для этого воспользуйтесь кнопками Добавить и Удалить.

Примечания

  • XOX
  • Ведение журнала трассировки файловых операций и сбоев доступа к страницам может привести к появлению больших объемов данных. Рекомендуется ограничить ведение журнала трассировки, включающего наблюдение за файловыми операциями и сбоями доступа к страницам, двумя часами.
  • Для накопления данных от ядра системы и некоторых других поставщиков необходимо иметь особые права. Это возможно, если указать учетную запись администратора в поле От имени.
  • В любое время доступен только один экземпляр каждого поставщика данных трассировки.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите подходящую команду из перечисленных в таблице.
Действие | Команда
Просмотр всех установленных поставщиков и их состояний. | logman query providers
Занесение в журнал данных трассировки, собранных системным поставщиком. | logman update имя_выборки -P "Windows kernel trace" (process, thread, disk, net, page, file)
Занесения в журнал данных трассировки, собранных несистемным поставщиком. | logman update имя_выборки -P поставщик
Значение | Описание
query providers | Вывод списка поставщиков, установленных в локальной системе.
update collection_name | Обновление запроса имя_выборки на выборку данных.
-P "Windows kernel trace" (process, thread, disk, net, page, file) | Использование Windows kernel trace в качестве поставщика данных для журнала трассировки. Process, thread, disk, net, pf, hf, registry, image и file — необязательные параметры, позволяющие включить в журнал трассировки следующие события: process — включение данных о создании и завершении процессов; thread — включение данных о создании и завершении потоков; disk — включение данных об операциях дискового ввода-вывода; net — включение данных об отправке и получении запросов TCP/IP; pf — включение данных о случайных сбоях доступа к страницам; hf — включение данных об устойчивых сбоях доступа к страницам; registry — включение данных об операциях с реестром; image — включение данных об имени программы для загруженного процесса; file — включение данных об операциях файлового ввода-вывода.
-P поставщик | Использование несистемного поставщика данных для журнала трассировки.

Например, чтобы задать Nonsystem01 в качестве поставщика данных для журнала трассировки perf_log, введите:

logman update perf_log -P Nonsystem01

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    logman /?

См. также


Определение буферов журнала трассировки

Рисунок Microsoft Windows

Чтобы определить буферы журнала трассировки

Использование интерфейса Windows

  1. Откройте оснастку Производительность.
  2. Дважды щелкните значок Оповещения и журналы производительности, а затем щелкните значок Журналы трассировки.
  3. В области сведений дважды щелкните запись журнала.
  4. Откройте вкладку Дополнительно.
  5. В поле Размер буфера задайте размер буфера в килобайтах, который требуется использовать для накопления данных трассировки.
  6. В поле Минимум задайте наименьшее количество буферов, которые должны использоваться для накопления данных трассировки.
  7. В поле Максимум задайте наибольшее количество буферов, которые должны использоваться для накопления данных трассировки.
  8. Для периодической очистки буферов поставщика данных трассировки установите флажок Перемещать данные из буферов в журнал не реже, чем каждые и задайте интервал перемещения в секундах.

Примечание

  • XOX

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    logman update имя_выборки –bs {значение} –nb {мин макс} –ft [[чч:]мм:]сс

Значение | Описание
update имя_выборки | Обновление запроса имя_выборки на выборку данных.
–bs {значение} | Размер буфера (в килобайтах) для журнала трассировки
–nb {мин макс} | Минимальное и максимальное число буферов для журнала трассировки
–ft [[чч:]мм:]сс | Включение режима очиски буфера и задание интервала очистки

Например, чтобы задать для журнала трассировки perf_log размер буфера равным 128 Кбайт, минимальное число буферов равным 10 и максимальное число буферов равным 25, введите:

logman update perf_log –bs 128 –nb 10 25

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    logman /?

См. также


Создание и настройка оповещений

  • Создание оповещения
  • Определение счетчиков и порогов для оповещения
  • Определение действий для оповещения


Создание оповещения

Рисунок Microsoft Windows

Чтобы создать оповещение

  1. Откройте оснастку Производительность.
  2. Дважды щелкните элемент Оповещения и журналы производительности и выберите раздел Оповещения.

    В области сведений будут показаны все имеющиеся записи оповещений. Зеленый значок показывает, что оповещение запущено, а красный значок — что оповещение остановлено.

  3. Щелкните правой кнопкой мыши пустое место в области сведений и выберите команду Новые параметры оповещений.
  4. В поле Имя введите имя оповещения и нажмите кнопку ОК.
  5. На вкладке Общие задайте комментарий, счетчики, пороговые значения и интервал чтения показаний.

    Чтобы задать действия, выполняемые при инициации оповещения, воспользуйтесь вкладкой Действие; чтобы задать время запуска службы с целью инициации оповещений, воспользуйтесь вкладкой Расписание.

Примечания

  • XOX
  • Можно также воспользоваться полем От имени и кнопкой Задать пароль для указания учетной записи для журналов производительности и службы оповещений. Эти средства доступны на вкладке Общие.
  • Чтобы сохранить настройку счетчиков для файла журнала или записи оповещения, в области сведений щелкните этот элемент правой кнопкой мыши и выберите команду Сохранить параметры как. Далее задайте файл .htm, в котором следует сохранить параметры. Чтобы использовать сохраненные сведения в новом журнале или оповещении, щелкните правой кнопкой мыши область сведений и выберите команду Новые параметры журнала из или Новые параметры оповещений из. Это наиболее простой способ получения параметров журнала из настройки записи оповещения.

См. также


Определение счетчиков и порогов для оповещения

Рисунок Microsoft Windows

Чтобы определить счетчики и интервалы оповещения

  1. Откройте оснастку Производительность.
  2. Дважды щелкните элемент Оповещения и журналы производительности и выберите раздел Оповещения.
  3. В области сведений дважды щелкните запись оповещения.
  4. В поле Комментарий введите комментарий к оповещению, если требуется.
  5. Нажмите кнопку Добавить.
  6. Для каждого счетчика или группы счетчиков, которые требуется добавить в журнал, выполните следующие действия.
    1. Для наблюдения за счетчиками компьютера, на котором запущена служба «Оповещения и журналы производительности», выберите вариант Использовать локальные счетчики.

      Или, для наблюдения за счетчиками какого-либо компьютера, независимо от того, где запущена эта служба, выберите вариант Выбрать счетчики с компьютера и укажите имя наблюдаемого компьютера в формате UNC (Uniform Naming Convention — единая система именования), например \\MyLogServer.

    2. В списке Объекты выберите объект для наблюдения.
    3. В списке Выбрать счетчики из списка выберите один или несколько счетчиков для наблюдения.
    4. Для наблюдения за всеми экземплярами выбранных счетчиков выберите вариант Все вхождения. (Двоичные журналы могут включать экземпляры, которые недоступны при запуске журнала, но становятся доступны позже).

      Или, для наблюдения за определенными экземплярами выбранных счетчиков, выберите вариант Выбрать вхождения из списка и выделите один или несколько экземпляров для наблюдения.

    5. Нажмите кнопку Добавить.
  7. В поле со списком Оповещать, когда значение выберите вариант Меньше или Больше, а в поле Порог введите пороговое значение оповещения.
  8. В группе Снимать показания каждые укажите значение интервала и единицу измерения.
  9. При необходимости задайте дополнительные параметры на вкладках Действие и Расписание.

Примечания

  • XOX
  • При создании консоли наблюдения для экспорта убедитесь, что выбран вариант Использовать локальные счетчики. В противном случае журналы счетчиков будут получать данные с компьютера, имя которого задано в поле, независимо от того, где установлен файл консоли.
  • Объекты некоторых типов могут иметь несколько экземпляров. Например, в многопроцессорных системах существует несколько экземпляров объекта «Процессор». Объект «Физический диск» будет иметь два экземпляра в системе с двумя жесткими дисками. Некоторые объекты, такие как «Память» и «Сервер», существуют только в одном экземпляре. Для сбора статистики по нескольким экземплярам объекта могут быть заданы несколько счетчиков, а во многих случаях для всех экземпляров можно задать общий счетчик.


Определение действий для оповещения

Рисунок Microsoft Windows

Чтобы определить действия для оповещения

  1. Откройте оснастку Производительность.
  2. Дважды щелкните элемент Оповещения и журналы производительности и выберите раздел Оповещения.
  3. В области сведений дважды щелкните запись оповещения.
  4. Перейдите на вкладку Действие.
  5. Чтобы служба «Оповещения и журналы производительности» создала запись, доступную в окне «Просмотра событий», установите флажок Сделать запись в журнале событий приложений. Этот режим включен по умолчанию.
  6. Чтобы служба отправила сетевого сообщение, установите флажок Послать сетевое сообщение и введите имя компьютера, на котором оно должно быть отображено.
  7. Чтобы в момент инициации оповещения была начата запись журнала счетчиков, установите флажок Запустить журнал производительности и выберите необходимый журнал.
  8. Чтобы в момент инициации оповещения была запущена программа, установите флажок Запустить программу и введите путь и имя файла или нажмите кнопку Обзор, чтобы найти его. При инициации оповещения служба создаст процесс и выполнит заданную командную строку. Кроме того, все заданные аргументы командной строки будут переданы запускаемому файлу. Нажмите кнопку Аргументы командной строки и установите флажки, соответствующие аргументам, которые необходимо добавить в командную строку при запуске программы.

Примечания

  • XOX
  • XOX
  • По умолчанию (действие Запустить программу) программа запускается в фоновом режиме.
  • Для выполнения интерактивной программы откройте оснастку Службы, дважды щелкните элемент Оповещения и журналы производительности, а затем на вкладке Вход в систему установите флажок Разрешить взаимодействие с рабочим столом.

См. также


Работа с журналами и оповещениями

  • Запуск и остановка журнала счетчиков, журнала трассировки или оповещения вручную
  • Удаление счетчиков из журнала или оповещения
  • Просмотр и изменение свойств журнала или оповещения
  • Определение параметров запуска и остановки для журнала или оповещения
  • Удаление журнала или оповещения


Запуск и остановка журнала счетчиков, журнала трассировки или оповещения вручную

Рисунок Microsoft Windows

Чтобы запустить или остановить вручную журнал счетчиков, журнал трассировки или оповещение

Использование интерфейса Windows

  1. Откройте оснастку Производительность.
  2. Дважды щелкните значок Оповещения и журналы производительности, а затем щелкните значок Журналы счетчиков, Журналы трассировки или Оповещения.
  3. В области сведений щелкните правой кнопкой мыши необходимую запись журнала или оповещения и выберите команду Запуск, чтобы начать ведение журнала или отслеживание условий оповещения, или команду Остановка, чтобы остановить эти процессы.

Примечания

  • XOX
  • Запуск и остановка ведения журнала или отслеживания условий оповещения могут быть выполнены с некоторой задержкой. О смене состояния можно судить по изменению цвета значка (с зеленого на красный при остановке и наоборот при запуске).

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    logman start имя_выборки

    или

    logman stop имя_выборки

Значение | Описание
start имя_выборки | Запуск запроса имя_выборки на выборку данных. Этот параметр применяется для перехода к сбору данных вручную вместо сбора по расписанию. Для восстановления режима сбора данных по расписанию используйте параметр update с ключами времени начала (–b), окончания (–e) или повтора (–rt).
stop имя_выборки | Остановка запроса имя_выборки на выборку данных. Этот параметр применяется для перехода к сбору данных вручную вместо сбора по расписанию. Для восстановления режима сбора данных по расписанию используйте параметр update с ключами времени начала (–b), окончания (–e) или повтора (–rt).
Например, чтобы остановить запрос на выборку данных perf_log, введите:

logman stop perf_log

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    logman /?

См. также


Удаление счетчиков из журнала или оповещения

Рисунок Microsoft Windows

Чтобы удалить счетчик из журнала или оповещения

  1. Откройте оснастку Производительность.
  2. Дважды щелкните значок Оповещения и журналы производительности, а затем щелкните значок Журналы счетчиков или Оповещения.
  3. В области сведений дважды щелкните запись журнала или оповещения.
  4. В списке Счетчики выделите счетчик, который требуется удалить, и нажмите кнопку Удалить.

Примечание

  • XOX

См. также


Просмотр и изменение свойств журнала или оповещения

Рисунок Microsoft Windows

Чтобы просмотреть или изменить свойства журнала или оповещения

Использование интерфейса Windows

  1. Откройте оснастку Производительность.
  2. Дважды щелкните значок Оповещения и журналы производительности.
  3. Щелкните значок Журналы счетчиков, Журналы трассировки или Оповещения.
  4. В области сведений дважды щелкните журнал или оповещение.
  5. Просмотрите и, если требуется, измените свойства журнала.
Элемент | Свойства | Вкладка
Оповещения | Комментарий, счетчики, пороговые значения и интервал обновления | Общие
Оповещения | Действия, выполняемые при появлении события: запуск программы, отправка сообщения, запуск журнала производительности, обновление журнала событий | Действие
Журналы счетчиков | Счетчики, включаемые в журнал, и интервал обновления | Общие
Журналы счетчиков | Комментарий к журналу счетчиков, тип файла, ограничение на размер файла, путь и имя файла, параметры автоматического построения имени | Файлы журнала
Журналы счетчиков | Способы запуска и остановки (автоматически и вручную), а также расписание запуска и остановки в автоматическом режиме | Расписание
Журналы трассировки | Поставщики журналов трассировки и события для занесения в журнал | Общие
Журналы трассировки | Комментарий к журналу трассировки, ограничение на размер файла, путь и имя файла, параметры автоматического построения имени | Файлы журнала
Журналы трассировки | Размер буфера журнала трассировки, ограничения на количество буферов и интервал перемещения | Дополнительно

Примечания

  • XOX
  • Чтобы запустить или остановить журнал или оповещение, щелкните правой кнопкой мыши его имя в области сведений и выберите соответствующую команду (Запуск или Остановка). Эта команда имеет более высокий приоритет по сравнению с запуском и остановкой по расписанию; ее выполнение сопровождается включением ручного режима запуска и остановки.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите подходящую команду (см. ниже).
Действие | Команда
Смена счетчиков журнала и интервала обновления | logman update имя_выборки –c {путь [путь...]} | –cf {имя_файла} –si [[чч:]мм:]сс
Обновление выборки данных счетчиков, типа файла, ограничения на размер файла, пути и имени файла, а также параметров автоматического построения имени | logman update имя_выборки –f {bin | bincirc | csv | tsv | SQL} –max значения –o путь –v {nnnnn | ммддччмм}
Обновление способа запуска и остановки (автоматически и вручную), а также расписания запуска и остановки в автоматическом режиме | logman update имя_выборки –b М/д/гггг ч:мм:сс [AM | PM] –e М/д/гггг ч:мм:сс [AM | PM] –r
Обновление поставщиков журналов трассировки и событий для занесения в журнал | logman update имя_выборки –p поставщик
Обновление выборки данных трассировки, типа файла, ограничения на размер файла, пути и имени файла, а также параметров автоматического построения имени | logman update имя_выборки –f {bin | bincirc} –max значение –o путь –v {nnnnn | ммддччмм}
Обновление размера буфера журнала трассировки, ограничений на количество буферов и интервала перемещения | logman update имя_выборки –bs {значение} –nb {мин макс} –ft [[чч:]мм:]сс
Значение | Описание
update имя_выборки | Обновление выборки с именем имя_выборки. После изменения параметров выборку данных счетчика необходимо перезапустить.
–c {путь [путь...]} | –cf {имя_файла} | Путь журнала для счетчика производительности (путь) или путь и имя файла журнала, в котором содержится список этих счетчиков (–cf имя_файла). Чтобы задать несколько путей счетчиков, используйте пробел для разделения командной строки или параметр -cf, чтобы ввести список путей счетчиков из входного файла (по одному в строке). Для каждого пути объекта используется следующий формат: [\\компьютер]\объект[экземпляр]\счетчик, где компьютер (необязательный параметр) — имя или IP-адрес удаленного компьютера. Если имя компьютера не указано, по умолчанию будет использоваться локальный компьютер; объект — объект счетчика производительности (процесс или память); экземпляр (если указан) — объект производительности (процесс); счетчик — счетчик производительности для объекта (процессорное время).
–si [[чч:]мм:]сс | Интервал обновления для выборки данных счетчиков в часах, минутах и секундах
-f bin | bincirc | csv | tsv | SQL | Формат файла, используемый для сбора данных счетчиков производительности и данных трассировки. Для журнала может быть выбран один из следующих форматов: двоичный (bin), циклический двоичный (circbin), текст с разделителями-запятыми (csv) и текст с разделителями-знаками табуляции (tsv), а также формат базы данных SQL. Если формат файла не указан, по умолчанию используется двоичный. В выборках данных трассировки можно использовать только двоичный (bin) или циклический двоичный (circbin) формат.
–max {значение} | Максимальный размер файлов журнала в мегабайтах. Если размер журнала превышает максимальный, накопление данных прекращается. Для базы данных SQL максимальный размер представляет собой максимальное число записей.
–o путь | Путь файла, в котором записываются данные счетчиков производительности или данные трассировки. По умолчанию в качестве имени файла журнала используется имя выборки с расширением .blg для счетчиков производительности или .etl для данных трассировки.
–v {nnnnn | ммддччмм} | Добавление данных контроля версий в конец выходного файла и пути. Используйте для контроля версий числовой формат nnnnn или формат даты ммддччмм, включающий месяц, день, час (в 24-часовой нотации) и минуты.
–b М/д/гггг ч:мм:сс[AM | PM] | Время (в 24-часовом формате) начала записи выборки данных. Можно задать время в 12-часовом формате, добавив в командную строку параметр AM или PM. По умолчанию используются текущие день и время, если не заданы другие данные.
–e М/д/гггг ч:мм:сс[AM | PM] | Время (в 24-часовом формате) окончания записи выборки данных. Можно задать время в 12-часовом формате, добавив в командную строку параметр AM или PM. По умолчанию используются текущие день и время, если не заданы другие данные.
–r –[–]r | Повторная запись выборки данных каждый день в течение интервала времени, задаваемом параметрами –b и –e. Действительно только для интервалов, время начала и окончания которых приходится на один и тот же день, месяц и год. Параметр –[–]r выключает режим повтора.
–p {поставщик [флаги [уровень]]} | Имя поставщика
–bs {значение} | Размер буфера (в килобайтах) для журнала трассировки
–nb {мин макс} | Минимальное и максимальное число буферов для журнала трассировки
–ft [[чч:]мм:]сс | Включение режима очиски буфера и интервал очистки

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    logman /?

См. также


Определение параметров запуска и остановки для журнала или оповещения

Рисунок Microsoft Windows

Чтобы определить параметры запуска и остановки журнала или оповещения

Использование интерфейса Windows

  1. Откройте оснастку Производительность.
  2. Дважды щелкните значок Оповещения и журналы производительности, а затем щелкните значок Журналы счетчиков, Журналы трассировки или Оповещения.
  3. В области сведений дважды щелкните запись журнала или оповещения.
  4. Откройте на вкладку Расписание.
  5. В группе Запуск журнала выберите один из следующих вариантов.
    • Для запуска журнала или оповещения вручную выберите вариант Вручную. Если выбран этот вариант, для запуска журнала или оповещения в области сведений щелкните соответствующую запись правой кнопкой мыши и выберите команду Запуск.
    • Чтобы запустить журнал или оповещение в конкретное время определенной даты, выберите вариант Время и укажите время и дату.
  6. В группе Остановка журнала выберите один из следующих вариантов.
    • Для остановки журнала или оповещения вручную выберите вариант Вручную. Если выбран этот вариант, для остановки журнала или оповещения в области сведений щелкните соответствующую запись правой кнопкой мыши и выберите команду Остановка.
    • Чтобы остановить журнал или оповещение через определенное время, выберите вариант Через и укажите интервал и единицы измерения (дни, часы и т. д.)
    • Чтобы остановить журнал или оповещение в конкрентное время определенной даты, выберите вариант Время и укажите время и дату. (Год задается четырьмя цифрами, а месяц и день — двумя).
    • Чтобы остановить журнал, когда файл журнала достигнет максимального размера, установите следующие параметры.
      • Для журналов счетчиков выберите вариант Когда файл журнала заполнен. Запись данных в файл будет продолжаться в соответствии с максимальным размером файла, установленным на вкладке Файлы журналов.
      • Для журналов трассировки выберите вариант Когда файл журнала размером n Мбайт заполнен. Запись данных в файл будет продолжаться в соответствии с максимальным размером файла, установленным на вкладке Файлы журналов.

      При выборе этого варианта проверьте наличие достаточного места на диске и во всех действующих дисковых квотах. Если при ведении журнала закончится свободное место на диске, возникнет ошибка.

  7. Задайте дополнительные параметры журналов и оповещений.
    • Для журналов установите подходящие параметры в группе Когда файл журнала будет закрыт.
      • Если требуется непрерывное (автоматическое) ведение журнала счетчиков или трассировки, установите флажок Начать новый файл журнала.
      • Если после остановки файла журнала требуется запустить программу (например команду копирования файла журнала на другой узел для архивации), установите флажок Выполнить команду. Введите путь и имя файла программы либо нажмите кнопку Обзор и найдите эту программу.

        По умолчанию программа выполняется в фоновом режиме. Если требуется выполнить интерактивную программу, следует также открыть оснастку «Управление компьютером» и установить флажок Разрешить взаимодействие с рабочим столом на вкладке Вход в систему в окне свойств службы Оповещения и журналы производительности. Используйте поле «От имени» для задания учетной записи администратора данной системы.

        Где?

        • Программы
        • Администрирование
        • Управление компьютером
        • Службы и приложения
        • Службы
        • Оповещения и журналы производительности
        • Вкладка Вход в систему
    • Для оповещений установите в группе Когда наблюдение за оповещениями будет закончено флажок Начать новое наблюдение, если наблюдение за оповещениями должно проводиться непрерывно.

Примечание

  • XOX
  • Если журнал планируется остановить автоматически (в конкретное время определенной даты) или вручную, флажок Начать новый файл журнала недоступен.
  • Если журнал настроен на запуск в конкретное время, указанное в поле Время, журнал будет перезапущен, если система перезагрузится в течение интервала его ведения. Этот интервал определяется параметрами группы Остановка журнала.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    logman update имя_выборки –m start stop

Значение | Описание
update имя_выборки | Обновление запроса имя_выборки на выборку данных.
–m start stop | Запуск и остановка журнала вручную. start — время начала ведения журнала. stop — время окончания ведения журнала.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    logman /?

См. также


Удаление журнала или оповещения

Рисунок Microsoft Windows

Чтобы удалить журнал или оповещение

Использование интерфейса Windows

  1. Откройте оснастку Производительность.
  2. Дважды щелкните значок Оповещения и журналы производительности.
  3. Щелкните значок Журналы счетчиков, Журналы трассировки или Оповещения.
  4. В области сведений щелкните правой кнопкой мыши журнал или оповещение и выберите команду Удалить.

Примечание

  • XOX

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    logman delete имя_выборки

Значение | Описание
delete имя_выборки | Удаление запроса на выборку данных имя_выборки. Если запрос имя_выборки не существует, появится сообщение об ошибке.

Например, чтобы удалить журнал трассировки perf_log, введите:

logman delete perf_log

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    logman /?

  • Эта команда служит для удаления только журналов. Она не предназначена для удаления оповещений.


Основные понятия

В этом разделе собраны сведения общего характера о средствах наблюдения за производительностью Windows XP.

  • Введение в наблюдение за производительностью
  • Общее представление о подсистеме наблюдения за производительностью
  • Работа со средствами измерения производительности
  • Администрирование подсистемы наблюдения за производительностью
  • Ресурсы


Введение в наблюдение за производительностью

Windows XP включает следующие средства наблюдения за использованием ресурсов компьютера:

  • компонент «Системный монитор» консоли «Производительность»;
  • компонент «Оповещения и журналы производительности» консоли «Производительность»;
  • диспетчер задач.

Наблюдение за производительностью системы является важной составной частью системы обслуживания и администрирования установленной копии Windows XP. Данные о производительности используются для:

  • определения рабочей нагрузки и ее влияния на ресурсы системы;
  • обнаружения изменений и тенденций в рабочей нагрузке и использовании ресурсов для планирования будущей модернизации;
  • проверки изменений конфигурации и других способов настройки путем наблюдения результатов;
  • диагностики неполадок и конечных компонентов или процессов с целью оптимизации.

Компоненты «Системный монитор» и «Оповещения и журналы производительности» предоставляют подробные сведения о ресурсах, используемых конкретными объектами операционной системы и программами, предназначенными для сбора данных. Данные о производительности отображаются в виде диаграмм. Кроме того, данные записываются в журналы. Компонент «Оповещения» позволяет отправить пользователям уведомление посредством службы сообщений Windows, когда значение счетчика достигнет, превысит или упадет ниже заданного порога.

Результаты наблюдения за производительностью часто используются службой технической поддержки корпорации Майкрософт при диагностике неполадки. Поэтому наблюдение за производительностью системы рекомендуется в качестве одной из задач администратора.

Диспетчер задач представляет собой еще одно средство для получения данных о производительности компьютера, работающего под управлением Windows XP. Диспетчер задач предоставляет данные о программах и процессах, выполняемых компьютером, а также сводку сведений об использовании процессора и памяти.

Сведения общего характера о средствах измерения производительности см. в разделах Общие сведения о системном мониторе и Общие сведения об оповещениях и журналах производительности.


Общие сведения о системном мониторе

Системный монитор позволяет измерять производительность локального компьютера и других компьютеров в сети и обладает следующими возможностями:

  • сбор и просмотр в реальном масштабе времени данных о производительности локального компьютера или удаленных компьютеров;
  • просмотр собранных данных, текущих или ранее записанных в журнал счетчиков;
  • представление данных в виде диаграммы, гистограммы или отчета;
  • интеграция функциональных возможностей в объекты, поддерживающие элементы управления ActiveX, например веб-страницы, Microsoft Word, а также другие приложения, входящие в состав набора Microsoft Office;
  • создание страниц HTML с данными о производительности;
  • создание и сохранение конфигураций параметров наблюдения, устанавливаемых на других компьютерах с использованием консоли управления MMC.

Системный монитор позволяет осуществлять сбор и просмотр больших объемов данных о использовании ресурсов оборудования и активности системных служб на администрируемых компьютерах. Далее перечислены параметры, которые можно использовать при описании необходимых данных.

  • Тип данных. Чтобы определить собираемые данные, следует задать
    • объекты производительности, счетчики производительности и экземпляры объектов.

Некоторые объекты предоставляют данные о системных ресурсах, таких как память. Другие объекты предоставляют данные о работе приложений, например о системных службах или приложениях Microsoft BackOffice, выполняемых компьютером.

  • Источник данных. Системный монитор позволяет собирать данные с локального компьютера или других компьютеров в сети при наличии соответствующих разрешений. (По умолчанию для этого требуется разрешение на администрирование компьютера.) Кроме того, можно использовать текущие данные или данные, ранее записанные в журналы счетчиков.
  • Параметры выборки данных. Системный монитор поддерживает следующие режимы выборки данных: ручной и автоматический с заданным интервалом. При просмотре данных из журнала также можно задать начальное и конечное время, чтобы выбрать определенный временной интервал.

Вдобавок к параметрам, определяющим содержание данных, предусмотрено несколько вариантов их просмотра в системном мониторе. Далее перечислены имеющиеся возможности.

  • Тип отображения. Системный монитор поддерживает отображение данных в виде диаграммы, гистограммы и отчета. По умолчанию включен режим диаграммы, обладающий наибольшим набором параметров настройки.
  • Параметры отображения. В любом из трех режимов отображения данных можно выбирать цвета и шрифты. В режиме диаграммы и гистограммы можно задавать множество дополнительных параметров отображения, в том числе:
    • заголовок диаграммы или гистограммы и подпись вертикальной оси;
    • диапазон значений, отображаемых на диаграмме или гистограмме;
    • параметры линий и столбцов, показывающих значения счетчиков, включая цвет, ширину, стиль и т.д.

Дополнительные сведения о наблюдении за производительностью см. в разделе Введение в наблюдение за производительностью.

Дополнительные сведения об интерфейсе системного монитора см. в разделе Интерфейс системного монитора.


Общие сведения об оповещениях и журналах производительности

Компонент «Оповещения и журналы производительности» позволяет собирать данные о производительности с локального или удаленных компьютеров в автоматическом режиме. Данные журналов счетчиков можно просмотреть в системном мониторе или экспортировать в программу работы с электронными таблицами для анализа и создания отчета. Далее перечислены возможности компонента «Оповещения и журналы производительности».

  • Компонент «Оповещения и журналы производительности» записывает данные в текстовый файл с разделителями — запятыми или знаками табуляции — для импорта в электронные таблицы. Для ведения циклических журналов и журналов экземпляров, таких как потоки и процессы, которые могут запускаются после начала записи, также поддерживается двоичный формат файла журнала. (Циклический журнал представляет собой процесс последовательного занесения данных в один файл с перезаписью новыми данными старых.)
  • Кроме того, данные можно собирать в формате базы данных SQL. В этом режиме задаются существующая база данных SQL и набор журналов в этой базе данных, в который будут записываться и извлекаться данные о производительности. Этот формат полезен для сбора и анализа данных о производительности в масштабе предприятия (не в масштабе отдельного сервера).
  • Данные счетчиков, собираемые компонентом «Оповещения и журналы производительности», можно просмотреть как во время сбора, так и позже.
  • Поскольку ведение журнала выполняется службой, сбор данных осуществляется независимо от того, вошел ли какой-либо пользователь в систему на компьютере, за которым ведется наблюдение.
  • Можно задать начальное и конечное время, имена и размеры файлов и другие параметры для автоматического ведения журналов.
  • Из одного окна консоли можно управлять ведением нескольких журналов.
  • Можно включить оповещение, определяющее отправку сообщения, запуск программы, занесение записи в журнал событий приложений или начало ведения журнала, если значение счетчика станет меньше или больше указанного порога.

Аналогично системному монитору, компонент «Оповещения и журналы производительности» предоставляет средства определения объектов производительности, счетчиков производительности и экземпляров объектов, а также задания интервалов выборки для наблюдения данных об использовании аппаратных ресурсов и системных служб. Также имеются возможности (перечислены ниже) настройки записи данных о производительности.

  • Запуск и остановка журнала. Выполняются вручную или автоматически на основе расписания, составленного пользователем.
  • Настройка дополнительных параметров. Обеспечивает автоматическое ведение журнала, включая построение имен файлов и задание пераметров открытия и закрытия журнала на основе истекшего времени или размера файла.
  • Создание журналов трассировки. С помощью поставщика системных данных Windows XP, используемого по умолчанию, или другого поставщика, в журналы трассировки заносятся данные событиях в системе, обусловленных определенными действиями, такими как операция ввода-вывода на диск или сбой доступа к странице памяти. Когда происходит заданное событие, Windows XP записывает данные в файл, указанный службой «Оповещения и журналы производительности». Этот режим отличается от режима ведения журналов счетчиков. При ведении журнала счетчиков данные записываются по истечении интервала обновления, а не при наступлении определенного события. Для обработки выходных данных журнала трассировки необходимо средство синтаксического разбора. Разработчики могут создавать такие средства, используя интерфейсы программирования (application programming interfaces, API), представленные на веб-узле MSDN (http://msdn.microsoft.com/).
  • Кроме того, обработать журналы трассировки и получить отчеты с анализом данных можно также с помощью средства Tracerpt. Используйте это средство для обработки журналов трассировки событий ядра системы, Active Directory и других транзактных событий с целью получения отчетов с анализом данных трассировки и файлов .csv из двоичных журналов.
  • Определение программы, запускаемой, когда журнал остановлен.

Чтобы экспортировать данные журнала в Microsoft Excel, необходимо остановить службу «Оповещения и журналы производительности», так как Microsoft Excel осуществляет доступ к файлу журнала в монопольном режиме. Для большинства других программ можно работать с данными журнала, в то время как эта служба будет продолжать запись данных в файл.

Дополнительные сведения о интерфейсе пользователя компонента «Оповещения и журналы производительности» содержатся в разделе Интерфейс компонента «Оповещения и журналы производительности».


Общее представление о подсистеме наблюдения за производительностью

В этом разделе описаны интерфейс и функциональные возможности компонентов "Системный монитор" и "Оповещения и журналы производительности" консоли управления.

  • Объекты и счетчики производительности
  • Архитектура подсистемы наблюдения за производительностью
  • Наблюдение за производительностью в Windows NT 4.0


Объекты и счетчики производительности

Windows XP получает данные о производительности от компонентов компьютера. Работающий компонент системы генерирует данные о производительности. Эти данные представляются в виде объекта производительности, который обычно называется так же, как компонент, генерирующий данные. Например, объект «Процессор» представляет собой набор данных о производительности процессоров, имеющихся в системе.

Различные объекты производительности, встроенные в операционную систему, обычно соответствуют основным компонентам оборудования, таким как память, процессоры и т. д. Другие программы могут устанавливать собственные объекты производительности. Например, такие службы, как WINS, или такие серверные программы, как Microsoft Exchange, предоставляют объекты производительности, наблюдение за которыми можно осуществлять с помощью диаграмм и журналов.

Каждый объект производительности содержит счетчики, дающие сведения о конкретных элементах системы или службы. Например, счетчик «Обмен страниц в сек» объекта «Память» отслеживает скорость обмена страниц памяти.

Несмотря на то что в системе может иметься гораздо больше объектов, обычно наиболее часто для наблюдения за системными компонентами используются следующие объекты, доступные по умолчанию:

  • Кэш
  • Память
  • Объекты
  • Файл подкачки
  • Физический диск
  • Процесс
  • Процессор
  • Сервер
  • Система
  • Поток

Следующие службы и средства Windows XP предоставляют объекты производительности.

Средство или служба для наблюдения | Доступные объекты производительности
TCP/IP | ICMP, IP, NetBT, TCP, UDP
Обозреватель компьютеров, Рабочая станция, Сервер | Обозреватель сети, Перенаправитель, Сервер
QoS RSVP | Служба RSVP, Интерфейсы RSVP
WINS | WINS
Службы точки подключения | Монитор PBServer
Служба индексирования | Служба индексирования, Фильтр службы индексирования, Служба индексирования HTTP
Служба каталогов | NTDS
Активность сервера печати | Очередь печати

Для получения описания данных, поставляемых определенным счетчиком, связанным с объектом производительности, нажмите в диалоговом окне Добавить счетчики кнопку Объяснение. Сведения о добавлении счетчиков содержатся в разделе Добавление счетчиков в системном мониторе.

В то время как некоторые объекты (такие как «Память» и «Сервер») обладают только одним экземпляром, другие объекты производительности могут иметь несколько экземпляров. Если объект обладает несколькими экземплярами, можно добавить счетчики для сбора сведений о каждом экземпляре либо общий счетчик для всех экземпляров.

Далее перечислены возможные варианты значения счетчика.

  • Самое последнее измерение показателя использования ресурса. Такие счетчики также называются счетчиками мгновенных значений.

    Например, Процесс\Счетчик потоков, последнее измерение числа потоков определенного процесса.

  • Среднее из двух последних измерений. (Поскольку счетчики никогда не обнуляются, это значение действительно является средним между двумя измерениями.)

    Например, Память\Обмен страниц в сек, среднее значение скорости обмена страниц в секунду в течение последних двух интервалов выборки.

    • В пакете Platform Software Development Kit приведены инструкции по созданию счетчиков других типов.

Сочетание имени компьютера, объекта, счетчика, экземпляра и кода экземпляра называется путь счетчика. Обычно путь счетчика имеет следующий формат:

Имя_компьютера\Имя_объекта(Имя_экземпляра#Код)\Имя_счетчика

Элемент Имя_компьютера может отсутствовать. Если имя компьютера не указано, Windows XP по умолчанию использует локальный компьютер.


Архитектура подсистемы наблюдения за производительностью

Работа компонентов «Системный монитор» и «Оповещения и журналы производительности» консоли управления поддерживается на разных уровнях архитектуры Windows. Например, по умолчанию средства измерения производительности получают данные через реестр. Кроме того, получение данных о ресурсах оборудования и приложениях, установленных в системе, может выполняться посредством интерфейса инструментария управления Windows (Windows Management Instrumentation, WMI). Библиотека динамической компоновки (dynamic-link library, DLL) Performance Data Helper действует как посредник между WMI и средствами измерения производительности. Она форматирует данные и производит вычисления, если это необходимо, с целью преобразования исходных данных для отображения или создания отчета. Сведения о настройке средств измерения производительности для сбора данных с помощью WMI см. в разделе Сбор данных о производительности с помощью WMI.

Библиотеки DLL операционной системы предоставляют счетчики для наблюдения за состоянием таких ресурсов, как память, процессоры, диски, сетевые платы и протоколы. Кроме того, многие службы Windows и приложения BackOffice включают собственные библиотеки DLL со счетчиками, которые можно использовать для наблюдения за работой этих служб и приложений.

Компоненты «Системный монитор» и «Оповещения и журналы производительности» используют процесс службы «Удаленный реестр», управляющий входом пользователя в систему и выходом из нее, для наблюдения за удаленными подключениями. Кроме того, эти компоненты применяют службу сообщений Windows для отправки пользователям оповещений. (Для получения оповещений данная служба должна быть запущена.)


Наблюдение за производительностью в Windows NT 4.0

Возможности компонентов «Системный монитор» и «Оповещения и журналы производительности» оснастки «Производительность» превосходят возможности системного монитора Windows NT 4.0. Эти средства позволяют открывать файлы параметров, созданные системным монитором Windows NT 4.0.

Системный монитор для Windows NT 4.0 (perfmon4.exe) можно загрузить с веб-узла Microsoft Windows Resource Kits (http://www.microsoft.com/).


Работа со средствами наблюдения за производительностью

В этом разделе

  • Настройка конфигурации подсистемы наблюдения
  • Краткий справочник по параметрам системного монитора
  • Панель инструментов и сочетания клавиш системного монитора
  • Интерфейс системного монитора
  • Интерфейс компонента «Оповещения и журналы производительности»
  • Анализ данных о производительности
  • Повышение производительности системы
  • Выявление тенденций и планирование наращивания ресурсов


Настройка конфигурации подсистемы наблюдения

Настройка конфигурации подсистемы наблюдения является первым шагом при определении производительности системы. Для наблюдения за установленной копией Windows XP можно просматривать данные на диаграмме или сохранять их в журнале с целью использования в других приложениях.

Для достижения наилучших результатов перед настройкой конфигурации подсистемы наблюдения ознакомьтесь со следующими разделами. Чтобы быстро приступить к работе, можно воспользоваться готовой настройкой журнала в разделе Журналы счетчиков. Эта конфигурация, «Обзор системы», создает двоичный файл журнала, который после запуска вручную обновляется каждые 15 минут и ведется до достижения максимального размера файла. Если журнал запускается с этими параметрами, данные сохраняются в папке Perflogs корневого каталога и включают следующие счетчики: Память\Обмен страниц в сек, Физический диск(_Total)\Средняя длина очереди диска и Процессор(_Total)\% загруженности процессора.

Выбор способа наблюдения

Диаграммы удобны для кратковременного наблюдения за текущей производительностью локального или удаленного компьютера. Например, если требуется проследить за выполнением какого-либо системного процесса. Выберите интервал обновления, наиболее подходящий для наблюдения за определенным типом активности. Журналы используются для хранения данных производительности и расширения возможностей наблюдения, особенно за удаленным компьютером. Данные журнала можно экспортировать для создания отчетов и представления их в системном мониторе в виде диаграмм или гистограмм. Ведение журнала является наиболее распространенным способом наблюдения за несколькими компьютерами.

Выбор частоты обновления данных

Постоянное наблюдение за активностью следует осуществлять с интервалом не менее 15 минут. При наблюдении за конкретными неполадками этот интервал можно изменить. При наблюдении за активностью определенного процесса в определенное время задайте короткий интервал обновления, а при наблюдении за неполадкой, проявляющейся длительное время (например, за утечкой памяти), используйте более длинный интервал.

Кроме того, при выборе этого интервала учитывайте общую продолжительность наблюдения. Например, обновление данных каждые 15 секунд оправдано, только если наблюдение ведется не больше четырех часов. Если наблюдение ведется восемь часов и более, не задавайте интервал обновления менее 300 секунд (5 минут). Увеличив частоту обновления (задав меньшее значение параметра), можно получить большой объем данных, что может усложнить их обработку и повысить в системе нагрузку, обусловленную работой службы «Оповещения и журналы производительности».

При наблюдении за большим числом объектов и счетчиков также записываются большие объемы данных, занимающих дисковое пространство. Попробуйте найти оптимальное соотношение между числом наблюдаемых объектов и частотой обновления данных, чтобы размер файла журнала был не слишком большим.

Если данные обновляются с большим интервалом, есть способ просмотра изменения значений для двух соседних интервалов. Сведения об изменении диапазонов времени в журнале содержатся в разделе Использование данных журнала.

Выбор данных для наблюдения

Начните с наблюдения за активностью следующих компонентов в указанном порядке:

  • Память
  • Процессоры
  • Диски
  • Сеть

В следующей таблице приведены минимальные рекомендуемые значения счетчиков для наблюдения за сервером. При исследовании определенных ресурсов следует включить другие счетчики, относящиеся к тому же объекту производительности.

Компонент | Наблюдаемый аспект производительности | Соответствующие счетчики
Диск | Использование | Физический диск\Обращений чтения с диска/сек Физический диск\Обращений записи на диск/сек Логический диск\% свободного места Внимательно относитесь к значению счетчика «% активности диска». Поскольку экземпляр _Total этого счетчика не может точно отражать использование нескольких дисковых систем, следует также использовать счетчик «Процент времени бездействия». Имейте в виду, что значения всех этих счетчиков ограничиваются величиной 100%.
Диск | Неполадки | Физический диск\Средняя длина очереди диска (все вхождения)
Память | Использование | Память\Доступно байт Память\Байт-кэш памяти
Память | Неполадки | Память\Обмен страниц в сек Память\Чтений страниц/сек Память\Ошибок транзита/сек Память\Байт в выгружаемом страничном пуле Память\Байт в невыгружаемом страничном пуле Для анализа использования памяти могут также оказаться полезными следующие счетчики (хотя они не являются счетчиками объекта «Память»): Файл подкачки\% использования (все вхождения) Кэш\% попаданий при отображении данных Сервер\Байт в выгружаемом страничном пуле и Сервер\Байт в невыгружаемом страничном пуле
Сеть | Пропускная способность | Protocol transmission counters (изменяются в зависимости от сетевого протокола); для TCP/IP: Сетевой интерфейс\Всего байт/сек Сетевой интерфейс\Пакетов/сек Сервер\Всего байт/сек, Сервер\Передано байт/сек и Сервер\Получено байт/сек Можно воспользоваться другими объектами для наблюдения за пропускной способностью сети и сервера; см. раздел Наблюдение за активностью сети.
Процессор | Использование | Процессор\% загруженности процессора (все вхождения)
Процессор | Неполадки | Система\Длина очереди процессора (все экземпляры) Процессор\Прерываний/сек Система\Контекстных переключений/сек

Если некоторые из перечисленных счетчиков недоступны на данном компьютере, убедитесь, что необходимые службы установлены, а счетчики активизированы.

Выбор компьютера для наблюдения

При удаленном наблюдении за компьютерами предусмотрены разные способы сбора данных. Например, можно включить ведение журнала производительности на компьютере администратора и собирать данные со всех удаленных компьютеров. В другом случае можно на всех компьютерах запустить службы сбора данных и через определенные интервалы времени запускать пакетную программу для передачи данных на компьютер администратора для анализа и архивации.

Централизованный сбор данных (т.е. когда на локальном компьютере собираются данные с удаленных компьютеров, за которыми ведется наблюдение) является наиболее простым в реализации, так как требует запуска только одной службы ведения журнала. Возможен сбор данных от нескольких систем в единый файл журнала. Однако это создает дополнительный сетевой трафик и размер журнала может быть ограничен объемом доступной памяти на компьютере администратора. Для централизованного сбора данных воспользуйтесь диалоговым окном Добавить счетчики для выбора удаленного компьютера, когда на локальном компьютере запущен системный монитор.

Распределенный сбор данных (сбор данных, получаемых с удаленных компьютеров, за которыми ведется наблюдение) не вызывает трудностей с памятью и сетевым трафиком, как в случае централизованного сбора данных. Однако при этом доступ к данным откладывается, поскольку собранные данные для обработки должны быть переданы на компьютер администратора. Для распределенного сбора данных воспользуйтесь окном «Управление компьютером» на локальном компьютере для выбора удаленного компьютера, с которого требуется собирать данные.

При наблюдении за удаленными компьютерами имейте в виду, что доступ к удаленным компьютерам возможен только для пользователей, обладающих соответствующим правами доступа. Для наблюдения за удаленными системами с локального компьютера необходимо запустить службу «Оповещения и журналы производительности», используя учетную запись, обладающую разрешением на доступ к удаленным компьютерам. По умолчанию эта служба запускается с использованием системной учетной записи локального компьютера, которая обычно обладает разрешением только на доступ к службам и ресурсам локального компьютера. Для запуска ее под другой учетной записью воспользуйтесь режимом «Запуск от имени» при настройке сбора данных или измените свойства службы «Оповещения и журналы производительности» в разделе «Службы» окна «Управление компьютером».

Хранение записей данных о производительности

С помощью оснастки «Оповещения и журналы производительности» регистрируемые данные можно заносить в базу данных SQL. Сведения, находящиеся в базе данных, можно извлекать запросами и включать в отчеты. Используя средства анализа баз данных, можно фильтровать данные и подробно анализировать результаты, используя различные параметры. Журналы также можно использовать для анализа тенденций и планирования ресурсов.

Экспорт конфигурации подсистемы наблюдения

После создания конфигурации средств наблюдения за производительностью, в которой заданы счетчики, интервал обновления и другие параметры, можно сохранить эту настройку на локальном компьютере. При сохранении настройки в файле Perfmon.msc используемая по умолчанию конфигурация этих средств на данном компьютере изменяется. Поэтому параметры рекомендуется сохранять в файле с другим именем.

Кроме сохранения параметров наблюдения можно добавлять другие средства или дополнительные копии системного монитора. Например, если требуется одновременное отображение диаграммы и отчета. Сведения о добавлении средств в консоль см. в разделе Создание пользовательской консоли наблюдения.


Краткий справочник по настройке свойств системного монитора

Для доступа к следующим параметрам щелкните правой кнопкой мыши область сведений системного монитора и выберите команду Свойства.

Параметр | Вкладка
Режим просмотра: график, гистограмма или отчет | Общие
Объекты, счетчики и экземпляры (добавление и удаление) | Данные Счетчики также можно добавить, щелкнув правой кнопкой мыши область сведений и выбрав команду Добавить счетчики или нажав кнопку Добавить на панели инструментов. Удалять счетчики можно кнопкой Удалить на вкладке Данные, клавишей DELETE на клавиатуре или кнопкой Удалить на панели инструментов. Чтобы удалить все счетчики и добавить новые, нажмите на панели инструментов кнопку Новый набор счетчиков .
Источник отображаемых данных: текущие собираемые данные, данные журнала, архивированные данные журнала. | Источник Также можно нажать на панели инструментов кнопку Просмотр данных файла журнала , чтобы использовать в качестве источника данных файл журнала, или кнопку Просмотр текущей активности для просмотра текущих собираемых данных.
Диапазоны времени для ведения журнала и для просмотра | Источник
Частота обновления | Общие Данные также можно получать вручную с помощью кнопок Не изменять отображение и Обновить данные на панели инструментов.
Тип значений отчета или гистограммы: минимальные, максимальные или средние | Общие
Отображение условного обозначения счетчика | Общие
Отображение последнего, минимального и максимального значений выбранного счетчика (в строке значений); разрешение отображения нескольких экземпляров | Общие
Цвет, ширина и тип линии | Данные
Масштаб значений данных счетчика | Данные
Цвет фона вокруг области отображения диаграммы; цвет области отображения диаграммы | Оформление
Заголовок диаграммы | График
Подпись вертикальной оси, горизонтальная и вертикальная сетки, максимальные и минимальные значения осей | График
Цвет шрифта на диаграмме или в области условных обозначений | Оформление
Тип, размер и начертание шрифта | Оформление
Цвет сетки, цвет линии времени | Оформление
Тип линии границы, внешний вид окна диаграммы | Общие
Панель инструментов | Общие

При использовании любых типов значений кроме Текущие в ходе наблюдения за данными в реальном масштабе времени возникает значительная дополнительная нагрузка, поскольку для каждого отображаемого значения необходимы вычисления по всем отсчетам.


Панель инструментов системного монитора

Рисунок Microsoft Windows

Панель инструментов и сочетания клавиш системного монитора

Большинство часто встречающихся задач можно выполнить с помощью кнопок панели инструментов и сочетаний клавиш системного монитора. Далее в таблице перечислены типичные задачи и соответствующие им кнопки и сочетания клавиш.

Задача | Кнопка | Сочетание клавиш
Создание нового набора счетчиков | Новый набор счетчиков | CTRL+E
Очистка экрана | Очистка экрана | CTRL+D
Просмотр текущих данных | Просмотр текущей активности | CTRL+T
Просмотр данных файла журнала | Просмотр данных журнала | CTRL+L
Просмотр графика | Просмотр диаграммы | CTRL+G
Просмотр гистограммы | Просмотр гистограммы | CTRL+B
Просмотр отчета | Просмотр отчета | CTRL+R
Добавление счетчика | Добавить | CTRL+I
Удаление счетчика | Удалить | DELETE
Вставка списка счетчиков | Вставить список счетчиков | CTRL+V
Копирование свойств | Копировать свойства | CTRL+C
Открытие окна свойств | Свойства | CTRL+Q
Запрет на обновление экрана | Не изменить отображение | CTRL+F
Обновление данных | Обновить данные | CTRL+U
Выделение данных | Выделить | CTRL+H
Открытие справочного файла | Справка | F1


Интерфейс системного монитора

По умолчанию при открытии консоли «Производительность» в окне отображается панель инструментов, а область диаграммы содержит такой же набор счетчиков, как и в журнале «Обзор системы» компонента «Оповешения и журналы производительности». При добавлении счетчиков их значения начинают отображаться на диаграмме после небольшой задержки (в зависимости от выбранного интервала обновления). Возможно обновление данных в автоматическом режиме или вручную. Для обновления данных вручную служит кнопка Обновить данные. Для удаления отображаемых данных с экрана служит кнопка Очистить экран.

В столбцах под диаграммой отображаются названия и другие сведения о выбранных счетчиках. Они называются условными обозначениями. Условные обозначения включают следующие данные.

  • Компьютер, на котором работает системный монитор.
  • Объект производительности.
  • Счетчик производительности.
  • Цвет значений каждого счетчика.
  • Экземпляр объекта производительности. Следует обратить внимание на то, что по умолчанию экземпляры счетчика отсортированы по названию и номеру. Этот номер появляется после названия экземпляра и знака "#". Номер упрощает наблюдение за несколькими экземплярами, например, если ведется наблюдение за потоками процесса.

    Чтобы выключить отображение номера, щелкните диаграмму правой кнопкой мыши, выберите команду Свойства и снимите флажок Допускать дублирование счетчиков. По умолчанию к именам процессов и потоков добавляется суффикс #n (где n — целое число). Для добавления вместо номера идентификатора процесса создайте параметр ProcessNameFormat типа DWORD в следующем подразделе:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PerfProc\Performance

    и задайте для него значение 2.Аналагично, для добавления вместо номера идентификатора потока, создайте параметр ThreadNameFormat типа DWORD в следующем подразделе:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PerfProc\Performance

    и задайте для него значение 2.

    Для выключения любого из этих режимов и возвращения к настройке по умолчанию задайте для соответствующего параметра значение 1.

Для сопоставления линии на диаграмме со счетчиком выделите счетчик в области услолвных обозначений и нажмите клавиши CTRL+H или кнопку Выделить на панели инструментов, либо дважды щелкните линию. Если выделение включено, линия или столбец данных выбранного счетчика отображается белым цветом для большинства цветов фона (включая используемый по умолчанию) или черным цветом для фонов белого и светлых цветов. Если линии на диаграмме расположены слишком близко, попробуйте найти точку, где они расходятся. В противном случае системному монитору не удастся определить требуемый счетчик.

Над столбцами расположена строка значений, в которой отображаются последнее, минимальное, максимальное и среднее значения текущего выбранного счетчика. Эти значения вычисляются за период времени и по выборке, определяемым значением поля Длительность, а не за все время с момента начала наблюдения. Значение поля Длительность определяет общее время, показанное на диаграмме, которое связано со значением интервала обновления. Перемещение линии таймера вдоль диаграммы показывает течение интервалов обновления. Независимо от интервала обновления на диаграмме отображается не более 100 значений. Данные журнала сжимаются с тем, чтобы их можно было разместить в окне. Для просмотра сжатых данных из журнала щелкните диаграмму правой кнопкой мыши, выберите команду Свойства и задайте на вкладке Источник более короткий диапазон времени. На такой диапазон времени приходится меньше отсчетов, поэтому будет потеряно меньше данных.

Можно задавать следующие атрибуты диаграммы:

  • тип отображения и параметры диаграммы, гистограммы или отчета;
  • цвет фона области сведений и области отображения данных;
  • размер, название и начертание шрифта, используемого для отображения текста;
  • цвет, ширина и стиль линии диаграммы.

Используемые по умолчанию в Microsoft Word сочетания клавиш могут вступать в конфликт с сочетанием клавиш CTRL+H, используемым для выделения в системном мониторе. При использовании в Microsoft Word элемента «Системный монитор» (файл Sysmon.ocx, папка системный_корневой_каталог\System32) для поддержки функции выделения может потребоваться изменение существующей настройки этих клавиш.

По щелчку заголовка столбца Объект, Счетчик, Экземпляр или Компьютер в области условных обозначений выполняется сортировка записей по возрастанию или убыванию значений данного столбца. Например, чтобы отсортировать все записи по названию счетчика, щелкните заголовок столбца Счетчик.

Дополнительные сведения содержатся в разделе Краткий справочник по настройке свойств системного монитора


Интерфейс консоли «Оповещения и журналы производительности»

В оснастке «Оповещения и журналы производительности» определяются параметры журналов счетчиков, журналов трассировки и оповещений. В области сведений окна консоли отображаются имеющиеся журналы и оповещения. Одновременно могут работать несколько журналов и оповещений. Каждая запись журнала или оповещения представляет собой отдельную сохраненную конфигурацию параметров. Если запуск и остановка журнала выполняются в автоматическом режиме, одному журналу могут соответствовать несколько отдельных файлов данных. Например, если создаются ежедневные файлы журналов, один файл будет закрыт в 23:59, а в 00:00 следующего дня будет открыт новый файл. В следующей таблице описано назначение столбцов области сведений.

Столбец | Описание
Название | Имя журнала или оповещения. Это понятное имя описательного характера, по которому можно понять, сбор данных какого типа выполняется или за соблюдением какого условия ведется наблюдение. Одному журналу могут соответствовать несколько отдельных файлов журнала. В разделе журналов счетчиков по умолчанию присутствует образец журнала «Обзор системы». Можно начать ведение этого журнала или предварительно изменить необходимым образом его параметры.
Комментарий | Описание журнала или оповещения.
Тип файла журнала | Заданный формат журнала. Для оповещений всегда используется тип Оповещения; для журналов трассировки всегда используется тип Файл последовательной трассировки. Для журналов счетчиков может быть задан тип Двоичный файл, Двоичный циклический файл, Текстовый файл (разделитель — запятая) или Текстовый файл (разделитель — табуляция) или База данных SQL.
Имя файла журнала | Путь и основное имя файла, заданные для создания файлов этого журнала. Основное имя файла используется для автоматического построения имен новых файлов журнала.

Для просмотра параметров журнала дважды щелкните элемент списка, соответствующий этому журналу. В открывшемся диалоговом окне можно задать имя файлов журнала, время работы журнала и объекты и счетчики производительности для включения в журнал.

Если журнал запущен и выполняется сбор данных (на основе расписания работы журнала или оповещения), рядом с этим журналом или оповещением появляется зеленый значок. Если рядом с названием отображается красный значок, этот журнал или оповещение настроено, но не запущено.

Одновременно могут работать несколько журналов. Одному журналу могут соответствовать несколько файлов журнала, если выбран вариант перезапуска или журнал несколько раз был запущен и остановлен вручную. Однако в окне консоли эти файлы отображаться не будут. Для просмотра этих файлов воспользуйтесь проводником.


Анализ данных о производительности

Рисунок Microsoft Windows

Анализ данных производительности

Анализ данных о производительности состоит в проверке значений счетчиков, возвращаемых во время выполнения системой различных операций. В ходе этого процесса следует определить, какие процессы более активны и какие программы или потоки (если таковые имеются) наиболее активно используют ресурс. Используя такой тип анализа данных производительности, можно понять, как данная система справляется с рабочей нагрузкой.

В результате такого анализа можно заметить, что иногда система обеспечивает требуемую производительность, а иногда — нет. В зависимости от причины и уровня таких различий можно предпринять какие-либо действия для их устранения или оставить все как есть, отложив настройку и наращивание ресурсов.

Уровень производительности системы, достаточный для выполнения обычной рабочей нагрузки и всех необходимых служб, называется средним уровнем. Производительность на среднем уровне является субъективным показателем, определяемым администратором на основе конфигурации рабочей среды. Ему может соответствовать набор значений счетчиков (включая некоторые временно неприемлемые значения), но которые обычно указывают на оптимальную производительность для конкретных условий, задаваемых администратором. Средний уровень может выступать в качестве критерия при настройке производительности компьютеров пользователей и может быть включен в любые соглашения по обслуживанию системы.

Анализ данных о производительности включает:

  • Определение допустимых значений для счетчиков
  • Общие представление об изменениях в данных о производительности


Определение приемлемых значений для счетчиков

В общем случае приемлемый уровень производительности является субъективной оценкой, которая может сильно различаться в разных средах. Для сравнения рекомендуется использовать значение среднего уровня производительности, рассчитанное для данной организации. Следующая таблица, содержащая пороговые значения определенных счетчиков, поможет определить, имеются ли на данном компьютере элементы, ограничивающие его производительность. Если системный монитор постоянно возвращает указанные значения, значит, в работе системы имеются узкие места, и следует заняться настройкой или модернизацией соответствующих ресурсов.

Советы по настройке и модернизации содержатся в разделе Повышение производительности системы.

Ресурс | Объект\Счетчик | Рекомендуемое пороговое значение | Comments
Диск Физический диск\% свободного места
Логический диск\% свободного места 		15%
Диск Физический диск\% активности диска
Логический диск\% активности диска 		90%
Диск | Физический диск\Обращений чтения с диска/сек, Физический диск\Обращений записи на диск/сек | Зависит от технических условий изготовителя | Проверьте указанную скорость передачи дисков, чтобы проверить, соответствует ли она спецификациям. Обычно диски Ultra Wide SCSI могут выполнять от 50 до 70 операций ввода-вывода в секунду.
Диск | Физический диск\Текущая длина очереди диска | Количество осей вращения плюс 2 | Это счетчик мгновенных значений; возьмите несколько значений, полученных в разные моменты времени. Для наблюдения за средним значением воспользуйтесь счетчиком Физический диск\Средняя длина очереди диска.
Память | Память\Доступно байт | Меньше 4 Мбайт | Проследите за использованием памяти и увеличьте ее объем, если требуется.
Память | Память\Обмен страниц в сек | 20 | Проследите за активностью процесса подкачки страниц памяти.
Файл подкачки | Файл подкачки\% использования | Больше 70% | Чтобы получить представление об обмене страниц на компьютере, проследите за этим значением совместно со значениями счетчиков «Доступно байт» и «Обмен страниц в сек».
Процессор | Процессор\% загруженности процессора | 85% | Найдите процесс, использующий наибольшую долю процессорного времени. Замените процессор на более быстрый или установите дополнительный процессор.
Процессор | Процессор\Прерываний/сек | Зависит от процессора; подходящее начальное значение — 1000 прерываний в секунду | Значительное увеличение значения этого счетчика без соответствующего увеличения активности системы указывает на наличие неполадки. Определите, какая сетевая плата отправляет эти прерывания. Возможно, потребуется установить дополнительную плату или контроллер.
Сервер | Сервер\Всего байт/сек | Если сумма значений счетчиков «Всего байт/сек» для всех серверов приближается к максимальной скорости передачи данных по сети, возможно, следует разделить сеть на сегменты.
Сервер Сервер\Нехваток рабочих элементов 3 Если значение счетчика достигает указанного порога, попробуйте добавить записи (типа DWORD) InitWorkItems (число элементов рабочей очереди, выделенных процессору во время запуска системы) или MaxWorkItems (максимальное число буферов приема, которые могут быть выделены сервером) в реестр (в раздел HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters). Запись InitWorkItems может принимать значение в диапазоне от 1 до 512, а запись MaxWorkItems — от 1 до 65535. Начните с любого значения для InitWorkItems и значения 4096 для MaxWorkItems, а затем удваивайте эти значения до тех пор, пока предел счетчика «Сервер\Нехваток рабочих элементов» остается ниже 3. Сведения по изменению реестра см. в справочном файле Редактор реестра.

Внимание!

  • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных.
Сервер | Сервер\Выгружаемый пул (пик) | Объем физической оперативной памяти | Это значение определяет максимальный размер файла подкачки и показывает объем физической памяти.
Сервер | Рабочие очереди сервера\Длина очереди | 4 | Если значение достигает данного порога, возможно, производительность системы ограничивается процессором. Это счетчик мгновенных значений; возьмите несколько значений, полученных в разные моменты времени.
Несколько процессоров | Система\Длина очереди процессора | 2 | Это счетчик мгновенных значений; возьмите несколько значений, полученных в разные моменты времени.


Общее представление об изменениях в данных о производительности

При анализе изменений в показателях производительности следует принять во внимание следующие факторы.

  • Уровень использования ресурсов может сильно меняться в зависимости от времени суток.
  • Счетчики, значения которых вычисляются за определенный интервал времени, являются более информативными, чем средние значения за все время наблюдения, так как последние могут включать данные, собранные во время запуска службы или других событий, кратковременно, но существенно увеличивающих рабочую загрузку.


Повышение производительности системы

Анализ данных наблюдения позволяет обнаружить такие явления, как избыточный спрос на определенные ресурсы, приводящий к возникновению узкого места в работе системы. В этом разделе описаны общие причины возникновения узких мест и рекомендации по настройке и проверке производительности системы.

Причины возникновения узких мест в работе системы

Чрезмерный спрос на системные ресурсы, приводящий к появлению узких мест в работе системы, может возникать по следующим причинам:

  • недостаточно ресурсов; требуется их наращивание или модернизация;
  • ресурсы используются неравномерно и требуется их перераспределение;
  • ресурс неисправен и требуется его замена;
  • определенный ресурс используется программой в монопольном режиме, поэтому может потребоваться замена ее другой программой, изменение программы разработчиком, наращивание или модернизация ресурсов либо запуск программы в периоды низкой загруженности;
  • ресурс неправильно настроен и требуется изменение его параметров.

Рекомендации по настройке и проверке производительности системы

Таблица пороговых значений в разделе Определение допустимых значений счетчиков поможет связать низкий уровень производительности с определенным ресурсом. Описание процедур настройки и модернизации, относящихся к определенному компоненту, можно найти в одном из следующих разделов:

  • Наблюдение и настройка использования памяти
  • Наблюдение за загруженностью процессора
  • Наблюдение за активностью диска
  • Наблюдение за активностью сети
  • Наблюдение за службами Windows XP
  • Наблюдение за устаревшими программами

Наиболее частой причиной снижения производительности компьютерных систем является недостаток памяти. При возникновении неполадок с производительностью начните с проверки счетчиков памяти. Неудовлетворительное время ответа на рабочей станции скорее всего является результатом неполадок памяти и процессора; серверы больше подвержены влиянию неполадок диска и сети.

Прежде чем приступить к настройке, примите к сведению следующие рекомендации.

  • Одновременно вносите не более одного изменения. В некоторых случаях неполадка, которая, как кажется, относится к одному компоненту, может быть результатом возникновения узких мест в работе нескольких компонентов. Поэтому к изучению каждой неполадки следует подходить постепенно.

    Одновременное внесение нескольких изменений делает невозможным определение результатов каждого конкретного изменения.

  • Повторяйте наблюдение после каждого изменения. Это важно для определения последствий этого изменения и принятия решения о необходимости внесения дополнительных изменений. Методично вносите одно изменение в ресурс за другим, после каждого наблюдая за изменениями в производительности. Поскольку изменения в настройке могут повлиять на другие ресурсы, важно хранить записи внесенных изменений и результатов наблюдения за производительностью.
  • Вдобавок к наблюдению просматривайте журналы событий, поскольку при некоторых неполадках, связанных с производительностью, в журнал событий заносятся сообщения. Дополнительные сведения о просмотре событий содержатся в справочном файле Просмотр событий.
  • Чтобы определить, связаны ли сетевые компоненты с неполадками в производительности, сравните работу программ, запущенных по сети, с работой локальных программ.

Советы по настройке и модернизации компонентов

В данном разделе приведены советы по настройке наблюдаемых ресурсов.

  • Память
    • Увеличьте объем физической памяти, чтобы он превышал минимальный требуемый.
    • Создайте несколько файлов подкачки, если имеется несколько дисков.
    • Определите оптимальный размер файла подкачки. Рекомендуется установить размер файла подкачки в 1,5 раза больше размера установленной оперативной памяти.
    • Убедитесь, что параметры памяти установлены правильно, как описано в разделе Обеспечение достаточного количества памяти.
    • Запускайте требовательные к памяти программы на высокопроизводительных компьютерах во время низкой рабочей нагрузки.
  • Диск
    • Обновите диск на более быстрый или установите дополнительные диски. Также не забудьте модернизировать контроллер и шину диска.
    • На серверах для создания чередующихся томов на нескольких физических дисках используйте оснастку «Управление дисками». Это повышает пропускную способность, так как обеспечивает параллельную обработку запросов ввода-вывода.
    • Распределите выполнение программ между серверами. Для перераспределения рабочей нагрузки можно воспользоваться распределенной файловой системой (Distributed File System, DFS).
    • Разместите задачи, активно использующие диск, на разных физических дисках или дисковых контроллерах.
    • Используйте программу «Дефрагментация диска» для дефрагментации файлов с целью ускорения доступа к данным и увеличения размера свободного места на диске.
    • Если требуется увеличить эффективность операций доступа к диску, установите последние версии драйверов контроллеров. За дополнительными сведениями обращайтесь к производителю контроллера.
  • Процессор
    • Добавьте процессор (особенно для многопотоковых программ) или обновите процессор на более быстрый.
    • На многопроцессорных компьютерах установите соответствие процессоров для потоков процессов и прерываний.
  • Сеть
    • Настройте сеть так, чтобы системы, совместно используемые одной группой пользователей, находились в той же подсети.
    • Отключите привязку часто используемых сетевых плат. Дополнительные сведения см. в разделе Чтобы изменить порядок привязки протоколов.
    • Если используется более одного протокола, можно задать порядок привязки каждого протокола для рабочей станции и протокола NetBIOS. Дополнительные сведения содержатся в справочном файле «Сеть и удаленный доступ к сети». Ниже приведены некоторые причины изменения порядка привязки.
      • Если наиболее часто используемый протокол в списке привязки идет первым, среднее время подключения уменьшается.
      • Кроме того, в зависимости от топологии сети некоторые протоколы работают быстрее, чем другие. При оптимизации работы компьютера-клиента расположение более быстрого протокола первым позволяет увеличить производительность. Поскольку сервер позволяет устанавливать входящие подключения с использованием протокола, выбранного компьютером-клиентом, менять порядок привязки протоколов на сервере не следует.
    • Установите на сервере высокопроизводительную сетевую плату. Если на данном сервере используется 16-разрядная сетевая плата, можно значительно повысить производительность, заменив ее 32-разрядной.
    • Установите несколько сетевых плат. Windows XP поддерживает работу нескольких плат с данным протоколом и несколько протоколов на данной плате. Хотя такая конфигурация предназначена для создания отдельных сетей, недоступных друг для друга, ею можно воспользоваться для увеличения пропускной способности при совместном использовании файлов.

Повышение производительности системы проводится по результатам следующих наблюдений:

  • Наблюдение и настройка использования памяти
  • Наблюдение за загруженностью процессора
  • Наблюдение за активностью диска
  • Наблюдение за активностью сети
  • Наблюдение за службами Windows XP
  • Наблюдение за устаревшими программами


Наблюдение и настройка использования памяти

Наблюдение и настройка использования памяти включают следующие действия:

  • Наблюдение за использованием системных ресурсов программами
  • Обеспечение достаточного количества памяти


Наблюдение за использованием системных ресурсов программами

Рисунок Microsoft Windows

Использование системных ресурсов приложениями

Поскольку производительность компьютера главным образом определяется ресурсами процессора и памяти, следует понимать, как программы используют эти ресурсы. В этом разделе описано, как просмотр значений определенных счетчиков на диаграмме системного монитора может помочь в определении объема ресурсов процессора и памяти, используемых программами. Начните с наблюдения за счетчиками «Процесс\ % загруженности процессора» и «Процесс\Рабочее множество».

  • % загруженности процессора. Время (в процентах), в течение которого процессор занят выполнением всех потоков определенного процесса. (Следует иметь в виду, что величина «% загруженности процессора» принимает большие значения для процесса «Бездействие системы», когда система не занята.)
  • Рабочее множество. Текущее количество байт физической памяти, используемое процессом или выделенное ему. Эта величина может быть больше, чем минимальный объем памяти, действительно необходимый приложению. Она может отражать физический объем памяти, распределенный между несколькими процессами.

Используя эти счетчики, можно строить в системном мониторе диаграммы использования процессора, соответствующие некоторым или всем программам, выполняемым на компьютере, как показано на следующем примере (процесс консоли управления MMC).

Диаграмма использования процессора приложениями

Имейте в виду, что при запуске программы значения счетчика «Процесс\% загруженности процессора» неравномерно увеличиваются, уменьшаются, а затем выравниваются. Важно иметь в виду, что загрузка процессора сильно возрастает при запуске программы; для получения более точной диаграммы загрузки процессора можно исключить из данных наблюдения начальные значения, сильно отличающиеся от среднего уровня.

После загрузки на диаграмме будет отображаться активность процессора, по мере того как программа будет выполнять какие-либо действия. Например, когда системный монитор будет получать новый набор значений. Чтобы проследить за этим, измените интервал обновления системного монитора. Имейте в виду, что если системный монитор работает с небольшим интервалом обновления, данные будут читаться чаще, а загрузка процессора будет выше. При большем интервале обновления загрузка процессора ниже.

В ходе наблюдения за значениями счетчиков памяти программ видно, как программы запрашивают системные ресурсы, и как эти ресурсы выделяются. Для каждой программы, запускаемой на компьютере, операционной системой выделяется часть физической памяти. Она называется рабочим множеством. Даже если программа не проявляет активности, операционной системой все равно выделяется память для ее рабочего множества.

Значение рабочего множества представляет интерес, когда счетчик «Память\Доступно байт» опускается ниже определенного порога. Windows XP удовлетворяет требования программ к памяти путем использования свободных (доступных) байтов. Когда объем свободной памяти опускается ниже определенного значения, операционная система начинает пополнять его, отбирая память у рабочих множеств или менее активных программ. В результате можно заметить, что значение рабочего множества одних программ увеличивается, а других — уменьшается. Если памяти недостаточно для удовлетворения требований всех активных программ, используется файл подкачки, что снижает производительность. Сведения о наблюдении за активностью файла подкачки содержатся в разделе Избыточная подкачка страниц.

Диаграмма использования памяти приложениями

В готовые отчеты и диаграммы можно включить дополнительные программы и счетчики. Для анализа активности системы следует использовать эти и другие счетчики.

Инструкции по наблюдению за активностью процессора и использованием памяти содержатся в следующих разделах:

  • Обеспечение достаточного количества памяти
  • Наблюдение за загруженностью процессора


Обеспечение достаточного количества памяти

Использование памяти является, пожалуй, самым важным фактором, влияющим на производительность системы. Одним из признаков недостатка памяти является частое использование системой файла подкачки. Файл подкачки используется для перемещения блоков памяти определенного размера, содержащих программы и данные и называющихся страницами, из оперативной памяти на диск для освобождения памяти для других целей. Хотя использование файла подкачки допускается, так как это позволяет увеличить объем памяти, доступный Windows XP, постоянное его использование является причиной значительного снижения производительности. Снижение использования файла подкачки может значительно ускорить работу системы.

В этом разделе описано, как можно определить, достаточно ли в системе памяти и какую роль она играет в конфигурации системы, а также как приступить к анализу использования файла подкачки. Более подробно подкачка и другие связанные с этим факторы рассмотрены в разделе Избыточная подкачка страниц.

Проверка конфигурации

Прежде чем приступить к подробному наблюдению за использованием памяти на локальном компьютере, проверьте правильность его комплектации и настройки.

  1. Убедитесь, что данная система обладает объемом памяти, рекомендуемым для работы Windows XP и всех служб и программ. Сравните имеющийся объем памяти с требованиями операционной системы и программ. Для этого обратитесь к документации по программам и службам, работающим на данном компьютере.

    Сведения о просмотре объема системной памяти см. в разделе Определение объема оперативной памяти, установленной на компьютере. Чтобы определить требования к памяти, возьмите объем памяти, необходимый для работы операционной системы, и добавьте к нему следующее:

    • число пользователей, умноженное на средний размер файлов данных, открытых пользователем;
    • число программ, запущенных на компьютере-сервере, умноженное на средний размер этих программ.

    Если неизвестно, сколько памяти требуется для работы определенного процесса, можно включить отображение его рабочего множества в системном мониторе, затем завершить его работу и понаблюдать за соответствующим изменением использования подкачки на данном компьютере. Объем памяти, освобожденный по завершении работы программы, является объемом физической памяти, который требуется добавить в систему.

  2. Проверьте, соответствуют ли параметры системы целям использования данного компьютера. При установке Windows XP программа настройки изменяет конфигурацию компьютера для оптимизации совместного использования его ресурсов. Однако в некоторых случаях такая конфигурация может привести к избыточному использованию подкачки, так как она использует системный кэш рабочих множеств большого объема. Если данный компьютер не предназначен для совместного использования файлов или программ, требующих такой конфигурации, можно отключить ее, чтобы уменьшить объем подкачки.

    Сведения об изменении этих параметров см. в разделе Чтобы настроить параметры памяти данного компьютера.

Наблюдение за счетчиками памяти

Наблюдение за ситуациями, порождающими недостаток памяти, рекомендуется начинать со следующих счетчиков:

  • Память\Доступно байт
  • Память\Обмен страниц в сек

Счетчик «Доступно байт» показывает текущий объем памяти в байтах, доступный для использования процессами. Счетчик «Обмен страниц/сек» показывает число страниц, полученных с диска из-за необходимости обращения к этим страницам, или записанных на диск для освобождения свободной памяти в рабочем множестве.

Низкие значения счетчика «Доступно байт» (4 Мбайт и меньше) указывают на общий недостаток памяти на компьютере или на то, что какая-либо программа не освобождает память. Если значение «Обмен страниц/сек» достигает или превышает 20, следует внимательно изучить активность страничного обмена. Большое значение счетчика «Обмен страниц/сек» может не указывать на недостаток памяти, а быть результатом работы программы, использующей файл, отображенный в памяти.

Чтобы определить, является ли причиной именно это, наблюдайте за счетчиками «Доступно байт», «Обмен страниц/сек» и «Файл подкачки \ % использования». Если происходит чтение некэшированного файла, отображенного в памяти, также будет наблюдаться низкая или средняя активность кэша. Дополнительные сведения см. в разделе Избыточная подкачка страниц.

При возникновении недостатка памяти наблюдайте за счетчиками «Память\Доступно байт» и «Память\Байт выделенной виртуальной памяти», чтобы отследить изменения объема памяти, и за счетчиками «Процесс\Байт исключительного пользования», «Процесс\Рабочее множество» и «Процесс\Счетчик дескрипторов» процессов, которые, как предполагается, вызывают нехватку памяти. Также наблюдайте на счетчиками «Память\Байт в невыгружаемом страничном пуле», «Память\Распределений в невыгружаемом страничном пуле» и «Процесс(имя_процесса)\Байт в невыгружаемом страничном пуле», если предполагается, что нехватка памяти вызвана процессом ядра.

Избыточная подкачка страниц

Так как избыточная подкачка влечет сильную загрузку жесткого диска, в результате избыточной подкачки страниц кроме недостатка памяти возможно также возникновение узкого места в дисковой системе. Поэтому если при определении причины избыточной подкачки страниц недостаток памяти не прослеживается явно, наряду со счетчиками памяти понаблюдайте за следующими счетчиками использования диска:

  • Логический диск\% активности диска
  • Физический диск\Средняя длина очереди диска

Например, одновременно наблюдайте за счетчиками «Чтение страниц/сек», «% активности диска» и «Средняя длина очереди диска». Сочетание низкой активности чтения страниц с высокими значениями активности диска и средней длины очереди диска указывает на наличие узкого места в дисковой системе. Однако если увеличение длины очереди не сопровождается уменьшением частоты чтения страниц, это означает нехватку памяти.

Чтобы определить влияние избыточной подкачки на активность диска, перемножьте значения счетчиков «Физический диск\Среднее время обращения к диску (сек)» и «Память\Обмен страниц/сек». Если значения этих счетчиков превышают 0,1, подкачка занимает более 10% времени доступа к диску. Если такая ситуация наблюдается долгое время, вероятно, следует нарастить объем памяти.

Исследование активности программы

Далее проверьте зависимость избыточной подкачки от запущенных программ. Если возможно, остановите работу программы, когда рабочее множество имеет наибольшее значение, и посмотрите, как при этом изменится частота подкачки страниц. При обнаружении избыточной подкачки проверьте значения счетчика «Память\Обмен страниц/сек». Этот счетчик показывает число страниц, которые должны быть прочитаны с диска, так как они отсутствуют в физической памяти. (Этот счетчик отличается от счетчика «Ошибок страницы/сек», указывающего только на то, что доступ к данным не был получен немедленно, так как они не были найдены в заданном рабочем множестве страниц памяти.)

Проверка размера файла подкачки

Существует несколько приемов, позволяющих оптимизировать использование файла подкачки для повышения производительности.

  • Файл подкачки следует по возможности размещать на отдельном жестком диске. При наличии нескольких жестких дисков файл подкачки следует разделить, так как это повышает скорость работы с ним. Если при наличии двух жестких дисков разделить файл подкачки, то поскольку доступ к данным на обоих жестких дисках осуществляется одновременно, это значительно повысит производительность. Однако если имеются два жестких диска, из которых один быстрее другого, возможно, более эффективным решением будет размещение файла подкачки только на более быстром жестком диске. Поэкспериментируйте, чтобы определить наиболее производительную конфигурацию для данной системы.
  • Можно увеличить размер файла подкачки. При запуске Windows XP на диске, где установлена эта операционная система, автоматически создается файл подкачки (Pagefile.sys). Файл подкачки используется в Windows XP для предоставления виртуальной памяти. Рекомендуется установить размер файла подкачки в 1,5 раза больше размера установленной оперативной памяти. В то же время размер этого файла также зависит от объема свободного пространства на жестком диске во время создании этого файла. Определить размер файла подкачки можно, узнав в проводнике размер файла Pagefile.sys.

    Если на жестком диске еще есть свободное место, можно увеличить размер файла подкачки. Если пользователи обычно запускают несколько программ одновременно, при увеличении размера файла подкачки их запуск может ускориться.

    Хотя можно оставить предложенные размеры файла подкачки (исходный и максимальный), рекомендуется увеличить исходный размер, чтобы при запуске программ системе не приходилось увеличивать размер файла подкачки, фрагментируя его.

    Когда размер файла подкачки достигает максимального, появляется сообщение о возможной остановке работы системы. Чтобы выяснить, достигает ли размер файла подкачки максимального значения, сравните реальный размер файла с его максимальным размером, который задается в окне «Свойства системы», открываемом с панели управления. Если эти значения близки, следует увеличить исходный размер файла подкачки или запускать одновременно меньшее количество приложений.

    Другим способом определения оптимального значения файла подкачки является использование счетчиков файла подкачки.

    • Файл подкачки\% использования
    • Файл подкачки\% использования (пик)

    Если значение счетчика «% использования (пик)» достигает максимального размера файла подкачки или значение счетчика «% использования» близко к 100 процентам, попробуйте увеличить исходный размер файла подкачки.

Если файлы подкачки распределены по нескольким дискам, в качестве экземпляров счетчиков объекта «Файл подкачки» будут отображаться полные имена файлов подкачки. Можно либо добавить счетчик для каждого файла подкачки, либо выбрать экземпляр «_Total» для наблюдения за общей активностью всех файлов подкачки.


Наблюдение за загруженностью процессора

Наблюдение за счетчиками объектов «Процессор» и «Память» позволяет получить ценные сведения об использовании процессоров и помогает обнаружить узкие места в системе. Обратите внимание на следующие счетчики.

  • Процессор\% загруженности процессора — для наблюдения за использованием процессора.

    Дополнительно можно наблюдать за счетчиками объекта «Процессор» «% работы в пользовательском режиме», «% работы в привилегированном режиме» и «% загруженности процессора».

  • Система\Длина очереди процессора — для поиска узких мест.

Наблюдение за значениями использования процессора

Для анализа активности процессора проведите наблюдение за счетчиком «Процессор\% времени процессора». Этот счетчик показывает процент времени, затрачиваемого процессором на выполнение всех активных потоков.

При анализе использования процессора учитывайте роль данного компьютера и тип выполняемой работы. В зависимости от работы, выполняемой компьютером, высокие значения загрузки процессора могут означать либо эффективное выполнение системой большого объема работ, либо попытки сохранения рабочего состояния. Например, при наблюдении за рабочей станцией, используемой для вычислений, программа может занимать до 100% времени процессора. Даже если это снижает производительность других приложений, работающих на этом компьютере, следует уменьшить объем выполняемой работы.

С другой стороны, значения, близкие к 100%, на серверном компьютере, обрабатывающем множество клиентских запросов, означает, что запросы выстраиваются в очередь, а затем обрабатываются, и это является узким местом. Для сервера неприемлем такой постоянный высокий уровень загрузки.

Случаи, когда процессор является узким местом

Процессор становится узким местом системы, когда потоки процессов требуют больше циклов процессора, чем доступно. Длинные очереди процессора могут блокировать систему. Два наиболее распространенных случая, когда процессор является узким местом, включают программы, сильно загружающие процессор, и драйверы или компоненты подсистемы (обычно дисковые или сетевые компоненты), генерирующие избыточное количество прерываний.

Чтобы определить, не является ли процессор узким местом из-за большого количества запросов процессорного времени, проверьте значение счетчика «Система\Длина очереди процессора». Очередь из двух и более элементов уже означает наличие узкого места. Если большинство времени процессора используется более чем несколькими программами, установка более быстрого процессора поможет разрешить этот вопрос. Дополнительный процессор может помочь, если выполняются многопотоковые процессы, но имейте в виду, что преимущества масштабирования системы с использованием нескольких процессоров невелики. Дополнительные сведения содержатся в разделе Наблюдение за многопроцессорными системами.

Кроме того, счетчик «Рабочие очереди сервера\Длина очереди», отслеживающий текущую длину рабочей очереди сервера для данного компьютера, помогает понять, является ли процессор узким местом. Постоянное значение длины, превышающее 4, может означать перегрузку процессора. Значение этого счетчика является текущим, а не средним за определенный период времени.

Чтобы определить, не является ли причиной возникновения узкого места активность прерываний, понаблюдайте за значениями счетчика «Процессор\Прерываний/сек», показывающего частоту служебных запросов от устройств ввода/вывода. Сильное увеличение значения этого счетчика без соответствующего увеличения активности системы может означать неполадку в оборудовании.

В качестве косвенного индикатора активности драйверов дисков, сетевых плат и других устройств, генерирующих прерывания, также можно использовать счетчик «Процессор\% времени прерываний».

Примечание

  • Для обнаружения неполадок оборудования, могущих снизить производительность процессора, таких как конфликты прерываний (IRQ), понаблюдайте за значениями счетчика «Система\Байт управления файлами/сек».

Наблюдение за многопроцессорными системами

Чтобы определить эффективность многопроцессорного компьютера, воспользуйтесь следующими дополнительными счетчиками.

Счетчик | Описание
Процессор\% загруженности процессора | Суммарное время каждого процессора для всех потоков процесса.
Процессор(_Total)\% загруженности процессора | Измерьте активность всех процессоров компьютера. Этот счетчик суммирует среднее время активности всех процессоров за интервал обновления и делит их на число процессоров. Например, если все процессоры в течение интервала обновления заняты наполовину, будет выдано значение 50%. Значение 50% также будет выдано, если половина процессоров в течение интервала обновления была занята полностью, а другая половина простаивала.
Поток\% загруженности процессора | Время процессора, выделяемое потоку.

Управление активностью процессора в многопроцессорных системах

Если для повышения производительности определенной программы или процесса за счет других процессов требуется назначить ему отдельный процессор, выберите в диспетчере задач команду Задать соответствие. Данный параметр доступен только в многопроцессорных системах.

Изменение соответствия процессоров может повысить производительность путем уменьшения числа сбросов кэша процессора при перемещении потока от одного процессора к другому. Это может значительно повысить производительность выделенных файловых серверов. Однако имейте в виду, что сопоставление программе определенного процессора может не позволить потокам других программ переходить на менее занятый процессор.

Также может потребоваться управления соответствием процессоров для прерываний, генерируемых дисковыми контроллерами или сетевыми платами. На компакт-диске Microsoft Windows Resource Kits (http://www.microsoft.com/) имеется средство, позволяющее управлять прерываниями таким способом.


Наблюдение за активностью диска

Статистика использования диска помогает регулировать загрузку сетевых серверов. Для устранения неполадок, планирования распределения ресурсов и измерения активности физического тома в системном мониторе имеются счетчики физических дисков.

Следует наблюдать как минимум за следующими счетчиками:

  • Физический диск\Обращений чтения с диска/сек и Обращений записи на диск/сек
  • Физический диск\Текущая длина очереди диска
  • Физический диск\% активности диска
  • Логический диск\% свободного места

При проверке производительности диска журнал следует вести на другом диске или компьютере, чтобы этот процесс не мешал проверке диска.

Дополнительные счетчики, которые могут представлять интерес: «Физический диск\Среднее время обращения к диску (сек)», «Средний размер одного обмена с диском (байт)» и «Скорость обмена с диском (байт/сек)».

Счетчик «Среднее время обращения к диску (сек)» отражает время, затрачиваемое на выполнение запросов к диску. Большое значение говорит о том, что контроллер диска постоянно повторяет попытки обращения к диску из-за его неисправности. Эти повторные попытки увеличивают среднее время обращения к диску. Для большинства дисков наибольшее среднее время обращения составляет не более 0,3 секунды.

Также следует проверить показания счетчика «Средний размер одного обмена с диском (байт)». Значение больше 20 Кбайт обычно говорит о хорошей производительности диска, меньшие значения будут в случае, если приложение использует диск неэффективно. Например, приложения, обращающиеся к данным на диске в произвольном порядке, увеличивают значения счетчика «Среднее время обращения к диску (сек)», так как передача данных случайным образом увеличивает время поиска данных на диске.

Счетчик «Скорость обмена с диском (байт/сек)» показывает пропускную способность дисковой системы.

Так как счетчики дисков могут вызывать небольшое увеличение времени доступа к диску, Windows XP не включает их автоматически при загрузке.

Распределение нагрузки

Для регулировки нагрузки на сетевые серверы необходимо знать, какова нагрузка на их жесткие диски. Для этого служит счетчик «Физический диск\% активности диска», показывающий время активности диска в процентах. Если значение счетчика «% активности диска» высоко (более 90%), следует проверить значение счетчика «Физический диск\Текущая длина очереди диска» для определения числа системных запросов, ожидающих доступа к диску. Количество ожидающих запросов ввода/вывода в установившемся режиме не должно превышать более чем в 1,5—2 раза количество физических дисков в дисковом устройстве.

Большинство дисковых устройств содержат один шпиндель, а дисковые массивы RAID — обычно более одного шпинделя. Аппаратные массивы RAID представляются в системном мониторе в виде единого диска, а программно организованные дисковые массивы — в виде нескольких томов (экземпляров). Наблюдение за счетчиками физического диска может вестись как для каждого физического диска, так и для всех дисков компьютера (используя экземпляр «_Total»).

Значения счетчиков «Текущая длина очереди диска» и «% активности диска» позволяют отыскать узкие места в дисковой подсистеме. Если значения счетчиков «Текущая длина очереди диска» и «% активности диска» высоки в течение длительного времени, следует рассмотреть возможность обновления дисков или перемещения некоторых файлов на другие диски.

Примечания

  • Счетчики объекта «Логический диск» удалены. Сопоставление логических дисков физическим выполняется в системе путем использования одного имени экземпляра. Таким образом, при наличии динамического тома, содержащего несколько физических дисков, экземпляры будут выглядеть как «Диск 0 C:», «Диск 1 C:» и «Диск 2 D:», где диск C: состоит из физических дисков 0 и 1. Если на диске имеется два логических раздела, экземпляр отображается как «0 C: D:».
  • Статистика отдельных дисков недоступна для аппаратно чередующихся наборов. Эти данные можно получить, только если наблюдение за чередующимися наборами включено в программном обеспечении.
  • При использовании дискового массива RAID значение счетчика «% активности диска» может превосходить 100 процентов. В таком случае для определения среднего числа системных запросов, ожидающих доступа к диску, следует воспользоваться счетчиком «Средняя длина очереди диска».


Наблюдение за активностью сети

Наблюдение за сетью обычно включает анализ использования ресурсов сервера и измерение общего сетевого трафика. Системный монитор позволяет наблюдать за обоими этими параметрами, хотя для подробного анализа трафика следует воспользоваться сетевым монитором.

Начните анализ использования ресурсов сервера с наблюдения за счетчиками, описанными в разделе Настройка конфигурации наблюдения. Для рассмотрения использования ресурсов, относящихся к сети, добавьте счетчики, относящиеся к различным уровням конфигурации сети. Значения сетевого счетчика, отличающиеся от обычных, указывают на наличие неполадок в памяти, процессорах или дисках сервера. Поэтому наилучший подход к анализу работы сервера состоит в наблюдении за показаниями сетевых счетчиков и счетчиков «Процессор\% загруженности процессора», «Физический диск\% активности диска» и «Память\Обмен страниц в сек».

Например, если резкое увеличение значения счетчика «Обмен страниц в сек» сопровождается уменьшением значения счетчика «Всего байт/сек» сервера, компьютер, видимо, испытывает недостаток физической памяти для сетевых операций. Большинство сетевых ресурсов, включая сетевые адаптеры и программное обеспечение протоколов, используют невыгружаемую память. Избыточная подкачка может происходить из-за того, что большая часть физической памяти была выделена для поддержки сетевых операций, а для приложений, использующих выгружаемую память, осталось слишком мало памяти. Для проверки этой ситуации следует просмотреть журнал системных событий на предмет сообщений о недостатке памяти, допускающей выгрузку или не допускающей ее.

Примечание

  • Операционная система автоматически устанавливает предел выделения пула невыгружаемой памяти. По умолчанию это около 80% установленной памяти. Если в результате сетевой активности будет достигнут этот предел, могут возникнуть неполадки. Этот предел можно изменить, задав требуемое значение в реестре:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\MaxNonpagedMemoryUsage

    Сведения об изменении значений реестра содержатся в справке по редактору реестра.

    Внимание!

    • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных.

Если запущен сетевой монитор, для анализа общей производительности сети в системном мониторе можно использовать сетевые объекты. Сведения о наблюдении за общим сетевым трафиком содержатся в разделе Наблюдение за общим сетевым трафиком.

Наблюдение за пропускной способностью между уровнями сети

Исследование производительности сети включает наблюдение за активностью различных уровней сети.

  • Уровень каналов передачи данных. Включает сетевую плату. Счетчики объекта «Сетевой интерфейс»:
    • Всего байт/сек
    • Отправлено байт/сек
    • Получено байт/сек

    • Примечание

    • Если используются сетевые адаптеры с определением носителей, при отключении адаптера от сетевого носителя на панели задач Windows XP отображается значок. Поскольку драйвер, поддерживающий носитель, продолжает работать, даже если трафик не обрабатывается, драйвер продолжает использовать системные ресурсы, что приводит к снижению производительности. Поэтому следует обращать внимание на отключенные адаптеры после определения их системой. После вывода значка проверьте подключение адаптера. При необходимости переподключите адаптер либо отключите или удалите его, чтобы избежать утечки ресурсов, связанных с этим условием.
  • Сетевой уровень. Счетчики объекта «IP»:
    • Переслано датаграмм/сек
    • Полученных датаграмм/сек
    • Датаграмм/сек
    • Отправлено датаграмм/сек
  • Транспортный уровень. В зависимости от используемых сетевых протоколов. Счетчики объекта «TCP» для протокола TCP/IP:
    • Получено сегментов/сек
    • Переотправлено сегментов/сек
    • Сегментов/сек
    • Отправлено сегментов/сек

    Если частота повторных отправлений высока, возможно наличие неполадок оборудования.

    Также имеются счетчики объектов ICMP и UDP, полезные для более подробного наблюдения за передачей данных по протоколу TCP/IP. Объект производительности ICMP состоит из счетчиков, измеряющих частоты отправки и получения сообщений по протоколу ICMP (Internet Control Message Protocol). Кроме того, имеются счетчики, отслеживающие ошибки протокола ICMP.Объект производительности UDP состоит из счетчиков, измеряющих скорость отправки и получения датаграмм UDP с использованием протокола UDP. Он также включает счетчики наблюдения за ошибками протокола UDP.

    При использовании протокола NWLink имеется три объекта: NWLink IPX и NWLink NetBIOS для компьютеров, устанавливающих подключение по протоколу IPX, и NWLink SPX для компьютеров, устанавливающих подключение по протоколу SPX. Имейте в виду, что счетчики кадров этих объектов всегда возвращают нулевые значения.

  • Уровень представления/приложения. Для наблюдении за сервером служат счетчики объекта «Сервер», а для наблюдения за компьютером-клиентом пользователя — счетчики объекта «Перенаправитель». (Некоторые процессы уровня приложения, такие как веб-серверы, могут обладать собственными счетчиками, служащими для наблюдения за передачей данных на этом уровне.)

    Счетчики объекта «Перенаправитель» собирают данные о запросах, переданных службой «Рабочая станция»; счетчики объекта «Сервер» собирают данные о запросах, полученных и обработанных службой «Сервер».

    Следует наблюдать как минимум за счетчиками «Всего байт/сек» обоих объектов — «Перенаправитель» (для клиентских компьютеров) и «Сервер» (для серверных компьютеров).

    Каждый из этих объектов предоставляет некоторые другие счетчики, помогающие выявить возможные неполадки в службах «Рабочая станция» и «Сервер».

    • Перенаправитель\Активных команд
    • Перенаправитель\Сетевых ошибок/сек
    • Перенаправитель\Отказов на операцию чтения/сек
    • Перенаправитель\Отказов на операцию записи/сек
    • Перенаправитель\Зависаний сеансов сервера
    • Сервер\Сеансов, закрытых из-за возникновения ошибки
    • Сервер\Нехваток рабочих элементов
    • Сервер\Выгружаемый пул (пик)
    • Сервер\Отказов невыгружаемого страничного пула

    Если значение счетчика «Нехваток рабочих элементов» увеличивается, попробуйте изменить значения параметров реестра InitWorkItems и MaxWorkItems в разделе HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer.

    Счетчик «Сеансов, закрытых из-за возникновения ошибки» подсчитывает число автоматических отключений и сеансов, закрытых из-за возникновения ошибки. Чтобы получить более точное число сеансов, закрытых из-за возникновения ошибки, отнимите от значения счетчика «Сеансов, закрытых из-за возникновения ошибки» значение счетчика «Сеансов, закрытых по таймауту». Дополнительные сведения содержатся в разделе Ресурсы.

Наблюдение за общим сетевым трафиком

Если суммарный сетевой трафик превышает пропускную способность локальной сети, обычно снижается производительность всей сети. Для предотвращения этой ситуации важно наблюдать за объемом трафика по всей сети, особенно в больших сетях с мостами и маршрутизаторами. Чтобы наблюдать за сетевым трафиком, необходимо установить сетевой монитор.

Сведения о сетевом мониторе содержатся в справке по сетевому монитору.


Наблюдение за службами Windows XP

Многие службы (см. далее), доступные в Windows XP, предоставляют собственные объекты и счетчики производительности.

  • Наблюдение за службой «Обозреватель сети»
  • Наблюдение за активностью службы каталогов
  • Наблюдение за службой DHCP
  • Наблюдение за службой «Координатор распределенных транзакций»
  • Наблюдение за службой управления допуском QoS
  • Наблюдение за службой DNS
  • Наблюдение за службой факсов
  • Наблюдение за службой репликации файлов
  • Наблюдение за службой индексирования
  • Наблюдение за службой проверки подлинности в Интернете
  • Наблюдение за информационными службами Интернета
  • Наблюдение за службой «Телефонная книга»
  • Наблюдение за службой SMTP
  • Наблюдение за счетчиками телефонии
  • Наблюдение за службой WINS
  • Наблюдение за состоянием батарей


Наблюдение за службой «Обозреватель сети»

Если в организации имеются домены под управлением Windows NT Server 4.0, для наблюдения за службой «Обозреватель сети» воспользуйтесь следующими счетчиками:

  • Обозреватель сети\Ошибок распределения почтовых слотов
  • Обозреватель сети\Ошибок открытия почтового слота/сек
  • Обозреватель сети\Ошибок приема в почтовый слот
  • Обозреватель сети\Ошибок записи в почтовый слот
  • Обозреватель сети\Промахов датаграмм почтовых слотов
  • Обозреватель сети\Промахов объявлений серверов
  • Обозреватель сети\Промахов запросов на список серверов
  • Обозреватель сети\Ошибок распределения объявлений сервера/сек


Наблюдение за активностью службы каталогов

Объект NTDS предоставляет статистику активности службы каталогов. Этот объект включает несколько важных счетчиков:

  • Оставшихся в пакете входящих обновлений объектов DRA
  • Ожидающих синхронизаций репликации DRA
  • Сеансов LDAP-клиентов
  • Время привязки LDAP


Наблюдение за службой DHCP

Объект производительности службы DHCP предоставляет счетчики для наблюдения за ее активностью. Дополнительные сведения об использовании этих счетчиков содержатся в разделе Основные понятия DHCP.


Наблюдение за службой «Координатор распределенных транзакций»

Объект производительности «Координатор распределенных транзакций» предоставляет статистику активности службы «Координатор распределенных транзакций», входящей в службы компонентов, координирующих внешние (или двухфазные) транзакции. Дополнительные сведения см. в разделе Службы компонентов.


Наблюдение за службой контроля допуска QoS

Служба контроля допуска QoS предоставляет объект производительности «Служба RSVP». Администраторы сетей могут использовать счетчики этого объекта для наблюдения за резервированием ресурсов, проводимым службой RSVP (Resource Reservation Protocol — протокол резервирования ресурсов) в подсети.


Наблюдение за службой DNS

Объект производительности Domain Name System предоставляет статистику активности службы DNS. Дополнительные сведения см. в разделе Использование системного монитора.


Наблюдение за службой факсов

Объект «Служба факсов» позволяет наблюдать за активностью службы факсов, если она запущена. Для анализа производительности службы рекомендуется использовать эти счетчики в сочетании с данными журнала событий, относящимися к факсимильным сообщениям.

Следующие счетчики позволяют выявить неполадку в системе, такую как установку неправильного драйвера модема, препятствующую отправке или приему факсов.

  • Не получено факсов. Этот счетчик показывает число непринятых факсов. Это может быть вызовом, ответ на который состоялся, но в ходе которого не был принят факс.
  • Разорвано исходящих подключений. Этот счетчик показывает число неотправленных факсов, например, из-за отсутствия сигнала в линии, отсутствия ответа, занятости линии или другой ошибки.
  • Не отправлено факсов. Этот счетчик показывает число факсов, которые не удалось отправить.

Если эти счетчики имеют ненулевые значения, найдите в журнале событий более подробные сведения (сообщения об отсутствии сигнала в линии, об отсутствии ответа или занятости линии). Неизвестная ошибка может указывать на неполадку в системе. В этом случае проверьте, нет ли шума в телефонной линии и проверьте, правильный ли драйвер модема установлен на устройствах приема и отправки факсов.


Наблюдение за службой репликации файлов

Служба репликации файлов предоставляет два объекта (FileReplicaConn и FileReplicaSet), позволяющих наблюдать за ее активностью.

Объект FileReplicaConn предоставляет статистику производительности объекта REPLICACONN, определяющего подключения к корневым папкам DFS (Distributed File System — распределенная файловая система).

Объект FileReplicaSet предоставляет статистику производительности объекта REPLICASET, определяющего набор реплик (одну или несколько реплик, общие тома или каталоги, в которых хранятся дубликаты содержимого исходного общего ресурса). Этот объект предоставляет статистику для компьютера, на котором размещен исходный общий ресурс.

Например, в топологии двунаправленного кольца, содержащего три компьютера А, Б и В, где компьютер А и компьютер В реплицируют данные с компьютера Б, счетчики FileReplicaSet будут возвращать значения для компьютера Б.


Наблюдение за службой индексирования

Служба индексирования предоставляет три различных объекта производительности:

  • Служба индексирования HTTP. Счетчики этого объекта предоставляют статистику запросов, обрабатываемых службой индексирования.
  • Служба индексирования. Счетчики этого объекта предоставляют статистику создания и слияния индексов службой индексирования.
  • Фильтр службы индексирования. Счетчики этого объекта характеризуют активность фильтра службы индексирования.

Счетчик «Служба индексирования HTTP\Общее число отклоненных запросов» служит для выявления узких мест в работе службы индексирования на сервере.


Наблюдение за службой проверки подлинности в Интернете

Следующие объекты предоставляют данные об активности службы проверки подлинности в Интернете (IAS):

  • IAS-клиенты учетных записей
  • IAS-сервер учетных записей
  • IAS-клиенты проверки подлинности
  • IAS-сервер проверки подлинности
  • Удаленный сервер учета IAS
  • Удаленный сервер проверки подлинности IAS
  • Прокси-сервер учета IAS
  • Прокси-сервер проверки подлинности IAS


Наблюдение за информационными службами Интернета

За активностью информационных служб Интернета позволяют наблюдать следующие счетчики:

  • Служба FTP
  • Общий объект служб IIS
  • Веб-служба и кэш веб-служб
  • Страницы Active Server

Служба FTP

Счетчики объекта «Служба FTP» характеризуют активность анонимных и неанонимных подключений к серверному приложению FTP. Эти счетчики могут предоставлять статистику по отдельным узлам.

Общий объект служб IIS

Общий объект служб IIS содержит счетчики, характеризующие ограничение пропускной способности и использование кэша объектов IIS (кэша, совместно используемого службами IIS).

Ограничение пропускной способности (bandwidth throttling) значением, установленным администратором, — возможность, предоставляемая службами IIS. Если пропускная способность служб IIS достигает или превышает заданный предел, запросы к службам IIS откладываются или отвергаются, пока не освободится часть полосы пропускания.

В кэше объектов IIS хранятся часто используемые объекты, а также объекты, частое обращение к которым без использования кэша может существенно снизить производительность. Счетчики предоставляют сведения о размере и содержимом кэша объектов IIS, а также об эффективности его использования (числе попаданий и промахов).

Веб-служба и кэш веб-служб

Счетчики объекта Веб-служба предоставляют сведения о подключениях анонимных и неанонимных пользователей к приложению службы HTTP и сгруппированных по типу запросах HTTP, обработанных с момента запуска веб-службы.

Страницы Active Server

Объект «Страницы Active Server» позволяет наблюдать за приложениями, работающими на веб-сервере, использующем протокол ASP (Active Server Pages — активные серверные страницы). Для наблюдения за запросами к приложениям CGI или расширениям ISAPI следует использовать счетчики объекта Веб-служба.


Наблюдение за службой «Телефонная книга»

Объект производительности «Монитор PBServer» позволяет наблюдать за активностью сервера телефонных книг. Трафик, проходящий через сервер телефонных книг, характеризуется значениями счетчика «Всего попаданий/cек».


Наблюдение за службой SMTP

Объект производительности «SMTP-сервер» позволяет наблюдать за активностью сообщений, производимых службой SMTP (Simple Mail Transport Protocol).


Наблюдение за счетчиками телефонии

Счетчики телефонии могут оказаться полезными, если компьютер служит в качестве сервера телефонии, например сервера удаленного доступа, или используется драйвер для эмуляции на сервере местной АТС или коммутатора.

Ведите наблюдение за следующими счетчиками и обратите внимание на активность сервера, если их значения меньше ожидаемых:

  • Телефония\Входящих звонков/сек
  • Телефония\Исходящих звонков/сек
  • Телефония\Всего звонков


Наблюдение за службой WINS

Служба WINS (Windows Internet Name Service — служба Windows имен Интернета) предоставляет объект производительности «WINS-сервер» для наблюдения за активностью этой службы. Счетчики объекта «WINS-сервер» очищаются каждый раз при перезапуске этой службы.

Дополнительные сведения о счетчиках производительности WINS содержатся в справочнике по наблюдению за производительностью службы WINS.


Наблюдение за состоянием батареи

Объект производительности «Состояние батареи» предоставляет счетчики для наблюдения за состоянием батарей портативных компьютеров. В этом объекте имеются следующие счетчики:

  • ChargeRate. Скорость зарядки в милливаттах (мВт). Если батарея не заряжается, значение этого счетчика равно нулю.
  • DischargeRate. Скорость разрядки в милливаттах (мВт). Если батарея не разряжается, значение этого счетчика равно нулю.
  • RemainingCapacity. Заряд батареи в милливаттах (мВт).
  • Tag. Число замен батареи.
  • Voltage. Напряжение батареи в милливольтах (мВ).


Наблюдение за устаревшими программами

В данном разделе приведены инструкции по наблюдению за 16-разрядными программами для Windows и программами для MS-DOS.

В Windows XP 16-разрядные программы для Windows работают как отдельные потоки в многопотоковом процессе NTVDM (Windows Virtual DOS Machine). Процесс NTVDM модулирует 16-разрядную среду Windows. Программа для MS-DOS выполняется в собственном процессе NTVDM.

Наблюдение за 16-разрядными программами или программами MS-DOS, работающими на локальном компьютере, в системном мониторе возможно с помощью экземпляра ntvdm объекта производительности «Процесс». При этом следует иметь в виду, что 16-разрядные программы, выполняемые в процессе NTVDM, доступны для наблюдения, только если запущены в отдельной области памяти.

Если будет замечено, что 16-разрядные программы в Windows XP работают плохо, можно изменить свойства таких программ, щелкнув соответствующую программу правой кнопкой мыши в проводнике и выбрав команду «Свойства».

  • Если программа работает в окне и вывод на экран осуществляется медленно, выберите на вкладке Экран вариант Полноэкранный.
  • Если программа работает в окне с периодическими остановками, на вкладке Разное переместите ползунок Приоритет при ожидании в положение низкий.

Если внесение описанных выше изменений не привело к повышению производительности программы, попробуйте отключить эмуляцию совместимого аппаратного таймера. Для этого щелкните правой кнопкой мыши файл _Default.pif или данную программу, выберите команду «Свойства» и на вкладке Программа нажмите кнопку Дополнительно. В открывшемся диалоговом окне снимите флажок Эмуляция совместимого аппаратного таймера. Это изменение обычно приводит к снижению производительности и должно выполняться, только если другие попытки не увенчались успехом.


Выявление тенденций и планирование наращивания ресурсов

Данные, собираемые в ходе ежедневного наблюдения, можно использовать для анализа тенденций в изменении производительности и планирования наращивания ресурсов. Даже если работа компьютера на сегодня является удовлетворительной, важно заранее планировать необходимые ресурсы на случай приема новых сотрудников или внедрения новых программ и технологий. Неконтроллируемое разрастание может привести к перегрузке сети и ее неудовлетворительной работе. Периодически анализируя производительность системы, можно предвидеть потребность в дополнительных ресурсах до наступления критической ситуации.

Используя данные, собранные счетчиками, описанными в разделе Настройка конфигурации подсистемы наблюдения, проведите наблюдение, как значения каждого компонента изменяются во времени. Эти изменения могут означать необходимость наращивания или модернизации компонентов, как описано в разделе Советы по настройке и модернизации компонентов.


Администрирование подсистемы наблюдения за производительностью

В этом разделе

  • Управление подсистемой наблюдения за производительностью из командной строки


Управление подсистемой наблюдения за производительностью из командной строки

В дополнение к оснастке «Производительность» имеются программы, которые можно запускать из командной строки.

  • Logman. Управляет счетчиками производительности и журналами трассировки событий на локальном или удаленных компьютерах.
  • Perfmon. Открывает консоль «Производительность» Windows XP с параметрами системного монитора из файлов настройки для Windows NT 4.0.
  • Relog. Сохранение данных счетчиков производительности из файлов журналов в файлы других форматов, такие как Текстовый файл (разделитель - запятая), Текстовый файл (разделитель - табуляция), Двоичный файл и База данных SQL.
  • Tracerpt. Обрабатывает журналы трассировки событий и данные, поступающие в реальном масштабе времени от поставщиков трассировочных данных. Эту программу можно также использовать для создания отчетов с анализом данных трассировки и файлов CSV (текстовый файл с разделителями-запятыми) для событий, имевших место в системе.
  • Typeperf. Выводит данные счетчиков производительности в окно командной строки или в файл журнала поддерживаемого формата.
  • Lodctr. Регистрирует имена новых счетчиков производительности и текст объяснения для службы или драйвера устройства. Кроме того, сохраняет и восстанавливает параметры счетчика и текст, объясняющий его назначение.
  • Unlodctr. Удаляет имена счетчиков производительности и текст объяснения для службы или драйвера устройства из системного реестра.

Дополнительные сведения о включении команд с вызовом этих программ в сценарии инструментария управления Windows см. ссылку Scripting Logs and Monitoring на веб-узле Microsoft Windows Resource Kits.(http://www.microsoft.com/)

Сведения о других программах, запускаемых из командной строки, см. в разделе Справочник по параметрам командной строки. Дополнительные сведения о возможностях управления см. в разделе Управление и администрирование.


Ресурсы

  • С более подробной информацией о характеристиках производительности и их анализом можно ознакомиться на веб-узле Microsoft Windows Resource Kits (http://www.microsoft.com/).
  • Сведения об оптимизации программ и создании счетчиков производительности для программ см. на веб-узле корпорации Майкрософт (http://msdn.microsoft.com/).
  • Сведения о включении функциональных возможностей наблюдения за производительностью в приложения Microsoft Office и Visual Basic см. в разделе Разработка программ наблюдения за производительностью.


Разработка программ наблюдения за производительностью

Вдобавок к большому числу настраиваемых параметров системный монитор предоставляет средства программного расширения возможностей наблюдения. Системный монитор доступен в виде элемента ActiveX (файл Sysmon.ocx в папке системный_корневой_каталог\System32), поддерживающего интерфейс Visual Basic Automation, который можно использовать в своих программах, дополняя их возможностями наблюдения. В простейшем случае элемент системного монитора можно встроить в приложение Microsoft Office, например в Microsoft Word. Таким образом диаграммы системного монитора можно включать в отчеты и печатать. Соответствующие инструкции см. в разделе Чтобы вставить элемент «Системный монитор» в документ Microsoft Word.

Если этот элемент размещен в приложении, можно обращаться к его свойствам, событиям и методам, запуская редактор Visual Basic из программы-контейнера или непосредственно из среды Visual Basic.

С помощью интерфейса автоматизации системного монитора можно создавать собственные программные средства для наблюдения за производительностью. Дополнительные сведения см. в пакете Microsoft Platform Software Development Kit (SDK).


Устранение неполадок

Установите вид неполадки.

Значения счетчика всегда равны нулю.

Причина. Процесс, за которым ведется наблюдение, остановлен, поэтому данные для обработки системным монитором отсутствуют.

Решение. Если процесс остановлен вручную, перезапустите его, чтобы он отображался в системном мониторе. В противном случае поищите в программе просмотра событий записи, занесенные в одно время. Возможно, это укажет на ошибку, связанную с этим процессом.

Причина. Библиотека DLL счетчика отключена после выбора соответствующих счетчиков для ведения журнала или отображения. Средства измерения производительности не сообщают о том, что счетчик удален или отключен, а возвращает нулевые значения.

Решение. Включите библиотеку DLL соответствующего счетчика.

Причина. Утеряны разрешения на доступ к компьютеру, за которым ведется наблюдение. Если у пользователя недостаточно прав для наблюдения за компьютером, при попытке выбора счетчика будет выдано сообщение об ошибке. В легенде диаграммы или гистограммы счетчик останется, но данные отображаться не будут.

Решение. Администратору следует проверить, обладает ли учетная запись пользователя разрешениями на доступ к средствам измерения производительности.

Системный монитор отображает поля на диаграммах.

Причина. Это может быть вызвано влиянием на сбор данных процесса с более высоким приоритетом в системе с большой загрузкой. Если в системе достаточно ресурсов для продолжения сбора данных, построение диаграммы продолжится, как и раньше. Появится сообщение с описанием этой ситуации.

Решение. Уменьшите загрузку системы процессом наблюдения за производительностью.

См. также: Советы и рекомендации

Значения, занесенные в журнал, не отображаются на диаграмме.

Причина. Диаграмма ограничена отображением 100 значений.

Решение. Уменьшите выбранный диапазон времени.

См. также: Использование данных журнала

Объекты, счетчики и экземпляры отсутствуют или их не являются допустимыми.

Причина. Проверьте программы, работавшие в то время, как в окне "Производительность" были обнаружены неполадки в установленных счетчиках, а установленные счетчики были отключены для предотвращения замедления работы системы. Отключенные объекты и счетчики не отображаются в диалоговом окне Добавить счетчики.

Решение 1: Включите отключенные счетчики. В редакторе реестра измените значение параметра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\имя_службы\Performance\Disable Performance Counters с 1 (отключен) на 0 (включен). Имейте в виду, что счетчики, отключенные после первоначальной проверки, содержат ошибки и могут вызвать неполадки в системе. Сведения об устранении неполадок в библиотеках DLL счетчиков содержатся на веб-узле корпорации Майкрософт (http://msdn.microsoft.com/).

Решение 2: Отключите функцию автоматической проверки библиотек DLL счетчиков или настройте уровень проверки. В редакторе реестра найдите подраздел Configuration Flags в разделе HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Perflib и измените значение параметра REG_DWORD в этом подразделе:

Значение REG_DWORD | Уровень проверки DLL счетчика производительности
0x00 | Проверка наличия ошибок выравнивания в буфере и сообщение об обнаруженных критических ошибках.
0x01 | Отсутствие проверки наличия ошибок выравнивания в буфере.
0x02 Запрет отключения DLL при обнаружении ошибок.

Примечание

  • При использовании этого параметра Windows все равно записывает сообщения в журнал сообщений.
0x04 | Отключение всей функции проверки счетчиков производительности.
0x08 Включение или отключение объектов производительности при превышении значения таймаута.

Примечание

  • Обычно Windows явно записывает сообщение в журнал событий.
0x10 | Включение сбора статистики производительности и ошибок для каждого объекта производительности. Это устанавливается по умолчанию.

Внимание!

  • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных.

Причина. Процесс, запустивший счетчики объекта, не запущен или не установлен.

Решение. Используя диспетчер задач, проверьте, запущен ли этот процесс. В этом случае воспользуйтесь файлом Exctrlst.exe с компакт-диска Microsoft Windows Resource Kit, чтобы проверить, включена ли библиотека DLL счетчика.

Причина. Счетчики не включены.

Решение. Убедитесь, что служба или средство, предоставляющее данные счетчика, установлено и настроено.

Причина. Библиотека DLL, установившая счетчики, выдает ошибки. Примером может случить счетчик, не поддерживающий функции локализации.

Решение. В окне просмотра событий проверьте наличие ошибок библиотеки DLL счетчика или Performance Data Helper.

Причина. Попытка наблюдения за 16-разрядным приложением или приложением для MS-DOS. В списке экземпляров присутствуют только 32-разрядные процессы. Активные 16-разрядные процессы отображаются как потоки процесса NTVDM (Windows Virtual DOS Machine).

Решение. Ведите наблюдение за приложением посредством процесса NTVDM.

См. также: Наблюдение за устаревшими программами

Причина. Экземпляр, за которым требуется наблюдать, в данный момент неактивен. Если системный монитор настроен на сбор текущих данных, для сбора данных можно выбрать только активные экземпляры. (При просмотре данных журнала можно выбрать любые неактивные экземпляры, данные о которых имеются в журнале.) Если после выбора процесса его выполнение остановилось, он останется в списке, но будет возвращать нулевые значения.

Решение. Убедитесь, что требуемый экземпляр активен.

Иногда при наблюдении за процессами с одинаковыми названиями отображаются высокие значения для одного процесса и низкие для другого.

Причина. Иногда средства измерения производительности выдают неправильные значения для отдельных экземпляров процессов с одинаковыми названиями, возвращая суммарное значение как значение одного экземпляра.

Решение. Пользуясь кодом экземпляра, наблюдайте за счетчиками «Процесс\Идентификатор процесса» и «Процесс\Код (ID) создавшего процесса».

Если при наблюдении на некоторыми потоками один поток останавливается, его данные возвращаются как данные другого потока.

Причина. Это вызвано способом нумерации потоков. Например предположим, что ведется наблюдение за тремя потоками: 0, 1 и 2. Если поток 0 остановится, остальные потоки будут перенумерованы. Исходный поток 0 завершился, а исходный поток 1 переименован в 0. В результате данные остановленного потока 0 будут возвращаться вместе с данными работающего потока 1, так как исходный поток 1 теперь является исходным потоком 0.

Решение. Для наблюдения за этими потоками воспользуйтесь кодом экземпляра и кодом потока.

При попытке экспорта в Microsoft Excel данных журнала, обновляемого службой "Оповещения и журналы производительности", появляется сообщение об ошибке.

Причина. Microsoft Excel требует эксклюзивного доступа к файлу журнала. Другие программы, осуществляющие доступ к этому файлу в монопольном режиме, неизвестны, поэтому в большинстве случаев можно работать с данными из этого файла, в то время как эта служба будет продолжать запись данных в файл.

Решение. Остановите службу "Оповещения и журналы производительности", прежде чем использовать файл журнала в Microsoft Excel.

Потеряно подключение к удаленному компьютеру, с которого велся журнал, и возобновление ведения журнала невозможно.

Причина. Ведение журнала с удаленного компьютера требует использования службы удаленного управления реестром. Если выполнение службы остановлено из-за ошибки, по умолчанию оно будет возобновлено лишь единожды.

Решение. Если выполнение службы удаленного управления реестром остановится более одного раза, во второй раз и далее потребуется перезапустить эту службу вручную. Чтобы сменить этот порядок, установленный по умолчанию, воспользуйтесь программами "Управление компьютером" или "Службы" (в меню Администрирование) для изменения свойств службы удаленного управления реестром.

Справка по системному монитору не отображается при выборе команды Справка; предоставляется только справка по оснастке «Оповещения и журналы производительности».

Причина. Поскольку системный монитор разработан как элемент ActiveX, его работа отличается от работы других программ. Например, справка по системному монитору недоступна, если щелкнуть правой кнопкой мыши раздел «Системный монитор» и выбрать в контекстном меню команду Справка либо выбрать в меню Справка команду Вызов справки.

Решение. Нажмите кнопку Справка на панели инструментов системного монитора.

Ведение журнала счетчиков производительности с удаленного компьютера невозможно.

Причина. Отсутствуют разрешения, необходимые для просмотра счетчиков на удаленном компьютере.

Решение. Обратитесь к администратору удаленного компьютера для предоставления прав на доступ к данному компьютеру для чтения.

Причина. Могут отсутствовать необходимые привилегии, предоставляемые групповой политикой.

Решение. Обратитесь к администратору удаленного компьютера для предоставления доступа к следующим политикам прав пользователей: Конфигурация системы и Конфигурация отдельного процесса. Дополнительные сведения о групповой политике содержатся в разделе Групповая политика.

Причина. Служба «Оповещения и журналы производительности» может не иметь разрешения для входа на удаленный компьютер или создания и обновления файла журнала.

Решение. Воспользуйтесь полем От имени и кнопкой Задать пароль, чтобы указать имя учетной записи для входа с необходимыми разрешениями для службы оповещений и журналов производительности. Эти средства доступны на вкладке Общие.

Причина. На удаленном компьютере не запущена служба «Удаленный реестр».

Решение. Запустите службу «Удаленный реестр» на удаленном компьютере.

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните узел Службы.

    Где?

    • Службы и приложения
    • Службы
  3. В области сведений выберите службу Удаленный реестр
  4. В меню Действие выберите команду Пуск.

Причина. Ограничение размера файла журнала не достаточно для сбора запрошенных данных.

Решение. Увеличьте ограничение на размер файла журнала или установите максимально разрешенное. Дополнительные сведения см. в разделе Задание параметров файла журнала.

Причина. Интервал обновления журнала может быть слишком коротким для ответа сервера на каждый периодический запрос данных.

Решение. Увеличьте интервал обновления журнала. Для получения дополнительных сведений см. раздел Просмотр или изменение свойств журнала или оповещения.

Счетчики не работают после установки нового приложения, и требуется восстановить прежние настройки.

Причина. При установке нового приложения, добавляющего в операционную систему счетчики производительности, Windows создает копию для архивации записей реестра счетчиков производительности перед добавлением файла счетчиков приложения. Архивация осуществляется в файл PerfStringBackup.INI. Если Windows успешно добавляет файла счетчиков производительности приложения, предыдущая версия файла PerfStringBackup.INI заменяется только что созданным.

Решение. Восстановите реестр счетчиков производительности в состояние, описанное в неповрежденном файле архивации, с помощью следующей команды:

LODCTR /R:имя_файла

где имя_файла представляет имя файла архива с записями реестра счетчиков производительности.

Примечание

  • Чтобы сделать копию настройки реестра счетчиков производительности в любое время, воспользуйтесь следующей командой:

    LODCTR /S:имя_файла

    где имя_файла является любым именем. Эти файлы архива могут сохраняться в любом месте на компьютере.


Работа с данными

  • Копирование данных между окнами
  • Печать данных о производительности
  • Сохранение данных диаграммы как страницы HTML
  • Вставка элемента «Системный монитор» в документ Microsoft Word
  • Сохранение данных в файл журнала
  • Сбор данных о производительности с помощью WMI


Выбор счетчиков для наблюдения за конкретными компонентами системы

В следующих разделах находятся справочные сведения по выбору счетчиков для наблюдения за использованием определенного ресурса или активностью определенной службы с целью диагностики элементов, ограничивающих производительность системы.

  • Обнаружение узкого места в работе памяти
  • Обнаружение узкого места в работе диска
  • Обнаружение узкого места в работе процессора
  • Обнаружение узкого места в работе сети
  • Обнаружение узкого места в работе принтера


Работа с параметрами

  • Сохранение настройки консоли наблюдения
  • Создание пользовательской консоли наблюдения
  • Использование файлов параметров системного монитора для Windows NT 4.0


Обнаружение узкого места в работе памяти

Следующие счетчики позволяют обнаружить узкие места в работе памяти:
  • Память\Доступно байт
  • Память\Обмен страниц в сек

В разделе Анализ данных производительности приведены пороговые значения счетчиков, превышение которых недопустимо, а в разделе Повышение производительности системы — методики настройки, позволяющие повысить производительность.


Обнаружение узкого места в работе процессора

Следующие счетчики позволяют обнаружить узкие места в работе процессора:

  • Процессор\Прерываний/сек
  • Процессор\% загруженности процессора
  • Процесс(процесс)\% загруженности процессора
  • Система\Длина очереди процессора

В разделе Анализ данных производительности приведены пороговые значения счетчиков, превышение которых недопустимо, а в разделе Повышение производительности системы — методики настройки, позволяющие повысить производительность.


Обнаружение узкого места в работе диска

Следующие счетчики позволяют обнаружить узкие места в работе диска:

  • Физический диск\% активности диска и Процент времени бездействия
  • Физический диск\Обращений чтения с диска/сек и Обращений записи на диск/сек
  • Физический диск\Средняя длина очереди диска
  • Логический диск\% свободного места

Наблюдайте за счетчиками памяти, чтобы определить, не является ли причиной сильной загрузки диска излишняя подкачка страниц.

В разделе Анализ данных производительности приведены пороговые значения счетчиков, превышение которых недопустимо, а в разделе Повышение производительности системы — методики настройки, позволяющие повысить производительность.


Обнаружение узкого места в работе сети

Следующие счетчики позволяют обнаружить узкие места в работе сети:

  • Сетевой интерфейс\Всего байт/сек, Отправлено байт/сек и Получено байт/сек
  • Объект_уровня_протоколов\Получено сегментов/сек, Отправлено сегментов/сек, Отправлено кадров/сек и Получено кадров/сек

    • Для объектов производительности NWLink счетчики, относящиеся к сетевым пакетам, возвращают только нулевые значения. Для этих объектов следует использовать счетчики на основе датаграмм.

  • Сервер\Всего байт/сек, Отправлено байт/сек и Получено байт/сек

В разделе Анализ данных производительности приведены пороговые значения счетчиков, превышение которых недопустимо, а в разделе Повышение производительности системы — методики настройки, позволяющие повысить производительность.


Обнаружение узкого места в работе принтера

Следующие счетчики позволяют обнаружить узкие места в работе принтера:

  • Очередь печати\Печатаемых байт/сек
  • Очередь печати\Ошибок заданий

Низкие значения счетчика «Печатаемых байт/сек» указывают на недостаточную производительность принтера. При этом следует иметь в виду, что эти значения зависят от типа принтера. Приемлемые характеристики производительности принтера приведены в его документации.

Ошибки заданий печати обычно бывают вызваны неправильной настройкой порта. Проверьте правильность значений параметров порта.


Настройка параметров памяти данного компьютера

Рисунок Microsoft Windows

Чтобы настроить параметры памяти данного компьютера

  1. Откройте компонент Сетевые подключения.
  2. Щелкните правой кнопкой мыши значок Подключение по локальной сети и выберите команду Свойства.
  3. В списке Отмеченные компоненты используются этим подключением дважды щелкните компонент Служба доступа к файлам и принтерам сетей Microsoft.
  4. Обратите внимание, что по умолчанию в группе Критерии оптимизации выбран вариант макс. пропускная способность доступа к общим файлам. Чтобы отключить этот режим и уменьшить объем подкачки, выберите вариант макс. пропускная способность для сетевых приложений.

Примечание

  • XOX


Определение объема оперативной памяти, установленной на компьютере

Рисунок Microsoft Windows

Чтобы определить объем оперативной памяти, установленной на компьютере

  1. Щелкните правой кнопкой значок Мой компьютер и выберите команду Свойства.
  2. На вкладке Общие в разделе Компьютер в конце сведений о компьютере приведен объем памяти (в килобайтах).

Примечание

  • XOX