Общие сведения о программе «Настройка системы»

XOX

Программа настройки системы (Msconfig.exe) автоматизирует стандартные шаги по устранению неполадок, выполняемые специалистами технической поддержки корпорации Майкрософт при выявлении неполадок в настройке Windows. Данная программа позволяет изменять конфигурацию системы путем отключения некоторых компонентов с помощью флажков, что снижает риск опечаток при работе с текстом системных файлов.

С помощью программы восстановления системы можно отменять изменения, вредно влияющие на работу компьютера. Чтобы открыть средство восстановления системы из программы настройки системы, нажмите кнопку Запустить восстановление системы на вкладке Общие. XOX

Внимание!

  • Корпорация Майкрософт настоятельно рекомендует не использовать программу настройки системы для изменения файла Boot.ini без руководства специалиста службы поддержки корпорации Майкрософт. Изменение этого файла может привести к неработоспособности компьютера.

Дальнейшие действия

Создание чистой среды для устранения неполадок

См. также


Создание чистой среды для устранения неполадок

Рисунок Microsoft Windows

Чтобы создать чистую среду для устранения неполадок

XOX

  1. На вкладке Общие выберите Диагностический запуск - загрузка только основных драйверов и основных запуск служб, нажмите кнопку OK, а затем нажмите кнопку Перезагрузка, чтобы перезагрузить компьютер.
  2. После запуска Windows проверьте, остались ли признаки неполадок.

Примечание

  • Перед перезагрузкой компьютера рекомендуется вывести данный раздел справки на печать, поскольку в ходе загрузки доступ к справочной системе будет невозможен.

Дальнейшие действия

Неполадки возникают снова

Неполадки больше не возникают

См. также


Выявление других возможных причин неполадки

XOX

Если неполадки продолжают возникать после выполнения тестового запуска, рассмотрите следующие возможные причины. XOX

  • Отсутствует, поврежден или заменен системный файл. Данная возможность проверяется с помощью программы проверки системных файлов.
  • Поврежден реестр. Данная возможность проверяется с помощью программы проверки реестра.
  • Компьютер поражен вирусом. Для получения сведений об антивирусных программах выполните поиск в Интернете по ключевому слову вирус.
  • Обновление предыдущей версии Windows было выполнено неудачно.

См. также


Обнаружение причин неполадок с помощью выборочного запуска

Чтобы обнаружить причину неполадки с помощью выборочного запуска

XOX

  1. На вкладке Общие выберите параметр Выборочный запуск и снимите все последующие флажки. Снять флажок использовать оригинальный BOOT.INI невозможно.
  2. Устанавливайте флажки по одному, начиная с первого (обрабатывать файл SYSTEM.INI), и перезагружайте компьютер в ответ на приглашение до тех пор, пока не появятся признаки неполадок.
  3. Как только неполадка будет воспроизведена, откройте вкладку, соответствующую последнему выбранному файлу. Например, если неполадка будет воспроизведена после установки флажка обработки файла Win.ini, откройте в окне программы настройки системы вкладку WIN.INI.

Примечания

  • Перед перезагрузкой компьютера рекомендуется вывести данный раздел справки на печать, поскольку в ходе загрузки доступ к справочной системе будет невозможен.
  • Начните процесс устранения неполадок с установки первого флажка в режиме Выборочный запуск, а затем перезагрузите компьютер при появлении соответствующего приглашения.

Дальнейшие действия

Неполадки возникают снова

Неполадки больше не возникают

См. также


Обнаружение причин неполадок с помощью параметров загрузки системы

Чтобы обнаружить причину неполадки с помощью параметров загрузки системы

XOX

  1. На вкладке Общие выберите параметр Выборочный запуск.
  2. Снимите флажки обрабатывать файл SYSTEM.INI, обрабатывать файл WIN.INI и загружать системные службы. Снять флажок использовать оригинальный BOOT.INI невозможно.
  3. Чтобы проверить процесс загрузки программного обеспечения, установите флажок загружать элементы автозагрузки и нажмите кнопку OK.
  4. Перезагрузите компьютер при появлении соответствующего приглашения.

Примечание

  • Перед перезагрузкой компьютера рекомендуется вывести данный раздел справки на печать, поскольку в ходе загрузки доступ к справочной системе будет невозможен.

Дальнейшие действия

Неполадки возникают снова

Неполадки больше не возникают

См. также


Обнаружение причин неполадок с помощью вкладки «Автозагрузка»

Чтобы обнаружить причину неполадки с помощью вкладки «Автозагрузка»

XOX

  1. Откройте вкладку Автозагрузка.
  2. Чтобы начать процесс устранения неполадок, снимите все флажки.
  3. Устанавливайте флажки по одному, начиная с первого, и перезагружайте компьютер в ответ на приглашение до тех пор, пока не появятся признаки неполадок.

Примечания

  • Перед перезагрузкой компьютера рекомендуется вывести данный раздел справки на печать, поскольку в ходе загрузки доступ к справочной системе будет невозможен.
  • На вкладке Автозагрузка отображаются элементы, помещаемые при загрузке компьютера в группу «Автозагрузка», в параметры Win.ini load= и run=, а также в реестр.

См. также


Определение причин неполадок с помощью вкладок системных файлов

XOX

На вкладках System.ini и Win.ini отображаются параметры соответствующих файлов. При использовании этих вкладок снижается риск внесения ошибок при редактировании системных файлов. Недоступные флажки указывают строки, временно удаленные программой настройки системы.

Примечание

  • На вкладках System.ini и Win.ini разделы обозначены флажками. Снимая флажки, можно временно удалять соответствующие разделы целиком.

См. также