Вкладка «Поставщик данных»

Вкладка Поставщик используется для выбора подходящего поставщика OLE DB для тех данных, к которым осуществляется доступ. Изменить поставщик можно не во всех приложениях. Вкладка доступна только в том случае, если приложением предусмотрена возможность выбора поставщик а. Допускается сохранение связи с данными вместе с приложением или в качестве отдельного файла. Дополнительные сведения о создании связи с данными содержатся в разделе "Creating a Data Link" пакета MDAC SDK.

Параметр | Описание
Поставщики OLE DB | Список всех обнаруженных на жестком диске поставщиков OLE DB. Дополнительные сведения о поставщиках содержатся в разделе "Microsoft OLE DB Providers Overview" пакета MDAC SDK.
Далее | Переход на вкладку Подключение, соответствующую выбранному поставщику OLE DB.

Примечание. Имеется возможность напрямую перейти на вкладку Подключение, дважды щелкнув название поставщика. Дополнительные сведения о связи с данными содержатся в разделе Справочные сведения о Data Link API.


Вкладка «Дополнительно»

Вкладка Дополнительно используется для просмотра и настройки остальных параметров инициализации данных.

Вкладка Дополнительно диалогового окна Свойства связи с данными для каждого поставщика своя. На нее выносятся только свойства инициализации, которые характерны для выбранного поставщика. Дополнительные сведения о свойствах инициализации содержатся в документации к каждому поставщику OLE DB.

Следующая таблица описывает большую часть параметров инициализации.

Параметр | Описание
Уровень олицетворения Уровень представления, используемый сервером при исполнении роли клиентов. Данное свойство не распространяется на соединения RPC (Remote Procedure Call – вызовы удаленных процедур); а сами уровни представления аналогичны использующимся в RPC. Значения свойства напрямую соответствуют уровням олицетворения, которые могут быть указаны для проверенных соединений RPC, но могут применяться и к другим соединениям. Выберите один из следующих уровней.
  • Аноним—Анонимное подключение клиента к серверу. Процессу сервера недоступны идентификационные сведения клиента, поэтому представление клиента невозможно.

  • Делегирование—При работе от лица клиента, процесс может использовать защищенный контекст клиента. Кроме того, в этом случае от имени клиента процессом сервера могут осуществляться подключения к другим серверам.

  • Идентификация—Клиент может быть опознан сервером. Сервер может исполнять роль клиента при проверке таблицы управления доступом ACL (Access Control List), однако получить доступ к системным объектом как клиент он не может.

  • Олицетворение—При работе в качестве клиента, процесс сервера может использовать защищенный контекст клиента. Сведения могут быть получены только при установленном соединении, но не при каждом вызове.
Уровень защиты Уровень защиты данных, передаваемых между сервером и клиентом. Данное свойство не распространяется на соединения RPC (Remote Procedure Call – вызовы удаленных процедур); а сами уровни защиты аналогичны использующимся в RPC. Значения свойства напрямую соответствуют уровням защиты, которые могут быть указаны для проверенных соединений RPC, но могут применяться и к другим соединениям. Выберите один из следующих уровней.
  • Вызов—Проверка подлинности источника данных в начале каждого запроса от клиента к серверу.

  • Подключение—Проверка подлинности данных проводится только при установлении соединения с сервером.

  • Не проверяется—Подлинность отправляемых на сервер данных не проверяется.

  • Пакет—Проверка подлинности того, что все полученные данные исходят от клиента.

  • Целостность пакета—Проверка подлинности того, что все полученные данные исходят от клиента и не были изменены при передаче.

  • Приватность пакета—Проверка подлинности того, что все полученные данные исходят от клиента и не были изменены при передаче, а также защита конфиденциальности данных шифрованием.
Время ожидания подключения | Время (в секундах), в течение которого поставщик OLE DB ожидает завершения инициализации. По истечении этого времени соединение установлено не будет и возникнет ошибка.
Права доступа Выберите одно или несколько прав доступа.
  • Read—Только чтение.

  • ReadWrite—Чтение и запись.

  • Share Deny None—Никому не отказывать ни в чтении, ни в записи.

  • Share Deny Read—Запретить всем работу в режиме чтения.

  • Share Deny Write—Запретить всем работу в режиме записи.

  • Share Exclusive—Запретить всем работу в режиме чтения/записи.

  • Write—Только запись.

Примечание. Дополнительные сведения об инициализации связи с данными содержатся в разделе Справочные сведения о Data Link API.


Вкладка «Все»

Вкладка Все предназначена для просмотра и настройки всех параметров инициализации OLE DB, которые поддерживает текущий поставщик. В зависимости от используемого поставщика OLE DB параметры могут изменяться. Дополнительные сведения о свойствах инициализации содержатся в документации к каждому поставщику OLE DB.

Параметр | Описание
Список свойств инициализации | Список всех свойств и их текущих значений.
Изменить значение | Открывает для выделенного свойства диалоговое окно Изменение значения свойства.

Примечание. Имеется возможность открыть диалоговое окно Изменение значения свойства, дважды щелкнув нужное свойство. Дополнительные сведения об инициализации связи с данными содержатся в разделе Справочные сведения о Data Link API.


Вкладка «Подключение»

Вкладка Подключение используется для настройки параметров подключения к данным с помощью поставщика OLE DB.

Вкладка Подключение диалогового окна Свойства связи с данными для каждого поставщика своя. На нее выносятся только те свойства соединения, которые характерны для выбранного поставщика. Этими свойствами определяется размещение данных и способ доступа к ним. Дополнительные сведения содержатся в документации по каждому поставщику OLE DB.

Следующая таблица описывает большую часть параметров подключения.

Параметр | Описание
Источник данных | Введите имя источника данных, к которому нужно получить доступ. Как правило, это имя сервера.
Размещение | Введите местоположение источника данных, к которому нужно получить доступ. Как правило, это имя базы данных.
учетные сведения Windows NT | Использование службы проверки подлинности пользователей. Этот параметр доступен только в том случае, если поставщик OLE DB поддерживает работу со службой проверки подлинности пользователей. Например, поставщик OLE DB для SQL Server. Необходимо в источнике данных иметь разрешение на использование этой службы.
следующие имя и пароль пользователя: | Использование наперед заданных имени пользователя и пароля при подключении к источнику данных.
Пользователь | Введите имя пользователя, необходимое для подключения к источнику данных.
Пароль | Введите пароль, который будет использоваться при подключении к источнику данных.
Пустой пароль | Позволяет поставщику возвращать строку подключения с пустым паролем.
Разрешить сохранение пароля | Разрешает сохранение пароля вместе со строкой подключения. Будет ли включен пароль в строку подключения, зависит от функциональных особенностей вызывающего приложения. Примечание. Пароль сохраняется и передается в незашифрованном виде.
Введите начальный каталог | Введите каталог, к которому требуется доступ при подключении.
Проверить подключение | Проверка соединения с указанным источником данных. Если соединение установить не удалось, убедитесь в правильности заданных настроек. Возможно, отсутствие соединения вызвано неточным соблюдением регистра символов или ошибками синтаксиса.

Примечание. Дополнительные сведения о связи с данными содержатся в разделе Справочные сведения о Data Link API.


Вкладка «Подключение» для Jet

Вкладка Подключение используется для настройки параметров подключения к данным Microsoft Access.

Вкладка Подключение для каждого поставщика своя. На нее выносятся только те свойства соединения, которые необходимы для поставщика OLE DB для Microsoft Jet.

Параметр | Описание
Имя базы данных | Введите имя файла базы данных Microsoft Access (.mdb), к которой будет осуществляться доступ. Для выбора файла из списка нажмите соответствующую кнопку.
Пользователь | Введите имя пользователя, необходимое для подключения к источнику данных.
Пароль | Введите пароль, который будет использоваться при подключении к источнику данных.
Пустой пароль | Позволяет поставщику возвращать строку подключения с пустым паролем.
Разрешить сохранение пароля | Разрешает сохранение пароля вместе со строкой подключения. Будет ли включен пароль в строку подключения, зависит от функциональных особенностей вызывающего приложения. Примечание. Пароль сохраняется и передается в незашифрованном виде.
Проверить подключение | Проверка соединения с указанным источником данных. Если соединение установить не удалось, убедитесь в правильности заданных настроек. Возможно, отсутствие соединения вызвано неточным соблюдением регистра символов или ошибками синтаксиса.

Примечание. Дополнительные сведения о связи с данными содержатся в разделе Справочные сведения о Data Link API.


Вкладка «Подключение» для ODBC

Вкладка Подключение используется для настройки параметров подключения к данным ODBC.

Вкладка Подключение для каждого поставщика своя. На нее выносятся только те свойства соединения, которые необходимы для поставщика OLE DB для ODBC.

Параметр | Описание
Использовать имя источника данных | Выберите из списка или введите имя источника данных ODBC (DSN), к которому необходимо получить доступ. Имеется возможность добавить другие источники с помощью администратора источников данных ODBC. Обновите список с помощью кнопки Обновить.
Использовать строку подключения | Ввод или создание строки подключения ODBC вместо использования существующего источника данных DSN.
Сборка Вызов диалогового окна Выбор источника данных. После выбора источник данных строка подключения к этому источнику появится на вкладке Подключение диалогового окна Свойства связи с данными.

При выборе файлового источника данных результирующая строка подключения ODBC не будет зависеть от источника. Она останется в файле связи с данными (.udl) и не будет зависеть от выбора источника данных.

При выборе источника данных компьютера результирующая строка подключения ODBC будет зависеть от источника. Строка подключения ODBC будет указывать на источник выбранного компьютера. Пользователям других систем для доступа к файлу связи с данными (.udl) необходимо будет также установить источник данных компьютера.
Пользователь | Введите имя пользователя, необходимое для подключения к источнику данных.
Пароль | Введите пароль, который будет использоваться при подключении к источнику данных.
Пустой пароль | Позволяет поставщику возвращать строку подключения с пустым паролем.
Разрешить сохранение пароля Разрешает сохранение пароля вместе со строкой подключения. Будет ли включен пароль в строку подключения, зависит от функциональных особенностей вызывающего приложения.

Примечание. Пароль сохраняется и передается в незашифрованном виде.
Введите начальный каталог | Введите имя каталога (или базы данных) или выберите его из раскрывающегося списка.
Проверить подключение | Проверка соединения с указанным источником данных. Если соединение установить не удалось, убедитесь в правильности заданных настроек. Возможно, отсутствие соединения вызвано неточным соблюдением регистра символов или ошибками синтаксиса.

Примечание. Дополнительные сведения о связи с данными содержатся в разделе Справочные сведения о Data Link API.


Вкладка «Подключение» для Oracle

Вкладка Подключение используется для настройки параметров подключения к данным Oracle.

Вкладка Подключение для каждого поставщика своя. На нее выносятся только те свойства соединения, которые необходимы для поставщика OLE DB для Oracle.

Параметр | Описание
Имя сервера | Укажите сервер с базой данных, к которой будет осуществляться доступ.
Пользователь | Введите имя пользователя, необходимое для подключения к источнику данных.
Пароль | Введите пароль, который будет использоваться при подключении к источнику данных.
Пустой пароль | Позволяет поставщику возвращать строку подключения с пустым паролем.
Разрешить сохранение пароля | Разрешает сохранение пароля вместе со строкой подключения. Будет ли включен пароль в строку подключения, зависит от функциональных особенностей вызывающего приложения. Примечание. Пароль сохраняется и передается в незашифрованном виде.
Проверить подключение | Проверка соединения с указанным источником данных. Если соединение установить не удалось, убедитесь в правильности заданных настроек. Возможно, отсутствие соединения вызвано неточным соблюдением регистра символов или ошибками синтаксиса.

Примечание. Дополнительные сведения о связи с данными содержатся в разделе Справочные сведения о Data Link API.


Вкладка «Подключение» для SQL Server

Вкладка Подключение используется для настройки параметров подключения к данным Microsoft SQL Server.

Вкладка Подключение для каждого поставщика своя. На нее выносятся только те свойства соединения, которые необходимы для поставщика OLE DB для Microsoft SQL Server.

Параметр | Описание
Имя сервера | Выберите имя сервера из раскрывающегося списка или введите местоположение сервера, на котором находится требуемая база данных. Выбор базы данных на сервера выполняется на другом шаге. Обновите список с помощью кнопки Обновить.
учетные сведения Windows NT | Выберите параметр, чтобы указать, сто поставщику требуется безопасное (или надежное) подключение к SQL Server, выполняющемуся в системе Microsoft Windows NT. При выборе этого параметра SQL Server использует для подключения с помощью данного источника данных учетные сведения пользователя, а не режим проверки подлинности в текущем сеансе входа на сервер. Предоставленные имя и пароль игнорируются. Системный администратор SQL Server должен сопоставить ваше сетевое имя Microsoft Windows с именем в SQL Server.
следующие имя и пароль пользователя | Использование наперед заданных имени пользователя и пароля при подключении к источнику данных.
Пользователь | Введите имя пользователя, необходимое для подключения к источнику данных.
Пароль | Введите пароль, который будет использоваться при подключении к источнику данных.
Пустой пароль | Позволяет поставщику возвращать строку подключения с пустым паролем.
Разрешить сохранение пароля Разрешает сохранение пароля вместе со строкой подключения. Будет ли включен пароль в строку подключения, зависит от функциональных особенностей вызывающего приложения.

Примечание. Пароль сохраняется и передается в незашифрованном виде.
Выберите базу данных Воспользуйтесь одним из следующих методов:
  1. Укажите базу данных, к которой нужно получить доступ.

  2. Для SQL Server 7.0 присоедините файл базы данных SQL как имя базы данных. Введите имя базы данных, которое будет использовано в качестве присоединенного файла базы данных SQL.

  3. Для SQL Server 6.5 и более ранней версии введите имя файла базы данных для присоединения. Введите имя одиночного файла базы данных. Для выбора файла из списка нажмите соответствующую кнопку.
Проверить подключение | Проверка соединения с указанным источником данных. Если соединение установить не удалось, убедитесь в правильности заданных настроек. Возможно, отсутствие соединения вызвано неточным соблюдением регистра символов или ошибками синтаксиса.

Примечание. Дополнительные сведения о связи с данными содержатся в разделе Справочные сведения о Data Link API.


Справочные сведения о Data Link API

Дополнительные сведения об интерфейсе программирования приложений Data Link API содержатся на узле msdn.microsoft.com. (Откройте электронную библиотеку MSDN, а затем Platform SDK, чтобы найти раздел MDAC SDK, содержащий справочник Data Link API Reference.)


Диалоговое окно «Изменение значения свойства»

Диалоговое окно Изменение значения свойства предназначено для изменения выбранного на вкладке «Все» параметра инициализации OLE DB. В зависимости от используемого поставщика OLE DB параметры могут изменяться.

Примечание. Подробнее узнать о дополнительных параметрах инициализации можно из документации к поставщику OLE DB.

Параметр | Описание
Описание свойства | Описание выбранного свойства.
Значение свойства | Выбор подходящего значения.
Сброс значения | Замена текущего значения выбранного свойства на значение по умолчанию для поставщика OLE DB.