Диалоговое окно "Microsoft ODBC для установки Oracle"

В диалоговом окне Microsoft ODBC для установки Oracle содержатся следующие элементы.

Имя источника данных | Имя или идентификатор, используемый приложениями для вызова или использования источника данных. Могут использоваться описательные имена источников данных. По умолчанию это поле пусто, но его значение необходимо.
Описание | В этом поле содержится описание. По умолчанию оно пусто.
Пользователь | Имя пользователя для источника данных.
Сервер | Псевдоним базы данных, созданный в SQL*Net Easy Configuration, или строка подключения. (Сведения о структуре строки см. в разделе Атрибуты строки подключения. Описания строк подключения к личным и удаленным базам данных см. в файле справки Oracle.)
Трансляция | Нажмите кнопку Выбрать, чтобы выбрать загруженный транслятор данных. По умолчанию Отсутствует транслятор.
Быстродействие В поле Размер буфера укажите размер памяти (в байтах), выделяемый для хранения извлекаемых данных. Процесс загрузки настраивается таким образом, чтобы за одну загрузку сервер Oracle возвращал число строк достаточное, чтобы заполнить буфер. Использование большого размера увеличивает быстродействие при загрузке данных большого объема.

Если флажок Включить REMARKS в функции каталога установлен, драйвер возвращает столбцы заметок для набора результатов SQLColumns. Снимите этот флажок, чтобы увеличить быстродействие.

Если установлен флажок Включить SYNONYMS в SQLColumns и имеет значение "True" (1), вызов API SQLColumns возвращает сведения для столбцов Tables, Views и Synonyms. Сведения для столбцов загружаются быстрее, если это значение не установлено (или если оно равно нулю).
Настройка Флажок Использовать стандарт дня недели (DayOfWeek) ODBC указывает формат дней недели, используемый для набора результатов. Если он установлен, набор результатов должен соответствовать формату дня недели ODBC (воскресенье = 1; суббота = 7). В противном случае должно выполняться соответствие формату дней недели Oracle (понедельник = 1, воскресенье = 7).

Флажок SQLDescribeCol всегда возвращает значение точности указывает, что вызов SQLDescribeCol возвращает значение точности 130, если соответствующих сведений нет в Oracle. Для некоторых числовых типов данных Oracle не установлена фиксированная точность, например для числовых столбцов и для столбцов с определением NUMBER без указания точности или масштаба. Если этот флажок снят, для столбцов этих типов драйвер возвращает значение 0.

Примечание. Подробные и сведения об этой драйвере содержатся на узле msdn.microsoft.com. (Откройте электронную библиотеку MSDN, а затем Platform SDK, чтобы найти раздел MDAC SDK, содержащий раздел ODBC Drivers.) Драйвер Microsoft ODBC для Oracle поддерживает только SQL*Net 2.3 и более поздних версий. Дополнительные сведения о продуктах Oracle см. в документации Oracle. Другие сведения можно найти в этом файле в разделах Уровни поддержки программного обеспечения и Поддержка продукта.


.topic 4209
Имя или идентификатор, используемый приложениями для вызова или использования источника данных. По умолчанию это поле пусто, но его значение необходимо.

.topic 4210
В этом поле содержится описание. По умолчанию оно пусто.

.topic 4201
Объем данных (в байтах), который должен загружаться приложением за один раз.

.topic 4202
Введите имя пользователя базы данных; в качестве имени используется код пользователя базы данных.

.topic 4203
Выбор формата дней недели, используемый для набора результатов (ODBC или Oracle).

.topic 4204
Если этот флажок установлен, драйвер возвращает столбцы заметок для набора результатов SQLColumns. Снимите этот флажок, чтобы увеличить быстродействие.

.topic 4205
Если этот флажок установлен, драйвер возвращает сведения о столбце SYNONYMS.

.topic 4206
Строка подключения к механизму сервера Oracle.

.topic 4207
Выбор загруженного транслятора данных.

.topic 4208
Если этот флажок установлен, вызов SQLDescribeCol возвращает значение точности 130, если этих данных нет в Oracle. Если флажок не установлен, драйвер возвращает для столбцов этих типов значение 0.


Атрибуты строки подключения

Вместо диалогового окна для некоторых приложений должна использоваться строка подключения, в которой указываются определенные атрибуты подключения драйвера к источнику данных. Каждый атрибут определяет конкретные данные, необходимые драйверу для успешного подключения. В строке подключения всегда используется следующий формат:

"DSN=<data-source-name> ;[SERVER=<value>] [;PWD=<value>] [;UID=<value>] [;<Attribute>=<value>]"

Примечание. Драйвер Microsoft ODBC для Oracle поддерживает также аргумент CONNECTSTRING из первой (1.x) версии драйвера.

Если не указаны атрибуты UID, PWD, SERVER (или CONNECTSTRING) и DRIVER, необходимо указать имя источника данных. Однако все остальные атрибуты не являются обязательными. Если атрибут не указан, по умолчанию используется значение, указанное на вкладке DSN в диалоговом окне Администратор источников данных ODBC.

В следующей таблице приведены описания атрибутов строки подключения.

Атрибут | Описание | Значение по умолчанию
DSN Имя источника данных, указанное на вкладке Пользовательский DSN или Системный DSN в окне Администратор источников данных ODBC. ""
PWD Пароль сервера Oracle, к которому требуется подключиться. Драйвером поддерживаются ограничения на длину пароля (30 знаков) и на набор знаков пароля, используемые в Oracle. ""
SERVER Строка для сервера Oracle, к которому требуется подключиться.

В этой строке может быть введен псевдоним базы данных Oracle, запись из файла Tnsnames.ora или псевдоним для установки подключения к нужному серверу с помощью сервера имен Oracle Names Server.

Псевдоним базы данных может устанавливаться с помощью Oracle SQL*Net Fast Configuration (или Net8 Easy Configuration для баз данных Oracle8). Дополнительные сведения о подключении к базам данных Oracle см. в документации Oracle.

 ""
UID Имя пользователя на сервере Oracle. При работе с некоторыми базами данных и таблицами значение этого атрибута требуется в целях обеспечения безопасности.

Чтобы указать, что проверка подлинности выполняется операционной системой Oracle, введите "UID=/;".

""
BUFFERSIZE Оптимальный размер буфера для загрузки столбцов.

Процесс загрузки настраивается таким образом, чтобы за одну загрузку сервер Oracle возвращал число строк достаточное, чтобы заполнить буфер. Использование большого размера увеличивает быстродействие при загрузке данных большого объема.

 65535
SYNONYMCOLUMNS | Если этот атрибут имеет значение "true" (1), вызов API SQLColumns возвращает сведения для столбцов Tables, Views и Synonyms. В противном случае SQLColumns возвращает сведения только для столбцов Tables и Views. Для увеличения быстродействия не указывайте это значение. | 1
REMARKS | Если этот атрибут имеет значение "true" (1), драйвер возвращает столбцы заметок для набора правил SQLColumns. Для увеличения быстродействия не указывайте это значение. | 0
StdDayOfWeek | Включение использования стандарта ODBC для параметра DAYOFWEEK. Это значение используется по умолчанию. При необходимости значение может быть изменено для использования формата, возвращаемого Oracle. | 1

Примечание. Может учитываться регистр знаков значений атрибутов.

Примеры

Следующая строка подключения задает подключение к источнику данных "Employees" через сервер "mickey.world" с использованием имени пользователя Oracle "cindy":

"DSN=Employees;UID=cindy;PWD=secret;SERVER=mickey.world"

Следующая строка подключения задает подключение к источнику данных "Payroll" через сервер Oracle "moola", причем проверка подлинности выполняется операционной системой Oracle:

"DSN=Payroll;UID=/;PWD=;SERVER=moola"


Диалоговое окно "Microsoft ODBC для подключения к Oracle"

В диалоговом окне Microsoft ODBC для подключения к Oracle содержатся следующие элементы.

Пользователь | Имя, используемое для подключения к базе данных Oracle.
Пароль | Пароль, используемый для подключения к базе данных Oracle (соблюдаются ограничения на пароли, используемые в Oracle).
Сервер | В этой строке вводится псевдоним базы данных Oracle, запись из файла Tnsnames.ora или псевдоним для установки подключения к нужному серверу с помощью сервера имен Oracle Names Server. Подробные сведения о подключении к базе данных Oracle содержатся на узле msdn.microsoft.com. (Откройте электронную библиотеку MSDN, а затем Platform SDK, чтобы найти раздел MDAC SDK, содержащий раздел ODBC Drivers.) Сведения о файле Tnsnames.ora содержатся в документации Oracle.


Поддержка продукта

Подробные и сведения об этой драйвере содержатся на узле msdn.microsoft.com. (Откройте электронную библиотеку MSDN, а затем Platform SDK, чтобы найти раздел MDAC SDK, содержащий раздел ODBC Drivers.)

Корпорацией Oracle поставляется документация по установке и использованию программного обеспечения клиента Oracle.


Уровни поддержки программного обеспечения

Драйвер Microsoft ODBC для Oracle поддерживает следующие программные продукты.

  • Microsoft Windows 95/98, Microsoft Windows NT 4.0 и Windows 2000

  • Oracle Call Interface 7 (OCI7)

  • SQL*Net 2.3 или более поздней версии

  • ODBC 2.x или более ранней версии (Могут устанавливаться драйвера ODBC более поздних версий, но некоторые их функции не могут использоваться.)


SQLColumns

Это средство создания набора результатов для таблицы, который представляет собой список столбцов указанной таблицы или нескольких таблиц. Чтобы запросить столбцы для синонима PUBLIC, необходимо установить атрибут подключения SYNONYMCOLUMNS и ввести в качестве аргумента szTableOwner пустую строку. При возвращении столбцов для синонима PUBLIC в столбец TABLE NAME драйвером записывается пустая строка. В конце каждой строки набора результатов содержится дополнительный столбец ORDINAL POSITION. Это значение соответствует исходному расположению столбца в таблице.