Элемент управления WMI

  • Общие сведения о WMI
  • Общие сведения о элементе управления WMI
  • Включение или выключение ведения журнала ошибок WMI
  • Задание интервала между процедурами архивирования хранилища
  • Изменение настройки сценариев WMI
  • Система безопасности


Общие сведения о WMI

Рисунок Microsoft Windows

Общие сведения об инструментарии управления Windows

Инструментарий управления Windows (Windows Management Instrumentation, WMI) представляет собой реализацию корпорации Майкрософт протокола WBEM (Web-Based Enterprise Management — управление предприятием на основе веб-технологий), регламентирующего стандарты общего доступа к данным управления по сети предприятия. WMI обеспечивает встроенную поддержку модели CIM (Common Information Model — общая модель данных), которой должны соответствовать объекты среды управления.

WMI включает CIM-совместимую базу данных, в которой хранятся определения объектов, и диспетчер объектов CIM, в задачи которого входит занесение объектов в хранилище и управление ими, а также сбор данных от поставщиков WMI. Поставщики WMI играют роль посредников между WMI и компонентами операционной системы, приложениями и другими системами. Например, поставщик реестра получает данные из реестра, а поставщик SNMP предоставляет данные и события от устройств SNMP. Поставщики не только предоставляют данные, но и методы, с помощью которых можно управлять компонентами, свойства, которые могут быть изменены, и события, информирующие об изменениях, происходящих в компонентах.

WMI может использоваться средствами управления компьютерами, такими как Microsoft Systems Management Server. Кроме того, WMI применяется в других технологиях и продуктах корпорации Майкрософт, таких как Microsoft Health Monitor и Microsoft Operations Manager, а также сторонними изготовителями компьютерных систем управления. Можно также использовать WMI вместе с системами программирования (такими как Windows Script Host) как для получения сведений о конфигурации компьютерных систем, в том числе о серверных приложениях, так и для изменения конфигурации (подробнее об этом — в пакете разработчика WMI SDK).

WMI поддерживается такими средствами управления, как «Свойства системы», «Сведения о системе» и «Зависимости» (оснастка «Службы»). Ниже дается краткое описание этих компонентов.

  • Компонент «Свойства системы» позволяет просматривать и изменять свойства системы на локальном или удаленном компьютере. Имеется возможность перезагружать удаленный компьютер для применения новой настройки или для обнаружения нового оборудования, просматривать имя компьютера и сведения о домене для других компьютеров в сети, а также изменять параметры файла подкачки на компьютере, выполняющем программы, требующие большого объема памяти. Дополнительные сведения о свойствах системы см. в разделе Использование средства «Свойства системы».
  • Компонент «Сведения о системе» собирает и отображает сведения о конфигурации системы. Это особенно удобно при обращении в службу технической поддержки. Дополнительные сведения см. в разделе Использование компонента «Сведения о системе».
  • Оснастка «Службы» облегчает управление службами на компьютере. Средство «Зависимости» позволяет определить службы, от которых зависит текущая служба, а также службы, зависящие от нее. Дополнительные сведения об оснастке «Службы» см. в разделе Использование оснастки «Службы».
Технические подробности о разработке программного обеспечения для подсистемы WMI см. в пакете WMI SDK (Software Development Kit). Пакет WMI SDK распространяется MSDN (Microsoft Developer Network) как часть пакета Microsoft Platform SDK.


Общие сведения о элементе управления WMI

Оснастка «Элемент управления WMI» — это средство, позволяющее настраивать параметры WMI на удаленном и локальном компьютерах. Далее перечислены задачи, которые позволяет выполнять элемент управления WMI.

Авторизация пользователей и групп, а также задание уровней разрешений

Можно предоставить пользователю или группе доступ к службам и задачам WMI, а также разрешить их выполнение. Для каждого такого пользователя или группы задается уровень разрешений на выполнение действий в конкретных пространствах имен. Например, можно разрешить группе управлять объектами CIM (Common Information Model — общая модель данных) на своих локальных компьютерах.

Настройка средства ведения журнала ошибок

Можно включить или выключить ведение журнала ошибок, а также, если журнал включен, задать регистрацию только ошибок (по умолчанию) или всех действий (подробный журнал). Ведение журнала ошибок помогает устранять возможные неполадки WMI. Имеется также возможность определить максимальный размер для файлов журналов и размещение их папок.

Архивирование хранилища

Можно настроить элемент управления WMI на регулярное архивирование хранилища или выполнять архивирование вручную в нужное время. Хранилище представляет собой базу данных объектов, доступных через WMI. Также предусмотрена процедура восстановления предыдущей версии хранилища.

Смена пространства имен, используемого по умолчанию для сценариев

Можно сменить пространство имен, адресуемое по умолчанию в сценариях WMI.

Подключение в качестве другого пользователя

Можно войти в подсистему WMI под другим именем пользователя, чтобы изменить настройку элемента управления WMI. Например, если на нескольких рабочих станциях была определена учетная запись администратора, она позволяет подключиться к этим станциям с помощью соответствующего имени пользователя.

См. также


Включение или выключение средства ведения журнала ошибок WMI

Чтобы включить или выключить средство ведения журнала ошибок WMI:

  1. Откройте оснастку Элемент управления WMI.
  2. В дереве консоли щелкните правой кнопкой мыши значок Элемент управления WMI и выберите команду Свойства.
  3. Выберите вкладку Ведение журнала.
  4. Чтобы выключить ведение журнала, установите переключатель Уровень ведения журнала в положение Отключить. Чтобы включить ведение журнала, выберите положение Только ошибки или Подробный.

Примечания

  • Для выполнения данной задачи необходимо на управляемом компьютере быть администратором или членом группы администраторов, либо иметь соответствующие разрешения.
  • Чтобы открыть консоль «Элемент управления WMI», нажмите кнопку Пуск, выберите команду Выполнить, введите wmimgmt.msc и нажмите кнопку OK.
  • В режиме Только ошибки выполняется запись внутренних ошибок WMI. В режиме Подробный выполняется запись всех действий и ошибок.
  • Подробное ведение журнала может негативно сказаться на быстродействии системы, поэтому выбирайте режим Подробный только тогда, когда необходимы более детальные сведения о событиях, приведших к ошибкам.
  • Файлы журналов поддерживаются как для ядра и среды WMI, так и для каждого доступного для WMI поставщика.
  • Имеется возможность задать максимальный размер для файлов журналов в поле Максимальный размер. Когда файл журнала достигает максимального размера, он переименовывается в файл с расширением .lo_, и создается новый файл журнала с расширением .log. При достижении вторым файлом заданного размера первый файл удаляется, а второй файл переименовывается.
  • Допускается установка уровней ведения журнала на удаленном или локальном компьютере. Для доступа к удаленному компьютеру щелкните правой кнопкой Элемент управления WMI, выберите команду Подключение к другому компьютеру, установите переключатель в положение к другому компьютеру, а затем введите имя компьютера, к которому нужно подключиться. При работе с элементом управления WMI в консоли «Управление компьютером» для подключения к другому компьютеру щелкните правой кнопкой мыши значок Управление компьютером.
  • Допускается подключение к компьютеру в качестве другого пользователя, если у вас имеется несколько имен для входа в систему. Для подключения в качестве другого пользователя выберите вкладку Общие, нажмите кнопку Изменить, снимите флажок Войти под именем текущего пользователя, а затем введите имя пользователя и пароль.
  • Рекомендуется включать файлы журналов в сообщения с вопросами, относящимися к службам WMI.

См. также


Задание интервала между процедурами архивирования хранилища

Чтобы выполнить архивирование или восстановление хранилища WMI

  1. Откройте оснастку Элемент управления WMI.
  2. В дереве консоли щелкните правой кнопкой мыши значок Элемент управления WMI и выберите команду Свойства.
  3. Выберите вкладку Архивация или восстановление.
  4. Нажмите кнопку Архивировать или кнопку Восстановить.

Примечания

  • Для выполнения данной задачи необходимо на управляемом компьютере быть администратором или членом группы администраторов, либо иметь соответствующие разрешения.
  • Чтобы открыть консоль «Элемент управления WMI», нажмите кнопку Пуск, выберите команду Выполнить, введите wmimgmt.msc и нажмите кнопку OK.
  • Нажав кнопку Архивировать, можно задать имя файла, который в дальнейшем будет доступен при восстановлении. Это может оказаться полезным, если требуется сохранить определенную конфигурацию классов.
  • Архивирование или востановление возможно как на удаленном, так и на локальном компьютерах. Для доступа к удаленному компьютеру щелкните правой кнопкой Управляющий элемент WMI, выберите команду Подключение к другому компьютеру, установите переключатель в положение к другому компьютеру, а затем введите имя компьютера, к которому нужно подключиться. При работе с элементом управления WMI в консоли «Управление компьютером» для подключения к другому компьютеру щелкните правой кнопкой мыши значок Управление компьютером.
  • Допускается подключение к компьютеру в качестве другого пользователя, если у вас имеется несколько имен для входа в систему. Для подключения в качестве другого пользователя выберите вкладку Общие, нажмите кнопку Изменить, снимите флажок Войти под именем текущего пользователя, а затем введите имя пользователя и пароль.

См. также


Изменение настройки сценариев WMI

Чтобы изменить настройку сценариев WMI

  1. Откройте оснастку Элемент управления WMI.
  2. В дереве консоли щелкните правой кнопкой мыши значок Элемент управления WMI и выберите команду Свойства.
  3. Откройте вкладку Дополнительно.
  4. В группе Пространство имен по умолчанию для написания сценариев нажмите кнопку Изменить.
  5. В диалоговом окне Обозреватель пространств имен выберите другое пространство имен, используемое по умолчанию для сценариев.

Примечания

  • Для выполнения данной задачи необходимо на управляемом компьютере быть администратором или членом группы администраторов, либо иметь соответствующие разрешения.
  • Чтобы открыть консоль «Элемент управления WMI», нажмите кнопку Пуск, выберите команду Выполнить, введите wmimgmt.msc и нажмите кнопку OK.
  • Задайте в качестве конечного пространства имен, используемого по умолчанию, то, которое используется сценариями WMI чаще всего. Пространство имен по умолчанию применяется тогда, когда конкретное пространство имен в тексте сценария не указано.
  • Если управляемый компьютер имеет систему Windows NT 4.0, можно определить, допускается ли выполнение сценариев WMI с активных серверных страниц (Active Server Pages, ASP). Если включить этот параметр, ваши страницы ASP будут всегда подключаться к службам управления Windows посредством идентификации на уровне процессов информационных служб Интернета (Internet Information Services, IIS), что может привести с снижению уровня безопасности.
  • Смена пространства имен для сценариев возможна как на удаленном, так и на локальном компьютере. Для доступа к удаленному компьютеру щелкните правой кнопкой Элемент управления WMI, выберите команду Подключение к другому компьютеру, установите переключатель в положение к другому компьютеру, а затем введите имя компьютера, к которому нужно подключиться. При работе с элементом управления WMI в консоли «Управление компьютером» для подключения к другому компьютеру щелкните правой кнопкой мыши значок Управление компьютером.
  • Допускается подключение к компьютеру в качестве другого пользователя, если у вас имеется несколько имен для входа в систему. Для подключения в качестве другого пользователя выберите вкладку Общие, нажмите кнопку Изменить, снимите флажок Войти под именем текущего пользователя, а затем введите имя пользователя и пароль.

См. также


Система безопасности

  • Управление безопасностью WMI
  • Задание разрешений и авторизация пользователей и групп
  • Изменение разрешений или удаление авторизованных пользователей


Управление безопасностью WMI

Инструментарий управления Windows (Windows Management Instrumentation, WMI) поддерживает ограниченный набор средств безопасности, который характеризуется проверкой каждого пользователя прежде, чем ему разрешается подключиться к WMI как на локальном, так и на удаленном компьютере. Эти средства представляют собой надстройку по отношению к средствам безопасности операционной системы. При этом WMI не замещает и не обходит средства безопасности, предоставляемые ОС.

По умолчанию все члены группы «Администраторы» имеют полный доступ к службам WMI на управляемом компьютере. Все остальные имеют разрешения на чтение, запись и выполнение только на своих локальных компьютерах.

Чтобы изменить разрешения, необходимо добавить пользователя в группу «Администраторы» на управляемом компьютере, либо провести авторизацию пользователей или групп в WMI и задать для них уровень разрешения. Доступ основывается на пространстве имен WMI.

На компьютерах с системой Windows 95, Windows 98 или Windows Millennium Edition все пользователи имеют полный доступ к локальной системе. Однако могут быть заданы разрешения для пользователей, управляющих компьютерами с такими ОС с удаленного компьютера.

Безопасность проверяется только в том случае, когда пользователь подключается к службе управления Windows. Таким образом, любые изменения, сделанные в разрешениях подключенного пользователя, вступят в силу только при следующем запуске службы WMI. Например, если доступ пользователя отозван, изменения вступят в силу, когда пользователь выйдет из WMI и вновь попытается подключиться к этой службе.

См. также


Авторизация пользователей WMI и задание разрешений

Чтобы выполнить авторизацию пользователей WMI и задать разрешения

  1. Откройте оснастку Элемент управления WMI.
  2. В дереве консоли щелкните правой кнопкой мыши значок Элемент управления WMI и выберите команду Свойства.
  3. Выберите вкладку Безопасность.
  4. Выберите пространство имен, для которого нужно предоставить доступ пользователей или групп, а затем нажмите кнопку Безопасность.
  5. В диалоговом окне Безопасность нажмите кнопку Добавить.
  6. В диалоговом окне Выбор: Пользователи, Компьютеры или Группы введите необходимое имя пользователя или группы, нажмите кнопку Проверить имена, а затем — кнопку OK. Можно изменить место поиска имен или нажать кнопку Дополнительно, чтобы составить запрос для отбора объектов. Дополнительные сведения см. в инструкциях этого диалогового окна.
  7. В диалоговом окне Безопасность в списке Разрешения установите флажки разрешений, которые следует предоставить новому пользователю или группе.
    8. Уровень | Описание
Выполнение методов | Разрешает выполнение методов, экспортированных из классов и экземпляров WMI.
Полная запись | Разрешает полный доступ на чтение, запись и удаление ко всем объектам, классам и экземплярам WMI.
Частичная запись | Разрешает доступ на запись к статическим объектам WMI.
Запись поставщика | Разрешает доступ на запись к объектам, предоставляемым поставщиком.
Включить учетную запись | Разрешает доступ на чтение к объектам WMI.
Включить удаленно | Разрешает удаленный доступ к пространству имен.
Прочесть безопасность | Разрешает доступ на чтение к данным безопасности WMI.
Изменение правил безопасности | Разрешает доступ на чтение и запись к данным безопасности WMI.

Примечания

  • Чтобы открыть консоль «Элемент управления WMI», нажмите кнопку Пуск, выберите команду Выполнить, введите wmimgmt.msc и нажмите кнопку OK.
  • Для выполнения данной задачи необходимо на управляемом компьютере быть администратором или членом группы администраторов, либо иметь соответствующие разрешения.
  • Допускается задание разрешений на удаленном и локальном компьютерах. Для доступа к удаленному компьютеру щелкните правой кнопкой Управляющий элемент WMI, выберите команду Подключение к другому компьютеру, установите переключатель в положение к другому компьютеру, а затем введите имя компьютера, к которому нужно подключиться. При работе с элементом управления WMI в консоли «Управление компьютером» для подключения к другому компьютеру щелкните правой кнопкой мыши значок Управление компьютером.
  • Допускается подключение к компьютеру в качестве другого пользователя, если у вас имеется несколько имен для входа в систему. Для подключения в качестве другого пользователя выберите вкладку Общие, нажмите кнопку Изменить, снимите флажок Войти под именем текущего пользователя, а затем введите имя пользователя и пароль.
  • На компьютерах с системой Windows 95, Windows 98 или Windows Millennium Edition все пользователи имеют полный доступ к локальной системе. Настройка безопасности относится только к удаленному подключению к компьютеру с системой Windows 95, Windows 98 или Windows Millennium Edition.
  • Чтобы закрыть доступ пользователю или группе к службам WMI, выделите этого пользователя или группу и нажмите кнопку Удалить.

См. также


Изменение разрешений или удаление авторизованных пользователей

Чтобы изменить разрешения или удалить авторизованных пользователей

  1. Откройте оснастку Элемент управления WMI.
  2. В дереве консоли щелкните правой кнопкой мыши значок Элемент управления WMI и выберите команду Свойства.
  3. Выберите вкладку Безопасность.
  4. Выберите пространство имен, для которого необходимо изменить разрешения пользователя или группы либо удалить пользователя или группу, а затем нажмите кнопку Безопасность.
  5. В диалоговом окне Безопасность в группе Имя выберите пользователя или группу, которых нужно удалить или для которых нужно изменить разрешения.
  6. Выполните одно из следующих действий.
    • Чтобы удалить пользователя или группу, нажмите кнопку Удалить.
    • Чтобы изменить параметры безопасности, в группе Разрешения задайте разрешения для пользователя или группы, сняв или установив соответствующие флажки.

Примечания

  • Для выполнения данной задачи необходимо на управляемом компьютере быть администратором или членом группы администраторов, либо иметь соответствующие разрешения.
  • Чтобы открыть консоль «Элемент управления WMI», нажмите кнопку Пуск, выберите команду Выполнить, введите wmimgmt.msc и нажмите кнопку OK.
  • Безопасность WMI проверяется только тогда, когда пользователь подключается к службе управления Windows. Таким образом, любые изменения, сделанные в разрешениях подключенного пользователя, не вступят в силу до следующего входа пользователя в WMI. Например, если доступ пользователя отозван, изменения не вступят в силу до тех пор, пока пользователь не выйдет из службы управления Windows и не попытается войти вновь.
  • Допускается изменение разрешений пользователя или группы на удаленном или локальном компьютере. Для доступа к удаленному компьютеру щелкните правой кнопкой Элемент управления WMI, выберите команду Подключение к другому компьютеру, установите переключатель в положение к другому компьютеру, а затем введите имя компьютера, к которому нужно подключиться. При работе с элементом управления WMI в консоли «Управление компьютером» для подключения к другому компьютеру щелкните правой кнопкой мыши значок Управление компьютером.
  • Допускается подключение к компьютеру в качестве другого пользователя, если у вас имеется несколько имен для входа в систему. Для подключения в качестве другого пользователя выберите вкладку Общие, нажмите кнопку Изменить, снимите флажок Войти под именем текущего пользователя, а затем введите имя пользователя и пароль.

См. также