Общие сведения о программе «Блокнот»

Блокнот — это несложный текстовый редактор, используемый для создания простых документов. Наиболее часто программа «Блокнот» используется для просмотра и редактирования текстовых (TXT) файлов, но многие пользователи применяют программу «Блокнот» в качестве простого инструмента для создания веб-страниц.

Программа «Блокнот» поддерживает только основное форматирование, поэтому случайное сохранение специального форматирования в документах, в которых должен остаться чистый текст, исключено. Это особенно полезно при создании HTML-документов для веб-страниц, так как особые знаки или другое форматирование могут не отображаться на опубликованных веб-страницах и даже могут приводить к возникновению ошибок.

Файлы программы «Блокнот» могут быть сохранены в следующих кодировках: Юникод, ANSI, UTF-8 или Юникод Big Endian. Эти форматы обеспечивают большую гибкость при работе с документами, использующими различные наборы знаков.

См. также


Поиск символов или слов

Рисунок Microsoft Windows

Чтобы найти конкретный символ или слово

  1. В меню Правка выберите команду Найти.
  2. В поле Что введите фрагмент текста, который требуется найти.
  3. Нажмите кнопку Найти далее.

Примечания

  • Чтобы найти текст с учетом верхнего и нижнего регистра букв, заданных в поле Что, установите флажок С учетом регистра .
  • Можно задать направление поиска относительно текущей позиции курсора. В группе Направление выберите Вверх для поиска в направлении начала документа. Выберите Вниз для поиска в направлении конца документа.


Поиск и замена символов или слов

Чтобы найти и заменить символы или слова

  1. Выберите в меню Правка команду Заменить.
  2. В поле Что введите символы или слова, которые требуется найти.
  3. В поле Чем введите текст, на который требуется заменить искомый текст.
  4. Чтобы заменить сразу все вхождения искомого текста, нажмите кнопку Заменить все. Чтобы заменять вхождения по одному, нажимайте кнопку Найти далее, а затем кнопку Заменить.


Включение режима переноса слов

Чтобы включить перенос по словам

  • В меню Формат выберите команду Перенос по словам.

Примечания

  • При включении режима переноса по словам слева от этой команды в меню появляется метка.
  • Перенос текста по словам облегчает чтение текста, но не влияет на внешний вид документа при выводе на печать.


Переход к конкретной строке

Чтобы перейти к конкретной строке

  1. В меню Правка выберите команду Перейти.
  2. В поле Переход на строку введите номер строки, в которую требуется переместить курсор.

Примечания

  • Чтобы эта команда работала, строки документа не обязательно должны быть пронумерованы.
  • Счет строк ведется сверху вниз по левому полю, начиная с начала документа.


Вырезание, копирование, вставка и удаление текста

Чтобы вырезать, скопировать, вставить или удалить текст

  • Чтобы вырезать фрагмент текста для переноса в другое место, выделите нужный текст, а затем выберите в меню Правка команду Вырезать.
  • Чтобы скопировать фрагмент текста для его вставки в другое место, выделите нужный текст, а затем выберите в меню Правка команду Копировать.
  • Чтобы вставить скопированный или вырезанный фрагмент текста, поместите курсор в место вставки, а затем выберите в меню Правка команду Вставить.
  • Чтобы удалить текст, выделите его и выберите в меню Правка команду Удалить.


Изменение начертания и размера шрифта

Чтобы изменить начертание и размер шрифта

  1. В меню Формат выберите команду Шрифт.
  2. Выберите нужные значения в полях Шрифт, Начертание и Размер.

Примечание

  • Пример того, как будет выглядеть выбранныйшрифт, отображается в поле Образец.


Создание колонтитулов

Чтобы создать нижний или верхний колонтитул

  1. В меню Файл выберите команду Параметры страницы.
  2. В поле Верхний колонтитул или Нижний колонтитул введите сочетание букв или символов из следующей таблицы.
    3. Действие | Параметр
Вставка имени открываемого файла или вывод (Безымянный), если имя файлу не присвоено. | &Ф
Вставка даты. | &Д
Вставка времени по часам компьютера. | &В
Вставка номеров страниц. | &С
Вставка символа амперсанда (&). | &&
Выровнять верхний колонтитул по левому краю, центру или правому краю. | &л, &ц или &п

Примечания

  • В полях верхнего и нижнего колонтитула можно вводить несколько сочетаний символов. Оставьте один или два пробела между сочетаниями, чтобы верхний и нижний колонтитулы легче читались.
  • Чтобы выровнять текст по левому краю, центру или правому краю, введите л, ц или &п в поле Верхний колонтитул или Нижний колонтитул, а затем любые другие комбинации, которые предполагается использовать.
  • Допускается также использование дополнительного текста. Например, Страница&p задает печать заголовков Страница 1, Страница 2 и так далее.


Изменение способа отображения напечатанного документа

Чтобы изменить способ отображения напечатанного документа

  1. В меню Файл выберите команду Параметры страницы.
  2. В диалоговом окне Параметры страницы выполните одно из следующих действий.
    • Чтобы изменить размер бумаги, выберите нужный размер из списка Размер.
    • Чтобы сменить источник бумаги, выберите имя лотка или податчика из раскрывающегося списка Подача.
    • Чтобы напечатать документ вертикально, выберите параметр Книжная; для горизонтальной печати выберите параметр Альбомная.
    • Чтобы изменить поля, введите значения ширины в группе Поля.
    • Чтобы изменить настройки принтера, нажмите кнопку Принтер.


Печать документа программы «Блокнот»

Чтобы вывести документ программы «Блокнот» на печать

  1. В меню Файл выберите команду Печать.
  2. На вкладке Общие выберите принтер и необходимые параметры, а затем нажмите кнопку Печать.

Примечание

  • Чтобы изменить отображение напечатанного документа, воспользуйтесь командой Параметры страницы в меню Файл.


Вставка в документ времени и даты

Чтобы вставить в документ время и дату

  1. Переместите курсор в нужное место вставки времени и даты.
  2. В меню Правка выберите команду Дата/время.


Ведение журнала использования документа

Чтобы вести журнал использования документа

  1. В первой строке документа программы «Блокнот», начиная с первой позиции, введите следующее расширение (прописные буквы и точка обязательны):

    .LOG

  2. В меню Файл выберите команду Сохранить.

Примечание

  • При каждом открытии этого документа программа «Блокнот» будет добавлять в конец файла текущие значения даты и времени по часам компьютера.


Использование различных языковых форматов в программе «Блокнот»

Программа «Блокнот» позволяет создавать и открывать документы в нескольких различных форматах: ANSI, Юникод, Юникод Big Еndian и UTF-8. Это обеспечивает возможность работы с документами, использующими различные наборы знаков.

По умолчанию документы сохраняются как стандартный текст ANSI.

Юникод включает в себя все основные наборы символов. В него включены наборы символов, общие для использования в компьютерной и деловой среде. При сохранении документа в кодировке Юникод допускается использование управляющих символов для облегчения выбора направления письма и расположения текста для таких языков, как арабский или иврит.

Некоторые шрифты не позволяют отображать все символы кодировки Юникод. Если в текстовом файле не хватает некоторых символов, шрифт может быть изменен на другой, включающий эти символы. Обычно для символов кодировки Юникод подходит шрифт Microsoft Sans Serif.

Байты (единица хранения данных) слова в документе, созданном в кодировке Юникод при помощи таких процессоров, как, например, Macintosh, располагаются в порядке, обратном по отношению к порядку байтов в словах документов, создаваемых при помощи процессора Intel. Наиболее значимые байты хранятся первыми с прямым порядком хранения. Чтобы документы были доступны пользователям компьютеров такого типа, необходимо сохранить файл программы «Блокнот» в формате Юникод Big Endian.

UTF означает универсальный формат преобразования наборов знаков. UTF-8 представляет собой 8-битную форму Юникода. Сохраните документ в формате UTF-8, если используется старые носители, поддерживающие только 8 значащих бит в отдельном байте.

Дополнительные сведения об этих форматах можно найти на веб-узле Unicode Consortium.

Примечание

  • XOX