Общие сведения о программе «Архивация»

Программа архивации позволяет защитить данные от случайной утери в случае, если в системе возникнет сбой оборудования или носителя. Например, с помощью программы архивации можно создать резервную копию данных на жестком диске, а затем создать архив на другом устройстве хранения данных. Носителем архива может быть логический диск (например, жесткий диск), отдельное устройство (такое, как съемный диск) или целая библиотека дисков или лент, объединенная в пул носителей и управляемая сменщиком Robotic. При случайном удалении или замене исходных данных на жестком диске из-за его сбоя данные могут быть легко восстановлены из архивной копии.

Программа архивации создает снимок состояния тома, представляющий собой точную копию содержимого жесткого диска на определенный момент времени, в том числе всех открытых файлов, используемых системой. Во время выполнения программы архивации пользователи могут продолжать работу с системой без риска потери данных.

Дополнительные сведения о снимках состояния томов см. в разделе Общие сведения о снимке состояния тома.

Программа архивации предоставляет следующие возможности.

  • Архивация выбранных файлов и папок на жестком диске.
  • Восстановление архивированных файлов и папок на локальный жесткий диск или любой другой доступный диск.
  • Использование средства аварийного восстановления системы для сохранения и восстановления всех системных файлов и параметров конфигурации, необходимых для восстановления системы после сбоя.
  • Создание копии данных из любого внешнего хранилища или данных, хранящихся на присоединенных дисках.
  • Создание копии данных состояния системы локального компьютера, включающих реестр, службы компонентов, базу данных Active Directory и базу данных служб сертификации.
  • Создание копии системного раздела, загрузочного раздела и файлов, необходимых для загрузки системы в случае сбоя компьютера или сети.
  • Планирование периодического выполнения архивации для получения текущих версий архивов.

Программа архивации позволяет архивировать и восстанавливать данные на томах с файловыми системами FAT и NTFS. Данные, архивированные с тома NTFS XOX, рекомендуется восстанавливать также на том NTFS XOX. В противном случае могут быть утеряны данные, а также некоторые атрибуты файлов и папок, такие, как разрешения, параметры шифрованной файловой системы, сведения о дисковых квотах, присоединенных дисках и внешних хранилищах.

Примечание

  • Программа архивации выполняет простые функции по управлению носителями, например форматирование. Более сложные задачи управления, такие, как присоединение и отсоединение лент или дисков, выполняются службой «Съемные ЗУ». Дополнительные сведения о службе «Съемные ЗУ» см. в разделе Общие сведения о съемных носителях.


Решение задач для архивации

Рисунок Microsoft Windows

Решение задач

При использовании программы архивации часто выполняются следующие задачи. Чтобы найти конкретное слово или фразу, перейдите на вкладку Указатель или Поиск.

Архивация файлов и папок в файл или на ленту

Программа архивации позволяет архивировать файлы и папки на случай сбоя жесткого диска или случайного удаления файлов.

Пошаговые инструкции

Дополнительные сведения

Восстановление файлов и папок из файла или с ленты

Программа архивации позволяет восстанавливать архивированные файлы и папки.

Пошаговые инструкции

Дополнительные сведения

Архивация данных состояния системы

Программа архивации позволяет архивировать копии важных системных компонентов, таких, как реестр, загрузочные файлы и база данных службы каталогов Active Directory.

Пошаговые инструкции

Дополнительные сведения

Восстановление данных состояния системы

Программа архивации позволяет восстанавливать копии важных системных компонентов, таких, как реестр, загрузочные файлы и база данных службы каталогов Active Directory.

Пошаговые инструкции

Дополнительные сведения


Архивация файлов и папок

В процессе архивации в файле или на ленте создается резервная копия данных. Для архивации в файл необходимо задать имя файла и место, где он будет сохранен. Файлы архива обычно имеют расширение BKF, но его можно сменить на любое другое. Файл архива можно сохранить на жестком диске, дискете или на любом другом съемном либо несъемном носителе, на котором возможно сохранение файлов.

Для архивации данных на ленту необходимо, чтобы к компьютеру было подключен накопитель на магнитной ленте. Для управления накопителями на магнитной ленте используется оснастка Съемные ЗУ. Хотя программа архивации работает совместно со службой «Съемные ЗУ», для выполнения некоторых сопровождающих действий, например для подготовки и извлечения лент, может потребоваться оснастка «Съемные ЗУ».

Следующие четыре шага описывают простую операцию архивации.

Выберите файлы, папки и диски для архивации

В программе архивации диски, файлы и папки компьютера представлены в виде дерева, позволяющего выбирать файлы и папки для архивации. Открытие папок и выбор файлов в этом дереве выполняется так же, как и в проводнике Windows.

Выберите носитель или файл для создания архива данных

Есть два способа выбора носителя.

Архив данных можно создать в файле или на устройстве хранения данных. В качестве устройства хранения данных можно использовать жесткий диск, диск Zip либо съемный или несъемный носитель любого типа, доступный для сохранения файлов. Этот вариант доступен всегда.

Архив данных можно создать на накопителе на магнитной ленте. Этот вариант доступен только при наличии накопителя на магнитной ленте, установленного на компьютере или подключенного к нему. Если данные архивируются на накопитель на магнитной ленте, этот носитель будет управляться оснасткой «Съемные ЗУ».

Задайте параметры архивации

Окно Параметры программы архивации позволяет настраивать параметры архивации. Чтобы настроить архивацию, выполните в окне Параметры следующие действия.

Выберите требуемый тип архивации. Существуют следующие типы архивации: копирующий, ежедневный, разностный, добавочный и обычный.

Укажите, требуется ли вести журнал архивации. Если ведется файл журнала, можно также выбрать запись всех либо только основных событий.

Укажите, требуется ли архивировать данные, хранящиеся на присоединенных дисках.

Назначьте типы файлов, которые требуется исключить из операции архивирования.

Укажите, требуется ли проверять правильность архивации данных.

Начните архивацию

При запуске архивации будут запрошены сведения о текущем задании архивации и предоставлена возможность задать дополнительные параметры. После того как сведения о задании будут введены или изменены, будет начата архивация выбранных файлов и папок.

Если запланирована автоматическая архивация, сведения о задании все равно будут запрошены. Однако после ввода этих сведений архивация не будет начата, а будет добавлена как запланированная в планировщик заданий.

Примечания

  • Архивация файлов и папок может проводиться только администратором или оператором архива. Пользователи, не являющиеся членами группы «Пользователи» или «Опытные пользователи», могут архивировать только свои собственные файлы и папки либо должны иметь не менее одного из следующих разрешений на доступ к архивируемым файлам и папкам: «Чтение», «Чтение и выполнение», «Изменение» или «Полный доступ». Для получения дополнительных сведений о разрешениях и правах пользователей щелкните ссылку См. также.
  • Данные состояния системы включают системный реестр, службу каталогов и другие ключевые системные компоненты. Для архивации этих компонентов следует выполнить архивацию данных состояния системы.
  • Архивация данных состояния системы возможна только для локального компьютера. Архивировать данные состояния системы для удаленного компьютера нельзя.
  • Архивацию можно запланировать для автоматического выполнения в определенное время или с определенной периодичностью. Чтобы сделать это, нажмите кнопку Запуск.
  • Если на данном компьютере запущены службы Windows Media и требуется выполнить архивацию файлов этих служб, ознакомьтесь с разделом о выполнении архивации служб Windows Media электронной документации по службам Windows Media. Для архивации или восстановления файлов служб WindowsMedia следуйте инструкциям, приведенным в электронной документации по службам Windows Media.
  • Если для управления носителями используется оснастка «Съемные ЗУ» или для сохранения данных используется внешнее хранилище, следует регулярно архивировать файлы, находящиеся в следующих папках:

    СистемныйКорневойКаталог\System32\Ntmsdata

    СистемныйКорневойКаталог\System32\Remotestorage

    Это будет гарантировать возможность восстановления всех данных, сохраненных во внешнем хранилище и на съемном ЗУ.

См. также


Типы архивации

Программа архивации поддерживает пять способов архивации данных на компьютере или в сети.

Копирующая архивация

Копирование всех выбранных файлов без отметки их как архивированных (атрибут «Архивный» не снимается). Копирование используется, когда требуется выполнить архивирование отдельных файлов в промежутке между созданием обычных и добавочных архивов, поскольку оно не влияет на другие операции архивирования.

Ежедневная архивация

Копирование всех файлов, измененных в течение дня до выполнения ежедневной архивации. Обработанные файлы не помечаются как архивированные (атрибут «Архивный» не снимается).

Разностная архивация

Архивация файлов, созданных или измененных со времени последней обычной или добавочной архивации. Файлы не помечаются как архивированные (атрибут «Архивный» не снимается). При создании обычного и разностного архива для восстановления файлов и папок потребуется наличие как последнего обычного, так и последнего разностного архива.

Добавочная архивация

Архивация только файлов, созданных или измененных с момента последней обычной или добавочной архивации. Файлы помечаются как архивированные (атрибут «Архивный» снимается). При использовании и обычного, и добавочного архива для восстановления данных потребуется наличие как последнего обычного, так и всех добавочных архивов.

Обычная архивация

Архивация всех выбранных файлов с отметкой их как архивированных (атрибут «Архивный» снимается). При выполнении обычной архивации для восстановления всех файлов требуется наличие только последней копии файла или ленты архива. Как правило, при первом создании архива выполняется обычная архивация.

Архивация данных с использованием и обычных, и добавочных архивов требует меньше всего места для хранения архивов и является самым быстрым способом архивации. Однако восстановление файлов может занять много времени, так как архив может храниться на нескольких дисках или лентах.

Архивация данных с использованием и обычных, и разностных архивов занимает больше времени, особенно при частом изменении данных, но она упрощает процесс восстановления данных, так как весь архив обычно хранится на небольшом количестве дисков или лент.


Архивация файлов в файл или на ленту

Чтобы заархивировать файлы в файл или на ленту

С помощью интерфейса Windows

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. Перейдите на вкладку Архивация и выберите в меню Задание команду Создать.
  4. Выберите файлы и папки для архивации, установив флажки в списке Установите флажки для всех объектов, которые вы хотите заархивировать.
  5. В списке Местоназначение архива выберите один из вариантов.
    • Для архивации файлов или папок в файл выберите Файл. Этот вариант выбран по умолчанию.
    • Для архивации файлов и папок на ленту выберите накопитель на магнитной ленте.
  6. В поле Носитель архива или имя файла выполните одно из следующих действий.
    • Для архивации файлов и папок в файл введите путь и имя файла архива (BKF) или нажмите кнопку Обзор, чтобы найти его.
    • Для архивации файлов и папок на ленту выберите нужную ленту.
  7. Задайте параметры тип архива и тип журнала, выбрав в меню Сервис команду Параметры. Установив нужные значения параметров архивации, нажмите кнопку ОК.
  8. Нажмите кнопку Архивировать и внесите изменения в диалоговом окне Сведения о задании архивации.
  9. Чтобы задать дополнительные параметры архивации, например проверку данных или аппаратное сжатие, нажмите кнопку Дополнительно. Установив нужные значения, нажмите кнопку ОК. Более подробные сведения о дополнительных параметрах архивации см. в разделе Задание дополнительных параметров архивации.
  10. Чтобы начать архивацию, нажмите кнопку Архивировать.

Внимание!

  • Программа архивации позволяет архивировать данные с томов FAT16, FAT32 и NTFS. Данные, архивированные с тома NTFS XOX, рекомендуется восстанавливать также на том NTFS XOX; в противном случае могут быть утеряны данные и свойства файлов и папок. Некоторые файловые системы могут поддерживать не все средства других файловых систем. Например, при восстановлении на томе FAT или томе NTFS Windows NT 4.0 данных, архивированных с тома NTFS XOX, будут утеряны разрешения, параметры шифрованной файловой системы (EFS), сведения о дисковых квотах, присоединенных дисках и внешних хранилищах.
  • Для архивации и восстановления файлов базы данных Microsoft SQL Server рекомендуется использовать встроенные служебные программы архивации и восстановления SQL. Дополнительные сведения см. в документации Microsoft SQL Server.
  • Некоторые накопители на магнитной ленте могут не поддерживать аппаратное сжатие.

Примечания

  • Архивация файлов и папок может проводиться только администратором или оператором архива. Для получения дополнительных сведений о разрешениях и правах пользователей щелкните ссылку См. также.
  • XOX
  • Если мастер архивации и восстановления не запускается по умолчанию, для его использования выберите в меню Сервис команду Мастер восстановления.
  • Для архивации системы следует заархивировать все данные на компьютере плюс данные состояния системы, к которым относятся, например, реестр и база данных службы каталогов Active Directory.
  • Архивация данных состояния системы возможна только для локального компьютера. Для удаленного компьютера архивировать данные состояния системы нельзя.
  • Файлы архива обычно имеют расширение BKF, хотя можно использовать любое расширение.
  • Операторы архива и администраторы могут архивировать и восстанавливать зашифрованные файлы и папки, не расшифровывая их.
  • Если на данном компьютере запущены службы мультимедиа Windows и требуется выполнить архивацию или восстановление файлов этих служб, ознакомьтесь с соответствующим разделом электронной документации по службам Windows Media и следуйте приведенным в ней инструкциям.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Чтобы выполнить архивацию в файл или на ленту, введите:

    ntbackup backup @имя bks-файла /J "имя задания архивации" /F "имя файла" /T "имя ленты" /P "имя пула" /G "идентификатор guid" /N "носитель" /A

Значение | Описание
@имя bks-файла | Имя файла (с расширением BKS) со списком файлов для использования в данном задании архивации. Перед именем файла должен стоять символ @. Этот файл содержит сведения о файлах и папках, подлежащих архивации. Он должен быть создан при помощи программы архивации с графическим интерфейсом. Можно вместо этого указать путь диска или файла для архивации, например «D:\»
/J "имя задания архивации" | Имя задания, которое будет упоминаться в файле журнала. Обычно оно описывает файлы и папки, подлежащие архивации в текущем задании, а также содержит дату и время архивации
/F "имя файла" | Задает путь логического диска и имя файла журнала. Вместе с этим параметром не следует использовать следующие параметры: /P /G /T
/T "имя ленты" | Добавление или замена данных на ленте
/P "имя пула" | Пул носителей, носитель из которого будет использован. Обычно это подпул пула носителей архивации, например 4-мм DDS. Не следует использовать вместе с параметрами: /A /G /F /T
/G "идентификатор guid" | Добавление или замена данных на ленте. Этот параметр не следует использовать вместе с параметром /P
/N "носитель" | Новое имя ленты. Не следует использовать вместе с параметром /A
/A | Архивация с добавлением в архив. Этот параметр используется вместе с параметром /G или /T. Не следует использовать его вместе с параметром /P
Сведения о других параметрах архивации в файл и на ленту см. в разделе Служебная программа командной строки ntbackup.

Например, чтобы под именем "Задание 1" задать архивацию всех файлов и папок с локального диска D:\ в файл C:\backup.bkf, введите:

ntbackup backup D:\ /J "Задание 1" /F "C:\backup.bkf"

Все другие параметры будут взяты из настроек программы архивации.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис данной команды, введите в командной строке:

    ntbackup /?

  • Если другие параметры архивации не указаны, при выполнении команды ntbackup будут по умолчанию использованы тип архива, параметры проверки, уровень ведения журнала, аппаратное сжатие и другие параметры, заданные в программе архивации.


Данные состояния системы

Программа архивации позволяет архивировать и восстанавливать следующие системные компоненты:

  • реестр;
  • базу данных регистрации классов COM+;
  • загрузочные файлы, в том числе системные файлы;
  • базу данных служб сертификации;
  • службу каталогов Active Directory;
  • каталог SYSVOL;
  • сведения о службе кластеров;
  • метакаталог IIS;
  • защищенные системные файлы Windows.

При архивации эти компоненты называются данными состояния системы. Точный перечень компонентов, образующих данные состояния системы, зависит от операционной системы и конфигурации компьютера.

XOX

Данные состояния системы включают только реестр, базу данных регистрации классов COM+, защищенные файлы Windows и загрузочные файлы.

Семейство Windows 2000 Server

Данные состояния системы включают реестр, базу данных регистрации классов COM+, защищенные файлы Windows и загрузочные файлы. В зависимости от конфигурации сервера в этот перечень могут быть включены и другие данные. Например, если сервер используется в качестве сервера сертификации, данные состояния системы включают в себя также базу данных служб сертификации. Если сервер является контроллером домена, данные состояния системы включают Active Directory и каталог SYSVOL.

Кроме того, если на контроллере домена работает служба DNS, часть данных состояния системы, относящаяся к Active Directory, содержит также сведения о зоне DNS, интегрированные в сервер домена. Сведения о зоне DNS, не интегрированные в сервер домена, по умолчанию сохраняемые в виде файлов *.dns в каталоге \WINDOWS\SYSTEM32\DNS, являются частью загрузочного тома и будут включены при выполнении полной архивации компьютера.

Если на сервере работает служба кластеров, данные состояния системы будут включать в себя дополнительно все контрольные точки реестра ресурсов и журнал восстановления ресурса кворума, содержащий последние сведения базы данных кластера.

Архивация данных состояния системы

Архивация или восстановление данных состояния системы выполняется сразу для всех данных состояния системы локального компьютера. Нельзя выполнить архивацию или восстановление отдельных компонентов данных, поскольку компоненты состояния системы взаимосвязаны. Однако можно восстановить данные состояния системы в альтернативное размещение. В этом случае будут восстановлены лишь файлы реестра, файлы каталога SYSVOL, файлы сведений о базе данных кластера и системные загрузочные файлы. База данных службы каталогов Active Directory, база данных служб сертификации и база данных регистрации классов COM+ при указании альтернативного размещения восстановлены не будут.

Примечания

  • Для архивации файлов и папок необходимо обладать определенными разрешениями или правами пользователя.
  • Для восстановления данных состояния системы контроллера домена необходимо предварительно запустить компьютер в режиме восстановления службы каталогов. Это позволит восстановить каталог SYSVOL и службу Active Directory.
  • Для архивации и восстановления данных состояния системы необходимо быть администратором. Архивация и восстановление данных состояния системы возможны только для локального компьютера. Архивировать и восстанавливать данные состояния системы для удаленного компьютера нельзя.
  • Поскольку нельзя выбрать компоненты состояния системы для архивации, можно архивировать только все защищенные системные файлы, включенные в данные состояния системы, установив дополнительные параметры архивации. XOX


Архивация данных состояния системы

Чтобы заархивировать данные состояния системы

С помощью интерфейса Windows

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. Перейдите на вкладку Архивация и установите в списке Установите флажки для всех объектов, которые вы хотите заархивировать флажок для объекта Состояние системы. Это позволит заархивировать данные состояния системы вместе с остальными данными, отмеченными в текущем задании архивации.

Внимание!

  • Архивные копии данных состояния системы всегда должны быть свежими и надежными.

Примечания

  • Архивация файлов и папок может проводиться только администратором или оператором архива. Для получения дополнительных сведений о разрешениях и правах пользователей щелкните ссылку См. также.
  • XOX
  • Если мастер архивации и восстановления не запускается по умолчанию, для его использования выберите в меню Сервис команду Мастер восстановления.
  • Если архивация данных состояния системы выполняется на ленту и программе архивации не удается найти свободные носители, воспользуйтесь службой Съемные ЗУ для добавления ленты в пул носителей архивации, чтобы программа архивации могла ее использовать. Для получения дополнительных сведений о съемных носителях щелкните ссылку См. также.
  • Архивация данных состояния системы возможна только для локального компьютера. Данные состояния системы для удаленного компьютера архивировать нельзя.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Чтобы выполнить архивацию данных состояния системы, введите:
    ntbackup backup systemstate
Значение | Описание
systemstate | Указание, что следует выполнить архивацию данных состояния системы. При выборе данного параметра будет установлен копирующий тип архива
Сведения о других параметрах архивации см. в разделе Служебная программа командной строки ntbackup.

Например, чтобы под именем "Задание 1" задать архивацию данных состояния системы в файл C:\backup.bkf, введите:

ntbackup backup systemstate /J "Задание 1" /F "C:\backup.bkf"

Все другие параметры будут взяты из настроек программы архивации.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис данной команды, введите в командной строке следующую команду:

    ntbackup /?

  • Если другие параметры архивации не указаны, при выполнении команды ntbackup будут по умолчанию использованы тип архива, параметры проверки, уровень ведения журнала, аппаратное сжатие и другие параметры, заданные в программе архивации.


Планирование архивации

Чтобы запланировать архивацию

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. Перейдите на вкладку Архивация и выберите в меню Задание команду Создать.
  4. Выберите файлы и папки для архивации, установив флажки в списке Установите флажки для всех объектов, которые вы хотите заархивировать.
  5. Выберите в списке Размещение архива пункт Файл или накопитель на магнитной ленте и сохраните список выбранных файлов и папок, выбрав в меню Задание команду Сохранить выделенные.
  6. В поле Носитель архива или имя файла введите путь и имя файла архива или выберите ленту.
  7. Задайте параметры архивации — тип архива и тип журнала, выбрав в меню Сервис команду Параметры. После этого нажмите кнопку ОК.
  8. Нажмите кнопку Запуск и внесите изменения в диалоговом окне Сведения о задании архивации.
  9. Чтобы задать дополнительные параметры архивации, например проверку данных или аппаратное сжатие, нажмите кнопку Дополнительно. Завершив задание дополнительных параметров, нажмите кнопку ОК.

    Более подробные сведения о настройке дополнительных параметров архивации см. в разделе Задание дополнительных параметров архивации.

  10. В диалоговом окне Сведения о задании архивации нажмите кнопку Расписание.
  11. В диалоговом окне Указание учетной записи введите имя и пароль пользователя, учетная запись которого будет использована при выполнении данного запланированного задания архивации.
  12. В поле Имя задания диалогового окна Параметры запланированного задания введите имя данного задания архивации и нажмите кнопку Свойства, чтобы указать дату, время и частоту выполнения этого задания. По завершении нажмите кнопку ОК, затем еще раз нажмите кнопку ОК.

Внимание!

  • Программа архивации позволяет архивировать данные с томов FAT16, FAT32 и NTFS. Данные, архивированные с тома NTFS XOX, рекомендуется восстанавливать также на том NTFS XOX; в противном случае могут быть утеряны данные и свойства файлов и папок. Некоторые файловые системы могут поддерживать не все средства других файловых систем. Например, при восстановлении на томе FAT или томе NTFS Windows NT 4.0 данных, архивированных с тома NTFS XOX, будут утеряны разрешения, параметры шифрованной файловой системы (EFS), сведения о дисковых квотах, присоединенных дисках и внешних хранилищах.

Примечания

  • Архивация файлов и папок может проводиться только администратором или оператором архива. Для получения дополнительных сведений о разрешениях и правах пользователей щелкните ссылку См. также.
  • XOX
  • Если планируется архивация на ленту, воспользуйтесь службой Съемные ЗУ, чтобы убедиться, что эта лента доступна в пуле носителей архивации. Для получения дополнительных сведений о съемных носителях щелкните ссылку См. также.
  • Для возможности планирования заданий должна быть запущена служба планировщика заданий. Чтобы запустить ее, откройте окно командной строки и введите net start schedule. Запуск, остановку и просмотр состояния служб можно также осуществлять в разделе «Службы» оснастки «Управление компьютером».
  • Чтобы заархивировать данные состояния системы, включающие такие компоненты, как реестр и служба каталогов Active Directory, необходимо установить флажок Состояние системы в списке Установите флажки для всех объектов, которые вы хотите заархивировать.
  • Архивация данных состояния системы возможна только для локального компьютера. Данные состояния системы для удаленного компьютера архивировать нельзя.
  • В диалоговом окне Параметры запланированного задания можно удалить запланированное задание архивации, нажав кнопку Удалить.
  • После того, как задание запланировано, его параметры можно изменить, перейдя на вкладку Запланированные задания и щелкнув значок архива, отображающийся в календаре.
  • Операторы архива и администраторы могут архивировать и восстанавливать зашифрованные файлы и папки, не расшифровывая их.
  • Если на данном компьютере запущены службы мультимедиа Windows и требуется выполнить архивацию файлов этих служб, ознакомьтесь с соответствующим разделом электронной документации по службам Windows Media и следуйте приведенным в ней инструкциям.


Архивация данных с использованием пакетных файлов

Архивация может выполняться из пакетного файла с помощью команды ntbackup и различных параметров командной строки. Однако есть два важных ограничения архивации данных с использованием пакетных файлов.

  • С помощью команды ntbackup можно архивировать только папки целиком. Нельзя проводить архивацию отдельных файлов. Однако в командной строке можно указать файл с расширением BKS, который содержит список файлов, подлежащих архивации. Для архивации выбранных файлов необходимо наличие программы архивации с графическим интерфейсом.
  • Команда ntbackup не поддерживает использование подстановочных знаков. Например, при задании шаблона *.txt архивация файлов с расширением TXT выполнена не будет.


Восстановление файлов и папок

Следующие четыре шага описывают простую операцию восстановления.

Выберите файлы и папки, которые требуется восстановить

В программе архивации диски, файлы и папки компьютера представлены в виде дерева архивированных файлов и папок, позволяющего выбирать объекты для восстановления. Открытие папок и выбор файлов в этом дереве выполняется так же, как и в проводнике.

Выберите размещение для восстановления файлов и папок из архива

Программа архивации позволяет выбрать одно из следующих трех размещений для восстанавливаемых файлов.

Данные можно восстановить в исходную папку (или папки), из которой была выполнена архивация. Этот параметр применяется при восстановлении поврежденных или утерянных файлов и папок.

Данные можно восстановить в любую альтернативную папку. Если выбран этот параметр, структура архивированных файлов и папок будет восстановлена в другой папке. Этот вариант подходит, если требуется извлечь несколько старых файлов, но нельзя заменять все остальные текущие файлы и папки на диске.

Архивированные файлы можно восстановить в одну папку. При этом не сохраняется структура архивированных файлов и папок: все архивированные файлы будут помещены в одну папку. Этот вариант удобен при поиске файла, если неизвестно его расположение.

Задайте параметры восстановления

Вкладка Восстановление диалогового окна Параметры позволяет выбрать способ восстановления файлов и папок. Выберите один из трех вариантов:

  • Не заменять файл на компьютере. Это предотвратит замену файлов, находящихся на жестком диске. Это самый безопасный режим восстановления файлов.

  • Заменять файл на компьютере только если он старее. Если со времени последней архивации данных были изменены какие-либо файлы, этот вариант восстановления будет гарантировать, что внесенные изменения не будут утеряны.

  • Всегда заменять файл на компьютере. Все файлы на жестком диске будут заменены файлами из архива. Если со времени последней архивации данных были изменены какие-либо файлы, все внесенные изменения будут утеряны.

Запустите процесс восстановления

Перед началом процесса восстановления будет выдан запрос на готовность к восстановлению данных. Можно также задать дополнительные параметры восстановления, такие, как восстановление настроек безопасности, базы данных съемных ЗУ и данных точек соединения.

Внимание!

  • Программа архивации позволяет архивировать данные с томов FAT16, FAT32 и NTFS. Данные, архивированные с тома NTFS XOX, рекомендуется восстанавливать также на том NTFS XOX; в противном случае могут быть утеряны данные и свойства файлов и папок. Некоторые файловые системы могут поддерживать не все средства других файловых систем. Например, при восстановлении на томе FAT или томе NTFS Windows NT 4.0 данных, архивированных с тома NTFS XOX, будут утеряны разрешения, параметры шифрованной файловой системы (EFS), сведения о дисковых квотах, присоединенных дисках и внешних хранилищах.

Примечания

  • Архивация файлов и папок может проводиться только администратором или оператором архива. Для получения дополнительных сведений о разрешениях и правах пользователей щелкните ссылку См. также.
  • Данные состояния системы включают реестр, службу каталогов Active Directory и другие ключевые системные компоненты. Для архивирования и восстановления этих компонентов следует выполнить архивирование данных состояния системы.
  • Если при восстановлении данных состояния системы не задано альтернативное размещение, данные состояния системы компьютера будут удалены и заменены восстанавливаемыми данными. Кроме того, при восстановлении данных состояния системы в альтернативное размещение в указанную папку будут восстановлены лишь файлы реестра, файлы каталога SYSVOL, файлы сведений о базе данных кластера и системные загрузочные файлы. База данных службы каталогов Active Directory, база данных служб сертификации и база данных регистрации классов COM+ при указании альтернативного размещения восстановлены не будут.
  • Для восстановления данных состояния системы контроллера домена необходимо предварительно запустить компьютер в режиме восстановления службы каталогов. Это позволит восстановить каталог SYSVOL и службу Active Directory.
  • Восстановление данных состояния системы возможно только на локальном компьютере. Восстановить данные состояния системы на удаленном компьютере нельзя.
  • Администраторы и операторы архива могут восстанавливать зашифрованные файлы и папки, не расшифровывая их.


Восстановление файлов из файла или с ленты

Чтобы восстановить файлы из файла или с ленты

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. Перейдите на вкладку Восстановление и управление носителем и в списке Установите флажки для всех объектов, которые вы хотите восстановить установите флажки для тех файлов и папок, которые требуется восстановить.
  4. В списке Восстановить файлы в выберите один из следующих вариантов.
    • Исходное размещение — восстановление файлов и папок из архива в папку (или папки), где они находились до архивации. Перейдите к шагу 6.
    • Альтернативное размещение — восстановление файлов и папок из архива в указанную папку. Этот параметр позволяет сохранить структуру папок архивных данных. Все архивные папки и подпапки будут созданы в указанном альтернативном размещении.
    • Единственная папка — восстановление файлов и папок из архива в указанную папку. При выборе этого параметра структура папок архивных данных не сохраняется. В указанной папке будут восстановлены только файлы.
  5. Если выбран вариант Альтернативное размещение или Единственная папка, введите в поле Альтернативное размещение путь к нужной папке или нажмите кнопку Обзор, чтобы найти ее.
  6. В меню Сервис выберите команду Параметры, перейдите на вкладку Восстановление и выполните одно из следующих действий.
    • Если в ходе восстановления не следует заменять файлы, уже имеющиеся на жестком диске, выберите вариант Не заменять файл на компьютере.
    • Если в ходе восстановления требуется заменить старые файлы на диске новыми файлами из архива, выберите вариант Заменять файл на компьютере только если он старее.
    • Если в ходе восстановления требуется заменять файлы на локальном диске независимо от того, как датированы файлы в архиве, выберите вариант Всегда заменять файл на компьютере.
  7. Нажмите кнопку OK, чтобы принять заданные параметры восстановления.
  8. Нажмите кнопку Восстановить.
  9. Если требуется изменить дополнительные параметры восстановления, например, восстановление настроек безопасности, базы данных съемных носителей или данных о точках соединений, нажмите кнопку Дополнительно. Завершив задание дополнительных параметров, нажмите кнопку ОК.
  10. Нажмите кнопку ОК, чтобы начать восстановление.

Внимание!

  • Если при восстановлении данных состояния системы не задано альтернативное размещение, данные состояния системы компьютера будут удалены и заменены восстанавливаемыми данными. Кроме того, при восстановлении данных состояния системы в альтернативное размещение в указанную папку будут восстановлены лишь файлы реестра, файлы каталога SYSVOL, файлы сведений о базе данных кластера и системные загрузочные файлы. База данных службы каталогов Active Directory, база данных служб сертификации и база данных регистрации классов служб компонентов при указании альтернативного размещения восстановлены не будут.
  • При выборе варианта Заменять файл на компьютере только если он старее могут быть заменены некоторые или все файлы, находящиеся на диске.
  • Выбор варианта Всегда заменять файл на компьютере может привести к потере данных, если файл, над которым ведется работа, содержится в архиве.
  • Программа архивации позволяет архивировать данные с томов FAT16, FAT32 и NTFS. Данные, архивированные с тома NTFS XOX, рекомендуется восстанавливать также на том NTFS XOX; в противном случае могут быть утеряны данные и свойства файлов и папок. Некоторые файловые системы могут поддерживать не все средства других файловых систем. Например, при восстановлении на томе FAT или томе NTFS Windows NT 4.0 данных, архивированных с тома NTFS XOX, будут утеряны разрешения, параметры шифрованной файловой системы (EFS), сведения о дисковых квотах, присоединенных дисках и внешних хранилищах.
  • Для архивации и восстановления файлов базы данных Microsoft SQL Server рекомендуется использовать встроенные служебные программы архивации и восстановления SQL. Дополнительные сведения см. в документации Microsoft SQL Server.

Примечания

  • Восстановление файлов и папок может проводиться только администратором или оператором архива. Для получения дополнительных сведений о разрешениях и правах пользователей щелкните ссылку См. также.
  • XOX
  • Для восстановления данных с ленты необходимо предварительно обновить ее каталог на носителе. Для получения дополнительных сведений об обновлении каталога щелкните ссылку См. также.
  • Для восстановления файлов можно также воспользоваться мастером восстановления, выбрав в меню Сервис команду Мастер восстановления.
  • Для восстановления данных состояния системы контроллера домена необходимо предварительно запустить компьютер в режиме восстановления службы каталогов. Это позволит восстановить каталог SYSVOL и базу данных службы каталогов Active Directory.
  • Восстановление данных состояния системы возможно только на локальном компьютере. Восстановить данные состояния системы на удаленном компьютере нельзя.
  • Операторы архива и администраторы могут архивировать и восстанавливать зашифрованные файлы и папки, не расшифровывая их.


Восстановление данных состояния системы

Чтобы восстановить данные состояния системы

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. Перейдите на вкладку Восстановление и управление носителем и установите в списке Установите флажки для всех объектов, которые вы хотите восстановить флажок для объекта Состояние системы. Это позволит восстановить данные состояния системы вместе с остальными данными, отмеченными в текущем задании восстановления.

Внимание!

  • Если при восстановлении данных состояния системы не задано альтернативное размещение, данные состояния системы компьютера будут удалены и заменены восстанавливаемыми данными. Кроме того, при восстановлении данных состояния системы в альтернативное размещение в указанную папку будут восстановлены лишь файлы реестра, файлы каталога SYSVOL, файлы сведений о базе данных кластера и системные загрузочные файлы. База данных службы каталогов Active Directory, база данных служб сертификации и база данных регистрации классов служб компонентов при указании альтернативного размещения восстановлены не будут.

Примечания

  • Восстановление файлов и папок может проводиться только администратором или оператором архива. Для получения дополнительных сведений о разрешениях и правах пользователей щелкните ссылку См. также.
  • XOX
  • Для восстановления данных с ленты необходимо предварительно обновить ее каталог на диске. Для получения дополнительных сведений об обновлении каталога щелкните ссылку См. также.
  • Восстановить данные состояния системы можно также с помощью мастера восстановления, выбрав в меню Сервис команду Мастер восстановления.
  • Для восстановления данных состояния системы контроллера домена необходимо запустить компьютер в специальном безопасном режиме, который называется режимом восстановления службы каталогов. Это позволит восстановить каталог SYSVOL и базу данных службы каталогов Active Directory. Для получения дополнительных сведений о запуске компьютера в безопасном режиме щелкните ссылку См. также.
  • Восстановление данных состояния системы возможно только на локальном компьютере. Восстановить данные состояния системы на удаленном компьютере нельзя.


Создание набора аварийного восстановления системы с помощью программы архивации

Чтобы создать набор аварийного восстановления системы с помощью программы архивации

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. Выберите в меню Сервис команду Мастер аварийного восстановления системы.
  4. Следуйте инструкциям, появляющимся на экране.

Внимание!

  • Необходимо иметь наготове дискету емкостью 1,44 мегабайта (Мбайт) для сохранения параметров системы и носитель для хранения файлов архива.

Примечания

  • XOX
  • В ходе данной процедуры архивируются только системные файлы, необходимые для загрузки системы. Сведения об архивировании данных см. в разделе Архивация файлов и папок.


Восстановление системы после сбоя с использованием средства аварийного восстановления системы

Чтобы восстановить систему после сбоя с использованием средства аварийного восстановления системы

  1. Перед началом процедуры восстановления убедитесь в наличии следующих элементов:
    • предварительно созданной дискеты аварийного восстановления системы;
    • предварительно созданного носителя архива;
    • исходного установочного компакт-диска операционной системы.
  2. Вставьте исходный установочный компакт-диск операционной системы в дисковод.
  3. Перезагрузите компьютер. При появлении на экране приглашения нажать клавишу для загрузки с компакт-диска нажмите соответствующую клавишу.
  4. Нажмите клавишу F2 при появлении соответствующего приглашения на текстовом этапе установки. Будет выведено приглашение вставить предварительно созданную дискету аварийного восстановления системы.
  5. Следуйте указаниям, появляющимся на экране.

Примечание

  • При аварийном восстановлении системы файлы данных не восстанавливаются. Для получения дополнительных сведений об архивировании и восстановлении файлов данных щелкните ссылку См. также.


Задание параметров архивации

Чтобы задать параметры архивации

С помощью интерфейса Windows

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. В меню Сервис выберите команду Параметры.
  4. На вкладке Общие установите нужные параметры.

Примечания

  • XOX
  • Если установлен флажок Оценивать информацию о выборе файлов перед выполнением операций архивации или восстановления, будет выполнена оценка количества файлов и байтов, архивируемых или восстанавливаемых в текущем задании. Эти сведения будут подсчитаны и выведены перед началом процесса архивации или восстановления.
  • Если установлен флажок Использовать каталоги носителей для ускорения построения каталогов восстановления на диске, восстановление отмеченных объектов будет выполняться с использованием каталога носителя для построения каталога на диске. Это наиболее быстрый способ построения каталога на диске. Однако если требуется восстановить данные с нескольких лент, а лента с каталогом носителя отсутствует, либо если нужно восстановить данные с поврежденного носителя, этот флажок устанавливать не следует. После этого будет просмотрен весь архив (или все имеющиеся его части) и создан каталог на диске. Если размер архива велик, это может занять много времени.
  • Если установлен флажок Проверять данные после завершения архивации, для проверки правильности архивации данные из архива будут сравнены с исходными данными на жестком диске. Некоторые используемые файлы могут вызывать ошибки при проверке, но эти ошибки обычно можно игнорировать. Большое число таких ошибок может указывать на неполадки с используемым носителем или файлом архива. В этом случае следует повторить архивацию, используя другой носитель или файл.
  • Флажок Архивировать содержимое подключенных дисков позволяет архивировать данные, хранящиеся на присоединенном диске. Если этот флажок установлен, при архивации присоединенного диска будет выполнена архивация хранящихся на нем данных. В противном случае будут архивироваться только сведения о путях присоединенного диска.
  • Флажок Выводить предупреждение, если служба съемных носителей не активна при запуске архивации, выводит предупреждение при запуске архивации, если служба Съемные ЗУ не работает. После этого служба съемных носителей запускается автоматически. При архивации данных в файл, который затем будет записан на дискету, жесткий или съемный диск, этот флажок устанавливать не требуется. Если предполагается архивация данных на ленту или другой носитель, управляемый службой «Съемные ЗУ», флажок нужно установить.
  • Флажок Выводить предупреждение, если при запуске архивации имеется совместимый импортируемый носитель, выводит предупреждение при запуске архивации, если в пуле импортированных носителей доступен новый носитель. При архивации данных в файл, который затем будет записан на дискету, жесткий или съемный диск, этот флажок устанавливать не требуется. Если предполагается архивация данных на ленту или другой носитель, управляемый службой «Съемные ЗУ», этот флажок нужно установить. Для получения дополнительных сведений о пулах носителей и съемных ЗУ щелкните ссылку См. также.
  • Флажок Выводить предупреждение при вставке нового носителя, выводит предупреждение при обнаружении службой «Съемные ЗУ» нового носителя. При архивации данных в файл, который затем будет записан на дискету, жесткий или съемный диск, этот флажок устанавливать не требуется. Если предполагается архивация данных на ленту или другой носитель, управляемый службой «Съемные ЗУ», этот флажок нужно установить.
  • Если установлен флажок Всегда перемещать новый импортированный носитель в пулы носителей архивации, новые носители, обнаруженные службой «Съемные ЗУ», автоматически будут перемещаться в пул носителей архивации. При архивации данных в файл, который затем будет записан на дискету, жесткий или съемный диск, этот флажок устанавливать не требуется. Если служба «Съемные ЗУ» не используется для управления носителями и нужно, чтобы все новые носители были доступны только для программы архивации, этот флажок следует установить.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Чтобы после создания архива выполнялась его проверка, введите:
    ntbackup backup /V:yes|no
Значение | Описание
/V:yes|no | Проверка данных после архивации
Сведения о доступных параметрах архивации см. в разделе Служебная программа командной строки ntbackup.

Например, чтобы под именем "Задание 1" задать архивацию всех файлов и папок с локального диска D:\ в файл C:\backup.bkf с проверкой архива после его создания, введите:

ntbackup backup D:\ /J "Задание 1" /F "C:\backup.bkf" /V:yes

Все другие параметры будут взяты из настроек программы архивации.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис данной команды, введите в командной строке:

    ntbackup /?

  • Если не указаны другие параметры архивации, при выполнении команды ntbackup будут по умолчанию использованы тип архива, параметры проверки, уровень ведения журнала, аппаратное сжатие и другие параметры, заданные в программе архивации.


Выбор типа архива

Чтобы выбрать тип архива

С помощью интерфейса Windows

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. В меню Сервис выберите команду Параметры.
  4. На вкладке Тип архива выберите в списке Используемый по умолчанию тип архива требуемый тип архива.

Примечания

  • XOX
  • Существует пять типов архивов: копирующий, ежедневный, разностный, добавочный и обычный. Для получения дополнительных сведений об этих типах архива щелкните ссылку См. также.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Чтобы задать тип архива, введите:
    ntbackup backup /M тип архива
Значение | Описание
/M тип архива | Тип архива. Этот параметр должен иметь одно из следующих значений: normal, copy, differential, incremental или daily
Сведения о других параметрах архивации см. в разделе Параметры командной строки.

Например, чтобы под именем "Задание 1" задать обычную архивацию данных состояния системы в файл C:\backup.bkf, введите:

ntbackup backup systemstate /M normal /J "Задание 1" /F "C:\backup.bkf"

Все другие параметры будут взяты из настроек программы архивации.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис данной команды, введите в командной строке:

    ntbackup /?

  • Если другие параметры архивации не указаны, при выполнении команды ntbackup будут по умолчанию использованы тип архива, параметры проверки, уровень ведения журнала, аппаратное сжатие и другие параметры, заданные в программе архивации.


Исключение из архива файлов определенных типов

Чтобы исключить из архива файлы определенных типов

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. В меню Сервис выберите команду Параметры.
  4. На вкладке Исключение файлов выполните одно из следующих действий:
    • если требуется исключить файлы, принадлежащие всем пользователям, нажмите кнопку Добавить под списком Файлы, исключенные для всех пользователей;
    • если требуется исключить лишь собственные файлы, нажмите кнопку Добавить под списком Файлы, исключенные для пользователя.
  5. В диалоговом окне Добавление исключаемых файлов выполните одно из следующих действий:
    • чтобы исключить зарегистрированный тип файла, выберите его в списке Зарегистрированный тип файла;
    • чтобы исключить особый тип файла, введите в поле Особая маска файла точку и от одного до трех знаков расширения файла.
  6. Если требуется исключить тип файлов только в определенной папке или на жестком диске, введите путь в поле Применяется к пути и нажмите кнопку ОК.

Примечания

  • XOX
  • Если исключаются файлы в определенной папке (по определенному пути), будут исключены также файлы из всех подпапок этой папки, если только не снят флажок Применять ко всем подпапкам.
  • Чтобы изменить способ исключения файла из архива, выберите этот файл в списке Файлы, исключенные для всех пользователей или Файлы, исключенные для пользователя и нажмите кнопку Изменить. Появится диалоговое окно Добавление исключаемых файлов.


Задание дополнительных параметров архивации

Чтобы задать дополнительные параметры архивации

С помощью интерфейса Windows

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. На вкладке Архивация выберите файлы и папки для архивации.
  4. Нажмите кнопку Архивировать.
  5. В диалоговом окне Сведения о задании архивации нажмите кнопку Дополнительно.
  6. Установите дополнительные параметры архивации и нажмите кнопку ОК. Описание всех параметров приведено в разделе Примечания.

Примечания

  • XOX
  • Если установлен флажок Архивация данных из внешних хранилищ, выполняется архивация данных, предназначенных для внешних хранилищ. Если установить этот флажок, будет выполнена архивация точек повторной обработки (заместителей мест файлов) внешнего хранилища. Если не устанавливать этот флажок, архивация точек повторной обработки удаленного хранилища выполняться не будет. Восстановление данных из внешнего хранилища возможно только на том NTFS.
  • Если установлен флажок Проверка данных после архивации, будет выполнено сравнение данных из архива и исходных данных. Это может значительно увеличить время архивации.
  • Если установлен флажок Если возможно, сжимать архивируемые данные, данные при архивации будут сжиматься, так что на один носитель можно будет записать больше данных. Если этот параметр отключен, значит, на компьютере отсутствует накопитель на магнитной ленте, либо используемый накопитель не поддерживает сжатие данных.
  • Если установлен флажок Автоматически архивировать защищенные системные файлы вместе с состоянием системы, в архив вместе с загрузочными файлами, включаемыми в данные состояния системы, будут добавлены также все системные файлы из системного корневого каталога. Выбор этого параметра значительно увеличивает размер задания архивации (например, для XOX — более чем на 200 Мбайт), но если незадолго до архивации имело место обновление драйверов или изменение файлов операционной системы, то его следует включить.
  • Если установлен флажок Отключить снимок состояния тома, архив будет создан как стандартный снимок состояния на текущий момент времени. Если этот флажок снят, некоторые файлы, открытые или используемые во время архивации, могут быть пропущены. Отключать этот параметр не рекомендуется. Если программе архивации не удастся создать снимок состояния тома, будет использован метод архивации, применявшийся до XOX.
  • Значение, выбранное в поле со списком Тип архива, определяет способ архивации данных. Существует пять типов архивов: копирующий, ежедневный, разностный, добавочный и обычный.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Чтобы задать дополнительные параметры архивации, введите:
    ntbackup backup /V:yes|no /HC:on|off /SNAP:on|off
Значение | Описание
/V:yes|no | Включение или отключение проверки архива после завершения архивации
/HC:on|off | Включение или отключение аппаратного сжатия, если оно доступно на носителе архива. Обычно возможность сжатия данных имеется только в накопителях на магнитной ленте
/SNAP:on|off | Является (on) или не является (off) архив снимком состояния тома
Сведения о других параметрах архивации см. в разделе Служебная программа командной строки ntbackup.

Например, чтобы под именем "Задание 1" задать архивацию всех файлов и папок с локального диска D:\ в файл C:\backup.bkf и отключить создание снимка состояния тома, введите:

ntbackup backup D:\ /J "Задание 1" /F "C:\backup.bkf" /SNAP:off

Все другие параметры будут взяты из настроек программы архивации.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    ntbackup /?

  • Если другие параметры архивации не указаны, при выполнении команды ntbackup будут по умолчанию использованы тип архива, параметры проверки, уровень ведения журнала, аппаратное сжатие и другие параметры, заданные в программе архивации.


Задание параметров восстановления

Чтобы задать параметры восстановления

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. В меню Сервис выберите команду Параметры.
  4. На вкладке Восстановление выполните одно из следующих действий.
    • Если в ходе восстановления не следует заменять файлы, уже имеющиеся на жестком диске, выберите вариант Не заменять файл на компьютере.
    • Если в ходе восстановления требуется заменить старые файлы на диске новыми файлами из архива, выберите вариант Заменять файл на компьютере только если он старее.
    • Если в ходе восстановления требуется заменять файлы на локальном диске независимо от того, как датированы файлы в архиве, выберите вариант Всегда заменять файл на компьютере.

Внимание!

  • При выборе варианта Заменять файл на компьютере только если он старее могут быть заменены некоторые или все файлы, находящиеся на диске.
  • Выбор варианта Всегда заменять файл на компьютере может привести к потере данных, если файл, над которым ведется работа, содержится в архиве.

Примечание

  • XOX


Задание дополнительных параметров восстановления

Чтобы задать дополнительные параметры восстановления

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера программы архивации.
  3. Откройте вкладку Восстановление и управление носителем и выберите файлы для восстановления.
  4. Нажмите кнопку Восстановить.
  5. В диалоговом окне Подтверждение восстановления нажмите кнопку Дополнительно.
  6. Установите дополнительные параметры восстановления и нажмите кнопку ОК. Описание всех параметров приведено в разделе «Примечания»

Примечания

  • XOX
  • Если установлен флажок Восстановление безопасности, для каждого файла и папки будут восстановлены параметры безопасности. Параметры безопасности включают разрешения, элементы аудита и сведения о владельце. Этот флажок доступен, только если архивация данных проводилась с тома NTFS XOX и восстановление проводится также на том NTFS XOX.
  • Если установлен флажок Восстановление базы данных съемных носителей будет восстановлена база данных съемных носителей. Если управление носителями осуществляется без использования службы «Съемные ЗУ», устанавливать этот флажок не требуется. Кроме того, в ходе восстановления будет удалена текущая база данных съемных ЗУ.
  • Если установлен флажок Восстановление точек соединения, а также ссылок для файлов и папок ниже соединения на исходное размещение, будут восстановлены точки соединения на жестком диске, а также данные, на которые они указывают. Если этот флажок не установлен, точки соединения будут восстановлены как общие каталоги, но данные, на которые они указывают, будут недоступны. Кроме того, если при восстановлении присоединенного диска также требуется восстановить его данные, необходимо установить этот флажок. Если этот флажок не установлен, будет восстановлена только папка, содержащая присоединенный диск.
  • Если установлен флажок При восстановлении реплицируемых наборов данных помечать восстановленные данные как основные для всех реплик, восстановленные данные службы репликации файлов (FRS) будут реплицированы на другие серверы. При восстановлении данных FRS этот флажок должен быть установлен. Если этот флажок не установлен, восстанавливаемые данные FRS не смогут быть реплицированы на другие серверы, так как восстановленные данные будут старше текущих данных на других серверах. Это повлечет замену другими серверами восстановленных данных; таким образом, восстановление данных FRS будет предотвращено.
  • Если установлен флажок Восстанавливать реестр кластера на кворумном диске и других узлах, база данных кворума кластера будет восстановлена и реплицирована на все узлы в кластере серверов. Когда этот параметр включен, после перезагрузки восстанавливаемого узла программа архивации останавливает службу кластера на всех других узлах кластера серверов.

    Дополнительные сведения см. в разделе Восстановление содержимого диска кворума кластера.

  • Если установлен флажок Сохранить существующие точки подключения томов, в ходе восстановления не будет выполняться замена никаких точек подключения томов, имеющихся в разделе или на томе, на который выполняется восстановление. Обычно этот флажок следует устанавливать при восстановлении данных на целом диске или разделе. Например, если при восстановлении данных на сменном диске этот диск разбит, отформатирован и на нем восстановлены точки подключения томов, это флажок следует установить, чтобы предотвратить восстановление точек подключения томов. Если при восстановлении данных в только что отформатированный раздел или диск требуется восстановить старые точки подключения томов, это флажок устанавливать не следует.


Форматирование ленты

Чтобы отформатировать ленту

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. На вкладке Восстановление щелкните правой кнопкой мыши ленту, которую требуется отформатировать.
  4. Выберите команду Форматировать.

Примечания

  • XOX
  • Некоторые накопители требуют форматирования ленты перед ее использованием и не поддерживают данную возможность.
  • При отсутствии накопителя на магнитной ленте эта возможность недоступна.


Перемотка ленты

Чтобы перемотать ленту

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. На вкладке Восстановление выберите ленту, которую требуется перемотать.
  4. В меню Сервис выберите команду Обслуживание носителей, а затем — команду Перемотка.

Примечания

  • XOX
  • Команду Перемотка можно также выбрать в меню, щелкнув правой кнопкой мыши ленту на вкладке Восстановление.


Стирание данных с ленты

Чтобы стереть данные с ленты

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. На вкладке Восстановление и управление носителем выберите ленту, с которой требуется стереть данные.
  4. В меню Сервис выберите команду Обслуживание носителей, а затем — команду Стереть.

Примечания

  • XOX
  • Данные с ленты можно стереть, только если она находится в накопителе или в отсеке загрузчика устройства смены лент.
  • После стирания данных лента перемещается из пула носителей архивации в пул свободных носителей.
  • Для стирания данных с ленты можно также воспользоваться оснасткой Съемные ЗУ.
  • Кроме того, команду Стереть можно выбрать из меню, щелкнув правой кнопкой мыши ленту на вкладке Восстановление.


Обновление каталога

Чтобы обновить каталог

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. На вкладке Восстановление щелкните правой кнопкой мыши носитель, содержащий архив, каталог для которого требуется обновить.
  4. Выберите команду Каталог.

Примечания

  • XOX
  • В ходе этой процедуры будет создан каталог на диске. Каталог на носителе создан не будет.
  • При создании каталога архива, сохраненного на ленте, необходимо предварительно выполнить одно из следующих действий.
    • Если все ленты архива имеются в наличии, не повреждены и не испорчены, выберите в меню Сервис команду Параметры, перейдите на вкладку Общие и убедитесь, что установлен флажок Использовать каталоги носителей для ускорения построения каталогов восстановления на диске. Это ускорит процесс построения каталога.
    • Если в наличии имеются не все ленты архива либо среди них есть поврежденные или испорченные, выберите в меню Сервис команду Параметры, перейдите на вкладку Общие и убедитесь, что флажок Использовать каталоги носителей для ускорения построения каталогов восстановления на диске снят. Это обеспечит построение полного и точного каталога, но займет больше времени.


Удаление каталога

Чтобы удалить каталог

  1. XOX

    2. По умолчанию программа архивации запускается в режиме мастера, если этот режим не отключен.

  2. Нажмите кнопку Расширенный в окне мастера архивации.
  3. На вкладке Восстановление щелкните правой кнопкой мыши архив, содержащий каталог, который требуется удалить.
  4. Выберите команду Удалить каталог, если архив был сохранен в файле, или команду Удалить из системы, если архив был сохранен на ленте.

Примечания

  • XOX
  • Эту процедуру следует выполнять, только если лента или файл повреждены или утеряны и требуется удалить их из каталога на диске.
  • Если выбрать команду Удалить каталог, с диска будет удален каталог для выбранного архива. Сам архив удален не будет.
  • Если выбрать команду Удалить из системы, с диска будет удален каталог для выбранного архива, а лента, если она является автономной, будет удалена из базы данных Съемные ЗУ. Каталог носителя с ленты удален не будет.
  • Чтобы восстановить каталог для файла или ленты, на вкладке Восстановление щелкните правой кнопкой мыши файл или ленту для создания каталога и выберите команду Занести файл в каталог или Каталог. Для получения дополнительных сведений о создании каталога щелкните ссылку См. также.


Разрешения и права пользователей

Для архивации файлов и папок необходимо обладать определенными разрешениями или правами пользователя. Члены локальных групп Администраторы и Операторы архива могут архивировать любой файл или папку на локальном компьютере, к которому относится локальная группа. Кроме того, администраторы и операторы архива на контроллере домена могут архивировать любые файлы или папки на любом компьютере в этом домене или в домене, с которым установлены двусторонние доверительные отношения (кроме данных состояния системы; см. примечание). Пользователи, не являющиеся администраторами или операторами архива, могут архивировать только собственные файлы и папки либо должны иметь не менее одного из следующих разрешений на доступ к файлам и папкам, которые требуется архивировать: «Чтение», «Чтение и выполнение», «Изменение» или «Полный доступ».

Кроме того, необходимо быть уверенным, что доступ к жесткому диску не будет ограничен дисковыми квотами: это сделает архивацию данных невозможной. Чтобы узнать, существуют ли ограничения дисковых квот, щелкните правой кнопкой мыши диск, на котором требуется сохранить данные, выберите команду Свойства и перейдите на вкладку Квота.

Доступ к архиву можно ограничить, установив в диалоговом окне Сведения о задании архивации флажок Разрешить доступ к архивным данным только владельцам и администраторам. Если этот флажок установлен, восстановление файлов и папок из архива сможет выполнять только администратор или пользователь, создавший архив.

Примечание

  • Архивировать и восстанавливать данные состояния можно только на локальном компьютере. Более того, для архивации и восстановления данных состояния системы необходимо быть администратором локального компьютера. Прав оператора архива на локальном компьютере для этого недостаточно. Для архивации и восстановления данных состояния системы на удаленном компьютере недостаточно даже прав администратора на этом удаленном компьютере.


Добавление пользователя в группу «Операторы архива»

Чтобы добавить пользователя в группу «Операторы архива»

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните узел Группы.

    Где?

    • Управление компьютером
    • Локальные пользователи и группы
    • Группы
  3. В области сведений дважды щелкните значок Служба факсов.
  4. В диалоговом окне Свойства: Операторы архива нажмите кнопку Добавить.
  5. В диалоговом окне Выбор: Пользователи или Группы ниже списка Имя введите домен и имя пользователя, которого требуется сделать оператором архива. Сначала введите имя домена, затем обратную косую черту и имя пользователя. Например: \\Moscow\Vadim.
  6. Нажмите кнопку Добавить, а затем — кнопку ОК.

Внимание!

  • Для добавления пользователей в группу операторов контроллера домена необходимо использовать оснастку «Active Directory — пользователи и компьютеры». XOX

Примечания

  • Добавлять пользователей в группу «Операторы архива» могут только члены группы «Администраторы».
  • XOX


Общие сведения о снимке состояния тома

XOX позволяет создавать снимки состояния томов, представляющие собой точные копии файлов, в том числе всех открытых файлов. Например, при архивации снимка состояния тома архивируются базы данных, открытые в монопольном режиме, и файлы, открытые в результате действий оператора или системы. Таким образом, файлы, измененные во время архивации, копируются без ошибок.

Архивация с созданием снимка состояния тома имеет следующие преимущества:

  • во время архивации приложения могут продолжать запись данных на том;
  • открытые файлы не пропускаются при архивации;
  • архивацию можно выполнить в любое время, не блокируя учетные записи пользователей.


Примеры командной строки

Следующие примеры иллюстрируют использование команды ntbackup для архивации файлов и папок из командной строки и с помощью пакетных файлов.

Пример 1.

ntbackup backup \\iggy-multi\c$ /m normal /j "Задание 1" /p "Backup" /n "Созданный из командной строки архив 1" /d "Архивация из командной строки" /v:yes /r:no /l:s /rs:no /hc:on

В этом примере создается обычный архив "Задание 1" удаленного общего ресурса \\iggy-multi\c$. Для этого ленте из пула носителей "Backup" присваивается имя "Созданный из командной строки архив 1". Заданию архивации также будет дано описание "Архивация из командной строки". Архив будет проверен сразу после завершения архивации, доступ к нему будет предоставляться не только владельцу/администратору, будет вестись сокращенный журнал, архивация данных из внешнего хранилища выполняться не будет, а аппаратное сжатие будет включено.

Пример 2.

ntbackup backup d:\ /j "Задание 2" /a /t "Созданный из командной строки архив 1" /m copy

В этом примере создается копирующий архив "Задание 2" локального диска D:\. Архивируемые файлы и папки будут добавлены на ленту "Созданный из командной строки архив 1". Все другие параметры будут взяты из настроек программы архивации.

Пример 3.

ntbackup backup "@C:\Program Files\Windows NT\ntbackup\data\commandline.bks" /j "Задание 3" /t "Созданный из командной строки архив 1" /n "Созданный из командной строки архив 2"

В этом примере создается архив того типа, который указан в программе архивации. При этом будет использован файл со списком файлов для архивации Commandline.bks, расположенный в папке C:\Program Files\Windows NT\ntbackup\data\. Задание архивации будет названо "Задание 3", а название ленты "Созданный из командной строки архив 1" будет заменено на "Созданный из командной строки архив 2".

Пример 4.

ntbackup backup \\iggy-multi\d$ /j "Созданный из командной строки архив 4" /f "D:\backup.bkf"

ntbackup backup \\iggy-multi\d$ /j "Созданный из командной строки архив 5" /f "D:\backup.bkf" /a

ntbackup backup \\iggy-multi\d$ /j "Созданный из командной строки архив 6" /f "D:\backup.bkf"

Приведенные выше примеры иллюстрируют выполнение архивации из командной строки. Все три примера используют тип архива, параметры проверки, уровень ведения журнала, аппаратное сжатие и другие параметры, заданные в программе архивации. В первом примере выполняется архивация ресурса \\iggy-multi\d$ в файл D:\Backup.bkf. Во втором примере те же данные архивируются в тот же файл. В третьем примере имеющийся архив заменяется новым архивом, содержащим те же данные. Во всех трех примерах букву диска можно заменить полным именем UNC (то есть вместо файла архива d:\backup.bkf задать файл \\iggy-multi\d$\backup.bkf).


Параметры командной строки

Архивация может выполняться из командной строки или пакетного файла с помощью команды ntbackup и различных параметров командной строки. В квадратные скобки [] заключены необязательные параметры.

Синтаксис

ntbackup backup [systemstate] "имя bks-файла" /J "имя задания" [/P "имя пула"] [/G "идентификатор guid"] [/T "имя ленты"] [/N "носитель"] [/F "имя файла"] [/D "описание"] [/A] [/V:yes|no] [/R:yes|no] [/L:f|s|n] [/M тип архива] [/RS:yes|no] [/HC:on|off] [/UM] [/SNAP:on|off]

Параметры

systemstate

Указание, что следует выполнить архивацию данных состояния системы. При выборе данного параметра будет установлен обычный или копирующий тип архивации.

имя bks-файла

Имя файла (с расширением BKS) со списком файлов для архивации в данном задании архивации. Этот файл содержит сведения о файлах и папках, подлежащих архивации. Он должен быть создан при помощи программы архивации с графическим интерфейсом.

/J "имя задания"

Имя задания, которое будет упоминаться в файле журнала. Обычно оно описывает файлы и папки, включенные в данное задание архивации, а также содержит дату и время архивации.

/P "имя пула"

Пул носителей, носитель из которого будет использован. Обычно это подпул пула носителей архивации, например 4-мм DDS. Этот параметр нельзя использовать вместе со следующими параметрами: /A /G /F /T.

/G "идентификатор guid"

Добавление или замена данных на ленте. Этот параметр не следует использовать вместе с параметром /P.

/T "имя ленты"

Добавление или замена данных на ленте. Не следует использовать вместе с параметром /P.

/N "носитель"

Новое имя ленты. Нельзя использовать вместе с параметром /A.

/F "имя файла"

Путь и имя файла на логическом диске. Этот параметр не следует использовать вместе с параметрами: /P /G /T.

/D "описание"

Метка архива.

/A

Архивация с добавлением в архив. Используется вместе с параметром /G или /T. Этот параметр не следует использовать вместе с параметром /P.

/V:yes|no

Проверка данных после архивации.

/R:yes|no

Доступ к этой ленте разрешен только владельцу или членам группы «Администраторы».

/L:f|s|n

Тип файла журнала: f=полный, s=сокращенный, n=нет (файл журнала не создается).

/M тип архива

Тип архива. Этот параметр должен иметь одно из следующих значений: normal, copy, differential, incremental или daily.

/RS:yes|no

Архивация базы данных Съемные ЗУ.

/HC:on|off

При возможности — использование аппаратного сжатия.

/UM

Выполнение поиска первого доступного носителя, форматирование и использование его для текущего задания архивации. Если при использовании параметра /UM нужно указать пул носителей определенного типа, для поиска носителя соответствующего типа (например, 4-мм DDS) используется параметр /P. Если используется параметр /UM, будет выполнен поиск доступных носителей среди следующих пулов носителей: свободные, импортированные, неопознанные и носители приложения архивации. Когда будет найден доступный носитель, поиск будет завершен, а носитель — отформатирован и задействован без подтверждения со стороны пользователя. Эта команда применяется только к автономным накопителям на магнитной ленте и неприменима к загрузчикам ленты.

/SNAP:on|off

Является (on) или не является (off) архив снимком состояния тома.

Примечания

  • Восстановление файлов из командной строки с помощью команды ntbackup невозможно.
  • Если не заданы параметры /V /R /L /M /RS /HC, будут по умолчанию использованы соответствующие настройки программы архивации с графическим интерфейсом. Например, если в диалоговом окне Параметры программы архивации включено сжатие при архивации, при отсутствии в командной строке параметра /HC данные будут сжиматься. Но если в командной строке задать параметр /HC:off, он заменит значение в диалоговом окне Параметры, и сжатие выполняться не будет.
  • Если на данном компьютере запущены службы Windows Media и требуется выполнить архивацию файлов этих служб, ознакомьтесь с разделом об архивации служб Windows Media электронной документации по службам Windows Media. Для архивации или восстановления файлов служб Windows Media следуйте инструкциям, приведенным в электронной документации по службам Windows Media.
  • Архивация данных состояния системы возможна только для локального компьютера. Для удаленного компьютера архивировать данные состояния системы нельзя.
  • Если управление носителями осуществляется службой «Съемные ЗУ» или для сохранения данных используется внешнее хранилище, необходимо регулярно архивировать файлы, находящиеся в следующих папках:

    СистемныйКорневойКаталог\System32\Ntmsdata

    СистемныйКорневойКаталог\System32\Remotestorage

    Это будет гарантировать возможность восстановления всех данных, сохраненных во внешнем хранилище и на съемном ЗУ.