Использование программы связи с данными

Программа связи с данными используется для создания и управления подключениями между локальным компьютером и хранилищами данных OLE DB. При создании связи с данными заполняется файл .udl, который можно использовать для будущих подключений к базе данных. Если в Microsoft правильно установлены объекты данных Microsoft ActiveX (ADO) или OLE DB, для открытия программы связи с данными можно использовать следующую процедуру.

Чтобы открыть программу связи с данными

  1. Откройте Windows проводник.
  2. Выберите папку, в которой требуется сохранить UDL-файл. Щелкните правой кнопкой мыши в правой области проводника, выберите пункт Создать, а затем Текстовый документ.
  3. В меню Сервис выберите команду Свойства папки. На вкладке Вид снимите флажок Скрывать расширения для зарегистрированных типов файлов и нажмите кнопку OK.
  4. Щелкните правой кнопкой мыши текстовый файл, созданный на шаге 2, и выберите команду Переименовать. Введите нужное имя для файла, используя расширение UDL (например, mydata.udl), а затем нажмите кнопку ENTER.
  5. На экране может появиться предупреждение о том, что после смены расширения файл может оказаться недоступным. Для файлов .udl это предупреждение можно не принимать во внимание. Нажмите кнопку Да.
  6. Дважды щелкните UDL-файл, чтобы открыть диалоговое окно Свойства связи с данными.

Примечания

  • XOX
  • Обычно ADO и OLE DB устанавливаются при установке программ, использующих базы данных.
  • Для получения сведений об использовании программы связи с данными откройте UDL-файл. В диалоговом окне Свойства связи с данными нажмите кнопку Справка.
  • XOX

См. также


Интернет-игры

Чтобы поиграть в эти Интернет-игры, необходимо подключиться к веб-узлу. Если подключиться к узлу не удается, то, возможно, пользователь подключен к Интернету через брандмауэр организации или личный брандмауэр. Более подробные сведения см. по ссылке Network Troubleshooting Resource Center for Microsoft Games (http://support.microsoft.com/default.aspx?scid=fh;EN-US;gmsnetw).

Помните—, что для установки компонентов или внесения в параметры системы изменений, требуемых для запуска некоторых игр, необходимо войти в Windows в качестве администратора.

Интернет-Нарды

Цель игры в нарды — провести все свои фишки вокруг доски (против часовой стрелки) в дом. Затем фишки из дома нужно выставить на двор; число шагов при этом должно точно совпадать со значением, выпавшим на игральных костях. Побеждает тот, кто первым выставит все свои фишки. При игре в Интернет-Нарды связь с соперником осуществляется через Интернет.

Запустите программу Интернет-Нарды.

Интернет-Шашки

Целью игры в шашки является удаление с доски шашек соперника. Для победы также достаточно заблокировать шашки соперника. При игре в Интернет-Шашки связь с соперником осуществляется через Интернет.

Запустите программу Интернет-Шашки.

Интернет-Червы

«Червы» — это карточная игра для четырех игроков, каждый из которых играет за себя. Цель игры состоит в том, чтобы заработать как можно меньше очков. Игра заканчивается, когда один из игроков получает 100 очков или больше. Побеждает игрок с наименьшим числом очков. При игре в Интернет-Червы связь с соперниками осуществляется через Интернет.

Запустите программу Интернет-Червы.

Интернет-Реверси

Игра в реверси ведется на доске размером 8х8 полей черно-белыми фишками. Цель игры состоит в том, чтобы фишек выбранного цвета на доске было больше, чем фишек соперника. Ставя свои фишки таким образом, чтобы фишки соперника оказывались между ними, можно перекрашивать фишки соперника в свой цвет. Игра заканчивается, когда у соперников не остается разрешенных ходов. При игре в Интернет-Реверси связь с соперником осуществляется через Интернет.

Запустите программу Интернет-Реверси.

Интернет-Пики

«Пики» — это карточная игра для двух команд, состоящих из двух игроков. Цель игры заключается в том, чтобы заключить командный контракт и разыграть карты согласованно с партнером для выполнения контракта. Игра заканчивается, когда одна из команд набирает 500 очков или минус 200 очков. При игре в Интернет-Пики связь с партнером и соперниками осуществляется через Интернет.

Запустите программу Интернет-Пики.

Примечания

  • XOX
  • Если пункт Игры отсутствует в меню Все программы, это означает, что игры не были установлены при установке Windows. XOX
  • Для получения сведений о правилах игры обращайтесь к меню Справка соответствующей программы.

См. также


Использование службы Windows «MSN Messenger Service»

Служба сообщений «MSN Messenger Service» позволяет:

  • видеть, кто находится в интерактивном режиме;
  • оперативно отправлять сообщения;
  • вызывать компьютеры нужных пользователей;
  • отправлять файлы;
  • обмениваться сообщениями с группой друзей;

Запустите программу Windows Messenger.

Примечания

  • XOX
  • Для получения сведений об использовании службы «MSN Messenger» обращайтесь к меню Справка в окне этой службы.


Использование программы Windows Movie Maker

Программа Windows Movie Maker позволяет перемещать записанный звук и видео с источника (например, с аналоговой или цифровой видеокамеры) на компьютер. Помимо использования записанного содержимого, для создания фильмов можно импортировать существующие звуковые и видеофайлы. Созданный фильм можно продемонстрировать семье и друзьям непосредственно из Windows Movie Maker, отправив его по электронной почте или разместив на веб-узле.

Запустите программу Windows Movie Maker.

Примечания

  • XOX
  • Для получения дополнительных сведений об использовании программы Windows Movie Maker обращайтесь к меню Справка этой программы.
  • XOX

См. также


Использование обозревателя MSN Explorer

MSN Explorer — это новая универсальная программа, позволяющий более полно использовать Интернет. С помощью MSN Explorer можно читать электронную почту, разговаривать с друзьями и слушать музыку по сети, а также просматривать веб-страницы. MSN Explorer — простая программа, работающая с существующим подключением к Интернету. Она обеспечивает использование всех преимуществ Интернет-технологий корпорации Майкрософт, таких как Hotmail, Internet Explorer, Windows Messenger и Windows Media Player.

Примечания

  • XOX
  • Для получения сведений об использовании обозревателя MSN Explorer обращайтесь к меню Справка& Параметры этой программы.


Дата компиляции

Рисунок Microsoft Windows
Дата компиляции: 2003-12-03


Использование очереди сообщений

Рисунок Microsoft Windows

Работа с очередью сообщений

Очередь сообщений (также используется название MSMQ) представляет собой инфраструктуру и среду для выполнения распределенных, свободно подключаемых приложений обмена сообщениями. Приложения очереди сообщений на исходных компьютерах отправляют сообщения в очереди, в которых сообщения временно хранятся, а приложения на конечных компьютерах получают сообщения из очередей. Такие приложения могут производить обмен данными в неоднородных сетях и с компьютерами, которые могут оказаться временно отключенными от сети. Для управления очередью сообщений используется несколько оснасток консоли MMC.

Чтобы установить очередь сообщений с набором функций независимого клиента, выполните следующие действия.

  1. Откройте окно Установка и удаление программ.
  2. Нажмите кнопку Добавление и удаление компонентов Windows.
  3. В окне мастера компонентов Windows установите флажок Очередь сообщений.
  4. Если требуется изменить стандартный набор устанавливаемых необязательных подкомпонентов, нажмите кнопку Состав и выполните следующие действия.
    • Если компьютер входит в домен и должен работать в режиме рабочей группы, снимите флажок Интеграция с Active Directory.
    • Если переключатели очереди сообщений устанавливать не требуется, снимите флажок Переключатели.
    • Если предполагается отправлять сообщения с использованием транспорта HTTP, установите флажок Поддержка протокола MSMQ HTTP.

Примечания

  • XOX
  • В XOX оснастка «Active Directory - пользователи и компьютеры» недоступна.
  • Чтобы открыть оснастку «Управление компьютером» после установки очереди сообщений, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.