Общие сведения о клиенте для сетей NetWare

Клиент для сетей NetWare предоставляет доступ к файлам и принтерам на серверах NetWare, использующих Novell Directory Services (NDS) или системную базу данных (NetWare версий 3.x или 4.x) с локального компьютера. Клиент для сетей NetWare поддерживает некоторые служебные программы NetWare и приложения, совместимые с NetWare.

Взаимодействие с системой Netware версии 5.x

Служба клиента для сетей Netware не поддерживает протокол IP и таким образом невозможно взаимодействие с Netware 5.x в среде IP. Для этого необходимо использовать протокол IPX в системе NetWare 5.x или перенаправитель, совместимый с протоколом NetWare Core Protocol (NCP) и поддерживающий исходный протокол IP.

Важно!

  • XOX


Решение задач: Клиент для сетей NetWare

Рисунок Microsoft Windows

Решение задач

При установке клиента для сетей NetWare часто приходится выполнять следующие задачи. XOX

Установка клиента для сетей NetWare

Установка клиента для сетей NetWare позволяет компьютерам, работающим под управлением Windows XP, непосредственно подключаться к файлам и принтарам на серверах NetWare.

Пошаговые инструкции

Установка NWLink IPX/SPX/NetBIOS-совместимого транспортного протокола

NWLink обеспечивает связь между компьютерами с системой Windows XP и компьютерами, использующими NetWare или совместимые с ней операционные системы. NWLink можно также использовать как протокол, который объединяет много компьютеров с Windows или компьютеры с системой MS Client для DOS.

Пошаговые инструкции

Подключение к ресурсу NetWare

Доступ к файлам на томах NetWare по сети. Для подключения к файловым ресурсам NetWare необходимо установить службу клиента (или шлюза) для сетей NetWare, а также протокол NWLink.

Пошаговые инструкции

Подключение к принтеру на сервере NetWare

Для подключения к принтеру на сервере NetWare необходимо установить службу клиента (или шлюза) для сетей NetWare и NWLink. После подключения к принтеру NetWare этот принтер появится в папке «Принтеры».

Пошаговые инструкции

Важно!

  • XOX


Установка клиента для сетей NetWare

Чтобы установить клиент для сетей NetWare

  1. Запустите программу Сетевые подключения.
  2. Щелкните правой кнопкой мыши подключение по локальной сети, для которого требуется установить клиент для сетей NetWare, и выберите команду Свойства.
  3. На вкладке Общие нажмите кнопку Установить.
  4. В диалоговом окне Выбор типа сетевого компонента выберите Клиент и нажмите кнопку Добавить.
  5. В диалоговом окне Выбор сетевого клиента выберите пункт Клиент для сетей NetWare и нажмите кнопку ОК.

Важно!

  • XOX

Примечания

  • XOX
  • При установке клиента для сетей NetWare устанавливается поддержка всех соответствующих подключений. Если поддержка клиента для сетей NetWare в каком-либо подключении не требуется, в окне свойств этого подключения снимите флажок Клиент для сетей NetWare.
  • Служба клиента для сетей Netware не поддерживает протокол IP и таким образом невозможно взаимодействие с Netware 5.x в среде IP. Необходимо использовать протокол IPX в системе NetWare 5.x или перенаправитель, совместимый с протоколом NetWare Core Protocol (NCP) и это поддержит исходный протокол IP.
  • Чтобы убедиться в правильной работе клиента для сетей NetWare, введите в командной строке net view /network:nw. Будет выведен список доступных серверов NetWare.
  • В составе клиента для сетей NetWare устанавливается также NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.


Установка основного сервера

Чтобы установить основной сервер

  1. Откройте клиент для сетей NetWare.
  2. Выберите вариант Основной сервер, а затем введите имя сервера в поле Другой.

Важно!

  • XOX

Примечания

  • XOX Чтобы использовать клиент для сетей NetWare, необходимо предварительно установить его.
  • В среде Novell Directory Services (NDS) можно выбрать только дерево и контекст, используемые по умолчанию, но не основной сервер.
  • Если основной сервер не определен, выберите вариант Нет. Вход в систему будет осуществлен на ближайшем доступном сервере NetWare. Работа в сети NetWare будет осуществляться через этот сервер. Если основной сервер не задан, какой-либо сервер нужно будет выбирать при каждом входе в систему. Основной сервер можно задать в любой момент или продолжать выбирать вариант Нет.

См. также


Установка дерева и контекста для использования по умолчанию

Чтобы установить дерево и контекст для использования по умолчанию

  1. Откройте клиент для сетей NetWare.
  2. Выберите вариант Дерево и контекст по умолчанию и введите в поля Дерево и Контекст дерево и контекст соответственно.

Важно!

  • XOX

Примечания

  • XOX Чтобы использовать клиент для сетей NetWare, необходимо предварительно установить его.
  • В среде Novell Directory Services (NDS) можно выбрать только дерево и контекст, используемые по умолчанию. В другой среде можно выбрать и основной сервер.

См. также


Установка параметров печати

Чтобы установить параметры печати

  1. Откройте клиент для сетей NetWare.
  2. В группе Параметры печати выполните одно или несколько следующих действий.
    • Для автоматического извлечения из принтера последней напечатанной страницы установите флажок Добавление перевода страницы.
    • Для отправки уведомления о завершении печати документа установите флажок Уведомление о печати.
    • Для печати заглавной страницы перед каждым заданием установите флажок Печать заголовка.
  3. В группе Параметры сценария входа для выполнения сценария входа с сервера NetWare установите флажок Выполнять сценарий входа.

Важно!

  • XOX

Примечание

    XOX

См. также


Установка NWLink IPX/SPX/NetBIOS-совместимого транспортного протокола

Чтобы установить NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол

  1. Откройте компонент Сетевые подключения.
  2. Щелкните правой кнопкой мыши подключение по локальной сети и выберите пункт Свойства.
  3. На вкладке Общие нажмите кнопку Установить.
  4. В диалоговом окне Выбор типа сетевого компонента выберите строку Протокол и нажмите кнопку Добавить.
  5. В диалоговом окне Выбор сетевого протокола выберите NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол и нажмите кнопку OK.

Важно!

  • XOX

Примечания

  • XOX
  • Для установки NWLink необходимо быть членом группы администраторов.
  • NWLink устанавливается сразу для всех подключений. Если для определенного подключения протокол NWLink не должен быть установлен, щелкните правой кнопкой мыши данное подключение, выберите команду Свойства и либо на вкладке Общие, либо на вкладке Сеть снимите флажок NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.
  • Чтобы убедиться в том, что NWLink работает, введите в командной строке команду ipxroute config. Таблица сведений о привязках, для которых настроен NWLink должна отобразиться .


Настройка NWLink IPX/SPX/NetBIOS-совместимого транспортного протокола

Чтобы настроить NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол

  1. Откройте компонент Сетевые подключения.
  2. Щелкните правой кнопкой мыши подключение по локальной сети, для которого требуется настроить протокол NWLink, и выберите команду Свойства.
  3. На вкладке Общие выберите NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол и нажмите кнопку Свойства
  4. На вкладке Общие введите значение номера внутренней сети или оставьте значение, используемое по умолчанию (00000000).
  5. Выполните одно из следующих действий.
    • В группе Тип пакета выберите вариант Автоопределение типа пакета и нажмите кнопку ОК.
    • В группе Тип пакета выберите требуемый тип пакета. Введите значение в поле Номер сети и нажмите кнопку OK.
  6. Нажмите кнопку ОК для сохранения изменений.

Важно!

  • XOX

Примечания

  • XOX
  • Дополнительные параметры протокола NWLink хранятся в реестре. В большинстве случаев нет необходимости изменять эти параметры. Выполните эту процедуру, только если требуется привязать протокол NWLink к другой сетевой плате или вручную изменить тип пакета.
  • По умолчанию протокол NWLink автоматически определяет тип пакета, используемый сетевой платой, к которой осуществлена привязка. Если службе NWLink не удается обнаружить передачу данных по сети или если обнаружены другие типы пакетов в дополнение к типу 802.2, устанавливается тип пакета 802.2. Можно определить, какой номер внешней сети, тип пакета и номер внутренней сети используют маршрутизаторы, выполнив команду ipxroute config из командной строки.


Подключение к ресурсу NetWare

Чтобы подключиться к ресурсу NetWare

Использование интерфейса Windows

  1. Откройте окно Мое сетевое окружение.
  2. Выполните одно из следующих действий.
    • Дважды щелкните значок Сеть NetWare или совместимая.
    • Дважды щелкните узел Вся сеть, затем дважды щелкните значок Сеть NetWare или совместимая.

    В проводнике Windows будут отображены деревья Novell Directory Services (NDS) со значком дерева и отдельные компьютеры NetWare со значком компьютера.

  3. Дважды щелкните значок дерева или тома для просмотра его содержимого. Для просмотра других компьютеров или томов следует дважды щелкнуть область содержимого.
  4. Выполните одно из следующих действий.
    • Когда найдены требующиеся том или папка, откройте их двойным щелчком мыши.
    • Чтобы подключить в виде локального логического диска том или папку, следует выбрать этот том или папку, затем в меню Сервис выбрать команду Подключение сетевого диска. Следуйте инструкциям мастера подключения сетевого диска.

Важно!

  • XOX

Примечания

  • XOX
  • При назначении сетевого диска по умолчанию осуществляется подключение с именем пользователя и паролем, использованным при входе в систему. Чтобы выполнить подключение с другим именем пользователя, следуйте инструкции мастера подключения сетевого диска.
  • Для просмотра ресурсов NetWare и подключения к ним требуется сначала установить службу клиента для сетей NetWare, а также NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Выполните любое из следующих действий.

    3. Чтобы подключиться к отдельному тому NetWare

    • Введите в командной строке команду:

      net use диск: {имя_UNC|имя_NetWare}

      Например, чтобы использовать синтаксис UNC для перенаправления диска G на каталог \Data\Mydata тома Thor или на сервер Nw4, введите:

      net use G: \\nw4\thor\data\mydata

      Следующее сообщение указывает, что не удается выполнить проверку подлинности для указанных имени пользователя и пароля.

      Неверный пароль для \\сервер\том[\каталог...]

    Чтобы подключиться с правильным именем пользователя и паролем

    • В командной строке добавьте имя пользователя и пароль путем ввода:

      /user: имя_пользователя пароль

      Например, для подключения диска G c именем «Annie» и с паролем «Marshmallow» к каталогу \Data\Mydata на томе Thor сервера Nw4 введите:

      net use G: \\nw4\thor\data\mydata /user:annie marshmallow

    Чтобы подключиться к Дереву Novell Directory Services (NDS) для сетей NetWare

    • Введите в командной строке команду:

      net use диск: \\имя_дерева\том.имя_орг.имя_орг [/u:имя_пользователя.имя_орг.имя_орг[пароль]]

      Значение | Описание
      имя_дерева | Имя тома дерева.
      имя_орг | Расположение дерева, к которому требуется подключиться.
      имя_пользователя.имя_орг.имя_орг | Имя пользователя и контекст для этого дерева, если это дерево не является используемым по умолчанию.

Важно!

  • XOX

Примечания

  • XOX
  • Для просмотра ресурсов NetWare и подключения к ним требуется сначала установить службу клиента для сетей NetWare, а также NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.
  • При подключении к файл-серверам NetWare команда net use эквивалентна команде NetWare map в рабочих станциях NetWare на основе MS-DOS.
  • Допускается подключение к отдельным томам NetWare, в которых применяется система безопасности с использованием привязок, а также к деревьям Novell Directory Services NDS. Тома, каталоги и очереди печати сервера NetWare представлены именами в формате UNC (universal naming convention) и используют тот же синтаксис команд, что используется в сетях на основе Microsoft Windows.
  • Путь к ресурсу NDS может быть введен с метками (cn=, ou=, o=) или без них.
  • При использовании командной строки для подключения к файловым ресурсам NetWare вместо имени диска может вводиться звездочка (*), что эквивалентно указанию имени первого свободного диска. Например:

    net use *: имя_UNC или имя_NetWare

  • Для того чтобы система сама запрашивала пароль, замените пароль в командной строке звездочкой (*). При вводе пароля по запросу он не отображается на экране.
  • Если запущена служба клиента для NetWare и управление осуществляется из командной строки, следует пользоваться 32-разрядной версией командной строки (Cmd.exe), доступной в меню Программы, а не 16-разрядной версией (Command.com).
  • Чтобы просмотреть полный синтаксис команды net use, введите в командной строке следующую команду:

    net use /?

См. также


Подключение к принтеру на сервере NetWare

Чтобы подключиться к принтеру на сервере NetWare

Использование интерфейса Windows

  1. Откройте на панели управления компонент Принтеры.
  2. Дважды щелкните значок Установка принтера, затем нажмите кнопку Далее.
  3. Следуйте дальнейшим инструкциям мастера установки принтера.

Важно!

  • XOX

Примечания

  • XOX
  • Для просмотра ресурсов NetWare и подключения к ним требуется сначала установить службу клиента для сетей NetWare, а также NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.
  • Если драйвер для принтера NetWare локально недоступен, будет выдан запрос на установку такого драйвера.

Использование командной строки

  1. Откройте окно Командная строка.
  2. С этой компанией можно связаться одним из следующих способов.

    3. Чтобы переадресовать выдачу из порта в очередь печати

    • Введите в командной строке команду:

      net use имя_сервера \\очередь_печати

      Например, чтобы переадресовать вывод на печать через LPT1 на очередь печати NetWare с именем Memos на сервере Nw4, введите

      net use lpt1 \\nw4\memos

      Это аналогично команде NetWare capture q=memos s=nw4 l=1.

    Чтобы отправить файл, не требующий форматирования, в порт LPT1

    • Перенаправьте вывод с помощью команды net use и введите в командной строке следующую команду:

      copy имя_файла имя_сервера

      Например:

      copy myfile.txt lpt1

    Чтобы скопировать файл непосредственно в очередь печати

    • Перенаправьте вывод с помощью команды net use и введите в командной строке следующую команду:

      copy имя_файла \\очередь_печати

      Например:

      copy myfile.txt \\nw4\memos

    Чтобы подключиться к принтеру в дереве Novell Directory Services (NDS) для сетей NetWare

    • Введите в командной строке команду:

      net use диск: \\имя_дерева\том.имя_орг.имя_орг [/u:имя_пользователя.имя_орг.имя_орг[пароль]]

      • Значение | Описание
имя_дерева | Имя тома дерева.
имя_орг | Расположение дерева, к которому требуется подключиться.
имя_пользователя.имя_орг.имя_орг | Имя пользователя и контекст для этого дерева, если это дерево не является используемым по умолчанию.

Важно!

  • XOX

Примечания

  • XOX
  • Для просмотра ресурсов NetWare и подключения к ним требуется сначала установить службу клиента для сетей NetWare, а также NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.
  • Путь к ресурсу NDS может быть введен с метками (cn=, ou=, o=) или без них.
  • В приложении, использующем вывод на печать непосредственно через стандартный порт, команда net use работает аналогично программе NetWare capture, связывая очередь печати NetWare с портом.
  • Если запущена служба клиента для NetWare и управление осуществляется из командной строки, следует пользоваться 32-разрядной версией командной строки (Cmd.exe), доступной в меню Программы, а не 16-разрядной версией (Command.com).

См. также


Просмотр ресурсов NetWare

Чтобы просмотреть ресурсы NetWare

Использование интерфейса Windows

  1. Откройте окно Мое сетевое окружение.
  2. Выполните одно из следующих действий.
    • Дважды щелкните значок Сеть NetWare или совместимая.
    • Дважды щелкните узел Вся сеть, затем дважды щелкните значок Сеть NetWare или совместимая.

    В проводнике Windows будут отображены деревья Novell Directory Services (NDS) со значком дерева и отдельные компьютеры NetWare со значком компьютера.

  3. Дважды щелкните значок дерева или тома для просмотра его содержимого. Для просмотра других компьютеров или томов следует дважды щелкнуть область содержимого.

Важно!

  • XOX

Примечания

  • XOX
  • Для просмотра ресурсов NetWare или подключения к ним требуется сначала установить службу клиента для сетей NetWare и NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.

Использование командной строки

  1. Откройте окно Командная строка.
  2. Выполните любое из следующий действий.

    3. Чтобы вывести на экран списка файл-серверов NetWare

    • Введите в командной строке команду:

      net view /network:nw

    Чтобы вывести на экран тома на заданном файл-сервере NetWare

    • Введите в командной строке команду:

      net view \\имя_сервера_nw /network:nw

      Например, для просмотра томов на сервере NetWare Nw4 введите:

      net view \\nw4 /network:nw

    Чтобы отобразить содержимое каталога на файловом сервере NetWare с запущенной безопасностью на основе привязок

    • Введите в командной строке команду:

      dir \\путь_каталога

    Чтобы вывести на экран содержимое каталога на файловом сервере NetWare с запущенной службой Novell Directory Services (NDS)

    • Путь к каталогу водится в прямых кавычках. Введите в командной строке команду:

      dir "\\деревоNDS\том.устройство.группа"

Важно!

  • XOX

Примечания

  • XOX
  • Для просмотра ресурсов NetWare или подключения к ним требуется сначала установить службу клиента для сетей NetWare и NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.
  • Команда Net view выполняет ту же функцию, что и утилита NetWare slist.
  • Путь к ресурсу NDS может быть введен с метками (cn=, ou=, o=) или без них.
  • Если запущена служба клиента для NetWare и управление осуществляется из командной строки, следует пользоваться 32-разрядной версией командной строки (Cmd.exe), доступной в меню Программы, а не 16-разрядной версией (Command.com).

См. также


Просмотр текущих сетевых подключений

Чтобы просмотреть текущие сетевые подключения

Использование интерфейса Windows

Чтобы просмотреть все сетевые подключения

  • Откройте окно Мой компьютер.

Примечания

  • XOX
  • Поверх значков отключенных сетевых дисков отображается красный крестик «Х».

Чтобы просмотреть только подключения NetWare

  • XOX

Важно!

  • XOX

Использование командной строки

  1. Откройте окно Командная строка.
  2. Введите в командной строке команду:

    net use

Важно!

  • XOX

Примечания

  • XOX
  • Для просмотра ресурсов NetWare или подключения к ним требуется сначала установить службу клиента для сетей NetWare и NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.
  • Если запущена служба клиента для NetWare и управление осуществляется из командной строки, следует пользоваться 32-разрядной версией командной строки (Cmd.exe), доступной в меню Программы, а не 16-разрядной версией (Command.com).
  • Чтобы просмотреть полный синтаксис команды net use, введите в командной строке следующую команду:

    net use /?

См. также


Смена пароля NetWare

Чтобы изменить пароль NetWare

На сервере привязки NetWare

  1. Откройте окно Командная строка.
  2. Перейдите к диску сервера NetWare и введите команду

    cd \public

  3. Введите следующую команду, где NetWareServer представляет имя сервера NetWare, для которого требуется изменить пароль:

    setpass NetWareServer

  4. При появлении соответствующих запросов введите прежний пароль, новый пароль и подтверждение нового пароля.

    Будет выведено подтверждение успешного изменения пароля.

  5. Если будет выдан запрос, введите y для изменения пароля на других серверах NetWare, использующих старый пароль.

    6. Введите n, чтобы оставить неизменным пароль на других серверах NetWare.

Важно!

  • XOX

Примечания

  • XOX
  • Для просмотра ресурсов NetWare или подключения к ним требуется сначала установить службу клиента для сетей NetWare, а также NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.
  • Для изменения пароля на нескольких серверах подключитесь ко всем этим серверам перед вводом команды setpass.
  • Если запущена служба клиента для NetWare и управление осуществляется из командной строки, следует пользоваться 32-разрядной версией командной строки (Cmd.exe), доступной в меню Программы, а не 16-разрядной версией (Command.com).

Дерево Novell Directory Services (NDS) для сетей NetWare

  1. Нажмите клавиши CTRL+ALT+DEL.
  2. Нажмите кнопку Смена пароля.
  3. В поле со списком Вход в выберите Сеть NetWare или совместимая.
  4. В поле Старый пароль введите текущий пароль.
  5. Введите новый пароль в поле Новый пароль, затем введите его еще раз в поле Подтверждение.

Важно!

  • XOX

Примечания

  • Пароль изменяется во всех деревьях NDS, к которым в настоящий момент имеется подключение. Если введенный прежний пароль не соответствует текущему паролю в любой из этих структур, будет выдан запрос на прежний пароль для этих структур.
  • Для просмотра ресурсов NetWare и подключения к ним требуется сначала установить службу клиента для сетей NetWare, а также NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.

См. также


16-разрядные служебные программы NetWare для MS-DOS

Как проводник, так и команда net use позволяют выполнять те же функции, что и служебные программы NetWare attach, capture, login и logout, которые не поддерживаются в Windows XP, поскольку могут вызывать сбои. Подобно команде NetWare capture, команда net use позволяет приложениям для MS-DOS и Windows печать через определенный порт. Для подключения к очередям печати также можно воспользоваться папкой «Принтеры».

Вместо программы slist NetWare следует использовать команду net view.

Важно!

  • XOX

Примечания

  • Если при попытке доступа к серверу или какой-либо папке появляется сообщение об ошибке, проверьте, является ли буква диска F свободной, а также отключите все ненужные сетевые диски.
  • Служба клиетна для NetWare не поддерживает служебные программы системы NetWare версии 4.x или 5.x.
  • В случае использования клиента для сетей NetWare и командной строки следует пользоваться 32-х разрядной версией командной строки (Cmd.exe) в меню Программы, вместо 16-разрядной версии (Command.com). При работе с клиентом для сетей NetWare пакетный файл (например сценарий входа), открывающий экземпляр окна командной строки, должен начинаться с команды #cmd, а не #command.