Диалоговое окно «Установка драйвера ODBC для Microsoft Access»

Диалоговое окно Установка драйвера ODBC для Microsoft Access включает следующие элементы.

Сведения об источнике данных | Указывается база данных Access. По умолчанию используется имя, назначенное производителем. Поле Описание по умолчанию пусто. В нем может быть введено описание.
База данных | Кнопка Восстановить используется для восстановления поврежденных баз данных. Кнопка Сжать используется для уменьшения неиспользуемого места на диске. Кнопки Выбрать и Создать используются для открытия имеющихся или новых баз данных.
Системная база данных | Нажмите эту кнопку, чтобы выбрать базу данных общего доступа. По умолчанию используется имя пользователя «Admin», для которого по умолчанию в качестве пароля Microsoft Access используется пустая строка.
Параметры Нажмите эту кнопку, чтобы изменить следующие параметры.
  • Время ожидания страницы. Время (в десятых долях секунды) хранения неиспользуемых страниц в буфере. Это значение всегда должно быть больше нуля.

  • Размер буфера. Размер внутреннего буфера (в килобайтах), используемого Microsoft Access для переноса данных с диска и на диск. Это значение может быть любым целым числом, кратным 256.

  • Ограничения доступа к базе данных.
Дополнительно | Нажмите эту кнопку, чтобы настроить дополнительные параметры быстродействия драйвера.

Примечание. Подробные сведения об этом драйвере содержатся на узле msdn.microsoft.com. (Откройте электронную библиотеку MSDN, а затем Platform SDK, чтобы найти раздел MDAC SDK, содержащий раздел ODBC Drivers.) Другие сведения можно найти в этом файле в разделах Преобразование источника данных, Файлы Access , Записи реестра IISAM и Файлы стандартных компонентов ODBC. Предоставляется поддержка продукта.


.topic 2
Закрытие диалогового окна без сохранения изменений.

.topic 3
Имя источника данных, например Payroll или Personnel. При использовании драйвера Microsoft Excel 3.0 или 4.0 указывается каталог по умолчанию, в котором драйвер ODBC осуществляет поиск файлов данных. При использовании драйвера Microsoft Excel 5.0, 7.0, или 97 указывается книга данных, в которой драйвер ODBC осуществляет поиск файлов данных.

.topic 4
Необязательное описание данных из источника данных; например "Дата приема на работу, выплачиваемая зарплата и отметки сотрудников".

.topic 5
Вызов справки для этого диалогового окна.

.topic 6
Закрытие диалогового окна настройки и сохранение изменений.

.topic 7
Выбор доступа к базе данных только для чтения. Обновления запрещаются.

.topic 8
Количество строк, которые следует просмотреть, чтобы определить тип данных каждого столбца. В случае драйвера Microsoft Excel указывается любое число от 1 до 16, по умолчанию - 8; если указано 0, просматриваются все строки.

.topic 9
Открытие диалогового окна "Выбор каталога", в котором выбирается каталог, содержащий необходимые файлы. При определении каталога источника данных следует указать каталог, в котором находятся наиболее используемые в Microsoft Excel 3.0 или 4.0 файлы Excel.

.topic 10
Открытие диалогового окна "Выбор книги", в котором выбирается книга, которую следует открыть.

.topic 11
Выбор текущего рабочего каталога приложения в качестве каталога источника данных. Если флажок снят, каталог источника данных может быть выбран нажатием клавиши "Выбор каталога". Отключен для Microsoft Excel 5.0, 7.0 или 97.

.topic 12
Версия Excel используемых файлов.

.topic 13
Эти параметры используются для изменения размещения и версии файлов Excel.

.topic 14
Эти параметры используются для настройки атрибутов конкретных драйверов.

.topic 15
Настройка атрибутов драйвера.

.topic 16
Размещение выбранного каталога Excel.

.topic 17
Размещение выбранной книги Excel.

.topic 201
Добавление расширения, которое было введено в поле "Расширение".

.topic 202
Закрытие диалогового окна без сохранения изменений.

.topic 203
Имя источника данных, например Payroll или Personnel и каталог данных по умолчанию, в котором драйвер ODBC ведет поиск файлов данных.

.topic 204
Если флажок установлен, могут использоваться все файлы в каталоге. Если флажок снят, список расширений включает расширения по умолчанию *.asc, *.csv, *.tab и *.txt; расширения могут быть добавлены и удалены по необходимости.

.topic 205
Открытие диалогового окна "Определение текстового формата", в котором определяются форматы столбцов и указываются схемы таблиц в каталоге источника данных.

.topic 206
Необязательное описание данных из источника данных; например "Дата приема на работу, выплачиваемая зарплата и отметки сотрудников".

.topic 207
Расширение файла, которое следует добавить; формат: *.ххх. Например, чтобы использовать файлы .dat, введите *.dat.

.topic 208
Расширения имен файлов текстовых файлов в источнике данных, в зависимости от состояния флажка "По умолчанию".

.topic 214
Данные параметры используются для форматирования конкретных типов файлов.

.topic 215
Данные параметры используются для добавления в список "Расширения" или удаления из списка "Расширения" тех расширений файлов, которые не заданы по умолчанию. Для добавления расширений файлов снимите флажок "По умолчанию", введите новое расширение в поле "Расширение" и нажмите кнопку "Добавить".

.topic 216
Данные параметры используются для выбора расположения текстового файла и отображения имени файла.

.topic 209
Вызов справки для этого диалогового окна.

.topic 210
Закрытие диалогового окна настройки и сохранение изменений.

.topic 211
Удаление выбранного расширения файла из списка "Расширения".

.topic 212
Открытие диалогового окна "Выбор каталога", в котором выбирается каталог, содержащий необходимые файлы.

.topic 213
Выбор текущего рабочего каталога приложения в качестве каталога источника данных. Если этот флажок снят, для выбора источника данных нажмите кнопку "Выбор каталога".

.topic 217
Настройка атрибутов текстового файла; добавление или удаление типов текстовых файлов.

.topic 218
Расположение текстового файла.

.topic 301
Добавление столбца с использованием значений в полях Тип данных, Имя и Ширина.

.topic 302
Закрытие диалогового окна без сохранения изменений.

.topic 321
Набор символов ANSI или OEM.

.topic 303
Выбор набора символов ANSI для формата элемента, выбранного в списке "Таблицы".

.topic 304
Если этот флажок установлен, столбцы из первой строки выбранной таблицы используются как имена столбцов.

.topic 305
В этом списке перечисляются имена всех столбцов таблицы, выбранной в списке Таблицы, причем сохраняется порядок столбцов в таблице.

.topic 319
Возможность определения атрибутов столбцов для выбранного текстового файла.

.topic 306
Тип данных. Возможные значения BIT, BYTE, CHAR, CURRENCY, DATE, FLOAT, INTEGER, LONGCHAR, SHORT или SINGLE.

.topic 307
Специальный разделительный знак, используемый для разделения столбцов. Должен быть только один знак. Использование двойных кавычек (") запрещено. Это поле доступно, если в поле Формат выбрано значение Спец разделители.

.topic 308
Выбор формата с разделителем или с фиксированной длиной; в случае использования формата с разделителем, указывается тип разделителя.

.topic 309
Нажмите эту кнопку, чтобы содержимое таблицы было просмотрено в соответствии со значением в поле Формат и на основе полученных данных были определены типы данных, имена и ширина столбцов. Эта кнопка доступна, если для таблицы выбран формат с разделителем.

.topic 310
Вызов справки для этого диалогового окна.

.topic 311
Изменение выбранного столбца с использованием значений в полях Тип данных, Имя и Ширина.

.topic 312
Имя выбранного столбца. В этом поле может быть указано новое имя существующего или нового столбца.

.topic 313
Закрытие диалогового окна с сохранением изменений.

.topic 314
Удаление выбранного столбца.

.topic 315
Число строк, просматриваемых программой установки или драйвером при настройке столбцов и типов данных столбцов. Если формат элемента, выбранного в списке Таблицы не определен, по умолчанию имеет значение 25, но могут вводиться любые значения от 1 до 32767.

.topic 316
Список всех файлов, соответствующих списку расширений, указанных в диалоговом окне Установка текстового драйвера ODBC. Выберите файл, чтобы отобразить или изменить атрибуты его таблицы.

.topic 320
Эти параметры используются для определения атрибутов выбранного текстового файла.

.topic 317
The width of the column; can be changed for CHAR or LONGCHAR columns. Для других типов данных поле Ширина недоступно и в нем не отображается значение. Если формат элемента, выбранного в списке Таблицы не определен, по умолчанию используется значение 1.

.topic 318
Выбор набора символов, не являющегося ANSI(набор по умолчанию), для формата элемента, выбранного в списке "Таблицы".

.topic 401
Закрытие диалогового окна без сохранения изменений.

.topic 402
Порядок сортировки полей (ASCII (по умолчанию) или международный, Шведско-финский или Норвежско-датский набор знаков).

.topic 403
Имя источника данных, например Payroll или Personnel, и каталог по умолчанию, в котором драйвер ODBC осуществляет поиск файлов данных.

.topic 404
Необязательное описание данных из источника данных; например "Дата приема на работу, выплачиваемая зарплата и отметки сотрудников".

.topic 405
Если этот флажок установлен, база данных открывается в монопольном режиме, в котором доступ к ней может получить только один пользователь, что увеличивает быстродействие. Если этот флажок не установлен, база данных открывается в режиме совместного доступа и может открываться несколькими пользователями одновременно.

.topic 406
Вызов справки для этого диалогового окна.

.topic 407
Выбор типа доступа к сети, используемого при доступе к данным Paradox: любо "3.x" для Paradox 3.x, либо "4.x" для Paradox 4.x или 5.x. Если используется Paradox 4.X или 5.X, выберите "3.x" или "4.x"; если используется Paradox 3.X, необходимо выбрать "3.x".

.topic 408
Закрытие диалогового окна настройки и сохранение изменений.

.topic 409
Время (в десятых долях секунды) хранения неиспользуемых страниц в буфере. По умолчанию имеет значение 600 (или 60 секунд). Должно быть больше нуля.

.topic 410
Открытие диалогового окна "Выбор каталога", в котором выбирается каталог, содержащий необходимые файлы.

.topic 415
Расположение файла Paradox.

.topic 411
Перед выбором сетевого каталога необходимо ввести следующие сведения для Paradox.
 Имя пользователя в поле "Пользователь". Затем нажмите кнопку "Выбор сетевого каталога".
 Сетевой каталог.

.topic 416
Путь к каталогу, содержащему заблокированную базу данных Paradox и либо файл Pdoxusrs.net (в Paradox 4.x), либо файл Paradox.net (в Paradox 5.x). Если в каталоге нет одного из этих файлов, он создается драйвером Paradox.

.topic 412
Выбор текущего рабочего каталога приложения в качестве каталога источника данных. Если этот флажок снят, для выбора источника данных нажмите кнопку "Выбор каталога".

.topic 413
Имя пользователя Paradox отображается для других пользователей файлов Paradox, когда они сталкиваются с блокировкой.

.topic 414
Версия используемых файлов Paradox (например Paradox 4.x или Paradox 5.x).

.topic 417
Эти параметры используются для выбора и отображения версии и расположения базы данных Paradox.

.topic 418
Эти параметры используются для настройки драйвера Paradox.

.topic 419
Настройка атрибутов драйвера.

.topic 501
Если этот флажок установлен, статистика на уровне таблицы округляется. Это параметр применяется для всех источников данных, использующих драйвер dBase.

.topic 502
Закрытие диалогового окна без сохранения изменений.

.topic 503
Порядок сортировки полей (ASCII (по умолчанию) или международный набор знаков).

.topic 504
Имя источника данных, например Payroll или Personnel, и каталог по умолчанию, в котором драйвер ODBC осуществляет поиск файлов данных.

.topic 505
Необязательное описание данных из источника данных; например "Дата приема на работу, выплачиваемая зарплата и отметки сотрудников".

.topic 506
Если этот флажок установлен, база данных открывается в монопольном режиме, в котором доступ к ней может получить только один пользователь, что увеличивает быстродействие. Если этот флажок не установлен, база данных открывается в режиме совместного доступа и может открываться несколькими пользователями одновременно.

.topic 507
Вызов справки для этого диалогового окна.

.topic 508
Закрытие диалогового окна настройки и сохранение изменений.

.topic 509
Время (в десятых долях секунды) хранения неиспользуемых страниц в буфере. По умолчанию имеет значение 600 (или 60 секунд). Должно быть больше нуля.

.topic 515
Расположение базы данных dBase.

.topic 510
Открытие диалогового окна "Выбор каталога", в котором выбирается каталог, содержащий необходимые файлы.

.topic 511
Открытие диалогового окна "Выбор индексов", в котором файлы dBase связываются с файлами индексов.

.topic 512
Если этот флажок установлен, строки, помеченные как удаленные, могут загружаться и размещаться. Если этот флажок снят (по умолчанию), удаленные строки не отображаются. Если он установлен, удаленные строки отображаются как неудаленные.

.topic 513
Выбор текущего рабочего каталога приложения в качестве каталога источника данных. Если этот флажок снят, для выбора источника данных нажмите кнопку "Выбор каталога".

.topic 514
Версия используемых файлов dBase (например dBASE III, dBASE IV или dBASE 5.0).

.topic 516
Эти параметры используются для выбора и отображения версии и расположения базы данных dBase.

.topic 517
Эти параметры используются для настройки драйвера dBase.

.topic 518
Настройка атрибутов драйвера.

.topic 701
Установка дополнительных параметров драйвера, определяющих быстродействие.

.topic 702
Размер внутреннего буфера (в килобайтах), используемого Microsoft Access для переноса данных с диска и на диск. По умолчанию размер буфера составляет 2048 Кбайт (отображается как 2048). Введите любое целое число, кратное 256.

.topic 703
Закрытие диалогового окна без сохранения изменений.

.topic 704
Создание базы данных Access.

.topic 705
Освобождение неиспользуемого места, занимаемого существующей базой данных Access.

.topic 706
Имя источника данных, например Payroll или Personnel, и каталог по умолчанию, в котором драйвер ODBC осуществляет поиск файлов данных.

.topic 707
Размещение выбранной базы данных Access. Чтобы выбрать базу данных, нажмите кнопку "Выбрать".

.topic 708
Необязательное описание данных из источника данных; например "Дата приема на работу, выплачиваемая зарплата и отметки сотрудников".

.topic 709
Если этот флажок установлен, база данных открывается в монопольном режиме, в котором доступ к ней может получить только один пользователь, что увеличивает быстродействие. Если этот флажок не установлен, база данных открывается в режиме совместного доступа и может открываться несколькими пользователями одновременно.

.topic 710
Вызов справки для этого диалогового окна.

.topic 711
Если системная база данных не будет использоваться, выберите этот параметр, чтобы войти в указанную базу данных Access под именем "Admin" ("defaultUser").

.topic 712
Закрытие диалогового окна настройки и сохранение изменений.

.topic 713
Время (в десятых долях секунды) хранения неиспользуемых страниц в буфере. По умолчанию имеет значение 0,5 секунд. Должно быть больше нуля.

.topic 714
Выбор доступа к базе данных только для чтения. Обновления запрещаются.

.topic 715
Восстановление поврежденной базы данных Access.

.topic 716
Выбор базы данных Access.

.topic 723
Включение использования системной базы данных. Затем нажмите кнопку "Системная база данных".

.topic 717
Открытие диалогового окна "Выбор системной базы данных", в котором выбирается системная база данных (база данных для рабочей группы).

.topic 718
Эти параметры используется для просмотра расположения базы данных Access и выполнения функций управления базой данных.

.topic 719
Эти параметры используются для выбора системной базы данных (базы данных рабочей группы) и просмотра ее расположения.

.topic 720
Размещение выбранной базы данных Access.

.topic 721
Эти параметры используются для настройки драйвера Access.

.topic 722
Настройка атрибутов драйвера.


Файлы Access

В драйверы ODBC Desktop Database Drivers 4.0 входят следующие файлы ISAM для драйвера Microsoft Access.

32-разрядный файл ISAM | Версия Microsoft Access
Нет (включены в файл Msjet40.dll) | 7.0 и 97
Msrd2x40.dll | 2.0
Msrd3x40.dll | 3.0

Примечание. Если используется система Microsoft Windows 95/98 (не Microsoft Windows NT/Windows 2000) и на компьютере не установлен Microsoft Access, добавьте в файл Config.sys строку «FILES= 50».


Вход в системную базу данных для Access

При подключении к базе данных Access, ранее определенной как системная, в диалоговом окне Вход вводятся имя и пароль для входа в базу данных Access. Имена и пароли для входа назначаются администратором базы данных и должны вводиться без изменений.

В поле Источник данных указывается источник данных, с которым устанавливается соединение.

Примечание. Если источник данных не выбран, нажмите кнопку База данных, чтобы назначить его.

Нажмите кнопку OK, чтобы закрыть окно и запустить процесс входа в базу данных.

Нажмите кнопку Отмена, чтобы закрыть окно и отменить процесс входа в базу данных.


Файлы стандартных компонентов ODBC

В следующей таблице перечислены файлы, необходимые для каждого компонента драйверов ODBC Desktop Database Drivers 4.0. В системе Windows 95 и более поздних версиях эти файлы устанавливаются в каталоге \Windows\System directory. В системах Windows NT и Windows 2000 они устанавливаются в каталоге \Windows\System32. Если ранее файлы ODBC были установлены в другом каталоге, убедитесь, что используются новые файлы из каталога \Windows\System (или System32).

Некоторые файлы используются несколькими компонентами. Если драйверы ODBC Desktop Database Drivers поставляются вместе с коммерческими приложениями, эти файлы также должны поставляться.

Следующие файлы являются стандартными файлами для каждого драйвера ODBC Desktop Database Drivers.

Ds16gt.dll
Ds32gt.dll
Expsrv.dll
Msjint40.dll
Msjet40.dll
Msjter40.dll
Msjtes40.dll
Msvcrt40.dll 		Odbc16gt.dll
Odbc32.dll
Odbc32gt.dll
Odbccp32.cpl
Odbccp32.dll
Odbccr32.dll
Odbcinst.chm
Odbcint.dll 		Odbcjet.chm
Odbcji32.dll
Odbcjt32.dll
Odbctl32.dll
Vbajet32.dll
Odbctrac.dll


Диалоговое окно «База данных для сжатия»

При сжатии базы данных имеющиеся данные сохраняются, но освобождается неиспользуемое место на диске, занятое базой данных. В диалоговом окне База данных для сжатия выбирается сжимаемая база данных. В нем также может быть выбран доступ в ходе сжатия: запись и чтение (по умолчанию), только чтение (запрещаются все обновления) или монопольный.

Для сжатия данных может использоваться диалоговое окно Установка драйвера ODBC для Microsoft Access. Нажмите кнопку Сжать и выберите путь и имя файла в окне База данных для сжатия. Нажмите кнопку OK. В диалоговом окне Сжатие базы данных под именем выберите файл и путь, версию сжатого файла, национальные настройки и нажмите кнопку OK. Файл сжатой базы данных может иметь то же имя, что и файл сжимаемой базы данных. Однако, если имя файла сжатой базы данных совпадает с именем другого существующего файла, отображается сообщение об ошибке. Сжатие файлов, защищенных паролем, может привести к непредсказуемым результатам.


Диалоговое окно «Создание базы данных»

Введите полный путь к создаваемой базе данных Microsoft Access.

Если используется драйвер Microsoft Access, для создания новой базы данных нажмите кнопку Создать.

Примечание. Созданная таким способом база данных будет работать только с Microsoft Access версии 7.0 или более поздней.

Если при установке не были созданы базы данных, при подключении к источнику данных будет предложено выбрать файл базы данных.

Диалоговое окно Создание базы данных включает следующие элементы.

Имя и расположение базы данных | Указывается имя и расположение новой базы данных.
Национальные настройки | Указываются национальные настройки (LCID) или язык для базы данных.
Формат | Формат механизма Microsoft Jet Database Engine. Возможные значения: «Версия 4.x» (последняя версия, формат Unicode), «Версия 3.x» (формат ANSI) и «Версия 2.x» (формат ANSI).
Параметры | Если установлен флажок Системная база данных, к создаваемой базе данных может открываться совместный доступ, она будет записана на вкладке Системный DSN в администраторе источников данных ODBC При установке флажка Шифрование включается соответствующий параметр Access. Механизм Microsoft Jet Database Engine версии 4.0 позволяет шифровать базы данных при создании. Дополнительные сведения см. в Руководстве программиста по Jet Database Engine. Этот параметр доступен, только если выбран формат «Версия 4.x».


Преобразование источника данных

32-разрядные источники данных, используемые с драйверами ODBC Desktop Database Drivers версии 2.0, автоматически преобразуются в новые 32-разрядные источники данных для драйверов версии 4.0. 16-разрядные источники данных не преобразуются. Чтобы преобразовать 16-разрядный источник данных в 32-разрядный, создайте новый 32-разрядный источник и (необязательно) удалите старый 16-разрядный источник. Одно имя не может использоваться для 16- и 32-разрядного источников.


Файлы dBASE

В драйверы ODBC Desktop Database Drivers 4.0 входят следующие файлы ISAM для драйвера Microsoft dBase.

32-разрядный файл ISAM | Версии dBASE
Msxbse40.dll Oddbse32.dll | dBASE III dBASE IV dBASE 5.0


Диалоговое окно «Установка драйвера ODBC для dBASE»

Диалоговое окно Установка драйвера ODBC для dBASE включает следующие элементы.

Сведения об источнике данных | Указывается база данных dBASE. По умолчанию используется имя, назначенное производителем. Поле Описание по умолчанию пусто. В нем может быть введено описание.
База данных | Выберите любую версию установленной базы данных dBase и укажите ее расположение. Если установлен флажок Использовать текущий каталог, кнопки Выбор каталога и Выбор индексов недоступны.
Параметры Нажмите эту кнопку, чтобы изменить следующие параметры.
  • Порядок сортировки. Выбор порядка сортировки.

  • Время ожидания страницы. Время (в десятых долях секунды) хранения неиспользуемых страниц в буфере. Это значение всегда должно быть больше нуля.

  • Монопольный доступ. Если этот флажок установлен, доступ к базе может получить только один пользователь.

  • Показ удаленных строк. Если этот флажок установлен, строки, помеченные как удаленные, могут загружаться и размещаться.

  • Примерное число строк. Если этот флажок установлен, статистика на уровне таблицы округляется.

Примечание. Подробные сведения об этом драйвере содержатся на узле msdn.microsoft.com. (Откройте электронную библиотеку MSDN, а затем Platform SDK, чтобы найти раздел MDAC SDK, содержащий раздел ODBC Drivers.) Другие сведения можно найти в этом файле в разделах Преобразование источника данных, Файлы dBase , Записи реестра IISAM и Файлы стандартных компонентов ODBC.


Диалоговое окно «Определение текстового формата»

Диалоговое окно Определение текстового формата используется для определения формата столбцов в выбранном файле и для указания схемы каждой таблицы данных. Диалоговое окно Определение текстового формата включает следующие элементы.

Добавить | Добавление столбца с использованием значений в полях Тип данных, Имя и Ширина.
Набор знаков | ANSI или OEM. Значение OEM указывает набор знаков, отличный от ANSI, и используется по умолчанию, если не определен формат элемента, выбранного в списке Таблицы.
Заголовок с именами столбцов | Если этот флажок установлен, столбцы из первой строки выбранной таблицы используются как имена столбцов. Если формат элемента, выбранного в списке Таблицы не определен, флажок по умолчанию снят.
Столбцы | В этом списке перечисляются имена всех столбцов таблицы, выбранной в списке Таблицы, причем сохраняется порядок столбцов в таблице.
Тип данных | Может принимать значения BIT, BYTE, Char, CURRENCY, Date, Float, INTEGER, LONGCHAR, SHORT И SINGLE. Для данных типа дат могут использоваться форматы «дд-ммм-гг», «мм-дд-гг», «ммм-дд-гг», «гггг-мм-дд» и «гггг-ммм-дд». (обозначение «мм» соответствует номеру месяца, «ммм» соответствует сокращению названия месяца.)
Разделитель | Специальный разделительный знак, используемый для разделения столбцов. Должен быть только один знак. Использование двойных кавычек (") запрещено. Это поле доступно, если в поле Формат выбрано значение Спец разделители.
Формат | Выбирается или тип разделителя или фиксированная длина. Если используется разделитель, указывается тип используемого разделителя: запятая (CSV), табуляция, или особый знак (специальный). Если формат элемента, выбранного в списке Таблицы не определен, по умолчанию используется значение Разделители CSV. Если в поле Формат выбрана фиксированная длина и установлен флажок Заголовок с именами столбцов, первая строка должна быть разделена запятыми.
Предположить | Нажмите эту кнопку, чтобы содержимое таблицы было просмотрено в соответствии со значением в поле Формат и на основе полученных данных были определены типы данных, имена и ширина столбцов. Эта кнопка доступна, если для таблицы выбран формат с разделителем. Столбцы, ранее определенные в списке Столбцы, удаляются и заменяются новыми записями. Если флажок Заголовок с именами столбцов не установлен, создаются имена столбцов «F1», «F2» и так далее. Эта функция может применяться только для столбцов, размер которых не превышает 64 513 байт.
Изменить | Изменение выбранного столбца с использованием значений в полях Тип данных, Имя и Ширина.
Имя | Имя выбранного столбца. В этом поле может быть указано новое имя существующего или нового столбца. Если установлен флажок Заголовок с именами столбцов, отображаемое имя столбца не учитывается.
Удалить | Удаление выбранного столбца.
Строк для просмотра | Число строк, просматриваемых программой установки или драйвером при настройке столбцов и типов данных столбцов. Если формат элемента, выбранного в списке Таблицы не определен, по умолчанию имеет значение 25, но могут вводиться любые значения от 1 до 32767.
Таблицы | Список всех файлов, соответствующих списку расширений, указанных для каталога, выбранного в диалоговом окне Установка текстового драйвера ODBC. Если выбрано значение (По умолчанию), список Столбцы не доступен.
Ширина | Это значение может изменяться для столбцов типа CHAR и LONGCHAR. Для других типов данных поле Ширина недоступно и в нем не отображается значение. Если формат элемента, выбранного в списке Таблицы не определен, по умолчанию используется значение 1.


Файлы Excel

В драйверы ODBC Desktop Database Drivers 4.0 входят следующие файлы ISAM для Excel.

32-разрядный файл ISAM | Версии Microsoft Excel
Msexcl40.dll Odexl32.dll | 3.0, 4.0, 5.0, 7.0, 97

Драйвер Microsoft Excel не предназначен для чтения файлов Excel, версия формата которых раньше 3.0. Однако эти файлы могут быть открыты в Microsoft Excel более поздней версии и сохранены в формате версии 3.0, 4.0, 5.0, 7.0 или 97, который может быть прочтен драйвером.


Записи реестра IISAM

Значения реестра IISAM записываются во всех соответствующих файлах IISAM DLL при вызове функции DLLRegisterServer и удаляются при вызове функции DLLUnregisterServer. Функция DLLRegisterServer динамически вызывается функцией Jet ODBC для каждого файла IISAM DLL. Например, если при инициализации подключения с помощью любого файла IISAM происходит сбой, драйвер пытается инициализировать этот файл IISAM (для этого вызывается функция DLLRegisterServer) и повторяет попытку подключения.


Диалоговое окно «Установка драйвера ODBC для Microsoft Excel»

Диалоговое окно Установка драйвера ODBC для Microsoft Excel включает следующие элементы.

Сведения об источнике данных | Указывается файл Excel. Поле Описание по умолчанию пусто. Оно может содержать ваше описание.
База данных | Эти параметры предназначены для изменения местоположения файла, используемого по умолчанию. Если требуется изменить местоположение, нажмите кнопку Выбор каталога или Выбор книги (в зависимости от версии Excel, выбранной в поле Версия).
Драйвер | В поле Строк для просмотра указывается число строк, просматриваемых программой установки или драйвером при настройке столбцов и типов данных столбцов. Может быть указано любое целое число от 1 до 16. Установите флажок Только чтение, чтобы запретить обновление файла Excel.

Примечание. Подробные сведения об этом драйвере содержатся на узле msdn.microsoft.com. (Откройте электронную библиотеку MSDN, а затем Platform SDK, чтобы найти раздел MDAC SDK, содержащий раздел ODBC Drivers.) Другие сведения можно найти в этом файле в разделах Преобразование источника данных, Файлы Excel, Записи реестра IISAM и Файлы стандартных компонентов ODBC. Предоставляется поддержка продукта.


Диалоговое окно «Установка текстового драйвера ODBC»

Диалоговое окно Установка текстового драйвера ODBC включает следующие элементы.

Сведения об источнике данных | Указывается файл. Поле Описание по умолчанию пусто. В нем может быть введено описание.
База данных | Расположение файла по умолчанию. Если требуется изменить расположение, нажмите кнопку Выбор каталога.
Файлы | Список расширений имен текстовых файлов в источнике данных. Чтобы использовать все файлы в каталоге, установите флажок По умолчанию (*.*). Чтобы использовать только файлы с указанными расширениями, снимите флажок По умолчанию (*.*) и добавьте необходимые расширения. После снятия флажка По умолчанию (*.*) используются расширения *.asc, *.csv, *.tab и *.txt. Чтобы добавить расширение, введите его в поле Расширение и нажмите кнопку Добавить. При вводе расширений должен использоваться формат *.xxx. Например, чтобы использовать файлы .dat, введите *.dat. Чтобы удалить расширение, выберите его в списке расширений и нажмите кнопку Удалить.
Определить формат | Диалоговое окно Определение текстового формата используется для определения формата столбцов в выбранном файле и для указания схемы каждой таблицы данных. Примечание. Если используется текстовый драйвер, при выполнении инструкции CREATE TABLE с именем без расширения создается файл без расширения. Чтобы в диалоговом окне Определение текстового формата отображались файлы без расширения, в список расширений в диалоговом окне Установка текстового драйвера ODBC необходимо добавить «*.».

Примечание. Подробные сведения об этом драйвере содержатся на узле msdn.microsoft.com. (Откройте электронную библиотеку MSDN, а затем Platform SDK, чтобы найти раздел MDAC SDK, содержащий раздел ODBC Drivers.) Дополнительные сведения можно найти в этом файле в разделах Преобразование источника данных, Записи реестра IISAM, Текстовые файлы ISAM и Файлы стандартных компонентов ODBC.


Файлы Paradox

В драйверы ODBC Desktop Database Drivers 4.0 входят следующие файлы ISAM для Paradox.

32-разрядный файл ISAM | Версии Paradox
Mspdox40.dll Odpdx32.dll | Paradox 3.x Paradox 4.x Paradox 5.x


Поддержка продукта

Поскольку во многих продуктах корпорации Майкрософт драйверы ODBC используются как основные компоненты и эти продукты поставляются вместе с драйверами ODBC, службы поддержки Microsoft рассматривают эти драйверы как компоненты продуктов, в которые они входят. Поддержка ODBC предоставляется в соответствии с соглашением о поддержке соответствующего продукта. Дополнительные сведения см. в документации соответствующих продуктов.


Диалоговое окно «Восстановление базы данных»

В окне Восстановление базы данных выбирается база данных для восстановления. В нем также может быть выбран доступ в ходе восстановления: запись и чтение (по умолчанию), только чтение (запрещаются все обновления) или монопольный.

Если в ходе передачи возникает сбой, соответствующая база данных может быть повреждена и потребуется ее восстановление. Для выполнения восстановления может использоваться диалоговое окно Установка драйвера ODBC для Microsoft Access. Нажмите кнопку Восстановить и выберите путь и имя файла в окне Восстановление базы данных. Нажмите кнопку OK.


Диалоговое окно «Выбор базы данных»

Если при установке не были созданы базы данных, при подключении к источнику данных будет предложено выбрать файл базы данных.

Если используется драйвер Microsoft Access, нажмите кнопку Выбрать в диалоговом окне Установка драйвера ODBC для Microsoft Access, чтобы открыть существующую базу данных в диалогов окне Выбор базы данных. Это окно включает следующие элементы.

Имя базы данных | Имя файла существующей базы данных с расширением .mdb.
Только чтение | Выбор доступа к базе данных только для чтения. Обновления запрещаются.
Монопольный доступ | Если этот флажок установлен, база данных открывается в монопольном режиме, в котором доступ к ней может получить только один пользователь, что увеличивает быстродействие. Если этот флажок не установлен, база данных открывается в режиме совместного доступа и может открываться несколькими пользователями одновременно.


Диалоговое окно «Выбор индексов»

Диалоговое окно Выбор индексов включает следующие элементы.

Таблицы | Список всех файлов в выбранном источнике данных.
Индексы | Список индексов, назначенных файлу, выбранному в списке Таблицы.
Тип файлов | Выбор типов файлов, отображаемых в списке Индексы.

Драйвер ODBC dBASE автоматически открывает и обновляет файлы индексов dBASE IV. Файлы .ndx для dBase III связываются с файлами dBase в диалоговом окне Выбор индексов.

При создании индексов dBASE применяются следующие ограничения.

  • Имена всех столбцов должны быть допустимыми.

  • Все столбцы должны быть упорядочены одним способом: по возрастанию или по убыванию.

  • Длина любого отдельного текстового столбца не должна превышать 100 байт.

  • Если имеется несколько столбцов, все они должны быть тестовыми и их общий размер не должен превышать 100 байт.

  • Для полей заметок не могут создаваться индексы.

  • Для текущего набора полей не должен быть указан индекс. (Это связано с запретом на существование дубликатов индексов.)

  • Имя индекса должно соответствовать соглашению по именам dBase. Индексы dBase III должны храниться в отдельных файлах с расширением .ndx. В dBASE IV индексы создаются как имена тегов, которые хранятся в одном файле с расширением .mdx, имя которого совпадает с именем файла базы данных. (Например, файл Emp.mdx является индексом базы данных Emp.dbf.)

Чтобы связать индекс с таблицей:

  1. Выберите файл в списке Таблицы.

  2. Выберите индекс в списке Индексы.

  3. Нажмите кнопку OK, чтобы сохранить связи таблиц и индексов.

Примечание. Драйвер может распознавать только те индексы dBase III, которые созданы с помощью этого диалогового окна.


Диалоговое окно «Выбор системной базы данных»

Если используется драйвер Microsoft Access, установите переключатель База данных и нажмите кнопку Системная база данных в диалоговом окне Установка драйвера ODBC для Microsoft Access, чтобы выбрать системную базу данных в диалоговом окне Выбор системной базы данных. В зависимости от требований безопасности системы драйвер запрашивает имя и пароль системной базы данных. По умолчанию используется имя «Admin», для которого по умолчанию в качестве пароля Microsoft Access используется пустая строка.

Диалоговое окно Выбор системной базы данных включает следующие элементы.

Имя базы данных | Имя файла существующей базы данных с расширением .mdb.
Только чтение | Выбор доступа к базе данных только для чтения. Обновления запрещаются.
Монопольный доступ | Если этот флажок установлен, база данных открывается в монопольном режиме, в котором доступ к ней может получить только один пользователь, что увеличивает быстродействие. Если этот флажок не установлен, база данных открывается в режиме совместного доступа и может открываться несколькими пользователями одновременно.


Диалоговое окно «Выбор книги»

В диалоговом окне Выбор книги указывается расположение файла книги Microsoft Excel. Выбранный файл отображается в поле Имя базы данных. Чтобы запретить обновление этого файла, установите флажок Только чтение. Для поиска нужного файла книги используются поля Каталоги, Тип файлов и Диски. Чтобы найти книгу в сети, нажмите кнопку Сеть.


Диалоговое окно «Дополнительные параметры»

Чтобы воспользоваться диалоговым окном Дополнительные параметры, необходимо ввести имя и пароль для этого драйвера.

Если источник данных использует системную базу данных (базу данных рабочей группы), то в зависимости от требований безопасности системы драйвер запрашивает имя и пароль пользователя. По умолчанию используется имя «Admin», для которого по умолчанию в качестве пароля Microsoft Access используется пустая строка.

При доступе к любой базе данных Access драйвером используются следующие параметры, имеющиеся в окне Дополнительные параметры.

DefaultDir | Каталог, открываемый драйвером по умолчанию.
Driver | Используется для ввода пользовательского имени драйвера Access.
FIL | Тип файла. Для Microsoft Access имеет значение «MS Access».
ExtendedAnsiSQL | Атрибут строки подключения. Значение "1" включает возможности Jet 4.0, такие как создание и уничтожение представлений и процедур, определение усечения данных, создание типов данных и использование списка зарезервированных слов SQL-92. По умолчанию используется значение "0", при котром эти возможности не включаются.
ImplicitCommitSync | Способ записи в базу данных изменений, выполняемых не в рамках транзакции. Этот параметр по умолчанию имеет значение «Yes», что означает, что драйвер Microsoft Access ждет завершения передачи во внутренней/неявной транзакции.
MaxBufferSize | Размер внутреннего буфера (в килобайтах), используемого Microsoft Access для переноса данных с диска и на диск. По умолчанию размер буфера составляет 2048 Кбайт (отображается как 2048). Это значение может быть любым целым числом, кратным 256. В этом поле выбирается тот же параметр, что и в поле Размер буфера диалогового окна Настройка.
MaxScanRows | Число строк, которые могут просматриваться при выборе типа данных столбца на основе имеющихся данных. Может принимать значения от 1 до 16. По умолчанию используется значение 8. Если выбран 0, просматриваются все строки. (При выборе значения, не попадающего в указанный диапазон, выдается сообщение об ошибке.)
PageTimeout | Время (в десятых долях секунды) хранения неиспользуемых страниц в буфере. Для драйвера Microsoft Access по умолчанию используется значение 0.5. Оно должно быть больше нуля. Этот параметр применяется для всех источников данных, использующих драйвер Microsoft Access.
ReadOnly | Выбор доступа к базе данных только для чтения. Обновления запрещаются.
SafeTransactions | Если имеет значение 0 (по умолчанию), все транзакции передаются немедленно. Если имеет значение 1, все транзакции сохраняются на диске только после операции передачи. При этом немного снижается быстродействие.
Threads | Число фоновых потоков, используемых механизмом. По умолчанию имеет значение 3. Число потоков может быть увеличено, если базой данных выполняется большое число операций.
UserCommitSync | Укажите, будут ли явные определенные пользователем операции выполняться драйвером Microsoft Access асинхронно. Этот параметр по умолчанию имеет значение «Yes», что означает, что драйвер Microsoft Access ждет завершения передачи в определенной пользователем транзакции. Выбор значения «No» может привести к непредсказуемым результатам транзакций в многопользовательской среде.


Текстовые файлы ISAM

В драйверы ODBC Desktop Database Drivers 4.0 входят два 32-разрядных файла, предназначенных для текстовых файлов: Mstext40.dll и Odtext32.dll.


Диалоговое окно «Установка драйвера ODBC для Paradox»

Диалоговое окно Установка драйвера ODBC для Paradox включает следующие элементы.

Сведения об источнике данных | Указывается база данных Paradox. По умолчанию используется имя, назначенное производителем. Поле Описание по умолчанию пусто. В нем может быть введено описание.
База данных | Укажите расположение базы данных Paradox с помощью этих параметров или используйте текущий каталог. Кроме того, может быть указана конкретная версия любой установленной базы данных.
Параметры Нажмите эту кнопку, чтобы изменить параметры драйвера, определяющие доступ, службы и быстродействие.
  • Порядок сортировки. Порядок сортировки полей.

  • Монопольный доступ. Если этот флажок установлен, доступ к базе может получить только один пользователь. Увеличивает быстродействие.

  • Время ожидания страницы. Время (в десятых долях секунды) хранения неиспользуемых страниц в буфере.

  • Пользователь. Имя пользователя Paradox отображается для других пользователей файлов Paradox, когда они сталкиваются с блокировкой.

  • Тип сети. Тип доступа к сети, используемый при доступе к данным Paradox.

Примечание. Подробные сведения об этом драйвере содержатся на узле msdn.microsoft.com. (Откройте электронную библиотеку MSDN, а затем Platform SDK, чтобы найти раздел MDAC SDK, содержащий раздел ODBC Drivers.) Другие сведения можно найти в этом файле в разделах Преобразование источника данных, Файлы Paradox , Записи реестра IISAM и Файлы стандартных компонентов ODBC. Paradox является продуктом корпорации INPRISE и поставляется с собственным файлом справки.