Общие сведения об автономных файлах

Сетевые файлы можно сделать доступными в автономном режиме, сохранив общие файлы на локальном компьютере, чтобы они были доступны при отсутствии подключения к сети.

Это может быть полезно при использовании переносного компьютера для выполнения большей части работы или в том случае, если компьютер часто бывает отключен от сети. С автономными файлами можно работать так же, как и при наличии подключения к сети.

При восстановлении подключения к сети все изменения, внесенные в файлы при работе в автономном режиме, переносятся в сетевые файлы. Этот процесс называется синхронизацией. Если сетевой файл был изменен еще кем-то, предоставляется возможность сохранить в сети новую версию файла, оставить старую версию или сохранить обе версии.

Если папки локального компьютера предоставлены для общего доступа по сети, другие пользователи смогут работать с этими папками в автономном режиме. Для защиты файлов в общих папках можно предоставить другим пользователям разрешения на изменение документов или только на их просмотр. Также можно ограничить перечень общих файлов, с которыми пользователи смогут работать в автономном режиме.

Примечания

  • Любые общие файлы или папки в сети Microsoft Windows могут быть сделаны доступными в автономном режиме. Сделать файлы доступными в автономном режиме можно с любого компьютера, на котором включена служба совместного доступа к файлам и принтерам по протоколу SMB, включая компьютеры с Windows 95, Windows 98, Windows NT 4.0 и XOX. В сетях Novell NetWare работа с автономными файлами невозможна.
  • Системный администратор может настраивать общие папки так, чтобы при открытии любого сетевого файла в данной папке он становился доступным для автономной работы, или так, чтобы доступными для автономной работы становились только некоторые выбранные файлы.

См. также


Настройка компьютера для использования автономных файлов

Рисунок Microsoft Windows

Чтобы настроить компьютер для использования автономных файлов

  1. Откройте папку Мой компьютер.
  2. В меню Сервис выберите команду Свойства папки.
  3. Убедитесь в том, что на вкладке Автономные файлы установлен флажок Использовать автономные файлы.
  4. Чтобы включить полную синхронизацию, установите флажок Синхронизировать перед выходом из системы. Для быстрой синхронизации оставьте этот флажок снятым.

Примечания

  • XOX
  • Полная синхронизация обеспечивает наличие текущих версий всех общих сетевых файлов, которые были сделаны доступными для автономной работы. Быстрая синхронизация обеспечивает наличие полной версии каждого автономного файла, но может не всегда обеспечивать наличие текущих версий. Если с файлом работаете только вы и наличие последней версии файла не требуется, можно выбрать быструю синхронизацию.
  • Если требуется выбирать автономные файлы для синхронизации, время синхронизации и режим вывода запроса перед синхронизацией, можно воспользоваться диспетчером синхронизации. XOX
  • После настройки компьютера для использования автономных файлов необходимо сделать общие сетевые файлы доступными в автономном режиме. XOX


Предоставление возможности автономной работы с веб-страницами

Чтобы сделать веб-страницы доступными в автономном режиме

  1. Откройте обозреватель Internet Explorer.
  2. Перейдите к веб-странице, которую требуется сделать доступной в автономном режиме.
  3. Выберите в меню Избранное команду Добавить в избранное.
  4. Установите флажок Сделать доступной автономно.
  5. Чтобы задать расписание обновления веб-страницы и объем загружаемых данных, нажмите кнопку Настройка.
  6. Следуйте инструкциям, появляющимся на экране.

Примечания

  • XOX
  • Дополнительные сведения об использовании веб-страниц в автономном режиме см. в справке по Internet Explorer.


Прекращение доступа к автономным файлам

Чтобы прекратить доступ к автономным файлам

  1. Откройте папку Мой компьютер.
  2. В меню Сервис выберите команду Свойства папки.
  3. На вкладке Автономные файлы нажмите кнопку Дополнительно.
  4. Нажмите кнопку Добавить.
  5. Введите имя сетевого компьютера или нажмите кнопку Обзор для поиска компьютера, содержащего файлы, доступ к которым при отключении от сети не требуется.
  6. В группе Когда теряется сетевое подключение выберите параметр никогда не переходить в автономный режим.

Примечания

  • XOX
  • Данный процесс делает файлы с указанных компьютеров недоступными при отсутствии подключения к сети.
  • Также можно задать ответ используемого компьютера на запрос автономных файлов со всех компьютеров сети при отсутствии подключения к сети. На вкладке Автономные файлы нажмите кнопку Дополнительно. В группе Когда теряется сетевое подключение выберите один из следующих параметров:
    • для получения уведомления о потере сетевого подключения и продолжения работы с файлами, доступными в автономном режиме, выберите параметр уведомлять и переходить в автономный режим;
    • чтобы при потере сетевого подключения делать все автономные файлы недоступными, выберите параметр никогда не переходить в автономный режим.


Дата компиляции

 Дата компиляции 01.09.2001


Удаление автономных файлов

Чтобы удалить автономные файлы

  1. Откройте папку Мой компьютер.
  2. В меню Сервис выберите команду Свойства папки.
  3. На вкладке Автономные файлы нажмите кнопку Удалить файлы.
  4. В диалоговом окне Подтверждение удаления файла установите флажок рядом с именем общей папки, содержащей автономные файлы, которые требуется удалить.
  5. Выполните одно из следующих действий.
    • Чтобы удалить копии сетевых файлов, которые Windows автоматически сохраняет на компьютере, выберите вариант Удалить только временные автономные файлы.
    • Чтобы удалить сетевые файлы, сохраненные на компьютере автоматически, и сетевые файлы, которые были сделаны доступными в автономном режиме специально, выберите параметр Удалить и временные и постоянные версии файлов, доступных в автономном режиме.

Примечания

  • XOX
  • Для удаления отдельных автономных файлов нажмите кнопку Просмотр на вкладке Автономные файлы. Выделите файлы, которые требуется удалить. В меню Файл выберите команду Удалить.
  • Временные автономные файлы также называют автоматически кэшированными файлами. Эти общие сетевые файлы при их открытии автоматически загружаются и становятся доступными на локальном компьютере. Эти файлы не требуется делать доступными в автономном режиме, они становятся доступными автоматически. Windows может удалить их из локального кэша в любое время, если потребуется дополнительное дисковое пространство для других временных файлов.
  • Общие сетевые файлы, которые сделаны доступными в автономном режиме специально, доступны всегда. Эти файлы могут быть удалены с компьютера только пользователем.


Шифрование автономных файлов.

Чтобы включить шифрование автономных файлов

  1. Откройте папку Мой компьютер.
  2. В меню Сервис выберите команду Свойства папки.
  3. На вкладке Автономные файлы установите флажок Шифровать автономные файлы для защиты данных.

Примечания

  • XOX
  • Если флажок Шифровать автономные файлы для защиты данных установлен и отображается серым, автономные файлы либо частично зашифрованы, либо частично расшифрованы. О текущем состоянии файлов сообщается во всплывающей подсказке для флажка. Для шифрования файлов дважды щелкните флажок, чтобы установить его. Для расшифровки файлов щелкните флажок, чтобы снять его.
  • При следующих условиях флажок Шифровать автономные файлы для защиты данных недоступен:
    1. текущий пользователь не является администратором компьютера;
    2. локальный диск не является диском NTFS или не поддерживает шифрование;
    3. системным администратором внедрена политика шифрования для автономных файлов.


Предоставление возможности автономной работы с файлом или папкой

Чтобы сделать файл или папку доступными в автономном режиме

  1. Откройте папку Мой компьютер.
  2. Дважды щелкните значок сетевого диска для просмотра его содержимого.
  3. Выделите общий сетевой файл или папку, которые требуется сделать доступными в автономном режиме.
  4. В меню Файл выберите команду Сделать доступным автономно.

    5. Важно!

    • Команда Сделать доступным автономно отображается в меню Файл только в том случае, если компьютер настроен для использования автономных файлов. XOX

Примечания

  • XOX
  • Если папка «Мой компьютер» не содержит ссылки на сетевые диски, необходимо назначить общему сетевому ресурсу букву диска. XOX
  • Для просмотра списка всех общих сетевых файлов, доступных в автономном режиме, выберите в меню Сервис команду Свойства папки. На вкладке Автономные файлы нажмите кнопку Просмотр.
  • Если все файлы в общей папке сделаны доступными в автономном режиме, любые файлы, помещаемые в эту папку, будут автоматически становиться доступными в автономном режиме при следующей синхронизации компьютера с сетью. Перечень файлов, доступных в автономном режиме, определяется сетевым администратором.
  • Для файлов, доступных в автономном режиме, можно создавать ярлыки. Однако, если создать ярлык для папки, доступной в автономном режиме, содержимое этой папки не будет доступно в автономном режиме.
  • Чтобы сделать сетевой файл или папку недоступными в автономном режиме, щелкните нужный объект правой кнопкой и выберите команду Сделать доступным автономно еще раз, чтобы снять галочку.


Подготовка к работе в автономном режиме

Для обеспечения возможности работы с файлами и программами в автономном режиме необходимо настроить компьютер для использования автономных файлов. Работа в автономном режиме означает работу с общими сетевыми файлами, папками и программами при отсутствии подключения к сети. В автономном режиме также можно работать с веб-страницами с веб-узла организации или из Интернета. Для подготовки к работе в автономном режиме выполните следующие процедуры. Для переносных и автономных компьютеров используются эти же процедуры.

Настройка компьютера для использования автономных файлов

По умолчанию компьютер настроен для использования автономных файлов, но необходимо выбрать параметр синхронизации для определения версий используемых сетевых файлов.

Пошаговые инструкции

Предоставление возможности автономной работы с файлом или папкой

При первом предоставлении сетевого файла или папки для автономной работы выполнить необходимые действия помогает мастер автономных файлов. После исчезновения диалогового окна Синхронизация объект становится доступным для работы в автономном режиме.

Пошаговые инструкции

Предоставление возможности автономной работы с веб-страницами

С помощью Microsoft Internet Explorer можно делать веб-страницы или целые веб-узлы доступными для просмотра в автономном режиме. Мастер предлагает указать объем содержимого, которое требуется сделать доступным в автономном режиме. Также можно задать расписание автоматической синхронизации содержимого.

Поскольку для просмотра веб-страниц, доступных в автономном режиме, используется Internet Explorer, параметры автономных файлов, заданные с помощью папки «Мой компьютер» в диалоговом окне Свойства папки, не применяются к веб-страницам, доступным в автономном режиме. Вместо них используются параметры, доступные для автономных веб-страниц в Internet Explorer.

Пошаговые инструкции

Прекращение доступа к автономным файлам

Общие программы и файлы с конкретных сетевых компьютеров можно сделать недоступными в автономном режиме. Это полезно в случае, когда работу в автономном режиме по умолчанию требуется продолжить, но автономная работа над файлами с конкретного компьютера в сети нежелательна.

Пошаговые инструкции


Изменение доступа к автономным файлам для общих папок

Чтобы изменить доступ к автономным файлам для общих папок

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой общую папку или диск и выберите команду Доступ.
  3. Нажмите кнопку Кэширование.
  4. Убедитесь, что флажок Разрешить кэширование файлов в этой общей папке установлен.
  5. Выберите нужный параметр.

    6. Ручное кэширование документов

    Обеспечивает доступ в автономном режиме только к файлам, указанным пользователем. Данный параметр кэширования идеален для общих папок, содержащих файлы, с которыми будут работать несколько пользователей. Ручной режим кэширования устанавливается по умолчанию при предоставлении доступа к общей папке в автономном режиме.

    Автоматическое кэширование документов

    Каждый открываемый файл в общей папке становится доступным в автономном режиме. Более старые копии файлов автоматически удаляются, освобождая место для более новых версий.

    Автоматическое кэширование программ и документов

    Предоставляет автономный доступ к общим папкам, содержащим неизменяемые файлы. Данный параметр кэширования снижает сетевой трафик, так как автономные файлы открываются без доступа к сетевым версиям. Автономные файлы обычно запускаются и выполняются быстрее, чем сетевые версии.

    При использовании автоматического кэширования программ и документов файлы в общей папке следует сделать доступными только для чтения.

Примечания

  • XOX
  • По умолчанию под кэш выделяется 10 процентов доступного дискового пространства, но это значение можно изменить. Откройте вкладку Автономные файлы и перетащите ползунок Место на диске для временных автономных файлов вправо, чтобы увеличить размер кэша, или влево, чтобы уменьшить размер кэша.
  • Чтобы узнать текущий размер кэша, откройте папку папку автономных файлов и выберите в меню Файл команду Свойства.


Просмотр автономных файлов

Чтобы просмотреть автономные файлы

  1. Откройте папку Мой компьютер.
  2. В меню Сервис выберите команду Свойства папки.
  3. На вкладке Автономные файлы нажмите кнопку Просмотр.

Примечание

  • XOX


Работа в автономном режиме

Windows помогает работать в автономном режиме, делая возможным использование общих сетевых файлов и программ даже при отсутствии подключения к сети. После настройки портативного или автономного компьютера для работы в автономном режиме можно продолжать работать с общими сетевыми файлами как обычно.

При работе с автономными файлами их можно просматривать в папке «Автономные файлы», а также удалять их из этой папки. Также может потребоваться задать способ и частоту синхронизации файлов или включить шифрование автономных файлов. Эти задачи и некоторые общие вопросы о работе в автономном режиме рассмотрены ниже.

Просмотр автономных файлов

При выборе файла в папке «Автономные файлы» отображаются сведения о его доступности, типе, расположении и размере.

Пошаговые инструкции

Удаление автономных файлов

При удалении файлов из папки «Автономные файлы» сетевые версии этих файлов не удаляются. Имеется возможность удалять только временные автономные файлы или все автономные файлы.

Пошаговые инструкции

Управление синхронизацией файлов

При настройке компьютера для работы с автономными файлами может быть выбран вариант, при котором в Microsoft Windows выполняется автоматическая синхронизация для всех автономных файлов. Либо можно выбирать автономные файлы для синхронизации, время синхронизации, а также включать и выключать запрос перед синхронизацией с помощью диспетчера синхронизации.

Пошаговые инструкции

Шифрование автономных файлов

Для обеспечения безопасности автономных файлов их можно зашифровать, если диск имеет формат NTFS. Если включен режим шифрования автономных файлов, файлы на локальном компьютере зашифровываются так же, как и файлы в сети. Расшифровывать зашифрованные файлы или папки перед их использованием не требуется.

Пошаговые инструкции

Типичные вопросы о работе в автономном режиме.

Как узнать об изменении сетевого подключения?

При изменении состояния подключения в области состояния отображается значок автономных файлов и информационная выноска, оповещающая об изменении состояния подключения. Когда подключение к сети не установлено, поверх значка сетевого диска в разделах «Мой компьютер» и «Мое сетевое окружение» отображается красная метка «X». При просмотре этих дисков отображаются только файлы, к которым был открыт доступ в автономном режиме.

Изменяются ли мои привилегии при работе в автономном режиме?

Привилегии для работы с сетевыми файлами или папками, к которым открыт доступ в автономном режиме, сохраняются независимо от наличия подключения к сети. Например, если к файлу на сетевом диске имеется доступ только для чтения, при отсутствии подключения к сети право на чтение этого файла сохранится.

Возможна ли печать на сетевых принтерах при работе в автономном режиме?

При отсутствии подключения к сети печать на сетевых принтерах невозможна. Для печати можно использовать локальные принтеры.

Что происходит при восстановлении подключения к сети?

При восстановлении подключения к сети сетевые файлы синхронизируются с вашими автономными файлами. Это значит, что сетевые файлы обновляются в соответствии с изменениями, внесенными при работе в автономном режиме. Если сетевые копии файлов, измененных в автономном режиме, не были изменены другими пользователями, ваши изменения копируются в сеть. Если изменения были внесены другими пользователями, можно выбрать сохранение вашей версии, сохранение версии, имеющейся в сети, либо сохранение этих двух версий.

Если к компьютеру подключены несколько пользователей, открывших файлы из одной общей папки, синхронизация файлов этого компьютера будет невозможна до тех пор, пока эти пользователи не закроют свои файлы.

Если вы удалили автономный файл и его копия в сети была изменена другим пользователем, файл будет удален с локального компьютера, но не из сети.

Если вы изменили автономный файл и его копия в сети была удалена другим пользователем, можно сохранить вашу версию в сети или удалить этот файл с локального компьютера.

Если после отключения от сети в общую сетевую папку был добавлен новый файл, этот файл будет скопирован на локальный компьютер, когда будет восстановлено подключение и выполнена синхронизация.