Общие сведения о поиске в Active Directory

Active Directory — служба каталогов, которая предоставляет сведения об объектах каталога в ответ на запросы пользователей и программ. Сведения обо всех объектах в сети, включая людей, группы, компьютеры, принтеры, общие папки и подразделения, каталогизируются и распределяются по сети. Администраторы и пользователи могут легко осуществлять поиск сведений в каталоге при помощи окна поиска или с помощью функций поиска папки Active Directory — пользователи и компьютеры.

Пользователи, контакты и группы

Поиск пользователей, контактов и групп в Active Directory просто выполнить, выбрав в поле со списком значение Пользователи, контакты и группы. Чтобы выполнить поиск пользователя, контакта или группы, следует указать условия поиска, в частности имя руководителя пользователя, примечание, описывающее особые интересы пользователя, или имя лица, являющегося членом определенной группы. Для найденного пользователя, контакта или группы можно отправить сообщение по электронной почте или открыть домашнюю страницу путем щелчка правой кнопкой мыши объекта в списке результатов поиска и выбора команды Отправить почту или Открыть домашнюю страницу.

Компьютеры

Используйте окно Поиск компьютеров для поиска компьютеров в Active Directory с помощью таких параметров, как имя, назначенное компьютеру, или операционная система, под управлением которой работает компьютер. Управление найденным компьютером осуществляется щелчком правой кнопкой мыши компьютера в списке результатов поиска и выбором команды Управление.

Принтеры

Если общий принтер был опубликован в Active Directory, значение поля со списком Принтеры может использоваться для его поиска с помощью таких параметров, как его регистрационный номер, применяемый язык печати или наличие возможности двусторонней печати. Подключение к найденному принтеру легко осуществляется щелчком правой кнопкой мыши принтера в списке результатов поиска и выбором команды Подключить или двойным щелчком принтера.

Общие папки

После опубликования общей папки в Active Directory поиск может осуществляться выбором в поле со списком пункта Общие папки при помощи различных условий поиска, например назначенных ключевых слов, имени папки или имени лица, управляющего папкой. Чтобы просмотреть файлы, содержащиеся в найденной папке, откройте проводник двойным щелчком папки в списке результатов поиска и выбором команды Проводник.

Организационные подразделения

Подразделение является контейнерным объектом Active Directory, который используется для группирования и организации объектов в доменах. В то время как пользователи, группы, компьютеры и другие подразделения могут помещаться в эти логические контейнеры, подразделение может содержать только объекты из родительского домена. Выберите в поле со списком пункт Организационные подразделения для выполнения поиска подразделений, с применением таких параметров, как общее имя, назначенное подразделением.

Особый поиск

Кроме поиска обычных объектов, таких как компьютеры, принтеры и пользователи, в Active Directory также может осуществляться поиск других объектов, например конкретного подразделения или шаблона сертификатов. Выберите в поле со списком значение Особый поиск для создания запросов на особый поиск с применением расширенных параметров поиска, а также для создания расширенных запросов поиска с применением протокола Lightweight Directory Access Protocol (LDAP), который является основным протоколом доступа к Active Directory. Дополнительные сведения см. в разделе Общие сведения о LDAP (Lightweight Directory Access Protocol)

Общие запросы

Для выполнения общих административных запросов в Active Directory выберите поле Общие запросы. Например, можно быстро найти пользователя или учетные записи компьютеров, которые были отключены. Также существует параметр для поиска только имен групп без пользователей и контактов.

В зависимости от конфигурации компьютеры с операционной системой Windows 2000 Professional или Windows XP Professional могут быть ограничены только поиском принтеров. Дополнительные сведения см. в разделе Чтобы найти принтер.

Для получения дополнительных сведений об Active Directory посетите веб-узел Active Directory Programmer's Guide, доступ к которому предоставлен MSDN и ссылку на который можно найти на веб-узле корпорации Майкрософт (http://www.microsoft.com/).


Поиск пользователя, контакта или группы

Рисунок Microsoft Windows

Чтобы найти пользователя, контакт или группу

  1. В поле со списком Найти выберите объект Пользователи, контакты и группы.
  2. В поле В выберите домен или подразделение, в котором требуется выполнить поиск, или нажмите кнопку Обзор, чтобы выбрать нужный домен или подразделение.
  3. Введите условия поиска на вкладках Пользователи, контакты и группы и Дополнительно.
    • На вкладке Пользователи, контакты и группы введите имя и описание пользователя, контакта или группы.
    • На вкладке Дополнительно указываются специальные поля, задающие условия поиска.
  4. Нажмите кнопку Найти, чтобы запустить поиск, или кнопку Очистить все, чтобы очистить поля условий поиска и начать новый поиск.

Примечания

  • Для найденного пользователя, контакта или группы можно отправить сообщение по электронной почте или открыть домашнюю страницу щелчком правой кнопкой мыши объекта в списке результатов поиска и выбором команды Отправить почту или Открыть домашнюю страницу.
  • Если требуется задать диспетчер в особом или расширенном поиске, выберите в списке Поле одно из двух значений: Управляется или Руководитель, в поле Условие выберите значение совпадает, а в поле Значение введите различающееся имя. Чтобы выяснить различающееся имя диспетчера, обратитесь к администратору сети.
  • При некоторых конфигурациях компьютера эта процедура может не работать на компьютерах под управлением Windows 2000 Professional и Windows XP Professional. Для получения дополнительных сведений обратитесь к администратору сети.

См. также


Поиск компьютера

Чтобы найти компьютер

  1. В поле со списком Найти выберите Компьютеры.
  2. В поле в выберите домен или подразделение, в котором требуется выполнить поиск, или нажмите кнопку Обзор, чтобы выбрать нужный домен или подразделение.
  3. Введите условия поиска на вкладках Компьютеры и Дополнительно следующим образом.
    • На вкладке Компьютеры введите имя компьютера, владельца компьютера и роль (Любая, Рабочие станции и серверы или Контроллер домена).
    • С помощью специальных полей на вкладке Дополнительно поиск может уточняться путем указания таких параметров поиска как, например, операционная система, используемая компьютером.
  4. Нажмите кнопку Найти, чтобы запустить поиск, или кнопку Очистить все, чтобы очистить поля условий поиска и начать новый поиск.

Примечания

  • Управление найденным компьютером осуществляется с помощью средства управления компьютером путем щелчка правой кнопкой мыши компьютера в списке результатов поиска и выбора команды Управление.
  • Если требуется задать диспетчер в особом или расширенном поиске, выберите в списке Поле одно из двух значений: Управляется или Руководитель, в поле Условие выберите значение совпадает, а в поле Значение введите различающееся имя. Чтобы выяснить различающееся имя диспетчера, обратитесь к администратору сети.
  • При некоторых конфигурациях компьютера эта процедура может не работать на компьютерах под управлением Windows 2000 Professional и Windows XP Professional. Для получения дополнительных сведений обратитесь к администратору сети.


Чтобы на йти принтер

Чтобы найти принтер

  1. В поле со списком Найти выберите Принтеры.
  2. В поле в выберите домен или подразделение, в котором требуется выполнить поиск, или нажмите кнопку Обзор, чтобы выбрать нужный домен или подразделение.
  3. Введите условия поиска.
    • На вкладке Принтеры введите имя, местоположение и модель принтера.

      • Если в поле Место присутствует значение, то это означает, что сетевой администратор настроил сеть так, что Windows будет по умолчанию пытаться найти ближайший к вам принтер. Можно также нажать кнопку Обзор, чтобы выполнить поиск принтера в другом месте.

    • На вкладке Возможности можно указать дополнительные условия поиска, такие как возможность двусторонней печати или печати с определенным разрешением.
    • На вкладке Дополнительно задаются специальные поля, определяющие такие условия, как возможность разбора по копиям или поддержка определенного языка принтера.
  4. Нажмите кнопку Найти, чтобы запустить поиск, или кнопку Очистить все, чтобы очистить поля условий поиска и начать новый поиск.

Примечания

  • При открытии диалогового окна Поиск компьютеров с помощью кнопки Пуск нет необходимости выполнять шаг 1.
  • Если в области результатов поиска показано слишком много принтеров, введите дополнительные условия, чтобы уточнить поиск. Для получения дополнительных сведений об использовании расширенных способов поиска щелкните ссылку «См. также».
  • Чтобы подключиться к принтеру, показанному в области результатов, щелкните его правой кнопкой мыши и выберите команду Подключить, либо просто дважды щелкните этот принтер.


Поиск общей папки

Чтобы найти общую папку

  1. В поле со списком Найти выберите Общие папки.
  2. В поле В выберите домен или подразделение, в котором требуется выполнить поиск, или нажмите кнопку Обзор, чтобы выбрать нужный домен или подразделение.
  3. Введите условия поиска на вкладках Общие папки и Дополнительно.
    • На вкладке Общие папки введите имя папки и любые ключевые слова, назначенные папке.
    • С помощью специальных полей на вкладке Дополнительно поиск может уточняться путем указания таких условий поиска, как, например, сетевой путь каталога.
  4. Нажмите кнопку Найти, чтобы запустить поиск, или кнопку Очистить все, чтобы очистить поля условий поиска и начать новый поиск.

Примечания

  • Если требуется задать диспетчер в особом или расширенном поиске, выберите в списке Поле одно из двух значений: Управляется или Руководитель, в поле Условие выберите значение совпадает, а в поле Значение введите различающееся имя. Чтобы выяснить различающееся имя диспетчера, обратитесь к администратору сети.
  • При некоторых конфигурациях компьютера эта процедура может не работать на компьютерах под управлением Windows 2000 Professional и Windows XP Professional. Для получения дополнительных сведений обратитесь к администратору сети.


Поиск подразделения

Чтобы найти подразделение

  1. В поле со списком Найти выберите Организационные подразделения.
  2. В поле В выберите домен или подразделение, в котором требуется выполнить поиск, или нажмите кнопку Обзор, чтобы выбрать нужный домен или подразделение.
  3. Выполните следующие действия.
    • На вкладке Организационные подразделения введите имя организационного подразделения.
    • На вкладке Дополнительно указываются специальные поля, задающие условия поиска.
  4. Нажмите кнопку Найти, чтобы запустить поиск, или кнопку Очистить все, чтобы очистить поля критериев поиска и начать новый поиск.

Примечания

  • Если требуется задать диспетчер в особом или расширенном поиске, выберите в списке Поле одно из двух значений: Управляется или Руководитель, в поле Условие выберите значение совпадает, а в поле Значение введите различающееся имя. Чтобы выяснить различающееся имя диспетчера, обратитесь к администратору сети.
  • При некоторых конфигурациях компьютера эта процедура может не работать на компьютерах под управлением Windows 2000 Professional и Windows XP Professional. Для получения дополнительных сведений обратитесь к администратору сети.


Поиск клиентов удаленной установки

Чтобы найти клиентов удаленной установки

  1. В поле со списком Найти выберите Клиенты удаленной установки.
  2. В поле В выберите домен или подразделение, в котором требуется выполнить поиск, или нажмите кнопку Обзор, чтобы выбрать нужный домен или подразделение.
  3. На вкладке Клиенты удаленной установки введите глобальный уникальный идентификатор (GUID) клиентского компьютера и имя сервера удаленной установки (RI).
  4. Нажмите кнопку Найти, чтобы запустить поиск, или кнопку Очистить все, чтобы очистить поля условий поиска и начать новый поиск.

Примечания

  • Параметры вкладки Клиенты удаленной установки доступны при условии, что на сервере установлены службы удаленной установки (RIS)
  • Если требуется задать диспетчер в особом или расширенном поиске, выберите в списке Поле одно из двух значений: Управляется или Руководитель, в поле Условие выберите значение совпадает, а в поле Значение введите различающееся имя. Чтобы выяснить различающееся имя диспетчера, обратитесь к администратору сети.
  • При некоторых конфигурациях компьютера эта процедура может не работать на компьютерах под управлением Windows 2000 Professional и Windows XP Professional. Для получения дополнительных сведений обратитесь к администратору сети.


Создание особого поиска

Чтобы создать особый поиск

  1. В поле со списком Найти выберите Особый поиск.
  2. В поле в выберите домен или подразделение, в котором требуется выполнить поиск, или нажмите кнопку Обзор, чтобы выбрать нужный домен или подразделение.
  3. Выполните одно из следующих действий.
    • На вкладке Особый поиск нажмите кнопку Поле и выберите возможность или атрибут, по которым нужно выполнить поиск.
    • На вкладке Дополнительно поиск может вестись путем ввода запроса в соответствии со стандартом LDAP (Lightweight Directory Access Protocol).
  4. Нажмите кнопку Найти, чтобы запустить поиск, или кнопку Очистить все, чтобы очистить поля условий поиска и начать новый поиск.

Примечания

  • Для получения дополнительных сведений о LDAP щелкните ссылку «См. также».
  • Если требуется задать диспетчер в особом или расширенном поиске, выберите в списке Поле одно из двух значений: Управляется или Руководитель, в поле Условие выберите значение совпадает, а в поле Значение введите различающееся имя. Чтобы выяснить различающееся имя диспетчера, обратитесь к администратору сети.
  • При некоторых конфигурациях компьютера эта процедура может не работать на компьютерах под управлением Windows 2000 Professional и Windows XP Professional. Для получения дополнительных сведений обратитесь к администратору сети.


Выполение общего запроса

Чтобы выполнить общий запрос

  1. В поле со списком Найти выберите значение Компьютеры.
  2. В поле в выберите домен или подразделение, в котором требуется выполнить поиск, или нажмите кнопку Обзор, чтобы выбрать нужный домен или подразделение.
  3. Выполните одно из следующих действий.
    • Для выполнения общего запроса пользователя на вкладке Пользователи введите имя пользователя и описание учетной записи.
    • Для выполнения общего запроса компьютера на вкладке Компьютеры введите имя компьютера и его описание.
    • Для выполнения общего запроса группы на вкладке Группы введите имя группы и ее описание.
  4. Нажмите кнопку Найти, чтобы запустить поиск, или кнопку Очистить все, чтобы очистить поля условий поиска и начать новый поиск.

Примечание

  • При некоторых конфигурациях компьютера эта процедура может не работать на компьютерах под управлением Windows 2000 Professional и Windows XP Professional. Для получения дополнительных сведений обратитесь к администратору сети.


Фильтрация результатов поиска

Чтобы профильтровать результаты поиска

  1. Выполните поиск для объекта Active Directory.
  2. В меню Вид выберите команду Фильтр, чтобы включить средство фильтрации.
  3. Под заголовком соответствующего столбца области результатов поиска введите соответствующее значение.
  4. Щелкните значок фильтра рядом с текстовым полем и выберите необходимое условие.
  5. Повторите шаги 3 и 4 для всех столбцов, которые должен использовать фильтр. Каждый налагаемый фильтр уменьшает список результатов поиска.

Примечания

  • Для отображения заголовков столбцов необходимо выбрать в меню Вид команду Таблица. При просмотре результатов поиска в виде значков или списка фильтрация недоступна.
  • При каждом изменении текстовых полей или условий фильтра список будет автоматически заново отсортирован. Не нажимайте кнопку Найти, так как это приведет к сбросу данных фильтра.
  • Чтобы отключить фильтр, выберите в меню Вид команду Фильтр.
  • Чтобы отсортировать объекты, перечисленные в области результатов поиска, щелкните заголовок соответствующего столбца.


Добавление или удаление столбцов в таблице результатов поиска

Чтобы добавить или удалить столбцы в таблице результатов поиска

  1. Выполните поиск для объекта Active Directory.
  2. В меню Вид выберите команду Таблица.
  3. В меню Вид выберите команду Выбрать столбцы.
  4. В окне Выбор столбцов выполните одно из следующих действий:
    • чтобы добавить столбец, щелкните имя столбца в списке Доступные столбцы и нажмите кнопку Добавить;
    • чтобы удалить столбец, щелкните имя столбца в списке Отображаемые столбцы и нажмите кнопку Удалить.

Примечания

  • Добавляйте столбцы в том порядке, в котором они должны отображаться в области результатов поиска. Чтобы переместить столбец в другое место, необходимо сначала удалить его, а затем добавить в то место, где он должен отображаться.
  • Чтобы просмотреть все столбцы в области результатов поиска, возможно, потребуется развернуть окно, изменить ширину столбцов или воспользоваться полосой прокрутки.
  • Чтобы отсортировать объекты, перечисленные в области результатов поиска, щелкните заголовок соответствующего столбца.


Использование дополнительных возможностей для поиска

Чтобы использовать дополнительные возможности для поиска

  1. На вкладке Дополнительно (или на вкладке Особый поиск диалогового окна Особый поиск) нажмите кнопку Поле и выберите свойство или атрибут, по которому должен осуществляться поиск.
  2. В поле Условие выберите нужное условие.
  3. В поле Значение введите требуемое значение и нажмите кнопку Добавить.
  4. Повторите шаги 1-3 для каждого искомого параметра и затем нажмите кнопку Найти.

Примечания

  • Для получения сведений о поиске объектов Active Directory, таких как люди, группы, компьютеры, принтеры, общие папки и подразделения, щелкните ссылку «Cм. также».
  • Если требуется задать диспетчер в особом или расширенном поиске, выберите в списке Поле одно из двух значений: Управляется или Руководитель, в поле Условие выберите значение совпадает, а в поле Значение введите различающееся имя. Чтобы выяснить различающееся имя диспетчера, обратитесь к администратору сети. При поиске принтера нельзя выбирать значения Руководитель или Управляется.


Сохранение запроса поиска

Чтобы сохранить запрос поиска

  1. Откройте оснастку Пользователи и компьютеры Active Directory.
  2. В дереве консоли щелкните правой кнопкой мыши узел Сохраненные запросы или любую из его подпапок, в которую необходимо сохранить запрос.

    3. Где?

    • Пользователи и компьютеры Active Directory
    • Сохраненные запросы
  3. Выберите команды Создать и Запрос.
  4. В поле Имя введите название запроса.
  5. Введите описание в поле Описание.
  6. Для определения корневого размещения, с которого требуется начать поиск, нажмите кнопку Обзор.

    Чтобы найти все подконтейнеры из выбранного, установите флажок Включая подконтейнеры.

  7. Чтобы задать запрос, нажмите кнопку Запрос.

Примечания

  • XOX
  • Чтобы эффективно организовать сохраненные запросы, можно создать подпапки, дважды щелкнув правой кнопкой мыши узел Сохраненные запросы и выбрав поля Создать и Папка.
  • При некоторых конфигурациях компьютера эта процедура может не работать на компьютерах под управлением Windows 2000 Professional и Windows XP Professional. Для получения дополнительных сведений обратитесь к администратору сети.


Поиск контроллеров домена

В окне поиска контроллеров домена отображаются все контроллеры домена, входящие в состав леса. Если в данном лесе имеется большое число контроллеров домена, список может фильтроваться для отображения определенного набора контроллеров домена.

Диалоговое окно Поиск контроллеров домена доступно только из окна «Сайты и службы Active Directory» при создании нового объекта подключения.

Для получения дополнительных сведений о подключениях см. Чтобы добавить или настроить подключения вручную и Цели и стратегии репликации.


Общие сведения о протоколе LDAP (Lightweight Directory Access Protocol)

Основным протоколом доступа, который используется в Active Directory для создания запросов и получения сведений, является LDAP (Lightweight Directory Access Protocol) — общепринятый в качестве стандарта протокол служб каталогов. Будучи разработанным для использования в сетях TCP/IP, LDAP определяет то, как клиент каталога осуществляет доступ к серверу каталогов, участвует в совместном доступе к данным в каталоге и выполняет различные операции над каталогом.

LDAP был создан как эффективный и простой протокол доступа к каталогам; в данном протоколе определяются способы безопасного доступа к сведениям в каталоге и указываются допустимые действия по запрашиванию и изменению данных сведений. Это означает, что для поиска и вывода объектов, а также для запрашивания и администрирования Active Directory используется один и тот же протокол.

Так как LDAP является открытым стандартом Интернета, закрепленным группой IETF (Working Groups of the Internet Engineering Task Force), Active Directory работает с другими службами, использующими данный протокол. С использованием LDAP могут разрабатываться программы, позволяющие службам каталогов на основе LDAP осуществлять совместный доступ к сведениям Active Directory.

Для получения дополнительных сведений об Active Directory посетите веб-узел Active Directory Programmer's Guide, доступ к которому предоставлен MSDN и ссылку на который можно найти на веб-узле корпорации Майкрософт (http://www.microsoft.com/). Для получения дополнительных сведений о группе Internet Engineering Task Force, посетите веб-узел Internet Engineering Task Force.

Примечание

  • XOX