Общие сведения об упаковщике объектов

Упаковщик объектов — это средство, позволяющее создавать пакеты, которые затем можно вставлять в файлы.

Окно упаковщика объектов разделено на две области. В области Вид отображается значок, который будет представлять пакет. В области Содержание отображается имя файла, содержащего данные, которые требуется упаковать.

Чтобы создать пакет, следует скопировать содержимое областей Вид и Содержание в буфер обмена, а затем вставить в файл. Пакет отображается в файле в виде значка.

Для работы с пакетом следует дважды щелкнуть его значок. При этом, в зависимости от содержимого пакета, будет выполнено одно из следующих действий.

  • Если пакет содержит звукозапись или видеозапись, она будут воспроизведена.
  • Если пакет содержит рисунок, текст или электронную таблицу, данные будут открыты в программе, связанной с соответствующим типом файлов. Например, если пакет содержит точечный рисунок, созданный в графическом редакторе Paint, этот рисунок будет открыт в графическом редакторе Paint.

Примечание

  • Вставка пакета в файл возможна только в том случае, если этот файл был создан приложением для Windows, поддерживающим перетаскивание объектов.

См. также


Создание пакета

Создать пакет можно либо с помощью упаковщика объектов, либо с помощью проводника Windows. Далее перечислены требования к каждому из этих способов.

  • Для упаковки части файла необходимо использовать упаковщик объектов, причем приложение, в котором был создан файл, должно поддерживать перетаскивание объектов.
  • Для упаковки файла целиком можно использовать как упаковщик объектов, так и проводник Windows. Содержимое пакета в этом случае может быть создано любой программой.

См. также


Изменение значка пакета

Рисунок Microsoft Windows

Чтобы изменить значок пакета

  1. Выберите в меню Файл команду Импорт, чтобы определить расположение документа, значок которого требуется изменить.
  2. В области Вид нажмите кнопку Значок.
  3. В поле Имя файла введите имя и путь к программе, значок которой требуется использовать (например, C:\winnt\system32\Mspaint.exe), или нажмите кнопку Обзор, чтобы найти нужную программу.
  4. Выберите значок, который требуется использовать, и нажмите кнопку OK.

См. также


Изменение метки значка

Чтобы изменить метку значка

  1. Выберите в меню Файл команду Импорт, чтобы определить расположение документа, метку значка которого требуется изменить.
  2. В меню Правка выберите команду Метка.
  3. Введите новый текст метки и нажмите кнопку OK.

См. также


Создание пользовательского значка

Чтобы создать пользовательский значок

  1. В графическом редакторе Microsoft Paint или любом другом редакторе создайте или откройте рисунок, который требуется использовать в качестве значка.
  2. Выделите весь рисунок или фрагмент, который требуется использовать для значка.
  3. В меню Правка выберите команду Копировать.
  4. В упаковщике объектов щелкните любое место области Вид.
  5. В меню Правка выберите команду Вставить.
  6. В меню Файл выберите команду Сохранение содержимого, а затем нажмите кнопку Сохранить, чтобы связать значок с файлами в области Содержание.

Примечание

  • Создаваемые значки не имеют меток.

См. также


Создание пакета, содержащего файл целиком

Чтобы создать пакет, содержащий файл целиком

  1. В меню Файл выберите команду Импорт.
  2. Щелкните значок файла, который требуется упаковать, или выберите папку, чтобы найти нужный файл, а затем нажмите кнопку Открыть.
  3. В меню Правка выберите команду Копировать пакет.
  4. Откройте файл, в который требуется вставить существующий пакет, а затем щелкните место вставки.
  5. В меню Правка приложения файла выберите команду Вставить.

Примечания

  • Некоторые программы автоматически помещают пакет в левый верхний угол окна.
  • В упаковщик объектов можно импортировать любой файл, но для вставки пакета в файл необходимо, чтобы этот файл был создан приложением для Windows, поддерживающим перетаскивание объектов.

См. также


Cоздание пакета, содержащего часть файла

Чтобы создать пакет, содержащий часть файла

  1. Выделите нужную часть в файле, содержащем данные, которые требуется упаковать.
  2. В меню Правка окна файла выберите команду Копировать.
  3. В упаковщике объектов щелкните любое место области Содержание.
  4. В меню Правка упаковщика объектов выберите команду Вставить, чтобы внедрить данные в упаковщик объектов.
  5. В меню Правка упаковщика объектов выберите команду Копировать пакет.
  6. Откройте файл, в который вставляется пакет, и щелкните место вставки.
  7. В меню Правка окна файла выберите команду Вставить. Некоторые программы автоматически помещают пакет в левый верхний угол окна.

Примечание

  • Оба файла (исходный, содержащий выделенные данные, и конечный, в который вставляется пакет) должны быть созданы с помощью программ, поддерживающих перетаскивание объектов.

См. также


Изменение внедренных данных

Чтобы изменить внедренные данные

  1. Выберите пакет в файле, содержащем внедренные данные, которые требуется изменить.
  2. В меню Правка выберите команды Объект Пакет и Изменить пакет.
  3. В области Содержание окна упаковщика объектов дважды щелкните описание или рисунок.
  4. Измените данные.
  5. В меню Файл выберите команду Выход. Чтобы сохранить изменения, внесенные в файл, нажмите кнопку Да.
  6. Чтобы применить внесенные изменения, выберите команду Обновить в меню Файл упаковщика объектов.


Изменение связанных данных

Чтобы изменить связанные данные

  1. Выберите пакет в файле, содержащем связанные данные, которые требуется изменить.
  2. В меню Правка выберите команды Объект Пакет и Изменить пакет.
  3. В области Содержание окна упаковщика объектов дважды щелкните описание или рисунок.
  4. Измените данные.
  5. В меню Файл выберите команду Сохранить.
  6. В меню Файл выберите команду Выход.

Примечание

  • Изменения, внесенные в связанные данные, будут отражены во всех файлах, содержащих связь с этими данными. Если установлен режим обновления связанных данных вручную, для просмотра обновлений следует обновить связь с помощью диалогового окна Связи.

См. также


Вставка в файл команды MS-DOS

Чтобы вставить в файл команду MS-DOS

  1. В меню Правка выберите команду Командная строка.
  2. В поле Команда введите нужную команду MS-DOS, включая любые параметры и ключи, полный путь и расширение имени файла программы, а затем нажмите кнопку ОК.

    3. Команда MS-DOS появится в области Содержание.

  3. Нажмите кнопку Значок. Выберите среди представленных значков нужный и нажмите кнопку ОК. Если значок не отображается, нажмите кнопку Обзор и выберите необходимый файл.
  4. В меню Правка выберите команду Копировать пакет.
  5. Откройте файл, в который требуется вставить пакет, а затем расположите курсор в том месте файла, где должна отображаться команда.
  6. В меню Правка окна файла выберите команду Вставить.

Примечания

  • Некоторые программы автоматически помещают пакет в левый верхний угол окна.
  • Для выполнения команды MS-DOS достаточно дважды щелкнуть значок пакета.

См. также


Переходы между режимами отображения описания и рисунка

Чтобы выполнить переход между режимами отображения описания и рисунка

  • Щелкните в любом месте области Содержание упаковщика объектов и выполните одно из следующих действий:
    • чтобы отобразить имя файла в пакете, выберите параметр Описание;
    • чтобы отобразить снимок содержимого пакета, выберите параметр Рисунок.

Примечание

  • Режим отображения рисунка доступен только в том случае, если приложение, в котором создан фрагмент, поддерживает перетаскивание объектов.


Обновление связанных данных вручную

Чтобы обновить связанные данные вручную

  1. Выберите команду Связи в меню Правка окна файла, содержащего связанные данные.
  2. Нажмите кнопку Обновить сейчас.

Примечание

  • Эта возможность доступна не для всех программ.


Вставка пакета в файл

Чтобы вставить пакет в файл

  1. Откройте файл, в который требуется добавить пакет.
  2. В окне «Мой компьютер» найдите файл, который требуется вставить.
  3. Перетащите значок файла в открытый файл.

    4. Чтобы вставить пакет, содержащий связанный файл, при перетаскивании его значка удерживайте нажатыми клавиши SHIFT+CTRL.

Примечание

  • Вставка пакета в файл возможна только в том случае, если этот файл был создан приложением для Windows, поддерживающим перетаскивание объектов.