Редактор реестра

Редактор реестра является мощным инструментом изменения параметров системного реестра, содержащего служебную информацию системы. Настройки Windows хранятся в базе данных (реестре), организованной в виде древовидной структуры. Несмотря на то, что редактор реестра предоставляет возможности просмотра и изменения реестра, обычно в этом нет необходимости; более того, внесение неправильных изменений может привести к сбоям в системе. Опытный пользователь, готовый к изменению и восстановлению реестра, может безопасно использовать редактор реестра для выполнения таких задач, как удаление повторяющихся записей или удаление записей программ, которые были удалены.

Использование редактора реестра в 64-разрядной версии Windows XP

Реестр в 64-разрядной версии Windows XP поделен на 32-разрядный и 64-разрядный разделы. Большинство 32-разрядных разделов имеют те же имена, что и их аналоги в 64-разрядном разделе, и наоборот. По умолчанию в 64-разрядной версии редактора реестра, поставляемой в 64-разрядной версии Windows XP,отображаются только 64-разрядные разделы.

Для просмотра 32-разрядных разделов на компьютере с 64-разрядной версией Windows XP необходимо использовать 32-разрядную версию редактора реестра, расположенную в папке %systemroot%\Syswow64. Перед запуском 32-разрядной версии редактора реестра необходимо закрыть 64-разрядную версию программы, и наоборот. Работа с 64-разрядной и 32-разрядной версиями редактора реестра не различается.

Чтобы запустить 32-разрядную версию редактора реестра, нажмите кнопку «Пуск», щелкните пункт «Выполнить», введите в поле %systemroot%\syswow64\regedit и нажмите кнопку «OK».

  • Советы по использованию редактора реестра находятся в разделе Советы и рекомендации.
  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Общие сведения см. в разделе Основные понятия.


Советы и рекомендации

В операционной системе Windows сведения о конфигурации системы централизованно размещены в реестре. Это упрощает администрирование компьютера или сети, но, вместе с тем, одно неправильное изменение в реестре может вывести операционную систему из строя. Приведенный ниже список содержит советы и рекомендации по аккуратному использованию реестра и редактора реестра.

  • Перед внесением изменений в реестр делайте резервную копию.

    • Резервная копия реестра может быть создана программой архивирования. После внесения изменений в реестр создайте диск аварийного восстановления системы. Для облегчения устранения неполадок сохраняйте список изменений, внесенных в реестр. Дополнительные сведения содержатся в разделе Данные о состоянии системы.

  • Не заменяйте реестр Windows реестром другой версии операционных систем Windows или Windows NT.
  • Для редактирования реестра используйте не редактор реестра, а другие программы.

    • Неверные действия при изменении реестра могут серьезно повредить систему. Следует использовать программы, обеспечивающие безопасные методы редактирования реестра.

  • Никогда не оставляйте редактор реестра работающим без присмотра.


Инструкции

  • Изменение разделов и параметров
  • Импорт и экспорт разделов реестра
  • Загрузка и выгрузка кустов реестра
  • Обеспечение безопасности реестра
  • Печать всего реестра или его части


Изменение разделов и параметров

  • Поиск строки, параметра или раздела
  • Добавление раздела реестра в список «Избранное»
  • Добавление раздела
  • Добавление параметра
  • Изменение значения параметра
  • Удаление раздела или параметра
  • Переименование раздела или параметра
  • Подключение сетевого реестра
  • Отключение сетевого реестра
  • Копирование имени раздела реестра.
  • Восстановление реестра


Поиск строки, параметра или раздела

Рисунок Microsoft Windows

Чтобы найти строку, параметр или раздел

  1. Откройте редактор реестра.
  2. В меню Правка выберите команду Найти.
  3. В поле Найти: введите строку, параметр или раздел, которые требуется найти.
  4. Установите флажки имена разделов, имена параметров, значения параметров и Искать только строку целиком в соответствие с целью поиска, затем нажмите кнопку Найти далее.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Чтобы ускорить поиск, его следует вести только по сведениям одного типа; например, если искомые данные содержатся в параметре, следует снять флажки имена разделов и значения параметров.
  • Клавиша F3 служит для повторения поиска.

См. также


Добавление раздела реестра в список «Избранное»

Чтобы добавить раздел реестра в список «Избранное»

  1. Откройте редактор реестра.
  2. Выберите раздел реестра, который следует добавить в меню Избранное.
  3. Выберите в меню Избранное команду Добавить в избранное.
  4. В диалоговом окне Добавление в папку «Избранное» подтвердите выбранное имя раздела по умолчанию или введите новое.

    5. Раздел реестра добавляется в список Избранное. Возврат в данный список осуществляется путем его выбора в меню Избранное.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Может быть создан список избранных/часто посещаемых разделов реестра.
  • Для удаление раздела реестра из меню Избранное, выберите в меню Избранное команду Удалить из избранного; для удаления из списка Избранное может быть выбран один или несколько разделов.
  • Переименование элемента в списке «Избранное» не вызывает переименования соответствующего раздела реестра.

См. также


Добавление раздела

Чтобы добавить раздел

  1. Откройте редактор реестра.
  2. В левой части дерева реестра выберите раздел, в который необходимо добавить подраздел.
  3. В меню Правка выберите команду Создать, затем выберите Раздел.
  4. Введите имя нового раздела и нажмите клавишу ENTER.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечание

  • XOX
  • Если в реестре содержится ошибка, приводящая к неправильному запуску компьютера, имеется возможность восстановить реестр. Для получения инструкций щелкните ссылку «См. также».

См. также


Добавление параметра

Чтобы добавить параметр

  1. Откройте редактор реестра.
  2. Щелкните раздел реестра или запись, куда следует добавить новое значение.
  3. В меню Правка выберите команду Создать, а затем укажите тип добавляемого параметра: Строковый параметр, Двоичный параметр, Параметр DWORD, Мульти-строковый параметр или Расширяемый строковый параметр.
  4. Введите имя нового параметра и нажмите клавишу ENTER.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Если в реестре содержится ошибка, приводящая к неправильному запуску компьютера, имеется возможность восстановить реестр. Для получения инструкций по восстановлению реестра щелкните ссылку «См. также».
  • При добавлении параметра имя параметра и тип данных сохраняются со значением по умолчанию. Для получения инструкций по изменению значения по умолчанию щелкните ссылку «См. также».

См. также


Изменение значения параметра

Чтобы изменить значение параметра

  1. Откройте редактор реестра.
  2. Выберите изменяемый элемент.
  3. В меню Правка выберите команду Изменить.
  4. В поле Значение введите новое значение параметра и нажмите кнопку OK.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечание

  • XOX
  • Если в реестре содержится ошибка, приводящая к неправильному запуску компьютера, имеется возможность восстановить реестр. Для получения инструкций щелкните ссылку «См. также».
  • Для внесения изменений в раздел реестра необходимо иметь соответствующие разрешения. Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Удаление раздела или параметра

Чтобы удалить раздел или параметр

  1. Откройте редактор реестра.
  2. Выберите удаляемый раздел или параметр.
  3. В меню Правка выберите команду Удалить.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Из реестра могут быть удалены разделы и параметры. Тем не менее, невозможно удалить стандартный раздел (например HKEY_CURRENT_USER) или переименовать его.
  • Если в реестре содержится ошибка, приводящая к неправильному запуску компьютера, имеется возможность восстановить реестр. Для получения инструкций щелкните ссылку «См. также».

См. также


Переименование раздела или параметра

Чтобы переименовать раздел или параметр

  1. Откройте редактор реестра.
  2. Выберите раздел или параметр для переименования.
  3. В меню Правка выберите команду Переименовать.
  4. Введите новое имя и нажмите клавишу ENTER.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Если описанные действия привели к сбою при запуске системы, следует восстановить реестр. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Корневые разделы и параметры по умолчанию переименовывать нельзя.

См. также


Подключение сетевого реестра

Чтобы подключить сетевой реестр

  1. Откройте редактор реестра.
  2. В меню Файл выберите команду Подключить сетевой реестр.
  3. В диалоговом окне Подключение сетевого реестра введите имя компьютера, реестр которого требуется подключить.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Чтобы вносить изменения в реестр удаленного компьютера, в систему следует войти в качестве администратора или члена группы администраторов, причем на обоих компьютерах: локальном и удаленном. Настройки сетевой политики могут запрещать выполнение описанных действий.
  • Если в реестре содержится ошибка, приводящая к неправильному запуску компьютера, имеется возможность восстановить реестр. Для получения инструкций по восстановлению реестра щелкните ссылку «См. также».

См. также


Отключение сетевого реестра

Чтобы отключиться от сетевого реестра

  1. Откройте редактор реестра.
  2. В меню Файл выберите команду Отключить сетевой реестр.
  3. В диалоговом окне Отключение сетевого реестра выберите имя компьютера, реестр которого следует отключить.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Если в реестре содержится ошибка, приводящая к неправильному запуску компьютера, имеется возможность восстановить реестр. Для получения инструкций по восстановлению реестра щелкните ссылку «См. также».

См. также


Копирование имени раздела реестра

Чтобы скопировать имя раздела реестра

  1. Откройте редактор реестра.
  2. В левой части дерева реестра выберите раздел.
  3. Выберите в меню Правка команду Копировать имя раздела.
  4. Вставьте имя раздела реестра в другой программе или документе.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Если описанные действия привели к сбою при запуске системы, следует восстановить реестр. Для получения инструкций по восстановлению реестра щелкните ссылку «См. также».
  • Для получения сведений о поиске принтера в сети щелкните ссылку "См. также".

См. также


Восстановление реестра

Чтобы восстановить реестр

  1. Откройте редактор реестра.
  2. Чтобы напечатать данные инструкции, нажмите кнопку Параметры и выберите команду Печать. (если используется центр справки и поддержки, нажмите кнопку Печать над областью раздела.) Они не будут доступны после выключения компьютера в ходе выполнения действий пункта 2.
  3. Нажмите кнопку Пуск и выберите команду Завершение работы.
  4. В списке выберите перезагрузка и нажмите кнопку OK.
  5. При появлении сообщения Выберите операционную систему для запуска нажмите клавишу F8.
  6. С помощью стрелок выберите Загрузка последней удачной конфигурации, а затем нажмите клавишу ENTER.

    7. Для использования клавиш со стрелками на цифровой клавиатуре режим NUM LOCK должен быть отключен.

  7. При помощи клавиш со стрелками выберите операционную систему и нажмите клавишу ENTER.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Выбор команды Загрузка последней удачной конфигурации позволяет восстановить реестр в случае неполадок, вызванных, например, новым несовместимым с имеющимся оборудованием драйвером. Неполадки, возникшие вследствие повреждения или ошибочного удаления драйверов или файлов, не могут быть устранены таким образом.
  • При выборе команды Загрузка последней удачной конфигурации Windows восстановит сведения только в разделе реестра HKLM\System\CurrentControlSet. Любые изменения в других разделах реестра сохраняются.


Импорт и экспорт разделов реестра

  • Экспорт всего реестра или его части в текстовый файл
  • Импорт всего реестра или его части
  • Экспорт раздела реестра в файл куста
  • Импорт раздела реестра из файла куста


Экспорт всего реестра или его части в текстовый файл

Чтобы экспортировать весь реестр или его часть в текстовый файл

  1. Откройте редактор реестра.
  2. В меню Файл выберите команду Экспорт.
  3. В поле Имя файла введите имя.
  4. В группе Диапазон экспорта выберите один из параметров:
    • Весь реестр для экспорта всего реестра;
    • Выбранная ветвь, чтобы экспортировать только выделенный раздел, указанный в соответствующем поле.
  5. Нажмите кнопку Сохранить.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Для работы с файлами, созданными командой экспорта файла реестра, может быть использован любой текстовый редактор.
  • Файлы реестра могут быть сохранены в формате Windows, в формате, использовавшимся в Windows 95, Windows 98 и Windows NT 4.0, в формате двоичных файлов куста и в виде текстовых файлов. Файлы реестра сохраняются с расширением .reg; текстовые файлы сохраняются с расширением .txt.
  • Если в проводнике дважды щелкнуть файл с расширением .reg, содержимое файла будет импортировано в реестр компьютера.

См. также


Импорт всего реестра или его части

Чтобы импортировать весь реестр или его часть

  1. Откройте редактор реестра.
  2. В меню Файл выберите команду Импорт файла реестра.
  3. Найдите файл, который следует импортировать, выделите его и нажмите кнопку Открыть.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечание

  • Если в проводнике дважды щелкнуть файл с расширением .reg, содержимое файла будет импортировано в реестр компьютера.


Экспорт раздела реестра в файл куста

Чтобы экспортировать раздел реестра в файл куста

  1. Откройте редактор реестра.
  2. Выберите раздел, который следует сохранить в файл.
  3. В меню Файл выберите команду Экспорт.
  4. В диалоговом окне Экспорт файла реестра в поле со списком Папка выберите диск, папку или сетевой компьютер и папку, где будет сохранен куст.
  5. В поле Имя файла введите имя куста.
  6. В поле Тип файла выберите значение Файлы куста реестра.
  7. Нажмите кнопку Сохранить.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Для выполнения этой процедуры необходимо войти в систему с учетной записью «Администратор» или члена группы «Администраторы». Если компьютер подключен к сети, выполнение данной процедуры может быть запрещено параметрами сетевой политики.
  • В редакторе реестра имеется ряд команд, предназначенных для ведения реестра системы. Например, команды Загрузить куст и Выгрузить куст позволяют временно выгрузить часть системы на другой компьютер. Перед тем как загрузить или восстановить куст, его необходимо сохранить в виде раздела на гибком или на жестком диске.

См. также


Импорт раздела реестра из файла куста

Чтобы импортировать раздел реестра из файла куста

  1. Откройте редактор реестра.
  2. Выберите разделы, в которые будет восстановлен куст.
  3. В меню Файл выберите команду Импортировать.
  4. В поле со списком Папка выберите дисковод, папку или сетевой компьютер и папку, где был сохранен куст.
  5. В поле Тип файлов выберите значение Файлы куста реестра.
  6. Выберите имя файла куста.
  7. Нажмите кнопку Открыть.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Для выполнения этой процедуры необходимо войти в систему с учетной записью «Администратор» или члена группы «Администраторы». Если компьютер подключен к сети, выполнение данной процедуры может быть запрещено параметрами сетевой политики.
  • Восстановленный куст замещает существующий раздел реестра и становится постоянной частью конфигурации. Например, при проведении работы с частью системы выбирают команду Экспорт для сохранения куста на диске. Впоследствии используют команду Импорт в меню Файл для восстановления сохраненного раздела в системе.

См. также


Загрузка и выгрузка кустов реестра

  • Загрузка куста в реестр
  • Выгрузка куста из реестра


Загрузка куста в реестр

Чтобы загрузить куст в реестр

  1. Откройте редактор реестра.
  2. В левой части дерева реестра выберите один из разделов: HKEY_USERS или HKEY_LOCAL_MACHINE.
  3. В меню Реестр выберите команду Загрузить куст.
  4. В поле со списком Папка выберите дисковод, папку или сетевой компьютер и папку, которая содержит загружаемый куст.
  5. Нажмите кнопку Открыть.
  6. В поле Раздел введите имя, которое следует назначить кусту; нажмите кнопку OK.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Для выполнения этой процедуры необходимо войти в систему с учетной записью «Администратор» или члена группы «Администраторы». Если компьютер подключен к сети, выполнение данной процедуры может быть запрещено параметрами сетевой политики.
  • Команды Загрузить куст и Выгрузить куст действительны только для стандартных разделов HKEY_USERS и HKEY_LOCAL_MACHINE и активны только при выборе этих стандартных разделов. После загрузки куста в реестр он становится подразделом одного из этих стандартных разделов.

См. также


Выгрузка куста из реестра

Чтобы выгрузить куст из реестра

  1. Откройте редактор реестра.
  2. Выберите куст, загруженный ранее в систему.
  3. В меню Реестр выберите команду Выгрузить куст.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Для выполнения этой процедуры необходимо войти в систему с учетной записью «Администратор» или члена группы «Администраторы». Если компьютер подключен к сети, выполнение данной процедуры может быть запрещено параметрами сетевой политики.
  • Команды Загрузить куст и Выгрузить куст действительны только для стандартных разделов HKEY_USERS и HKEY_LOCAL_MACHINE и активны только при выборе этих стандартных разделов. После загрузки куста в реестр он становится подразделом одного из этих стандартных разделов.

См. также


Обеспечение безопасности реестра

  • Назначение разрешения разделу реестра
  • Назначение специального доступа к разделу реестра
  • Добавление пользователей или групп в список разрешений
  • Предоставление полного доступа к разделу реестра
  • Аудит работы с разделом реестра
  • Добавление пользователей и групп в список аудита
  • Назначение владельца раздела реестра


Назначение разрешения разделу реестра

Чтобы назначить разрешения разделу реестра

  1. Откройте редактор реестра.
  2. Выберите раздел, которому следует назначить разрешения.
  3. В меню Правка выберите команду Разрешения.
  4. Назначьте уровень доступа выбранным разделам следующим образом:
    • Установите флажок Разрешить в столбце Чтение, чтобы разрешить пользователю только чтение содержимого раздела без сохранения внесенных в файл изменений.
    • Установите флажок Разрешить в строке Полный доступ, чтобы предоставить пользователю разрешение на открытие, изменение и возможность стать владельцем выбранного раздела.
    • нажмите кнопку Дополнительно, чтобы предоставить пользователю особые разрешения для данного раздела;
  5. Если при назначении разрешений подразделам необходимо, чтобы наследуемые разрешения, назначенные родительскому разделу, использовались и для данного подраздела, установите флажок Наследовать от родительского объекта применимые к дочерним объектам разрешения, добавляя их к явно заданным в этом окне.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Владелец раздела реестра имеет возможность указать пользователей и группы, которые имеют доступ к разделу. Для определения лиц, имеющих право на открытие разделов реестров, им устанавливают разрешения. Всегда можно добавить или удалить пользователей или группы из списка лиц, имеющих права на доступ к разделам реестра.
  • Флажок Особые разрешения указывает на то, что для данного раздела установлены специальные разрешения, однако возможность задавать особые разрешения с помощью щелчка данного флажка отсутствует. Для задания особых разрешений воспользуйтесь кнопкой Дополнительно.

См. также


Назначение специального доступа к разделу реестра

Чтобы назначить специальный доступ к разделу реестра

  1. Откройте редактор реестра.
  2. Выберите раздел, к которому будет назначен специальный доступ.
  3. В меню Правка выберите команду Разрешения.
  4. Нажмите кнопку Дополнительно и выберите двойным щелчком мыши пользователя или группу, которым следует назначить специальный доступ.
  5. В области Разрешения установите флажки Разрешить или Запретить для каждого разрешения, которое нужно установить или отменить.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Назначение специального доступа целесообразно в тех случаях, когда нужно назначить разрешения, которые не исчерпываются правами «Чтение» или «Полный доступ».
  • Если при назначении разрешений подразделам необходимо, чтобы наследуемые разрешения, назначенные родительскому разделу, использовались и для данного подраздела, установите флажок Наследовать от родительского объекта применимые к дочерним объектам разрешения, добавляя их к явно заданным в этом окне .
  • Если при назначении разрешений родительскому разделу требуется, чтобы разрешения всех подразделов заменялись наследуемыми разрешениями родительского раздела, установите флажок Заменить разрешения для всех дочерних объектов заданными здесь разрешениями, применимыми к дочерним объектам.

См. также


Добавление пользователей или групп в список разрешений

Чтобы добавить пользователей или группы в список разрешений

  1. Откройте редактор реестра.
  2. Выберите раздел, список разрешений которого следует изменить.
  3. В меню Правка выберите команду Разрешения и нажмите кнопку Добавить.
  4. В диалоговом окне Выбор: пользователи, компьютеры или группы, в поле со списком Размещение выберите для просмотра рабочую станцию или домен, в котором находятся учетные записи пользователей и групп.
  5. Выберите имя пользователя или группы, нажмите кнопку Добавить, а затем — кнопку OK.
  6. В диалоговом окне Разрешения, в списке Разрешения, назначьте тип доступа выбранному пользователю или выбранной группе:
    • установите флажок Разрешить в столбце Чтение, чтобы разрешить пользователю только чтение раздела без сохранения внесенных в него изменений;
    • установите флажок Разрешить в строке Полный доступ, чтобы предоставить пользователю разрешение на открытие, изменение и возможность стать владельцем текущего раздела;

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Если какие-либо флажки в списке Разрешения заштрихованы, это означает, что данный раздел унаследовал разрешения от родительского раздела.
  • Чтобы разрешения, назначенные родительскому разделу, распространялись и на подразделы, нажмите кнопку Дополнительно и установите флажок Переносить наследуемые от родительского объекта разрешения на этот объект.
  • Если в диалоговом окне Выбор: пользователи, компьютеры или группы имя вводится вручную, нажмите кнопку Проверить имена, перед тем как нажать кнопку OK.


Предоставление полного доступа к разделу реестра

Чтобы предоставить полный доступ к разделу реестра

  1. Откройте редактор реестра.
  2. Выберите раздел, к которому требуется предоставить полный доступ.
  3. В меню Правка выберите команду Разрешения.
  4. В поле Группы или пользователи выберите пользователя, которому необходимо предоставить полный доступ к разделу реестра.
  5. В поле Разрешения для имя, где имя является именем пользователя, которому предоставляется полный доступ к разделу, установите флажок Разрешить для типа доступа Полный доступ.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Разрешить другому пользователю стать владельцем какого-либо раздела реестра может только владелец раздела.
  • Чтобы разрешить другому пользователю стать владельцем некоторого раздела, следует сначала предоставить пользователю полный доступ к разделу.

См. также


Аудит работы с разделом реестра

Чтобы выполнять аудит работы с разделом реестра

  1. Откройте редактор реестра.
  2. Выберите раздел, подлежащий аудиту.
  3. В меню Правка выберите команду Разрешения.
  4. Нажмите кнопку Дополнительно и перейдите на вкладку Аудит.
  5. Двойным щелчком мыши выберите имя группы или пользователя.
  6. В группе Доступ установите или снимите флажки в столбцах Успех и Отказ, чтобы включить или отключить аудит:
    Выбрать | Тип аудита
    Запрос значения | Аудит всех попыток чтения параметра из раздела реестра
    Задание значения | Аудит всех попыток задания значения в разделе реестра
    Создать подраздел | Аудит всех попыток создания подразделов в данном разделе реестра
    Перечисление подразделов | Аудит всех попыток определения подразделов данного раздела реестра
    Уведомление | Аудит событий уведомления из подраздела в реестре
    Создание ссылки | Аудит попыток создания символьной ссылки в указанном разделе
    Удаление | Аудит попыток удаления объекта реестра
    Запись DAC | Аудит всех попыток записи избирательной таблицы управления доступом для данного раздела
    Смена владельца | Аудит всех попыток смены владельца выбранного раздела
    Чтение разрешений | Аудит всех попыток открытия необязательной таблицы управления доступом для данного раздела

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Для выполнения этой процедуры необходимо войти в систему с учетной записью администратора или члена группы «Администраторы». Если компьютер подключен к сети, параметры сетевой политики могут запретить выполнение данной процедуры.
  • Перед тем как указать события, для которых следует провести аудит, нужно сначала добавить пользователей или группы.
  • Выполнение аудита способно существенно замедлить работу компьютера. Рекомендуется выполнять аудит сбоев, а не успешных действий.

См. также


Добавление пользователей и групп в список аудита

Чтобы добавить пользователей или группы в список аудита

  1. Откройте редактор реестра.
  2. Выберите раздел, подлежащий аудиту.
  3. В меню Правка выберите команду Разрешения.
  4. Нажмите кнопку Дополнительно, откройте вкладку Аудит и нажмите кнопку Добавить.
  5. Нажмите кнопку Типы объектов, выберите один или несколько типов пользователей или групп и нажмите кнопку OK.
  6. Нажмите кнопку Размещение, выберите компьютер или домен, пользователей и компьютеры которого требуется добавить, а затем нажмите кнопку OK.
  7. Выберите имя пользователя или группы, которые следует добавить, затем нажмите кнопку ОК, чтобы открыть диалоговое окно Элемент аудита, либо нажмите кнопку Дополнительно для поиска пользователя, компьютера или группы на основании заданных параметров.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Для выполнения этой процедуры необходимо войти в систему с учетной записью администратора или члена группы «Администраторы». Если компьютер подключен к сети, выполнение данной процедуры может быть запрещено настройками сетевой политики.
  • Перед тем как указать события, для которых следует выполнять аудит, необходимо сначала добавить пользователя или группу.

См. также


Назначение владельца раздела реестра

Чтобы назначить владельца разделу реестра

  1. Откройте редактор реестра.
  2. Выберите раздел, владельцем которого необходимо стать.
  3. В меню Правка выберите команду Разрешения.
  4. Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
  5. В группе Изменить владельца на выберите нового владельца и нажмите кнопку OK.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Назначение владельца раздела реестра может выполняться только пользователем, вошедшим в систему как администратор или пользователем, которому текущий владелец параметра реестра назначил разрешение на то, чтобы стать новым владельцем.

См. также


Печать всего реестра или его части

Чтобы напечатать весь реестр или отдельный раздел

  1. Откройте редактор реестра.
  2. Щелкните значок компьютера или корневой раздел реестра, который требуется напечатать.
  3. В меню Файл выберите команду Печать.
  4. Чтобы напечатать весь реестр, щелкните Весь реестр; чтобы напечатать часть реестра, выберите Выбранная ветвь и введите имя выбранной ветви, затем нажмите кнопку OK.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечание

  • XOX
  • Средний реестр занимает сотни печатных страниц. Рекомендуется выводить на печать только отдельные верви реестра.


Основные понятия

  • Общие сведения о редакторе реестра


Общие сведения о редакторе реестра

Редактор реестра является мощным инструментом изменения параметров системного реестра, содержащего служебную информацию системы. Настройки Windows хранятся в базе данных (реестре), организованной в виде древовидной структуры. Несмотря на то, что редактор реестра предоставляет возможности просмотра и изменения реестра, обычно в этом нет необходимости; более того, внесение неправильных изменений может привести к сбоям в системе. Опытный пользователь, готовый к изменению и восстановлению реестра, может безопасно использовать редактор реестра для выполнения таких задач, как удаление повторяющихся записей или удаление записей программ, которые были удалены.

Папки представляют собой разделы реестра и отображаются в области навигатора в левой части окна редактора реестра. В области разделов отображаются записи раздела. Дважды щелкните параметр, чтобы открыть диалоговое окно редактирования.

Не следует изменять реестр без крайней необходимости. В случае наличия ошибки в реестре компьютер перестает работать надлежащим образом. В этом случае следует восстановить реестр в состояние последнего удачного запуска системы. Для получения инструкций щелкните ссылку «См. также».

Разделы редактора реестра

В области навигатора редактора реестра содержатся папки, каждая из которых представляет собой стандартный раздел на локальном компьютере. При осуществлении доступа к реестру удаленного компьютера отображаются только два стандартных раздела: HKEY_USERS и HKEY_LOCAL_MACHINE.

Папка/стандартный раздел | Описание
HKEY_CURRENT_USER | Данный раздел является корневым для данных настройки пользователя, вошедшего в систему в настоящий момент. Здесь хранятся папки пользователя, цвета экрана и настройки панели управления. Эти данные называются профилем пользователя.
HKEY_USERS | Данный раздел содержит все профили пользователей компьютера. HKEY_CURRENT_USER является подразделом HKEY_USERS.
HKEY_LOCAL_MACHINE; | Раздел содержит данные настройки, относящиеся к данному компьютеру (для всех пользователей).
HKEY_CLASSES_ROOT | Данный раздел является подразделом HKEY_LOCAL_MACHINE\Software. Хранящиеся здесь сведения обеспечивают открытие необходимой программы при открытии файла с помощью проводника.
HKEY_CURRENT_CONFIG | Данный раздел содержит сведения о профиле оборудования, используемом локальным компьютером при запуске системы.

Следующая таблица содержит список типов данных, определенных и используемых системой в настоящий момент.

Тип данных | Описание
REG_BINARY | Необработанные двоичные данные. Большинство сведений об аппаратных компонентах хранится в виде двоичных данных и выводится в редакторе реестра в шестнадцатеричном формате.
REG_DWORD | Данные, представленные целым числом (4 байта). Многие параметры служб и драйверов устройств имеют этот тип и отображаются в двоичном, шестнадцатеричном или десятичном форматах.
REG_EXPAND_SZ | Строка данных переменной длины Этот тип данных включает переменные, обрабатываемые при использовании данных программой или службой.
REG_MULTI_SZ | Многострочный текст. Этот тип, как правило, имеют списки и другие записи в формате, удобном для чтения. Записи разделяются пробелами, запятыми или другими символами.
REG_SZ | Текстовая строка фиксированной длины.
REG_FULL_RESOURCE_DESCRIPTOR | Последовательность вложенных массивов, разработанная для хранения списка ресурсов аппаратного компонента или драйвера.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Для безопасного использования редактора реестра при удалении повторяющихся записей или удалении записей программ, которые были удалены, следует быть готовым как к правке, так и к восстановлению реестра.

См. также


Удаление пользователя или группы из списка аудита

Чтобы удалить пользователя или группу из списка аудита

  1. Откройте редактор реестра.
  2. Выберите раздел, список аудита которого требуется изменить.
  3. В меню Правка выберите команду Разрешения.
  4. Нажмите кнопку Дополнительно и перейдите на вкладку Аудит.
  5. Выберите пользователя или группу, которые следует удалить, и нажмите кнопку Удалить.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX
  • Для выполнения этой процедуры необходимо войти в систему с учетной записью «Администратор» или члена группы «Администраторы». Если компьютер подключен к сети, настройками сетевой политики может быть запрещено выполнение данной процедуры.


Удаление пользователя или группы из списка разрешений

Чтобы удалить пользователя или группу из списка разрешений

  1. Откройте редактор реестра.
  2. Выберите раздел, список разрешений которого следует изменить.
  3. В меню Правка выберите команду Разрешения.
  4. В поле Группы или пользователи выберите имя пользователя или группы которую требуется удалить из списка разрешений.
  5. Нажмите кнопку Удалить.

Внимание!

  • Неверные действия при изменении реестра могут серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных, имеющихся на компьютере.

Примечания

  • XOX