Регистрация событий завершения работы

Регистрация событий завершения работы используется для записи причин завершения работы или перезагрузки Windows.

  • Советы по использованию регистрации событий завершения работы см. в разделе Советы и рекомендации.
  • Справочные сведения по выполнению конкретных задач см. в разделе Инструкции.
  • Общие сведения см. в разделе Основные понятия.
  • Инструкции по устранению неполадок см. в разделе Устранение неполадок.


Советы и рекомендации

  • Создание правил использования параметров специальных причин

    Следует правильно применять причины, выведенные в диалоговом окне Регистрация событий завершения работы, чтобы получить от их использования максимальную пользу. Администраторам рекомендуется создать и сообщить пользователям особые правила по использованию каждой причины. Также следует предоставить руководство по указанию дополнительных сведений в поле Комментарий.

    Рекомендуется создавать правила использования, подобные правилам, приведенным в следующем примере.

    • Если во время повседневной работы устанавливается новое оборудование и программное обеспечение, следует использовать причину Hardware:Maintenance (Planned). Следует всегда указывать имя нового программного обеспечения в поле Комментарий окна «Регистрация событий завершения работы».

  • Определение стандартных сведений, включаемых в поле «Комментарий» окна «Регистрация событий завершения работы»

    Системным администраторам следует создать и передать пользователям специальные правила ввода сведений в поле Комментарий окна «Регистрация событий завершения работы». Следует установить правила, определяющие время ввода пользователями сведений, вид сведений, а также форму ввода этих сведений.

  • Регулярный просмотр данных регистрации событий завершения работы

    С целью определения сходства и тенденций в завершении работы компьютера рекомендуется регулярно просматривать данные по завершению работы в журнале событий. Помимо того, что выяснения причин завершения работы может быть достаточно для определения источника неполадок в работе системы, выяснение причин поможет также при определении необходимых изменений конфигурации, а также при определении других проблем, на которые следует обратить внимание. Дополнительные сведения см. в разделе Чтобы просмотреть данные регистрации событий завершения работы.

Общие сведения о регистрации событий завершения работы см. в разделе Общие сведения о регистрации событий завершения работы. Для получения сведений по использованию регистрации событий завершения работы для завершений работы, инициированных пользователем см. раздел Использование регистрации событий завершения работы для завершений работы, инициированных пользователем.


Инструкции

  • Завершение работы и документирование причины
  • Включение регистрации событий завершения работы
  • Выключение регистрации событий завершения работы
  • Добавление особых причин завершения работы
  • Отключение стандартных причин
  • Просмотр данных регистрации событий завершения работы


Завершение работы и документирование причины

Рисунок Microsoft Windows

Чтобы завершить работу и документировать причины

С помощью интерфейса Windows

  1. Нажмите кнопку Пуск, а затем выберите команду Завершение работы.
  2. В списке Параметры выберите причину.
  3. В поле Комментарий введите комментарий и нажмите кнопку ОК.

Важно!

  • Не выключайте компьютер до тех пор, пока на экране не появится разрешающая это действие надпись. Важные данные в процессе работы Windows хранятся в памяти, поэтому перед выключением компьютера необходимо сохранить их на жестком диске. После сохранения данных Windows отображает уведомление о возможности выключить компьютер.

Примечание

    В поле Комментарий можно ввести подробные сведения о причине выключения. При выборе значения Другое в поле Причина ввод данных в это текстовое поле обязателен.

  • Можно также завершить работу, нажав одновременно клавиши CTRL+ALT+DEL и выбрав вариант Завершение работы.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    shutdown [-l | -s |-r | -a] [-f] [-m \\имя_компьютера] [-t xx] [-c "сообщение"] [-d [u][p]:xx:yy]

    3. Значение | Описание
    -l | Выход текущего пользователя из системы (также используется по умолчанию). -m имя_компьютера имеет приоритет.
    -s | Выключение локального компьютера.
    -r | Перезагрузка после выключения.
    -a | Прерывание завершения работы. Игнорируются все параметры, кроме -l и имя_компьютера. Параметр -a можно использовать только в течение интервала таймаута.
    -f | Принудительное закрытие выполняющихся приложений.
    -m [\\имя_компьютера] | Компьютер, который требуется выключить.
    -t xx | Устанавливает таймер завершения работы системы на xx секунд. По умолчанию это время составляет 20 секунд.
    -c "сообщение" | Задает сообщение, выводящееся в области «Сообщение» в окне «Завершение работы системы». Можно использовать до 127 знаков. Текст сообщения должен быть заключен в прямые кавычки.
    -d [u][p]:xx:yy Перечень кодов причины выключения. В следующей таблице перечислены различные значения.
    Значение | Описание
u | Указывает код пользователя.
p | Указывает код планового выключения.
xx | Указывает основной код причины (0-255).
yy | Указывает вспомогательный код причины (0-65536).

Пример

Чтобы выключить сервер \\MyServer через 60 секунд, принудительно закрыть выполняющиеся приложения, перезагрузить компьютер после выключения, указать код пользователя, указать что выключение является плановым, занести в журнал основной код причины 125 и вспомогательный код причины 1, введите:

shutdown -r -f -m \\MyServer -t 60 -d up:125:1

Примечания

  • XOX
  • Если указывается основной и вспомогательный коды причины, необходимо предварительно определить эти коды на каждом компьютере, на котором планируется использовать конкретный код. Если коды причины не определены на конечном компьютере, программа «Просмотр событий» не сможет занести в журнал правильный текст причины.

См. также


Включение регистрации событий завершения работы

Рисунок Microsoft Windows

Чтобы выключить регистрацию событий завершения работы

  1. Откройте редактор реестра.

    2. Внимание!

    • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных. Если после внесения изменений возникли неполадки, при запуске системы выберите вариант Загрузка последней удачной конфигурации.
  2. В редакторе реестра перейдите в следующий раздел:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Reliability

  3. Выберите следующий параметр:

    ShutdownReasonUI:REG_DWORD:

  4. Назначьте значение 1 и закройте редактор реестра.

Примечания

  • Чтобы открыть редактор реестра, нажмите кнопку Пуск, выберите команду Выполнить, введите regedit и нажмите кнопку OK.

См. также


Выключение регистрации событий завершения работы

Рисунок Microsoft Windows

Чтобы выключить регистрацию событий завершения работы

  1. Откройте редактор реестра.

    2. Внимание!

    • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных. Если после внесения изменений возникли неполадки, при запуске системы выберите вариант Загрузка последней удачной конфигурации.
  2. В редакторе реестра перейдите в следующий раздел:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Reliability

  3. Выберите следующий параметр:

    ShutdownReasonUI:REG_DWORD:

  4. Назначьте значение 0 и закройте редактор реестра.

Примечания

  • Чтобы открыть редактор реестра, нажмите кнопку Пуск, выберите команду Выполнить, введите regedit и нажмите кнопку OK.

См. также


Добавление собственных причин выключения

Рисунок Microsoft Windows

Чтобы добавить собственные причины выключения

  1. Откройте редактор реестра.

    2. Внимание!

    • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных. Если после внесения изменений возникли неполадки, при запуске системы загрузите последнюю рабочую конфигурацию.
  2. В редакторе реестра перейдите в следующий раздел:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Reliability\UserDefined

  3. В меню Правка выберите команду Создать и подкоманду Мульти-строковый параметр. При этом будет создан новый раздел реестра со временным заголовком Новый параметр.
  4. Следует изменить временный заголовок Новый параметр, введя имя раздела реестра в следующем формате:

    Флаги элементов управления;Основной номер причины;Вспомогательный номер причины

    Элемент Флаги элементов управления может содержать одно или несколько их следующих значений:

    Значение | Описание
    P | Указывает, что причина является запланированной. Если значение не задано, причина является незапланированной.
    C или B | Комментарий является обязательным.
    S | Указывает, что причина должна быть выведена в диалоговом окне завершения работы, инициированного пользователем.
    D | Указывает, что причина должна быть выведена в диалоговом окне внезапного завершения работы.

    Пример

    Для запланированных инициированных пользователем завершений работы, для которых необходим комментарий с основной причиной 2 и вспомогательной причиной 2, введите в качестве имени следующее:

    PCS;2;2

  5. Введя имя нового раздела реестра, нажмите клавишу ENTER.
  6. Дважды щелкните новый раздел и определите Значение, используя следующий формат:

    Заголовок

    Описание

    Каждое значение состоит из двух выражений, расположенных на разных строках. Первой строкой является заголовок, отображающийся в поле со списком. Второй строкой является описание, выводящееся в виде текста ниже выбранной причины.

    Пример

    Стихийное бедствие (незапланированная причина)

    Наводнение, землетрясение, ураган или любое другое незапланированное природное явление, вызвавшее завершение работы компьютера. Укажите природное явление в поле «Комментарий».

  7. Закройте редактор реестра.

Примечания

  • Чтобы открыть редактор реестра, нажмите кнопку Пуск, выберите команду Выполнить, введите regedit и нажмите кнопку OK.
  • Могут быть указаны оба значения S и D, однако необходимо указать хотя бы одно значение, чтобы параметры были правильно заданными.
  • Если раздел Флаги элементов управления содержит значения, отличные от описанных выше значений, или число значений превышает пять, сообщение не является действительным и не будет выведено на экран. Значения могут выводиться в любом порядке.
  • Основной номер причины является числом, расположенным в диапазоне от 0 до 255. Если значение оставлено пустым, выходит за допустимые пределы или не является числовым, сообщение не является действительным и не будет выведено на экран.
  • Вспомогательный номер причины является числом, расположенным в диапазоне от 0 до 65536. Если значение оставлено пустым, выходит за допустимые пределы или не является числовым, сообщение не является действительным и не будет выведено на экран.
  • Пользовательские причины сохраняются в интерфейсе пользователя при помощи двух разделов реестра в следующем порядке: MajorReasonNumber, MinorReasonNumber.
  • Максимальная длина заголовка составляет 64 знака. Максимальная длина описания составляет 696 знаков.
  • Если в качестве значения раздела реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Reliability\ShutdownIgnorePredefinedReasons задано любое ненулевое значение и правильно определена по меньшей мере одна пользовательская причина, стандартные причины Windows не будут выводиться в диалоговом окне Завершение работы Windows. Для получения дополнительных сведений об отключении определенных заранее причин щелкните ссылку «См. также».

См. также


Отключение стандартных причин

Рисунок Microsoft Windows

Чтобы отключить стандартные причины

  1. Откройте редактор реестра.

    2. Внимание!

    • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных. Если после внесения изменений возникли неполадки, при запуске системы выберите вариант Загрузка последней удачной конфигурации.
  2. В редакторе реестра перейдите в следующий раздел:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Reliability

  3. В меню Правка укажите на команду Создать и выберите Параметр DWORD.
  4. В выведенном поле введите ShutdownIgnorePredefinedReasons и нажмите клавишу Enter.
  5. Дважды щелкните только что созданный раздел реестра ShutdownIgnorePredefinedReasons и изменить Значение на 1.
  6. Нажмите кнопку ОК и закройте редактор реестра.

Примечания

  • Чтобы открыть редактор реестра, нажмите кнопку Пуск, выберите команду Выполнить, введите regedit и нажмите кнопку OK.
  • Перед отключением стандартных причин необходимо правильно определить по крайней мере одну особую причину. Для получения сведений по добавлению особых причин щелкните ссылку «См. также».

См. также


Просмотр данных регистрации событий завершения работы

Рисунок Microsoft Windows

Чтобы просмотреть данные регистрации событий завершения работы

  1. Запустите программу Просмотр событий.
  2. Щелкните Журнал системы, перейдите к столбцу Событие и найдите записи со значением 1075.

Примечание

  • XOX

См. также


Основные понятия

В этом разделе рассмотрены следующие темы:
  • Общие сведения о регистрации событий завершения работы
  • Общее представление о регистрации событий завершения работы
  • Использование регистрации событий завершения работы
  • Управление регистрацией событий завершения работы из командной строки


Общие сведения о регистрации событий завершения работы

При работе со средством регистрации событий завершения работы для полной документации причин завершения работы или перезагрузки компьютера используется простой и стандартный механизм. Эти сведения можно использовать в дальнейшем для анализа конечных причин завершения работы и углубления знаний о системной среде.

Чтобы записать причину завершения работы или перезагрузки, введите ее в диалоговом окне Завершение работы Windows. Диалоговое окно Завершение работы Windows отображается во время процесса завершения работы или перезагрузки после внезапного завершения работы. В Windows используются параметры определенных заранее причин. Также имеется возможность добавлять параметры особых причин. Введенные сведения записываются в журнал системы в компоненте «Просмотр событий» Дополнительные сведения об окне просмотра событий см. в разделе Общие сведения о просмотре событий.

В Windows XP по умолчанию отображается средство регистрации событий завершения работы. Дополнительные сведения о регистрации событий завершения работы см. в разделе Включение регистрации событий завершения работы. Дополнительные сведения о выключении регистрации событий завершения работы см. в разделе Выключение регистрации событий завершения работы.


Общее представление о регистрации событий завершения работы

В этом разделе рассмотрены следующие темы:

  • Завершения работы, инициированные пользователем
  • Внезапное завершение работы
  • Стандартные и особые причины завершения работы


Завершения работы, инициированные пользователем

Инициировать завершение работы можно при помощи кнопки Пуск, а также при запуске файла shutdown.exe. При таком завершении работы в Windows выполняются определенные процедуры, включая вывод на экран диалогового окна для ввода пользователем причины завершения работы или перезагрузки.

Завершение работы, не инициированное пользователем с использованием одного из представленных выше способов, называется «внезапное завершение работы». Внезапное завершение работы может быть вызвано нарушением подачи электроэнергии или сбоем системы. Дополнительные сведения см. в разделе Внезапное завершение работы.


Внезапное завершение работы

Не инициированное пользователем завершение работы является «внезапным» или «неожиданным». Например, внезапное завершение работы может быть вызвано нарушении подачи электроэнергии или сбоем системы. При внезапном завершении работы в Windows не выполняются все обычные для завершения работы процедуры, включая сбор данных о причине завершения работы. Однако при внезапном завершении работы для повторного запуска системы будет необходимо ввести причину завершения работы.

Для получения дополнительных сведений по использованию регистрации событий завершения работы для внезапного завершения работы см. раздел Использование регистрации событий завершения работы для внезапного завершения работы. Общие сведения о регистрации событий завершения работы см. в разделе Общие сведения о регистрации событий завершения работы.


Стандартные и особые причины завершения работы

Стандартные причины

Если включена регистрация событий завершения работы, во время выполнения процесса завершения работы в Windows в раскрывающемся списке Причина выводятся стандартные причины. Эти причины нельзя изменить или переименовать. Однако имеется возможность отказаться от использования стандартных причин и определить все причины завершения работы самостоятельно.

Перед отключением стандартных причин необходимо правильно определить по крайней мере одну особую причину. Дополнительные сведения об определении особых причин завершения работы см. в разделе Чтобы добавить особые причины завершения работы.

Чтобы отключить стандартные причины, см. раздел Чтобы отключить стандартные причины.

Особые причины

Администраторы могут добавлять особые причины для инициируемых пользователем или внезапных завершений работы. Можно определить и уточнить особую причину. Например, причину, определенная как «InternalApplication» можно уточнить как «InternalApplication: Maintenance» или «InternalApplication: Installation». В данном примере основная причина (представленная соответствующим кодом основной причины) — «InternalApplication», а вспомогательная причина (представленная соответствующим кодом вспомогательной причины) — «Maintenance» или «Installation». Можно определить причину еще точнее, добавив к описанию вспомогательной причины «(Запланированное)» или «(Незапланированное)». Это позволит при завершении работы или перезагрузке выбрать одну из следующих причин:

  • InternalApplication: Maintenance (Запланированное);
  • InternalApplication: Maintenance (Незапланированное);
  • InternalApplication: Installation (Запланированное);
  • InternalApplication: Installation (Незапланированное).

Чтобы текст особой причины завершения работы был записан в журнал в компоненте «Просмотр событий», необходимо определить специальную причину завершения работы для каждого компьютера, для которого будет использоваться эта причина. Дополнительные сведения об определении особых причин завершения работы см. в разделе Чтобы добавить особые причины завершения работы.


Использование регистрации событий завершения работы

В этом разделе рассмотрены следующие темы:

  • Использование регистрации событий завершения работы для завершений работы, инициированных пользователем
  • Использование регистрации событий завершения работы для внезапных завершений работы


Использование регистрации событий завершения работы для завершений работы, инициированных пользователем

При завершении работы компьютера средством регистрации событий завершения работы на экран выводится приглашение для ввода причины завершения работы. После этого причины регистрируются в компоненте «Просмотр событий».

Дополнительные сведения о просмотре причин завершения работы в компоненте «Просмотр событий» см. в разделе Чтобы просмотреть данные регистрации событий завершения работы.

Имеется возможность дополнить стандартные причины Windows особыми причинами, определенными пользователем. Дополнительные сведения см. в разделе Чтобы добавить особые причины завершения работы.


Использование регистрации событий завершения работы для внезапных завершений работы

Не инициированное пользователем завершение работы является «внезапным» или «неожиданным». Внезапное завершение работы может быть вызвано нарушением подачи электроэнергии или сбоем системы. При входе в систему компьютера после внезапного завершения работы первого пользователя с правами администратора на экран будет выведено диалоговое окно, в котором могут быть указаны причины завершения работы. При регистрации причины внезапного завершения работы или перезагрузки имеется возможность выбрать один из следующих вариантов причины:

  • Отказ системы: Ошибка STOP
  • Сбой питания: Отключение кабеля
  • Сбой питания: Общие неполадки
  • Другие отказы: Система не отвечает
Помимо этих причин в компоненте «Регистрация событий завершения работы» доступно поле Код проблемы, которое может быть использовано для записи уникального идентификатора, соответствующего системе, в работе которой наблюдается сбой, а также поле Комментарий, в которое можно ввести более подробное описание причины завершения работы. При выборе варианта Другое необходимо ввести текст в поле.

После этого причины регистрируются в компоненте «Просмотр событий». Дополнительные сведения о просмотре причин завершения работы в компоненте «Просмотр событий» см. в разделе Чтобы просмотреть данные регистрации событий завершения работы.

Имеется возможность дополнить или заменить стандартные причины Windows особыми причинами, определенными пользователем. Дополнительные сведения см. в разделе Чтобы добавить особые причины завершения работы.

После внезапного завершения работы необходимо указать причину. Если после перезагрузки компьютера, которая последовала за внезапным завершением работы, в течение двух минут причина не была определена, в Windows будет выполнен выход из системы, а на экран будет выведена заставка начального входа в систему.

Можно определить причину только последней перезагрузки компьютера.


Управление регистрацией событий завершения работы из командной строки

Помимо использования диалогового окна Завершение работы Windows для записи причин завершения работы или перезагрузки имеется возможность использовать для выполнения этих действий командную строку. Дополнительные сведения см. в разделе Чтобы завершить работу и документировать причины.

При использовании командной строки для завершения работы или перезагрузки имеется возможность использовать несколько необязательных параметров, включая основной и вспомогательный код причины. Дополнительные сведения см. в разделе Завершение работы.

Дополнительные сведения о других служебных программах командной строки см. в разделе Справочник по использованию командной строки.


Устранение неполадок

Вид неполадки

При завершении работы компьютера не выполняется регистрация событий завершения работы.

Причина. Регистрация событий завершения работы выключена.

Решение. Включите регистрацию событий завершения работы.

См. также: Чтобы включить регистрацию событий завершения работы.

При инициировании завершения работы при помощи командной строки текст причины завершения работы не выводится в окне «Просмотр событий».

Причина. Не был использован правильный код причины. При использовании командной строки для завершения работы и документирования причин завершения работы основной и вспомогательный коды причины, указанные в команде, должны быть определены на компьютере, завершение работы которого выполняется. Если эти коды не определены, конечная запись в окне «Просмотр событий» будет содержать те же коды, которые были использованы в команде завершения работы, однако на экран будет выведен неправильный текст.

Решение. Определите коды причин на компьютере, завершение работы которого должно быть выполнено.

См. также: Чтобы добавить особые причины завершения работы

После выбора причины завершения работы кнопка ОК становится недоступной.

Причина. Для параметра причины необходимо ввести текстовую запись.

Решение. Введите сведения в соответствующее текстовое поле.

См. также: Использование регистрации событий завершения работы для завершений работы, инициированных пользователем; Использование регистрации событий завершения работы для внезапного завершения работы.