SNMP

Протокол SNMP (Simple Network Management Protocol) обеспечивает возможность наблюдения и обмена сведениями о состоянии между различными узлами.

  • Перед установкой SNMP ознакомьтесь с разделом Контрольный список: внедрение службы SNMP.
  • Описание некоторых возможностей, изменившихся в Windows XP, см. в разделе Новые способы выполнения некоторых задач.
  • Советы по использованию SNMP находятся в разделе Советы и рекомендации.
  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Общие сведения см. в разделе Основные понятия.
  • Инструкции по устранению неполадок содержатся в разделе Устранение неполадок.


Контрольный список: внедрение службы SNMP

Действие | Справочные сведения
Приобретение, установка и настройка программного обеспечения SNMP. | Служба SNMP
Сбор сведений, необходимых для внедрения SNMP в сети. Обязательно следует указать контактное лицо (администратор), физическое местоположение компьютера, настроенные имена сообществ SNMP, а также IP- или IPX-адреса либо имена компьютеров систем управления SNMP в сети. | Использование SNMP
Установка SNMP на компьютер. | Установка службы SNMP
Настройка свойств агента SNMP. | Настройка свойств агента
При наличии в сети дополнительных служб TCP/IP (таких как мост или маршрутизатор) перед продолжением необходимо изучить документ RFC 1213 для получения дополнительных сведений о настройке. | Стандарты SNMP (документы RFC)
Настройка адресов назначения ловушек. | Настройка ловушек
Настройка параметров безопасности SNMP. | Настройка безопасности

Примечание

  • XOX


Новые способы выполнения некоторых задач

В следующей таблице перечислены общие задачи по настройке протокола SNMP (Simple Network Management Protocol) в Windows XP. Пользовательский интерфейс Windows XP для выполнения этих задач отличается от того, который применяется в Windows NT 4.0.

Примечание

  • XOX
Если требуется | В Windows NT 4.0 используйте | В Windows XP используйте
Установить службу SNMP. | Пункт «SNMP Service» в параметрах установки TCP/IP Windows NT. | Компонент Установка и удаление программ на панели управления. Дополнительные сведения см. в разделе Установка службы SNMP.
Настроить агент SNMP. | Control Panel, Network, вкладка Services. | Значок Службы в консоли управления компьютером. Дополнительные сведения см. в разделе Настройка свойств агента.
Настроить ловушки SNMP. | Control Panel, Network, вкладка Services. | Значок Службы в консоли управления компьютером. Дополнительные сведения см. в разделе Настройка ловушек.
Настроить безопасность SNMP. | Control Panel, Network, вкладка Services. | Значок Службы в консоли управления компьютером. Дополнительные сведения см. в разделе Настройка безопасности.


Советы и рекомендации

Служба SNMP значительно упрощает управление сетью. Для наиболее полного использования ее преимуществ соблюдайте следующие рекомендации.

  • Старайтесь организовать сообщества SNMP по функциональным организациям, следуя распределенной модели безопасности. Для получения дополнительных сведений о протоколе SNMP выполните поиск по фразе «Simple Network Management Protocol» на веб-узле ресурсов Microsoft Windows (http://www.microsoft.com/).
  • По умолчанию на вкладке «Безопасность» указано одно имя сообщества (public) и установлен параметр Принимать пакеты SNMP от любого узла. Эти параметры следует изменить, указав имя выбранного сообщества и установив параметр Принимать пакеты SNMP только от этих узлов с указанием списка узлов. Настройки должны контролироваться и обновляться постоянно.
  • Используйте возможность проверки безопасности SNMP путем настройки ловушек проверки подлинности во всех агентах SNMP.
  • При необходимости наблюдения за компонентами конкретных служб, такими как DHCP (Dynamic Host Configuration Protocol) или WINS (Windows Internet Name Service), убедитесь, что эти службы были успешно установлены и настроены.


Инструкции

  • Установка службы SNMP
  • Настройка свойств агента
  • Настройка ловушек
  • Настройка безопасности
  • Запуск или остановка службы SNMP
  • Настройка трансляции событий в ловушки


Установка службы SNMP

Рисунок Microsoft Windows

Чтобы установить службу SNMP

  1. Откройте Мастер компонентов Windows.
  2. В списке Компоненты щелкните Средства управления и наблюдения (не устанавливая и не снимая соответствующий флажок) и нажмите кнопку Состав.
  3. Установите флажок Протокол SNMP и нажмите кнопку OK.
  4. Нажмите кнопку Далее.

Примечания

  • XOX
  • XOX
  • XOX
  • После установки SNMP запускается автоматически.

См. также


Настройка свойств агента

Рисунок Microsoft Windows

Чтобы настроить свойства агента

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните узел Службы.

    Где?

    • Службы и приложения
    • Службы
  3. В области сведений выберите Служба SNMP.
  4. В меню Действие выберите команду Свойства.
  5. На вкладке Агент SNMP в поле Контактное лицо введите имя пользователя или администратора для данного компьютера.
  6. В поле Размещение укажите физическое расположение компьютера или контактного лица.
  7. В группе Службы установите нужные флажки и нажмите кнопку OK.

Примечания

  • XOX
  • Изменения значений в полях Контактное лицо или Размещение вступают в силу в течение нескольких минут.

См. также


Настройка ловушек

Рисунок Microsoft Windows

Чтобы настроить ловушки

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните узел Службы.

    Где?

    • Службы и приложения
    • Службы
  3. В области сведений выберите Служба SNMP.
  4. В меню Действие выберите команду Свойства.
  5. На вкладке Ловушки в поле Имя сообщества введите с учетом регистра символов имя сообщества, которому текущий компьютер будет отправлять ловушки, и нажмите кнопку Добавить в список.
  6. В группе Адреса назначения ловушки нажмите кнопку Добавить.
  7. Введите в поле Имя, IP-адрес или IPX-адрес узла сведения об узле и нажмите кнопку Добавить.
  8. Повторяйте шаги с 5 по 7, пока не будут добавлены все нужные сообщества и адреса назначения ловушек.

Примечания

  • XOX
  • Изменения существующих настроек SNMP вступают в силу немедленно. Перезапускать службу SNMP для ввода настроек в силу не требуется.
  • XOX

См. также


Настройка безопасности

Рисунок Microsoft Windows

Чтобы настроить безопасность

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните узел Службы.

    Где?

    • Службы и приложения
    • Службы
  3. В области сведений выберите Служба SNMP.
  4. В меню Действие выберите команду Свойства.
  5. На вкладке Безопасность установите флажок Посылать ловушку проверки подлинности, если требуется отправлять ловушку при каждом сбое проверки подлинности.
  6. В группе Приемлемые имена сообществ нажмите кнопку Добавить.
  7. В поле Права сообщества выберите уровень доступа данного узла для обработки запросов SNMP от выбранного сообщества.
  8. В поле Имя сообщества введите имя сообщества с учетом регистра символов и нажмите кнопку Добавить.
  9. Укажите, следует ли принимать пакеты SNMP от узла:
    • чтобы принимать запросы SNMP от любого узла сети, выберите Принимать пакеты SNMP от любого узла;
    • чтобы ограничить прием пакетов SNMP, выберите Принимать пакеты SNMP только от этих узлов, нажмите кнопку Добавить, введите имя, IP-адрес или IPX-адрес соответствующего узла и снова нажмите кнопку Добавить.

Важно!

  • В случае удаления всех имен сообществ, включая используемое по умолчанию имя Public, SNMP не будет отвечать ни на одно из представленных имен сообществ.

Примечания

  • XOX
  • Имена сообществ и узлов можно добавлять по необходимости.
  • Для изменения записи следует выделить ее и нажать кнопку Изменить. Для удаления выделенной записи нажмите кнопку Удалить.
  • Изменения существующих настроек SNMP вступают в силу немедленно. Перезапускать службу SNMP для ввода настроек в силу не требуется.
  • XOX

См. также


Запуск или остановка службы SNMP

Рисунок Microsoft Windows

Чтобы запустить или остановить службу SNMP

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните узел Службы.

    Где?

    • Службы и приложения
    • Службы
  3. В области сведений выберите Служба SNMP.
  4. В меню Действие выберите Пуск, Стоп или Перезапустить.

Примечания

  • XOX
  • При добавлении расширений SNMP изменения вступают в силу после перезапуска службы.

См. также


Настройка трансляции событий в ловушки

Рисунок Microsoft Windows

Чтобы настроить трансляцию событий в ловушки

  1. Откройте окно Командная строка.
  2. В командной строке введите evntcmd /?, чтобы просмотреть сведения о синтаксисе и параметрах команды evntcmd.

Примечание

  • XOX

См. также


Основные понятия

В этом разделе

  • Общие сведения о протоколе SNMP
  • Общее представление о SNMP
  • Использование SNMP
  • Ресурсы


Общие сведения о протоколе SNMP

  • Определение SNMP
  • Служба SNMP


Определение SNMP

Протокол SNMP (Simple Network Management Protocol) является стандартом управления сетью, широко используемым в сетях TCP/IP.

SNMP обеспечивает способ управления узлами сети (такими как рабочие станции, серверы, маршрутизаторы, мосты и концентраторы) с центрального компьютера, на котором выполняется программное обеспечение управления сетью. SNMP выполняет службы управления с использованием распределенной архитектуры систем управления и агентов.

Поскольку управление сетью критично как для аудита, так и для управления ресурсами, SNMP может использоваться для выполнения следующих задач.

  • Настройка удаленных устройств. Из системы управления можно отправить сведения о настройке на каждый узел сети.
  • Наблюдение за производительностью сети. Существует возможность отслеживать скорость обработки и передачи данных, а также собирать сведения об успешной передаче данных.
  • Определение сбоев сети или неправильного доступа. На сетевых устройствах можно настроить триггеры, срабатывающие при возникновении конкретных событий. При срабатывании триггера устройство пересылает в систему управления сообщение о событии. Часто используется оповещение при завершении и перезапуске устройства, обнаружении неудачного соединения на маршрутизаторе и неправильном доступе.
  • Аудит использования сети. Существует возможность наблюдения как за общим использованием сети для определения доступа пользователей или групп, так и за типами использования для сетевых устройств и служб.


Служба SNMP

Служба SNMP (Simple Network Management Protocol) поддерживает компьютеры, использующие протоколы TCP/IP и IPX. Эта служба является необязательной и может быть установлена после успешной настройки протокола TCP/IP.

Служба SNMP обеспечивает работу агента SNMP, делающего возможным удаленное централизованное управление компьютерами со следующим программным обеспечением:

  • Windows XP Home Edition
  • Windows XP Professional
  • Windows 2000 Professional
  • Windows 2000 Server

Агент SNMP также позволяет управлять следующими службами:

  • служба WINS Windows XP and Windows 2000;
  • служба DHCP Windows XP and Windows 2000;
  • служба IIS Windows XP and Windows 2000;
  • LAN Manager.

Для доступа к сведениям, предоставляемым службой агента SNMP, необходимо по крайней мере одно приложение системы управления SNMP. Служба SNMP поддерживает, но в настоящее время не включает в себя управляющее программное обеспечение SNMP. Управляющее программное обеспечение SNMP должно выполняться на узле, играющем роль системы управления. Для получения дополнительных сведений программном обеспечении для управления SNMP выполните поиск по фразе «Simple Network Management Protocol» на веб-узле ресурсов Microsoft Windows (http://www.microsoft.com/).

Примечание

  • XOX


Общее представление о SNMP

  • Системы управления и агенты SNMP
  • Описание работы SNMP
  • Сообщения SNMP


Системы управления и агенты SNMP

Для использования SNMP необходимо наличие двух компонентов.

  • Система управления SNMP.

    Система управления, также называемая консолью управления, отправляет агенту SNMP запросы на получение сведений и данных. Системой управления SNMP является любой компьютер, на котором выполняется управляющее программное обеспечение SNMP. Управляющее приложение не обязательно должно выполняться на том же узле, что и агент SNMP.

    Система управления SNMP запрашивает сведения с управляемого компьютера, называемого агентом SNMP, такие как объем свободного места на жестком диске или число активных сеансов. Если системе управления предоставлен доступ к агенту на запись, эта система управления также может инициировать изменение конфигурации агента.

  • Агент SNMP.

    • Агент SNMP отвечает на отправляемые системой управления запросы сведений. Агентом SNMP является любой компьютер, на котором выполняется программное обеспечение агента SNMP. Служба SNMP, представляющая собой программное обеспечение агента, отвечает на запросы сведений от одной или нескольких систем управления. Служба SNMP может быть настроена на определение круга отслеживаемой статистики и управляющих систем, уполномоченных для запрашивания сведений.

    Как правило, агенты не отправляют сообщения, а только отвечают на входящие сообщения. Ловушки являются единственным типом сообщений, создаваемых агентами SNMP самостоятельно и способствуют повышению безопасности. Ловушка настраивается на выполнение при возникновении события агента, такого как перезагрузка системы или попытка незаконного доступа.

    Управляющие узлы и агенты принадлежат к сообществу SNMP, представляющему собой набор узлов, объединенных для удобства управления. Определение сообществ обеспечивает безопасность, разрешая обмен данными только между системами управления и агентами в рамках одного сообщества.


Описание работы SNMP

Агенты и системы управления используют сообщения SNMP для проверки и передачи сведений об узлах. Для отправки сообщений SNMP используется протокол UDP (User Datagram Protocol). Протокол IP (Internet Protocol) используется для маршрутизации сообщений между системой управления и узлом.

Сведения, запрашиваемые системой управления, содержатся в MIB (management information base). MIB — это база данных, содержащая различные сведения о подключенном к сети компьютере, такие как версия сетевого программного обеспечения, выполняемого на этом компьютере, и объем свободного места на жестком диске.

Следующий пример иллюстрирует порядок ответа агента SNMP на запрос сведений системой управления.

Модель SNMP
  1. Система управления (Узел A) отправляет датаграмму SNMP агенту (Узел B), используя имя, IP-адрес или IPX-адрес узла агента.
  2. Агент SNMP получает датаграмму и проверяет имя сообщества, к которому принадлежит система управления. Если имя сообщества допустимо, агент получает запрошенные данные. Если имя сообщества является недопустимым, а служба SNMP настроена для отправки ловушки проверки подлинности, агент отправляет извещение о сбое проверки подлинности по заданным для него адресам назначения ловушек (узлы C и D).
  3. Если имя сообщества является допустимым, агент SNMP возвращает системе управления датаграмму с запрошенными сведениями.

Для получения дополнительных сведений о типах сообщений SNMP или MIB выполните поиск по фразе «Simple Network Management Protocol» на веб-узле ресурсов Microsoft Windows (http://www.microsoft.com/).

Примечания

  • Для выполнения задач система управления SNMP отправляет сообщения Get, Get-next, Set и Getbulk.
  • При возникновении события агент может отправлять ловушку. Например, ловушка может быть отправлена в ответ на событие перезагрузки системы.
  • XOX


Сообщения SNMP

Когда программы управления SNMP отправляют запросы на сетевое устройство, программное обеспечение агента на этом устройстве получает отправленные запросы и извлекает нужные сведения из MIB. Затем агент отправляет запрошенные сведения обратно в исходную программу управления SNMP. Для выполнения этих задач агент использует следующие сообщения.

Сообщение SNMP | Описание
Get | Основное запрашивающее сообщение SNMP. Отправляется системой управления SNMP для запроса у агента SNMP сведений об одной записи MIB. Например, об объеме свободного места на диске.
Get-next | Расширенный тип запрашивающего сообщения. Может использоваться для просмотра целого дерева объектов управления. Обрабатывая запрос Get-next для конкретного объекта, агент возвращает идентификатор и значение объекта, логически следующего за объектом, указанным в запросе. Запрос Get-next удобен для динамических таблиц, таких как внутренняя таблица маршрутов IP.
Set | Если разрешен доступ на запись, с помощью данного сообщения можно отправить и назначить агенту обновленное значение MIB.
Getbulk | Запрашивает агент узла о передаче максимального объема данных в пределах заданных ограничений по размеру сообщения. Это уменьшает количество пакетов протокола, необходимых для получения большого объема сведений управления. Максимальный размер сообщения не должен превышать максимальный блок данных для канала (предельно допустимый размер одного сетевого пакета), в противном случае может возникнуть фрагментация.
Trap (ловушка) | Сообщение, самостоятельно отправляемое агентом SNMP системе управления SNMP при обнаружении агентом события определенного типа, возникшего локально на управляемом узле. Консоль управления SNMP, получающую ловушку, называют адресом назначения ловушки. Например, ловушка может быть отправлена в ответ на событие перезагрузки системы.


Использование SNMP

  • Определение сообществ
  • Свойства агента
  • Свойства ловушки
  • Параметры безопасности SNMP
  • Параметры службы SNMP
  • Управление SNMP из командной строки


Определение сообществ

Для удобства администрирования группы узлов назначают сообществам SNMP (Simple Network Management Protocol) с целью ограниченной проверки безопасности агентов и систем управления. Сообществам присваиваются имена. Один узел может принадлежать к нескольким сообществам одновременно, но агенты принимают запросы только от систем управления, входящих в список допустимых имен сообществ для этих агентов.

См. Советы и рекомендации.

Для использования преимуществ проверки подлинности, предоставляемой SNMP, определяйте сообщества логически. В следующем примере сообществ два: Public 1 и Public 2.

Сообщества
  • Компьютер Agent1 может отправлять ловушки и другие сообщения на компьютер Manager2, так как они оба являются членами сообщества Public2.
  • Компьютеры Agent2–Agent4 могут отправлять ловушки и другие сообщения на компьютер Manager1, так как все они по умолчанию являются членами сообщества Public1.

Управление именами сообществ выполняется посредством настройки параметров безопасности SNMP.

Примечание

  • Связь между именами сообществ и именами домена или рабочей группы отсутствует. Имена сообществ представляют общий пароль для групп узлов сети, и их следует выбирать и изменять при смене любого пароля.


Свойства агента

Агент SNMP (Simple Network Management Protocol) поставляет сведения об активности на сетевом уровне IP (Internet Protocol) в соответствующую систему управления.

Служба SNMP отправляет сведения MIB в ответ на запрос SNMP или на ловушку SNMP.

Следующие свойства агента можно настроить на вкладке Агент SNMP диалогового окна Служба SNMP Свойства.

Служба агента | Установите соответствующий флажок, если компьютер
Физическая | Управляет физическими устройствами, например разделом жесткого диска.
Приложений | Использует приложения, передающие данные с помощью протокола TCP/IP. Эта служба должна быть включена всегда.
Канала данных и подсети | Управляет мостом.
Интернет | Является шлюзом (маршрутизатором) IP.
Узел-узел | Является узлом IP. Эта служба должна быть включена всегда.

Кроме того, возможна настройка следующих свойств агента.

  • Местонахождение контактного лица.
  • Имя контактного лица, такого как администратор сети.

Дополнительные сведения о настройке свойств агента SNMP см. в разделе Настройка свойств агента.


Свойства ловушки

Служба SNMP, настроенная для использования агента, создает ловушки каждый раз при возникновении конкретных событий. Эти сообщения посылаются по адресу назначения ловушки. Например, агент может быть настроен на отправку ловушки проверки подлинности в случае, когда запрос сведений поступает из неопознанной системы управления.

Адрес назначения ловушки состоит из имени компьютера либо IP- или IPX-адреса системы управления. В качестве адреса назначения ловушки должен быть указан подключенный к сети узел, на котором выполняется управляющее программное обеспечение SNMP. Адреса назначения ловушек могут быть настроены пользователем, но события для создания ловушек (такие как перезагрузка системы) определяются агентом SNMP.

XOX

Для настройки адресов назначения ловушек используется вкладка Ловушки в диалоговом окне Служба SNMP - свойства.

Дополнительные сведения о настройке ловушек SNMP см. в разделе Настройка ловушек.


Параметры безопасности SNMP

SNMP (Simple Network Management Protocol) обеспечивает безопасность через использование имен сообществ и ловушек проверки подлинности. Обмен данными SNMP для агента можно ограничить, разрешив обмен данными только с конкретным списком других систем управления SNMP.

Для настройки безопасности SNMP используется вкладка Безопасность диалогового окна Служба SNMP Свойства.

Для включения безопасности SNMP могут быть настроены следующие параметры.

  • Приемлемые имена сообществ. Служба требует наличия по крайней мере одного имени сообщества, используемого по умолчанию. Имя сообщества public является универсально приемлемым во всех реализациях SNMP. Пользователь может добавить несколько имен сообществ, а также удалить или изменить имя сообщества, используемое по умолчанию. Имена сообществ, настроенных в этом окне, используются в адресах назначения ловушек. Поступление запроса SNMP из сообщества, отсутствующего в данном списке, вызывает отправку ловушки проверки подлинности.
  • Права. Допускается выбор уровня доступа, определяющего порядок обработки агентом SNMP запросов из выбранного сообщества. Например, можно настроить уровень доступа для блокирования обработки агентом SNMP любых запросов, поступающих из конкретного сообщества.
  • Принимать пакеты SNMP от любого узла. При выборе этого параметра исходным узлом является исходная система управления SNMP, а списком приемлемых узлов — список приемлемых систем управления. Пакеты SNMP не отклоняются на основе имени или адреса исходного узла или списка приемлемых узлов. Данный вариант установлен по умолчанию.
  • Принимать пакеты SNMP только от этих узлов. В этом контексте список приемлемых узлов задает приемлемые системы управления SNMP. При установке данного флажка принимаются только пакеты SNMP, полученные от узлов, перечисленных в этом списке. В противном случае сообщение SNMP отклоняется и отправляется ловушка проверки подлинности. Выбор данного параметра обеспечивает большую безопасность, чем использование имени сообщества, которое может содержать множество узлов.
  • Посылать ловушку проверки подлинности. Проверка подлинности заключается в проверке допустимости имени или адреса узла. Когда агент SNMP получает запрос, который не содержит правильного имени сообщества или не был отправлен узлом из списка приемлемых узлов, агент посылает ловушку проверки подлинности на один или несколько адресов назначения ловушки (системам управления), указывая на сбой проверки подлинности. Данный вариант установлен по умолчанию.

Дополнительные сведения о настройке безопасности SNMP см. в разделе Настройка безопасности.

Внимание!

  • В случае удаления всех имен сообществ, включая используемое по умолчанию имя public, SNMP не будет отвечать ни на одно из представленных имен сообществ.
  • По умолчанию на вкладке «Безопасность» указано одно имя сообщества public и установлен параметр Принимать пакеты SNMP от любого узла. Для повышения безопасности эти параметры следует изменить, указав имя выбранного сообщества и установив параметр Принимать пакеты SNMP только от этих узлов с указанием списка узлов. Настройки должны контролироваться и обновляться постоянно.


Параметры службы SNMP

Вкладки Общие, Вход в систему и Восстановление диалогового окна Служба SNMP Свойства используются для настройки порядка запуска службы SNMP, ее входа в систему, а также восстановления при аварийном завершении работы программы службы или операционной системы.

Сведения об изменении этих параметров см. в разделе Службы.


Управление SNMP из командной строки

С помощью команды evntcmd можно настраивать ловушки SNMP для событий, записываемых в системные журналы. Эту команду также можно использовать для указания адресов назначения ловушек в сообществе SNMP. Сведения об использовании команды evntcmd для настройки ловушек и адресов назначения для ловушек см. в разделе evntcmd. Сведения об определении событий, для которых можно настраивать ловушки, см. в разделе Просмотр событий.

С помощью команды evntwin можно запускать средство «Трансляция событий в ловушки», предоставляющее графический интерфейс для настройки трансляции событий в ловушки. Однако средство «Трансляция событий в ловушки» не позволяет настраивать адреса назначения ловушек. Сведения о настройке адресов назначения ловушек с помощью консоли SNMP см. в разделе Настройка ловушек.

Для использования команд evntcmd и evntwin необходимо установить SNMP.

Сведения о других служебных программах командной строки см. в разделе Справочник по параметрам командной строки. Дополнительные сведения о возможностях управления см. в разделе Управление и администрирование.


Ресурсы

  • Стандарт SNMP
  • Стандарты SNMP (документы RFC)
  • Последние технические сведения


Стандарт SNMP

Протокол SNMP (simple network management protocol) был создан с целью разработки эффективной платформы управления разнородными сетями на базе TCP/IP в 1988 году и утвержден IAB (Internet Activities Board) в качестве стандарта Интернета в 1990 году.

В Windows XP реализованы версии SNMP 1 и 2C. Эти версии основаны на промышленных стандартах, определяющих структуру, порядок хранения и обмен сведениями управления сетью между агентами и системами управления для сетей на базе TCP/IP.

Стандарт SNMP обобщает следующие концепции, описанные в документах RFC:

  • Согласно определению, данному в RFC 1213, MIB II (Management Information Base II) — это набор управляемых объектов, представляющих различные типы сведений о компонентах TCP/IP в сети, таких как список сетевых интерфейсов, таблица маршрутов и таблица подключений TCP. Служба SNMP Windows XP поддерживает Host Resources MIB (RFC 1514), LAN Manager MIB II, DHCP MIB, WINS MIB, и Internet Information Services MIB. Для использования со службой SNMP Windows XP могут быть созданы и другие MIB. Для получения дополнительных сведений об объектах MIB выполните поиск по фразе «Simple Network Management Protocol» на веб-узле ресурсов Microsoft Windows (http://www.microsoft.com/).
  • SMI (Structure for Management Information) является отдельным документом RFC Интернета (RFC 1902), описывающим синтаксис объекта для указания порядка ссылок на данные MIB и их хранения.
  • Согласно определению, данному в RFC 1157, SNMP (Simple Network Management Protocol) — это стандарт, определяющий порядок обмена данными между SNMP-совместимыми устройствами и перечень допустимых типов сообщений.


Стандарты SNMP (документы RFC)

Документы RFC представляют собой постоянно обновляющийся комплект отчетов, предложений протоколов и описаний стандартов протоколов, которые используются сообществом Интернета. Спецификации SNMP (Simple Network Management Protocol) определены в документах RFC, опубликованных IETF (Internet Engineering Task Force) и другими рабочими группами.

Основные стандарты SNMP указаны в следующих документах RFC.

RFC | Описание
1155 | Структура и определение сведений управления для глобальных сетей на базе TCP/IP
1157 | Протокол SNMP (Simple Network Management Protocol)
1213 | Информационная база (Management Information Base) для управления глобальными сетями на базе TCP/IP: MIB-II
1901 | Введение в SNMPv2 на основе сообществ
1902 | Структура сведений управления для протокола SNMP версии 2 (SNMPv2)
1903 | Текстовые соглашения для протокола SNMP версии 2 (SNMPv2)
1904 | Условия совместимости для протокола SNMP версии 2 (SNMPv2)
1905 | Операции протокола SNMP версии 2 (SNMPv2)
1906 | Сопоставления транспорта для протокола SNMP версии 2 (SNMPv2)
1907 | Информационная база управления (Management Information Base) для протокола SNMP версии 2 (SNMPv2)
1908 | Сосуществование версий 1 и 2 Интернет-стандарта управления сетями (Internet-standard Network Management Framework)
2089 | V2ToV1: сопоставление SNMPv2 и SNMPv1 в двуязычном агенте SNMP

Дополнительные сведения по RFC и способам их получения см. в разделе Стандарты TCP/IP (документы RFC).

Примечания

  • Самые последние документы RFC по SNMP см. на веб-узле активных рабочих групп IETF.
  • XOX


Последние технические сведения

Служба поддержки продуктов корпорации Майкрософт предоставляет дополнительные сведения по SNMP. См. раздел Дополнительные сведения от службы поддержки продуктов корпорации Майкрософт.


Устранение неполадок

Вид неполадки

Клиент SNMP не функционирует.

Причина. Неизвестная неполадка сети или SNMP.

Решение. Обработка ошибок SNMP интегрирована с окном просмотра событий. При подозрении на наличие неполадок службы SNMP воспользуйтесь окном просмотра событий. Фильтр в меню Вид можно настроить на отображение только сообщений SNMP.

См. также Использование окна просмотра событий.

Система управления SNMP постоянно превышает время ожидания при запросе сервера WINS.

Причина. Задан слишком короткий период ожидания SNMP, либо сервер WINS отключен от сети или недоступен.

Решение. Увеличьте период ожидания SNMP в системе управления SNMP. Если это не поможет, обратитесь к системному администратору для проверки сервера WINS.