Что такое "Выбор программ по умолчанию"

"Выбор программ по умолчанию" - это функция с помощью которой можно указать программы, используемые по умолчанию для таких операций, как просмотр страниц в Интернете и отправка сообщений электронной почты. Кроме того, можно указать, какие программы будут доступны в главном меню, на рабочем столе и в других местах.

Для указания обозревателя, проигрывателя мультимедиа, программы электронной почты, программы доставки сообщений или виртуальной машины Java, которые будут использоваться системой Windows по умолчанию, необходимо обладать правами администратора.

* Примечание

  • Microsoft Windows Messenger, проигрыватель Microsoft Windows Media и виртуальная машина Microsoft (VM) не входят в состав 64-разрядной версии Windows XP Windows&nbsp;XP 64-bit Edition. В результате эти программы отсутствуют в функции "Выбор программ по умолчанию" в 64-разрядной версии Windows XP Windows&nbsp;XP 64-bit Edition.

* Связанные разделы

Выбор программ по умолчанию с помощью функции "Выбор программ по умолчанию"

Устранение неполадок функции "Выбор программ по умолчанию"


Выбор программ по умолчанию с помощью функции "Выбор программ по умолчанию"

Чтобы выбрать программы по умолчанию с помощью функции "Выбор программ по умолчанию"

  1. Нажмите кнопку Пуск, а затем выберите Выбор программ по умолчанию.
  2. Чтобы указать программы по умолчанию для таких операций, как просмотр страниц в Интернете и отправка сообщений электронной почты, выполните одно из следующих действий.
Выберите | Чтобы
Computer Manufacturer | Восстановить значения параметров, установленные изготовителем компьютера. Этот параметр доступен для выбора только в том случае, если на компьютере изготовителем установлен пакет обновления 1 для Windows XP и назначены параметры для этой функции.
Microsoft Windows | Использовать программы, которые по умолчанию входят в состав системы Windows. Даже если по умолчанию будут использоваться программы корпорации Майкрософт, все другие программы, установленные на компьютере, будут по-прежнему доступными.
Non-Microsoft | По умолчанию использовать те программы, установленные на компьютере, производителем которых не является корпорация Майкрософт. Если выбрать этот параметр, указанные программы Microsoft Windows будут недоступны. Однако доступ к программам можно установить в любое время с помощью функции "Выбор программ по умолчанию".
Custom | Использовать по умолчанию как программы корпорации Майкрософт Windows, так и программы других производителей. Выборочная настройка позволяет указать программы по умолчанию для каждой операции. Если не нужно, чтобы программа отображалась в главном меню , на рабочем столе или в других местах, где обычно отображаются программы, снимите флажок Enable access to this program рядом с названием программы.

* Примечания

  • При запуске функции "Выбор программ по умолчанию" параметр Custom по умолчанию всегда выбран.
  • Если в области Custom выбрать Use my current…, будет по-прежнему использоваться программа, являющаяся программой по умолчанию для этой категории.
  • Работа программ с функцией "Выбор программ по умолчанию" определяется их производителями. Для некоторых программ, не являющихся программами корпорации Майкрософт, могут продолжать отображаться значки с меню кнопки Пуск и других местах, даже если для них будет снят флажок Enable access to this program.
  • Невозможно указать различные программы по умолчанию для разных пользователей или запретить доступ к программам для некоторых пользователей. Параметры, установленные с помощью функции "Выбор программ по умолчанию", используются для всех пользователей компьютера.

* Связанные разделы

Что такое "Выбор программ по умолчанию"

Устранение неполадок функции "Выбор программ по умолчанию"


Устранение неполадок функции "Выбор программ по умолчанию"

Ниже приведен список вопросов, с которыми можно столкнуться при использовании функции "Выбор программ по умолчанию".

  • При попытке изменения параметров функции "Выбор программ по умолчанию" получено следующее сообщение об ошибке "You do not have permission to set program access and defaults."

    • Функцию можно использовать только при входе с правами администратора.

    Войдите в систему как администратор, а затем измените параметры.

  • Была предпринята попытка указать различные программы по умолчанию для разных пользователей, но это невозможно.

    • Программы по умолчанию, выбранные в окне "Выбор программ по умолчанию", используются всеми пользователями этого компьютера. Невозможно указать различные программы по умолчанию для разных пользователей или запретить доступ к программам для определенных пользователей.

  • Предварительно установленные программы, не являющиеся программами корпорации Майкрософт, не отображаются в списке "Выбор программ по умолчанию".

    • Чтобы программы отображались в списке "Выбор программ по умолчанию", их необходимо зарегистрировать. Если программа не отображается в списке, она является незарегистрированной и не может быть установлена в качестве программы по умолчанию при использовании функции "Выбор программ по умолчанию". Обратитесь за помощью в компанию-производитель программы.

  • Программы, не являющиеся программами корпорации Майкрософт, были удалены из главного меню, но они в нем по-прежнему отображаются.

    • Работа программ с функцией "Выбор программ по умолчанию" определяется их производителями. Для некоторых программ сторонних производителей значки могут продолжать отображаться в главном меню и других местах, даже если для них снят флажок Enable access to this program.

  • Почему каждый раз при запуске функции "Выбор программ по умолчанию" выбирается параметр Custom?

    • По умолчанию функция запускается с выбранным параметром Custom.

* Примечания

  • Дополнительные сведения о функции "Выбор программ по умолчанию" см. в статье Q328326 базы знаний корпорации Майкрософт.
  • Microsoft Windows Messenger, проигрыватель Microsoft Windows Media и виртуальная машина Microsoft (VM) не входят в состав 64-разрядной версии Windows XP Windows&nbsp;XP 64-bit Edition. В результате эти программы отсутствуют в списке функции "Выбор программ по умолчанию" в 64-разрядной версии Windows XP.