Системный монитор

Системный монитор предоставляет средства наблюдения за использованием ресурсов операционной системы.

  • Прежде чем начать наблюдение, ознакомьтесь с разделом Контрольный список для наблюдения за производительностью.
  • Описания средств, изменившихся в Windows XP, см. в разделе Новые способы выполнения стандартных задач.
  • Справочные сведения по конкретным задачам см. в разделе Инструкции.
  • Сведения общего характера см. в разделе Основные понятия.
  • Рекомендации по устранению возможных неполадок см. в разделе Устранение неполадок.


Новые способы выполнения типичных задач

В следующей таблице приведены общие задачи для системного монитора и указания, где можно выполнить эти задачи в Windows XP и Windows 2000. Для пользователей предыдущих версий системного монитора (Perfmon.exe) в таблице также указано, где эти задачи выполняются в Windows NT 4.0. Многие кнопки панели инструментов не изменились и могут использоваться вместо приведенных последовательностей действий.

Задача | Средство Windows NT 4.0 | Средство Windows 2000 или Windows XP
Создание диаграммы, на основе данных о производительности. | Системный монитор в меню Администрирование. | Компонент Системный монитор консоли «Производительность», открываемой из окна «Администрирование».
Создание отчета. | Системный монитор в меню Администрирование. | Компонент «Системный монитор» консоли «Производительность», открываемой из окна «Администрирование».
Создание рабочего пространства с несколькими представлениями. | Системный монитор в меню Администрирование. | Консоль управления MMC, меню Файл, команда Добавить/удалить оснастку.


Инструкции

  • Работа со счетчиками
  • Работа в разных режимах наблюдения
  • Работа с данными
  • Работа с параметрами


Основные понятия

В этом разделе представлены сведения общего характера о системном мониторе.

  • Общие сведения о системном мониторе
  • Общее представление о системном мониторе
  • Использование системного монитора


Общее представление о системном мониторе

В этом разделе описаны интерфейс и работа системного монитора.

  • Объекты и счетчики производительности
  • Архитектура подсистемы наблюдения за производительностью
  • Наблюдение за производительностью в Windows NT 4.0


Использование системного монитора

В этом разделе

  • Настройка конфигурации подсистемы наблюдения
  • Выбор счетчиков для наблюдения за конкретными компонентами системы
  • Краткий справочник по настройке свойств системного монитора
  • Панель инструментов и сочетания клавиш системного монитора