Свойства системы

Средство «Свойства системы» позволяет просматривать и изменять свойства системы на локальном или удаленном компьютере.

  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Сведения общего характера находятся в разделе Основные понятия.


Инструкции

  • Установка параметров быстродействия
  • Установка системных параметров и параметров восстановления


Установка параметров быстродействия

  • Изменение максимального размера реестра компьютера
  • Изменение размера файла подкачки виртуальной памяти
  • Изменение быстродействия фоновых и оперативных программ
  • Просмотр свойств системы


Изменение максимального размера реестра компьютера

Рисунок Microsoft Windows

Чтобы изменить максимальный размер реестра компьютера

  1. XOX
  2. В дереве консоли щелкните правой кнопкой элемент Управление компьютером (локальным) и выберите команду Свойства.
  3. На вкладке Дополнительно нажмите кнопку Параметры быстродействия и в группе Виртуальная память нажмите кнопку Изменить.
  4. В группе Размер системного регистра введите новый размер реестра (в мегабайтах) в поле Максимальный размер (МБ).
  5. Перезагрузите компьютер, чтобы изменения вступили в силу.

Примечания

  • XOX
  • Чтобы выполнить эту задачу, необходимо быть администратором или членом группы администраторов на своем компьютере и на управляемом компьютере.
  • Допускается просмотр и изменение свойств системы на удаленном и локальном компьютерах. Для доступа к удаленному компьютеру щелкните правой кнопкой мыши элемент Управление компьютером (локальным), выберите команду Подключиться к другому компьютеру, а затем укажите необходимый компьютер.
  • Параметр максимального размера реестра определяет верхний предел области, выделяемой для данных реестра. Возможно, потребуется увеличить это значение, если объем данных реестра, созданных программами, превысит предел, установленный в группе Размер системного реестра.

См. также


Изменение размера файла подкачки виртуальной памяти

Чтобы изменить размер файла подкачки виртуальной памяти

  1. XOX
  2. В дереве консоли щелкните правой кнопкой элемент Управление компьютером (локальным) и выберите команду Свойства.
  3. На вкладке Дополнительно нажмите кнопку Параметры быстродействия и в группе Виртуальная память нажмите кнопку Изменить.
  4. В списке Диск выберите диск, содержащий файл подкачки, размер которого необходимо изменить.
  5. В группе Размер файла подкачки для выбранного диска введите новые значения (в мегабайтах) в поле Исходный размер (МБ) или в поле Максимальный размер (Мб), а затем нажмите кнопку Установить.

    6. При уменьшении максимального или минимального размера файла подкачки необходимо перезагрузить компьютер, чтобы изменения вступили в силу. При увеличении размера перезагрузка, обычно, не требуется.

Примечания

  • XOX
  • Чтобы выполнить эту задачу, необходимо быть администратором или членом группы администраторов на своем компьютере и на управляемом компьютере.
  • Допускается просмотр и изменение свойств системы на удаленном и локальном компьютерах. Для доступа к удаленному компьютеру щелкните правой кнопкой мыши элемент Управление компьютером (локальным), выберите команду Подключиться к другому компьютеру, а затем укажите необходимый компьютер.
  • Для увеличения производительности следует установить исходный размер файла подкачки не меньше, чем рекомендованный в группе Общий объем файла подкачки на всех дисках. Рекомендуемый размер файла подкачки должен быть в 1,5 раза больше размера оперативной памяти компьютера.
  • Обычно используется рекомендуемый размер файла подкачки, хотя можно увеличить размер этого файла, если на компьютере часто выполняются приложения, требующие много памяти.
  • Для удаления файла подкачки задайте нулевые значения для его исходного и максимального размеров.

См. также


Изменение быстродействия фоновых и оперативных программ

Чтобы изменить быстродействие фоновых и оперативных программ

  1. XOX
  2. В дереве консоли щелкните правой кнопкой элемент Управление компьютером (локальным) и выберите команду Свойства.
  3. Нажмите кнопку Параметры быстродействия на вкладке Дополнительно.
  4. Установите переключатель Отклик приложений.
    • Чтобы использовать больше ресурсов процессора для оперативных программ, чем для фоновых программ, выберите вариант приложений.
    • Чтобы использовать одинаковое количество ресурсов процессора для всех программ, выберите вариант служб, работающих в фоновом режиме.

Примечания

  • XOX
  • Чтобы выполнить эту задачу, необходимо быть администратором или членом группы администраторов на своем компьютере и на управляемом компьютере.
  • Допускается просмотр и изменение свойств системы на удаленном и локальном компьютерах. Для доступа к удаленному компьютеру щелкните правой кнопкой мыши элемент Управление компьютером (локальным), выберите команду Подключиться к другому компьютеру, а затем укажите необходимый компьютер.
  • В режиме приложений время отклика оперативных программ уменьшится. Для более быстрого выполнения фоновых задач, например архивирования, используйте режим служб, работающих в фоновом режиме.
  • В режиме приложений для выполнения программ выделяются небольшие изменяемые отрезки времени, а в режиме служб, работающих в фоновом режиме используются длинные фиксированные кванты.

См. также


Просмотр свойств системы

Чтобы просмотреть свойства системы

  1. XOX
  2. В дереве консоли щелкните правой кнопкой элемент Управление компьютером (локальным) и выберите команду Свойства.

Примечания

  • XOX
  • Допускается просмотр и изменение свойств системы на удаленном и локальном компьютерах. Для доступа к удаленному компьютеру щелкните правой кнопкой мыши элемент Управление компьютером (локальным), выберите команду Подключиться к другому компьютеру, а затем укажите необходимый компьютер.
  • На вкладке Общие выводятся следующие сведения: версия установленной операционной системы, имя пользователя, зарегистрировавшего данную копию Windows, тип процессора и общий объем физической памяти компьютера. Если операционная система была установлена изготовителем вычислительной техники (ИВТ), на этой вкладке также отображаются сведения о технической поддержке.

См. также


Установка системных параметров и параметров восстановления

  • Добавление или изменение значений переменных среды
  • Выбор операционной системы, загружаемой по умолчанию
  • Задание действий, выполняемых при внезапной остановке системы
  • Отключение удаленного компьютера
  • Идентификация компьютера в сети


Добавление или изменение значений переменных среды

Чтобы добавить или изменить значения переменных среды

  1. XOX
  2. В дереве консоли щелкните правой кнопкой элемент Управление компьютером (локальным) и выберите команду Свойства.
  3. На вкладке Дополнительно нажмите кнопку Переменные среды.
  4. Выберите пользователя в списке Пользовательские переменные для.
  5. Щелкните имя пользовательской или системной переменной, которую требуется изменить или удалить.
    • Чтобы добавить новую переменную и ее значение, нажмите кнопку Создать.
    • Чтобы изменить имя текущей переменной и ее значение, нажмите кнопку Изменить.
    • Чтобы удалить текущую переменную и ее значение, нажмите кнопку Удалить.

Примечания

  • XOX
  • Чтобы выполнить эту задачу, необходимо быть администратором или членом группы администраторов на своем компьютере и на управляемом компьютере.
  • Допускается просмотр и изменение свойств системы на удаленном и локальном компьютерах. Для доступа к удаленному компьютеру щелкните правой кнопкой мыши элемент Управление компьютером (локальным), выберите команду Подключиться к другому компьютеру, а затем укажите необходимый компьютер.
  • Изменения сохраняются в реестре и при следующей загрузке компьютера будут установлены автоматически.
  • Изменения не влияют на выполняющиеся программы и, возможно, не вступят в силу до перезагрузки компьютера.

См. также


Выбор операционной системы, загружаемой по умолчанию

Чтобы выбрать операционную систему, загружаемую по умолчанию

  1. XOX
  2. В дереве консоли щелкните правой кнопкой элемент Управление компьютером (локальным) и выберите команду Свойства.
  3. На вкладке Дополнительно нажмите кнопку Загрузка и восстановление.
  4. В группе Загрузка операционной системы в раскрывающемся списке Операционная система по умолчанию выберите операционную систему, которая загружается по умолчанию, если пользователь пропускает перечень вариантов загрузки, появляющийся после включения компьютера.
  5. В поле Отображать список операционных систем введите время в секундах, в течении которого должен отображаться перечень, содержащий возможные варианты загрузки.

Примечание

  • XOX
  • Чтобы выполнить эту задачу, необходимо быть администратором или членом группы администраторов на своем компьютере и на управляемом компьютере.
  • Допускается просмотр и изменение свойств системы на удаленном и локальном компьютерах. Для доступа к удаленному компьютеру щелкните правой кнопкой мыши элемент Управление компьютером (локальным), выберите команду Подключиться к другому компьютеру, а затем укажите необходимый компьютер.

См. также


Задание действий, выполняемых при внезапной остановке системы

Чтобы задать действия, выполняемые при внезапной остановке системы

  1. Щелкните значок Система на панели управления.
  2. На вкладке Дополнительно нажмите кнопку Настройка в группе Загрузка и восстановление, а затем в группе Отказ системы выберите необходимые действия, выполняемые Windows при обнаружении системной ошибки:
    • Отправить административное оповещение — обеспечит оповещение администратора системы;
    • Выполнить автоматическую перезагрузку — Windows автоматически перезапустит компьютер.
  3. В группе Запись отладочной информации выберите тип сведений, записываемых Windows при внезапной остановке системы:
    • Малый дамп памяти — записывает небольшой набор сведений, необходимых для определения неполадки. В этом режиме Windows создает новый файл (размером 64 КБ) при каждой внезапной остановке системы. Такие файлы будут храниться в папке, заданной в поле Папка малого дампа;
    • Дамп памяти ядра — записывает только данные ядра, что позволяет увеличить (по сравнению с полным дампом памяти) скорость записи журнала при внезапной остановке системы. Пространство, отводимое для файла подкачки, зависит от размера оперативной памяти (ОЗУ) компьютера, в то время как максимальный размер дампа памяти ядра составляет 2 060 МБ. Рекумендуемые размеры приведены в следующей таблице:
      Размер ОЗУ | Файл подкачки не должен быть меньше
      256 МБ – 1 373 МБ | 1,5-кратного размера ОЗУ
      1 374 МБ и больше | 2 060 МБ (максимальный объем данных в дампе памяти ядра)
    • Полный дамп памяти — не предусмотрен для систем с 4 ГБ оперативной памяти и для систем, использующих расширение физических адресов (Physical Address Extension, PAE). В этом режиме записывается все содержимое системной памяти при внезапной остановке системы. Выбирая этот параметр необходимо иметь на загрузочном томе файл подкачки не меньше полного объема физической памяти плюс один мегабайт.

Примечания

  • XOX
  • Для изменения параметров в группе Отказ системы необходимо войти на локальный компьютер в качестве администратора.
  • При задании параметров дампа памяти проверьте также размер файла подкачки на загрузочном томе. Задайте размер файла согласно рекомендациям (см. выше). Для получения сведений о том, как задать размер файла подкачки, щелкните ссылку «См. также».

    Рекомендуется использовать одинаковое значение как для минимального, так и для максимального размера файла подкачки. Это не позволит файлу непрерывно изменять текущий размер, что в свою очередь устранит нежелательную фрагментацию диска.

  • Выбирая вариант Дамп памяти ядра, убедитесь в том что размер файла подкачки соответствует значению, рекомендованному в процедуре; в противном случае необходимые данные могут быть не записаны.
  • Если выбран вариант Дамп памяти ядра или Полный дамп памяти и установлен флажок Затирать существующий файл дампа, Windows всегда будет записывать данные в один и тот же файл. Для записи различных дампов памяти снимите флажок Затирать существующий файл и изменяйте имя файла после каждой остановки системы.
  • Можно освободить некоторое количество памяти, если снять флажки записать отладочную информацию в файл, записать событие в системный журнал и отправить административное оповещение. Объем освободившейся памяти зависит от типа компьютера, однако обычно освобождается 60–70 КБ, которые занимают драйверы, обеспечивающие указанные функции.
  • В случае обращения в службу технической поддержки корпорации Майкрософт по поводу возникающей системной ошибке может потребоваться соответствующий файл дампа памяти.

См. также


Отключение удаленного компьютера

Чтобы отключить удаленный компьютер

  1. XOX
  2. В дереве консоли щелкните правой кнопкой компонент Управление компьютером (локальным) и выберите команду Подключение к другому компьютеру.
  3. В диалоговом окне Выбор компьютера установите режим другим компьютером, введите имя компьютера, который необходимо отключить или перезапустить, и нажмите кнопку OK. Для поиска необходимого компьютера можно также воспользоваться кнопкой Обзор.
  4. В дереве консоли щелкните правой кнопкой компонент Управление компьютером (имя удаленного компьютера) и выберите команду Свойства.
  5. На вкладке Дополнительно нажмите кнопку Загрузка и восстановление.
  6. Нажмите кнопку Перезагрузка, чтобы открыть диалоговое окно Завершение работы.
  7. С помощью переключателя Действия по отключению выберите действие, которое необходимо выполнить на управляемом компьютере.
  8. С помощью переключателя Закрывать приложения выберите режим закрытия приложений при отключении или перезапуске компьютера и нажмите кнопку OK.

Примечания

  • XOX
  • Чтобы выполнить эту задачу, необходимо быть администратором или членом группы администраторов на своем компьютере и на управляемом компьютере.

См. также


Идентификация компьютера в сети

Чтобы идентифицировать компьютер в сети

  1. XOX
  2. В дереве консоли щелкните правой кнопкой компонент Управление компьютером (локальным) и выберите команду Свойства.
  3. Выберите вкладку Сетевая идентификация. На этой вкладке выводится имя компьютера, рабочая группа или домен, к которым компьютер относится, а также краткое описание компьютера.

Примечания

  • XOX
  • Допускается просмотр и изменение свойств системы на удаленном и локальном компьютерах. Для доступа к удаленному компьютеру щелкните правой кнопкой мыши элемент Управление компьютером (локальным), выберите команду Подключиться к другому компьютеру, а затем укажите необходимый компьютер.
  • Краткое описание компьютера можно ввести (если оно отсутствует) или изменить на вкладке Сетевая идентификация. Однако изменение будет невозможно, если пользователь вошел в систему, используя ограниченную учетную запись (в Windows XP Home Edition) или учетную запись гостя.

См. также


Основные понятия

  • Общие сведения о средстве «Свойства системы»


Общие сведения о средстве «Свойства системы»

«Свойства системы» — это компонент инструментария управления Windows (Windows Management Instrumentation, WMI), позволяющий просматривать и изменять свойства системы на удаленном и локальном компьютерах. Далее перечислены задачи, которые можно решать с помощью этого компонента.

Изменение размера файла подкачки виртуальной памяти

Можно изменить настройку файла подкачки на компьютере, для запуска программ которого требуется большой объем виртуальной памяти.

Перезагрузка удаленного компьютера

Можно перезапустить удаленный компьютер для применения измененной настройки или обнаружения нового оборудования.

Идентификация компьютера в сети

Можно просмотреть сведения об именах компьютеров и доменов для других компьютеров в сети.

Для изменения некоторых свойств системы необходимо быть ее администратором.

См. также

  • Работа с файлами консоли управления MMC
  • Общее представление об инструментарии управления Windows
  • Изменение размера файла подкачки виртуальной памяти
  • Перезагрузка удаленного компьютера
  • Идентификация компьютера в сети


Общее представление об инструментарии управления Windows

Инструментарий управления Windows (Windows Management Instrumentation, WMI) — подсистема, обеспечивающая поддержку управления предприятием через Интернет. WMI предоставляет универсальную среду для работы с данными, необходимыми для управления предприятием. При этом посредством стандартизации предлагаемых средств обеспечивается комплексное решение задач управления. Подробные сведения о пакете WMI SDK (Software Development Kit) можно получить через MSDN (Microsoft Developer's Network).