Общие сведения о правилах набора номера

Интерфейс программирования приложений телефонии (TAPI) позволяет настраивать правила набора номера для всех программ телефонии. При запуске программы TAPI (такой как «Телефон») до настройки правил набора номера обычно запрашивается минимум сведений, необходимых для набора номера. Для полной настройки правил набора номера на компьютере используется объект Телефон и модем на панели управления, как описано в данном разделе.

Местоположение вызова

Местоположение вызова представляет собой набор параметров, используемых для анализа телефонных номеров и определения правильной последовательности набора номера. Допускается создание любого числа местоположений вызова для различных целей.

Местоположение вызова может соответствовать фактическому географическому положению, такому как кабинет или гостиничный номер, где для выхода на внешнюю линию требуется набрать код. Если работа сопряжена с поездками в разные города или страны, можно создать местоположение вызова для каждого кода области, города или страны.

Местоположение вызова также может быть создано для правил набора номера, не обязательно связанных с географическим положением. Например, различные правила набора номера могут быть созданы для различных учетных записей, телефонных карточек или префиксов выхода на междугородную линию.

Сведения о местоположении вызова включают в себя следующие параметры:

  • Имя
  • Страну или регион
  • Код города (области)
  • Правила набора номера
  • Area code rules
  • Сведения о телефонной карточке

Задание имен и использование местоположений вызова

Для местоположения вызова можно задать любое запоминающееся имя. По умолчанию для набора номеров используется местоположение, выбранное в диалоговом окне Телефон и модем. Многие программы телефонии, такие как «Телефон» или «Факс», позволяют выбирать местоположение вызова перед набором номера. При выполнении междугородного звонка программа телефонии использует сведения о наборе номера, заданные для текущего местоположения вызова.

Доступные местоположения вызова отображаются на вкладке Набор номера диалогового окна Телефон и модем, открываемого с панели управления. На этой вкладке можно выбрать местоположение вызова, используемое по умолчанию, или изменить любое существующее местоположение. Сведения о создании нового местоположения вызова см. в разделе Создание нового местоположения. Сведения об изменении существующего местоположения см. в разделе Изменение параметров набора номера для местоположения.

Общие правила местоположения вызова

Общие правила местоположения задают имя местоположения, страну или регион, а также код города. Кроме того, они позволяют выходить с внутренней АТС на внешние линии для выполнения местных и междугородных звонков, отключать режим оповещения (чтобы входящие вызовы не прерывали имеющееся соединение), а также включать тоновый или импульсный набор номера.

Используемые по умолчанию правила набора номера для местных, междугородных и международных звонков определяются выбором страны или региона. Правила набора номера задают префикс выхода на междугородную линию и префикс выхода на международную линию, набираемые перед телефонными номерами других городов или стран.

Правила набора кода города

Правила набора кода города позволяют изменить порядок набора номеров внутри страны или региона, как описано в разделе Задание правил набора кода города. Стандартные правила набора телефонных номеров других городов часто требуют, чтобы программой набирался префикс выхода на междугородную линию, код города, а затем номер телефона. Для вызова номеров в том же городе программой набирается только номер телефона нужного абонента. Стандартные правила показаны в следующей таблице.

Формат и пример | Служба
Префикс выхода на междугородную линию (Код города) Префикс-Номер абонента 1 (425) 555-0101 | Номеров в других городах
Префикс-Номер абонента 555-0101 | Номеров в том же городе

Цифры в каждой из этих категорий могут различаться для разных стран, регионов или местоположений.

Правила набора кода города используются для задания следующих исключений из стандартных правил.

Формат и пример | Служба
(Код города) Префикс-Номер абонента (425) 555-0101 | Номеров в других городах
(Код города) Префикс-Номер абонента (425) 555-0101 | Номеров в том же городе
Префикс выхода на междугородную линию Префикс-Номер абонента 1 555-0101 | Номеров в том же городе
Префикс выхода на междугородную линию (Код города) Префикс-Номер абонента 1 (425) 555-0101 | Номеров в том же городе
Префикс выхода на междугородную линию (Код города) Префикс-Номер абонента 01 (425) 555-0101 | Номера в других городах при использовании префикса выхода на междугородную линию, не являющегося стандартным для страны или области

Если нестандартный префикс выхода на междугородную линию используется для всех кодов городов, гораздо удобнее использовать телефонную карточку, чем создавать правила набора кода для каждого кода города, куда необходимо позвонить. Дополнительные сведения см. в разделе Телефонные карточки.

Задание нескольких правил для кода города

Если код города набирается с различными префиксами, можно задать для этого кода города несколько правил. Правила набора кода города применяются в том порядке, в котором они перечислены в списке. Если для какого-либо префикса применяется два правила, порядок набора номера для этого префикса определяет последнее правило.

Новые создаваемые правила набора кода города добавляются в конец списка. Поэтому для правильного применения нескольких правил следует создавать их в следующем порядке.

  1. Любое стандартное правило для использования со всеми неуказанными префиксами. (В этом случае используется параметр Включить все префиксы в код города). Это правило должно отображаться в начале списка.
  2. Правила набора кода города с конкретными префиксами. (Используется параметр Включить только префиксы из списка).

Большинство префиксов для кода города следуют приведенным далее стандартным образцам набора номера.

Порядок набора | Служба
8 (Код города) Префикс-Номер абонента | Номеров в других городах
Префикс-Номер абонента | Номеров в том же городе

Если большая часть префиксов для кода города не следует стандартным образцам набора номера, создайте одно правило, задающее новый стандартный порядок набора для этого кода города, и другое правило, задающее исключения. Это проще, чем создать одно правило набора кода города с перечислением префиксов для этого кода.

Предположим, большинство номеров для кода города имеет следующий формат:

(Код города) Префикс-Номер абонента,

но три номера имеют формат

1 (Код города) Префикс-Номер абонента

Сначала следует создать правило набора кода города, применяемое для всех префиксов, и установить для него в списке Правила только флажок Набрать код города. Это задаст стандартное правило для кода города. Оно будет применяться для всех префиксов, не указанных во втором правиле списка.

Затем следует создать правило набора для трех префиксов, следующих второму порядку набора номера. Для этого правила в списке Правила нужно установить флажки Набрать (убедитесь, что в смежном поле стоит 8) и Набрать код города. Это задаст правило, которое будет применяться только для трех префиксов и отображаться в списке вторым.

Телефонные карточки

Местоположение вызова может использовать телефонную карточку для задания последовательности набираемых номеров для конкретной телефонной карточки или службы междугородной связи. Кроме того, можно выбрать использование телефонных карточек для указания номер для выхода на междугородную линию или международную линию, не являющегося стандартным для страны или области.

На телефонной карточке записан ее номер, а также личный PIN-код. Она определяет номера доступа и порядок набора номеров для местных, междугородных и международных вызовов. Создав новую телефонную карточку, можно использовать ее для любого местоположения вызова. Сведения о создании и использовании телефонной карточки см. в разделах Создание новой телефонной карточки и Использование телефонной карточки для междугородных вызовов.

При использовании нескольких служб междугородной связи с разными номерами доступа можно создавать телефонные карточки для каждой службы, а также различные местоположения вызова для использования каждой из карточек. Программы телефонии, например «Телефон» и «Факс», обычно позволяют выбирать местоположение вызова перед набором номера. При наборе номера выберите местоположение вызова, которое соответствует используемой службе междугородней связи.

Задание номер для выхода на междугородную линию

Номер для выхода на междугородную линию набирается перед кодом города или страны при выполнении международных звонков или звонков внутри страны. Обычно для набора правильных префиксов выхода на междугородную или международную достаточно выбрать страну для местоположения вызова. Если стандартные префиксы для выбранной страны не обеспечивают доступ к службам междугородной связи, см. раздел Задание номера для выхода на междугородную линию.


Указание серверов телефонии на клиентском компьютере

Рисунок Microsoft Windows

Чтобы указать сервера телефонии на клиентском компьютере

  1. Откройте окно командной строки.
  2. Введите tcmsetup /c сервер1 сервер2 ...

Примечания

  • XOX
  • Для правильной работы телефонии ТAPI необходимо выполнить команду tcmsetup для указания серверов для клиентов TAPI, как описано этой процедуре. Для получения дополнительных сведений о команде tcmsetup щелкните ссылку «См. также».
  • Клиент должен находиться в том же домене, что и сервер, либо в полностью доверенном домене при выполнении команды tcmsetup.
  • Для выполнения команды tcmsetup необходимо войти в систему с учетной записью «Администратор». Войдя в систему в качестве члена группы «Пользователи» или «Опытные пользователи», можно использовать команду runas для выполнения команды tcmsetup в качестве администратора, например:

    runas /user:домен\имя_пользователя "tcmsetup /c имя_сервера"

    Для получения дополнительных сведений о команде runas щелкните ссылку «См. также».

  • В командной строке tcmsetup /c параметры сервер1 сервер2 ... представляют имена одного или нескольких серверов TAPI. Эта команда замещает любой предыдущий список, поэтому следует включить каждый сервер телефонии, который требуется сделать доступным для клиента.
  • Для того ввода изменений вступили в силу может потребоваться перезагрузка службы телефонии. Для получения сведений об остановке служб щелкните ссылку «См. также».
  • Для того чтобы пользователи смогли выполнять исходящие вызовы с помощью телефонных линий на сервере TAPI, администратор сервера TAPI должен назначить пользователей телефонным линиям.

См. также


Определение параметров управления дозвоном Н.323

Чтобы определить параметры управления дозвоном Н.323

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Дополнительно в списке Службы доступа выберите Поставщик службы телефонии H.323 (Microsoft) и затем нажмите кнопку Настроить.
  3. В группе Управление дозвоном Н.323 в поле Таймаут оповещения дозвона введите время в миллисекундах, в течение которого будет подаваться сигнал входящего звонка, затем вызов будет завершен.
  4. В группе Управление дозвоном Н.323 в поле Прослушивающий порт введите номер порта, который прослушивает клиент Н.323 при ожидании входящих звонков, и нажмите кнопку ОК.

Примечания

  • XOX
  • Необходимо иметь разрешения учетной записи «Администратор», чтобы настроить параметры управления дозвоном Н.323.


Указание привратника Н.323

Чтобы указать привратника Н.323

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Дополнительно в списке Службы доступа выберите Поставщик службы телефонии H.323 (Microsoft) и затем нажмите кнопку Настроить.
  3. В группе Использование TAPI 3.1 при наборе номера через привратника, установите флажок Привратник Н.323: и введите имя компьютера или IP-адрес (например, 10.255.255.255) желаемого привратника.
  4. В группе Использование TAPI 3.1 при наборе номера через привратника зарегистрируйтесь в этом привратнике, указав следующие сведения.
    • Для использования телефонного номера установите флажок Вход с моим № телефона: и введите необходимый телефонный номер.
    • Для использования учетной записи установите флажок Вход с моей учетной записью: и введите необходимую учетную запись.

Примечания

  • XOX
  • Привратник Н.323 является центром всех звонков в своей зоне управления. Привратник выполняет задачи: преобразование адресов, управление допуском, контроль пропускной способности и функции управления зонами. Кроме того, привратник может управлять дозвоном, авторизировать звонки, управлять пропускной способностью и выполнять функциями управления звонками.
  • Необходимо иметь разрешения учетной записи «Администратор», чтобы настроить параметры привратника Н.323.
  • При установленном флажке Привратник Н.323, не будут использованы шлюз и настройка прокси-сервера, указанных в диалоговом окне Настройка службы доступа Н.323.
  • Для использования привратника H.323 необходимо зарегистрироваться в этом привратнике, указав номер телефона и (или) имя учетной записи. Регистрация в привратнике позволяет получать вызовы на данном компьютере. Если точно неизвестно, какой номер телефона и какую учетную запись необходимо использовать для регистрации в привратнике Н.323, свяжитесь с администратором телефонии или поставщиком услуг.


Указание шлюза или прокси-сервера H.323

Чтобы указать шлюз или прокси-сервер H.323

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Дополнительно в списке Службы доступа выберите Поставщик службы телефонии H.323 (Microsoft) и затем нажмите кнопку Настроить.
  3. В диалоговом окне Настройка службы доступа Н.323 выполните следующие действия.
    • Чтобы указать шлюз H.323, установите флажок Шлюз H.323:, а затем введите имя компьютера или IP- адрес шлюза.
    • Чтобы указать прокси-сервер H.323, установите флажок Прокси-сервер H.323:, а затем введите имя сервера или IP- адрес прокси-сервера.

Примечания

  • XOX
  • Шлюз H.323 соединяет IP-сеть с коммутируемыми сетями, такими как PSTN (Public Switched Telephone Network). Правильное имя или IP-адрес шлюза можно узнать у системного администратора телефонии.
  • Прокси-сервер действует как защитный барьер между внутренней сетью (интрасетью) и Интернетом, закрывая доступ других пользователей Интернета к секретным сведениям во внутренней сети или на локальном компьютере. Правильное имя или IP-адрес шлюза можно узнать у системного администратора телефонии.


Настройка службы доступа к телефонии

Чтобы настроить службу доступа к телефонии

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Дополнительно в списке Службы доступа выберите службу доступа, которую требуется настроить.
  3. Нажмите кнопку Настроить.

Примечания

  • XOX
  • Перечень настраиваемых параметров зависит от службы доступа. Если кнопка Настроить недоступна, служба доступа не имеет настраиваемых параметров.


Задание правил набора кода города

Чтобы задать правила набора кода города

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Набор номера выберите размещение, которое требуется изменить, и нажмите кнопку Изменить.

    Чтобы создать новое местоположение, нажмите кнопку Создать.

  3. Перейдите на вкладку Код города.
  4. Чтобы добавить новое правило набора кода города, нажмите кнопку Создать.

    Чтобы изменить существующее правило, выделите его и нажмите кнопку Изменить.

  5. В поле Код города введите код города.
  6. При настройке поля Префиксы возможны следующие варианты.
    • Чтобы применить правило ко всем префиксам данного кода города, установите переключатель в положение Включить все префиксы в код города.
    • Чтобы применить правило к определенным префиксам, установите переключатель Включить только префиксы из списка и нажмите кнопку Добавить, введите один или несколько префиксов и затем нажмите кнопку OK.
  7. При настройке группы Правила возможны следующие варианты.
    • Если перед номерами, содержащими данные префиксы, следует набирать дополнительные цифры, установите флажок Набрать и введите цифры, которые следует набирать.
    • Если перед телефонным номером следует набирать код города, установите флажок Набрать код города.

Примечания

  • XOX


Использование телефонных карточек для междугородных вызовов

Чтобы использовать телефонные карточки для междугородных вызовов

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Набор номера выберите размещение, которое требуется изменить, и нажмите кнопку Изменить.

    Чтобы создать новое местоположение, нажмите кнопку Создать.

  3. На вкладке Телефонная карточка выберите телефонную карточку, которую требуется использовать.

Примечания

  • XOX
  • При использовании нескольких телефонных карточек можно создать для каждой из них отдельное местоположение. Программы телефонии, например «Телефон» или «Мастер рассылки факсов», обычно позволяют выбирать местоположение перед набором номера.
  • Если для выхода на междугородную линию используется (номер для выхода на междугородную линию), можно использовать телефонную карточку для задания порядка набора номера. При создании телефонной карточки для междугородной связи создайте уникальное местоположение для ее использования.
  • Для просмотра процедур создания телефонных карточек или местоположений щелкните ссылку «См. также».


Изменение параметров набора номера для местоположения

Чтобы изменить параметры набора номера для местоположения

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Набор номера выберите местоположение, которое требуется изменить, и нажмите кнопку Изменить.
  3. Перейдите на вкладку Общие, Код города или Телефонная карточка для изменения соответствующих параметров местоположения.

Примечания

  • XOX
  • Для получения дополнительных сведений о местоположениях или об изменении конкретных элементов местоположения щелкните ссылку «См. также».


Создание нового местоположения

Чтобы создание новое местоположение

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Набор номера нажмите кнопку Создать.
  3. На вкладке Общие введите в поле Имя местоположения имя нового местоположения.
  4. Укажите характеристики телефонной линии вводом дополнительных сведений на вкладках Общие, Код города и Телефонная карточка.

Примечания

  • XOX
  • Для получения дополнительных сведений о местоположениях или об указании конкретных элементов местоположения щелкните ссылку «См. также».


Указание префиксов выхода на внешнюю линию

Чтобы указать префиксы выхода на внешнюю линию

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Набор номера выберите расположение, которое требуется изменить, и нажмите кнопку Изменить.

    Чтобы создать новое местоположение, нажмите кнопку Создать.

  3. На вкладке Общие в группе Правила введите префиксы выхода на внешнюю линию для местных и междугородных звонков.

Примечания

  • XOX
  • Не выполняйте эту процедуру для указания префиксов выхода на междугородную или международную линии, таких как 8, 1, 0, 00 или 011. В этом окне указываются номера для выхода на городскую или междугородную линии с внутренней АТС организации. При выполнении междугородных или международных звонков правила набора номеров для местоположения вставляют необходимые префиксы автоматически.


Изменение существующей телефонной карточки

Чтобы изменить существующую телефонную карточку

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Набор номера выберите местоположение, которое требуется изменить, и нажмите кнопку Изменить.
  3. На вкладке Телефонная карточка выберите тип карточки, которую требуется изменить, и нажмите кнопку Изменить.
  4. Перейдите на вкладку Общие для изменения имени телефонной карточки, учетного номера или личного PIN-кода.
  5. Перейдите на вкладку Междугородные звонки, Международная связь или Местные звонки для изменения номеров доступа или порядка набора номеров для соответствующего типа звонков.

Примечания

  • XOX
  • Если в поле Шаги набора номера при использовании карточки добавлен пункт Набор номера доступа, Набрать PIN-код или Набор номера учетной записи, а значение в соответствующем поле не задано, программа выведет приглашение ввести недостающее значение по нажатию кнопки OK или Применить.


Задание номера для выхода на междугородную линию

Чтобы задать номер для выхода на междугородную линию

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Набор номера нажмите кнопку Создать.
  3. На вкладке Общие введите Имя местоположения, а затем заполните поля Страна, Код города и задайте нужные параметры в группе Правила.
  4. На вкладке Телефонная карточка нажмите кнопку Создать, и на вкладке Общие в поле Имя карточки введите имя для телефонной карточки, например, название оператора междугородной связи.
  5. На вкладках Междугородные звонки и Международная связь введите в соответствующие поля номера для выхода на междугородную или международную линии.
  6. На вкладках Междугородные звонки и Международная связь в группе Шаги набора номера при использовании карточки нажмите кнопку Номер доступа и кнопки последующих шагов набора номеров для выполнения междугородных и международных звонков.
  7. На вкладке Местные звонки оставьте пустым поле Номер для выхода на локальную линию до тех пор, пока этот номер не понадобится, и затем в поле Шаги для набора номера при использовании карточки введите шаги для набора местных номеров.

    Для того чтобы набирать только местный телефонный номер, нажмите кнопку Вызываемый номер и снимите флажок Набрать код города.

  8. Нажмите кнопку OK, чтобы сохранить новую телефонную карточку.
  9. Убедитесь, что на вкладке Телефонная карточка новая карточка выбрана в поле Типы карточек для использования с текущего местонахождения, и нажмите кнопку OK.
  10. В списке Расположение оставьте выбранным текущее местонахождение, если требуется использовать его по умолчанию для междугородных звонков, и нажмите кнопку OK.

Примечания

  • XOX
  • Данная процедура задает номера для выхода на междугородную или международную линии. Для использования стандартных номеров, принятых в выбранной стране, выполнять ее, как правило, не требуется. Для использования стандартных номеров обычно достаточно выбрать страну местонахождения.
  • По умолчанию используются правила набора номеров местоположения, выбранного на вкладке Набор номера диалогового окна Телефон и модем. Если создано несколько местоположений, некоторые программы телефонии (такие как программа «Телефон») позволяют выбрать местоположение перед набором номера.


Создание новой телефонной карточки

Чтобы создать новую телефонную карточку

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Набор номера выберите размещение, которое требуется изменить, и нажмите кнопку Изменить.

    Чтобы создать новое местоположение, нажмите кнопку Создать.

  3. На вкладке Телефонная карточка нажмите кнопку Создать.
  4. На вкладке Общие введите следующие параметры.
    Значение | Описание
    Имя карточки | Имя, используемое для идентификации карточки
    Учетный номер | Учетный номер. присвоенный телефонной карточке выдавшим ее оператором телефонной связи. Для некоторых телефонных карточек это — домашний или рабочий телефон, связанный с учетной записью
    Личный PIN-код | Любой личный код, необходимый для защиты вашей учетной записи от несанкционированного использования. Часто состоит из четырех цифр и обычно набирается после учетного номера. Некоторые телефонные карточки не используют PIN-код
  5. На вкладках Междугородные звонки, Международная связь и Местные звонки введите номер телефона для доступа к соответствующей службе. Включите все номера, набираемые после выхода на внешнюю линию.
    • На вкладке Междугородные звонки в поле Номер для выхода на междугородную линию указывается номер доступа к междугородной службе оператора телефонной связи, выдавшего карточку.
    • На вкладке Междугородные звонки в поле Номер для выхода на международную линию указывается номер доступа к международной службе оператора телефонной связи, выдавшего карточку.
    • На вкладке Местные звонки в поле Номер для выхода на внешнюю линию указывается номер доступа к местной службе оператора телефонной связи, выдавшего карточку. Для набора номеров без использования телефонной карточки оставьте это поле пустым.
  6. На вкладках Междугородные звонки, Международные звонки и Местные звонки в поле Шаги набора номера при использовании карточки нажмите кнопки, чтобы добавить шаги, необходимые для выполнения вызова.
    Элемент меню | Набираемый номер
    Номер доступа | Номер доступа к линии оператора телефонной связи, выдавшего карточку. Этот номер вводится в верхней части данной вкладки
    Учетный номер | Учетный номер телефонной карточки, введенный на вкладке Общие
    PIN-код | Личный PIN-код, введенный на вкладке Общие. Обычно набирается непосредственно после учетного номера
    Ожидание | Приостанавливает набор номера до появления сигнала в линии, завершения голосового сообщения или окончания заданного промежутка времени
    Вызываемый номер | Код страны, код города и номер телефона
    Введите цифры | Любая последовательность цифр от 0 до 9, а также символов * и #
  7. Чтобы изменить последовательность шагов, выделите нужный шаг и нажмите кнопку Вверх или Вниз.

    Чтобы удалить шаг, нажмите кнопку Удалить.

Примечания

  • XOX
  • Если в поле Шаги набора номера при использовании карточки добавлен пункт Набор номера доступа, Набрать PIN-код или Набор номера учетной записи, а значение в соответствующем поле не задано, программа выведет приглашение ввести недостающее значение по нажатию кнопки OK или Применить.


Добавление службы доступа к телефонии

Чтобы добавить службу доступа к телефонии

  1. Откройте объект Телефон и модем на панели управления.
  2. На вкладке Дополнительно нажмите кнопку Добавить.
  3. В диалоговом окне Установка службы доступа в поле Службы доступа к телефонии щелкните службу доступа и нажмите кнопку Добавить.

    4. При отсутствии необходимой службы доступа в этом списке установите соответствующие файлы драйвера для службы доступа. Дополнительные сведения см. в разделе «Примечания».

Примечания

  • XOX
  • Эта процедура позволяет добавить только службы доступа, уже установленные на локальный жесткий диск в папку Системный_корневой_каталог\system32. Для установки драйверов новой службы доступа используйте программу установки, поставляемую на диске изготовителем.
  • Поставляемая изготовителем программа установки обычно добавляет новую службу доступа в список на вкладке Дополнительно окна Телефон и модем. Если после выполнения программы установки служба доступа не появилась на вкладке Дополнительно, воспользуйтесь для добавления службы доступа данной процедурой. Если служба доступа отсутствует в диалоговом окне Установка службы доступа, обратитесь за дальнейшими инструкциями к документации изготовителя.