Общие сведения о диспетчере задач

В диспетчере задач отображаются сведения о программах и процессах, выполняемых на компьютере. Кроме того, там можно просмотреть наиболее часто используемые показатели быстродействия процессов.

Диспетчер задач служит для отображения ключевых показателей быстродействия компьютера. Для выполняемых программ можно просмотреть их состояние и завершить программы, переставшие отвечать на запросы. Имеется возможность просмотра активности выполняющихся процессов с использованием до 15 параметров, а также графиков и сведений об использовании ЦП и памяти.

Кроме того, если имеется подключение к сети, можно просматривать состояние сети и параметры ее работы.

Если к компьютеру подключились несколько пользователей, можно увидеть их имена, какие задачи они выполняют, а также отправить им сообщение.

Для получения дополнительных сведений выберите одну из ссылок.

Выполняющиеся программы

На вкладке Приложения отображается состояние выполняющихся на компьютере программ.

На этой вкладке имеется возможность завершить или запустить программу, а также перейти в окно программы.

См. также

Выполняющиеся процессы

На вкладке Процессы отображаются сведения о выполняющихся на компьютере процессах.

Например, допускается отображение сведений об использовании ЦП и памяти, ошибках страницы, счетчике дескрипторов и некоторые другие параметры.

См. также

Показатели быстродействия

На вкладке Быстродействие динамически отображаются следующие сведения о быстродействии компьютера.

  • Графики загрузки ЦП и использования памяти.
  • Общее число дескрипторов, потоков и процессов, выполняющихся на компьютере.
  • Общий объем физической памяти, памяти ядра и выделения памяти в килобайтах.

См. также

Просмотр производительности сети

Вкладка Сеть позволяет просматривать графическое представление сведений о производительности сети. Простой качественный график показывает состояние сетей, к которым подключен компьютер. Вкладка «Сеть» отображается только для компьютеров с сетевой платой.

На этой вкладке выводятся сведения о качестве и доступности сетевого подключения, а также о том, имеется ли подключение к одной или нескольким сетям.

См. также

Наблюдение за сеансами

На вкладке Пользователи отображаются пользователи, имеющие доступ к компьютеру, а также состояние сеанса и имена пользователей. В столбце Имя клиента отображается, если возможно, имя компьютера-клиента, который использует этот сеанс. В столбце Сеанс отображается имя, которое можно использовать для выполнения таких задач, как отправка сообщения другому пользователю или подключение к его сеансу.

Вкладка Пользователи доступна, только если на компьютере включено быстрое переключение пользователей и если он входит в рабочую группу или является изолированным. Вкладка Пользователи недоступна для компьютеров, которые являются членами сетевого домена.

См. также


Изменение параметров отображения в диспетчере задач

Рисунок Microsoft Windows

Чтобы изменить параметры отображения в диспетчере задач

  1. Выберите вкладку того параметра отображения, который требуется изменить. Щелкните:
    • вкладку Приложения, чтобы просмотреть сведения в режиме крупных или мелких значков, а также в режиме таблицы.
    • вкладку Процессы, чтобы выбрать столбцы, выводящиеся на экран.
    • вкладку Быстродействие, чтобы изменить график загрузки ЦП и вывести время ядра.
    • вкладку Сеть чтобы просмотреть сведения о сетевых подключениях.
  2. Выберите требуемую команду в меню Вид.

Примечание

  • Чтобы время ядра отображалось на графиках Загрузка ЦП и Хронология загрузки ЦП красными линиями, перейдите на вкладку Быстродействие. В меню Вид выберите команду Вывод времени ядра. Эти линии показывают объем ресурсов ЦП, потребляемых операциями ядра.


Обновление данных диспетчера задач

Чтобы обновить данные диспетчера задач

  • В меню Вид выберите команду Обновить.

Примечания

  • Для изменения частоты автоматического обновления данных в меню Вид выберите нужный параметр из подменю Скорость обновления.
  • Чтобы временно заморозить данные, отображаемые в диспетчере задач, в меню Вид выберите параметр Приостановить из подменю Скорость обновления.
  • Данные автоматически обновляются каждые две секунды по умолчанию. Для получения дополнительных сведений о частоте обновления данных щелкните ссылку См. также.


Запуск новой программы

Чтобы запустить новую программу

  1. На вкладке Приложения нажмите кнопку Новая задача.
  2. В поле Открыть введите или выберите имя программы, которую нужно добавить, и нажмите кнопку ОК.

Примечания

  • Команда Новая задача идентична команде Выполнить в меню Пуск.
  • Если имя добавляемой программы неизвестно, ее можно найти, нажав кнопку Обзор.


Переход в окно другой программы

Чтобы перейти в окно другой программы

  • На вкладке Приложения выберите программу, в окно которой требуется перейти, и нажмите кнопку Переключиться.


Изменение приоритета выполняемой программы

Чтобы изменить приоритет выполняемой программы

  • На вкладке Процессы щелкните правой кнопкой мыши программу, приоритет которой требуется изменить, укажите на пункт Приоритет, а затем выберите требуемый приоритет.

Примечания

  • Чтобы просмотреть приоритеты запущенных программ, на вкладке Процессы в меню Вид выберите команду Выбрать столбцы. В диалоговом окне Выбор столбцов установите флажок Базовый приоритет и нажмите кнопку ОК.
  • Изменение приоритета может повлиять на скорость выполнения программы (увеличить или уменьшить, в зависимости от того, повышается или понижается приоритет), но также может снизить производительность других процессов.


Завершение программы с помощью диспетчера задач

Чтобы завершить программу с помощью диспетчера задач

  • На вкладке Приложения выберите программу, которую требуется завершить, и нажмите кнопку Снять задачу.

Примечание

  • Все несохраненные данные или изменения в программе будут утеряны.


Заголовки столбцов счетчика процессов

На вкладке диспетчера задач Процессы имеется возможность отслеживать выполнение процессов при помощи следующих счетчиков, отображаемых в заголовках столбцов. Чтобы отобразить процесс как заголовок столбца, в меню Вид выберите команду Выбрать столбцы. Установите флажки, которые соответствуют процессам, которые требуется отобразить как заголовки столбцов.

  • Базовый приоритет
  • Время ЦП
  • Загрузка ЦП
  • Объекты GDI
  • Счетчик дескрипторов
  • Имя образа
  • Прочий ввод-вывод
  • Прочих байт при вводе-выводе
  • Число чтений
  • Прочитано байт
  • Число записей
  • Записано байт
  • Память — использование
  • Память — изменение
  • Невыгружаемый пул
  • Ошибок страницы
  • Ошибок страницы — изменение
  • Выгружаемый пул
  • Память — максимум
  • Идентиф. процесса (PID)
  • Код сеанса
  • Счетчик потоков
  • Пользователь
  • Объекты USER
  • Объем виртуальной памяти


Указание заголовков столбцов счетчика процессов

Чтобы указать заголовки столбцов счетчика процессов

  1. На вкладке Процессы в меню Вид выберите команду Выбрать столбцы.
  2. Установите флажки, которые соответствуют счетчикам процессов, которые требуется отобразить как заголовки столбцов, и нажмите кнопку OK.

Примечание

  • Для получения дополнительных сведений об счетчиках процессов щелкните ссылку См. также.


Сортировка списка процессов

Чтобы отсортировать список процессов

  • На вкладке Процессы щелкните заголовок столбца, по которому требуется выполнить сортировку.

Примечание

  • Чтобы выполнить сортировку в обратном порядке, щелкните заголовок столбца еще раз.


Завершение процесса с помощью диспетчера задач

Чтобы завершить процесс с помощью диспетчера задач

  • На вкладке Процессы выберите процесс, который требуется завершить, и нажмите кнопку Завершить процесс.

Внимание!

  • Будьте осторожны при завершении процесса. При завершении работы приложения несохраненные данные будут утеряны. При завершении работы системной службы может нарушиться функционирование некоторых компонентов системы.

Примечание

  • Чтобы завершить процесс и все процессы, которые были прямо или косвенно им созданы, на вкладке Процесс щелкните правой кнопкой мыши процесс, который требуется завершить, а затем выберите команду Завершить дерево процессов.

    Например, при завершении дерева процессов программы электронной почты, например Microsoft Outlook, будут также завершены связанные с ней процессы, такие как mapisp32.exe (очередь MAPI).


Назначение процессу обработчика

Чтобы назначить процессу обработчика

  • На вкладке Процессы щелкните правой кнопкой процесс, которому нужно назначить обработчика, выберите команду Задать соответствие, а затем выберите один или несколько обработчиков.

Примечания

  • Команда Задать соответствие доступна только в многопроцессорных компьютерах.
  • Применение команды Задать соответствие ограничивает выполнение программы или процесса выбранным обработчиком и может снизить общее быстродействие системы.


Общие сведения о показателях быстродействия

На вкладке «Быстродействие» динамически отображаются следующие сведения о производительности компьютера. Для получения дополнительных сведений выберите одну из ссылок.

Показатель «Загрузка ЦП»

График, показывающий процентную долю времени, в течение которого процессор работает. Этот счетчик является главным показателем активности процессора. Просмотрите график, чтобы узнать, сколько процессорного времени используется. Если компьютер работает медленно, диаграмма отобразит высокий процент.

Показатель «Хронология загрузки ЦП»

График, показывающий, насколько занят был ЦП в течение работы. Частота отображения на графике зависит от выбранного значения для подменю Скорость обновления в меню Вид. Для скорости обновления существуют следующие значения: Высокая — дважды в секунду; Обычная — раз в две секунды; Низкая — раз в четыре секунды; Приостановить — экран не обновляется автоматически.

Использование файла подкачки

Размер файла подкачки системы. Если его объем, используемый компьютером при работе, почти достигает максимума, можно увеличить размер файла подкачки.

Хронология использования файла подкачки

График, отображающий долю использования файла подкачки. Частота отображения на графике зависит от значения, выбранного в меню Вид в подменю Скорость обновления.

Всего

Общее число дескрипторов, потоков и процессов, выполняющихся на компьютере.

Выделение памяти (КБ)

Память, выделенная для программ и системы. Из-за наличия памяти, скопированной в файл подкачки и называемой виртуальной памятью значение выделенной памяти в списке Пик может превышать объем физической памяти. Для области Всего отображается то же самое значение, что и на графике Хронология использования файла подкачки.

Физическая память (КБ)

Физическая память, также называемая ОЗУ, установленная на компьютере. Параметр Доступно показывает количество свободной памяти, доступной для использования. Параметр Системный кэш показывает текущий объем памяти, занятой под отображение страниц открытых файлов.

Память ядра (КБ)

Память, используемая ядром операционной системы и драйверами устройств. Параметр Выгружаемая показывает, сколько памяти может быть скопировано в файл подкачки, освобождая тем самым физическую память. После этого физическая память станет доступна для использования операционной системой. Параметр Невыгружаемая показывает объем памяти, который останется в физической памяти и не будет скопирован в файл подкачки.


Просмотр быстродействия компьютера

Чтобы просмотреть быстродействие компьютера

  • Перейдите на вкладку Быстродействие.

Примечания

  • Вкладка «Быстродействие» отображает информацию о быстродействии компьютера, например, о ЦП и различных видах использования памяти.
  • Для получения дополнительных сведений о вкладке «Быстродействие» щелкните ссылку См. также.


Общие сведения о сетевых полях

Общие сведения о работе с сетью

Вкладка Сеть позволяет определять объемы передачи данных в сети для подключений на локальном компьютере. Это очень полезное и быстрое средство для определения доли задействованной пропускной способности сети. Когда используется несколько сетевых подключений, можно сравнивать трафики на каждом подключении.

Если на компьютере имеется несколько сетевых карт, диаграмма отображает составной индекс для всех сетей, показывая общий трафик.

Чтобы показать на графике сетевой трафик для какого-нибудь интерфейса, автоматически увеличивается масштаб просмотра и отображается трафик относительно доступной пропускной способности. В случае низкого уровня трафика полная высота графика может представлять только 5% от доступной пропускной способности для данного подключения. Когда трафик начинает превышать отображаемый уровень, масштаб просмотра уменьшается соответственно текущему уровню трафика (например, для отображения 10% от общей доступной пропускной способности). Чем больше проценты, отображаемые на графике, тем меньше увеличение масштаба отображения трафика по отношению к доступной пропускной способности. Масштаб указывается на графике. Чтобы отключить масштаб, в меню Параметры нажмите кнопку Автомасштаб, чтобы переключить значение.

Кроме того, имеется возможность менять заголовки столбцов, которые отображаются под графиком. Эти заголовки описаны в следующей таблице.

Имя столбца | По умолчанию включен | Описание
Имя сетевого адаптера | Да | Имя сетевого адаптера в папке «Сетевые подключения».
Описание адаптера |  | Описание адаптера, обычно то же, что и имя устройства в папке сетевых подключений.
Использование сети |  | Показатели использование сети (в процентах) основываются на начальной скорости подключения для данного интерфейса.
Скорость линии |  | Скорость подключения интерфейса берется из начальной скорости подключения.
Пропускная способность отправки |  | Процентная доля пропускной способности подключения, занятая потоком отправленных с компьютера данных за наблюдаемый промежуток времени.
Пропускная способность получения |  | Процентная доля пропускной способности подключения, занятая потоком полученных компьютером данных за наблюдаемый промежуток времени.
Пропускная способность всего |  | Процентная доля пропускной способности подключения, занятая потоком отправленных и полученных данных за наблюдаемый промежуток времени.
Отправлено байт |  | Общее число байт, отправленное за время подключения. Кумулятивный показатель, может быть сброшен.
Получено байт |  | Общее число байт, полученное за время подключения. Кумулятивный показатель, может быть сброшен.
Всего байт |  | Общее число байт, отправленное и полученное за время подключения. Кумулятивный показатель, может быть сброшен.
Отправлено байт в интервале |  | Общее число байт, отправленное за наблюдаемый промежуток времени.
Получено байт в интервале |  | Общее число байт, полученное за наблюдаемый промежуток времени.
Всего байт в интервале |  | Общее число байт, полученное и отправленное за наблюдаемый промежуток времени.
Отправлено одноадресных пакетов |  | Общее число байт, запрашиваемое для передачи в адреса одноадресной рассылки протоколами высокого уровня. Значение включает пакеты, которые не были отправлены.
Получено одноадресных пакетов |  | Общее число байт, полученное из адресов одноадресной рассылки протоколами высокого уровня.
Всего одноадресных пакетов |  | Общее число одноадресных пакетов, отправленных и полученных за время подключения.
Отправлено одноадресных пакетов в интервале |  | Общее число байт, запрашиваемое для передачи в подсеть адресов одноадресной рассылки протоколами высокого уровня за наблюдаемый промежуток времени.
Получено одноадресных пакетов в интервале |  | Общее число байт из подсети адресов одноадресной рассылки, доставленное протоколами высокого уровня за наблюдаемый промежуток времени.
Всего одноадресных пакетов в интервале |  | Общее число одноадресных пакетов, полученных и отправленных за наблюдаемый промежуток времени.
Отправлено неодноадресных пакетов |  | Общее число байт, запрашиваемое для передачи в подсеть адресов неодноадресной рассылки протоколами высокого уровня за время подключения.
Получено неодноадресных пакетов |  | Общее число байт из подсети адресов неодноадресной рассылки, доставленное протоколами высокого уровня за время подключения.
Всего неодноадресных пакетов |  | Общее число неодноадресных пакетов, отправленных и полученных за время подключения.
Отправлено неодноадресных пакетов в интервале |  | Общее число байт, запрашиваемое для передачи в подсеть адресов неодноадресной рассылки протоколами высокого уровня за наблюдаемый промежуток времени.
Получено неодноадресных пакетов в интервале |  | Общее число байт из подсети адресов неодноадресной рассылки, доставленное протоколами высокого уровня за наблюдаемый промежуток времени.
Всего неодноадресных пакетов в интервале |  | Общее число неодноадресных пакетов, полученных и отправленных за наблюдаемый промежуток времени.


Просмотр сетевых подключений

Чтобы просмотреть сетевые подключения

  • Выберите вкладку Сеть.

Примечания

  • Вкладка Сеть отображается только для компьютеров с сетевой платой.
  • Вкладка Сеть позволяет определять объемы передачи данных в сети для подключений на локальном компьютере. XOX


Общие сведения о полях с информацией о пользователях

Все поля вкладки Пользователи описаны ниже. Для получения дополнительных сведений выберите одну из ссылок.

Пользователь

Отображает пользователей, подключенных к компьютеру.

Код

Отображает числовое значение кода ID, которое определяет сеанс на компьютере.

Состояние

Отображает текущее состояние сеанса. Возможные состояния сеансов в диспетчере задач — это Активно и Отключено.

Имя клиента

Задает имя компьютера-клиента, который использует этот сеанс, если возможно.

Сеанс

Отображает имена сеансов на данном компьютере.


Просмотр действий пользователя

Чтобы просмотреть действия пользователя

  • Выберите вкладку Пользователи.

Примечания

  • Вкладка «Пользователи» отображается, когда включено средство быстрого переключения пользователей. Для получения дополнительных сведений о средстве быстрого переключения пользователей щелкните ссылку См. также.
  • Быстрое переключение пользователей доступно, только если компьютер входит в рабочую группу или является изолированным. Быстрое переключение пользователей являются недоступными для компьютеров, которые являются членами сетевого домена.


Отправка сообщения пользователю

Чтобы отправить сообщение пользователю

  1. На вкладке Пользователи щелкните правой кнопкой пользователя, которому требуется отправить сообщение, и нажмите кнопку Отправить сообщение.

  2. В поле Заголовок сообщения введите заголовок сообщения.
  3. В поле Сообщение введите сообщение, которое будет отправлено пользователю. Чтобы начать новый раздел, нажмите клавиши CTRL+ENTER.
  4. Чтобы отправить сообщение, нажмите кнопку OK.

Примечания

  • Вкладка Пользователи отображается, когда включено средство быстрого переключения пользователей. Для получения дополнительных сведений о средстве быстрого переключения пользователей щелкните ссылку См. также.
  • Возможность отправки сообщения используется для предупреждения пользователя об отключении его сеанса, для сообщения о состоянии сервера и для отправки других сведений о системе.
  • Сообщения можно отправлять только тем пользователям, сеансы которых находятся в состоянии «Активно» или «Подключено», включая сеанс консоли.