Дата компиляции

 Дата компиляции 01.09.2001


Проверка существования записи ресурса адреса (А) в DNS

Рисунок Microsoft Windows

Чтобы проверить существование А записи ресурса в DNS

  1. Откройте окно Командная строка.
  2. Введите:

    3. nslookup IP-адрес корневого сервера

  3. Введите:

    4. nslookup

  4. Введите в командную строку следующую команду:

    set q=A

  5. Введите в командную строку следующую команду:

    Имя_домена_ActiveDirectory

  6. Найдите в выведенных на экран записей ресурса полное доменное имя контроллера домена.

    7. Если записей нет, выполните одно из следующих действий.

    • Если полномочная зона для имени DNS контроллера домена настроена на динамическое обновление, используйте команду ipconfig/registerdns для обновления регистрации DNS. Процедуру необходимо выполнить из командной строки контроллера домена, у которого не зарегистрированы записи ресурса адреса (А).
    • Если полномочная зона для имени DNS контроллера домена не разрешает динамическое обновление, на сервере DNS используйте консоль DNS в консолиММС для администрирования сервера DNS, добавления записей ресурса адреса и включения динамического обновления.

Примечания

  • XOX
  • Для получения дополнительных сведений о команде Nslookup щелкните ссылку См. также.

См. также


Устранение неполадок при присоединении к домену

Ошибка. Компьютер не присоединяется к домену.

Причина. Компьютер не может обнаружить контроллер домена для указанного домена Active Directory.

Решение. Проверьте записи ресурса DNS, которые необходимо присоединить к домену Active Directory.

См. также Проверка записей ресурсов DNS, которые необходимо присоединить к Active Directory, Требоваения DNS для присоединения к домену Active Directory.


Разрешение вопросов по сетевой идентификации

Ошибка. Компьютер не может найти контроллер домена для домена Active Directory, на котором выведено сообщение об ошибке, т. к. DNS-сервера, используемые этим компьютером для разрешения имени не отвечают. В результате компьютер нельзя присоединить к домену Active Directory до тех пор, пока существует данная проблема.

Причина. DNS-сервера не отвечают, потому что IP-адреса предпочитаемых или альтернативных DNS-серверов для данного компьютера неправильны, или же существуют неполадки сетевых подключений, или IP-адреса верны, а DNS-cервера не работают.

Решение. Свяжитесь с администратором сети и проверьте, что IP-адреса DNS-серверов, которые использует компьютер, верны.

Причина. DNS-сервера не отвечают из-за неполадки сетевых подключений.

Решение. Исключите возможность неполадок основного сетевого подключения, используя команду ping.

См. также Проверка конфигурации TCP/IP с помощью команды ping.

Причина.DNS-сервера не выполняются.

Решение. Чтобы определить, выполняются ли DNS-cервера, используйте консоль DNS в консоли управления ММС для просмотра локальных и удаленных DNS серверов.

См. также DNS console Help in MMC..

Причина. При отсутствии неполадок сетевых подключений и выполнении серверов DNS, значит, компьютер может использовать DHCP для получения IР-адресов DNS-cерверов и DHCP-сервер дает неверные IP-адреса.

Решение. Определите, использует ли компьютер DHCP для получения IP-адресов DNS-серверов, вводом в командную строку ipconfig/all. Затем, если параметру DHCP включен соответствует значение Да, компьютер использует DHCP для получения адресов серверов DNS. Свяжитесь с сетевым администратором, чтобы проверить выполнение DHCP-сервера и правильности выданных им IP-адресов DNS-сервера.

См. также. Требования DNS для присоединения к домену Active Directory.


Разрешение вопросов по сетевой идентификации

Ошибка. Компьютер не может найти контроллер домена для домена Active Directory, на котором выведено сообщение об ошибке, т. к. DNS-сервера, используемые этим компьютером для разрешения имени не находят запись ресурса служб (SRV).

Причина. запись ресурса SRV для DNS не зарегистрирована в DNS.

Решение. Проверьте существование записи ресурса SRV для запрашиваемого домена и существование службы типов. Используйте средство командной строки «Dcdiag», которое необходимо запустить на контроллере указанного домена Active Directory. Чтобы загрузить средство «Dcdiag», см. ссылку Download Center на веб-узле корпорации Майкрософт(перейдите по адресу http://www.microsoft.com/ и выполните поиск строки «download center»).

Причина. Одна или несколько зон, указанных в списке сообщений об ошибках, не включает делегирование для дочерних зон.

Решение. Проверьте делегирование зоны DNS, используя средство командной строки Nslooup.

См. также. Требования DNS для присоединения к домену Active Directory.


Разрешение вопросов по сетевой идентификации

Ошибка. Компьютер не может найти записи ресурса службы (SRV) для DNS,необходимые для обнаружение контроллера домена Dctive Directory, на котором было выведено сообщение об ошибке, т. к. DNS-сервера, используемые компьютером для разрешения имени, не находят записи ресурса SRV.

Причина. У DNS-серверов, которые использует компьютер для разрешения имени, могут иметь неверные корневые ссылки.

Решение. Обновите корневые ссылки для DNS-серверов.

См. также DNS console Help in Microsoft Management Console (MMC)..

Причина. Некоторые делегировани, указанные в зонах DNS, неверны.

Решение. Проверьте делегирования зоны DNS, используя средство командной строки Nslooup.

См. также. Требования DNS для присоединения к домену Active Directory.


Разрешение вопросов по сетевой идентификации

Ошибка. Компьютер удачно разрешил записи ресурса служб (SRV) для DNS, необходимых для обнаружения контроллера домена, но не нашел контроллер домена Active Directory, на котором выведено сообщение об ошибке.

Причина. Необходимые записи ресурса адреса (А), указывающие имя контроллера для IP-адресов, не существуют в DNS.

Решение. Проверьте, что требуемые записи ресурса адреса не существуют в DNS, используя средство командной строки Nslookup.

См. также Проверка существования записи ресурса адреса (А) в DNS.

Причина. Контроллер домена, объявленный в DNS, может быть не подключен к сети или подключен, но не работает.

Решение. Проверьте подключение и работу контроллера домена.

См. также Проверка конфигурации TCP/IP с помощью команды ping, Требования DNS для присоединения к домену Active Directory.


Настройка предпочитаемого DNS-сервера

Чтобы настроить предпочитаемый DNS-сервер

  1. Откройте объект Сетевые подключения.
  2. Щелкните правой кнопкой мыши значок Подключение по локальной сети и выберите команду Свойства.
  3. Выберите Протокол Интернета (TCP/IP) и нажмите кнопку Свойства
  4. Выполните одно из следующих действий.
    • Для использования DHCP для получения предпочитаемых DNS-серверов установите переключатель в положение Получить адрес сервера DNS автоматически.

      • Эта возможность доступна, только если установлен переключатель Получить IP-адрес автоматически.

    • Для использования статических IP-адресов предпочитаемых DNS-серверов установите переключатель в положение Получить адрес сервера DNS автоматически.

      • В поле Предпочитаемый DNS-сервер укажите IP-адрес сервера DNS для этого компьютера.

Примечания

  • XOX
  • Обычно, предпочитаемый DNS-сервер — это существующий DNS-сервер того же сайта, что и настраиваемый компьютер. Если на компьютере, который нужно настроить, выполняется DNS-сервер и нужно послать запросы к этому локальному DNS-серверу, укажите собственный IP-адрес компьютера, как его предпочитаемый DNS-сервер. Дополнительно, можно указать IP-адрес альтернативного DNS-сервера, который компьютер будет использовать, если предпочитаемый сервер DNS не отвечает.
  • Если компьютер, для которого настраивается предпочитаемый сервер DNS, использует локальный сервер DNS, как предпочитаемый, настойчиво рекомендуется использовать статический IP-адрес. Для выполнения этой процедуры установите переключатель в положение Используте следующий IP-адрес и укажите статический IP-адрес, маску подсети и IP-адрес основного шлюза.

См. также


Проверка записей ресурсов DNS, которые необходимо присоединить к домену Active Directory с помощью nslookup

Чтобы проверить записи ресурсов DNS, которые необходимо присоединить к домену Active Directory с помощью nslookup

  1. Откройте окно Командная строка.
  2. Введите:

    nslookup

  3. Введите в командную строку следующую команду:

    4. set q=ТипЗаписиРесурса

  4. Введите в командную строку следующую команду:

    5. _ldap._tcp.dc._msdcs.ИмяДоменаActiveDirectory

  5. Просмотрите выходные результаты предыдущего запроса SRV и определите, требуются ли дальнейшие действия, в зависимости от того, успешно или неудачно выполнен запрос:
    • Если запрос выполнен успешно, просмотрите зарегистрированные записи ресурсов SRV, возвращенные в запросе, чтобы определить, все ли контроллеры домена Active Directory включены и зарегистрированы с использованием действительных IP-адресов.
    • Если в запросе получен отказ, продолжайте устранение неполадок динамического обновления или DNS-серверов, чтобы выяснить причину отказа.
Значение | Описание
nslookup | Название команды.
set q= | Команда для отправки запроса на сервер.
ТипЗаписиРесурса | Тип записи ресурса для применения в качестве фильтра в последующих операциях поиска. Например, в данном случае, поскольку требуется ограничить последующие запросы возвращением записей расположения службы (SRV), использующих указанное имя, введите: set q=srv
_ldap._tcp.dc._msdcs.ИмяДоменаActiveDirectory | Имя DNS, используемое для домена Active Directory и соответствующих контроллеров домена. Например, если имя DNS домена Active Directory имеет вид example.microsoft.com, введите: _ldap._tcp.dc._msdcs.example.microsoft.com.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    nslookup /help

  • В некоторых случаях при выполнении этой процедуры можно увидеть сообщения о таймаутах. Это может иметь место в случаях, когда зоны обратного просмотра не настроены на обслуживание DNS-серверами домена DNS, совпадающего с доменом службы каталогов Active Directory.
  • Ниже приводится пример вывода результатов в окне сеанса команды Nslookup, используемой для проверки записей ресурсов расположения службы (SRV), зарегистрированных контроллерами домена. В этом примере два контроллера домена, dc1 и dc2, зарегистрированы для домена «example.microsoft.com».

C:\nslookup
Default Server:  dc1.example.microsoft.com
Address:  10.0.0.14
 set type=srv
 _ldap._tcp.dc._msdcs.example.microsoft.com
Server:  dc1.example.microsoft.com
Address:  10.0.0.14
_ldap._tcp.dc._msdcs.example.microsoft.com   SRV service location:
          priority       = 0
          weight         = 0
          port           = 389
          svr hostname   = dc1.example.microsoft.com
_ldap._tcp.dc._msdcs.example.microsoft.com   SRV service location:
          priority       = 0
          weight         = 0
          port           = 389
          svr hostname   = dc2.example.microsoft.com
dc1.example.microsoft.com     internet address = 10.0.0.14
dc2.example.microsoft.com     internet address = 10.0.0.15
  • Команда Nslookup является стандартным средством и предоставляется в большинстве реализаций службы DNS. Она позволяет проверять серверы DNS и получать в командной строке подробные ответы. Эта информация полезна при устранении неполадок сопоставления имен, при проверке правильности добавления или обновления записей ресурсов в зоне, а также при отладке серверов.
  • Проверьте, что записи ресурсов, используемые для регистрации служб и важных узлов, таких как контроллеры домена, правильно добавлены в зоны.

    В некоторых случаях может потребоваться добавление вручную или проверка регистрации записей ресурсов расположения служб (SRV), используемых для поддержки контроллеров доменов.

    Чтобы добавить записи ресурсов SRV, созданные для контроллера домена, откройте и просмотрите файл Netlogon.dns, создаваемый мастером установки Active Directory, когда компьютер сервера повышается до контроллера домена. Местоположение файла:

    системный_корневой_каталог\System32\Config\Netlogon.dns

  • Служба сетевого входа в систему на каждом контроллере домена регистрирует ряд различных записей ресурсов DNS на DNS-серверах. Дополнительные сведения об этих записях о том, как Net Logon обновляет DNS, см. на странице Windows DNS на веб-узле Microsoft(переход на http://www.microsoft.com/ и поиск "Windows DNS").

См. также


Устранение неполадок при присоединенении к домену Active Directory и переименовании компьютера.

Компьютер не может быть присоединен к домену Active Directory или должен быть переименован из-за одной из причин, указанных в сообщении об ошибке. Для некоторых причин необходимо связаться к администратором сети и исправить настройку компьютера. Для разрешения ошибок, которые не требуют участия администратора сети, настройте компьютер на обновление первичного суффикса DNS при смене членства в домене, или измените первичный суффикс DNS в соответствии с именем DNS домена Active Directory или установите любой другой предложенный первичный суффикс.

См. также Чтобы изменить DNS-суффикс компьютера.

Примечание

  • Если использование первичного DNS-суффикса компьютера не разрешено в домене Active Directory, сетевой администратор может разрешить использовать различные DNS-суффиксы, настроив атрибут «MS-DS-allowedDnsSuffixes» в DNS-объекте домена Active Directory, где компьютер является членом.


Требования DNS для присоединения к домену Active Directory

Active Directory использует DNS для обнаружения контроллеров домена, включающих компьютеры, присоединенные к сети для обновления контроллера домена, и запуска процесса сетевой проверки подлинности.

Компьютеры, присоедниненные к домену Active Directory должны удовлетворять следоющим трем требованиям DNS:

  • компьютер должен быть настроен с указанием IP-адреса предпочитаемого сервера DNS;
  • запись ресурса служб (SRV) _ldap._tcp.dc._msdcs.Имя_домена_DNS cуществует в DNS;
  • запись ресурса адреса (А) для имени DNS контроллера домена, указанного в поле данных записи ресурса SRV _ldap._tcp.dc._msdcs.Имя_домена_DNS существует в DNS.

Настройка предпочитаемого DNS-сервера

Для присоединения компьютера к домену можно указать статитческий IP-адрес предпочитаемого DNS-сервера вручную или получить этот адрес, используя протокол DHCP.

Настройка требуемых записей ресурсов DNS

Компьютерам, подключаемым к домену Active Directory, нужны следующие записи ресурсов в DNS для обнаружения контроллера домена Active Directory:

  • запись ресурса SRV _ldap._tcp.dc._msdcs.Имя_домена_DNS, которая определяет имена контроллеров домена Active Directory;

    Имя_домена_DNS — имя DNS для домена Active Directory, к которому нужно присоединить компьютер;

  • соответствующая запись ресурса адреса (А), определяющая IP-адреса для контроллеров домена, указанных в списке записи ресурса SRV _ldap._tcp.dc._msdcs.Имя_домена_DNS.

Для получения дополнительных сведений см. раздел Проверка записей ресурсов DNS, которые необходимо присоединить к домену Active Directory.


Документы RFC, посвященные TCP/IP

Стандарты TCP/IP публикуются в документах, называемых рабочими предложениями (RFC — Requests for Comments). Документы RFC представляют собой эволюционирующий набор отчетов, проектов протоколов и стандартов протоколов, описывающих внутреннее устройство TCP/IP и Интернета.

Хотя стандарты TCP/IP всегда публикуются в виде документов RFC, не все документы RFC содержат описания стандартов. RFC разрабатываются отдельными авторами, которые по своему желанию создают проекты новых протоколов и спецификаций и отправляют их группе IETF (Internet Engineering Task Force) и другим рабочим группам. Эти проекты сначала рассматриваются техническим экспертом, рабочей группой или редактором RFC, после чего им присваивается определенный статус.

Если проект проходит эту начальную стадию, он передается более крупному сообществу Интернета для дальнейших доработок и внесения замечаний, и ему присваивается номер RFC. Этот номер RFC не изменяется.

Если в дальнейшем в предложенную спецификацию вносятся изменения, обновленный проект издается под новым номером RFC (этот номер всегда больше номера исходного документа RFC).

В процессе стандартизации документ RFC может иметь один из шести статусов, описанных в следующей таблице.

Статус | Описание
Стандартный протокол (Standard protocol) | Официальный стандарт протокола Интернета
Проект стандартного протокола (Draft standard protocol) | Активно исследуется и пересматривается для последующего придания ему статуса стандартного протокола
Предложение стандартного протокола (Proposed standard protocol) | Протокол, который в будущем может стать стандартным
Экспериментальный протокол (Experimental protocol) | Протокол, разработанный для экспериментальных целей. Экспериментальный протокол не предназначен для работы в реальных условиях
Информационный протокол (Informational protocol) | Протокол, разработанный другой стандартизирующей организацией, включенный для удобства сообщества Интернета
Исторический протокол (Historic protocol) | Протокол, который был вытеснен или заменен другими протоколами

Документы RFC, которым соответствует реализация протокола TCP/IP в XOX

В следующей таблице показаны документы RFC, которым соответствует протокол TCP/IP, реализованный в XOX.

Номер RFC | Заголовок
768 | User Datagram Protocol (UDP)
783 | Trivial File Transfer Protocol (TFTP)
791 | Internet Protocol (IP)
792 | Internet Control Message Protocol (ICMP)
793 | Transmission Control Protocol (TCP)
816 | Fault Isolation and Recovery
826 | Address Resolution Protocol (ARP)
854 | Telnet Protocol (TELNET)
862 | Echo Protocol (ECHO)
863 | Discard Protocol (DISCARD)
864 | Character Generator Protocol (CHARGEN)
865 | Quote of the Day Protocol (QUOTE)
867 | Daytime Protocol (DAYTIME)
894 | IP over Ethernet
919 | Broadcasting Internet Datagrams
922 | Broadcasting Internet Datagrams in the Presence of Subnets
950 | Internet Standard Subnetting Procedure
959 | File Transfer Protocol (FTP)
1001 | Protocol Standard for a NetBIOS Service on a TCP/UDP Transport: Concepts and Methods
1002 | Protocol Standard for a NetBIOS Service on a TCP/UDP Transport: Detailed Specifications
1009 | Requirements for Internet Gateways
1034 | Domain Names – Concepts and Facilities
1035 | Domain Names – Implementation and Specification
1042 | IP over Token Ring
1055 | A Nonstandard for Transmission of IP Datagrams Over Serial Lines: SLIP
1065 | Structure and Identification of Management Information for TCP/IP-based Internets
1112 | Internet Group Management Protocol (IGMP)
1122 | Requirements for Internet Hosts – Communication Layers
1123 | Requirements for Internet Hosts - Application and Support
1144 | Compressing TCP/IP Headers for Low-Speed Serial Links
1157 | Simple Network Management Protocol (SNMP)
1179 | Line Printer Daemon Protocol
1188 | IP over FDDI
1191 | Path MTU Discovery
1201 | IP over ARCNET
1256 | ICMP Router Discovery Messages
1323 | TCP Extensions for High Performance
1332 | PPP Internet Protocol Control Protocol (IPCP)
1518 | An Architecture for IP Address Allocation with CIDR
1519 | Classless Inter-Domain Routing (CIDR): An Address Assignment and Aggregation Strategy
1534 | Interoperation Between DHCP and BOOTP
1542 | Clarifications and Extensions for the Bootstrap Protocol
1552 | PPP Internetwork Packet Exchange Control Protocol (IPXCP)
1661 | Point-to-Point Protocol (PPP)
1662 | PPP in HDLC-like Framing
1748 | IEEE 802.5 MIB using SMIv2
1749 | IEEE 802.5 Station Source Routing MIB using SMIv2
1812 | Requirements for IP Version 4 Routers
1828 | IP Authentication using Keyed MD5
1829 | ESP DES-CBC Transform
1851 | ESP Triple DES-CBC Transform
1852 | IP Authentication using Keyed SHA
1878 | Variable Length Subnet Table For IPv4
1886 | DNS Extensions to Support IP Version 6
1994 | PPP Challenge Handshake Authentication Protocol (CHAP)
1995 | Incremental Zone Transfer in DNS
1996 | A Mechanism for Prompt DNS Notification of Zone Changes
2018 | TCP Selective Acknowledgment Options
2085 | HMAC-MD5 IP Authentication with Replay Prevention
2104 | HMAC: Keyed Hashing for Message Authentication
2131 | Dynamic Host Configuration Protocol (DHCP)
2136 | Dynamic Updates in the Domain Name System (DNS UPDATE)
2181 | Clarifications to the DNS Specification
2205 | Resource ReSerVation Protocol (RSVP) Version 1 Functional Specification
2236 | Internet Group Management Protocol, Version 2
2308 | Negative Caching of DNS Queries (DNS NCACHE)
2401 | Security Architecture for the Internet Protocol
2402 | IP Authentication Header
2406 | IP Encapsulating Security Payload (ESP)
2581 | TCP Congestion Control

Получение документов RFC

ХОХ Этот веб-узел в настоящее время поддерживается членами ISI (Information Sciences Institute), которые публикуют классифицированные списки документов RFC. Документы RFC классифицируются по следующим категориям: утвержденные стандарты Интернета, предложения по стандартам Интернета (в виде проектов), рекомендации по работе с Интернетом и информация (FYI).

Note

  • XOX


Настройка TCP/IP для альтернативной конфигурации

Чтобы настроить TCP/IP для альтернативной конфигурации

  1. Откройте объект Сетевые подключения.
  2. Щелкните правой кнопкой мыши сетевое подключение, которое требуется настроить, и выберите команду Свойства.
  3. На вкладке Общие (для подключения по локальной сети) или на вкладке Сеть (для всех остальных подключений) выберите Протокол Интернета (TCP/IP) и нажмите кнопку Свойства.
  4. На вкладке Общие выберите параметр Получить IP-адрес автоматически.
  5. На вкладке Альтернативная конфигурация установите переключатель в положение Настроенные пользователем и введите значения следующих параметров:
    • IP-адрес
    • Маска подсети
    • Основной шлюз
    • Основной и дополнительный DNS-сервер
    • Основной и дополнительный WINS-сервер
  6. Нажмите кнопку ОК.

Примечания

  • XOX
  • XOX
  • XOX использует либо средство автоматического назначения частных IP-адресов (APIPA), либо альтернативную конфигурацию для автоматической настройки протокола IP для сетевых подключений.

    • По умолчанию компьютер сначала пытается связаться с DHCP-сервером сети и получить от него динамическую конфигурацию для каждого установленного сетевого подключения, как описано ниже.

    • Если DHCP-сервер достижим и получение от него конфигурационной информации проходит успешно, настройка TCP/IP на этом завершается.
    • Если связаться с DHCP-сервером не удается или произошел сбой арендованной конфигурации, компьютер использует настройки на вкладке Альтернативная конфигурация, чтобы определить, следует использовать автоматическое назначение частных IP-адресов (APIPA) для конфигурации TCP/IP или использовать альтернативную конфигурацию TCP/IP. Когда используется APIPA, в XOX TCP/IP использует адрес в диапазоне IP-адресов APIPA (от 169.254.0.1 до 169.254.255.254) и задается маска подсети 255.255.0.0.
  • Диапазон IP-адресов (с 169.254.0.1 по 169.254.255.254), используемый APIPA, зарезервирован в IANA (Internet Assigned Numbers Authority). IP-адреса из этого диапазона не применяются в Интернете.

См. также


Настройка TCP/IP на автоматическую адресацию

Чтобы настроить TCP/IP на автоматическую адресацию

  1. Откройте объект Сетевые подключения.
  2. Щелкните правой кнопкой мыши сетевое подключение, которое требуется настроить, и выберите команду Свойства.
  3. На вкладке Общие (для подключения по локальной сети) или на вкладке Сеть (для всех остальных подключений) выберите Протокол Интернета (TCP/IP) и нажмите кнопку Свойства.
  4. Установите переключатель в положение Получить IP-адрес автоматически и нажмите кнопку OK.

Примечания

  • XOX
  • XOX
  • XOX использует средство автоматического назначения частных IP-адресов (APIPA) для автоматической настройки конфигурации протокола IP для сетевых подключений.

    По умолчанию компьютер сначала пытается связаться с DHCP-сервером сети и получить от него динамическую конфигурацию для каждого установленного сетевого подключения, как описано ниже.

    • Если DHCP-сервер достижим и получение от него конфигурационной информации проходит успешно, настройка TCP/IP на этом завершается.
    • Если связаться с DHCP-сервером не удается или произошел сбой арендованной конфигурации, компьютер использует настройки на вкладке Альтернативная конфигурация, чтобы определить, следует использовать автоматическое назначение частных IP-адресов (APIPA) для конфигурации TCP/IP или использовать альтернативную конфигурацию TCP/IP. Когда используется APIPA, XOX использует адрес в диапазоне IP-адресов APIPA (от 169.254.0.1 до 169.254.255.254) и задается маска подсети 255.255.0.0.
  • Диапазон IP-адресов (с 169.254.0.1 по 169.254.255.254), используемый APIPA, зарезервирован в IANA (Internet Assigned Numbers Authority). IP-адреса из этого диапазона не применяются в Интернете.

См. также


Общие сведения о настройке TCP/IP

По умолчанию фильтрация TCP/IP отключена. Перед тем как приступать к настройке протокола TCP/IP на компьютере с системой XOX, необходимо получить ответы на следующие вопросы.

  • Использует ли сеть динамическую настройку конфигурации TCP/IP с помощью протокола DHCP (Dynamic Host Configuration Protocol).

    • Динамическая настройка проще всего; ее можно использовать, если в сети есть DHCP-сервер. DHCP-сервер назначает своим клиентам IP-адреса, маски подсети, адреса основных шлюзов (IP-маршрутизаторов), доменные имена DNS и адреса DNS-серверов и WINS-серверов. Протокол TCP/IP настроен использовать динамическую настройку по умолчанию.

  • Требуется ли в сети ручная настройка конфигурации TCP/IP.

    • Некоторые существующие сети либо не используют DHCP, либо требуют ручной настройки конфигурации TCP/IP для каждого компьютера.

  • Требуется ли в сети альтернативная настройка конфигурации TCP/IP.

    • Например, переносные компьютеры иногда подключают к сети организации, что обеспечивает динамическую адресацию. В других случаях им необходима альтернативная или ручная настройка для домашних сетей.

Дополнительные сведения о способах настройки см. в разделе Способы настройки TCP/IP.

Если динамическая настройка TCP/IP с помощью DHCP не используется, получите у системного администратора следующую информацию, необходимую для ручной настройки TCP/IP.

  • IP-адрес и маску подсети для каждого сетевого адаптера, установленного в компьютере.
  • IP-адрес локального основного шлюза (IP-маршрутизатора).
  • Имя домена DNS и IP-адреса DNS-серверов сети.

    • Для развертывания Active Directory основной DNS-суффикс компьютера, также называемый основным доменным именем компьютера, по умолчанию совпадает с именем домена Active Directory, в котором находится этот компьютер. Если нужно, чтобы основной DNS-суффикс компьютера отличался от имени домена Active Directory, в котором находится компьютер, ознакомьтесь с разделом Изменение DNS-суффикса компьютера.

  • IP-адреса WINS-серверов, если в сети используется служба WINS.

Дополнительные сведения о параметрах конфигурации см. в разделе Параметры конфигурации TCP/IP.


Отключение автоматического назначения адресов

Чтобы отключить автоматическое назначение адресов

  1. Откройте редактор реестра.

    2. Внимание!

    • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных. Если после внесения изменений возникли неполадки, при запуске системы загрузите вариант Последняя правильна конфигурация.
  2. В редакторе реестра перейдите в следующий раздел:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
    Services\Tcpip\Parameters

  3. Создайте следующий параметр:

    IPAutoconfigurationEnabled: REG_DWORD

  4. Присвойте ему значение 0, чтобы отключить средство автоматического назначения частных IP-адресов (APIPA) для данного сетевого адаптера.

Примечания

  • XOX
  • XOX
  • Если параметр IPAutoconfigurationEnabled отсутствует, то предполагается, что он имеет значение 1 (средство APIPA включено).

См. также


Настройка TCP/IP на динамическую адресацию

Чтобы настроить TCP/IP на динамическую адресацию

  1. Откройте объект Сетевые подключения.
  2. Щелкните правой кнопкой мыши сетевое подключение, которое требуется настроить, и выберите команду Свойства.
  3. На вкладке Общие (для подключения по локальной сети) или на вкладке Сеть (для всех остальных подключений) выберите Протокол Интернета (TCP/IP) и нажмите кнопку Свойства.
  4. Установите переключатель в положение Получить IP-адрес автоматически и нажмите кнопку OK.

Примечания

  • XOX
  • XOX
  • Эту процедуру нужно выполнять только в том случае, если ранее использовалась статическая настройка конфигурации TCP/IP. По умолчанию XOX пытается получить конфигурацию TCP/IP от DHCP-сервера сети.

См. также


Настройка TCP/IP на статическую адресацию

Чтобы настроить TCP/IP на статическую адресацию

  1. Откройте объект Сетевые подключения.
  2. Щелкните правой кнопкой сетевое подключение, которое требуется настроить, и выберите команду Свойства.
  3. На вкладке Общие (для подключения по локальной сети) или на вкладке Сеть (для всех остальных подключений) выберите Протокол Интернета (TCP/IP) и нажмите кнопку Свойства.
  4. Установите переключатель в положнение Использовать следующий IP-адрес и выполните одно из следующих действий.
    • Для подключения по локальной сети введите в поля IP-адрес, Маска подсети и Основной шлюз IP-адрес, маску подсети и адрес основного шлюза.
    • Для подключений других типов введите IP-адрес в поле IP-адрес.
  5. Установите переключатель в положение Использовать следующие адреса DNS-серверов.
  6. В поля Предпочитаемый DNS-сервер и Альтернативный DNS-сервер введите адреса основного и дополнительного DNS-серверов.
  7. Чтобы задать дополнительные настройки подключения по локальной сети, выберите вкладку Дополнительно и выполните одно или несколько из следующих действий.
    • Чтобы настроить дополнительные IP-адреса:
      1. На вкладке Параметры IP в группе IP-адреса нажмите кнопку Добавить.
      2. В диалоговом окне TCP/IP-адрес в поле IP-адрес введите IP-адрес и в поле Маска подсети — маску подсети, а затем нажмите кнопку Добавить.
      3. Повторите шаги 1 и 2 для каждого добавляемого IP-адреса, после чего нажмите кнопку OK.
    • Чтобы настроить дополнительные основные шлюзы:
      1. На вкладке Параметры IP в группе Основные шлюзы нажмите кнопку Добавить.
      2. В диалоговом окне Адрес шлюза TCP/IP введите IP-адрес основного шлюза в поле Шлюз. Чтобы вручную установить основную метрику, снимите флажок Автоматическое назначение метрики и введите значение в поле Метрика.
      3. Нажмите кнопку Добавить.
      4. Повторите шаг 1 для всех основных шлюзов, которые нужно добавить, и нажмите кнопку OK.
    • Чтобы настроить специальную метрику для этого соеднинения, на вкладке Параметры IP, снимите флажок Автоматическое назначение метрики и в поле Метрика интрефейса введите соответствующее значение.

Примечания

  • XOX
  • XOX

См. также


Проверка конфигурации TCP/IP с помощью команды ping

Чтобы проверить конфигурацию TCP/IP с помощью команды ping

  1. Чтобы быстро получить значения параметров конфигурации TCP/IP на компьютере, откройте командную строку и выполните команду ipconfig. С помощью сведений, отображенных командой ipconfig, убедитесь, что сетевой адаптер для проверяемой конфигурации TCP/IP не находится в состоянии Сеть отключена.
  2. В командной строке обратитесь по адресу замыкания на себя; для этого выполните команду ping 127.0.0.1.
  3. Обратитесь командой «ping» по IP-адресу компьютера.
  4. Обратитесь командой «ping» по IP-адресу основного шлюза.

    5. Если команда ping не была успешно выполнена, проверьте правильность IP-адреса основного шлюза и работоспособность этого шлюза (маршрутизатора).

  5. Обратитесь командой «ping» по IP-адресу удаленного узла (узла, находящегося в другой подсети).

    6. Если команда ping не была успешно выполнена, проверьте правильность IP-адреса удаленного узла, работоспособность этого узла, а также работоспособность всех шлюзов (маршрутизаторов) между локальным компьютером и удаленным узлом.

  6. Обратитесь командой «ping» по IP-адресу DNS-сервера.

    7. Если команда ping не была успешно выполнена, проверьте правильность IP-адреса DNS-сервера, работоспособность DNS-сервера, а также работоспособность всех шлюзов (маршрутизаторов) между локальным компьютером и DNS-сервером.

Примечания

  • XOX
  • Если не удается найти команду ping или она работает неправильно, проверьте системный журнал в программе «Просмотр событий» на предмет неполадок, возникших при установке или во время работы протокола Интернета (TCP/IP).
  • Команда «ping» использует сообщения эхо-запрос и эхо-ответ по протоколу ICMP. Политики фильтрования пакетов для маршрутизаторов, брандмауэров и других шлюзов безопасности могут предотвратить перенаправление трафика.
  • Команда «ipconfig» является эквивалентом для командной строки команды «winipcfg», имеющейся в Windows Millennium Edition, Windows 98 и Windows 95. ВXOX нет графического эквалента команды «winipcfg», но для получения функционального эквивалента откройте компонент Сетевые подключения, щелкните правой кнопкой мыши сетевое подключение, выбрите команду Состояние и щелкните вкладку Поддержка.

    • При вызове команды «ipconfig» без параметров выводится только IP-адрес, маска подсети и основной шлюз для каждого сетевого адаптера.

  • Чтобы выполнить команду «ipconfig», откройте командную строку и введите ipconfig.
  • XOX

См. также


Проверка TCP/IP-соединений с помощью команд ping и net view

Чтобы проверить TCP/IP-соединения с помощью команд ping и net view

  1. Чтобы проверить TCP/IP-соединение с помощью команды ping, используйте команду ipconfig для проверки, что сетевой адаптер не находится в состоянии Сеть отключена.
  2. Откройте командную строку и обратитесь командой «ping» к узлу назначения по его IP-адресу.

    3. Если команда ping выдает сообщение «Превышен интервал ожидания для запроса», проверьте правильность IP-адреса удаленного узла, работоспособность этого узла, а также работоспособность всех шлюзов (маршрутизаторов) между локальным компьютером и удаленным узлом.

  3. Чтобы проверить разрешение имен узлов, обратитесь командой ping к узлу по его имени.

    4. Если команда ping выдает сообщение «Не удается разрешить системное имя узла», проверьте правильность указания имени узла и выясните, может ли оно разрешаться DNS-сервером.

  4. Чтобы проверить TCP/IP-соединение с помощью команды net view, откройте командную строку и выполните команду net view \\имя_компьютера. Команда net view выводит список общих папок и принтеров компьютера, работающего под управлением XOX, создавая временный сеанс с этим компьютером. Если на указанном компьютере нет общих папок и принтеров, команда net view выдает сообщение «В списке нет элементов».

    5. Если команда net view выдает сообщение «Системная ошибка 53», проверьте правильность имени, указанного в параметре имя_компьютера, работоспособность компьютера под управлением XOX, а также работоспособность всех шлюзов (маршрутизаторов) между локальным компьютером и удаленным компьютером с операционной системойXOX.

    Если команда net view выдает сообщение «Произошла системная ошибка 5. Отказано в доступе», проверьте, что вход в систему был осуществлен учетной записью, которая имеет разрешения просматривать общие ресурсы на удаленном компьютере.

    Для устранения этой неполадки выполните следующие действия.

    • С помощью команды ping выполните обмен пакетами с компьютером имя_компьютера.

      Если команда ping выдает сообщение «Не удается разрешить системное имя узла», то имя_компьютера не удается разрешить в IP-адрес.

    • Обратитесь командой net view по IP-адресу компьютера с операционной системой XOX:

      net view \\IP-адрес

      Если команда net view выполняется успешно, то имя_компьютера разрешается в неправильный IP-адрес.

      Если команда net view выдает сообщение «Системная ошибка 53», то на удаленном компьютере не работает служба доступа к файлам и принтерам сетей Microsoft.

Примечания

  • XOX
  • Если не удается найти команду ping или она работает неправильно, проверьте системный журнал в программе «Просмотр событий» на предмет неполадок, возникших при установке или во время работы протокола Интернета (TCP/IP).
  • Команда «ping» использует сообщения эхо-запрос и эхо-ответ по протоколу ICMP. Политики фильтрования пакетов для маршрутизаторов, брандмауэров и других шлюзов безопасности могут предотвратить перенаправление трафика.
  • Эта процедура предполагает использование только протокола TCP/IP. При использовании других протоколов, например совместимый транспортный протокол NWLink IPX/SPX/NetBIOS, команды net view будут выполяться правильно, даже если существуют проблемы разрешения имен и установления связей с TCP/IP. Подключение команды net view предпринимается со всеми установленными протоколами. Если подключение команды net view с протоколом TCP/IP не удается, предпринимается попытка подключения net view с помощью совместимого транспортного протокола NWLink IPX/SPX/NetBIOS.
  • Команда «ipconfig» является эквивалентом для командной строки команды «winipcfg», имеющейся в Windows Millennium Edition, Windows 98 и Windows 95. ВXOX нет графического эквалента команды «winipcfg», но для получения функционального эквивалента откройте компонент Сетевые подключения, щелкните правой кнопкой мыши сетевое подключение, выбрите команду Состояние и щелкните вкладку Поддержка.

    • При вызове команды «ipconfig» без параметров выводится только IP-адрес, маска подсети и основной шлюз для каждого сетевого адаптера.

  • Чтобы выполнить команду «ipconfig», окройте командную строку и введите ipconfig.
  • XOX
  • XOX

См. также


Установка простых служб TCP/IP

Чтобы установить простые службы TCP/IP

  1. На панели управления откройте компонент Установка и удаление программ.
  2. Нажмите кнопку Добавление и удаление компонентов Windows.
  3. В списке Компоненты выберите Сетевые службы и нажмите кнопку Состав.
  4. В списке Сетевые службы - состав выберите Простые службы TCP/IP и нажмите кнопку OK.
  5. Нажмите кнопку Далее.
  6. Если появится соответствующее приглашение, введите путь к установочным файлам XOX и нажмите кнопку OK.
  7. Нажмите кнопку Готово, затем Закрыть.

Примечания

  • XOX
  • XOX
  • Простые службы TCP/IP включают программное обеспечение XOX для поддержки необязательных служб протокола TCP/IP, перечисленных в следующей таблице.
    • протокол | Описание | RFC
Character Generator (CHARGEN) | Посылает данные, построенные на основе набора 95 печатаемых ASCII-символов. Полезен в качестве отладочного средства для проверки или устранения неполадок строчных принтеров. | 864
Daytime | Возвращает сообщения, содержащие текущие день недели, месяц, число, год и время (в формате чч:мм:сс), а также сведения о часовом поясе. Некоторые программы могут пользоваться этими сообщениями для отладки или наблюдения за погрешностью системных часов, а также для установки системного времени | 867
Discard | Отбрасывает все сообщения, поступающие на данный порт, без ответа или уведомления. Может служить нуль-портом для приема и маршрутизации проверочных сообщений TCP/IP в процессе установки и настройки сети; в некоторых случаях также может использоваться программами в качестве средства отбрасывания сообщений | 863
Echo | Возвращает отправителю данные любых сообщений, принимаемых на данный серверный порт. Может быть полезен в качестве средства отладки и наблюдения за сетью. | 862
Quote of the Day (QUOTE) | Возвращает цитату в виде сообщения, состоящего из одной или нескольких текстовых строк. Цитаты выбираются в произвальном порядке из следующего файла системный_корневой _каталог\System32\Drivers\Etc\Quotes Вместе с простыми службами TCP/IP устанавливается файл-пример. Если указанный файл отсутствует, данная служба работает не будет | 865
  • Все эти протокольные службы классифицируются как необязательные (elective) стандарты Интернета; они описаны в перечисленных в таблице документах RFC. Дополнительные сведения об этих протокольных службах см. в соответствующих документах RFC.
  • Не устанавливайте простые службы TCP/IP, если данному компьютеру не требуется поддерживать связь с другими системами, использующими эти протокольные службы.
  • После установки простых службы TCP/IP, нельзя включить или отключить только отдельные службы.

См. также


Трассировка маршрута с помощью команды tracert

Чтобы выполнить трассировку маршрута с помощью команды tracert

  • Откройте командную строку и выполните следующую команду:

    tracert имя_узла

    Либо, выполните команду tracert ip-адрес,

    указав в параметре имя_узла или ip-адрес, соответственно, имя узла или IP-адрес удаленного компьютера.

    • Например, чтобы выполнить трассировку маршрута от локального компьютера к узлу www.microsoft.com, введите следующую команду:

    tracert www.microsoft.com

    Чтобы эта команда «tancert» не разрешала и не выводила на экран именя всех маршрутизаторов на пути, используйте параметр -d. Это упростит вид пути. Например, чтобы выполнить трассировку маршрута от локального компьютера к узлу www.microsoft.com без отображения имен маршрутизаторов, введите следующую команду:

    tracert -d www.microsoft.com

Примечания

  • XOX
  • Команда tracert определяет путь, посылая ICMP-сообщения «эхо-запрос» и «эхо-ответ» (подобно команде ping) для вывода на экран сведения о каждом пройденном маршрутизаторе и о времени обмена данными (RTT) с каждым из них. Политики фильтрования пакетов для маршрутизаторов, брандмауэров и других шлюзов безопасности могут предотвратить перенаправление трафика.
  • Если трассировка маршрута с помощью программы tracert окончилась неудачей, то на основании выводимых ею данных можно определить, какой промежуточный маршрутизатор не перенаправляет данные дальше или делает это слишком медленно.
  • Для получения подробынх сведений о перенаправлении и потерях пакетов на каждом маршрутизаторе и ссылке, через которые проходит этот путь используйте команду pathping.

См. также


Настройка TCP/IP на использование DNS

Чтобы настроить TCP/IP на использование DNS

  1. Откройте объект Сетевые подключения.
  2. Щелкните правой кнопкой сетевое подключение, которое требуется настроить, и выберите команду Свойства.
  3. На вкладке Общие (для подключения по локальной сети) или на вкладке Сеть (для всех остальных подключений) выберите Протокол Интернета (TCP/IP) и нажмите кнопку Свойства.
  4. Если требуется получать адреса DNS-серверов от DHCP-сервера, установите переключатель в положение Получить адрес DNS-сервера автоматически.
  5. Чтобы настроить адреса DNS-серверов вручную, установите переключатель в положение Использовать следующие адреса DNS-серверов и введите в поля Предпочитаемый DNS-сервер и Альтернативный DNS-сервер IP-адреса соответствующих DNS-серверов.
  6. Чтобы настроить дополнительные параметры DNS, нажмите кнопку Дополнительно, откройте вкладку DNS и выполните одно или несколько из следующих действий.
    • Чтобы указать IP-адрес дополнительного DNS-сервера:
      1. В группе Адреса DNS-серверов, в порядке использования нажмите кнопку Добавить.
      2. В диалоговом окне DNS-сервер TCP/IP введите IP-адрес DNS-сервера и нажмите кнопку Добавить.
    • Чтобы настроить разрешение неизвестных имен DNS:
      • Для разрешения неизвестных имен путем добавления основного DNS-суффикса и DNS-суффикса подключения (если он задан), установите переключатель в положение Дописывать основной DNS-суффикс и суффикс подключения. Если требуется также дописывать родительские суффиксы основного DNS-суффикса вплоть до домена второго уровня, установите флажок Дописывать родительские суффиксы осн. DNS-суффикса.
      • Для разрешения неизвестного имени путем добавления суффиксов из заранее определенного списка, установите переключатель в положение Дописывать следующие DNS-суффиксы (по порядку) и с помощью кнопки Добавить добавьте в список нужные суффиксы.
    • Чтобы задать DNS-суффикс для конкретного подключения, введите этот DNS-суффикс в поле DNS-суффикс подключения.
    • Чтобы изменить характеристики динамического обновления DNS, выполните следующие действия.
      • Дляиспользования динамического обновления DNS для регистрации IP-адреса подключения и основного доменного имени компьютера, установите флажок Зарегистрировать адреса этого подключения в DNS. Этот флажок установлен по умолчанию. Основное доменное имя компьютера представляет собой имя компьютера, к которому добавлен основной DNS-суффикс; это имя выводится в качестве полного имени компьютера на вкладке Имя компьютера в окне «Система» панели управления.
      • Для использования динамического обновления DNS для регистрации IP-адресов и доменного имени данного подключения, установите флажок Использовать DNS-суффикс подключения при регистрации в DNS. Этот флажок по умолчанию снят. Доменное имя подключения — это имя компьютера, к которому добавлен DNS-суффикс подключения.

Примечания

  • XOX
  • XOX
  • Чтобы полностью отключить динамическое обновление DNS всех имен компьютера, снимите флажки Зарегистрировать адреса этого подключения в DNS и Использовать DNS-суффикс подключения при регистрации в DNS для всех подключений в окне «Сетевые подключения».

См. также


Настройка TCP/IP на использование WINS

Чтобы настроить TCP/IP на использование WINS

  1. Откройте объект Сетевые подключения.
  2. Щелкните правой кнопкой сетевое подключение, которое требуется настроить, и выберите команду Свойства.
  3. На вкладке Общие (для подключения по локальной сети) или на вкладке Сеть (для всех остальных подключений) выберите Протокол Интернета (TCP/IP) и нажмите кнопку Свойства.
  4. Нажмите кнопку Дополнительно, откройте вкладку WINS и нажмите кнопку Добавить.
  5. В диалоговом окне WINS-сервер TCP/IP введите IP-адрес WINS-сервера и нажмите кнопку Добавить.
  6. Повторите шаги 4 и 5 для каждого добавляемого WINS-сервера, после чего нажмите кнопку OK.
  7. Чтобы включить использование файла Lmhosts для разрешения удаленных имен NetBIOS, установите флажок Включить просмотр LMHOSTS. Этот флажок установлен по умолчанию.
  8. Чтобы указать местоположение файла, который нужно импортировать в файл Lmhosts, нажмите кнопку Импорт LMHOSTS и выберите файл в диалоговом окне Открыть.
  9. Чтобы включить или отключить NetBIOS через TCP/IP, выполните следующие шаги.
    • Чтобы DHCP-сервер определял режим работы NetBIOS через TCP/IP установите переключатель в положение По умолчанию. Значение зарезервированного Майкрософт параметра DHCP Отключить NetBIOS через TCP/IP либо включает (значение 1), либо отключает (значение 2) работу NetBIOS через TCP/IP для DHCP-клиента. Если DHCP-сервер не отослал параметр DHCP Отключить NetBIOS через TCP/IP во время согласования аренды DHCP или протокол TCP/IP настраивается вручную, NetBIOS через TCP/IP включен. Дополнительные сведения о параметре DHCP Отключить NetBIOS через TCP/IP находятся по ссылке См. также.
    • Чтобы включить использование NetBIOS через TCP/IP, установите переключатель в положение Включить NetBIOS через TCP/IP.
    • Чтобы отключить использование NetBIOS через TCP/IP, установите переключатель в положение Отключить NetBIOS через TCP/IP.

Внимание!

  • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных.

Примечания

  • XOX
  • XOX
  • Если IP-адреса WINS-серверов назначаются DHCP-сервером, то добавлять вручную адреса WINS-серверов не нужно.
  • Если NetBIOS через TCP/IP отключен, то подключение к компьютерам, не использующим Windows 2000 или XOX, может быть невозможно.
  • При отключении NetBIOS через TCP/IP нельзя использовать широко-вещательное разрешение NetBIOS-имен для разрешения в IP-адреса имен компьютеров, находящихся в сегменте сети, или, по-другому, в подсети. Настройки типичных сетевых конфигураций объединяют все компьютеры в эту подсеть. Если NetBIOS через TCP/IP отключен, нужно установить DNS-сервер и либо зарегистрировать компьютеры с DNS (или вручную настроить записи DNS), либо настроить записи в локальном файле HOSTS для каждого компьютера.
  • Будет невозможно задавать код области NetBIOS на вкладке WINS. Чтобы задать код области NetBIOS, укажите его в следующем параметре реестра:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters\ScopeID

См. также


Протокол ICMP

Протокол межсетевых управляющих сообщений ICMP (Internet Control Message Protocol) является обязательным стандартом TCP/IP, описанным в документе RFC 792, «Internet Control Message Protocol (ICMP)». Используя ICMP, узлы и маршрутизаторы, связывающиеся по протоколу IP, могут сообщать об ошибках и обмениваться ограниченной управляющей информацией и сведениями о состоянии.

ICMP-сообщения обычно автоматически отправляются в следующих случаях.

  • IP-датаграмма не может попасть к узлу назначения.
  • IP-маршрутизатор (шлюз) не может перенаправлять датаграммы с текущей скоростью передачи.
  • IP-маршрутизатор перенаправляет узел-отправитель на другой, более выгодный маршрут к узлу назначения.

ICMP-сообщения инкапсулируются и передаются в IP-датаграммах, как показано на следующем рисунке.

Инкапсуляция ICMP-сообщения в IP-датаграмму

Типы ICMP-сообщений различаются по заголовку ICMP. Так как ICMP-сообщения переносятся IP-датаграммами, их доставка не гарантируется.

Наиболее часто встречающиеся ICMP-сообщения перечислены и описаны в следующей таблице.

ICMP-сообщение | Описание
Эхо-запрос (Echo request) | Определяет, доступен ли в сети IP-узел (компьютер или маршрутизатор).
Эхо-ответ (Echo reply) | Отвечает на эхо-запрос ICMP.
Адресат недоступен (Destination unreachable) | Информирует узел о том, что датаграмма не может быть доставлена.
Замедление источника (Source quench) | Требует от узла снизить скорость отправки датаграмм, так как в сети возник затор.
Перенаправление (Redirect) | Информирует узел о наличии лучшего маршрута.
Истечение времени (Time exceeded) | Сообщает, что время жизни IP-датаграммы (TTL) истекло.

Для отправки эхо-запросов ICMP и приема эхо-ответов ICMP можно использовать команду ping. Эти сообщения позволяют выявлять неполадки в работе сетей и узлов, а также устранять другие неполадки TCP/IP-соединений.

Дополнительные сведения о протоколе ICMP см. в документе RFC 792, «Internet Control Message Protocol (ICMP)». Дополнительные сведения о получении документов RFC см. в разделе Получение документов RFC.

См. также