Telnet

Клиент Telnet и сервер Telnet работают совместно, позволяя пользователю взаимодействовать с удаленным компьютером.

Клиент Telnet позволяет пользователям подключаться к удаленным компьютерам и взаимодействовать с ними через окно терминала.

Сервер Telnet позволяет пользователям клиентов Telnet входить в систему на компьютерах, на которых выполняется программное обеспечение сервера Telnet, и запускать на этих компьютерах программы с текстовым интерфейсом. Сервер Telnet выполняет роль шлюза, через который клиенты Telnet взаимодействуют друг с другом. Программное обеспечение сервера Telnet, поставляемое с XOX, поддерживает не более двух клиентов Telnet одновременно. При необходимости в дополнительных лицензиях используйте сервер Telnet из пакета служб Microsoft Windows для UNIX.

  • Дополнительные сведения о клиенте Telnet см. в разделе Клиент Telnet.
  • Дополнительные сведения о сервере Telnet см. в разделе Сервер Telnet.


Клиент Telnet

С помощью клиента Telnet пользователи Windows могут подключаться к удаленному компьютеру, на котором запущен сервер Telnet, и запускать приложения или выполнять административные задачи на этом компьютере.

  • Для получения общих сведений см. раздел Основные понятия
  • Инструкции по устранению неполадок содержатся в разделе Устранение неполадок.


Основные понятия

В этом разделе содержатся следующие сведения.

  • Общие сведения о клиенте Telnet
  • Использование клиента Telnet


Общие сведения о клиенте Telnet

Клиент Telnet использует протокол Telnet, входящий в набор протоколов TCP/IP, для подключения к удаленному компьютеру в сети. Программное обеспечение клиента Telnet позволяет компьютеру подключаться к удаленному серверу Telnet и запускать приложения на этом сервере.

В набор служб Windows для UNIX входит улучшенный клиент Telnet для командной строки. Для проверки подлинности клиентов при соединениях по протоколу Telnet между компьютерами с Windows NT, Windows 2000 или XOX можно использовать процесс проверки подлинности NTLM.


Использование клиента Telnet

Этот раздел содержит сведения на следующие темы.

  • Проверка подлинности
  • Команды Telnet
  • Режим сеанса и режим команд
  • Управление Telnet из командной строки


Проверка подлинности

Для доступа к серверу Telnet можно использовать локальные имя пользователя и пароль Windows или сведения учетной записи в домене.

Если проверка подлинности NTLM не используется, имя пользователя и пароль передаются на сервер Telnet как обычный текст.

При использовании проверки подлинности NTLM клиент Telnet использует для проверки подлинности контекст безопасности XOX и не запрашивает имя пользователя и пароль. Имя пользователя и пароль зашифровываются.

Если для пользователя установлен параметр Потребовать смену пароля при следующем входе в систему, попытка входа на сервер Telnet с использованием проверки подлинности NTLM вызовет сбой. Для успешного входа в систему пользователь должен войти на сервер непосредственно и изменить пароль, а затем войти по протоколу Telnet.

При подключении к серверу Telnet с использование проверки подлинности NTLM пользователь не будет иметь доступа к дополнительным сетевым ресурсам из-за ограничения проверки подлинности NTLM. Для доступа к сетевым ресурсам из сеанса Telnet необходимо повторно указывать имя пользователя и пароль.


Команды Telnet

Командная строка клиента Telnet принимает следующие команды.

Команда | Описание
open | Синтаксис: open имя_узла номер_порта. Используется для установки соединения с узлом по протоколу Telnet.
close | Команда close используется для закрытия существующего соединения по протоколу Telnet.
display Команда display используется для просмотра текущих параметров клиента Telnet.

Команда display выводит список текущих рабочих параметров. При работе в режиме сеанса Telnet (после подключения к серверу Telnet) для изменения параметров следует нажать клавиши CTRL+]. Будет выполнен выход из сеанса Telnet. (Для возвращения в сеанс Telnet нажмите клавишу ENTER.) Доступны следующие рабочие параметры:

  • WILL AUTH (проверка подлинности NTLM)
  • WONT AUTH
  • WILL TERM TYPE
  • WONT TERM TYPE
  • LOCALECHO off
  • LOCALECHO on
quit | Команда quit используется для выхода из Telnet.
set Команда set используется для задания типа терминала для подключения, включения режима локального отображения команд, задания проверки подлинности NTLM, задания управляющего символа и настройки ведения журнала.

  • SET NTLM — включение NTLM.

    • При использовании проверки подлинности NTLM во время подключения с удаленного компьютера пользователю не требуется вводить имя и пароль для входа в систему.

  • SET LOCALECHO — включение режима локального отображения команд.
  • SET TERM {ANSI|VT100|VT52|VTNT} — задание указанного типа терминала.

    • Тип терминала VT100 используется при выполнении обычных приложений командной строки. Тип терминала VTNT используется при выполнении расширенных приложений командной строки, таких как edit.

  • ESCAPE символ — задание последовательности клавиш для переключения из режима сеанса в режим команд. Например, чтобы задать в качестве управляющего символа CTRL+P, введите set escape, нажмите клавиши CTRL+P, а затем — клавишу ENTER.
  • LOGFILE ИмяФайла — задание файла журнала активности Telnet. Файл журнала должен располагаться на локальном компьютере.

    • Запись в журнал начинается автоматически после выбора этого параметра.

  • LOGGING — включение ведения журнала.

    • Если файл журнала не задан, выводится сообщение об ошибке.
unset Команда unset используется для отключения режима локального отображения команд или для включения режима проверки подлинности с запросом имени пользователя и пароля.

  • UNSET NLM — отключение NLM.
  • UNSET LOCALECHO — отключение режима локального отображения команд.
status | Команда status позволяет определить, подключен ли клиент Telnet.
CTRL+] | Сочетание клавиш CTRL+] используется для перехода в командную строку Telnet из подключенного сеанса.
enter | Команда enter из командной строки используется для перехода в подключенный сеанс (если таковой существует).
? или help | Вывод справочных сведений.
Сведения о командах клиента и сервера Telnet см. в разделе Telnet.


Режим сеанса и режим команд

Существует два режима работы клиента Telnet: режим команд Telnet и режим сеанса Telnet. Режим команд Telnet позволяет использовать терминал Telnet для открытия подключения к удаленному узлу, закрытия подключения к удаленному узлу, просмотра рабочих параметров, задания параметров терминала, печати сведений о состоянии и завершения работы программы.

После подключения к удаленному узлу клиент Telnet находится в режиме сеанса Telnet. Этот режим используется наиболее широко. После входа в систему пользователю предоставляется сеанс командной строки. Затем пользователи могут использовать приложения с текстовым интерфейсом на любом удаленном компьютере, на котором выполняется сервер Telnet, как после непосредственного входа в систему на соответствующем компьютере.

После подключения к узлу можно перейти из режима сеанса в режим команд для изменения параметров терминала. Для перехода из режима сеанса Telnet в режим команд Telnet используется сочетание клавиш CTRL + ]. Для возврата в режим сеанса Telnet достаточно нажать клавишу ENTER.

Сведения о командах клиента и сервера Telnet см. в разделе Telnet.


Управление Telnet из командной строки

Команды Telnet, вводимые в контексте telnet, позволяют обмениваться данными с удаленным компьютером, использующим протокол Telnet. Запуск Telnet без параметров позволяет войти в контекст telnet. В этом контексте можно использовать команды telnet для управления компьютером, на котором выполняется клиент Telnet.

Сведения о других служебных программах командной строки см. в разделе Справочник по параметрам командной строки.


Устранение неполадок

Вид неполадки

Клиент Telnet не восстанавливается после удаления служб Windows для UNIX.

Причина. Программа установки выполнила неудачную попытку восстановления исходных файлов Telnet.

Решение. Восстановите файлы Telnet с установочного компакт-диска Windows. Например, следующие команды позволяют восстановить необходимые файлы, если системной папкой является C:\WINDOWS, а исходному компакт-диску назначена буква D:

C:\>copy D:\I386\telnet.exe C:\WINDOWS\SYSTEM32
C:\>expand -r D:\I386\tlntsvr.ex_ C:\WINDOWS\SYSTEM32
C:\>expand -r D:\I386\tlntsvrp.dl_ C:\WINDOWS\SYSTEM32
C:\>expand -r D:\I386\tlntsess.ex_ C:\WINDOWS\SYSTEM32

Неровные символы и строки в окне клиента Telnet при подключении к серверу Telnet со службами Windows для UNIX.

Причина. Данная неполадка может быть вызвана несоответствием между размером окна клиента Telnet и максимальным размером окна команд, который поддерживается сервером Telnet.

Решение. Попробуйте уменьшить размер окна клиента Telnet перед повторным подключением.

При прерывании и последующем восстановлении сеанса Telnet на компьютере, работающем под управлением Windows, с компьютера, работающего под управлением UNIX, выравнивание курсора в командной строке может быть нарушено.

Причина. Данная неполадка вызывается прерыванием обмена данными.

Решение. Введите команду Windows для очистки экрана: cls.

См. также


Сервер Telnet

Сервер Telnet для Windows предоставляет сеансы текстового терминала для клиентов Telnet. Сервер Telnet поддерживает два типа проверки подлинности и четыре типа терминалов: ANSI, VT-100, VT-52 и VTNT.

  • Советы по использованию сервера Telnet см. в разделе Советы и рекомендации.
  • Общие фундаментальные сведения собраны в разделе Основные понятия.
  • Инструкции по устранению неполадок содержатся в разделе Устранение неполадок.


Советы и рекомендации

  • Обеспечьте безопасность на уровне пользователя
    Для управления доступом пользователей Telnet к файлам на сервере используйте для системного раздела только файловую систему NTFS. Создайте группу TelnetUsers и добавьте в нее всех пользователей Telnet, а затем назначьте разрешения на доступ к файлам и папкам для управления доступом членов группы к этим файлам и папкам.
  • Разрешите пользователям отключаться перед остановкой службы
    Прежде чем остановить сервер Telnet или удалить его, отправьте в сеансы клиентов Telnet сообщение о предстоящей остановке службы. После этого службу можно остановить, дав пользователям время на закрытие своих сеансов.
  • Убедитесь, что кодовая страница клиента совпадает с кодовой страницей терминала UNIX
    Если пользователи будут подключаться к серверу Telnet с компьютеров, работающих под управлением многоязыковой версии UNIX (например, поддерживающей европейские языки), следует убедиться в том, что кодовая страница, используемая командной оболочкой, может правильно отображать расширенные символы. Чтобы задать кодовую страницу для всех пользователей при их входе в систему, добавьте в файл СистемныйКорневойКаталог\system\login.cmd команду chcp для задания соответствующей кодовой страницы. Например, для поддержки версии UNIX для английского и европейских языков добавьте команду chcp 1252.
  • При использовании Telnet с любым из четырех поддерживаемых дальневосточных языков применяйте в окне «Командная строка» шрифт True Type

    • Telnet поддерживает следующие дальневосточные языки: японский, китайский (упрощенное и традиционное письмо) и корейский. Для правильного отображения символов этих дальневосточных языков используйте в окне «Командная строка» шрифт True Type. По умолчанию используются точечные шрифты.

    Если Telnet используется с дальневосточными языками регулярно, шрифт True Type можно задать для использования по умолчанию.

    1. Чтобы задать шрифт для окна «Командная строка», щелкните заголовок окна «Командная строка» правой кнопкой и выберите команду Свойства.
    2. Выберите шрифт True Type и нажмите кнопку OK.
    3. Чтобы установить выбранный шрифт True Type для использования по умолчанию, выберите в диалоговом окне Изменение свойств ярлыка параметр Изменить ярлык для запуска этого окна.


Основные понятия

В этом разделе содержатся следующие сведения.

  • Общие сведения о сервере Telnet
  • Доступ к серверу Telnet
  • Проверка подлинности
  • Использование login.cmd


Общие сведения о сервере Telnet

Сервер Telnet выполняет роль шлюза для клиентов Telnet. Когда на компьютере выполняется сервер Microsoft Telnet, пользователи могут использовать клиенты Telnet для подключения к этому компьютеру с удаленных компьютеров. При подключении клиента Telnet к серверу Telnet удаленный пользователь получает запрос на ввод имени пользователя и пароля. По умолчанию для входа на сервер могут использоваться только сочетания имен и паролей, действующие на локальном сервере.

После входа в систему пользователю предоставляется командная строка, которую он может использовать так же, как окно командной строки, открытое на локальном компьютере. Однако по умолчанию пользователь не может использовать приложения, взаимодействующие с рабочим столом.

Служба Telnet использует протокол Telnet, входящий в набор протоколов TCP/IP, для подключения к удаленным компьютерам по сети.

Лицензирование Telnet

Лицензия разрешает установку одной копии сервера Telnet с каждой устанавливаемой копией Windows 2000 Server.

В следующей таблице показано максимально возможное число одновременных подключений к серверу Telnet.

Операционная система | Максимальное число подключений
Windows 2000 Server | 2
XOX | 2


Доступ к серверу Telnet

По умолчанию доступ к серверу по протоколу Telnet имеют только пользователи, входящие в группу «Администраторы». Владелец сервера Telnet может предоставить доступ другим пользователям. Чтобы указать, какие пользователи могут обращаться к серверу по протоколу Telnet, создайте на сервере локальную группу с именем TelnetClients и добавьте пользователей в эту группу. Если группа с таким именем существует на сервере, доступ к серверу по протоколу Telnet будут иметь только члены этой группы.

Чтобы предоставить доступ к серверу Telnet
  1. XOX
  2. В дереве консоли разверните узел Локальные пользователи и группы и щелкните папку Группы.
  3. Дважды щелкните группу TelnetClients.
  4. Нажмите кнопку Добавить.
  5. Выполните инструкции в окне Выбор пользователей для добавления пользователей в группу TelnetClients, а затем нажмите кнопку OK.

Примечания

  • XOX
  • Изменение написания имени группы TelnetClients не допускается.
  • Если локальная группа TelnetClients существует на компьютере сервера Telnet, пользователи, не являющиеся членами этой группы, не смогут обращаться к данному компьютеру по протоколу Telnet.

См. также


Проверка подлинности

Для доступа к серверу Telnet можно использовать локальные имя пользователя и пароль Windows или сведения учетной записи в домене. Данная схема безопасности, называемая проверкой подлинности NTLM, интегрирована в систему безопасности Windows. При использовании проверки подлинности NTLM клиент использует для проверки подлинности контекст безопасности Windows и не запрашивает имя пользователя и пароль. Имя пользователя и пароль зашифровываются. Сеансы, не использующие шифрование, используют незашифрованный текст (также называемый простым текстом) и видны в сети.

Если проверка подлинности NTLM не используется, имя пользователя и пароль передаются на сервер Telnet как обычный текст. Любой пользователь, перехвативший пакеты, пересылаемые в процессе проверки подлинности, может легко прочитать пароль и использовать его для несанкционированного доступа к интрасети. В связи с этим использовать обычный текст при проверке подлинности не рекомендуется.

Если для пользователя установлен параметр Потребовать смену пароля при следующем входе в систему, то попытка входа на сервер Telnet вызывает сбой. Пользователь должен войти на сервер непосредственно и изменить пароль, а затем войти по протоколу Telnet.

При подключении к серверу Telnet с использование проверки подлинности NTLM пользователь не будет иметь доступа к дополнительным сетевым ресурсам из-за ограничения проверки подлинности NTLM. Для доступа к сетевым ресурсам из сеанса Telnet необходимо повторно указывать имя пользователя и пароль.

Сведения о командах клиента и сервера Telnet см. в разделе Telnet.


Использование login.cmd

Программа login.cmd выполняется при входе на сервер Telnet. Файлы login.cmd можно редактировать для изменения текста, отображаемого при входе в систему. Также можно использовать login.cmd для запуска других программ.

При установке служб Windows для UNIX эта программа копируется в файл %SystemRoot%\system32\login.cmd. Выглядит она следующим образом:

@echo off
rem
rem  Глобальный сценарий входа по умолчанию для сервера Telnet
rem
rem  В установке по умолчанию этот командный сценарий выполняется
rem  при вызову начальной командной оболочки.
rem  В свою очередь, это приводит к вызову сценария входа
rem  отдельного пользователя.
rem
echo
*====================================================
echo
Вас приветствует Telnet-сервер производства корпорации Майкрософт.
echo
*===============================================
cd /d %HOMEDRIVE%\%HOMEPATH%

В следующем примере файлы изменен для отображения текста «Добро пожаловать на мой сервер Telnet» и запуска программы net config, выводящей сведения о конфигурации сервера:

@echo off
rem
rem  Глобальный сценарий входа по умолчанию для сервера Telnet
rem
rem  В установке по умолчанию этот командный сценарий выполняется
rem  при вызову начальной командной оболочки.
rem  В свою очередь, это приводит к вызову сценария входа
rem  отдельного пользователя.
rem
echo
*================================================
echo
Добро пожаловать на мой сервер Telnet
echo
*================================================
cd /d %HOMEDRIVE%\%HOMEPATH% net config server


Устранение неполадок

Вид неполадки

Вход в систему не произведен: выбранный режим входа для данного пользователя на этом компьютере не предусмотрен.

Причина. Пользователю не разрешен локальный вход в систему на компьютере сервера Telnet.

Решение. Убедитесь в том, что пользователь или группа, в состав которой входит этот пользователь (например, группа TelnetUsers), имеет право на локальный вход в систему. Убедитесь в том, что пользователю или группе, в состав которой входит этот пользователь, не запрещен локальный вход в систему.

Доступ запрещен: указанный пользователь не является членом группы TelnetClients.

Причина. Для подключения к серверу Telnet пользователи должны входить в состав группы TelnetClients.

Решение. Добавьте пользователя в группу TelnetClients.

Вход в систему не произведен: перед первым входом в систему пользователь должен сменить свой пароль.

Причина. Пароль пользователя должен быть изменен.

Решение. Пользователь должен войти в систему на данном компьютере непосредственно (то есть лично), чтобы сменить пароль.

Вход в систему не произведен: сервер Telnet разрешает только проверку подлинности NTLM.

Причина. Либо клиент не поддерживает проверку подлинности NTLM, либо клиент поддерживает только проверку подлинности NTLM, которая не включена на сервере Telnet.

Решение. Если клиент Telnet не поддерживает проверку подлинности NTLM, воспользуйтесь клиентом, который ее поддерживает. Если это невозможно, включите на сервере Telnet проверку подлинности с использованием обычного текста. Для максимальной безопасности используйте только клиенты Telnet, поддерживающие проверку подлинности NTLM, а на сервере Telnet включите проверку подлинности NTLM и отключите проверку подлинности с использованием обычного текста.

Ошибка при подключении к узлу localhost: не удается открыть подключение к узлу через порт 23.

Причина. Сервер Telnet не настроен для прослушивания порта 23 или не запущен.

Решение. Убедитесь, что сервер Telnet запущен и настроен для прослушивания порта 23. Если это невозможно, при подключении укажите настроенный порт после имени узла.

Не удается подключиться к сетевым дискам.

Причина. Проверка подлинности NTLM не разрешает доступ к сетевым дискам.

Решение. Назначьте сетевому диску букву диска, например с помощью команды net use.

См. также