Изменение параметров запоминания команд

Рисунок Microsoft Windows

Чтобы изменить параметры запоминания команд

  1. XOX
  2. Щелкните правой кнопкой мыши строку заголовка и выполните одно из следующих действий.
    • Чтобы изменить параметры запоминания команд для всех окон командной строки, выберите команду По умолчанию.
    • Чтобы изменить параметры запоминания команд только для текущего окна командной строки, выберите команду Свойства.
  3. На вкладке Общие в группе Запоминание команд укажите размер буфера и число используемых буферов.

Примечания

  • XOX
  • Изменение размера буфера влияет на число команд, которые могут храниться в буфере. Изменение числа буферов приводит к изменению максимального числа процессов, имеющих отдельные буферы команд. Увеличение числа или размера буферов требует больше памяти.
  • Для удаления повторяющихся команд из списка использованных команд установите флажок Отбрасывать повторения.

См. также


Изменение размера курсора командной строки

Чтобы изменить размер курсора командной строки

  1. XOX
  2. Щелкните правой кнопкой мыши строку заголовка и выполните одно из следующих действий.
    • Чтобы изменить этот параметр для всех окон командной строки, выберите команду По умолчанию.
    • Чтобы изменить этот параметр только для текущего окна командной строки, выберите команду Свойства.
  3. На вкладке Общие в группе Размер курсора выберите размер курсора.

Примечание

  • XOX


Изменение параметров отображения командной строки

Чтобы изменить параметры отображения командной строки

  1. XOX
  2. Щелкните правой кнопкой мыши строку заголовка и выполните одно из следующих действий.
    • Чтобы изменить этот параметр для всех окон командной строки, выберите команду По умолчанию.
    • Чтобы изменить этот параметр только для текущего окна командной строки, выберите команду Свойства.
  3. На вкладке Общие в группе Параметры вывода установите переключатель В окне или Во весь экран.

Примечания

  • XOX
  • На компьютерах с процессорами x86 переключение между оконным и полноэкранным режимами осуществляется нажатием клавиш ALT+ENTER.


Изменение оконных шрифтов командной строки MS-DOS

Чтобы изменить оконные шрифты командной строки MS-DOS

  1. XOX
  2. Щелкните правой кнопкой мыши строку заголовка и выполните одно из следующих действий.
    • Чтобы изменить этот параметр для всех окон командной строки, выберите команду По умолчанию.
    • Чтобы изменить этот параметр только для текущего окна командной строки, выберите команду Свойства.
  3. Щелкните вкладку Шрифт.
  4. В поле Шрифт выберите имя шрифта.
    • Если выбран шрифт TrueType, в поле со списком Размер появится список размеров в пунктах, из которого следует выбрать нужный; кроме того, размер может быть введен вручную в поле Размер.
    • Если выбраны Точечные шрифты, размеры, перечисленные в поле со списком Размер, соответствуют выбираемым размерам окна командной строки.
  5. Для использования полужирных шрифтов (в случае шрифтов TrueType) надо установить флажок Жирный.

Примечания

  • XOX
  • В поле Образец окна можно видеть, как изменяется текущий размер окна в зависимости от выбранного шрифта и его размера.
  • В поле Выбранный шрифт отображается вид символов при выбранных параметрах шрифта. Полужирное начертание не может применяться к точечным шрифтам.
  • Размер окна может быть изменен до максимального размера, указанного на вкладке Расположение. Для удобства использования и читаемости рекомендуется выбирать размер окна не менее четверти и не более половины размера рабочего стола.


Изменение цветов элементов командной строки

Чтобы изменить цвета элементов командной строки

  1. XOX
  2. Щелкните правой кнопкой мыши строку заголовка и выполните одно из следующих действий.
    • Чтобы изменить этот параметр для всех окон командной строки, выберите команду По умолчанию.
    • Чтобы изменить этот параметр только для текущего окна командной строки, выберите команду Свойства.
  3. Чтобы выбрать для экрана цвета фона и текста, а также цвета фона и текста для всплывающих окон, на вкладке Цвета выберите элемент, цвет которого требуется изменить, и выделите нужный цвет.

Примечания

  • XOX
  • Образец экрана с учетом выбранных цветов текста и фона отображается в поле Образец экрана.
  • Образец экрана с учетом выбранных цветов текста и фона для всплывающих окон отображается в поле Образец всплывающего окна.


Изменение расположения экрана командной строки

Чтобы изменить расположение экрана командной строки

  1. XOX
  2. Щелкните правой кнопкой мыши строку заголовка и выполните одно из следующих действий.
    • Чтобы изменить этот параметр для всех окон командной строки, выберите команду По умолчанию.
    • Чтобы изменить этот параметр только для текущего окна командной строки, выберите команду Свойства.
  3. Выберите вкладку Расположение.
  4. В группе Размер буфера экрана задайте ширину и высоту экрана в зависимости от числа знаков, введенных в буфер.
  5. В группе Размер окна задайте ширину и высоту окна.
  6. В группе Положение окна задайте положение левого верхнего угла окна.

Примечания

  • XOX
  • Если требуется, чтобы система Windows сама выбрала местоположение окна, следует установить флажок Автоматический выбор.
  • Если текущий размер окна меньше, чем значения, установленные для размера буфера экрана, появляется полоса прокрутки.
  • Не допускается изменение размеров окна до значений, превосходящих установленные для буфера окна.
  • На компьютерах с процессорами x86 при переключении в полноэкранный режим отображается число строк (25, 43 или 50), которое поддерживается оборудованием и которое и наиболее близко соответствует настройке оконного режима.


Изменение параметров редактирования окна командной строки

Чтобы изменить параметры редактирования окна командной строки

  1. XOX
  2. Щелкните правой кнопкой мыши строку заголовка и выполните одно из следующих действий.
    • Чтобы изменить этот параметр для всех окон командной строки, выберите команду По умолчанию.
    • Чтобы изменить этот параметр только для текущего окна командной строки, выберите команду Свойства.
  3. На вкладке Общие в группе Редактирование имеются следующие флажки.
    • Флажок Выделение мышью позволяет использовать мышь, для того чтобы вырезать и вставлять текст в окне командной строки.
    • Флажок Быстрая вставка позволяет вставлять текст, начиная с позиции курсора, причем последующие символы сдвигаются вправо, а не замещаются.
    • Флажок Автозаполнение позволяет использовать клавишу TAB для переключения между доступными элементами в текущем каталоге.

Примечание

  • XOX


Дата компиляции

 Дата компиляции 01.09.2001


Изменение сведений о настройках OS/2

Чтобы изменить настройки OS/2 на компьютере под управлением Windows с отдельным разделом OS/2.

  1. В Windows запустите текстовый редактор OS/2. Чтобы запустить текстовый редактор OS/2 нажмите кнопку Пуск, выберите команду Выполнить, введите путь к файлу и имя файла текстового редактора OS/2 и нажмите кнопку OK.
  2. Откройте файл Config.sys в текстовом редакторе OS/2. Файл Config.sys находится в корневом каталоге жесткого диска.

    3. Операционная система Windows извлекает сведения о настройках из реестра и сохраняет их во временном файле.

  3. Введите сведения о настройках, необходимые для достижения требуемого результата.
  4. Сохраните и закройте файл в текстовом редакторе OS/2.
  5. Закройте текстовый редактор.

    6. Windows запишет обновленные данные в системный реестр.

  6. Завершите работу Windows и перезагрузите компьютер.

Примечания

  • Чтобы указать путь, введите буквенное обозначение диска, двоеточие (:), обратную косую черту (\), затем последовательность имен папок и подпапок, в которых хранится файл, разделяя их обратной косой чертой и, наконец, имя файла или папки, которые следует открыть.
  • Для дополнительных сведений об использовании операционной системы OS/2 текстового редактора OS/2, см. руководство пользователя OS/2.


Изменение значка ярлыка MS-DOS

Чтобы изменить значок ярлыка MS-DOS

  1. Щелкните правой кнопкой ярлык MS-DOS и выберите команду Свойства.
  2. Выберите вкладку Программа (или вкладку Ярлык).
  3. Нажмите кнопку Сменить значок.
  4. В диалоговом окне Сменить значок дважды щелкните новый значок для ярлыка или нажмите кнопку Обзор, чтобы выбрать другой значок.


Создание или изменение PIF-файлов

Чтобы создать или изменить PIF-файлы

Перед созданием или изменением PIF-файла просмотрите документацию к программе MS-DOS. Изменение параметров PIF-файла влияет на взаимодействие программы с Windows. Возможно, данная программа будет правильно работать только с конкретными значениями, заданными по умолчанию.

  1. Откройте папку Мой компьютер.
  2. Выполните одно из следующих действий.
    • Если требуется создать файл описания программы (PIF), найдите программу и щелкните ее правой кнопкой. Затем выберите команду Свойства и измените настройки по умолчанию так, чтобы они удовлетворяли требованиям программы.
    • Если необходимо изменить настройки для существующего PIF-файла, найдите ярлык, указывающий на файл программы, и щелкните его правой кнопкой. Выберите команду Свойства и сделайте требуемые изменения.

Примечания

  • XOX
  • Создание файла описания программы (PIF-файла) для программы MS-DOS приводит к созданию ярлыка, указывающего на исполняемый файл программы. Все параметры, сохраненные в PIF-файле, содержатся и в ярлыке.
  • Выбор между запуском программы MS-DOS в оконном или полноэкранном режиме производится с помощью списка Окно вкладки Программа (или Ярлык).
  • Для ускорения вывода на экран программы MS-DOS после выбора команды Свойства в пункте 2 на вкладке Экран установите флажок Эмуляция функций ПЗУ (Fast ROM) в группе Производительность. Обратитесь к документации видеоадаптера для получения сведений о поддержке эмуляции функций ПЗУ.
  • Кроме того, для увеличения производительности программы MS-DOS ей следует выделить больше оперативной памяти. Для того чтобы это сделать, после выбора команды Свойства в пункте 2 на вкладке Память выберите значение Auto параметров Отображаемая (EMS) память или Дополнительная (XMS) память; ограничение на объем используемой памяти накладываться не будет. Если программа работает с ошибками, установите значение 8192 в окне Всего.
  • Диалоговое окно Свойства заменяет редактор PIF-файлов, который использовался в предыдущих версиях Windows.


Копирование текста из окна командной строки

Чтобы копировать текст из окна командной строки

  1. XOX
  2. Щелкните правой кнопкой заголовок, выберите в контекстном меню команду Изменить, а затем — команду Пометить.
  3. Установите указатель в начало выделяемого текста и нажмите кнопку мыши.
  4. Нажмите и удерживайте клавишу SHIFT, затем щелкните в конце того фрагмента текста, который требуется скопировать (либо нажмите левую кнопку мыши и перетаскивайте указатель, чтобы выделить текст).
  5. Щелкните правой кнопкой мыши заголовок окна, выберите в контекстном меню команду Изменить, а затем команду Копировать.
  6. Установите курсор в то место, куда следует вставить текст.
    • В программе MS-DOS или в окне командной строки щелкните правой кнопкой мыши заголовок окна, выберите команду Изменить, а затем команду Вставить.
    • В программе Windows выберите в меню Правка команду Вставить.

Примечания

  • XOX
  • В окне командной строки или при работе программы MS-DOS в полноэкранном режиме вставка текста из буфера невозможна. XOX


Создание пользовательских файлов загрузки программ MS-DOS

Чтобы создать пользовательские файлы загрузки для программ MS-DOS, требующих особой конфигурации

  1. Отредактируйте файлы Config.nt и Autoexec.nt (находящиеся в systemroot\System32) с помощью текстового редактора, например блокнота.
  2. Сохраните файлы под другими именами.
  3. Щелкните правой кнопкой ярлык программы MS-DOS и выберите команду Свойства.
  4. Щелкните вкладку Программа и нажмите кнопку Дополнительно.
  5. В группе Пользовательские файлы инициализации MS-DOS введите новые имена для пользовательских файлов загрузки.

Примечания

  • Данная процедура может потребоваться в силу того, что некоторые программы MS-DOS используют особые инструкции для управлению памятью или видеоадаптером или требуют перед первым запуском установки других программ. Перед созданием файлов загрузки рекомендуется изучить документацию к программе.
  • Для получения инструкций о создании ярлыков воспользуйтесь документацией, поставляемой вместе с программой MS-DOS. XOX
  • Эта возможность доступна не для всех программ MS-DOS.
  • Для применения пользовательских файлов загрузки при запуске программы MS-DOS необходимо запускать программу с помощью ее ярлыка.
  • Создание файла-описателя программы (PIF-файла) для программы MS-DOS приводит к созданию ярлыка, указывающего на исполняемый файл программы. Все параметры, сохраненные в PIF-файле, содержатся и в ярлыке.


Вывод справки для команды MS-DOS

Чтобы выводить справку для команды MS-DOS

  1. XOX
  2. Введите в командную строку нужную команду, а затем введите символ /?.

    3. Например, введите chdir /? для вывода справки о команде chdir.

Примечания

  • XOX
  • Чтобы выводить справочную информацию с паузами между экранами, следует поместить в конец командной строки параметр | more. Например, введите dir /? | more для вывода справки о команде dir.


Установка эмуляции совместимого аппаратного таймера

Чтобы установить эмуляцию совместимого аппаратного таймера

  1. Откройте папку Мой компьютер.
  2. Найдите программу MS-DOS (файл .exe), файл описания программы (PIF) или ярлык, который требуется изменить.
  3. Щелкните правой кнопкой имя файла программы или значок ярлыка, выберите команду Свойства, щелкните вкладку Программа и нажмите на кнопку Дополнительно.
  4. В диалоговом окне Настройки PIF Windows установите флажок Эмуляция совместимого аппаратного таймера.

Примечания

  • XOX
  • Эмуляция совместимого аппаратного таймера позволяет снизить частоту сигналов таймера компьютера при выполнении программ MS-DOS. Чем выше быстродействие процессора (200 мегагерц (МГц), 300 МГц, и т. д.), тем быстрее передаются сигналы между аппаратным обеспечением и программами, что позволяет программам Windows работать эффективнее.
  • Большинство программ для MS-DOS разрабатывались без расчета на быстрые процессоры. Если программа MS-DOS при установке задает слишком высокую частоту, она может не заработать. Установите этот флажок только после изучения документации к программе. Установка данного флажка без необходимости может повлечь снижение скорости выполнения программы и неправильное вычисление времени.
  • Каждый ярлык соответствует файлу описания программы (PIF).
  • Данный параметр доступен не для всех программ MS-DOS.


Скрытие указателя мыши в программе MS-DOS

Чтобы скрыть указатель мыши в программе MS-DOS, не требующей использования мыши

  • Изучите документацию, поставляемую с программой MS-DOS, чтобы выяснить, поддерживает ли данная программа перетаскивание или другие действия, выполняемые с помощью мыши. Если нет, щелкните правой кнопкой мыши заголовок окна MS-DOS, чтобы отобразить меню и выберите команду Скрыть указатель мыши.

Примечания

  • Если в программе происходят переключения текстового и графического режимов, указатель может появиться вновь.
  • Если указатель мыши скрыт, он не отображается ни внутри, ни вне окна программы. Чтобы отобразить указатель мыши, в окне командной строки нажмите комбинацию клавиш ALT+ПРОБЕЛ и выберите в контекстном меню команду Показать указатель мыши.
  • Данный параметр доступен не для всех программ MS-DOS.


Выделение системных ресурсов для программы MS-DOS

Чтобы выделить системные ресурсы для программы MS-DOS и изменить время ее простоя

  1. Откройте папку Мой компьютер.
  2. Найдите программу MS-DOS (файл .exe), файл описания программы (PIF) или ярлык, который требуется изменить. Имя нужного файла см. в документации, поставляемой вместе с программой.
  3. Щелкните значок правой кнопкой мыши и выберите команду Свойства.
  4. В окне Свойства щелкните вкладку Разное.
  5. Переместите ползунок Приоритет при ожидании для получения нужного результата.
    • Чтобы выделить программе в фоновом режиме больше ресурсов процессора, передвиньте ползунок в сторону Низкий.
    • Чтобы уменьшить выделяемые программе ресурсы процессора, передвиньте ползунок в сторону Высокий.

Примечания

  • XOX
  • Кроме того, имеется возможность указывать период в течение которого программа MS-DOS будет находиться в режиме ожидания, прежде чем ей будет уменьшено выделение ресурсов; освобожденные ресурсы смогут использоваться другими программами.
  • Эта возможность доступна не для всех программ MS-DOS.
  • Создание файла описания программы (PIF-файла) для программы MS-DOS приводит к созданию ярлыка, указывающего на исполняемый файл программы. Все параметры, сохраненные в PIF-файле, содержатся и в ярлыке.


Общие сведения о MS-DOS

MS-DOS (расшифровывается как дисковая операционная система Microsoft) является операционной системой с интерфейсом командной строки, которая используется на персональных компьютерах. Как и в других операционных системах, например в OS/2, MS-DOS преобразует ввод с клавиатуры в команды, организует такие действия, как запись и чтение с дисков, вывод на экран, управление с помощью клавиатуры и множество других внутренних операций, обеспечивающих выполнение программ и организацию файлов.

Команды MS-DOS вводятся в окне командной строки. Для завершения сеанса MS-DOS введите exit в окне командной строки в позиции мерцающего курсора.

Режим MS-DOS — это оболочка, в которой в 32-битных системах, таких, как Windows, эмулируется среда MS-DOS. Программы MS-DOS могут работать под Windows, а также создавать файл описания программы (PIF), который появляется в виде ярлыка на рабочем столе.

XOX

Примечания

  • XOX
  • Создание файла описания программы (PIF-файла) для программы MS-DOS приводит к созданию ярлыка, указывающего на исполняемый файл программы. Все параметры, сохраненные в PIF-файле, содержатся и в ярлыке.


Запуск резидентной программы в окне

Чтобы запустить резидентную программу в окне

  1. Запустите резидентную программу (TSR); сведения о процедуре запуска см. в поставляемой с программой документации.
  2. Программа может отображаться в виде командной строки или с интерфейсом пользователя — так, как это описано в ее документации.
  3. Нажмите комбинацию клавиш ALT+ENTER для отображения программы в окне или для отображения ее интерфейса пользователя по умолчанию.

Примечания

  • Резидентная программа определяет сочетание клавиш, которое запускает ее в окне. Некоторые программы MS-DOS не могут выполняться в окне.
  • Резидентными программами могут быть, например, календари, калькуляторы, программы проверки орфографии и тезаурусы, предназначенные для работы в MS-DOS.
  • Для переключения между оконным или полноэкранным режимом в программах MS-DOS используется сочетание клавиш ALT+ENTER.
  • В Windows имеется возможность простого переключения между резидентными программами и стандартными программами Windows.
  • Если комбинация клавиш резидентной программы зарезервирована в системе Windows, щелкните ссылку См. также.


Копирование и вставка текста MS-DOS при помощи мыши

Чтобы скопировать и вставить текст MS-DOS при помощи мыши

  1. XOX
  2. Щелкните правой кнопкой заголовок, затем выберите команду Свойства.
  3. На вкладке Общие, в группе Редактирование, установите флажок Выделение мышью, если он не был уже установлен и нажмите кнопку OK.
  4. В диалоговом окне Изменение свойств ярлыка выберите один из перечисленных параметров
    5. :
    • Изменить свойства только текущего окна, чтобы режим выделения мышью использовался только в текущем окне;
    • Изменить ярлык для запуска этого окна, чтобы режим выделения мышью включался при каждом запуске программы MS-DOS.
    Нажмите кнопку OK.
  5. Нажмите кнопку мыши и перетащите указатель, выделив текст, который необходимо скопировать в окно командной строки.
  6. Поместите курсор в то место, куда следует вставить текст и выполните одно из следующих действий.
    • В программе MS-DOS откройте оконное меню и выберите в команду Изменить, а затем команду Вставить.
    • Для программы Windows выберите в меню Правка команду Вставить.

Примечания

  • XOX
  • Режим выделения мышью доступен не для всех программ MS-DOS.
  • В окне командной строки или при работе программы MS-DOS в полноэкранном режиме вставка текста из буфера невозможна.


Резервирование сочетаний клавиш для программ MS-DOS

Чтобы резервировать сочетания клавиш для программ MS-DOS

  1. Откройте папку Мой компьютер.
  2. Найдите программу MS-DOS (файл .exe), файл описания программы (PIF) или ярлык, который требуется изменить. Щелкните интерфейс правой кнопкой мыши и выберите команду Свойства.
  3. Выберите вкладку Разное в диалоговом окне Свойства.
  4. В группе Сочетания клавиш, отведенные для операционной системы Windows снимите флажки, стоящие рядом с сочетаниями клавиш, которые используются программой MS-DOS. Сочетание клавиш, флажок которого был очищен, будет игнорироваться системой Windows при использовании данной программы MS-DOS.

    5. Для программы MS-DOS могут резервироваться только перечисленные ниже сочетания клавиш.

    • ALT+TAB
    • ALT+ESC
    • CTRL+ESC
    • PRINT SCREEN
    • ALT+PRINT SCREEN
    • ALT+ENTER
    • ALT + ПРОБЕЛ

Примечания

  • XOX
  • Эта возможность доступна не для всех программ MS-DOS.
  • Некоторые программы MS-DOS используют сочетания клавиш (одновременное нажатие нескольких клавиш) для выполнения определенных функций.
  • Возможно, понадобиться зарезервировать сочетания клавиш для программ MS-DOS, если в этой программе используются те же сочетания клавиш, что и в Windows. Например, если программа MS-DOS использует сочетание клавиш ALT+TAB для некоторой команды, Windows может перехватить данную команду и переключиться в другое окно. (В Windows для переключения между программами используется сочетание клавиш ALT+TAB.)


Запуск резидентной программы из другой программы

Чтобы запустить резидентную программу из другой программы

  1. Запустите резидентную программу (TSR); сведения о процедуре запуска см. в поставляемой с программой документации.
  2. Запустите другую программу в том же окне путем ввода имени команды в командной строке и нажатия клавиши ENTER.

Примечания

  • Существует способ запуска резидентных программ совместно с другими программами путем создания пакетного файла, который запускает обе программы, и создания ярлыка, указывающего на пакетный файл.
  • Резидентными программами могут быть, например, календари, калькуляторы, программы проверки орфографии и тезаурусы.
  • Чтобы резидентная программа оставалась активной все время использования Windows, запустите ее в отдельном окне. В данное окно можно будет переключаться в любое время, точно так же, как и в окно любой другой программы.


Задание пользовательских файлов загрузки для программ MS-DOS

Чтобы задать пользовательские файлы загрузки для программ MS-DOS

Перед выполнением данного действия обратитесь к документации, поставляемой вместе с данной программой MS-DOS.

  1. Откройте папку Мой компьютер.
  2. Найдите файл программы MS-DOS (.exe файл), файл описания программы (PIF) или ярлык, который требуется изменить.
  3. Щелкните правой кнопкой мыши файл программы (.exe файл), файл описания программы или ярлык, затем выберите команду Свойства.
  4. Щелкните вкладку Программа.
  5. В поле Командная строка введите имя программы.
  6. Щелкните вкладку Дополнительно.
  7. Введите имена вновь созданных пользовательских файлов загрузки.

Примечания

  • XOX
  • Данный параметр доступен не для всех программ MS-DOS.
  • Создание файла описания программы (PIF-файла) для программы MS-DOS приводит к созданию ярлыка, указывающего на исполняемый файл программы. Все параметры, сохраненные в PIF-файле, содержатся и в ярлыке. В Windows PIF-файлы отображаются в виде ярлыков.


Задание сочетаний клавиш

Чтобы задать сочетания клавиш для программ

Перед выполнением данной процедуры обратитесь к документации, поставляемой вместе с программой, чтобы убедиться в том, что ярлык был установлен.

  1. Откройте папку Мой компьютер.
  2. Найдите файл программы (.exe-файл) или значок ярлыка программы. Щелкните значок файла или ярлыка правой кнопкой мыши и выберите команду Свойства.
  3. Щелкните вкладку Программа, в случае программы MS-DOS, или вкладку Ярлык, в случае программы Windows.
  4. Поместив курсор в поле Быстрый вызов, выберите клавишу, которую следует использовать в сочетании с клавишами CTRL+ALT. Это сочетание автоматически включает клавиши CTRL+ALT. В поле Быстрый вызов будет отображаться значение нет до тех пор, пока не будет выбрана клавиша; после этого в поле будет отображаться значение Ctrl+Alt+ выбранная клавиша. В сочетаниях нельзя использовать клавиши ESC, ENTER, TAB, ПРОБЕЛ, SHIFT, PRINT SCREEN и BACKSPACE.

Примечания

  • XOX
  • После того как определенной программе было назначено сочетание клавиш для быстрого вызова, данное сочетание не может использоваться для других программ. Для получения списка сочетаний клавиш, используемых в Windows, щелкните ссылку См. также.
  • Если сочетание клавиш было забыто, выполните пункты 2 и 3, чтобы просмотреть назначенные сочетания клавиш.
  • Использование сочетаний клавиш для открытия программ может оказаться более простым, чем открытие программ при помощи указывающего устройства, особенно на переносных компьютерах.


Открытие программы MS-DOS из окна командной строки

Чтобы открыть программу MS-DOS из окна командной строки

  1. XOX
  2. Введите имя установленной программы MS-DOS, которую требуется открыть, затем нажмите клавишу ENTER. Или перейдите в каталог, в котором находится программа, и введите ее имя там.

Примечания

  • XOX
  • Переключение между полноэкранным и оконным режимами работы производится с помощью клавиш ALT+ENTER.
  • Для завершения сеанса командной строки введите exit в позиции мерцающего курсора окна командной строки.


Создание двух ярлыков для одной программы MS-DOS

Чтобы создать два ярлыка для одной программы MS-DOS

  1. Откройте папку Мой компьютер.
  2. Найдите файл программы MS-DOS (.exe файл), файл описания программы (PIF) или ярлык, который требуется изменить.
  3. Щелкните правой кнопкой мыши файл и выберите команду Создать ярлык. Создайте два ярлыка с разными именами для программы MS-DOS. Если ярлык уже существует, сохраните новый ярлык с новым именем.
  4. Для каждого созданного ярлыка введите нужные параметры в диалоговом окне Свойства; для получения сведений о требуемых параметрах, обратитесь к документации, поставляемой вместе с программой MS-DOS.

Примечания

  • XOX
  • Создание различных PIF-файлов для ярлыков, указывающих на программы MS-DOS позволяет сохранять разные параметры и разное форматирование, которые будут автоматически применяться при запуске программы с помощью ярлыка.


Использование PIF-файлов

Файл описания программы (PIF-файл) создается всякий раз, когда создается ярлык программы MS-DOS или изменяются ее свойства, установленные по умолчанию. PIF-файлы позволяют для программ MS-DOS задавать свойства по умолчанию, например размер шрифта, цвета экрана и выделяемая память.

При изменении параметров программы MS-DOS автоматически создается PIF-файл. Установленные параметры будут использоваться при каждом запуске программы с помощью двойного щелчка ее значка. При запуске программы непосредственно из окна командной строки эти параметры не будут использоваться.

Создание файла описания программы (PIF-файла) для программы MS-DOS приводит к созданию ярлыка, указывающего на исполняемый файл программы. Все параметры, сохраненные в PIF-файле, содержатся и в ярлыке. В Windows PIF-файлы отображаются в виде ярлыков.