Установщик Windows

Установщик Windows упрощает управление процессом установки и удаления программного обеспечения, а также изменением, восстановлением и объявлением существующих приложений.

  • Перед использованием установщика Windows ознакомьтесь с разделом Контрольный список: настройка установщика Windows.
  • Советы по использованию установщика Windows содержатся в разделе Советы и рекомендации.
  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Общие сведения см. в разделе Основные понятия.
  • Инструкции по устранению неполадок содержатся в разделе Устранение неполадок.


Контрольный список: настройка установщика Windows

Действие | Справочные сведения
Ознакомьтесь с основными понятиями об установке программ, групповой политике и об Active Directory. | Active Directory — Пользователи и компьютеры; Основные сведения о групповой политике; Оснастка «Установка программ»
Настройте групповую политику в организации. | Контрольный список: применение групповой политики в Active Directory
Запустите групповую политику для применения к узлу, домену или организационному подразделению, пользователи и компьютеры которого должны получить программное обеспечение. | Создание групповой политики; Пути создания оснастки «Групповая политика»
Получите пакеты установщика Windows (MSI) для программного обеспечения. | Обратитесь к поставщику программного обеспечения
Создание узла «Установка программ». | Создание узла «Установка программ»


Советы и рекомендации

  • Определите категории приложений для организации.
    Использование категорий упростит пользователям нахождение приложений в компоненте «Установка и удаление программ» на панели управления. Дополнительные сведения см. в разделе Определение категорий для развернутых приложений.
  • Помните, что преобразования применяются во время развертывания.
    Преобразования (MST-файлы) представляют собой настройки, применимые к пакетам установщика Windows. Преобразования применяются во время назначения или публикации, но не во время установки. На практике это означает, что до нажатия клавиши OK необходимо проверить правильность выбора параметров на вкладке Модификации в диалоговом окне свойств пакета. В противном случае может быть развернут неправильно преобразованный пакет, что потребует либо удаления и повторного развертывания программного обеспечения, либо его обновления с использованием правильно преобразованной версии. Сведения о том, как это сделать, см. в разделах Удаление управляемого приложения и Обновление управляемого приложения.
  • Назначайте и публикуйте пакеты установки в объекте групповой политики только один раз.
    Пакет установщика Windows должен быть назначен или опубликован в одном объекте групповой политики не более одного раза. Например, пакет Microsoft Office может быть назначен для компьютеров, управляемых объектом групповой политики, но не назначен или не опубликован для пользователей, управляемых этим объектом.
  • Используйте преимущества средств разработки.
    Разработчики, знакомые с файлами, записями реестра и другими требованиями для правильной работы приложения, могут создать простые пакеты установщика Windows, используя доступные средства от различных поставщиков программного обеспечения.
  • Изменяйте пакеты существующего программного обеспечения.
    С помощью средств, поставляемых коммерческими поставщиками, можно создавать пакеты установщика Windows для программного обеспечения, изначально не содержащего MSI-файлы. Эти пакеты сравнивают состояние компьютера до и после установки. Для получения наилучших результатов выполните установку новой копии.
  • Используйте System Management Server и DFS.
    Microsoft Systems Management Server и распределенная файловая система (Distributed File System — DFS) Windows полезны для управления точками распространения программного обеспечения (общими ресурсами сети, из которых пользователи устанавливают управляемое программное обеспечение).
  • Выполняйте назначение или публикацию на высоком уровне иерархии Active Directory.
    Используйте наследование для распространения приложений внутри организации. Для улучшения контроля над пользователями, получившими программное обеспечение, используйте «описатели защиты» (записи управления доступом) в объекте групповой политики. Дополнительные сведения см. в разделе Использование групп безопасности для фильтрации групповой политики.

    Примечания

    • Для выполнения установки программного обеспечения из точек распространения группа Прошедшие проверку должна иметь записи управления доступом Чтение и Применение групповой политики.
    • Для управления программным обеспечением группа Администраторы должна иметь Полный доступ.
  • Используйте свойства установки программ для расширения возможностей управления.
    Щелкните правой кнопкой узел Установка программ в дереве консоли групповой политики и выберите команду Свойства.

    Где?

    • применимое имя политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программ

    • Это упростит административный процесс назначения или публикации большого числа пакетов с одинаковыми свойствами в одном объекте групповой политики, например при публикации всего программного обеспечения из одной точки распространения.

  • Используйте свойства пакета установщика Windows для улучшения управления.
    Перейдите к узлу «Установка программ», как указано выше, щелкните правой кнопкой нужный пакет в области сведений и выберите команду Свойства. Используйте эту процедуру для назначения и публикации отдельных пакетов.


Инструкции

  • Использование пакетов установщика Windows совместно с проводником
  • Использование пакетов установщика Windows со служебной программой «Установка и удаление программ»
  • Использование установщика Windows из командной строки
  • Настройка групповой политики для установщика Windows


Использование пакетов установщика Windows совместно с проводником

Рисунок Microsoft Windows

Чтобы использовать пакеты установщика Windows совместно с проводником

  1. Откройте проводник Windows.
  2. Щелкните правой кнопкой пакет установщика Windows (MSI-файл) и выберите команду Установить, Восстановить или Удалить.

Примечание

  • XOX.

См. также


Использование пакетов установщика Windows со служебной программой «Установка и удаление программ»

Рисунок Microsoft Windows

Чтобы использовать пакеты установщика Windows со служебной программой «Установка и удаление программ»

  1. На панели управления откройте компонент Установка и удаление программ.
  2. Нажмите кнопку Изменение или удаление программ и выделите программу, которую требуется заменить или удалить.
  3. Чтобы заменить программу, нажмите кнопку Заменить.
  4. Чтобы удалить программу, нажмите кнопку Удалить.

Примечание

  • XOX

См. также


Использование установщика Windows из командной строки

  • Установка пакета с использованием командной строки
  • Удаление пакета с использованием командной строки
  • Восстановление пакета с использованием командной строки
  • Объявление пакета с использованием командной строки
  • Создание административного пакета установки из командной строки
  • Создание файла журнала установки с помощью командной строки
  • Установка преобразования с использованием командной строки
  • Установка и объявление продукта с преобразованием при помощи командной строки


Установка преобразования с использованием командной строки

Рисунок Microsoft Windows

Чтобы установить преобразование с использованием командной строки

  1. Откройте окно Командная строка.
  2. Введите msiexec /i пакет TRANSFORMS=список преобразований и нажмите клавишу ENTER.

    3. Здесь:

    i — установка продукта;

    TRANSFORMS — свойство, используемое для указания файлов преобразования (MST), которые следует применить к пакету. Представляет собой список путей через точку с запятой;

    пакет — имя файла пакета установщика Windows (MSI).

Дополнительные сведения см. в разделе «Установка и объявление продукта с преобразованием при помощи командной строки».

Примечания

  • XOX.
  • Регистр символов при вводе параметров командной строки установщика Windows не учитывается.
  • Для получения дополнительных сведений о параметрах командной строки щелкните ссылку «См. также».

См. также


Установка и объявление продукта с преобразованием при помощи командной строки

Рисунок Microsoft Windows

Чтобы установить и объявить продукт с преобразованием при помощи командной строки

  1. Откройте окно Командная строка.
  2. Введите в командной строке msiexec пакет /j[u][m] /t список преобразований и нажмите клавишу ENTER.

    3. Здесь:

    j — объявление продукта. Этот параметр игнорирует любые значения свойств, введенные в командной строке.

    u — объявление для текущего пользователя.

    m — объявление для всех пользователей этого компьютера.

    t — применение преобразований к объявляемым пакетам.

    пакет — имя файла пакета установщика Windows.

Дополнительные сведения см. в разделе «Объявление пакета с использованием командной строки».

Примечания

  • XOX.
  • Регистр символов при вводе параметров командной строки установщика Windows не учитывается.
  • Для получения дополнительных сведений о параметрах командной строки щелкните ссылку «См. также».

См. также


Установка пакета с использованием командной строки

Рисунок Microsoft Windows

Чтобы установить пакет с использованием командной строки

  1. Откройте окно Командная строка.
  2. Введите в окне команд msiexec /i [пакет|код_продукта] и нажмите клавишу ENTER.

    3. Здесь:

    пакет — имя файла пакета установщика Windows;

    код_продукта — глобальный уникальный идентификатор (GUID) пакета установщика Windows.

Примечания

  • XOX.
  • Регистр символов при вводе параметров командной строки установщика Windows не учитывается.
  • Для получения дополнительных сведений о параметрах командной строки щелкните ссылку «См. также».

См. также


Удаление пакета с использованием командной строки

Рисунок Microsoft Windows

Чтобы удалить пакет с использованием командной строки

  1. Откройте окно Командная строка.
  2. Введите msiexec /x [пакет|КодПродукта] и нажмите ENTER.

    3. Здесь:

    пакет — имя файла пакета установщика Windows;

    КодПродукта — глобальный уникальный идентификатор (GUID) пакета установщика Windows.

Примечания

  • XOX.
  • Регистр символов при вводе параметров командной строки установщика Windows не учитывается.
  • Для получения дополнительных сведений о параметрах командной строки щелкните ссылку «См. также».

См. также


Восстановление пакета с использованием командной строки

Рисунок Microsoft Windows

Чтобы восстановить пакет с использованием командной строки

  1. Откройте окно Командная строка.
  2. Введите в окне команд msiexec /f[p][o][e][d][c][a][u][m][s][v] {пакет|КодПродукта} и нажмите клавишу ENTER.

    3. Здесь:

    /f — включение одного или нескольких следующих параметров командной строки:

    p — переустановка только в случае отсутствия файла;

    o — переустановка в случае отсутствия файла или если установлена старая его версия;

    o — переустановка в случае отсутствия файла или если файл одинаков с устанавливаемым, или если установлена старая его версия;

    o — переустановка в случае отсутствия файла или если установлена другая его версия;

    c — переустановка в случае отсутствия файла или в случае, если контрольная сумма не совпадает с вычисленным значением;

    a — принудительная переустановка всех файлов;

    u — перезапись всех необходимых пользовательских записей реестра;

    m — перезапись всех необходимых компьютерных записей реестра;

    s — замена всех существующих ярлыков;

    v — запуск файлов из источника и новое кэширование локального пакета;

    пакет — имя файла пакета установщика Windows;

    КодПродукта — глобальный уникальный идентификатор (GUID) пакета установщика Windows.

Примечания

  • XOX.
  • Регистр символов при вводе параметров командной строки установщика Windows не учитывается.
  • Параметром по умолчанию для этой командной строки является параметр /fpecms.
  • Для получения дополнительных сведений о параметрах командной строки щелкните ссылку «См. также».

См. также


Объявление пакета с использованием командной строки

Рисунок Microsoft Windows

Чтобы объявить пакет с использованием командной строки

  1. Откройте окно Командная строка.
  2. Введите в окне команд msiexec /j[u][m] пакет и нажмите клавишу ENTER.

    3. Здесь:

    u — объявление для текущего пользователя;

    m — объявление для всех пользователей данного компьютера;

    пакет — имя файла пакета установщика Windows.

Примечания

  • XOX.
  • При необходимости установить приложение с повышенными привилегиями используйте параметр /jm.
  • Регистр символов при вводе параметров командной строки установщика Windows не учитывается.
  • Для получения дополнительных сведений о параметрах командной строки щелкните ссылку «См. также».

См. также


Создание административного пакета установки из командной строки

Рисунок Microsoft Windows

Чтобы создать административный пакет установки из командной строки

  1. Откройте окно Командная строка.
  2. Введите msiexec /a пакет и нажмите клавишу ENTER.

    3. Здесь:

    пакет — имя файла пакета установщика Windows.

Примечания

  • XOX.
  • Регистр символов при вводе параметров командной строки установщика Windows не учитывается.
  • Для получения дополнительных сведений о параметрах командной строки щелкните ссылку «См. также».

См. также


Создание файла журнала установки с помощью командной строки

Рисунок Microsoft Windows

Чтобы создать файл журнала установки с помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите в окне команд msiexec /i пакет [/L][i][w][e][a][r][u][c][m][p][v][+][!] файл_журнала.txt и нажмите кнопку ENTER.

    3. Здесь:

    пакет — имя пакета установщика Windows.

    /L — запись данных в журнал. Следующие флажки определяют сведения, сохраняемые в журнале:

    i — сообщения состояния;

    w — некритические предупреждения;

    e — все сообщения об ошибках;

    a — запуски действий;

    r — записи, специфические для действия;

    u — запросы пользователя;

    c — начальные параметры интерфейса пользователя;

    m — нехватка памяти;

    p — свойства терминала;

    v — подробный вывод;

    + — добавление в существующий файл;

    ! — открывать каждую строку в журнале;

    * — подстановочный знак, записывает в журнал все сведения, кроме параметра v;

    файл_журнала.txt — имя и путь к текстовому файлу журнала.

Примечания

  • XOX.
  • Регистр символов при вводе параметров командной строки установщика Windows не учитывается.
  • Чтобы включить в файл журнала параметр v при использовании подстановочного знака, введите в командной строке /L*v.
  • Параметры файла журнала установщика Windows могут также использоваться для процессов удаления и восстановления.
  • Для получения дополнительных сведений о параметрах командной строки щелкните ссылку «См. также».

См. также


Настройка групповой политики для установщика Windows

  • Настройка компьютерных параметров групповой политики установщика Windows
  • Настройка пользовательских параметров групповой политики установщика Windows


Настройка компьютерных параметров групповой политики установщика Windows

Рисунок Microsoft Windows

Чтобы настроить компьютерные параметры групповой политики установщика Windows

  1. Откройте оснастку Групповая политика.
  2. В дереве консоли щелкните узел Установщик Windows.

    3. Где?

    • применимое имя политики
    • Конфигурация компьютера
    • Административные шаблоны
    • Компоненты Windows
    • Установщик Windows
  3. В области сведений дважды щелкните одну из следующих политик:
    • Запрет использования установщика Windows
    • Всегда производить установку с повышенными привилегиями
    • Запретить откат
    • Запретить диалоговое окно обзора нового источника
    • Запретить применение пакетов исправлений
    • Отключить запрос безопасности IE для сценариев Windows Installer
    • Разрешить пользователям изменять параметры установки
    • Разрешить обзор источника при повышенных привилегиях
    • Разрешить использование носителей при повышенных привилегиях
    • Разрешить применение пакетов исправлений во время привилегированных установок
    • Разрешить администраторам выполнение установки в сеансе сервера терминалов
    • Кэшировать файлы трансформации в безопасном месте на рабочей станции
    • Запретить установки для пользователей
    • Отключить создание контрольных точек восстановления системы
    • Ведение журнала
  4. В диалоговом окне Свойства выберите нужные параметры и нажмите кнопку OK.

Примечания

  • Чтобы открыть оснастку «Групповая политика» для редактирования объекта локальной групповой политики, нажмите кнопку Пуск, выберите команду Выполнить, введите gpedit.msc и нажмите клавишу ENTER.
  • Для получения дополнительных сведений о компьютерных параметрах групповой политики установщика Windows щелкните ссылку «См. также».
  • Для получения дополнительных сведений о запуске групповой политики щелкните ссылку «См. также».

См. также


Настройка пользовательских параметров групповой политики установщика Windows

Рисунок Microsoft Windows

Чтобы настроить пользовательские параметры групповой политики установщика Windows

  1. Откройте оснастку Групповая политика.
  2. В дереве консоли щелкните узел Установщик Windows.

    3. Где?

    • применимое имя политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Компоненты Windows
    • Установщик Windows
  3. В области сведений дважды щелкните одну из следующих политик:
    • Всегда производить установку с повышенными привилегиями
    • Порядок поиска
    • Запретить откат
    • Запретить использование съемных носителей при установке
  4. В диалоговом окне Свойства выберите необходимые параметры и нажмите кнопку OK.

Примечания

  • Чтобы открыть оснастку «Групповая политика» для редактирования объекта локальной групповой политики, нажмите кнопку Пуск, выберите команду Выполнить, введите gpedit.msc и нажмите клавишу ENTER.
  • Для получения дополнительных сведений о пользовательских параметрах групповой политики установщика Windows щелкните ссылку «См. также».
  • Для получения сведений о запуске групповой политики щелкните ссылку «См. также».

См. также


Основные понятия

Этот раздел содержит общие сведения об установщике Windows.

  • Общие сведения об установщике Windows
  • Общее представление об установщике Windows
  • Использование установщика Windows
  • Ресурсы


Общие сведения об установщике Windows

Установщик Windows является компонентом операционной системы Windows и предназначен для упрощения процесса установки приложений.

Он управляет установкой и удалением приложений, применяя набор определенных правил. Эти правила определяют установку и настройку установленного приложения. Кроме того, эту службу можно использовать для изменения, восстановления или удаления существующих приложений. Установщик Windows включает в себя службу установщика Windows для операционных систем Windows и формат файлов пакета (MSI), используемый для хранения сведений об установке и настройке приложений.

Установщик Windows также является расширяемой системой управления программным обеспечением. Он управляет установкой, добавлением и удалением компонентов программ, следит за устойчивостью файлов и осуществляет базовое аварийное восстановление путем отката. Установщик Windows поддерживает установку и запуск программного обеспечения из нескольких источников и может быть настроен разработчиками для установки пользовательских приложений.


Общее представление об установщике Windows

В этом разделе

  • Возможности установщика Windows
  • Технологии установщика Windows


Возможности установщика Windows

С помощью установщика Windows и пакетных файлов формата .msi установка и удаление программного обеспечения становятся более надежными и гибкими, обеспечивая более широкий набор установочных параметров. Установщик Windows позволяет выполнять следующие задачи.

  • Восстановление состояния компьютера после сбоя установки. Установщик Windows продолжает записывать все изменения в системе во время установки приложения. В случае сбоя установки установщик Windows может восстановить или вернуть систему в исходное состояние.
  • Помощь в предотвращении определенных форм конфликта между приложениями. Установщик Windows назначает правила установки, которые помогают предотвратить конфликты с общими ресурсами в существующих приложениях. Такие конфликты могут возникать при попытке программы установки обновить или удалить общие с существующим приложением библиотеки динамической компоновки (.dll).
  • Надежное удаление существующих программ. Установщик Windows может надежно удалить любую ранее установленную им программу. Удаляются все связанные с ней записи реестра и все файлы, кроме тех, которые являются общими с другим программным обеспечением. После удачной установки приложения, его можно удалить в любое время. (Удаление не следует путать с откатом, который восстанавливает исходное состояние компьютера при сбое установки.)
  • Диагностика и восстановление поврежденных приложений. Для проверки наличия в установленных приложениях поврежденных файлов или отсутствия файлов эти приложения могут послать запрос установщику Windows. Если такие файлы будут найдены, то установщик Windows восстановит приложение, скопировав только те файлы, которые будут определены как отсутствующие или поврежденные.
  • Поддержка установки средств приложения по требованию. Установщик Windows можно настроить на исходную установку минимального набора возможностей приложения. В дальнейшем дополнительные компоненты могут быть автоматически установлены при попытке пользователя получить доступ к тем возможностям приложения, для которых нужны эти компоненты. Эту возможность называют объявлением. Например, установщик Windows может установить Microsoft Word с минимальным набором возможностей. При первой попытке доступа пользователя к функции слияния (не включенной в исходную установку), установщик Windows автоматически установит компонент слияния. Точно так же установщик Windows удаляет компоненты, не используемые в приложении. Например, можно настроить установщик Windows на удаление компонента слияние, если он не будет использоваться более 60 дней.
  • Поддержка автоматической установки приложений. Пакеты установки можно настроить так, чтобы не прерывать процесс установки по требованию пользователя. Во время процесса установки установщик Windows может запросить атрибуты рабочего стола, включая определения того, были ли любые приложения установлены установщиком Windows.
  • Поддержка 32-разрядных и 64-разрядных приложений. Допускается установка 32-разрядных приложений на 64-разрядные компьютеры.
  • Поддержка технологии .NET. Microsoft .NET Framework представляет новую платформу для разработки интегрированных приложений, ориентированных на службы. Такие приложения могут получать информацию и взаимодействовать с разнообразными источниками вне зависимости от используемых типов компьютеров и языков. Технология .NET Framework и общая языковая среда выполнения позволяет разрабатывать приложения, которые будучи однажды написанными и скомпилированными, могут выполняться в любой среде. Конкретно, .NET обеспечивает повторное использование программных кодов, специализацию кодов, управление ресурсами, многоязычную среду разработки, безопасность, развертывание и администрирование. Архитектура .NET разделяет компоненты приложений. В результате приложение всегда загружает компоненты, с которыми оно было разработано и протестировано. Если приложение выполняется после установки, то оно будет выполняться всегда. Исключается неверная работа приложений, вызванная заменой первоначальных библиотек .dll на файлы .dll, разработанные для более поздних версий.
  • Интеграция с сосуществованием компонентов. Это средство исключает конфликты версий библиотек .dll, позволяя привязывать приложение к версии компонента, с которой оно было разработано и протестировано, вне зависимости от компьютера, на котором размещается приложение. Сосуществование компонентов поддерживает одновременное выполнение нескольких версий каждого компонента.
  • Интегрирование с политиками ограничения программ. Это средство обеспечивает защиту от вирусов, в том числе защиту от троянцев и червей, распространяющихся через Интернет и электронную почту. Политики ограничения программ делают безопасным простой контекст работы с помощью мыши. Групповая политика реализует эти политики через списки доверенных приложений, а установщик Windows работает с приложениями, разрешенными в политиках ограничения программ.


Технологии установщика Windows

Технологии установщика Windows делятся на две части, которые работают совместно: клиентская служба установщика (Msiexec.exe) и файл пакета (с расширением MSI). Для установки приложения установщик Windows использует сведения, содержащиеся в файле пакета.

Служба установщика
Установщик Windows — это служба операционной системы, которая позволяет ей управлять процессом установки.
Программа установщика
Программа Msiexec.exe является компонентом установщика Windows. Она использует библиотеку динамической компоновки Msi.dll для чтения файлов пакетов (MSI), применения преобразований и использует параметры командной строки. Установщик выполняет все задачи, связанные с установкой: копирует файлы на жесткий диск, вносит изменения в реестр, создает ярлыки на рабочем столе и выводит диалоговые окна для запроса пользовательских предпочтений.

После установки установщика Windows возможности сопоставления файлов операционной системой изменяются для распознавания MSI-файлов. По двойному щелчку файла с расширением MSI операционная система сопоставляет этот файл с установщиком Windows и запускает приложение Msiexec.exe.

Файл пакета установки
Каждый файл пакета (MSI) содержит базу данных реляционного типа, в которой хранятся все инструкции и данные, необходимые для установки (или удаления) программы различными путями. Например, файл пакета может содержать инструкции по установке приложения, предыдущая версия которого уже установлена. Он может также содержать инструкции по установке приложения, которое еще не было установлено.

Поскольку база данных является реляционной, изменения, внесенные в одной таблице, автоматически распространяются на всю базу. Это очень удобно для внесения необходимых изменений в процесс установки, что упрощает процесс настройки больших приложений или групп приложений. Таблицы базы данных установщика Windows отражают общую структуру всей группы приложений, в том числе:

  • доступные возможности;
  • компоненты;
  • отношения между возможностями и компонентами;
  • необходимые параметры реестра.

База данных установщика Windows (MSI-файл) состоит из нескольких взаимосвязанных таблиц, составляющих реляционную базу данных, необходимых для установки группы компонентов. Следующая таблица описывает группы связанных таблиц:

Группа | Описание
Основная группа таблиц | Описывает основные возможности и компоненты приложения и пакета установки.
Группа таблиц файлов | Содержит файлы, связанные с пакетом установки.
Группа таблиц реестра | Содержит записи реестра.
Группа системных таблиц | Отслеживает таблицы и столбцы установочной базы данных.
Группа таблиц локаторов | Используется для поиска уникальной подписи файла в реестре, данных конфигурации установщика, дереве каталогов или INI-файлах.
Группа установки программ | Содержит свойства, точечные рисунки, ярлыки и другие элементы, необходимые для установки приложения.
Группа процедур установки | Управляет задачами, выполняемыми в ходе установки стандартными или пользовательскими действиями.
Преобразования
Процессом установки можно управлять, применяя к установочной базе данных файлы преобразования (MST). Преобразования изменяют элементы базы данных. Например, установщик Windows может использовать файл преобразования для смены языка интерфейса пользователя приложения. Файлы преобразования установщика Windows изменяют файл пакета установки во время установки и, следовательно, могут динамически влиять на процесс установки.

Настроенные преобразования, как и пакеты исправлений, остаются в кэше компьютера. Эти преобразования применяются к файлу базового пакета каждый раз, когда установщику Windows требуется изменить конфигурацию в пакете установки. Преобразования применяются в ходе начальной установки и не применяются к уже установленным приложениям.


Использование установщика Windows

В этом разделе

  • Установщик Windows в управляемых средах
  • Параметры командной строки
  • Управление параметрами компьютеров средствам групповой политики
  • Управление параметрами пользователей средствами групповой политики


Установщик Windows в управляемых средах

Установщик Windows является частью IntelliMirror и ключевым компонентом технологии управления изменениями и конфигурацией на основе групповой политики Windows. Дополнительные сведения о IntelliMirror см. в разделе IntelliMirror.

С помощью технологий IntelliMirror, групповой политики и средств управления изменениями и конфигурацией администраторы могут разрешить доступ к определенным приложениям, задав режим выполнения всех операций (установка, удаление и восстановление) над этими приложениями от имени системной учетной записи. Администратор управляет файловой системой и реестром, а установщик Windows выполняет установку программного обеспечения по выбору пользователя. С повышенными привилегиями могут быть запущены только приложения, разрешенные администратором.

Дополнительные сведения о групповой политике и установке программного обеспечения см. в разделе Использование оснастки «Установка программ».

Для локального выполнения установки можно использовать установщик Windows, а для централизованного управления распространением и установкой программ — Systems Management Server.

Дополнительные сведения о групповой политике см. в разделах Групповая политика и Использование установщика Windows.

Администраторы используют Windows Active Directory, IntelliMirror и групповую политику для назначения или публикации приложений группам пользователей или компьютеров в организации. Служба каталогов Active Directory — это безопасная, распределенная, разделенная и реплицируемая служба, предоставляющая службы управления. К этим службам относятся стандартизованный метод поиска ресурсов в предприятии и применение групповой политики к объектам, управляемым Active Directory.

Дополнительные сведения о службе каталогов Active Directory см. в разделе Active Directory.

На клиентском компьютере установщик Windows является основным компонентом установки программного обеспечения и его сопровождения. Дополнительные сведения по установке программного обеспечения см. в разделе Общие представления об установке программ. Установщик Windows предоставляет улучшенные возможности рабочего стола Windows, независимо от того, находится ли этот рабочий стол в среде, управляемой сервером.


Параметры командной строки

Синтаксис командной строки установщика Windows включает следующие параметры.

Параметр Атрибуты Определение
/i {пакет|КодПродукта} Установка или настройка продукта.

Например, для установки продукта из A:\Example.msi используется следующая команда:
msiexec /i A:\Example.msi

Дополнительные сведения см. в разделе Установка пакета с использованием командной строки.

Сведения об установке преобразований с использованием командной строки см. в разделах Установка преобразования с использованием командной строки и Установка и объявление пакета с использованием командной строки.
/a пакет Административная установка.

Дополнительные сведения см. в разделе Создание административного пакета установки из командной строки.
/f [p][o][e][d][c][a][u][m][s][v]

{пакет|КодПродукта}

 Восстановление продукта. Этот параметр игнорирует любые значения свойств, введенные в командной строке.

p — переустановка только при отсутствии файла.

o — переустановка при отсутствии файла или если установлена его старая версия.

e — переустановка при отсутствии файла или если установлена его идентичная или старая версия.

d — переустановка при отсутствии файла или если установлена его другая версия.

c — переустановка при отсутствии файла или в случае, если контрольная сумма не совпадает с вычисленным значением.

a — принудительная переустановка всех файлов.

u — перезапись всех необходимых пользовательских записей реестра.

m — перезапись всех необходимых компьютерных записей реестра.

s — замена всех существующих ярлыков.

v — запуск файлов из источника и новое кэширование локального пакета.

Например, можно восстановить пакет установки с помощью следующей команды:
msiexec /fpecms Example.msi

Дополнительные сведения см. в разделе Восстановление пакета с использованием командной строки.
/x {пакет|КодПродукта} x — отмена установки продукта.

Например, можно удалить или отменить установку пакета с помощью следующей команды:
msiexec /x Example.msi

Дополнительные сведения см. в разделе Удаление пакета с использованием командной строки.
/j [u|m]пакет

[u|m]пакет /t список преобразований

[u|m]пакет /g КодЯзыка

 Объявление продукта. Этот параметр игнорирует любые значения свойств, введенные в командной строке.

u — объявление для текущего пользователя.

m — объявление для всех пользователей данного компьютера.

g — идентификатор языка.

t — применение преобразования к объявляемому пакету.

Например, для объявления пакета для всех пользователей этого компьютера можно использовать следующую команду:
msiexec /jm Example.msi

Дополнительные сведения см. в разделах Объявление пакета с использованием командной строки и Установка и объявление продукта с использованием командной строки.
/L [i][w][e][a][r][u][c][m][p][v][+][!]файл_журнала Указывает путь к файлу журнала. Следующие параметры определяют сведения, сохраняемые в журнале:

i — сообщения состояния;

w — некритические предупреждения;

e — все сообщения об ошибках;

a — запуск действий;

r — записи, специфические для действия;

u — запросы пользователя;

c — начальные параметры интерфейса пользователя;

m — нехватка памяти;

p — свойства терминала;

v — подробный вывод;

+ — добавление в существующий файл;

! — открывать каждую строку в журнале;

* — подстановочный знак, записывает в журнал все сведения, кроме параметра v.

Для включения параметра v введите /L*v.

Например, чтобы установить пакет и создать файл журнала, содержащий сведения о состоянии, сообщения об ошибках и нехватке памяти, введите следующую команду: msiexec /i Example.msi /Lime logfile.txt

Дополнительные сведения см. в разделе Создание файла журнала установки с помощью командной строки.
/p ПакетИсправлений Применение исправлений. Чтобы применить исправления к установленном образу администратора, необходимо сгруппировать параметры, как указано ниже:

/p — ПакетИсправлений

/a — пакет

Например, для применения исправлений к административному пакету установки используется следующий синтаксис:
msiexec /p <ПакетИсправлений> /a Example.msi

/q {n|b|r|f} Установка уровня пользовательского интерфейса.

qn — отсутствие интерфейса.

qb — основной интерфейс.

qr — сокращенный интерфейс пользователя с выводом модального диалогового окна в конце установки.

qf — полный интерфейс пользователя с выводом модального диалогового окна в конце.

qn+ — отсутствие интерфейса за исключением вывода модального диалогового окна в конце.

qb+ — основной пользовательский интерфейс с выводом модального диалогового окна в конце.

qb- — основной интерфейс с отсутствием модальных диалоговых окон.

Обратите внимание, что параметр /qb+- не является поддерживаемым уровнем интерфейса пользователя.

При отмене установки пользователем модальное окно не выводится.

Например, для вывода параметров основного пользовательского интерфейса во время установки пакета введите следующую команду:
msiexec /qb Example.msi

/? или /h отсутствуют Вывод сведений об авторских правах для установщика Windows.

? или h — вывод номера версии и сведений об авторских правах установщика Windows.

Например, для просмотра номера версии и сведений об авторских правах введите следующую команду:
msiexec /?

/y модуль y — вызов системной функции DllRegisterServer для регистрации модулей, указанных в командной строке. Например:
msiexec /y my_file.dll.

Этот параметр используется только для данных из реестра, которые не могут быть добавлены с помощью таблиц реестра MSI-файла.
/z модуль z — вызов системной функции DllRegisterServer для отмены регистрации модулей, указанных в командной строке. Например:
msiexec /z my_file.dll.

Этот параметр используется только для данных из реестра, которые не могут быть удалены с использованием таблиц реестра MSI-файла.


Управление параметрами компьютеров средствам групповой политики

С помощью групповой политики и Active Directory можно настроить установщик Windows для управления параметрами установки компьютера.

В следующей таблице приведены политики, связанные с управлением параметрами групповой политики компьютера для установщика Windows. Для настройки этих политик запустите оснастку «Групповая политика», как описано в разделе Создание оснастки «Групповая политика». Затем щелкните в дереве консоли узел Установщик Windows.

Где?

  • применимое имя политики
  • Конфигурация компьютера
  • Административные шаблоны
  • Установщик Windows

Данная политика разрешает всем пользователям устанавливать пакеты исправлений даже при запуске программы установки с повышенными привилегиями. Пакеты исправлений представляют собой обновления, заменяющие только измененные файлы программ. Поскольку пакеты исправлений легко могут быть использованы для распространения вирусных программ, некоторые типы установки запрещают их использование.

По умолчанию применять пакеты исправлений во время установки с повышенными привилегиями (предложенных на рабочем столе или отображаемых в окне «Установка и удаление программ») могут выполнять только системные администраторы.

Эта политика не влияет на установки, выполняемые в контексте пользовательской безопасности. По умолчанию пользователи могут устанавливать пакеты исправлений для программ, выполняемых в контексте пользовательской безопасности. См. также описание политики «Запретить применение пакетов исправлений».

Политика | Сведения
Запретить использование установщика Windows Запрет или ограничение использования установщика Windows.

Данная политика позволяет запретить пользователям устанавливать программное обеспечение на свои системы или разрешить устанавливать только программы, предложенные администратором.

При включении этой политики можно использовать параметры в окне Запрет использования установщика Windows для задания политики установки.

Никогда
Установщик Windows полностью включен. Пользователи могут устанавливать и обновлять программное обеспечение. Установщик Windows используется в Windows по умолчанию.
Только для не обслуживаемых программ
Пользователи могут устанавливать только те программы, которые назначены администратором (предложены на рабочем столе) или опубликованы (добавлены в компонент «Установка и удаление программ»).
Всегда
Отключение установщика Windows.

Примечание

  • Эта политика относится только к установщику Windows. При этом пользователям не запрещено использовать другие методы для установки и обновления программ.
Всегда производить установку с повышенными привилегиями Установщик Windows использует разрешения для системы при установке любой программы.

Эта политика распространяет на все программы повышенные привилегии, обычно зарезервированные для программ, назначенных пользователю (предложены на рабочем столе) или компьютеру (устанавливаются автоматически), либо доступных в компоненте «Установка и удаление программ» на панели управления. Она позволяет пользователю устанавливать программы, которые требуют доступ к каталогам, к которым пользователь может иметь доступ только для просмотра или изменения, включая каталоги на компьютерах с сильно ограниченным доступом.

Если отключить или не настроить эту политику, то система применит текущие пользовательские разрешения при установке программ, которые не распространены или не предложены администратором.

Примечание

  • Эта политика отображается и в папке «Конфигурация компьютера», и в папке «Конфигурация пользователя». Для ввода данной политики в действие необходимо включить ее в обеих папках.
Запретить откат Данная политика запрещает установщику Windows создавать и сохранять файлы, необходимые для восстановления прерванной или неудачной установки.

Политика Запретить откат также запрещает установщику Windows запись исходного состояния системы и изменений, вносимых в процессе установки, а также запрещает установщику Windows сохранять файлы, которые он должен удалить позже. В результате установщик Windows не может восстановить исходное состояние компьютера в случае, если установка не была завершена.

Эта политика создана для снижения объема временного дискового пространства, необходимого для установки программ. Политика Запретить откат также предотвращает прерывание установки злоумышленниками для сбора сведений о состоянии компьютера и для поиска защищенных системных файлов. Однако в связи с тем, что незавершенная установка может привести систему или приложение в нерабочее остояние, эту политику не следует использовать без необходимости.

Эта политика отображается и в папке «Конфигурация компьютера», и в папке «Конфигурация пользователя». Для ввода данной политики в действие необходимо включить ее в обеих папках.
Запретить диалоговое окно обзора нового источника Запрещает пользователям выполнять поиск установочных файлов при добавлении возможностей или компонентов в установленную программу.

Данная политика отключает кнопку Обзор рядом со списком Возможности в диалоговом окне установщика Windows. В результате пользователи должны выбирать источник установочных файлов из списка Возможности, настроенного администратором.

Эта политика действует даже в том случае, если установка запущена в контексте безопасности пользователя.

Если эта политика отключена или не настроена, кнопка Обзор доступна при запуске установки в контексте безопасности пользователя, но пользоваться этой кнопкой при запуске установки с повышенными привилегиями (например, с помощью ярлыка на рабочем столе или компонента «Установка и удаление программ») смогут только администраторы.

Эта политика относится только к установщику Windows. Она не запрещает пользователям использовать для поиска установочных файлов другие средства, такие как проводник Windows или папку «Мое сетевое окружение».
Запретить применение пакетов исправлений Запрещает пользователям устанавливать пакеты исправлений для своих программ.

Пакеты исправлений представляют собой обновления, заменяющие измененные файлы программ. Поскольку пакеты исправлений легко могут быть использованы для распространения вирусных программ, некоторые типы установки запрещают их использование.

Эта политика применима только для установок, запускаемых в контексте безопасности пользователя. По умолчанию пользователи, не являющиеся администраторами, не могут применять пакеты исправлений при запуске установки с повышенными системными привилегиями (например, с помощью ярлыка на рабочем столе или компонента «Установка и удаление программ»).
Отключить запрос безопасности IE для сценариев Windows Installer Позволяет веб-приложениям устанавливать на компьютер программное обеспечение без уведомления пользователя.

По умолчанию при попытке сценария, выполняемого веб-обозревателем, установить программу система выводит для пользователя предупреждение и запрос на разрешение или запрет установки. Эта политика подавляет вывод предупреждения и разрешает выполнение установки без вмешательства пользователя.

Она предназначена для предприятий, которые используют средства на основе Интернета для распространения программ среди своих работников. Эту политику следует применять осторожно, поскольку она делает систему уязвимой.
Разрешить пользователям изменять параметры установки

Разрешает пользователям изменять параметры установки, обычно доступные только для администраторов.

Эта политика обходит некоторые средства безопасности установщика Windows. Она делает возможным завершение установок, которые в обычных условиях были бы прерваны из-за нарушения безопасности.

Средства безопасности установщика Windows запрещают пользователям изменять параметры установки, обычно зарезервированные для администраторов, такие как выбор каталога для установки файлов. Если установщик Windows обнаруживает, что пакет установки разрешает пользователю изменять защищенные параметры, установка прерывается и выводится сообщение об ошибке. Эти средства безопасности действуют только при запуске программы установки в привилегированном контексте безопасности, в котором программа установки имеет доступ к каталогам, недоступным для пользователя.

Эта политика предназначена для менее ограниченных сред. Она может быть использована для обхода ошибок программы, препятствующих ее установке.
Разрешить обзор источника при повышенных привилегиях Разрешает пользователям выполнять поиск установочных файлов при выполнении привилегированных установок.

Данная политика включает кнопку Обзор в диалоговом окне Возможности. Пользователи могут выполнять поиск установочных файлов даже при запуске программы установки с повышенными системными привилегиями. По умолчанию обзор источников во время установки с повышенными привилегиями (предложенных на рабочем столе или отображаемых в окне «Установка и удаление программ») могут выполнять только системные администраторы.

Поскольку установка выполняется с повышенными системными привилегиями, пользователи могут просматривать каталоги, разрешения на доступ к которым у них отсутствуют.

Эта политика не влияет на установки, выполняемые в контексте пользовательской безопасности. Дополнительные сведения см. в описании политики «Запретить диалоговое окно обзора нового источника».
Разрешить использование носителей при повышенных привилегиях Разрешает пользователям устанавливать программы со съемных носителей, таких как дискеты и компакт-диски, при повышенных привилегиях.

Данная политика разрешает всем пользователям устанавливать программы со съемных носителей даже при запуске программы установки с повышенными системными привилегиями. По умолчанию пользователи могут устанавливать программы со съемных носителей только при запуске установки в контексте безопасности пользователя. При привилегированной установке (с помощью ярлыка на рабочем столе или компонента «Установка и удаление программ») выполнять установку со съемных носителей могут только системные администраторы.

Эта политика не влияет на установки, выполняемые в контексте пользовательской безопасности. По умолчанию пользователи могут устанавливать программы со съемных носителей только при запуске установки в контексте безопасности пользователя.

Для получения дополнительных сведений см. описание политики «Запретить использование съемных носителей при установке» в разделе Управление параметрами пользователей средствами групповой политики
Разрешить применение пакетов исправлений во время привилегированных установок | Разрешает пользователям обновлять программы во время привилегированных установок.
Разрешить администраторам выполнение установки в сеансе сервера терминалов Разрешает администраторам служб терминалов устанавливать и настраивать программы удаленно.

По умолчанию системные администраторы могут устанавливать программы только при входе в систему на том компьютере, на который устанавливается программа. Данная политика создает специальное исключение для компьютеров, выполняющих службы терминалов.

Эта политика относится только к системным администраторам. Другие пользователи не могут устанавливать программы удаленно.
Кэшировать файлы трансформацмм в безопасном месте на рабочей станции Копии файлов преобразования сохраняются в безопасном месте на локальном компьютере.

Файлы преобразования состоят из инструкций по изменению или настройке программы во время установки. По умолчанию установщик Windows хранит файлы преобразования в каталоге «Application Data» в профиле пользователя. При переустановке, удалении или восстановлении установки файл преобразования доступен, даже если пользователь работает на другом компьютере или при отсутствии подключения к сети.

При включении данной политики файл преобразования сохраняется в безопасном месте на компьютере пользователя, а не в профиле пользователя. Поскольку файл преобразованяи необходим установщику Windows для повтора установки, при которой использовался файл преобразования, пользователь должен использовать тот же компьютер или установить подключение к исходному или идентичному носителю для переустановки, удаления или восстановления установки.

Данная политика предназначена для предприятий, которые должны предпринимать специальные меры по предотвращению несанкционированного или злонамеренного изменения файлов преобразования.
Ведение журнала

Введите один или несколько следующих параметров журнала установки:

[i][w][e][a][r][u][c][m][p][v][o]

Данная политика задает типы событий, которые установщик Windows будет записывать в журнал для каждой установки. Журнал (файл msi.log) появляется в каталоге Temp на системном томе.

Чтобы указать тип записываемого события, введите букву, представляющую нужный тип события. Буквы, представляющие типы событий, можно вводить в любом порядке и в любом количестве. Чтобы отключить журнал, удалите из поля все буквы.

Доступны следующие параметры журнала установщика Windows:

Режим | Запись журнала
i | Сообщения о состоянии
w | Некритические предупреждения
e | Все сообщения об ошибках
a | Запуск действий
r | Записи, специфические для действий
u | Запросы пользователя
c | Исходные параметры интерфейса пользователя
m | Нехватка памяти
p | Свойства терминала
v | Подробный вывод
o | Сообщения о недостатке места на диске

Примечания

  • Если данная политика отключена или не настроена, установщик Windows записывает в журнал типы событий по умолчанию, представленные буквами iweap.
  • Для включения в журнал установки всех возможных событий введите iwearucmpvo. Учтите, что при этом продолжительность процесса установки будет значительно увеличена.


Управление параметрами пользователей средствами групповой политики

Для управления пользовательскими параметрами установки можно настроить установщик Windows на использование групповой политики и Active Directory.

В следующей таблице показаны политики, касающиеся управления параметрами пользователей групповой политики для установщика Windows. Для настройки этих политик запустите оснастку «Групповая политика», как описано в разделе Создание оснастки «Групповая политика». В дереве консоли щелкните узел Установщик Windows.

Где?

  • применимое имя политики
  • Конфигурация пользователя
  • Административные шаблоны
  • Установщик Windows
Политика Сведения
Всегда производить установку с повышенными привилегиями Указывает установщику Windows использовать разрешения для системы при установке любой программы.

Эта политика распространяет на все программы повышенные привилегии, обычно зарезервированные для программ, назначенных пользователю (предложены на рабочем столе) или компьютеру (устанавливаются автоматически), либо доступных в компоненте «Установка и удаление программ» на панели управления. Она позволяет пользователю устанавливать программы, которые требуют доступ к каталогам, к которым пользователь может иметь доступ только для просмотра или изменения, включая каталоги на компьютерах с сильно ограниченным доступом.

Если отключить или не настроить эту политику, то система применит текущие пользовательские разрешения при установке программ, которые не распространены или не предложены администратором.

Примечание

  • Политика отображается и в папке «Конфигурация компьютера», и в папке «Конфигурация пользователя». Для лучшей работы политики необходимо разрешить ее в обеих папках.
Порядок поиска

Введите один или несколько следующих параметров порядка поиска:
[n][m][u]

 Задает порядок поиска установочных файлов установщиком Windows.

По умолчанию установщик Windows ищет файлы сначала в сети, затем на съемных носителях (дисководе гибких дисков, дисководе компакт-дисков или DVD) и, наконец, в Интернете (URL).

Для изменения порядка поиска включите политику и введите индексы источников файлов в том порядке, в котором установщик Windows должен выполнять поиск:

Параметр | Тип носителя
n | При установке этого параметра поиск файлов выполняется в сети.
m | При установке этого параметра поиск файлов выполняется на съемных носителях.
u | При установке этого параметра поиск файла выполняется в Интернете.

Примечание

  • Чтобы исключить источник файлов, пропустите или удалите букву, представляющую этот тип источника.
Запретить откат Запрещает установщику Windows создать и сохранить файлы, необходимые для восстановления прерванной или неудачной установки.

Эта политика запрещает установщику Windows записывать исходное состояние системы и последовательность ее изменений во время установки. Она также запрещает установщику Windows хранить файлы, которые он должен удалить позже. В результате установщик Windows не может восстановить исходное состояние компьютера в случае, если установка не была завершена.

Эта политика создана для снижения объема временного дискового пространства, необходимого для установки приложений. Она также предотвращает прерывание установки злоумышленниками для сбора сведений о состоянии компьютера и для поиска защищенных системных файлов. Однако в связи с тем, что незавершенная установка может привести систему или приложение в нерабочее остояние, эту политику не следует использовать без необходимости.

Примечание

  • Эта политика отображается и в папке «Конфигурация компьютера», и в папке «Конфигурация пользователя». Для ввода данной политики в силу необходимо включить ее в обеих папках.
Запретить использование съемных носителей при установке Данная политика запрещает пользователя устанавливать программы со съемных носителей.

При попытке пользователя установить программу со съемного носителя, такого как компакт-диск, дискета или DVD, выводится сообщение о невозможности найти этот носитель.

Эта политика действует даже в том случае, если установка запущена в контексте безопасности пользователя.

Если данная политика отключена или не настроена, пользователи могут выполнять установку со съемных носителей при запуске установки из собственного контекста безопасности, но использовать съемные носители при запуске установки с повышенными системными привилегиями (например, с помощью ярлыка на рабочем столе или компонента «Установка и удаление программ») могут только системные администраторы.


Ресурсы

  • Последние технические сведения
  • Ресурсы Windows
  • Веб-узел Microsoft MSDN (http://www.microsoft.com/)


Устранение неполадок установщика Windows

Вид неполадки

Установочный пакет не устанавливается должным образом.

Причина. Это может быть вызвано повреждением установочного пакета.

Решение. Восстановите установочный пакет с помощью средства восстановления установщика Windows. Дополнительные сведения о восстановлении установочных пакетов см. в разделе Восстановление пакета с помощью командной строки.

Процесс установки прервался до завершения установки.

Причина. Установщику Windows не удалось прочесть установочный пакет, либо успешной установке препятствуют параметры компьютера.

Решение. Установщик Windows создает записи в журнале событий Windows. Откройте окно Просмотр событий и просмотрите записи журнала для установщика Windows. Установщик Windows можно настроить для создания пользовательского файла журнала установки. Дополнительные сведения о параметрах файла журнала установщика Windows см. в разделе Создание файла журнала установки с помощью командной строки.

Примечание

  • Чтобы открыть окно «Просмотр событий», нажмите кнопку Пуск и выберите команды Настройка и Панель управления. Дважды щелкните значок Администрирование, а затем дважды щелкните значок Просмотр событий.


Устранение неполадок

В этом разделе

  • Устранение неполадок установщика Windows