Загрузка примеров программ для сервера сценариев Windows

Рисунок Microsoft Windows

Чтобы загрузить примеры программ для сервера сценариев Windows

  1. В оглавлении веб-узла Microsoft Windows Script Technologies (http://www.microsoft.com/) щелкните пункт Windows Script Host.
  2. В раскрывшемся меню выберите команду Samples.
  3. На странице Samples щелкните ссылку Download. Появится диалоговое окно Загрузка файла.
  4. В диалоговом окне Загрузка файла нажмите кнопку OK. Появится диалоговое окно Сохранить как.
  5. В диалоговом окне Сохранить как создайте новую или выберите существующую папку для сохранения архива и нажмите кнопку Сохранить. В выбранную папку будет загружен файл Samples.exe.
  6. Откройте в проводнике эту папку и дважды щелкните файл Samples.exe. Появится диалоговое окно WinZip Self-Extractor.
  7. В поле Unzip to Folder введите путь для размещения файлов примеров. Нажмите кнопку Unzip, чтобы развернуть содержимое архива Samples.exe.

Примечания

  • Примеры включают программы на JScript и VBScript (файл Samples.exe можно удалить). Кроме того, среди файлов с текстами программ имеется файл Readme.doc с последними сведениями об этих примерах.
  • Можно изучить и отредактировать исходный текст программы, если в проводнике Windows щелкнуть файл сценария правой кнопкой мыши, а затем в контекстном меню выбрать команду Изменить.
  • Чтобы запустить сценарий, дважды щелкните его в проводнике Windows.

См. также


Объектная модель сервера сценариев Windows

Объектная модель сервера сценариев Windows ориентирована на использование при решении административных задач. Набор COM-интерфейсов модели можно разделить на две основные категории.

Выполнение сценариев и устранение неполадок

Свойства и методы, непосредственно относящиеся к выполнению сценариев. Они позволяют управлять объектом сервера сценариев, выводить на экран сообщения и выполнять основные COM-функции, такие как CreateObject и GetObject.

Вспомогательные функции

Свойства и методы выполнения действий, таких как подключение сетевого диска, установка принтера, создание и изменение переменных среды, а также работа с разделами реестра. Администраторы могут использовать эти функции для создания простых сценариев входа в систему.

Объект Предоставляемые возможности
WScript
  • Задание и получение аргументов командной строки
  • Определение имени файла сценария
  • Определение имени файла сервера сценариев (Wscript.exe или Cscript.exe)
  • Определение версии сервера сценариев
  • Создание, подключение и отключение COM-объектов
  • Обработка событий
  • Программная остановка выполнения сценария
  • Отправка данных на устройство вывода, используемое по умолчанию (в диалоговое окно или окно консоли)
WshArguments
  • Доступ к набору всех аргументов командной строки
WshNamed
  • Доступ к набору именованных аргументов командной строки
WshUnnamed
  • Доступ к набору неименованных аргументов командной строки
WshNetwork
  • Доступ к сетевым дискам и принтерам
  • Подключение и отключение сетевых ресурсов
  • Доступ к данным о текущем пользователе, вошедшем в систему
WshController
  • Создание процесса удаленного выполнения сценария с помощью метода CreateScript()
WshRemote
  • Удаленное администрирование компьютеров, подключенных к сети
  • Программное управление другими приложениями и сценариями
WshRemote Error
  • Доступ к данным об ошибке, возвращаемым при сбое выполнения удаленного сценария (объект WshRemote)
WshShell
  • Локальное выполнение программы
  • Управление содержимым реестра
  • Создание ярлыка
  • Доступ в системную папку
  • Управление переменными среды, такими как WINDIR, PATH или PROMPT
WshShortcut
  • Программное создание ярлыка
WshSpecialfolders
  • Доступ к любой специальной папке Windows
WshURLShortcut
  • Программное создание ярлыка, ссылающегося на ресурс Интернета
WshEnvironment
  • Доступ к любой переменной среды, такой как WINDIR, PATH или PROMPT
WshScriptExec
  • Определение данных об ошибке и состояния сценария, запущеного методом Exec()
  • Доступ к потокам ввода-вывода stdIn, stdOut и stdErr

Кроме объектного интерфейса сервера сценариев для автоматизации решения задач администраторы могут использовать любые элементы ActiveX, предоставляющие соответствующие интерфейсы. Например, можно создавать сценарии для управления службами каталогов Active Directory.

Для получения дополнительных сведений посетите веб-узел Windows Script Technologies, ссылку на который можно найти на веб-узле корпорации Майкрософт (http://www.microsoft.com/rus/).

См. также


Общие сведения о сервере сценариев Windows

Сервер сценариев Windows позволяет быстро запустить сценарий (для этого щелкните файл, находящийся на рабочем столе, или введите имя этого файла в командной строке). Как и Microsoft Internet Explorer, сервер сценариев Windows служит контроллером средств обработки сценариев Windows. Однако, в отличие от Internet Explorer, сервер сценариев Windows не требует много памяти и является идеальным средством как для интерактивных, так и для пакетных сценариев, таких как сценарий входа в систему и сценарий администрирования.

Существуют две версии сервера сценариев Windows: Wscript.exe, позволяющая задавать параметры выполнения сценариев в окне свойств, и Сscript.exe, позволяющая задавать параметры выполнения сценариев с помощью ключей командной строки. Чтобы запустить необходимую версию, введите в командной строке: Wscript.exe или Cscript.exe.

В ранних версиях Windows в качестве языка сценариев поддерживался только язык команд MS-DOS. По сравнению с VBScript и Jscript, язык команд MS-DOS обладает ограниченным набором средств, хотя и является компактным и быстрым. Например, в нем нет средств для управления процессом выполнения программы. Теперь сервер сценариев Windows позволяет воспользоваться преимуществами этих мощных языков (при этом поддержка языка команд MS-DOS предоставляется по-прежнему).

Для разработки сценариев Windows следует использовать редакторы сценариев JScript или VBScript (в составе Visual Basic Scripting Edition). При запуске сценария с рабочего стола или из командной строки, сервер сценария читает и передает содержимое указанного файла зарегистрированному обработчику сценариев. Вместо тега SCRIPT (применяется в HTML) для определения языка сценария используется расширение имени файла (.vbs для VBScript, .js для JScript). Благодаря этому, разработчик сценария не обязан знать точные программные идентификаторы (ProgID) различных обработчиков сценариев. Сопоставление расширения имени файла сценария с ProgID и запуск конкретного обработчика сценариев осуществляется сервером сценариев Windows.

В текущую версию сервера сценариев Windows добавлены новые функциональные возможности.

Улучшенное управление аргументами

Упрощены синтаксис и описание аргументов командной строки.

Удаленные сценарии

Сценарий можно загрузить в удаленную систему, а затем выполнить в ней.

Выполняющийся процесс является объектом

Для программирования доступны дочерние процессы, события, стандартные потоки ввода-вывода и переменные среды.

Текущий рабочий каталог

Текущий рабочий каталог активного процесса можно задавать и изменять программным путем.

Новые средства безопасности

Распространение и выполнение сценариев регулируются новой моделью защиты данных.

Для получения дополнительных сведений посетите веб-узел Windows Script Technologies, ссылку на который можно найти на веб-узле корпорации Майкрософт (http://www.microsoft.com/rus/).

См. также


Запуск сценариев с помощью сервера сценариев для командной строки (Cscript.exe)

Чтобы запустить сценарий с помощью сервера сценариев для командной строки (Cscript.exe)

Для выполнения сценариев с помощью сервера сценариев для командной строки предусмотрен следующий синтаксис:

cscript [имя_сценария] [параметры_сервера] [аргументы_сценария]

Здесь:

  • имя_сценария — имя файла сценария, включая путь и расширение.
  • параметры_сервера — ключи командной строки, задающие различные свойства сервера сценариев Windows. Параметр сервера всегда начинается с двух косых черт (//).
  • аргументы_сценария — ключи командной строки, которые передаются в сценарий. Аргумент сценария всегда начинается с одной косой черты (/).

Примечания

  • Все параметры являются необязательными, однако нельзя задать аргументы сценария, не задав сценарий. При отсутствии аргументов сценария или самого сценария программа Cscript.exe выведет описание синтаксиса команды и предусмотренные ключи.
  • Ключи сервера сценариев для командной строки (см. таблицу).
    Параметр | Действие
    //B | Включение пакетного режима, при котором не выводятся подсказки и сообщения об ошибках.
    //D | Включение отладчика.
    //E:обработчик | Указание обработчика, используемого для выполнения сценария.
    //H:cscript или //H:wscript | Регистрация Cscript.exe или Wscript.exe в качестве сервера сценариев, применяемого по умолчанию. Если ключ не задан, используется Wscript.exe.
    //I | Включение интерактивного режима, в котором выводятся подсказки и сообщения об ошибках. Применяется по умолчанию; отменяет ключ //B.
    //Job:xxxx | Выполнение задания xxxx, указанного в файле сценария .wsf.
    //Logo | Отображение перед выполнением сценария эмблемы сервера сценариев Windows. Применяется по умолчанию; отменяет режим //Nologo.
    //Nologo | Скрытие перед выполнением сценария эмблемы сервера сценариев Windows.
    //S | Сохранение параметров текущей командной строки для данного пользователя.
    //T:nnnnn | Указание максимального времени (в секундах), отведенного на выполнение сценария. Можно указать значение времени до 32 767 секунд. По умолчанию время выполнения не ограничено.
    //X | Запуск сценария в отладчике.
    //? Вывод предусмотреных параметров командной строки и встроенной справки (аналогично запуску программы Cscript.exe без аргументов и без задания сценария).
  • Параметр времени ожидания (//T:nnnnn) ограничивает максимальное время выполнения сценария. Если время выполнения превышает заданную величину, Cscript.exe прерывает работу обработчика и останавливает процесс.
  • С помощью сервера сценариев Windows можно создать файл .wsf, позволяющий вызвать несколько обработчиков сценариев и выполнить несколько заданий.

Для получения дополнительных сведений посетите веб-узел Windows Script Technologies, ссылку на который можно найти на веб-узле корпорации Майкрософт (http://www.microsoft.com/rus/).

См. также


Запуск сценариев с помощью сервера сценариев для Windows (Wscript.exe)

Чтобы запустить сценарий с помощью сервера сценариев для Windows (Wscript.exe)

Предусмотрено несколько способов запуска.

При просмотре файловой системы Windows

Найдите необходимый сценарий и дважды щелкните его. Файлы сценариев отображаются в окнах «Мой компьютер», «Проводник Windows» и «Результаты поиска», в меню Пуск, а также на рабочем столе.

При помощи команды Выполнить

Нажмите кнопку Пуск и выберите команду Выполнить. В поле Открыть введите имя исполняемого файла сервера сценариев Windows (Wscript.exe), пробел и полное имя (включая путь) нужного файла сценария. Также должно быть указано расширение имени файла сценария. Нажмите кнопку ОК для запуска сценария.

Из окна командной строки

В командной строке введите имя исполняемого файла сервера сценариев Windows (Wscript.exe), пробел и полное имя (включая путь) нужного файла сценария. Также должно быть указано расширение имени файла сценария. Нажмите клавишу ВВОД для запуска сценария.

Примечания

  • Файлы сценариев Windows могут иметь следующие расширения: .wsf, .vbs, .js.
  • Если дважды щелкнуть файл сценария, расширение которого не сопоставлено с Wscript.exe, появится окно Выбор программы. Выделите в нем программу Wscript.exe и установите флажок Всегда использовать выбранную программу. Это позволит зарегистрировать Wscript.exe в качестве сервера сценариев, используемого по умолчанию для файлов данного типа.
  • Диалоговое окно Параметры сервера сценариев Windows можно использовать для определения глобальных параметров, используемых Wscript.exe для выполнения любых сценариев на данном локальном компьютере.
  • Можно задавать свойства отдельных сценариев. Для получения сведений о том, как это сделать, щелкните ссылку «См. также».
  • С помощью сервера сценариев Windows можно создать файл .wsf, позволяющий вызвать несколько обработчиков сценариев и выполнить несколько заданий.

Для получения дополнительных сведений посетите веб-узел Windows Script Technologies, ссылку на который можно найти на веб-узле корпорации Майкрософт (http://www.microsoft.com/rus/).

См. также


Запуск примеров сценариев Windows

Чтобы запустить пример сценария Windows

  1. Командная строка
  2. В командной строке введите:

    cscript папка_сценариев\имя_сценария

    Здесь:

    папка_сценариев — папка, в которой хранятся загруженные примеры сценариев.

    имя_сценария — имя запускаемого сценария с расширением (например .js или .vbs).

    Например, если сценарии хранятся в папке C:\Samples и нужно запустить сценарий Network.vbs, необходимо ввести:

    cscript c:\sample\network.vbs

Примечания

  • XOX
  • Примеры сценариев необходимо загрузить с веб-узла корпорации Майкрософт.
  • Кроме того, для запуска сценария с помощью Wscript.exe можно два раза щелкнуть файл сценария мышью.

См. также


Задание глобальных свойств для выполнения любых сценариев с помощью Wscript.exe

Чтобы задать глобальные свойства для выполнения произвольного сценария с помощью Wscript.exe

  1. Нажмите кнопку Пуск и выберите команду Выполнить
    2. .
  2. В поле Открыть введите wscript и нажмите кнопку OK. Откроется диалоговое окно Параметры сервера сценариев Windows.
  3. Установите флажок Остановить сценарий после указанного числа секунд.
  4. В поле секунд введите время, которое необходимо зарезервировать для выполнения любого сценария.

Примечания

  • Эта настройка будет действовать при выполнении любых сценариев с помощью Wscript.exe. Каждый сценарий, выполняемый сервером, автоматически использует глобальные параметры.

Для получения дополнительных сведений посетите веб-узел Windows Script Technologies, ссылку на который можно найти на веб-узле корпорации Майкрософт (http://www.microsoft.com/rus/).

См. также


Задание свойств для выполнения конкретных сценариев с помощью Wscript.exe

Чтобы задать свойства для выполнения конкретного сценария с помощью Wscript.exe

  1. Проводник Windows. Найдите необходимый файл сценария и щелкните его правой кнопкой мыши.
  2. Нажмите кнопку Свойства и выберите вкладку Сценарий.
  3. Установите флажок Остановить сценарий после указанного числа секунд.
  4. В поле секунд введите время, которое необходимо зарезервировать для выполнения сценария.

Примечания

  • XOX
  • Эта настройка для конкретного файла имеет более высокий приоритет по сравнению с общими параметрами выполнения сценариев.
  • По нажатию кнопки OK будет создан командный файл, связывающий выбранные значения свойств со сценарием. Имя этого файла имеет расширение .wsh. Созданный файл можно использовать для запуска файла сценария.

Для получения дополнительных сведений посетите веб-узел Windows Script Technologies, ссылку на который можно найти на веб-узле корпорации Майкрософт (http://www.microsoft.com/rus/).

См. также