Оснастка MMC для ASP.NET

ASP.NET
Оснастка MMC для ASP.NET
DropDown image

В этом разделе описано использование оснастки консоли управления Microsoft (MMC) для настройки ASP.NET и приложений на основе ASP.NET.

MMC содержит средства, которые можно использовать для администрирования компьютеров, служб, других компонентов системы и сетей. Можно добавить в консоль одно или несколько средств администрирования, которые называются оснастками, для управления веб-приложением. Оснастка ASP.NET для консоли управления Microsoft (MMC) имеет универсальный интерфейс пользователя для настройки веб-серверов и приложений, которые размещены на этих серверах. Оснастка состоит из нескольких диалоговых окон, которые позволяют управлять специальными функциями, такими как обработка ошибок или проверка подлинности пользователя.

В этом разделе

Вкладка «Общие», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Особые ошибки», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Авторизация», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Проверка подлинности», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Приложение», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Управление состоянием», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Расположение», диалоговое окно «Параметры конфигурации ASP.NET»
Диалоговое окно «Изменить/Добавить строку подключения»
Диалоговое окно «Изменить/Добавить параметры приложения»
Диалоговое окно «Изменить/Добавить пользовательские обработчики ошибок»
Диалоговое окно «Изменение правила»
Диалоговое окно «Добавить расположение»

Дополнительные разделы

Configuring ASP.NET Applications

Сведения о модели конфигурации ASP.NET. Содержит описание использования файлов XML и API-интерфейса программирования конфигурации.
Чтобы внести предложение или сообщить о неполадке в работе справки или другой функции данного продукта, перейдите на страницу отзывов.


Вкладка «Общие», диалоговое окно «Параметры конфигурации ASP.NET»

Вкладка «Общие», диалоговое окно «Параметры конфигурации ASP.NET»
См. также
DropDown image

Вкладка Общие диалогового окна Параметры конфигурации ASP.NET позволяет настраивать два типа параметров конфигурации.

  • Строки подключения, определяющие информацию, которая используется для установления соединения с хранилищем данных, например с базой данных.

  • Параметры приложения, представляющие собой простые пары «имя/значение», которые позволяют централизованно задавать значения для всего приложения. Впоследствии можно получить доступ к этим значениям из любого места веб-приложения. Параметры приложения, определенные как часть конфигурации, всегда можно легко изменить. Параметры приложения всегда хранятся в виде строк.

Настройки, выполняемые на вкладке Общие, применяются к веб-приложению, которое было выбрано перед открытием диалогового окна Свойства.

Note Примечание

Параметры конфигурации могут быть унаследованы. Параметры можно задать в файле Machine.config, который является основным файлом конфигурации для всех веб-узлов и приложений на сервере. Можно создать новые параметры или заменить унаследованные параметры путем настройки конфигурации на уровне веб-приложения.

Открытие диалогового окна «Общие»

  1. В Microsoft Windows откройте элемент панели управления «Администрирование» и щелкните значок Диспетчер служб IIS.

    Откроется окно диспетчера служб IIS.

  2. В разделе Службы IIS раскройте список Servername (локальный компьютер), а затем – список Веб-узлы, щелкните правой кнопкой мыши Websitename или Веб-узел по умолчанию и выберите пункт Свойства.

    Откроется диалоговое окно Свойства веб-узла.

  3. Перейдите на вкладку ASP.NET и нажмите кнопку Изменить конфигурацию.

    Откроется диалоговое окно Параметры конфигурации ASP.NET.

  4. Перейдите на вкладку Общие.

Задачи

С помощью вкладки Общие можно выполнить следующие задачи.

  • Определить строки подключения к базе данных для веб-приложения.

  • Создать строковые значения для хранения часто используемой информации. Впоследствии можно получать доступ к этой информации и изменять ее из любого места в приложении.

Элементы пользовательского интерфейса

Диспетчер строк подключения

Выдает список строк подключения, определенных для выбранного веб-приложения. Унаследованные параметры выделены курсивом, а параметры, которые были переопределены, выделены жирным шрифтом.

Добавить

Нажмите, чтобы открыть диалоговое окно Изменение/Добавление строки подключения, в котором можно создать новую строку подключения.

Изменить

Нажмите, чтобы открыть диалоговое окно Изменение/Добавление строки подключения, в котором можно изменить существующую строку подключения.

Можно переопределить унаследованные параметры. В этом случае переопределенный параметр применяется только к выбранному веб-приложению. Нельзя изменить значение унаследованного параметра так, чтобы повысить его значение в конфигурационной иерархии.

Удалить

Нажмите, чтобы удалить или отключить строку подключения.

Можно полностью удалить новые параметры, заданные для этого веб-приложения. Если удаляется унаследованный параметр, исходный параметр сохраняет свое место в иерархии, а диспетчер служб IIS создает запись <remove>, отключающую этот параметр.

Сброс

Нажмите, чтобы восстановить исходное значение переопределенного или удаленного параметра.

Диспетчер служб IIS удаляет локальное переопределенное значение или удаляет запись <remove>, чтобы унаследованный параметр получил приоритет.

Параметры приложения

Выводит список пар «ключ/значение» для параметров приложения.

Добавить

Нажмите, чтобы открыть диалоговое окно Изменение/Добавление параметра приложения, в котором можно создать новую пару «ключ/значение».

Изменить

Нажмите, чтобы открыть диалоговое окно Изменение/Добавление параметра приложения, в котором можно изменить существующую пару «ключ/значение».

Можно переопределить унаследованные параметры. В этом случае переопределенный параметр применяется только к выбранному веб-приложению. Нельзя изменить значение унаследованного параметра так, чтобы повысить его значение в конфигурационной иерархии.

Удалить

Нажмите, чтобы удалить или отключить пару «ключ/значение».

Можно полностью удалить новые параметры, заданные для этого веб-приложения. Если удаляется унаследованный параметр, исходный параметр сохраняет свое место в иерархии, а диспетчер служб IIS создает запись <remove>, отключающую этот параметр.

Сброс

Нажмите, чтобы восстановить исходное значение переопределенной или удаленной пары «ключ/значение».

Диспетчер служб IIS удаляет локальное переопределенное значение или запись <remove>, чтобы унаследованный параметр получил приоритет.

См. также

Задачи

How to: Access ASP.NET Configuration Settings Programmatically

Справочные материалы

Вкладка «Проверка подлинности», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Авторизация», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Особые ошибки», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Расположение», диалоговое окно «Параметры конфигурации ASP.NET»
connectionStrings Element (ASP.NET Settings Schema)
appSettings Element (General Settings Schema)

Понятия

ASP.NET Configuration Overview


Вкладка «Особые ошибки», диалоговое окно «Параметры конфигурации ASP.NET»

Вкладка «Особые ошибки», диалоговое окно «Параметры конфигурации ASP.NET»
См. также
DropDown image

В случае возникновения ошибки на веб-странице ASP.NET или в одном из компонентов система ASP.NET генерирует код ошибки. Ошибки могут быть следующих типов:

  • Ошибки на этапе компиляции.

  • Ошибки синтаксического анализатора (неправильно сформированные элементы ASP.NET).

  • Ошибки конфигурации.

  • Ошибки на этапе выполнения.

По умолчанию ASP.NET динамически создает страницу ошибки, на которой приводится описание ошибки, название страницы, на которой произошла ошибка, и трассировка стека. Если включен режим отладки, то на динамически созданной странице также приводится фрагмент исходного кода, в котором произошла ошибка. Определяя особые ошибки, можно указать, как веб-приложение должно реагировать на возникновение ошибки.

Note Примечание

Подробные сведения о режиме отладки см. в разделе Вкладка «Приложение», диалоговое окно «Параметры конфигурации ASP.NET».

Отображение вкладки «Особые ошибки» в диалоговом окне «Параметры конфигурации ASP.NET»

  1. В Microsoft Windows откройте элемент панели управления Администрирование и щелкните значок Диспетчер служб IIS.

    Откроется окно диспетчера служб IIS.

  2. В разделе Службы IIS раскройте список Servername (локальный компьютер), а затем – список Веб-узлы, щелкните правой кнопкой мыши Websitename или Веб-узел по умолчанию и выберите пункт Свойства.

    Откроется диалоговое окно Свойства веб-узла.

  3. Перейдите на вкладку ASP.NET и нажмите кнопку Изменить конфигурацию.

    Откроется диалоговое окно Параметры конфигурации ASP.NET.

  4. Перейдите на вкладку Особые ошибки.

Задачи

С помощью вкладки Особые ошибки можно выполнить следующие задачи.

  • Задать стандартную страницу ошибки, которая будет отображаться в случае возникновения ошибки ASP.NET в любом месте веб-приложения.

  • Связать определенные коды ошибок HTTP с соответствующими страницами ошибок.

    Note Примечание

    Связывание можно провести только для тех ошибок, о которых уведомляется ASP.NET. Например, по умолчанию ASP.NET не получает уведомление об ошибках HTTP 404 (страница не найдена). Если нужно, чтобы эти ошибки передавались в ASP.NET, можно установить свойства веб-приложения таким образом, чтобы ошибки HTTP связывались со страницами aspx.

  • Указать, должны ли отображаться страницы особых ошибок для всех пользователей, для удаленных пользователей (не администраторов) или не должны отображаться вообще.

Элементы пользовательского интерфейса

Режим особых ошибок

Выберите режим, чтобы указать способ отображения особых ошибок.

  • Включен

    Страницы особых ошибок отображаются всегда. Используйте это значение параметра для просмотра ошибок на этапе разработки веб-приложения.

  • Выключен

    Страницы особых ошибок не отображаются. Вместо них отображается страница ошибки, динамически создаваемая ASP.NET.

  • Только для удаленных пользователей

    Ошибки перенаправляются только для запросов, которые поступают не с локального веб-сервера. Используйте этот режим, чтобы просматривать ошибки ASP.NET в ходе работы на сервере, а пользователям веб-приложения выводить особые ошибки.

URL-адрес перенаправления, используемый по умолчанию

Введите имя страницы (aspx или htm), которая будет отображаться в ответ на ошибки в веб-приложении, для которых не указан обработчик.

Унаследованные особые ошибки

Содержит список страниц особых ошибок, унаследованных из файлов конфигурации, расположенных на более высоких уровнях иерархии. Можно переопределить унаследованные параметры ошибок, добавив локальную особую ошибку для заменяемого кода состояния.

Локальные особые ошибки

Содержит список страниц ошибок, заданных специально для текущего веб-узла.

Добавить

Нажмите, чтобы открыть диалоговое окно Изменить/Добавить пользовательские обработчики ошибок, в котором можно указать код ошибки HTTP и страницу, которая будет отображаться, когда система ASP.NET определяет ошибку.

Note Примечание

Связывание можно провести только для тех ошибок, о которых уведомляется ASP.NET. Например, по умолчанию ASP.NET не получает уведомление об ошибках HTTP 404 (страница не найдена). Если нужно, чтобы эти ошибки передавались в ASP.NET, можно установить свойства веб-приложения таким образом, чтобы ошибки HTTP связывались со страницами aspx.

Необходимо указать код ошибки HTTP и URL-адрес страницы, с которой она связывается. Указываемая страница не обязательно должна находиться на текущем веб-узле.

Note Примечание

Диспетчер служб IIS не проверяет правильность указанного URL-адреса.

Изменить

Нажмите, чтобы открыть диалоговое окно Изменить/Добавить пользовательские обработчики ошибок, в котором можно изменить имя страницы или код ошибки для страницы, которая выбрана в разделе Локальные особые ошибки.

Удалить

Нажмите, чтобы удалить связывание со страницей ошибки.

См. также

Задачи

How to: Access ASP.NET Configuration Settings Programmatically

Справочные материалы

Вкладка «Проверка подлинности», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Авторизация», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Расположение», диалоговое окно «Параметры конфигурации ASP.NET»
connectionStrings Element (ASP.NET Settings Schema)
appSettings Element (General Settings Schema)

Понятия

ASP.NET Configuration Overview


Вкладка «Авторизация», диалоговое окно «Параметры конфигурации ASP.NET»

Вкладка «Авторизация», диалоговое окно «Параметры конфигурации ASP.NET»
См. также
DropDown image

Вкладка Авторизация диалогового окна Параметры конфигурации ASP.NET позволяет управлять правилами авторизации в каталоге текущего веб-узла на основании учетных записей пользователей и ролей. Учетные записи пользователей и роли можно создавать, используя проверку подлинности Microsoft Windows или проверку подлинности с помощью форм ASP.NET (система членства ASP.NET). Можно добавлять, изменять или удалять правила для каталога выбранного веб-узла. Правила применяются для текущего каталога и всех входящих в него каталогов по заданному URL-адресу, если в параметрах файла конфигурации во вложенном каталоге не указано иное.

Наследуемые правила из файла конфигурации Machine.config или из любого виртуального родительского каталога также отображаются, но их нельзя изменить. Чтобы изменить порядок действия унаследованных правил, можно создать новые параметры на уровне веб-узла. Параметры приложения всегда хранятся в виде строк.

Настройки, выполняемые на вкладке Авторизация, применяются к веб-узлу, который был выбран перед открытием диалогового окна Свойства.

Note Примечание

Параметры конфигурации могут быть унаследованы. Параметры можно задать в файле Machine.config, который является основным файлом конфигурации для всех веб-узлов на сервере. Подробные сведения о файлах конфигурации ASP.NET см. в разделе ASP.NET Configuration File Hierarchy and Inheritance.

Открытие диалогового окна «Авторизация»

  1. В Windows откройте элемент панели управления «Администрирование» и щелкните значок Диспетчер служб IIS.

    Откроется окно диспетчера служб IIS.

  2. В разделе Службы IIS раскройте список Servername (локальный компьютер), а затем – список Веб-узлы, щелкните правой кнопкой мыши Websitename или Веб-узел по умолчанию и выберите пункт Свойства.

    Откроется диалоговое окно Свойства веб-узла.

  3. Перейдите на вкладку ASP.NET и нажмите кнопку Изменить конфигурацию.

  4. Откроется диалоговое окно Параметры конфигурации ASP.NET.

  5. Перейдите на вкладку Авторизация.

Задачи

С помощью вкладки Авторизация можно выполнить следующие задачи.

  • Просмотреть правила авторизации, заданные во всех унаследованных файлах конфигурации, включая файл Machine.config.

  • Добавить, изменить или удалить правила авторизации для текущего каталога веб-узла.

Порядок правил

Правила авторизации применяются по порядку, сверху вниз. Иногда для назначения правильных разрешений приходится создавать несколько правил для одной папки. Например, может потребоваться создать правило, запрещающее доступ к папке анонимным пользователям, и правило, запрещающее доступ пользователям с ролью «Гость». В этом случае доступ к папке смогут получить только пользователи других групп (не группы «Гость»), которые вошли в систему (не являются анонимными).

Параметры файла Web.config

Параметры файла Web.config, настройка которых осуществляется посредством вкладки Безопасность, представлены в разделах <authorization>, <roleManager> и <authentication>.

Приведенный ниже фрагмент файла Web.config запрещает доступ к вложенному каталогу веб-узла. Доступ к этому вложенному каталогу могут получить администраторы и пользователь с именем John. Анонимные пользователи не смогут получить доступ.

CopyCode image Копировать код
<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <system.web>
        <authorization>
            <allow roles="administrators" />
            <allow users="John"/>
            <deny users="?" />
        </authorization>
    </system.web>
</configuration>

Элементы пользовательского интерфейса

Унаследованные правила авторизации

Содержит список унаследованных правил авторизации, заданных в файле Machine.config или виртуальном родительском каталоге согласно настройкам в ASP.NET Configuration File Hierarchy and Inheritance. Унаследованные параметры выделены курсивом, а параметры, которые были переопределены, выделены жирным шрифтом.

Локальные правила авторизации

Содержит список правил авторизации, применяемых к текущему каталогу веб-узла и всем его вложенным подкаталогам.

Добавить

Нажмите, чтобы открыть Диалоговое окно «Изменение правила» для создания нового правила.

Изменить

Нажмите, чтобы открыть Диалоговое окно «Изменение правила» для изменения выбранного правила.

Удалить

Нажмите, чтобы удалить выбранную строку из списка Локальные правила авторизации.

См. также

Задачи

How to: Access ASP.NET Configuration Settings Programmatically

Справочные материалы

Вкладка «Проверка подлинности», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Расположение», диалоговое окно «Параметры конфигурации ASP.NET»
connectionStrings Element (ASP.NET Settings Schema)
appSettings Element (General Settings Schema)

Понятия

ASP.NET Configuration Overview

Другие материалы

Оснастка MMC для ASP.NET


Вкладка «Проверка подлинности», диалоговое окно «Параметры конфигурации ASP.NET»

Вкладка «Проверка подлинности», диалоговое окно «Параметры конфигурации ASP.NET»
См. также
DropDown image

Вкладка Проверка подлинности диалогового окна Параметры конфигурации ASP.NET позволяет управлять проверкой подлинности учетных записей пользователей и ролей для текущего веб-узла. Проверка подлинности ASP.NET – это процесс получения из учетной записи пользователя учетных данных, таких как имя и пароль, для проверки предоставляемых полномочий. Полное описание процесса проверки подлинности ASP.NET см. в разделе ASP.NET Authentication.

Вкладка Проверка подлинности также позволяет добавлять, удалять и настраивать поставщиков пользователей, а также управлять ролями для заданного веб-приложения. Управление ролями ASP.NET позволяет определять ресурсы, к которым могут иметь доступ пользователи приложения. Управление ролями позволяет рассматривать группу учетных записей пользователей как одну единицу, назначив для роли несколько учетных записей. Подробные сведения об управлении ролями ASP.NET см. в разделе Understanding Role Management.

В веб-приложении можно создавать и использовать настраиваемых поставщиков пользователей. Полное описание процесса реализации настраиваемого поставщика пользователей см. в разделе Implementing a Membership Provider.

Настройки, выполняемые на вкладке Проверка подлинности, применяются к веб-узлу, который был выбран перед открытием диалогового окна Свойства.

Note Примечание

Параметры конфигурации могут быть унаследованы. Параметры можно задать в файле Machine.config, который является основным файлом конфигурации для всех веб-узлов на сервере. Подробные сведения о файлах конфигурации ASP.NET см. в разделе ASP.NET Configuration File Hierarchy and Inheritance.

Отображение вкладки «Проверка подлинности» в диалоговом окне «Параметры конфигурации ASP.NET»

  1. В Microsoft Windows откройте элемент панели управления Администрирование и щелкните значок Диспетчер служб IIS.

    Откроется окно диспетчера служб IIS.

  2. В разделе Службы IIS раскройте список Servername (локальный компьютер), а затем – список Веб-узлы, щелкните правой кнопкой мыши Websitename или Веб-узел по умолчанию и выберите пункт Свойства.

    Откроется диалоговое окно Свойства веб-узла.

  3. Перейдите на вкладку ASP.NET и нажмите кнопку Изменить конфигурацию.

    Откроется диалоговое окно Параметры конфигурации ASP.NET.

  4. Перейдите на вкладку Проверка подлинности.

Задачи

С помощью вкладки Проверка подлинности можно выполнить следующие задачи.

  • Настроить тип проверки подлинности для веб-приложения.

  • Добавить, удалить или изменить поставщиков пользователей для веб-приложения.

  • Добавить, удалить или изменить поставщиков ролей для веб-приложения.

Элементы пользовательского интерфейса

Режим проверки подлинности

Щелкните, чтобы задать режим проверки подлинности для этого веб-узла. Полное описание каждого режима проверки подлинности см. в разделе ASP.NET Authentication.

Имя файла «cookie» HTTP

Введите имя файла «cookie» HTTP, который будет использоваться для проверки подлинности на этом веб-узле. Параметр Имя файла «cookie» HTTP доступен только для настройки проверки подлинности с помощью форм.

URL для входа

Введите URL-адрес, на который перенаправляется запрос, чтобы выполнить вход в систему, в случае если не найден правильный файл «cookie» для проверки подлинности. Адрес по умолчанию – login.aspx. Параметр URL для входа доступен только для настройки проверки подлинности с помощью форм.

Защита файлов «cookie»

Щелкните, чтобы указать тип шифрования файлов «cookie», используемых для проверки подлинности. Параметр Защита файлов «cookie» доступен только для настройки проверки подлинности с помощью форм.

Таймаут файлов «cookie»

Введите время в минутах, определяющее срок действия файла «cookie», используемого для проверки подлинности. Значение по умолчанию – 30 минут. Параметр Таймаут файлов «cookie» доступен только для настройки проверки подлинности с помощью форм.

Требуется SSL

Установите этот флажок, если для передачи файла «cookie», используемого для проверки подлинности, необходимо соединение по протоколу SSL. Параметр Требуется SSL доступен только для настройки проверки подлинности с помощью форм.

Включить скользящий срок действия

Установите этот флажок, чтобы время действия файла «cookie», используемого для проверки подлинности, обнулялось, в случае если поступил запрос и истекло более половины времени таймаута. Параметр Включить скользящий срок действия доступен только для настройки проверки подлинности с помощью форм.

Класс поставщиков пользователей

Щелкните, чтобы выбрать настроенных поставщиков пользователей для этого веб-узла.

Управление поставщиками

Щелкните, чтобы открыть диалоговое окно Параметры поставщиков, в котором можно добавить, удалить или настроить поставщиков пользователей для веб-узла.

Включить управление ролями

Установите этот флажок, чтобы включить управление ролями, позволяющее назначать правила доступа для групп учетных записей пользователей.

Класс поставщиков ролей

Щелкните, чтобы выбрать настроенных поставщиков ролей для этого веб-узла.

Управление поставщиками

Щелкните, чтобы открыть диалоговое окно Параметры поставщиков, в котором можно удалить или настроить поставщиков ролей для веб-узла.

См. также

Понятия

Implementing a Membership Provider
Understanding Role Management
ASP.NET Configuration File Hierarchy and Inheritance

Другие материалы

ASP.NET Authentication
Оснастка MMC для ASP.NET


Вкладка «Приложение», диалоговое окно «Параметры конфигурации ASP.NET»

Вкладка «Приложение», диалоговое окно «Параметры конфигурации ASP.NET»
См. также
DropDown image

Вкладка Приложение диалогового окна Параметры конфигурации ASP.NET позволяет настраивать три типа параметров конфигурации.

  • Общие параметры компиляции, параметры страницы и параметры времени выполнения.

  • Параметры глобализации.

  • Параметры идентификации.

Открытие диалогового окна «Параметры конфигурации ASP.NET» с помощью диспетчера служб IIS

  1. Откройте диалоговое окно Свойства для веб-приложения.

  2. Перейдите на вкладку ASP.NET, затем нажмите кнопку Изменить конфигурацию и перейдите на вкладку Приложение.

Настройки, выполняемые на вкладке Приложение, применяются к веб-приложению, которое было выбрано перед открытием диалогового окна Свойства. Параметры, примененные на вкладке Приложение, отображаются в разделе конфигурации system.web файла Web.config для выбранного веб-приложения.

Note Примечание

Параметры конфигурации могут быть унаследованы. Параметры можно задать в файле Machine.config, который является основным файлом конфигурации для всех веб-узлов и веб-приложений на сервере. Можно создать новые параметры или переопределить унаследованные параметры путем настройки конфигурации на уровне веб-приложения.

Подробнее о диалоговом окне Параметры конфигурации ASP.NET см. в разделе ASP.NET Configuration Overview

Задачи

  • С помощью вкладки Приложение можно выполнить следующие задачи.

  • Установить язык по умолчанию для страниц ASP.NET в веб-приложении.

  • Установить тему и главную страницу, используемые по умолчанию для веб-приложения.

  • Включить отладку для веб-приложения.

  • Указать максимальное время выполнения запроса в секундах до его автоматического закрытия системой ASP.NET.

  • Задать наборы символов для кодировки содержимого запросов и ответов, а также региональные параметры, которые определяют результаты функций, зависящих от региона, таких как формат даты, чисел и денежных единиц.

  • Установить удостоверение Windows, которое будет олицетворено и с которым будут запускаться страницы ASP.NET.

Элементы пользовательского интерфейса

Вкладка Приложение включает три категории параметров.

  • Общие параметры компиляции, параметры страницы и параметры времени выполнения

  • Параметры глобализации

  • Параметры идентификации

Общие параметры компиляции, параметры страницы и параметры времени выполнения

Позволяет настраивать такие параметры конфигурации, как Язык страницы по умолчанию, Тема страницы по умолчанию, Главная страница по умолчанию, Включить отладку и Таймаут выполнения запроса (в секундах).

Язык страницы по умолчанию

Позволяет выбрать язык программирования, используемый по умолчанию в файлах динамической компиляции. Доступны следующие языки: VB (система разработки Microsoft Visual Basic), C#, JS (ПО разработки Microsoft JScript) и VJ# (инструмент разработки Microsoft Visual J#).

Тема страницы по умолчанию

Позволяет установить тему по умолчанию для всех страниц веб-приложения.

Главная страница по умолчанию

Позволяет указать путь к файлу главной страницы (относительно локального файла конфигурации).

Включить отладку

Позволяет указать, должна ли выполняться компиляция окончательных или отладочных версий двоичных файлов. Если флажок не установлен, то параметр имеет значение false.

Таймаут выполнения запроса (в секундах)

Позволяет задать максимальное время в секундах, в течение которого может выполняться запрос, прежде чем он будет автоматически закрыт системой ASP.NET.

Параметры глобализации

Позволяет настраивать такие параметры конфигурации, как Кодирование запроса, Кодирование ответа, Культура и Культура пользовательского интерфейса.

Кодирование запроса

Позволяет указать предполагаемую кодировку каждого входящего запроса, включая переданные данные и строку запроса. Значение по умолчанию – UTF-8.

Кодирование ответа

Позволяет задать кодировку содержимого ответов. Значение по умолчанию – UTF-8.

Кодировка файлов

Позволяет задать кодировку по умолчанию для синтаксического разбора файлов aspx, asmx и asax.

Культура

Позволяет выбрать культуру по умолчанию для обработки входящих веб-запросов. Культура определяет результаты функций, зависящих от региона, таких как формат даты, чисел и денежных единиц.

Культура пользовательского интерфейса

Позволяет выбрать культуру по умолчанию для обработки запросов на поиск ресурсов, зависящих от языковых стандартов.

Параметры идентификации

Позволяет настраивать такие параметры конфигурации, как Олицетворение, Имя пользователя и Пароль.

Олицетворение

Позволяет указать, должно ли олицетворение клиента использоваться при каждом запросе.

Имя пользователя

Позволяет задать имя пользователя, которое будет использоваться в случае применения олицетворения клиента при каждом запросе.

Пароль

Позволяет задать пароль, который будет использоваться в случае применения олицетворения клиента при каждом запросе.

См. также

Задачи

How to: Access ASP.NET Configuration Settings Programmatically
How to: Set the Culture and UI Culture for ASP.NET Web Page Globalization

Справочные материалы

Вкладка «Проверка подлинности», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Авторизация», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Особые ошибки», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Общие», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Расположение», диалоговое окно «Параметры конфигурации ASP.NET»

Понятия

ASP.NET Configuration Overview
ASP.NET Themes and Skins Overview
ASP.NET Master Pages Overview


Вкладка «Управление состоянием», диалоговое окно «Параметры конфигурации ASP.NET»

Вкладка «Управление состоянием», диалоговое окно «Параметры конфигурации ASP.NET»
См. также
DropDown image

Вкладка Управление состоянием диалогового окна Параметры конфигурации ASP.NET позволяет управлять состоянием и указывать сведения о странице в рамках нескольких запросов для страниц выбранного веб-узла. Состояние сеанса ASP.NET позволяет хранить и извлекать значения учетной записи пользователя во время перехода по различным страницам ASP.NET, входящим в веб-приложение. На вкладке Управление состоянием можно настроить расположение и способ хранения этих значений.

Настройки, выполняемые на вкладке Управление состоянием, применяются к веб-узлу, который был выбран перед открытием диалогового окна Свойства.

Note Примечание

Параметры конфигурации могут быть унаследованы. Параметры можно задать в файле Machine.config, который является основным файлом конфигурации для всех веб-узлов на сервере. Подробные сведения о файлах конфигурации ASP.NET см. в разделе ASP.NET Configuration File Hierarchy and Inheritance.

Открытие вкладки «Управление состоянием» в диалоговом окне «Параметры конфигурации ASP.NET»

  1. В Microsoft Windows нажмите кнопку Пуск, выберите пункты Все программы и Администрирование, а затем щелкните значок Диспетчер служб IIS.

    Откроется окно диспетчера служб IIS.

  2. В разделе Службы IIS раскройте список Servername (локальный компьютер), а затем – список Веб-узлы, щелкните правой кнопкой мыши Websitename или Веб-узел по умолчанию и выберите пункт Свойства.

    Откроется диалоговое окно Свойства веб-узла.

  3. Перейдите на вкладку ASP.NET и нажмите кнопку Изменить конфигурацию.

    Откроется диалоговое окно Параметры конфигурации ASP.NET.

  4. Перейдите на вкладку Управление состоянием.

Задачи

С помощью вкладки Управление состоянием можно выполнить следующие задачи.

  • Выбрать режим состояния сеанса для данного веб-приложения.

  • Настроить режимы состояния сеанса SQLServer и StateServer.

Элементы пользовательского интерфейса

Режим состояния сеанса

Выберите режим состояния сеанса. По умолчанию установлен режим состояния сеанса InProc или в памяти на веб-сервере. Список режимов состояния сеанса, доступных в ASP.NET, см. в разделе Session-State Modes.

Режим без файлов «cookie»

Выберите режим файлов «cookie», чтобы указать, когда использовать файлы «cookie» для хранения данных пользователя. Сведения о доступных режимах без файлов «cookie» см. в разделе HttpCookieMode.

Таймаут сеанса

Введите время в минутах, которое может проходить между запросами без прерывания сеанса.

Строка подключения

Введите строку подключения, задающую имя сервера и номер порта для службы состояний ASP.NET в режиме StateServer.

Таймаут сети

Введите время в секундах, которое может проходить между запросами без прерывания сетевого сеанса в режиме StateServer.

Строка подключения

Введите строку подключения, задающую имя сервера и номер порта для режима SQLServer.

См. также

Справочные материалы

HttpCookieMode

Понятия

Session-State Modes
ASP.NET Configuration File Hierarchy and Inheritance

Другие материалы

Оснастка MMC для ASP.NET


Вкладка «Расположение», диалоговое окно «Параметры конфигурации ASP.NET»

Вкладка «Расположение», диалоговое окно «Параметры конфигурации ASP.NET»
См. также
DropDown image

Параметры конфигурации можно применить к определенному веб-приложению или каталогу при помощи тега location с соответствующим атрибутом path. Атрибут path используется для указания определенного файла или вложенного каталога, к которым применяются особые параметры конфигурации. С помощью вкладки Расположение диалогового окна Параметры конфигурации ASP.NET можно внести параметры конфигурации в файл конфигурации.

Вкладка Расположение диалогового окна Параметры конфигурации ASP.NET позволяет управлять следующими элементами:

  • Настройками расположений, то есть настройками пути, определенными в файлах конфигурации узлов.

Открытие диалогового окна «Параметры конфигурации ASP.NET» с помощью диспетчера служб IIS

  1. Откройте диалоговое окно Свойства для веб-приложения.

  2. Перейдите на вкладку ASP.NET, затем нажмите кнопку Изменить конфигурацию и перейдите на вкладку Приложение.

Настройки, выполняемые на вкладке Расположение, применяются к веб-приложению, которое было выбрано перед открытием диалогового окна Свойства.

Примечание. Параметры конфигурации могут наследоваться. Параметры можно задать в файле Machine.config, который является основным файлом конфигурации для всех веб-узлов и веб-приложений на сервере. Можно создать новые параметры или заменить наследуемые параметры путем настройки конфигурации на уровне веб-приложения в файле Web.config.

Подробнее о диалоговом окне Параметры конфигурации ASP.NET см. в разделе ASP.NET Configuration Overview

Задачи

С помощью вкладки Расположение можно выполнить следующую задачу.

  • Указать настройки пути, определенные в файле конфигурации узла.

Элементы пользовательского интерфейса

Настройки расположения

Добавить

Позволяет открыть диалоговое окно Добавить расположение, в котором можно указать индекс и расположение, чтобы добавить новое расположение в диалоговое окно Настройки расположения диалогового окна Параметры конфигурации ASP.NET.

Изменить конфигурацию

Позволяет открыть новую вкладку Параметры конфигурации ASP.NET для узла, указанного заданием пути в файле конфигурации.

Удалить

Позволяет удалить запись о расположении из файла конфигурации данного узла.

См. также

Задачи

How to: Access ASP.NET Configuration Settings Programmatically

Справочные материалы

Вкладка «Общие», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Проверка подлинности», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Авторизация», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Особые ошибки», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Приложение», диалоговое окно «Параметры конфигурации ASP.NET»

Понятия

ASP.NET Configuration Overview
Securing ASP.NET Configuration


Диалоговое окно «Изменить/Добавить строку подключения»

Диалоговое окно «Изменить/Добавить строку подключения»
См. также
DropDown image

Диалоговое окно Изменить/Добавить строку подключения позволяет создать новое свойство ConnectionString или изменить существующее свойство ConnectionString. Диалоговое окно Изменить/Добавить строку подключения появляется после нажатия кнопки Добавить или Изменить на вкладке Общие диалогового окна Параметры конфигурации ASP.NET.

Открытие диалогового окна «Параметры конфигурации ASP.NET» с помощью диспетчера служб IIS

  1. Откройте диалоговое окно Свойства для веб-приложения.

  2. Перейдите на вкладку ASP.NET, затем нажмите кнопку Изменить конфигурацию и перейдите на вкладку Приложение.

Можно нажать кнопку Добавить на вкладке Общие в диалоговом окне Параметры конфигурации ASP.NET, чтобы открыть диалоговое окно Изменить/Добавить строку подключения. После этого можно задать имя или ключ для свойства ConnectionString и параметр Connection.

Также можно нажать кнопку Изменить на вкладке Общие в диалоговом окне Параметры конфигурации ASP.NET, чтобы открыть диалоговое окно Изменить/Добавить строку подключения, в котором будет можно изменить существующее свойство ConnectionString. Выбранное свойство ConnectionString появляется в окне Параметр подключения.

Note Примечание

Можно переопределить унаследованные параметры. В этом случае переопределенный параметр применяется только к выбранному веб-приложению. Нельзя изменить значение унаследованного параметра так, чтобы повысить его значение в конфигурационной иерархии.

Подробнее о диалоговом окне Параметры конфигурации ASP.NET см. в разделе ASP.NET Configuration Overview

Задачи

С помощью диалогового окна Изменить/Добавить строку подключения можно выполнять следующие задачи.

  • Добавить новое свойство ConnectionString в диалоговое окно Диспетчер строки подключения на вкладке Общие.

  • Изменить существующее свойство ConnectionString в диалоговом окне Диспетчер строки подключения на вкладке Общие.

Элементы пользовательского интерфейса

Изменить/Добавить строку подключения

Имя

Позволяет задать имя свойства ConnectionString.

Если диалоговое окно Изменить/Добавить строку подключения было открыто нажатием кнопки Изменить на вкладке Общие, будет невозможно задать имя для строки подключения.

Параметр подключения

Позволяет задать значение свойства ConnectionString.

Если диалоговое окно Изменить/Добавить строку подключения было открыто нажатием кнопки Изменить на вкладке Общие, в окне Параметр подключения будет отображаться значение существующего свойства ConnectionString.

ОК

Позволяет применить новое созданное свойство ConnectionString или применить изменения, внесенные в существующее свойство ConnectionString.

Отмена

Закрывает диалоговое окно Изменить/Добавить строку подключения. Изменения не записываются в диспетчер строки подключения.

См. также

Справочные материалы

Вкладка «Общие», диалоговое окно «Параметры конфигурации ASP.NET»
connectionStrings Element (ASP.NET Settings Schema)

Понятия

ASP.NET Configuration Overview


Диалоговое окно «Изменить/Добавить параметры приложения»

Диалоговое окно «Изменить/Добавить параметры приложения»
См. также
DropDown image

Параметры приложения представляют собой простые пары «ключ/значение», которые позволяют централизованно создавать значения для всего приложения, доступ к которым впоследствии можно получить из любого места веб-приложения. Параметры приложения, определенные как часть конфигурации в файле Web.config, всегда можно легко изменить. В диалоговом окне Параметры приложения на вкладке Общие отображается список пар «ключ/значение» для параметров приложения.

С помощью диалогового окна Изменить/Добавить параметры приложения можно создавать и изменять параметры веб-приложения.

Можно нажать кнопку Добавить в разделе Параметры приложения вкладки Общие в диалоговом окне Параметры конфигурации ASP.NET, чтобы открыть диалоговое окно Изменить/Добавить параметры приложения. Далее можно задать ключ и значение для свойства AppSettings, которые будут добавлены в диалоговое окно Параметры приложения и в файл Web.config для веб-приложения.

Аналогичным образом можно выбрать параметр в диалоговом окне Параметры приложения и нажать кнопку Изменить. Далее можно изменить значение выбранного свойства AppSettings. Изменения вносятся в диалоговое окно Параметры приложения и в файл Web.config для этого веб-приложения.

Открытие диалогового окна «Параметры конфигурации ASP.NET» с помощью диспетчера служб IIS

  1. Откройте диалоговое окно Свойства для веб-приложения.

  2. Перейдите на вкладку ASP.NET, затем нажмите кнопку Изменить конфигурацию и перейдите на вкладку Приложение.

Подробнее о диалоговом окне Параметры конфигурации ASP.NET см. в разделе ASP.NET Configuration Overview

Задачи

С помощью диалогового окна Изменить/Добавить параметры приложения можно выполнять следующие задачи.

  • Создавать новые пары «имя/значение», которые позволяют централизованно задавать значения для всего приложения.

  • Изменять пары «ключ/значение», уже имеющиеся в веб-приложении.

Элементы пользовательского интерфейса

Ключ

Позволяет добавить новый ключ для пары «ключ/значение». Если была нажата кнопка Изменить, будет невозможно задать новый ключ в текстовом поле.

Значение

Позволяет добавить новое значение для пары «ключ/значение». Значение выбранной пары «ключ/значение» можно изменить и в случае, если была нажата кнопка Изменить.

ОК

Позволяет применить новое созданное свойство AppSettings или применить изменения в существующем параметре приложения.

Отмена

Позволяет закрыть диалоговое окно Изменить/Добавить параметры приложения без внесения изменений в параметры приложения и файл Web.config для этого веб-приложения.

См. также

Справочные материалы

Вкладка «Общие», диалоговое окно «Параметры конфигурации ASP.NET»
appSettings Element (General Settings Schema)

Понятия

ASP.NET Configuration Overview


Диалоговое окно «Изменить/Добавить пользовательские обработчики ошибок»

Диалоговое окно «Изменить/Добавить пользовательские обработчики ошибок»
См. также
DropDown image

Диалоговое окно Изменить/Добавить пользовательские обработчики ошибок позволяет связать код ошибки с определенной страницей ошибки. Когда ASP.NET генерирует код ошибки, отображается указанная страница.

Настройки, выполняемые в диалоговом окне Изменить/Добавить пользовательские обработчики ошибок, применяются к веб-приложению, которое было выбрано перед открытием диалогового окна Свойства.

Note Примечание

Параметры конфигурации могут быть унаследованы. Параметры можно задать в файле Machine.config, который является основным файлом конфигурации для всех веб-узлов и приложений на сервере. Можно создать новые параметры или заменить унаследованные параметры путем настройки конфигурации на уровне веб-приложения.

Примечание. ASP.NET не получает некоторые коды ошибок, в том числе 404. Можно связывать только те ошибки, которые генерируются внутри ASP.NET.

Открытие диалогового окна «Изменить/Добавить пользовательские обработчики ошибок»

  1. В Microsoft Windows откройте элемент панели управления «Администрирование» и щелкните значок Диспетчер служб IIS.

    Откроется окно диспетчера служб IIS.

  2. В разделе Службы IIS раскройте список Servername (локальный компьютер), а затем – список Websitename или Веб-узел по умолчанию и выберите пункт Свойства.

    Откроется диалоговое окно Свойства веб-узла.

  3. Перейдите на вкладку ASP.NET и нажмите кнопку Изменить конфигурацию.

    Откроется диалоговое окно Параметры конфигурации ASP.NET.

  4. Перейдите на вкладку Особые ошибки.

    • Чтобы добавить пользовательский обработчик ошибок, нажмите кнопку Добавить.

    • Чтобы изменить пользовательский обработчик ошибок, нажмите кнопку Изменить.

    Откроется диалоговое окно Изменить/Добавить пользовательские обработчики ошибок.

Элементы пользовательского интерфейса

Код состояния

Введите код ошибки HTTP, чтобы связать его со страницей ошибок.

URL-адрес перенаправления

Введите URL-адрес страницы, которую будет отображать ASP.NET в ответ на полученный код ошибки. Указываемая страница не обязательно должна находиться на текущем веб-узле.

Note Примечание

ASP.NET не проверяет правильность указанного URL-адреса.

ОК

Нажмите, чтобы сохранить пользовательский обработчик ошибок.

Отмена

Нажмите, чтобы отменить изменения.

См. также

Справочные материалы

Вкладка «Особые ошибки», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Особые ошибки», диалоговое окно «Параметры конфигурации ASP.NET»


Диалоговое окно «Изменение правила»

Диалоговое окно «Изменение правила»
См. также
DropDown image

Диалоговое окно Изменение правила позволяет создать новое правило авторизации или изменить существующее правило. Учетные записи пользователей и роли можно создавать, используя проверку подлинности Microsoft Windows или проверку подлинности с помощью форм ASP.NET (система членства ASP.NET).

Открытие диалогового окна «Изменение правила»

  1. В Windows откройте элемент панели управления Администрирование и щелкните значок Диспетчер служб IIS.

    Откроется окно диспетчера служб IIS.

  2. В разделе Службы IIS раскройте список Servername (локальный компьютер), а затем – список Веб-узлы, щелкните правой кнопкой мыши Websitename или Веб-узел по умолчанию и выберите пункт Свойства.

    Откроется диалоговое окно Свойства веб-узла.

  3. Перейдите на вкладку ASP.NET и нажмите кнопку Изменить конфигурацию.

    Откроется диалоговое окно Параметры конфигурации ASP.NET.

  4. Перейдите на вкладку Авторизация.

    • Чтобы добавить правило, нажмите кнопку Добавить.

    • Чтобы изменить правило, выберите его и нажмите кнопку Изменить.

    Появится диалоговое окно Изменение правила.

Задачи

С помощью диалогового окна Изменение правила можно выполнять следующие задачи.

  • Создание нового правила авторизации или изменение существующего правила.

Элементы пользовательского интерфейса

Тип правила

Нажмите кнопку Разрешить, чтобы разрешить доступ всем пользователям.

-Или-

Нажмите кнопку Запретить, чтобы запретить доступ всем пользователям.

Подробные сведения о правилах см. в разделе AuthorizationRuleCollection.

Команды

Выберите значение Все команды, чтобы разрешить доступ всем методам передачи HTTP ASP.NET. Значение Все команды выбрано по умолчанию.

Выберите значение Определенные команды, а затем через запятую введите методы передачи HTTP, которым разрешен доступ.

В ASP.NET зарегистрированы следующие команды: GET, HEAD, POST и DEBUG.

Пользователи и роли

Обязательно.

Чтобы применить правило, выполните одно или несколько из следующих действий.

  • Выберите пункт Все пользователи, чтобы применить правило ко всем пользователям.

  • Выберите пункт Анонимные пользователи, чтобы применить правило только к анонимным пользователям.

  • Выберите пункт Пользователи, а затем через запятую введите имена учетных записей пользователей, чтобы применить правило к определенной группе пользователей.

  • Установите флажок Роли и через запятую введите имена ролей, чтобы применить правило к определенному набору ролей.

Если выбраны параметры Пользователи и Роли, правило применяется только к тем учетным записям пользователей, которые входят в указанные роли.

Для определения учетных записей пользователей и ролей воспользуйтесь проверкой подлинности Windows или проверкой подлинности с помощью форм ASP.NET (система членства ASP.NET).

ОК

Нажмите, чтобы применить правило.

Отмена

Нажмите, чтобы отменить изменения.

См. также

Задачи

How to: Implement Simple Forms Authentication

Справочные материалы

Вкладка «Авторизация», диалоговое окно «Параметры конфигурации ASP.NET»
Вкладка «Авторизация», диалоговое окно «Параметры конфигурации ASP.NET»

Понятия

Forms Authentication Across Applications

Другие материалы

Managing Authorization Using ASP.NET Roles (Visual Studio)


Диалоговое окно «Добавить расположение»

Диалоговое окно «Добавить расположение»
См. также
DropDown image

Диалоговое окно Добавить расположение позволяет добавить новый параметр настройки расположения для веб-узла. Параметры настройки могут быть применены к определенным ресурсам с помощью тега <location> с соответствующим атрибутом path. Атрибут path используется для указания определенного файла или вложенного каталога, к которым применяются особые параметры конфигурации.

Диалоговое окно Добавить расположение появляется после нажатия кнопки Добавить на вкладке Расположение диалогового окна Параметры конфигурации ASP.NET.

Открытие диалогового окна «Параметры конфигурации ASP.NET» с помощью диспетчера служб IIS

  1. Откройте диалоговое окно Свойства для веб-приложения.

  2. Перейдите на вкладку ASP.NET, затем нажмите кнопку Изменить конфигурацию и перейдите на вкладку Приложение.

С помощью диалогового окна Добавить расположение можно выполнять следующие задачи.

  • Задать индекс (ключ) элемента расположения.

  • Указать значение расположения, которое добавляется в список настроек Расположение.

Элементы пользовательского интерфейса

Индекс

Задает индекс (ключ) элемента расположения.

Расположение

Задает значение элемента, добавляемого в список. (Например, путь к определенному файлу или каталогу.)

ОК

Применяет новое значение расположения, которое введено в окно Настройки расположения в диалоговом окне Параметры конфигурации ASP.NET, и закрывает диалоговое окно Добавить расположение.

Отмена

Закрывает диалоговое окно Добавить расположение. Изменения, сделанные в окне Настройки расположения, не записываются.

См. также

Справочные материалы

Вкладка «Расположение», диалоговое окно «Параметры конфигурации ASP.NET»
Local IIS Tab, Choose Location/Open Web Site Dialog Box

Понятия

ASP.NET Configuration Overview


dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}
DropDown image

dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

Full Text Search and Index Debug Topic graphic