Программа просмотра Assembly Cache Viewer

Руководство разработчика по .NET Framework
Программа просмотра Assembly Cache Viewer
DropDown image

Assembly Cache Viewer является расширением оболочки Windows, позволяющим просматривать содержимое глобального кэша сборок и управлять им с помощью проводника Windows.

Использование Assembly Cache Viewer

С помощью программы просмотра Assembly Cache Viewer можно выполнять следующие действия:

  • Просматривать содержимое кэша.

  • Просматривать и изменять размер кэша, используемый для загрузки.

  • Просматривать свойства отдельной сборки.

  • Добавлять сборки в кэш.

  • Удалять сборки из кэша.

  • Отображать справочные сведения.

Просмотр содержимого кэша сборки

  • Перейдите во вложенную папку \assembly папки Windows <Системный диск>:\<папка Windows>\assembly в проводнике Windows Explorer. Отобразится содержимое глобального кэша сборок.

    Файл Shfusion.dll отображение содержимого папки сборки в виде, отличном от отображения содержимого обычной папки Windows. Названия сборок, установленных в глобальном кэше сборок, с подробными сведениями о каждом типе, версии, культуре и маркере открытого ключа сборки.

    Файл Shfusion.dll находится в папке %windir%\Microsoft.NET\Framework\vx.x.xxxx, где vx.x.xxxx указывает самую последнюю из установленных версий .NET Framework. Например, если установлены версии v1.1.4322 и v1.0.5000, используется v1.1.4322.

На следующем снимке экрана показано содержимое кэша сборки, отображаемое в программе просмотра.

Содержимое глобального кэша сборок

Чтобы просмотреть и изменить размеры кэша для загрузки

  • Выберите Настройки конфигурации кэша в меню Сервис на компьютерах, работающих под управлением Windows NT, или в меню Вид на компьютерах, работающих под управлением Windows 98. Можно также воспользоваться значком Настройки конфигурации кэша на панели инструментов.

    Появится диалоговое окно Свойства кэша. Это окно сходно с традиционным диалоговым окном свойств диска, за исключением того, что в нем отображается использованный объем кэша (в мегабайтах).

На следующем снимке экрана представлено диалоговое окно Свойства кэша.

Диалоговое окно "Свойства кэша"

Чтобы просмотреть свойства сборки

  • Щелкните правой кнопкой мыши имя сборки и выберите в контекстном меню пункт Свойства.

    Появится диалоговое окно "Свойства", в котором отображается имя , версия, культура, открытый ключ сборки, база кода, на которой основана сборка, и дата последнего изменения сборки. Свойства сборки можно также просмотреть из меню Файл.

На следующем снимке экрана представлено диалоговое окно "Свойства" сборки System.Data.

Диалоговое окно свойств сборки

Чтобы добавить сборку в кэш

  • С помощью проводника Windows перетащите файл, содержащий манифест, в каталог кэша сборки. В кэш могут быть добавлены только сборки со строгим именованием.

Если у вас имеется .NET Framework SDK, то для добавления сборки в кэш можно использовать средство Global Assembly Cache Tool (Gacutil.exe).

Чтобы удалить сборку из кэша

  • Щелкните правой кнопкой мыши имя сборки и выберите в контекстном меню пункт Удалить.

Сборку можно также удалить с помощью меню Файл или воспользовавшись средствомGacutil.exe, если у вас имеется .NET Framework SDK.

Чтобы отобразить справку для программы просмотра

  • Используйте клавишу F1 или выберите пункт Разделы справки в меню Справка.

Чтобы внести предложение или сообщить о неполадке в работе справки или другой функции данного продукта, перейдите на страницу отзывов.


shfusionhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}
DropDown image

shfusionhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

Чтобы внести предложение или сообщить о неполадке в работе справки или другой функции данного продукта, перейдите на страницу отзывов.