Информационные службы Интернета

Информационные службы Интернета (Internet Information Services, IIS) упрощают публикацию различных сведений в Интернете или интрасети. В состав IIS входит обширный набор административных средств управления веб-узлами и веб-сервером. Используя такие программные средства, как активные серверные страницы (Active Server Pages, ASP), можно создавать и развертывать гибкие, масштабируемые веб-приложения. Службы IIS не устанавливаются по умолчанию, но их можно добавить с помощью диалогового окна Установка и удаление программ, открываемого на панели управления. Дополнительные сведения см. в разделе Установка IIS.

Примечание. Службы IIS в составе Windows XP Professional предназначены для использования в домашней или офисной системе. IIS Professional может обслуживать одновременно не более 10 клиентских подключений и не предоставляет всех возможностей серверных версий. IIS предлагается в домашних и профессиональных версиях Windows взамен прежней стандартной личной веб-службы (Personal Web Service, PWS). Обновление PWS предыдущей версии Windows не предусмотрено.

Если установка IIS уже выполнена, можно просмотреть документацию продукта, введя в адресной строке обозревателя путьhttp://localhost/iisHelp/ и нажав кнопку ВВОД.


Установка IIS

Установка IIS, добавление и удаление необязательных компонентов IIS выполняется в диалоговом окне Установка и удаление программ, открываемом на панели управления. Перед установкой IIS необходимо установить ряд обязательных программных средств. Изучите контрольный список программного обеспечения IIS перед тем, как приступать к установке IIS.

Контрольный список программного обеспечения IIS

Прежде чем устанавливать IIS, необходимо установить протокол TCP/IP и служебные программы связи.

Желательно также установить следующие дополнительные компоненты.

  • На компьютере интрасети рекомендуется установить службу DNS (Domain Name System — система доменных имен). В небольшой интрасети на всех сетевых компьютерах можно использовать файл Hosts или Lmhosts. Это необязательное условие, но оно дает пользователям возможность применять понятные текстовые имена вместо IP-адресов. В Интернете веб-узлы обычно используют имена DNS. Если доменное имя узла зарегистрировано, для доступа к узлу достаточно ввести это имя в обозревателе.
  • По соображениям безопасности корпорация Майкрософт рекомендует форматировать все диски IIS для файловой системы NTFS.
  • Microsoft FrontPage позволяет создавать веб-узлы, а также редактировать их. Приложение FrontPage является редактором WYSIWYG с удобным графическим интерфейсом для выполнения таких задач, как вставка таблиц, рисунков и сценариев.
  • Microsoft Visual InterDev служит для разработки интерактивных веб-приложений.

Дополнительные сведения о протоколе TCP/IP и программах связи, службе DNS и средствах безопасности NTFS см. в электронной документации Windows XP Professional.

Процедура установки IIS

Во время установки IIS устанавливаются такие необязательные компоненты, как «Общие файлы», «Документация» и оснастка «Internet Information Services». Установку этих компонентов можно отменить, но это может привести к ограничению функциональных возможностей или выключению служб IIS. Если вы незнакомы с этими необязательными компонентами и их ролью в работе IIS, установите IIS с параметрами, предлагаемыми по умолчанию. Установив IIS, прочитайте раздел «Установка необязательных компонентов IIS» в электронной документации IIS.

Чтобы установить IIS, добавить или удалить необязательные компоненты

  1. Нажмите кнопку Пуск, выберите команду Панель управления и затем выберите Установка и удаление программ.
  2. Нажмите кнопку Добавление и удаление компонентов Windows. Откроется окно мастера компонентов Windows.
  3. Следуя появляющимся на экране инструкциям, установите IIS, а также удалите или добавьте компоненты IIS.

Примечания

  • Если выполняется обновление системы Windows NT 4.0 Workstation, в которой была установлена служба IIS, до уровня Windows XP Professional, службы IIS устанавливаются по умолчанию. Если службы IIS не были установлены в Windows NT 4.0 Workstation, их придется устанавливать вручную.
  • Личный веб-сервер (Personal Web Server, PWS) в Windows XP Professional не поддерживается. Если требуется обновить продукт Windows, предназначенный для домашнего или личного пользования, то для обеспечения аналогичных функциональных возможностей веб-сервера необходимо установить IIS.
  • Дополнительные сведения об информационных службах Интернета см. в электронной документации IIS по адресу http://localhost/iisHelp/ (наберите этот адрес в адресном поле обозревателя и нажмите клавишу ВВОД).


Контрольный список программного обеспечения IIS

Прежде чем устанавливать IIS, необходимо установить протокол TCP/IP и служебные программы связи.

Желательно также установить следующие дополнительные компоненты.

  • На компьютере интрасети рекомендуется установить службу DNS (Domain Name System — система доменных имен). В небольшой интрасети на всех сетевых компьютерах можно использовать файл Hosts или Lmhosts. Это необязательное условие, но оно дает пользователям возможность применять понятные текстовые имена вместо IP-адресов. В Интернете веб-узлы обычно используют имена DNS. Если доменное имя узла зарегистрировано, для доступа к узлу достаточно ввести это имя в обозревателе.
  • По соображениям безопасности корпорация Майкрософт рекомендует форматировать все диски IIS для файловой системы NTFS.
  • Microsoft FrontPage позволяет создавать веб-узлы, а также редактировать их. Приложение FrontPage является редактором WYSIWYG с удобным графическим интерфейсом для выполнения таких задач, как вставка таблиц, рисунков и сценариев.
  • Microsoft Visual InterDev служит для разработки интерактивных веб-приложений.

Дополнительные сведения о протоколе TCP/IP и программах связи, службе DNS и средствах безопасности NTFS см. в электронной документации Windows XP Professional.


Тестирование и устранение неполадок IIS

В этом разделе описываются основные процедуры, помогающие тестировать установленный веб-сервер IIS и устранять его неполадки.

Тестирование IIS

Установив систему Windows XP Professional, следует проверить, правильно ли работает сервер IIS.

Чтобы проверить веб-узел в интрасети

  1. Запустите веб-обозреватель, например Microsoft Internet Explorer.
  2. Введите в поле Адрес URL-адрес домашнего каталога. URL-адрес вводится в следующем формате: http://имя_веб_узла/default.

По умолчанию IIS ищет в указанном каталоге домашнюю страницу с именем default.htm, default.asp или iisstart.asp. Если веб-обозреватель возвратит ошибку, обратитесь к Таблице устранения неполадок, где указан предлагаемый порядок действий.

Чтобы проверить веб-узел в Интернете

Сервер IIS следует тестировать с компьютера, расположенного в другой локальной сети.

  1. Откройте веб-обозреватель, например Microsoft Internet Explorer, на компьютере, имеющем активное подключение к Интернету.
  2. Введите в поле Адрес URL-адрес домашнего каталога сервера. URL-адрес вводится в следующем формате: http://имя_веб_узла/default.

По умолчанию IIS ищет в указанном каталоге домашнюю страницу с именем default.htm, default.asp или iisstart.asp. Если веб-обозреватель возвратит ошибку, обратитесь к Таблице устранения неполадок, где указан предлагаемый порядок действий.

Таблица устранения неполадок

Ошибка | См. раздел
Сервер не найден | Проверка связи с сервером с помощью команды ping
Не удается отобразить страницу | Проверка связи с сервером с помощью команды ping и Перезапуск IIS
В процессе разработки или Узел, к которому выполняется обращение, не имеет в настоящее время домашней страницы | Проверка и изменение местоположения содержимого веб-узла, отображаемого по умолчанию

Устранение неполадок

В данном разделе рассматриваются следующие процедуры.

  • Проверка связи с сервером с помощью команды ping
  • Проверка и изменение местоположения содержимого веб-узла, отображаемого по умолчанию
  • Проверка наличия файлов

Проверка связи с сервером с помощью команды ping

Если веб-обозреватель возвратил сообщение об ошибке Сервер не найден или Не удается отобразить страницу, проверьте с помощью команды ping следующее:

  • успешно ли сервер разрешения имен преобразует имя искомого веб-сервера IIS в IP-адрес;
  • отвечает ли сервер на сетевые запросы с удаленного компьютера.

Команда ping вводится в окне командной строки. Прежде чем посылать ее на сервер, необходимо узнать имя сервера или его IP-адрес. Если указывается имя сервера, находящегося в интрасети, нужно использовать NetBios-имя; если указывается имя сервера, подключающегося к Интернету, следует использовать его полное доменное имя (fully qualified domain name, FQDN).

Чтобы определить NetBios-имя

  1. В меню Пуск щелкните правой кнопкой мыши пункт Мой компьютер, а затем выберите команду Свойства.
  2. Откройте вкладку Имя компьютера и нажмите кнопку Свойства. В поле Имя компьютера: отображается NetBios-имя сервера.

Чтобы определить полное доменное имя

  1. В меню Пуск щелкните правой кнопкой мыши пункт Мой компьютер, а затем выберите команду Свойства.
  2. Откройте вкладку Имя компьютера. В поле Полное имя: отображается полное доменное имя сервера.

Чтобы определить IP-адрес

  • Введите на сервере IIS в окне командной строки команду ipconfig. Дополнительные сведения о команде ipconfig см. по ссылке См. также.

Внимание! Для адекватного тестирования сервера команду ping необходимо ввести с удаленного компьютера. Если это сделать на самом сервере, проверка связи сервера с самим собой выполняться не будет.

Чтобы проверить связь с сервером, указав его имя

Если сервер находится в интрасети, проверьте связь с ним с помощью команды ping, указав NetBios-имя.

  1. В окне командной строки удаленного компьютера введите команду ping имя_сервера
  2. Нажмите клавишу ВВОД.

Если сервер находится в Интернете, проверьте связь с ним с помощью команды ping, указав полное доменное имя сервера.

  • В окне командной строки удаленного компьютера введите команду ping www.полное_доменное_имя.com

После ввода команды ping с именем сервера произойдет одно из следующих событий:

  • веб-сервер возвратит четыре ответа, содержащие его IP-адрес; это будет означать, что сервер способен отвечать на сетевые запросы;
  • возвращается сообщение об ошибке, такое, как Превышен интервал ожидания для запроса или Неизвестный узел.

Если получена ошибка Превышен интервал ожидания для запроса, значит, веб-сервер не отвечает на сетевые запросы или на участке между ним и удаленным компьютером произошел какой-то сбой в сети. Дополнительные сведения по устранению неполадок см. по ссылке См. также.

Если получена ошибка Неизвестный узел, попробуйте выполнить команду ping с IP-адресом сервера, чтобы определить, успешно ли проходит процедура разрешения имени.

Чтобы проверить связь с сервером, указав его IP-адрес

  • В окне командной строки удаленного компьютера введите команду ping IP_адрес

После ввода команды ping произойдет одно из следующих событий:

  • веб-сервер возвратит четыре ответа, содержащие его IP-адрес; это будет означать, что сервер способен отвечать на сетевые запросы;
  • возвращается сообщение об ошибке, такое как Превышен интервал ожидания для запроса или Неизвестный узел.

Если сервер отвечает на команду ping с его IP-адресом, но не отвечает на команду ping с именем сервера, значит, неправильно выполняется разрешение имени. Найдите описание процедур устранения неполадок в электронной справке Windows XP Professional, задав поиск по ключевым словам разрешение имен.

Если возвращается ошибка Превышен интервал ожидания для запроса или Неизвестный узел, значит, веб-сервер не отвечает на сетевые запросы, или на участке между ним и удаленным компьютером произошел какой-то сбой в сети. Дополнительные сведения по устранению неполадок см. по ссылке См. также.

Проверка и изменение местоположения содержимого веб-узла, отображаемого по умолчанию

При получении сообщения В процессе разработки или Узел, к которому выполняется обращение, не имеет в настоящее время домашней страницы следует проверить и в случае необходимости изменить местоположение веб-узла, отображаемого по умолчанию. Содержимое этого узла находится в каталоге x:\inetpub\wwwroot, где x — имя диска, на котором установлена ОС Windows XP Professional. Например, если система Windows XP Professional установлена на диске C, файлы содержимого домашней страницы по умолчанию будут храниться в каталоге c:\inetpub\wwwroot.

Внимание! Проверку местоположения файлов содержимого следует проводить, войдя в систему на сервере, на котором запущены службы IIS.

Чтобы определить местоположение содержимого веб-узла, отображаемого по умолчанию

  1. Откройте оснастку IIS. (В меню Пуск выберите команду Выполнить и введите inetmgr в поле Открыть.)
  2. Откройте в левой части окна оснастки узел сервера. Звездочка между значком сервера и его именем указывает на то, что сервер локальный.
  3. Выделите элемент Веб-узел по умолчанию.
  4. Выберите в меню Действие команду Свойства.
  5. Откройте вкладку Домашний каталог. В поле Локальный путь появится путь папки, в которой находится содержимое веб-узла, отображаемого по умолчанию.

Примечание. Если требуется изменить локальный путь, нажмите кнопку Обзор на вкладке «Домашний каталог» или введите новое местоположение в поле Локальный путь. Убедитесь, что файлы содержимого находятся в указанной папке. Для получения дополнительных сведений нажмите кнопку Справка на вкладке «Домашний каталог».

Чтобы проверить наличие файлов содержимого в соответствующей папке

  • Определив местоположение содержимого веб-узла, отображаемого по умолчанию, убедитесь с помощью проводника Windows, что файлы действительно находятся в этой папке. В противном случае определите их фактическое размещение и обновите местоположение содержимого веб-узла, отображаемого по умолчанию, на вкладке «Домашний каталог».

Перезапуск IIS

В случае получения сообщения об ошибке Не удается отобразить страницу может возникнуть необходимость перезапустить IIS, если причину неполадок не удастся выявить в результате процедуры Проверка связи с сервером с помощью команды ping. Запуск и остановка веб-узлов на веб-сервере производятся в оснастке IIS; можно также перезапустить службу публикации в Вебе (WWW Publishing), что приведет к повторному запуску IIS на уровне сервера. Перезапуск службы WWW Publishing затрагивает все узлы, открытые с указанного компьютера. Для выполнения процедуры перезапуска IIS необходимо являться членом группы администраторов на соответствующем компьютере Windows XP Professional. Дополнительные сведения о пользователях и группах можно найти в электронной справке Windows XP Professional, задав поиск по ключевому слову группа.

Внимание! Перезапускать службы IIS необходимо, войдя в систему на сервере, на котором они выполняются.

Перезапуск веб-узла

  1. Откройте оснастку IIS. (В меню Пуск выберите команду Выполнить и введите inetmgr в поле Открыть.)
  2. Откройте в левой части окна оснастки узел сервера. Звездочка между значком сервера и его именем указывает на то, что сервер локальный.
  3. Выделите веб-узел, который требуется перезапустить.
  4. В меню Действие выберите команду Остановить. После остановки веб-узла рядом с его именем в оснастке IIS появится пометка «остановлено».
  5. Чтобы перезапустить веб-узел, в меню «Действие» выберите команду Пуск.

Перезапуск службы WWW

  1. Откройте оснастку IIS. (В меню Пуск выберите команду Выполнить и введите inetmgr в поле Открыть.)
  2. Откройте в левой части окна оснастки узел сервера. Звездочка между значком сервера и его именем указывает на то, что сервер локальный.
  3. В меню Действие выберите команду Перезапуск IIS.
  4. Выберите режим Перезапуск служб Интернета на имя_сервера, где имя_сервера — имя используемого сервера.
  5. Нажмите кнопку ОК.

См. также

  • Для получения сведений о разрешении имен задайте в электронной справке Windows XP Professional поиск по ключевым словам WINS, DNS, NetBios и разрешение имен.
  • Для получения сведений о команде ping задайте в электронной документации Windows XP Professional поиск по ключевому слову ping.
  • Для получения сведений о команде ipconfig задайте в электронной справке Windows XP Professional поиск по ключевому слову ipconfig.
  • Для получения сведений об использовании проводника Windows задайте в электронной справке Windows XP Professional поиск по ключевому слову проводник.
  • Для получения сведений о пользователях и группах задайте в электронной справке Windows XP Professional поиск по ключевому слову группа.
  • В книге Microsoft Windows 2000 Administrator's Pocket Consultant (ISBN 0-7356-0831-8) содержатся полезные сведения о сетях TCP/IP, управлении файлами и каталогами, сетевом администрировании и разрешении имен.
  • Электронная документация IIS доступна по адресу http://localhost/iisHelp/iis/default.htm


Электронная почта

Служба Microsoft SMTP осуществляет транспортировку и доставку сообщений с помощью простого протокола пересылки почты (Simple Mail Transfer Protocol, SMTP), основанного на стандартах Интернета. Служба SMTP также позволяет управлять маршрутизацией и доставкой сообщений, обеспечивая безопасную среду передачи.

Если установлена программа электронной почты (протокол SMTP), для просмотра документации по продукту введите file:\\%системный_корневой_каталог%\help\mail.chm в строке адреса обозревателя и нажмите клавишу ВВОД.

электронная почта, почта, электронные сообщения, mailto:, протокол SMTP, SMTP, протоколы почты, почтовый ящик, протокол LDAP, LDAP, почта Интернета, настройка электронной почты, сообщения.


Серверные расширения FrontPage

Серверные расширения FrontPage — это набор из трех программ, которые поддерживают такие возможности, как совместное создание веб-страниц, счетчики обращений, обработка форм электронной почты и редактирование веб-узла непосредственно на компьютере сервера.

Оснастка консоли управления Microsoft® FrontPage® предназначена для администрирования серверных расширений FrontPage и расширенных с помощью FrontPage веб-узлов. Эта программа позволяет:

  • расширять виртуальные серверы;
  • создавать дочерние веб-узлы;
  • обновлять серверные расширения в веб-узле;
  • преобразовывать папки в дочерние веб-узлы;
  • преобразовывать дочерние веб-узлы в папки;
  • обновлять гиперссылки в веб-узле.

Оснастка консоли управления FrontPage имеет исчерпывающую справочную систему, содержащую общие сведения и описания методов администрирования серверных расширений FrontPage. Файл справки по умолчанию устанавливается в папку C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\bin\nnnn\Fpmmc.chm, где nnnn — код, зависящий от языка установленной версии серверных расширений FrontPage. Например, в английской версии (США) путь выглядит следующим образом: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\bin\1033\Fpmmc.chm. Дополнительная документация для серверных расширений FrontPage доступна на веб-узле корпорации Майкрософт.

Серверные расширения FrontPage, веб-сервер, веб-администрирование, администрирование веб-узлов, расширение веб-узлов с помощью FrontPage


Страница результатов поиска IIS

Информационные службы Интернета

Чтобы найти нужные сведения, воспользуйтесь электронной справочной системой IIS. Если службы IIS установлены, для просмотра документации по продукту введите в адресную строку обозревателя http://localhost/iisHelp/ и нажмите клавишу ВВОД. Затем можно повторить ввод запроса.

Использование информационных служб Интернета

Информационные службы Интернета (Internet Information Services, IIS) — это компонент Windows, облегчающий публикацию сведений и развертывание бизнес-приложений в Интернете. IIS позволяет создать мощную платформу для поддержки сетевых приложений и обеспечения связи в сети.

Примечания

  • Для запуска в Windows служб IIS нажмите кнопку Пуск, выделите пункт Настройка, а затем выберите команду Панель управления. Дважды щелкните значок Администрирование, а затем дважды щелкните значок Управление компьютером. Разверните в дереве консоли управления узел Службы и приложения и выберите элемент Internet Information Services.
  • Если искомые сведения отсутствуют в данном разделе, обратитесь к документации IIS.
Active Channel, Active Server Pages, ActiveX, администрирование, сервер, анонимный доступ, корень приложения, приложения, встроенные объекты ASP, проверка подлинности, обычная проверка подлинности, советы и рекомендации, Интернет, администрирование на базе обозревателя, обозреватели, сертификаты Интернета, цифровой, приложения CGI, проверка подлинности по алгоритму «вызов/ответ», каналы, клиенты, Интернет, клиентские сценарии, сервер кластера, компонент COM, MTS, подключение, содержимое Интернета, динамическое содержимое, интерактивный, элемент управления, ActiveX, аварийная защита, приложения баз данных, DCOM, DHTML, XML, документация, связанный с Интернетом, электронная коммерция, электронный бизнес, шифрование, форма, FTP, протокол FTP, GIF, JPG, JPEG, HTML, публикация, HTTP, IIS, объект Admin, объект Base, примеры, установка, установка сервера IIS, информационные службы Интернета, серверы Интернета, диспетчер служб Интернета, поставщик услуг Интернета, ISP, интрасеть, ISAPI, расширения ISAPI, фильтры ISAPI, ISDN, IUSR_имя_компьютера, Java, Javascript, JS, консоль управления, MMC, модем, разрешения, PICS, изолирование процесса, объединение в пул, программирование, удаленное администрирование, сценарии, безопасность, предприятие, фермы, серверные сценарии, сеанс, состояние, SSL, стандарты, транзакция, универсальный указатель ресурсов, URL, VBScript, виртуальный каталог, веб-фермы, страница, узел, размещение в Вебе, World Wide Web, WWW, WWWroot, InetPub, InetSrv, личный диспетчер Веба, ISM, PWM, PWS, личный веб-сервер, личные веб-службы, Peer Web Server, Peer Web Services, Secure Sockets Layer, Windows 2000, Windows 2000, Professional, Server, Advanced Datacenter.