Консоль управления Microsoft Management Console 3.0

Рисунок Microsoft Windows

Консоль управления (MMC), версия 3.0

Консоль MMC (Microsoft Management Console) группирует средства администрирования, которые используются для администрирования компьютеров, служб, других системных компонентов и сетей.

  • Чтобы найти функции, которые были добавлены в консоль MMC 2.0 или изменены, см. раздел Новые возможности в консоли управления MMC 3.0.
  • Советы по использованию консоли MMC 3.0 см. в разделе Советы и рекомендации для консоли MMC 3.0.
    • (http://www.microsoft.com/)
  • Справка по выполнению конкретных задач содержится в разделе Инструкции по консоли MMC 3.0.
  • Сведения общего характера см. в разделе Концепции консоли MMC 3.0.
  • Инструкции по устранению неполадок см. в разделе Устранение неполадок консоли MMC 3.0.
  • Сведения о специальных возможностях консоли MMC см. в разделе Специальные возможности консоли MMC.

Примечание

  • В редких случаях некоторые оснастки могут не работать правильно с MMC 3.0. Чтобы обеспечить правильную работу этих основанных на ММС средств с MMC 3.0, необходимо установить обновления. Дополнительные сведения о доступных обновлениях см. узел загрузки ММСВеб-узел корпорации Майкрософт


Новые возможности в консоли MMC 3.0

Консоль MMC 3.0 поддерживает оснастки с усовершенствованными функциями, которые предназначены для улучшения инфраструктуры консоли MMC 3.0. Имеются несколько улучшений, применимых для консолей оснастки MMC 3.0, которые включают:

  • Область «Действие»

    Область Действие расположена в правой части консоли оснастки. В ней перечислены доступные пользователям действия, основанные на выбранных в данный момент элементах дерева или панели результатов. Чтобы показать или скрыть область Действие, нажмите кнопку Показать или скрыть панель действий на панели инструментов, похожую на кнопку Скрыть/отобразить дерево консоли. Подробные сведения см. в разделе Консоли оснастки.

    Примечание

    • Чтобы использовать область «Действие» консоли MMC 3.0, проверьте с помощью редактора реестра, существует ли следующий раздел реестра:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\UseNewUI

      Если этот раздел не существует, создайте его, как описано в разделе Добавление раздела справки редактора реестра.

  • Новое диалоговое окно Добавить или удалить оснастку

    Новое диалоговое окно Добавить или удалить оснастку упрощает добавление, упорядочение и удаление оснасток. Можно управлять доступными расширениями и автоматически включать оснастки, которые могут быть установлены позже. Можно упорядочить оснастки, помещая их в узлы и упорядочивая их в дереве. Чтобы использовать это диалоговое окно, следует вручную установить ключ реестра. Подробнее об использовании диалогового окна Добавить или удалить оснастку консоли MMC 3.0 см. в разделе Диалоговое окно «Добавить или удалить оснастку» консоли MMC 3.0.

  • Улучшенную обработку ошибок

    Консоль MMC 3.0 выдает уведомления об ошибках в оснастках, которые могут привести к ошибкам консоли, и предоставляет несколько вариантов реагирования на эти ошибки. Подробные сведения см. в разделе Обработка ошибок оснастки.

Подробные сведения об использовании консоли MMC 3.0 с оснастками и консолях оснастки, созданных для более ранних версий MMC, см. раздел Использование в ММС 3.0 файлов, созданных в более ранних версиях ММС.


Советы и рекомендации для консоли MMC 3.0

Вход в систему с учетной записью пользователя без прав администратора

  • При входе в систему с учетной записью администратора контролируемые системы могут подвергаться атакам злоумышленников. Дополнительные сведения см. в разделе Почему не следует работать на компьютере с учетной записью администратора.
  • Чтобы открыть указанные средства, используйте команду runas. Дополнительные сведения см. в разделе Runas.
  • Для часто используемых средств создайте ярлыки, которые используют команду runas. Эти ярлыки помогут эффективно выполнять работу без дискредитации безопасности. Дополнительные сведения см. в разделе Чтобы создать ярлык, использующий команду runas.
  • Выполнив задачу, закройте средство. Это будет препятствовать возможной попытке нарушить безопасность системы и несанкционированному доступу злоумышленника.

Дополнительные сведения см. в разделе Советы и рекомендации по обеспечению локальной безопасности.

Соблюдение правил безопасности для используемых средств

  • Изучайте справку каждого средства на предмет правил безопасности.

Использование функции «Очистка диска»

  • Параметры пользователя для файлов консоли сохраняются в вашем профиле. Поскольку эти изменения накапливаются, они занимают место на диске. Чтобы освободить место на диске, используйте функцию «Очистка диска», как описано в разделе Чтобы использовать вкладку «Очистка диска».


Использование справочной системы консоли MMC 3.0

Вызвать справку для ММС позволяют: меню Справка главной панели инструментов, кнопка кнопка справки панели инструментов окна консоли оснастки, системное меню окна MMC или окна консоли оснастки, щелчок правой кнопкой мыши дерева консоли или области сведений и нажатие клавиши F1.

Справка для MMC отображает объединенное оглавление, включающее общую справку для MMC и специальную справку для каждой оснастки, входящей в консоль оснастки. Справка, отображаемая для оснастки, должна быть специально создана для этой оснастки и вызываться ею. При создании консоли можно предоставить дополнительную документацию для задач, связанных с консолью, или сведения, относящиеся к вашей сети.


Инструкции по консоли MMC 3.0

  • Открытие консоли MMC
  • Создание ярлыка на рабочем столе для открытия консоли MMC
  • Создание или изменение консоли оснастки
  • Использование групповой политики для управления консолью MMC
  • Работа с MMC и файлами консоли


Открытие консоли MMC

Рисунок Microsoft Windows

Чтобы открыть консоль MMC

С использованием интерфейса Windows

  • Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc и нажмите кнопку OK.

С помощью командной строки

  1. Откройте окно командной строки одним из следующих способов:
    • Нажмите кнопку Пуск, затем выберите команду Командная строка.
    • Нажмите кнопку Пуск, выберите команду Выполнить, введите cmd и нажмите кнопку ОК.
  2. В командной строке введите mmc и нажмите клавишу ENTER.

Примечания

  • Если локальные или групповые политики ограничивают использование некоторых оснасток, то не удастся открыть консоли, содержащие такие оснастки.
  • Чтобы открыть существующую или сохраненную консоль MMC, найдите консоль оснастки или ярлык для консоли оснастки в проводнике, затем дважды щелкните их.
  • Также можно открыть существующую консоль MMC из другой консоли, в которой работаете в данное время. Для этого откройте меню Файл и выберите команду Открыть.

См. также


Создание ярлыка на рабочем столе для открытия MMC

Рисунок Microsoft Windows

Чтобы создать ярлык на рабочем столе для открытия MMC

  1. Щелкните правой кнопкой мыши рабочий стол, выберите пункт Создать, а затем Ярлык.
  2. В окне мастера создания ярлыка введите путь к консоли MMC или нажмите кнопку Обзор, чтобы найти консоль MMC.
  3. Нажмите кнопку Далее.
  4. Введите имя нового ярлыка.
  5. Нажмите кнопку Готово. Мастер создания ярлыка сохраняет новый ярлык на рабочем столе Windows.

Примечания

  • Ярлык, созданный на рабочем столе, можно перетащить в другие папки, например папку с файлами .msc или папку для меню Пуск.
  • Ярлык для MMC в папках может быть создан с помощью проводника Windows. Для этого щелкните папку, в которую будет добавлен ярлык, в меню Файл выберите команды Создать и Ярлык и следуйте указаниям на экране.

См. также


Создание или изменение консоли оснастки

В этом разделе рассмотрены следующие темы:

  • Создание новой консоли оснастки из консоли MMC 3.0
  • Установка параметров консоли MMC
  • Создание и упорядочение списка «Избранное» в консоли оснастки
  • Создание новой консоли оснастки на базе существующей консоли
  • Добавление, удаление и упорядочение оснасток и расширений в консоли MMC 2.0
  • Добавление, удаление и упорядочение оснасток и расширений в консоли MMC 3.0


Создание новой консоли оснастки

Рисунок Microsoft Windows

Чтобы создать новую консоль оснастки из MMC 3.0

  1. Выполните одно из следующих действий:
    • Из консоли оснастки в меню Файл выберите команду Создать;
    • В командной строке введите mmc /a.
  2. Настройте новую консоль, следуя инструкциям в таблице ниже.
    3. Задача | Назначение задачи | Ссылки
    Добавление и упорядочение оснасток Добавьте средства, которые должна содержать консоль оснастки. Для MMC 3.0 см. Диалоговое окно «Добавить или удалить оснастки» для MMC 3.0.

    Для более ранних версий MMC см. Добавление, удаление и упорядочение оснасток и расширений.
    Дайте имя консоли оснастки | Добавьте понятное имя в заголовок консоли, чтобы можно было убедиться, что открыта правильная консоль. | Чтобы установить параметры консоли MMC
    Установите режим По умолчанию консоль оснастки находится в авторском режиме. Если вы создаете консоль для делегирования работы, возможно, вы предпочтете один из пользовательских режимов.
    • Чтобы установить параметры консоли MMC
    • Контроль использования консоли MMC с помощью групповой политики
    • Режимы доступа к консоли оснастки
    Настройка видов | Скройте на консоли элементы, которые вам не нужны или отвлекают внимание. | Настройка консоли
    Создание и упорядочение списка «Избранное» | Используйте список «Избранное» в MMC для быстрого доступа к часто используемым узлам в дереве. | Создание и упорядочение списка «Избранное» в консоли оснастки

Примечание

  • Если не удается открыть консоль в авторском режиме, это может быть вызвано ограничениями, налагаемыми локальной или групповой политикой. Для получения дополнительных сведений о режимах доступа к консоли оснастки щелкните ссылку «См. также».
  • Чтобы использовать область «Действие» консоли MMC 3.0, проверьте с помощью редактора реестра, существует ли следующий раздел реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\UseNewUI

    Если этот раздел не существует, создайте его, как описано в разделе Добавление раздела реестра справки редактора реестра.

См. также


Установка параметров консоли MMC

Рисунок Microsoft Windows

Чтобы установить параметры консоли MMC

  1. Откройте сохраненную консоль в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши MMC-файл и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку ОК.
  2. В меню Консоль выберите команду Параметры.
  3. Чтобы изменить заголовок консоли, введите новый заголовок в поле.
  4. Чтобы изменить значок для консоли, нажмите кнопку Сменить значок. В поле Имя файла введите путь к файлу, содержащему значки.
  5. В поле Текущий значок выберите значок и нажмите кнопку ОК.
  6. Чтобы изменить режим использования консоли по умолчанию, из списка Режим консоли выберите один из режимов, в котором будет открываться консоль.
    • Авторский. Разрешает полную настройку консоли оснастки, включая возможность добавления и удаления оснасток, создание новых окон, создание списка «Избранное» и панели задач, а также доступ ко всем параметрам диалоговых окон Настройка вида и Параметры. Пользователи, создающие специальные консоли для выполнения личных задач, обычно используют этот режим. Полученная в результате консоль оснастки обычно сохраняется в одном из следующих пользовательских режимов.
    • Пользовательский — полный доступ. Аналогичен авторскому режиму, за исключением отсутствия возможностей добавления и удаления оснасток, изменения параметров консоли, создания списка «Избранное» и панелей задач.
    • Пользовательский — ограниченный доступ, много окон. Предоставляет доступ только к частям дерева консоли, отображаемым при сохранении файла консоли. Пользователи могут создавать новые окна, но не могут закрывать ни одно из существующих окон.
    • Пользовательский — ограниченный доступ, одно окно. Предоставляет доступ только к частям дерева консоли, отображаемым при сохранении файла консоли. Пользователи не могут создавать новые окна.
  7. Если по умолчанию консоль используется в одном из пользовательских режимов, выполните указанные ниже действия.
    • Чтобы запретить пользователям изменение консоли, установите флажок Не сохранять изменения для этой консоли.
    • Чтобы сделать диалоговое окно Настройка вида доступным для пользователей, установите флажок Позволить пользователю настраивать вид консоли.

Примечания

  • Если изменен заголовок консоли, в поле заголовка не отображается путь к элементу, выбранному в дереве консоли. Однако, если заголовок не изменен или удален, пути отображаются.
  • Значки, которые могут быть использованы для специальных консолей, находятся во многих файлах. Например, значки можно найти в файле Shell32.dll, который находится в папке %systemroot%\System32.
  • Чтобы отменить получение сообщения Сохранить настройку консоли в имя_консоли?, которое появляется при каждом закрытии консоли, открытой в авторском режиме, установите в качестве режима использования консоли по умолчанию один из пользовательских режимов и снимите флажок Не сохранять изменения для этой консоли. В этом случае любые изменения в консоли будут сохраняться по умолчанию.

См. также


Создание и упорядочение списка «Избранное» на консоли оснастки

Рисунок Microsoft Windows

Чтобы создать и упорядочить список «Избранное» на консоли оснастки

Используйте список «Избранное» для добавления, удаления и упорядочения избранных ссылок. Список «Избранное» может включать виды страниц и панели задач, на которые необходимо быстро перейти.

Чтобы добавить элемент в список «Избранное» на консоли оснастки
  1. В дереве консоли щелкните элемент, который необходимо добавить в список «Избранное».
  2. В меню Избранное выберите команду Добавить в избранное.
  3. В поле Создать в выполните одно из описанных ниже действий.
    • Чтобы добавить элемент к существующей папке, щелкните нужную папку и нажмите кнопку ОК.
    • Чтобы добавить элемент к новой папке, щелкните папку, которая будет выступать в качестве родительской для создаваемой папки, и нажмите кнопку Создать папку. В поле Имя папки введите имя, нажмите кнопку ОК и снова нажмите кнопку ОК.
Чтобы упорядочить список «Избранное» на консоли оснастки
  • В меню Избранное выберите команду Упорядочить избранное и выполните любое из следующих действий.
    • Чтобы добавить папку, нажмите кнопку Создать папку, введите имя в поле Имя папки и нажмите кнопку ОК.
    • Чтобы переместить элемент в папку, щелкните элемент, расположенный ниже папки «Избранное», нажмите кнопку Переместить в папку, щелкните папку, в которой элемент будет размещен, и нажмите кнопку ОК.
    • Чтобы изменить имя элемента, щелкните элемент, расположенный ниже папки «Избранное», нажмите кнопку Переименовать, введите новое имя и нажмите клавишу ВВОД.
    • Чтобы удалить элемент, щелкните элемент, расположенный ниже папки «Избранное», и нажмите кнопку Удалить.

См. также


Создание новой консоли оснастки на базе существующей консоли

Рисунок Microsoft Windows

Чтобы создать новую консоль оснастки на базе существующей консоли

  1. Откройте существующую консоль, которую предполагается использовать в качестве основы для новой консоли.
  2. В меню Файл выберите команду Сохранить как и введите имя новой консоли.

Примечания

  • Чтобы открыть существующую или сохраненную консоль MMC, найдите консоль оснастки или ярлык для консоли оснастки в проводнике и дважды щелкните ее.
  • Также можно открыть существующую консоль MMC из другой консоли, в которой работаете в данное время. Для этого откройте меню Файл и выберите команду Открыть.

См. также


Добавление, удаление и упорядочение оснасток и расширений в MMC 3.0

Рисунок Microsoft Windows

Чтобы добавить, удалить и упорядочить оснастки и расширения в MMC 2.0

  1. В меню «Файл» открытой консоли MMC выберите Добавить или удалить оснастку.
  2. В раскрывающемся списке Оснастки выберите оснастку, к которой требуется добавить новую консоль, или щелкните папку Корень консоли.
  3. Выполните любое из следующих действий.
    • Чтобы добавить новые надстройки, нажмите кнопку Добавить; откроется диалоговое окно Добавить изолированную оснастку. В диалоговом окне Добавить изолированную оснастку выберите оснастку, которую требуется добавить. За один раз можно добавлять только одну оснастку. Нажмите кнопку Добавить, чтобы добавить выбранную оснастку. Повторяйте это действие до тех пор, пока все нужные оснастки не будут добавлены в открытую консоль MMC. По окончании добавления оснасток нажмите кнопку Закрыть. Чтобы закрыть диалоговое окно Добавить или удалить оснастку, нажмите кнопку OK.
    • Чтобы удалить имеющуюся оснастку, выберите ее в списке Добавить или удалить оснастку и нажмите кнопку Удалить. По окончании удаления оснасток нажмите кнопку ОК.
    • Чтобы добавить расширения к оснасткам в открытой консоли MMC, откройте вкладку Расширения. На вкладке Расширения выберите оснастку, к которой требуется добавить расширения, из раскрывающегося списка Оснастки, которые могут быть расширены. Если требуется добавить все имеющиеся расширения для выбранной оснастки, щелкните Добавить все расширения. Чтобы добавить в оснастку отдельные расширения, выберите нужные расширения из списка Доступные расширения. Если кнопка Загрузка для выбранного расширения активна, нажмите ее, чтобы получить расширение с другого компьютера или с компакт-диска продукта Windows. Нажмите кнопку ОК, чтобы установить расширения для выбранной оснастки. Чтобы добавить расширения в другие оснастки открытой консоли, повторите эти действия.

Примечания

  • По умолчанию открывается диалоговое окно Добавить или удалить оснастку консоли управления MMC версии 2.0. Чтобы использовать диалоговое окно консоли управления MMC версии 3.0, проверьте с помощью редактора реестра, существует ли следующий раздел реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\UseNewUI

    • Если этот раздел не существует, создайте его, как описано в разделе Добавление раздела справки редактора реестра.

См. также


Добавление, удаление и упорядочение оснасток и расширений в MMC 3.0

Используйте диалоговое окно Добавить или удалить оснастку для добавления, удаления и упорядочения оснасток и расширений в консоли оснастки MMC 3.0.

Чтобы добавить или удалить оснастку

  1. В меню «Файл» открытой консоли ММС 3.0 выберите Добавить или удалить оснастки.
  2. Выделите оснастку, которую требуется добавить, в списке Доступные оснастки и нажмите кнопку Добавить, чтобы добавить оснастку в список Выбранные оснастки.
  3. Прочтите краткое описание оснастки в любом списке, выбрав ее и затем прочитав содержание поля Описание в нижней части диалогового окна. Некоторые оснастки могут не иметь описания.
  4. Измените порядок оснасток в консоли оснастки, выбрав оснастку в списке Выбранные оснастки и затем нажав кнопку Вверх или Вниз.
  5. Если требуется добавить новую оснастку в узел открытой консоли, отличный от узла Корень консоли, см. процедуру «Чтобы установить родительский узел для оснастки» в этом разделе.
  6. Удалите оснастку, выбрав ее в списке Выбранные оснастки и затем нажав кнопку Удалить.
  7. Закончив добавление или удаление оснасток, нажмите кнопку ОК.

Чтобы установить родительский узел для оснастки

  1. Нажмите кнопку Дополнительно.
  2. Установите флажок Разрешить изменять родительскую оснастку и нажмите кнопку ОК.

    Теперь диалоговое окно Добавить или удалить оснастки отображает раскрывающийся список Родительская оснастка, который содержит корень консоли и все текущие оснастки в списке Выбранные оснастки.

  3. Выберите родительский узел в списке Родительская оснастка. Затем выберите дочернюю оснастку в списке Доступные оснастки и нажмите кнопку Добавить.

    Чтобы переместить оснастку, которая уже находится в списке Выбранные оснастки, в другой родительский узел, следует удалить ее и снова добавить.

Примечания

  • Чтобы открыть диалоговое окно Добавить или удалить оснастку из консоли оснастки, в меню Файл выберите команду Добавить или удалить оснастку.
  • Эта процедура применима только к консолям MMC 3.0, для которых раздел реестра UseNewUI установлен в реестре Windows. Дополнительные сведения о добавлении или удалении оснасток с консоли MMC 2.0 см. в разделеДобавление, удаление и упорядочение оснасток и расширений. По умолчанию открывается диалоговое окно консоли MMC 2.0 Добавить или удалить оснастку. Чтобы использовать диалоговое окно консоли управления MMC версии 3.0, проверьте с помощью редактора реестра, существует ли следующий раздел реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\UseNewUI

    Если этот раздел не существует, создайте его, как описано в разделе Добавление раздела справки редактора реестра.

См. также


Контроль использования консоли MMC с помощью групповой политики

В этом разделе рассмотрены следующие темы:

  • Контроль использования консоли MMC с помощью локальной групповой политики
  • Контроль использования консоли MMC с помощью групповой политики на уровне домена


Контроль доступа пользователей к консолям MMC с использованием локальной групповой политики

Рисунок Microsoft Windows

Чтобы контролировать использование MMC с использованием локальной групповой политики

  1. Откройте консоль MMC.
  2. В меню Консоль выберите команду Добавить или удалить оснастку и нажмите кнопку Добавить.
  3. В группе Оснастка выберите объект Редактор объектов групповой политики и нажмите кнопку Добавить.
  4. В диалоговом окне Выбор объекта групповой политики выполните одно их следующих действий.
    • Чтобы изменить локальный объект групповой политики, выберите Локальный компьютер.
    • Чтобы изменить другой объект групповой политики, нажмите кнопку Обзор.
  5. Нажмите кнопку Готово, кнопку Закрыть, а затем — кнопку OK.

    Оснастка «Редактор объектов групповой политики» откроет выбранный редактор объектов групповой политики.

  6. Выполните одно из следующих действий:
    • Чтобы ограничить доступ к MMC в авторском режиме
    • Чтобы ограничить доступ списком разрешенных оснасток
    • Чтобы ограничить или разрешить доступ к оснастке

Чтобы ограничить доступ к MMC в авторском режиме

  1. В дереве консоли щелкните компонент Консоль управления (MMC).

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Компоненты Windows
    • Консоль управления MMC
  2. В области сведений дважды щелкните Запретить пользователям использовать авторский режим.
  3. На вкладке Настройка выполните одно из следующих действий.
    • Чтобы разрешить пользователю использовать авторский режим в MMC, установите переключатель в положение Не задана или Отключена.
    • Чтобы запретить пользователю использовать авторский режим в MMC, установите переключатель в положение Включена.

Примечание

  • Если выбран параметр Запретить пользователям использовать авторский режим, при попытке доступа к консоли появится сообщение, указывающее на закрытый доступ к консоли оснастки в авторском режиме. Пользователи с учетными данными администратора могут восстановить доступ к файлам в авторском режиме. Для этого следует воспользоваться командой Выполнить и ввести gpedit.msc. При этом откроется редактор объектов групповой политики для политики локального компьютера. Далее перейдите к компоненту Консоль управления (MMC), как описано в процедуре выше, дважды щелкните Запретить пользователям использовать авторский режим в области результатов и затем выберите Не задан или Отключен.

Чтобы ограничить доступ списком разрешенных оснасток

  1. В дереве консоли щелкните компонент Консоль управления (MMC).

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Компоненты Windows
    • Консоль управления MMC
  2. В области результатов дважды щелкните Ограничить использование оснасток списком явно разрешенных оснасток.
  3. На вкладке Политика выполните одно из следующих действий.
    • Чтобы разрешить пользователю доступ к оснасткам, которые явно не запрещены, установите переключатель в положение Не задан или Отключен.
    • Чтобы запретить пользователю доступ к любой оснастке, которая явно не разрешена, установите переключатель в положение Включен.

Примечание

  • Если разрешена данная политика, только разрешенные оснастки появляются в списке доступных оснасток в диалоговом окне Добавить изолированную оснастку в MMC.

Чтобы ограничить или разрешить доступ к оснастке

  1. В дереве консоли щелкните Запрещенные или разрешенные оснастки.

    2. Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Консоль управления MMC
    • Запрещенные или разрешенные оснастки
  2. В области сведений дважды щелкните оснастку, которую необходимо разрешить или запретить, и выполните одно из следующих действий.
    • Чтобы разрешить пользователю доступ к этой оснастке, если это не запрещено политикой Ограничить использование оснасток списком явно разрешенных оснасток, установите переключатель в положение Не задан.
    • Чтобы разрешить пользователям доступ к оснастке, установите переключатель в положение Включен.
    • Чтобы запретить пользователям доступ к оснастке, установите переключатель в положение Отключен.

Примечания

  • Чтобы открыть консоль управления, нажмите кнопку Пуск, выберите команду Выполнить и введите mmc, а затем нажмите кнопку OK.
  • Для получения дополнительных сведений об этих настройках щелкните вкладку Объяснение в диалоговом окне для выбранной настройки групповой политики и см. справку.
  • Эти возможности доступны только в сети с настроенным редактором объектов групповой политики; системный администратор должен включить оснастку «Редактор объектов групповой политики». Они недоступны в Windows XP Home Edition.

См. также


Групповая политика для домена и MMC

Рисунок Microsoft Windows

Чтобы контролировать использование MMC с использованием локальной групповой политики

  1. Откройте консоль MMC.
  2. В дереве щелкните правой кнопкой подразделение, для которого нужно настроить политику, и выберите команду Свойства.
  3. На вкладке Групповая политика нажмите кнопку Изменить.

    Появится редактор объектов групповой политики.

  4. Выполните одно из следующих действий:
    • Чтобы ограничить доступ к MMC в авторском режиме для домена
    • Чтобы ограничить доступ для домена списком разрешенных оснасток
    • Чтобы ограничить или разрешить доступ к оснастке для домена

Чтобы ограничить доступ к MMC в авторском режиме для домена

  1. В дереве консоли щелкните компонент Консоль управления (MMC).

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Компоненты Windows
    • Консоль управления (MMC)
  2. В области сведений дважды щелкните Запретить пользователям использовать авторский режим.
  3. На вкладке Политика выполните одно из следующих действий.
    • Чтобы разрешить пользователю использовать авторский режим в MMC, установите переключатель в положение Не задана или Отключена.
    • Чтобы запретить пользователю использовать авторский режим в MMC, установите переключатель в положение Включена.

Чтобы ограничить доступ для домена списком разрешенных оснасток

  1. В дереве консоли щелкните компонент Консоль управления (MMC).

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Компоненты Windows
    • Консоль управления (MMC)
  2. В области результатов дважды щелкните Ограничить использование оснасток списком явно разрешенных оснасток.
  3. На вкладке Политика выполните одно из следующих действий.
    • Чтобы разрешить пользователю доступ к оснасткам, которые явно не запрещены, установите переключатель в положение Не задан или Отключен.
    • Чтобы запретить пользователю доступ к любой оснастке, которая явно не разрешена, установите переключатель в положение Включен.

    4. Примечание

    • Если разрешена данная политика, только разрешенные оснастки появляются в списке доступных оснасток в диалоговом окне Добавить изолированную оснастку в MMC.

Чтобы ограничить или разрешить доступ к оснастке для домена

  1. В дереве консоли щелкните Запрещенные или разрешенные оснастки.

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Компоненты Windows
    • Консоль управления (MMC)
    • Запрещенные или разрешенные оснастки
  2. В области сведений дважды щелкните оснастку, которую необходимо разрешить или запретить, и выполните одно из следующих действий.
    • Чтобы разрешить пользователю доступ к этой оснастке, если это не запрещено политикой Ограничить использование оснасток списком явно разрешенных оснасток, установите переключатель в положение Не задан.
    • Чтобы разрешить пользователям доступ к оснастке, установите переключатель в положение Включен.
    • Чтобы запретить пользователям доступ к оснастке, установите переключатель в положение Отключен.

    3. Примечание

    • Когда запрещается или явно разрешается доступ к оснастке, она добавляется в список запрещенных или разрешенных оснасток. Список запретов имеет приоритет перед списком разрешений, поэтому доступ к оснастке, присутствующей в обоих списках, запрещен.

Примечания

  • Чтобы открыть окно «Пользователи и компьютеры Active Directory», нажмите кнопку Пуск и выберите команды Программы, Администрирование и Пользователи и компьютеры Active Directory.
  • Данная процедура применима только в сети с настроенным редактором объектов групповой политики. Чтобы использовать компьютер, являющийся контроллером домена, для настройки редактора объектов групповой политики для домена, надо быть администратором домена или иметь эквивалентные права.
  • Для получения дополнительных сведений об этих настройках щелкните вкладку Объяснение в диалоговом окне для выбранной настройки групповой политики и см. справку.

См. также


Работа с MMC и файлами консоли

В этом разделе рассмотрены следующие темы:

  • Настройка консоли
  • Перемещение по консоли MMC 3.0
  • Просмотр связанной оснастки и элемента для страницы свойств
  • Экспорт данных из консоли оснастки


Настройка консоли

В этом разделе рассмотрены следующие темы:

  • Настройка вида консоли оснастки
  • Сортировка, скрытие или отображение столбцов в области результатов
  • Создание, просмотр и удаление дополнительных окон


Настройка вида консоли оснастки

Рисунок Microsoft Windows

Чтобы настроить вид консоли оснастки

  1. В меню Вид выберите команду Настроить.
  2. В диалоговом окне Настройка вида отобразите элементы, выбрав соответствующий флажок, или удалите элементы, сняв соответствующие флажки.
  3. Чтобы скрыть или отобразить область, выполните следующие действия.
    • Нажмите кнопку Скрыть/отобразить дерево консоли или Показать или скрыть панель действий. Эти кнопки открывают и закрывают дерево и области «Действие».
    • В меню Вид выберите команду Настроить, затем отобразите область, выбрав соответствующий флажок, или удалите область, сняв соответствующие флажки.

Примечания

  • Если консоль оснастки не находится в авторском режиме, виды настроить не удастся.
  • Можно скрыть или отобразить дерево и область Действие. Область результатов отображается всегда.
  • Когда отображается дерево или область Действие, выделяется соответствующая кнопка Скрыть/отобразить дерево консоли или Показать или скрыть панель действий. Если кнопка выделена, но область не видна, вероятно, потребуется изменить размер области или окна, либо и то, и другое. Если никакие кнопки не видны, это означает, что скрыта стандартная панель инструментов. Эта функция настраивается в диалоговом окне Настройка вида.

См. также


Сортировка, скрытие или отображение столбцов

Рисунок Microsoft Windows

Чтобы выполнить сортировку, скрытие или отображение столбцов в области результатов

Чтобы сортировать столбцы

  • Чтобы отсортировать данные в области результатов, щелкните заголовок столбца, который необходимо отсортировать.
  • Чтобы изменить направление сортировки, снова щелкните заголовок столбца.

Чтобы скрыть или отобразить столбцы

  1. Чтобы скрыть или отобразить столбцы на консоли MMC, щелкните элемент дерева, столбцы которого отображаются в области результатов.
  2. Чтобы открыть диалоговое окно Добавление или удаление столбцов, в области Действие щелкните Дополнительные действия, откройте меню Вид и выберите команду Добавить или удалить столбцы.
  3. Чтобы отобразить столбцы, выделите имена столбцов в списке Имеющиеся столбцы и щелкните Добавить. Чтобы одновременно добавить несколько имен столбцов, при выделении имен столбцов нажмите и удерживайте клавишу Ctrl.
  4. Чтобы скрыть столбцы, выделите имена столбцы в списке Отображаемые столбцы и щелкните Удалить.
  5. Можно изменить порядок сортировки столбцов в списке Отображаемые столбцы, выделив имя столбца и щелкнув кнопку Вверх или Вниз. Кнопка Вверх перемещает столбец ближе к левому краю области результатов, а кнопка Вниз перемещает столбец ближе к правому краю.

Примечания

  • Столбец, по которому сортируются данные, помечается стрелкой. Если стрелка указывает вниз, то столбец сортируется в убывающем порядке; если она указывает вверх, то столбец сортируется в возрастающем порядке.
  • Чтобы просмотреть доступные действия, войдите в меню Действие или щелкните правой кнопкой элемент дерева.
  • Если консоль оснастки не находится в авторском режиме, то возможности изменения видов будут ограничены.
  • Скрытие или отображение столбцов не включается для всех элементов. Если в меню Вид не видна команда Добавить или удалить столбцы, то использовать эту функцию для выбранного элемента будет невозможно.

См. также


Создание, просмотр и удаление дополнительных окон

Рисунок Microsoft Windows

Создание, просмотр и удаление дополнительных окон

  1. Чтобы создать новое окно, которое помещается в корне консоли, войдите в меню Окно, затем выберите команду Новое.
  2. Чтобы создать новое окно, которое помещается в корень элемента в дереве, щелкните правой кнопкой этот элемент в дереве, затем выберите команду Новое окно отсюда.
  3. Чтобы просмотреть окна, выполните одно из следующих действий.
    • В меню Окно щелкните окно, которое необходимо просмотреть.
    • В меню Окно выберите команду Каскадом или Сверху вниз. Можно перемещаться по окнам, щелкая их. Кроме того, можно изменять размеры окон и упорядочивать их, чтобы сравнивать данные в разных окнах.
  4. Чтобы удалить окно, щелкните окно, которое необходимо удалить, затем нажмите кнопку Закрыть в правом верхнем углу окна.

Примечания

  • Элементы, находящиеся выше корня окна, в этом окне недоступны. Если окно помещается в корень элемента в дереве, то в этом окне доступны только данный элемент и все элементы, находящиеся ниже его. Это может быть полезным для того, чтобы сконцентрировать внимание на конкретной работе или делегировать ее.
  • Если консоль оснастки не находится в авторском режиме, то возможности создания нового окна будут ограничены.
  • Можно создать консоль оснастки, которая содержит несколько оснасток, для этого создайте окно, которое помещается в корень единственного элемента в дереве, затем удалите окно, которое находится в корне консоли. В результате появится консоль оснастки, которая сфокусирована на элементах ниже по дереву. Если используется консоль оснастки, которая настроена таким образом и отсутствуют ограничения на создание нового окна, можно получить доступ ко всей консоли путем создания окна, которое привязывается к корню консоли.

См. также


Перемещение по консоли MMC 3.0

Рисунок Microsoft Windows

Перемещение по консоли MMC 3.0

  • Чтобы перемещаться консоли MMC 3.0, используя дерево, разверните элементы дерева, щелкнув значок + рядом с элементом, затем щелкните элемент, для которого необходимо просмотреть результаты.
  • Чтобы перемещаться по консоли MMC 3.0, используя панель результатов, дважды щелкните элемент, чтобы видеть входящие в него элементы, затем нажмите кнопку Вверх, чтобы видеть элемент-родитель и элементы, находящиеся с ним на одном уровне.

Примечания

  • Если дерево не видно, нажмите кнопку Скрыть/отобразить дерево консоли.
  • Кнопка Вверх недоступна, когда пользователь находится в корне окна.

См. также


Просмотр связанной оснастки и элемента для страницы свойств

Рисунок Microsoft Windows

Чтобы просмотреть связанную оснастку и элемент для страницы свойств

  1. В дереве консоли или области сведений открытой консоли оснастки щелкните правой кнопкой мыши элемент, для которого необходимо просмотреть свойства, и выберите команду Свойства.
  2. Выполните следующие действия в диалоговом окне свойств.
    • Чтобы просмотреть, какая оснастка предоставляет определенную вкладку в диалоговом окне свойств, удерживая нажатой клавишу CTRL, укажите мышью название вкладки.
    • Чтобы определить расположение в дереве консоли элемента, связанного с диалоговым окном свойств, укажите мышью заголовок диалогового окна свойств, удерживая нажатой клавишу CTRL.

Примечание

  • Команда Свойства также доступна в области Действие и в меню Действие.

См. также


Экспорт данных из консоли оснастки

Рисунок Microsoft Windows

Чтобы выполнить экспорт данных из консоли оснастки

  1. В открытой консоли оснастки щелкните элемент в дереве консоли, который выводит столбцы в области результатов.
  2. Если предполагается экспортировать только некоторые строки, выберите эти строки.
  3. В области «Действие» выберите команду Экспортировать список.
  4. Закройте диалоговое окно Экспортировать список.

Примечание

  • С помощью некоторых оснасток можно экспортировать только все строки в области результатов и невозможно выбрать для экспорта подмножество строк.

См. также


Основные понятия о консоли MMC 3.0

  • Обзор консоли MMC 3.0
  • Общие сведения о консоли MMC 3.0
  • Безопасность консоли MMC 3.0
  • Использование консоли MMC 3.0
  • Ресурсы


Общие сведения о консоли MMC 3.0

Консоль управления (MMC) — средство для создания, сохранения и открытия средств администрирования (называемых оснастками), которые управляют оборудованием, программными и сетевыми компонентами операционной системы Windows. MMC 3.0 можно выполнять на Windows Server 2003 R2.

MMC не выполняет административных функций, но группирует средства, которые это делают. Оснастки являются наиболее распространенными из этих средств. Другие элементы, которые могут быть добавлены, включают элементы управления ActiveX, ссылки на веб-страницы, папки и задачи.

Windows Server 2003 R2 включает несколько предварительно настроенных консолей оснастки, например, просмотр событий (Eventvwr.msc) и системный монитор (Perfmon.msc). Могут быть созданы необходимые дополнительные консоли оснастки. В зависимости от того, как настроена консоль оснастки, она может быть настраиваемым многофункциональным средством для ИТ-специалиста широкого профиля, средством с ограниченными функциями для делегирования работы ИТ-специалисту или чем-то средним.

ММС может использоваться двумя способами: в пользовательском режиме, где вы работаете с существующими консолями оснастки, обеспечивая администрирование системы, или в авторском режиме, где вы создаете новые консоли оснастки или изменяете существующие. Дополнительные сведения об отличиях между пользовательским и авторским режимами см. в разделе Режимы доступа к консоли оснастки.


Общие сведения о консоли MMC версии 3.0

В этом разделе рассмотрены следующие темы.

  • Консоль MMC в авторском режиме
  • Консоли оснастки
  • Оснастки
  • Окно консоли MMC версии 3.0
  • Список «Избранное» консоли MMC версии 3.0
  • Режимы доступа к консоли оснастки


Консоль MMC 3.0 в авторском режиме

MMC в авторском режиме позволяет создавать новые и изменять существующие консоли оснастки. Для создания административного средства на консоль добавляются оснастки и другие элементы. Имеется возможность создания дополнительных окон консоли, которые обеспечивают отображение различных элементов, образующих консоль оснастки. Также имеется возможность создания видов панели задач, которые содержат ярлыки ссылок для выполнения команд меню из разных мест и инструментов в консоли оснастки, а также для запуска функций, вызываемых из командной строки. После сохранения консоли ее можно разослать пользователям.

Примечание

  • В MMC 3.0 область Действие заменяет виды панели задач. Мастер создания вида панели задач не используется для оснасток, созданных для MMC 3.0, но по-прежнему поддерживается для старых оснасток.

Для получения инструкций по изменению консоли оснастки см. Создание или изменение консоли оснастки.

Сведения об авторском режиме и других режимах доступа ММС см. Режимы доступа к консоли оснастки.


Консоли оснастки

Новая консоль оснастки представляет собой окно, разделенное на три области.

  • Левая область отображает дерево консоли, которое на верхнем уровне показывает оснастки, доступные в консоли. Можно скрыть дерево, нажав на кнопку Скрыть/отобразить дерево консолии на панели инструментов MMC. Может быть невозможно показать или скрыть эту область в пользовательском режиме, в зависимости от настроек конфигурации для консоли.

  • Средняя область - это область результатов. Она показывает сведения о пункте, выбранном в настоящее время в консоли, и функциях, относящихся к нему. Если щелкнуть другие элементы в дереве, информация в области результатов изменится. Область результатов может отображать различные типы сведений, включая веб-страницы, графики, диаграммы, таблицы и списки.
  • Правая область - это область Действие. В ней перечислены действия, доступные в данный момент, которые определяются на основе выбранных в настоящее время элементов в дереве и области результатов. Эти действия также доступны из меню Действия или при нажатии правой кнопки мыши элемента, над которым требуется выполнить действие. Можно скрыть область Действие, нажав на кнопку Показать или скрыть панель действий на панели инструментов MMC. Может быть невозможно показать или скрыть эту область в пользовательском режиме, в зависимости от параметров конфигурации для консоли.

В используемой операционной системе могут быть предварительно настроенные консоли оснастки, доступные в меню Программы или в папке «Администрирование» на панели управления.

Можно использовать MMC 3.0, чтобы открывать консоли оснастки, которые были созданы с использованием более ранних версий MMC (версий 1.2 или 2.0). Если используется MMC 3.0, чтобы открыть консоль оснастки, следует сохранять ее в формате MMC 3.0. Консоль оснастки в формате MMC 3.0 не может быть преобразована в более ранний формат. Если желательно не менять формат более ранней версии, не сохраняйте консоль оснастки или сохраните ее в файле под другим именем.

Примечание

  • Чтобы использовать область «Действие» консоли MMC 3.0, проверьте с помощью редактора реестра, существует ли следующий раздел реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\UseNewUI

    Если этот раздел не существует, создайте его, как описано в разделе Добавление раздела справки редактора реестра.


Оснастки

Оснастка — это основной компонент консоли MMC. Оснастки могут быть использованы только с консолями; их нельзя выполнить независимо от консоли.

При установке компонента, с которым связана оснастка, оснастка доступна любому пользователю, создающему на компьютере консоль (если не имеется ограничений политики пользователя). Сведения о политике пользователя см. в разделе Групповая политика и MMC.

Оснастки и расширения оснасток

В консоли ММС существует два вида оснасток: изолированные оснастки и расширения оснасток. Изолированная оснастка, обычно называемая просто оснасткой, может быть добавлена к дереву консоли без предварительного добавления других элементов. Расширение оснастки, обычно называемое расширением, всегда добавляется к оснастке или к другому расширению оснастки, которое уже находится в дереве. Если для оснастки разрешены расширения, они работают с объектами, управляемыми оснасткой, например с компьютером, принтером, модемом или другим устройством.

Когда оснастка или расширение добавляются на консоль, они могут появиться в виде нового элемента в дереве консоли или добавлять новые пункты контекстного меню, дополнительные панели инструментов, дополнительные страницы свойств или мастера к оснастке, уже установленной на консоли.

Добавление оснасток на консоль

На консоль может быть добавлена как одиночная оснастка, так и несколько оснасток и другие элементы. Кроме того, можно добавить на одну консоль несколько экземпляров одной и той же оснастки для администрирования различных компьютеров или для восстановления поврежденной консоли. Всякий раз, когда новый экземпляр оснастки добавляется на консоль, для любых переменных оснастки установлены значения по умолчанию, пока оснастка не будет настроена. Например, если определенная оснастка настроена для управления удаленным компьютером и добавляется второй экземпляр оснастки, этот второй экземпляр автоматически не будет настроен на управление удаленным компьютером.

Обычно добавляются только оснастки, установленные на компьютере, который используется для создания консоли. Однако, если компьютер является частью домена, консоль MMC может быть использована для загрузки оснасток, которые не установлены локально, но доступны в службе каталога Active Directory. Дополнительные сведения о добавлении опубликованных оснасток и расширений на консоль см. в разделе Создание новой консоли оснастки.


Окно MMC 3.0

Дерево консоли — это иерархическая структура в левой области окна MMC. В дереве консоли показаны элементы, доступные в консоли оснастки. Эти элементы могут включать папки, оснастки, элементы управления, веб-страницы и другие средства. Можно скрыть или показать дерево в консоли. Дополнительные сведения см. в разделе Настройка вида консоли оснастки.

Область результатов — это центральная область консоли оснастки. В ней отображаются содержащиеся объекты или сведения об элементе, выбранном в настоящее время в дереве. Область результатов всегда видима, но ее содержимое и внешний вид зависят от элемента, выбранного в дереве. Сведения об изменении вида объектов в области результатов см. в справке для используемой оснастки и в разделе Сортировка, скрытие или отображение столбцов в области результатов.

Область Действие — это правая область консоли оснастки. Она отображает доступные действия для элементов, выбранных в дереве, и для области результатов. Можно показать или скрыть область Действие. Дополнительные сведения см. в разделе Настройка вида консоли оснастки.

Примечание

  • Чтобы использовать область «Действие» консоли MMC 3.0, проверьте с помощью редактора реестра, существует ли следующий раздел реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\UseNewUI

    Если этот раздел не существует, создайте его, как описано в разделе Добавление раздела справки редактора реестра.

Дерево, корень и контейнеры

Для вывода на экран дерева новой консоли оснастки откройте консоль ММС: нажмите кнопку Пуск, выберите команду Выполнить, введите mmc и нажмите кнопку ОК.

В новой консоли единственным элементом дерева консоли является папка, помеченная как Корень консоли. Административные функции консоли могут быть созданы добавлением на консоль новых элементов. Рекомендации по добавлению элементов к консоли см. в разделе ММС 3.0 в авторском режиме.

Не обязательно размещать окно консоли в корне консоли. Его можно расположить в любом элементе дерева консоли. В этом случае элементы дерева консоли, расположенные над бывшим корнем, скрываются, и окно фокусируется на новом корневом элементе и любых средствах администрирования в подчиненной области (ниже по дереву).

Инструкции по изменению расположения корня консоли оснастки см. в разделе Добавление, удаление и упорядочение оснасток и расширений.

Контейнером называется любой элемент дерева консоли, к которому добавлены объекты. Дважды щелкнув знак плюс плюс, можно развернуть контейнер и отобразить его содержимое; знак минус минус свертывает контейнер. По умолчанию контейнер — это просто папка папка, используемая для объединения элементов дерева консоли. Однако с помощью MMC можно добавлять средства к элементам, отличным от папок, и тогда эти элементы тоже становятся контейнерами.

Корень консоли является контейнером. Он содержит только дерево консоли. Верхний элемент оснастки обычно является папкой или другим контейнером.

Отображаемый элемент представляет собой другой тип элемента, содержащего другие элементы. Щелчок отображаемого элемента открывает в окне сведений список, текст или рисунок, а не дополнительные элементы. Веб-страницы являются отображаемыми элементами, так как для них требуется программа обозревателя, которая открывается только в области результатов. Не следует добавлять элементы в отображаемые элементы, поскольку пользователь может скрыть дерево консоли. При этом ему может быть неизвестно, что отображаемый элемент содержит другие элементы. Вместо этого лучше создать для набора отображаемых элементов папку, добавив ее к дереву консоли. Это позволит пользователю производить выбор из всех элементов такой папки при скрытом дереве консоли.

Инструкции по скрытию дерева см. в разделе Настройка вида консоли оснастки.

Лист — это единственный тип элемента, который не может содержать других элементов. Если щелкнуть лист, элементы, содержащиеся в нем, появляются в области результатов. Обычно это элементы, которые по отдельности включены в дерево консоли. Однако, если число таких элементов велико (сотни и тысячи), в оснастке желательно применять лист, а не контейнер.

Добавление новой возможности к консоли оснастки

Возможно ни одна из оснасток, предлагаемых командой Добавить или удалить оснастку, не соответствует требованиям. Возможные решения этой проблемы перечислены ниже.

  • Поищите требуемую оснастку или расширение на веб-страницах среди оснасток, поставляемых Microsoft или другими разработчиками.
  • Создайте собственное расширение для существующей оснастки или создайте новую изолированную оснастку.

Дополнительные сведения об этих возможностях см. в разделе Ресурсы.


Список «Избранное» консоли MMC 3.0

Список «Избранное» находится в меню Избранное. Список «Избранное» может быть использован для создания ярлыков элементов дерева консоли. Для удобства использования предоставлена возможность добавлять ярлыки для часто используемых средств или средств, расположенных в дереве консоли несколькими уровнями ниже. Список «Избранное» облегчает выполнение задач новичкам. Например, можно создать консоль с ярлыками в списке «Избранное» только для тех элементов в дереве консоли, которые нужны данному пользователю для выполнения своей задачи. Для упрощения представления данных можно скрыть дерево консоли.

Список «Избранное» может быть использован для организации видов панели задач. Например, сложная консоль имеет несколько видов панели задач, которые распределяются между несколькими элементами в дереве консоли. Добавление этих видов панели задач к списку «Избранное» позволит пользователям обращаться к ним из одного места.

Дополнительные сведения см. в разделе Чтобы создать новую консоль оснастки из консоли MMC 3.0.


Режимы доступа к консоли оснастки

Создавая специальную консоль оснастки, можно присвоить ей один из двух режимов доступа: авторский режим или пользовательский режим. В свою очередь, существуют три уровня пользовательского режима, так что всего имеется четыре варианта доступа по умолчанию к консоли, которые описаны в таблице ниже.

    Режим | Описание
Авторский режим | Разрешает полную настройку консоли оснастки, включая возможность добавления и удаления оснасток, создание новых окон, создание списка «Избранное» и панелей задач, а также доступ ко всем параметрам диалоговых окон Настройка вида и Параметры. Пользователи, создающие специальные консоли для выполнения личных задач, обычно используют этот режим. Полученная в результате консоль оснастки обычно сохраняется в одном из следующих пользовательских режимов.
Пользовательский режим — полный доступ | Аналогичен авторскому режиму за исключением отсутствия возможностей добавления и удаления оснасток, изменения параметров консоли оснастки, создания списка «Избранное» и панелей задач.
Пользовательский режим — ограниченный доступ, многооконный | Предоставляет доступ только к частям дерева консоли, отображаемым при сохранении файла консоли. Пользователи могут создавать новые окна, но не могут закрывать ни одно из существующих окон.
Пользовательский режим — ограниченный доступ, однооконный | Предоставляет доступ только к частям дерева консоли, отображаемым при сохранении файла консоли. Пользователи не могут создавать новые окна.

Эти параметры могут быть настроены в диалоговом окне Параметры в консоли MMC. Сведения об открытии этого диалогового окна см. в разделе Чтобы установить параметры консоли MMC.

Изменения, внесенные в консоли оснастки в авторском и пользовательском режимах, сохраняются по-разному. Если работа с консолью оснастки ведется в авторском режиме, при закрытии консоли выводится предложение сохранить изменения. Однако при работе с консолью оснастки в пользовательском режиме и снятом флажке Не сохранять изменения для этой консоли (доступном по команде Параметры в меню Файл) изменения будут сохранены при закрытии консоли.

Если выполнено одно из следующих условий, предустановленный режим консоли игнорируется и консоль открывается в авторском режиме.

    • MMC уже открыта при открытии консоли оснастки.
    • Консоль оснастки открывается с помощью команды контекстного меню Автор.
    • Консоль открыта в командной строке с параметром /a.

Дополнительные сведения о режимах консоли оснастки и синтаксисе командной строки для ММС см. в разделе Чтобы открыть консоль MMC.

Авторский режим не требуется пользователям, которым не нужно создавать или изменять консоли оснастки. Системный администратор может настроить профили пользователей, так чтобы запретить им переход в авторский режим, как через параметр /a, так и через контекстное меню. Кроме того, администратор может использовать настройки групповой политики для запрещения пользователям открытия MMC и сохраненных консолей в авторском режиме. Дополнительные сведения см. в разделе Групповая политика и консоль MMC 3.0.


Безопасность консоли MMC 3.0

Консоли оснастки зачастую являются мощными средствами, поэтому все общие рекомендации по управлению безопасностью применимы к консоли MMC. Если конкретная оснастка или поддерживающая ее технология предоставляет дополнительные рекомендации по безопасности, эти рекомендации следует ввести в политики и процедуры.

В данном разделе рассматриваются следующие процедуры.

  • Групповая политика и консоль MMC 3.0
  • Использование команды runas с помощью консоли MMC

Подробные сведения о параметрах безопасности см. в следующих разделах:

  • Почему не следует работать на компьютере, используя учетную запись администратора
  • Чтобы запустить программу, используя учетную запись администратора
  • Чтобы создать ярлык с помощью команды runas


Групповая политика и консоль MMC 3.0

Только администраторы могут использовать групповую политику для разрешения и ограничения доступа к определенным оснасткам или ограничения возможности пользователя или группы использовать авторский режим в MMC. Это верно в сети с настроенной групповой политикой.

Чтобы настроить политику для пользователей определенного компьютера, необходимо быть администратором компьютера или иметь эквивалентные права. Чтобы настроить политику для подразделения в домене, необходимо быть администратором домена или иметь эквивалентные права. Невозможно использовать консоль MMC для создания политик компьютера, можно создавать только политики пользователей.

Дополнительные сведения о групповой политике содержатся в справке.

Для получения дополнительных сведений о применении групповой политики к MMC см. Использование групповой политики для управления консолью MMC.


Использование команды runas с консолью MMC

Администраторам рекомендуется использовать учетную запись с ограниченными разрешениями для выполнения повседневных задач, не связанных с администрированием, и учетную запись с более широкими правами только для выполнения отдельных административных задач. Чтобы реализовать такой подход без выхода из системы и повторного входа, войдите в систему с обычной учетной записью и используйте команду runas для запуска программ, требующих более широких прав.

С помощью команды runas можно выполнять программы (*.exe), запускать сохраненные консоли MMC (*.msc), ярлыки программ и сохраненных консолей MMC и компоненты панели управления. Их можно запускать в качестве администратора, даже если вход в систему был произведен с учетной записью члена другой группы, например группы пользователей или опытных пользователей.

Можно использовать команду runas для запуска любой программы, консоли оснастки или компонента панели управления. Поскольку указываются соответствующие сведения об имени пользователя и его пароле, учетная запись пользователя предоставляет возможность подключения к компьютеру и доступ к программам, консолям оснастки или компонентам панели управления системы.

Команда runas позволяет администрировать сервер в другом лесе (т. е. компьютер, с которого запускается средство, и управляемый сервер располагаются в разных доменах).

При попытке запуска программы, консоли оснастки или компонента панели управления из сети с помощью команды runas выполнение может окончиться неудачей, поскольку личные сведения, использованные для подключения к совместно используемому сетевому файлу, могут отличаться от тех, что использованы при запуске программы. Личные сведения, использованные при запуске программы, могут не позволить получить доступ к тому же сетевому ресурсу.

Некоторые компоненты, например папка «Принтеры» и элементы рабочего стола, открываются косвенно. Эти компоненты не могут быть запущены командой runas.

Если выполнение команды runas заканчивается неудачей, может оказаться, что служба вторичного входа не запущена или используемая учетная запись пользователя недопустима. Чтобы проверить состояние службы вторичного входа, в компоненте «Управление компьютером» щелкните узел Службы и приложения, а затем — Службы. Чтобы проверить учетную запись пользователя, попытайтесь подключиться к соответствующему домену с помощью этой учетной записи.

Подробности о команде runas см. в разделе Runas.


Использование MMC 3.0

Рисунок Microsoft Windows

Использование консоли MMC версии 3.0

В этом разделе рассмотрены следующие темы.

  • Консоль MMC версии 3.0 в авторском режиме
  • Использование окна консоли MMC версии 3.0.
  • Создание и использование консолей с несколькими оснастками
  • Использование вкладки «Изолированная оснастка» в диалоговом окне «Добавить или удалить оснастку»
  • Использование страниц свойств в консолях оснастки
  • Параметры командной строки консоли ММС версии 3.0
  • Использование справочной системы консоли MMC версии 3.0


Использование окна консоли MMC 3.0

Способ использования окна консоли MMC зависит, в основном, от того, как сформирована консоль оснастки. В простейшем случае консоль оснастки формируется под конкретный набор задач. В этом случае следует просто посмотреть, куда приведет консоль оснастки.

Чаще всего используются три области консоли MMC: дерево, область результатов и область Действие. Начните открывать контейнеры в дереве до тех пор, пока объект, с которым предполагается работать, либо не будет выделен в дереве, либо отобразится в области результатов. Выберите объект или объекты в дереве или в области результатов, затем щелкните какое-либо действие в области Действие, чтобы продолжить работу с этими объектами. В области Действие появляются только те действия, которые могут выполняться в данный момент с выбранными объектами; эта область напоминает меню Действие.

Примечание

  • Контейнером называется любой элемент дерева консоли, к которому добавлены элементы. Чтобы развернуть контейнер и просмотреть его содержимое, дважды щелкните знак плюс Знак плюс.

Если имеются объекты, к которым желательно обеспечить быстрый доступ без перемещения по дереву, можно добавить их в этой консоли оснастки в меню Избранное. Соответствующие инструкции см. в разделе Создание и использование меню «Избранное».

Сведения о сочетаниях клавиш для перемещения по дереву см. в разделе Перемещения в консоли MMC с помощью клавиатуры и мыши.

Работа с заранее настроенными консолями оснастки

В процессе работы может понадобиться использовать заранее настроенные консоли оснастки (обычно называемые сохраненные консоли), являющиеся частью операционной системы или приложения, и никогда не потребуется создавать собственные консоли оснастки. Заранее настроенные консоли оснастки обычно доступны в папке «Администрирование» на панели управления или в меню Пуск. Если специальная консоль оснастки сохранена в папке «Администрирование» для пользователя (размещается по адресу \\%системный_диск%\Documents and Settings\пользователь\Главное меню\Программы\Администрирование), она доступна в папке «Администрирование» в меню Программы.

Возможно, что любая из заранее настроенных консолей, являющихся частью операционной системы, может быть отрыта в любом из трех пользовательских режимов. По умолчанию используется режим Режим пользователя - ограниченный доступ, однооконный. Дополнительные сведения о настройках по умолчанию для режима консоли см. в разделе Режимы доступа к консоли оснастки.

Настройка вида для сохраненных консолей оснастки

Чтобы скрыть и отобразить элементы консоли, можно использовать диалоговое окно Настройка вида, открываемое командой Настроить в меню Вид. Одним из элементов, которые могут быть скрыты, является само меню Вид. Если это меню было скрыто, но необходимо перенастроить вид, диалоговое окно Настройка вида может быть открыто командой Настроить вид в системном меню. Дополнительные сведения см. в разделе Настройка консоли.

Работа со столбцами в сохраненных консолях

В сохраненных консолях, которые выводят столбцы в области сведений, может быть настроен внешний вид столбцов и строк. Например, можно изменить порядок столбцов или скрыть некоторые из них. Также, щелкнув заголовок столбца, можно выстроить строки в алфавитном или хронологическом порядке. Кроме того, в некоторых оснастках столбцы могут отфильтрованы в соответствии с дополнительными атрибутами. Если эта возможность разрешена, под заголовком столбца появляется ряд полей с раскрывающимися списками, содержащих параметры фильтрации. Дополнительные сведения см. в разделе Чтобы выполнить сортировку, скрытие или отображение столбцов в области результатов.

Содержимое столбцов может быть экспортировано в текстовый файл. Дополнительные сведения см. в разделе Чтобы экспортировать данные в текстовый файл.

Если столбцы настроены в консоли оснастки, параметры сохраняются из сеанса в сеанс.

Дополнительные сведения об области результатов см. в разделе Окно консоли MMC 3.0.


Создание и использование консолей оснастки с несколькими оснастками

Консоль оснастки может содержать одну или несколько оснасток. Если создается консоль с несколькими оснастками, можно создать средства, облегчающие поиск оснастки в консоли.

  • Выберите порядок, в котором консоли должны появляться в дереве, и добавьте их в том же порядке в консоль оснастки. Дополнительные сведения см. в разделе Чтобы добавить, удалить и упорядочить оснастки и расширения.
  • Выберите способ упорядочения оснасток в разных папках в корне консоли. Дополнительные сведения см. в разделе Окно консоли MMC 3.0.
  • Выберите способ создания структуры в папке «Избранное», чтобы облегчить пользователям консоли оснастки поиск важных для него видов. Дополнительные сведения см. в разделе Список «Избранное» консоли MMC 3.0.

Выделение в дереве указывает, какая оснастка и какой объект в оснастке просматриваются в данный момент. Однако, если используется консоль оснастки, в которой имеются две или более оснасток с длинными или одинаковыми деревьями, возможно, потребуется прокрутить дерево вверх или вниз, чтобы найти используемую оснастку. В этом случае, возможно, придется создать окно для каждой из этих оснасток или для одного или нескольких узлов дерева. Для этого щелкните правой кнопкой узел, на основе которого необходимо создать окно, затем выберите команду Новое окно отсюда. Для перемещения между окнами используйте меню Окно. Чтобы создать новое окно, следует использовать консоль оснастки в режиме, который позволяет это выполнять. Дополнительные сведения о режимах консоли см. в разделе Режимы доступа к консоли оснастки.


Использование вкладки «Изолированная оснастка» в диалоговом окне «Добавить или удалить оснастку»

Вкладку Изолированная оснастка диалогового окна Добавить или удалить оснастку следует использовать, чтобы добавить оснастку в текущую консоль, получить информацию о версии оснастки или удалить оснастку из консоли.

  • Чтобы добавить оснастки в определенный корень, выберите корень в списке Оснастки перед тем, как добавите оснастку.
  • Чтобы добавить оснастку в выбранный корень, щелкните Добавить. Будет открыто диалоговое окно Добавить изолированную оснастку. Выберите оснастку, щелкнув ее в списке Доступные изолированные оснастки, а затем щелкните Добавить.
  • Чтобы просмотреть дополнительную информацию об установленной оснастке, в том числе информацию о версии, сначала щелкните корень, в котором находится оснастка, в списке Оснастки. Затем щелкните оснастку, после чего щелкните Сведения. Если дополнительные сведения о выбранном объекте отсутствуют, кнопка Сведения будет недоступна.
  • Чтобы удалить оснастку, сначала щелкните корень, в котором находится оснастка, в списке Оснастки. Затем выберите оснастку и щелкните Удалить. При удалении оснастки с расширениями, зависимые расширения данной оснастки также будут удалены.

Примечания

  • Чтобы открыть из консоли диалоговое окно Добавить или удалить оснастку, щелкните меню Файл, а затем щелкните Добавить или удалить оснастку.

См. также


Использование страниц свойств в сохраненных консолях оснастки

Значительная часть работы с использованием консоли оснастки выполняется со страниц свойств. Фактически, определенные оснастки или расширения доступны в консоли оснастки только через страницу свойств. В некоторых случаях можно определить, какая оснастка предоставляет определенную вкладку в диалоговом окне свойств, удерживая нажатой клавишу CTRL и указывая мышью название вкладки. Если, нажав клавишу CTRL, указать мышью заголовок диалогового окна свойств, можно определить путь в дереве консоли к элементу, связанному со страницей свойств. Дополнительные сведения см. в разделе Чтобы просмотреть связанную оснастку и элемент для страницы свойств.

Диалоговые окна свойств консолей оснастки часто бывают скрыты за консолями оснастки и другими средствами. Если не удается найти страницу свойств, с которой производилась работа, просто откройте снова диалоговое окно или сверните другие программы на экране.


Параметры командной строки консоли ММС 3.0

Используя параметры командной строки консоли ММС, можно открыть конкретную консоль оснастки, открыть ММС в авторском режиме или определить, какая версия ММС открыта: 32-разрядная или 64-разрядная.

Синтаксис

mmc путь\имя_файла.msc [/a] [/64] [/32]

Параметры

путь\имя_файла.msc
Запуск консоли MMC с открытием сохраненной консоли оснастки. Необходимо указать полный путь и имя файла для сохраненной консоли. Если файл консоли не указан, MMC открывает новую консоль оснастки.
/a
Открытие сохраненной консоли оснастки в авторском режиме. Используется для внесения изменений в сохраненные консоли.
/64
Открывает 64-разрядную версию MMC (MMC64). Этот параметр следует использовать, только если требуется использовать 64-разрядную оснастку при выполнении 64-разрядной операционной системы Microsoft.
/32
Открывает 32-разрядную версию MMC (MMC32). При выполнении 64-разрядной операционной системы Microsoft и при наличии только 32-разрядных оснасток их можно выполнять, открыв MMC с этим параметром командной строки.

Заметки

  • Использование параметра командной строки путь\имя_файла.msc

    Для создания командных строк и ярлыков, которые не зависят от явного расположения файлов консоли, можно использовать переменные среды. Например, если путь к файлу консоли включает системную папку (например, mmc c:\winnt\system32\имя_консоли), то для указания пути можно использовать строку данных %systemroot% (mmc %systemroot%\system32\имя_консоли.msc). Это полезно при делегировании заданий пользователям, работающим на разных компьютерах.

  • Использование параметра командной строки /a

    Когда консоли открываются с этим параметром, они открываются в авторском режиме, независимо от режима, используемого по умолчанию. При этом установки режима по умолчанию для файлов не меняются; при пропуске этого параметра MMC открывает файлы консолей оснастки в соответствии с их режимами по умолчанию.

  • После открытия MMC или файла консоли любая существующая консоль открывается с помощью команды Открыть из меню Консоль.
  • С помощью командной строки можно создавать ярлыки для запуска консоли MMC и работы с сохраненными консолями оснастки. Команда для командной строки работает в окне команды Выполнить из меню кнопки Пуск, в любом окне командной строки, в ярлыках, в пакетных файлах и программах, вызывающих такие команды.

Условные обозначения форматирования

Формат | Описание
Курсив | Сведения вводимые пользователем
Полужирный шрифт | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурных скобках ({}), варианты разделены вертикальной линией (|). Пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы

См. также


Совместимость консоли MMC 3.0

В этом разделе представлены сведения общего характера о совместимости разных версий консоли MMC и оснасток MMC:

  • Выполнение 32-разрядных и 64-разрядных оснасток в операционных системах семейства Windows Server 2003
  • Использование в MMC 3.0 файлов, созданных в более ранних версиях ММС


Выполнение 32-разрядных и 64-разрядных оснасток в операционных системах семейства Windows Server 2003

64-разрядные операционные системы корпорации Майкрософт могут выполнять и 32-разрядные консоли ММС (ММС32), и 64-рязрядные (ММС64). Консоль ММС64 не может выполнять 32-разрядные оснастки, а ММС32 — 64-разрядые. Некоторые оснастки доступны как в 32-разрядном, так и 64-разрядном режиме. Оснастка считается доступной в 64-разрядном режиме, если она указана в реестре как раздел HKEY_CLASSES_ROOT\CLSID\код_класса_оснастки\InprocServer32, где код_класса_оснастки — зарегистрированный код класса CLSID оснастки.

В данном разделе даются инструкции по управлению и определению, какая версия ММС выполняется на 64-разрядной операционной системе корпорации Майкрософт.

Выбор варианта запуска, если указан параметр /32 или /64

MMC может выполняться с параметрами командной строки, включая имя файла консоли и (в 64-разрядной операционной системе Windows) следующие параметры командной строки:

  • /32
    Указывает MMC32.
  • /64
    Указывает MMC64. Это установка по умолчанию в 64-разрядной операционной системе Windows.

Если используются оба эти параметра командной строки, действителен последний параметр в командной строке. Если выполняются определенные условия, MMC64 будет функционировать как MMC32, как описано в следующем разделе.

Выбор варианта запуска, если указан файл консоли

Если командная строка консоли ММС не содержит параметра /32 или /64, но в ней указано имя файла консоли, ММС64 проверяет файл перед определением выбора версии ММС для выполнения. Последовательность решений следующая:

  1. Если все оснастки в консоли доступны в 64-разрядном режиме, используется MMC64.
  2. Если все оснастки в консоли доступны в 32-разрядном режиме, используется MMC32. (MMC64 запускает MMC32, затем MMC64 завершает работу.)
  3. Если некоторые из оснасток доступны только в 64-разрядном режиме, а другие - только в 32-разрядном режиме, используется версия ММС, которая может запускать большинство оснасток. Остальные оснастки не загружаются.

    Например, если консоль содержит три оснастки, которые доступны только в 32-разрядном режиме, и две оснастки, которые доступны только в 64-разрядном режиме, будет использоваться ММС32 и при открытии консоли будут отображаться только три 32-разрядные оснастки. Две оснастки, доступные только в 64-разрядном режиме, не будут загружаться.

  4. Если некоторые из оснасток доступны только в 64-разрядном режиме и равное количество оснасток доступно только в 32-разрядном режиме, программа выведет сообщение с вопросом, какую версию ММС выполнять. Если выбрать MMC64, загрузятся только 64-разрядные оснастки. Если выбрать MMC32, загрузятся только 32-разрядные оснастки.

Когда указывать путь к файлу консоли

В операционных системах Windows XP Professional и Windows Server 2003 системные файлы сохраняются в папке %windir%\system32. В 64-разрядных версиях этих операционных систем папка \system32 содержит 64-разрядные файлы, включая файлы 64-разрядных консолей, например, eventvwr.msc. Если есть также и 32-разрядная версия оснастки, она находится в папке %windir%\syswow64. В этом примере 32-разрядная версия оснастки «Просмотр событий» будет %windir%\syswow64\eventvwr.msc. Если есть и 64-разрядная версия консоли в папке \system32, и 32-разрядная версия в папке \syswow64, и вы хотите явно запустить 32-разрядную версию, необходимо обойти процесс принятия решений MMC, указав и путь, и параметр командной строки /32. Например:

MMC /32 %windir%\syswow64\eventvwr.msc

Примечание

  • Двойной щелчок ярлыка файла в папке \syswow64 аналогичен двойному щелчку файла в проводнике, поскольку он запускает ММС без параметра командной строки /32. Чтобы открыть 32-разрядные консоли в папке \syswow64, вместо того, чтобы использовать ярлык, нажмите кнопку Пуск, выберите пункт Выполнить и затем введите команду, указывающую и путь, и параметр командной строки /32.


Использование в ММС 3.0 файлов, созданных в более ранних версиях ММС

Консоль MMC 3.0 разработана для поддержки оснасток, разработанных для MMC 1.2 и MMC 2.0. Можно добавить эти оснастки на консоль MMC 3.0, и они будут функционировать как в версиях ММС, для которых они были разработаны.

Можно использовать MMC 3.0, чтобы открывать консоль оснастки, которая была создана с использованием MMC 2.0 или MMC 1.2. Если затем сохранить консоль оснастки, появится запрос о ее сохранении формате MMC 3.0. Если сохранить ее в формате MMC 3.0, ее нельзя будет открывать в более ранних версиях MMC. Нельзя использовать MMC 2.0, для того чтобы открывать консоль оснастки, которая была создана с помощью MMC 3.0.


Специальные возможности MMC

В дополнение к продуктам и службам, поддерживающим специальные возможности в Microsoft Windows, консоль MMC обеспечивает комбинации клавиш для выбора команд и перемещения в окнах консоли и между ними. Оснастки и другие элементы, добавленные на консоль MMC, могут сами предоставлять специальные возможности. Дополнительные сведения см. в справке или другой документации по элементам консоли.

В этом разделе:

  • Перемещения в ММС с использованием клавиатуры и мыши
  • Комбинации клавиш MMC


Перемещения в консоли MMC с помощью клавиатуры и мыши

Можно просматривать дерево консоли, разворачивая и сворачивая ветви. Для этого щелкните знаки «плюс» Знак плюс и «минус» Знак минус или дважды щелкните ветвь. Следующая таблица содержит сочетания клавиш для перемещений как внутри окон, так и между окнами текущей консоли.

Нажатие клавиш | Результат
TAB или F6 | Перемещает вперед между областями активного окна консоли.
SHIFT+TAB или SHIFT+F6 | Перемещает назад между областями активного окна консоли.
CTRL+TAB или CTRL+F6 | Перемещает вперед между окнами консоли.
CTRL+SHIFT+TAB или CTRL+SHIFT+F6 | Перемещает назад между окнами консоли.
ПЛЮС (+) на цифровой клавиатуре | Развертывает выбранный элемент.
МИНУС (-) на цифровой клавиатуре | Свертывает выбранный элемент.
Звездочка (*) на цифровой клавиатуре | Развертывает все дерево консоли под корневым элементом в активном окне консоли.
СТРЕЛКА ВВЕРХ | Перемещает выделение в области на один элемент вверх.
СТРЕЛКА ВНИЗ | Перемещает выделение в области на один элемент вниз.
PAGE UP | Перемещает выделение на самый верхний видимый элемент области.
PAGE DOWN | Перемещает выделение на самый нижний видимый элемент области.
HOME | Выбирает первый элемент области.
END | Выбирает последний элемент области.
СТРЕЛКА ВПРАВО | Развертывает выбранный элемент. Если выбранный элемент не содержит скрытых элементов, действует как СТРЕЛКА ВНИЗ.
СТРЕЛКА ВЛЕВО | Свертывает выбранный элемент. Если выбранный элемент не содержит скрытых элементов, действует как СТРЕЛКА ВВЕРХ.
ALT+СТРЕЛКА ВПРАВО | Перемещает выделение на следующий элемент. Выполняет те же функции, что и стрелка Вперед на панели инструментов.
ALT+СТРЕЛКА ВЛЕВО | Перемещает выделение на предыдущий элемент. Выполняет те же функции, что и стрелка Назад на панели инструментов.

Следующая таблица включает список действий мыши для перемещения по дереву консоли MMC.

Действия с мышью | Результат
Нажатие левой кнопки мыши | Выбирает элемент.
Двойной щелчок | Отображает либо скрывает элементы, скрытые внутри выбранного элемента. Отображает свойства либо открывает элемент.
Нажатие правой кнопки мыши | Отображает контекстное меню Действие для выбранного элемента.

Примечание

  • Если кнопки мыши ведут себя не так, как описано, то, вероятно, они переключены. Используемый компьютер, возможно, настроен так, что по умолчанию произведена взаимная замена действий правой и левой кнопок мыши.


Сочетания клавиш консоли MMC

В этом разделе рассматриваются два типа сочетаний клавиш: сочетания клавиш для главного окна и сочетания клавиш для активного окна.

Сочетания клавиш для главного окна MMC

Следующая таблица включает сочетания клавиш для команд меню, которые воздействуют на всю консоль оснастки или на главное окно консоли оснастки.

Команда | Результат
CTRL+O | Открывает сохраненную консоль оснастки.
CTRL+N | Открывает новую консоль оснастки.
CTRL+S | Сохраняет открытую консоль оснастки.
CTRL+M | Открывает диалоговое окно Добавить или удалить оснастку.
CTRL+W | Открывает новое окно.
F5 | Обновляет содержимое всех окон консоли оснастки.
ALT + ПРОБЕЛ | Отображает системное меню MMC.
ALT+F4 | Закрывает консоль оснастки.
ALT+A | Открывает меню Действие.
ALT+V | Открывает меню Вид.
ALT+В | Открывает меню Файл.
ALT+М | Открывает меню Избранное.
ALT+W | Открывает меню Окно.
ALT+H | Открывает меню Справка.

Примечание

  • Сочетание клавиш CTRL+W доступно для консолей, открытых в авторском режиме или пользовательском режиме с полным доступом. Другие сочетания с клавишей CTRL доступны только для консолей, открытых в авторском режиме.

Сочетания клавиш для активного окна консоли MMC

Ниже в таблице приведены сочетания клавиш для команд меню, которые воздействуют на активное окно консоли оснастки или на его содержимое.

Действие | Результат
CTRL+P | Выводит на печать текущую страницу или активную область, если оснастка поддерживает печать.
ALT+ЗНАК МИНУС | Отображает системное меню активного окна консоли оснастки.
SHIFT+F10 | Отображает контекстное меню Действие для выбранного элемента.
F1 | Открывает раздел справки (если он есть) для выбранного элемента.
F5 | Обновляет содержимое всех окон консоли оснастки.
CTRL+F10 | Развертывает активное окно консоли оснастки.
CTRL+F5 | Восстанавливает активное окно консоли оснастки.
ALT+ВВОД | Отображает диалоговое окно свойств выбранного элемента, если оно существует.
F2 | Переименовывает выбранный элемент.
CTRL+F4 | Закрывает активное окно консоли оснастки. Когда у консоли оснастки имеется только одно окно, это действие закрывает консоль оснастки.


Устранение неполадок консоли MMC версии 3.0

Установите вид неполадки.

Не удается найти справку для оснастки.

Причина. Оснастка не содержит файл справки, отображаемый в справочной системе консоли ММС. Оснастка может использовать другие способы предоставления справочных сведений.

Решение. Откройте в авторском режиме консоль, содержащую оснастку, щелкните в дереве консоли элемент, справку для которого нужно получить, и щелкните меню Справка. Над командой Вызов справки в меню Справка может появиться отдельная команда для справки по оснастке.

Если отдельная команда не появилась, поищите в содержимом панелей инструментов и в области результатов кнопку справки Кнопка справки или дополнительный значок. Если не обнаружена отдельная команда, кнопка или значок, справка для данной оснастки отсутствует. Если оснастка выпущена не корпорацией Майкрософт, возможно, понадобится обратиться с вопросом непосредственно к производителю. Чтобы узнать наименование производителя оснастки, выделите оснастку в дереве консоли MMC, а затем в меню Справка выберите команду О программе.

Оснастка отсутствует в списке диалогового окна Добавить изолированную оснастку.

Причина. Соответствующая служба или программное обеспечение не установлены на компьютере.

Решение. Необходимо установить компонент, чтобы увидеть его оснастку.

При использовании консоли возникла одна или несколько следующих неисправностей: поведение консоли отличается от ожидаемого, превышен интервал ожидания консоли или выведены сообщения об ошибках, не появлявшиеся ранее.

Причина. Одно из следующих предположений может быть причиной: возможно, файл консоли оснастки поврежден; возможно, вследствие изменений в сети, устарела конфигурация консоли оснастки.

Решение. Определите оснастку, вызывающую проблему, и обратитесь к сведениям по устранению неполадок в документации по этой оснастке для нахождения способа восстановления или перенастройки оснастки. Чтобы выявить оснастку, вызывающую неполадки, щелкните правой кнопкой мыши элемент в дереве консоли или в области сведений и выберите из контекстного меню команду Свойства. Удерживая нажатой клавишу CTRL, укажите названия вкладок диалогового окна.

Если не удается непосредственно восстановить или перенастроить консоль, попробуйте добавить на консоль другой экземпляр используемой оснастки, настройте ее и затем удалите старую версию оснастки.

См. также: разделы Чтобы добавить, удалить или упорядочить оснастки и расширения, Оснастки и Чтобы просмотреть связанную оснастку и элемент для страницы свойств.


Ресурсы

Дополнительные сведения о MMC 3.0 см. в следующих источниках.

  • На веб-странице центра технической поддержки корпорации Майкрософт, которая находится на веб-узле корпорации Майкрософт (http://www.microsoft.com/), содержатся основные сведения о поддержке и статьи, написанные сотрудниками службы технической поддержки корпорации Майкрософт.
  • Дополнительные сведения см. в техническом руководстве по Windows Server 2003 на веб-узле корпорации Майкрософт (http://www.microsoft.com/)


Запрошенное средство недоступно

Для доступа к этому средству попробуйте выполнить следующие действия.

Настройте компьютер.

Чтобы получить доступ к определенным административным средствам, необходимо выполнить следующие условия.

  • Компьютер под управлением операционной системы семейства Windows Server 2003 должен быть настроен как контроллер домена.
  • На компьютере-клиенте с системой Windows XP Professional, который был добавлен в домен, должен быть установлен пакет средств администрирования Windows Server 2003.
  • Сервер с системой Windows Server 2003 должен быть добавлен в домен.

Дополнительные сведения о настройке контроллера домена и установке пакета средств администрирования Windows Server 2003 см. в справке.

Установите необходимое оборудование.

Некоторые программы устанавливаются автоматически при установке оборудования, для работы с которым они предназначены. Например, при установке факса Windows Server 2003 устанавливает программу Fax. Чтобы установить новое оборудование, нажмите кнопку Пуск, выберите команды Настройка и Панель управления и дважды щелкните значок Установка оборудования.

Установите данное средство.

Средство может быть не установлено на компьютере по следующим причинам.

  • Средство является необязательным компонентом. Чтобы установить дополнительный компонент, нажмите кнопку Пуск, выберите команды Настройка и Панель управления и дважды щелкните значок Установка и удаление программ.
  • Если компьютер работает в сети, системный администратор мог удалить эту программу или установить политику, не позволяющую запускать ее.
  • На компьютере установлен пакет средств администрирования, но это средство является одним из дополнительных компонентов, которые еще не установлены.

Доступ к оснастке Active Directory.

Для доступа к службам терминалов на компьютере под управлением операционной системы семейства Windows Server 2003, в которой имеется эта оснастка, можно использовать средство Windows XP Professional «Дистанционное управление рабочим столом». Дополнительные сведения об использовании средства «Дистанционное управление рабочим столом» и служб терминалов см. в разделах:

  • Чтобы создать новое подключение
  • Домашняя страница операционных систем Windows Server 2003 (http://www.microsoft.com/)

Уточните у системного администратора, что это средство не было изменено или удалено.

Если компьютер работает в сети, системный администратор мог удалить это средство.


Дата компиляции

 Дата компиляции: 2005-10-14


Создание вида панели задач

Рисунок Microsoft Windows

Чтобы создать вид панели задач в сохраненной консоли MMC

  1. Откройте сохраненную консоль оснастки в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши MSC-файл и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку OK.
  2. В дереве консоли щелкните значок оснастки.
  3. В области Действие щелкните Новый вид панели задач.
  4. Следуйте инструкциям мастера создания вида панели задач.
  5. Если сразу после создания вида панели задач необходимо создать задачи, установите флажок Запустить мастер создания новой задачи на последнем экране мастера.

Примечания

  • Вид панели задач также может быть создан в новой консоли, но сначала необходимо добавить оснастку.
  • В консоли MMC 3.0 панель Действие заменяет виды панели задач. Мастер создания нового вида панели задач не доступен для оснасток, созданных для MMC 3.0, но по-прежнему поддерживается более старыми версиями оснасток.

См. также


Создание задач для вида панели задач

Рисунок Microsoft Windows

Чтобы создать задачи для вида панели задач

  1. Откройте сохраненную консоль оснастки в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши MSI-файл и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку ОК.
  2. Щелкните в дереве элемент, связанный с видом панели задач, а затем в области Действие щелкните Правка вида панели задач.
  3. На вкладке Задачи нажмите кнопку Создать.
  4. Следуйте инструкциям мастера создания задачи.

Примечания

  • Если создается новый вид панели задач и требуется добавить задачу, можно запустить мастер создания задачи, установив флажок Запустить мастер создания новой задачи на последнем экране мастера создания вида панели задач.
  • Если выбран пункт Задача элемента дерева и на странице Команда контекстного меню мастера создания задачи не удается просмотреть все элементы дерева в списке Источник команд, необходимо раскрыть это дерево вручную перед запуском мастера создания задачи.
  • В консоли MMC 3.0 область Действие заменяет виды панели задач. Мастер создания вида панели задач недоступен для оснасток, созданных для консоли MMC 3.0, однако он продолжает поддерживаться для более старых оснасток.

См. также


Диалоговое окно «Добавление столбцов»

Рисунок Microsoft Windows

Диалоговое окно «Добавление или удаление столбцов»

Используйте диалоговое окно Добавление или удаление столбцов, чтобы скрыть, отобразить или упорядочить столбцы на отображаемой в данный момент области результатов консоли.

  • Чтобы отобразить скрытый в данный момент столбец, щелкните имя столбца в списке Отображаемые столбцы, затем нажмите кнопку Добавить.
  • Чтобы скрыть отображаемый в данный момент столбец, щелкните имя столбца в списке Имеющиеся столбцы, затем нажмите кнопку Удалить.

    Некоторые столбцы скрыть невозможно. Когда выбран один из этих столбцов, кнопка Удалить недоступна.

  • Чтобы изменить порядок столбцов, щелкните имя столбца в списке Имеющиеся столбцы, затем нажмите кнопку Вверх или Вниз.

    Кроме того, порядок столбцов можно изменить непосредственно в области результатов, перетащив заголовок столбца на новое место.

  • Чтобы восстановить параметры столбца, принимаемые по умолчанию для текущей области результатов, нажмите кнопку По умолчанию. Эта функция недоступна, если уже действуют принимаемые по умолчанию параметры столбца.

Примечание

  • Чтобы открыть с консоли диалоговое окно Добавление или удаление столбцов, в меню Вид выберите команду Добавить или удалить столбцы.

См. также


Диалоговое окно «Добавление в папку "Избранное"»

Для добавления текущей страницы в список «Избранное» используйте диалоговое окно Добавление в папку «Избранное».

  • Чтобы добавить элементы в корень списка «Избранное», используя имя, отображаемое в поле Имя, затем нажмите кнопку ОК.
  • Чтобы изменить имя страницы, отображаемой в списке «Избранное», введите новое имя в поле Имя.
  • Чтобы поместить элемент в существующую папку в списке «Избранное», щелкните эту папку.
  • Чтобы создать новую папку, в которую будет помещен этот элемент, нажмите кнопку Создать папку и введите имя новой папки в поле Имя папки.

Примечание

  • Чтобы открыть с консоли диалоговое окно Добавление в папку «Избранное», в меню Избранное выберите команду Добавить в избранное.

См. также


Диалоговое окно «Папка для избранного»

Чтобы переместить элементы вашего списка «Избранное» из одной папки в другую, используйте диалоговое окно Папка для избранного.

В папке «Избранное» содержатся явно созданные папки. Чтобы перейти в папку, в которую предполагается переместить элемент, дважды щелкните папки, в которых содержится этот элемент. Когда нужная папка будет выделена, нажмите кнопку ОК.

Примечание

  • Чтобы открыть диалоговое окно Папка для избранного, в меню Избранное выберите команду Упорядочить избранное, щелкните элемент в списке «Избранное», затем нажмите кнопку Переместить в папку.

См. также


Диалоговое окно «Упорядочить избранное»

Чтобы упорядочить список «Избранное» для консоли, используйте диалоговое окно Упорядочить избранное. Список «Избранное» может включать виды страниц и панели задач, на которые необходимо быстро перейти.

  • Чтобы просмотреть элементы в папке, дважды щелкните папку в представлении в виде дерева в правой стороне диалогового окна.
  • Чтобы просмотреть описание страницы в списке «Избранное», щелкните этот элемент. В области ниже четырех кнопок появляются имя и имеющееся описание.
  • Чтобы создать новую папку для элементов в списке «Избранное», нажмите кнопку Создать папку, затем введите имя новой папки в поле Имя папки. Папка создается в папке Избранное. Чтобы просмотреть новую папку, дважды щелкните папку Избранное.
  • Чтобы переименовать элемент или папку, щелкните его, нажмите кнопку Переименовать, затем введите новое имя.
  • Чтобы переместить элемент в другую папку, щелкните его, затем нажмите кнопку Переместить в папку. Откроется диалоговое окно Папка для избранного. Все другие папки для избранного содержатся в папке «Избранное». Чтобы перейти в папку, в которую предполагается переместить элемент, дважды щелкните папки, в которых содержится этот элемент. Когда нужная папка будет выделена, нажмите кнопку ОК.
  • Чтобы удалить элемент или папку, щелкните его, затем нажмите кнопку Удалить.

Внимание!

  • Если удаляется папка, то все элементы в этой папке тоже будут удалены. Перед тем как удалить папку, откройте эту папку и убедитесь, что все элементы в ней можно удалять.

Примечание

  • Чтобы открыть с консоли диалоговое окно Упорядочить избранное, в меню Избранное выберите команду Упорядочить избранное.

См. также


Диалоговое окно «Добавить изолированную оснастку».

Рисунок Microsoft Windows

Диалоговое окно «Добавить изолированную оснастку»

Используйте диалоговое окно Добавить изолированную оснастку, чтобы добавить доступные оснастки в текущую консоль.

Чтобы добавить оснастку, щелкните ее в списке Доступные изолированные оснастки, а затем щелкните Добавить. Оснастка будет добавлена, а диалоговое окно останется открытым до тех пор, пока вы не щелкнете Закрыть.

Примечания

  • Чтобы открыть с консоли диалоговое окно Добавить изолированную оснастку, щелкните меню Файл, а затем щелкните Добавить или удалить оснастку. После чего нажмите кнопку Добавить.
  • Если оснастка, которую вы хотите добавить, отсутствует в списке Доступные изолированные оснастки, вам может понадобиться установить программу, управляемую оснасткой консоли.

См. также


Диалоговое окно «Добавить или удалить оснастку» — вкладка «Расширения»

Используйте вкладку Расширения диалогового окна Добавить или удалить оснастку, чтобы добавить расширения к оснасткам и расширениям, которые установлены в текущей консоли, чтобы получить сведения о версиях расширений установленных в данный момент оснасток и расширений или удалить расширения из консоли.

  • Чтобы добавить расширения, сначала щелкните в списке Оснастки, которые могут быть расширены оснастку или расширение, для которых требуется добавить расширения. В списке перечислены только оснастки и расширения, которые были добавлены в эту консоль. Затем щелкните одно или более расширений в списке Доступные расширения или установите флажок Добавить все расширения, чтобы добавить все доступные расширения к элементу в списке Оснастки, которые могут быть расширены.
  • Чтобы просмотреть дополнительные сведения о расширении, включая информацию о версии, сначала щелкните оснастку или расширение в списке Оснастки, которые могут быть расширены. Затем щелкните расширение и кнопку Сведения. Если дополнительные сведения для выбранного элемента отсутствуют, кнопка Сведения недоступна.
  • Чтобы удалить расширения, сначала щелкните в списке Оснастки, которые могут быть расширены оснастку или расширение, для которых требуется удалить расширения. Затем снимите флажки для расширений, которые требуется удалить. Если вы удалите расширение, имеющее расширения, эти зависимые расширения также будут удалены.

Примечание

  • Чтобы открыть диалоговое окно Добавить или удалить оснастку из консоли, в меню Файл выберите команду Добавить или удалить оснастку.

См. также


Диалоговое окно «Настройка вида»

Чтобы просмотреть или изменить состояние элементов консоли (какой элемент скрытый, какой отображается), используйте диалоговое окно Настройка вида.

Элементы консоли MMC

Дерево консоли
Признак отображения дерева консоли. Дерево появляется в левой области консоли. Оно используется для перемещения по консоли и для просмотра иерархической структуры консоли.
Стандартные меню («Действие» и «Вид»)
Признак отображения меню Действие и Вид.
Стандартная панель инструментов
Признак отображения стандартной панели инструментов MMC.

Стандартная панель инструментов включает кнопки: для перемещения вперед, назад и вверх; для отображения и скрытия дерева консоли; для открытия справки по консоли MMC и любой добавленной оснастке.

Строка состояния
Признак отображения строки состояния в нижней части окна консоли MMC.
Строка описания
Признак отображения строки описания над панелью результатов.

Строка описания предоставляет сведения о выбранном элементе в дереве консоли.

Вкладки панели задач
Признак отображения вкладок для переходов на панели задач.
Область «Действие»
Признак отображения области Действие. Область Действие появляется как правая область консоли. На ней отображаются все доступные в данный момент действия, основанные на элементах, выбранных в дереве и в области результатов.

Элементы оснастки

Меню
Признак отображения меню любых оснасток, имеющих меню.
Панели инструментов
Признак отображения панелей инструментов любых оснасток, имеющих панели инструментов.

Примечание

  • Чтобы открыть из консоли диалоговое окно Настройка вида, щелкните Вид в области Действие, затем щелкните Настроить; или в меню Вид выберите команду Настроить.

См. также


Диалоговое окно «Экспортировать список»

Для экспорта данных из консоли оснастки в файл используйте диалоговое окно Экспортировать список.

  • Укажите папку и имя файла, как в стандартном диалоговом окне Windows Сохранение.
  • Выберите тип файла. Данные можно сохранять с разделителями — знаками табуляции или запятыми, — в виде простого текста или текста в формате Юникод.
  • Если необходимо экспортировать строки, выбранные при открытии диалогового окна Экспортировать список, установите флажок Сохранить только выбранные строки.

Примечание

  • Чтобы открыть диалоговое окно Экспортировать список из консоли оснастки, нажмите кнопку Экспортировать список в области Действие.

См. также


Диалоговое окно «Параметры» — вкладка «Консоль»

Рисунок Microsoft Windows

Диалоговое окно «Параметры», вкладка «Консоль»

Чтобы установить имя, значок и режим текущей консоли оснастки, используйте вкладку Консоль диалогового окна Параметры.

  • Чтобы присвоить консоли заголовок, введите заголовок в текстовом поле в верхней части диалогового окна. Заголовок появляется в строке заголовка консоли.
  • Чтобы заменить значок для консоли, нажмите кнопку Сменить значок, затем либо укажите имя файла значка, либо найдите значок с помощью команды обзора. Можно выбрать любой значок, который будет найден при обзоре. Например, можно найти исполняемый файл, у которого имеется связанный с ним значок, и выбрать этот значок.

    • или

  • Чтобы установить режим для консоли, выберите режим из списка Режим консоли. Чтобы подробнее ознакомиться с каким-либо режимом, щелкните его и прочитайте описание под списком.

Если выбран один из режимов пользователя, можно указать, может ли пользователь изменять виды внутри консоли и будут ли сохраняться все изменения в консоли после того, как пользователь закроет консоль.

  • Чтобы запретить пользователям сохранение изменений консоли, установите флажок Не сохранять изменения для этой консоли. Данный флажок недоступен, если выбран режим Авторский.
  • Чтобы разрешить пользователям изменять виды этой консоли, установите флажок Позволить пользователю настраивать вид консоли.

Примечание

  • Чтобы открыть из консоли диалоговое окно Параметры, в меню Файл выберите команду Параметры.

См. также


Диалоговое окно «Параметры» -- вкладка «Очистка диска»

Рисунок Microsoft Windows

Диалоговое окно «Параметры», вкладка «Очистка диска»

Чтобы удалить файлы, в которых записаны изменения, внесенные в консоли в пользовательском режиме, используйте вкладку Консоль диалогового окна Параметры.

При изменении способа отображения консолей (например, при изменении размера окна или добавлении нового окна) эти параметры настройки сохраняются в файле личной настройки. В файл личной настройки записываются все изменения, внесенные в консоли в пользовательском режиме. Изменения, внесенные в авторском режиме, сохраняются в консоли, а не в файле.

Для удаления файла личной настройки нажмите кнопку Удалить. Происходит удаление только параметров настройки, связанных с профилем данного пользователя. После этого консоли будут отображаться на экране с использованием параметров, принимаемых по умолчанию.

Данную процедуру можно использовать для восстановления параметров экрана, принимаемых по умолчанию, или для экономии места на диске.

Примечание

  • Чтобы открыть из консоли диалоговое окно Параметры, в меню Файл выберите команду Параметры.

См. также


Диалоговое окно «Выбор расширений» в консоли MMC 3.0

Чтобы добавлять расширения и удалять их из оснасток и других расширений, используйте диалоговое окно Выбор расширений.

  • Включите или отключите выбранные расширения для оснастки, выполнив следующие действия.
    1. Щелкните оснастку в списке Выбранные оснастки, затем нажмите кнопку Изменить расширения. Будет открыто диалоговое окно Расширения для имя оснастки. По умолчанию все доступные расширения включены.
    2. Чтобы выбрать конкретные расширения, установите переключатель Включать только выбранные расширения, затем выберите расширения, которые необходимо включить.

    Примечания

    • Если выбирать для включения только выбранные расширения, а другие расширения устанавливать позже, то новые расширения будут недоступны до тех пор, пока их явно не включат или пока не установят для этой оснастки переключатель Всегда включать все доступные расширения.
    • Если у оснастки отсутствуют доступные расширения, то при установке переключателя Включать только выбранные расширения список будет пуст. Однако можно установить переключатель Включать только выбранные расширения, чтобы препятствовать автоматическому включению расширений, которые могут быть установлены позже.
    • Если включенное расширение имеет расширения, можно включать или отключать их точно так же, как включаются расширения для оснастки. Щелкните расширение, затем нажмите кнопку Изменить расширения в диалоговом окне Расширения для имя оснастки. Откроется диалоговое окно Расширения для имя расширения, подобное диалоговому окну Расширения для имя оснастки.

    См. также


Свойства панели задач -- вкладка «Общие»

Рисунок Microsoft Windows

Свойства панель задач, вкладка «Общие»

Используйте вкладку Общие диалогового окна Свойства панель задач для просмотра и изменения имени, описания и характеристик отображения панели задач.

  • Чтобы изменить имя панели задач, в поле Имя введите новое имя. Имя панели задач появляется в верхней части области результатов.
  • Чтобы добавить или изменить описание панели задач, введите новые данные в поле Описание. Описание появляется под именем панели задач в верхней части области результатов.
  • Чтобы изменить стиль отображения сведений в области результатов, нажмите одну из кнопок Стиль области сведений. Выбранный вами вид отображается в виде эскизов на странице свойств, с кратким описанием преимуществ вида под ним.
  • Чтобы изменить стиль отображения описаний задач, нажмите одну из кнопок Стиль для описания заданий. Нажмите кнопку Текст для отображения описания под каждой задачей. Используйте эту возможность для помощи пользователям, которые недостаточно знакомы с задачами на панели задач. Нажмите кнопку Подсказка, чтобы скрыть текст до тех пор, пока пользователь не поместит указатель мыши на задачу. Этот вариант экономит место на панели задач.
  • Если панель задач содержит лишнюю вкладку Стандартные, установите флажок Скрыть стандартную вкладку.
  • Чтобы обеспечить больше места для сведений, выберите больший размер в списке Размер списка. Чтобы обеспечить больше места для задач, выберите меньший размер в списке Размер списка. Список Размер списка недоступен, если выбрана кнопка Без списка.
  • Чтобы указать, применим ли вид панели задач ко всем элементам дерева этого типа или только к выбранному элементу дерева, нажмите кнопку Параметры. Откроется диалоговое окно Параметры панели задач. Если указать, что этот вид панели задач применим ко всем элементам дерева этого типа, можно также сделать его видом по умолчанию для элементов дерева этого типа.

Примечание

  • Чтобы открыть окно Свойства панель задач из консоли, откройте панель задач и затем выберите Правка вида панели задач в области Действие или в меню Действие.

См. также


Свойства панели задач — вкладка «Задачи»

Рисунок Microsoft Windows

Свойства панель задач, вкладка «Задачи»

Используйте вкладку Задачи диалогового окна Свойства панель задач для просмотра, изменения, упорядочения и удаления задач в панели задач. Задачи перечислены в том порядке, в котором они отображаются в панели задач.

  • Чтобы добавить задачу, нажмите кнопку Создать и следуйте указаниям мастера по созданию новой задачи.
  • Чтобы изменить имя, описание и значок задачи, щелкните на ней в списке Отображать эти задачи и затем нажмите кнопку Изменить. Откроется диалоговое окно Изменение задачи.
  • Чтобы изменить порядок перечисления задач в панели задач, щелкните на ней в списке Отображать эти задачи и затем нажмите кнопку Вверх или Вниз.
  • Чтобы удалить задачу, щелкните на ней и нажмите кнопку Удалить.

Примечание

  • Чтобы открыть окно Свойства панель задач из консоли, откройте панель задач и затем нажмите Правка вида панели задач в области Действие или в меню Действие.

См. также


Изменение вида панели задач

Рисунок Microsoft Windows

Чтобы изменить вид панели задач

  1. Откройте сохраненную консоль оснастки в авторском режиме, выполнив одно из следующих действий.
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку ОК.
  2. В дереве консоли щелкните элемент, связанный с видом панели задач.
  3. В меню Действие выберите команду Новый вид панели задач.
  4. На вкладке Общие выполните следующие действия.
    • Чтобы изменить имя вида панели задач, в поле Имя введите новое имя. Имя появляется в левом верхнем углу вида панели задач и на вкладке в нижней части вида панели задач.
    • Чтобы изменить описание вида панели задач, в поле Описание введите новое описание. Описание отобразится под именем вида панели задач.
    • Чтобы изменить формат списка или настроить вид панели задач на хранение только задач, установите переключатель Стиль для области сведений в положение, соответствующее новому формату списка, или в положение Без списка.
    • Чтобы удалить вкладку Стандартные из вида панели задач, установите флажок Скрыть стандартную вкладку.
    • Чтобы настроить описания задач, установите переключатель Стиль для описания задачи в положение Текст или Подсказка. Текстовые описания отображаются справа от задачи. Описания подсказки «всплывают» при указании на задачу мышью.
    • Чтобы изменить размер списка, в поле Размер списка выберите новое значение ширины (Вертикальный список) или высоты (Горизонтальный список).
  5. Нажмите кнопку Параметры и выполните одно из следующих действий.
    • Чтобы применить вид панели задач только к выбранному в настоящий момент элементу дерева консоли, установите переключатель в положение К выбранному элементу дерева.
    • Чтобы применить вид панели задач ко всем элементам в дереве консоли, имеющим тот же тип, что и выбранный в настоящее время элемент дерева консоли, установите переключатель в положение Ко всем элементам, имеющим тип выбранного элемента.

      Примечания

      • Если установлен переключатель Ко всем элементам, имеющим тип выбранного элемента и требуется, чтобы появлялся вид панели задач по умолчанию, установите флажок Изменить вид по умолчанию для этих элементов дерева на данной панели задач вместо вида на вкладке Стандартные.
      • В MMC 3.0 область Действие заменяет виды панели задач. Мастер создания вида панели задач не используется для оснасток, созданных для MMC 3.0, но по-прежнему поддерживается для старых оснасток.

См. также


Изменение задач в виде панели задач

Рисунок Microsoft Windows

Чтобы изменить задачи в виде панели задач

  1. Откройте сохраненную консоль оснастки в авторском режиме, выполнив одно из следующих действий:
    • Щелкните правой кнопкой мыши файл .msc и выберите из контекстного меню Автор.
    • Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc путь\имя_файла.msc /a и нажмите кнопку ОК.
  2. В дереве консоли щелкните элемент, связанный с видом панели задач, затем в меню Действие выберите команду Правка вида панели задач.
  3. На вкладке Задачи в группе Отображать эти задачи щелкните задачу и выполните указанные ниже действия.
    • Чтобы переместить выбранную задачу вверх в списке отображения вида панели задач, нажмите кнопку Вверх.
    • Чтобы переместить выбранную задачу вниз в списке отображения вида панели задач, нажмите кнопку Вниз.
    • Чтобы удалить выбранную задачу из списка отображения вида панели задач, нажмите кнопку Удалить.
    • Нажмите кнопку Изменить и выполните одно из следующих действий.
      • Чтобы изменить имя задачи, на вкладке Общие в поле Имя задачи введите новое имя.
      • Чтобы изменить описание задачи, на вкладке Общие в поле Описание введите новое описание. В зависимости от настроек вида панели задач, описание появляется справа от задачи или всплывает при указании задачи мышью.
      • Чтобы изменить значок для задачи, на вкладке Значок задачи щелкните новый значок и нажмите кнопку OK.

См. также


Обработка ошибок оснастки

Для улучшения надежности консоль MMC 3.0 уведомляет об ошибках в оснастках, которые могут привести к ошибкам консоли MMC. При обнаружении ошибки появляется диалоговое окно, в котором идентифицируется оснастка, вызвавшая ошибку (если эта информация доступна) и выдаются варианты для реагирования на эту ошибку.

Если вызывающую ошибку оснастку можно идентифицировать, то консоль MMC предлагает несколько вариантов, из которых следует выбрать один.

  • Закрыть консоль MMC и отправить отчет об ошибках в корпорацию Майкрософт.
    Это рекомендуемый вариант. Если сразу не закрыть сеанс, обнаруженная ошибка может привести к ошибке сеанса MMC. Группы разработчиков корпорации Майкрософт тщательно рассматривают присланные с помощью этой системы сообщения об ошибках, поскольку они помогают создавать более надежное программное обеспечение.
  • Продолжить работу и до конца сеанса игнорировать ошибки этой оснастки.
    Можно выбрать этот вариант, если необходимо оставаться в этом сеансе в течение достаточно продолжительного времени, чтобы удалить оснастку, являющуюся причиной появления сообщений об ошибках, и сохранить консоль оснастки. В этом случае, возможно, придется создать консоль оснастки, содержащую только эту оснастку, с тем, чтобы, если она приведет к ошибке сеанса, это не отразилось на других оснастках.Можно также выбрать этот вариант, если необходимо закрыть консоль MMC, но не отправлять отчет об ошибках в корпорацию Майкрософт.

    Этот вариант доступен только в том случае, если консоль MMC может идентифицировать оснастку, вызывающую проблему.

  • Продолжить работу и до конца этого и всех последующих сеансов игнорировать ошибки этой оснастки.
    Выбирайте этот вариант только в том случае, если вы уверены, что ошибки, вызванные оснасткой, не окажут влияния на функции оснастки или функции консоли оснастки.

    Этот вариант доступен только в том случае, если консоль MMC может идентифицировать оснастку, вызывающую проблему.

Если вызывающую ошибку оснастку невозможно идентифицировать, консоль MMC предлагает несколько вариантов, из которых следует выбрать один.

  • Закрыть консоль MMC и отправить отчет об ошибках в корпорацию Майкрософт.
    Это рекомендуемый вариант. Если сразу не закрыть сеанс, обнаруженная ошибка может привести позже к ошибке сеанса MMC.
  • Игнорировать эту ошибку и продолжить работу.
    Выбирайте этот вариант только в том случае, если хотите закрыть консоль MMC, но не отправлять отчет об ошибках в корпорацию Майкрософт, или если хотите использовать оснастку и вас не беспокоит потеря данных этого сеанса.


Виды панели задач и задачи

В консоли MMC 3.0 область Действие заменяет виды панели задач. Мастер создания нового вида панели задач недоступен для всех оснасток, созданных для консоли MMC 3.0, но продолжает поддерживать более старые оснастки. Для этих более старых оснасток необходимы следующие сведения.

Виды панели задач представляют собой страницы, на которые могут быть добавлены виды представления области результатов консоли оснастки, а также ярлыки функций как внутри, так и вне данной консоли оснастки. Эти ярлыки можно использовать для выполнения задач, например запуска мастера, открытия страниц свойств, выполнения команд меню, запуска командных строк или открытия веб-страниц. Вид панели задач может быть настроен таким образом, чтобы он содержал все задачи, которые могут понадобиться данному пользователю. Кроме того, на консоли оснастки можно создать несколько видов панели задач, поэтому имеется возможность группировать задачи по функциям и пользователям.

Виды панели задач могут упростить выполнение работы новичкам. Например, можно добавить все подходящие задачи на вид панели задач и затем скрыть дерево панели, с тем, чтобы пользователи смогли начать использовать средство еще до того, как будет изучено расположение отдельных элементов в дереве консоли или операционной системе.

Виды панели задач позволяют упростить сложные задачи. Например, если пользователь часто выполняет задачу, для которой требуется несколько оснасток и других средств, задачи могут быть представлены в одном месте, в котором открываются или запускаются необходимые диалоговые окна, страницы свойств, командные строки и сценарии.

Дополнительные сведения о создании видов панели задач и задач см. в разделе Создание панелей задач.


Использование вкладки «Очистка диска»

Рисунок Microsoft Windows

Чтобы использовать вкладку «Очистка диска»

  1. Откройте консоль MMC.
  2. В строке меню откройте меню Консоль.
  3. Выберите команду Параметры. Откроется диалоговое окно Параметры с двумя вкладками.
  4. Щелкните вкладку Очистка диска.
  5. Для удаления файлов консолей нажмите кнопку Удалить файлы.
  6. Закройте диалоговое окно. нажав кнопку ОК.
  7. Для отмены удаления файлов, нажмите кнопку Отмена в нижней части окна.

Примечания

  • Чтобы открыть консоль управления, нажмите кнопку Пуск, выберите команду Выполнить и введите mmc, затем нажмите кнопку OK.
  • В тексте на вкладке Очистка диска сообщается, что изменения вида файла консоли сохранены в профиле пользователя. На вкладке Очистка диска также указан объем дискового пространства, отведенного под изменения консолей.


Работа с файлами консоли управления (MMC)

Консоль управления Microsoft Management Console (MMC) группирует средства, включая оснастки, которые применяются для администрирования как локальных, так и удаленных компьютеров. Система Windows может уже включать служебные программы, сохраненные как файлы консоли (с расширением .msc). Эти программы доступны в папке «Администрирование» на панели управления и в меню Программы. Кроме того, можно создавать специализированные средства администрирования и рассылать их пользователям. В Windows XP Professional и в Windows Server 2003 эти средства можно сохранить так, что они будут доступны в папке «Администрирование» в меню Программы.

  • Администрирование локальных компьютеров

    • Добавление элемента в новую консоль MMC

    1. Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc и нажмите кнопку OK.
    2. В меню Консоль выберите команду Добавить или удалить оснастку и нажмите кнопку Добавить.
    3. В списке Оснастка двойным щелчком выберите добавляемый элемент, затем выполните одно из следующих действий.
      • Установите переключатель в положение локальным компьютером (тем, на котором она выполняется) и нажмите кнопку Готово.
      • Если появится окно мастера, следуйте указаниям на экране.
    4. Чтобы добавить на консоль еще один элемент, повторите шаг 3.

    Примечания

    • Если консоль сохранена в папке «Администрирование» для пользователя (размещается по адресу: системный_диск\Documents and Settings\Все пользователи\Главное меню\Программы\Администрирование), она доступна для этого пользователя в папке «Администрирование» в меню Программы.
    • Если оснастка не появилась в списке, необходимо предварительно установить программу, устройство или службу, администрируемые этим объектом.
    • Чтобы добавить подчиненный элемент для элемента, не являющегося корнем консоли, щелкните соответствующий элемент в списке Оснастки, прежде чем на шаге 2 нажать кнопку Добавить.

    Чтобы открыть сохраненную консоль ММС.

    • Выполните одно из следующих действий.
      • Нажмите кнопку Пуск, выберите команды Настройка и Панель управления, дважды щелкните значок Администрирование, а затем дважды щелкните консоль.
      • Нажмите кнопку Пуск и выберите команды Программы, Администрирование и щелкните консоль.
      • Щелкните консоль в меню Программы.
      • Откройте папку, в которой размещена консоль, и дважды щелкните консоль.
  • Администрирование удаленных компьютеров

    • Чтобы добавить элемент на новую консоль MMC для удаленного компьютера

    1. Нажмите кнопку Пуск, выберите команду Выполнить, введите mmc и нажмите кнопку OK.
    2. В меню Консоль выберите команду Добавить или удалить оснастку и нажмите кнопку Добавить.
    3. В списке Оснастка двойным щелчком выберите добавляемый элемент, затем выполните следующие действия.
      • Установите переключатель другим компьютером, введите имя компьютера, который будет управляться оснасткой, и нажмите кнопку Готово.
      • Если появится окно мастера, следуйте указаниям на экране.
    4. Чтобы добавить на консоль еще один элемент, повторите шаг 3.

    Примечания

    • Если оснастка не появилась в списке, необходимо предварительно установить программу, устройство или службу, администрируемые оснасткой на удаленном компьютере.
    • Если диалоговое окно или мастер не появились на шаге 3, элемент консоли можно использовать только для администрирования локального компьютера.
    • Если консоль сохранена в папке «Администрирование» для пользователя (размещается по адресу: системный_диск\Documents and Settings\Все пользователи\Главное меню\Программы\Администрирование), она доступна для этого пользователя в папке «Администрирование» в меню Программы.
    • Чтобы добавить подчиненный элемент для элемента, не являющегося корнем консоли, щелкните соответствующий элемент в списке Оснастки, прежде чем на шаге 2 нажать кнопку Добавить.

    Чтобы открыть сохраненную консоль MMC для удаленного компьютера

    • Выполните одно из следующих действий.
      • Нажмите кнопку Пуск и выберите команды Программы, Администрирование и щелкните консоль.
      • Откройте папку, в которой размещена консоль, и дважды щелкните соответствующую консоль.
  • Общие процедуры

    • Чтобы открыть консоль MMC

    • Введите в командную строку команду:

      • mmc

    Чтобы установить программу, управляемую оснасткой консоли MMC

    1. Нажмите кнопку Пуск, выберите команды Настройка и Панель управления, а затем дважды щелкните значок Установка и удаление программ.
    2. Следуйте указаниям на экране.


Добавление видов панели задач и задач

Перед добавлением видов панели задач и задач на консоль оснастки определите число требуемых видов панели задач. Если требуется несколько видов панели задач, также необходимо определить разделение задач по этим видам. Кроме того, следует принять решение относительно типа используемой панели задач. Панель задач может отображать список и задачи или только задачи.

Чтобы создать вид панели задач для консоли оснастки, консоль должна содержать по крайней мере одну оснастку. Для настройки заголовков и списков, появляющихся в виде панели задач, и для определения одного или нескольких элементов в дереве консоли, с которыми связывается панель задач, используется мастер создания вида панели задач.

После завершения работы мастера создания вида панели задач для добавления задач к виду панели задач используется мастер создания задачи. Задачи могут включать команды меню для элементов консоли и команды, запускаемые из командной строки. Можно создать команды, действующие как часть дерева консоли или области сведений или открывающие другой компонент на компьютере. Однако если задача создана из команды меню для элемента в дереве консоли, а элемент удален, задача отключается.

Примечание

  • В MMC 3.0 область Действие заменяет виды панели задач. Мастер создания вида панели задач не используется для оснасток, созданных для MMC 3.0, но по-прежнему поддерживается для старых оснасток.

Сведения о создании и редактировании видов панели задач и задач см. в разделе Чтобы создать вид панели задач, Чтобы создать задачи для вида панели задач, Чтобы изменить вид панели задач и Чтобы изменить задачи в виде панели задач .


Создание и использование списка «Избранное»

Список «Избранное» используется для создания ярлыков элементов дерева консоли и видов панели задач. Эти значки затем доступны в меню Избранное.

Дополнительные сведения о создании списка «Избранное» см. в разделе Создание и упорядочение списка «Избранное» в консоли оснастки.


Интерактивная поддержка
и информация
  • Загрузка обновлений, новых возможностей и драйверов с веб-узла Windows Update (http://windowsupdate.microsoft.com)
  • Службы технической поддержки корпорации Майкрософт (http://support.microsoft.com)
  • Веб-узел Microsoft Accessibility (http://www.microsoft.com/enable)