Общие сведения о средстве «Дистанционное управление рабочим столом»

При помощи средства «Дистанционное управление рабочим столом» в Windows XP Professional можно получить доступ к сеансу Windows на своем компьютере, находясь при этом за другим компьютером. Например, при помощи средства «Дистанционное управление рабочим столом» можно подключиться к рабочему компьютеру из дома и получить доступ ко всем файлам, приложениям и сетевым ресурсам так же, как и при работе на рабочем компьютере. Можно оставить программы выполняющимися на рабочем компьютере и дома продолжить работу с теми же программами, окна которых будут отображаться на экране домашнего компьютера.

При подключении к рабочему компьютеру с помощью программы «Дистанционное управление рабочим столом» выполняется блокировка компьютера, чтобы другие пользователи не могли получить доступ к приложениям и файлам. Отменить блокировку рабочего компьютера для продолжения работы на нем можно при помощи сочетания клавиш CTRL+ALT+DEL.

При помощи средства «Дистанционное управление рабочим столом» несколько пользователей могут одновременно проводить активные сеансы работы на одном и том же компьютере. Это означает, что разные пользователи могут оставлять свои приложения запущенными и сохранять состояния своих сеансов Windows, в то время как другие пользователи также находятся в системе.

Средство «Быстрое переключение пользователей» позволяет легко переключать пользователей на одном и том же компьютере. Допустим, при работе на домашнем компьютере необходимо войти в систему рабочего компьютера, чтобы обновить отчет о затратах. В это время одному из членов семьи необходимо проверить важное сообщение электронной почты. Можно отключить программу «Дистанционное управление рабочим столом», чтобы другой пользователь вошел в систему и проверил электронную почту, а затем снова подключиться к рабочему компьютеру, на экране которого отчет о затратах будет отображен в неизменном виде. Средство быстрого переключения пользователей доступно на отдельных компьютерах и компьютерах, являющихся членами рабочей группы.

При помощи средства «Дистанционное управление рабочим столом» возможно выполнение нескольких сценариев.

  • Работа дома — доступ к рабочему компьютеру с домашнего компьютера, включая полный доступ к локальным и удаленным устройствам.
  • Совместная работа — отображение рабочего стола своего компьютера на экране компьютера сотрудника, например для отладки программы, обновления презентации слайдов в программе Microsoft PowerPoint или для корректуры документа.
  • Общий доступ к консоли — поддержка на одном компьютере сеансов нескольких пользователей с разными приложениями и параметрами (например, для продавцов или банковских служащих).

Для работы с программой «Дистанционное управление рабочим столом» требуются:

  • компьютер, работающий под управлением Windows XP Professional («удаленный» компьютер) с локальным сетевым подключением или Интернетом;
  • второй компьютер («локальный» компьютер) с доступом к локальному сетевому подключению через сетевое соединение, модем или виртуальную частную сеть (VPN). На этом компьютере необходимо установить подключение удаленного рабочего стола, ранее известное как клиент службы терминалов;
  • соответствующие учетные записи пользователей и разрешения.


Советы и рекомендации по обеспечению безопасности

  • Рекомендуется добавить себя в группу группу «Пользователи удаленного рабочего стола». Выполнив это действие, нет необходимости входить в систему с учетной записью администратора при удаленном доступе к компьютеру. Не следует добавлять себя в группу «Администраторы». Рекомендуется работать на компьютере с учетной записью администратора только при выполнении задач, для которых требуются привилегии администратора. Для наилучшей работы входите в систему с учетной записью члена группы «Пользователи» и «Опытные пользователи». Если необходимо выполнить какое-либо действие, доступное только для администраторов, войдите в систему как администратор, выполните необходимые действия, а затем завершите сеанс. Для дополнительных сведений см. Почему не следует работать на компьютере с учетной записью администратора.
  • Всем пользователям удаленного рабочего стола рекомендуется входить в систему, используя надежный пароль. Это особенно важно, если компьютер подключен к Интернету с помощью кабельного модема или подключение DSL. Дополнительные сведения см. в разделе Создание надежных паролей.


Различия между средством «Дистанционное управление рабочим столом» и средством «Удаленный помощник»

Средства «Дистанционное управление рабочим столом» и «Удаленный помощник» используют одинаковую рабочую технологию, однако в их работе есть различия.

При помощи средства «Дистанционное управление рабочим столом» можно получить доступ к сеансу Windows на своем компьютере, находясь при этом за другим компьютером. Например, при помощи средства «Дистанционное управление рабочим столом» можно подключиться к рабочему компьютеру из дома и получить доступ ко всем файлам, приложениям и сетевым ресурсам так же, как и при работе на рабочем компьютере.

Используя средство «Удаленный помощник», можно получить содействие, например, друга имеющего подключение к Интернету для доступа к вашему компьютеру и могущего предоставить свою помощь. Пользователь, оказывающий помощь, может просматривать на своем компьютере все, что происходит на экране вашего компьютера и использовать окно разговора для передачи советов. При наличии соответствующего разрешения помощник может использовать удаленное управление компьютером для устранения возникших затруднений.


Настройка компьютера на использование дистанционного управления рабочим столом

Рисунок Microsoft Windows

Чтобы настроить компьютер на использование дистанционного управления рабочим столом

  1. Щелкните значок Система на панели управления.
  2. На вкладке Удаленное использование установите флажок Разрешить удаленное подключение к этому компьютеру и нажмите кнопку ОК.
  3. Убедитесь в наличии необходимых разрешений на удаленное подключение к данному компьютеру и нажмите кнопку ОК. Необходимо быть администратором компьютера или членом группы «Пользователи удаленного рабочего стола» на этом компьютере. Дополнительные сведения см. в разделе Чтобы разрешить подключение других пользователей к компьютеру.

Примечания

  • Для включения средства «Дистанционное управление рабочим столом» необходимо войти в систему с учетной записью администратора или быть участником группы «Администраторы».
  • XOX

См. также


Настройка домашнего компьютера на использование дистанционного управления рабочим столом

Чтобы настроить домашний компьютер на использование дистанционного управления рабочим столом

На рабочем компьютере

  1. Напечатайте эту страницу и выполните следующие инструкции на домашнем компьютере. Установив курсор в любое место текста, щелкните правой кнопкой мыши и в контекстном меню выберите команду Печать.
  2. Убедитесь в наличии необходимого разрешения на использование дистанционного подключения к рабочему столу. Для этого необходимо быть администратором или участником группы «Пользователи удаленного рабочего стола». В случае неуверенности в наличии необходимого разрешения следует обратиться к администратору.
  3. Необходимо знать имя рабочего компьютера.
  4. Необходимо оставить рабочий компьютер включенным.

Примечание

  • Чтобы определить сетевое имя компьютера, откройте окно Система с панели управления. На вкладке Имя компьютера найдите запись Полное имя компьютера. Имя вашего компьютера находится в этой текстовой строке слева от первой точки.

На домашнем компьютере

В Windows XP

  1. Подключитесь к сети организации при помощи локального сетевого подключения (LAN), модема или подключения к виртуальной частной сети (VPN).
  2. XOX
  3. Введите имя удаленного компьютера, к которому требуется подключиться, и нажмите кнопку Подключить.

В операционной системе, отличной от Windows XP

  1. Войдите в систему поставщика услуг Интернета (ISP).
  2. Получите необходимое клиентское программного обеспечение. (http://www.microsoft.com/downloads)
  3. Установите клиентское программное обеспечение на домашнем компьютере.
  4. XOX
  5. Введите имя удаленного компьютера, к которому требуется подключиться, и нажмите кнопку Подключить.

См. также


Получение клиентского программного обеспечения

Чтобы получить клиентское программное обеспечение

Чтобы настроить второй компьютер («локальный» компьютер) для дистанционного управления рабочим столом, необходимы следующие условия.
  • Доступ к удаленному компьютеру (на котором запущена Windows XP Professional) при помощи локального сетевого подключения (LAN), модема или подключения к виртуальной частной сети (VPN).
  • Установленная на компьютере программа «Дистанционное подключение к удаленному компьютеру» или клиент службы терминалов. В следующей таблице представлены инструкции по установке клиентского программного обеспечения в зависимости от операционной системы.
Операционная система | Версия клиента | Получение доступа
Windows XP Home Edition и Windows XP Professional | Установленное по умолчанию Подключение к удаленному рабочему столу (необходимо включить) | Пуск/Программы/Стандартные/Связь/Подключение к удаленному рабочему столу
Windows 2000 Server | Клиент служб терминалов (32-разрядный) установлен по умолчанию | Пуск/Программы/Клиент служб терминалов
Windows 95 & Windows 98 | Не установлено | См. раздел Чтобы установить программу «Дистанционное управление рабочим столом» (32-разрядные компьютеры)
Windows NT 4.0 | Не установлено | См. раздел Чтобы установить программу «Дистанционное управление рабочим столом» (32-разрядные компьютеры)
Windows NT 3.51 | Не установлено | См. раздел Чтобы установить клиент служб терминалов (компьютеры Windows NT 3.51)
Windows для рабочих групп | Не установлено | См. раздел Чтобы установить клиент служб терминалов (16-разрядные компьютеры)
Windows CE | Не установлено | Щелкните ссылку Веб-узел Microsoft Download Center (http://www.microsoft.com/) и следуйте инструкциям, чтобы установить клиент Windows CE.

См. также


Установка программы «Дистанционное управление рабочим столом» (32-разрядные компьютеры)

Чтобы установить программу «Дистанционное управление рабочим столом» (32-разрядные компьютеры)

  1. На компьютере, на котором установлена операционная система Windows 95, Windows 98, Windows NT 4.0 или Windows 2000, вставьте в дисковод установочный компакт-диск Windows XP Professional.
  2. При появлении на экране страницы приветствия выберите ссылку Выполнение иных задач, а затем выберите вариант Установка удаленного управления рабочим столом.
  3. Следуйте инструкциям на экране.


Установка клиента служб терминалов (16-разрядные компьютеры)

Чтобы установить клиент служб терминалов (16-разрядные компьютеры)

  1. На компьютере, работающем под управлением Windows 2000 Server, предоставьте общий доступ к папке установки клиента.
  2. На компьютере под управлением Windows для рабочих групп подключитесь к локальному сетевому подключению, в котором имеется компьютер, работающий под управлением Windows 2000 Server.
  3. Подключитесь к общей папке Tsclient.
  4. В папке Tsclient\Win16 дважды щелкните файл Setup.exe.
  5. Следуйте инструкциям, появляющимся на экране.

Примечание

  • Чтобы определить сетевое имя компьютера, откройте объект Система на панели управления. На вкладке Имя компьютера найдите запись Полное имя компьютера. Имя компьютера находится в этой текстовой строке слева от первой точки.

См. также


Установка клиента служб терминалов (компьютеры Windows NT 3.51)

Чтобы установить клиент служб терминалов (компьютеры Windows NT 3.51)

  1. На компьютерах, на которых установлена операционная система Windows 2000 Sever, включите совместное использование папки установки клиента.
  2. На компьютере под управлением Windows NT 3.51 подключитесь к локальному сетевому подключению, в котором имеется компьютер, работающий под управлением Windows 2000 Server.
  3. Подключитесь к общей папке Tsclient.
  4. В папке Tsclient\Win32\Acme351 дважды щелкните файл Setup.exe.
  5. Следуйте инструкциям, появляющимся на экране.

Примечание

  • Чтобы определить сетевое имя компьютера, работающего под управлением Windows 2000 Server, откройте объект Система на панели управления. На вкладке Имя компьютера найдите запись Полное имя компьютера. Имя компьютера находится в этой текстовой строке слева от первой точки.

См. также


Использование подключения к удаленному рабочему столу

В данном разделе собраны сведения о приложении «Интернет-подключение к удаленному рабочему столу». Веб-приложение «Интернет-подключение к удаленному рабочему столу» состоит из элемента ActiveX и образцов страниц подключения. При настройке программы «Интернет-подключение к удаленному рабочему столу» на веб-сервере для подключения клиента к серверам терминалов и другим компьютерам можно использовать обозреватель Internet Explorer и протокол TCP/IP.

В данном разделе собраны общие сведения о настройке приложения «Интернет-подключение к удаленному рабочему столу».

  • Общие сведения о подключении к удаленному рабочему столу
  • Настройка подключения к удаленному рабочему столу
  • Установка подключения к удаленному рабочему столу
  • Подключение к другому компьютеру с помощью подключения к удаленному рабочему столу


Общие сведения о подключении к удаленному рабочему столу

Веб-приложение «Интернет-подключение к удаленному рабочему столу» состоит из элемента ActiveX, образцов страниц ASP и других файлов. При установке на веб-сервере приложения «Интернет-подключение к удаленному рабочему столу» пользователи получают возможность создавать подключение к удаленному рабочему столу другого компьютера в Internet Explorer, даже если программа «Подключение к удаленному рабочему столу», ранее известная как клиент сервера терминалов, не установлена на компьютерах пользователей.

При использовании приложения «Интернет-подключение к удаленному рабочему столу» доступны следующие возможности.

  • Простая непосредственная передача клиентской части приложений «Сервер терминал» и «Дистанционное управление рабочим столом». При помощи приложения «Интернет-подключение к удаленному рабочему столу» передача подключения терминального сервера может осуществляться так же просто, как и отправка адреса URL.
  • Поддержка перемещаемых пользователей. Пользователи, находящиеся вдалеке от своего компьютера, могут использовать приложение «Интернет-подключение к удаленному рабочему столу» для получения безопасного доступа к основной рабочей станции или нужному терминальному серверу с компьютеров, на которых установлена операционная система Windows и программа Internet Explorer.
  • Универсальная межплатформенная система. При помощи программы «Интернет-подключение к удаленному рабочему столу» организации могут использовать идентичные клиенты на всех платформах.
  • Передача внешних приложений. Организации, которым необходимо передать сервер терминалов или подключение к удаленному рабочему столу поставщикам, заказчикам или производителям, могут использовать приложение «Интернет-подключение к удаленному рабочему столу», чтобы просто, недорого и эффективно отправить приложения через Интернет.

Сведения об использовании веб-подключения к удаленному рабочему столу см. в разделе Чтобы подключиться к другому компьютеру с помощью приложения «Интернет-подключение к удаленному рабочему столу».


Настройка подключения к удаленному рабочему столу

Служба подключения к удаленному рабочему столу является компонентом веб-службы IIS, включенному по умолчанию в Windows XP Professional и Windows 2000. Приложение «Интернет-подключение к удаленному рабочему столу» не устанавливается по умолчанию. Установка этого приложения выполняется при помощи компонента Установка и удаление программ.

При установке приложения «Интернет-подключение к удаленному рабочему столу» файлы копируются по умолчанию в каталог %systemroot%\Web\Tsweb веб-сервера. Включенные примеры страниц default.htm и connect.asp могут быть использованы в неизменном виде или их можно изменить в соответствии с требованиями для приложения.

Со стороны клиента для программы «Интернет-подключение к удаленному рабочему столу» требуется подключение компьютера к Интернету с использованием протокола TCP/IP, а также программа Microsoft Internet Explorer 4.0 или более поздней версии.

Дополнительные сведения см. в следующих разделах.

  • Чтобы установить подключение к удаленному рабочему столу
  • Чтобы подключиться к другому компьютеру с помощью подключения к удаленному рабочему столу

Сведения по настройке программы «Интернет-подключение к удаленному рабочему столу» доступны в пакете Microsoft Platform SDK.


Установка подключения к удаленному рабочему столу

Чтобы установить подключение к удаленному рабочему столу

  1. На панели управления откройте компонент Установка и удаление программ.
  2. Нажмите кнопку Установка компонентов Windows.
  3. Выберите компонент Internet Information Services (IIS) и нажмите кнопку Состав.
  4. В списке Internet Information Services - состав выберите элемент Служба WWW и нажмите кнопку Состав.
  5. В списке Служба WWW - состав установите флажок Интернет-подключение к удаленному рабочему столу и нажмите кнопку ОК.
  6. В окне мастера компонентов Windows нажмите кнопку Далее.
  7. Откройте диспетчер служб Интернета.
  8. Разверните структуру папок до папки имя_локального_компьютера\Веб-узлы\Веб-узел по умолчанию\tsweb.
  9. Щелкните папку tsweb правой кнопкой мыши и выберите команду Свойства.
  10. Выберите вкладку Безопасность каталога в диалоговом окне Свойства.
  11. В группе Анонимный доступ и проверка подлинности нажмите кнопку Изменить.
  12. В диалоговом окне Способы проверки подлинности установите флажок Анонимный доступ и дважды нажмите кнопку ОК.

Примечания

  • XOX
  • Служба IIS не установлена по умолчанию в Windows XP Professional.
  • Для выполнения этой процедуры необходимо войти в систему с учетной записью администратора. Если компьютер подключен к сети, параметры сетевой политики могут запретить выполнение данной процедуры.
  • XOX

  • Сведения об использовании Интернет-подключения к удаленному рабочему столу см. в разделе Подключение к другому компьютеру с помощью подключения к удаленному рабочему столу.

См. также


Подключение к другому компьютеру с помощью подключения к удаленному рабочему столу

Чтобы подключиться к другому компьютеру с помощью подключения к удаленному рабочему столу

  1. Убедитесь, что программа «Интернет-подключение к удаленному рабочему столу» установлена и запущена на веб-сервере. Дополнительные сведения см. в разделе Настройка подключения к удаленному рабочему столу.
  2. Убедитесь, что клиентский компьютер имеет активное подключение к сети и работает служба сервера WINS (или другой метод определения имен).
  3. На клиентском компьютере запустите программу Microsoft Internet Explorer.

  4. В поле Адрес введите URL-адрес основного каталога веб-сервера, на котором размещена программа «Интернет-подключение к удаленному рабочему столу».

    Адрес URL — это запись «http://», после которой следует сетевое имя сервера Windows и путь к папке, содержащей файлы службы Интернет-подключения к удаленному рабочему столу (по умолчанию используется папка /Tsweb/). (Имейте в виду, что нужно использовать знак прямой косой черты.) Например, если веб-сервер зарегистрирован вместе с сервером WINS как «Admin1», в поле Адрес введите http://admin1/homepage.htm и нажмите клавишу ВВОД. На экран будет выведена страница «Интернет-подключение к удаленному рабочему столу».

  5. В поле Сервер введите имя удаленного компьютера, к которому требуется подключиться.
  6. При необходимости укажите размер экрана и сведения входа для подключения.
  7. Нажмите кнопку Подключить.

Примечания

  • Для работы с программой «Интернет-подключение к удаленному рабочему столу» необходима программа Internet Explorer 4.0 или более поздней версии.


Отключение средства «Дистанционное управление рабочим столом»

Чтобы отключить средство «Дистанционное управление рабочим столом»

  1. Откройте компонент Система на панели управления.
  2. На вкладке Удаленное использование снимите флажок Разрешить удаленное подключение к этому компьютеру и нажмите кнопку ОК.

Примечания

  • Для отключения средства «Дистанционное управление рабочим столом» необходимо войти в систему с учетной записью администратора.
  • XOX


Подключение других пользователей к компьютеру

Чтобы разрешить подключение других пользователей к компьютеру

  1. Щелкните значок Система на панели управления.
  2. Выберите вкладку Удаленное использование.
  3. В области Дистанционное управление рабочим столом нажмите кнопку Выбрать удаленных пользователей.
  4. В диалоговом окне Пользователи удаленного рабочего стола нажмите кнопку Добавить.
  5. В диалоговом окне Выбор: пользователи нажмите кнопку Размещение, чтобы указать область поиска.
  6. Нажмите кнопку Типы объектов, чтобы указать типы объектов, поиск которых требуется выполнить.
  7. В поле Введите имена выбираемых объектов (примеры): введите имена объектов, которые требуется найти.
  8. Нажмите кнопку Проверить имена.
  9. Найдя имя, нажмите кнопку ОК. Теперь имя появится в списке пользователей в диалоговом окне Пользователи удаленного рабочего стола.

Примечания

  • XOX
  • Необходимо иметь учетную запись администратора компьютера или входить в группу «Администраторы», чтобы добавлять пользователя в группу удаленных пользователей.

См. также


Изменение значка ярлыка файла подключения.

Чтобы изменить значок ярлыка файла подключения

  1. Создайте файл подключения (файл .rdp) или используйте существующий файл .rdp.
  2. Откройте проводник Windows и создайте ярлык для файла .rdp.
  3. Щелкните ярлык правой кнопкой мыши, выберите команду Свойства и нажмите кнопку Изменить значок.
  4. Выберите значок в списке в диалоговом окне Изменение значка и нажмите кнопку ОК.
  5. Нажмите кнопку OK, чтобы закрыть диалоговое окно Свойства ярлыка.
  6. Предоставьте файл .rdp и ярлык соответствующим пользователям.

Примечания

  • Необходимо также предоставить файл значка (.ico), если он недоступен на компьютерах пользователей.
  • Файлы .rdp по умолчанию сохраняются как скрытые файлы в папке Мои документы.

См. также


Устранение неполадок

  • Устранение общих ошибок
  • Устранение ошибок лицензирования
  • Устранение конкретных неполадок


Совместное использование папки установки клиента

Чтобы совместно использовать папку установки клиента

  1. На компьютерах, на которых установлена операционная система Windows 2000 Sever, откройте проводник Windows.
  2. Перейдите к папке %Системный_корневой_каталог%\System32\Clients\Tsclient, где Системный_корневой_каталог является папкой, содержащей файлы установки Windows, например C:\Windows\System32\Clients\Tsclient.
  3. Щелкните папку правой кнопкой мыши и выберите пункт Доступ.
  4. Установите флажок Открыть общий доступ к этой папке, нажмите кнопку Применить и кнопку ОК.

    Будет отображено имя общего ресурса Tsclient. Имя можно изменить путем ввода нового имени в поле Общий ресурс. Предельное число пользователей можно изменить, установив переключатель в положение не более и выбрав число из списка.

Примечания

  • Чтобы открыть проводник в Windows 2000 Server, нажмите копку Пуск, выберите пункт Программы, Стандартные, а затем выберите программу Проводник.
  • Для того чтобы сделать диск или папку доступными для совместного использования, надо войти в систему в качестве опытного пользователя, оператора сервера или члена группы администраторов.

См. также