Component Services Administration Help

Справка по администрированию служб компонентов

Программа администрирования служб компонентов предназначена для настройки и администрирования компонентов COM и приложений COM+. В данном документе содержатся общие сведения и основные процедуры, которые можно использовать для выполнения часто встречающихся административных задач. Обычно эти задачи включают в себя установку и настройку приложений COM+, настройку безопасности на уровне приложения и создание и поддержку разделов COM+.

Программа администрирования служб компонентов создана как для системных администраторов, так и для разработчиков приложений. Например, разработчики могут воспользоваться данной программой для настройки обычных характеристик компонентов и приложений, таких как участие в транзакциях и группирование объектов. Подробные сведения и стандартные процедуры по выполнению задач, которые разработчики могут решать с помощью программы администрирования служб компонентов, а также справочные сведения об административных объектах COM+ и программных интерфейсах содержатся в главе «COM+ (Component Services)» SDK платформы. Если комплект SDK платформы не установлен, обратитесь на веб-узел MSDN для его просмотра или установки.

Сведения о последних усовершенствованиях в работе программы администрирования служб компонентов см. в разделе Новые возможности служб компонентов.

Обзор разделов и задач, собранных в данном руководстве, см. в разделе Работа со справкой по администрированию служб компонентов.

Важная информация по безопасности приведена в разделе Администрирование надежных вычислений.


What's New in Component Services

Новые возможности служб компонентов

В этом выпуске программы администрирования служб компонентов предлагаются новые возможности и изменения существующих возможностей, которые сделаны для увеличения общей масштабируемости, доступности, безопасности и управляемости приложений COM+ как для разработчиков, так и для системных администраторов. Чтобы новые возможности можно было проще настроить и развернуть, соответствующие разделы справки программы администрирования служб компонентов обновлены, а также добавлены дополнительные разделы и новые ссылки в документацию SDK платформы.

Новая система безопасности (D)COM

В пакет обновления 2 (SP2) для Windows XP включена новая система безопасности для приложений (D)COM. Эта новая система безопасности облегчает возможность сокращения доступа несанкционированных пользователей к приложениям COM.

Кроме ранее доступных разрешений на доступ и запуск для приложений COM в новой системе безопасности есть отдельное разрешение на активацию. Пользователи, у которых есть разрешение на активацию, но нет разрешения на запуск приложения COM, могут создать клиентский прокси для приложения, только если это приложение уже выполняется на сервере. Для использования этого прокси также требуется разрешение на доступ, так что всем пользователям с разрешением на активацию надо дать разрешение на доступ.

Разрешения на доступ, запуск и активацию теперь делятся на отдельные разрешения локальных и удаленных доступа, запуска и активации. Пользователи с локальным разрешением для приложения COM могут выполнить разрешенное действие только на локальном компьютере (компьютере, на котором выполняется это приложение). Для выполнения действия с другого компьютера по сети у ползователя должно быть разрешение на удаленный доступ.

В новую систему безопасности также входит новая политика огораничений на уровне компьютера. Эта политика ограничивает разрешения, которые могут быть даны любым способом (включая использование API CoInitializeSecurity). Например, можно запретить удаленный доступ к любому приложению COM, отменив разрешения на удаленные доступ, запуск и активацию в политике ограничений на уровне компьютера.

В следующей таблице представлена политика ограничения на уровне компьютера по умолчанию.

Разрешение | Администраторы | Все | Анонимное
Доступ | Локальные, удаленные | Локальные, удаленные | Локальные
Активация | Локальные, удаленные | Локальные | Нет разрешений
Запуск | Локальные, удаленные | Локальные | Нет разрешений

Обратите внимание на то, что у анонимных пользователей нет удаленных разрешений, а у пользователей, не являющихся администраторами, нет разрешений на удаленный запуск или активацию. Эти параметры по умолчанию могут вызвать разрыв в существующих сценариях. Дополнительные сведения см. на странице DCOM в MSDN.

Дополнительные сведения о новой системе безопасности COM, включая инструкции по установке разрешений, см. в разделе Разрешения на доступ и Разрешения на запуск и активацию.

Средства, измененные с предыдущего выпуска

Ниже приведены краткие описания средств для расширения программы администрирования служб компонентов, которые появились в предыдущем выпуске.

Группирование приложений

Новая служба группирования приложений COM+ добавляет масштабируемость процессов с одним потоком и интегрирована с новой службой повторного запуска приложений COM+. Более подробные сведения содержатся в разделе Группирование приложений COM+.

Повторный запуск приложений

Со временем быстродействие приложения уменьшается, поскольку могут возникать проблемы, связанные с нехваткой памяти, использованием немасштабируемых ресурсов и ошибками процесса. Закрытие и повторный автоматический запуск приложения COM+ обеспечивает повторную инициализацию процесса и повторное выделение используемой памяти. Подробные сведения и пошаговые инструкции по настройке повторного запуска приложений COM+ см. в разделе Администрирование повторного запуска приложения.

Разделы COM+

В данном выпуске вводится поддержка разделов COM+. Эта функция позволяет одновременно установить на один компьютер несколько версий одного приложения COM+. Она поможет снизить затраты, вызванные необходимостью использовать несколько серверов для управления различными конфигурациями приложения. Например, можно создать конфигурации приложения COM+ для тестирования и для разработки. Подробные сведения и пошаговые инструкции по созданию и управлению разделами COM+ см. в разделе Администрирование разделов COM+.

Служба SOAP в COM+

Новая служба SOAP в COM+ позволяет клиентам получать доступ к настроенным компонентам COM на сервере сети с помощью XML и простого протокола доступа к объектам (SOAP). Служба SOAP COM+ позволяет легко развертывать приложения COM+ в сети в виде веб-служб XML без потери централизованного управления. Дополнительные сведения см. в разделе Администрирование службы SOAP COM+.

Активизация при небольшом объеме памяти

В данном выпуске до создания сервера или объекта COM+ происходит автоматическая проверка памяти. Если объем доступной для приложения виртуальной памяти меньше определенного порогового значения, то до создания объекта активизация не выполняется. После неудачного выполнения активизации средство активизации при небольшом объеме памяти значительно увеличит надежность системы. Дополнительные сведения об этой возможности см. в разделе Активизация при небольшом объеме памяти.

Приостановка и отключение приложений

Приложения COM+ стали более управляемыми. Администратор может приостанавливать и возобновлять работу серверных приложений COM+, а также отключать и включать серверные и библиотечные приложения COM+ или даже отдельно настроенные компоненты. Повторная активизация приостановленных или отключенных приложений окажет влияние на существующие компоненты. Дополнительные сведения см. в разделе Администрирование операций приложений COM+.

Образ процесса

В реальной среде очень непросто устранить неполадки, связанные с приложениями. Часто бывает необходимо собрать сведения о неполадке не прерывая выполняемого процесса. В данном выпуске существует новая возможность сохранения образа процесса. Эта возможность позволяет системному администратору сохранить общее состояние процесса не прерывая его. Подробные сведения см. в разделе Программа администрирования образа процесса.


Roadmap for Using Component Services Administration Help

Работа со справкой по администрированию служб компонентов

В разделах, описанных в следующей таблице, можно найти основные понятия администрирования и задачи, содержащиеся в данном руководстве.

Раздел | Описание
Руководство по администрированию служб компонентов | Основные понятия администрирования, общие сведения о категориях для группировки административных задач, описание объектов, содержащихся в дереве консоли служб компонентов.
Настройка системы для служб компонентов | Описание задач, которые необходимо выполнить после установки служб компонентов, но перед использованием программы администрирования служб компонентов в сети.
Установка приложений COM+ | Основные сведения по установке клиентских и серверных приложений COM+.
Администрирование операций приложений COM+ | Основные понятия и процедуры, связанные с завершением и запуском, отключением и включением, приостановкой и возобновлением работы приложений COM+.
Администрирование группирования приложений | Основные принципы и процедуры, относящиеся к группированию приложений COM+, функциональная возможность COM+, обеспечивающая масштабируемость процессов с одним потоком и упрощающая восстановление при сбоях потоков с одним процессом за счет обработки активизаций другими выполняющимися процессами.
Администрирование повторного запуска приложений | Общие сведения и процедуры, связанные с повторным запуском приложений COM+. Это средство COM+ позволяет автоматически завершить и заново запустить приложение, повышая стабильность работы и быстродействие системы.
Администрирование безопасности приложений | Обзор администрирования безопасности служб компонентов, а также ссылки на более подробные сведения об установке атрибутов для обеспечения безопасности.
Администрирование разделов COM+ | Обзор разделов COM+, изложение основных принципов и процедур, связанных с созданием и управлением разделами как на локальном компьютере, так и в домене.
Администрирование службы SOAP COM+ | Изложение принципов и описание процедур, относящихся к службе SOAP в COM+, которая обеспечивает удаленный доступ к функциям компонентов через протокол SOAP.
Администрирование распределенных транзакций | Введение в администрирование распределенных транзакций, содержащее ссылки на разделы основных понятий и задач по настройке системы для использования DTC, просмотра статистики транзакций и обработки состояния транзакций.
Программа администрирования образа процесса | Основные понятия и процедуры, связанные с программой сохранения образа процесса, которая используется для отладки приложений COM+.
Администрирование очередей компонентов | Основные сведения и процедуры, связанные со службой очередей компонентов COM+, с помощью которой осуществляется запрос служб из серверного приложения COM+ клиентским приложением даже в том случае, если серверное приложение недоступно или отключено.
Словарь COM+ | Определения важнейших терминов и функциональных возможностей COM+.


Administering Trustworthy Computing

Администрирование надежных вычислений

Разработчики, администраторы и потребители все больше зависят от глобальной связи, что вызывает рост требований к безопасности, поэтому корпорация Майкрософт предприняла инициативу «Надежность вычислений». Команды разработчиков продукции Майкрософт, взявшие на себя эту инициативу, обязуются справиться с ее задачами и предоставить пользователям максимально безопасную вычислительную среду. Во исполнение этого обязательства данная версия программы администрирования служб компонентов позволяет задавать политику программных ограничений для приложений COM+, а также предоставляет возможность легко настраивать безопасность на основе ролей для разделов и приложений COM+.

Однако надежность вычислений невозможно обеспечить исключительно программными средствами. Необходимо, чтобы разработчики и администраторы осознавали и предвидели потенциальную уязвимость своих систем и приложений. Хотя требования для конкретной вычислительной среды могут предполагать особые меры предосторожности, ниже приводится список полезных общих принципов и правил обеспечения максимальной безопасности:

  • Предоставляйте физический доступ к компьютерам, особенно к контроллерам доменов, только заслуживающим доверия служащим.

  • Придерживайтесь принципа минимальности полномочий, предоставляя только те полномочия, которые требуются для выполнения данной конкретной задачи.

  • Определите группы и их участников, а также назначьте уровни доступа по умолчанию в соответствии с определенными для них ролями.

  • Для защиты данных на компьютерах обязательно используйте списки контроля доступа.

  • Повсеместно внутри своей организации используйте пароли.

  • Загружайте и запускайте только такие программы, которые получены из заслуживающих доверия источников.

  • Используйте самые современные антивирусные программы.

  • Устанавливайте все последние исправления, устраняющие уязвимые места в защите.

Для ознакомления с дополнительной информацией о реализации этих принципов в среде сервера Microsoft® Windows® Server 2003, а также с обзором средств и новых функций безопасности нажмите кнопку Пуск, выберите пункт Справка и поддержка и затем Безопасность.

Более подробные сведения об использовании служб безопасности COM+ см. в разделе Администрирование безопасности приложения.


Guide to Administering Component Services

Руководство по администрированию служб компонентов

Существуют два способа развертывания и администрирования приложений COM+. Можно использовать либо программу администрирования служб компонентов, либо создать сценарии для автоматизации этих процедур. Данное руководство описывает процесс администрирования компьютеров, а также процесс настройки и администрирования компонентов и приложений COM+ с помощью программы администрирования служб компонентов.

Примечание. В дополнение к программе администрирования служб компонентов можно написать специальные программы для автоматизации административных задач. Доступ к административным объектам в этих программах осуществляется с помощью библиотеки динамической компоновки COMAdmin. Сведения об использовании таких объектов приведены в комплекте Microsoft Platform SDK (см. документ «Component Services», раздел «COM+ General Tasks», подраздел «Automating COM+ Administration»).

Разделы данной главы описаны в следующей таблице. В ней также содержится обзор основных понятий и задач, которые необходимы для использования программы администрирования служб компонентов.

Раздел | Описание
Типы приложений служб компонентов | Основные понятия, необходимые для понимания ролей и типов приложений COM+.
Обзор административных задач служб компонентов | Сведения о категориях для группировки административных задач служб компонентов.
Дерево консоли служб компонентов | В этом разделе описываются категории элементов, которые отображаются в дереве консоли служб компонентов.


Component Services Application Types

Типы приложений служб компонентов

Большинство задач администрирования служб компонентов включают доведение результатов разработки до практического использования в сети, а также обеспечение высокой производительности и безопасности развернутых приложений и компонентов. Конкретные задачи, которые приходится решать в этой области администрирования, зависят от типа приложения, с которым работает пользователь, и служб, используемых данным приложением. В этом разделе представлен обзор типов приложений и используемых ими служб.

Примечание. Следует учитывать, что в данном руководстве по администрированию служб компонентов описана лишь часть параметров, которые могут быть заданы с помощью программы администрирования служб компонентов. Настройка параметров, не описанных в данном руководстве, должна выполняться только специалистами, в совершенстве знающими особенности реализации компонентов и приложений. Обычно настройки, описанные в главе «COM+ (Component Services)» SDK платформы, производятся разработчиком до установки и развертывания приложения.

Приложения, администрируемые с помощью программы администрирования служб компонентов, можно условно разделить на две категории: приложения COM и приложения COM+. Эти термины используются в данном руководстве в тех случаях, когда параметры настройки могут изменяться в зависимости от типа приложения.

Приложения COM

Идея приложения COM не является чем-то новым — это просто обозначение группы компонентов COM, созданных для совместной работы. Примером приложения COM может служить Microsoft® Excel, поскольку это приложение состоит из основного исполняемого файла и дополнительных динамических библиотек расширения приложения. Эти библиотеки обеспечивают проверку орфографии, использование возможностей языка Microsoft Visual Basic® и т.д.

Приложения COM+

С другой стороны, приложения COM+ представляют собой группы компонентов COM, разработанных и совместно настроенных с целью использования таких возможностей служб компонентов, как управление очередями, обеспечение безопасности на основе ролей и т. д. Поэтому в данном руководстве этим приложениям уделяется больше внимания, чем приложениям COM. Некоторые особенности приложения COM+ реализуются при создании компонентов на программном уровне, а другие определяются с помощью программы администрирования служб компонентов.

Кроме того, приложения COM+ можно разделить на два типа, отличающиеся по требованиям, предъявляемым к администрированию. Это так называемые серверные приложения COM+ и библиотечные приложения COM+. Серверные приложения выполняются в своем собственном пространстве процессов. Такое приложение может состоять, например, из группы динамических библиотек, обеспечивающих обработку паролей. Библиотечные приложения состоят из компонентов, предназначенных для работы в рамках процесса другого исполнителя. В библиотечном приложении можно объединить, например, те динамические библиотеки, которые обеспечивают работу других компонентов приложений и при этом могут использовать настройки безопасности этих компонентов.


Component Services Administrative Tasks Overview

Обзор административных задач служб компонентов

Административные задачи, которые выполняются с помощью программы администрирования служб компонентов, можно разделить на четыре категории:

  • настройка системы для служб компонентов;

  • начальная настройка служб;

  • установка и настройка приложений COM+;

  • наблюдение за работой и настройка служб компонентов.

    Примечание. В данном разделе описаны только обязательные и общие задачи, которыми отнюдь не исчерпывается перечень возможных задач. Для более полного представления о предмете следует ознакомиться с документацией по тем областям, для которых выполняется администрирование.

Настройка системы для служб компонентов

Перед началом работы со службами COM+ необходимо выполнить настройку для дальнейшей работы этих служб в сети. Например, следует начать с установки параметров доступа к базовому приложению, управление которым должно осуществляться с помощью настроек и задач, выполняемых в программе администрирования служб компонентов. Дополнительные сведения об этих задачах содержатся в разделе Настройка системы для служб компонентов.

Начальная настройка служб

После предварительной настройки конфигурации служб компонентов в соответствии с особенностями сети, возможно, потребуется изменить параметры настройки в соответствии с теми приложениями и службами, которые будут использоваться в сети.

Ниже приведены примеры типов настройки компьютеров в сети.

  • Ряд компонентов могут оказаться не включенными в приложения COM+. Такими компонентами являются компоненты COM, развернутые независимо, или приложения COM. Для обеспечения безопасности этих компонентов может потребоваться настройка отдельных параметров безопасности COM на соответствующих компьютерах. (С другой стороны, при создании приложений COM+ доступны все преимущества модели безопасности на основе ролей.) Дополнительные сведения см. в разделе Настройка безопасности COM.

  • Если приложения будут использовать распределенные транзакции, следует указать способ запуска DTC (вручную или автоматически) для каждого компьютера, где будет работать это приложение. Кроме того, в случае использования транзакций в системе кластеров Windows необходимо соответствующим образом настроить сеть. Для получения дополнительных сведений см. раздел Администрирование распределенных транзакций.

Установка и настройка приложений COM+

Прежде чем приступить к работе с приложением COM+, его необходимо настроить в соответствии с параметрами тех служб, которые будут использоваться этим приложением. Затем следует установить клиентскую и серверную части приложения на компьютеры в сети. Перед установкой приложения COM+ можно, если требуется, создать разделы COM+.

Ниже представлены примеры задач, возникающих при установке и настройке приложений COM+.

  • Прежде чем приступить к настройке параметров, определяющих работу приложения COM+ в сети, следует установить это приложение на отладочный компьютер, где и будет осуществляться настройка. Дополнительные сведения см. в разделе Отладочные и реальные компьютеры.

  • Необходимо обеспечить правильное использование приложением схемы безопасности данной сети, иными словами, доступ к приложению и доступ самого приложения к другим ресурсам должен осуществляться надлежащим образом. Для этого, возможно, придется добавить пользователей к ролям этого приложения и задать удостоверение безопасности для приложения. Дополнительные сведения см. в разделе Администрирование безопасности приложений.

  • После настройки приложения COM+ в соответствии с требованиями безопасности и используемыми им службами, необходимо установить клиентскую и серверную части приложения на реальные компьютеры в сети. Перед установкой приложения COM+ можно, если требуется, создать разделы COM+. Дополнительные сведения см. в разделе Установка приложений COM+.

Наблюдение за работой и настройка служб компонентов

После развертывания компонентов, использующих службы компонентов, с помощью наблюдения за этими службами можно определить пути повышения производительности, а также обрабатывать сбои. В некоторых случаях изменение этих параметров — особенно введение более тщательного контроля — может снизить производительность. Обязательно прочитайте документацию по выполнению конкретной настройки.

Ниже представлены примеры задач, возникающих при наблюдении за компонентами и приложениями.

  • При появлении новой версии приложения COM+ обновление версии осуществляется путем удаления старой версии и установки новой. Дополнительные сведения см. в разделе Установка приложений COM+.

  • Для повышения контроля безопасности можно использовать процедуру отслеживания ссылок, которая позволяет выполнять дополнительные проверки безопасности и вести расширенный учет сведений с целью предохранения объектов от слишком раннего освобождения, совершенного случайно или злонамеренно. Дополнительные сведения см. в разделе Отслеживание ссылок.

  • Если приложения участвуют в распределенных транзакциях, контроль производительности осуществляется путем просмотра состояния, сообщений и статистики по транзакциям. Кроме того, повышение производительности системы возможно путем изменения размера или местоположения файла журнала, в котором хранится статистика по транзакциям. Дополнительные сведения см. в разделах Наблюдение за производительностью DTC и Настройка файла журнала DTC.


Component Services Console Tree

Дерево консоли служб компонентов

Дерево консоли программы администрирования служб компонентов позволяет просматривать приложения, компоненты и роли безопасности, доступные для администрирования. В данном разделе описаны основные папки, подпапки и значки, которые отображаются в дереве консоли.

Папки и подпапки

Ниже приведены основные папки и подпапки, которые отображаются в дереве консоли программы администрирования служб компонентов.

Компьютеры

Эта папка содержит значок Мой компьютер и значки других компьютеров, добавленные администратором.

Мой компьютер

По умолчанию значок Мой компьютер соответствует локальному компьютеру, на котором установлена программа администрирования служб компонентов.

Разделы COM+

Эта папка содержит разделы COM+, в которые установлены приложения COM+.

Примечание. Папка Разделы COM+ отображается в дереве консоли только в том случае, если на вкладке Параметры страницы свойств окна Мой компьютер установлен флажок Включить разделы.

Базовый раздел приложения

Эта папка является подкаталогом папки Разделы COM+. Она содержит общие для всей системы компоненты приложения COM+, которые должны быть доступны всем пользователям в домене. Она присутствует всегда, когда включены разделы COM+.

Приложения COM+

Эта папка содержит приложения COM+, установленные на данном компьютере. Для изменения свойств приложения щелкните правой кнопкой мыши на требуемом приложении и выберите в контекстном меню пункт Свойства. Дополнительные сведения по установке приложений см. в разделе Установка приложений COM+.

Компоненты

Эта папка содержит настроенные компоненты, установленные в приложении COM+. Для изменения свойств компонента щелкните правой кнопкой мыши на требуемом компоненте и выберите в контекстном меню пункт Свойства.

Устаревшие компоненты

Эта папка содержит ненастроенные компоненты, установленные в приложении COM+. Для изменения свойств устаревшего компонента щелкните правой кнопкой мыши на требуемом компоненте и выберите в контекстном меню пункт Свойства. Можно повысить роль устаревшего компонента до уровня настроенного компонента, щелкнув на компоненте правой кнопкой мыши и выбрав в контекстном меню пункт Свойства.

Интерфейсы

Эта папка содержит интерфейсы, доступные в компоненте. Для изменения свойств интерфейса щелкните правой кнопкой мыши на требуемом интерфейсе и выберите в контекстном меню пункт Свойства.

Подписка

Эта папка содержит доступные в компоненте подписки. Можно изменить свойства подписки, щелкнув на ней правой кнопкой мыши и выбрав в контекстном меню пункт Свойства.

Методы

Эта папка содержит методы, доступные из интерфейсов компонентов. Для изменения свойств метода щелкните правой кнопкой мыши на требуемом методе и выберите в контекстном меню пункт Свойства.

Роли

Эта папка содержит роли, доступные для данного приложения COM+. Для изменения свойств роли щелкните правой кнопкой мыши на требуемой роли и выберите в контекстном меню пункт Свойства.

Пользователи

Эта папка содержит список пользователей, которым назначена данная роль.

Пользователи раздела COM+

Эта папка содержит список пользователей раздела COM+. Можно изменить раздел по умолчанию, назначенный этим пользователям, щелкнув правой кнопкой мыши на пользователе и выбрав пункт Свойства в контекстном меню.

Примечание. Папка Пользователи разделов COM+ отображается в дереве консоли только в том случае, если на вкладке Параметры страницы свойств окна Мой компьютер установлен флажок Включить разделы.

Настройка DCOM

С помощью данной папки можно просматривать и изменять настройки отдельных приложений COM. Например, если необходимо усилить безопасность приложения COM, чтобы оно правильно запускалось при вызове приложением COM+, можно изменить настройки безопасности приложения COM в папке Настройка DCOM, не изменяя настройки безопасности компьютера в целом.

Координатор распределенных транзакций

В этой папке в окне Список транзакций отображается список текущих транзакций, в которых участвует данный компьютер, а в окне Статистика транзакций отображается статистика транзакций со сведениями об этих транзакциях. Более подробно о координаторе распределенных транзакций см. в разделе Администрирование распределенных транзакций.

Список транзакций

В этой подпапке отображаются текущие транзакции, в которых принимает участие данный компьютер. В этот список входят транзакции, состояние которых находится под сомнением или сохраняется без изменений в течение времени ожидания транзакций, указанного на вкладке Параметры окна свойств компьютера.

Статистика транзакций

В данной подпапке отображаются сведения о транзакциях, такие как производительность, тип, скорость, а также максимальное и минимальное время отклика для тех транзакций, в которых участвует компьютер.

Выполняемые процессы

В этой папке отображаются все текущие процессы приложения COM+.

Значки

Ниже приведены различные значки, которые отображаются в дереве консоли программы администрирования служб компонентов.

Значки COM+ | Описание
Программы администрирования |
 | Программа администрирования служб компонентов
Приложения |
 | Библиотечное приложение COM+
 | Отключенное библиотечное приложение COM+
 | Серверное приложение COM+
 | Отключенное серверное приложение COM+
 | Приложение службы COM+
 | Отключенное приложение службы COM+
 | Прокси для приложения COM+
Компоненты |
 | Компонент COM+
 | Отключенный компонент COM+
 | 64-разрядный компонент COM+
 | Отключенный 64-разрядный компонент COM+
Процессы |
 | Выполняющийся процесс
 | Повторный запуск процесса
 | Приостановленный процесс
Транзакции |
 | Список текущих транзакций
 | Набор данных о текущих и итоговых транзакциях.
Прочее |
 | Раздел COM+
 | Интерфейс COM+
 | Метод COM+
 | Пользователь COM+
 | Роль безопасности COM+, назначенная пользователю
 | Подписка COM+


Configuring the System for Component Services

Настройка системы для служб компонентов

После установки Microsoft Windows необходимо настроить данную систему для служб компонентов. Настройка включает в себя предоставление администратору прав управления системным приложением. Кроме того, необходимо настроить службы компонентов на работу в конкретной сети, а именно включить компьютеры в список служб компонентов и обеспечить взаимодействие компонентов на разных компьютерах за счет настройки протокола DCOM. Данные задачи настройки являются крайне важными для правильного управления службами компонентов.

Вводные сведения

В зависимости от требований конкретной системы может понадобиться более детальная настройка, чем описано в разделах данного документа. Настройка перечисленных ниже свойств допускается и позднее, однако важно с самого начала ознакомиться с возможным кругом задач.

  • Для работы с программой администрирования служб компонентов необходимо настроить и запустить службу координатора распределенных транзакций (DTC). Дополнительные сведения см. в разделе Администрирование распределенных транзакций.

  • В целях повышения масштабируемости системы возможно выполнение настройки служб компонентов, предусматривающей завершение неиспользуемых процессов приложения. Более подробные сведения см. в разделе Настройка завершения серверного процесса.
Раздел | Описание
Основные понятия по настройке системы | Список задач по настройке системы, а также ссылки на пошаговые инструкции.
Задачи по настройке системы | Ссылки на пошаговые инструкции.


System Configuration Concepts

Основные понятия по настройке системы

В данном разделе содержатся сведения о типичных задачах по настройке системы, которые необходимо выполнить после установки Windows для правильной работы программы администрирования служб компонентов. Более подробные сведения о выполнении каждой задачи см. в разделе Задачи по настройке системы.

Примечание. Программа администрирования служб компонентов требует наличия выполняемой службы координатора распределенных транзакций Microsoft (DTC). Если служба DTC остановлена, то при попытке изменения любых настроек с помощью программы администрирования служб компонентов произойдет перезапуск службы DTC. Если при попытке использования программы администрирования служб компонентов возникают ошибки, проверьте, что служба DTC запущена, и в случае необходимости перезапустите ее. Более подробные сведения о запуске и остановке службы DTC см. в разделе Запуск и остановка службы DTC.

Настройка управления системным приложением

Системное приложение, которое находится в папке "Приложения COM+" программы администрирования служб компонентов, управляет функциями настройки и развертывания для служб компонентов. Чтобы ограничить доступ к этому важному приложению, необходимо определить круг пользователей, которым разрешено администрирование среды приложений. Это разрешение необходимо для внесения любых изменений в настройку служб компонентов, включая установку приложения или добавление компьютера.

Для этого системного приложения используется модель безопасности на основе ролей, в которой определены, например, такие роли как "Администратор", "Читатель", "Серверное приложение", "Любое приложение" и "Доверенный пользователь очередей компонентов". Пользователи с ролью "Администратор" имеют доступ к этому системному приложению на чтение и запись. Им разрешено добавлять, изменять и удалять любые настройки с помощью программы администрирования служб компонентов. Только пользователи с ролью "Администратор" могут устанавливать в систему приложения COM+. По умолчанию единственным участником с этой ролью является локальная группа "Администраторы". Только пользователям из локальной группы "Администраторы" может назначаться роль "Администратор".

Предупреждение. Необходимо назначить роль "Администратор" по крайней мере одному пользователю или группе, иначе никто не сможет администрировать службы компонентов.

Пользователям с ролью "Читатель" предоставлен доступ к системному приложению только на чтение. Им разрешено просматривать настройки с помощью программы администрирования служб компонентов, но запрещено добавлять, изменять и удалять что-либо. По умолчанию все пользователи имеют эту роль, т.е. все, кто имеет доступ к данному компьютеру, могут просматривать параметры настройки служб компонентов.

Примечание. По соображениям безопасности нежелательно предоставлять возможность любым лицам просматривать параметры настройки служб компонентов. В этом случае следует удалить пользователя "Все" из списка роли "Читатель" и назначить эту роль только тем пользователям, которым требуется разрешить доступ на чтение к параметрам настройки служб компонентов. Чтобы изменения вступили в силу, следует перезагрузить компьютер.

Участникам роли "Серверное приложение" разрешено запускать серверные приложения COM+, а членам роли "Любое приложение" разрешено запускать как серверные приложения COM+, так и библиотечные приложения COM+. По умолчанию группе "Все" назначены все роли.

Участники группы "Доверительный пользователь очередей компонентов" могут передавать сообщения для компонентов в очереди от лица других пользователей. По умолчанию эта роль не назначена ни одному пользователю.

Примечание. Участники с ролью "Доверительный пользователь очередей компонентов" имеют право присваивать произвольные идентификаторы, т.е. недобросовестный участник может выполнять вызовы компонентов в очереди с повышенными полномочиями. Поэтому рекомендуется сократить, насколько возможно, число таких пользователей. Более подробные сведения по вопросам настройки безопасности при использовании очередей компонентов COM+ см. в разделе Администрирование очередей компонентов.

Инструкции по настройке административной безопасности для системного приложения см. в разделе Настройка административной безопасности. Более подробные сведения о безопасности см. в разделах Администрирование безопасности приложений и Администрирование надежных вычислений.

Включение компьютеров в список служб компонентов

Все компьютеры, администрирование которых требуется выполнять с помощью служб компонентов, следует добавить в дерево консоли программы администрирования служб компонентов. В противном случае для данных компьютеров невозможно задать уровень безопасности или установить на них приложение. Инструкции по добавлению компьютеров приведены в разделе Включение компьютеров в список служб компонентов.

Настройка протокола DCOM

Протокол DCOM (Distributed COM) полностью обслуживает сетевое взаимодействие между компонентами COM, выполняемыми на разных компьютерах. Протокол DCOM необходимо включить на каждом компьютере, где выполняются компоненты COM, взаимодействующие с другими компонентами по сети. Отключение DCOM не влияет на взаимодействие компонентов, выполняемых на одном компьютере, но любое взаимодействие между компонентами на разных компьютерах будет прекращено. Инструкции по включению обмена данными между компонентами на разных компьютерах приведены в разделе Включение и отключение протокола DCOM.


System Configuration Tasks

Задачи по настройке системы

В следующих разделах данной главы содержатся подробные сведения о выполнении необходимых задач по исходной настройке системы.

  • Настройка административной безопасности

  • Включение компьютеров в список служб компонентов

  • Включение и отключение протокола DCOM

Общие сведения об этих задачах см. в разделе Основные принципы настройки системы.


Setting Administrative Security

Настройка административной безопасности

Системное приложение, расположенное в дереве консоли программы администрирования служб компонентов в папке "Приложения COM+", управляет операциями настройки и развертывания для служб компонентов. По умолчанию системное приложение использует для вызовов уровень проверки подлинности "Секретность пакетов", обеспечивающий максимальную степень защиты.

Примечание. По соображениям безопасности рекомендуется сохранить для системных приложений уровень проверки подлинности по умолчанию - "Секретность пакетов".

Чтобы изменения в системе, например, установка приложений COM+ или добавление компьютера, производились надлежащим образом, следует настроить безопасность и определить, кому разрешается администрировать среду. Приведенная ниже процедура обеспечивает включение безопасности для системного приложения путем определения участников с ролью "Администратор". Только членам группы "Администраторы" на компьютере может назначаться роль "Администратор" для системного приложения.

Предупреждение. Чтобы включить безопасность системного приложения, требуется назначить роль "Администратор" по крайней мере одному пользователю или группе. Если это не сделано, то никто не может администрировать службу компонентов.

Примечание. Пользователи с ролью "Администратор" для системного приложения должны быть участниками локальной группы "Администраторы".

Назначение пользователю роли "Администратор" для системного приложения

  1. В дереве консоли программы администрирования служб компонентов разверните значок Приложения COM+.

  2. Разверните значок Системное приложение.

  3. Разверните значок Роли.

  4. Разверните значок Администратор.

  5. Щелкните на папке Пользователи правой кнопкой мыши и выберите команду Пользователь в меню Создать.

  6. Укажите в нижней области окна Выбор пользователей и групп полное имя группы, которую требуется добавить. Если имя неизвестно, поступите следующим образом:
    1. В окне Выбор пользователей и групп нажмите кнопку Размещение.

    2. В открывшемся окне Размещение выберите требуемый домен и нажмите кнопку ОК, чтобы закрыть окно Размещение.

    3. В окне Выбор пользователей, компьютеров и групп нажмите кнопку Дополнительно.

    4. В открывшемся окне Выбор пользователей, компьютеров и групп нажмите кнопку Поиск для просмотра списка пользователей и групп в выбранном домене.

    5. Выберите пользователя или группу в списке Имя (RDN), а затем нажмите кнопку OK.
  7. Для добавления других групп и учетных записей пользователей повторите шаги 5 и 6.

  8. Перезагрузите компьютер, чтобы изменения вступили в силу.

Сведения об отзыве у пользователей или групп роли "Администратор" для системного приложения см. в разделе Удаление учетной записи пользователя или группы из роли.


Making Computers Visible to Component Services

Включение компьютеров в список служб компонентов

При наличии необходимых прав на удаленном компьютере пользователь может управлять приложениями COM+ и отслеживать транзакции на нем из программы администрирования служб компонентов, выполняемой на собственном компьютере.

Для добавления удаленного компьютера в иерархию программы администрирования служб компонентов выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на значке Компьютеры, выберите в контекстном меню пункт Создать и выполните команду Компьютер.

  2. В диалоговом окне Добавление компьютера введите имя добавляемого компьютера. Если имя неизвестно, поступите следующим образом:
    1. Нажмите кнопку Обзор, затем в окне Выбор компьютера нажмите кнопку Дополнительно.

    2. Для ограничения поиска заполните соответствующие поля на вкладке Общие запросы, а затем нажмите кнопку Поиск, чтобы просмотреть список компьютеров, которые соответствуют указанным критериям.

    3. Выберите компьютер из списка Имя (RDN) и нажмите кнопку ОК для возврата в диалоговое окно Добавление компьютера.
  3. Нажмите кнопку ОК.

После добавления компьютера в дерево консоли его значок появляется в области данных. Теперь с помощью программы администрирования служб компонентов можно управлять объектами на удаленном компьютере точно так же, как и на локальном компьютере.

Кроме того, можно удалить удаленный компьютер из иерархии программы администрирования служб компонентов.

Для удаления удаленного компьютера из иерархии программы администрирования служб компонентов выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов выберите значок Компьютеры.

  2. В области данных выделите один или несколько компьютеров, подлежащих удалению.

  3. Нажмите клавишу Delete или щелкните правой кнопкой мыши на значке компьютера, который требуется удалить, и выберите команду Удалить.


Enabling or Disabling Distributed COM

Включение и отключение протокола DCOM

Если компьютер, на котором выполняются службы компонентов, работает в сети, для взаимодействия компонентов COM на разных компьютерах требуется протокол DCOM. В системах с операционной системой Windows по умолчанию на компьютерах включен протокол DCOM. Если отключить протокол DCOM, взаимодействие с компонентами на других компьютерах будет нарушено.

Предупреждение. Если отключить протокол DCOM на удаленном компьютере, то в дальнейшем снова включить DCOM на этом компьютере через удаленный доступ будет невозможно. Для повторного включения протокола DCOM требуется прямой доступ к этому компьютеру.

Для включения или отключения протокола DCOM выполните следующие действия.

  1. В папке Компьютеры дерева консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на значке компьютера, на котором требуется отключить или включить протокол DCOM, и выберите в контекстном меню пункт Свойства.

  2. Перейдите на вкладку Свойства по умолчанию.

  3. Для включения протокола DCOM установите флажок Разрешить использование DCOM на этом компьютере, а для отключения протокола DCOM — отмените выбор данного флажка.

  4. Нажмите кнопку ОК.


Administering COM+ Applications

Администрирование приложений COM+

COM+ расширяет компонентную модель, упрощая добавление полезных функций к настраиваемому компоненту. Дополнительные функции включают обеспечение безопасности на основе ролей, управление очередями, повторное выполнение процесса и доступ через SOAP.


Installing COM+ Applications

Установка приложений COM+

Многие задачи, которые приходится решать системным администраторам, связаны с установкой серверных приложений на отладочных и реальных компьютерах, с установкой прокси для приложений на компьютерах клиентов, а также с удалением или обновлением приложений. Программа администрирования служб компонентов позволяет выполнять большую часть этой работы. Кроме того, выполнение всех этих задач можно автоматизировать при помощи сервера сценариев Microsoft® Windows®.

Вводные сведения

Установка приложения COM+ обычно включает в себя операции с компонентами и готовыми приложениями COM+ на отладочном компьютере, используемом для разработки и проверки данного приложения. Дополнительные сведения об отладочных компьютерах см. в разделе Отладочные и реальные компьютеры.

Перед началом установки обычно выполняется программа администрирования служб компонентов (на отладочном компьютере), чтобы настроить характеристики безопасности, в том числе задать удостоверения и назначить пользователей на роли. Для получения дополнительных сведений см. раздел Администрирование безопасности приложений.

Кроме того, следует настроить завершение серверного процесса таким образом, чтобы процесс завершался через определенное время бездействия.

Наконец, можно создать разделы COM+, в которые будет производиться установка приложений COM+. Разделы COM+ позволяют установить на один компьютер несколько конфигураций приложения COM+. Дополнительные сведения см. в разделе Администрирование разделов COM+.

В разделах, описанных в следующей таблице, приведены сведения, связанные с установкой приложений COM+. Общие сведения о приложениях COM+ см. в разделе Руководство по администрированию служб компонентов.

Раздел | Описание
Основные понятия установки | Базовые сведения об установке приложений COM+.
Задачи установки | Ссылки на описание задач, связанных с установкой приложений COM+.


Installation Concepts

Основные понятия установки

Для установки приложений с помощью программы администрирования служб компонентов требуются определенные разрешения системы безопасности. Сведения о настройке безопасности при установке приложений COM+ см. в разделе Настройка административной безопасности.

Помимо безопасности, есть и другие задачи по настройке конфигурации, которые должны быть решены до установки приложений COM+ с помощью программы администрирования служб компонентов. Более подробно о настройке среды служб компонентов см. в разделе Обзор административных задач служб компонентов.

В разделах, описанных в следующей таблице, содержатся общие сведения по вопросам установки приложений COM+.

Раздел | Описание
Отладочные и реальные компьютеры | Общие сведения об использовании одних компьютеров для разработки и проверки и других компьютеров для окончательного развертывания приложения.
Обзор установки приложений COM+ | Обзор сценариев установки, а также ссылки на пошаговые инструкции.
Установка серверной части приложений COM+ | Краткий обзор вопросов, связанных с установкой серверных компонентов, которые требуют установки других ресурсов, таких как подключения к базам данных.
Установка клиентской части приложений COM+ | Обзор вопросов, связанных с установкой клиентской части компонентов.


Staging and Production Computers

Отладочные и реальные компьютеры

Установку и отладку приложений рекомендуется выполнять в отладочной среде, что обеспечивает моделирование сценариев событий, которые могут произойти после развертывания этих приложений на реальных компьютерах, используемых другими пользователями в сети.

Отладочная среда может также использоваться для управления версиями приложения и обновления компонентов. Вместо изменения настроек и обновления отдельных компонентов сразу на реальном компьютере измененное приложение сначала будет протестировано в отладочной среде, а затем экспортировано целиком для установки на реальный компьютер.

Используя разделы COM+, можно настроить отладочную и рабочую среду на одном и том же компьютере. Для получения дополнительных сведений см. раздел Администрирование разделов COM+.

Иногда настройка отладочной и рабочей среды идентична, и единственным отличием является отсутствие общего доступа к отладочной среде. В последнем случае можно дублировать приложения и перенести проверенный набор приложений вместе с настройками с отладочного на реальный компьютер. Дополнительные сведений о репликации см. в разделе Репликация приложений COM+.


COM+ Application Installation Overview

Обзор установки приложений COM+

Приложения COM+ могут быть развернуты внутри компании, когда разработчик приложения хорошо знает конечную среду размещения (учетные записи пользователей и групп, имена серверов и т.д.). В этом случае разработчик заранее настраивает и экспортирует приложение, так что администратору остается только установить приложение на конечные компьютеры.

Кроме того, приложения COM+ могут быть приобретены у сторонних поставщиков. Если поставщик не предоставляет обычную программу установки, помогающую выполнить требуемые действия, то необходимо установить и настроить приложение COM+ самостоятельно.

Настройка приложения COM+ часто выполняется на отладочном, а не на реальном компьютере. При использовании отладочного компьютера необходимо экспортировать настроенное приложение COM+ и прокси для приложения COM+ с отладочного компьютера и установить их на реальные компьютеры. Для получения дополнительных сведений см. раздел Отладочные и реальные компьютеры.

Установка приложения COM+ вручную подразделяется на следующие этапы. В зависимости от варианта поставки приложения разработчиком или поставщиком некоторые шаги могут оказаться необязательными. Дополнительные сведения содержатся в документации по приложению.

  1. На отладочном компьютере выполните настройку приложения COM+ на конкретную конечную среду.

  2. Экспортируйте файлы установки клиентской и серверной частей приложения с отладочного компьютера

  3. Установите приложение COM+ или прокси для приложения COM+ на реальный компьютер.

Подробные пошаговые инструкции по установке приложений см. в разделе Задачи установки.

Общие сведения о настройке приложений COM+ см. в разделе Обзор административных задач служб компонентов.

Обновление версий приложений COM+

Когда приложения COM+ устаревают или выходят из употребления, может потребоваться их удаление или обновление. Для обновления приложения COM+ необходимо сначала удалить его предыдущую установленную версию, а затем установить обновленное приложение.

Пошаговые инструкции см. в разделах Удаление приложений COM+ и Установка приложений COM+.


Server-Side Installation for COM+ Applications

Установка серверной части приложений COM+

Все необходимые сведения о серверной части приложения COM+ содержатся в файле серверного приложения (.msi). Для установки приложения COM+ из файла .msi можно воспользоваться программой администрирования служб компонентов или приложением Windows Installer.

Для предотвращения несанкционированных изменений экспортируемых приложений следует хранить файлы серверных приложений только в тех каталогах, к которым ограничен доступ с правами на запись. Для повышения безопасности снабдите свои файлы серверного приложения подписью с помощью Microsoft® Authenticode®.

Если для какого-либо компонента приложения COM+ необходимо установить или изменить конфигурацию других ресурсов — подключений к базам данных, файлов данных и текстовых файлов, конфигурации виртуального корневого каталога Internet Information Services (IIS) и т. п. — то эти ресурсы должны быть установлены без помощи программы администрирования служб компонентов.

Подробные пошаговые инструкции по установке приложений см. в разделе Установка серверных приложений COM+.


Client-Side Installation for COM+ Applications

Установка клиентской части приложений COM+

После установки на компьютере серверного приложения COM+ может потребоваться организация удаленного доступа к этому приложению посредством DCOM или очередей сообщений.

При необходимости удаленного доступа к приложению следует выполнить экспорт прокси для приложения COM+ при помощи программы администрирования служб компонентов. Файл прокси для приложения (.msi) содержит сведения о регистрации. Эти сведения необходимы для удаленного доступа к классам в серверном приложении COM+, когда этот доступ осуществляется на компьютере клиента через DCOM. Затем с помощью этого файла и программы администрирования служб компонентов выполняется установка прокси для приложения COM+ на компьютеры клиентов данного узла.

Существует возможность создания прокси для приложения, осуществляющего доступ к другому серверу, а не к компьютеру, с которого выполнен экспорт. Подобное решение полезно, когда с отладочного компьютера требуется экспортировать прокси для приложения на реальном компьютере. Для изменения имени сервера перейдите на вкладку Параметры страницы свойств компьютера в программе администрирования служб компонентов и введите соответствующее имя удаленного сервера (RSN) прокси для приложения.

Пошаговые инструкции для экспорта и установки прокси для приложений см. в разделах Экспорт прокси для приложения COM+ и Установка прокси для приложений COM+.


Installation Tasks

Задачи установки

В данном разделе перечислены возможные задачи по установке приложений COM+. Эти задачи следует решать в том порядке, как они описаны.

  • Создание нового приложения COM+

  • Экспорт серверных приложений COM+

  • Установка серверных приложений COM+

  • Экспорт прокси для приложений COM+

  • Установка прокси для приложений COM+

  • Удаление приложений COM+

  • Репликация приложений COM+


Creating a New COM+ Application

Создание нового приложения COM+

Программа администрирования служб компонентов может использоваться для создания новых пустых приложений COM+. Исполнитель этой процедуры должен быть участником роли "Администратор" по отношению к системному приложению на конечном компьютере. В используемой по умолчанию конфигурации эта роль назначается только администраторам локальных компьютеров. Более подробно см. раздел Настройка административной безопасности.

Важное замечание. Серверное приложение COM+ можно установить только на компьютер, который работает под управлением Microsoft® Windows® 2000 или более поздних версий. Серверному приложению требуется платформа, поддерживающая службы компонентов.

Минимальной конфигурацией приложения считается конфигурация, не требующая обеспечения безопасности. При необходимости обеспечения безопасности приложения воспользуйтесь программой администрирования служб компонентов и установите безопасность на уровне процесса или добавьте пользователей к готовым ролям после создания приложения. Дополнительные сведения о настройке безопасности для приложения см. в разделе Администрирование безопасности приложения.

Примечание. Чтобы сетевые пользователи могли запускать приложение COM+ без аутентификации, в списки участников ролей приложения необходимо включить "Анонимного" пользователя. На сервере Windows Server 2003 по умолчанию "Анонимный" пользователь не входит в группу "Все".

Для создания нового приложения COM+ с помощью программы администрирования служб компонентов выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов в папке Службы компонентов откройте папку Приложения COM+ компьютера, на который требуется установить данное приложение.

    Примечание. Если включена функция разделов COM+, папку Приложения COM+ можно найти в папке Разделы COM+ того компьютера, на который будет установлено приложение. Дополнительные сведения о службе разделов COM+ и инструкции по включению этой службы в системе см. в разделе Администрирование разделов COM+.

  2. Щелкните правой кнопкой мыши на папке Приложения COM+ и выберите команду Приложение в меню Создать.

  3. В окне Мастера установки приложения COM+ нажмите кнопку Далее.

  4. В диалоговом окне Установка или создание нового приложения выберите параметр Создать пустое приложение.

  5. В диалоговом окне Создание пустого приложения введите имя нового приложения и укажите, должны ли компоненты приложения при их вызове активизироваться в вызывающем процессе (Библиотечное приложение) или в отдельном серверном процессе (Серверное приложение). Нажмите кнопку Далее.

  6. В диалоговом окне Удостоверение приложения укажите удостоверение приложения и нажмите кнопку Далее.

    Примечание. По умолчанию используется запись Взаимодействующий пользователь. Взаимодействующий пользователь — это пользователь, вошедший в систему на исполняющем приложение компьютере с помощью учетной записи Windows. Можно выбрать другого пользователя. Для этого выберите параметр Указанный пользователь и введите сведения о конкретном пользователе или группе Windows.

  7. В диалоговом окне Добавление ролей приложения укажите все роли, которые требуется создать для этого приложения. По умолчанию создается одна роль с именем CreatorOwner. Нажмите кнопку Далее.

  8. В диалоговом окне Назначение ролей пользователям добавьте требуемых пользователей к созданным ролям. По умолчанию роль CreatorOwner назначается Вашей учетной записи. Нажмите кнопку Далее.

  9. Нажмите кнопку Готово.

В структуре дерева консоли в области данных отображается новое приложение.


Exporting COM+ Server Applications

Экспорт серверных приложений COM+

Программа администрирования служб компонентов может использоваться для экспорта серверного приложения COM+ с целью его установки на одном или нескольких компьютерах-серверах. Программа администрирования служб компонентов позволяет, например, скопировать приложение COM+ с отладочного компьютера, где это приложение было разработано и проверено, на реальный компьютер в отдельном узле.

Примечание. Блокировки, предусмотренные в приложении для предотвращения изменений и удалений, экспортируются вместе с приложением.

Важное замечание. Серверное приложение COM+ можно установить только на компьютер, который работает под управлением Microsoft® Windows® 2000 или более поздних версий. Серверному приложению требуется платформа, поддерживающая службы компонентов. Поэтому при установке приложения COM+ на компьютер, который работает под управлением Microsoft Windows NT®, Microsoft Windows 98 или Microsoft Windows 95, необходимо экспортировать приложение как прокси для приложения, а не как серверное приложение. Дополнительные сведения см. в разделе Экспорт прокси для приложений COM+.

Для экспорта серверного приложения COM+ выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните на значке приложения COM+, которое требуется экспортировать.

  2. Щелкните правой кнопкой мыши на значке требуемого приложения и выберите в контекстном меню команду Экспорт.

  3. В первом диалоговом окне Мастера экспорта приложений COM+ нажмите кнопку Далее.

  4. В диалоговом окне Мастер экспорта приложений COM+ введите полный путь к файлу приложения, которое требуется создать. Если полный путь неизвестен, нажмите кнопку Обзор для поиска существующего каталога.

    Примечание. После завершения работы мастера создается указанный файл серверного приложения с расширением .msi. Этот файл содержит все сведения, необходимые для приложения COM+.

    Замечание о безопасности. Для предотвращения несанкционированных изменений экспортируемых приложений экспорт следует производить только в каталоги с ограничением прав на запись. Для повышения безопасности снабдите файл приложения (.msi) подписью с помощью Microsoft® Authenticode®.

  5. В группе Экспортировать как диалогового окна Мастер экспорта приложений COM+ выберите параметр Серверное приложение - установка приложения на других компьютерах.

  6. Если требуется включить всех пользователей, которым были назначены роли для данного приложения, установите флажок Экспортировать пользователей и их роли.

    Примечание. Этот параметр следует использовать только в том случае, если приложение предполагается установить на компьютер, находящийся в том же домене безопасности Microsoft® Windows®, что и компьютер, с которого выполняется экспорт приложения. Иначе коды пользователей, назначенные ролям, могут оказаться неверными и вызовут ошибки при попытке установить данное приложение. Кроме того, необходимо быть крайне осторожным при установке приложения на компьютер с другой языковой версией Windows, чем на компьютере, с которого выполняется экспорт приложения. Некоторые имена пользователей и групп, например, "Администраторы", на конечном компьютере будут переведены. Таких пользователей необходимо заново добавить к роли для предоставления им доступа к приложению на конечном компьютере.

  7. Нажмите кнопку Далее.

  8. В последнем диалоговом окне нажмите кнопку Готово.

    Важное замечание. Если код класса (CLSID) компонента, идентификатор библиотеки типов (TypeLibId) или идентификатор интерфейса (IID) изменяются после экспорта приложения, необходимо вновь экспортировать и установить приложение. Кроме того, после повторного экспорта приложения может понадобиться заново установить другие характеристики приложения.


Installing COM+ Server Applications

Установка серверных приложений COM+

Программа администрирования служб компонентов может использоваться для установки серверных приложений COM+. Исполнитель этой процедуры должен быть участником роли "Администратор" по отношению к системному приложению на конечном компьютере. В используемой по умолчанию конфигурации эта роль назначается только администраторам локальных компьютеров. Более подробно см. раздел Настройка административной безопасности.

Важное замечание. Серверное приложение COM+ можно установить только на компьютер, который работает под управлением Microsoft® Windows® 2000 или более поздних версий. Серверному приложению требуется платформа, поддерживающая службы компонентов.

Минимальной конфигурацией приложения считается конфигурация, не требующая обеспечения безопасности. При необходимости обеспечения безопасности приложения воспользуйтесь программой администрирования служб компонентов и установите безопасность на уровне процесса или добавьте пользователей к готовым ролям после установки приложения. Для получения дополнительных сведений о настройке безопасности для приложения см. раздел Администрирование безопасности приложения.

Примечание. Чтобы сетевые пользователи могли запускать приложение COM+ без аутентификации, в списки участников ролей приложения необходимо включить "Анонимного" пользователя. На сервере Windows Server 2003 по умолчанию "Анонимный" пользователь не входит в группу "Все".

Для установки серверного приложения COM+ с помощью программы администрирования служб компонентов выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов в папке Службы компонентов откройте папку Приложения COM+ компьютера, на который требуется установить данное приложение.

    Примечание Если включена функция разделов COM+, папку Приложения COM+ можно найти в папке Разделы COM+ того компьютера, на который требуется установить приложение. Дополнительные сведения о службе разделов COM+ и инструкции по включению этой службы в системе см. в разделе Администрирование разделов COM+.

  2. Щелкните правой кнопкой мыши на папке Приложения COM+, затем выберите команду Приложение в меню Создать.

  3. В начальном диалоговом окне Мастера установки приложений COM+ нажмите кнопку Далее.

  4. В диалоговом окне Установка или создание нового приложения выберите параметр Установить готовые приложения.

  5. В диалоговом окне Установить из файла приложения найдите и выделите файл .msi для устанавливаемого приложения, а затем нажмите кнопку Открыть.

  6. В диалоговом окне Выбор файлов приложения нажмите кнопку Добавить, чтобы найти дополнительные приложения, которые следует установить, а затем нажмите кнопку Далее.

  7. В диалоговом окне Удостоверение приложения укажите удостоверение приложения, а затем нажмите кнопку Далее.

    Примечание. По умолчанию выбрано значение Взаимодействующий пользователь. Взаимодействующий пользователь — это пользователь, вошедший в систему на исполняющем приложение компьютере с помощью учетной записи Windows. Предусмотрена возможность указать другого пользователя. Для этого выберите параметр Указанный пользователь и введите сведения о конкретном пользователе или группе Windows.

  8. В диалоговом окне Параметры установки приложения укажите каталог, куда следует установить приложение COM+, а затем нажмите кнопку Далее.

    Файлы компонентов приложения копируются из файла .msi в каталог для установки. По умолчанию для установки используется следующий каталог:

    %Program Files%\COMPlus Applications\<код_приложения>

    Воспользуйтесь предлагаемым по умолчанию каталогом либо выберите параметр Другой каталог и нажмите кнопку Обзор для выбора другого каталога.

    Примечание. Для выполнения этой процедуры необходимо, чтобы удостоверение приложения, заданное на шаге 8, по крайней мере, обеспечивало доступ для чтения к каталогу для установки. Кроме того, пользователь, применяющий программу администрирования служб компонентов, должен иметь доступ на запись в каталог для установки.

  9. Нажмите кнопку Готово.

В структуре дерева консоли в области данных отображается новое приложение. При установке нескольких приложений выбираемые на шаге 8 и 9 параметры применяются ко всем приложениям.

Для установки серверного приложения COM+ с помощью проводника Windows выполните следующие действия.

  1. С помощью проводника Windows найдите файл серверного приложения (.msi) на том компьютере, куда следует установить приложение COM+. Этот файл может находиться в локальном или сетевом каталоге.

  2. Дважды щелкните на имени файла серверного приложения. Можно также щелкнуть правой кнопкой мыши на имени файла, а затем выбрать в контекстном меню команду Установить. Программа установки Windows Installer автоматически установит серверное приложение на конечном компьютере.

Для установки серверного приложения COM+ с помощью командной строки выполните следующие действия.

В поле командной строки введите:

msiexec -i [<property overrides>] <application_name>.msi

В дополнение к стандартным переопределениям свойств, предусмотренным программой установки Windows Installer, можно использовать следующий параметр для замены предлагаемого по умолчанию каталога установки приложения COM+ на указанный в данном параметре:

TARGETDIR = <target installation directory>

Другие процедуры для этих действий

Другой способ установки приложения состоит в перетаскивании файла приложения из окна проводника Windows в правую область окна программы администрирования служб компонентов при открытой папке Приложения COM+ компьютера.


Exporting COM+ Application Proxies

Экспорт прокси для приложений COM+

Экспорт прокси для приложений COM+ выполняется с помощью программы администрирования служб компонентов. После установки прокси на компьютерах клиентов клиентские приложения получают возможность использовать сведения об этом прокси для поиска и доступа (посредством DCOM) к серверному приложению COM+ на реальном компьютере.

Важное замечание. Если код класса (CLSID) компонента, идентификатор библиотеки типов (TypeLibId) или идентификатор интерфейса (IID) изменяются после экспорта приложения, необходимо вновь экспортировать прокси для этого приложения и повторно установить прокси на компьютерах клиентов.

Для экспорта прокси для приложения COM+ выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на значке требуемого приложения, а затем выберите в контекстном меню команду Экспорт.

  2. В первом диалоговом окне Мастера экспорта приложений COM+ нажмите кнопку Далее.

  3. В диалоговом окне Сведения об экспорте приложения введите полный путь к создаваемому файлу прокси для приложения или нажмите кнопку Обзор для поиска существующего файла или каталога.

  4. В группе Экспортировать как выберите параметр Прокси приложения - установка доступа с других компьютеров к этому, а затем нажмите кнопку Далее.

  5. В последнем диалоговом окне нажмите кнопку Готово.

По умолчанию файл прокси для приложения включает сведения об удаленном сервере, указывающие, с какого компьютера-сервера был осуществлен экспорт прокси для приложения. Если экспорт прокси для приложения выполняется с виртуального сервера, по умолчанию прокси для приложения будет использовать в качестве имени удаленного сервера узел, в котором находился виртуальный сервер при экспорте. С помощью программы администрирования служб компонентов можно изменить имя удаленного сервера, установленное по умолчанию.

Обратите внимание, что имя удаленного сервера, заданное по умолчанию в файле прокси для приложения, также может быть переопределено в ходе установки. Дополнительные сведения см. в разделе Установка прокси для приложений COM+.

Для указания вспомогательного удаленного сервера, используемого прокси для приложений, выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на значке компьютера, с которого экспортируются приложения, и выберите в контекстном меню пункт Свойства.

  2. В диалоговом окне свойств компьютера перейдите на вкладку Параметры.

  3. В группе Экспорт введите в поле Прокси для приложений (RSN) имя удаленного сервера, который должен использоваться прокси для приложений.

  4. Нажмите кнопку ОК.


Installing COM+ Application Proxies

Установка прокси для приложений COM+

После создания прокси для приложений в виде файла Windows Installer (.msi) установка этого прокси на компьютере клиента не представляет труда. В результате установки прокси для приложений клиентские приложения получают сведения о регистрации, необходимые им для удаленного доступа к приложению COM+ с компьютера клиента.

Важное замечание. Установка прокси для приложения COM+ возможна на любой компьютер, где имеется Windows Installer. Программа установки Windows Installer автоматически устанавливается на все компьютеры, работающие под управлением Microsoft® Windows® 2000 или более поздних версий, и доступна для компьютеров, работающих под управлением Microsoft Windows 95, Microsoft Windows 98 и Microsoft Windows NT® 4.0. Если же для работы прокси для приложения необходима служба очередей компонентов COM+, то установка такого прокси возможна только на компьютер с ОС Windows 2000 или выше. Служба очередей компонентов доступна только для платформ, поддерживающих службы компонентов.

Для установки прокси для приложений COM+ с помощью программы администрирования служб компонентов выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов в папке Службы компонентов откройте папку Приложения COM+ компьютера, на который требуется установить данное приложение.

    Примечание. Если включена служба разделов COM+, папка Приложения COM+ отображается в папке Разделы COM+ того компьютера, на который требуется установить прокси для приложения. Для получения дополнительных сведений о службе разделов COM+ и инструкций по включению этой службы в системе см. раздел Администрирование разделов COM+.

  2. Щелкните правой кнопкой мыши на папке Приложения COM+, затем выберите команду Приложение в меню Создать.

  3. В начальном диалоговом окне Мастера установки приложений COM+ нажмите кнопку Далее.

  4. В диалоговом окне Установка или создание нового приложения выберите параметр Установить готовые приложения.

  5. В диалоговом окне Установить из файла приложения найдите и выделите файл .msi для устанавливаемого прокси для приложения, а затем нажмите кнопку Открыть.

  6. В диалоговом окне Выбор файлов приложения нажмите кнопку Добавить, чтобы найти дополнительные прокси для приложений, которые следует установить, а затем нажмите кнопку Далее.

  7. В диалоговом окне Параметры установки приложения укажите каталог, куда следует установить прокси для приложения COM+, а затем нажмите кнопку Далее.

    Файлы компонентов приложения копируются из файла .msi в каталог для установки. По умолчанию для установки используется следующий каталог:

    %Program Files%\COMPlus Applications\<код_приложения>

    Воспользуйтесь предлагаемым по умолчанию каталогом либо выберите параметр Другой каталог и нажмите кнопку Обзор для выбора другого каталога.

    Примечание. Для выполнения этой процедуры требуется доступ с правами на запись к каталогу установки.

  8. Нажмите кнопку Готово.

В структуре дерева консоли в области данных отображается новое приложение. При установке нескольких приложений каталог, указанный на шаге 8, используется для всех приложений.

Для установки прокси для приложения COM+ с помощью проводника Windows выполните следующие действия.

  1. На компьютере клиента найдите файл прокси для приложения (.msi) с помощью проводника Windows. Этот файл может находиться в локальном или сетевом каталоге.

  2. Дважды щелкните на имени файла прокси для приложения. Можно также щелкнуть правой кнопкой мыши на имени файла, а затем выбрать в контекстном меню команду Установить. Microsoft Installer автоматически установит прокси для приложения на компьютере клиента.

Для установки прокси для приложения COM+ с помощью командной строки выполните следующие действия.

В поле командной строки введите:

msiexec -i [<property overrides>] <application_name>.msi

В дополнение к стандартным переопределениям свойств, предусмотренным программой Windows Installer, можно указать параметры программы установки, описанные в следующей таблице.

Параметр программы установки | Описание
REMOTESERVERNAME = <new target server> | Изменение заданного по умолчанию сервера, к которому подключается компьютер клиента, на указанный новый конечный сервер.
ALLUSERS = 0 | Установка прокси для приложения только для текущего пользователя. По умолчанию прокси для приложения устанавливается на уровне компьютера.
TARGETDIR = <target installation directory> | Изменение каталога для установки приложения COM+ с заданного по умолчанию на указанный каталог.


Removing COM+ Applications

Удаление приложений COM+

Когда существующие приложения устаревают или выходят из употребления, может потребоваться их удаление. При удалении приложения удаляются также все компоненты, входящие в это приложение. Если какой-либо компонент приложения COM+ использует дополнительные ресурсы (подключения к базам данных, файлы данных и текстовые файлы, конфигурацию виртуального корневого каталога IIS и т. п.), то эти ресурсы должны быть удалены без помощи программы администрирования служб компонентов.

Примечание. Если попытаться удалить серверное приложение COM+ во время его выполнения, приложение завершит работу без предупреждения, а затем будет удалено.

Для удаления приложения COM+ с помощью программы администрирования служб компонентов выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов дважды щелкните на значке компьютера, с которого требуется удалить приложение.

  2. Дважды щелкните на папке Приложения COM+ для указанного компьютера для отображения списка всех приложений.

  3. Выберите приложение, которое требуется удалить.

  4. Если выбрано серверное приложение, завершите его работу. Можно также щелкнуть правой кнопкой мыши на требуемом приложении, а затем выбрать в контекстном меню команду Завершить работу. Если выбрано библиотечное приложение, убедитесь в том, что завершены все процессы, использовавшие данную библиотеку.

  5. Щелкните правой кнопкой мыши на требуемом приложении. Если в контекстном меню команда Удалить недоступна, то для приложения необходимо разрешить удаление, выполнив следующие действия.
    1. Щелкните правой кнопкой мыши на требуемом приложении и выберите в контекстном меню пункт Свойства.

    2. На странице свойств приложения откройте вкладку Дополнительно.

    3. В группе Защита отмените выбор флажка Отключить удаление.

    4. Нажмите кнопку ОК.
  6. Щелкните правой кнопкой мыши на требуемом приложении и выберите в контекстном меню команду Удалить.

  7. Для удаления приложения нажмите кнопку Да в диалоговом окне Подтверждение удаления.

Описанные далее способы особенно удобны для удаления приложений COM+ с компьютеров клиентов, на которых нет программы администрирования служб компонентов.

Для удаления приложения COM+ с помощью проводника Windows выполните следующие действия.

  1. На компьютере, на котором требуется удалить приложение COM+, найдите файл серверного приложения (.msi) или файл прокси для приложения (.msi) с помощью проводника Windows.

  2. Щелкните правой кнопкой мыши на имени требуемого файла .msi и выберите в контекстном меню команду Удалить. Программа Windows Installer автоматически удалит приложение.

Для удаления приложения COM+ с помощью командной строки выполните следующие действия.

В поле командной строки введите:

msiexec -x <application_name>.msi

Другие процедуры для этих действий

Приложение COM+ можно удалить с помощью программы Установка и удаление программ панели управления.


Replicating COM+ Applications

Репликация приложений COM+

В определенных случаях требуется выполнить репликацию всех приложений COM+ и их настроек с главного компьютера на целевой. Репликация особенно полезна в следующих сценариях:

  • распределенные веб-узлы (веб-фермы);

  • обеспечение отказоустойчивости в кластере;

  • перенос с отладочного на реальный компьютер.

Репликацию приложений можно выполнять вручную, одно за другим экспортируя каждое приложение и затем устанавливая их на главный компьютер. Однако намного более простой способ выполнения этой утомительной и чреватой ошибками задачи состоит в использовании служебной программы репликации приложений COM+ (COMRepl.exe), входящей в состав Microsoft® Windows® 2000 или более поздних версий. Эта программа репликации копирует все приложения COM+ с главного на конечный компьютер. Она также выполняет репликацию всех настроек COM+ на уровне компьютера.

Для использования программы comrepl в командной строке введите:

comrepl <sourceComputer> <targetComputerList> [/n [/v]]

Параметры командной строки описаны в следующей таблице.

Параметр | Описание
<sourceComputer> | Имя исходного компьютера.
<targetComputerList> | Имена конечных компьютеров, разделенные пробелами.
/n | Подавление вывода запроса на подтверждение перед запуском репликации.
/v | Копирование вывода в файл журнала на консоль.

Примечания

  • На все конечные компьютеры необходимо заранее установить службы компонентов, так как репликация выполняется только для данных настройки и приложений, но не для файлов служб компонентов.

  • Пользователь должен успешно проходить проверку роли для системного приложения как на исходном, так и на конечных компьютерах.

  • Локальные учетные записи компьютера, которые могут использоваться ролями, не реплицируются.

  • Все конечные компьютеры должны быть включены.

  • За репликацию на конечные компьютеры всех данных, не связанных напрямую со службами компонентов, (например, таблиц баз данных, файлов данных и т. д.) отвечает пользователь.

  • Конечный компьютер определяется только по имени.


Administering the Operation of COM+ Applications

Администрирование операций приложений COM+

Программа администрирования служб компонентов предоставляет средства для администрирования операций приложений COM+. Эти средства обеспечивают гибкость при отладке и устранении неполадок в приложениях, а также могут быть полезны при развертывании приложения.

Разделы, описанные в следующей таблице, содержат основные понятия, связанные с запуском приложения COM+, и сведения об использовании программы администрирования служб компонентов для настройки работы приложений COM+.

Раздел | Описание
Основные понятия об операциях приложения | Основные сведения по запуску приложений COM+.
Задачи приложения | Пошаговые инструкции по настройке работы приложений COM+.


Application Operation Concepts

Основные понятия об операциях приложения

Программа администрирования служб компонентов позволяет повысить эффективность работы приложений COM+ путем предоставления более гибких средств для отладки и устранения неполадок данных приложений. Кроме того, COM+ предоставляет средство активизации при небольшом объеме памяти, чтобы до активизации объектов и процессов убедиться, что объем памяти достаточен для активизации. Данная служба является автоматической, поэтому с ней не связана ни одна административная задача.

В разделах, описанных в следующей таблице, содержатся общие сведения по запуску и администрированию операций приложений COM+.

Раздел | Описание
Управление операциями приложения COM+ | Основные сведения по улучшению операций приложений COM+, особенно в процессе отладки и при устранении неполадок.
Активизация при небольшом объеме памяти | Сведения о средстве автоматической проверки необходимого объема памяти до активизации объектов и процессов.


Controlling COM+ Application Operation

Управление операциями приложения COM+

Системный администратор может использовать программу администрирования служб компонентов для быстрой остановки или запуска серверных приложений COM+. Кроме того, администратор может использовать данную программу для включения и отключения серверных и библиотечных приложений COM+, а также для приостановки и возобновления работы серверных приложений COM+.

Примечание. Средства приостановки и возобновления процесса предусмотрены только для определенных серверных процессов COM+. Отключение и включение приложений возможно выполнить как для серверных, так и для библиотечных приложений COM+.

Завершение работы и запуск серверных приложений COM+

Администратор может завершить серверное приложение COM+ при необходимости завершения всего процесса. В противном случае средство завершения не является эффективным способом управления работой приложения. Если при завершении процесса существуют распределенные связи объектов с процессами или компьютерами, то в любой вызывающей программе вероятно появление непредвиденных ошибок. Кроме того, после завершения работы приложения при последующей активизации оно будет просто запущено вновь.

Во избежание подобных ошибок при завершении работы администратор может отключить приложение COM+, приостановить работу серверного приложения COM+ или использовать повторный запуск приложений, предусматривающий завершение работы приложения с одновременным продолжением обслуживания существующих объектов.

Пошаговые инструкции см. в разделе Завершение работы и запуск серверных приложений COM+.

Настройка завершения работы серверного процесса

Администратор может выполнить настроику, предусматривающую завершение серверного процесса, если данный процесс находится в состоянии бездействия в течение определенного времени. Это удобный способ автоматического освобождения неиспользуемых ресурсов.

Пошаговые инструкции см. в разделе Настройка завершения серверного процесса.

Отключение и включение приложений COM+

С помощью средства отключения и включения приложений COM+ администратор может останавливать серверные и библиотечные процессы. При необходимости установить новые приложения или программное обеспечение, обновить приложения или установить новое оборудование отключение приложения COM+ позволяет предотвратить появление ошибок, которые возникают при использовании метода завершения.

После отключения приложения активизация компонентов в приложении отклоняется. Даже при перезагрузке компьютера активизация компонентов продолжает отклоняться, поскольку система сохраняет сведения о состоянии приложения (отключено) в базе данных конфигурации COM+. Активизация становится доступной только после того, как администратор включит приложение.

Администратор может установить новые приложения в режиме отключения без завершения работы приложения. Установка приложений в режиме отключения предотвращает активизацию компонентов и запуск приложений в процессе установки. По завершении установки всех приложений их можно включить.

При обновлении библиотечных приложений COM+ рекомендуется использовать режим отключения без завершения работы приложений. Например, если брокерская компания выпускает новую версию приложения для торговли на рынке ценных бумаг, то приложение можно отключить, не прерывая процесс торговли. Программа администрирования служб компонентов генерирует сообщение об отключении приложения, и приложение может затем уведомить клиентов о временном прекращении торговли. После завершения начатых торговых операций системный администратор может завершить работу приложения, заменить библиотеки DLL, а затем включить приложение. Кроме того, администратор может добавить новое оборудование, а затем настроить приложение. Все эти действия администратор выполняет без ущерба для входящих активизаций. Администратор может перезагрузить сервер баз данных, с которым связано приложение, пока оно отключено.

Пошаговые инструкции см. в разделе Отключение и включение приложений COM+.

Приостановка и возобновление процессов серверных приложений COM+

С помощью средства приостановки и возобновления работы серверного приложения можно выполнить отладку приложения. Для этого необходимо временно остановить серверные приложения COM+ для принятия активизаций. Например, если администратор замечает неполадки со службой объекта на определенном клиенте, он может отключить поврежденное приложение. Если администратор обнаруживает, что один из серверных процессов, обслуживающих данное приложение, поврежден, он может приостановить этот серверный процесс и повторно включить приложение. Активизации будут перенаправлены другим серверам, а администратор может выполнить отладку поврежденного процесса.

Возможность прерывать и возобновлять работу серверного приложения можно также использовать для повторного запуска программы прослушивания очередей компонентов. Если приложение COM+, использующее очереди, запущено, но не запущен слушатель, то можно активизировать программу прослушивания очередей компонентов, прервать и повторно запустить приложение, при этом программа прослушивания очередей компонентов будет запущена. Таким же образом можно деактивизировать программу прослушивания очередей компонентов, прервать и повторно запустить приложение, при этом программа прослушивания очередей компонентов завершит свою работу после обработки сообщений, работа с которыми уже начата. Дополнительные сведения о службе очередей компонентов см. в разделе Администрирование очередей компонентов.

При приостановке процесса серверного приложения все дальнейшие активизации отклоняются и обслуживаются только вызовы методов для объектов, которые уже созданы. Однако прерванное действие не сохраняется в конфигурационной базе данных, поэтому, если перезагрузить компьютер до сохранения изменений, то все изменения, внесенные в базу данных во время приостановки процесса, будут аннулированы.

Примечание. Средство приостановки и возобновления является специфическим для каждого процесса. Если компьютер перезагружается или создается другой сервер, который реализует данное приложение, то любая активизация, переданная на сервер, обрабатывается, что может вызвать большое число ошибок. Классы COM, добавляемые в библиотечные приложения COM+, не поддерживают средство прерывания и повторного запуска серверного приложения.

Пошаговые инструкции см. в разделе Приостановка и возобновление процессов серверных приложений COM+.


Low-Memory Activation Gates

Активизация при небольшом объеме памяти

Проблемы надежности часто возникают, когда при большой загрузке сервера его ресурсы не могут эффективно взаимодействовать с клиентской частью. Если серверу не хватает физических ресурсов, чтобы соответствовать требованиям при пиковой загрузке, то он может использовать виртуальную память. Если пользовательский или системный код неправильно обрабатывает сбои при выделении памяти, то это является серьезной неполадкой. Сервер начинает работать медленно, и как только объем памяти исчерпывается, происходит сбой при выделении памяти. Сервер начинает выполнять неправильные действия по прерыванию сбоев выделения памяти. Если ошибка содержится в пользовательском или серверном коде, который запущен на сервере, то найти и устранить ее очень трудно.

COM+ старается предотвратить ситуации, в которых данные ошибки выполняются на сервере. С помощью средства активизации при небольшом объеме памяти COM+ следит за загруженностью памяти системы, чтобы до выполнения пользовательского кода быть уверенным в том, что доступно требуемое количество памяти. Если процент доступной для приложения виртуальной памяти падает ниже определенного порогового значения, то активизация не происходит до создания серверного приложения или объекта COM+, как показано на рисунке ниже. Если не удается выполнить активизацию, которую необходимо запустить обычным образом, то средство активизации при небольшом объеме памяти позволяет минимизировать неполадки, связанные с выделением памяти в пользовательском коде, который значительно увеличивает надежность системы.

Средство активизации при небольшом объеме памяти используется только для настройки компонентов COM+, которые установлены в приложении COM+.

Работа со средством активизации при небольшом объеме памяти

Средство активизации при небольшом объеме памяти использует различные фиксированные пороговые значения для разных типов активизаций. При создании серверного приложения COM+ можно выполнить активизацию, если доступно не менее 10 процентов виртуальной памяти. Если доступно менее 10 процентов, то будет выполнена проверка, может ли файл подкачки быть расширен, чтобы разместить дополнительную память. Если файл подкачки может быть расширен, то серверное приложение создается. Если файл подкачки расширить невозможно, то активизация не выполняется и память не выделяется.

Аналогичный процесс происходит при создании объекта. В этом случае активизация разрешена, если доступно более 5 процентов виртуальной памяти. Если доступно менее 5 процентов, то выполняется проверка размещения. Если при проверке размещения можно расширить файл подкачки, то объект создается. Если расширить файл подкачки нельзя, то активизацию выполнить невозможно.

Настроить фиксированные пороговые значения для средства активизации при небольшом объеме памяти невозможно. По этой причине в разделе Задачи приложения отсутствуют процедуры, относящиеся к данному средству.


Application Operation Tasks

Задачи приложения

В данном разделе перечислены возможные задачи по работе приложений COM+.

  • Завершение работы и запуск серверных приложений COM+

  • Настройка завершения работы серверного процесса

  • Отключение и включение приложений COM+

  • Приостановка и возобновление процессов серверных приложений COM+


Shutting Down and Starting COM+ Server Applications

Завершение работы и запуск серверных приложений COM+

Администратор может завершить серверное приложение COM+ в случае, если весь процесс необходимо завершить. В противном случае средство завершения не является эффективным способом прерывания работы приложения. Чтобы при завершении работы избежать ошибок подобного рода, можно отключить приложение COM+, приостановить процесс серверного приложения COM+ или использовать повторный запуск приложений, при котором работа приложения будет завершена, а обслуживание существующих объектов будет продолжено.

Дополнительные сведения о завершении и запуске серверных приложений COM+, о преимуществах отключения и включения приложений, а также о преимуществах приостановки и возобновления процессов серверных приложений см. в разделе Основные понятия об операциях приложения.

Ниже описаны процедуры завершения работы и запуска серверного приложения COM+.

Для завершения работы серверного приложения COM+ выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните на серверном приложении COM+, работу которого требуется завершить.

  2. Щелкните правой кнопкой мыши на требуемом приложении и выберите в контекстном меню команду Завершить работу.

Для запуска серверного приложения COM+ выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните на серверном приложении COM+, которое требуется запустить.

  2. Щелкните правой кнопкой мыши на требуемом приложении COM+ и выберите в контекстном меню команду Запустить.


Setting the Server Process Shutdown

Настройка завершения работы серверного процесса

Администратор может выполнить настройку, предусматривающую завершение серверного процесса, если данный процесс находится определенное время в состоянии бездействия. Это удобный способ автоматического освобождения неиспользуемых ресурсов.

Ниже описана процедура по настройке завершения работы серверного процесса.

Для настройки завершения работы процесса серверного приложения COM+ выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов найдите серверное приложение COM+, для которого требуется настроить процесс завершения работы.

  2. Щелкните правой кнопкой мыши на этом приложении и выберите в контекстном меню пункт Свойства.

  3. В диалоговом окне свойств перейдите на вкладку Дополнительно.

  4. В группе Завершение серверного процесса выберите один из следующих параметров.
    • Не останавливать при ожидании Этот параметр служит для указания на то, что серверный процесс имеет неограниченное время ожидания и не требует автоматического завершения. Завершение такого процесса должно выполняться вручную.

    • Завершить при ожидании более (мин) В текстовом поле справа от данного параметра введите требуемое время в минутах. По истечение указанного времени процесс будет автоматически завершен. Допускается ввод значения от 1 до 1440 минут (24 часа). По умолчанию устанавливается значение 3 минуты. Приостановленный процесс не является простаивающим, но он может перейти в состояние простоя после его возобновления.
  5. Нажмите кнопку ОК.

Настройки параметров завершения серверного процесса вступают в действие при следующем запуске приложения.


Disabling and Enabling COM+ Applications

Отключение и включение приложений COM+

С помощью средства отключения и включения приложений COM+ администратор может останавливать серверные и библиотечные процессы. Отключив приложение COM+, можно предотвратить появление ошибок, которые возникают при использовании метода завершения, когда необходимо установить новые приложения или программное обеспечение, обновить приложения или установить новое оборудование.

Дополнительные сведения о преимуществах включения и отключения приложений COM+ см. в разделе Основные понятия об операциях приложения.

Ниже описаны процедуры по включению и отключению приложений COM+.

Для отключения приложения COM+ выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните на приложении COM+, которое требуется отключить.

  2. Щелкните правой кнопкой мыши на этом приложении и выберите в контекстном меню команду Отключить.

Для включения приложения COM+ выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните на приложении COM+, которое требуется включить.

  2. Щелкните правой кнопкой мыши на этом приложении и выберите в контекстном меню команду Включить.


Pausing and Resuming COM+ Server Application Processes

Приостановка и возобновление процессов серверных приложений COM+

С помощью средства приостановки и возобновления работы серверного приложения можно выполнить отладку приложения. Для этого необходимо временно остановить серверные приложения COM+ для принятия активизаций. При прерывании процесса серверного приложения все дальнейшие активизации отклоняются и обслуживаются вызовы методов для объектов, которые уже созданы. Однако прерванное действие не сохраняется в базе данных конфигурации.

Дополнительные сведения о преимуществах приостановки и возобновления серверных приложений COM+ см. в разделе Основные понятия об операциях приложения.

Ниже описаны процедуры приостановки и возобновления работы серверных процессов COM+.

Для приостановки серверного процесса COM+ выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов дважды щелкните на папке Выполняемые процессы компьютера, на котором требуется приостановить работу серверного приложения.

  2. Щелкните правой кнопкой мыши на процессе, который требуется приостановить, и выберите в контекстном меню команду Приостановить.

Для возобновления работы серверного процесса COM+ выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов дважды щелкните на папке Выполняемые процессы компьютера, на котором требуется возобновить работу серверного приложения.

  2. Щелкните правой кнопкой мыши на приостановленном процессе, который необходимо возобновить, и в контекстном меню выберите команду Продолжить.


Administering Application Pooling

Администрирование группирования приложений

Служба группирования приложений COM+ повышает надежность системы, позволяя масштабировать процессы с одним потоком аналогично тому, как группирование потоков позволяет масштабировать объекты с одним потоком. Кроме того, группирование приложений может облегчить восстановление после сбоев в отдельных процессах, позволяя другим запущенным процессам обрабатывать активизации.

В разделах, описанных в следующей таблице, приведены сведения по общим вопросам и выполнению задач с использованием группирования приложений COM+.

Раздел | Описание
Основные понятия администрирования группирования приложений | Основные сведения по группированию приложений COM+.
Задачи администрирования группирования приложений | Пошаговые инструкции по настройке группирования приложений COM+.


Application Pooling Administration Concepts

Основные понятия администрирования группирования приложений

Служба группирования приложений COM+ повышает надежность системы, позволяя масштабировать процессы с одним потоком аналогично тому, как группирование потоков позволяет масштабировать объекты с одним потоком. Особенно полезна эта возможность в ситуациях, при которых старый код (в котором не определена модель организации потоков) должен выполняться в главном контейнере с одним потоком.

Кроме того, группирование приложений может облегчить восстановление после сбоев в отдельных процессах, позволяя другим запущенным процессам обрабатывать активизации. Например, если для одного приложения выполняются три процесса и в одном из них возникает сбой, остальные процессы остаются незатронутыми, а вероятность потери результатов работы сводится к минимуму. Если служба повторного запуска приложений COM+ также включена, группирование приложений обеспечивает дополнительную надежность и стабильность, поскольку одновременно перезапускается только один из указанного числа выполняющихся процессов.

Примечание Свойства повторного запуска и группирования библиотечных приложений наследуются у соответствующих основных процессов.

Использование со службой группирования приложений COM+ программы администрирования служб компонентов позволяет задать несколько серверных процессов, которые затем эффективно действуют как одно приложение. При запуске приложения COM+ создает заданное число процессов Dllhost, и эти процессы одновременно обслуживают активизации для данного приложения. Каждый из экземпляров процесса Dllhost может обслуживать любой вызов, адресованный серверному приложению.

Для настройки группирования приложений с помощью программы администрирования служб компонентов достаточно задать целочисленное значение в поле Размер группы на странице свойств Группирование и повторное использование. Это значение задает максимальное число процессов Dllhost, запускаемых для обслуживания активизаций для этого приложения. При значении поля Размер группы равном 1, т.е. значении по умолчанию, служба группирования приложений COM+ отключена.

Пошаговые инструкции по настройке группирования приложений с помощью программы администрирования служб компонентов см. в разделе Настройка группирования приложений. Настроить группирование приложений можно и программно с помощью административных функций SDK COM+.


Application Pooling Administration Tasks

Задачи администрирования группирования приложений

Следующий раздел содержит сведения по выполнению процедуры настройки группирования приложений с помощью программы администрирования служб компонентов:

Настройка группирования приложений


Configuring Application Pooling

Настройка группирования приложений

Для настройки группирования приложений COM+ применяется программа администрирования служб компонентов. Дополнительные сведения о базовых принципах повторного запуска приложений см. в разделе Основные понятия администрирования группирования приложений.

Настройка группирования приложений для приложения COM+

Примечание. Свойства повторного запуска и группирования библиотечных приложений наследуются у соответствующих основных процессов.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на приложении COM+, для которого требуется назначить группирование, и выберите пункт Свойства.

  2. На вкладке Группирование и повторное использование в области Группирование приложений введите значение в поле Размер группы в соответствии с количеством экземпляров приложения, которое должно выполняться. При значении поля Размер группы равном 1, т.е. значении по умолчанию, служба группирования приложений COM+ отключена.

  3. Нажмите кнопку ОК.


Administering Application Recycling

Администрирование повторного запуска приложений

Повторный запуск приложения является эффективным средством повышения стабильности работы приложения путем настройки в COM+ автоматического завершения работы и повторного запуска приложения.

Разделы, описанные в следующей таблице, содержат основные понятия, связанные с повторным запуском приложений, и сведения об использовании программы администрирования служб компонентов для настройки повторного запуска приложений COM+.

Раздел | Описание
Основные понятия администрирования повторного запуска приложений | Основные сведения по повторному запуску приложений COM+.
Задачи администрирования повторного запуска приложений | Пошаговые инструкции по настройке повторного запуска приложений COM+.


Application Recycling Administration Concepts

Основные понятия администрирования повторного запуска приложений

Эта возможность позволяет значительно повысить общую стабильность работы приложения путем быстрого исправления известных неполадок и защиты от неизвестных ошибок. Со временем быстродействие приложения уменьшается, поскольку могут возникать проблемы, связанные с нехваткой памяти, использованием немасштабируемых ресурсов и ошибками процесса. В качестве решения возникших проблем в программе администрирования служб компонентов предусмотрено закрытие и повторный автоматический запуск приложения COM+, что обеспечивает повторную инициализацию процесса и повторное выделение используемой памяти.

При повторном запуске приложения создается копия процесса Dllhost, связанного с приложением. Копия процесса Dllhost работает со всеми будущими запросами объектов, а старый процесс Dllhost завершает работу с оставшимися запросами объектов. Когда сняты блокировки со всех внешних ссылок на объекты в процессе или достигнуто время ожидания, старый процесс Dllhost завершает работу. Для повторного запуска приложения необходимо убедиться в том, что клиентское приложение никогда не сталкивается с приостановкой работы служб.

Повторный запуск приложения можно настроить административно, используя программу администрирования служб компонентов, или программным образом, используя средства администрирования SDK. Повторный запуск процесса можно выполнить на основании следующих критериев.

  • С момента запуска процесса Dllhost до повторного запуска прошло определенное число минут.

  • Используется определенный объем памяти, который процесс Dllhost не может превышать.

  • Определенное количество вызовов для настройки объектов в процессе Dllhost.

  • Определенное число активизаций процесса Dllhost.

Для повторного запуска процесса можно выбрать несколько критериев. После соответствия первому критерию из набора COM+ перезапускает процесс. Для определения времени, отведенного старому процессу Dllhost на завершение обработки оставшихся запросов, после которого он будет принудительно закрыт, можно задать величину времени ожидания.

Примечание. Приложение COM+, которое настроено на запуск в качестве службы Windows, невозможно повторно запустить.

По конкретным вопросам настройки повторного запуска приложений обращайтесь к разделу Настройка повторного запуска процесса.


Application Recycling Administration Tasks

Задачи администрирования повторного запуска приложений

Следующий раздел содержит сведения по выполнению процедуры настройки повторного запуска приложений с помощью программы администрирования служб компонентов:

Настройка повторного запуска приложений


Configuring Application Recycling

Настройка повторного запуска приложений

Для настройки повторного запуска приложений COM+ применяется программа администрирования служб компонентов. Дополнительные сведения о базовых принципах повторного запуска приложений см. в разделе Основные понятия администрирования повторного запуска приложений.

Для настройки повторного запуска приложения COM+ выполните следующие действия.

Примечание. Приложение COM+, которое настроено на запуск в качестве службы Windows, невозможно повторно запустить.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на приложении COM+, которое требуется повторно запустить, и выберите пункт Свойства.

  2. В зависимости от необходимых критериев на вкладке Группирование и очистка введите соответствующие значения в полях Предельное время жизни (мин.), Предельный объем памяти (Кб.), Время ожидания (мин.), Предельное число вызовов и Предельное число активизаций.

    Примечание. Если в полях Предельное время жизни (мин.), Предельный объем памяти (Кб.), Предельное число вызовов или Предельное число активизаций введено значение 0 (по умолчанию), то в соответствии с данными критериями повторный запуск приложения не выполняется. Если во всех четырех полях введено значение 0, то для данного приложения средство повторного запуска отключено.

    • Предельное время жизни. Максимальное время (в минутах) до повторного выполнения процесса. Это время находится в диапазоне от 0 до 30 240 минут (21 день). По умолчанию оно равно 0.

    • Предельный объем памяти (Кб.). Максимальный объем используемой процессом памяти (в килобайтах) до его повторного запуска. Если объем памяти, используемой процессом, превышает указанный объем в течение более 1 минуты, то процесс запускается заново. Действительный объем памяти находится в диапазоне от 0 до 1 048 576 Кб. По умолчанию он равняется 0 Кб.

    • Время ожидания (мин.). Время ожидания (в минутах) до снятия блокировки со всех внешних ссылок на объекты в процессе. После этого процесс будет принудительно завершен. Это число находится в диапазоне от 1 до 1 440. По умолчанию оно равняется 15. Это значение используется, если уже решено, что процесс будет повторно запущен в соответствие с другими критериями.

    • Максимальное число вызовов. Максимальное число вызовов, которое могут принять объекты приложения, до повторного выполнения процесса. Это число находится в диапазоне от 0 до 1 048 576. По умолчанию оно равняется 0.

    • Максимальное число активизаций. Максимальное количество активизаций объектов приложения до повторного выполнения процесса. Это число находится в диапазоне от 0 до 1 048 576. По умолчанию оно равняется 0.
  3. Нажмите кнопку ОК.


Administering Application Security

Администрирование безопасности приложений

Службы компонентов предоставляют простую и надежную модель безопасности, которую можно использовать для защиты данных, ресурсов и приложений COM+ от случайного или злонамеренного повреждения.

Центральным механизмом является использование ролей — категорий пользователей, заданных разработчиком приложения. Разработчик определяет роли для приложения и его компонентов, а системный администратор назначает их реальным пользователям. Созданные роли позволяют реализовать политику управления доступом для приложения.

Что касается администрирования, безопасность на основе ролей делает более понятным и простым управление безопасностью приложений COM+. Задачи управления безопасностью на основе ролей обычно сводятся к присвоению заданных ролей группам или учетным записям пользователей Microsoft® Windows® и настройке удостоверения для приложения (учетная запись, с которой работает приложение).

Предварительное замечание

Обеспечение безопасности является неотъемлемой частью разработки приложения. Разработчики пытаются достичь оптимального баланса между требованиями безопасности, производительностью и функциональными возможностями. Разработчик выбирает надлежащий уровень безопасности на основе ролей и определяет роли, соответствующие категориям пользователей этого приложения. Выбор ролей может повлиять на любой функциональный аспект приложения, поэтому он должен рассматриваться в общем контексте разработки приложения.

Примечание. Более подробно вопросы обеспечения безопасности COM+ рассматривается в разделе о безопасности COM+ в главе «Component Services» SDK платформы. Безопасность COM рассматривается в разделе о безопасности COM в главе «Component Services» SDK платформы. Для ознакомления и установки SDK платформы посетите веб-узел MSDN.

Разделы, описанные в следующей таблице, содержат подробные сведения о понятиях и задачах обеспечения безопасности.

Раздел | Описание
Основные понятия администрирования безопасности | Обзор и ссылки на более подробные сведения по администрированию безопасности приложений.
Задачи администрирования безопасности | Ссылки на пошаговые процедуры выполнения задач обеспечения безопасности.


Security Administration Concepts

Основные понятия администрирования безопасности

Используемая приложениями COM+ модель безопасности, основанная на ролях, – это надстройка над такими механизмами обеспечения безопасности Microsoft® Windows® и COM, как идентификация пользователей, службы проверки подлинности, олицетворение и представительство. Эти механизмы обеспечения безопасности продолжают действовать незаметно для приложений на базовых уровнях. Windows предоставляет основные средства защиты, обеспечивая идентификацию пользователей с помощью учетных записей, управление доступом к системным ресурсам и аудит событий безопасности с помощью локальных пользователей и групп, а также защиту файлов с помощью файловой системы NTFS.

Администрирование безопасности служб компонентов требует знания средств безопасности Windows. Более подробные сведения содержатся в документации по Windows и в пакете Microsoft Windows Resource Kit.

Администрирование безопасности приложений COM+

Администрирование безопасности приложений COM+ включает следующие задачи:

  • Назначение групп пользователей Windows на предварительно заданные роли для приложения или для определенного раздела COM+ и последующее управление этими ролями.

  • Задание удостоверения приложения при его установке. Обычно для этой цели используется учетная запись пользователя. В дальнейшем это удостоверение используется для идентификации приложения во время выполнения, а также при обращении к другим приложениям и ресурсам. (Это относится только к серверным приложениям; для библиотечных приложений не требуется.)

Эффективное управление безопасностью на основе ролей требует четкого понимания требований к безопасности приложений и механизма удовлетворения этих требований с помощью ролей. Очень важно назначать роли пользователям в соответствии с политикой безопасности, принятой для приложения.

Предостережение. Не рекомендуется с помощью программы администрирования служб компонентов изменять настройку безопасности для приложения без особой необходимости. Приложение, использующее механизм ролей, может содержать код, выполняющий проверку соответствия ролей и учетных записей. Изменение настройки безопасности приложения может привести к тому, что приложение вообще перестанет работать, будет работать неправильно или без необходимой защиты.

Администрирование безопасности приложений COM

Приложения COM используют различные свойства настройки безопасности. Для каждого из этих свойств определено значение на уровне компьютера, которое используется по умолчанию для всех приложений. Кроме того, для любого приложения можно задать собственные свойства безопасности COM. Если приложение не имеет собственных настроек безопасности, используются настройки, заданные для компьютера, на котором выполняется это приложение.

Программа служб компонентов позволяет изменить настройку безопасности COM для компьютера. Чтобы задать индивидуальные свойства безопасности для конкретного приложения COM, следует использовать программу DCOMCNFG. Как правило, менять что-либо не приходится, но некоторые приложения и системы могут потребовать перенастройки.

Безопасность COM подробно рассматривается в разделе о безопасности COM в главе «Службы компонентов» (Component Services) пакета средств разработки (SDK) для данной платформы.

Более подробные сведения по администрированию безопасности служб компонентов содержатся в разделах, указанных в следующей таблице.

Раздел | Описание
Безопасность на основе ролей | Обзор работы безопасности на основе ролей.
Уровни безопасности для проверки доступа | Описание выполнения проверки безопасности доступа.
Политика программных ограничений | Обзор политики программных ограничений и причин ее использования.
Проверка подлинности в COM+ | Описание необходимости проверки подлинности в политике безопасности.
Олицетворение и использование представителей в COM+ | Описание необходимости использования олицетворения и ограничений, связанных с использованием представителей.
 | Обзор способов использования удостоверения приложения.
Безопасность библиотечных приложений | Описание специальных средств обеспечения безопасности библиотечных приложений COM+.


Role-Based Security

Безопасность на основе ролей

Определение и соблюдение политики управления доступом для приложений и разделов COM+ осуществляется на основе ролей безопасности. Роли — это категории пользователей приложения или раздела COM+, на основе которых определяются права доступа к ресурсам приложения. Разработчик задает роли (как символические категории пользователей) для приложения и, если требуется, для его элементов, включая компоненты, интерфейсы, методы и закрытые ресурсы приложения. Эти роли затем определяют категории пользователей, которым разрешен доступ к различным элементам приложения.

Если приложение использует механизм ролей, принадлежность вызывающего к соответствующей роли проверяется при каждом вызове приложения. Если роль вызывающего не предусматривает прав доступа к вызываемому элементу, вызов не выполняется. Доступ вызывающих к приложению и его ресурсам предоставляется в строгом соответствии с ограничениями, установленными для их ролей.

Задача системного администратора – назначить учетные записи пользователей и группы Microsoft® Windows® на роли, заданные для приложения или раздела COM+. Это очень важный момент для реализации политики безопасности приложения. Пользователи должны получать роли в строгом соответствии с тем, к каким данным и ресурсам им необходимо обращаться через данное приложение.

Назначение групп пользователей на роли

Оптимальным способом назначения ролей пользователям является использование групп Windows. Сначала учетные записи пользователей включаются в соответствующие группы, а затем эти группы назначаются на соответствующие роли. Использование групп Windows для назначения ролей упрощает управление большим количеством пользователей. В корпоративных системах часто трудно отследить место каждого пользователя в организации и как оно вписывается в политику безопасности каждого приложения, основанную на ролях. Чем больше пользователей, администраторов и приложений, тем сложнее эта задача. Самое эффективное решение в этой ситуации – назначать роли, заданные для приложений COM+, целым группам пользователей.

Прежде чем назначать роли группам, необходимо понять политику обеспечения безопасности приложения. В идеале названия ролей должны соответствовать категориям пользователей, которым они назначаются (например, «Менеджеры» и «Кассиры»). Кроме того, с помощью программы служб компонентов можно получить описание каждой роли, в котором могут содержаться сведения о том, какие пользователи могут назначаться на данную роль. Если вам непонятно, как распределять пользователей по ролям, обратитесь к документации по приложению или непосредственно к разработчику.

С помощью программы служб компонентов можно произвести начальное распределение ролей во время установки приложения и впоследствии вносить необходимые изменения.

Пошаговые инструкции по управлению ролями приведены в следующих разделах.

  • Включение авторизации на основе ролей

  • Назначение учетной записи пользователя или группы на роль

  • Удаление учетной записи пользователя или группы из роли

  • Перемещение учетной записи пользователя или группы в другую роль


Security Levels for Access Checks

Уровни безопасности для проверки доступа

Безопасность проверяется только на границах приложения. То есть, если один компонент приложения вызывает другой компонент того же приложения, проверка безопасности не производится. Но если два приложения используют один и тот же процесс и компонент одного приложения вызывает компонент другого, проверка безопасности выполняется, поскольку происходит выход за границы приложения. Аналогично, если два приложения находятся в различных серверных процессах и компонент одного приложения вызывает компонент другого, проверка безопасности выполняется. Следовательно, если есть два компонента и требуется, чтобы при вызове одного компонента другим выполнялись проверки безопасности, эти компоненты должны быть в разных приложениях COM+.

Поскольку библиотечные приложения COM+ работают с другими процессами, существуют границы безопасности между библиотечным приложением и основным процессом. Кроме того, библиотечное приложение не управляет безопасностью на уровне процесса, что влияет на способ настройки безопасности для таких приложений. Более подробную информацию см. в разделе Безопасность библиотечных приложений.

Проверки доступа на уровне компонента

Для серверного приложения COM+ можно выполнять проверку доступа на уровне компонента или на уровне процесса. Если выбрана проверка прав доступа на уровне компонента, можно более тонко настроить роли. Вы можете назначить роли компонентам, интерфейсам и методам и реализовать более четкую политику авторизации. Это стандартная настройка для приложений, где безопасность обеспечивается с помощью ролей. Если вы хотите использовать роли для библиотечных приложений COM+, выбор проверки безопасности на уровне компонента обязателен.

Проверка прав доступа на уровне компонента необходима также в случае, если вы обеспечиваете безопасность с помощью ролей программным путем. Сведения о контексте безопасности для вызовов доступны только в случае, если безопасность обеспечивается на уровне компонента. Кроме того, если права доступа проверяются на уровне компонента, свойство безопасности включается в контекст объекта. Это означает, что настройка безопасности может влиять на то, как активируется объект.

Проверка доступа на уровне процесса

Проверка на уровне процесса выполняется только в пределах одного приложения. То есть роли, которые вы определили для всего приложения COM+, определяют, кто может обращаться к ресурсам этого приложения. Более тонкая настройка ролей не производится. В двух словах, роли используются для создания дескриптора безопасности, с которым сверяются все вызовы компонентов приложения. В этом случае нет необходимости создавать подробную политику авторизации с большим количеством ролей. Приложение использует один дескриптор безопасности.

Для библиотечных приложений COM+ не следует выбирать проверку доступа на уровне процесса. Библиотечное приложение работает в клиентском процессе и поэтому не управляет безопасностью на уровне процесса. Более подробную информацию см. в разделе Безопасность библиотечных приложений.

Если включена проверка доступа на уровне процесса, сведения контекста безопасности для вызовов недоступны. Это означает, что если используется только безопасность на уровне процесса, нельзя обеспечить безопасность программным путем в приложении. Кроме того, свойство безопасности не включено в контекст объекта. Это означает, что если используется только проверка доступа на уровне процесса, настройка безопасности никогда не влияет на то, как активируется объект.

Пошаговые инструкции по настройке уровня безопасности для проверки прав доступа см. в разделе Настройка уровня безопасности для проверки доступа.


Software Restriction Policy

Политика программных ограничений

Правильное использование политики программных ограничений может сделать ваш бизнес более динамичным, так как обеспечивает проактивные меры по предотвращению проблем, а не просто дорогостоящее восстановление системы после отказа. Политика программных ограничений создана для защиты систем от неизвестных и опасных кодов. Данная политика содержит механизм, где единственный доверенный код дает неограниченный доступ к привилегиям пользователя.

Если используется политика программных ограничений, то неизвестный код, который может содержать вирусы или конфликтовать с уже установленным программным обеспечением, может выполняться только в ограниченной среде (так называемой «песочнице»), где ему закрыт доступ к любым привилегиям пользователей, важным с точки зрения безопасности. Например, если вложение в сообщение электронной почты содержит программу-червь, ему запрещен автоматический доступ к адресной книге, и поэтому программа-червь не сможет распространиться. Если вложение сообщения электронной почты содержит вирус, политика программных ограничений ограничит его способность повредить систему, так как вложение не сможет выйти за пределы определенной среды.

Политика программных ограничений основана на присвоении соответствующих уровней доверия коду, который выполняется в системе. В настоящий момент существует два уровня доверия: «Неограниченный» и «Не разрешено». Код с уровнем доверия «Неограниченный» имеет неограниченный доступ к привилегиям пользователя, поэтому этот уровень доверия следует применять только к хорошо известным и безопасным кодам. Код с уровнем доверия «Не разрешено» не имеет доступа к привилегиям пользователя, важным с точки зрения безопасности, и может выполняться только в «песочнице», чтобы код с уровнем доверия «Неограниченный» не мог загрузить код с уровнем доверия «Не разрешено» в свое адресное пространство.

Настройка политики программных ограничений для системы производится в программе администрирования локальной политики безопасности, а политика ограничений для отдельных приложений COM+ устанавливается либо программным путем в самом приложении, либо с помощью программы администрирования служб компонентов Если уровень доверия для приложения COM+ не указан, для его определения используются настройки, заданные на уровне системы.

Настройки политики программных ограничений COM+ необходимо тщательно координировать с настройками для всей системы, поскольку приложение COM+ с уровнем доверия «Неограниченный» может загружать только компоненты с таким же уровнем доверия, в то время как приложение COM+ с уровнем доверия «Не разрешено» может загружать компоненты с любым уровнем доверия, но не имеет доступа к привилегиям пользователя, связанным с безопасностью.

Пошаговые инструкции по настройке политики программных ограничений см. в разделе Настройка политики программных ограничений.


Authentication in COM+

Проверка подлинности в COM+

Проверка подлинности — это процесс проверки подлинности удостоверений и того, что вызывающие – это действительно те, за кого они себя выдают. Обычно это могут делать совместно клиент и сервер, проверяя подлинность друг друга. Но для серверного приложения, выполняющего авторизацию клиентов (например, в случае использования ролей для обеспечения безопасности), очень важно проверять и подлинность клиентов. Проверка подлинности клиентов является необходимым условием эффективной политики авторизации, так как, если есть сомнения в подлинности удостоверения клиента, приложению приходится полагаться на честность.

Для приложений COM+ можно включить и настроить проверку подлинности административным путем, а затем эта функция работает прозрачно. Уровень проверки подлинности устанавливается административным путем с помощью программы служб компонентов или административных функций SDK.

Для серверного приложения COM+ можно выбирать из нескольких уровней проверки подлинности, обеспечивающих разную степень безопасности - от полного отсутствия проверки подлинности до шифрования каждого пакета и всех параметров вызова методов. Высокий уровень безопасности обычно снижает быстродействие системы, что необходимо учитывать при настройке приложения. COM+ выясняет уровни проверки подлинности клиента и сервера и использует наиболее безопасный из этих уровней. Это позволяет административно управлять минимальным уровнем проверки подлинности со стороны сервера.

Примечание. Для приложений COM+ не следует устанавливать уровень проверки подлинности программным образом с использованием CoInitializeSecurity. COM+ вызывает CoInitializeSecurity только один раз за весь процесс.

Для библиотечных приложений COM+ проверка подлинности в основном управляется основным процессом. Однако библиотечное приложение можно настроить таким образом, чтобы оно не участвовало в проверке подлинности. При этом вызовы приложения могут выполняться с проверкой и без проверки подлинности. В последнем случае проверка подлинности клиентов всегда проходит успешно. Дополнительные сведения см. в разделе Безопасность библиотечных приложений.

Сведения об уровнях проверки подлинности см. в разделе Уровень проверки подлинности.

Пошаговые инструкции по настройке проверки подлинности для библиотечных и серверных приложений COM+ см. в разделе Настройка проверки подлинности в COM+.


Impersonation and Delegation in COM+

Олицетворение и использование представителей в COM+

Олицетворением называется ситуация, в которой сервер делает вызовы от имени клиента, указывая при этом удостоверение и учетные данные клиента, а не свои собственные. В некоторых случаях сервер должен предоставить удостоверение клиента, чтобы получить доступ от имени клиента. Обычно это делается, чтобы проверка доступа или подлинности проводилась для удостоверения клиента.

Использование олицетворения позволяет обеспечить выполнение сервером только тех задач, которые могут выполняться клиентом. В зависимости от полномочий конкретного клиента доступ к ресурсам может ограничиваться или расширяться.

Можно сделать так, чтобы при подключении к базе данных сервер олицетворял клиента. В этом случае проверка подлинности и авторизация клиента могут быть выполнены самой базой данных. Или, если приложение обращается к файлам, защищенным дескриптором безопасности, и вы хотите, чтобы клиент мог получить авторизованный доступ только к информации в этих файлах, приложение может олицетворять клиента при обращении к файлам.

Когда приложение COM+ вызывает другое приложение или ресурс, оно указывает уровень олицетворения. Для серверных приложений COM+ можно задать уровень олицетворения административным путем. Библиотечные приложения COM+ не могут задавать свой собственный уровень олицетворения. Они используют уровень олицетворения основного процесса.

Условия олицетворения на уровне представительства

Выступление в качестве представителя — это олицетворение клиента сервером в сети. Это означает, что приложение-сервер использует удостоверение и права клиента при вызове других приложений, выполняющихся на удаленных компьютерах. Поскольку выступление в качестве представителя предоставляет приложению наиболее широкие полномочия и потому связано с риском нарушения безопасности, существует возможность администрирования представителей с помощью службы Active Directory. Чтобы клиентское приложение могло сделать сервер своим представителем в сети, необходимо соблюдение двух условий.

  • Серверное приложение должно выполняться с удостоверением, помеченным в Active Directory как «Доверенный представитель».

  • Клиентское приложение должно выполняться с удостоверением, не имеющим пометки «Учетная запись не допускает представителей» в Active Directory.

Описание уровней олицетворения см. в разделе Уровень олицетворения.

Пошаговые инструкции по установке уровня олицетворения серверных приложений COM+ см. в разделе Настройка уровня олицетворения в COM+.

Пошаговые инструкции по настройке использования представителей в Active Directory см. в разделе Использование Active Directory для настройки учетной записи для делегирования.


Application Identity

Удостоверение приложения

Удостоверение приложения — это учетная запись пользователя, которая используется для идентификации приложения во время выполнения. При установке серверного приложения COM+, т.е. приложения, которое выполняется внутри собственного пространства процесса, для него требуется задать удостоверение, с которым это приложение выполняется. Удостоверение может быть присвоено взаимодействующему пользователю (это любой пользователь зарегистрировавшийся на компьютере, на котором выполняется данное приложение), пользователю локальной службы (учетная запись, предоставляющая минимальные полномочия на запуск доступной локально службы), пользователю сетевой службы (учетная запись, обеспечивающая полномочия пользователя локальной службы, а также доступ по сети) или определенной учетной записи пользователя (для чего требуется указать действительный пароль для этой учетной записи). Задавать удостоверения для библиотечных приложений COM+ не требуется, так как они всегда выполняются в пространстве основного процесса с удостоверением клиента.

Удостоверение определяет контекст безопасности для вызовов, посылаемых приложением во время выполнения. Когда приложение вызывает другое приложение, оно использует свое удостоверение (за исключением случая, когда оно олицетворяет клиента и производит вызовы от имени клиента). Приложение, получившее вызов, использует удостоверение вызывающего приложения для выполнения собственной проверки безопасности вызова.

Какое удостоверение предоставить

Удостоверение конкретного пользователя обычно дает больше возможностей, чем удостоверение взаимодействующего пользователя. Если используется удостоверение конкретного пользователя, сервер будет работать даже в случае, если на компьютере, где выполняется приложение, не зарегистрирован ни один пользователь.

Удостоверение конкретного пользователя обеспечивает более высокий уровень безопасности, чем удостоверение взаимодействующего пользователя, так как, чтобы назначить его приложению, необходимо указать пароль этого пользователя. Использование удостоверения взаимодействующего пользователя связано и с другими рисками для безопасности, потому что приложение будет выполняться с удостоверением подключенного пользователя без его разрешения или ведома. Например, если приложение работает на компьютере в то время, когда в системе находится администратор, оно работает с удостоверением администратора и может делать вызовы от лица клиентов.

Если приложению не нужен доступ к личным файлам конкретного пользователя, то самым безопасным вариантом обычно является работа под локальной учетной записью или учетной записью сетевой службы, поскольку эти учетные записи предоставляют еще меньше разрешений, чем даже учетные записи пользователей.

Если используется удостоверение взаимодействующего пользователя, то приложение будет выполняться только в том случае, если на компьютере зарегистрирован какой-то пользователь. С другой стороны, только удостоверение взаимодействующего пользователя позволяет клиенту видеть графический интерфейс пользователя (ГИП), предоставляемый приложением.

Условия использования представителей

Если вы задаете удостоверение для приложения COM+, которое должно быть в состоянии выступать в качестве представителя от имени клиентов, и выбираете удостоверение конкретного пользователя, это должен быть пользователь домена с пометкой «Доверенный представитель» в учетной записи. Если используется удостоверение взаимодействующего пользователя, то любой пользователь, который может войти в систему, должен быть доверенным представителем.

Если удостоверение приложения не имеет пометки «Доверенный представитель», любая его попытка олицетворять клиента в сети завершится сбоем вызова.

Общие сведения об олицетворении и представительстве в COM+ см. в разделе Олицетворение и использование представителей в COM+.

Пошаговые инструкции по настройке удостоверений см. в разделе Настройка удостоверения приложения.


Library Application Security

Безопасность библиотечного приложения

Поскольку библиотечное приложение COM+ работает в другом процессе, у которого могут быть свои настройки безопасности, вопрос обеспечения безопасности библиотечного приложения требует особого рассмотрения. Ниже указаны ограничения, связанные с безопасностью библиотечного приложения.

  • Библиотечные приложения выполняются с дескриптором безопасности основного процесса, а не со своим собственным удостоверением пользователя. Они имеют только те привилегии, которые есть у основного процесса.

  • Библиотечные приложения не управляют безопасностью на уровне процесса. Никакие пользователи с ролями не добавляются в дескриптор безопасности для процесса. Единственный способ для библиотечного приложения сделать собственные проверки прав доступа – это использовать средства безопасности на уровне компонента.

  • Включая или отключая проверку подлинности, можно сделать так, чтобы библиотечное приложение участвовало или не участвовало в проверке подлинности в основном процессе.

  • Библиотечные приложения COM+ не могут задавать свой собственный уровень олицетворения. Они используют уровень олицетворения основного процесса.

Использование библиотечных приложений для ограничения привилегий приложения

Иногда приложение специально настраивается как библиотечное, чтобы оно выполнялось с удостоверением основного процесса. Это существенно ограничивает возможности приложения, так как в этом случае оно может обращаться только к тем ресурсам, к которым имеет доступ его клиент (основной процесс). Потоки, которые запускают компоненты библиотечного приложения, по умолчанию используют дескриптор процесса, поэтому, когда они делают вызовы за границы приложения или обращаются к таким ресурсам, как файлы, защищенные дескриптором безопасности, они оказываются клиентами. Для приложений, выполняющих операции с важными данными, это может быть простым способом управления областью их действий.

Принудительная проверка роли

Для безопасности важно и то, использует ли библиотечное приложение безопасность на основе ролей. Если механизм ролей используется, то для проверки доступа необходимо использовать безопасность на основе компонента. Роли, назначенные библиотечному приложению, не отражаются в дескрипторе безопасности процесса. Единственным способом авторизации, которым может управлять библиотечное приложение, является авторизация на уровне компонента.

Более подробную информацию о компоненте см. в разделе Уровни безопасности для проверки доступа.

Пошаговые инструкции по настройке безопасности на уровне компонента см. в разделе Настройка уровня безопасности для проверки доступа.

Включение и отключение проверки подлинности

Необходимо также решить, будут ли проверяться входящие вызовы библиотечного приложения на уровне основного процесса и, соответственно, включать или отключать проверку подлинности.

Например, если доступ к библиотечному приложению происходит из обозревателя, возможно, ему придется принимать обратные вызовы без проверки подлинности. Для этого необходимо отключить проверку подлинности, чтобы основной процесс не выполнял проверку вызовов библиотечного приложения. Если проверка подлинности отключена, библиотечное приложение фактически работает без проверки подлинности и все вызовы к нему успешны. При вызовах библиотечного приложения проверка безопасности на уровне основного процесса не выполняется. В двух словах, библиотечное приложение помечается как не требующее проверки подлинности, и проверка безопасности при вызове этого приложения не производится.

Сведения о проверке подлинности в COM+ см. в разделе Проверка подлинности в COM+.

Пошаговые инструкции по включению и отключению проверки подлинности в библиотечных приложениях COM+ см. в разделе Включение проверки подлинности для библиотечного приложения.


Security Administration Tasks

Задачи администрирования безопасности

В следующих разделах описываются задачи администрирования безопасности, которые можно выполнить с помощью программы администрирования служб компонентов.

  • Управление ролями пользователей

  • Настройка уровня безопасности для проверки доступа

  • Настройка политики программных ограничений

  • Настройка проверки подлинности в COM+

  • Настройка уровня олицетворения в COM+

  • Настройка удостоверения приложения

Общие сведения об этих задачах см. в разделе Основные понятия администрирования безопасности.


Managing Users in Roles

Управление пользователями для ролей

Большая часть задач администрирования по настройке безопасности для приложений COM+ включает назначение стандартных ролей пользователям при установке приложения и в процессе его использования. Дополнительные сведения об использовании этих средств безопасности см. в разделе Безопасность на основе ролей.

В данном документе содержатся пошаговые инструкции по выполнению следующих задач.

  • Включение авторизации на основе ролей

  • Назначение учетной записи пользователя или группы на роль

  • Удаление учетной записи пользователя или группы из роли

  • Перемещение учетной записи пользователя или группы в другую роль


Enabling Role-Based Authorization Checking

Включение авторизации на основе ролей

Для обеспечения в приложении COM+ безопасности на основе ролей необходимо включить для данного приложения авторизацию на основе ролей. Это позволяет гарантировать, что пользователь, обращающийся к приложению, будет проверен на принадлежность роли до того, как он сможет выполнить какую-либо операцию в данном приложении. Если авторизация на основе ролей отключена, то безопасность на основе ролей для данного приложения не используется.

Для включения авторизации на основе ролей выполните следующие действия.

  1. Щелкните правой кнопкой мыши на приложении COM+, для которого требуется включить авторизацию на основе ролей, и выберите в контекстном меню пункт Свойства.

  2. В диалоговом окне свойств перейдите на вкладку Безопасность.

  3. В группе Авторизация установите флажок Принудительная проверка прав доступа для приложения. Отмена выбора этого флажка означает, что обеспечение безопасности на основе ролей для данного приложения не выполняется.

  4. Нажмите кнопку ОК.

Выбранный режим авторизации будет включен при следующем запуске приложения.


Assigning a User Account or Group to a Role

Назначение учетной записи пользователя или группы на роль

Назначение ролей группам и учетным записям пользователей производится с помощью программы администрирования служб компонентов. Оптимальным способом назначения учетной записи пользователя на роль считается добавление учетной записи пользователя в группу Microsoft® Windows® с последующим назначением группы на эту роль. Использование групп Windows для назначения ролей упрощает управление большим количеством пользователей. Для получения дополнительных сведений о создании групп Windows и добавлении учетной записи пользователя в группу Windows обратитесь к интерактивной справке программы управления компьютером (раздел "Локальные пользователи и группы").

Примечание. Чтобы сетевые пользователи могли запускать приложение COM+ без аутентификации, список ролей приложения должен включить «Анонимного» пользователя. По умолчанию в Windows Server 2003 группа «Все» не включает «Анонимного» пользователя.

После включения учетной записи пользователя в подходящую группу Windows выполните описанные ниже действия для назначения группы Windows на роль.

Для назначения группы Windows на роль безопасности выполните следующие действия.

  1. В дереве консоли программы служб компонентов выберите приложение COM+, содержащее роль, к которой необходимо добавить запись пользователя или группу. Разверните представление дерева консоли так, чтобы были видны роли приложения.

  2. Найдите роль, к которой требуется добавить учетную запись пользователя или группу.

    Примечание. Отсутствие требуемой роли в папке Роли означает, что эта роль не задана для выбранного приложения. Для назначения учетных записей пользователей на эту роль необходимо, чтобы разработчик добавил ее в приложение.

  3. Щелкните правой кнопкой мыши папку Пользователи и в меню Создать выберите команду Пользователь.

  4. В диалоговом окне Выбор пользователей и групп введите в нижней области полное имя пользователя или группы, которую требуется добавить. Если имя неизвестно, нажмите кнопку Дополнительно, а затем кнопку Найти для просмотра списка пользователей и групп в выбранном домене. Выберите пользователя или группу в списке Имя (RDN) и нажмите кнопку OK.

  5. Для добавления других групп и учетных записей пользователей повторите шаг 4.

  6. После завершения назначения групп и учетных записей пользователей на роль нажмите кнопку ОК.

Каждой учетной записи пользователя или группе, назначенной на роль, соответствует значок в папке Пользователи. Вновь назначенные роли вступают в действие при следующем запуске приложения.


Removing a User Account or Group from a Role

Удаление учетной записи пользователя или группы из роли

Чтобы запретить отдельным пользователям или членам групп доступ к ресурсам приложения, связанным с определенными ролями, удалите учетные записи этих пользователей или группы из роли.

Для удаления учетной записи пользователя или группы из роли выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов найдите приложение COM+, содержащее требуемую роль. Разверните представление дерева консоли так, чтобы были видны пользователи, назначенные на эту роль.

  2. Щелкните правой кнопкой мыши на учетной записи пользователя или на группе, которую требуется удалить, и выберите команду Удалить.

  3. При выводе запроса в диалоговом окне Подтверждение удаления элемента нажмите кнопку Да для удаления выбранного пользователя или группы.

Учетные записи пользователей и группы, удаленные из роли, перестанут отображаться в папке Пользователи. Вновь назначенные роли вступают в действие при следующем запуске приложения. После выполнения изменений в Системном приложении следует перезагрузить компьютер, чтобы эти изменения вступили в силу.


Moving a User Account or Group to a Different Role

Перемещение учетной записи пользователя или группы в другую роль

В случае изменения привилегий пользователя или добавления новых ролей в приложение может понадобиться переместить учетную запись из одной роли в другую. Для перемещения учетной записи пользователя или группы пользователей из одной роли в другую необходимо удалить эту учетную запись или группу из текущей роли и назначить ее на новую роль.

Для перемещения учетной записи пользователя или группы из одной роли в другую выполните следующие действия.

  1. Удалите учетную запись пользователя или группу из прежней роли.
    1. В дереве консоли программы администрирования служб компонентов найдите приложение COM+, содержащее требуемую роль. Разверните представление дерева консоли так, чтобы были видны пользователи, назначенные на эту роль.

    2. Щелкните правой кнопкой мыши на учетной записи пользователя или на группе, которую требуется удалить, и выберите команду Удалить.

    3. В ответ на запрос в диалоговом окне Подтверждение удаления элемента нажмите кнопку Да для удаления выбранного пользователя или группы.

    Учетные записи пользователей и группы, удаленные из роли, перестанут отображаться в папке Пользователи.

  2. Назначьте учетную запись пользователя или группу, удаленную из роли, на требуемые новые роли.
    1. В дереве консоли программы служб компонентов выберите приложение COM+, содержащее роль, к которой необходимо добавить запись пользователя или группу. Разверните представление дерева консоли так, чтобы были видны роли приложения.

    2. Найдите роль, к которой требуется добавить учетную запись пользователя или группу.

      Примечание. Отсутствие требуемой роли в папке Роли означает, что эта роль не определена для выбранного приложения. Для назначения учетных записей пользователей на эту роль необходимо, чтобы разработчик добавил ее в приложение.

    3. Щелкните правой кнопкой мыши папку Пользователи в роли и выберите в меню Создать команду Пользователь.

    4. В диалоговом окне Выбор пользователей и групп введите в нижней области полное имя пользователя или группы, которую требуется добавить. Если имя неизвестно, нажмите кнопку Дополнительно, а затем кнопку Найти для просмотра списка пользователей и групп в выбранном домене. Выберите пользователя или группу в списке Имя (RDN) и нажмите кнопку OK.

    5. После завершения назначения группы или учетной записи пользователя на роль нажмите кнопку OK.

    Каждой учетной записи пользователя или группе, назначенной на роль, соответствует значок в папке Пользователи.

Изменение роли для учетной записи пользователя или группы вступает в силу при следующем запуске приложения.


Setting a Security Level for Access Checks

Настройка уровня безопасности для проверки доступа

После включения авторизации на основе ролей для приложения COM+ необходимо выбрать уровень, на котором должна производиться проверка доступа. Общие сведения об уровнях безопасности см. в разделе Уровни безопасности для проверки доступа.

Для выбора уровня безопасности выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на приложении COM+, для которого требуется указать уровень безопасности, и выберите пункт Свойства.

  2. В диалоговом окне свойств перейдите на вкладку Безопасность.

  3. В группе Уровень безопасности выберите один из следующих параметров.
    • Проверка доступа только на уровне процесса При выборе этого параметра пользователи в ролях, которые назначены данному приложению, добавляются в дескриптор безопасности процесса. Данный параметр оказывает влияние на следующие действия.

      Точная проверка роли отключается на уровне компонента, метода и интерфейса. Проверка безопасности выполняется только на уровне приложения.

      Свойства безопасности не включаются в контекст объектов, выполняющихся в данном приложении. Таким образом безопасность никогда не влияет на способ активизации объекта.

      Контекст безопасности для вызовов недоступен. Не работает программная безопасность, которая основывается на сведениях о контексте безопасности для вызовов.

    • Проверка доступа на уровне процесса и компонента При выборе этого параметра выполняется проверка с использованием дескриптора безопасности на уровне процесса и полная проверка безопасности на основе ролей. Данный параметр оказывает влияние на следующие действия.

      Для включения проверки роли для конкретных компонентов необходимо включить проверку доступа на уровне компонента.

      Свойства безопасности включаются в контекст любого объекта, выполняющегося в данном приложении. Если настройки объекта несовместимы с контекстом создателя, то он активизируется в своем контексте.

      Контекст безопасности для вызовов доступен. Включена программная безопасность на основе ролей.

      Примечание. Для обеспечения проверки доступа для библиотечных приложений COM+ необходимо выбрать проверку доступа на уровне процесса и компонента. Для проверки безопасности на уровне процесса библиотечные приложения основываются на основном процессе.

  4. Нажмите кнопку ОК.

При следующем запуске приложения безопасность автоматически проверяется на указанном уровне и только пользователи, назначенные на роль для данного приложения, получают доступ к этому приложению.


Configuring the Software Restriction Policy

Настройка политики программных ограничений

Если явно указаны уровни доверия программных ограничений для приложения COM+, то они перекрывают политику программных ограничений, установленную по умолчанию для всей системы. Это необходимо для серверных приложений COM+, так как по умолчанию устанавливается одинаковая политика программных ограничений для всех серверных приложений (поскольку все они запускаются в одном файле — dllhost.exe).

Примечание. Если устанавливается уровень доверия для библиотечного приложения COM+, то это оказывает действие на системную политику программных ограничений для данного приложения. Общие сведения об использовании политики программных ограничений в COM+ см. в разделе Политика программных ограничений.

Для настройки политики программных ограничений выполните следующие действия.

  1. Щелкните правой кнопкой мыши на приложении COM+, для которого требуется настроить политику ограничений, и выберите в контекстном меню пункт Свойства.

  2. В диалоговом окне свойств перейдите на вкладку Безопасность.

  3. Для включения настройки уровня доверия в группе Политика программных ограничений установите флажок Применить политику программных ограничений. Отмена выбора данного флажка означает использование приложением общей для всей системы политики программных ограничений.

  4. В поле Уровень ограничений выберите соответствующий уровень. Доступные уровни описаны ниже в порядке от наименее к наиболее доверенному.
    • Не разрешено Приложение не может использовать все привилегии пользователя. В него могут быть загружены любые компоненты с любым уровнем доверия политики ограничений.

    • Неограниченный Приложение имеет неограниченный доступ к привилегиям пользователя. В него могут быть загружены только компоненты с уровнем доверия "Неограниченный".
  5. Нажмите кнопку ОК.

Выбранный уровень доверия вступает в действие при следующем запуске приложения.


Setting Authentication in COM+

Настройка проверки подлинности в COM+

В COM+ настройки и действия проверки подлинности зависят от того, выполняется ли работа с серверным или с библиотечным приложением.

Для серверных приложений COM+ уровень проверки подлинности определят то, как выполняется проверка при вызове клиентами компонентов в приложении. Дополнительные сведения см. в разделе Настройка уровня проверки подлинности для серверного приложения.

Для библиотечных приложений COM+ можно включить или отключить проверку подлинности, чтобы указать, будет ли выполняться проверка подлинности приложения основным процессом. Дополнительные сведения см. в разделе Включение проверки подлинности для библиотечного приложения.

Обзор средств проверки подлинности в COM+ см. в разделе Проверка подлинности в COM+.


Setting an Authentication Level for a Server Application

Настройка уровня проверки подлинности для серверного приложения

При настройке уровня проверки подлинности для приложения необходимо указать степень проверки при вызове клиентом приложения. Повышение уровня проверки подлинности обеспечивает большую безопасность и целостность данных, однако обычно несколько снижает производительность. Обзор средств проверки подлинности в COM+ см. в разделе Проверка подлинности в COM+.

Для выбора уровня проверки подлинности для серверного приложения выполните следующие действия.

  1. Щелкните правой кнопкой мыши на серверном приложении COM+, для которого требуется настроить проверку подлинности, и выберите в контекстном меню пункт Свойства.

  2. В диалоговом окне свойств перейдите на вкладку Безопасность.

  3. В поле Уровень проверки подлинности для вызовов выберите соответствующий уровень. Ниже перечислены допустимые уровни проверки подлинности в порядке повышения безопасности.
    • Нет Проверка подлинности не выполняется.

    • Подключение Проверка подлинности выполняется только при установлении подключения.

    • Вызов Проверка подлинности выполняется в начале каждого вызова.

    • Пакет Выполняется проверка подлинности пакета и проверяется, что все данные вызова получены. Для серверных приложений COM+ этот параметр устанавливается по умолчанию.

    • Целостность пакетов Выполняется проверка подлинности пакета и проверяется, что никакие данные не были изменены при передаче.

    • Секретность пакетов Выполняется проверка подлинности пакета и его шифрование, включая данные, а также удостоверение и подпись отправителя.
  4. Нажмите кнопку ОК.

Выбранный уровень проверки подлинности вступает в силу при следующем запуске приложения.


Enabling Authentication for a Library Application

Включение проверки подлинности для библиотечного приложения

Требования безопасности для библиотечных приложений отличаются от серверных, поскольку библиотечные приложения COM+ управляются другими процессами. Если доступ к библиотечному приложению происходит из обозревателя, то необходимо осуществлять обратные вызовы без проверки подлинности.

Для этого необходимо отключить проверку подлинности, чтобы основной процесс не выполнял проверку вызовов библиотечного приложения. При отключении проверки подлинности библиотечное приложение завершает проверку подлинности, и все вызовы данного приложения будут успешными. Дополнительные сведения см. в разделе Безопасность библиотечного процесса. Обзор средств проверки подлинности в COM+ см. в разделе Проверка подлинности в COM+.

Для включения (отключения) проверки подлинности для библиотечного приложения выполните следующие действия.

  1. Щелкните правой кнопкой мыши на библиотечном приложении COM+, для которого требуется включить (отключить) проверку подлинности, и выберите в контекстном меню пункт Свойства.

  2. В диалоговом окне свойств перейдите на вкладку Безопасность.

  3. В группе Проверка подлинности установите флажок Включить проверку подлинности для включения проверки подлинности, отмена выбора этого флажка отключает проверку подлинности.

  4. Нажмите кнопку ОК.

Выбранный параметр проверки подлинности вступает в действие при следующем запуске приложения.


Setting an Impersonation Level in COM+

Настройка уровня олицетворения в COM+

При настройке уровня олицетворения для приложения определяются полномочия, которые приложение предоставляет другим приложениям для использования их удостоверений при вызовах. Уровень олицетворения можно настроить только для серверных приложений COM+. Библиотечные приложения выполняются с удостоверением основного процесса и используют уровень олицетворения, указанный в данном процессе. Общие сведения об олицетворении в COM+ см. в разделе Олицетворение и использование представителей в COM+.

Для выбора уровня олицетворения для серверного приложения выполните следующие действия.

  1. Щелкните правой кнопкой мыши на серверном приложении COM+, для которого требуется настроить олицетворение, и выберите в контекстном меню пункт Свойства.

  2. В диалоговом окне свойств перейдите на вкладку Безопасность.

  3. В поле Уровень олицетворения выберите соответствующий уровень. Ниже перечислены допустимые уровни олицетворения в порядке расширения прав.
    • Анонимное Клиент является анонимным для сервера. Сервер может выступать от имени клиента, однако дескриптор олицетворения (локальные учетные данные) не содержит никаких сведений о клиенте.

    • Идентификация Сервер может получить удостоверение клиента и выступать от его имени при проверке по спискам управления доступом.

    • Олицетворение Для серверных приложений COM+ этот параметр устанавливается по умолчанию. Сервер может выступать от имени клиента со следующими ограничениями. Сервер получает доступ ко всем ресурсам на компьютере клиента. Если сервер выполняется на том же компьютере, что и клиент, он получает доступ к сетевым ресурсам от лица клиента. Если сервер выполняется на другом компьютере, он получает доступ только к ресурсам, расположенным на компьютере сервера.

    • Представитель Сервер может выступать от имени клиента независимо от того, выполняется ли он на одном или на разных компьютерах с клиентом. При олицетворении все учетные данные клиента (и локальные, и сетевые) могут быть переданы на любое число компьютеров.
  4. Нажмите кнопку ОК.

Выбранный уровень олицетворения вступает в действие при следующем запуске приложения.

Сведения о настройке учетной записи пользователя для работы с уровнем олицетворения для представителя см. в разделе Использование Active Directory для настройки учетной записи для делегирования.


Configuring an Account for Delegation Using Active Directory

Использование Active Directory для настройки учетной записи для делегирования

Поскольку выступление в качестве представителя предоставляет приложению наиболее широкие полномочия и потому связано с риском нарушения безопасности, существует возможность администрирования представителей с помощью службы Active Directory. Чтобы клиентское приложение могло сделать сервер своим представителем в сети, необходимо соблюдение двух условий:

  • Серверное приложение должно выполняться с удостоверением, помеченным в Active Directory как «Доверенный представитель».

  • Клиентское приложение должно выполняться с удостоверением, не имеющим пометки «Учетная запись не допускает представителей» в Active Directory.

Для настройки учетной записи пользователя для делегирования выполните следующие действия.

  1. На сервере, который вы назначили контроллером домена, щелкните на программе администрирования «Active Directory — пользователи и компьютеры».

  2. В требуемом домене откройте папку Пользователи.

  3. Щелкните правой кнопкой мыши на учетной записи, для которой требуется разрешить использование делегирования, и выберите в контекстном меню пункт Свойства.

  4. Откройте вкладку Учетная запись.

  5. Если требуется разрешить использование данной учетной записи в качестве удостоверения сервера, использующего уровень олицетворения для представителя, установите в группе Параметры учетной записи флажок Учетная запись доверена для делегирования.

  6. Если требуется разрешить использование данной учетной записи в качестве удостоверения клиента, использующего уровень олицетворения для представителя, отмените выбор флажка Учетная запись не допускает представителей в группе Параметры учетной записи.

  7. Нажмите кнопку ОК.

Новые настройки учетной записи вступают в действие после следующего обновления схемы Active Directory (если нет неполадок в сети, то это происходит в течение 5 минут).

Если серверный процесс запущен под системной учетной записью, то учетной записью участника является учетная запись компьютера в Active Directory. В этом случае необходимо установить, чтобы учетная запись компьютера использовала представителей.

Для настройки учетной записи компьютера для делегирования выполните следующие действия.

  1. На сервере, который вы назначили контроллером домена, щелкните на программе администрирования «Active Directory — пользователи и компьютеры».

  2. В требуемом домене откройте папку Компьютеры.

  3. Щелкните правой кнопкой мыши на учетной записи, для которой требуется разрешить использование делегирования, и выберите в контекстном меню пункт Свойства.

  4. На вкладке Общие установите флажок Доверять компьютеру делегирование.

  5. Нажмите кнопку OK.

Новые настройки учетной записи вступают в действие после следующего обновления схемы Active Directory (если нет неполадок в сети, то это происходит в течение 5 минут).

Дополнительные сведения по включению делегирования в Active Directory см. в справочной системе по "Active Directory — пользователи и компьютеры".

Пошаговые инструкции по установке уровня олицетворения серверных приложений COM+ см. в разделе Настройка уровня олицетворения в COM+.


Setting Application Identity

Настройка удостоверения приложения

Программа администрирования служб компонентов позволяет задать удостоверение для серверного приложения COM+. (Для библиотечного приложения COM+ в качестве удостоверения всегда используется удостоверение главного процесса.) При задании удостоверения приложения можно указать учетную запись определенного пользователя с действующим паролем или выбрать параметр Взаимодействующий пользователь. Эта учетная запись пользователя используется для идентификации приложения во время выполнения, а также при обращении к другим приложениям и ресурсам. Обзор удостоверений приложений см. в разделе Удостоверение приложения.

Для задания удостоверения серверного приложения COM+ выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на приложении COM+, для которого требуется задать удостоверение, и выберите пункт Свойства.

  2. В диалоговом окне свойств перейдите на вкладку Удостоверение.

  3. В группе Учетная запись выберите один из следующих параметров.
    • Чтобы серверу присваивалось удостоверение пользователя, зарегистрированного на данном компьютере, выберите параметр Текущий (вошедший в систему) пользователь.

    • Чтобы указать, что сервер должен работать с удостоверением локальной службы, выберите параметр Локальная служба - встроенная учетная запись службы.

    • Чтобы указать, что сервер должен работать с удостоверением сетевой службы, выберите параметр Сетевая служба – встроенная учетная запись службы с доступом в сеть.

    • Чтобы присвоить серверу удостоверение определенного пользователя, выберите параметр Указанный пользователь, а затем введите имя пользователя, пароль и подтверждение пароля. Если полное имя пользователя неизвестно, нажмите кнопку Обзор для его поиска. В диалоговом окне Выбора пользователей нажмите кнопку Дополнительно, а затем для просмотра списка всех пользователей и групп в выбранном домене нажмите кнопку Поиск. Выберите пользователя или группу в списке Имя (RDN) и нажмите кнопку OK.
  4. Нажмите кнопку ОК.

Выбранное удостоверение вступает в действие при следующем запуске приложения.


Administering COM+ Partitions

Администрирование разделов COM+

Использование разделов COM+ позволяет устанавливать и одновременно использовать несколько конфигураций приложения на одном компьютере. С помощью программы администрирования служб компонентов можно создать и настроить разделы на локальном компьютере, а затем установить в данные разделы приложения COM+ с определенными конфигурациями.

Примечание. Для просмотра разделов COM+ и управления ими с помощью программы администрирования служб компонентов установите флажок проверки Включить разделы на вкладке Параметры страницы Свойства компьютера.

Разделы, описанные в следующей таблице, содержат основные понятия, связанные с разделами COM+, и сведения по использованию программы служб компонентов для создания и управления разделами и наборами разделов COM+.

Раздел | Описание
Основные понятия администрирования разделов COM+ | Подробные сведения о разделах COM+ и сведения, относящиеся к созданию и управлению разделами и наборами разделов COM+.
Задачи администрирования разделов COM+ | Пошаговые инструкции по созданию и управлению разделами и наборами разделов COM+.


COM+ Partition Administration Concepts

Основные понятия администрирования разделов COM+

В некоторых сетях требуется одновременно использовать различные конфигурации приложений. Например, компании может потребоваться использовать учебную конфигурацию приложения одновременно с конфигурациями для тестирования и разработки. Учебная конфигурация позволит пользователям хорошо изучить приложение, в то время как продолжается разработка и тестирование приложения.

Запуск каждой конфигурации приложения на отдельном компьютере не эффективен, поскольку повышает стоимость оборудования и увеличивает затраты на администрирование. В COM+ эта проблема решается с помощью создания разделов. Использование разделов COM+ позволяет устанавливать и одновременно использовать несколько конфигураций приложений COM+ на одном компьютере.

Администраторы должны уметь работать с разделами COM+, поскольку они предоставляют большие преимущества пользователям в домене. Кроме того, программисты могут использовать разделы COM+ для проверки того, что их приложения выполняются нужным образом в среде с разделением на разделы.

Следующие подразделы этого раздела содержат подробные сведения о разделах COM+ и их использовании:

  • Что такое разделы COM+?

  • Основной сценарий использования разделов COM+

  • Обзор администрирования разделов COM+


What Are COM+ Partitions?

Что такое разделы COM+?

Раздел COM+ представляет собой логический контейнер, с помощью которого различные конфигурации приложения могут выполняться независимо. Каждая конфигурация приложения устанавливается в отдельный раздел и может быть настроена и управляться в соответствии с потребностями ее пользователей. Например, поставщик услуг приложения может устанавливать различные конфигурации приложения для каждого поддерживаемого пользователя и управлять этими конфигурациями.

Примечание. Для просмотра разделов COM+ и управления ими с помощью программы администрирования служб компонентов установите флажок проверки Включить разделы на вкладке Параметры страницы Свойства компьютера.

Использование разделов COM+ обеспечивает следующие преимущества:

  • Организации могут снизить суммарную стоимость оборудования за счет использования меньшего числа серверов приложений для поддержки пользователей, которым требуется несколько версий приложения с различными настройками.

  • Уменьшаются расходы по администрированию. Вместо настройки и управления несколькими компьютерами администратор настраивает и управляет несколькими разделами одного компьютера. Кроме того, разделами можно управлять с помощью программных средств путем добавления нового программного интерфейса COM+.

  • Для локальных пользователей, пользователей домена и подразделений безопасность можно внедрить и использовать на уровне раздела.

  • Для управления разделами программисты и администраторы могут использовать средства разработки и администрирования Майкрософт, такие как SDK платформы, “Active Directory — пользователи и компьютеры” и программа администрирования служб компонентов.


Primary Usage Scenario for COM+ Partitions

Основной сценарий использования разделов COM+

Основной причиной использования разделов COM+ является размещение веб-приложений. В свою очередь, веб-страница, которую посещает пользователь, может обращаться к поставщику услуг приложения, который активизирует компоненты COM+. Каждая активизация компонента должна быть сопоставлена с разделом.

Примечание. Для просмотра разделов COM+ и управления ими с помощью программы администрирования служб компонентов установите флажок проверки Включить разделы на вкладке Параметры страницы Свойства компьютера.

Например, компания разрабатывает для персонала больницы приложение COM+. Распределенное приложение является веб-приложением. С его помощью можно хранить и вызывать истории болезни пациентов, используя базу данных SQL.

Предположим, что у компании-разработчика есть три клиента: больница А, больница Б и больница В. Каждая больница запускает на своем локальном компьютере клиентскую часть приложения COM+, а серверная часть приложения COM+ находится на веб-сервере компании-разработчика. С компьютера-клиента можно получить доступ к серверу через Интернет.

Поскольку для каждой больницы существует свой набор хранилищ, требования и набор историй болезней, то компания-разработчик на своем веб-сервере должна обеспечить различные конфигурации серверной части приложения для каждого клиентского подключения. Как показывает следующий пример, разделы COM+ решают эту проблему.


Administration Overview for COM+ Partitions

Обзор администрирования разделов COM+

Основной способ развертывания и администрирования разделов COM+ — это способ развертывания и администрирования на уровне домена. Для этого необходимо создать общие для всего домена разделы COM+ в Active Directory и сделать их доступными для нескольких пользователей домена. Можно создавать общие для домена разделы COM+, объединять их в наборы, сопоставлять пользователей домена и организационные подразделения с этими наборами разделов, используя “Active Directory — пользователи и компьютеры” и программу администрирования служб компонентов. Затем с помощью программы администрирования служб компонентов можно сопоставить разделы COM+ на сервере приложений с общими для домена разделами COM+, созданными в Active Directory.

Примечание. Для просмотра разделов COM+ и управления ими с помощью программы администрирования служб компонентов установите флажок проверки Включить разделы на вкладке Параметры страницы Свойства компьютера.

Все административные задачи раздела COM+ могут выполняться либо с помощью программы администрирования служб компонентов или средства администрирования “Active Directory — пользователи и компьютеры”, либо программно. Ниже приведены некоторые часто встречающиеся задачи по администрированию разделов COM+.

  • Создание общих для домена разделов COM+ и наборов разделов в Active Directory.

  • Сопоставление пользователей и подразделений в домене набору разделов в Active Directory.

  • Создание разделов COM+ на сервере приложений для локальных пользователей и пользователей домена.

  • Назначение пользователям разделов COM+ по умолчанию.

  • Назначение пользователям ролей безопасности разделов COM+.

  • Объединение приложений в разделы COM+.

Следующие подразделы этого раздела разъясняют ключевые понятия, которыми следует владеть для администрирования разделов COM+:

  • Базовый раздел приложения

  • Разделы COM+ и Active Directory

  • Разделы COM+ по умолчанию

  • Локальные разделы COM+

  • Свойства разделов

  • Безопасность раздела


The Base Application Partition

Базовый раздел приложения

Кроме разделов, создаваемых администраторами, на каждом компьютере существует специальный раздел — базовый раздел приложения. Базовый раздел приложения содержит общие для всей системы компоненты приложений COM+, которые должны быть доступны всем пользователям в домене. При установке компонента приложения в базовый раздел приложения не требуется устанавливать копию компонента в каждый раздел COM+, в котором этот компонент используется.

Примечание. Для просмотра разделов COM+ и управления ими с помощью программы администрирования служб компонентов установите флажок проверки Включить разделы на вкладке Параметры страницы Свойства компьютера.

Если пользовательский раздел COM+ по умолчанию или текущий раздел не содержит компонент приложения, к которому пользователь хочет получить доступ, но этот компонент установлен в базовом разделе приложения, то компонент будет активизирован из базового раздела приложения.


COM+ Partitions and Active Directory

Разделы COM+ и Active Directory

Создаваемые в Active Directory наборы разделов позволяют пользователям домена получать доступ к разделам COM+ в пределах всего домена. Отдельные пользователи и организационные единицы приписываются к определенным наборам разделов. Затем в этот набор разделов можно добавлять общие для всего домена разделы COM+, к которым пользователю или организационному подразделению требуется иметь доступ.

Один пользователь или одно подразделение может иметь доступ к нескольким разделам COM+ или к их приложениям, поскольку между пользователем или подразделением и набором разделов существует однозначное соответствие. Без использования набора разделов пользователю или подразделению для доступа к приложениям, находящимся в разных разделах COM+, потребовалось бы иметь несколько удостоверений пользователя.

Чтобы приложение COM+ было доступно пользователям домена, администратор должен выполнить соответствующие действия как с контроллером домена, где расположена служба Active Directory, так и на сервере, где установлено приложение COM+.

Действия, которые необходимо выполнить с контроллером домена

Вначале администратор создает раздел COM+ в Active Directory. После создания раздела COM+ в Active Directory администратор может создать в Active Directory набор разделов. При создании набора разделов администратор определяет разделы COM+, которые включаются в данный набор. На последнем шаге администратор может сопоставить пользователей домена или организационные подразделения с новым набором разделов. Эти операции выполняются либо с помощью средства администрирования “Active Directory — пользователи и компьютеры”, либо программно через интерфейс служб Active Directory (ADSI).

Действия, которые необходимо выполнить на сервере приложения COM+

Чтобы создать общий для всего домена раздел COM+, администратор должен связать раздел COM+ в Active Directory с разделом COM+ на сервере приложений. Для этого администратор должен создать новый раздел COM+ на сервере приложений, указав то же имя созданного раздела и код раздела (GUID), что и у общего для всего домена раздела COM+, созданного в Active Directory на контроллере домена. Чтобы упростить решение данной задачи, программа служб компонентов позволяет найти в Active Directory необходимый раздел и его код.

Примечание. Для просмотра разделов COM+ и управления ими с помощью программы администрирования служб компонентов установите флажок проверки Включить разделы на вкладке Параметры страницы Свойства компьютера.

После создания общего для всего домена раздела COM+ разделом по умолчанию для пользователя становится раздел по умолчанию из набора разделов в Active Directory. Дополнительные сведения о разделах по умолчанию см. в разделе Разделы COM+ по умолчанию.

Наконец, администратор может устанавливать приложения COM+ в новый раздел COM+ на сервере приложения. Эти приложения становятся доступны всем другим пользователям и организационным подразделениям в этом домене, которые сопоставлены с тем же набором разделов, частью которого является данный раздел COM+.

Дополнительные сведений об администрировании разделов COM+ с целью предоставления доступа к ним пользователям домена см. в разделе Создание общего для домена раздела COM+ или в справочных материалах по средству администрирования “Active Directory — пользователи и компьютеры”.


Default COM+ Partitions

Разделы COM+ по умолчанию

Если пользователю назначен раздел COM+ по умолчанию, то сначала COM+ пытается активизировать компоненты в этом разделе. Если активизация не была выполнена успешно, то приложение COM+ продолжает поиск необходимых компонентов в базовом разделе приложения. Исключения из данного процесса возможны, если компонент COM+ включает в себя моникер раздела, который явно указывает раздел, в котором расположен необходимый компонент. В этом случае моникер раздела имеет приоритет перед любой настройкой раздела COM+ по умолчанию.

Примечание. Для просмотра разделов COM+ и управления ими с помощью программы администрирования служб компонентов установите флажок проверки Включить разделы на вкладке Параметры страницы Свойства компьютера.

При использовании локальных разделов COM+ на сервере приложений раздел COM+ по умолчанию назначается пользователям через папку Пользователи раздела COM+ программы администрирования служб компонентов на сервере приложений. При использовании наборов разделов в Active Directory раздел пользователя по умолчанию определяется набором разделов пользователя.

Пошаговые инструкции см. в разделе Назначение раздела COM+ по умолчанию новому разделу COM+.


Local COM+ Partitions

Локальные разделы COM+

Разделы COM+ могут использоваться локально на сервере приложений. В таком случае администратор создает раздел COM+ на сервере приложений с помощью программы администрирования служб компонентов, но не задает соответствие между вновь созданным разделом COM+ и общим для всего домена разделом COM+, существующим в Active Directory. Разделы COM+, которые созданы локально, а не в Active Directory, доступны только для локальных пользователей. Для пользователей других компьютеров в домене они недоступны. После создания локального раздела COM+ и установки в него приложения COM+ администратор может назначить этот раздел в качестве раздела COM+ по умолчанию для одного или нескольких пользователей на сервере.

Примечание. Поскольку разделы COM+ чаще всего используются в среде предприятия, рекомендуется использовать локальные разделы только для разработки и проверки, а не для работы с ними.

Примечание. Для просмотра разделов COM+ и управления ими с помощью программы администрирования служб компонентов установите флажок проверки Включить разделы на вкладке Параметры страницы Свойства компьютера.


Partition Properties

Свойства разделов

Разделы COM+ имеют пять доступных свойств. Названия этих свойств и их описание приведено ниже.

  • Имя раздела — текстовая строка, связанная с разделом.

  • Описание — текстовое описание раздела.

  • Код раздела — глобальный уникальный идентификатор, который система использует для соотнесения пользователя и раздела.

  • Отключение удаления — защитная функция, запрещающая пользователям удалять раздел.

  • Отключение изменения — защитная функция, запрещающая пользователям вносить изменения в раздел.

Чтобы просмотреть эти свойства, в программе администрирования служб компонентов щелкните правой кнопкой мыши на имени раздела и выберите в контекстном меню пункт Свойства.

Примечание. Для просмотра разделов COM+ и управления ими с помощью программы администрирования служб компонентов установите флажок проверки Включить разделы на вкладке Параметры страницы Свойства компьютера.


Partition Security

Безопасность раздела

Для каждого раздела COM+ (кроме базового раздела приложения) программа администрирования служб компонентов отображает папку Роли. Роль “Активизатор” является основной ролью, которая может назначаться пользователям в отношении определенного раздела COM+. Если удостоверению пользователя назначена роль “Активизатор”, то он может активизировать набор компонентов COM+, зарегистрированных в этом разделе. Компонент COM+ в базовом разделе приложения может активизироваться любым пользователем, имеющим права на активизацию этого компонента.

Примечание. Для просмотра разделов COM+ и управления ими с помощью программы администрирования служб компонентов установите флажок проверки Включить разделы на вкладке Параметры страницы Свойства компьютера.

Роль “Активизатор” не применяется при использовании наборов разделов в Active Directory. Членство в наборе разделов Active Directory автоматически дает право на активизацию компонентов в разделе COM+.

Только пользователи с ролью “Администратор” системного приложения COM+ могут создавать и изменять разделы COM+ и пользователей с ролью “Активизатор” в различных разделах COM+, а также заполнять папку Пользователи раздела COM+ логическими пользователями и группами.


COM+ Partition Administration Tasks

Задачи администрирования разделов COM+

Все задачи по установке и поддержке разделов COM+ могут выполняться с помощью программы администрирования служб компонентов и средства администрирования “Active Directory — пользователи и компьютеры”.

В этом разделе содержатся пошаговые процедуры по администрированию разделов на сервере приложения с помощью программы администрирования служб компонентов. Для получения сведений об администрировании разделов в Active Directory см. справочную систему службы “Active Directory —пользователи и компьютеры”.

Ниже приведен список основных задач, связанных с разделами COM+.

  • Включение разделов COM+

  • Создание общего для всего домена раздела COM+

  • Назначение раздела COM+ по умолчанию новому пользователю раздела COM+

  • Создание локального раздела COM+

  • Изменение имени раздела COM+

  • Отключение возможности удаления раздела COM+

  • Отключение возможности изменения раздела COM+

  • Добавление описания раздела COM+

  • Назначение пользователю роли активизатора

  • Назначение администрирования разделов COM+

  • Экспорт раздела COM+


Enabling COM+ Partitions

Включение разделов COM+

Программа администрирования служб компонентов позволяет включать разделы COM+ в системе. Отображение разделов COM+ и управление разделами невозможно, если они не включены.

Для включения существующих разделов с помощью программы администрирования служб компонентов выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов откройте папку Компьютеры и выберите компьютер.

  2. Щелкните правой кнопкой мыши на имени компьютера и в контекстном меню выберите команду Свойства.

  3. На вкладке Параметры установите флажок Включить раздел.


Creating a Domainwide COM+ Partition

Создание общего для всего домена раздела COM+

Для создания общего для всего домена раздела COM+ следует создать раздел (и набор разделов для этого раздела) в Active Directory с помощью “Active Directory — пользователи и компьтеры”. Затем следует создать такой же раздел на сервере приложений COM+ с помощью программы администрирования служб компонентов. Когда на сервере приложений создается раздел COM+ с таким же GUID, какой имеет раздел COM+ в Active Directory, эти разделы становятся связанными и образуют единый общий для всего домена раздел COM+.

Примечание. Выполнять в Active Directory следующие процедуры могут только участники группы Администраторы домена или Администраторы предприятия в Active Directory, либо пользователи, которым переданы соответствующие полномочия. Более подробно см. интерактивную справку “Active Directory — пользователи и компьютеры”.

Для создания общего для всего домена раздела COM+ выполните следующие действия.

  1. Создайте раздел COM+ в Active Directory:
    1. В главном меню средства администрирования “Active Directory — пользователи и компьютеры” выберите пункт Вид, затем пункт Дополнительные параметры.

    2. В папке Система требуемого домена щелкните правой кнопкой мыши на папке ComPartitions и выберите команду Создать раздел.

    3. На странице Общие свойства нового раздела введите имя и описание нового раздела и нажмите кнопку ОК.
  2. Создайте набор разделов в Active Directory:
    1. В главном меню средства администрирования “Active Directory — пользователи и компьютеры” выберите пункт Вид, затем пункт Дополнительные параметры.

    2. В папке Система требуемого домена щелкните правой кнопкой мыши на папке ComPartitionSets и выберите команду Создать набор разделов.

    3. На странице Общие свойства нового набора введите имя и описание нового набора разделов и нажмите кнопку Далее.

    4. На странице Настройка разделов для нового набора выберите разделы, которые должны входить в данный набор разделов, затем нажмите Добавить и нажмите кнопку Далее.

    5. На странице Настройка пользователей для нового набора с помощью кнопок Добавить пользователя и Добавить подразделение добавьте пользователей и организационные подразделения, которым должен быть сопоставлен этот набор разделов, затем нажмите кнопку Готово.
  3. Сопоставьте пользователей или организационные подразделения домена с новым набором разделов:
    1. В “Active Directory — пользователи и компьютеры” щелкните правой кнопкой мыши на имени пользователя или организационного подразделения, которому требуется сопоставить набор разделов, и выберите команду Свойства.

    2. На вкладке COM+ выберите из списка Набор разделов тот набор разделов, который требуется сопоставить с этим пользователем или организационным подразделением.
  4. Создайте на сервере приложений раздел COM+ и свяжите его с разделом COM+ в Active Directory:
    1. Проверьте, что для этого сервера приложений разделы COM+ включены.

    2. В дереве консоли программы администрирования служб компонентов выберите компьютер, на котором необходимо создать раздел. Разверните представление дерева консоли так, чтобы были видны папки, определенные для компьютера.

    3. Щелкните правой кнопкой мыши на папке Разделы COM+, выберите команду Создать и выберите из меню второго уровня команду Раздел.

    4. В окне Мастера установки раздела COM+ нажмите кнопку Далее.

    5. Выберите параметр Создать пустой раздел.

    6. Нажмите кнопку Обзор каталога. На экране будет отображено диалоговое окно Добавление разделов для приложений службы каталогов.

    7. В Active Directory выберите раздел COM+, с которым требуется связать раздел на сервере приложений.

    8. Нажмите кнопку Далее, затем — Готово.


Assigning a Default COM+ Partition to a New COM+ Partition User

Назначение раздела COM+ по умолчанию новому пользователю раздела COM+

С помощью программы администрирования служб компонентов новому пользователю разделов COM+ можно назначить раздел COM+ по умолчанию. При попытке нового пользователя получить доступ к приложению COM+ происходит поиск раздела по умолчанию этого пользователя для данного приложения.

Для назначения раздела COM+ по умолчанию новому пользователю разделов COM+ выполните следующие действия.

  1. Проверьте, что на данном компьютере разделы COM+ включены.

  2. В дереве консоли программы администрирования служб компонентов выберите компьютер, на котором расположен пользователь. Разверните представление дерева консоли так, чтобы были видны папки, определенные для компьютера.

  3. Щелкните правой кнопкой мыши на папке Пользователи раздела COM+ и выберите команду Создать, затем — Пользователь. На экране будет отображено диалоговое окно Назначение раздела по умолчанию.

  4. Нажмите кнопку Добавить. Будет отображено диалоговое окно Выбор : Пользователи.

  5. В поле Ввода имен объектов введите имена одного или нескольких пользователей.

  6. Нажмите кнопку ОК.

  7. В списке Раздел по умолчанию выберите раздел по умолчанию для нового пользователя.

  8. Нажмите кнопку ОК.


Creating a Local COM+ Partition

Создание локального раздела COM+

Программа администрирования служб компонентов позволяет создавать разделы COM+ для установки в них локальных приложений COM+, которые должны быть недоступны другим пользователям данного домена.

Для создания локального раздела COM+ выполните следующие действия.

  1. Проверьте, что на локальном компьютере разделы COM+ включены.

  2. В дереве консоли программы администрирования служб компонентов выберите компьютер, на котором необходимо создать раздел. Разверните представление дерева консоли так, чтобы были видны папки, определенные для компьютера.

  3. Щелкните правой кнопкой мыши на папке Разделы COM+, выберите команду Создать и выберите из меню второго уровня команду Раздел.

  4. В окне Мастера установки раздела COM+ нажмите кнопку Далее.

  5. Выберите параметр Создать пустой раздел.

  6. Введите имя нового раздела.

  7. Если необходимо создать глобальный уникальный идентификатор для нового раздела, то удалите существующий код раздела в поле Код раздела, а затем в этом поле введите новый код.

  8. Нажмите кнопку Далее, затем — Готово.


Changing a COM+ Partition Name

Изменение имени раздела COM+

С помощью программы администрирования служб компонентов можно изменить имя созданного раздела COM+.

Примечание. Изменить имя базового раздела приложения невозможно.

Для изменения имени раздела приложения выполните следующие действия.

  1. Проверьте, что на данном компьютере разделы COM+ включены.

  2. В программе администрирования служб компонентов выберите имя раздела COM+.

  3. Щелкните правой кнопкой мыши на этом имени и выберите команду Свойства.

  4. На вкладке Общие удалите текущее имя, введите новое имя и нажмите кнопку ОК.


Disabling Deletion of a COM+ Partition

Отключение возможности удаления раздела COM+

Программа администрирования служб компонентов позволяет отключить возможность удаления раздела COM+.

Примечание. Выполнить данное действие с базовым разделом приложения невозможно. Базовый раздел приложений не может быть удален.

Для отключения возможности удаления раздела COM+ выполните следующие действия.

  1. Проверьте, что на данном компьютере разделы COM+ включены.

  2. В программе администрирования служб компонентов выберите имя раздела COM+.

  3. Щелкните правой кнопкой мыши на имени требуемого раздела и выберите команду Свойства.

  4. На вкладке Дополнительно установите флажок Отключить удаление и нажмите кнопку ОК.


Disabling Changes to a COM+ Partition

Отключение возможности изменения раздела COM+

Программа администрирования служб компонентов позволяет отключить возможность изменения раздела COM+.

Для отключения возможности изменения раздела COM+ выполните следующие действия.

  1. Проверьте, что на данном компьютере разделы COM+ включены.

  2. В программе администрирования служб компонентов выберите имя раздела COM+.

  3. Щелкните правой кнопкой мыши на имени требуемого раздела и выберите команду Свойства.

  4. На вкладке Дополнительно установите флажок Отключить изменения и нажмите кнопку ОК.


Adding a Description to a COM+ Partition

Добавление описания раздела COM+

Программа администрирования служб компонентов позволяет добавить описание раздела COM+.

Для добавления описания раздела COM+ выполните следующие действия.

  1. Проверьте, что на данном компьютере разделы COM+ включены.

  2. В программе администрирования служб компонентов выберите имя раздела COM+.

  3. Щелкните правой кнопкой мыши на имени требуемого раздела и выберите команду Свойства.

  4. На вкладке Общие введите описание раздела и нажмите кнопку ОК.


Assigning a User to the Activator Role

Назначение пользователю роли активизатора

Чтобы предоставить пользователю права на активизацию компонента COM+ в определенном разделе COM+, следует назначить ему роль “Активизатор” для данного раздела.

Для назначения пользователю роли активизатора для раздела выполните следующие действия.

  1. Проверьте, что на данном компьютере разделы COM+ включены.

  2. В дереве консоли программы администрирования служб компонентов выберите компьютер, на котором установлен раздел COM+.

  3. Разверните представление дерева консоли так, чтобы была видна папка Разделы COM+.

  4. Разверните папку Разделы COM+.

  5. Разверните раздел, в который необходимо добавить нового пользователя на роль активизатора.

  6. Разверните папку Роли.

  7. Разверните папку Активизатор.

  8. Щелкните правой кнопкой мыши на папке Пользователи и выберите команду Создать, а затем — Пользователь. На экране отобразится диалоговое окно Выбор: Пользователи и группы.

  9. Введите удостоверение пользователя, которому необходимо предоставить роль “Активизатор”.

  10. Нажмите кнопку ОК.


Assigning Administration of COM+ Partitions

Назначение администрирования разделов COM+

Чтобы предоставить определенному пользователю права на администрирование всех разделов COM+, следует назначить этому пользователю роль “Администратор” в системном приложении COM+.

Для назначения пользователю роли системного администратора COM+ выполните следующие действия.

  1. Проверьте, что на данном компьютере разделы COM+ включены.

  2. В дереве консоли программы администрирования служб компонентов выберите компьютер, на котором установлено приложение COM+.

  3. Разверните представление дерева консоли так, чтобы была видна папка Разделы COM+.

  4. Разверните папку Разделы COM+.

  5. Разверните значок Базовый раздел приложения.

  6. Разверните папку Приложения COM+.

  7. Разверните папку Системное приложение.

  8. Разверните папку Роли.

  9. Разверните значок Администратор.

  10. Щелкните правой кнопкой мыши на папке Пользователи и выберите команду Создать, а затем — Пользователь. На экране отобразится диалоговое окно Выбор: Пользователи и группы.

  11. Введите удостоверение пользователя, которого необходимо добавить на роль администратора системного приложения.

  12. Нажмите кнопку ОК.


Exporting a COM+ Partition

Экспорт раздела COM+

Мастер экспорта раздела COM+ позволяет извлекать и распаковывать конфигурации и содержимое существующих разделов, поэтому существует возможность перемещать разделы на другие компьютеры.

Для обращения к мастеру экспорта раздела COM+ выполните следующие действия.

  1. Проверьте, что на данном компьютере разделы COM+ включены.

  2. В дереве консоли программы администрирования служб компонентов выберите имя компьютера, содержащего раздел COM+, который требуется экспортировать. Разверните представление дерева консоли так, чтобы были видны папки, определенные для компьютера.

  3. Разверните папку Разделы COM+.

  4. Щелкните правой кнопкой мыши на разделе COM+, который требуется экспортировать, и выберите в контекстном меню команду Экспорт. На экране появится диалоговое окно мастера экспорта разделов COM+. Нажмите кнопку Далее.

    Примечание. Чтобы экспортировать вместе с ролями удостоверения пользователей, установите флажок проверки Экспортировать пользователей и их роли на странице Сведения об экспорте раздела.

  5. Нажмите кнопку Далее.

Мастер экспорта раздела COM+ создает пакет Windows Installer и CAB-файл. Для установки этого раздела на конечный компьютер переместите на него эти два файла и дважды щелкните мышью на пакете Windows Installer.


Administering the COM+ SOAP Service

Администрирование службы SOAP в COM+

Простой установкой флажка Использовать SOAP в программе администрирования служб компонентов можно предоставить доступ к приложению COM+ как к веб-службе XML. Кроме того, веб-службы XML, как обычные, так и развернутые с помощью COM+, могут прозрачно использоваться как компонент COM. Таким образом обеспечивается возможность быстрого создания новых веб-служб XML на основе существующих приложений COM+ и упрощается встраивание веб-служб XML в новые приложения COM+.

В разделах, описанных в следующей таблице, приведены сведения по общим вопросам и выполнению задач с использованием COM+ для предоставления настроенных компонентов COM в качестве веб-служб XML.

Раздел | Описание
Концепция службы SOAP в COM+ | Обзор веб-служб XML и SOAP.
Задачи службы SOAP в COM+ | Инструкции по использованию COM+ для создания и развертывания веб-служб XML.


COM+ SOAP Service Concepts

Концепция службы SOAP в COM+

Следующие подразделы этого раздела содержат базовые сведения, необходимые для использования и администрирования службы SOAP в COM+.

  • Обзор службы SOAP в COM+

  • Обеспечение безопасности для службы SOAP в COM+


COM+ SOAP Service Overview

Обзор службы SOAP в COM+

Протокол HTTP революционно изменил подход к использованию компьютеров, позволив с помощью веб-обозревателя получать удобный доступ по сети к информации, находящейся на удаленном сервере. В настоящее время веб-службы XML совершают революцию в области разработки приложений, обеспечивая клиентским приложениям удобный способ вызова удаленных методов по сети.

Очень удобно, чтобы клиентское приложение имело возможность вызывать методы, реализованные на удаленном сервере. Иногда для этого используется быстро изменяющаяся информация, хранящаяся на удаленном сервере (например, метод возвращает текущую цену акции, соответствующую указанному коду ценной бумаги). В других случаях разработчику требуется возможность обновления реализации метода без повторного развертывания всех приложений, которые его используют.

Как и в случае веб-страниц, доступ к веб-службам XML производится через веб-сервер (например, IIS) с помощью протокола HTTP. Однако в отличие от веб-страниц, для которых используется язык HTML, эти пакеты HTTP содержат входные и выходные параметры вызовов, реализованных на сервере методов, закодированных с помощью SOAP.

Вы можете предоставить доступ к методам в интерфейсах по умолчанию настроенных компонентов COM в любом приложении COM+ как к веб-службам XML. При написании таких компонентов не требуется никаких специальных программных мер за исключением того, что методы, к которым будет предоставлен доступ, должны быть заключены в интерфейс по умолчанию компонента, и этот компонент должен быть настроен (в каталоге COM+ сервера). Подробные инструкции по использованию службы SOAP в COM+ для создания веб-служб содержатся в разделе Создание веб-служб XML.

Управление доступом к компонентам, предоставляемым в виде веб-служб XML, возможно с помощью методов управления доступом как IIS, так и приложения COM+. Подробнее о выполнении этих задач см. раздел Обеспечение безопасности веб-служб XML.

При использовании COM+ для создания веб-службы XML эта служба может использоваться любыми зарегистрированными клиентами, в том числе не использующими COM+ или даже Microsoft® Windows®. Однако COM+ значительно упрощает создание веб-служб XML, позволяя использовать существующие приложения COM+ в качестве веб-служб XML абсолютно прозрачно. При экспорте приложения COM+, которое было доступно как веб-служба XML с сервера, любой клиент, который импортирует это приложение, может прозрачно использовать веб-службу XML сервера одновременно с использованием импортированного приложения. Эта возможность позволяет совершенно без усилий преобразовывать существующие приложения COM+ в веб-службы XML и развертывать эти службы в сети.


COM+ SOAP Service Security Considerations

Обеспечение безопасности для службы SOAP в COM+

При использовании версии 1.1 платформы .NET Framework создаваемая с помощью SOAP в COM+ веб-служба XML принудительно выполняет настройку безопасности на основе ролей в приложении COM+. Эта настройка позволяет шифровать данные, которыми обмениваются клиент и сервер, а также требует удостоверения подлинности клиента на основе сертификатов. Информацию о настройке безопасности COM+ на основе ролей см. в разделе Администрирование безопасности приложения.

Отключив для приложения COM+ проверку подлинности пакетов и безопасность на основе ролей, можно разрешить анонимный доступ к соответствующей веб-службе XML для всех клиентов, имеющих доступ по сети к данному компьютеру.

Если включить проверку подлинности пакетов и безопасность на основе ролей для приложения COM+, соответствующая веб-служба XML будет доступна только получившим разрешение клиентам COM+. В безопасном режиме анонимный доступ отключен, и файл WSDL не публикуется. Созданную в безопасном режиме веб-службу XML невозможно затем перевести в небезопасный режим.

По умолчанию при обмене данными по протоколу SOAP для открытых данных используется порт HTTP (80), а для зашифрованных данных — порт HTTPS (443). Чтобы доступ клиента к веб-службе XML был возможен, настройка всех брандмауэров, находящихся между клиентом и сервером, должна разрешать передачи пакетов TCP SYN на соответствующие порты сервера. И наоборот, администратор брандмауэра может закрыть эти порты, чтобы ограничить доступ к веб-службам XML.

Подробные инструкции по настройке отдельных параметров безопасности для веб-служб XML приведены в разделе Обеспечение безопасности веб-служб XML.


COM+ SOAP Service Tasks

Задачи службы SOAP в COM+

Разделы данной главы содержат пошаговые инструкции по использованию COM+ для организации веб-служб XML на базе приложений COM+ и управления ими.

  • Создание веб-служб XML

  • Обеспечение безопасности веб-служб XML

  • Экспорт приложений, использующих SOAP

  • Импорт приложений, использующих SOAP


Creating XML Web Services

Создание веб-служб XML

К любому приложению COM+ может быть предоставлен доступ как к веб-службе XML. После этого методы интерфейсов по умолчанию в настроенных компонентах приложения (компонентах в каталоге сервера COM+) будут доступны для удаленных вызовов. Используя программу администрирования служб компонентов, можно создать виртуальный корневой каталог IIS, из которого методы компонентов могут вызываться с помощью SOAP.

Для предоставления доступа к приложению COM+ как к веб-службе XML

  1. В дереве консоли программы администрирования служб компонентов в папке Службы компонентов откройте папку Приложения COM+ компьютера, которым необходимо управлять.

  2. Щелкните правой кнопкой мыши на приложении, которому предоставляется доступ как к веб-службе XML, и выберите из контекстного меню команду Свойства.

  3. В диалоговом окне свойств откройте вкладку Активизация.

  4. Установите флажок проверки Использовать SOAP.

  5. В текстовом поле Корень SOAP укажите имя виртуального корневого каталога IIS, в котором методы настроенных компонентов приложения должны быть доступны удаленно.

Если виртуальный корневой каталог IIS задается как vroot, а полным именем домена сервера является servername, то адресом URL, по которому компонент будет доступен как веб-служба XML, будет являться http://servername/vroot/. Соответствующим каталогом в файловой системе будет \windows\system32\com\SoapVRoots\vroot\.


Securing XML Web Services

Обеспечение безопасности веб-служб XML

При использовании версии 1.1 платформы .NET Framework создаваемая с помощью SOAP в COM+ веб-служба XML принудительно выполняет настройку безопасности на основе ролей в приложении COM+. Если требуется предоставить доступ к данной веб-службе XML анонимным клиентам, следует отключить проверку подлинности пакетов и безопасность на основе ролей для соответствующего приложения COM+. Дополнительные сведения см. в разделе Обеспечение безопасности для службы SOAP в COM+.

Для того, чтобы проверить, реализуется ли в приложении COM+, использующем SOAP, безопасность на основе ролей, выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов в папке Службы компонентов откройте папку Приложения COM+ компьютера, которым необходимо управлять.

  2. Щелкните правой кнопкой мыши на использующем SOAP приложении, которое должно быть проверено, и выберите команду Свойства в контекстном меню.

  3. В диалоговом окне свойств откройте вкладку Активизация.

  4. Если параметр Безопасность SOAP имеет значение Полная реализация безопасности COM+, это означает, что данное приложение COM+, использующее SOAP, использует безопасность на основе ролей. Если параметр Безопасность SOAP имеет значение Открыть методы компонентов любой вызывающей программе, это означает, что приложение, использующее SOAP, для управления доступом использует настройку безопасности IIS.

  5. Нажмите кнопку ОК.

При использовании версии 1.1 платформы .NET Framework параметр Безопасность SOAP имеет значение Полная реализация безопасности COM+, если только для данного приложения параметр Уровень проверки подлинности для вызовов не имеет значение Нет (на вкладке Безопасность страницы свойств приложения COM+) и проверка доступа не отключена. В последнем же случае параметр Безопасность SOAP имеет значение Открыть методы компонентов любой вызывающей программе. Пошаговые инструкции по настройке уровня проверки подлинности приведены в разделе Настройка уровня проверки подлинности для серверного приложения.

Примечание. Чтобы изменить настройку безопасности на основе ролей для приложения, использующего SOAP, перед выполнением изменений отключите доступ к SOAP и вновь включите доступ к SOAP после внесения изменений. COM+ не позволяет изменять настройку безопасности приложения при включенном SOAP.

Дополнительные сведения о настройке безопасности COM+ на основе ролей см. в разделе Администрирование безопасности приложения.


Exporting a SOAP-Enabled Application

Экспорт приложений, использующих SOAP

При использовании службы SOAP в COM+ для предоставления доступа к приложению как к веб-службе XML эта служба может использоваться любыми зарегистрированными клиентами, в том числе не использующими COM+ или даже Microsoft® Windows®. Однако существенно проще работать с серверным приложением COM+, использующим SOAP, из клиентского приложения COM+. Требуется лишь экспортировать приложение, использующее SOAP, в режиме прокси, а затем импортировать его на клиентский компьютер, с которого требуется обращаться к соответствующей веб-службе XML.

Для экспорта приложения, использующего SOAP, с сервера

  1. В дереве консоли программы администрирования служб компонентов в папке Службы компонентов откройте папку Приложения COM+ компьютера, которым необходимо управлять.

  2. Щелкните правой кнопкой на использующем SOAP приложении, которое требуется экспортировать, и выберите в контекстном меню команду Экспорт. Будет запущен Мастер экспорта приложений COM+.

  3. В текстовом поле Введите полный путь и имя создаваемого файла приложения, введите полный путь и имя для файла MSI, который должен содержать экспортируемое приложение, или нажмите кнопку Обзор для выбора пути и имени файла с помощью диалогового окна.

  4. В группе Экспортировать как выберите селективную кнопку Прокси приложения - установка доступа с других компьютеров к этому.


Importing a SOAP-Enabled Application

Импорт приложений, использующих SOAP

После экспорта приложения, использующего SOAP, с сервера в режиме прокси клиенты, выполнившие импорт, получают доступ к методам содержащихся в нем компонентов. Когда компоненты импортированного таким способом приложения используются клиентом, они не выполняются на клиентском компьютере. Вместо этого происходит удаленное обращение к ним как к веб-службе XML, предоставляемой сервером, с которого данное приложение было экспортировано. Такой способ значительно упрощает использование возможностей использующего SOAP приложения COM+ по сети.

Для импорта приложения, использующего SOAP, на клиентский компьютер

  1. В дереве консоли программы администрирования служб компонентов в папке Службы компонентов откройте папку, соответствующую клиентскому компьютеру, на который требуется установить данное приложение.

  2. Щелкните правой кнопкой мыши на папке Приложения COM+ клиентского компьютера и выберите команду Создать, а затем — Приложение. Будет запущен Мастер установки приложения COM+.

  3. В окне Мастера установки приложения COM+ нажмите кнопку Далее, затем выберите Установить готовые приложения.

  4. Найдите в окне обзора сети или задайте путь к файлу MSI на сервере, с которого требуется установить приложение, использующее SOAP.


Administering the Process Dump Tool

Программа администрирования образа процесса

Программа сохранения образа процесса упрощает процесс отладки приложений COM+ путем сохранения состояния приложения в момент возникновения неполадки.

Разделы, описанные в следующей таблице, содержат основные понятия, связанные со средством сохранения образа процесса, и сведения об использовании программы администрирования служб компонентов для сохранения образа процесса приложений COM+.

Раздел | Описание
Основные понятия сохранения образа процесса | Основные понятия по сохранению образа процесса и его преимуществах.
Задачи программы сохранения образа процесса | Пошаговые инструкции по настройке сохранения образа процесса приложений COM+.


Process Dump Tool Concepts

Основные понятия сохранения образа процесса

Программа сохранения образа процесса позволяет администратору упростить задачу разработчика по отладке приложения путем сохранения при сбое состояния приложения COM+ в определенный каталог. Ниже приведены примеры неполадок приложения.

  • Приложение зависает и не отвечает клиенту.

  • В результате возникновения исключения выполнение приложения прерывается COM+.

  • Возникает сбой приложения.

Во всех примерах средство сохранения образа процесса позволяет сохранить состояние процесса в момент возникновения неполадки и предоставляет широкие возможности для отладки приложения.

Можно сохранить состояние всех файлов на любом компьютере, а не только на компьютере, на котором выполняется приложение. Кроме того, каталог COM+ на компьютере, на котором выполняется приложение, можно настроить таким образом, чтобы файл образа можно было записать на любой компьютер в сети. Отладку приложения можно выполнять в отключенном режиме.

Пошаговые инструкции по включению сохранения образа процесса см. в разделе Включение сохранения образа процесса..

Пошаговые инструкции по отключению сохранения образа процесса см. в разделе Отключение сохранения образа процесса.


Process Dump Tool Tasks

Задачи программы сохранения образа процесса

В следующих разделах содержатся сведения по выполнению задач сохранения образа процесса.

  • Включение сохранения образа процесса

  • Отключение сохранения образа процесса


Enabling Process Dump

Включение сохранения образа процесса

Средство сохранения образа процесса может быть использовано для получения сведений о состоянии приложения при возникновении исключений, сбоев или при зависании приложения. Сведения об использовании программы сохранения образа процесса в COM+ см. в разделе Основные понятия сохранения образа процесса.

Примечание. Службы компонентов не могут управлять файлом образа. Обычно файлы образов имеют большой размер, поэтому рекомендуется периодически удалять или архивировать эти файлы.

Для сохранения образа приложения при возникновении исключения или сбоя выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов найдите и щелкните правой кнопкой мыши на приложении COM+, для которого требуется включить средство сохранения образа, и выберите в контекстном меню команду Свойства.

  2. В диалоговом окне свойств перейдите на вкладку Сохранение копии.

  3. В текстовом поле Каталог для сохранения образов введите полный путь к файлу образа. Не включайте в него имя файла. Путь по умолчанию: %SystemRoot%\system32\com\dmp.

  4. В списке Максимальное число сохраненных образов введите максимальное число файлов образа, которое может одновременно находиться на компьютере до их перезаписи. Это число должно быть в диапазоне от 1 до 200. По умолчанию оно равняется 5.

  5. В группе Включение сохранения образа процесса установите флажок Разрешить сохранение образа при сбое приложения.

  6. Нажмите кнопку ОК.

Для сохранения образа приложения при его зависании выполните следующие действия.

  1. В папке Выполняемые процессы дерева консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на требуемом приложении COM+ и в контекстном меню выберите команду Сохранить копию.

  2. Файл образа создается в папке, указанной в текстовом поле Каталог для сохранения образов на вкладке Сохранение копии страницы свойств приложения.

Дополнительные сведения об отключении сохранения образа см. в разделе Отключение сохранения образа процесса.


Disabling Process Dump

Отключение сохранения образа процесса

После завершения отладки приложения можно отключить средство сохранения образа процесса (чтобы запретить сохранение образа процесса при возникновении исключения или при сбое) с помощью следующей процедуры. Для получения сведений об использовании программы сохранения образа процесса в COM+ см. Основные понятия сохранения образа процесса.

Для отключения сохранения образа процесса выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов найдите и щелкните правой кнопкой мыши на приложении COM+, для которого требуется отключить средство сохранения образа, и выберите в контекстном меню команду Свойства.

  2. В диалоговом окне свойств перейдите на вкладку Сохранение копии.

  3. В группе Включение сохранения образа процесса отмените выбор флажка Разрешить сохранение образа при сбое приложения.

  4. Нажмите кнопку ОК.

Сведения о включении сохранения образа процесса см. в разделе Включение сохранения образа процесса.


Administering Queued Components

Администрирование очередей компонентов

Средство очередей компонентов COM+ позволяет клиенту обращаться к службе из серверного приложения COM+, даже если серверное приложение временно недоступно. Запрос клиента располагается в очереди и обрабатывается, когда сервер становится доступным.

Примечание. Для использования очередей компонентов COM+ необходимо установить на компьютере службы очередей сообщений. Сведения об установке очередей компонентов см. в подразделе Использование очередей сообщений раздела Поддержка использования и разработки на странице Центр справок и поддержки, доступной из меню кнопки Пуск в Microsoft® Windows®.

Разделы, описанные в следующей таблице, содержат сведения об использовании служб компонентов для администрирования очередей компонентов.

Раздел | Описание
Основные понятия администрирования очередей компонентов | Обзор основных понятий очередей компонентов COM+.
Задачи администрирования очередей компонентов | Перечень задач по администрированию очередей компонентов COM+.


Queued Components Administration Concepts

Основные понятия администрирования очередей компонентов

С помощью программы очередей компонентов клиентское приложение может запросить службу из серверного приложения COM+. Клиентский запрос записывается в очередь исходящих запросов, которую программа очереди сообщений передает в очередь серверного приложения. Запрос располагается в очереди серверного приложения до тех пор, пока не будет обработан данным приложением. Порядок обработки запроса очередей компонентов показан на следующем рисунке.

Примечание. Для связи с сервером служба очередей компонентов позволяет использовать клиенту асинхронную связь, связь с использованием транзакций и связь с проверкой подлинности. Для получения сведений о разработке очередей компонентов см. раздел “Queued Components” главы “Component Services” SDK платформы.

Первой административной задачей при использовании службы очередей компонентов COM+ является определение, для какого серверного приложения COM+ необходимо создать очереди. Сведения о создании очереди приложения см. в разделе Использование очередей приложением COM+.

Если необходимо, чтобы приложения, использующие очереди, непрерывно обрабатывали запросы, нужно также активизировать программу прослушивания. В противном случае запросы в очереди могут находиться длительное время и программа прослушивания будет активизироваться только при обработке этих запросов. Сведения о том, как активизировать программу прослушивания очередей приложения, см. в разделе Активизация программы прослушивания очередей компонентов.

Программа прослушивания очередей компонентов является многопотоковой. Это означает, что многочисленные экземпляры могут работать одновременно и очередь запросов может быть быстро обработана. Итоговые экземпляры серверного приложения могут использовать все ресурсы компьютера, на котором предполагалось использовать службу, имеющую небольшое влияние. Хотя, изначально предполагается, что обработка запросов в очереди является первоочередной задачей компьютера. Чтобы управлять выделением ресурсов для определенных приложений, использующих очереди, можно указать максимальное число одновременно используемых программ прослушивания потоков, которые могут обработать очереди запросов. Дополнительные сведения см. в разделе Указание максимального числа потоков прослушивания для приложения, использующего очереди.

Чтобы не обрабатывать запросы от неавторизованных клиентов, можно потребовать, чтобы каждый клиент при каждом запросе предоставлял сертификат, доказывающий его подлинность. Сведения о реализации этой меры безопасности см. в разделе Указание протокола проверки подлинности. Инструкции по обновлению сертификата клиента см. в разделе Обновление сертификата очередей сообщений.

Причиной того что запрос не обрабатывается, может быть неполадка с сервером или с самим запросом. При возникновении такой неполадки служба очередей компонентов пытается несколько раз обработать запрос, а затем перемещает его в очередь окончательного размещения, где он и остается, пока не будет вручную перемещен в нужную очередь. Сведения о повторной постановке запросов в очередь см. в разделе Использование программы перемещения сообщений.


Queued Components Administration Tasks

Задачи администрирования очередей компонентов

Разделы данной главы содержат пошаговые инструкции по администрированию службы очередей компонентов COM+.

Примечание. Для использования очередей компонентов необходимо установить на компьютере службы очередей сообщений. Для получения сведений об установке очередей компонентов см. подраздел Использование очередей сообщений в разделе Поддержка использования и разработки на странице Центр справок и поддержки, доступной из меню кнопки Пуск в Microsoft® Windows®.

  • Использование очередей приложением COM+

  • Активизация программы прослушивания очередей компонентов

  • Указание максимального числа потоков прослушивания для приложения, использующего очереди

  • Указание протокола проверки подлинности

  • Обновление сертификата очередей сообщений

  • Использование программы перемещения сообщений


Specifying a COM+ Application as Queued

Использование очередей приложением COM+

При указании приложения COM+ в качестве приложения, использующего очереди, служба компонентов создает очередь, связанную с очередью сообщений, в которой хранятся запросы к службам приложения.

Для указания приложения COM+ в качестве приложения, использующего очереди, выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов в папке Службы компонентов откройте папку Приложения COM+ компьютера, которым необходимо управлять.

  2. Щелкните правой кнопкой мыши на приложении, для которого требуется создать очередь, затем выберите в контекстном меню команду Свойства.

  3. В диалоговом окне свойств перейдите на вкладку Очереди.

  4. Установите флажок Постановка в очередь – к этому приложению можно обратиться через очереди MSMQ.

  5. Нажмите кнопку ОК.


Activating the Queued Components Listener

Активизация программы прослушивания очередей компонентов

Чтобы после указания серверного приложения, использующего очереди, направить запрос из очереди в серверное приложение COM+, необходимо активизировать программу прослушивания, связанную с данным приложением.

Примечание. До активизации программы прослушивания необходимо указать, что данное приложение использует очереди. Пошаговые инструкции по настройке использования очереди приложением см. в разделе Использование очередей приложением COM+.

Для активизации программы прослушивания очередей компонентов выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов в папке Службы компонентов откройте папку Приложения COM+ компьютера, которым необходимо управлять.

  2. Щелкните правой кнопкой мыши на приложении, использующем очереди, для которого требуется активизировать программу прослушивания, и в контекстном меню выберите команду Свойства.

  3. В диалоговом окне свойств перейдите на вкладку Очереди.

  4. Установите флажок Прослушивание – это приложение после запуска будет обрабатывать сообщения, поступающие в очередь MSMQ.

  5. Нажмите кнопку ОК.


Specifying the Maximum Number of Listener Threads for a Queued Application

Указание максимального числа потоков прослушивания для приложения, использующего очереди

По умолчанию максимальное число потоков прослушивания в 16 раз больше, чем число процессоров данного компьютера. Значение по умолчанию используется, если неизвестно, вызовет ли неполадки потребление ресурсов определенной службой очередей компонентов. Если служба потребляет слишком много ресурсов, то измените значение на меньшее. Если необходимо выделить больше ресурсов данной службе, то увеличьте это значение.

Для указания количества потоков прослушивания для приложения, использующего очереди, выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов в папке Службы компонентов откройте папку Приложения COM+ компьютера, которым необходимо управлять.

  2. Щелкните правой кнопкой мыши на приложении, использующем очереди, для которого требуется указать максимальное число потоков, и в контекстном меню выберите команду Свойства.

  3. В диалоговом окне свойств перейдите на вкладку Очереди.

  4. В поле Предельное число одновременных проигрывателей (0-1 000, 0 = значение по умолчанию) введите максимальное число потоков для обработки очереди запросов для данного приложения.

  5. Нажмите кнопку ОК.


Specifying the Authentication Protocol

Указание протокола проверки подлинности

В зависимости от требований безопасности узла можно установить, что служба очередей компонентов всегда проверяет удостоверение клиента, никогда не проверяет удостоверение или проверяет удостоверение, если выполняется проверка совместимости.

Для указания протокола проверки подлинности выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов в папке Службы компонентов откройте папку Приложения COM+ компьютера, которым необходимо управлять.

  2. Щелкните правой кнопкой мыши на приложении, использующем очереди, для которого требуется настроить протокол проверки подлинности, и в контекстном меню выберите команду Свойства.

  3. В диалоговом окне свойств перейдите на вкладку Очереди.

  4. В группе Проверка подлинности сообщений MSMQ выберите параметр, отвечающий необходимым требованиям безопасности.

  5. Нажмите кнопку ОК.


Renewing a Message Queuing Certificate

Обновление сертификата очередей сообщений

В обычных условиях сертификат очереди сообщения создается автоматически. Если необходимо обновить сертификат вручную, то выполните следующую процедуру.

Примечание. Для выполнения данной задачи необходимо установить на компьютере службы очередей сообщений. Для получения сведений об установке очередей компонентов см. подраздел Использование очередей сообщений в разделе Поддержка использования и разработки на странице Центр справок и поддержки, доступной из меню кнопки Пуск в Microsoft® Windows®.

Для обновления сертификата очередей сообщений выполните следующие действия.

  1. На рабочем столе щелкните правой кнопкой мыши на значке Мой компьютер и в контекстном меню выберите команду Управление.

  2. Дважды щелкните на значке Очередь сообщений в папке Службы и приложения дерева консоли Управление компьютером.

  3. В появившемся диалоговом окне откройте вкладку Сертификат пользователя.

  4. В группе Внутренний сертификат нажмите кнопку Обновить.

  5. Нажмите кнопку ОК.


Using the Message Mover

Использование программы перемещения сообщений

Для перемещения запросов из одной очереди в другую можно использовать программу перемещения сообщений. Программа перемещения сообщений представляет собой объект автоматической обработки, который может быть вызван из несложного сценария. Использование программы перемещения сообщений разрешено только пользователям с ролью доверенных пользователей очередей компонентов. Сведения о назначении роли доверенного пользователя очередей компонентов см. в разделе Назначение учетной записи пользователя или группы на роль.

Примечание. Для использования очередей компонентов необходимо установить на компьютере службы очередей сообщений. Для получения сведений об установке очередей компонентов см. подраздел Использование очередей сообщений в разделе Поддержка использования и разработки на странице Центр справок и поддержки, доступной из меню кнопки Пуск в Microsoft® Windows®.

Ниже приведена функция сценария VBScript, которая иллюстрирует использование программы перемещения сообщений для перемещения запросов очередей компонентов из одной очереди в другую, где strSource и strDest являются путями, соответственно, к исходной и конечной очередям на компьютере.

Function MyMessageMover ( _
  strSource, _
  strDest _
)  ' Return False if any errors occur.

    MyMessageMover = False  ' Initialize the function.
    On Error Resume Next    ' Initialize error handling.
    Err.Clear               ' Clear the error object.

    Dim objMessageMover   ' The message mover
    Dim lngMovedMessages  ' Number of messages moved

    Set objMessageMover = Wscript.CreateObject("QC.MessageMover")
    If Err.Number <> 0 Then
        MsgBox "Error # " & Hex(Err.Number) & vbNewLine & Err.Description
        Exit Function  ' Replace with specific error handling.
    End If

    objMessageMover.SourcePath = strSource
    objMessageMover.DestPath = strDest
    lngMovedMessages = objMessageMover.MoveMessages
    If Err.Number <> 0 Then
        MsgBox "Error # " & Hex(Err.Number) & vbNewLine & Err.Description
        Exit Function  ' Replace with specific error handling.
    End If

    Wscript.Echo lngMovedMessages, "messages moved from", _
      strSource, "to", strDest

    MyMessageMover = True  ' Successful end to procedure
    Set objMessageMover = Nothing
    Set lngMovedMessages = Nothing
End Function

Следующий код VBScript демонстрирует способ вызова функции MyMessageMover.

' Replace AppName with a COM+ application that has Queuing enabled.
If Not MyMessageMover(".\private$\AppName_deadqueue", ".\AppName") Then
    Wscript.Echo "MyMessageMover failed."
End If


COM+ Glossary

Словарь COM+

A-Z А Б В Г Д Е Ж З И К Л М Н О П Р С Т У Ф Ц Ч Ш Щ Э Ю Я

A-Z

вернуться в начало

SOAP

Простой протокол на основе XML, предназначенный для обмена информацией о структурах и типах по веб-сети. Протокол не содержит семантики приложений и транспортной семантики, что обеспечивает ему высокую степень модульности и расширяемости. См. также SOAP, веб-службы XML.

SOAP в COM+

Функция служб компонентов, позволяющая предоставлять доступ к приложению COM+ как к веб-службе XML. SOAP в COM+ позволяет также использовать веб-службы XML в качестве компонентов COM. См. также SOAP, веб-службы XML.

Transaction Internet Protocol (TIP)

Стандартный двухэтапный протокол завершения, позволяющий разнородным диспетчерам транзакций координировать распределенные транзакции, в особенности через Интернет. Двухэтапный протокол завершения TIP прост в реализации и не зависит от протокола связи между приложениями, поэтому он может быть использован вместе с любым протоколом уровня приложений, в том числе HTTP. См. также двухэтапный протокол завершения.

А

вернуться в начало

авторизация

Процесс проверки того, имеет ли вызывающий права на выполнение действий, которые он указал в своем запросе.

активизация

Последовательность событий, в результате которой создается объект COM и возвращается указатель на интерфейс этого объекта. В COM+ объект активизируется либо в своем контексте, либо в контексте своего создателя (объект, который выполнил запрос на активизацию данного объекта). Работа служб COM+ зависит от правильной активизации объекта на основе его настроек. В процессе активизации система определяет контекст для выполнения объекта, проводит инициализацию свойств контекста, проверяет разрешения на доступ и создает удостоверение для защиты. См. также безопасность активизации, способ активизации, контекст, активизация по необходимости (JIT).

активизация по необходимости (JIT)

Автоматическая служба COM+, которая позволяет простаивающим серверным ресурсам использоваться более продуктивно. Если компонент настроен на активизацию по необходимости, то COM+ деактивизирует его, даже если у клиента существует активная ссылка на данный объект. При последующих вызовах клиентом метода в объекте COM+ повторно активизирует объект прозрачно для клиента (по необходимости). См. также активизация.

Б

вернуться в начало

безопасность активизации

Форма безопасности, которая определяет, кто может запускать сервер. Безопасность активизации автоматически применяется к диспетчеру управления службами определенного компьютера. При получении запроса на активизацию объекта от клиента диспетчер управления службами сравнивает данный запрос со сведениями о безопасности активизации, которые хранятся в реестре. Кроме того, безопасность активизации также проверяется при активизациях на том же компьютере. Также называется безопасность при запуске. См. также активизация, тип активизации, безопасность вызова, Диспетчер управления службами (SCM).

безопасность вызова

Форма безопасности, которая помогает управлять доступом к методам серверных объектов после запуска сервера. См. также безопасность активизации.

безопасность на основе ролей

Служба защиты COM+ для приложений COM+. Роль представляет категорию пользователей приложения COM+ и используется для определения разрешений на доступ к ресурсам приложения. Разработчик назначает роли для компонентов, интерфейсов и методов. Администратор назначает пользователей на подходящие роли, после чего пользователь с заданной ролью получает доступ ко всем ресурсам, связанным с этой ролью.

безопасность при запуске См. безопасность активизации.

библиотечное приложение COM+

Приложение COM+, которое выполняется внутри создавшего его процесса клиента. Библиотечные приложения могут использовать безопасность на основе ролей, но они не поддерживают удаленный доступ и очереди компонентов. См. также серверное приложение COM+, безопасность на основе ролей.

В

вернуться в начало

веб-службы XML

Единицы логики приложения, предоставляющие данные и службы для других приложений. Приложения обращаются к веб-службам XML через стандартные веб-протоколы, например, через SOAP. См. также SOAP в COM+, SOAP.

взаимоблокировка

В многопотоковых приложениях сбой, вызванный потоками, который возникает, когда каждый член набора потоков ждет другого члена набора.

вложенные транзакции

Дополнительная транзакция, запущенная из существующей основной или родительской транзакции. Основная транзакция не завершается, пока не завершатся все подчиненные или вложенные транзакции. COM+ не поддерживает вложенные транзакции. См. также транзакция.

внутренний объект

В иерархии транзакций внутренним объектом называется любой объект, который расположен под корневым объектом. См. также объект COM, корневой объект.

Г

вернуться в начало

глобальный координатор транзакций

Корневой диспетчер транзакций в дереве завершения в системе распределенных транзакций на основе Microsoft Windows. Он принимает решения о завершении или прерывании транзакции и никогда не находится в состоянии под сомнением. См. также дерево завершения, распределенные транзакции, координатор распределенных транзакций, транзакция, диспетчер транзакций.

группирование объектов См. группирование объектов COM+.

группирование объектов COM+

Автоматическая служба COM+, которая позволяет настраивать компоненты для сохранения их активными в группе, чтобы они были готовы к использованию любым клиентом, которому необходим данный компонент.

группирование приложений См. группирование приложений COM+.

группирование приложений COM+

Функция служб компонентов, позволяющая масштабировать процессы с одним потоком, которая также упрощает восстановление после сбоев в одиночных процессах, позволяя другим запущенным процессам обрабатывать активизации. См. также повторный запуск приложений СOM+.

Д

вернуться в начало

двухэтапный протокол завершения

Протокол, который используется только в распределенных транзакциях, чтобы исход транзакции согласовывался для всех диспетчеров транзакций, которые участвуют в данной транзакции. Протокол выполняется в два различных этапа, чтобы полностью прервать или завершить транзакцию. Этап первый заключается в выполнении условий каждого диспетчера ресурсов, а этап второй заключается в завершении транзакции. См. также распределенные транзакции, диспетчер ресурсов, транзакция, Transaction Internet Protocol (TIP), диспетчер транзакций.

действие

В COM+ действием называется логический поток команд, состоящих из одной или нескольких транзакций и содержащий семейство компонентов, сгруппированных в приложение COM+. Каждый объект COM принадлежит одному действию. Связь между объектом и действием изменить невозможно.

дерево завершения

В системе распределенных транзакций представление транзакции основывается на иерархических отношениях между отдельными диспетчерами транзакций, участвующими в распределенных транзакциях. Включенными в данную иерархию оказываются вовлеченные в транзакцию диспетчеры ресурсов, которые связаны с диспетчерами транзакций. См. также распределенные транзакции, координатор распределенных транзакций (DTC), глобальный координатор транзакций, диспетчер ресурсов, транзакция, диспетчер транзакций.

дерево завершения транзакции См. дерево завершения.

динамическая маскировка

Форма маскировки, при которой исходное удостоверение клиента рассматривается как маркер доступа серверного потока при каждом вызове метода сервером нижнего уровня. Хотя удостоверение может быть определено динамически, но для этого могут потребоваться дополнительные дорогостоящие ресурсы. Для приложений COM+ по умолчанию используется динамическая маскировка, поскольку она обеспечивает гибкость, которая обычно необходима в условиях, когда использование олицетворения стоит на первом месте. См. также маскировка, олицетворение, статическая маскировка.

диспетчер общих свойств

В COM+ диспетчером общих свойств называется распределитель ресурсов, который используется для распространения временного состояния на несколько объектов внутри серверного процесса. См. также распределитель ресурсов.

диспетчер прокси

Диспетчером прокси в стандартной сборке называется компонент, который управляет всеми прокси интерфейсами для одиночного объекта. См. также прокси интерфейса, упаковка.

диспетчер ресурсов

Служба, которая управляет постоянными данными или данными длительного хранения в базах данных, очередями сообщений длительного хранения или файловыми системами транзакций. Диспетчер ресурсов может сохранять данные и выполнять аварийное восстановление данных. Серверные приложения COM+ используют диспетчер ресурсов для поддержки состояния сохраняемых в приложении данных, таких как записи о складских запасах, ожидаемых заказах и дебиторской задолженности. Диспетчеры ресурсов вместе с координатором распределенных транзакций Microsoft обеспечивают целостность и изолированность приложения. См. также диспетчер ресурсов с кэшем Координатор распределенных транзакций.

диспетчер ресурсов с кэшем

Диспетчер ресурсов, который действует как внешний интерфейс для другого диспетчера ресурсов и кэширует информацию локально, что снижает стоимость доступа к базовым ресурсам. В отличие от обычного диспетчера ресурсов диспетчер ресурсов с кэшем не участвует в восстановлении данных, потому что он никогда не хранит базовые данные постоянно. См. также диспетчер ресурсов.

диспетчер транзакций

Часть координатора распределенных транзакций Microsoft, который выполняется на каждом компьютере, участвует в распределенных транзакциях и управляет действиями, связанными завершением или прерыванием части транзакции. См. также Координатор распределенных транзакций.

диспетчер управления службами (SCM)

Процесс Microsoft Windows Server, который управляет всеми службами в реестре Windows.

Ж

вернуться в начало

журнал трассировки

Файл журнала автоматически создается координатором распределенных транзакций, который содержит данные, связанные с одной или несколькими распределенными транзакциями. Примером данных в журнале трассировки может служить код транзакции, время транзакции и сообщение об исходе транзакции.

З

вернуться в начало

заглушка интерфейса

Объект, представляющий интерфейс, который распаковывает собранные параметры, вызывает необходимый метод и упаковывает (собирает) значения на выходе из вызванного метода. Заглушка выполняется в адресном пространстве получателя и связывается с соответствующим прокси в адресном пространстве отправителя. См. также прокси интерфейса.

И

вернуться в начало

издатель

Отправитель события. В архитектуре событий COM+ издатель создает вызов метода, чтобы запустить событие. См. также события COM+, подписчик.

изменение состояния

Принадлежность к системе или процессу, которые отслеживают все подробности состояния действия, в котором он принимает участие. См. также неизменность состояния.

интерфейс

В модели программирования COM интерфейс — это семейство связанных общих функций, которые обеспечивают доступ к объекту COM. Набор интерфейсов в объекте COM создает контракт, в котором указаны способы взаимодействия объекта COM с другими объектами и программами. См. также класс (COM), объект COM, метод.

интерфейсы XA

Интерфейсы, позволяющие разработчикам приложений получать доступ к XA-совместимым базам данных и создавать диспетчеры ресурсов, работающие с реляционными базами данных, очередями сообщений, файлами транзакций и объектно-ориентированными базами данных. Корпорация Майкрософт не поддерживает сам протокол XA, но поддерживает средства обмена данными между транзакциями OLE и XA.

интерфейс постоянного объекта

Интерфейс COM, реализованный в постоянном объекте. Для указания расположения и времени сохранения своего состояния клиенты используют интерфейс постоянного объекта. См.также интерфейс, постоянный объект.

интерфейс уведомления нулевого этапа

Интерфейс COM+, который позволяет приложениям определить готовность транзакции к обработке при помощи двухэтапного протокола завершения, после чего приложения могут выполнить обработку и сообщить диспетчеру транзакций о ее завершении. См. также интерфейс, двухэтапный протокол завершения.

исключение

Необычное событие или ошибка, происходящие в процессе выполнения программы, которые требуют, чтобы программа работала нестандартным образом.

К

вернуться в начало

каталог COM+

Хранилище, в котором расположены данные конфигурации COM+. При выполнении административных задач COM+ необходимо обращаться в данный каталог для считывания и записи в него данных. Данный каталог доступен только с помощью программы администрирования служб компонентов или библиотеки COMAdmin.

класс (COM)

Объединенная реализация одного или нескольких интерфейсов, содержащая имя. Класс COM определяется по CLSID или, иногда, по ProgID. См. также интерфейс, метод.

компенсирующий диспетчер ресурсов

Средство COM+, которое позволяет ресурсам, не использующим транзакции, участвовать в двухэтапном завершении транзакций с помощью координатора распределенных транзакций Microsoft®. Компенсирующие диспетчеры ресурсов обычно не предоставляют полных возможностей изолированности, как это делают обычные диспетчеры ресурсов, однако они обеспечивают целостность транзакций и повышают надежность за счет ведения журнала. См. также координатор распределенных транзакций (DTC), диспетчер ресурсов, двухэтапный протокол завершения.

компонент COM

Модуль двоичного кода, который включает в себя код упаковки и регистрации и создает объекты COM. Все приложения COM+ состоят из одного или нескольких компонентов COM.

контекст

Набор свойств, связанных с одним или несколькими объектами COM, который используется для работы служб с этими объектами. Каждый объект COM выполняется в одном контексте от активизации до деактивизации (всегда внутри одного контейнера). Свойства контекста, запущенные при активизации объекта, такие как свойства контекста безопасности, являются необходимыми для работы объекта. См. также активизация.

концептуальная модель

Первый шаг при разработке приложения COM+, на котором разработчик определяет задачи, которые требуется решить, а также необходимые компоненты и службы. См. также логическая модель, физическая модель, модель трехуровневой архитектуры.

координатор распределенных транзакций

Системная служба, которая управляет транзакциями и связанными с транзакциями подключениями, распределенными между двумя и более диспетчерами ресурсов на одном или нескольких компьютерах, помогающая убедиться в правильности ЦСИД транзакций. См. также свойства ЦСИД, распределенные транзакции, транзакция, диспетчер транзакций.

корневой объект

Первый объект транзакции, называемый корневым объектом транзакции, всегда расположен в пределах новой транзакции. В транзакции есть только один корневой объект. Другие объекты в иерархии транзакции расположены под корневым объектом и называются внутренними объектами. См. также объект COM, внутренний объект.

Л

вернуться в начало

логическая модель

Второй шаг при разработке приложения COM+, на котором концептуальная модель переходит на логический уровень трехуровневой архитектуры. Данная трехуровневая архитектура имеет следующий вид: уровень презентации или служб пользователя; средний уровень или рабочие службы; уровень данных или службы данных. См. также концептуальная модель, уровень данных, средний уровень, физическая модель, уровень презентации, модель трехуровневой архитектуры.

М

вернуться в начало

маркер доступа

Объект, описывающий контекст безопасности процесса или потока. Сведения в маркере включают в себя удостоверение и привилегии учетной записи пользователя, связанного с процессом или потоком. При входе пользователя система проверяет его пароль путем сравнения его со сведениями, хранящимися в базе данных безопасности. Если пароль проходит данную проверку, то система создает маркер доступа. Каждый процесс выполняется под управлением данного маркера. Пользователь имеет копию данного маркера доступа. См. также контекст, основной маркер доступа.

маскировка

Возможность сервера скрывать свое удостоверение при вызовах от имени клиента. Если маскировка включена, то при вызовах сервер может олицетворять клиента, используя его удостоверение. Если маскировка отключена, то сервер осуществляет вызовы со своим собственным удостоверением. См. также динамическая маскировка, олицетворение, статическая маскировка.

мета-событие

Тип события, используемый системой событий COM+ для уведомления заинтересованных подписчиков о создании, изменении или перемещении объектов классов событий или подписок. См. также события COM+, событие, объект EventClass.

метод

В программировании COM методом называется процесс, выполняемый объектом COM при получении сообщения. См. также объект COM, интерфейс.

метод события

Метод в интерфейсе COM+, который определяет событие COM+. Методы событий должны иметь уникальное имя и могут содержать только входные параметры. Значение на выходе должно быть HRESULT. См. также интерфейс, метод.

модель нейтрального контейнера

Потоковая модель, в которой объекты следуют инструкциям для контейнеров с несколькими потоками, однако могут выполняться в любом потоке. Модель нейтрального контейнера является рекомендуемой для компонентов COM и приложений COM+. См. также процесс модели контейнера, процесс со свободными потоками, процесс со смешанной моделью, модель контейнера с несколькими потоками, процесс с одним потоком.

модель контейнера с несколькими потоками

Модель контейнера, в которой все потоки в процессе, запущенные как свободные, располагаются в одном контейнере. Поэтому нет необходимости собирать различные потоки. Поскольку в данной модели COM не использует окно сообщений, то потоки не извлекают и не отправляют сообщения. См. также процесс модели контейнера, процесс со свободными потоками, процесс со смешанной моделью, модель нейтрального контейнера, процесс с одним потоком.

модель трехуровневой архитектуры

Основная структура для логического создания модели. Сегменты компонентов приложения в данной модели идут в следующем порядке: уровень презентации или служб пользователя; средний уровень или рабочие службы; уровень данных или службы данных. Эти уровни необязательно представляют физическое размещение компьютеров в сети. Они представляют логические уровни приложения. См. также концептуальная модель, уровень данных, логическая модель, средний уровень, физическая модель, уровень презентации.

моникер

Имя, которое является уникальным для объекта COM. Как путь определяет файл в файловой системе, так моникер определяет объект в каталоге пространства имен. См. также объект COM.

моникер очереди

Имя, используемое для активизации очереди компонента. См. также очередь компонентов COM+, моникер.

Н

вернуться в начало

наборы разделов См. наборы разделов COM+.

наборы разделов COM+

Группа разделов COM+, сопоставленная с определенным идентификатором пользователя в Active Directory.

настроенный компонент

Компонент COM, который был установлен в приложение COM+. После установки настройки компонента записываются в каталог COM+, после чего он получает возможность использовать все доступные службы COM+. См. также компонент COM, ненастроенный компонент.

неизменность состояния

Принадлежность к системе или процессу, который принимает участие в действии, но не отслеживает все подробности его состояния. См. также изменение состояния.

ненастроенный компонент

Компонент COM, который не был настроен в каталоге COM+. Ненастроенные компоненты не могут использовать службы COM+. См. также компонент COM, настроенный компонент.

О

вернуться в начало

объект См. объект COM.

объект COM

В модели программирования COM структура программирования инкапсулирует данные и функциональность, которые определены и организованы в виде единого модуля. Единственным способом доступа к ним является использование интерфейсов структуры программирования. Как минимум, объект COM должен поддерживать интерфейс IUnknown, который обслуживает объект в процессе его использования и обеспечивает доступ к другим интерфейсам объекта. См. также интерфейс, метод, псевдообъект.

объект класса события

Настроенный компонент, предоставляющий постоянную запись в системе событий COM+ для описания издателей и интерфейсов для запуска, связанных с этими издателями. См. также события COM+.

объект подписки

В системе событий COM+ объектом подписки является объект, созданный подписчиком для запроса и управления доставкой событий. См. также события COM+, подписчик.

объект события

Объект COM, который может сообщить одному или нескольким потокам о том, что событие произошло, т.е. работает как регулировщик дорожного движения. Любой поток процесса может создать объект события. См. также объект COM.

объект-перечислитель

Позволяет осуществлять нумерацию элементов в семействе компьютеров. См. также объект COM.

олицетворение

Возможность потока выполняться в контексте безопасности, отличном от контекста безопасности процесса, который владеет данным потоком. Серверный поток использует маркер доступа, который представляет учетные записи клиента, и с этим маркером данный поток получает доступ к ресурсам, к которым есть доступ у клиента. См. также маркер доступа, контекст, уровень олицетворения.

одновременный доступ

Возможность нескольких транзакций или процессов иметь одновременный доступ к одним и тем же данным. Обычно COM+ управляет одновременным доступом с помощью синхронизации. См. также синхронизация.

основной маркер доступа

Основной маркер доступа описывает контекст безопасности учетной записи пользователя, связанной с процессом. См. также маркер доступа, контекст.

отказоустойчивость

В кластерных сетевых системах процесс перемещения загруженного или отказавшего ресурса, такого как сервер, диск или сеть, на дублирующий элемент.

Очереди компонентов COM+

Служба COM+, основанная на службе очередей сообщений Microsoft®, которая обеспечивает простой способ асинхронного создания и выполнения компонентов. Обработка сообщений происходит независимо от доступности отправителя или получателя.

очередь компонентов См. очередь компонентов COM+.

П

вернуться в начало

перехват

Процесс обработки вызовов объекта, поступивших из-за пределов контекста, при активизации объекта в данном контексте. Межконтекстный вызов обрабатывается с помощью облегченного прокси интерфейса, который будет обрабатывать такой вызов при любом необходимом посредничестве, для настройки среды, чтобы в одной располагался вызывающий, а в другой — вызываемый. См. также активизация, контекст, прокси интерфейса.

повторный запуск приложений См. повторный запуск приложений COM+.

повторный запуск приложений COM+

Функция служб компонентов, которая существенно повышает общую стабильность работы приложений за счет того, что позволяет постепенно завершить процесс, соответствующий приложению, и повторно запустить его. См. также группирование приложений СOM+.

подписчик

Получатель события. В архитектуре событий COM+ подписчик получает вызовы, сделанные издателем. См. также события COM+, издатель.

постоянный объект

Объект COM, который может по требованию клиента сохранить свое внутреннее состояние. Это соответствует стандартам COM, по которым клиенты отправляют запрос на выполнение объекта, его загрузку и сохранение в хранилище данных (например, однородный файл, структурированное хранилище или память). Клиент должен управлять расположением, где хранятся постоянные данные объекта, но не форматом данных. См. также объект COM, постоянный интерфейс объекта.

представитель

Форма олицетворения, при которой сервер имеет право выполнять действия от имени клиента. Сервер может олицетворять клиентов по сети. См. также олицетворение.

приложение COM+

Основная единица администрирования и безопасности служб компонентов. Приложением COM+ является группа компонентов COM, которые выполняют схожие функции. Компоненты состоят из интерфейсов и методов COM. См. также интерфейс, метод.

приложение обработки транзакций

Семейство операций транзакций, которые автоматизируют данную задачу. См. также распределенные транзакции, транзакция, система обработки транзакции.

проверка подлинности

Процесс проверки сведений, указанных во входящих вызовах, и проверка подлинности запросов удостоверений. Для приложений COM+ проверка подлинности является средством, которое можно включить и настроить административным образом, после чего оно явно работает с приложением.

программа администрирования служб компонентов

Программа администрирования служб компонентов, представленная в операционной системе Microsoft Windows® 2000, представляет собой средство, с помощью которого администраторы и разработчики создают, настраивают и поддерживают работу приложений COM+, а также администрируют распределенные транзакции и резидентные базы данных. Она также позволяет просматривать системные события и управлять службами на локальном компьютере, где они установлены.

программа перемещения сообщений

Элемент архитектуры службы очередей компонентов COM+, который перемещает сообщения с ошибками в исходную входную очередь для повторной обработки. См. также очередь компонентов COM+, программа прослушивания, проигрыватель, средство записи.

программа прослушивания

Элемент архитектуры службы очередей компонентов COM+. Программа прослушивания — это объект COM, который открывает очередь сообщений, связанную с главным приложением, и ожидает приема сообщений. По мере поступления сообщений программа прослушивания открывает потоки команд для обработки сообщений. См. также очередь компонентов COM+, программа перемещения сообщений, проигрыватель, средство записи.

проигрыватель

Элемент архитектуры службы очередей компонентов COM+, который получает сообщения из очереди, загружает серверный объект, применяет стандартные заглушки интерфейсов для разборки данных и вызывает методы сервера. Проигрыватель разбирает контекст безопасности клиента со стороны сервера, а затем вызывает серверный компонент и делает вызов того же метода. Вызовы метода не совершаются со стороны проигрывателя, пока компонент клиента и транзакции, записанные в вызовах метода, завершаются. См. также очередь компонентов COM+, программа прослушивания, программа перемещения сообщений, средство записи.

прокси для приложения

Набор файлов со сведениями о регистрации, позволяющий клиенту осуществлять удаленный доступ к серверному приложению COM+. После установки на клиентский компьютер прокси для приложения записывает на компьютер сведения о серверном приложении. Затем клиент может осуществлять удаленный доступ к серверному приложению.

прокси интерфейс

Объект, представляющий интерфейс, который упаковывает (собирает) параметры для данного интерфейса, вызывает удаленный метод, а затем распаковывает (разбирает) значения на выходе из заглушки интерфейса. Прокси выполняется в адресном пространстве отправителя и связывается с соответствующей заглушкой в адресном пространстве получателя. См. также заглушка интерфейса.

процесс модели контейнера

Процесс, содержащий два или более контейнеров с одним потоком и не содержащий контейнеров с несколькими потоками. См. также процесс со свободными потоками, процесс со смешанной моделью, модель контейнера с несколькими потоками, модель нейтрального контейнера, процесс с одним потоком.

процесс с одним потоком

Процесс, состоящий из одного контейнера с одним потоком. Все объекты COM, находящиеся в контейнере с одним потоком, могут получать вызовы методов только из единственного потока, который принадлежит данному контейнеру. См. также процесс модели контейнера, процесс со свободными потоками, процесс со смешанной моделью, модель контейнера с несколькими потоками, модель нейтрального контейнера.

процесс со свободными потоками

Процесс, содержащий контейнер с несколькими потоками и не содержащий контейнеров с одним потоком. См. также процесс модели контейнера, процесс со смешанной моделью, модель контейнера с несколькими потоками, модель нейтрального контейнера, процесс с одним потоком.

процесс со смешанной моделью

Процесс, содержащий контейнер с несколькими потоками и один или несколько контейнеров с одним потоком. См. также процесс модели контейнера, процесс со свободными потоками, модель контейнера с несколькими потоками, модель нейтрального контейнера, процесс с одним потоком.

псевдообъект

Тип содержащегося объекта, например, выбранный пользователем документ, диапазон ячеек или диапазон символов в текстовом документе. Такой тип объекта называется псевдообъектом, поскольку он не рассматривается как отдельный объект, пока пользователь сохраняет выделение. См. также объект COM.

Р

вернуться в начало

разделы См. разделы COM+.

Разделы COM+

Служба COM+, с помощью которой на одном компьютере можно создать отдельные области для запуска приложений.

разделенная регистрация

Для компонентов, которые уже являются компонентами COM и используются в среде служб COM+, разделенная регистрация является способом, при котором основные аспекты регистрации COM хранятся в реестре Windows, а новые службы и атрибуты COM+ (например, очередь компонентов) хранятся в регистрационной базе данных COM+. Каждый атрибут компонента хранится либо в реестре Windows, либо в регистрационной базе данных COM+. Новые компоненты COM регистрируются только в регистрационной базе данных COM+, а некоторые создают дубликаты в реестре Windows, чтобы существующие средства могли их использовать.

распределенные транзакции

Транзакции, которые включают несколько диспетчеров ресурсов на одном или на разных компьютерах. См. также транзакция.

распределитель ресурсов

В модели программирования COM+ распределитель ресурсов управляет временными ресурсами общего доступа от имени компонентов приложения внутри процесса. Распределители ресурсов подобны диспетчерам ресурсов, но не гарантируют долгосрочность ресурсов. См. также диспетчер общих свойств.

С

вернуться в начало

сведения о местонахождении

Для транзакций DTC это непрозрачная структура данных, которая представляет собой адрес диспетчера транзакция для диспетчера ресурсов.

свойства ЦСИД

Данное сокращение состоит из первых букв состояний обработки процесса: целостность, согласованность, изолированность и долговечность. Эти свойства позволяют обеспечивать предсказуемое поведение, усиливают роль транзакций в качестве средства, созданного для обеспечения согласования и предсказуемости результата в распределенных средах при возникновении независимых ошибок.

семафор

Объект ядра, используемый для разрешения доступа к общим ресурсам.

серверное приложение COM+

Приложение COM+, выполняемое в собственном процессе. Серверные приложения поддерживают все службы COM+. См. также библиотечное приложение СOM+.

сильно связанное событие

Событие, отправитель которого (издатель), тесно связан с получателем (подписчик). В системе с сильно связанными событиями издатель имеет интерфейс, в котором при возникновении изменений вызывается необходимый метод. Подписчик знает, от какого издателя запросить уведомление и интерфейс, который он представляет. Для системы с сильно связанными событиями необходимо, чтобы и издатель, и подписчик выполнялись постоянно. См. также события COM+, слабо связанное событие.

синхронизация

В COM+ синхронизацией является служба, которая переходит от одного компонента к другому и запрещает нескольким вызывающим входит в компонент одновременно. Синхронизация определяет время открытия потоками вызовов к объекту.

система обработки транзакций

Полная система, содержащая как оборудование, так и программное обеспечение, на котором расположено приложение обработки транзакций, для выполнения обычных транзакций, необходимых для работы. См. также распределенные транзакции, транзакция, приложение обработки транзакций.

слабо связанное событие

Событие, отправитель которого (издатель), не связан тесно с получателем (подписчик). В системе со слабо связанными событиями, такими как события COM+, сведения о событии от различных издателей хранятся в хранилище событий. Подписчик отправляет запрос в это хранилище и выбирает события, которые необходимо получить. При выборе сведений о событии из хранилища событий создается подписка. Если событие происходит, то система событий выполняет в базе данных поиск заинтересованных подписчиков, создает новый объект для каждого заинтересованного класса и вызывает метод в объекте. См. также события COM+, подписчик.

событие

Действие, которое объект может распознать (например, щелчок кнопкой мыши или нажатие клавиши), и для которого можно создать код для отклика. См. также события COM+.

события COM+

События COM+ соотносят и соединяют издателей и подписчиков через слабо связанную систему событий. Издатель выполняет вызов метода для запуска события, а подписчик принимает эти вызовы через систему событий, а не напрямую от издателя. Служба событий COM+ ведет список заинтересованных подписчиков, которые получают вызовы, и передает эти вызовы, не извещая издателя. См. также слабо связанное событие, издатель, подписчик, сильно связанное событие.

состязание

В многопотоковом приложении ситуация, которая возникает, если несколько потоков получают доступ к элементу данных без координации, возможно вследствие несогласованности результатов, в зависимости от того, какой поток первым достигнет элемента. COM поддерживает некоторые функции, разработанные специально, чтобы избежать подобного состязания на серверах, которые не участвуют в процессе. См. также модель контейнера с несколькими потоками.

способ активизации

Категория активизации приложения COM+, которая определяет, будет ли приложение выполняться внутри или вне пространства клиентского процесса (в зависимости от того, является ли приложение соответственно библиотечным или серверным), а также запускается ли приложение как служба NT. См. также библиотечное приложение COM+, серверное приложение COM+.

средний уровень

В модели трехуровневой архитектуры приложений для бизнеса средним уровнем является уровень, обобщающий правила данных и деловую логику. Компоненты, представленные на среднем уровне, могут использоваться для создания деловых правил, таких как алгоритм ведения бизнеса, правовые и государственные аспекты регулирования, которые разработаны для сохранения структуры данных согласованной с одной или несколькими базами данных. Поскольку компоненты среднего уровня соответствуют различным клиентам, то они могут использоваться всеми приложениями и в соответствии с правилами могут быть перенесены в другое размещение. Также называется уровень рабочих служб или уровень деловой логики. См. также уровень данных, уровень презентации, модель трехуровневой архитектуры.

средство записи

Элемент архитектуры службы очередей компонентов COM+, который собирает контекст безопасности клиента в сообщение и записывает все вызовы методов для объектов. Средство записи является системным диспетчером прокси, который отбирает поддерживающие очереди интерфейсы из каталога COM+. См. также очередь компонентов COM+, каталог COM+, программа прослушивания, программа перемещения сообщений, проигрыватель.

статическая маскировка

Форма маскировки, при которой исходное удостоверение клиента может быть предоставлено серверу низшего уровня один раз, и настройка исходного удостоверения клиента выполнена один раз на прокси. Удостоверение клиента представляется в качестве маркера серверного потока, который используется при последовательных вызовах методов. См. также маскировка, динамическая маскировка, олицетворение.

Т

вернуться в начало

транзакция

Единица работы, в которой отображается серия связанных операций, выполняющихся в процессе работы приложения. Транзакция выполняется только один раз и обладает свойством целостности - либо выполняются все составляющие транзакции, либо ни одна из них. См. также распределенные транзакции.

У

вернуться в начало

упаковка

Процесс упаковки и распаковки параметров метода интерфейса в пределах потока или процесса таким образом, что происходит вызов удаленной процедуры.

уровень данных

В модели трехуровневой архитектуры приложений для бизнеса доступ к СУБД может быть осуществлен со среднего уровня или уровня рабочих служб и, иногда, с уровня презентаций или уровня служб пользователя. Уровень данных состоит из компонентов доступа к данным (отличных от ряда подключений СУБД), чтобы облегчить совместный доступ к ресурсам и разрешить клиентам настройку без установки библиотек СУБД и драйверов ODBC для каждого клиента. Также называется уровень служб данных. См. также средний уровень, уровень презентации, модель трехуровневой архитектуры.

уровень олицетворения

Настройка, которая используется клиентом для предоставления серверу определенных прав на выполнение действий от своего имени. В COM+ данный уровень может быть настроен только для серверных приложений COM+.

уровень презентации

В модели трехуровневой архитектуры приложений для бизнеса уровнем презентации является уровень, на котором данные предоставляются пользователю совместно с некоторыми разрешениями на работу с ними. Двумя основными типами интерфейса пользователя для уровня презентации являются обычное приложение и веб-приложение. Также называется уровень служб пользователя. См. также уровень данных, средний уровень, модель трехуровневой архитектуры.

устаревшие компоненты

Ненастроенный компонент COM, который был установлен в приложение COM+. См. также компонент COM, настроенный компонент, ненастроенный компонент.

Ф

вернуться в начало

файл .msi

Файл, создаваемый программой администрирования служб компонентов при экспорте приложения COM+ или прокси для приложения с целью установки на другой компьютер. Файл .msi может быть установлен на любом клиенте с операционной системой Windows с помощью установщика Windows Installer. См. также прокси для приложения, приложение COM+, программа администрирования служб компонентов.

физическая модель

Третий и последний шаг в процессе разработки приложения COM+, на котором разработчик определяет физическое расположение компонентов и способ их кодировки. См. также концептуальная модель, логическая модель, уровень презентации, модель трехуровневой архитектуры.


Administering (D)COM Applications

Администрирование приложений (D)COM

Модель Component Object Model (COM) дает возможность инкапсулировать функциональные возможности в приложении COM, которое затем может использоваться многочисленными другими приложениями. Технология Distributed COM (DCOM) позволяет даже обращаться к приложению COM с другого компьютера по сети.

Разделы, указанные в следующей таблице, содержат подробные сведения о понятиях и задачах, связанных с администрированием приложений COM.

Раздел | Описание
Концепции администрирования COM | Обзор и ссылки на более подробные сведения по администрированию приложений COM.
Задачи администрирования COM | Ссылки на пошаговые процедуры администрирования приложений COM.


COM Administration Concepts

Концепции администрирования COM

Обсуждение следующих тем в этом разделе дает подробную информацию об администрировании приложений COM.

  • Настройка безопасности COM


COM Security Settings

Настройка безопасности COM

Приложения COM (например, Microsoft® Word) используют ряд свойств конфигурации безопасности: уровень проверки подлинности, уровень олицетворения, разрешения на доступ, разрешения на запуск и разрешения на настройку. Для каждого из этих свойств определено значение на уровне компьютера, которое используется по умолчанию для всех приложений. Кроме того, существует возможность задания индивидуальных свойств настройки безопасности COM для любого приложения. Если для приложения не заданы собственные настройки безопасности, используются настройки, заданные на уровне компьютера. Политика ограничений, заданная на уровне компьютера, определяет минимальный уровень безопасности, который не может быть изменен параметрами безопасности на уровне машины или приложения.

Требования безопасности для определенных приложений или определенных систем могут вызвать необходимость изменения настроек безопасности на уровне компьютера. Вы можете менять настройки безопасности для конкретного приложения COM или компьютера, а также политику ограничений на уровне компьютера с помощью программы служб компонентов (Component Services).

Настройка безопасности для компьютера

Приложение COM может использовать для каждого свойства безопасности COM либо значение, заданное на уровне компьютера, либо индивидуальное значение. Если для приложения заданы индивидуальные настройки безопасности, то настройки, заданные на уровне компьютера, игнорируются. Приложения, не имеющие собственных настроек безопасности, используют настройки, заданные для компьютера.

Если значения по умолчанию не удовлетворяют требованиям безопасности приложений в вашей системе, то для изменения настроек безопасности на уровне компьютера можно использовать службы компонентов (Component Services). Cледует, однако, помнить, что изменение настроек безопасности для всего компьютера влияет на каждое приложение COM, не настроенное индивидуально пользователем.

Если вам подходят настройки по умолчанию, заданные для всего компьютера, больше ничего делать не нужно. Ниже перечислены настройки безопасности COM, используемые по умолчанию для компьютера.

  • Уровень проверки подлинности: Связь.

  • Уровень олицетворения: Идентификация.

  • Разрешения на доступ предоставляются удостоверению сервера и локальной системе.

  • Полное имя состоит из имени пользователя и пароля.

  • Базовая служба безопасности, которую COM считает лучшей для данной среды. В 2000, Windows XP и Windows Server 2003 это служба Kerberos или NTLMSSP

Для получения более подробных сведений о настройке уровней безопасности в COM см. разделы, описанные в следующей таблице.

Раздел | Описание
Уровень проверки подлинности | Обзор уровней, на которых выполняется взаимная проверка соответствия удостоверений и учетных данных клиентом и сервером, а также проверка и шифрование данных, которыми они обмениваются.
Уровень олицетворения | Описание уровней, на которых сервер делает вызовы от имени клиента, указывая при этом удостоверение и учетные данные клиента, а не свои собственные.
Разрешения на доступ | Описание разрешений, определяющих список пользователей, которым разрешен или запрещен доступ к приложениям COM.
Разрешения на запуск и активацию | Обзор разрешений, определяющих список пользователей, которым разрешен или запрещен запуск или использование приложений COM.
Отслеживание ссылок | Описание механизма, с помощью которого COM выполняет дополнительные проверки подлинности вызовов на подсчет ссылок и ведет учет дополнительных сведений с целью предохранения объектов от слишком раннего освобождения, совершенного случайно или злонамеренно.


Authentication Level

Уровень проверки подлинности

Проверка подлинности – это процесс, в ходе которого клиент и сервер проверяют подлинность друг друга с помощью учетных данных, а также проверяют и шифруют данные, которыми обмениваются.

Заданное значение уровня проверки подлинности определяет уровень проверки подлинности, необходимый для взаимодействия с приложением (когда приложение посылает или принимает вызовы). Повышение уровня проверки подлинности обеспечивает большую безопасность и целостность данных, однако обычно несколько снижает производительность.

С помощью программы служб компонентов можно изменить уровень олицетворения для всего компьютера. Эта настройка, заданная на уровне компьютера, используется в случае, если приложение COM не задает собственный уровень проверки подлинности программным путем. По умолчанию уровень проверки подлинности для всего компьютера – это Связь.

Пошаговые инструкции по заданию уровней см. в разделе Задание уровня проверки подлинности для компьютера.

Ниже перечислены допустимые уровни проверки подлинности в порядке повышения безопасности.

Уровень | Описание
Нет | Проверка подлинности не выполняется.
Связь | Проверка подлинности выполняется только при установке подключения.
Вызов | Проверка подлинности выполняется в начале каждого вызова.
Пакет | Выполняется проверка подлинности пакета и проверяется, что все данные вызова получены.
Целостность пакетов | Выполняется проверка подлинности пакета и проверяется, что никакие данные не были изменены при передаче.
Секретность пакетов | Выполняется проверка подлинности пакета и его шифрование, включая данные, удостоверение отправителя и его подпись.


Impersonation Level

Уровень олицетворени

Олицетворением называется ситуация, в которой сервер делает вызовы от имени клиента, указывая при этом удостоверение и учетные данные клиента, а не свои собственные. Это возможно только в случае, если клиент явно предоставляет серверу разрешение на использование своего удостоверения.

Настройка уровня олицетворения используется клиентом для предоставления серверу определенных прав на выполнение действий от имени этого клиента. Самый высокий уровень доверия требуется серверу, чтобы олицетворять клиента в сети. Для олицетворения клиента в пределах компьютера достаточно иметь уровень олицетворения Олицетворение; для олицетворения в сети используется уровень олицетворения Представитель. Чтобы воспользоваться предоставленным правом, серверное приложение должно выполняться с удостоверением, помеченным службой Active Directory как «Доверенный представитель». Чтобы клиент мог предоставить серверу права представителя, удостоверение этого клиента не должно иметь пометки службы Active Directory «Учетная запись не допускает представителей». (Дополнительные сведения об удостоверениях и представителях см. в разделе Удостоверение приложения.)

С помощью программы служб компонентов можно изменить уровень олицетворения для всего компьютера. Этот уровень используется по умолчанию в том случае, если конкретный клиент COM на этом компьютере не задает собственный уровень олицетворения программным путем. По умолчанию уровень олицетворения для компьютера – Идентификация.

Пошаговые инструкции см. в разделе Задание уровня олицетворения для компьютера.

Ниже перечислены допустимые уровни проверки подлинности в порядке повышения безопасности.

Уровень | Описание
Анонимное | Клиент является анонимным для сервера. Сервер может выступать от имени клиента, однако дескриптор олицетворения (локальные учетные данные) не содержит никаких сведений о клиенте.
Идентификация | Сервер может получить удостоверение клиента и выступать от его имени при проверке по спискам управления доступом.
Олицетворение | Сервер может олицетворять клиента, действуя от его имени, со следующими ограничениями. Сервер получает доступ ко всем ресурсам на компьютере клиента. Если сервер выполняется на том же компьютере, что и клиент, он получает доступ к сетевым ресурсам от лица клиента. Если сервер выполняется на другом компьютере, он получает доступ только к ресурсам, расположенным на компьютере сервера.
Представитель | Сервер может выступать от имени клиента независимо от того, выполняется ли он на одном или на разных компьютерах с клиентом. При олицетворении все учетные данные клиента (и локальные, и сетевые) могут быть переданы на любое число компьютеров.


Access Permissions

Разрешения на доступ

Разрешения на доступ определяют список пользователей, которым разрешен или запрещен доступ к приложениям COM. Разрешения на доступ, заданные на уровне компьютера, применяются ко всем приложениям COM, в которых не определены собственные разрешения на доступ.

Разрешения на доступ могут быть заданы отдельно для каждого приложения COM. Разрешения на доступ, заданные на уровне компьютера, применяются ко всем приложениям COM, в которых не определены собственные разрешения на доступ. Политика ограничений, принятая для компьютера, ограничивает разрешения на доступ, которые могут быть предоставлены при любом из этих двух сценариев.

Разрешения на доступ делятся на разрешение локального доступа и разрешение удаленного доступа. Пользователи с разрешением локального доступа имеют право на доступ к приложению COM, работающему на том же компьютере, что и вызывающий клиент. Пользователи с разрешением удаленного доступа имеют право на доступ к приложению COM с других компьютеров через сетевое соединение.

Программа служб компонентов позволяет добавлять и удалять учетные записи пользователей и групп из списка пользователей, которым предоставлены разрешения на доступ. На приложения COM+ это не влияет.

Политика ограничений, принятая для компьютера, ограничивает разрешения на доступ, которые могут быть предоставлены приложениям COM. Администратор может использовать предельные значения из политики ограничений, принятой для компьютера, для переопределения менее строгих разрешений, используемых по умолчанию на уровне приложения или компьютера. По умолчанию политика ограничений, принятая для компьютера, разрешает предоставлять разрешения на локальный и удаленный доступ членам группы «Все», а разрешения только на локальный доступ – членам группы «Все» и «Анонимному» пользователю. Если системная политика исключает «Анонимного» пользователя из группы «Все», анонимные клиенты не могут обращаться к приложениям COM с других компьютеров.

Пошаговые инструкции по изменению этих настроек см. в разделах Настройка разрешений на доступ для компьютера или Настройка разрешений на доступ для приложения.


Launch and Activation Permissions

Разрешения на запуск и активацию

Разрешения на запуск и активацию определяют список пользователей, которым разрешено или запрещено запускать или активировать приложения COM. Разрешение на запуск требуется для запуска нового приложения COM. Разрешение на активацию требуется для использования приложения COM, даже если это приложение уже было запущено.

Можно задать отдельные разрешения на запуск и активацию для каждого приложения COM. Разрешения на запуск и активацию, заданные на уровне компьютера, применяются к приложениям COM, для которых не определены собственные разрешения на запуск. Политика ограничений, принятая для компьютера, ограничивает разрешения на запуск и активацию, которые могут быть предоставлены при любом из этих двух сценариев.

Разрешения на запуск и активацию делятся на разрешения локальных и удаленных запуска и активации. Пользователи с разрешением на локальные запуск и активацию имеют право запустить и использовать приложение COM, работающее на том же компьютере, что и вызывающий клиент. Пользователи с разрешением на удаленный запуск и активацию имеют право запускать и использовать приложение COM с других компьютеров через сетевое соединение.

Программа служб компонентов позволяет добавлять и удалять учетные записи пользователей и групп из списка пользователей, которым предоставлены разрешения на запуск и активацию на уровне компьютера. На приложения COM+ это не влияет.

Политика ограничений, принятая для компьютера, ограничивает разрешения на запуск и активацию, которые могут быть предоставлены приложениям COM. Администратор может использовать предельные значения из политики ограничений, принятой для компьютера, для переопределения менее строгих разрешений, используемых по умолчанию на уровне приложения или компьютера. По умолчанию политика ограничений, принятая для компьютера, позволяет предоставить разрешения на локальные и удаленные запуск и активацию членам группы «Администраторы», а разрешения на локальные запуск и активацию – членам группы «Все». Если системная политика исключает «Анонимного» пользователя из группы «Все», анонимные клиенты не могут запускать или активировать приложения COM с других компьютеров.

Пошаговые инструкции по изменению этих настроек см. в разделах Настройка разрешений на доступ на запуск и активацию для компьютера и Настройка разрешений на запуск и активацию для приложения.


Reference Tracking

Отслеживание ссылок

Если включен механизм отслеживания ссылок, называемый также подсчетом безопасных ссылок, COM выполняет дополнительные проверки подлинности для вызовов на подсчет ссылок и хранит дополнительные сведения для защиты объектов от слишком раннего освобождения (случайного или злонамеренного). Включение отслеживания ссылок повышает безопасность системы, но может снизить ее производительность. Отслеживание ссылок не поддерживается для уровня проверки подлинности по умолчанию (Нет) и для уровня олицетворения по умолчанию (Анонимное).

Пошаговые инструкции см. в разделе Настройка отслеживания ссылок для компьютера.


COM Administration Tasks

Задачи администрирования COM

Разделы данной главы содержат пошаговые инструкции по администрированию приложений COM.

  • Настройка размещения приложения COM

  • Настройка удостоверения приложения COM

  • Настройка безопасности COM для компьютера

  • Настройка безопасности COM для приложения


Setting the Location of a COM Application

Настройка размещения приложения COM

Свойство размещения сообщает среде COM о том, на каком компьютере должно выполняться приложение COM.

Для настройки размещения приложения COM сделайте следующее.

  1. В дереве консоли программы служб компонентов щелкните правой кнопкой мыши приложение DCOM, которое хотите изменить, и выберите пункт Свойства.

  2. Откройте вкладку Размещение.

  3. Отметьте флажком место, где должно работать приложение. Чтобы приложение выполнялось не на текущем компьютере или не на том компьютере, где находятся данные, выберите Выполнять приложение на следующем компьютере и введите NetBIOS-имя нужного компьютера.


Setting the Identity of a COM Application

Настройка удостоверения приложения COM

Свойство удостоверения сообщает среде COM о том, на каком компьютере должно выполняться приложение COM.

Для настройки удостоверения приложения COM сделайте следующее.

  1. В дереве консоли программы служб компонентов щелкните правой кнопкой мыши на приложении DCOM, которое хотите изменить, и выберите пункт Свойства.

  2. Откройте вкладку Удостоверение.

  3. Нажмите кнопку, обозначающую удостоверение, с которым должно работать приложение.


Setting Machine-Wide COM Security Configuration

Настройка безопасности COM для компьютера

Программа администрирования служб компонентов позволяет выполнить настройку на уровне компьютера свойств безопасности COM, которые используются приложениями COM. Дополнительные сведения об использовании этих средств безопасности см. в разделе Настройка безопасности COM.

В данном документе содержатся пошаговые инструкции по выполнению следующих задач.

  • Настройка уровня проверки подлинности для компьютера

  • Настройка уровня олицетворения для компьютера

  • Настройка разрешений на доступ для компьютера

  • Настройка разрешений на запуск и активацию для компьютера

  • Настройка отслеживания ссылок для компьютера


Setting the Machine-Wide Authentication Level

Настройка уровня проверки подлинности для компьютера

Уровень проверки подлинности, заданный для всего компьютера, определяет уровень, на котором клиентские и серверные приложения COM проверяют подлинность удостоверений друг друга при вызовах. Чтобы включить безопасность для компьютера, необходимо выбрать для него любой уровень проверки подлинности, кроме Нет. Дополнительные сведения см. в разделе Уровень проверки подлинности.

Для задания уровня проверки подлинности для компьютера выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на компьютере, для которого требуется изменить уровень проверки подлинности, и выберите пункт Свойства.

  2. Откройте вкладку Свойства по умолчанию.

  3. Установите флажок Разрешить использование DCOM на этом компьютере.

  4. В поле Уровень проверки подлинности по умолчанию выберите параметр, отличный от Нет.

  5. Нажмите кнопку ОК.

Новый уровень проверки подлинности для компьютера вступает в действие при следующем запуске приложения на этом компьютере. Внесенные изменения не влияют на выполняющиеся в данный момент приложения до их перезапуска.


Setting the Machine-Wide Impersonation Level

Настройка уровня олицетворения для компьютера

Уровень олицетворения, заданный клиентом, определяет предоставляемые серверу права на выполнение действий от имени клиента. Уровень олицетворения, заданный для всего компьютера, используется по умолчанию в том случае, если конкретный клиент на этом компьютере не указывает собственный уровень олицетворения программным путем. Общие сведения см. в разделе Уровень олицетворения.

Для задания уровня олицетворения для компьютера выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на компьютере, для которого требуется изменить уровень олицетворения, и выберите пункт Свойства.

  2. Откройте вкладку Свойства по умолчанию.

  3. Установите флажок Разрешить использование DCOM на этом компьютере.

  4. В поле Уровень олицетворения по умолчанию выберите нужный уровень.

  5. Нажмите кнопку ОК.

Новый уровень олицетворения для компьютера вступает в действие при следующем запуске приложения на этом компьютере. Внесенные изменения не влияют на выполняющиеся в данный момент приложения до их перезапуска.


Setting Machine-Wide Access Permissions

Задание разрешений на доступ на уровне компьютера

Разрешения на доступ, заданные на уровне компьютера, определяют пользователей, которым предоставляется или запрещается доступ к приложениям COM. С помощью программы служб компонентов можно изменить разрешения на доступ по умолчанию для всего компьютера или политику ограничений для всего компьютера. Общие сведения см. в разделе Разрешения на доступ.

Для задания разрешений на доступ на уровне компьютера выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на компьютере, для которого требуется изменить разрешения на доступ, и выберите пункт Свойства.

  2. Откройте вкладку Безопасность COM.

  3. В окне Разрешение на запуск и активацию нажмите кнопку Изменить ограничения или Изменить умолчания в зависимости от того, что вы хотите изменить: политику ограничений для компьютера или установки по умолчанию для компьютера. Появится диалоговое окно Разрешение на запуск.

  4. Для удаления учетной записи пользователя или группы выберите ее в списке Группы или пользователи и нажмите кнопку Удалить. Учетная запись выбранного пользователя или группы больше не отображается в списке.

  5. Для добавления учетной записи пользователя или группы нажмите кнопку Добавить. В нижней области окна Выбор пользователей, компьютеров и групп введите полное имя пользователя или группы, которую требуется добавить. Если имя неизвестно, нажмите кнопку Дополнительно, а затем для просмотра списка пользователей и групп в выбранном домене нажмите кнопку Поиск. Выберите пользователя или группу в списке Имя (RDN) и нажмите кнопку OK. Добавленная учетная запись пользователя или группа отображается в списке Группы или пользователи.

  6. В этом списке выберите Группу или пользователя, для которых хотите изменить разрешение на доступ.

  7. В списке Разрешения разрешите или запретите локальный и удаленный доступ для выбранного пользователя или группы с помощью флажков Разрешить и Запретить.

  8. Нажмите OK для возврата в диалоговое окно Безопасность COM по умолчанию.

  9. Нажмите кнопку ОК.

Новые разрешения на доступ на уровне компьютера вступают в действие при следующем запуске приложения на этом компьютере. Внесенные изменения не влияют на выполняющиеся в данный момент приложения до их перезапуска.


Setting Machine-Wide Launch and Activation Permissions

Настройка разрешений на запуск для компьютера

Разрешения на запуск и активацию, заданные на уровне компьютера, определяют, какие пользователи явно получили разрешение, а кому отказано в разрешении на запуск и активацию приложений COM. С помощью программы служб компонентов можно изменить разрешения на запуск и активацию по умолчанию для всего компьютера или политику ограничений для всего компьютера. Обзорную информацию см. в разделе Разрешения на запуск и активацию.

Важное замечание. При настройке разрешений необходимо убедиться в том, что группа SYSTEM включена в список Группы или пользователи в диалоговом окне Разрешение на запуск и активацию и имеет разрешение на запуск. Группа SYSTEM неявно включена в группу "Все". Однако по соображениям безопасности рекомендуется не включать разрешения на запуск для группы "Все".

Для задания разрешений на запуск и активацию на уровне компьютера выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на компьютере, для которого требуется изменить разрешения на запуск, и выберите пункт Свойства.

  2. Откройте вкладку Безопасность COM.

  3. В окне Разрешение на запуск и активацию нажмите кнопку Изменить ограничения или Изменить умолчания в зависимости от того, что вы хотите изменить: политику ограничений для компьютера или установки по умолчанию для компьютера. Появится диалоговое окно Разрешение на запуск.

  4. Для удаления учетной записи пользователя или группы выберите ее в списке Группы или пользователи и нажмите кнопку Удалить. Учетная запись выбранного пользователя или группы больше не отображается в списке.

  5. Для добавления учетной записи пользователя или группы нажмите кнопку Добавить. В нижней области окна Выбор пользователей, компьютеров и групп введите полное имя пользователя или группы, которую требуется добавить. Если имя неизвестно, нажмите кнопку Дополнительно, а затем для просмотра списка пользователей и групп в выбранном домене нажмите кнопку Поиск. Выберите пользователя или группу в списке Имя (RDN) и нажмите кнопку OK. Добавленная учетная запись пользователя или группа отображается в списке Группы или пользователи.

  6. В списке Группы или пользователи выберите группу или пользователя, для которых хотите изменить разрешения на запуск и активацию.

  7. В списке Разрешения разрешите или запретите локальный запуск, локальную активацию, удаленный запуск и удаленную активацию для выбранного пользователя или группы с помощью флажков Разрешить и Запретить.

  8. Нажмите OK для возврата в диалоговое окно Безопасность COM по умолчанию.

  9. Нажмите кнопку ОК.

Новые разрешения на доступ для компьютера вступают в действие при следующем запуске приложения на этом компьютере. Внесенные изменения не влияют на выполняющиеся в данный момент приложения до их перезапуска.


Setting Machine-Wide Reference Tracking

Задание отслеживания ссылок на уровне компьютера

Если отслеживание ссылок включено, COM выполняет дополнительные проверки безопасности и ведет учет дополнительных сведений с целью предохранения объектов от слишком раннего освобождения, совершенного случайно или злонамеренно. Включение отслеживания ссылок, называемого также подсчетом безопасных ссылок, снижает производительность. Обзор отслеживания ссылок см. в разделе Отслеживание ссылок.

Примечание. Если параметр Уровень проверки подлинности по умолчанию имеет значение Нет или параметр Уровень олицетворения по умолчанию имеет значение Анонимное, то включить отслеживание ссылок невозможно.

Для включения (или отключения) отслеживания ссылок на уровне компьютера выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на компьютере, для которого требуется включить отслеживание ссылок, и выберите пункт Свойства.

  2. Откройте вкладку Свойства по умолчанию.

  3. Убедитесь в том, что флажок Разрешить использование DCOM на этом компьютере установлен.

  4. В группе Свойства связи DCOM по умолчанию выберите один из следующих параметров.
    • Для включения отслеживания ссылок установите флажок Повышенная безопасность для отслеживания ссылок.

    • Для отключения отслеживания ссылок отмените выбор флажка Повышенная безопасность для отслеживания ссылок.
  5. Нажмите кнопку ОК.

Новый режим отслеживания ссылок вступает в действие при следующем запуске приложения на этом компьютере. Внесенные изменения не влияют на выполняющиеся в данный момент приложения до их перезапуска.


Setting Application-Specific COM Security Configuration

Настройка безопасности COM для приложения

Программа служб компонентов позволяет задать свойства безопасности COM для конкретного приложения COM. Дополнительные сведения об использовании этих средств безопасности см. в разделе Настройка безопасности COM.

В данном документе содержатся пошаговые инструкции по выполнению следующих задач.

  • Настройка разрешений на доступ для приложения

  • Настройка разрешений на запуск и активацию для приложения


Setting Application-Specific Access Permissions

Настройка разрешений на доступ для приложения

Разрешения на доступ, заданные на уровне приложения, определяют пользователей, которым предоставляется или не предоставляется право доступа к приложению COM. Общие сведения см. в разделе Разрешения на доступ.

Для настройки разрешений на доступ на уровне приложения выполните следующие действия.

  1. В дереве консоли программы служб компонентов щелкните правой кнопкой мыши приложение DCOM, которое хотите изменить, и выберите пункт Свойства.

  2. Выберите вкладку Безопасность.

  3. В окне Разрешения на доступ нажмите кнопку Настроить, а затем кнопку Изменить.

  4. Для удаления учетной записи пользователя или группы выберите ее в списке Группы или пользователи и нажмите кнопку Удалить. Учетная запись выбранного пользователя или группы больше не отображается в списке.

  5. Для добавления учетной записи пользователя или группы нажмите кнопку Добавить. В нижней области окна Выбор пользователей, компьютеров и групп введите полное имя пользователя или группы, которую требуется добавить. Если имя неизвестно, нажмите кнопку Дополнительно, а затем для просмотра списка пользователей и групп в выбранном домене нажмите кнопку Поиск. Выберите пользователя или группу в списке Имя (RDN) и нажмите кнопку OK. Добавленная учетная запись пользователя или группа отображается в списке Группы или пользователи.

  6. В данном списке выберите Группу или пользователя, для которого требуется изменить разрешение на доступ по умолчанию.

  7. В списке Разрешения разрешите или запретите локальный и удаленный доступ для выбранного пользователя или группы с помощью флажков Разрешить и Запретить.

  8. Нажмите OK для возврата в диалоговое окно Безопасность COM по умолчанию.

  9. Нажмите кнопку ОК.

Новые разрешения на запуск для приложения вступают в действие при следующем запуске приложения на этом компьютере.


Setting Application-Specific Launch and Activation Permissions

Настройка разрешений на запуск и активацию для приложения

Разрешения на запуск и активацию, заданные для приложения, определяют пользователей, которым предоставляется или не предоставляется разрешение на запуск или активацию приложения COM. Обзорную информацию см. в разделе Разрешения на запуск и активацию.

Для настройки разрешений на запуск и активацию для приложения сделайте следующее.

  1. В дереве консоли программы служб компонентов щелкните правой кнопкой мыши на приложении DCOM, которое хотите изменить, и выберите пункт Свойства.

  2. Откройте вкладку Безопасность.

  3. В окне Разрешения на запуск и активацию нажмите кнопку Настроить, а затем кнопку Изменить.

  4. Для удаления учетной записи пользователя или группы выберите ее в списке Группы или пользователи и нажмите кнопку Удалить. Учетная запись выбранного пользователя или группы больше не отображается в списке.

  5. Для добавления учетной записи пользователя или группы нажмите кнопку Добавить. В нижней области окна Выбор пользователей, компьютеров и групп введите полное имя пользователя или группы, которую требуется добавить. Если имя неизвестно, нажмите кнопку Дополнительно, а затем для просмотра списка пользователей и групп в выбранном домене нажмите кнопку Поиск. Выберите пользователя или группу в списке Имя (RDN) и нажмите кнопку OK. Добавленная учетная запись пользователя или группа отображается в списке Группы или пользователи.

  6. В данном списке выберите Группу или пользователя, для которого требуется изменить разрешение на доступ по умолчанию.

  7. В списке Разрешения разрешите или запретите локальный запуск, локальную активацию, удаленный запуск и удаленную активацию для выбранного пользователя или группы с помощью флажок Разрешить и Запретить.

  8. Нажмите OK для возврата в диалоговое окно Безопасность COM по умолчанию.

  9. Нажмите кнопку ОК.

Новые разрешения на запуск для приложения вступают в действие при следующем запуске приложения на этом компьютере.


Administering Distributed Transactions

Администрирование распределенных транзакций

Координатор распределенных транзакций COM+ (DTC) отвечает за координацию транзакций, участвующих в обновлении нескольких ресурсов с защитой транзакций (например, баз данных, очередей сообщений, файловых систем). Ресурсы с защитой транзакций могут находиться на одном компьютере или быть распределенными по сети компьютеров.

Программа администрирования служб компонентов, включающая координатор распределенных транзакций Microsoft® (DTC), позволяет настраивать компьютеры и сеть для поддержки распределенных транзакций, а также для наблюдения за распределенными транзакциями и управления ими.

Предварительное замечание

Решения о характеристиках транзакций, например, поддерживает ли компонент транзакции, является ли транзакция обязательной для компонента и другие, обычно принимаются в процессе разработки компонента или приложения. С другой стороны, административные решения обычно связаны с настройкой, запуском и остановкой DTC, наблюдением за потоком транзакций и управлением им, а также наблюдением за производительностью транзакций.

Чтобы получить более подробные сведения об администрировании распределенных транзакций, см. разделы, описанные в следующей таблице.

Раздел | Описание
Основные понятия администрирования распределенных транзакций | Введение в DTC, а также ссылки на дополнительные сведения по этой теме.
Задачи администрирования распределенных транзакций | Ссылки на задачи администрирования распределенных транзакций.


Distributed Transaction Administration Concepts

Основные понятия администрирования распределенных транзакций

В приложениях, использующих распределенные транзакции, для обеспечения защиты от сбоев можно управлять одновременной работой нескольких клиентов, компонентов и баз данных. В пределах распределенной транзакции вся работа, выполненная участвующими компонентами, либо полностью сохраняется, либо полностью отменяется, что упрощает отслеживание и восстановление данных после ошибок, так как в результате сбоев не остается частично выполненных действий.

Программа администрирования служб компонентов предоставляет некоторые возможности, которые позволяют администраторам выполнять основные задачи по администрированию координатора распределенных транзакций (DTC). Эти возможности можно найти в различных частях пользовательского интерфейса служб компонентов.

  • Диалоговое окно свойств компьютера. Открыв страницу Свойства компьютера, представленного в дереве консоли, можно выполнять ряд административных задач DTC. Примеры задач, включают в себя запуск и остановку службы DTC, изменение расположения файла журнала DTC и настройку безопасности DTC.

  • Меню для выбранного компьютера. Чтобы открыть данное меню, щелкните правой кнопкой мыши на значке компьютера в дереве консоли. С помощью этого меню можно запустить или остановить службу DTC.

  • Служебные программы Список транзакций и Статистика транзакций. Эти служебные программы (чтобы получить к ним доступ, раскройте папку Координатор распределенных транзакций в дереве консоли) позволяют просматривать и изменять состояние отдельных распределенных транзакций.

Пошаговые инструкции по администрированию DTC с помощью программы администрирования служб компонентов см. в разделе Задачи администрирования распределенных транзакций.

Дополнительные сведения о принципах администрирования DTC с использованием задач, которые выполняются другими средствами без использования программы администрирования служб компонентов, содержатся в документации к SDK платформы Майкрософт.


Distributed Transaction Administration Tasks

Задачи администрирования распределенных транзакций

Набор задач по администрированию распределенных транзакций включает в себя настройку системы на поддержку распределенных транзакций, отслеживание транзакций и управление производительностью, а также устранение неполадок, связанных с системными сбоями. Обзор администрирования распределенных транзакций содержится в разделе Основные понятия администрирования распределенных транзакций.

Примечание. Пользователям, у которых нет административных полномочий, необходимо иметь права на просмотр и изменение параметров конфигурации DTC. Если у пользователя отсутствуют соответствующие права, то при всех попытках просмотреть или изменить параметры конфигурации отображается сообщение о том, что доступ запрещен. Если у пользователя есть доступ только на чтение, то административный пользовательский интерфейс DTC отображается, но все административные функции являются недоступными.

Для получения пошаговых инструкций о выполнении определенных задач, связанных с координатором распределенных транзакций COM+, см. следующие разделы.

  • Настройка DTC

  • Управление DTC

  • Устранение неполадок DTC


Configuring the DTC

Настройка DTC

Настройка системы для поддержки распределенных транзакций может выполняться с помощью программы администрирования служб компонентов. Пошаговые инструкции по настройке DTC содержатся в следующих разделах:

  • Настройка координатора транзакций по умолчанию

  • Настройка сетевого протокола клиента

  • Настройка файла журнала DTC

  • Настройка безопасности DTC


Configuring the Default Transaction Coordinator

Настройка координатора транзакций по умолчанию

Для запуска и координации транзакций на каждом компьютере по умолчанию используется локальный диспетчер транзакций DTC. Тем не менее данный компьютер можно настроить таким образом, чтобы в качестве координатора транзакций по умолчанию использовался диспетчер транзакций DTC на другом компьютере. Диспетчер транзакций DTC на указанном компьютере используется как координатор транзакций во всех случаях, когда клиент на локальном компьютере начинает транзакцию DTC, не указав явным образом координатор транзакций. Используемый по умолчанию координатор транзакций координирует все транзакции, начатые в COM+. Кроме того, используемый по умолчанию координатор транзакций служит координатором транзакций для всех диспетчеров ресурсов локального компьютера, вовлеченных в какие-либо транзакции DTC.

В качестве координатора по умолчанию следует выбирать надежные системы. Сетевое подключение к компьютеру координатора по умолчанию также должно быть надежным. В противном случае в результате выбора координатора по умолчанию служба DTC может стать менее доступной для данного локального компьютера. Кластер Windows Server 2003 с выполняющейся на нем службой кластеров вполне может служить координатором по умолчанию. При задании кластера Windows Server 2003 с выполняющейся на нем службой кластеров в качестве координатора по умолчанию можно указать имя любого виртуального сервера этого кластера.

Для настройки координатора транзакций по умолчанию одновременно требуются полномочия администратора локального компьютера и компьютера, предназначенного для работы в качестве координатора транзакций по умолчанию. Это позволяет локальной системе DTC извлекать соответствующие сведения из системного реестра на компьютере координатора транзакций по умолчанию.

Для назначения удаленного компьютера в качестве координатора транзакций по умолчанию выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на значке компьютера, настройки координатора транзакций которого необходимо изменить, а затем выберите команду Свойства.

  2. В диалоговом окне свойств компьютера перейдите на вкладку MSDTC.

  3. Отмените выбор флажка Использовать локальный координатор.

  4. В поле Удаленный узел введите имя удаленного компьютера. Если точное имя компьютера неизвестно, нажмите кнопку Выбрать для отображения списка всех компьютеров в сети и выберите требуемый компьютер из списка.

  5. Нажмите кнопку ОК.

Для назначения локального компьютера в качестве координатора транзакций по умолчанию выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на значке компьютера, который требуется назначить в качестве координатора транзакций по умолчанию, а затем выберите команду Свойства.

  2. В диалоговом окне свойств компьютера перейдите на вкладку MSDTC.

  3. Установите флажок Использовать локальный координатор.

  4. Нажмите кнопку ОК.


Configuring the Client Network Protocol

Настройка сетевого протокола клиента

При настройке DTC с целью использования удаленного координатора транзакций DTC можно указать транспорт RPC, который прокси DTC будет использовать для подключения к этому координатору транзакций на удаленном компьютере. Так как протокол TCP/IP более распространен, именно этот протокол рекомендуется и используется по умолчанию для DTC.

Примечание. Если продукт Windows Server 2003 был установлен как обновление Windows 2000 Server, сетевые протоколы, которые были доступны до обновления, будут доступны и в Windows Server 2003. Если Windows Server 2003 не был установлен как обновление, единственным доступным сетевым протоколом будет TCP/IP.

Для настройки сетевого протокола клиента выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на значке компьютера, для которого требуется задать тип сетевого протокола, а затем выберите команду Свойства.

  2. В диалоговом окне свойств компьютера перейдите на вкладку MSDTC.

  3. В списке Конфигурация сетевого протокола клиента выберите TCP/IP или любой другой сетевой протокол, присутствующий в списке.

  4. Нажмите кнопку ОК.


Configuring the DTC Log File

Настройка файла журнала DTC

Допускается настройка расположения и размера файла журнала DTC.

Предостережение. Изменение размера файла журнала на самом деле означает удаление текущего журнала и создание нового файла. Перед заменой файла журнала DTC необходимо проверить, можно ли безопасно удалить существующий файл журнала. Для этого следует убедиться в отсутствии транзакций в состоянии "Под сомнением", "Нельзя известить о прерывании" или "Нельзя известить о завершении". Более подробные сведения см. в разделе Обработка транзакций вручную.

Для изменения размера или местоположения файла журнала выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на компьютере, на котором находится файл журнала DTC, а затем выберите команду Свойства.

  2. В диалоговом окне свойств компьютера перейдите на вкладку MSDTC.

  3. В группе Контроль состояния службы для MSDTC нажмите кнопку Остановить для остановки службы DTC.

    Примечание. Если служба DTC не будет остановлена, при попытке очистки файла журнала на экране появится сообщение консоли DTC о том, что для выполнения запрошенного действия следует остановить и повторно запустить службу DTC.

  4. Для изменения местоположения файла журнала введите новый диск и путь к файлу журнала в поле Расположение (группа Сведения о журнале). Если полный путь неизвестен, нажмите кнопку Обзор для выбора местоположения файла журнала.

  5. Для изменения размера файла журнала введите новый размер файла журнала в мегабайтах в поле Размер (группа Сведения о журнале).

  6. Чтобы изменить расположение и размер файла журнала DTC, нажмите кнопку Сброс.

  7. В группе Контроль состояния службы для MSDTC нажмите кнопку Запустить для запуска службы DTC.

  8. Нажмите кнопку ОК.


Configuring DTC Security

Настройка безопасности DTC

Ниже приведены две основные задачи по настройке безопасности DTC.

  • Изменение параметров безопасности, установленных по умолчанию.

  • Указание учетной записи DTC.

Для изменения установленных по умолчанию параметров безопасности DTC выполните следующие действия.

  1. В дереве консоли программы служб компонентов в папке Компьютеры щелкните правой кнопкой мыши на значке локального компьютера и в контекстном меню выберите пункт Свойства.

  2. Откройте вкладку MSDTC.

  3. Нажмите кнопку Настройка безопасности.

  4. В диалоговом окне Настройка безопасности в группе Настройки безопасности установите флажки рядом с разрешаемыми видами доступа.

  5. Нажмите кнопку ОК для возврата в диалоговое окно свойств компьютера.

  6. Нажмите кнопку ОК.

Для изменения установленной по умолчанию учетной записи пользователя выполните следующие действия.

Предостережение. Не изменяйте учетную запись пользователя, используемую по умолчанию, с помощью диалогового окна Координатор распределенных транзакций: Свойства в программе администрирования локальных служб. Изменение учетной записи пользователя, используемой по умолчанию, с помощью диалогового окна Координатор распределенных транзакций: Свойства может привести к невозможности запуска DTC, поскольку в каталог COM+ не внесены необходимые изменения. Кроме того, возникает угроза безопасности, так как создается возможность работы DTC с недействительной учетной записью.

  1. В дереве консоли программы служб компонентов в папке Компьютеры щелкните правой кнопкой мыши на значке локального компьютера и в контекстном меню выберите команду Свойства.

  2. Откройте вкладку MSDTC.

  3. Нажмите кнопку Настройка безопасности.

  4. В группе Учетная запись DTC диалогового окна Настройка безопасности введите имя пользователя, пароль, а затем в следующем поле подтвердите правильность ввода пароля. Если полное имя пользователя неизвестно, нажмите кнопку Обзор для его поиска.

  5. Нажмите кнопку ОК для возврата в окно свойств компьютера.

  6. Нажмите кнопку ОК.


Managing the DTC

Управление DTC

MS DTC предоставляет средства наблюдения и управления транзакциями, позволяющие устранять неполадки и оптимизировать производительность.

Для получения подробных пошаговых инструкций об управлении DTC см. следующие разделы.

  • Запуск и остановка DTC

  • Наблюдение за производительностью DTC

  • Просмотр сведений о транзакции

  • Разрешение транзакций вручную

  • Сброс файла журнала DTC

  • Управление фоновой трассировкой транзакций


Starting and Stopping the DTC

Запуск и остановка DTC

Программа администрирования служб компонентов позволяет запустить и остановить службу DTC.

Примечание. Программа администрирования служб компонентов требует выполнения DTC для завершения каких-либо изменений настройки. Если служба DTC остановлена, то при попытке изменения любых настроек с помощью программы администрирования служб компонентов произойдет перезапуск службы DTC. Если при попытке использования программы администрирования служб компонентов возникают ошибки, проверьте, что служба DTC запущена, и в случае необходимости перезапустите ее.

Для запуска или остановки DTC с помощью программы администрирования служб компонентов выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов выберите компьютер, транзакциями которого необходимо управлять.

  2. Щелкните правой кнопкой мыши на выбранном компьютере и выберите команду Запустить MS DTC или Остановить MS DTC.

Если запустить службу DTC не удается, проверьте программу просмотра событий на наличие записей о событиях DTC перед сбоем. DTC обычно записывает в журнал событие в случае неудачного запуска.


Monitoring DTC Performance

Наблюдение за производительностью DTC

С помощью программы администрирования служб компонентов можно выполнить наблюдение за производительностью транзакций DTC. Обычно выполнение этой задачи происходит после настройки параметров транзакции.

Программа администрирования служб компонентов отображает статистические сведения о транзакциях с участием сервера в служебной программе Статистика транзакций. Эта статистика позволяет оценить производительность DTC.

Для просмотра статистики транзакций выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов дважды щелкните мышью на значке компьютера, для которого требуется просмотреть статистику транзакций.

  2. Дважды щелкните на папке Координатор распределенных транзакций, а затем откройте папку Статистика транзакций.

В группах Текущая, Средняя и Время отклика приводятся данные о состояниях транзакций.


Viewing Transaction Information

Просмотр сведений о транзакции

В определенных случаях, например если произошел сбой связи или неправильно работающее приложение с распределенными транзакциями оставило необработанные транзакции, может потребоваться просмотр списка транзакций и их свойств, выбор транзакций для отображения, задание периода ожидания транзакций и частоты обновления данных.

Для просмотра списка транзакций DTC выполните следующие действия.

  1. В дереве консоли программы служб компонентов дважды щелкните мышью на значке компьютера, для которого вы хотите увидеть список транзакций.

  2. Дважды щелкните папку Координатор распределенных транзакций, а затем папку Список транзакций.

Список содержит все транзакции, их состояния и коды. Чтобы обработать транзакции, обратитесь к разделу Обработка транзакций вручную.

Для просмотра свойств транзакции в списке транзакций DTC выполните следующие действия.

  1. В дереве консоли программы служб компонентов дважды щелкните значок компьютера, для которого вы хотите увидеть список транзакций.

  2. Дважды щелкните папку Координатор распределенных транзакций, а затем папку Список транзакций.

  3. В области данных щелкните правой кнопкой мыши на транзакции, свойства которой требуется просмотреть, и выберите в контекстного меню команду Представление.

  4. Для просмотра родительской транзакции и ее дочерних транзакций выберите команду Свойства.


Manually Resolving Transactions

Разрешение транзакций вручную

Иногда необходимо принудительно завершить или прервать транзакцию, чтобы снять блокировки и предоставить доступ к ресурсам базы данных для других сетевых пользователей и приложений.

Для обработки транзакции вручную выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов дважды щелкните мышью на значке компьютера, для которого требуется просмотреть список транзакций.

  2. Дважды щелкните папку Координатор распределенных транзакций, а затем папку Список транзакций.

  3. Щелкните правой кнопкой мыши на транзакции, которую требуется обработать, выберите в контекстном меню команду Обработать, а затем — одну из команд Завершить, Прервать или Отложить.

Выбор команды зависит от следующих процедур.

Обработка состояния "Под сомнением"

Состояние Под сомнением указывает, что транзакция выполняется в подчиненной службе DTC, а главная служба DTC недоступна.

Для обработки транзакции в состоянии "Под сомнением" выполните следующие действия.

  1. Воспользуйтесь окном Список транзакций, чтобы найти непосредственного родителя транзакции в состоянии "Под сомнением". Сведения о просмотре свойств транзакции см. в разделе Просмотр сведений о транзакции.

  2. Найдите главную систему DTC и с помощью окна Список транзакций этой системы определите результат выполнения транзакции под сомнением, как описано ниже.
    • Если транзакция отсутствует в списке на странице Транзакции, то она была прервана, и эту транзакцию можно вручную прервать в подчиненной системе.

    • Если транзакция в главной системе имеет состояние Нельзя известить о завершении, то она была завершена, и эту транзакцию можно вручную завершить в подчиненной системе.

    • Если транзакция в главной системе имеет состояние Нельзя известить о прерывании, то она была прервана, и эту транзакцию можно вручную прервать в подчиненной системе.

    • Если транзакция в главной системе имеет состояние Под сомнением, воспользуйтесь страницей Транзакции в этой системе, чтобы найти следующую систему, являющуюся непосредственно главной для данной транзакции. Продолжайте отслеживание транзакции вверх по дереву завершения до тех пор, пока не будет обнаружена главная система, в которой эта транзакция либо не показывается (это означает, что она прервана), либо находится в состоянии Нельзя известить о прерывании (это означает, что она прервана) или в состоянии Нельзя известить о завершении (это означает, что она завершена). Если транзакция прервана в главной системе, вручную прервите эту транзакцию в системе, непосредственно подчиненной данному компьютеру. Если транзакция завершена в главной системе, вручную завершите эту транзакцию в подчиненной системе.
  3. После того как транзакция будет вручную завершена или прервана в подчиненной системе, принудительно отложите эту транзакцию в системе, являющейся непосредственно главной.

Обработка состояния "Нельзя известить о прерывании"

Состояние Нельзя известить о прерывании свидетельствует о том, что данная транзакция была прервана, но при этом подчиненный диспетчер транзакций не был извещен о результатах выполнения этой транзакции. Такую транзакцию следует обработать вручную, как описано ниже.

Предостережение. Не откладывайте транзакцию вручную до тех пор, пока все подчиненные службы DTC не будут уведомлены о результатах выполнения этой транзакции.

Для отображения транзакции в состоянии "Нельзя известить о прерывании" выполните следующие действия.

  1. Щелкните правой кнопкой мыши на транзакции в состоянии Нельзя известить о прерывании. При этом для данной транзакции будут показаны главная служба DTC и подчиненные диспетчеры транзакций.

  2. Обнаружив подчиненные диспетчеры транзакций, принудительно прервите данную транзакцию в каждой системе.

  3. После того как транзакция будет вручную завершена во всех подчиненных системах, вернитесь к службе DTC, которая показывает транзакцию в состоянии Нельзя известить о прерывании, и принудительно отложите данную транзакцию.

Обработка состояния "Нельзя известить о завершении"

Состояние Нельзя известить о завершении свидетельствует о том, что данная транзакция была завершена, но при этом подчиненные диспетчеры транзакций DTC или диспетчеры ресурсов не были извещены о результатах выполнения этой транзакции. Такую транзакцию следует обработать вручную.

Предостережение. Не откладывайте транзакцию вручную до тех пор, пока все подчиненные службы DTC не будут уведомлены о результатах выполнения этой транзакции.

Для обработки транзакции в состоянии "Нельзя известить о завершении" выполните следующие действия.

  1. Щелкните правой кнопкой мыши на транзакции в состоянии Нельзя известить о завершении. При этом для данной транзакции будут показаны главная служба DTC и подчиненные диспетчеры транзакций.

  2. Найдите подчиненные диспетчеры транзакций DTC и принудительно завершите данную транзакцию в каждой подчиненной системе.

  3. После того как транзакция будет вручную обработана во всех подчиненных системах, вернитесь к службе DTC, которая показывает транзакцию в состоянии Нельзя известить о завершении, и принудительно отложите данную транзакцию.


Resetting the DTC Log File

Очистка файла журнала DTC

Очистка файла журнала DTC обязательна перед перемещением его на другое устройство или изменением его размера. Перед очисткой файла журнала DTC убедитесь в отсутствии транзакций в состояниях Под сомнением, Нельзя известить о прерывании и Нельзя известить о завершении.

Примечание. При доступе из удаленной системы очистка файла журнала DTC невозможна. Поскольку данный файл обновляется непосредственно программой администрирования служб компонентов, эта программа должна выполняться в той системе, где находится файл журнала.

Для очистки файла журнала DTC выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на папке Мой компьютер и выберите команду Свойства.

  2. В диалоговом окне Свойств компьютера перейдите на вкладку MSDTC.

  3. В группе Контроль состояния службы для MSDTC нажмите кнопку Остановить для остановки службы DTC.

  4. В группе Сведения о журнале нажмите кнопку Сброс для очистки файла журнала.

    Примечание. Если в расположении, указанном посредством диска и каталога, уже существует файл журнала, то при нажатии кнопки Сброс текущий файл журнала удаляется. Перед удалением файла журнала DTC убедитесь в отсутствии транзакций с состояниями Под сомнением, Нельзя известить о прерывании и Нельзя известить о завершении. Чтобы проверить текущее состояние транзакций, воспользуйтесь окном Список транзакций в программе администрирования служб компонентов. Дополнительные сведения см. в разделе Просмотр сведений о транзакции.

  5. В группе Контроль состояния службы для MSDTC нажмите кнопку Запустить для повторного запуска службы DTC.

  6. Нажмите кнопку ОК.


Controlling Background Tracing

Управление фоновой трассировкой

С помощью соответствующего диалогового окна можно управлять фоновой трассировкой транзакций DTC. Это диалоговое окно служит только для фоновой трассировки и не может быть использовано для трассировки отдельных транзакций или для удаленного управления параметрами трассировки.

Для управления параметрами фоновой трассировки выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на папке Мой компьютер и выберите команду Свойства.

  2. Выберите вкладку MSDTC.

  3. Нажмите кнопку Параметры отслеживания. На экран будет выведено диалоговое окно Параметров отслеживания.

В данном диалоговом окне можно настроить параметры вывода и ведения журнала. Для получения дополнительных сведений о настройке Параметров вывода и ведения журнала см. следующие разделы.

Настройка параметров вывода

По умолчанию включены параметры Отслеживать прерванные транзакции и Отслеживать длинные транзакции.

Примечание. Если выбор флажка Отслеживать транзакции или флажка Отслеживать выводы отменен, то параметры отслеживания по умолчанию недоступны.

Для установки требуемого типа отслеживания выполните следующие действия.

  1. Откройте диалоговое окно Параметры отслеживания, как описано в предыдущей процедуре.

  2. В группе Параметры отслеживания установите или отмените выбор соответствующих флажков. Допускаются следующие уровни.
    • Отслеживание всех транзакций

    • Отслеживание прерванных транзакций

    • Отслеживание длинных транзакций
  3. Нажмите кнопку ОК.

Настройка параметров ведения журнала

Параметры ведения журнала позволяют управлять файлом журнала для отслеживаемых данных.

Для настройки параметров ведения журнала выполните следующие действия.

  1. Перейдите в диалоговое окно Параметры отслеживания, как описано в начале данной страницы.

  2. В группе Параметры журнала выберите следующие возможности.
    • Новый сеанс Нажмите данную кнопку, чтобы начать новый сеанс отслеживания. Если существует старый журнал трассировки, то после начала нового сеанса он будет архивирован.

    • Остановить сеанс Нажмите данную кнопку, чтобы остановить текущий сеанс отслеживания. При остановке сеанса отслеживания файл журнала трассировки становится незащищенным и его можно при необходимости удалить.

    • Стереть данные Нажмите данную кнопку, чтобы переместить все данные из буферов памяти в файл журнала на диске. Чтобы убедиться, что все данные из буферов памяти отправлены на диск, необходимо нажать данную кнопку, прежде чем просматривать данные отслеживания. В противном случае некоторые данные могут не отображаться при просмотре файла журнала. При нажатии данной кнопки может измениться быстродействие системы. После остановки сеанса отслеживания эта кнопка становится недоступной.

    • Максимальное число буферов памяти (размера PageSize) Если требуется изменить максимальное число доступных буферов памяти, задайте новое число в данном поле. По умолчанию максимальное число буферов памяти равно 25. Если рекомендуется увеличить данное число, то служба DTC запишет соответствующее сообщение в журнал просмотра событий. Данная память берется из буфера, который не использует файл подкачки. Поэтому, если памяти буфера, который не использует файл подкачки, недостаточно, то значение в данном поле увеличить невозможно. В данном случае DTC выводит соответствующее сообщение. При выводе данного сообщения нажмите кнопку OK.
  3. Нажмите кнопку ОК.


Troubleshooting DTC Problems

Устранение неполадок DTC

Одной из наиболее часто встречающихся ошибок DTC является ошибка вовлечения в транзакцию. Если эта ошибка происходит в то время, когда компонент транзакции осуществляет доступ к базе данных Microsoft® SQL Server™, выполните перечисленные ниже проверки.

  • Проверка запуска DTC

  • Проверка времени ожидания транзакции


Verify That the DTC Has Started

Проверка запуска DTC

Убедитесь в том, что служба DTC запущена в той системе, где развернуты компоненты, работающие в составе службы компонентов.

Если приложение требует доступа к базе данных Microsoft SQL Server на удаленном компьютере, убедитесь, что служба DTC запущена и на этом компьютере. Именно это часто является причиной возникновения ошибки вовлечения в транзакцию.

Более подробно о запуске и остановке службы DTC см. в разделе Запуск и остановка службы DTC.


Check Transaction Time-Out

Проверка времени ожидания транзакции

В случае появления ошибки вовлечения в транзакцию проверьте, не была ли транзакция компонента прервана из-за превышения времени ожидания транзакций до того, как было завершено вовлечение базы данных. В этом случае можно увеличить значение времени ожидания транзакций с помощью программы администрирования служб компонентов.

Для проверки периода ожидания транзакции выполните следующие действия.

  1. В дереве консоли программы администрирования служб компонентов щелкните правой кнопкой мыши на значке компьютера, на котором была начата транзакция, а затем выберите в контекстном меню команду Свойства.

  2. В диалоговом окне свойств компьютера перейдите на вкладку Параметры.

  3. В группе Время ожидания транзакции в поле Время ожидания транзакции (с) введите величину периода ожидания транзакции (в секундах).

    Примечание. Разрешается ввести любое значение от 0 до 3 600 секунд (1 час). При значении 0 секунд ограничения на время ожидания транзакции не устанавливаются. Попробуйте разные значения, чтобы подобрать наилучшее время ожидания для данного компьютера.

  4. Нажмите кнопку Применить.

  5. Выберите вкладку MSDTC и в группе Контроль состояния службы для DTC нажмите кнопку Остановить для остановки службы DTC.

  6. Нажмите кноку Запустить для активизации нового значения времени ожидания транзакции.

  7. Нажмите кнопку ОК.